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Troubleshooting

Note CiscoWorks Common Services 3.0.5 provides Security Manager with its 
framework for installation, uninstallation, and reinstallation on servers. If the 
installation or uninstallation of Security Manager server software causes an error, 
see “Troubleshooting the Installation” in the Common Services online help or 
read it on Cisco.com: http://www.cisco.com/en/US/docs/net_mgmt/
ciscoworks_common_services_software/3.0.5/installation/windows/
guide/appenda.html.

These topics help you to troubleshoot problems that might occur when you install, 
uninstall, or reinstall Security Manager-related software applications on a client 
system or on a server, including the standalone version of Cisco Security Agent.

• Questions and Answers, page B-2

• Troubleshooting the Standalone Security Agent, page B-18

• Running a Server Self-Test, page B-20

• Collecting Server Troubleshooting Information, page B-21

• Viewing and Changing Server Process Status, page B-22

• Reviewing the Server Installation Log File, page B-23
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Questions and Answers
Topics in this section answer questions that you might ask about installing, 
uninstalling, or reinstalling Security Manager and IPS Event Viewer successfully:

• Server Q&A, page B-2

• IPS Event Viewer Q&A, page B-9

• Client Q&A, page B-10

Server Q&A
This section answers questions that you might have about:

• Problems During Installation, page B-2

• Problems After Installation, page B-5

• Problems During Uninstallation, page B-6

Problems During Installation

Q. When I install the server software, what does this installation error message 
mean? 

A. Server software installation error messages and explanations appear in 
Table B-1 on page B-3, where they are sorted alphabetically by their first 
word.
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Table B-1 Installation Error Messages (Server)

Message Reason for Message User Action

License file failed. ERROR: 
The file with the name 
c:\progra~1\CSCOpx\setup 
does not exist

An earlier attempt to uninstall a 
Common Services-dependent 
application failed. 

1. Shut down the server, then 
restart it.

2. Use a Registry editor to 
delete this entry:
$HKEY_LOCAL_MACHINE\SOFT

WARE\Cisco\Resource 

Manager\CurrentVersion.

3. In the directory where you 
installed Security Manager, 
create a subdirectory named 
setup.

4. If it exists, delete the 
CMFLOCK.TXT file.

5. Reinstall Security Manager.

One instance of CiscoWorks 
Installation is already 
running. If you are sure that 
no other instances are 
running, remove the file 
C:\CMFLOCK.TXT. This 
installation will now abort.

An earlier attempt to install a 
Common Services-dependant 
application failed.

Delete the C:\CMFLOCK.TXT 
file, then try again.

Severe

Failed on call to 
FileInsertLine.

Your server does not meet the 
requirement for hard drive space.

See Server Requirements, 
page 2-5.

Temporary directory used by 
installation has reached 
_istmp9x. If _istmp99 is 
reached, no more setups can 
be run on this computer, 
they fail with error -112.

Temporary files that are 
supposed to be deleted 
automatically during software 
installations have not been 
deleted on your server. 

Search the temporary directory 
on your server for subdirectories 
with names that include the 
“_istmp” string. Permanently 
delete all such subdirectories. 
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Q. What should I do if the server installer suspends operation (hangs)? 

A. Reboot and try again.

Q. Can I install both Cisco Security Manager and Cisco Secure Access Control 
Server on one system?

A. We recommend that you do not. Caching problems and port conflicts can 
interfere with the performance and stability of either application, or both, 
when both are installed on one system.

Windows cannot find 
'C:\Documents and 
Settings\Administrator\WINDO
WS\System32\cmd.exe'. Make 
sure you typed the name 
correctly, and then try 
again. To search for a file, 
click the Start button, and 
then click Search.

You left Terminal Services 
enabled during installation, even 
though we do not support this. 
See Readiness Checklist for 
Installation, page 3-5.

1. Disable Terminal Services. 

To learn how to do this, see 
the “Terminal Server 
Support for Windows 2000 
and Windows 2003 Server” 
topic in Installation and 
Setup Guide for CiscoWorks 
Common Services 3.0.5 
(Includes CiscoView) on 
Windows, at 
http://www.cisco.com/en/U
S/docs/net_mgmt/ciscowork
s_common_services_softwa
re/3.0.5/installation/window
s/guide/prereq.html#wp103
3369.

2. Try again to install 
Security Manager.

Note For additional information about installation error messages, see the Common Services 3.0.5 
documentation on Cisco.com.

Table B-1 Installation Error Messages (Server) (continued)

Message Reason for Message User Action
B-4
Installation Guide for Cisco Security Manager 3.1

OL-11475-10

http://www.cisco.com/en/US/docs/net_mgmt/ciscoworks_common_services_software/3.0.5/installation/windows/guide/prereq.html#wp1033369
http://www.cisco.com/en/US/docs/net_mgmt/ciscoworks_common_services_software/3.0.5/installation/windows/guide/prereq.html#wp1033369


 

Appendix B      Troubleshooting
    Questions and Answers
Q. Can Security Manager 3.1 coexist on a server with any older version of 
Common Services than 3.0.5? 

A. No. We do not support coexistence on the same server with any 
Common Services version older than 3.0.5.

Problems After Installation

Q. The Security Manager GUI does not appear, or is not displayed correctly, or 
certain GUI elements are missing. What happened? 

A. There are several possible explanations. Investigate the scenarios in this list 
to understand and work around simple problems that might affect the GUI:

• Some required services are not running on your server. Restart the server 
daemon manager, wait for all services to start completely, then restart 
Security Manager Client and try again to connect. 

• Your server does not have enough free disk space. Confirm that the 
Security Manager partition on your server has at least 500 MB free.

• Your base license file is corrupted. See Getting Help with Licensing, 
page 1-10. 

• Your server uses the wrong Windows language. Only English, on 
US-English versions of Windows, and Japanese, on Japanese versions of 
Windows, are supported. (See Server Requirements, page 2-5.) Any 
other language can corrupt the installed version of Security Manager, and 
missing GUI elements are one possible symptom. If you are using an 
unsupported language, you must select a supported language, then 
uninstall and reinstall Security Manager. See Uninstalling and 
Reinstalling Server Applications, page 4-23.

• Problems occurred when you installed Cisco Security Agent. You can 
check its installation log to learn whether problems interfered with the 
installation. See Troubleshooting the Standalone Security Agent, 
page B-18.

• You ran the Security Manager installation utility over a network 
connection, but we do not support this use case (see Installing Server 
Applications, page 4-4). You must uninstall and reinstall the server 
software. See Uninstalling Server Applications, page 4-23 and 
Reinstalling Server Applications, page 4-25.
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• Your client system does not meet the minimum requirements. See Client 
Requirements, page 2-8. 

• You tried to use HTTP, but the required protocol is HTTPS.

• Buttons are the only missing element. You opened the Display Properties 
control panel on the client system, then changed one or more settings 
under the Appearance tab while you were simultaneously using 
Security Manager Client. To work around this problem, exit 
Security Manager Client, then restart it.

• The wrong graphics card driver software is installed on your client 
system. See Client Requirements, page 2-8.

Q. Security Manager sees only the local volumes, not the mapped drives, when 
I use it to browse directories on my server. Why?

A. Microsoft includes this feature by design in Windows, to enhance server 
security. You must store your Security Manager license files on a volume that 
is local to your server, due to the restricted browsing of mapped drives.

Q. Why is Security Manager missing from the Start menu in my Japanese 
version of Windows?

A. You might have configured the regional and language option settings on the 
server to use English. We do not support English as the language in any 
Japanese version of Windows (see Server Requirements, page 2-5). Use the 
Control Panel to reset the language to Japanese.

Q. My server SSL certificate is no longer valid. Also, the DCRServer process 
does not start. What happened?

A. You reset the server date or time so that it is outside the range in which your 
SSL certificate is valid. See Readiness Checklist for Installation, page 3-5. To 
work around this problem, reset the server date/time settings. 

Problems During Uninstallation

Q. What does this uninstallation error message mean? 

A. Uninstallation error messages and explanations appear in Table B-2 on 
page B-7, where they are sorted alphabetically by their first word.
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Table B-2 Uninstallation Error Messages

Message Reason for Message User Action

C:\NMSROOT\MDC\msfc-backend 
refers to a location that is 
unavailable. It could be on 
a hard drive on this 
computer, or on a network. 
Check to make sure that the 
disk is properly inserted, 
or that you are connected to 
the Internet or your 
network, and then try again. 
If it still cannot be 
located, the information 
might have been moved to a 
different location.

If you dismiss the message and 
the uninstallation fails, try either 
or both of these possible 
workarounds, then try again to 
uninstall:

Simple File Sharing

1. Select Start > Settings > 
Control Panel > Folder 
Options.

2. Click the View tab. 

3. Scroll to the bottom of the 
Advanced Settings pane.

4. Deselect the Use simple file 
sharing (Recommended) 
check box, then click OK.

Offline File Synchronization

1. Select Start > Settings > 
Control Panel > Folder 
Options.

2. Click the Offline Files tab. 

3. Deselect the Enable Offline 
Files check box, then click 
OK.

C:\temp\<subdirectory>\
setup.exe - Access is 
denied.

The process cannot access 
the file because it is being 
used by another process.

0 file(s) copied.
1 file(s) copied.

Uninstallation failed. Reboot the server, then complete 
the procedure described in 
Uninstalling Server 
Applications, page 4-23.
B-7
Installation Guide for Cisco Security Manager 3.1

OL-11475-10



 

Appendix B      Troubleshooting
    Questions and Answers
Q. What should I do if the uninstaller hangs? 

A. Reboot, then try again.

Q. What should I do if the uninstaller displays a message to say that the 
crmdmgtd service is not responding and asks “Do you want to keep waiting?”

A. The uninstallation script includes an instruction to stop the crmdmgtd service, 
which did not respond to that instruction before the script timed out. Click 
Yes. In most cases, the crmdmgtd service then stops as expected.

Windows Management 
Instrumentation (WMI) is 
running.

The setup program has 
detected Windows Management 
Instrumentation (WMI) 
services running. This will 
lock some Cisco Security 
Manager processes and may 
abort uninstallation 
abruptly. To avoid this, 
uninstallation will stop and 
start the WMI services.

Do you want to proceed?

Click Yes to proceed with 
this uninstallation. Click 
No to exit uninstallation.

Either your organization uses 
WMI or someone enabled the 
WMI service accidentally on 
your server.

Click Yes.

Note For additional information about uninstallation error messages, see the Common Services 3.0.5 
documentation on Cisco.com.

Table B-2 Uninstallation Error Messages (continued)

Message Reason for Message User Action
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IPS Event Viewer Q&A

Q. How can I confirm if IPS Event Viewer installed correctly on my server when 
I installed Security Manager?

A. Log in as a Windows administrator on your Security Manager server, then do 
the following:

1. From the NMSROOT\IEV\log subdirectory, open system.log— where 
NMSROOT is the directory in which you installed Common Services 
(C:\Program Files\CSCOpx, for example). The logfile should contain 
exactly this text, and nothing else:
Cisco IPS Event Viewer service successfully started.

2. Select Start > Settings > Control Panel > Administrative Tools > 
Services, then confirm that the following Windows services have started:

• Cisco IPS Event Viewer

• MySQL

Q. Does the Windows service called “Cisco IPS Event Viewer” have any special 
dependencies?

A. Yes. It cannot run successfully unless the Windows service called “MySQL” 
is also running.

Q. Can I uninstall IPS Event Viewer separately from Security Manager on 
my server?

A. If you used the Security Manager installer to install IPS Event Viewer, you 
cannot uninstall IPS Event Viewer without uninstalling Security Manager at 
the same time. Although IPS Event Viewer is displayed in the list of installed 
programs in the Add/Remove Programs window after installation, we 
recommend that you uninstall IPS Event Viewer using the Security Manager 
uninstaller instead of using the Add/Remove Programs control panel.
B-9
Installation Guide for Cisco Security Manager 3.1

OL-11475-10



 

Appendix B      Troubleshooting
    Questions and Answers
Client Q&A
This section answers questions that you might have about:

• Problems During Installation, page B-10

• Problems After Installation, page B-13

• Problems During Uninstallation, page B-16

• Other Problems, page B-17

Problems During Installation

Q. When I install the client software, what does this installation error message 
mean?

A. Client software installation error messages and explanations appear in 
Table B-3, where they are sorted alphabetically by their first word.

Table B-3 Installation Error Messages (Client)

Message Reason for Message User Action

could not install engine jar Previous software installations 
and uninstallations caused 
InstallShield to run incorrectly.

1. Navigate to: 
C:\Program Files\
Common Files\
InstallShield\Universal\
common\Gen1.

2. Rename the Gen1 folder, 
then try again to install 
Security Manager Client.

If Gen1 is not present, 
rename common instead.
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Error - Cannot Connect to 
Server

The client cannot connect to 
the server. This can be 
caused by one of the 
following reasons:
The server name is incorrect
The protocol (http, https) 
is incorrect
The server is not running
Network access issues
Please confirm the server 
name and protocol are 
correct the server is 
running and you are not 
experiencing network 
connectivity issues by 
loading the CS Manager home 
page in your browser.

Most likely, the server is 
misconfigured for HTTPS 
traffic.

1. From a browser, log in to the 
Cisco Security Management 
Suite desktop at 
https://<server>/CSCOnm/
servlet/login/login.jsp.

2. Click Server 
Administration.

3. In the Admin window, select 
Server > Security.

4. From the TOC, select Single 
Server Management > 
Browser-Server Security 
Mode Setup, then confirm 
that the Enable radio button 
is selected.

If the radio button is not 
selected, select it now, then 
click Apply.

5. When prompted, restart the 
Cisco Security Manager 
Daemon Manager.

6. Wait 5 minutes, then try 
again to use 
Security Manager Client.

If you still cannot connect, 
consider the other possible 
problems that the error 
message describes.

Table B-3 Installation Error Messages (Client) (continued)

Message Reason for Message User Action
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Error occurred during the 
installation: null.

Previous software installations 
and uninstallations caused 
InstallShield to run incorrectly.

1. Navigate to: 
C:\Program Files\
Common Files\
InstallShield\Universal\
common\Gen1.

2. Rename the Gen1 folder, 
then try again to install 
Security Manager Client.

If Gen1 is not present, 
rename common instead.

Errors occurred during the 
installation.

• null

Only a Windows user whose 
login account has administrative 
privileges can install 
Security Manager Client. 

Log in as a Windows 
administrator, then try again to 
install Security Manager Client.

Internet Explorer cannot 
download CSMClientSetup.exe 
from <server>. Internet 
Explorer was not able to 
open this Internet site. The 
requested site is either 
unavailable or cannot be 
found. Please try again 
later.

If the OS on your client system is 
Windows 2003, its Internet 
Explorer Enhanced Security 
default settings might stop you 
from downloading the client 
software installation utility from 
your server.

1. Select Start > Control 
Panel > Add or Remove 
Programs.

2. Click Add/Remove 
Windows Components.

3. When the Windows 
Component Wizard window 
opens, deselect the Internet 
Explorer Enhanced 
Security Configuration 
check box, click Next, then 
click Finish.

Table B-3 Installation Error Messages (Client) (continued)

Message Reason for Message User Action
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Q. What should I do if the client installer suspends operation (hangs)? 

A. Try the following. Any one of them might solve the problem:

• If Norton Internet Security 2005 is installed, disable it, then try again to 
run the installer. 

• Reboot the client system, then try again to run the installer.

• Use a browser on the client system to log in to the Security Manager 
server at: http://<server_name>:1741. If you see an error message that 
says “Forbidden” or “Internal Server Error,” the required Tomcat service 
is not running. Unless you rebooted your server recently and Tomcat has 
not had enough time yet to start running, you might have to review server 
logs or take other steps to investigate why Tomcat is not running.

Problems After Installation

Q. Why is Security Manager Client missing from the Start menu in my Japanese 
version of Windows?

A. You might have configured the regional and language option settings to use 
English on the client system. We do not support English as the language in 
any Japanese version of Windows. Use the Control Panel to reset the language 
to Japanese.

Please read the information 
below. 

The following errors were 
generated:

• WARNING: The <drive> 
partition has 
insufficient space to 
install the items 
selected.

You tried to install 
Security Manager Client on a 
drive or partition that does not 
have enough free space.

Click Back, then select a 
different location in which to 
install Security Manager Client.

Alternatively, see Changing the 
Default Location for Temporary 
Files, page 4-2.

Unable to Get Data

A database failure prevented 
successful completion of 
this operation. 

You tried to use the client to 
connect to the server before the 
server database was completely 
up and running.

Wait a few minutes, then try 
again to log in. If the problem 
persists, verify that all required 
services are running.

Table B-3 Installation Error Messages (Client) (continued)

Message Reason for Message User Action
B-13
Installation Guide for Cisco Security Manager 3.1

OL-11475-10



 

Appendix B      Troubleshooting
    Questions and Answers
Q. What can I do if my connections from a client system to the server seem 
unusually slow, or if I see DNS errors when I try to log in?

A. You might have to create an entry for your Security Manager server in the 
hosts file on your client system. Such an entry can help you to establish 
connections to your server if it is not registered with the DNS server for your 
network. To create this helpful entry on your client system, use Notepad or 
any other plain text editor to open C:\WINDOWS\system32\drivers\
etc\hosts. (The host file itself contains detailed instructions for how to add 
an entry.)

Q. What is wrong with my authentication setup if my login credentials are 
accepted without any error message when I try to log in with 
Security Manager Client, but the Security Manager desktop is blank and 
unusable? (Furthermore, does the same problem explain why, in my web 
browser, Common Services on my Security Manager server accepts my login 
credentials but then fails to load the Cisco Security Management Suite 
desktop?)

A. You did not finish all of the required steps for Cisco Secure ACS to provide 
login authentication services for Security Manager and Common Services. 
Although you entered login credentials in ACS, you did not define the 
Security Manager server as a AAA client. You must do so, or you cannot log 
in. See the ACS documentation for detailed instructions.

Q. What should I do if I cannot use Security Manager Client to log in to the 
server and a message says...? 

... repeatedly that the 
server is checking its 
license.

Verify that your server meets the minimum hardware 
and software requirements. See Server 
Requirements, page 2-5.

InstallShield Wizard 
could not create the 
Java virtual machine.

Verify that your client system meets the minimum 
hardware and software requirements. See Client 
Requirements, page 2-8.
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Synchronizing with 
DCR.

There are two possible explanations:

• You started Security Manager Client shortly 
after your server restarted. If so, allow a few 
more minutes for the server to become fully 
available, then try again to use 
Security Manager Client.

• Your CiscoWorks administrative password 
contains special characters, such as ampersands 
(&). As a result, the Security Manager 
installation failed to create a comUser.dat file 
in the NMSROOT\lib\classpath subdirectory on 
your server, where NMSROOT is the directory in 
which you installed Common Services (the 
default is C:\Program Files\CSCOpx): 

a. Either contact Cisco TAC for assistance in 
replacing comUser.dat or reinstall 
Security Manager. 

b. Create a new Common Services password that 
does not use special characters.

Error - Unable to 
Check License on 
Server.

An attempt to check 
the license file on 
the CS Manager server 
has failed.

Please confirm that 
the server is running. 
If the server is 
running, please 
contact Cisco 
Technical Assistance.

At least one of the following services did not start 
correctly. On the server, select Start > Programs > 
Administrative Tools > Services, right-click each 
service named below, then select Restart from the 
shortcut menu:

• Cisco Security Manager Daemon Manager.

• Cisco Security Manager database engine.

• Cisco Security Manager Tomcat Servlet Engine.

• Cisco Security Manager VisiBroker 
Smart Agent.

• Cisco Security Manager Web Engine.

Wait 5 minutes, then try again to start 
Security Manager Client.
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Q. My client system uses Windows 2000 as its operating system and its copy of 
Internet Explorer shows page display errors when I try to establish 
connections to a Security Manager server. What is the problem?

A. Security Manager uses and requires a cipher strength of 128 bits for SSL 
communication. Internet Explorer cannot use 128-bit encryption on systems 
that run Windows 2000 without Service Pack 4. If your client system uses 
Windows 2000 without Service Pack 4, its copy of Internet Explorer uses 
56-bit encryption for SSL connections, and therefore cannot communicate 
with any Security Manager server. For a complete description of the system 
requirements to use Security Manager Client, see Client Requirements, 
page 2-8.

Tip To learn what cipher strength your client system uses in its copy of 
Internet Explorer, select Help > About Internet Explorer.

Q. Why is the Activity Report not displayed when I use Internet Explorer as my 
default browser?

A. This problem occurs because of invalid registry key values or inaccuracies 
with the location of some of the dll files associated with Internet Explorer. For 
information on how to work around this problem, refer to the Microsoft 
Knwoledge Base article 281679, which is available at this URL: 
http://support.microsoft.com/kb/281679/EN-US.

Problems During Uninstallation

Q. When I uninstall the client software, what does this uninstallation error 
message mean?

A. Client software uninstallation error messages and explanations appear in 
Table B-4, where they are sorted alphabetically by their first word.
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Other Problems

Q. I am unable to install or uninstall any software on a client system. Why?

A. If you run an installation and an uninstallation simultaneously on the client 
system, even if they are for different applications, you corrupt the client 
system InstallShield database engine and are prevented from installing or 
uninstalling any software. For more information, log in to your Cisco.com 
account, then use Bug Toolkit to view CSCsd21722 and CSCsc91430.

Table B-4 Uninstallation Error Messages (Client)

Message Reason for Message User Action

Welcome to the 
InstallShield 
Wizard for ERROR: 
cannot load product 
/product.xml

The uninstall.dat file 
is not in its expected 
location, or was 
deleted.

• If you moved the uninstall.dat file, return it to the 
specified folder, then try again to use the 
uninstallation utility. 

• If you deleted uninstall.dat, but you know that 
another client system is using the identical version 
of Security Manager Client1, copy the required 
file from that other system to the specified folder 
where the file is missing, then try again to use the 
uninstallation utility.

• If you deleted uninstall.dat and have no other copy 
of it, do the following:

1. Delete the directory in which you installed 
Security Manager Client.

2. Rename the C:\Program Files\
Common Files\InstallShield\Universal\
Gen1 subdirectory.

3. Install a new copy of Security Manager 
Client.

1. You can assume that the uninstall.dat files for Security Manager Client are identical on two client systems when you see 
identical values in the client.info files on those same two client systems. To check whether the values are identical, use any 
text editor to read the client.info file, which is located by default in the directory where you installed Security Manager 
Client. The relevant values in the file use these labels: PRODVERS, VERSION, PATCHVER, and BUILD_NUM. 

Note For additional information about uninstallation error messages, see the Common Services 3.0.5 
documentation on Cisco.com.
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Troubleshooting the Standalone Security Agent
This section answers questions that you might ask about troubleshooting the 
standalone version of Cisco Security Agent that is installed in most cases when 
you install Security Manager server software.

Q. Under what circumstances might the standalone agent block network access 
to and from my server?

A. In broad terms, there are only two possibilities: Either malicious software is 
running on your server and the agent blocked it, or legitimate software on the 
server tried to do something that the agent misinterpreted as malicious. Both 
these problems can occur only if you previously set the agent security level to 
high and, in so doing, enabled an agent policy that is intended to detect and 
block the actions of untrusted rootkits. (The default setting is medium.)

We recommend that you investigate both possibilities to determine which of 
them is true in your case. Reading this log file should help you to identify the 
application whose actions the agent deemed suspicious: C:\Program 
Files\Cisco Systems\CSAgent\log\csalog.txt.

If your investigation shows that malicious software is running on the server, 
we recommend that you identify and eliminate whatever exploited 
vulnerabilities allowed the dangerous installation to occur. We further 
recommend that you wipe the server hard drive, then use the checklists and 
procedures in this guide to reinstall everything.

If you discover that benign (harmless) software— such as a trustworthy 
antivirus tool or a known device driver that loads dynamically after a system 
restart — triggered the agent, you can do any of the following:

• Reset the agent security level to medium, then restart the server.

Note If you later set the agent security level again to high, the agent 
will again consider the trusted and reinstalled software to be 
untrustworthy and will again block all network traffic. 

• Uninstall the trusted software.
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• Uninstall the agent. We recommend that you do never do this. See 
Uninstalling the Standalone Agent, page C-4.

• Ask Cisco TAC to give you a revised agent. See Obtaining 
Documentation, Obtaining Support, and Security Guidelines, page xiii.

Another explanation is possible if the standalone agent blocks network access 
from your server. The Cisco Security Agent baseline policy for Windows 
users will not allow you to use Windows File Explorer to access any web page 
through HTTP.

Q. Why is Cisco Security Agent missing from the Start menu in my Japanese 
version of Windows?

A. You might have configured the regional and language option settings on the 
server to use English. We do not support English as the language in any 
Japanese version of Windows (see Server Requirements, page 2-5). Use the 
Control Panel to reset the language to Japanese.

Q. How can I verify that any Windows services that my standalone Cisco 
Security Agent might require are actually running on my server?

A. The standalone agent requires only one Windows service. Select Start > 
Settings > Control Panel > Administrative Tools > Services. You should 
see a running service called “Cisco Security Agent.”

Q. The red flag icon for Cisco Security Agent changed in my Windows system 
tray. The icon now has a red circle partially superimposed over it. What does 
it mean?

A. Something has disabled the agent (for example, you turned it off) or it is 
broken. Restarting your server might cause the standalone agent to reset 
itself, or you can check whether a message in the log tells you exactly what 
happened. See C:\Program Files\Cisco Systems\CSAgent\log\csalog.txt.
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Q. The agent has blocked a valid operation. What can I do?

A. You can choose any of these possible workarounds:

• Right-click the agent icon in the Windows system tray, then select the off 
option to disable the agent temporarily. When you complete the task, 
reenable the agent.

• Uninstall the agent, even though we recommend that you do not uninstall 
it. See Uninstalling the Standalone Agent, page C-4.

• Select Start > Programs > Cisco Systems > Cisco Security Agent > 
Cisco Security Agent Diagnostics to run the diagnostic utility. 

If none of the workarounds is sufficient, you can open a case with Cisco TAC 
(see Obtaining Documentation, Obtaining Support, and Security Guidelines, 
page xiii). 

Q. If I upgrade Security Manager from 3.0 or 3.0.1, what happens to my 
Security Agent log files from that old Security Manager version?

A. The log files are retained in C:\Program Files\Cisco Systems\CSAgent\log\.

Running a Server Self-Test
To run a self-test that confirms whether your Security Manager server is 
operating correctly:

Step 1 From a system on which Security Manager Client is connected to your 
Security Manager server, select Tools > Security Manager Administration.

Step 2 In the Administration window, click Server Security, then click any button.

Step 3 When a new browser opens, click the CiscoWorks link.

Step 4 From the Common Services area on the CiscoWorks home page, select Server > 
Admin.

Step 5 In the Admin page TOC, click Selftest.

Step 6 Click Create.
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Step 7 Click the SelfTest Information at <MM-DD-YYYY HH:MM:SS> link, where:

• MM-DD-YYYY is the current month, day, and year.

• HH:MM:SS is a timestamp that specifies the hour, minute, and second when 
you clicked Selftest.

Step 8 Read the entries in the Server Info page.

Collecting Server Troubleshooting Information
The Security Manager Diagnostics utility collects server diagnostic information 
in a ZIP file, CSMDiagnostics.zip. You overwrite the file with new information 
each time you run Security Manager Diagnostics, unless you rename the file. The 
information in your CSMDiagnostics.zip file can help a Cisco technical support 
engineer to troubleshoot any problems that you might have with 
Security Manager or its related applications on your server. 

You can run Security Manager Diagnostics in either of two ways.

Note There is no requirement to submit a CSMDiagnostics.zip file when you first 
submit a problem report. In a case where we require the file, your Cisco technical 
support engineer tells you how to submit it.

From a Security Manager client system: From a Security Manager server:

1. After you establish a Security Manager Client 
session to your server, click Tools > Security 
Manager Diagnostics, then click OK.

The CSMDiagnostics.zip file is saved on your 
server in the NMSROOT\MDC\etc\ directory, 
where NMSROOT is the directory in which 
you installed Common Services (C:\Program 
Files\CSCOpx, for example). If you rename 
the file, you will not overwrite it accidentally.

2. Click Close. 

1. Select Start > Run, then enter command. 
Alternatively, if your server keyboard 
includes a Windows key, press Windows-R, 
then enter command.

2. Enter C:\Program Files\CSCOpx\MDC\
bin\CSMDiagnostics. Alternatively, to save 
the ZIP file in a different location than 
NMSROOT\MDC\etc\, enter 
CSMDiagnostics drive:\path. For example, 
CSMDiagnostics D:\temp.
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Viewing and Changing Server Process Status
To verify that the server processes for Security Manager are running correctly: 

Step 1 From the CiscoWorks home page, select Common Services > Server > Admin.

Step 2 In the Admin page TOC, click Processes.

The Process Management table lists all server processes. Entries in the 
ProcessState column indicate whether a process is running normally.

Step 3 If a required process is not running, restart it. See Restarting All Processes on 
Your Server, page B-22.

Note Only users with local administrator privileges can start and stop the server 
processes. 

Restarting All Processes on Your Server

Note You must stop all processes, then restart them all, or this method does not work. 

Step 1 At the command prompt, enter net stop crmdmgtd to stop all processes. 

Step 2 Enter net start crmdmgtd to restart all processes.

Tip Alternatively, you can select Start > Settings > Control Panel > 
Administrative Tools > Services, then restart Cisco Security Manager 
Daemon Manager.
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Reviewing the Server Installation Log File
If responses from the server differ from the responses that you expect, you can 
review error and warning messages in the server installation log file. 

Use a text editor to open C:\Ciscoworks_install_NNN.log, where NNN is a 
timestamp in the format YYYYMMDD_HHMMSS. 

In most cases, the log file to review is the one that has either the highest number 
appended to its filename or has the most recent creation date.

For example, you might see log file error and warning entries that say:

ERROR: Cannot Open C:\PROGRA~1\CSCOpx/lib/classpath/ssl.properties at 
C:\PROGRA~1\CSCOpx\MDC\Apache\ConfigSSL.pl line 259.
INFO: Enabling SSL....
WARNING: Unable to enable SSL. Please try later....

Note In the event of a severe problem, you can send the log file to Cisco TAC. See 
Obtaining Documentation, Obtaining Support, and Security Guidelines, page xiii.
B-23
Installation Guide for Cisco Security Manager 3.1

OL-11475-10



 

Appendix B      Troubleshooting
    Reviewing the Server Installation Log File
B-24
Installation Guide for Cisco Security Manager 3.1

OL-11475-10


	Troubleshooting
	Questions and Answers
	Server Q&A
	IPS Event Viewer Q&A
	Client Q&A

	Troubleshooting the Standalone Security Agent
	Running a Server Self-Test
	Collecting Server Troubleshooting Information
	Viewing and Changing Server Process Status
	Restarting All Processes on Your Server
	Reviewing the Server Installation Log File



<<
  /ASCII85EncodePages false
  /AllowTransparency false
  /AutoPositionEPSFiles true
  /AutoRotatePages /All
  /Binding /Left
  /CalGrayProfile (Dot Gain 20%)
  /CalRGBProfile (sRGB IEC61966-2.1)
  /CalCMYKProfile (U.S. Web Coated \050SWOP\051 v2)
  /sRGBProfile (sRGB IEC61966-2.1)
  /CannotEmbedFontPolicy /Warning
  /CompatibilityLevel 1.4
  /CompressObjects /Tags
  /CompressPages true
  /ConvertImagesToIndexed true
  /PassThroughJPEGImages true
  /CreateJDFFile false
  /CreateJobTicket false
  /DefaultRenderingIntent /Default
  /DetectBlends true
  /DetectCurves 0.0000
  /ColorConversionStrategy /LeaveColorUnchanged
  /DoThumbnails false
  /EmbedAllFonts true
  /EmbedOpenType false
  /ParseICCProfilesInComments true
  /EmbedJobOptions true
  /DSCReportingLevel 0
  /EmitDSCWarnings false
  /EndPage -1
  /ImageMemory 1048576
  /LockDistillerParams false
  /MaxSubsetPct 100
  /Optimize true
  /OPM 1
  /ParseDSCComments true
  /ParseDSCCommentsForDocInfo true
  /PreserveCopyPage true
  /PreserveDICMYKValues true
  /PreserveEPSInfo true
  /PreserveFlatness true
  /PreserveHalftoneInfo false
  /PreserveOPIComments false
  /PreserveOverprintSettings true
  /StartPage 1
  /SubsetFonts true
  /TransferFunctionInfo /Apply
  /UCRandBGInfo /Preserve
  /UsePrologue false
  /ColorSettingsFile ()
  /AlwaysEmbed [ true
  ]
  /NeverEmbed [ true
  ]
  /AntiAliasColorImages false
  /CropColorImages true
  /ColorImageMinResolution 300
  /ColorImageMinResolutionPolicy /OK
  /DownsampleColorImages true
  /ColorImageDownsampleType /Bicubic
  /ColorImageResolution 300
  /ColorImageDepth -1
  /ColorImageMinDownsampleDepth 1
  /ColorImageDownsampleThreshold 1.50000
  /EncodeColorImages true
  /ColorImageFilter /DCTEncode
  /AutoFilterColorImages true
  /ColorImageAutoFilterStrategy /JPEG
  /ColorACSImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /ColorImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000ColorACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000ColorImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasGrayImages false
  /CropGrayImages true
  /GrayImageMinResolution 300
  /GrayImageMinResolutionPolicy /OK
  /DownsampleGrayImages true
  /GrayImageDownsampleType /Bicubic
  /GrayImageResolution 300
  /GrayImageDepth -1
  /GrayImageMinDownsampleDepth 2
  /GrayImageDownsampleThreshold 1.50000
  /EncodeGrayImages true
  /GrayImageFilter /DCTEncode
  /AutoFilterGrayImages true
  /GrayImageAutoFilterStrategy /JPEG
  /GrayACSImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /GrayImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000GrayACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000GrayImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasMonoImages false
  /CropMonoImages true
  /MonoImageMinResolution 1200
  /MonoImageMinResolutionPolicy /OK
  /DownsampleMonoImages true
  /MonoImageDownsampleType /Bicubic
  /MonoImageResolution 1200
  /MonoImageDepth -1
  /MonoImageDownsampleThreshold 1.50000
  /EncodeMonoImages true
  /MonoImageFilter /CCITTFaxEncode
  /MonoImageDict <<
    /K -1
  >>
  /AllowPSXObjects false
  /CheckCompliance [
    /None
  ]
  /PDFX1aCheck false
  /PDFX3Check false
  /PDFXCompliantPDFOnly false
  /PDFXNoTrimBoxError true
  /PDFXTrimBoxToMediaBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXSetBleedBoxToMediaBox true
  /PDFXBleedBoxToTrimBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXOutputIntentProfile ()
  /PDFXOutputConditionIdentifier ()
  /PDFXOutputCondition ()
  /PDFXRegistryName ()
  /PDFXTrapped /False

  /Description <<
    /CHS <FEFF4f7f75288fd94e9b8bbe5b9a521b5efa7684002000500044004600206587686353ef901a8fc7684c976262535370673a548c002000700072006f006f00660065007200208fdb884c9ad88d2891cf62535370300260a853ef4ee54f7f75280020004100630072006f0062006100740020548c002000410064006f00620065002000520065006100640065007200200035002e003000204ee553ca66f49ad87248672c676562535f00521b5efa768400200050004400460020658768633002>
    /CHT <FEFF4f7f752890194e9b8a2d7f6e5efa7acb7684002000410064006f006200650020005000440046002065874ef653ef5728684c9762537088686a5f548c002000700072006f006f00660065007200204e0a73725f979ad854c18cea7684521753706548679c300260a853ef4ee54f7f75280020004100630072006f0062006100740020548c002000410064006f00620065002000520065006100640065007200200035002e003000204ee553ca66f49ad87248672c4f86958b555f5df25efa7acb76840020005000440046002065874ef63002>
    /DAN <>
    /DEU <>
    /ESP <>
    /FRA <>
    /ITA <>
    /JPN <>
    /KOR <FEFFc7740020c124c815c7440020c0acc6a9d558c5ec0020b370c2a4d06cd0d10020d504b9b0d1300020bc0f0020ad50c815ae30c5d0c11c0020ace0d488c9c8b85c0020c778c1c4d560002000410064006f0062006500200050004400460020bb38c11cb97c0020c791c131d569b2c8b2e4002e0020c774b807ac8c0020c791c131b41c00200050004400460020bb38c11cb2940020004100630072006f0062006100740020bc0f002000410064006f00620065002000520065006100640065007200200035002e00300020c774c0c1c5d0c11c0020c5f40020c2180020c788c2b5b2c8b2e4002e>
    /NLD (Gebruik deze instellingen om Adobe PDF-documenten te maken voor kwaliteitsafdrukken op desktopprinters en proofers. De gemaakte PDF-documenten kunnen worden geopend met Acrobat en Adobe Reader 5.0 en hoger.)
    /NOR <>
    /PTB <>
    /SUO <>
    /SVE <>
    /ENU (Use these settings to create Adobe PDF documents for quality printing on desktop printers and proofers.  Created PDF documents can be opened with Acrobat and Adobe Reader 5.0 and later.)
  >>
  /Namespace [
    (Adobe)
    (Common)
    (1.0)
  ]
  /OtherNamespaces [
    <<
      /AsReaderSpreads false
      /CropImagesToFrames true
      /ErrorControl /WarnAndContinue
      /FlattenerIgnoreSpreadOverrides false
      /IncludeGuidesGrids false
      /IncludeNonPrinting false
      /IncludeSlug false
      /Namespace [
        (Adobe)
        (InDesign)
        (4.0)
      ]
      /OmitPlacedBitmaps false
      /OmitPlacedEPS false
      /OmitPlacedPDF false
      /SimulateOverprint /Legacy
    >>
    <<
      /AddBleedMarks false
      /AddColorBars false
      /AddCropMarks false
      /AddPageInfo false
      /AddRegMarks false
      /ConvertColors /NoConversion
      /DestinationProfileName ()
      /DestinationProfileSelector /NA
      /Downsample16BitImages true
      /FlattenerPreset <<
        /PresetSelector /MediumResolution
      >>
      /FormElements false
      /GenerateStructure true
      /IncludeBookmarks false
      /IncludeHyperlinks false
      /IncludeInteractive false
      /IncludeLayers false
      /IncludeProfiles true
      /MultimediaHandling /UseObjectSettings
      /Namespace [
        (Adobe)
        (CreativeSuite)
        (2.0)
      ]
      /PDFXOutputIntentProfileSelector /NA
      /PreserveEditing true
      /UntaggedCMYKHandling /LeaveUntagged
      /UntaggedRGBHandling /LeaveUntagged
      /UseDocumentBleed false
    >>
  ]
>> setdistillerparams
<<
  /HWResolution [2400 2400]
  /PageSize [612.000 792.000]
>> setpagedevice


