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Using Network Management Tools

This chapter describes CiscoWorks and several third-party network management tools, and includes the
following sections:

e Net-SNMP, page 2-1

e SilverCreek SNMP Test Suite, page 2-3

e Ipswitch WhatsUp Gold, page 2-17

e HP OpenView Network Node Manager, page 2-30
e CiscoWorks, page 2-46

Net-SNMP

Net-SNMP Version 5.1.2 provides the following tools and libraries:
e An extensible agent
e An SNMP library
e Tools to request or set information from SNMP agents
e Tools to generate and handle SNMP traps
You can download the Net-SNMP network management tool from the following URL.:
http://sourceforge.net/projects/net-snmp/
This section includes the following topics:
e Polling a MIB, page 2-1
¢ Sending a Trap, page 2-2

Polling a MIB

To poll a MIB, after you have finished configuring the adaptive security appliance, run the snmpwalk
command from the NMS to the adaptive security appliance:

~

Note  No specific configuration is required for Net-SNMP on Linux when you run the snmpwalk command.

[root@iLinux2 ~]# snmpwalk -v3 -u md5des -1 authPriv -a MD5 -A mysecretpass -x des -X
passphrase 10.31.8.254 1.3.6.1.2.1.1
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The following is sample output from the snmpwalk command:

SNMPv2-MIB: :sysDescr.0 = STRING: Cisco Adaptive Security Appliance Version 8.2(0)227

SNMPv2-MIB: :sysObjectID.0 = OID: SNMPv2-SMI::enterprises.9.1.915
SNMPv2-MIB: :sysUpTime.0 = Timeticks: (486600) 1:21:06.00

SNMPv2-MIB: :sysContact.0 = STRING: admin admin

SNMPv2-MIB: :sysName.0 = STRING: ciscoasa

SNMPv2-MIB: :sysLocation.0 = STRING: sjc - 190 W Tasman Drive, San Jose,
USA

SNMPv2-MIB: :sysServices.0 = INTEGER: 4

Sending a Trap

When the adaptive security appliance sends a trap, it is authoritative, which means that the user created
within the snmptrapd command must be associated with the EnginelD sending the trap.

To establish this association, perform the following steps:

Step1  In the /var/net-snmp/snmptrapd.conf file, enter the following statement:

createUser -e ENGINEID myuser authentication protocol “my authentication pass” AES "my

privacy pass”
For this statement, define the listed parameters, which include the following:

— ENGINEID—The EnginelD of the application that is going to be sending the trap

— myuser—The USM username that is going to be sending the trap

— authentication protocol—The authentication type (SHA or MDS5, with SHA the preferred

setting.)

- “my authentication pass”—The authentication pass-phrase to use to generate the secret
authentication key. Enclose the pass-phrase in quotation marks if it includes spaces.

— privacy protocol—The encryption type to use (AES or DES, with AES the preferred setting)

- “my privacy pass”—The encryption pass-phrase to use to generate the secret encryption key.

Enclose the pass-phrase in quotation marks if it includes spaces. If you do not enclose the
encryption pass-phrase in quotation marks, it is set to the same value as the authentication

pass-phrase.

Step2  In the /tmp/snmptrapd.conf file, enter the following statement:

createUser -e 80000009fe8949e0b20319e2d175b93fe7dc24af0df£f7db915 md5des MD5 mysecretpass

DES passphrase

Step3  Run the snmptrapd command, pointing to that file.

~

Note  This process runs in the foreground, uses only the specified configuration file, and logs messages

to the stderr file.

[root@iLinux2 net-snmp]# snmptrapd -f -C -c /tmp/snmptrapd.conf -Le

Step4d  Run the snmptrap command from the adaptive security appliance to send a linkdown or linkup trap by

entering the following commands:

hostname (config)# int g3/1.391
hostname (config-if)# shut
hostname (config-if)# no shut
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The following is sample output from the snmptrap command:

2009-03-18 23:52:06 NET-SNMP version 5.1.2 Started.
2009-03-18 23:52:20 10.31.8.254 [10.31.8.2547]:

SNMPv2-MIB: :sysUpTime.0 = Timeticks: (938700) 2:36:27.00 SNMPv2-MIB: : snmp
TrapOID.0 = OID: IF-MIB::linkDown IF-MIB::ifIndex.l = INTEGER: 1 IF-MIB::
ifAdminStatus.l = INTEGER: down (2) IF-MIB::ifOperStatus.l = INTEGER: down (2

)
2009-03-18 23:52:22 10.31.8.254 [10.31.8.254]:

SNMPv2-MIB: :sysUpTime.0 = Timeticks: (939000) 2:36:30.00 SNMPv2-MIB: : snmp
TrapOID.0 = OID: IF-MIB::1linkUp IF-MIB::ifIndex.l = INTEGER: 1 IF-MIB::ifAdminS
tatus.l = INTEGER: up (1) IF-MIB::ifOperStatus.l = INTEGER: up(1l)

SilverCreek SNMP Test Suite

The SilverCreek SNMP test suite enables the detection of SNMP compliance problems and
implementation errors in private and standard MIBs. You can download a free version of the software
from the following URL.:

http://www.iwl.com/trial-downloads/silvercreek-trial. html?Itemid=
This section includes the following topics:

e Running SilverCreek, page 2-3

e Setting Up an SNMP Version 3 Agent, page 2-5

e Loading and Deleting MIBs, page 2-7

e Running a Test Suite, page 2-8

e Enabling Debugging, page 2-9

e Testing MIBs, page 2-12

e Receiving Notification Trap Messages, page 2-15

e Testing Performance, page 2-16

Running SilverCreek

To run the SilverCreek software, choose Start > All Programs > SilverCreekMx Evaluation > Run
Test Suite and Tools (Start Here).

When the application starts, along with the SilverCreek main window (see Figure 2-1), a console
window (see Figure 2-2) appears that shows the following information:

e Logging messages

e Debugging messages

e Other message exchanges that occur between the NMS and the SNMP Version 3 agent
e MIBs that are loaded

Using SNMP Version 3 with CiscoWorks and Third-Party Tools Implementation Guide
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Figure 2-1
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Figure 2-2 SilverCreek Console Window
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Setting Up an SNMP Version 3 Agent

Step 1

To set up the SNMP Version 3 agent, perform the following steps:

Choose File > New Agent Setup.

275378
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Figure 2-3 shows how the new agent must be configured.

Figure 2-3 New Agent Setup Dialog Box
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Step 2 Enter the hostname or the IP address, port number, and SNMP Version 3 parameters.

After the agent is connected, as shown in Figure 2-4, you can run SNMP test suites from the Test Suites
tab in the left pane.
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Figure 2-4
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To load and delete MIBs, perform the following steps:

To manually load and delete MIBs, choose MIB > Load | Delete MIBs.
To view the loaded MIBs, click View Loaded Modules (see Figure 2-5).

You can maintain all the MIB files in the default mibs directory, which is defined by the environment

variable, MIB_PATH.
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Figure 2-5 Load and Delete MIBs Dialog Box
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Running a Test Suite

275387

To run a test suite, perform the following steps:

Step 1 In the main window, select a test category (for example, MIB-II tests) in the left pane (see Figure 2-6).

The list of available tests for the selected test category appears in the right pane, and test details appear
in the bottom pane.

Step2  Select a single test or multiple tests, and click Run All or Selected Tests.

The test status appears in the Status column. The total number of tests run, passed, failed, and so on
appears at the bottom of the window.
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Figure 2-6 SilverCreek Main Window Showing Selected Tests
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Enabling Debugging

To enable debugging, choose Tools > Options (see Figure 2-7).
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Figure 2-7 Debug Tab of the Options Dialog Box
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Figure 2-8 shows the warning message that appears to indicate that the test runs more slowly with
debugging turned on.
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Figure 2-8 Warning Notes Dialog Box

Cne or more debug options are enabled.

Funning tests in batch mode with debug options turned on will substantially slow down the
automated testing process.

“ou can disakble debug options using Yiew-=Packet Trace menu if vou don't intend to run batch
tests in debug mode.

Save.,, Cloze

Figure 2-9 shows the console dialog box that lists the debugging messages, which appear when you run
a test.
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Figure 2-9 Console Dialog Box Listing Debugging Messages
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Testing MIBs

To test MIBs, perform the following steps:

Step 1 In the left pane of the main window, click the MIB Testing tab.

All the MIB modules that are loaded and available for testing appear (see Figure 2-10).
Step2  Click the radio buttons for the MIBs that need to be tested.
Step3  In the right pane, select the tests that need to be run.

The purpose and details of the tests appear in the bottom pane.
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Accessing the MIB Browser

Step 1

To access the MIB Browser, perform the following steps:

In the main window, choose MIB > MIB Browser.

The MIB Browser (see Figure 2-11) provides more detailed access to the agent MIBs, including the

ability to poll an individual MIB, walk a selected tree, and so on.

| oL-19726-01
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Figure 2-11 MIB Browser: Local MIB Tree Mode Dialog Box

' MIB Browser: Local MIB Tree mode - tree reflects locally loaded MIBs
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[ registration-authorit:
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H—(_] rman [16] IMcles: abject:

(] clot1 clBricy
O— 1 hast 1251 | % Index instance:  Click on & roww to display ..

' %
g

< | >

Ready...

Step2  Scroll down to the OID, .iso.org.dod.internet.mgmt.mib-2.system and right-click system; then choose
the option to walk this tree.

The MIB browsing results appear in the right pane, as shown in Figure 2-12.
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1B Browser: Local MIB Tree mode - tree reflects locally loaded|MIBs

Eile  Wiew

2peration

SilverCreek SNMP Test Suite

MIB Browser: Local MIB Tree Mode Dialog Box Showing MIB Results

Tool hocde:

Local MIB Tree

s standard [0]
registration-authorit:
smember-body [2]

— @ sysDesc
— i =ysOhjec
— @ =ysUpTir
— @ =y=Cont:
— @ =yshiame
— i =ysLoca
— i sysServi
— syaORL:
[]—ﬁ =y=0RT:
H— (] interfaces
H—(_ ] =t [3]
(] i [4]
H— (] icmp [5]
H—(_] tep [6]
(7 uckp [7]
H—(_7] 2o [3]
H— (] transmissic
H—(_ ] snimp [11]
H— (7] rmon [16]
H— (7] clot1 dBridg

e O e B e e B g B e o B pr e B g B M

H—"71 hnst 1951

|

| >

eIl

Ho. &) OID-Hame Syntax Value Full_0ID

1 aysDescr.0 DizplayString Cizco &daptive 5 1 36121110
2 sysOhjectiD.0 OhjectiD 1361418167 136121120
3 syzpTime.0 TimeTicks 5252500 136121130
4 sysContact.0 DizplayString harid 136121140
5 syshlame.0 DizplayString ciscossa 1361211580
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See the Release Notes for the Cisco ASA 5500 Series Version 8.2(1) for a list of the open caveats that
apply to SNMP MIBs.

Receiving Notification Trap Messages

Step 1
Step 2

To receive notification trap messages, perform the following steps:

In the main window, choose Notifications >Notifications Monitor.

To configure the agent-specific information, click V3 Inform.

The Received Notifications dialog box (see Figure 2-13) shows the trap messages that are received,
along with the notification details displayed at the bottom.

~

Note

SNMP Version 3 does not send authentication failure traps; an SNMP Version 3 agent sends a
PDU report instead.

| oL-19726-01
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Figure 2-13 Notification Monitor Dialog Box

' Notification Monitor,

Options
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Order
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Listening Traps from All Source Addreszes

Open Log | Save All | Clear Cloze |
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Click "Configurstion' to change source fiter ...
Click rowes to see trap details

Testing Performance

To test performance, perform the following steps:

Choose Tools > Performance Monitoring Tool, select an operation that you want to perform (for

Step 1
example, Walk (get-bulks), and provide an Object name. You can run various commands multiple times.

Click Send Synchronously.

The selected SNMP operations start. Results appear in a separate window.

Step 2

The following example (see Figure 2-14) uses ifType, asks how many times you want to repeat the
operation, and uses the value, 10.
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Figure 2-14 Performance Measuring Dialog Box

' Performance Measuring @ @

"Send Synchranoushy' a request is sent only after the response for the previous regquest has been received. This is
the most commonly seen mode of SMMP communication.

"Send Asynchronoush': requests are sent continuously without wwaiting for the responzes coming in first for the
previous reguests . When round-trip time iz significant asynchronous mode should be much faster than synchronous
mode. You can adjust the maximum number of requests sent in s burst to make sure the sender does not overrun the
agent under test,

Resultz are tah delimited S0 that it can be impotted into spreadsheet application such as Excel.

Select a SMMP Operation to add to the list of commands to measure performance:

Get | Set | Mext | Walk (get-nexts) | Bulk | Walk {get-bulks) Clear Al

ulkwvalk +10 0 1
ifType

Load Comimands: | Save Commands |

,207 Maximum number of reguests sent in an asynchronous burst.
Mote if this value iz set too high the agent may drop requests.

Send Asynchronously Send Synchronously | Cancel |
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Ipswitch WhatsUp Gold

Ipswitch WhatsUp Gold is network management software that enables network discovery, and SNMP
monitoring and polling. You can download a free version of the software at the following URL:

http://www.whatsupgold.com/products/download/
This section includes the following topics:
e Starting Ipswitch WhatsUp Gold, page 2-17
e Adding a New SNMP Agent, page 2-18
e Adding SNMP Version 3 Credentials, page 2-19
e Using the WhatsUp Gold Web Interface, page 2-22
e Walking an SNMP MIB or an OID, page 2-23
e Configuring SNMP Traps, page 2-27

Starting Ipswitch WhatsUp Gold

To start the Ipswitch WhatsUp Gold application, choose Start > Programs > Ipswitch WhatsUp Gold
12.3 > WhatsUp Gold.

The main network explorer window appears (see Figure 2-15).
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Figure 2-15

@ Ipswitch WhatsUp Gold ¥12.3 - [Network Explorer - Dynamic Group Examples]
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E Device Types [Advanced) i Device View I -"}E Map View I , EE @ §
Ready A E

Adding a New SNMP Agent

To add a new SNMP agent, perform the following steps:

Step 1 Choose File > New > New Device.
The Add New Device dialog box appears (see Figure 2-16).
Figure 2-16 Add New Device Dialog Box
x
IP address or host name of the new device: Advanced. .. |
[l
Example: 192,168,200,123 or www,somedomain, com
o _ _ _ Caneel |
v add device immediakely without scanning
Help | g
wy
&
Step2  Enter the IP address or hostname.
Step 3

After the device has been added, enter device properties in the General pane, as shown in Figure 2-17.
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Figure 2-17 Device Properties Dialog Box

® pevice Properties : 172.23.62.198 ll
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|1?2.23.52.193

Additional Metwark, Interfaces. ..
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W Menu
Attributes

K, Cancel Help
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Adding SNMP Version 3 Credentials

To add SNMP Version 3 credentials, perform the following steps:

Step1  Click the Credentials link (see Figure 2-18), and enter the SNMP device object ID information.

Using SNMP Version 3 with CiscoWorks and Third-Party Tools Implementation Guide
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Figure 2-18

® Device Properties : 172.23.62.193

Device Properties Dialog Box Showing SNMP Credentials
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Step 2

Click the button next to the SNMP v1/v2/v3 credentials drop-down list and enter the username,

authentication and encryption algorithms, and corresponding passwords, then click OK (see Figure 2-19

and Figure 2-20).

Figure 2-19

Edit SNMP v3 Credential Type Dialog Box

Edit SNMP ¥3 Credential Type: mdSdes

Description:

I mdSdes

Usernarne:

I mdSdes
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Encryption
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S

Password:
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Password:

K

Cancel

_ concel |

Help
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Figure 2-20 Credentials Library Dialog Box

Credentials Library
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= Edit...
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Copy..,

Delete. ..
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K

Cancel

i
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Help

Figure 2-21 shows the added SNMP Version 3 node on the network.

Figure 2-21 Network Explorer Window with Added SNMP Version 3 Node
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Using the WhatsUp Gold Web Interface

To start the WhatsUp Gold application, perform the following steps:

Choose Start > Programs >IpSwitch WhatsUp Gold v12.3 > WhatsUp Web Interface. You can

Step 1
perform SNMP Version 3 walks and polls from this location.
Step2  Figure 2-22 shows the initial login window. Enter the default username and password, which is “admin.”
Figure 2-22 WhatsUp Gold Login Window for Web Interface
¥ Login - WhatsUp Gold - Mozilla Firefox _1al x|
File Edit ‘“ew History Bookmarks Tools Help
i;' s c x {5 I @ |http:jleT‘D.D‘1:808Dp’NmCUn5UIep’CUreNm,iUserfDIgUserLDg\np’DIgUSErLUgin.asp b |'| Google )"::'
|2 Most Wisited $ Getting Started | Latest Headines |j Customize Links \j Free Hotmail \j Windows Marketplace |j ‘Windows Media |j Windows
‘ Q Try WhatsUp Gold Yersion 12,4, VaIP, ... | ] -'l Mozilla Firefox Start Page |es) ] & Login - WhatsUp Gold ﬁ \ F
Q@WhatsUoGold
Qm\um Edttion w12.3.1
User name:
Password:
Start page:
IWhatsUp Horme ‘Workspace ﬂ
Login
Evaluation License: 30 days remaining
TPSWITCH
The ‘admin' password has not yet been changed. The default usemarne and passward is: ‘admin’. Once you login you can
change your passward on the Preferences dialog. To do this, after you login you can: =]
1__Click the 150" menin the ton left LI g
| Done W 4 R

Figure 2-23 shows the Home Workspace pane that appears after the user logs in.
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Figure 2-23 WhatsUp Gold Home Workspace Pane
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z 12 Traceroute Reports you need mast visible and is customizable to cater to
e w2 Lookip your awn sp_ecmc monitaring needs. Your Home Waorkspace
= . contains 3 views: General and Problem Areas 1 and 2. You can
=2 SNMP MIB Walker expand your workspace views by adding more Waorkspace
. SNV MIE Rl Explorer Reports or removing the reports you do not need |
- ps, Each WyhatsUp user can configure their own workspace views to
[5] MAC Address of this display the Workspace Reports he or she feels are necessary to
4+ Diagnostic ap. their personal monitoring needs. As with full reports, Group
Access Rights apply to Workspace Reparts that require a device
. B e ey 2 weh Performance Monitar group or device to be selected. Only users with access rights to a
sk Sl ety Logout E5 Web Task Manager Menu specific device or device group will be ahle to select that device or
&) Active Discovery Log group for a warkspace report
(@ General Error Log I Mavigating through the Web interface
Health I» Learning about Wo_rkspaces
— I Creating access rights for a device group
__| State Change Timeline P The WhatsUp User Guide
Top 10 I» Monitoring Performance Data in Real Time
&
javascripk:; W A g

Walking an SNMP MIB or an OID

To walk a MIB or an OID, perform the following steps:

Step1  Choose GO > Tools > SNMP MIB Walker (see Figure 2-24).
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Figure 2-24 SNMP MIB Walker Menu Option
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| jarvascript:; ’? A E
Step2  In the Network Tool: SNMP MIB Walker dialog box (see Figure 2-25), enter the following information:

e The agent IP address or hostname
e The OID or MIB that needs to be walked
e The SNMP Version 3 credentials
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Figure 2-25 Network Tool: SNMP MIB Walker Dialog Box

I=EY
I @ |http:HlZF‘D.D.1:SUSDJ‘NmCDnsoIejCoreNm;’Tools)’D\gMibWaIkerJ‘D\gMibWa\ker‘asp ii_?
=2 Network Tool: SNMP MIB Walker @ MibFileExplorer =3 MibWalker g}
Address or hosthame: Credentials:
[i722362.198 | [md5des @nPa) =l
O D) Eiter _Adganced. |
IsnmpTargetMIE | Wialk
3
| Done ’? A &

Step3  Click Walk.
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Figure 2-26 shows the walk results in a tree format.

Figure 2-26 Network Tool: SNMIP MIB Walker Results - Tree View

&) Network Took SNMP MIB Walker - Mozilla Firefox: =13 x|
I @ |httDlHlZT.D‘D.1:8080}’N!TICUﬂ5U|EfCUl’EN!TI,I’TDU|SII’D|gMidekErfD‘gMiﬁWa‘kEr‘ESD 0

=2 Network Tool: SNMP MIB Walker

@ MibFileExplorer =g MibWalker \;_)j

Address or hosthame Credentials:
[17z2362198 | [rdsdes @rvP) =

Object ID: Eilter: Adyanced...
[ Walk

|snmpTargetM\B

Walking 1.3.6.1.6.3.12 (snmpTargetMIB) on 172.23.62.198

|— iso.org.dod.internet
|— SNMpPY2{6)
|7 snmpModules{3)
f snmpTargetMIB{12)
|— snmpTargetObjects{1)
r snmpTargetAddrTable(2)
|— snmpTargetAddrEntry(1)
r snmpTargetAddrTDomain{2)

f snmpTargetAddrTAddress{3)
r snmpTargetAddrTimeout(4)
r snmpTargetAddrRetryCount{s)

f snmpTargetAddrTagList{6)

4]

|7 116.114.97.112.104.111.115.116.46.109.100.53.100.101.115.46.49.55.50.46.50.51.46.51.50.46.49.53.90.46.54.53.53.51.56 1.3.6.1.6.1.1
|— 116.114.97.112.104.111.115.116.46.109.100.53.100.101.115.46.49.55.50.46.50.51.46.51.50.46.49.53.50.46.54.53.53.51.56 AC17:20:98:0.A2
|— 116.114.97.112.104.111.115.116.46.109.100.53.100.101.115.46.49.55.50.46.50.51.46.51.50.46.49.53.50.46.54.53.53.51.56 1500

116.114.97.112.104.111.115.116.46.109.100.53.100.101.115.46.49.55.50.46.50.51.46.51.50.46.49.53.50.46.54.53.53.51.596 3

Stop Back =]

| Dane

¥
S
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Figure 2-27 shows the results in sequence.
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Figure 2-27 Network Tool: SNMP MIB Walker Results Window

) Network Tool: SNMP MIB Walker - Mozilla Firefox 3l x|

I @ |http:”lz?ﬂ.ﬂ.1:BEIBEIJ‘NmCnnsnle,iCnreNm)’Tﬂnls)’D\nghWaIkarJ‘D\nghWa\ker‘asp 57

=2 Network Tool: SNMP MIB Walker @ MibFileExplorer =3 MibWalker Q)

Address or hostname: Credentials:

|‘\ 72.23.62.198 ,_I | mdbdas (SNMPYE) j

Qbject D: Eiter _Advangsd. |
| alk

|snmpTargelMIE

Walking 1.3.6.1.6.3.12 (snmpTargetMIB) on 172.23.62.198 Stop Back | =]

Ohject ID Value
shmpTargetAddTDomain. 116.114.97. 1121041111 1.3.6.1.6.1.1
snmpTargetAddTAddress. 116.114.97 112.104.111.1 AC:17:20:95:0:A2
snmpTargetAddrTimeout. 116.114.97.112.104.111.11 1500
snmpTargetAddrRetryCount. 116.114.97.112.104.111 3
snmpTargetAddrTaglist. 116.114.97 112.104.111.11£ trap
snmpTargetaddrParams. 116.114.97.112.104.111.11: traphost. mdodes. 172.23.32.152.65538
snmpTargetAddrStorageType. 116.114.57 112.104.11 non'olatile (3)
snmpTargetAddrRowStatus 116.114.97 112,104,111 active (1)
snmpTargetParamshPModel 116.114.97 11210411 3
snrpTargetParamsSecurityModel 116.114.97 11210 3
shrnpTargetPararmsSecurityMarme 116,114 97 11210 mdSdes
snrnpTargetParamsSecurityLevel 11611497 11210 authPriv (3)
snrnpTargetParamsStorageType 11611497 112104 nontvolatile (3)
shmpTargetParamsRowStatus 116.114.97 112.104.1 active (1)

Walk completed

14 objects successfully retrieved

275395

Done ’? 4

Configuring SNMP Traps

To configure SNMP traps, perform the following steps:

Step 1 Choose Program Options > Passive Monitor Listeners > SNMP Trap > Configure (see Figure 2-28).
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Step 2

Figure 2-28

[ Program Options

Program Options - Passive Monitor Listeners Dialog Box

X
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Report D ata
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Configure, .. |

"3% ‘indows Event Log  Monitor WWindows Event Log

® N oK |

Cancel | Help
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The SNMP Listener Configuration dialog box appears (see Figure 2-29). From here you can configure

the listener port and forward traps to a host.
Figure 2-29

SNMP Listener Configuration

¥ Listen for messages on pork: | 162

¥ Accept unsolicited SNMP traps:

[~ Forward traps

= | Forward unsalicited traps

Forward traps ko

fddl,.

Hast Part I

Edlit oo

Eerove, ..

(8]

Cancel

Help

FRHLE

Ix

SNMP Listener Configuration Dialog Box

g

5

Click the Reports tab and select SNMP Trap Log (see Figure 2-30).
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Figure 2-30 SNMP Reports Pane
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TPSWITCH Training

| Done

Figure 2-31 shows the SNMP trap log.
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Figure 2-31 SNMP Trap Log Pane
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HP OpenView Network Node Manager

HP OpenView Network Node Manager (NNM) 7.53 is a management tool that is used to automatically
create network topologies, manage devices, and monitor device health. The adaptive security appliance
is integrated into the HP NNM device topology, and communicates device statistics and SNMP traps
using SNMP Version 3.

Note  See the Cisco ASA 5500 Series Adaptive Security Appliance Version 8.2(1) Release Notes for a list of
the open caveats that apply to NNM 8.x.

This section includes the following topics:
e Installing NNM, page 2-31
e Starting the NNM, page 2-31
e Loading MIBs, page 2-32
¢ Adding a Network to the Current Map, page 2-33
e Configuring Specific SNMP Version 3 Parameters, page 2-36
e Setting Global SNMP Version 3 Credentials, page 2-37
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e Viewing Node Information, page 2-38
¢ Configuring the NNM MIB Browser, page 2-39
e Using the HP OpenView NNM Web Application, page 2-44

Installing NNM

NNM 7.53 was tested on the Windows 2003 Server platform. A trial version with the required
installation instructions is available at the following URL:

https://h10078.www 1.hp.com/cda/hpms/display/main/hpms_content.jsp?zn=bto&cp=1-11-15-1197115
5_4000_100__

Starting the NNM

To start the NNM, perform the following steps:

Step1  From the command prompt of the NNM server, choose one of the following:

e Start > Programs > HP OpenView > Network Node Manager Admin > Network Node
Manager.

¢ Double-click the ovw.exe file, located in C:\Program Files\HP OpenView\bin.

The Root window appears, with the Internet map icon displayed (see Figure 2-32).

Figure 2-32 NNM Console Root Window

_|of x|
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Using SNMP Version 3 with CiscoWorks and Third-Party Tools Implementation Guide
I oL-19726-m .m



Chapter2  Using Network Management Tools |

B HP OpenView Network Node Manager

Step2  Double-click the Internet map icon.

The Internet window appears, with the network nodes displayed (see Figure 2-33).
Figure 2-33 NNM Console Internet Window Showing Network Nodes

Internet

172.23.32

CISCO-ASA

[ "

10.0.0.30 [rmgh

(B )
[ {100.0.05 [autsiddy 5 52 13 [insh, [ {3
100 ciscoass) 172.23.62

jashlReadwike]

275402

Loading MIBs

To load MIBs, perform the following steps:

Step1  In the NNM main window, choose Options > Load/Unload MIBs: SNMP.
A list of currently loaded MIBs appears.
Step2  Click Load to select additional MIBs from the server file system (see Figure 2-34).
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Figure 2-34
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Adding a Network to the Current Map

Step 1

Step 2

To add a network to the current map, perform the following steps:

Find the IP address and hostname of at least one high-traffic device within the network that you want to
add.

In the Internet-level submap, choose Edit > Add Objects.
The Add Object Palette dialog box appears (see Figure 2-35).
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Figure 2-35 Add Object Palette Dialog Box
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Step3  Click the Connector Symbol Class icon, and drag the Gateway Symbol Subclass icon onto the
Internet-level submap. Choose this gateway connector, regardless of the type of device you are using to
start the discovery.

The Add Object dialog box appears (see Figure 2-36).
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Figure 2-36 Add Object Dialog Box
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Double-click IP Map.
The Add Object — Set Attributes dialog box appears (see Figure 2-37).
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Figure 2-37 Add Object — Set Attributes Dialog Box
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Step5  Type the IP address and hostname of an SNMP-enabled device within the network that you want to add
to your management domain, and click Verify.

Step6  After NNM checks the configuration, NNM corrects the symbol choice and (if necessary) its placement
for you. The device is now configured to be managed by NNM and should be visible on the Internet map.

Configuring Specific SNMP Version 3 Parameters

To configure credentials for specific SNMP nodes, perform the following steps:

Step1  Double-click the xnmsnmpconf.exe file, located in C:\Program Files\HP OpenView\bin.
Step2  In the NNM main window, choose Options > SNMP Configuration.

A configuration pane appears.
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Note  When you set SNMP Version 3 credentials, you must use the overloaded SNMP string. For more
information, see Step 2 in the “Configuring the NNM MIB Browser” section on page 2-39.

Setting Global SNMP Version 3 Credentials

To set global SNMP Version 3 credentials, in the Global Settings section, enter an SNMPv3 user and
password to be used for default communication (see Figure 2-38). For the format of the community
string, see Step 2 in the “Configuring the NNM MIB Browser” section on page 2-39.

Figure 2-38 SNMP Configuration
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Setting Specific SNMP Version 3 Credentials

To set specific SNMP Version 3 credentials, enter SNMP Version 3 users and passwords for individual
SNMP nodes by clicking the Specific Nodes tab (see Figure 2-39).
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Figure 2-39 SNMP Configuration Dialog Box
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Viewing Node Information

To view node information, perform the following steps:

Step 1

Step 2
Interface Status.

MNode | Comrmurity | Set Community | Prawy | Fietry | Tirneout | Part | F'olhng |
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1020234 3MAitann.. ] [ha.. T[] [- [-]
1020310 3Pauthp.. [ [no.. [ [ []

Al |
Iodify... |
Delete |

SNMP Configuration - 10.20.2.252 E

The Network Interface Properties dialog box appears (see Figure 2-40).

i

ok
Cancel

Help
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From the Internet map, drill down to a specific node for a view of all available interfaces.

To view additional interface information, right-click an interface, then choose Interface Properties or
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Figure 2-40 Network Interface Properties Dialog Box
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Configuring the NNM MIB Browser

To configure the NNM MIB Browser, perform the following steps:

Step1  From the NNM server command prompt, start the MIB Browser, located in C:\Program Files\HP
OpenView\bin\xnmbrowser.exe.

Step2  Enter the IP address of the SNMP host and the community string. For SNMP Version 3 connections, the
community string uses the syntax for the overloaded community string.

The following is an example of the syntax used for the overloaded community string:

SNMPv3 noAuthNoPriv

3N[/KEEP]/[ [contextEngineID] [-contextName]/ ]Jusername

SNMPv3 authNoPriv

3A[;[MD5A|SHAA]authKey[/KEEP]]/[ [contextEngineID] [-contextName]/
Jusername

SNMPv3 authPriv

3P[; [MD5" |SHA" JauthKey[; [DES” |AES" | 3DES" ]privKey] [/KEEP]]/[
[contextEngineID] [-contextName]/ ]Jusername

Using SNMP Version 3 with CiscoWorks and Third-Party Tools Implementation Guide
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Note  The default authentication is MDS5, and the default encryption is DES.

This section includes the following topics:
e Configuring SNMP Version 3 No-auth/No-priv Connections, page 2-40
e Configuring SNMP Version 3 MDS5 Auth/No-priv Connections, page 2-40
e Configuring SNMP Version 3 SHA Auth/No-priv Connections, page 2-40
¢ Configuring SNMP Version 3 MD5 Auth/Priv Connections, page 2-41
¢ Configuring SNMP Version 3 SHA Auth/Priv Connections, page 2-41
e Browsing a MIB, page 2-41
e Running a MIB Browser Packet Trace, page 2-42
e Using the NNM SNMP Version 3 Trap Viewer, page 2-43

Configuring SNMP Version 3 No-auth/No-priv Connections

To configure SNMP Version 3 No-auth/No-priv connections, perform the following steps:

Step1  To configure the UUT group, enter the snmp-server group asanoauth v3 noauth command.
Step2  To configure the UUT user, enter the snmp-server user titannoauth asanoauth v3 command.

Step 3 For the community name, enter 3N/titannoauth.

Configuring SNMP Version 3 MD5 Auth/No-priv Connections

To configure SNMP Version 3 MD5 Auth/No-priv connections, perform the following steps:

Step1  To configure the UUT group, enter the snmp-server group asaauth v3 auth command.

Step2  To configure the UUT user, enter the snmp-server user titanauth asaauth v3 auth mdS authpass
command.

Step3  For the community name, enter 3A:authpass/titanauth.

Configuring SNMP Version 3 SHA Auth/No-priv Connections

To configure SNMP Version 3 SHA Auth/No-priv connections, perform the following steps:

Step 1 To configure the UUT group, enter the snmp-server group asaauth v3 auth command.

Step2  To configure the UUT user, enter the snmp-server user titanshaauth asaauth v3 auth sha authpass
command.
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For the community name, enter 3A:SHA *authpass/titanshaauth.

Configuring SNMP Version 3 MD5 Auth/Priv Connections

Step 1
Step 2

Step 3

To configure SNMP Version 3 MDS5 Auth/Priv connections, perform the following steps:

To configure the UUT group, enter the snmp-server group asapriv v3 priv command.

To configure the UUT user, enter the snmp-server user titandes asapriv v3 auth mdS authpass priv
des privpass command.

For the community name, enter one of the following:
e 3P:authpass:privpass/titandes

e 3P:MDS5”authpass:DES”privpass/titandes

Configuring SNMP Version 3 SHA Auth/Priv Connections

Step 1
Step 2

Step 3

Browsing a MIB

Step 1
Step 2

To configure SNMP Version 3 SHA Auth/Priv connections, perform the following steps:

To configure the UUT group, enter the snmp-server group asapriv v3 priv command.

To configure the UUT user, enter the snmp-server user titanshades asapriv v3 auth sha authpass priv
des privpass command.

For the community name, enter 3P:SHA *authpass:DES”privpass/titanshades.

To browse a MIB, perform the following steps:

Drill down to the OID, .iso.org.dod.internet.mgmt.mib-2.system, and select the system object.

Click Start Query to fill in the MIB Values field with the DUT description (see Figure 2-41).
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Figure 2-41 Browse MIB Dialog Box
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Running a MIB Browser Packet Trace

To run a MIB Browser packet trace, in the MIB Browser dialog box, choose View > SNMP Packet
Trace.

The Messages dialog box appears (see Figure 2-42), which shows the packet contents of the SNMP
communication between the MIB Browser and the SNMP agent. This information is helpful for
debugging.
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Figure 2-42 Packet Trace in the Messages Dialog Box
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Using the NNM SNMP Version 3 Trap Viewer

When using the NNM SNMP Version 3 Trap Viewer, perform the following steps:

Step 1
Step 2

Step 3

Make sure that the SNMP Version 3 credentials of a user on the SNMP agent are cached in the NNM.

When using the MIB B

rowser to query an SNMP agent, enter the following community string:

3P:authpass:privpass/KEEP/titandes

~

Note By using the KEEP parameter in the overloaded community string, you save the user credentials
in the NNM configuration file, which is required because secure SNMP Version 3 traps and
inform requests are sent from the SNMP agent to the NNM, and authentication must occur. The
user information is included in the configuration file, located in C:\etc\srconf\mgr\mgr.cnf. You
can modify this file directly. For instructions, see the NNM SPI SNMP Version 7.53
documentation.

Alternatively, you can use the snmpget command, as shown in the following example:

C:\Program Files\HP OpenView\bin>snmpget -c “3P;MD5%authpass;DES*privpass/KEEP/titandes”

10.0.0.33 sysDescr.0

To configure the SNMP agent to send traps, enter the following command on the adaptive security

appliance:

hostname (config)# snmp-server host inside 10.0.0.10 traps version 3 titandes
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Note  The command syntax may differ slightly between adaptive security appliance platforms. The
user configured in this example is the same as the user defined in the community string in the
“Configuring the NNM MIB Browser” section on page 2-39.

The NNM traprcv utility is a command-line tool that receives SNMP trap messages and responds to
SNMP inform requests from remote SNMP entities. It binds to the SNMP trap port (udp/162) to listen
for notifications, and as a result, must be run as root. It prints standard output messages about the
notifications that it has received. The traprcv utility can receive SNMP Version 1 traps, SNMP Version
2c traps, SNMP Version 2c¢ inform requests, SNMP Version 3 traps, and SNMP Version 3 inform
requests. For more information, see the NNM SPI SNMP Version 7.53 documentation.

Run the traprev utility and wait for traps on the SNMP agent. The utility is available at the following
location (see Figure 2-43): C:\Program Files\HP OpenView\snmpv3\utils\traprcv.exe.

Figure 2-43 SNMP Trap Receiver
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Using the HP OpenView NNM Web Application

Step 1

Step 2

To start the NNM web application, perform the following steps:

In a web browser, go to the following URL.:
http://<NNM-Server-IP-Address>:7510/topology/home
To view SNMP nodes, from the drop-down menu, choose Internet View (see Figure 2-44).

The Internet View window appears (see Figure 2-45).
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Figure 2-44 NNM Home Base Window
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Mode View

J5tation Yiew Fepresentation of a selected device and its connector deviees, within a specified

p= from the selected device.

Mode Skatus Summary |“AIarm Browser || About |

Mode Status Summary as of Feb 11, 2009 11:29:22 AM EST

Mcricical : o jo3)

DHajor 0 (0%

Oxinar 2 (40%)

Cwarning @ o (03]

Erorual 3 (60%)

Evmmewm = 0 j0s)

Total 5
Crnamic Yiews ready

MMM Release BLOZ.53 "3%
Applet com.hp.ov, dynamicviews . gui,core, Dynamic. .. j o= Ide N Y L S MY C Y e |85 BT TR 5 e e N U

Step3  To view node properties, double-click the selected node to open a new browser window with the node
information.
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Figure 2-45 Internet View Window

B Internet View [from 172.18.154.102]

File Edit View Performance Configuration Faulk  Tools Help

Graph |

asa-5505-4

aga-9540-3

Total: 5 Critical: 1 Majort 1 Minor:  Warning: O Mormalt | Unmanaged:  Unknown: O

|pynamic Yiews ready
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CiscoWorks

CiscoWorks LAN Management Solution (LMS) is a suite of powerful management tools that simplify

the configuration, administration, monitoring, and troubleshooting of Cisco networks. For more

information, see the following URL:
http://www.cisco.com/en/US/products/sw/cscowork/ps2425/index.html
This section includes the following topics:

e Starting CiscoWorks, page 2-47

e Getting Started with the CiscoWorks LMS Portal, page 2-47

e Using the Device Center, page 2-48

e Performing an SNMP Walk, page 2-49

e Using the Management Station to Device Tool, page 2-54

Jl_ Using SNMP Version 3 with CiscoWorks and Third-Party Tools Implementation Guide
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Starting CiscoWorks

To start CiscoWorks on a Windows 2003 server, perform the following steps:

Choose Start >All Programs > CiscoWorks > CiscoWorks. Figure 2-46 shows the login page.

Figure 2-46 Login Page

-1
File Edit view Favorites Tools Help | '.,'
QBack » &) v [x] 2] | - search - Favorites 4" Media {ﬂl A o B
Advess [ hetps:jfpresm1/CSCOnmsrviet logijlogn.jsp B ks »
.
Nmm
Cisco
. presm
JavaScript:
Enaie
Couties T —
Enabled

Browser:

Supported Yersion

Copyright (¢) 1895 - 2008 Cisco Systems, Inc. ALl ;I
rights reserved.

=
[Eowme BRI
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Getting Started with the CiscoWorks LMS Portal

The CiscoWorks LMS Portal is the first page (see Figure 2-47) that appears when you start the LMS
application. This page serves as the interface, starting point, and top-level navigation for the frequently
used functions in the application.

Using SNMP Version 3 with CiscoWorks and Third-Party Tools Implementation Guide
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Figure 2-47

CiscoWorks LMS Portal Page

a prcsmi - LMS - Functional - Microsoft Internek Explorer

File Edit View Favorites Tools  Help

=151x

|

Qe - O - 11 @)
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_id=default

CiscoWorks LMS Portal (prcsm1)
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=

Welcome admin
Home | Logout | Help | About

Building and exporting & network map using Campus
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Using MetConfig to deploy mass configuration
" changes
« Using SWIM to upgrade device images
.. Using Liser Tracking to find an end host by IP or MAC

* Software Center
# Device and Credentials
> Groups

Cisco My Portal 0 puplic & Private
@
‘ Functional | System ‘ IMetwark | DFM | e ‘ U ATl PDT|
LMS workflows Demo Common Services Setup Center
« Using Baseling Templates +Home Server Setup
* Server ~Server Seftings

Device Diagnostic Tools

Device Fault Manager

CiscoWorks Assistant

+Home
“ Workflows
» Administration

'*Home

- Alerts and Activities
+Device Management
Fault History
+MNotification Services
- Configuration

+Device Troubleshooting
Device Center

CiscoWorks Product Updates

External Links

- Revalidated VeriSign Cerificate for Campus Manager
= Revalidated VeriSign Certificate for Internetvwork Performance Monitor

- More Updates ...

# Cisco.com Resources

* CiscoWorks Resources
~ Third Party

~ Customn Tools

I

|€1 Done

Using the Device Center

Step 1

Step 2

To manage devices, perform the following steps:

’_ ,_ ,_ |@ Trusted sites
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Choose Device Diagnostic Tools > Device Center (see Figure 2-48).

The Device Center Home page appears with the Device Selector in the left pane and Device Center
summary information in the right pane.

Enter the IP address or device name or choose a device from the list in the Device Selector pane, and
click Go.

Jl_ Using SNMP Version 3 with CiscoWorks and Third-Party Tools Implementation Guide
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Figure 2-48 Device Center Home Window
2 presmi - Device Center Home - Microsoft Internet Explorer =181x]
Eile Edt Vew Favorites Tools Help ‘ l"'
Back » &) - [x] 2] bl - Search - Favorites @Y Media @l - = =B
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|1?2 2362198 | Device IP Address 172.23.62.198
Device Type Mot Available

Device Selector

==Search Input=> o g

Search Results
O3 4 Devices
€ [ Device Type Groups
€ C User Defined Groups

Tools

- Management Station to Device
- Ping

- Telnet

= Trace Route

= Edit Device Identity

- Packet Capture

- SHMP Set

= SHMP Walk

= Device Troubleshooting

Functions Available

Enter Device Hame/IP Address:

]

Al

’7 ’7 ’7 ‘0 Trusted sites
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Performing an SNMP Walk

To perform an SNMP walk, perform the following steps:

Step 1 In the Functions Available pane, click the SNMP Walk link.

The SNMP Walk dialog box appears (see Figure 2-49).

| oL-19726-01
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Figure 2-49 SNMP Walk Dialog Box

a prcsmi - Device Center Home - Microsoft Internet Explorer ;Iilﬂ
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SMMPY3 Privacy Passwiord: I... [TITTTT]

SHMPy3 Privacy Protocol | DES 'I
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Tools Debug: [~
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- Packet Capture |€1 Done ’7 ’7 ’7 &) Trusted sites P
= SHMP Set
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[&]ene [T @ Trusted sres
Step2  Choose the SNMP version to use from the following options:
e For SNMP Version 3 (NoAuthNoPriv and AuthNoPriv Security Levels)
a. Enter the SNMPv3 Username.
b. Enter the SNMPv3 Auth Password.
¢. Choose the SNMP v3 Auth Protocol from the drop-down list (either MD5 or SHA).
d. Enter the SNMP Context Name.

~

Note Because the adaptive security appliance does not support contexts, you must leave the
SNMP Context Name blank.

e For SNMP Version 3 (AuthPriv Security Level)

a. Enter the SNMPv3 Username.

b. Enter the SNMPv3 Auth Password.

c. Specify the SNMP v3 Auth Protocol. Choose either MD5 or SHA.
d. Enter the Privacy Password.

e. Choose a privacy protocol from the drop-down list. The available values are DES, 3DES, AES128,
AES192, and AES256.

f. Enter the SNMP Context Name.

Using SNMP Version 3 with CiscoWorks and Third-Party Tools Implementation Guide
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Note
SNMP Context Name blank.

Because the adaptive security appliance does not support contexts, you must leave the

g. (Optional) Enter the starting OID. If you leave this field blank, the tool starts from 1.
h. Enter the SNMP Timeout. The default value is 10 seconds.

i. (Optional) Check the Output OIDs Numerically check box to print the output OIDs numerically.

j. By default, the corresponding OID name is printed in the output window.

k. (Optional) Check the Output Indexes Numerically check box to show the output index

numerically.

I. (Optional) Check the Debug check box to enable the debugging option. All the fields are

case-sensitive.

m. Click OK to obtain the results, which are based on the parameters that you entered.

n. When the walk is complete, save it as a text file (see Figure 2-50).

~

Note

A full walk may take a long time to finish.

Figure 2-50

a prcsml - Device Center Home - Microsoft Internet Explorer E-:7
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SNMP Walk Results Example
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sysDescr 0 = STRING : Cisco Adaptive Security Appliance Yersion §.2(0)232
sysOhjectiD 0= QID : ciscoASASS20

=ysUnTime.0 = Timeticks : 3 days 1:41:21

=ysContact.0 = STRING : hari o

=ysMame 0 = STRING : ciscoasa

sysLocation.0 = STRING © sjc

sysServices 0 = INTEGER : 4

Close

=18l x|

2

Tools

- Management Station to Device
- Ping
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= Trace Route
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The read-write username and password for SNMP Version 3 and the read-write community string for
SNMP Versions 1 and 2c are case sensitive. The SNMP Walk dialog box displays the credentials (SNMP
Versions 1, 2¢, and 3) for the device from the Device and Credential Repository (DCR), if they are
available. Otherwise, the default values for the respective SNMP versions appear.

If you use the SNMP Walk feature with Network Operator/Help Desk access privileges, device credential

fetching fails and the fields of the read/write community strings for SNMP Versions 1, 2¢, and 3
credentials are set to default values.

Figure 2-49 shows the list of privacy protocols supported. You must manually enter SNMP Versions 1,
2c, and 3 credentials (see Figure 2-52).

Figure 2-51 SNMP Walk Dialog Box
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Figure 2-52 SNMP Version 3 Parameters

prcsmal - presmil - SMMP Walk - Microsoft Internet Explorer =] =l

SHMP Walk
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ShitdPv3 Auth Password: I...--------.

SMMPw3 Auth Protocol: | MD5 =

SMMP3 Privacy Password: I..........

ShMP3 Privacy Protocol:
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|
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Figure 2-53 shows the SNMP walk results for the MDS5 authentication and AES256 encryption algorithm

settings.

Figure 2-53 SNMP Walk Results Dialog Box

prcsmil - presmi - SNMP Walk Results - Microsol o ] 4|

SHMP Walk Results

sysDescr.0 = STRING ; Cisco Adaptive Security Appliance Yersion 82000232 ;I
eysObjectiD 0 = QID : ciscoASAS520 L
=ysUpTime. 0 = Timeticks © 3 days 27:33
sysContact.0 = STRING : hari d
syshlame 0 = STRING ; ciscoasa
syslocation.0 = STRING : sjc
syzServices 0 = INTEGER : 4
iftlumber.0 = INTEGER : 8

iflndex 1 = INTEGER : 1

iflndex 2 = IMTEGER : 2

iflnclex.3 = IMTEGER : 3

iflndex 4 = INTEGER: : 4

iflndex 5 = IMTEGER : 5

iflndex 6 = INTEGER : B

iflnrew 7 = INTFFR - 7

Close
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Using the Management Station to Device Tool

Step 1
Step 2

Step 3

To troubleshoot problems with unmanaged or unresponsive devices, you can check the device
connectivity by protocol. The Management Station to Device tool helps you diagnose Layer 4
(application) connectivity problems.

Layer 4 tests include the following key services essentials that are needed to manage network devices:
e Debugging and measurement tools (UDP and TCP)
e Web server (HTTP)
e File transfer (TFTP)
e Terminal (Telnet)
e Read-write access (SNMP)

The management station to device check occurs only for protocol connectivity. Credentials for the
corresponding protocols are not tested or verified. If you enter a hostname instead of an IP address, the
tool performs a name lookup to discover the address. This task fails if the tool cannot find an address.

You can use this tool to send an SNMP GET request to the destination device for an SNMP read test
(SNMPR). The tool also sends an SNMP SET request to the device for an SNMP write test (SNMPW).
This protocol is supported for SNMP Versions 1, 2c, and 3.

If you start the Management Station to Device tool with Network Operator/Help Desk access privileges,
device credential fetching fails and the fields of the read-write community strings for SNMP Versions 1,
2c, and 3 credentials are set to default values. You must manually enter SNMP Versions 1, 2c, and 3
credentials.

To start the Management Station to Device tool, perform the following steps:

Choose Device Diagnostic Tools > Device Center.

Enter the name or IP address, fully qualified domain name, or hostname of the device that you want to
check in the Device Selector field or select the device from the list, and click Go.

The Summary and Functions Available panes appear.
Click Management Station to Device in the Functions Available pane.

The Management Station to Device dialog box appears (see Figure 2-54).

Jl_ Using SNMP Version 3 with CiscoWorks and Third-Party Tools Implementation Guide

0L-19726-01



| Chapter2

Using Network Management Tools

CiscoWorks
Figure 2-54 Management Station to Device Dialog Box
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|

Choose the connectivity applications that you want to include from the following options. All fields are

case sensitive.

e If you choose SNMP v3 (NoAuthNoPriv Security Level), enter the following information:

— Read Username.

—  Write Username.

— Timeout (in seconds). The default value is two seconds.

e If you choose SNMP v3 (AuthNoPriv Security Level), enter the following information:

— Read Username.

— Read Auth Password.

— Read Auth Protocol. Choose either MD5 or SHA from the drop-down list.

—  Write Username.

— Write Auth Password.

— Write Auth Protocol. Choose MD5 or SHA from the drop-down list.

— Timeout (in seconds). The default value is two seconds.

e If you choose SNMP v3 (AuthPriv Security Level), enter the following information:

— Read Username.

— Read Auth Password.

- Read Auth Protocol. Choose MD5 or SHA from the drop-down list.

— Read Privacy Password.

| oL-19726-01
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— Read Privacy Protocol. Choose a privacy protocol from the drop-down list. The available
protocols are DES, 3DES, AES128, AES192, and AES256.

- Write Username.

- Write Auth Password.

— Write Auth Protocol. Choose MD5 or SHA from the drop-down list.
— Write Privacy Password.

— Write Privacy Protocol. Choose a privacy protocol from the drop-down list. The available
protocols are DES, 3DES, AES128, AES192, and AES256.

— Timeout (in seconds). The default value is two seconds.

The Interface Test Results dialog box displays the results (see Figure 2-55). The Interface Details
Results dialog box shows the interfaces tested and the test results for each option.

~

Note  The read-write username and password for SNMP Version 3 and the read-write community
string for SNMP Versions 1 and 2c are case sensitive.

Figure 2-55 Management Station Device Results Dialog Box
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