
Upgrading the Cisco ICS 7750 to System Software 
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This document tells how to upgrade the Cisco ICS 7750 from system software release 2.1.0 or 2.2.0 to 
system software release 2.3.0. Use this document with the Release Notes for the Cisco ICS 7750 for 
System Software Release 2.x.x.

Note You must have at least system software release 2.1.0 in order to upgrade to release 2.3.0. If you are using 
a system software release earlier than 2.1.0, contact your Cisco sales representative for instructions on 
how to migrate your system from an earlier system software release to system software release 2.1.0.

Note The Image Install Tool, which is included on the ICS software CD, supports only the installation of 
system software release 2.2.0. If you use the Image Install Tool to install release 2.2.0, follow the 
procedures given in this document to upgrade from system software release 2.2.0 to system software 
release 2.3.0. 
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Preparing for the Upgrade
Preparing for the Upgrade
This section describes preparatory steps that should be completed before the upgrade. This section 
includes the following topics:

• Accessing ICS System Manager

• Recording and Backing Up SPE310 Data

• Accessing the SPE310 Windows Interface

Accessing ICS System Manager
Make sure that you can access ICS System Manager and prepare for the upgrade to release 2.3.0:

Step 1 On a PC, open Netscape Communicator or Microsoft Internet Explorer.

Step 2 In the Location or Address field, enter the following URL, replacing IP address with the IP address of 
the system processing engine (SPE) running System Manager:

http://IP address/ics

Step 3 Log in as the super administrator (user ID is admin), and enter your password (the default is admin).

Step 4 Click Login.

Recording and Backing Up SPE310 Data
After accessing ICS System Manager, perform the following actions to prepare the SPE310s for upgrade:

• Record the IP address and slot number of the SPE310 running System Manager.

• Record the IP address and slot number of any other SPE310s in the chassis.

• Back up the system software data. Refer to the Release Notes for the Cisco ICS 7750 for System 
Software Release 2.x.x for instructions.

Accessing the SPE310 Windows Interface
Make sure that you can access the SPE310 Windows interface in either of the following ways. Then 
continue with the “Downloading the Release 2.3.0 Upgrade Package” section on page 4.

• Accessing the SPE310 Windows Interface Through Terminal Services Client

• Accessing the SPE310 Windows Interface Through Directly Connected Peripherals
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Preparing for the Upgrade
Accessing the SPE310 Windows Interface Through Terminal Services Client

To access the SPE310 Windows interface through Terminal Services Client, follow these steps:

Step 1 On the PC that you use to administer the Cisco ICS 7750, choose Start > Programs > Terminal 
Services Client > Client Connection Manager.

Step 2 Use the Client Connection Manager to open a Terminal Services connection with the target SPE:

• If you already have a Terminal Services Client connection defined for the target SPE, choose it, and 
then choose File > Connect.

• If you do not have a Terminal Services Client connection defined for the target SPE, choose 
File > New Connection. Follow the instructions in the wizard, and then choose File > Connect.

The Terminal Services Client window opens. You can use Terminal Services Client to access standard 
Windows utilities on the SPE310, such as Windows Explorer and the Control Panel.

Accessing the SPE310 Windows Interface Through Directly Connected Peripherals

Follow these steps to connect a monitor, keyboard, and mouse directly to the SPE310 to access the 
Windows user interface:

Step 1 Connect the monitor cable to the video port on the SPE310, and power on the monitor. 

Step 2 Continue as follows, based on the type of peripherals that you are using:

• USB—Connect a USB keyboard to one SPE310 USB port, and connect a USB mouse to the other 
USB port.

• PS/2—Connect the “Y” splitter cable for your keyboard and mouse to the keyboard/mouse port on 
the target SPE310, and then connect your keyboard and mouse to the available ends of the “Y” 
splitter cable.

Note If you are using the “Y” splitter cable to connect a PS/2 mouse and a keyboard to the 
SPE310, the keyboard and mouse must be connected at or before the time of the SPE310 
reboot to be recognized by the operating system. This is not the case with a USB keyboard 
and mouse, which are usually recognized without an operating system reboot. 

Note For a summary of the issues related to connecting peripherals to SPE310s, and for best 
practices on how to use peripherals with SPE310s, see the “Using Peripherals with 
SPE310s” section in the Release Notes for the Cisco ICS 7750 for 
System Software Release 2.x.x.
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Downloading the Release 2.3.0 Upgrade Package
Note For a list of USB peripherals that have been tested on the Cisco ICS 7750, refer to the 
“Connecting a Monitor, Keyboard, and Mouse to the SPE310 Card” section in the 
Cisco ICS 7750 Getting Started Guide.

Step 3 Use the keyboard, mouse, and monitor to access standard Windows utilities on the SPE310, such as 
Windows Explorer and the Control Panel.

Downloading the Release 2.3.0 Upgrade Package
Following these steps to download the release 2.3.0 upgrade:

Step 1 Log on to CCO either as a registered user or as a guest.

Go to the Cisco home page (www.cisco.com), and log on as registered user or as a guest:

• Registered users with software service contracts will be granted full access privileges to the 
Software Center. If you do not have access to the Software Image Library, please check the terms of 
your service contract before contacting Cisco (or your sponsoring Cisco partner, for PICA 
customers). 

• Guest users will be granted limited access to Cisco’s Software Image Library. Contact your Cisco 
service representative to obtain Special File privileges. 

Step 2 Enter the following URL in your web browser:

http://www.cisco.com/kobayashi/sw-center/sw-voice.shtml

Step 3 Click the link for release 2.3.0.

Note If you are downloading one of the software images with Triple DES (3DES) encryption, special 
approval might be required. Follow the instructions on the screen.  

Step 4 Enter the special access code in the field as instructed, if necessary. 

There are some areas of the Software Center which you can access only by entering a special access 
code. Special access codes are provided either through a postal letter (through electronic or regular mail) 
informing you of the availability of an upgrade on CCO or through a conversation with authorized Cisco 
personnel. 

Step 5 Click on the link S77a-Upgrade-2.3.0.exe to download the release 2.3.0 upgrade package. When 
prompted, select the option in your browser to save the file to your PC hard drive. 
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Upgrading SPE310 System Cards
Upgrading SPE310 System Cards
Follow these steps to upgrade an SPE310 to release 2.3.0.

Note If you are upgrading an SPE310 running Cisco Unity, you must perform the procedure described in the 
section “Upgrading the Cisco Unity SPE” before performing the upgrade procedure.

Step 1 Access the Windows interface on the SPE310 you want to upgrade to release 2.3.0. See the “Accessing 
the SPE310 Windows Interface” section on page 2.

Step 2 Access the release 2.3.0 software package in one of the following ways:

• Copy the package to the SPE310 hard drive.

• Copy the package to a shared network directory, and make sure that you can access this directory 
from the SPE310 (for example, if drive E is mapped to a shared network directory, and you copy the 
software package to the ics directory on drive E, then the software should be accessible from E:\ics).

Step 3 On the SPE310, choose Start > Programs > Accessories > Command Prompt to open a command 
prompt.

Step 4 At the command prompt, enter the following command to extract the release 2.3.0 system software 
package:

C:\> <shared-drive>\<directory>\s77a-upgrade-2.3.0.exe

Where <shared-drive> is either:

• The SPE310 C drive

• A shared network drive that can be accessed by the SPE310

and <directory> is the directory in which you copied the system software package.

Note During the extraction process, you will be asked to supply a target directory where the extracted 
files will be stored. The default target directory is \ICS_Upgrade_2.3.0. The instructions in the 
rest of this document assume that the files were extracted to the default target directory. If you 
choose a different target directory, use that directory name when performing the procedures 
below.

After the extraction is complete, the ReadMe.txt file opens.

Step 5 Read and close the ReadMe.txt file.

Step 6 Enter the following command to change to the directory in which the Microsoft hot fixes are located:

C:\> cd C:\ICS_Upgrade_2.3.0\Microsoft\HotFix

Step 7 Enter the following command to install Microsoft hot fixes:

C:\ICS_Upgrade_2.3.0\Microsoft\HotFix> patchinstaller

Step 8 After the Microsoft hot fixes have finished installing, reboot the SPE310.

Step 9 After the SPE310 has finished rebooting, choose Start > Programs > Accessories > Command 
Prompt to open a command prompt.

Step 10 Enter the following command to change to the directory in which the software upgrade executable is 
located:
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Upgrading SPE310 System Cards
C:\> cd C:\ICS_Upgrade_2.3.0\ICSSM

Step 11 Enter the following command to start the software upgrade on the SPE310:

C:\ICS_Upgrade_2.3.0\ICSSM> setup

Step 12 When prompted, select the Upgrade radio button, and click Next to upgrade the SPE310 to system 
software release 2.3.0.

Step 13 When the upgrade is finished, click Finish.

Step 14 Continue as follows:

• If there are other SPE310s in the chassis, repeat this procedure for each SPE310 in the chassis.

• If there are no other SPE310s in the chassis, go to the “Upgrading MRP, ASI, and SSP System 
Cards” section below.

Upgrading the Cisco Unity SPE
If you are upgrading an SPE running Cisco Unity, you may need to manually stop some of the services 
that are running on the Cisco Unity SPE before you can perform the system software upgrade. Follow 
these steps to complete the Cisco Unity upgrade:

Step 1 Access the Windows interface on the target SPE310. See the “Accessing the SPE310 Windows 
Interface” section on page 2.

Step 2 Right-click the Unity tray icon in the status bar that appears at the bottom of the window.

Step 3 From the pop-up menu, choose Stop Unity.

Step 4 On the target SPE, choose Start > Programs > Administrative Tools > Services.

Step 5 In the Services window, right-click Microsoft Exchange Information Store. From the pop-up menu, 
choose Stop.

Step 6 Click Yes to confirm to Stop Other Services.

Step 7 Perform the upgrade to ICS System Software release 2.3.0 as described in the “Upgrading SPE310 
System Cards” section on page 5.
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Upgrading MRP, ASI, and SSP System Cards
Upgrading MRP, ASI, and SSP System Cards
Follow these steps to upgrade the SSP, MRP200, ASI81, and ASI160 system cards to release 2.3.0.

Note You must upgrade the SSP and all MRP200, ASI80, and ASI161 system cards. You do not need to 
upgrade the MRP300, MRP3-8FXS, and MRP3-16FXS system cards.

Step 1 Access ICS System Manager from a PC that has access to the release 2.3.0 system software package. 
See the “Accessing ICS System Manager” section on page 2

Note It is recommended that you access ICS System Manager from a PC rather than from the SPE310 
running System Manager when uploading Cisco IOS images to the Software Library as in this 
procedure.

Step 2 On the ICS System Manager home page, click the Software Upgrade tab.

Step 3 At the right side of the Software Library table, click Add Image.

Step 4 From the Upload Image page, click Browse.

Step 5 Navigate to the following directory on the SPE310 running System Manager where the MRP/ASI 
image is located:

C:\ICS_Upgrade_2.3.0\Images\MRP

Step 6 Select the image ics7700-sv3y-mz.122-4.YF

Step 7 Click Upload to ICS 7750 to add the MRP/ASI image to the Software Library table.

Step 8 When the MRP/ASI image is done uploading, from the Upload Image page, click Browse.

Step 9 Navigate to the following directory on the SPE310 running System Manager where the SSP image is 
located:

C:\ICS_Upgrade_2.3.0\Images\SSP

Step 10 Select the image c2900xl-c3h2s-tar.120-0.0.1.WC5.tar

Step 11 Click Upload to ICS 7750 to add the SSP image to the Software Library table.

Step 12 Click Deliver to a system card beside the image that you want to deliver.

Step 13 Click the drop-down arrow to view a list of choices for the Select a Target System Card field, and 
choose the target MRP200, ASI81, or ASI160 system card.

Step 14 Click Deliver. The image is uploaded to the card that you chose. This process takes up to 10 minutes.

Step 15 Repeat Step 12 through Step 14 for the SSP and every MRP200, ASI81, and ASI160 in the chassis.
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Related Documentation
Related Documentation
The following sections describe the documentation available for the Cisco ICS 7750. These documents 
consist of hardware and software installation guides, Cisco IOS configuration and command references, 
system error messages, feature modules, and other documents.

Cisco ICS 7750 Documents
The documents described in this section are available on CCO and on CD:

On Cisco.com, beginning under the Service & Support heading:

Technical Documents > Voice/Telephony > Cisco ICS 7750

On the Documentation CD-ROM (order number DOC-CONDOCCD=) at:

Cisco Product Documentation > Voice/Telephony > Cisco ICS 7750

Release 2.3.0 Documents

The following documents were updated or created for system software release 2.3.0. These documents 
are available in the following location:

http://www.cisco.com/univercd/cc/td/doc/product/voice/ics/ics23/index.htm

• Cisco ICS 7750 Documentation Locator for Release 2.3.0

• Cisco ICS 7750 Getting Started Guide

• Cisco ICS 7750 FRU Installation and Replacement

• Cisco Interface Cards Installation Guide

• Release Notes for Cisco IOS 12.2(4)YH on the Cisco ICS 7750

• Upgrading the Cisco ICS 7750 to System Software Release 2.3.0 (this document)

Obtaining Documentation
The following sections explain how to obtain documentation from Cisco Systems.

World Wide Web
You can access the most current Cisco documentation on the World Wide Web at the following URL:

http://www.cisco.com

Translated documentation is available at the following URL:

http://www.cisco.com/public/countries_languages.shtml
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Obtaining Technical Assistance
Documentation CD-ROM
Cisco documentation and additional literature are available in a Cisco Documentation CD-ROM 
package, which is shipped with your product. The Documentation CD-ROM is updated monthly and may 
be more current than printed documentation. The CD-ROM package is available as a single unit or 
through an annual subscription.

Ordering Documentation
Cisco documentation is available in the following ways:

• Registered Cisco Direct Customers can order Cisco product documentation from the Networking 
Products MarketPlace:

http://www.cisco.com/cgi-bin/order/order_root.pl

• Registered Cisco.com users can order the Documentation CD-ROM through the online Subscription 
Store:

http://www.cisco.com/go/subscription

• Nonregistered Cisco.com users can order documentation through a local account representative by 
calling Cisco corporate headquarters (California, USA) at 408 526-7208 or, elsewhere in North 
America, by calling 800 553-NETS (6387).

Documentation Feedback
If you are reading Cisco product documentation on Cisco.com, you can submit technical comments 
electronically. Click Leave Feedback at the bottom of the Cisco Documentation home page. After you 
complete the form, print it out and fax it to Cisco at 408 527-0730.

You can e-mail your comments to bug-doc@cisco.com.

To submit your comments by mail, use the response card behind the front cover of your document, or 
write to the following address:

Cisco Systems
Attn: Document Resource Connection
170 West Tasman Drive
San Jose, CA 95134-9883

We appreciate your comments.

Obtaining Technical Assistance
Cisco provides Cisco.com as a starting point for all technical assistance. Customers and partners can 
obtain documentation, troubleshooting tips, and sample configurations from online tools by using the 
Cisco Technical Assistance Center (TAC) Web Site. Cisco.com registered users have complete access to 
the technical support resources on the Cisco TAC Web Site. 
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Obtaining Technical Assistance
Cisco.com
Cisco.com is the foundation of a suite of interactive, networked services that provides immediate, open 
access to Cisco information, networking solutions, services, programs, and resources at any time, from 
anywhere in the world. 

Cisco.com is a highly integrated Internet application and a powerful, easy-to-use tool that provides a 
broad range of features and services to help you to

• Streamline business processes and improve productivity 

• Resolve technical issues with online support

• Download and test software packages

• Order Cisco learning materials and merchandise

• Register for online skill assessment, training, and certification programs

You can self-register on Cisco.com to obtain customized information and service. To access Cisco.com, 
go to the following URL:

http://www.cisco.com

Technical Assistance Center
The Cisco TAC is available to all customers who need technical assistance with a Cisco product, 
technology, or solution. Two types of support are available through the Cisco TAC: the Cisco TAC 
Web Site and the Cisco TAC Escalation Center.

Inquiries to Cisco TAC are categorized according to the urgency of the issue:

• Priority level 4 (P4)—You need information or assistance concerning Cisco product capabilities, 
product installation, or basic product configuration.

• Priority level 3 (P3)—Your network performance is degraded. Network functionality is noticeably 
impaired, but most business operations continue.

• Priority level 2 (P2)—Your production network is severely degraded, affecting significant aspects 
of business operations. No workaround is available.

• Priority level 1 (P1)—Your production network is down, and a critical impact to business operations 
will occur if service is not restored quickly. No workaround is available.

Which Cisco TAC resource you choose is based on the priority of the problem and the conditions of 
service contracts, when applicable.

Cisco TAC Web Site

The Cisco TAC Web Site allows you to resolve P3 and P4 issues yourself, saving both cost and time. The 
site provides around-the-clock access to online tools, knowledge bases, and software. To access the 
Cisco TAC Web Site, go to the following URL:

http://www.cisco.com/tac

All customers, partners, and resellers who have a valid Cisco services contract have complete access to 
the technical support resources on the Cisco TAC Web Site. The Cisco TAC Web Site requires a 
Cisco.com login ID and password. If you have a valid service contract but do not have a login ID or 
password, go to the following URL to register:

http://www.cisco.com/register/
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Obtaining Technical Assistance
If you cannot resolve your technical issues by using the Cisco TAC Web Site, and you are a Cisco.com 
registered user, you can open a case online by using the TAC Case Open tool at the following URL:

http://www.cisco.com/tac/caseopen

If you have Internet access, it is recommended that you open P3 and P4 cases through the Cisco TAC 
Web Site.

Cisco TAC Escalation Center

The Cisco TAC Escalation Center addresses issues that are classified as priority level 1 or priority 
level 2; these classifications are assigned when severe network degradation significantly impacts 
business operations. When you contact the TAC Escalation Center with a P1 or P2 problem, a Cisco TAC 
engineer will automatically open a case.

To obtain a directory of toll-free Cisco TAC telephone numbers for your country, go to the following 
URL:

http://www.cisco.com/warp/public/687/Directory/DirTAC.shtml

Before calling, please check with your network operations center to determine the level of Cisco support 
services to which your company is entitled; for example, SMARTnet, SMARTnet Onsite, or Network 
Supported Accounts (NSA). In addition, please have available your service agreement number and your 
product serial number.

This document is to be used in conjunction with the Release Notes for the Cisco ICS 7750 for System Software Release 2.x.x.
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