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C H A P T E R 2

Connect the PC and Log into the GUI

This chapter explains how to connect PCs and workstations to the Cisco ONS 15454 and how to log into 
Cisco Transport Controller (CTC) software, which is the ONS 15454 Operation, Administration, 
Maintenance and Provisioning (OAM&P) user interface. Procedures for connecting to the 
ONS 15454 ANSI using TL1 are provided in the Cisco ONS SONET TL1 Command Guide. Procedures 
for connecting to the ONS 15454 ETSI using TL1 are provided in the Cisco ONS 15454 SDH TL1 
Command Guide.

Note Unless otherwise specified, “ONS 15454” refers to both ANSI and ETSI shelf assemblies.

Before You Begin
This section lists the chapter procedures (NTPs). Turn to a procedure for applicable tasks (DLPs).

1. NTP-G17 Set Up Computer for CTC, page 2-2—Complete this procedure if your PC or workstation 
has never been connected to an ONS 15454.

2. NTP-G18 Set Up CTC Computer for Local Craft Connection to the ONS 15454, page 
2-9—Complete this procedure to set up your computer for an onsite craft connection to the 
ONS 15454.

3. NTP-G19 Set Up a CTC Computer for a Corporate LAN Connection to the ONS 15454, page 
2-21—Complete this procedure to set up your computer to connect to the ONS 15454 using a 
corporate LAN.

4. NTP-G20 Set Up a Remote Access Connection to the ONS 15454, page 2-23—Complete this 
procedure to set up your computer for remote modem access to the ONS 15454.

5. NTP-G21 Log into the ONS 15454 GUI, page 2-24—Complete this procedure to log into CTC.
2-1
 Installation and Operations Guide, R6.0



 

Chapter 2      Connect the PC and Log into the GUI
NTP-G17 Set Up Computer for CTC
NTP-G17 Set Up Computer for CTC

Note If you will log into nodes running CTC software earlier than Software Release 4.6, uninstall Java 
Runtime Environment (JRE) 1.4.2 and reinstall JRE 1.3.1_2. To run Software R4.7, R5.0, or R6.0, 
uninstall JRE 1.3.1_2 and reinstall JRE 1.4.2.

Step 1 If your computer does not have an appropriate browser installed, complete the following:

• To install Netscape 7.x, download the browser from the following site: 
http://channels.netscape.com/ns/browsers/default.jsp

• To install Internet Explorer 6.x on a PC, download the browser from the following site: 
http://www.microsoft.com

Step 2 If your computer is a Windows PC, complete the “DLP-G37 Run the CTC Installation Wizard for 
Windows” task on page 2-3, then go to Step 4.

Step 3 If your computer is a UNIX workstation, complete the “DLP-G38 Run the CTC Installation Wizard for 
UNIX” task on page 2-6.

Step 4 When your PC or workstation is set up, continue with the setup procedure appropriate to your network: 

• NTP-G18 Set Up CTC Computer for Local Craft Connection to the ONS 15454, page 2-9

• NTP-G19 Set Up a CTC Computer for a Corporate LAN Connection to the ONS 15454, page 2-21

• NTP-G20 Set Up a Remote Access Connection to the ONS 15454, page 2-23

Note Cisco recommends that you configure your browser to disable the caching of user IDs/passwords on 
computers used to access Cisco optical equipment. 

In Internet Explorer, choose Tools > Internet Options > Content. Click Auto Complete and uncheck 
the User names and passwords on forms option. 

In Netscape 7.0, choose Edit > Preferences > Privacy & Security > Forms and uncheck the option to 
save form data. For passwords, choose Edit > Preferences > Privacy & Security > Passwords and 
uncheck the option to remember passwords. Note that passwords can be stored in an encrypted format. 
Netscape versions earlier than 6.0 do not cache user IDs and passwords.

Stop. You have completed this procedure.

Purpose This procedure configures your PC or UNIX workstation to run CTC. 

Tools/Equipment Cisco ONS 15454 Release 6.0 software CD

Prerequisite Procedures Chapter 15, “Shelf Hardware Reference”

Required/As Needed Required

Onsite/Remote Onsite or remote

Security Level None
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DLP-G37 Run the CTC Installation Wizard for Windows

Note If you will log into nodes running CTC software earlier than Software Release 4.6, uninstall JRE 1.4.2 
and reinstall JRE 1.3.1_2. To run Software R4.7, R5.0, or R6.0, uninstall JRE 1.3.1_2 and reinstall 
JRE 1.4.2.

Note JRE 1.4.2 requires Netscape 7.x or Internet Explorer 6.x.

Step 1 Verify that your computer has the following:

• Processor—Pentium III, 700 Mhz or faster

• RAM—384 MB recommended, 512 MB optimum

• Hard drive—20 GB hard drive recommended with at least 50 MB of space available

• Operating system—Windows 98 (1st and 2nd editions), Windows NT 4.0 (with Service Pack 6a), 
Windows 2000 (with Service Pack 3), or Windows XP Home

If your operating system is Windows NT 4.0, verify that Service Pack 6a or later is installed. From 
the Start menu, choose Programs > Administrative Tools > Windows NT Diagnostics and check 
the service pack on the Version tab of the Windows NT Diagnostics dialog box. If Service Pack 6a 
or later is not installed, do not continue. Install Service Pack 6a following the computer upgrade 
procedures for your site.

Note Processor and RAM requirements are guidelines. CTC performance is faster if your 
computer has a faster processor and more RAM. 

Step 2 Insert the Cisco ONS 15454 Release 6.0 software CD into your computer CD drive. The installation 
program begins running automatically. If it does not start, navigate to the CD directory and double-click 
setup.exe.

Purpose This task installs the CTC online user manuals, Acrobat Reader 6.0.1, 
JRE 1.4.2, and the CTC JAR files. JRE 1.4.2 is required to run Release 6.0. 
Preinstalling the CTC JAR files saves time at initial login. If the JAR files 
are not installed, they are downloaded from the TCC2/TCC2P card the first 
time you log in.

Tools/Equipment Cisco ONS 15454 Release 6.0 software CD

Prerequisite Procedures None

Required/As Needed This task is required if you will use a Windows computer to run CTC and 
if any one of the following is true: 

• JRE 1.4.2 is not installed.

• CTC online user manuals are not installed and are needed.

• CTC JAR files are not installed and needed.

Onsite/Remote Onsite or remote

Security Level None
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The Cisco Transport Controller Installation Wizard displays the components that will be installed on 
your computer:

• Java Runtime Environment 1.4.2

• Acrobat Reader 6.0.1

• Online User Manuals

• CTC JAR files

Step 3 Click Next.

Step 4 Complete one of the following:

• Click Typical to install both the Java Runtime Environment and online user manuals. If you already 
have JRE 1.4.2 installed on your computer, choose Custom.

• Click Custom if you want to install either the JRE or the online user manuals. By default, Acrobat 
Reader and the online user manuals are selected.

Step 5 Click Next. 

Step 6 Complete the following, as applicable:

• If you selected Typical in Step 4, skip this step and continue with Step 7.

• If you selected Custom in Step 4, check the CTC component that you want to install and click Next. 

– If you selected Online User Manuals, continue with Step 7. 

– If you did not select Online User Manuals, continue with Step 9.

Step 7 The directory where the installation wizard will install the CTC online user manuals appears. The default 
is C:\Program Files\Cisco\CTC\Documentation. 

• If you want to change the CTC online user manuals directory, type the new directory path in the 
Directory Name field, or click Browse to navigate to the directory. 

• If you do not want to change the directory, skip this step.

Step 8 Click Next.

Step 9 Review the components that will be installed. If you want to change the components, complete one of 
the following. If not, proceed to Step 10.

• If you selected Typical in Step 4, click Back twice to return to the installation setup type page. 
Choose Custom and repeat Steps 5 through 8. 

• If you selected Custom in Step 4, click Back once or twice (depending on the components selected) 
until the component selection page appears. Repeat Steps 6 through 8.

Step 10 Click Next. It might take a few minutes for the JRE installation wizard to appear. If you selected Custom 
in Step 4 and did not check Java Runtime Environment 1.4.2, continue with Step 12.

Step 11 To install the JRE, complete the following:

a. In the Java 2 Runtime Environment License Agreement dialog box, view the license agreement and 
choose one of the following:

• I accept the terms of the license agreement—Accepts the license agreement. Continue with 
Step b.

• I do not accept the terms of the license agreement—Disables the Next button on the Java 2 
Runtime Environment License Agreement dialog box. Click Cancel to return to the CTC 
installation wizard. CTC will not install the JRE. Continue with Step 12.
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Note If JRE 1.4.2 is already installed on your computer, the License Agreement dialog box 
does not appear. You must click Next and then choose Modify to change the JRE 
installation, or Remove to uninstall the JRE. If you choose Modify and click Next, 
continue with Step e. If you choose Remove and click Next, continue with Step i.

b. Click Next.

c. Choose one of the following:

• Click Typical to install all JRE features. If you select Typical, the JRE version installed will 
automatically become the default JRE version for your browsers.

• Click Custom if you want to select the components to install and select the browsers that will 
use the JRE version.

d. Click Next.

e. If you selected Typical, continue with Step h. If you selected Custom, click the drop-down list for 
each program feature that you want to install and choose the desired setting. The program features 
include:

• Java 2 Runtime Environment—(Default) Installs JRE 1.4.2 with support for European 
languages. 

• Support for Additional Languages—Adds support for non-European languages.

• Additional Font and Media Support—Adds Lucida fonts, Java Sound, and color management 
capabilities.

The drop-down list options for each program feature include:

• This feature will be installed on the local hard drive—Installs the selected feature.

• This feature and all subfeatures will be installed on the local hard drive—Installs the selected 
feature and all subfeatures.

• Don’t install this feature now—Does not install the feature (not an option for Java 2 Runtime 
Environment).

To modify the directory where the JRE version is installed, click Change, navigate to the desired 
directory, and click OK.

f. Click Next.

g. In the Browser Registration dialog box, check the browsers that you want to register with the Java 
Plug-In. The JRE version will be the default for the selected browsers. It is acceptable to leave both 
browser check boxes unchecked.

Note Setting the JRE as the default for these browsers might cause problems with these browsers.

h. Click Next. 

i. Click Finish.

Note If you are uninstalling the JRE, click Remove.

Step 12 In the Cisco Transport Controller Installation Wizard, click Next. The online user manuals are installed.
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Step 13 Click Finish.

Step 14 Return to your originating procedure (NTP).

DLP-G38 Run the CTC Installation Wizard for UNIX

Note If you will log into nodes running CTC software earlier than Software R4.6, uninstall JRE 1.4.2 and 
reinstall JRE 1.3.1_2. To run Software R4.7, R5.0, or R6.0, uninstall JRE 1.3.1_2 and reinstall JRE 1.4.2.

Note JRE 1.4.2 requires Netscape 7.x or Internet Explorer 6.x.

Step 1 Verify that your computer has the following:

• RAM—384 MB recommended, 512 MB optimum

• Hard drive—20 GB hard drive recommended with at least 50 MB of space available

• Operating system—Solaris 8 or 9

Note These requirements are guidelines. CTC performance is faster if your computer has a faster 
processor and more RAM. 

Step 2 Change the directory. Type:

cd /cdrom/cdrom0/

Step 3 From the techdoc454 CD directory, type:

./setup.bat

The Cisco Transport Controller Installation Wizard displays the components that will be installed on 
your computer:

• Java Runtime Environment 1.4.2 

• Acrobat Reader 6.0.1

Purpose This task installs the CTC online user manuals, Acrobat 6.0.1, and 
JRE 1.4.2 on UNIX workstations, as necessary. JRE 1.4.2 is required to run 
Release 6.0.

Tools/Equipment Cisco ONS 15454 Release 6.0 software CD

Prerequisite Procedures None

Required/As Needed This task is required if you will use a UNIX workstation to run CTC and 
any of the following are true: 

• JRE 1.4.2 is not installed.

• CTC online user manuals are not installed and are needed.

Onsite/Remote Onsite or remote

Security Level None
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• Online User Manuals

• CTC JAR files

Step 4 Click Next.

Step 5 Complete one of the following:

• Click Typical to install both the Java Runtime Environment and online user manuals. If you already 
have JRE 1.4.2 installed on your computer, choose Custom.

• Click Custom if you want to install either the JRE or the online user manuals. 

Step 6 Click Next. 

Step 7 Complete the following, as applicable:

• If you selected Typical in Step 5, continue with Step 8.

• If you selected Custom in Step 5, check the CTC component that you want to install and click Next. 

– If you selected Online User Manuals, continue with Step 8. 

– If you did not select Online User Manuals, continue with Step 10. 

Step 8 The directory where the installation wizard will install the CTC online user manuals appears. The default 
is /usr/doc/ctc. 

• If you want to change the CTC online user manuals directory, type the new directory path in the 
Directory Name field, or click Browse to navigate to the directory.

• If you do not want to change the CTC online user manuals directory, skip this step.

Step 9 Click Next.

Step 10 Review the components that will be installed.

• If you selected Typical in Step 5, click Back twice to return to the installation setup type page. 
Choose Custom and repeat Steps 6 through 9.

• If you selected Custom in Step 5, click Back once or twice (depending on the components selected) 
until you reach the component selection page and check the desired components. Repeat Steps 7 
through 9.

Step 11 Click Next. It might take a few minutes for the JRE installation wizard to appear. If you selected Custom 
in Step 4 and did not check Java Runtime Environment 1.4.2, continue with Step 13.

Step 12 To install the JRE, complete the following:

a. In the Java 2 Runtime Environment License Agreement dialog box, view the license agreement and 
choose one of the following:

• I accept the terms of the license agreement—Accepts the license agreement. Continue with 
Step b.

• I do not accept the terms of the license agreement—Disables the Next button on the Java 2 
Runtime Environment License Agreement dialog box. Click Cancel to return to the CTC 
installation wizard. CTC will not install the JRE. Continue with Step 13.

Note If JRE 1.4.2 is already installed on your computer, the License Agreement dialog box 
does not appear. You must click Next and then choose Modify to change the JRE 
installation or Remove to uninstall the JRE. If you choose Modify and click Next, 
continue with Step e. If you choose Remove and click Next, continue with Step i.

b. Click Next.
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c. Choose one of the following:

• Click Typical to install all JRE features. If you select Typical, the JRE version installed will 
automatically become the default JRE version for your browsers. 

• Click Custom if you want to select the components to install and select the browsers that will 
use the JRE version.

d. Click Next.

e. If you selected Typical, continue with Step i. If you selected Custom, click the drop-down list for 
each program feature that you want to install and choose the desired setting. The program features 
include:

• Java 2 Runtime Environment—(Default) Installs JRE 1.4.2 with support for European 
languages. 

• Support for Additional Languages—Adds support for non-European languages.

• Additional Font and Media Support—Adds Lucida fonts, Java Sound, and color management 
capabilities.

The drop-down list options for each program feature include:

• This feature will be installed on the local hard drive—Installs the selected feature.

• This feature and all subfeatures will be installed on the local hard drive—Installs the selected 
feature and all subfeatures.

• Don’t install this feature now—Does not install the feature (not an option for Java 2 Runtime 
Environment).

To modify the directory where the JRE version is installed, click Change, navigate to the desired 
directory, and click OK.

f. Click Next.

g. In the Browser Registration dialog box, check the browsers that you want to register with the Java 
Plug-In. The JRE version will be the default for the selected browsers. It is acceptable to leave both 
browser check boxes unchecked.

Note Setting the JRE version as the default for these browsers might cause problems with these 
browsers. 

h. Click Next. 

i. Click Finish.

Note If you are uninstalling the JRE, click Remove.

Step 13 In the Cisco Transport Controller Installation Wizard, click Next. The online user manuals are installed.

Step 14 Click Finish.

Note Be sure to record the names of the directories you choose for JRE and the online user manuals.

Step 15 Return to your originating procedure (NTP).
2-8
Cisco ONS 15454 DWDM Installation and Operations Guide, R6.0

September 2005



 

Chapter 2      Connect the PC and Log into the GUI
NTP-G18 Set Up CTC Computer for Local Craft Connection to the ONS 15454
NTP-G18 Set Up CTC Computer for Local Craft Connection to the 
ONS 15454

Step 1 Complete one of the CTC computer setup tasks shown in Table 2-1 based on your CTC connection 
environment.

Purpose This procedure explains how to set up a PC running Windows or a Solaris 
workstation for an onsite local craft connection to the ONS 15454. 

Tools/Equipment Network interface card (NIC), also referred to as an Ethernet card

Straight-through (CAT-5) LAN cable

Prerequisite Procedures NTP-G17 Set Up Computer for CTC, page 2-2

Required/As Needed As needed

Onsite/Remote Onsite or remote

Security Level None

Table 2-1 CTC Computer Setup for Local Craft Connections to the ONS 15454

CTC Connection Environment CTC Computer Setup Task

• You are connecting from a Windows PC.

• All nodes that you will access run software earlier 
than Release 3.3.

• You will connect to one ONS 15454. 

• You need to access non-ONS 15454 applications 
such as ping and tracert (trace route).

DLP-G39 Set Up a Windows PC for Craft 
Connection to an ONS 15454 on the Same 
Subnet Using Static IP Addresses, page 2-11

• You are connecting from a Windows PC.

• The CTC computer is provisioned for Dynamic 
Host Configuration Protocol (DHCP).

• The ONS 15454 has DHCP forwarding enabled.

• The ONS 15454 is connected to a DHCP server.

Note The ONS 15454 does not provide IP addresses. 
If DHCP is enabled, it passes DCHP requests to 
an external DHCP server.

DLP-G40 Set Up a Windows PC for Craft 
Connection to an ONS 15454 Using Dynamic 
Host Configuration Protocol, page 2-13

Note Do not use this task for initial node 
turn-up. Use the task only if DHCP 
forwarding is enabled on the 
ONS 15454. By default, DHCP is not 
enabled. To enable it, see the 
“NTP-G26 Set Up CTC Network 
Access” procedure on page 3-11.
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Step 2 Connect a straight-through CAT-5 LAN cable from the PC or Solaris workstation NIC to one of the 
following:

• RJ-45 (LAN) port on the active or standby TCC2/TCC2P card

• RJ-45 (LAN) port on a hub or switch to which the ONS 15454 is physically connected

Note For instructions on crimping your own straight-through (CAT-5) LAN cables, refer to the 
Cisco ONS 15454 Troubleshooting Guide or the Cisco ONS 15454 SDH Troubleshooting 
Guide.

Note For initial shelf turn-up, you should connect your PC directly to the LAN port on the 
TCC2/TCC2P card of the ONS 15454. 

Step 3 After setting up your CTC computer, continue with the “NTP-G21 Log into the ONS 15454 GUI” 
procedure on page 2-24 as needed.

Stop. You have completed this procedure.

• You are connecting from a Windows PC.

• All nodes that you will access run software 
Release 3.3 or later.

• You will connect to ONS 15454s at different 
locations and times and do not wish to reconfigure 
your PC’s IP settings each time.

• You will not access or use non-ONS 15454 
applications such as ping and tracert (trace route).

• If you are using an ANSI shelf, you will connect to 
the TCC2/TCC2P Ethernet port or backplane LAN 
pins either directly or through a hub.

• If you are using an ETSI shelf, you will connect to 
the ONS 15454 Ethernet port or the RJ-45 jack on 
the MIC-C/T/P FMEC either directly or through a 
hub.

DLP-G41 Set Up a Windows PC for Craft 
Connection to an ONS 15454 Using 
Automatic Host Detection, page 2-16

• You are connecting from a Solaris workstation.

• You will connect to one ONS 15454.

• You need to access non-ONS 15454 applications 
such as ping and tracert (trace route).

DLP-G42 Set Up a Solaris Workstation for a 
Craft Connection to an ONS 15454, page 
2-19

Table 2-1 CTC Computer Setup for Local Craft Connections to the ONS 15454 (continued)

CTC Connection Environment CTC Computer Setup Task (continued)
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DLP-G39 Set Up a Windows PC for Craft Connection to an ONS 15454 on the 
Same Subnet Using Static IP Addresses

Step 1 Verify the operating system that is installed on your computer: 

a. From the Windows Start menu, choose Settings > Control Panel.

b. In the Control Panel window, double-click the System icon.

c. On the General tab of the System Settings window, verify that the Windows operating system is one 
of the following: Windows 98, Windows NT 4.0, Windows 2000, or Windows XP.

Step 2 According to the Windows operating system installed on your computer, perform one of the following 
steps:

• For Windows 98, complete Step 3.

• For Windows NT 4.0, complete Step 4.

• For Windows 2000, complete Step 5.

• For Windows XP, complete Step 6.

Step 3 If you have Windows 98 installed on your PC, complete the following steps to change its TCP/IP 
configuration:

a. From the Windows Start menu, choose Settings > Control Panel.

b. In the Control Panel dialog box, click the Network icon.

c. In the Network dialog box, choose TCP/IP for your NIC card, then click Properties.

d. In the TCP/IP Properties dialog box, click the DNS Configuration tab and choose Disable DNS.

e. Click the WINS Configuration tab and choose Disable WINS Resolution.

f. Click the IP Address tab.

g. In the IP Address window, click Specify an IP address. 

h. In the IP Address field, enter an IP address that is identical to the ONS 15454 IP address except for 
the last octet. The last octet must be 1 or 3 through 254. This IP address appears on the LCD unless 
its display is suppressed during node provisioning. 

Purpose This task sets up your computer for a local craft connection to the 
ONS 15454 when: 

• You will access nodes running software releases earlier than Software 
Release 3.3.

• You will connect to one ONS 15454; if you will connect to multiple 
ONS 15454s, you might need to reconfigure your computer’s IP 
settings each time you connect to an ONS 15454.

• You need to use non-ONS 15454 applications such as ping and tracert 
(trace route).

Tools/Equipment None

Prerequisite Procedures NTP-G17 Set Up Computer for CTC, page 2-2

Required/As Needed As needed

Onsite/Remote Onsite

Security Level None
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i. In the Subnet Mask field, type the same subnet mask as the ONS 15454. The default is 
255.255.255.0 (24 bit).

j. Click OK.

k. In the TCP/IP dialog box, click the Gateway tab.

l. In the New Gateway field, type the ONS 15454 IP address. Click Add.

m. Verify that the IP address appears in the Installed Gateways field, then click OK.

n. When the prompt to restart your PC appears, click Yes.

o. Proceed to Step 7.

Step 4 If you have Windows NT 4.0 installed on your PC, complete the following steps to change its TCP/IP 
configuration:

a. From the Windows Start menu, choose Settings > Control Panel.

b. In the Control Panel dialog box, click the Network icon.

c. In the Network dialog box, click the Protocols tab, choose TCP/IP Protocol, then click Properties.

d. Click the IP Address tab.

e. In the IP Address window, click Specify an IP address. 

f. In the IP Address field, enter an IP address that is identical to the ONS 15454 IP address shown on 
the ONS 15454 LCD except for the last octet. The last octet must be 1 or 3 through 254.

g. In the Subnet Mask field, type 255.255.255.0.

h. Click Advanced.

i. In the Gateways List, click Add. The TCP/IP Gateway Address dialog box appears.

j. Type the ONS 15454 IP address in the Gateway Address field.

k. Click Add.

l. Click OK.

m. Click Apply.

n. In some cases, Windows NT 4.0 prompts you to reboot your PC. If you receive this prompt, click 
Yes.

o. Proceed to Step 7.

Step 5 If you have Windows 2000 installed on your PC, complete the following steps to change its TCP/IP 
configuration:

a. From the Windows Start menu, choose Settings > Network and Dial-up Connections > 
Local Area Connection.

b. In the Local Area Connection Status dialog box, click Properties.

c. On the General tab, choose Internet Protocol (TCP/IP), then click Properties.

d. Click Use the following IP address.

e. In the IP Address field, enter an IP address that is identical to the ONS 15454 IP address shown on 
the ONS 15454 LCD except for the last octet. The last octet must be 1 or 3 through 254.

f. In the Subnet Mask field, type 255.255.255.0.

g. In the Default Gateway field, type the ONS 15454 IP address. 

h. Click OK.

i. In the Local Area Connection Properties dialog box, click OK.
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j. In the Local Area Connection Status dialog box, click Close.

k. Proceed to Step 7.

Step 6 If you have Windows XP installed on your PC, complete the following steps to change its TCP/IP 
configuration:

a. From the Windows Start menu, choose Control Panel > Network Connections.

Note If the Network Connections menu is not available, click Switch to Classic View.

b. From the Network Connections dialog box, click the Local Area Connection icon.

c. From the Local Area Connection Properties dialog box, choose Internet Protocol (TCP/IP), then 
click Properties.

d. In the IP Address field, enter an IP address that is identical to the ONS 15454 IP address shown on 
the ONS 15454 LCD except for the last octet. The last octet must be 1 or 3 through 254.

e. In the Subnet Mask field, type 255.255.255.0.

f. In the Default Gateway field, type the ONS 15454 IP address. 

g. Click OK.

h. In the Local Area Connection Properties dialog box, click OK.

i. In the Local Area Connection Status dialog box, click Close.

Step 7 Return to your originating procedure (NTP).

DLP-G40 Set Up a Windows PC for Craft Connection to an ONS 15454 Using 
Dynamic Host Configuration Protocol

Note Do not use this task for initial node turn-up. Use the task only if DHCP forwarding is enabled on the 
ONS 15454. By default, DHCP is not enabled. To enable it, see the “NTP-G26 Set Up CTC Network 
Access” procedure on page 3-11.

Note The ONS 15454 does not provide the IP addresses. If DHCP forwarding is enabled, it passes DCHP 
requests to an external DHCP server.

Purpose This task sets up your computer for craft connection to the ONS 15454 
using DHCP. 

Tools/Equipment None

Prerequisite Procedures NTP-G17 Set Up Computer for CTC, page 2-2

NTP-G26 Set Up CTC Network Access, page 3-11

Required/As Needed As needed

Onsite/Remote Onsite

Security Level None
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DLP-G40 Set Up a Windows PC for Craft Connection to an ONS 15454 Using Dynamic Host Configuration Protocol
Step 1 Verify the operating system that is installed on your computer: 

a. From the Windows Start menu, choose Settings > Control Panel.

b. In the Control Panel window, double-click the System icon.

c. On the General tab of the System Settings window, verify that the Windows operating system is one 
of the following: Windows 98, Windows NT 4.0, Windows 2000, or Windows XP.

Step 2 According to the Windows operating system installed on your computer, perform one of the following 
steps:

• For Windows 98, complete Step 3.

• For Windows NT 4.0, complete Step 4.

• For Windows 2000, complete Step 5.

• For Windows XP, complete Step 6.

Step 3 If you have Windows 98 installed on your PC, complete the following steps to change its TCP/IP 
configuration:

a. From the Windows Start menu, choose Settings > Control Panel.

b. In the Control Panel dialog box, click the Network icon.

c. In the Network dialog box, select TCP/IP for your NIC, then click Properties.

d. In the TCP/IP Properties dialog box, click the DNS Configuration tab and choose Disable DNS.

e. Click the WINS Configuration tab and choose Disable WINS Resolution.

f. Click the IP Address tab.

g. In the IP Address window, click Obtain an IP address automatically. 

h. Click OK.

i. When the prompt to restart your PC appears, click Yes.

j. Proceed to Step 7.

Step 4 If you have Windows NT 4.0 installed on your PC, complete the following steps to change its TCP/IP 
configuration:

a. From the Windows Start menu, choose Settings > Control Panel.

b. In the Control Panel dialog box, click the Network icon.

c. In the Network dialog box, click the Protocols tab, choose TCP/IP Protocol, then click Properties.

d. Click the IP Address tab.

e. In the IP Address window, click Obtain an IP address from a DHCP server.

f. Click OK.

g. Click Apply.

h. If Windows prompts you to restart your PC, click Yes.

i. Proceed to Step 7.

Step 5 If you have Windows 2000 installed on your PC, complete the following steps to change its TCP/IP 
configuration:

a. From the Windows Start menu, choose Settings > Network and Dial-up Connections > 
Local Area Connection.

b. In the Local Area Connection Status dialog box, click Properties.
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DLP-G40 Set Up a Windows PC for Craft Connection to an ONS 15454 Using Dynamic Host Configuration Protocol
c. On the General tab, choose Internet Protocol (TCP/IP), then click Properties.

d. Click Obtain an IP address from a DHCP server.

e. Click OK.

f. In the Local Area Connection Properties dialog box, click OK.

g. In the Local Area Connection Status dialog box, click Close.

h. Proceed to Step 7.

Step 6 If you have Windows XP installed on your PC, complete the following steps to change its TCP/IP 
configuration:

a. From the Windows Start menu, choose Control Panel > Network Connections.

Note If the Network Connections menu is not available, click Switch to Classic View.

b. In the Network Connections dialog box, click Local Area Connection.

c. In the Local Area Connection Status dialog box, click Properties.

d. On the General tab, choose Internet Protocol (TCP/IP), then click Properties.

e. Click Obtain an IP address from a DHCP server.

f. Click OK.

g. In the Local Area Connection Properties dialog box, click OK.

h. In the Local Area Connection Status dialog box, click Close.

Step 7 Return to your originating procedure (NTP).
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DLP-G41 Set Up a Windows PC for Craft Connection to an ONS 15454 Using Automatic Host Detection
DLP-G41 Set Up a Windows PC for Craft Connection to an ONS 15454 Using 
Automatic Host Detection 

Step 1 Verify the operating system that is installed on your computer: 

a. From the Windows Start menu, choose Settings > Control Panel. 

Note In Windows XP, you can select Control Panel directly from the Start menu. Make sure you 
are in Classic View before continuing with this procedure.

b. In the Control Panel window, double-click the System icon.

c. On the General tab of the System Settings window, verify that the Windows operating system is one 
of the following: Windows 98, Windows NT 4.0, Windows 2000, or Windows XP.

Step 2 According to the Windows operating system installed on your computer, perform one of the following 
steps:

• For Windows 98, complete Step 3.

• For Windows NT 4.0, complete Step 4.

• For Windows 2000, complete Step 5.

• For Windows XP, complete Step 6.

Step 3 If you have Windows 98 installed on your PC, complete the following steps to change its TCP/IP 
configuration:

a. From the Windows Start menu, choose Settings > Control Panel.

b. In the Control Panel dialog box, click the Network icon.

c. In the Network dialog box, select TCP/IP for your NIC, then click Properties.

Purpose This task sets up your computer for local craft connection to the 
ONS 15454 when:

• If you are using an ANSI shelf, you will connect to the ONS 15454 
Ethernet port or backplane LAN pins either directly or through a hub.

• If you are using an ETSI shelf, you will connect to the ONS 15454 
Ethernet port or the RJ-45 jack on the MIC-C/T/P FMEC either 
directly or through a hub.

• All nodes that you will access are running Software R3.3 or later.

• You will connect to multiple ONS 15454s and do not want to 
reconfigure your IP address each time.

• You do not need to access non-ONS 15454 applications such as ping 
and tracert (trace route).

Tools/Equipment None

Prerequisite Procedures NTP-G17 Set Up Computer for CTC, page 2-2

Required/As Needed As needed

Onsite/Remote Onsite

Security Level None
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DLP-G41 Set Up a Windows PC for Craft Connection to an ONS 15454 Using Automatic Host Detection
d. In the TCP/IP Properties dialog box, click the DNS Configuration tab and choose Disable DNS.

e. Click the WINS Configuration tab and choose Disable WINS Resolution.

f. Click the IP Address tab.

g. In the IP Address window, click Specify an IP address. 

h. In the IP Address field, enter any legitimate IP address other than the node IP address as indicated 
on the LCD of the ONS 15454. The default IP address is 192.1.0.2. 

Note You can suppress the LCD IP address display using CTC. For more information, see the 
“DLP-G162 Change IP Settings” task on page 10-19.

i. In the Subnet Mask field, type the same subnet mask as the ONS 15454. The default is 
255.255.255.0 (24 bit).

j. Click OK.

k. In the TCP/IP dialog box, click the Gateway tab.

l. In the New Gateway field, type the address entered in Step h. Click Add.

m. Verify that the IP address appears in the Installed Gateways field, then click OK.

n. When the prompt to restart your PC appears, click Yes.

o. Proceed to Step 7.

Step 4 If you have Windows NT 4.0 installed on your PC, complete the following steps to change its TCP/IP 
configuration:

a. From the Windows Start menu, choose Settings > Control Panel.

b. In the Control Panel dialog box, click the Network icon.

c. In the Network dialog box, click the Protocols tab, choose TCP/IP Protocol, then click Properties.

d. Click the IP Address tab.

e. In the IP Address window, click Specify an IP address. 

f. In the IP Address field, enter any legitimate IP address other than the node IP address as indicated 
on the LCD of the ONS 15454. The default IP address is 192.1.0.2. 

Note You can suppress the LCD IP address display using CTC. For more information, see the 
“DLP-G162 Change IP Settings” task on page 10-19.

g. In the Subnet Mask field, type the same subnet mask as the ONS 15454. The default is 
255.255.255.0 (24 bit).

h. Click Advanced.

i. In the Gateways List, click Add. The TCP/IP Gateway Address dialog box appears.

j. Type the IP address entered in Step f in the Gateway Address field.

k. Click Add.

l. Click OK.

m. Click Apply.

n. Reboot your PC. 
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DLP-G41 Set Up a Windows PC for Craft Connection to an ONS 15454 Using Automatic Host Detection
o. Proceed to Step 7.

Step 5 If you have Windows 2000 installed on your PC, complete the following steps to change its TCP/IP 
configuration:

a. From the Windows Start menu, choose Settings > Network and Dial-up Connections > 
Local Area Connection.

b. In the Local Area Connection Status dialog box, click Properties.

c. On the General tab, choose Internet Protocol (TCP/IP), then click Properties.

d. Click Use the following IP address.

e. In the IP Address field, enter any legitimate IP address other than the node IP address as indicated 
on the LCD of the ONS 15454. The default IP address is 192.1.0.2. 

Note You can suppress the LCD IP address display using CTC. For more information, see the 
“DLP-G162 Change IP Settings” task on page 10-19.

f. In the Subnet Mask field, type the same subnet mask as the ONS 15454. The default is 
255.255.255.0 (24 bit).

g. Type the IP address entered in Step e in the Gateway Address field.

h. Click OK.

i. In the Local Area Connection Properties dialog box, click OK.

j. In the Local Area Connection Status dialog box, click Close.

k. Proceed to Step 7.

Step 6 If you have Windows XP installed on your PC, complete the following steps to change its TCP/IP 
configuration:

a. From the Windows Start menu, choose Control Panel > Network Connections.

Note If the Network Connections menu is not available, click Switch to Classic View.

b. From the Network Connections dialog box, click the Local Area Connection icon to select it. 
Right-click and select Properties.

c. From the Local Area Connection Properties dialog box, click on Internet Protocol (TCP/IP) to 
select it, then click Properties.

d. In the IP Address field, enter any legitimate IP address other than the node IP address as indicated 
on the LCD of the ONS 15454. The default IP address is 192.1.0.2. 

e. Select the Use the Following IP Address: radio button.

Note You can suppress the LCD IP address display using CTC. For more information, see the 
“DLP-G162 Change IP Settings” task on page 10-19.

f. In the Subnet Mask field, type the same subnet mask as the ONS 15454. The default is 
255.255.255.0 (24 bit).

g. Type the IP address entered in Step d in the Gateway Address field.

h. Click OK.
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DLP-G42 Set Up a Solaris Workstation for a Craft Connection to an ONS 15454
i. In the Local Area Connection Properties dialog box, click OK.

j. In the Local Area Connection Status dialog box, click Close.

Step 7 Return to your originating procedure (NTP).

DLP-G42 Set Up a Solaris Workstation for a Craft Connection to an ONS 15454

Step 1 Log into the workstation as the root user.

Step 2 Check to see if the interface is plumbed by typing:

# ifconfig device 

For example:

# ifconfig hme1

• If the interface is plumbed, a message similar to the following appears:

hme1:flags=1000842<BROADCAST,RUNNING,MULTICAST,IPv4>mtu 1500 index 2 inet 0.0.0.0 
netmask 0

If a message similar to this one appears, go to Step 4.

• If the interface is not plumbed, a message similar to the following appears: 

ifconfig: status: SIOCGLIFFLAGS: hme1: no such interface. 

If a message similar to this one appears, go to Step 3.

Step 3 Plumb the interface by typing:

# ifconfig device plumb 

For example: 

# ifconfig hme1 plumb

Step 4 Configure the IP address on the interface by typing:

# ifconfig interface ip-address netmask netmask up

For example: 

# ifconfig hme0 192.1.0.3 netmask 255.255.255.0 up

Note Enter an IP address that is identical to the ONS 15454 IP address except for the last octet. The 
last octet must be 1 or 3 through 254. 

Purpose This task sets up a Solaris workstation for a craft connection to the 
ONS 15454.

Tools/Equipment None

Prerequisite Procedures NTP-G17 Set Up Computer for CTC, page 2-2

Required/As Needed As needed

Onsite/Remote Onsite

Security Level None
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DLP-G42 Set Up a Solaris Workstation for a Craft Connection to an ONS 15454
Step 5 In the Subnet Mask field, type 255.255.255.0. Skip this step if you checked Craft Access Only on the 
Provisioning > Network > General > Gateway Settings tab.

Step 6 Test the connection:

a. Start Netscape Navigator.

b. Enter the ONS 15454 IP address in the web address (URL) field. If the connection is established, a 
Java Console window, CTC caching messages, and the Cisco Transport Controller Login dialog box 
appear. If this occurs, go to Step 2 of the “DLP-G46 Log into CTC” task on page 2-25 to complete 
the login. If the Login dialog box does not appear, complete Steps c and d.

c. At the prompt, type: 

ping ONS-15454-IP-address

For example, to connect to an ONS 15454 with a default IP address of 192.1.0.2, type:

ping 192.1.0.2

If your workstation is connected to the ONS 15454, the following message appears:

IP-address is alive

Note Skip this step if you checked the Craft Access Only check box on the Provisioning > 
Network > General > Gateway Settings tab. 

d. If CTC is not responding, a “no answer from x.x.x.x” message appears. Verify the IP and subnet 
mask information. Check that the cables connecting the workstation to the ONS 15454 are securely 
attached. Check the link status by typing:

# ndd -set /dev/device instance 0

# ndd -get /dev/device link_status

For example:

# ndd -set /dev/hme instance 0

# ndd -get /dev/hme link_status

A result of “1” means the link is up. A result of “0” means the link is down.

Note Check the man page for ndd. For example, type: # man ndd.

Step 7 Return to your originating procedure (NTP).
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NTP-G19 Set Up a CTC Computer for a Corporate LAN Connection to the ONS 15454
NTP-G19 Set Up a CTC Computer for a Corporate LAN 
Connection to the ONS 15454

Step 1 If your computer is already connected to the corporate LAN, go to Step 3. If you changed your 
computer’s network settings for craft access to the ONS 15454, change the settings back to the corporate 
LAN access settings. This generally means:

• Set the IP Address on the TCP/IP dialog box back to Obtain an IP address automatically 
(Windows 98) or Obtain an IP address from a DHCP server (Windows NT 4.0, 2000, or XP). 

• If your LAN requires that Domain Name System (DNS) or Windows Internet Naming Service 
(WINS) be enabled, change the setting on the DNS Configuration or WINS Configuration tab of the 
TCP/IP dialog box. 

Step 2 Connect a straight-through (CAT-5) LAN cable from the PC or Solaris workstation NIC card to a 
corporate LAN port.

Step 3 If your computer is connected to a proxy server, disable proxy service or add the ONS 15454 nodes as 
exceptions. To disable proxy service, complete one of the following tasks, depending on the web browser 
that you use:

• DLP-G43 Disable Proxy Service Using Internet Explorer (Windows), page 2-22

• DLP-G44 Disable Proxy Service Using Netscape (Windows and UNIX), page 2-22

Step 4 Continue with the “NTP-G21 Log into the ONS 15454 GUI” procedure on page 2-24.

Stop. You have completed this procedure.

Purpose This procedure sets up your computer to access the ONS 15454 through a 
corporate LAN. 

Tools/Equipment NIC, also referred to as an Ethernet card

Straight-through (CAT-5) LAN cable

Prerequisite Procedures • NTP-G17 Set Up Computer for CTC, page 2-2

• The ONS 15454 must be provisioned for LAN connectivity, including 
IP address, subnet mask, default gateway.

• The ONS 15454 must be physically connected to the corporate LAN.

• The CTC computer must be connected to the corporate LAN that has 
connectivity to the ONS 15454.

Required/As Needed As needed

Onsite/Remote Onsite or remote

Security Level None
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DLP-G43 Disable Proxy Service Using Internet Explorer (Windows) 

Step 1 From the Start menu, select Settings > Control Panel.

Note If your computer is running Windows XP, you can select Control Panel directly from the Start 
menu. Make sure that you are in Classic View before continuing with this procedure.

Step 2 In the Control Panel window, choose Internet Options.

Step 3 In the Internet Properties dialog box, click Connections > LAN Settings.

Step 4 In the LAN Settings dialog box, complete one of the following tasks:

• Uncheck Use a proxy server to disable the service.

• Leave Use a proxy server selected and click Advanced. In the Proxy Setting dialog box under 
Exceptions, enter the IP addresses of ONS 15454 nodes that you will access. Separate each address 
with a semicolon. You can insert an asterisk (*) for the host number to include all the ONS 15454s 
on your network. Click OK to close each open dialog box.

Step 5 Return to your originating procedure (NTP).

DLP-G44 Disable Proxy Service Using Netscape (Windows and UNIX) 

Step 1 Open Netscape.

Step 2 From the Edit menu, choose Preferences.

Step 3 In the Preferences dialog box under Category, choose Advanced > Proxies.

Purpose This task disables proxy service for PCs running Internet Explorer. 

Tools/Equipment None

Prerequisite Procedures NTP-G17 Set Up Computer for CTC, page 2-2

Required/As Needed Required if your computer is connected to a network computer proxy 
server and your browser is Internet Explorer. 

Onsite/Remote Onsite or remote

Security Level None

Purpose This task disables proxy service for PCs and UNIX workstations running 
Netscape. 

Tools/Equipment None

Prerequisite Procedures NTP-G17 Set Up Computer for CTC, page 2-2

Required/As Needed Required if your computer is connected to a network computer proxy server 
and your browser is Netscape.

Onsite/Remote Onsite or remote

Security Level None
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Step 4 On the right side of the Preferences dialog box under Proxies, perform one of the following options:

• Choose Direct connection to the Internet to bypass the proxy server.

• Choose Manual proxy configuration to add exceptions to the proxy server, then click View. In the 
Manual Proxy Configuration dialog box under Exceptions, enter the IP addresses of the ONS 15454 
nodes that you will access. Separate each address with a comma. Click OK to close each open dialog 
box.

Step 5 Return to your originating procedure (NTP).

NTP-G20 Set Up a Remote Access Connection to the ONS 15454

Step 1 Connect the modem to the RJ-45 (LAN) port on the TCC2/TCC2P card, to the LAN pins on the 
ONS 15454 backplane (ANSI only), or to the RJ-45 jack on the MIC-C/T/P FMEC (ETSI only).

Step 2 While referring to the modem documentation, complete the following tasks to provision the modem for 
the ONS 15454: 

• For CTC access, set the modem for Ethernet access.

• Assign an IP address to the modem that is on the same subnet as the ONS 15454.

• The IP address the modem assigns to the CTC computer must be on the same subnet as the modem 
and the ONS 15454.

Note For assistance on provisioning specific modems, contact the Cisco Technical Assistance Center 
(Cisco TAC).

Step 3 Continue with the “NTP-G21 Log into the ONS 15454 GUI” procedure on page 2-24.

Stop. You have completed this procedure.

Purpose This procedure connects the CTC computer to an ONS 15454 using a LAN 
modem. To complete this procedure:

• A modem must be connected to the ONS 15454.

• The modem must be provisioned for ONS 15454. To run CTC, the 
modem must be provisioned for Ethernet access.

Tools/Equipment Modem and modem documentation

Prerequisite Procedures NTP-G17 Set Up Computer for CTC, page 2-2

Required/As Needed As needed

Onsite/Remote Onsite

Security Level None
2-23
Cisco ONS 15454 DWDM Installation and Operations Guide, R6.0

September 2005



 

Chapter 2      Connect the PC and Log into the GUI
NTP-G21 Log into the ONS 15454 GUI
NTP-G21 Log into the ONS 15454 GUI

Step 1 Complete the “DLP-G46 Log into CTC” task on page 2-25. 

Note For information about navigating in CTC, see Appendix A, “CTC Information and Shortcuts.”

Step 2 As needed, complete the “DLP-G48 Create Login Node Groups” task on page 2-28. Login node groups 
allow you to manage nodes that are not connected to the login node through a data communications 
channel (DCC).

Step 3 As needed, complete the “DLP-G49 Add a Node to the Current Session or Login Group” task on 
page 2-30.

Step 4 As needed, complete the “DLP-G50 Delete a Node from the Current Session or Login Group” task on 
page 2-30.

Step 5 As needed, complete the “DLP-G51 Delete a Node from a Specified Login Node Group” task on 
page 2-31.

Step 6 As needed, complete the “DLP-G52 Change the JRE Version” task on page 2-31.

Step 7 As needed, complete the “DLP-G53 Configure the CTC Alerts Dialog Box for Automatic Popup” task 
on page 2-32.

Stop. You have completed this procedure.

Purpose This procedure logs into CTC, the graphical user interface (GUI) software 
used to manage the ONS 15454. This procedure includes optional node 
login tasks.

Tools/Equipment None

Prerequisite Procedures NTP-G17 Set Up Computer for CTC, page 2-2

One of the following procedures:

• NTP-G18 Set Up CTC Computer for Local Craft Connection to the 
ONS 15454, page 2-9

• NTP-G19 Set Up a CTC Computer for a Corporate LAN Connection 
to the ONS 15454, page 2-21

• NTP-G20 Set Up a Remote Access Connection to the ONS 15454, 
page 2-23

Required/As Needed As needed

Onsite/Remote Onsite or remote

Security Level Retrieve or higher
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DLP-G46 Log into CTC

Note For information about CTC views and navigation, see Appendix A, “CTC Information and Shortcuts.”

Step 1 From the computer connected to the ONS 15454, start Netscape (PC or UNIX) or Internet Explorer (PC 
only):

• If you are using a PC, launch Netscape or Internet Explorer from the Windows Start menu or a 
shortcut icon.

• If you are using UNIX, launch Netscape from the command line by typing one of the following:

– To install Netscape colors for Netscape use, type:

# netscape -install

– To limit Netscape to 32 colors so that if the requested color is not available, Netscape chooses 
the closest color option, type:

netscape -ncols 32

Note CTC requires a full 24-color palette to run properly. When using color-intensive applications 
such as Netscape in UNIX, it is possible that UNIX might run out of colors to use for CTC. 
The -install and -ncols 32 command line options limit the number of colors that Netscape 
uses. 

Step 2 In the Netscape or Internet Explorer web address (URL) field, enter the ONS 15454 IP address. For 
initial setup, this is the default IP address, 192.1.0.2. (This IP address appears on the LCD. You can 
suppress the LCD IP address display using CTC after you log in. For more information, see the 
“DLP-G162 Change IP Settings” task on page 10-19.) 

Step 3 Press Enter.

Purpose This task logs into CTC. 

Tools/Equipment None

Prerequisite Procedures NTP-G17 Set Up Computer for CTC, page 2-2

One of the following procedures:

• NTP-G18 Set Up CTC Computer for Local Craft Connection to the 
ONS 15454, page 2-9

• NTP-G19 Set Up a CTC Computer for a Corporate LAN Connection 
to the ONS 15454, page 2-21

• NTP-G20 Set Up a Remote Access Connection to the ONS 15454, 
page 2-23

Required/As Needed Required

Onsite/Remote Onsite or remote

Security Level Retrieve or higher
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Note If you are logging into ONS 15454 nodes in an operation network that are running different 
releases of CTC software, log into the node running the most recent release. If you log into a 
node running an older release, you will receive an INCOMPATIBLE-SW alarm for each node in 
the network running a new release, and CTC will not be able to manage these nodes. To check 
the software version of a node, select About CTC from the CTC Help menu. This will display 
the ONS 15454 software version for each node visible on the network view. If the node is not 
visible, the software version can be read from the LCD display. To resolve an alarm, refer to the 
Cisco ONS 15454 Troubleshooting Guide or the Cisco ONS 15454 SDH Troubleshooting Guide.

Step 4 If a Java Plug-in Security Warning dialog box appears, complete the “DLP-G47 Install Public-Key 
Security Certificate” task on page 2-28 to install the public-key security certificate required by Software 
Release 4.1 and later.

After you complete the security certificate dialog box (or if the certificate is already installed), a Java 
Console window displays the CTC file download status. The web browser displays information about 
your Java and system environments. If this is the first login, CTC caching messages appear while CTC 
files are downloaded to your computer. The first time you connect to an ONS 15454, this process can 
take several minutes. After the download, the CTC Login dialog box appears (Figure 2-1).

Figure 2-1 Logging into CTC

Note When the CTC Login dialog box appears, it might be minimized.

Step 5 In the Login dialog box, type a user name and password (both are case sensitive). For initial setup, type 
the user name CISCO15 and the password otbu+1.
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Note The CISCO15 user is provided with every ONS 15454. CISCO15 has Superuser privileges, so 
you can create other users. You must create another Superuser before you can delete the 
CISCO15 user. CISCO15 is delivered with the otbu+1 password. To change the password for 
CISCO15, click the Provisioning > Security tabs after you log in and change the password. To 
set up ONS 15454 users and assign security, go to the “NTP-G23 Create Users and Assign 
Security” procedure on page 3-5. Additional information about security is provided in the 
“20.1 User IDs and Security Levels” section on page 20-1.

Step 6 Each time you log into an ONS 15454, you can make selections about the following login options:

• Node Name—Displays the IP address entered in the web browser and a drop-down list of previously 
entered ONS 15454 IP addresses. You can select any ONS 15454 on the list for the login, or you can 
enter the IP address (or node name) of any new node where you want to log in.

• Additional Nodes—Displays a list of current login node groups. To create a login node group or add 
additional groups, see the “DLP-G48 Create Login Node Groups” task on page 2-28.

• Disable Network Discovery—Check this box to view only the ONS 15454 (and login node group 
members, if any) entered in the Node Name field. Nodes linked to this node through DCCs are not 
discovered and will not appear in CTC network view. Using this option can decrease the CTC startup 
time in networks with many DCC-connected nodes, and can reduce memory consumption. 

• Disable Circuit Management—Check this box to disable discovery of existing circuits. Using this 
option can decrease the CTC initialization time in networks with many existing circuits and reduce 
memory consumption. This option does not prevent the creation and management of new circuits.

Step 7 Click Login.

If the login is successful, the CTC window appears. From here, you can navigate to other CTC views to 
provision and manage the ONS 15454. If you need to turn up the shelf for the first time, see Chapter 3, 
“Turn Up a Node.” If login problems occur, refer to the Cisco ONS 15454 Troubleshooting Guide or the 
Cisco ONS 15454 SDH Troubleshooting Guide.

Step 8 Return to your originating procedure (NTP).
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DLP-G47 Install Public-Key Security Certificate

Step 1 If the Java Plug-in Security Warning dialog box appears, choose one of the following options:

Note The Java Plug-in Security Warning dialog box options that appear depend on the JRE version 
you are using. If you installed JRE 1.4.2, you will see the following options: Yes, No, Always, 
and More Details. If you are using JRE 1.3.1_02, you will see the following options (shown in 
parentheses in the following list): Grant This Session, Deny, Grant Always, and 
View Certificate.

• Yes (Grant This Session)—Installs the public-key certificate to your PC only for the current session. 
After the session is ended, the certificate is deleted. This dialog box will appear the next time you 
log into the ONS 15454.

• No (Deny)—Denies permission to install the certificate. If you choose this option, you cannot log 
into the ONS 15454. 

• Always (Grant Always)—Installs the public-key certificate and does not delete it after the session 
is over. Cisco recommends this option.

• More Details (View Certificate)—Allows you to view the public-key security certificate.

Step 2 Return to your originating procedure (NTP).

DLP-G48 Create Login Node Groups

Step 1 From the Edit menu in node view, choose Preferences.

Purpose This task installs the ITU Recommendation X.509 public-key security 
certificate. The public-key certificate is required to run Software 
Release 4.1 or later.

Tools/Equipment None

Prerequisite Procedures This task is performed during the “DLP-G46 Log into CTC” task on 
page 2-25. You cannot perform it outside of this task.

Required/As Needed Required 

Onsite/Remote Onsite or remote

Security Level Provisioning or higher

Purpose This task creates a login node group to display ONS 15454s that have an IP 
connection but not a DCC connection to the login node.

Tools/Equipment None

Prerequisite Procedures DLP-G46 Log into CTC, page 2-25

Required/As Needed As needed

Onsite/Remote Onsite or remote

Security Level Provisioning or higher
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Step 2 Click Login Node Group and Create Group.

Step 3 Enter a name for the group in the Create Login Group Name dialog box. Click OK.

Step 4 In the Members area, type the IP address (or node name) of a node you want to add to the group. Click 
Add. Repeat this step for each node that you want to add to the group.

Step 5 Click OK. 

The next time you log into an ONS 15454, the login node group will be available in the Additional Nodes 
list of the Login dialog box. For example, in Figure 2-2, a login node group is created that contains the 
IP addresses for Nodes 1, 4, and 5. During login, if you choose this group from the Additional Nodes 
list and Disable Network Discovery is not selected, all nodes in the figure appear. If the login group and 
Disable Network Discovery are both selected, only Nodes 1, 4, and 5 appear. You can create as many 
login node groups as you need. The groups are stored in the CTC preferences file and are not visible to 
other users.

Figure 2-2 Login Node Group 

Step 6 Return to your originating procedure (NTP).
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DLP-G49 Add a Node to the Current Session or Login Group

Step 1 From the CTC File menu, click Add Node.

Step 2 In the Add Node dialog box, enter the node name (or IP address).

Step 3 If you want to add the node to the current login node group, check Add to current login node group. 
Otherwise, leave it unchecked.

Note This check box is active only if you selected a login group when you logged into CTC. 

Step 4 Click OK. 

After a few seconds, the new node appears on the network view map.

Step 5 Return to your originating procedure (NTP).

DLP-G50 Delete a Node from the Current Session or Login Group

Step 1 From the View menu, choose Go to Network View. 

Step 2 Click the node that you want to delete. 

Step 3 From the CTC File menu, click Delete Selected Node.

After a few seconds, the node disappears from the network view map.

Step 4 Return to your originating procedure (NTP).

Purpose This task adds a node to the current CTC session or login node group.

Tools None

Prerequisite Procedures DLP-G46 Log into CTC, page 2-25

Required/As Needed As needed

Onsite/Remote Onsite or remote

Security Level Provisioning or higher

Purpose This task removes a node from the current CTC session or login node 
group. To remove a node from a login node group that is not the current 
one, see “DLP-G51 Delete a Node from a Specified Login Node Group” 
task on page 2-31.

Tools None

Prerequisite Procedures DLP-G46 Log into CTC, page 2-25

Required/As Needed As needed

Onsite/Remote Onsite or remote

Security Level Provisioning or higher
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DLP-G51 Delete a Node from a Specified Login Node Group

Step 1 From the CTC Edit menu, choose Preferences.

Step 2 In the Preferences dialog box, click the Login Node Groups tab.

Step 3 Click the login node group tab containing the node you want to remove. 

Step 4 Click the node you want to remove, then click Remove.

Step 5 Click OK.

Step 6 Return to your originating procedure (NTP).

DLP-G52 Change the JRE Version

Note This task is not used in Release 6.0 because only one JRE version is supported. This task is used in CTC 
releases that support multiple JRE versions.

Step 1 From the Edit menu, choose Preferences.

Step 2 Click the JRE tab. The JRE tab shows the current JRE version and the recommended version.

Step 3 Click the Browse button and navigate to the JRE directory on your computer.

Step 4 Choose the JRE version.

Step 5 Click OK. 

Purpose This task removes a node from a specified login node group. To remove a 
node from the current login node group, see the “DLP-G50 Delete a Node 
from the Current Session or Login Group” task on page 2-30.

Tools None

Prerequisite Procedures DLP-G46 Log into CTC, page 2-25

Required/As Needed As needed

Onsite/Remote Onsite or remote

Security Level Provisioning or higher

Purpose This task changes the JRE version, which is useful if you would like to 
upgrade to a later JRE version from an earlier one without using the 
software or documentation CD. This does not affect the browser default 
version. After selecting the desired JRE version, you must exit CTC. The 
next time you log into a node, the new JRE version will be used.

Tools None

Prerequisite Procedures DLP-G46 Log into CTC, page 2-25

Required/As Needed As needed

Onsite/Remote Onsite or remote

Security Level Provisioning or higher
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Step 6 From the File menu, choose Exit. 

Step 7 In the confirmation dialog box, click Yes.

Step 8 Return to your originating procedure (NTP).

DLP-G53 Configure the CTC Alerts Dialog Box for Automatic Popup

Step 1 Click the CTC Alerts toolbar icon. 

Step 2 In the CTC Alerts dialog box, choose one of the following:

• All alerts—Sets the CTC Alerts dialog box to open automatically for all notifications.

• Error alerts only—Sets the CTC Alerts dialog box to open automatically for circuit deletion errors 
only.

• Never—Sets the CTC Alerts dialog box to never open automatically.

Step 3 Click Close.

Step 4 Return to your originating procedure (NTP).

Purpose This task sets up the CTC Alerts dialog box to open for all alerts, for circuit 
deletion errors only, or never. The CTC Alerts dialog box displays network 
disconnection, Send-PDIP inconsistency, circuit deletion status, condition 
retrieval errors, and software download failure.

Tools None

Prerequisite Procedures DLP-G46 Log into CTC, page 2-25

Required/As Needed As needed

Onsite/Remote Onsite or remote

Security Level Provisioning or higher
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