CHAPTER

Getting Started with Cisco VSPT

Revised: March 17, 2010, OL-8907-06

This chapter provides directions for starting and using the Cisco VSPT. It contains the following
sections:

e Starting Cisco VSPT, page 3-1
e Using Cisco VSPT, page 3-3
e Defining Users and Permissions, page 3-6

e Exiting the Cisco VSPT, page 3-7

Starting Cisco VSPT

To start the Cisco VSPT, use this procedure.

~

Note  If you encounter any font problems in Cisco VSPT, start the VNC server using
-fb /user/openwin/lib/X11/fonts/misc/ as the command arguments.

Step 1 Do one of the following to start Cisco VSPT:
e Start Cisco VSPT standalone.
- Login to the Cisco VSPT server or access it from a machine with X window capability.

— In a terminal window, change to the default directory:

>cd /opt/CSCOvsp27

~

Note Navigate to the appropriate directory if you installed the Cisco VSPT in a different location.

— Enter the following command to start the Cisco VSPT:

>./vspt

e Start Cisco VSPT from Cisco Media Gateway Controller Node Manager (CMNM).
- Before starting Cisco MNM, log in as root.
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— Right-click the Cisco PGW 2200 Softswitch host object in the Map Viewer and choose
Tools > Voice Service Provisioning Tool (VSPT).

~

Note  If you start the Cisco VSPT from Cisco MNM, the correct Cisco VSPT version is automatically
launched to match the selected Cisco PGW 2200 Softswitch. You must have that version of
Cisco VSPT installed before you launch it on the Cisco PGW 2200 Softswitch host object from
Cisco MNM.

The login screen shown in Figure 3-1 appears.

Figure 3-1 Login Screen

User Hame:

Password:

205524

Step2  Enter your user name and password and click OK.
The default user name is admin, and the password is also admin.

~

Note  Cisco VSPT checks the license and provides the expiry date for that license after you provide
the login information.

The Welcome screen is displayed briefly during the login process, and the Main VSPT window appears
(see Figure 3-2).
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Figure 3-2 Main Cisco VSPT Window
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Using Cisco VSPT

This section describes

the Cisco VSPT menus and Configuration Editor views and gives instructions for

using the tool functions.

Menus
The Cisco VSPT menu bar contains these menus:
e File
e View
e Tools
e Help
These menus are described in the following sections.
File Menu
Table 3-1 describes File menu options.
Table 3-1 File Menu Options
Menu Option Description
New Begin a new configuration session.
Open Open an existing configuration.
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Table 3-1 File Menu Options (continued)
Menu Option Description
Import Import an existing configuration from a Cisco PGW 2200 Softswitch, or import

trunk group, trunk, routing, or dial plan files into the Cisco VSPT.

Export Export configuration files from the Cisco VSPT to a specified directory.
Save Save the current configuration using one of the following options:
e As Working—Use to save a new configuration, either a configuration
imported from the Cisco PGW 2200 Softswitch or a configuration created in
Cisco VSPT. Use also to save modifications to an existing configuration,
overwriting the last version.
The configuration is saved in the /var/opt/CSCOvsp27/data/mgc/mistral
directory.
¢ As Snapshot—Use to save modifications to an existing configuration under
anew name in the ARCHIVE directory. The snapshot configuration is saved
in /var/opt/CSCOvsp27/data/mgc/mistral/configname/ ARCHIVE.
e As New Config—Use to save a modified configuration under a new name,
leaving the original unchanged.
Exit Stop any open provisioning sessions and close the Cisco VSPT.
View Menu
Table 3-2 describes View menu options.
Table 3-2 View Menu Options
Menu Option Description
MML Show generated MML for the current configuration.
Trunk Group File Show generated trunk group file for the current configuration.
Trunk File Show generated trunk file for the current configuration.
Tools Menu

Table 3-3 describes Tools menu options.

Table 3-3 Tools Menu Options

Menu Option Description

Integrity Check Check your configuration for inconsistencies and missing information.
Deploy Move the configuration to one or more target hosts.

Remote Shell Open a Telnet or SSH session.

MGC Viewer View, activate, remove, and synchronize configurations on the

Cisco PGW 2200 Softswitch.

BAMS Config

View and configure a Cisco Billing and Measurements Server (BAMS). See the
Cisco Billing and Measurements Server User’s Guide for your release of
Cisco BAMS for information about its configuration.
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Table 3-3 Tools Menu Options (continued)
Menu Option Description
State Operation View and configure the state of Cisco PGW 2200 Softswitch components.

Advanced Number |View and configure screening numbers, ported number table, and the number
Editor termination table. See the Cisco MGC Software Release 9 Dial Plan Guide for
information about using the Cisco VSPT Advanced Number Editor.

Audit Audit bearer trunk information that moves between the
Cisco PGW 2200 Softswitch and the Cisco BAMS.

Backup and Restore |Create, modify, or delete scheduled backups or restores on the
Cisco PGW 2200 Softswitch Host, Catalyst 2900XL, Catalyst 5500, Catalyst
6509, Cisco ITP-L 2600, Cisco BAMS P3, and Cisco HSI server components.

Administrators

Change Password |Change your own password.

User Admin Add, modify, or delete users.

Table 3-4 describes Help menu options.

Table 3-4 Help Menu Commands

Menu Option Description
VSPT User Guide |View a local version of the Cisco VSPT User Guide.

About VSPT View information about the current version of Cisco VSPT, including the
software release number.

Configuration Editor Views

You create, view, and modify configurations using the Cisco VSPT Configuration Editor, which has
three different views.

To select a view, click one of the radio buttons at the top of the Configuration Editor window:

e MGC Config—Cisco PGW 2200 Softswitch Configuration view. Use to add components and
provision component properties.

e Traffic—Traffic view. Use to create customer-specific files, including trunk groups, trunks, and
routing.

e Number Analysis—Number Analysis view. Use to provision dial plans.
In each view, the left pane displays selectable components in an Explorer-type tree view.
The right pane displays data entry fields for the selected component.

Click a component to select it. To see all of the subcomponents for the component you select, click the
icon next to the component name to expand the component list.

For instructions on using the Cisco VSPT to provision components, component properties, trunk groups,
trunks, and routing, see the Cisco Media Gateway Controller Software Release 9 Provisioning Guide.
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For instructions on using the Cisco VSPT to provision a dial plan, see the Cisco Media Gateway
Controller Software Release 9 Dial Plan Guide.

Defining Users and Permissions

After you install the Cisco VSPT, you define users and their respective permissions using the following
procedure:

Step1  Log in to the server as root.

Step2  Start Cisco VSPT, either by first starting Cisco MGC Node Manager and then starting Cisco VSPT, or
by starting the Cisco VSPT standalone.

Step3  Click Tools > User Admin.

The User Administration screen in Figure 3-3 appears.

Figure 3-3 Cisco VSPT User Administration
b4l User Administration
Username: Permission:
admin adwin
Username: | |
Password: | |
Permission: |uiewer - |
|_| add || Modfy || Delete || close |_| g
=
()

Stepd  To add a user, do the following:
a. Enter a user name and password.

b. From the Permission dropdown list, select the desired permission level, Admin, User, or Viewer.

Note Admin—Can create, modify, and delete users. This type of user has full read and write access to all of
the configurations on the Cisco BAMS and the Cisco PGW 2200 Softswitch.
User—Cannot create, modify, or delete users. This type of user has full read and write access to all of
the configurations on the Cisco BAMS and the Cisco PGW 2200 Softswitch.
Viewer—Cannot create, modify, or delete users. This type of user has the read-only access to the
Cisco PGW 2200 Softswitch configurations saved on the Cisco VSPT but has no access to the
Cisco BAMS configurations saved on the Cisco VSPT. A viewer cannot access the configurations on the
remote Cisco BAMS or the Cisco PGW 2200 Softswitch.

c. Click Add.
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To modify a user, select the user name, change the password or permission level, and click Modify.

To delete a user, select the user name, and click Delete.

Exiting the Cisco VSPT

You can exit the Cisco VSPT by choosing File > Exit or by clicking the X button in the upper right of
the main window.

Cisco Voice Services Provisioning Tool User Guide
| oL-8907-06 .m



Chapter3  Getting Started with Cisco VSPT |

M Exiting the Cisco VSPT

Cisco Voice Services Provisioning Tool User Guide
m. oL-8907-06 |



	Getting Started with Cisco VSPT
	Starting Cisco VSPT
	Using Cisco VSPT
	Menus
	File Menu
	View Menu
	Tools Menu
	Help Menu

	Configuration Editor Views

	Defining Users and Permissions
	Exiting the Cisco VSPT



<<
  /ASCII85EncodePages false
  /AllowTransparency false
  /AutoPositionEPSFiles true
  /AutoRotatePages /All
  /Binding /Left
  /CalGrayProfile (Dot Gain 20%)
  /CalRGBProfile (sRGB IEC61966-2.1)
  /CalCMYKProfile (U.S. Web Coated \050SWOP\051 v2)
  /sRGBProfile (sRGB IEC61966-2.1)
  /CannotEmbedFontPolicy /Warning
  /CompatibilityLevel 1.4
  /CompressObjects /Tags
  /CompressPages true
  /ConvertImagesToIndexed true
  /PassThroughJPEGImages true
  /CreateJDFFile false
  /CreateJobTicket false
  /DefaultRenderingIntent /Default
  /DetectBlends true
  /DetectCurves 0.0000
  /ColorConversionStrategy /LeaveColorUnchanged
  /DoThumbnails false
  /EmbedAllFonts true
  /EmbedOpenType false
  /ParseICCProfilesInComments true
  /EmbedJobOptions true
  /DSCReportingLevel 0
  /EmitDSCWarnings false
  /EndPage -1
  /ImageMemory 1048576
  /LockDistillerParams false
  /MaxSubsetPct 100
  /Optimize true
  /OPM 1
  /ParseDSCComments true
  /ParseDSCCommentsForDocInfo true
  /PreserveCopyPage true
  /PreserveDICMYKValues true
  /PreserveEPSInfo true
  /PreserveFlatness true
  /PreserveHalftoneInfo false
  /PreserveOPIComments false
  /PreserveOverprintSettings true
  /StartPage 1
  /SubsetFonts true
  /TransferFunctionInfo /Apply
  /UCRandBGInfo /Preserve
  /UsePrologue false
  /ColorSettingsFile ()
  /AlwaysEmbed [ true
  ]
  /NeverEmbed [ true
  ]
  /AntiAliasColorImages false
  /CropColorImages true
  /ColorImageMinResolution 300
  /ColorImageMinResolutionPolicy /OK
  /DownsampleColorImages true
  /ColorImageDownsampleType /Bicubic
  /ColorImageResolution 300
  /ColorImageDepth -1
  /ColorImageMinDownsampleDepth 1
  /ColorImageDownsampleThreshold 1.50000
  /EncodeColorImages true
  /ColorImageFilter /DCTEncode
  /AutoFilterColorImages true
  /ColorImageAutoFilterStrategy /JPEG
  /ColorACSImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /ColorImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000ColorACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000ColorImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasGrayImages false
  /CropGrayImages true
  /GrayImageMinResolution 300
  /GrayImageMinResolutionPolicy /OK
  /DownsampleGrayImages true
  /GrayImageDownsampleType /Bicubic
  /GrayImageResolution 300
  /GrayImageDepth -1
  /GrayImageMinDownsampleDepth 2
  /GrayImageDownsampleThreshold 1.50000
  /EncodeGrayImages true
  /GrayImageFilter /DCTEncode
  /AutoFilterGrayImages true
  /GrayImageAutoFilterStrategy /JPEG
  /GrayACSImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /GrayImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000GrayACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000GrayImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasMonoImages false
  /CropMonoImages true
  /MonoImageMinResolution 1200
  /MonoImageMinResolutionPolicy /OK
  /DownsampleMonoImages true
  /MonoImageDownsampleType /Bicubic
  /MonoImageResolution 1200
  /MonoImageDepth -1
  /MonoImageDownsampleThreshold 1.50000
  /EncodeMonoImages true
  /MonoImageFilter /CCITTFaxEncode
  /MonoImageDict <<
    /K -1
  >>
  /AllowPSXObjects false
  /CheckCompliance [
    /None
  ]
  /PDFX1aCheck false
  /PDFX3Check false
  /PDFXCompliantPDFOnly false
  /PDFXNoTrimBoxError true
  /PDFXTrimBoxToMediaBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXSetBleedBoxToMediaBox true
  /PDFXBleedBoxToTrimBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXOutputIntentProfile ()
  /PDFXOutputConditionIdentifier ()
  /PDFXOutputCondition ()
  /PDFXRegistryName ()
  /PDFXTrapped /False

  /Description <<
    /CHS <FEFF4f7f75288fd94e9b8bbe5b9a521b5efa7684002000500044004600206587686353ef901a8fc7684c976262535370673a548c002000700072006f006f00660065007200208fdb884c9ad88d2891cf62535370300260a853ef4ee54f7f75280020004100630072006f0062006100740020548c002000410064006f00620065002000520065006100640065007200200035002e003000204ee553ca66f49ad87248672c676562535f00521b5efa768400200050004400460020658768633002>
    /CHT <FEFF4f7f752890194e9b8a2d7f6e5efa7acb7684002000410064006f006200650020005000440046002065874ef653ef5728684c9762537088686a5f548c002000700072006f006f00660065007200204e0a73725f979ad854c18cea7684521753706548679c300260a853ef4ee54f7f75280020004100630072006f0062006100740020548c002000410064006f00620065002000520065006100640065007200200035002e003000204ee553ca66f49ad87248672c4f86958b555f5df25efa7acb76840020005000440046002065874ef63002>
    /DAN <>
    /DEU <>
    /ESP <>
    /FRA <>
    /ITA <>
    /JPN <>
    /KOR <FEFFc7740020c124c815c7440020c0acc6a9d558c5ec0020b370c2a4d06cd0d10020d504b9b0d1300020bc0f0020ad50c815ae30c5d0c11c0020ace0d488c9c8b85c0020c778c1c4d560002000410064006f0062006500200050004400460020bb38c11cb97c0020c791c131d569b2c8b2e4002e0020c774b807ac8c0020c791c131b41c00200050004400460020bb38c11cb2940020004100630072006f0062006100740020bc0f002000410064006f00620065002000520065006100640065007200200035002e00300020c774c0c1c5d0c11c0020c5f40020c2180020c788c2b5b2c8b2e4002e>
    /NLD (Gebruik deze instellingen om Adobe PDF-documenten te maken voor kwaliteitsafdrukken op desktopprinters en proofers. De gemaakte PDF-documenten kunnen worden geopend met Acrobat en Adobe Reader 5.0 en hoger.)
    /NOR <>
    /PTB <>
    /SUO <>
    /SVE <>
    /ENU (Use these settings to create Adobe PDF documents for quality printing on desktop printers and proofers.  Created PDF documents can be opened with Acrobat and Adobe Reader 5.0 and later.)
  >>
  /Namespace [
    (Adobe)
    (Common)
    (1.0)
  ]
  /OtherNamespaces [
    <<
      /AsReaderSpreads false
      /CropImagesToFrames true
      /ErrorControl /WarnAndContinue
      /FlattenerIgnoreSpreadOverrides false
      /IncludeGuidesGrids false
      /IncludeNonPrinting false
      /IncludeSlug false
      /Namespace [
        (Adobe)
        (InDesign)
        (4.0)
      ]
      /OmitPlacedBitmaps false
      /OmitPlacedEPS false
      /OmitPlacedPDF false
      /SimulateOverprint /Legacy
    >>
    <<
      /AddBleedMarks false
      /AddColorBars false
      /AddCropMarks false
      /AddPageInfo false
      /AddRegMarks false
      /ConvertColors /NoConversion
      /DestinationProfileName ()
      /DestinationProfileSelector /NA
      /Downsample16BitImages true
      /FlattenerPreset <<
        /PresetSelector /MediumResolution
      >>
      /FormElements false
      /GenerateStructure true
      /IncludeBookmarks false
      /IncludeHyperlinks false
      /IncludeInteractive false
      /IncludeLayers false
      /IncludeProfiles true
      /MultimediaHandling /UseObjectSettings
      /Namespace [
        (Adobe)
        (CreativeSuite)
        (2.0)
      ]
      /PDFXOutputIntentProfileSelector /NA
      /PreserveEditing true
      /UntaggedCMYKHandling /LeaveUntagged
      /UntaggedRGBHandling /LeaveUntagged
      /UseDocumentBleed false
    >>
  ]
>> setdistillerparams
<<
  /HWResolution [2400 2400]
  /PageSize [612.000 792.000]
>> setpagedevice


