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Preface

This preface describes the objectives, audience, organization, and conventions of this document. It 
contains the following sections:

• Document Objective, page v

• Audience, page vi

• Document Organization, page vi

• Terminology, page vi

• Document Conventions, page vii

• Documentation Suite, page vii

• Obtaining Documentation, page ix

• Obtaining Technical Assistance, page x

• Document Change History, page xii

Document Objective
This document provides the information you need to get started using the Cisco MNM Provisioning Tool 
(MNM-PT), Version 2.4(1). You should read the system-level documentation supplied with your system 
before using this guide. A complete list of these documents is included in the Cisco Media Gateway 
Controller Software Version 9 Installation and Configuration Guide that ships with your system.

Note The Cisco MNM Provisioning Tool (MNM-PT) was previously known as the Voice Services 
Provisioning Tool (VSPT).

Installation is covered in the separate Cisco MGC Node Manager Installation Guide at:

http://www.cisco.com/univercd/cc/td/doc/product/access/sc/rel9/emins/index.htm

Detailed provisioning instructions are beyond the scope of this Guide, and are covered in the 
Cisco Media Gateway Controller Software Version 9 Provisioning Guide at:

http://www.cisco.com/univercd/cc/td/doc/product/access/sc/rel9/prvgde/index.htm, in particular 
Chapter 3, Provisioning with the Voice Services Provisioning Tool at

http://www.cisco.com/univercd/cc/td/doc/product/access/sc/rel9/prvgde/r9gui.htm
v
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Audience
Detailed instructions for provisioning dial plans are covered in the Cisco Media Gateway Controller 
Software Version 9 Dial Plan Guide at
http://www.cisco.com/univercd/cc/td/doc/product/access/sc/rel9/dplan/index.htm, in particular Chapter 
3, “Provisioning Dial Plans with the VSPT”, at
http://www.cisco.com/univercd/cc/td/doc/product/access/sc/rel9/dplan/dp_vspt.htm

Note This document uses the term media gateway controller software or MGC application to mean the 
Cisco MGC software that runs in the UNIX environment on a server. The term MGC refers to the 
combination of this software and the server. The Cisco MGC communicates with the SS7 network to 
process and route calls between a traditional time-division multiplexing (TDM) network and a packet 
data network. This routing takes place through a variety of media gateways, standalone devices that 
perform the conversion between the TDM and data network formats.

Note The Cisco PGW 2200 Softswitch was formerly known as the Cisco PGW 2200 PSTN Gateway. Older 
names of this product are the Cisco VSC 3000 and Cisco SC 2200. Some parts of this document may 
still use the older names.

Audience
This document is designed for network operators and administrators who have experience with 
telecommunications networks, protocols, and equipment and who have familiarity with data 
communications networks, protocols, and equipment. Software and hardware installers and network 
designers will also find this document useful.

Document Organization
Table 1 describes the major sections of this document.

Terminology
The following terms are used in this document:

Cisco MGC host—A Sun host server running Cisco MGC software. If your product is the Cisco SC2200, 
this is also known as an SC host. If your product is the Cisco PGW 2200 Softswitch, this is also known 
as a PSTN Gateway host.

Table 1 Document Organization

Chapter Title Description

Chapter 1 This chapter describes the MNM-PT and 
provides information on how to get 
started using the tool.

Chapter 2 This chapter describes the utilities 
included with MNM-PT and provides 
instructions for using them.
vi
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Document Conventions
Cisco SC node—The combination of the Cisco SC2200 product and the control signaling network. The 
SC node consists of all solution components except the media gateway. 

Cisco MGC node—The logical grouping of the active and standby MGC hosts, the control signaling 
network, and the Cisco Signaling Link Terminals (SLTs). 

Simplex MGC node—A node that uses a single Cisco MGC host. Typically, nodes of this type are used 
for solution evaluation tests or for small installations. Any loss of service in the Cisco MGC host disrupts 
all call traffic. If your product is the Cisco SC2200, this is also called a simplex SC node.

Continuous-service MGC node—A node that uses two Cisco MGC hosts to prevent system downtime 
that might otherwise result from the failure of a single MGC host. Calls in progress are maintained when 
one MGC host fails. Continuous-service nodes use SLTs to preprocess SS7 signaling and distribute 
signaling to both MGC hosts. If a failover occurs, all stable calls are maintained. If your product is the 
Cisco SC2200, this is also called a continuous-service SC node. 

Document Conventions
Notes use the following conventions:

Caution Means reader be careful. In this situation, you might do something that could result in equipment 
damage or loss of data.

Note Means reader take note. Notes contain helpful suggestions or references to material not covered in the 
publication.

Documentation Suite
The following documentation provides information about the Cisco MGC software and the solutions it 
supports.

MNM-PT Release Notes
Release Notes for MNM-PT Version 2.4(1) (includes release information through this version):

http://www.cisco.com/univercd/cc/td/doc/product/access/sc/rel9/relnote/vspt24.htm

Cisco Media Gateway Controller Node Manager Documentation
The Cisco Media Gateway Controller Node Manager (Cisco MGC Node Manager) provides an 
integrated graphical user interface for managing the Cisco PGW 2200 Softswitch node, and MNM-PT 
may be launched from Cisco MGC Node Manager. The following documentation is available for 
Cisco MGC Node Manager:

Cisco MGC Node Manager User’s Guide Version 2.4(1) at 
http://www.cisco.com/univercd/cc/td/doc/product/access/sc/rel9/cmnm243/index.htm.
vii
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Documentation Suite
Cisco MGC Node Manager Release Notes Version 2.4 at 
http://www.cisco.com/univercd/cc/td/doc/product/access/sc/rel9/relnote/cmnm24.htm.

Unlike MNM-PT, where each version is designed to work with a specific version of Cisco MGC 
software, each version of Cisco MGC Node Manager is backward-compatible with earlier Cisco MGC 
software versions.

Cisco MGC Documentation
The following documentation available for the Cisco MGC Release 9 is on the CD that ships with your 
software and at http://www.cisco.com/univercd/cc/td/doc/product/access/sc/rel9/index.htm:

• Cisco Media Gateway Controller Software Release 9 Installation and Configuration Guide 

• Cisco Media Gateway Controller Software Release 9 Provisioning Guide 

• Cisco Media Gateway Controller Software Release 9 Dial Plan Guide 

• Cisco Media Gateway Controller Software Release 9 MML Command Reference 

• Cisco Media Gateway Controller Software Release 9 Messages Reference Guide

• Cisco Media Gateway Controller Software Release 9 Operations, Maintenance, and 
Troubleshooting Guide 

• Cisco Media Gateway Controller Hardware Installation Guide

• Cisco Media Gateway Controller Software Release 9 Billing Interface Guide 

• Cisco MGC Software Release 9.3(2) Feature Modules 

• Cisco Media Gateway Controller Management Information Base (MIB) Guide 

• Cisco Signaling Link Terminal 

• Cisco Billing and Measurements Server, Release 2 and Cisco Billing and Measurements Server, 
Release 3.10

• H.323 Signaling Interface Guide

• Cisco Media Gateway Controller Software Release 9 Solutions, with link to solution documentation 
at http://www.cisco.com/univercd/cc/td/doc/product/access/sc/rel9/soln/index.htm.

• Cisco Media Gateway Controller Sofware Master Index

• Voice Services Provisioning Tool Release User’s Guides for Version 2.1 through 2.4(1)

• Release Notes for the Cisco Media Gateway Controller Software Release 9. Includes Release Notes 
for Version 9, Cisco MNM 2.x, and VSPT 2.x, Solaris 2.6 and 8, and HSI 2.20.

If you are using Cisco MGC Release 7, you can find documentation at 
http://www.cisco.com/univercd/cc/td/doc/product/access/sc/rel7/index.htm. 

Documentation Map
Figure 1 shows the sequence in which the various manuals documenting Cisco telephony solutions 
should be read.
viii
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Obtaining Documentation
Figure 1 Documentation Map

Obtaining Documentation
The following sections explain how to obtain documentation from Cisco Systems.

World Wide Web
You can access the most current Cisco documentation on the World Wide Web at the following URL:

http://www.cisco.com
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Obtaining Technical Assistance
Translated documentation is available at the following URL:

http://www.cisco.com/public/countries_languages.shtml

Documentation CD-ROM
Cisco documentation and additional literature are available in a Cisco Documentation CD-ROM 
package, which is shipped with your product. The Documentation CD-ROM is updated monthly and may 
be more current than printed documentation. The CD-ROM package is available as a single unit or 
through an annual subscription.

Ordering Documentation
Cisco documentation is available in the following ways:

• Registered Cisco Direct Customers can order Cisco product documentation from the Networking 
Products MarketPlace:

http://www.cisco.com/cgi-bin/order/order_root.pl

• Registered Cisco.com users can order the Documentation CD-ROM through the online Subscription 
Store:

http://www.cisco.com/go/subscription

• Nonregistered Cisco.com users can order documentation through a local account representative by 
calling Cisco corporate headquarters (California, USA) at 408 526-7208 or, elsewhere in North 
America, by calling 800 553-NETS (6387).

Documentation Feedback
If you are reading Cisco product documentation on Cisco.com, you can submit technical comments 
electronically. Click Leave Feedback at the bottom of the Cisco Documentation home page. After you 
complete the form, print it out and fax it to Cisco at 408 527-0730.

You can e-mail your comments to bug-doc@cisco.com.

To submit your comments by mail, use the response card behind the front cover of your document, or 
write to the following address:

Cisco Systems
Attn: Document Resource Connection
170 West Tasman Drive
San Jose, CA 95134-9883

We appreciate your comments.

Obtaining Technical Assistance
Cisco provides Cisco.com as a starting point for all technical assistance. Customers and partners can 
obtain documentation, troubleshooting tips, and sample configurations from online tools by using the 
Cisco Technical Assistance Center (TAC) Web Site. Cisco.com registered users have complete access to 
the technical support resources on the Cisco TAC Web Site. 
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Obtaining Technical Assistance
Cisco.com
Cisco.com is the foundation of a suite of interactive, networked services that provides immediate, open 
access to Cisco information, networking solutions, services, programs, and resources at any time, from 
anywhere in the world. 

Cisco.com is a highly integrated Internet application and a powerful, easy-to-use tool that provides a 
broad range of features and services to help you to

• Streamline business processes and improve productivity 

• Resolve technical issues with online support

• Download and test software packages

• Order Cisco learning materials and merchandise

• Register for online skill assessment, training, and certification programs

You can self-register on Cisco.com to obtain customized information and service. To access Cisco.com, 
go to the following URL:

http://www.cisco.com

Technical Assistance Center
The Cisco TAC is available to all customers who need technical assistance with a Cisco product, 
technology, or solution. Two types of support are available through the Cisco TAC: the Cisco TAC 
Web Site and the Cisco TAC Escalation Center.

Inquiries to Cisco TAC are categorized according to the urgency of the issue:

• Priority level 4 (P4)—You need information or assistance concerning Cisco product capabilities, 
product installation, or basic product configuration.

• Priority level 3 (P3)—Your network performance is degraded. Network functionality is noticeably 
impaired, but most business operations continue.

• Priority level 2 (P2)—Your production network is severely degraded, affecting significant aspects 
of business operations. No workaround is available.

• Priority level 1 (P1)—Your production network is down, and a critical impact to business operations 
will occur if service is not restored quickly. No workaround is available.

Which Cisco TAC resource you choose is based on the priority of the problem and the conditions of 
service contracts, when applicable.

Cisco TAC Web Site

The Cisco TAC Web Site allows you to resolve P3 and P4 issues yourself, saving both cost and time. The 
site provides around-the-clock access to online tools, knowledge bases, and software. To access the 
Cisco TAC Web Site, go to the following URL:

http://www.cisco.com/tac

All customers, partners, and resellers who have a valid Cisco services contract have complete access to 
the technical support resources on the Cisco TAC Web Site. The Cisco TAC Web Site requires a 
Cisco.com login ID and password. If you have a valid service contract but do not have a login ID or 
password, go to the following URL to register:

http://tools.cisco.com/RPF/register/register.do
xi
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If you cannot resolve your technical issues by using the Cisco TAC Web Site, and you are a Cisco.com 
registered user, you can open a case online by using the TAC Case Open tool at the following URL:

http://www.cisco.com/tac/caseopen

If you have Internet access, it is recommended that you open P3 and P4 cases through the Cisco TAC 
Web Site.

Cisco TAC Escalation Center

The Cisco TAC Escalation Center addresses issues that are classified as priority level 1 or priority 
level 2; these classifications are assigned when severe network degradation significantly impacts 
business operations. When you contact the TAC Escalation Center with a P1 or P2 problem, a Cisco TAC 
engineer will automatically open a case.

To obtain a directory of toll-free Cisco TAC telephone numbers for your country, go to the following 
URL:

http://www.cisco.com/warp/public/687/Directory/DirTAC.shtml

Before calling, please check with your network operations center to determine the level of Cisco support 
services to which your company is entitled; for example, SMARTnet, SMARTnet Onsite, or Network 
Supported Accounts (NSA). In addition, please have available your service agreement number and your 
product serial number.

Document Change History
Table 2 Change History

Subject Document #, Change Date Change Summary

Updated to document features 
new in MNM-PT 2.4(1) 

OL-3871-01, June, 2003 Updated to document features new in Cisco MGC 
software release 9.4(1) and to reflect name change and 
tighter integration with Cisco MGC Node Manager.

Updated to document features 
new in VSPT 2.3(2)

OL-3541-01, December 05, 
2002

Updated to document features new in Cisco MGC 
software release 9.3(2).

Updated to document features 
new in VSPT 2.3(1)

OL-1910-02, July 30, 2002 Updated to document HSI adjunct, 6509 LAN Switch, 
and integrated SLT.

Initial release, VSPT 2.2 OL-1910-01, February 15, 2002 Initial online release
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Cisco MGC Node Manager Provisioning Tool 
Overview

Cisco Open Packet Telephony (OPT) provides the framework for delivering voice services over 
packet-based data, voice, and video networks. OPT encompasses a broad range of hardware platforms 
and Cisco software, delivering a continuum of voice solutions from core infrastructure to enhanced 
services over circuit and packet networks. The Cisco Media Gateway Controller (MGC) is at the center 
of Cisco OPT solutions.

Provisioning a Cisco MGC is the process of preparing it to communicate with an SS7 network, with 
Cisco media gateways, and with the other components of an OPT solution. The Cisco MNM 
Provisioning Tool (MNM-PT) provides an easy-to-use graphical tool to provision Cisco MGCs. 

Individual releases of the MNM-PT are designed to be used with specific releases of the Cisco MGC 
software. MNM-PT Version2.4(1) is designed to be used with Cisco MGC Version 9.4(1). If you are 
using a different release of the Cisco MGC software, see the Installation Guide Table 1-1 to identify the 
release of MNM-PT that you need.

This chapter introduces the MNM-PT and provides directions for obtaining, installing, and using the 
software. 

This chapter contains the following sections:

• Provisioning Introduction, page 1-13

• MNM-PT Introduction, page 1-14

• MNM-PT Basics, page 1-15

• Starting the MNM-PT, page 1-18

• Using the MNM-PT, page 1-19

• Defining Users and Permissions, page 1-22

• Exiting the MNM-PT, page 1-23

Provisioning Introduction
All solutions involving the Cisco MGC are configured through the use of one or more Cisco MGC hosts, 
one or more Signaling System 7 (SS7) network signaling options, and one or more media gateways that 
control bearer-traffic routing. 
1-13
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Chapter 1      Cisco MGC Node Manager Provisioning Tool Overview
MNM-PT Introduction
Note In this document, a solution is a logical combination of Cisco hardware and software configured to 
perform a specific network task.

Prior to starting any provisioning session, you should have a clear understanding of the network topology 
for your solution. Create a network drawing, and refer to it while configuring your network.

In addition, you should perform the following tasks before starting a provisioning session:

• Thoroughly plan your network configuration. Refer to the documentation for your solution for 
detailed network configuration information.

• Set up your system hardware, and install all required software. For more information, refer to 
Prerequisites in Chapter 1 of the Installation Guide, and the Cisco Media Gateway Controller 
Software Version 9 Installation and Configuration Guide at

http://www.cisco.com/univercd/cc/td/doc/product/access/sc/rel9/swinstl/index.htm

MNM-PT Introduction
The MNM-PT allows you to import an existing configuration, modify the configuration, and export it to 
the same or different devices. The MNM-PT can also facilitate provisioning of individual call 
parameters, simplifying the provisioning of a large live network.

Using the MNM-PT helps avoid common errors that might arise if devices are provisioned 
independently, eliminates the need to enter duplicate data, and enables importing and exporting 
configurations to and from the Cisco PGW 2200. The MNM-PT generates configuration files necessary 
to provision the PGW 2200, including the following provisioning information:

• Signaling

• Trunk groups

• Trunks

• Routes

• Dial plans

The MNM-PT also allows provisioning Cisco Media Gateways (MGX), specifically the Cisco MGX 
8850 with the Voice Interworking Service Module (VISM) Version 3.1. With the MNM-PT, you can 
carry out Cisco MGX 8850 chassis provisioning tasks and VISM provisioning tasks.

During a provisioning session, the MNM-PT automatically generates the Man Machine Language 
(MML) or command line interface (CLI) scripts used to configure network elements, assembles these 
commands into a batch file, and deploys the file to the appropriate network device. 

The MNM-PT allows scheduled backups and restores of configurations on the following devices:

• The Cisco MGC host (active configuration)

• BAMS Phase 3 (active configuration of the system, plus eight nodes)

• The Cisco SLT 2600 (running configuration and image on flash)

• The Cisco Catalyst 5500 (configuration and image on flash)

• The Cisco Catalyst 2900XL (running configuration and image on flash)

MNM-PT can be installed with the CSCOk9000 package to support secure communications to 
SSH-enabled devices, the Cisco MGC host, the BAMS server, or the HSI server. The following 
operations all can use SSH: 
1-14
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Chapter 1      Cisco MGC Node Manager Provisioning Tool Overview
MNM-PT Basics
• Provisioning of an SSH-enabled Cisco PGW 2200

• Launching of ssh rather than Telnet for communicating with SSH-enabled network devices through 
a command-line interface

• Use of SSH to secure X windows communications with the end-user display device

• Use of SSH in place of Telnet for the initial step (logging into the component to be backed up and 
getting the configuration) in a backup and restore operation. The ccnfiguration is copied to a TFTP 
server using standard TFTP.

The MNM-PT can be deployed as an integrated component of the Cisco MGC Node Manager or as a 
standalone application. If it is installed on the Cisco MGC, call throughput might be impacted when the 
MNM-PT is active. It typically runs on a standalone UNIX server that is also running the Cisco MGC 
Node Manager (Cisco MNM) and supports multiple users and provisioning sessions. You can launch the 
MNM-PT from the managed object icon in the Cisco MNM Map Viewer. For information about Cisco 
MNM, refer to the Cisco MGC Node Manager User’s Guide Version 2.4(1) at
http://www.cisco.com/univercd/cc/td/doc/product/access/sc/rel9/cmnm241/index.htm

This document is designed to help you get started using the MNM-PT, and does not include complete 
provisioning instructions, which are found in the Cisco Media Gateway Controller Software Version 9 
Provisioning Guide at
http://www.cisco.com/univercd/cc/td/doc/product/access/sc/rel9/prvgde/index.htm, in particular 
Chapter 3, Provisioning with the Voice Services Provisioning Tool at

http://www.cisco.com/univercd/cc/td/doc/product/access/sc/rel9/prvgde/r9gui.htm

Detailed instructions for provisioning dial plans are covered in the Cisco Media Gateway Controller 
Software Version 9 Dial Plan Guide at
http://www.cisco.com/univercd/cc/td/doc/product/access/sc/rel9/dplan/index.htm, in particular Chapter 
3, “Provisioning Dial Plans with the VSPT”, at
http://www.cisco.com/univercd/cc/td/doc/product/access/sc/rel9/dplan/dp_vspt.htm

MNM-PT Basics
This section describes the requirements for entering provisioning data using the VSPT.

MNM-PT Field Definitions
Table 1-1 lists MNM-PT field names, which correspond to system components in the Cisco MGC, and 
their definitions. For more information about system components, refer to the Cisco Media Gateway 
Controller Software Version 9 Provisioning Guide.

[this table is not a comprehensive list of provisioning components but a list and description of the major 
fields displayed in the MGC Config window]

.

Table 1-1 Field Name Definitions

Field Name Definition

MGCP1 Signaling 
Service

An MGCP signaling service is a signaling service between the Cisco MGC 
and a media gateway. 

IP Link for MGCP An IP Link for MGCP is a link for the MGCP signaling services.
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MGC Host An origination point code (OPC) is the address of the Cisco MGC you are 
provisioning.

Interfaces Hardware card provisioning for the Ethernet cards in the Cisco MGC host.

Point Codes

Originating Point 
Code

An originating point code (OPC) is the address for the Cisco MGC.

Adjacent Point Code An adjacent point code (APC) is the address of an STP2 that sends and 
receives signaling messages to and from the Cisco MGC.

Destination Point 
Code

A destination point codes (DPC) is the address of an endpoint, such as a 
PSTN3 switch that carries the bearer traffic.

Routing Keys

M3UA Route Key A Transpath NE component that represents the M3UA Routing key, a child of 
an OPC.

SUA Route Key A Transpath NE component that represents an SUA Routing key, a child of an 
OPC.

LinkSet A LinkSet is a set of links from the MGC to an endpoint, such as an adjacent 
STP.

SS7 Subsystem) A logical connection between a pair of mated STPs that allows the 
Cisco MGC to route through either STP to an endpoint.

ISUP Timer Profile ISDN User Part (ISUP) timer profile provisioned for signaling service.

INservice Intelligent network services table; can be changed at any time and is 
dynamically reconfigurable. 

SS7 Path (SS7 
Signaling Service)

An SS7 path is a connection between the Cisco MGC and a specified point 
code.

SS7 Route An SS7 route is a route for each signaling path from the Cisco MGC to the 
PSTN switch through the linksets you have created to the STPs.

IP Route A static IP route.

M3UA Route An M3UA route is a route for each signaling path from the Cisco MGC to the 
PSTN switch through the SGNode using M3UA.

SUA Route An M3UA route is a route for each signaling path from the Cisco MGC to the 
PSTN switch through the SGNode using M3UA.

SS7 Signaling 
Gateway

SS7 Signaling gateway

SS7 SG Nodes SS7 signaling gateway nodes

SS7 SG 
Subsystem

SS7 signaling gateway subsystem.

SS7 SG Pairs SS7 signaling gateway pair

SS7 SG Sigpaths SS7 service to a signaling gateway 

Line Number 
Translation

Line number translation represents a line number and internal number 
translation.and is dynamically reconfigurable.

Table 1-1 Field Name Definitions (continued)

Field Name Definition
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SIP SIP (session initiation protocol) service, the connection between an MGC and 
a SIP server. 

Auto Congestion Ctrl

Response 
Category

Auto Congestion Control response categories that may be associated with a 
trunkgroup (MGC configuration) or a signalling path (SC configuration).

MCL Threshold Definition of onset and abate values of different contibuting factors for 
Machine Congestion Lavel(MCL).

MCL Callreject The definition of call reject percentage in different machine congestion levels 
(MCL)

Advice of Charge

Holiday Holiday table that provides the capability to distinguish specific days of the 
year and charge them differently from the actual day of the week that the 
holiday falls on.

Charge Charge table that defines the tariff rates (table index key for tariff.dat) and 
their durations.

Tariff Tariff table contains the tariff rates and scale factors. Each row is referenced 
by a tariff id which call processing will obtain by accessing the Charge table.

GTD Parameters GTD (generic transparency descriptor) transports ISUP messages and 
parameters, using a generic format, between the ingress and egress Cisco 
PGW 2200 Signaling Controllers..

External Node An external node is any object in the network that is connected to the 
Cisco MGC, for example, media gateways (Cisco MGWs) and associated 
BSCs4.

ITP ITP (Internet Transfer Point), a signaling gateway to the SS7 network

DPNSS DPNSS5 signaling path that is backhauled over IP to/from a Network Access 
Server (destination).

Association An SCTP6 association represents the connection between the Cisco MGC and 
a Cisco access server.

SGP Signaling gateway process

EISUP EISUP signaling service or signaling path, the signaling path to an externally 
located MGC (destination).

C7 IP Link A link to the SS7 network (for example, an SSP7 or STP) from the Cisco MGC 
through a Cisco SLT.

Sessionset A pair of backhaul IP links used on the PGW, used to communicate with 
external nodes that support IPFAS or BSMV0.

NASPath Network access server (NAS) signaling path, the Q.931 protocol path between 
the MGC and the media gateway

1. MGCP = Media Gateway Control Protocol.

2. STP = signal transfer point.

3. PSTN = Public Switched Telephone Network.

4. BSC = Broadband Service Card.

5. Digital Private Network Signaling System

Table 1-1 Field Name Definitions (continued)

Field Name Definition
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MNM-PT Data Entry Requirements
When you are entering data into the MNM-PT windows, follow standard MML conventions for names 
and descriptions. Each MML name must have the following characteristics:

• A maximum of 20 alphanumeric characters, including dashes

• No space, underscore, or special characters

• Must start with an alphabetic character

For example: name="dpc1"

MML descriptions can be as many as 128 characters and can include spaces and symbols. You should 
use a description that helps to identify the component or link that you are provisioning. For example, for 
an SS7 route, which indicates the signaling path from the Cisco MGC to a switch through a linkset, you 
could create a description “SS7 Route to PSTN Switch A through Linkset 1.” For more information 
about MML, refer to the Cisco Media Gateway Controller Software Version 9 MML Command Reference 
Guide.

The MNM-PT GUI enables you to step through the provisioning process in a logical sequence. The 
sequence of steps is described in the Cisco Media Gateway Controller Software Version 9 Provisioning 
Guide.

Starting the MNM-PT

Note See the Cisco Media Gateway Controller Software Version 9 Installation and Configuration Guide for 
information on setting up user privileges and access rights.

Perform the following steps to start the MNM-PT:

Step 1 Do one of the following:

• To start MNM-PT from Cisco MGC Node Manager, in the Map Viewer, right-click a Cisco MGC 
host and choose Tools > Provisioning Tool.

• To start MNM-PT standalone:

– Log in to the MNM-PT server or access it from a machine with X window capability.

– In a terminal window, change to the default directory:

>cd /opt/CSCOvsp24

– Navigate to the appropriate directory if you installed the MNM-PT in a different location.

– Enter the following command to start the MNM-PT:

>./vspt

The login screen shown in Figure 1-1 appears.

6. SCTP = Stream Control Transmission Protocol

7. SSP = service switching point.
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Figure 1-1 Login Screen

Step 2 Enter your user name and password and click OK.

The default user uame is admin, and the password is also admin. 

The Welcome screen is displayed briefly during the login process, and the main window appears (see 
Figure 1-2).

Figure 1-2 Main MNM-PT Window

Using the MNM-PT
This section describes the MNM-PT menus and Configuration Editor views, and provides directions for 
using the tool functions.

Menus
The MNM-PT menu bar contains these menus:
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• File

• View

• Tools

• Help

These menus are described in the following sections.

File Menu

Table 1-2 describes File menu commands.

View Menu

Table 1-3 describes View menu commands.

Table 1-2 File Menu commands

Command Description

New Begin a new configuration session

Open Open an existing configuration

Import Import an existing configuration from an MGC, or import trunk group, 
trunk, routing, or dial plan files into the MNM-PT

Export Export configuration files from the MNM-PT to a specified directory

Save Save the current configuration:

• As Working: Use to save a new configuration, either a 
configuration imported from the Cisco PGW or a configuration 
created in MNM-PT, and to save modifications to an existing 
configuration, overwriting the last version. The configuration is 
saved in the /var/opt/CSCOvsp24/data/mgc/mistral directory.

• As Snapshot: Use to save modifications to an existing 
configuration under a new name in the ARCHIVE directory. The 
snapshot configuration is saved in 
/var/opt/CSCOvsp24/data/mgc/mistral/<configname>/ARCHIVE

• As New Config: Use to save a modified configuration under a new 
name, leaving the original intact. 

Exit Stop any open provisioning sessions and close the MNM-PT.

Table 1-3 View Menu commands

Command Description

MML Show generated MML for the current configuration

MGW Commands Show generated Cisco MGX 8850 commands for the current 
configuration.

Trunk Group File Show generated trunk group file for the current configuration

Trunk File Show generated trunk file for the current configuration
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Tools Menu

Table 1-4 describes Tools menu commands.

Help Menu

Table 1-5 describes Help menu commands.

Configuration Editor Views
You create, view, and modify configurations using the MNM-PT Configuration Editor, which has three 
different views. Select a view by clicking one of the radio buttons at the top of the Configuration Editor 
window:

Table 1-4 Tools Menu commands

Command Description

Integrity Check Check your configuration for inconsistencies and missing information

Deploy Move the configuration to one or more target hosts and Cisco media gateways 
(MGWs)

Telnet Open a Telnet or SSH session

MGC Viewer View, activate, remove, and synchronize configurations on the MGC.

BAMS Config View and configure a Billing and Measurements Server (BAMS). Refer to the 
Billing and Measurements Server User’s Guide for your release of BAMS for 
information about BAMS configuration.

State Operation View and configure the state of MGC components.

Screening Editor View and configure screening number provisioning. Refer to the Cisco MGC 
Software Version 9 Dial Plan Guide for information about using the VSPT 
Screening Editor.

Audit Audit bearer trunk information between the Cisco MGC and the BAMS.

Backup and Restore Create, modify, or delete scheduled backups or restores on the Cisco MGC Host, 
Catalyst 2900XL, Catalyst 5500, Catalyst 6509, SLT 2600, BAMS P3, and HSI 
server components. 

Administrators:

Change Password Change your password.

User 
Administration

Add, modify, or delete users.

Table 1-5 Help Menu commands

Command Description

MNM-PT User 
Guide

View a local version of the MNM-PT User Guide.

About MNM-PT View information about the current version of MNM-PT, including the software 
release number.
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• MGC Config—MGC Configuration view. Use to add components and provision component 
properties.

• Traffic—Traffic view. Use to create customer-specific files, including trunk groups, trunks, and 
routing.

• Number Analysis—Number Analysis view. Use to provision dial plans.

In each view, the left pane displays selectable components in an Explorer-type tree view. The right pane 
displays data entry fields for the selected component. Click a component to select it. To see all of the 
subcomponents for the component you select, click the icon next to the component name to expand the 
component list.

Note For instructions for using the MNM-PT to provision components, component properties, trunk groups, 
trunks, and routing, refer to the Cisco Media Gateway Controller Software Version 9 Provisioning 
Guide. For instructions for using the MNM-PT to provision a dial plan, refer to the Cisco Media Gateway 
Controller Software Version 9 Dial Plan Guide.

Defining Users and Permissions
After you install the MNM-PT, you define users and their respective permissions using the following 
procedure:

Step 1 Log in to the server as root. 

Step 2 Start MNM-PT, either by first starting Cisco MGC Node Manager and then starting MNM-PT, or by 
starting it standalone.

Step 3 Click Tools > User Admin.

The screen in Figure 1-3 appears.
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Figure 1-3 MNM-PT User Administration

Step 4 To add a user, do the following:

• Enter a user name and password.

• From the Permission dropdown list, select the desired permission level, viewer, user, or admin.

• Click Add.

Step 5 To modify a user, select the user name, change the password or permission level, and click Modify.

Step 6 To delete a user, select the user name, and click Delete.

Exiting the MNM-PT
You can exit the MNM-PT by performing one of these actions:

• Click File > Exit. Click OK at the resulting prompt.

• Click the close box in the upper right of the MNM-PT screen. Click OK at the prompt.
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MNM-PT Utilities

MNM-PT Version 2.4(1) provides utilities to accomplish the following tasks:

• Perform an Integrity Check, page 2-25

• View Generated Output, page 2-28

• View Generated Cisco MGW Commands, page 2-29

• Deploy a Configuration, page 2-30

• Use Telnet or ssh, page 2-35

• MGC Viewer, page 2-36

• State Operation, page 2-38

• P, page 2-39

• Back Up and Restore, page 2-41

Perform an Integrity Check
When provisioning is complete, you can perform an integrity check to prevent possible configuration 
errors. You can check one or all of the following:

• Integrity for the MGC signaling configuration

• Traffic against the MGC configuration

• Dial plan results

Use the following procedure to perform an integrity check of the currently open configuration:

Step 1 Click Tools > Integrity Check. The Integrity Check dialog box appears (Figure 2-1).
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Figure 2-1 Integrity Check

Step 2 Select the tests you want to run: 

• Click Run all tests to run all three tests. See Integrity Check Dialog Box Options below for a 
description of each test.

• To run one or more individual tests, click Run individual tests. All tests are checked. Uncheck the 
tests you do not want to run.

Step 3 Click Start. MNM-PT runs the selected tests.

When the tests finish, a screen similar to the one in Figure 2-2 appears showing the results of the 
integrity checks.
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Figure 2-2 Integrity Check Results

Integrity Check Dialog Box Options
This section describes the options in the Integrity Check dialog box. 

Check Integrity for MGC Signaling Configuration

When you perform an integrity check for MGC signaling configuration, the MNM-PT does the 
following:

• Checks that the hostname is specified for MGC

• Checks that login/passwords are specified for MGC

• Checks that MGC ipaddrs are specified

• Checks that if MGC failover is specified, the failover IPs are specified

• Checks that MGX hostname is specified

• Checks that MGX login/password is specified

• Checks the MGX IPaddrs

• For EXTNODES where the configuration refers to an MGX, checks PeerAddrs on IPLNK to ensure 
that they are addresses on the specified MGX

• For IPFAS IPLNK:

– Ensures that SigSlot/SigPort is specified
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– Checks SigSlot/SigPort on MGX to ensure that the values are valid as specified on the MGX 

– Ensures that MGC ports and MGX ports match on the IPLNK

– Checks that all IPLNK under a single IPFASPATH map to the same port number 

Note The number of IPFAS sessions using a given port is displayed because some IPLNKs might use different 
port IDs.

Note After Cisco MGC Version 9.3(2) and MNM-PT Version 2.3(2), IPFAS signaling services apply only to 
the VISM card.

Check Traffic Against MGC Configuration

When you perform an integrity check of traffic against the MGC configuration, the MNM-PT does the 
following:

• When D-channels are defined as FAS and NFAS PRI in the trunk group/trunk section, verifies that 
there are corresponding IPFASPATH signaling services with corresponding IPLNKs

• Checks if there are any defined IPFASPATH signaling services defining a D-channel but no 
corresponding trunk group/trunk in the traffic information with a corresponding NFAS/FAS PRI.

• Checks that signaling services defined for trunk groups exist in the configuration

Check Dial Plan Results

The dial plan integrity check validates that the route names used within the dial plan route results 
actually exist on the traffic side.

Background Information

In the dial plan, the Bdigittree maps a called digit string to select the desired result. For the Bdigittree, 
the digit string indicates what it should do when a call destined for the number xxx-xxxx is received. 
The selected value identifies what to do with the call. The result set contains results (processing actions 
for the call). One of the results can be a route result. Associated with the route result is the name of a 
route (from the traffic branch) that shows the trunk groups that exist within a route. This implies that the 
call should be routed onto the specified route and routed onto one of the trunk groups within the route.

View Generated Output
The MNM-PT automatically generates output of various types which you can view using View menu 
commands:

• Generated MML commands

• Generated Cisco MGW commands

• Trunk group file

• Trunk group
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View Generated MML Commands
MNM-PT automatically generates MML commands to provision your Cisco MGC and saves these 
commands in a file to be executed when you deploy the configuration. 

To view the MML commands generated from your MNM-PT provisioning session, click View > MML.

A screen displaying generated MML, similar to the one shown in Figure 2-3, appears.

Figure 2-3 First Generated MML Screen

View Generated Cisco MGW Commands
To view the Cisco  MGW commands generated from your provisioning session, click View > MGW 
Commands on the main MNM-PT menu bar. A screen with generated Cisco MGW commands, similar 
to that shown in Figure 2-4, appears.
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Figure 2-4 Example of Generated Cisco MGW Commands

Deploy a Configuration
When you finish defining a configuration, you must deploy that configuration to the Cisco MGC. You 
can deploy to the Cisco MGC alone, to the Cisco MGC and one or more gateways, or to gateways only.

Note A new configuration should not be deployed during times of peak load on the Cisco MGC. 

A configuration created in MNM-PT can be deployed to a Cisco MGC as a new configuration or 
incrementally. Deploying incrementally allows you to more quickly deploy modifications to an existing 
configuration without having to redeploy the entire configuration. MNM-PT also allows you to visually 
check the incremental commands it generates before deploying those commands to the MGC.

If the Cisco MGC has SSH enabled, you should deploy the configuration using the SSH protocol.

Deploying a New Configuration
Use the following procedure to deploy a new configuration.

Note If you want to delete a component and plan to reuse the component name, first delete the component, 
deploy the session, and verify that the component name has been deleted before reusing the name.
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Step 1 Click Tools > Deploy on the main MNM-PT menu bar ( see Figure 1-3 on page 1-12). The Protocol 
Options dialog box appears.

Step 2 Select the desired protocol:

• Choose SSH if SSH is enabled on the device.

• Choose None if SSH is not enabled on the device. 

The screen shown in Figure 2-5 appears.

Figure 2-5 Deploying a Configuration

Step 3 Indicate how you want to deploy the configuration:

• To deploy to the Cisco MGC only, do one of the following: 

– If you want to send the configuration to the MGC but not activate it, click the button next to 
Send Configuration to MGC Only.

– If you want to send the configuration to the MGC and activate it, click the button next to Send 
and Activate Configuration.

– If you have a continuous-service configuration with two Cisco MGC hosts, click the button next 
to Send, Activate and Synchronize failover. The configuration is saved on the active host and 
copied to the standby host. You must restart the standby server after reconfiguration to apply 
changes.

• To deploy to the Cisco MGC and one or more selected gateways, select one of the above three 
options and in Step 4 also select one or more gateways from the list in Specify media gateways for 
deployment. 

• To deploy to selected gateways only (and not the Cisco MGC): Check the box next to Do not deploy 
to MGC and in Step 4 select one or more gateways from the list in Specify media gateways for 
deployment. 
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Note If you select an option other than New, the Advanced button is enabled. For information about 
the options this button provides, see the “Configuring an Incremental Deployment” section on 
page 2-33.

Step 4 Select a configuration in the Based on configuration drop-down list. This list displays all existing 
configurations on the selected MGC and the [LAST IMPORT] and [NEW] options.

• Last Import—The MNM-PT compares your provisioning session to the last imported configuration 
and deploys only changes you have made.

Note The LAST IMPORT option allows multiple users to modify an existing configuration. However, 
they must each be modifying a different area of the configuration for this option to work 
properly.

• New—Your entire provisioning session is deployed as a new configuration.

• Existing Configurations—MNM-PT imports the selected configuration from the Cisco MGC, 
compares the differences between that configuration and your current provisioning session, and 
deploys changes you have made.

Note Since you are deploying a new configuration, make sure to choose the New option in the Based 
on configuration drop-down list.

Step 5 Select the gateways you want to deploy, if applicable.

Note To select multiple gateways, you can use standard selection methods: Shift+click to select a 
contiguous range, Ctrl+click to select or deselect noncontiguous gateways.

Step 6 Click OK. The screen shown in Figure 2-6 appears and displays the status as the current provisioning 
session is deployed.
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Figure 2-6 Deployment Progress

Note In a continuous-service configuration, the XECfgParm.dat file on each machine must be configured. If 
you experience problems, verify the integrity of the XECfgParm.dat files on both machines. Refer to 
Chapter 2, “Installing Cisco  Media Gateway Controller Software,” in the Cisco  Media Gateway 
Controller Software Version 9 Installation and Configuration Guide. 

Configuring an Incremental Deployment
An incremental deployment allows you to modify an existing configuration and deploy only the 
modified areas to the Cisco MGG. Modifications can be made more quickly, and errors affecting 
unmodified areas are minimized. In addition, provisioning modifications made by other users in separate 
areas are not affected.

Note The Cisco MGC does not support some incremental deployment processes. If you have a problem with 
an incremental deployment, examine the MML commands to ensure that you have properly configured 
the desired components. Modify the component presenting the problem, or cancel the deployment and 
redeploy the component as a new configuration.

Use the following procedure to configure an incremental deployment:

Step 1 Follow Step 1 through Step 5 in the “Deploying a New Configuration” section on page 2-30.

Step 2 Click Advanced in the window shown in Figure 2-5. The screen shown in Figure 2-7 appears.
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Figure 2-7 Incremental Deployment Component Selector

If you have only made configuration changes to one or more of the areas listed, you can direct the 
MNM-PT to compare only those areas with the current configuration, and your modifications can be 
deployed more quickly.

Note If you select areas in this window, make sure to include all areas that you have modified. 

Step 3 Select one or more component types to deploy, and click OK.

Step 4 Go to Step 7 in the “Deploying a New Configuration” section on page 2-30, and complete the procedure 
described there. When you click OK, a screen similar to the one displayed in Figure 2-8 appears.
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Figure 2-8 Confirm MML Commands

Step 5 Inspect the MML commands, modify them if desired, and click Yes to continue with the incremental 
deployment. Click No to reissue the deployment as a new configuration.

Use Telnet or ssh
MNM-PT provides a utility to open a Telnet session directly to a device. Once you have established your 
Telnet connection, you then log in to the device and execute commands remotely on the device through 
the Telnet interface.

If you have installed SSH for MNM-PT and the remote device also supports SSH, you can select the ssh 
utility instead of Telnet.

Use the following procedure to open a Telnet or ssh session with a network device:

Step 1 Click Tools > Telnet. A screen similar to that shown in Figure 2-9 appears.
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Figure 2-9 Select Remote Network Device

Step 2 Select the device and connection method:

• Select a device from the dropdown list, or enter the name or IP address of a device on your network.

• Select the connection method, SSH (if the device supports it) or None for Telnet. 

• Click Go.

A Telnet or SSH window opens for you to log in to the device.

MGC Viewer
The MGC Viewer allows you to view, activate, remove, and synchronize configurations on the MGC. If 
you are communicating with an SSH-enabled Cisco MGC, you can use SSH instead of Telnet for the 
communication.

Use the following procedure to view configurations on a Cisco MGC:

Step 1 Click Tools > MGC viewer on the main MNM-PT menu. On the MGC Configuration screen that 
appears, click File > Open MGC. The Protocol Options dialog box appears.

Step 2 Select the desired protocol:

• Choose SSH if SSH is enabled on the device.

• Choose None if SSH is not enabled on the device. 

A screen similar to the one in Figure 2-10 appears.
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MGC Viewer
Figure 2-10 Select MGC

Step 3 Enter the host name of the MGC in the Hostname box, enter the MGC login and password, and click 
OK. A screen similar to the one in appears and lists all configurations on the specified MGC.

Step 4 Click Configuration on the MGC Viewer menu bar, and select one of the following actions:

Activate—Choose to activate the configuration.

Synchronize—Choose to synchronize with the current configuration.

Delete—Choose to delete the configuration.
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State Operation
The State Operation utility provides the ability to query the active configuration on the Cisco MGC for 
the state of managed objects. After a query, you can modify the state of an object and apply the update 
to the MGC. If you are querying the state of an SSH-enabled Cisco MGC, you can use SSH instead of 
Telnet for the communication.

Use the following procedure to query the state of managed objects on the Cisco MGC:

Step 1 Click Tools > State Operation on the main MNM-PT menu. The Protocol Options dialog box appears.

Step 2 Select the desired protocol:

• Choose SSH if SSH is enabled on the device.

• Choose None if SSH is not enabled on the device. 

A screen similar to the one in Figure 2-11 appears.

Figure 2-11 State Operation Dialog

Step 3 Click OK. The MNM-PT queries the MGC and a screen similar to the one in Figure 2-12 appears.
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Figure 2-12 MGC Managed Objects

Step 4 Expand the hierarchical tree in the left pane of the State Operations window to locate and highlight the 
object for which you want to know the state. In this example, we will display the state of linkset2. A 
window similar to the one in will appear and the right pane will display information about the state of 
the object you selected.

Figure 2-13 State Operations

Step 5 From this window, you can modify the state by selecting the desired state in the ChangeTo box. Click 
Modify to change the state in this window, and click Commit to change the state on the Cisco MGC. To 
query the object again, click Refresh.

P
erform an Audit
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You can use an audit to ensure that both the Cisco MGC and a BAMS server supporting the Cisco MGC 
host have consistently configured signal paths. The audit involves examines signal path and bearer 
channel data on both servers, comparing the data, and reporting any differences. If you are auditing an 
SSH-enabled Cisco MGC, you can use SSH instead of Telnet for the communication.

Use the following procedure to perform an audit:

Step 1 Click Tools > Audit. The Protocol Options dialog box appears as shown in Figure 2-14.

Figure 2-14 Protocol Options Dialog Box

Step 2 Select the desired communication protocol, SSH (if SSH is installed on MNM-PT and on the devices 
you are auditing) or None (uses Telnet). Click OK. The Audit Dialog Box appears.

Step 3 Enter the MGC hostname, login, and password in the top pane of the window.

Step 4 To specify the configuration to audit, click Select, highlight the configuration to audit, and click OK.

Step 5 Enter the BAMS hostname, login, and password in the bottom pane of the window.

Step 6 To specify the configuration to audit, click Select, highlight the configuration to audit, and click OK.

Step 7 Click Audit. A screen similar to the one displayed in Figure 2-15 appears.
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Figure 2-15 Audit Results

The left pane displays the signal path and bearer channel data configured on the MGC host, and the right 
pane displays the same data configured on the BAMS server.

Back Up and Restore
The MNM-PT backup and restore tool allows you to create, modify, and delete scheduled backups and 
restores hourly, daily, weekly, monthly, or on demand. 

You can perform back up and restore activities on any of the following devices if they have been 
configured for the MGC:

• MGC Host—Active configuration

• CAT5500—Configuration and image in Flash

• CAT2900XL—Running-config and image in Flash

• SLT2600—Running-config and image in Flash

• BAMS P3—Active configuration

• HSI Adjunct Server—Active configuration

The backup and restore tool also provides the status of each activity and generates user-viewable status 
logs.

Backup and restore support using SSH for the log in to the device you are backing up. See Backup and 
Restore Requirements for details.
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Backup and Restore Requirements
You typically use MNM-PT Backup to back up the configuration on Server A (one of the supported 
components) onto a different server, Server B. The configuration can then be restored if needed back to 
Server A, or copied to other components of the same type (Server C, D, etc), as a way to clone a 
configuration.

In the Backup process, MNM-PT logs into Server A, copies the configuration, and transfers it to Server 
B using TFTP. Server B must have the TFTP server enabled. Refer to the Cisco MGC Node Manager 
Installation Guide at http://www.cisco.com/univercd/cc/td/doc/product/access/sc/rel9/emins/index.htm 
for instructions on enabling TFTP.

If you are using SSH on a managed Cisco PGW, BAMS, or HSI server, please keep the following in 
mind:

• The log in to Server A to get the configuration can (and should) be done securely, using SSH. You 
specify the Server A's IP address, Login, and Password, and you select SSH, in the Add ... Schedule 
dialog box when you set up the backup.

• The transfer of the configuration onto Server B is done using TFTP. You also specify Server B's IP 
address, Login, and Password in the Add Schedule dialog box. The TFTP transfer is nonsecure, 
although the password is encrypted.

• The TFTP server on Server A (and any server where SSH is installed) is turned off (along with ftp) 
in conjunction with the CSCOh013 package, and thus configurations cannot be backed up onto such 
a server. Generally you would not want to do this anyway, since it would defeat the purpose of the 
backup operation.

• Although MNM-PT has SSH installed, it uses the CSCOk9000 package only, and not CSCOh013. 
As long as MNM-PT is not on a server where CSCOh013 is installed (such as the PGW server), you 
can back up configurations onto the MNM-PT server.

Schedule a Backup or Restore
To schedule a backup or restore, use the following procedure:

Step 1 Click Tools > Backup and Restore on the main MNM-PT menu bar. The Backup and Restore window 
appears listing components that can have scheduled backups.

Step 2 Click the component for which you want to schedule a backup. In the following example, the MGC 
component configuration is backed up. On the right side of the window, the schedules list for that 
component appears. 

Note If you want to perform a restore, you must have a backup file already created and available on 
the MGC.

Step 3 In the Add/View Schedules pane, click Add. A screen similar to the one shown in Figure 2-16 appears.
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Figure 2-16 Add MGC Schedule

Note The fields available in the dialog box vary according to the component selected. 

Step 4 In the Action field, select the action you want to perform. Choices include Backup and Restore.

Step 5 Enter information for the component you are backing up:

• Enter the IP address of the Cisco MGC.

• Enter the MGC login and password.

Step 6 In the File Name field, enter a name for the backup file.

Step 7 In the File Type drop-down list, select one of the following:

• MGC System—Backs up data files for the active configuration, the Times Ten database, the 
XEconfigParm.dat file, and UNIX configuration files.

• MML Config—Backs up exported MML files for the active configuration on the MGC

Step 8 Enter TFTP information for the server to which you are backing up (destination for the configuration 
file):

• Enter the IP address of the TFTP server.

• Enter the TFTP login and password. 

Step 9 Specify whether or not to use verbose log mode. Verbose mode records all commands issued by the 
MNM-PT and any system responses.

Step 10 Select whether to set up the backup operation using SSH or Telnet (None). 

Note The operation itself is executed with TFTP.

Step 11 Select the schedule type. Choices include:
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• Monthly

• Daily

• Hourly

• Weekly

• Now

• Later

Step 12 Select the protocol to use when connecting to and logging in to the component you are backing up:

• Choose SSH to use ssh.

• Choose None to use Telnet.

Step 13 Select the hour and minute that the backup should begin.

Step 14 Click OK. The backup activity is scheduled, and the scheduled event appears in the schedule list.

After the backup has been completed, the status of the activity is immediately available. The backup file 
with the name you specified is available for use with the MNM-PT.

Check Status of Backup or Restore

The MNM-PT generates status logs that provide information about each scheduled activity. The status 
log displays the following information for the activity:

• Date and time when activity began

• Success or failure

• File name on the TFTP server

• Directory of configuration files

• Image file name 

If you specified verbose log mode, the status log also displays the sequence of commands issued by the 
MNM-PT and any system responses.

Use the following procedure to check the status of a backup or restore activity:

Step 1 In the left pane of the backup and restore tool window, click the device that has been backed up or 
restored. Click the Status tab in the right pane. 

Step 2 Highlight the backup or restore for which you want information.

Step 3 Select the appropriate button for the action you want to perform. Choices are:

• Show status—Displays the log file for the activity.

• Acknowledge—Removes the text from the Status window and deletes the log file from the server.

• Clear—Removes the text from the Status window, but the log file remains on the server.
2-44
Cisco MGC Node Manager Provisioning Tool User’s Guide Version 2.4(1)

OL-3871-01



 

Cisco MGC Node Manager Provision
OL-3871-01
I N D E X
A

adapter

component 16

adjacent point code 16

APC

component 16

B

basics 15

C

C7 IP link

component 17

committing, configuration 31

component

adapter 16

APC 16

C7 IP link 17

external node 17

ExtNode 17

IP link 15

linkset 16

point code 16

SigMGCP 15

SS7 Route 16

SS7 SubSys 16

SS7SubSys 16

configuration

committing 31

deploying 31
D

deploy command 21

deploying, configuration 31

descriptions 18

destination point code 16

E

exit command 20

exiting the MNM-PT 23

ExtNode component 17

F

field definitions 15

field names 15

H

Help menu 20

I

IP link component 15

L

linkset component 16

logging in to the MNM-PT 18

login screen 18
IN-1
ing Tool User’s Guide Version 2.4(1)



 

Index
M

menu

Session 20

View 20

menus 20

MNM-PT

exiting 23

logging in 18

starting 18

MNM-PT basics 15

MNM-PTfield definitions 15

MNM-PT overview 14

N

Number Analysis tab 22

O

origination point code 16

P

point oode component 16

S

secure communication 38

secure communications 14, 39

Session menu 20

SigMGCP component 15

SS7 route

component 16

SS7SubSys component 16

SSH 14, 36, 38, 39

starting

MNM-PT 18
IN-2
Cisco MGC Node Manager Provisioning Tool User’s Guide Version
STP 16

STP, mated pair 16

sync command 20

T

tabs

Number Analysis 22

Telephony Controller 22

Traffic 22

Telephony Controller tab 22

Traffic tab 22

V

View menu 20

X

X windows 18
 2.4(1)
OL-3871-01


	Contents
	Preface
	Document Objective
	Audience
	Document Organization
	Terminology
	Document Conventions
	Documentation Suite
	MNM-PT Release Notes
	Cisco�Media Gateway Controller Node Manager Documentation
	Cisco MGC Documentation
	Documentation Map

	Obtaining Documentation
	World Wide Web
	Documentation CD-ROM
	Ordering Documentation
	Documentation Feedback

	Obtaining Technical Assistance
	Cisco.com
	Technical Assistance Center
	Cisco TAC Web Site
	Cisco TAC Escalation Center


	Document Change History

	Cisco MGC Node Manager Provisioning Tool Overview
	Provisioning Introduction
	MNM-PT Introduction
	MNM-PT Basics
	MNM-PT Field Definitions
	MNM-PT Data Entry Requirements

	Starting the MNM-PT
	Using the MNM-PT
	Menus
	File Menu
	View Menu
	Tools Menu
	Help Menu

	Configuration Editor Views

	Defining Users and Permissions
	Exiting the MNM-PT

	MNM-PT Utilities
	Perform an Integrity Check
	Integrity Check Dialog Box Options
	Check Integrity for MGC Signaling Configuration
	Check Traffic Against MGC Configuration
	Check Dial Plan Results


	View Generated Output
	View Generated MML Commands
	View Generated Cisco�MGW Commands

	Deploy a Configuration
	Deploying a New Configuration
	Configuring an Incremental Deployment

	Use Telnet or ssh
	MGC Viewer
	State Operation
	P
	Back Up and Restore
	Backup and Restore Requirements
	Schedule a Backup or Restore
	Check Status of Backup or Restore



	index

