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Preface

This preface describes the objectives, audience, organization, and conventions of this document. It
contains the following sections:

e Document Objective, page vii

¢ Audience, page viii

¢ Document Organization, page viii

e Terminology, page viii

¢ Document Conventions, page ix

¢ Documentation Suite, page ix

¢ Obtaining Documentation, page x

¢ Obtaining Technical Assistance, page xi
¢ Document Change History, page xiii

Document Objective

This document provides the information you need to install, configure, and use the Voice Services
Provisioning Tool (VSPT), Release 2.3(1). You should read the system-level documentation supplied
with your system before using this guide. A complete list of these documentsis included in the
Cisco Media Gateway Controller Software Release 9 Installation and Configuration Guide that ships
with your system.

Note  This document uses the term media gateway controller software or MGC application to mean the
Cisco MGC software that runs in the UNIX environment on a server. The term MGC refers to the
combination of this software and the server. The Cisco MGC communicates with the SS7 network to
process and route calls between atraditional time-division multiplexing (TDM) network and a packet
data network. This routing takes place through a variety of media gateways, standalone devices that
perform the conversion between the TDM and data network formats.

Note  TheCisco PGW 2200 PSTN Gateway (hereafter referred to asthe Cisco PGW 2200) wasformerly called
the Cisco VSC3000. Some parts of this document might use this older name.

Cisco Voice Services Provisioning Tool Release 2.3(1) User’s Guide
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W Audience

Audience

This document is designed for network operators and administrators who have experience with
telecommunications networks, protocols, and equipment and who have familiarity with data
communications networks, protocols, and equipment. Software and hardware installers and network
designers will also find this document useful.

Document Organization

Table 1 describes the major sections of this document.

Table 1 Document Organization
Chapter Title Description
Chapter 1 Voice Services Provisioning Tool |Thischapter introducesV SPT, Release 2,
Overview and provides directions for obtaining and
installing the software. In addition, it
provides basic information for using the
tool.
Chapter 2 Provisioning with VSPT Wizards | This chapter introduces VSPT wizards
and provides an example of configuring a
Cisco Media Gateway Controller (MGC)
through the use of a wizard.
Chapter 3 Voice Services Provisioning Tool |This chapter introduces additional tools
Utilities included with VSPT Release 2 and
provides directions for using them.
Terminology

The following terms are used in this document:

Cisco MGC host—A Sun host server running Cisco M GC software. If your product isthe Cisco SC2200,

thisis also known as an SC host. If your product is the Cisco PGW 2200, thisis also known asa PSTN
Gateway host.

Cisco SC node—The combination of the Cisco SC2200 product and the control signaling network. The
SC node consists of all solution components except the media gateway.

Cisco MGC node—The logical grouping of the active and standby MGC hosts, the control signaling
network, and the Cisco Signaling Link Terminals (SLTs).

Smplex MGC node—A node that uses a single Cisco MGC host. Typically, nodes of thistype are used
for solution evaluation tests or for small installations. Any loss of servicein the Cisco MGC host disrupts
all call traffic. If your product is the Cisco SC2200, thisis also called asimplex SC node.

Continuous-service MGC node—A node that uses two Cisco MGC hosts to prevent system downtime
that might otherwise result from the failure of asingle MGC host. Callsin progress are maintained when
one MGC host fails. Continuous-service nodes use SLTs to preprocess SS7 signaling and distribute
signaling to both MGC hosts. If afailover occurs, all stable calls are maintained. If your product is the
Cisco SC2200, thisis also called a continuous-service SC node.

Cisco Voice Services Provisioning Tool Release 2.3(1) User’s Guide
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Document Conventions

Notes use the following conventions:

A

Caution = Meansreader be careful. In this situation, you might do something that could result in equipment
damage or loss of data.

~

Note = Means reader take note. Notes contain helpful suggestions or references to material not covered in the
publication.

Documentation Suite

The following documentation provides information about the Cisco MGC software and the solutions it
supports, including the Cisco SS7 Interconnect for Access Servers Solution, the Cisco SS7 I nterconnect
for Voice Gateways Solution, and the Cisco Packet Tandem Solution.

Hardware Documentation

¢ Cisco Media Gateway Controller Hardware Installation Guide
¢ Regulatory Compliance and Safety Information for Cisco Media Gateway Controller Hardware

Software Installation and Configuration Documentation

¢ Cisco Media Gateway Controller Software Release 9 Installation and Configuration Guide
¢ Cisco Media Gateway Controller Software Release 9 Provisioning Guide
¢ Cisco Media Gateway Controller Software Release 9 Dial Plan Guide

¢ Cisco Media Gateway Controller Software Release 9 Operations, Maintenance, and
Troubleshooting Guide

¢ Release Notes for the Cisco Media Gateway Controller Software Release 9
¢ Cisco Media Gateway Controller Online Documentation Notice

¢ Cisco Media Gateway Controller SLT Documentation Notice

Gateway Documentation

Cisco DAS and H.323 Vol P Gateway Installation and Configuration Guide

Documentation Map

Figure 1 shows the sequence in which the various manuals documenting Cisco telephony solutions
should be read.

Cisco Voice Services Provisioning Tool Release 2.3(1) User’s Guide
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Figure 1 Documentation Map
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Obtaining Documentation

The following sections provide sources for obtaining documentation from Cisco Systems.

World Wide Web

You can access the most current Cisco documentation on the World Wide Web at the following sites:

e http://www.cisco.com

[l Cisco Voice Services Provisioning Tool Release 2.3(1) User's Guide

oL-1910-02 |



| Preface

Obtaining Technical Assistance

e http://www-china.cisco.com

e http://www-europe.cisco.com

Documentation CD-ROM

Cisco documentation and additional literature are available in a CD-ROM package, which ships
with your product. The Documentation CD-ROM is updated monthly and may be more current than
printed documentation. The CD-ROM package is available as a single unit or through an

annual subscription.

Ordering Documentation

Cisco documentation is available in the following ways:

¢ Registered Cisco Direct Customers can order Cisco Product documentation from the Networking
Products MarketPlace:

http://www.cisco.com/cgi-bin/order/order_root.pl

¢ Registered Cisco.com users can order the Documentation CD-ROM through the online Subscription
Store:

http://www.cisco.com/go/subscription

¢ Nonregistered Cisco.com users can order documentation through alocal account representative by
calling Cisco corporate headquarters (California, USA) at 408 526-7208 or, in North America, by
calling 800 553-NETS(6387).

Documentation Feedback

If you are reading Cisco product documentation on the World Wide Web, you can submit technical
comments electronically. Click Feedback in the toolbar and select Documentation. After you complete
the form, click Submit to send it to Cisco.

You can e-mail your comments to bug-doc@cisco.com.

To submit your comments by mail, use the response card behind the front cover of your document, or
write to the following address:;

Attn Document Resource Connection
Cisco Systems, Inc.

170 West Tasman Drive

San Jose, CA 95134-9883

We appreciate your comments.

Obtaining Technical Assistance

Cisco provides Cisco.com as a starting point for all technical assistance. Customers and partners can
obtain documentation, troubleshooting tips, and sampl e configurations from online tools. For Cisco.com
registered users, additional troubleshooting tools are available from the TAC website.

[ oL-1910-02
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Cisco.com

Cisco.com is the foundation of a suite of interactive, networked services that provides immediate, open
access to Cisco information and resources at any time, from anywhere in the world. This highly
integrated Internet application is a powerful, easy-to-use tool for doing business with Cisco.

Cisco.com provides a broad range of features and services to help customers and partners streamline
business processes and improve productivity. Through Cisco.com, you can find information about
Cisco and our networking solutions, services, and programs. In addition, you can resolve technical
issues with online technical support, download and test software packages, and order Cisco learning
materials and merchandise. Valuable online skill assessment, training, and certification programs are
also available.

Customers and partners can self-register on Cisco.com to obtain additional personalized information and
services. Registered users can order products, check on the status of an order, access technical support,
and view benefits specific to their relationships with Cisco.

To access Cisco.com, go to the following website:

http://www.cisco.com

Technical Assistance Center

The Cisco TAC website isavailable to all customers who need technical assistance with a Cisco product
or technology that is under warranty or covered by a maintenance contract.

Contacting TAC by Using the Cisco TAC Website

If you have a priority level 3 (P3) or priority level 4 (P4) problem, contact TAC by going to the TAC
website:

http://www.cisco.com/tac
P3 and P4 level problems are defined as follows:

e P3—Your network performanceisdegraded. Network functionality is noticeably impaired, but most
business operations continue.

e P4—You need information or assistance on Cisco product capabilities, product installation, or basic
product configuration.

In each of the above cases, use the Cisco TAC website to quickly find answers to your questions.
To register for Cisco.com, go to the following website:
http://www.cisco.com/register/

If you cannot resolve your technical issue by using the TAC online resources, Cisco.com registered users
can open a case online by using the TAC Case Open tool at the following website:

http://www.cisco.com/tac/caseopen

Contacting TAC by Telephone

If you have a priority level 1 (P1) or priority level 2 (P2) problem, contact TAC by telephone and
immediately open acase. To obtain adirectory of toll-free numbersfor your country, go to the following
website:

Cisco Voice Services Provisioning Tool Release 2.3(1) User’s Guide
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http://www.cisco.com/war p/public/687/Directory/Dir TAC.shtml
P1 and P2 level problems are defined as follows:

P1—Your production network is down, causing a critical impact to business operationsif serviceis
not restored quickly. No workaround is available.

e P2—Your production network is severely degraded, affecting significant aspects of your business
operations. No workaround is available.

Document Change History

Table 2 Change History

Subject Document #, Change Date Change Summary

Updated to document features  |OL-1910-02, July 30, 2002 Updated to document HSI adjunct, 6509 Lan Switch,
new in VSPT 2.3 and integrated SLT.

Initial release OL-1910-01, February 15, 2002 |Initial online release
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Note

CHAPTER 1

Voice Services Provisioning Tool Overview

Cisco Open Packet Telephony (OPT) provides the framework for delivering voice services over
packet-based data, voice, and video networks. OPT encompasses a broad range of hardware platforms
and Cisco software, delivering a continuum of voice solutions from core infrastructure to enhanced
services over circuit and packet networks. The Cisco Media Gateway Controller (MGC) is at the center
of all Cisco OPT solutions.

Provisioning an MGC is the process of preparing it to communicate with an SS7 network, with
Cisco media gateways, and with the other components of an OPT solution. The Cisco Voice Services
Provisioning Tool (VSPT) provides an easy-to-use graphical tool to provision Cisco MGCs.

This chapter introduces the V SPT, Release 2, and provides directions for obtaining, installing, and using
the software.

Individual releases of the V SPT software is designed to be used with specific rel eases of the Cisco MGC.
If you are using Release 7 of the MGC software, you must use VSPT Release 1.6. Refer to Table 1-1to
select the release of VSPT designed for your version of Cisco MGC software.

This chapter contains the following sections:
¢ Provisioning Introduction, page 1-1
e VSPT Introduction, page 1-2
¢ |Installing the VSPT, page 1-2
e VSPT Basics, page 1-8
e Starting the VSPT, page 1-11
e Using the VSPT, page 1-11
¢ Defining Users and Permissions, page 1-14
e Exiting the VSPT, page 1-14

Provisioning Introduction

All solutionsinvolving the Cisco MGC are configured through the use of one or more Cisco MGC hosts,
one or more Signaling System 7 (SS7) network signaling options, and one or more media gateways that
control bearer-traffic routing.

[ oL-1910-02
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I VSPT Introduction

A
Note  In this document, a solutionisalogical combination of Cisco hardware and software configured to
perform a specific network task.

Prior to starting any provisioning session, you should have aclear understanding of the network topol ogy
for your solution. Create a network drawing, and refer to it while configuring your network.

In addition, you should perform the following tasks before starting a provisioning session:

e Thoroughly plan your network configuration. Refer to the documentation for your solution for
detailed network configuration information.

e Set up your system hardware, and install all required software. For more information, refer to
Prerequisites, page 1-5, and the following documents

- Cisco Media Gateway Controller Hardware Installation Guide

- Cisco Media Gateway Controller Software Release 9 Installation and Configuration Guide

VSPT Introduction

The VSPT can be deployed as an integrated component of the Cisco MGC Node Manager or as a
standalone application. If it isinstalled on the Cisco MGC, call throughput might be impacted when the
V SPT isactive. It typically runs on a standalone UNIX server that is also running the Cisco MGC Node
Manager (CMNM) and supports multiple users and provisioning sessions. You can launch the VSPT
from the managed object icon in the CMNM map viewer. For informtion about CMNM, refer to the
CMNM Release 2 User’s Guide.

V SPT allowsyou toimport an existing configuration, modify the configuration, and export it to the same
or different devices. Wizards guide you through high-level configuration steps to create the initial
network provisioning information for a newly installed node, creating iterative entries from asingle
operation. VSPT can also facilitate provisioning of individual call parameters, simplifying the
provisioning of alarge live network.

During a provisioning session, the VSPT automatically generates the Man Machine Language (MML)
or command lineinterface (CL1) scripts used to configure network elements, assembl es these commands
into a batch file, and deploys the file to the appropriate network device.

Note  This document does not include instructions for dial plan provisioning. For dial plan information, refer
to the Cisco Media Gateway Controller Software Release 9 Dial Plan Guide.

Installing the VSPT

If you are aregistered Cisco.com user, you can download the VSPT software from the Cisco web site.
You must install the VSPT release that is compatible with your Cisco MGC software. Refer toTable 1-1
for a guide to Cisco MGC and VSPT software rel ease compatibility.

Cisco Voice Services Provisioning Tool Release 2.3(1) User’s Guide
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Table 1-1

VSPT & Cisco MGC Software Release Compatibility

Installing the VSPT

VSPT Software Release

Cisco MGC Software Release

BAMS Software Release

New Features Added

VSPT 2.3(1)

Cisco MGC Release 9.3(1)

BAMs Phase 2, BAMS
Phase 3 (3.10)

Backup and restore of the
HSI adjunct

VISM 2.2 and 3.0
Support

Backup and restore of the
Catalyst 6509 when used
asthe PGW node's LAN
switch

Support new result types

New, internally
generated cause codes
exported in the
PGW2200 dial plan

VSPT 2.2(2)

Cisco MGC Release
9.2(1.5-2)

BAMs Phase 2, BAMS
Phase 3

VSPT 2.2(2A)

Cisco MGC Release 9.2(1.5)

BAMs Phase 2, BAMS
Phase 3

Removal of support for
TDM cards, (ITK, V.35)
cards

Support for BAMS
Phase 3

VSPT 2.2(1C)

Cisco MGC Release
9.2(0-1)T

BAMs Phase 2, BAMS
Phase 3

Backup and restoreMGC
system files:

Netscape browser-

Screening editor to
create and modify
screening files.
Multiple provisioning
sessions.

Online help

VSPT 2.1(4)

Cisco MGC Release 9.1(5)

BAMSs Phase 2, BAMS
Phase 3 (3.08)

Support for multiple dial
plans:

Provisioning Advice of
Charge

VSPT 2.1(2.A)XA

Cisco MGC Release
9.1(3.4)XA

BAMSs Phase 2, BAMS
Phase 3 (3.08)

[ oL-1910-02
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I nstalling the VSPT

Table 1-1

VSPT & Cisco MGC Software Release Compatibility

VSPT Software Release

Cisco MGC Software Release

BAMS Software Release

New Features Added

VSPT 2.1(2.B) Cisco MGC Release BAMs Phase 2, BAMS
9.1(3.0-9T Phase 3 (3.08)
VSPT 2.0 e State Operations Utility
e CASsignaling paths
provisioning
e Define trunk group
profiles
e Automatic Congestion
Control provisioning
e Define SIP signaling
paths, SIP IP Links, and
SIP trunk groups, and
support for SIP routes
e Support for multiple
OPCs
Before installing the V SPT, you must verify the following:
¢ You have the appropriate release of the VSPT software. Visit the following Cisco web site to check
the VSPT release number (avalid login to the VSPT Cisco web site is required):
http://ww. ci sco. com > Software Center > Voice Software > CiSCO Voi ce Services
Pr ovi si oni ng Tool
¢ You have met the workstation hardware and software requirements. Refer to the Release Notes for
your release of the Cisco MGC Release 9 and VSPT Release 2 software for a complete list of
hardware requirements.
¢ You have established network connectivity between your workstation and the network elements.
¢ The network elements have the correct release of software installed.
A
Note = Make sure you have root access on your Sun workstation.
ﬁ Before you begin provisioning, you should have a list of components you want to provision, including

the component names, |P addresses, properties, and other parameters. To create this list, use the
instructions provided in the Cisco Media Gateway Controller Software Release 9 Provisioning Guide.
In addition, descriptions of the properties and values contained in the VSPT areincluded in Appendix A
of the Cisco Media Gateway Controller Software Release 9 Provisioning Guide and in the following
chapters. Review this information before you begin provisioning, and keep it available for reference
during provisioning.

[l Cisco Voice Services Provisioning Tool Release 2.3(1) User's Guide
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Prerequisites

Preplanning

Installing the VSPT

To install the VSPT software, you must have at least the following:

Sun SPARCstation running Solaris Version 2.8 or earlier
Sun Ultra-5 workstation (333 MHz or faster)
Sun Solaris 2.6 or later
Open Windows with the Common Desktop Environment
Latest Solaris 2.8 recommend patch set (log in to http://sunsolve.sun.com and click on Patches)
Cisco Media Gateway Controller software Release 9.x
8-bit video graphics card
Disk space:
— Approximately 20 MB of disk space for installation
— Directory /var/opt/data/:
Approximately 1 MB for each configuration
Approximately 1 MB for each configuration snapshot
— Directory /var/opt/log/:
Approximately 0.5 MB for each deployment
RAM:
— Minimum: 128 MB
- Recommended: 256 MB or greater
Swap space:
- Minimum: 128 MB
- Recommended: 256 MB or greater

Running the VSPT on the same host as the Cisco MGC can adversely affect performance. We
recommend using a standal one server.

The VSPT may also be installed on the same server as the Cisco MGC Node Manager client. It adds no
additional hardware requirements in this configuration.

V SPT supports multiple solutions and offers the option to provision components for these solutions.
Some components might not apply to your solution. Make sure you understand your solution component
requirements. For information, refer to the provisioning guide for your solution.

[ oL-1910-02
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I nstalling the VSPT

Upgrading VSPT Software

Note

If you have a previous release of the VSPT installed (such as VSPT Release 2.0 and you are performing
aminor upgrade to VSPT Release 2.3), the existing V SPT network configuration data is automatically
moved to VSPT Release 2.3. However, if a major earlier release is detected during the upgrade, (such
as VSPT Release 1.6) and you are upgrading to VSPT Release 2, the existing VSPT network
configuration data is not formatted for use with VSPT Release 2 and is not moved.

Two versions of the VSPT (such as VSPT 1.6 and 2) can exist on the same system; when you are
upgrading, the older version is not automatically removed and must be manually uninstalled if you want
to remove it. See the “Uninstalling the VSPT Software” section on page 1-6 for information.

Since the uninstall directory and files are removed during uninstall, do not change to the /opt/CSCO2X
directory to run the uninstall script.

Saving Configuration Files

Step 1
Step 2
Step 3

Step 4
Step 5

Note

Step 6

Before uninstalling the VSPT software, you can save current configuration data and administrative
information so users and logins do not need to be recreated after the upgrade. Use the following
procedure to save data and user information:

Log in to the server as root.
Create atemporary directory to hold the pertinent files.

Use the following command to copy the password file, /var/opt/CSCOvspX X/etc/dartpwd.txt, to the
temporary directory:

# cp -p /var/opt/CSCO/spXX/ etc/ dartpwd. txt /<tenporary directory>/dartpwd.txt

Change to the /var/opt/CSCOvspX X/data directory.
Use the tar commend to archive all filesin the directory.

The tar command preserves file permissions.

Copy the archive file to the temporary directory.

After you upgrade the V SPT software, replace the /var/opt/CSCOvsp<New>/etc/dartpwd.txt file and the
/var/opt/CSCOvsp<New>/data directory with the archive files you saved in the temporary directory.

Uninstalling the VSPT Software

The uninstallation process removes the /var/opt/<CSCOvspt2x> directory created by the installation
process. If adirectory contains afile that was not created during the installation process, it is not
removed and islogged in the uninstall.log file. This might occur in the data and logs directories, and all
application data stored in the /var/opt/<CSCOvsp2x> directory will not be deleted.

Use the following procedure to uninstall the software:
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Step 1

Step 2

Installing the VSPT

Enter the following commands:

>su -root

>cd /

>/opt/CSCO2x/uninstall/uninstall

Proceed with the V SPT software installation (see “ Installing the VSPT Software” section on page 1-7).

Installing the VSPT Software

Step 1
Step 2

Step 3

Step 4

Step 5
Step 6
Step 7

Step 8

Note

Step 9

Note

To install the software from the Cisco web site, follow this procedure:

Verify that the requirements listed in the “ Prerequisites” section on page 1-5 have been met.
Become the root user by entering the following command:

>su - root

Create the temporary directory /var/tmp/CSCOvsp23-install by entering the following command:
#nkdir -p /var/tnp/ CSCOvsp23-install

Open aweb browser and browse to the following site:

http://ww. ci sco. con> Software Center > Network Management > CiSCO Voi ce Services
Provi si oni ng Tool

Select the desired release number.
Download the software to the temporary directory /var/tmp/CSCOvsp23-install.
Extract the software image using the following tar command:

#tar xvf <filenane>.tar

Run the setup program by entering the following command:
#./setup

As an alternative to Step 8, you can avoid the GUI and install the VSPT in TTY mode by entering the
command ./setup -nodisplay and following the onscreen prompts. An X-server must be running, and the
DISPLAY environment variable must be properly configured. Use one of the following commandsto set
the x-display variable. Your choice of acommand depends on which shell you are using.

In“csh” or “tcsh”: setenv DISPLAY <hostname>:0
In“sh” or “ksh”: DI SPL AY =<hostname>:0;export $DI SPL AY

Follow the onscreen prompts.

If aprevious version of the Cisco VSPT isinstalled on the workstation, you may be asked if you want
to uninstall it, depending on the version to which you are upgrading. If you answer no, the installation
is aborted.

[ oL-1910-02
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Step 10 Remove the /var/tmp/CSCOvsp23-install directory when the installation is complete by entering the
following command:

#rm-rf /var/tnp/ CSCOv/sp23-install

Step 11 Change to the installation directory, /opt/CSCOvsp23, by entering the following command:
#cd / opt/ CSCOvspt 23

Step12 Run the CSCOvsp23 program by entering the following command:
#./vspt

Installation of the VSPT software is now complete. Table 1-2 defines the default VV SPT directories and
files. If you have questions or need assistance, see the Obtaining Technical Assistance section.

Table 1-2 VSPT Installation Directories and Files

/opt/CSCOvsp23

vspt V SPT application script
classes/ Class and property files
/docs

/help

images/

jrel Java Runtime Environment
/netscape Netscape web browser files
uninstall/ Uninstall script directory
/utils

version VSPT version
/var/opt/CSCOvsp23 (home directory)

data/ Configuration files

logs/ Log files

letc

Note Thedirectories and files listed in Table 1-2 are for the most recent version of VSPT Release 2. Your
directory structure may be different if you are using an older version or VSPT Release 2.

VSPT Basics

This section describes the requirements for entering provisioning data using the V SPT.
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VSPT Field Definitions

Table 1-3 lists VSPT field names, which correspond to system componentsin the Cisco MGC, and their
definitions. For more information about system components, refer to the Cisco Media Gateway
Controller Software Release 9 Provisioning Guide.

Table 1-3  Field Name Definitions

Field Name

Definition

MGC Host

An origination point code (OPC) is the address of the
Cisco MGC you are provisioning.

Interfaces (Cards)

Ethernet hardware cardsand virtual interfaces (connections) for
the Ethernet cards in the Cisco MGC host.

Adjacent Point Code

An adjacent point code (APC) is the address of an STP! that
sends and receives signaling messages to and from the
Cisco MGC.

LinkSet A LinkSet is aset of links from the MGC to an endpoint, such
as an adjacent STP.

C71PLink A link to the SS7 network (for example, an SSP? or STP) from
the Cisco MGC through a Cisco SLT.

Mated Pair (SS7 A logical connection between a pair of mated STPs that allows

Subsystem) the Cisco MGC to route through either STP to an endpoint.

Point Code A destination point codes (DPC) is the address of an endpoint,
such as a PSTN?3 switch that carries the bearer traffic.

SS7 Path(SS7 An SS7 path is a connection between the Cisco MGC and a

Signaling Service) specified point code.

SS7 Route An SS7 route is aroute for each signaling path from the

Cisco MGC to the PSTN switch through the linksets you have
created to the STPs.

External Node

An external node is any object in the network that is connected
to the Cisco MGC, for example, media gateways
(Cisco MGWs) and associated BSCs".

MGCP® Signaling
Service

An MGCP signaling service is a signaling service between the
Cisco MGC and a media gateway.

IPFAS Signaling
Service

An IPFAS signaling service is asignaling service (over 1P)
between the Cisco MGC and a media gateway.

IPLink for MGCP
and IPFAS

An|PLink for MGCP and IPFASis alink for the MGCP and
IPFAS signaling services.

Ex S

STP = signal transfer point.

SSP = service switching point.

PSTN = Public Switched Telephone Network.
BSC = Broadband Service Card.

VSPT Basics

[ oL-1910-02
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5. MGCP = Media Gateway Control Protocol.

Figure 1-1 shows the relationship of VSPT field names and the corresponding system
components.

Figure -1 Component Relationships

. Adjacent
External Point
i Adapter
Node Code Point P
Code
Y
SS7
route
Y \ 4
Linkset SS7 Ethernet
-«
subsystem adapter
(mated pairs)
\4 Y Y ¢ ¢
SS7 P Ethernet
MGCP IPFAS signaling crip < interface
signaling || signaling (SS7 path) link ¢
IP ©
link 3

VSPT Data Entry Requirements

When you are entering data into the VSPT windows, follow standard MML conventions for names and
descriptions. Each MML name must have the following characteristics:

¢ A maximum of 20 alphanumeric characters, including dashes
¢ No space, underscore, or special characters

e Must start with an alphabetic character
For example: name="dpc1"

MML descriptions can be as many as 128 characters and can include spaces and symbols. You should
use adescription that helpsto identify the component or link that you are provisioning. For example, for
an SS7 route, which indicates the signaling path from the Cisco MGC to a switch through alinkset, you
could create a description “ SS7 Route to PSTN Switch A through Linkset 1.” For more information
about MML, refer to the Cisco Media Gateway Controller Software Release 9 MML Command
Reference Guide.

The VSPT GUI enablesyou to step through the provisioning processin alogical sequence. The sequence
of stepsis described in the Cisco Media Gateway Controller Software Release 9 Provisioning Guide.
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Starting the VSPT

Starting the VSPT
~

Note  Seethe Cisco Media Gateway Controller Software Release 9 Installation and Configuration Guide for
information on setting up user privileges and access rights.

Perform the following steps to start the VSPT:

Step1  Loginto the VSPT server or access it from a machine with X-window capability.
Step2 Inatermina window, change to the default directory:

>cd /opt/CSCOvsp23

Navigate to the appropriate directory if you installed the VSPT in a different location.
Step3  Enter the following command to start the VSPT:

> /vspt

The system opens X-windows, and the login screen shown in Figure 1-2 appears.

Figure 1-2 Login Screen

% VSPT Login O] x|

User Mames admin
Paszword? |

| 0K | | Cancel |

70280

Step4  Enter your user name and password, and click OK.

The default user uameisadmin, and the password is al so admin. The Welcome screen isdisplayed briefly
during the login process, and the main window appears (see Figure 1-3).

Figure 1-3 Main VSPT Window

1 Configuration Editor - O] x|
File Wiew Tools Help

5 Unknown MGC
| Interfaces
& Signaling
External Modes

E
70281

Using the VSPT

This section describes the VSPT menus and buttons and provides directions for using the tool functions.
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Menu Bar

The VSPT provides a menu bar that contains the following selections:
e File
e View
e Tools
e Help

Table 1-4 lists the File menu choices.

Table 1-4  File Menu Command Choices

Command Description

New Begin a new configuration session

Open Open an existing configuration

Import Import an existing configuration from an MGC, or import trunk group,
trunk, routing, or dial plan filesinto the VSPT

Export Export configuration files from the VSPT to a specified directory

Save Save the current configuration:

e AsWorking: Use to save a new configuration, either a
configuration imported from the Cisco PGW or a configuration
created in VSPT, and to save modifications to an existing
configuration, overwriting the last version. The configuration is
saved in the /var/opt/CSCOvsp23/data/mgc/mistral directory.

e As Snapshot: Use to save modifications to an existing
configuration under a new name in the ARCHIVE directory. The
snapshot configuration is saved in
Ivar/opt/CSCOvsp23/data/mgc/mistral/< configname>/ARCHIVE

e AsNew Config: Useto save amodified configuration under a new
name, leaving the original intact.

Exit Stop any open provisioning sessions and close the VSPT

Table 1-5 lists the View menu command choices.

Table 1-5 View Menu Command Choices

Command Description

MML Show generated MML for the current configuration

MGW Commands Show generated Cisco MGX 8850 commands for the current
configuration

Trunk Group File Show generated trunk group file for the current configuration

Trunk File Show generated trunk file for the current configuration

Table 1-6 lists the Tools menu command choices.
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Table 1-6  Tools Menu Command Choices

Command Description

Integrity Check Check your configuration for inconsistencies and missing information

Deploy M ove the configuration to one or more target hosts and Cisco media gateways
(MGWSs)

Telnet Open atelnet session

MGC Viewer View, activate, remove, and synchronize configurations on the MGC.

MGX-8850 Wizard |View and configure MGX 8850 hosts. Refer to the Cisco Media Gateway
Controller Software Release 9 Provisioning Guide for information about the
MGX-8850 Wizard.

BAMS Config View and configure a Billing and Measurements Server (BAMS). Refer to the
Billing and Measurements Server User’s Guide for your release of BAMS for
information about BAMS configuration.

State Operation View and configure the state of MGC components.

Screening Editor View and configure screening number provisioning. Refer to the Cisco MGC
Software Release 9 Dial Plan Guide for information about using the VSPT
Screening Editor.

Audit Audit bearer trunk information between the Cisco MGC and the BAMS.

Backup and Restore |Create, modify, or delete scheduled backups or restores on the MGC Host,
CAT2900XL, CAT5500, CAT6509, SLT2600, BAMS P2, BAMS P3, and HSI
adjunct server components.

Make a Seed File |Use an existing configuration to create a text file that can be used by the
Cisco MGC Node Manager (CMNM) to deploy or discover devicesin the
network.

Table 1-7 lists the Help menu command choices.

Table 1-7 Help Menu Command Choices

Command Description

About VSPT View information about the current version of VSPT, including the software
release number

VSPT User's Menu |View online help information

Buttons

The VSPT provides buttons and explorer trees that you can use to move through the system. Click these
buttons to add or change network components. The VSPT contains the following buttons:

¢ MGC Config—Add components and provision component properties
o Traffic—Create customer-specific files, including trunk groups, trunks, and routing

¢ Number Analysis—Provision dial plans

Cisco Voice Services Provisioning Tool Release 2.3(1) User's Guide
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The left pane of the main VSPT screen displays selectable components. The right pane of the screen
displays data entry fields. Click a component to select it. To see all of the subcomponents for the
component you select, click the icon next to the component name to expand the component list.

Note  For instructions for using the VSPT to provision components, component properties, trunk groups,
trunks, and routing, refer to the Cisco Media Gateway Controller Software Release 9 Provisioning
Guide. For instructions for using the VSPT to provision adial plan, refer to the Cisco Media Gateway
Controller Software Release 9 Dial Plan Guide.

The Help menu selections display an html version of this guide and information about the current
software release number.

Defining Users and Permissions

After you install the VSPT, you define users and their respective permissions using the following
procedure:

Step1  Login to the server asroot and start VSPT 2.
Step2  Click Tools > User Admin on the menu bar.

The screen in Figure 1-4 appears.

Figure 1-4 VSPT User Administration

1 User Administration

Usernane: Permission:

admin admirn

Username; [ |

Password: [ |

Permission: |uiewer‘ hd |

| ndd || Modify || Delete || Clese | [3
=1
=

Step3  Add, modify, or delete user definitions as follows:

e To add a user, enter a user name and password, click Permission, select the permission level, and
click Add.

¢ To modify a user, select the user name, change the password or permission level, and click M odify.

¢ To delete a user, select the user name, and click Delete.

Exiting the VSPT

You can exit the VSPT at any time by performing one of these actions:
¢ Click File > Exit. Click OK at the resulting prompt.
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Exiting the VSPT

¢ Click the close box in the upper right of the VSPT screen. Click OK at the prompt.

Cisco Voice Services Provisioning Tool Release 2.3(1) User's Guide
[ oL-1910-02 .m



Chapter 1 Voice Services Provisioning Tool Overview |

W Exiting the VSPT

Cisco Voice Services Provisioning Tool Release 2.3(1) User’s Guide
m. oL-1910-02 |



Note

CHAPTER 2

Provisioning with VSPT Wizards

Wi zards are utilities included in the Cisco Voice Services Provisioning Tool (VSPT) that can help you
rapidly create a new MGC configuration deployment by providing a graphical user interface (GUI) for
provisioning specific solutions. A wizard leads you through the steps of provisioning the Cisco MGC
and the external components of the solution you choose.

A solution is alogical combination of Cisco hardware and software configured to perform a specific
network task.

This chapter provides an example of using a wizard to configure a solution. It includes the following
sections:

e Starting a New Provisioning Session, page 2-1
e Overview of the VSPT Wizards, page 2-2
¢ Using the Tandem Transit with STP Solution Wizard, page 2-3

Starting a New Provisioning Session

Step 1
Step 2
Step 3

When you start a new provisioning session, you can choose to base the configuration on an existing
configuration, by using the Import from MGC option, or you can use a configuration wizard, or you can
perform the configuration manually.

Use the following procedure to start a new V SPT provisioning session:

Start and log in to the VSPT.
Select File > New on the menu bar.

Enter a name for the new configuration you will create, and click OK. The screen shown in Figure 2-1
appears.

[ oL-1910-02

Cisco Voice Services Provisioning Tool Release 2.3(1) User's Guide



Chapter2  Provisioning with VSPT Wizards |

I Overview of the VSPT Wizards

Figure 2-1 Select Method for Creating Configuration
1 New Configuration Wizard

Select method for creating configuration.

# Import from MGC

Hostname |

Login [mgcusr

|
|
Pazsuord | |

Lonfig | " Select

1 Solution Wizard: SS7-PRI Gateway
1 Solution Wizard: Tandem Transit with STP links
1 Solution Wizard: Tandem Transit with SSP links

i Perform manual configuration

Cancel

70282

Step4  If you want to import an existing configuration, click the Import from M GC radio button, and click
Select; otherwise, click Perform Manual Configuration, or choose the solution wizard to use.

S
Note  Thisimportsthe Cisco MGC configuration only; it does not import gateway configurations. To

import configurationsfor gateways, after importing the M GC configuration, select each gateway
and import its configuration.

If you import an existing configuration, the screen shown in Figure 2-2 appears.

Figure 2-2  Select Configuration

¥ Configuration Chooser

Configurations
=

mdp1
mytemp
temp
temp-z1
temp-z2

Cancel

70283

Step5  Select the configuration to import, and click OK. The configuration will be imported from your
Cisco MGC.

Overview of the VSPT Wizards

The VSPT includes the following solution provisioning wizards:
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e SS7-PRI Gateway—Offloads modem dial traffic from competitive local exchange carrier (CLEC)
switches and either forwards the calls, using SS7, to the destination CL EC switches or translates the
primary rate access callsto integrated services digital network (ISDN PRI) to terminate them on the
network access server (NAS) gateways.

e Tandem Transit with STP Links—Offloads modem dial traffic from CLEC switches and forwards
the calls to the I P network through a signal transfer point (STP).

¢ Tandem Transit with SSP Links—Offloads modem dial traffic from CLEC switches and forwards
the calls to the Interne Protocol (IP) network with no intermediate connection to STPs.

Each wizard automatically guides you through the steps involved in creating a provisioning
configuration for a specific solution. A VSPT wizard:

¢ Letsyou create configuration files across multiple devices, for example, MGCs
and Cisco MGX 8850s

¢ Helps you avoid common errors when you are provisioning devices independently (for example,
ensuring that you correctly match D-channels for PRI)

e Letsyou avoid having to repeatedly enter duplicate data

¢ Createsthe MML files and the Cisco MGX 8850 command files you use to provision the
Cisco MGC and MGX 8850

The example in this chapter uses a wizard to provision atandem transit with STP links solution, but the
processissimilar for all VSPT wizards. Specific components and steps vary, depending on the solution
wizard you are using; for acomplete description of solution components, refer to the documentation for
that solution.

When you finish the provisioning session, the VSPT wizard saves your configuration as the “active”
configuration, and that configuration cannot be modified. To make changes, you must save the
configuration with another name and deploy the new provisioning session to make it active.

The number of configurations you can store might be limited by available disk space. Consider deleting
old or unwanted configurations, or save them to another machine, if you do not have sufficient disk
space.

Note  The provisioning procedures described in this chapter follow the sequence for provisioning a “typical”
Cisco MGC described in the Cisco Media Gateway Controller Software Release 9 Provisioning Guide.

Using the Tandem Transit with STP Solution Wizard

The VSPT utility, Solution Wizard: Tandem Transit with STP Links, guides you step-by-step through
the following procedures:

¢ Configuring the Cisco MGC, page 2-4
e Configuring SS7 Signaling Services, page 2-6
e Configuring Media Gateway Control Links, page 2-8

When you finish using the VSPT wizard, you must still configure the trunk groups, trunks, and routes.
For more information, see the Cisco Media Gateway Controller Software Release 9 Provisioning Guide.
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2
Tip

Before you begin provisioning, compile information about the solution components, including their

names, |P addresses, and properties. Worksheets designed for collecting this information are provided
in the Cisco Media Gateway Controller Software Release 9 Provisioning Guide. Complete them before
you begin provisioning, and refer to them during provisioning.

Configuring the Cisco MGC

Use the following procedure to provision a Cisco MGC using the Tandem Transit with STP solution

wizard:

Step1  Start anew provisioning session, and click File > New on the menu bar.
Step2  Click the Solution Wizard: Tandem Transit with STP radio button, and click OK. A screen similar

to the one in Figure 2-3 appears.

Figure 2-3  Specifying Cisco MGC Properties

%1 Mew Wizard: Tandem Transit with STP links

Specify MGC parameters

HEC Hostname: |

Loging [

Paszword: [

Import Settings

70300

Step3  Enter the MGC IP address, for example, 172.31.157.1, in the MGC Hostname field.

Step4  Enter alogin ID and a password.

Step5  Click Next. A screen similar to the one in Figure 2-4 appears.
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Figure 2-4  Specifying MGC IP Addresses

%1 Mew Wizard: Tandem Transit with STP links

Importing YISHs from MGK-8850 chazszis

Using the Tandem Transit with STP Solution Wizard

MEH-8850 Hostname |

Lagin [ |

Pazsword [ |
Import WISHs

Selected " Slot || State || HGC " External Mode Mame |

70303

Enter the network addresses of the MGC (IP_Addrl and IP_Addr2) in dotted decimal notation, for

If the Cisco MGC has afailover Cisco MGC, click the radio button next to Has a failover MGC, and

enter the network addresses of the failover Cisco MGC (I1P_Addr1 and | P_Addr2). Use dotted decimal
notation. If there is no failover Cisco MGC, click the radio button next to Does not have a failover
MGC. TheIP_Addr 1 and IP_Addr 2 fields are not valid and are grayed out when there is no failover

Step 6
example, 172.18.145.38.
Step7  Click Next.
Step 8
MGC.
Step 9

begins.

Figure 2-5 Specifying a Point Code

%1 Mew Wizard: Tandem Transit with STP links

Specify Point Code for MGC

Click Next. A screen similar to the one in Figure 2-5 appears, and SS7 signaling service provisioning

Name: [opc
Description:  [Qriginating Point Code
MetAddr: |0.0.0

MetIndicator: |National network (2}

OFC Tup=: [ TRUEQPC

True OPC: |<UNSET>

70307
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Configuring SS7 Signaling Services

Step 1
Step 2
Step 3
Step 4

Step 5
Step 6
Step 7

Step 8

Step 9

Step 10
Step 11
Step 12

Use the following procedure to configure SS7 signaling services:

Enter a name, for example, OPC, in the Name field on the screen shown in Figure 2-5.

Enter a description of the OPC, for example, Originating Point Code.

Enter the OPC network address (NetAddr) in dotted notation, for example, 1.1.2.

From the NetIndicator drop-down menu, choose a network indicator menu. There are four options.
¢ Internationa—Used if the node is an international gateway.

e Spare—In countries where multiple carriers share point codes, networks are differentiated by this
indicator.

¢ National—Used if the node routes calls through the national network (default value).
¢ Reserved—For national use. Do not use.

From the OPC type indicator, choose either TRUEOPC or CAPOCP.

Leave the True OPC indicator at <UNSET>.

Click Next.

Enter the number of adjacent point codes (APCs) to create, corresponding to the number of Cisco
MGX 8850 switches to be provisioned. Click Next. screen similar to the one in Figure 2-6 appears.

Figure 2-6  Specifying Properties for Each APC

%1 Mew Wizard: Tandem Transit with STP links

Specify parameterz for APC #1

Mame; |STP—1 |
lescription:  [Point code for STP |
NetAddr: 0.0.0 | awst |
NetIndicator: |National retuark (23 v

< Back Mext >

70309

Enter the APC name.
Enter a description of the APC.
Enter the network address (NetAddr) in dotted notation; for example, 2.2.1.
From the NetIndicator drop-down menu, choose the network indicator:
e Internationa—Used if the node is an international gateway.

e Spare—In countries where multiple carriers share point codes, networks are differentiated by this
indicator.

¢ National—Used if the node routes calls through the national network (default value).

e Reserved—For national use. Do not use.
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Step13  Click Next. A series of screen similar to the one in Figure 2-6 appears sequentially for each APC you
specified in Step 8.

Step14 Repeat Step 9 through Step 13 for each APC screen. After you have configured propertiesfor each APC
you specified in Step 8, a screen similar to the one shown in Figure 2-7 appears.

Figure 2-7 Specifying Properties for Mating APCs

%1 Mew Wizard: Tandem Transit with STP links

Specify parameterz for mating APCs

Mame prefix: |mate |
Protocol family: |ss?—|qNSI e |
Transport protocols: |3[;[;P hd |

70310

Step 15 Enter the name prefix for the subsystem (default is mate).
Step16  Choose the protocol family.
Step 17  Choose the transport protocol.

Step18 Click Next. A screen similar to the one in Figure 2-8 appears.

Figure 2-8 Specifying a Protocol for Linksets

%1 Mew Wizard: Tandem Transit with STP links

Specify Protocol for Linksets

Mame prefix: [Inkset |

Linkset procotol: |SS?—HNSI - |

< Back Mext >
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Step19  Enter the name prefix for the linkset (default is Inkset).

Step20 From the Linkset protocol drop-down menu, choose the linkset protocol for the linkset you are
configuring.

Step21 Click Next. A screen similar to the one in Figure 2-9 appears.
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Figure 2-9  Specifying Values for C7 IP Inks

%1 Mew Wizard: Tandem Transit with STP links

Specify Yalues for CF IPlnks

Mame prefix: [c7ip
IP addr for SLT 13 |
IP addr for SLT 23 |
Local port: [Fooo

70312

Step22 Enter the name prefix (the default is c7ip).

Step23  Enter the network addresses (1P addr for SLT 1 and IP addr for SLT 2) in dotted notation; for example,
172.16.145.38 and 172.16.145.40.

Step24 Enter the local port on the SLT.

Step25 Click Next. A screen similar to the one in Figure 2-10 appears, and you can begin configuring media
gateway control links.

Figure 2-10 Specifying the Number of Destination Point Codes

%1 Mew Wizard: Tandem Transit with STP links

Specify number of Destination Point Codes to create

Number of IPCs: |1

< Back Mext >

70301

Configuring Media Gateway Control Links

Use the following procedure to configure MGC links for this solution.

Step1  Enter the number of DPCs to create, in the window shown in Figure 2-10.

Step2  Click Next. A screen similar to the one in Figure 2-11 appears.
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Using the Tandem Transit with STP Solution Wizard
Figure 2-11 Specifying Properties for Each DPC
%1 Hew Wizard: Tandem Transit with STP links
Specify parameterz for DPC #1
IFC Name: [DPC—1 |
Metaddr: |3.3.3 " ENST |
557Path Mame: [sP—DPC—1 |
HDO: | ans1557_STANDARD -
Customer group 103 0000 |
< Back Mext >
:
Step3  Enter the DPC name.
Step4  Enter the network address of the destination network element in dotted notation; for example,
172.16.145.38.
Step5  Enter the SS7 path name.
Step6  From the MDO drop-down menu, choose the protocol for this signaling service, for example,
ANSISS7_STANDARD.
Step7  Enter the Customer group ID.
Step8  Click Next.
Step9  Enter the SS7 route name prefix, and click Next.
Step10 A screen similar to the one in Figure 2-12 appears.
Figure 2-12 Importing VISMs from the MGX 8850 Chassis
%1 Hew Wizard: Tandem Transit with STP links
Importing YISHs from MGK-8850 chazszis
MEH-8850 Hostname | |
Login [ |
Paszword [ |
Import WISHs
Selected " Slot || State || HGE " External Mode Mame |
< Back Finish
:
Step 11 Enter the name of the MGX 8850 host in which the VISM cards are installed.
Cisco Voice Services Provisioning Tool Release 2.3(1) User's Guide
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M Using the Tandem Transit with STP Solution Wizard

Step 12
Step 13
Step 14

Step 15

Enter the login ID for the MGX 8850 host.

Enter the password.

Click Import VISMs. A list of the imported MGX 8850 switches appears in the lower portion of the
screen.

Click Finish. You can now provision trunk groups, trunks, and routes for this solution. Refer to the
Cisco Media Gateway Controller Software Release 9 Provisioning Guide.

Provisioning Session Results

The results of the provisioning session you just completed are visible in the hierarchical tree in the left
pane of the main VSPT screen, as shown in Figure 2-13.

Figure 2-13 Expanded Hierarchical Tree Showing Results of Provisioning Session

%1 Configuration Editor - MGC-1

File Wiew Tools Help

# MGC Config i Traffic

1 Number Analysis

§ nssu-docs

5 Interfaces

& card-1

&= card-2

i Signaling

& Point Codes
e Linksets

& 557 Subsystems

&= 557 Paths

¢ 557 Routes
&= 557 Signaling Gateway
& 5|p

&= Auto Congestion Ctrl

& Advice of Charge
@ OTD Farameters

i External Nodes

| o
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You can expand the branches to view individual components. To view the provisioning information for
aparticular system component, click on the component name. Information about the sel ected component
is shown on the right-hand side of the screen (see Figure 2-14 for an example).
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Using the Tandem Transit with STP Solution Wizard

Figure 2-14 View a Selected Component Configuration

%1 Configuration Editor - MGC-1

File Wiew Tools Help

‘# HGC Config i Traffic
~ Attributes
O Number Analysis

¢ nssu-docs Nane: |stp—1 |
& el R n n

! |p_t§a':;a_fes : lescription:  [Adjacent Point Code |

é~ card-2 Nethddr: .24 | awst |

=

! Signaling i
% Point Codes MetIndicatars |National netwark (2} v
& OPCs i
L ope-1
5 APCs
tstp—l
STP-2
i DPCs
' Linksets
Lnkzet-1
Lnkset-2
&= 557 Subsystems
€ 557 Paths
€ 557 Routes
&= 557 Signaling Gateway
& 5|p
&= Auto Congestion Ctrl

& Advice of Charge -
& GTD Parameters Modify Delete

&= External Modes

| 1

=¥
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You cannot use the V SPT wizard to provision trunk groups, trunks, and routes. For more information
about provisioning these components using the V SPT, see the Cisco Media Gateway Controller
Software Release 9 Provisioning Guide.

Viewing Generated MML

To view the MML commands generated by the VSPT wizard, refer to the “View Generated MML
Commands” section on page 3-4.
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M Using the Tandem Transit with STP Solution Wizard
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Voice Services Provisioning Tool Utilities

V SPT Release 2.3(1) provides many utilities, including tools to accomplish the following tasks:
e Perform an Integrity Check, page 3-1
¢ View Generated MML Commands, page 3-4
¢ View Generated Cisco MGW Commands, page 3-4
¢ Deploy a Configuration, page 3-5
e Telnet, page 3-9
e MGC Viewer, page 3-10
e State Operation, page 3-12
e Perform an Audit, page 3-13
¢ Back Up and Restore, page 3-15

Perform an Integrity Check

When provisioning is complete, you can perform an integrity check to prevent possible configuration
errors. The integrity check involves:

¢ Checking Integrity for MGC Signaling Configuration
¢ Checking Traffic Against MGC Configuration
¢ Checking Dial Plan Results
Each integrity check is explained in more detail in the following subsections.

Checking Integrity for MGC Signaling Configuration

When you perform an integrity check for MGC signaling configuration, the VSPT does the following:
¢ Checksthat the hostname is specified for MGC
¢ Checksthat login/passwords are specified for MGC
e Checksthat MGC ipaddrs are specified
e Checksthat if MGC failover is specified, the failover | Ps are specified
¢ Checksthat MGX hostname is specified

Cisco Voice Services Provisioning Tool Release 2.3(1) User's Guide
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I Perform an Integrity Check

¢ Checksthat MGX login/password is specified
e Checksthe MGX IPaddrs

¢ For EXTNODES wherethe configuration refersto an MGX, checks PeerAddrs on IPLNK to ensure
that they are addresses on the specified MGX

e For IPFASIPLNK:

Ensures that SigSlot/SigPort is specified

Checks SigSlot/SigPort on MGX to ensure that the values are valid as specified on the MGX
Ensures that MGC ports and MGX ports match on the IPLNK

Checks that all IPLNK under asingle IPFASPATH map to the same port number

S,
Note  Thenumber of IPFAS sessions utilizing a given port is displayed because some IPLNKs might
use different port IDs.

Checking Traffic Against MGC Configuration

When you perform an integrity check of traffic against the MGC configuration, the VSPT does the
following:

e When D-channels are defined as FAS and NFAS PRI in the trunk group/trunk section, verifies that
there are corresponding IPFASPATH signaling services with corresponding IPLNKs

e Checksif there are any defined IPFASPATH signaling services defining a D-channel but no
corresponding trunk group/trunk in the traffic information with a corresponding NFAS/FAS PRI.

¢ Checksthat signaling services defined for trunk groups exist in the configuration

For information about an integrity check of dial plan results, refer to the Cisco Media Gateway
Controller Software Release 9 Dial Plan Guide.

Use the following procedure to perform an integrity check of your configuration:

Step1  Click Tools > Integrity Check. The screen shown in Figure 3-1 appears.
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Step 2

Figure 3-1 Integrity Check

%1 Integrity Check

# Aun all tests

{1 Run individual tests

Indicate the tests you want to run, and click Start.

70491

Perform an Integrity Check

When the tests finish, a screen similar to the one in Figure 3-2 appears showing the results of the

integrity checks.

Figure 3-2 Integrity Check Results

%1 Integrity Check

'Run all tests

# Run individual tests
[1#] Check integrity for MGC signaling configuration
|1 Check Traffic against MGC Configuration
|1 Check dialplan results

Started Check integrity for MGC signaling configuration...

Checking Iplinks under mgx8260—am—1 to see that IP addrs have been defined.

ek infas—telfort—2-1 specified card/ds1 information that is incorrect for Media Gateway m
ek infas—telfort—1-1 specified card/ds1 information that is incorrect for Media Gateway m
wk infas—amslon—1-1 specified card/ds1 information that is incorrect for Media Gateway
ik infas—globalxing—1-1 specified card/ds1 information that is incorrect for Media Gatewa:
Test completed

wwk | ntagrity Check Completed s

70492
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W View Generated MML Commands

View Generated MML Commands

The VSPT automatically generates MM L commands to provision your Cisco MGC and saves these
commands in afile to be executed when you deploy the configuration. To view the MML commands
generated from your VSPT provisioning session, click View > MML on the VSPT menu bar. A screen
displaying generated MML, similar to the one shown in Figure 3-3, appears.

Figure 3-3 First Generated MML Screen

% Generated MML x|
MML commands for signaling -

prov—add:Cardiname="card—1",desc="card in slot 0",type="EN".slot=0
prov—add:Enetif:name="enet—1",desc="interface in slot 0",card="card-1"
prov—add:Cardiname="card—2",desc="card in slot 2" type="EN"slot=2
prov—add:Enetif:name="enet—2",desc="interface in slot 2",card="card-2"
prov—add:Opaname="opc—vsc3000—am—1" desc="0riginating Point Code of WSC3000-AM—1"n
prov—add:Dponame="pc—vced k=1" desc="Point Code", netaddr="0.110.7" netind=3
prov—add:Dponame="pc—colt—1",desc="Point Code", netaddr="0.71.0" netind=3
prov—add:Dponame="pc—gts—1",desc="Point Code", netaddr="0.22.0", netind=3
prov—add:Dponame="pc—versatel-1",desc="Point Code",netaddr="0.45.3" netind=3
prov—add:Lnkset:name="Inkset—vcod k", desc="Lnkset to VCO4 K" apc="pc—vced k—1", proto="557—|
prov—addiLnksetname="Inkset—colt—1", desc="Lnkset"apc="pc—colt—1", proto="557-I1TU" type="IF
prov—addiLnksetname="Inkset—gts—1", desc="Lnkset".apc="pc—gts—1", proto="557-1TU" type="IP"
prov—addiLnkset:name="Inkset—versatel-1",desc="Lnkset" apc="pc—versatel-1", proto="557-I1T1"
prov—add:Ss7 pathiname="ss7 p—vced k', desc="557 Signaling Service to voed k' side="network".mi
prov—add:Ss7 pathiname="ss7 p—colt", desc="557 Signaling Service".side="user".mdo="I15UPY2_5%W
prov—add:Ss7 pathiname="ss7 p—gts", desc="557 Signaling Service".side="user",mdo="I1SUPY2_SW
prov—add:Ss7 pathiname="ss7 p—versatel",desc="557 Signaling Service",side="user",mdo="I1SUPYZ
prov—addiSs7routename="ss7r—vcod k", desc="357 Route to vood k. dpc="pc—vcodk—1"opc="opc—
prov—add:Ss7routename="ss7r—colt", desc="557 Route".dpc="pc—colt—1"opc="opc—vsc3000—-am;
prov—add:Ss7route name="ss7r—gts", desc="557 Route",dpc="pc—gts—1",opc="opc—vsc3000—am—
prov—add:Ss7routename="ss7r—versatel", desc="557 Route" dpc="pc—versatel-1"opc="opc—vsc3
prov—edidcorespeatname="default".acll drcant=50,acl1 drskip=20.acllarcant=50,acl1 arskip=20.:
prov—ediMclthresholdiname="callrate".mcl1onset=0,mcllabate=0,mcl2onset=0,mcl2abate=0,mq
prov—ediMclthresholdiname="cpu".mcl1onset=22,mcllabate=75,mclZonset=30,mcl2abate=77,m
prov—ediMclthresholdiname="memeorvaddress".mcl1onset=24, mcliabate=20.mcl2onset=28, mcl]
prov—ediMclthreshold:name="queuelen",mcllonset=75,mcl1abate=50,mclZonset=20,mcl2abate
prov—ediMclthreshold:name="virtualmermory".mcllonset=20,mcl1abate=75,mclZonset=25,mcl2
prov—ediMclcallrejectname="mcl1", callreject=25
prov—ediMclcallrejectname="mcl2", callreject=50
prov—ediMclcallrejectname="mcl3" callreject=100
prov—addiHeoliday:date="2001.06.06", hday="Hol3"
prov—addiHeoliday:date="2001.12.08", hday="Hol2"

o LA

N R P R P P T P W == P PPN =l

Close

70495

View Generated Cisco MGW Commands

To view the Cisco MGW commands generated from your provisioning session, click View > MGW
Commands on the main VSPT menu bar. A screen with generated Cisco MGW commands, similar to
that shown in Figure 3-4, appears.
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Figure 3-4 Example of Generated Cisco MGW Commands

[¥ Generated Media Gateway Commands x|
[MGWw CLI Commands For 10.3.4.5] -
chidletrm 20
chsysinmd 2
¥
chsysipl 10.233.20.9 0.0.0.0
chsysip2 10,233.20.73 0.0.0.0
addsonetin 9.1
chmpe 3
chndinf # # 1
chpclksrcg 1 21
addmacsapprof 11 # 15
adddlsp 1T HHEHHEHEHHEHO
chmgcpdname mgxg260—-am—1
chmgecplocaladdr1 10.233.20.9 2427
chmgecplocaladdr2 10.233.20.73 2427
chpmgcpaddr 172.18.126.51 2427 0.0.0.0 0
chsmgcpaddr 0.0.0.0 0 0,0.0.0 0
chmgcpcore # # 1 # # 2000
addsset11112 31
addsgrp 11
addsess 111 10.233.20.9 7009 172,18.126.51 7003 1
adddsiin 1.1 14 # # #1
adddsiin 2214 # # #1
addds1in 3.3 14 # # #1
adddsiind1 164 # # # 1
addds1in 5S4 14 # # #1
addvport 111115
addvport 1 17 1 17 15
addvport 232 20 31
addvport 363 2 31 31
addvport4 111495512
addvport 594 3 30 31
adddchan 1.1 1 #1 |
| Close |

Deploy a Configuration

When you finish defining a configuration, you must deploy that configuration to the Cisco MGC. You
can deploy to the Cisco MGC alone, to the Cisco MGC and one or more gateways, or to gateways only.

N

Note

70494

Deploy a Configuration

A new configuration should not be deployed during times of peak load on the Cisco MGC.

A configuration created in VSPT can be deployed to a Cisco MGC as a new configuration or
incrementally. Deploying incrementally allows you to more quickly deploy modifications to an existing

configuration without having to redeploy the entire configuration. VSPT also allows you to visually

check the incremental commands it generates before deploying those commands to the MGC.

Deploying a New Configuration

)

Note

Use the following procedure to deploy a new configuration.

If you want to delete a component and plan to reuse the component name, first delete the component,

deploy the session, and verify that the component name has been deleted before reusing the name.

[ oL-1910-02
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Step1  Click Tools > Deploy on the main VSPT menu bar ( see Figure 1-3 on page 1-11). The screen shownin

Figure 3-5 appears.

Figure 3-5 Deploying a Configuration

%1 Deployment Selection

rleploy to MGC: nssuwscl

Dlezstination Configuration

Bazed on configuration mdpl

WS deployment action
# Send Configuration to MGC Only
Send and Activate Configuration

Send, Activate and Synchronize failover

Do not deploy to HMGC

Advanced

rSpecify media gateways for deployment
10,345

Deselect ALl
Select ALl

0K

Step2 Indicate how you want to deploy the configuration:

e To deploy to the Cisco MGC only, do one of the following:

70486

- If you want to send the configuration to the MGC but not activate it, click the button next to
Send Configuration to MGC Only.

- If you want to send the configuration to the MGC and activate it, click the button next to Send

and Activate Configuration.

- If you have acontinuous-service configuration with two Cisco MGC hosts, click the button next
to Send, Activate and Synchronize failover. The configuration is saved on the active host and
copied to the standby host. You must restart the standby server after reconfiguration to apply

changes.

¢ To deploy to the Cisco MGC and one or more selected gateways, select one of the above three
options and also select one or more gateways from the list in Specify media gateways for

deployment.

e Todeploy to selected gateways only (and not the Cisco MGC): Check the box next to Do not deploy
to M GC and select one or more gateways from thelist in Specify media gatewaysfor deployment.

~

Note  To select multiple gateways, you can use standard selection methods: Shift+click to select a
contiguous range, Ctrl+click to select or deselect noncontiguous gateways.
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Step 3
Step 4

Note

Note

Step 5
Step 6

Deploy a Configuration ||

S
Note If you select an option other than New, the Advanced button is enabled. For information about
the options this button provides, see the “Configuring an Incremental Deployment” section on

page 3-8.

Enter the configuration name on the destination MGC.

Select a configuration in the Based on configuration drop-down list. This list displays all existing
configurations on the selected MGC and the [LAST IMPORT] and [NEW] options.

e Last Import—The VSPT compares your provisioning session to the last imported configuration and
deploys only changes you have made.

The LAST IMPORT option allows multiple users to modify an existing configuration. However, they
must each be modifying a different area of the configuration for this option to work properly.

* New—Your entire provisioning session is deployed as a new configuration.

¢ Existing Configurations—V SPT imports the selected configuration from the Cisco MGC, compares
the differences between that configuration and your current provisioning session, and deploys
changes you have made.

Since you are deploying a new configuration, make sure to choose the New option in the Based on
configuration drop-down list.

Select the gateways you want to deploy, if applicable.

Click OK. The screen shown in Figure 3-6 appears and displays the status as the current provisioning
session is deployed.

Figure 3-6 Deployment Progress

%1 Deploying M=]

Preparing files for deployment.

Transferring mml files...

mmlz prov—staisrcver="mdp1" dstver="sdp1",confirm
Copyright @ 1333-2001, Cisco Systems, Inc

MGC-01 — Media Gateway Controller 2001-08-30 13:30:12
M COMPLD
"PROV-STA"

mml> prov—stp

MGC-01 — Media Gateway Controller 2001-08-30 13:30:12
M COMPLD

"PROV-STP"

| Close

70488
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| Deploy a Configuration

~

Note

In a continuous-service configuration, the XECfgParm.dat file on each machine must be configured. If
you experience problems, verify the integrity of the XECfgParm.dat files on both machines. Refer to
Chapter 2, “Installing Cisco Media Gateway Controller Software,” in the Cisco Media Gateway
Controller Software Release 9 Installation and Configuration Guide.

Configuring an Incremental Deployment

Note

Step 1
Step 2

Note

Step 3

An incremental deployment allows you to modify an existing configuration and deploy only the
modified areas to the Cisco MGG. M odifications can be made more quickly, and errors affecting
unmodified areas are minimized. In addition, provisioning modifications made by other usersin separate
areas are not affected.

The Cisco MGC does not support some incremental deployment processes. If you have a problem with
an incremental deployment, examine the MML commands to ensure that you have properly configured
the desired components. Modify the component presenting the problem, or cancel the deployment and
redeploy the component as a new configuration.

Use the following procedure to configure an incremental deployment:

Follow Step 1 through Step 4 in the “Deploying a New Configuration” section on page 3-5
Click Advanced in the window shown in Figure 3-5. The screen shown in Figure 3-7 appears.

Figure 3-7 Incremental Deployment Component Selector

%1 Advanced Incremental Selector x|

|| Configuration

[1#] Trunk Groups

|1 Trunks

[1¥] Routes

[i¥] Dialplans
=
=

If you have only made configuration changes to one or more of the areas listed, you can direct the VSPT
to compare only those areas with the current configuration, and your modifications can be deployed
more quickly.

If you select areas in this window, make sure to include all areas that you have modified.

Select one or more component types to deploy, and click OK.
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Telnet

Step 4

Step 5

Step 1

Telnet W

Go to Step 6 in the “Deploying a New Configuration” section on page 3-5, and complete the procedure
described there. When you click OK, a screen similar to the one displayed in Figure 3-8 appears.

Figure 3-8 Confirm MML Commands

0 x|

prov—stansrcver="temp_011101B" dstver="nssu—docs", confirm -
prov—addienetif:name="enet—3",desc="interface in slot",card="card-2"
prov—addienetif:name="enet—3", desc="interface in slot",card="card-2"
prov—addiopcname="opc—1"type="TRUEQPC", netaddr="1.2.3" netind=2, desc=
prov—addiapcname="stp—1" netaddr="1.2.4" netind=2,desc="Adjacent Point C
prov—addiapcname="stp—2".netaddr="2.2.2" netind=2,desc="Adjacent Point C
prov—addidpcname="dpc—1" netaddr="1.2.5" netind=2,desc="Point Code"
prov—addiinksetname="Inkset—-2"type="I1P" apc="dpc—1", desc="Lnkset", proto=
prov—add:inksetname="Inkset—1"type="IP" apc="stp—1", desc="Lnkset", proto=|
prov—add:icZiplnkname="c7ip—1"timeslot=0,pri=1,desc="C7Iplink",if="enet—1
prov—addiss7 path:name="ss7p—2"custgrpid="0000", desc="557 Signaling Serv
prov—addiss7 path:name="ss7p—1"custgrpid="0000", desc="557 Signaling Serv
prov—addiss7route:name="ss7r—-3" pri=1,desc="357 Route",opc="opc—1",dpc="(
prov—addiss7route:name="ss7r-2", pri=1,desc="357 Route",opc="opc—1",dpc="(
prov—addiss7route:name="ss7r—4", pri=1,desc="357 Route",opc="opc—1",dpc="(
prov—addiss7route:name="ss7r—1" pri=1,desc="357 Route",opc="opc—1",dpc="(
prov—addigtdparam:name="gtd-2"gtdparamstring="acladi,app.atp"
prov—addigtdparam:name="gtd-1"gtdparamstring="aLL"
prov—addigtdparam:name="gtd-3"gtdparamstring="aLL"

prov—addiextnode name="extnode—peersIt" type="SLT".desc="External Node"
prov—addiextnodename="extnode—st", type="sLT", desc="External Mode"
prov—addiextnodename="extnode—-5300" type="455300", desc="External Node
prov—addiextnodename="extnode—2260" type="MGX2260", desc="External Mo,
] 3

fes Mo

70490

Inspect the MML commands, modify them if desired, and click Yes to continue with the incremental
deployment. Click No to reissue the deployment as a new configuration.

Telnet is an application based on the Telnet protocol that allows you to connect to remote computers.
V SPT Release 2 provides a utility to open atelnet session directly to a network device. Once you have

established your telnet connection, you then log in to that device and execute commands remotely on the
device through your telnet interface.

Use the following procedure to open atelnet session with a network device;

Click Tools > Telnet on the main VSPT menu. The screen shown in Figure 3-9 appears.

[ oL-1910-02
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Il MGC Viewer

Figure 3-9 Select Remote Network Device

¥ Telnet x|
Select, or specify a network device
hezuweca3 - Go
Cancel

4142

Step2  Select adevice from thelist, or enter the name or | P address of a device on your network, and click Go.

A screen similar to the one shown in Figure 3-10 appears.

Figure 3-10 Log In to Remote Device

xeene: =
Trying 1¥2,16,31.3...
Connected to nesuvsc?d,
Ezcape character iz "°17,

Sunls 5.8

login: |

4143

MGC Viewer

The MGC Viewer allows you to view, activate, remove, and synchronize configurations on the MGC.
Use the following procedure to view configurations on a Cisco MGC:

Step1  Click Tools > M GC viewer on the main VSPT menu. On the MGC Configuration screen that appears,

click File> Open MGC. A screen similar to the one in Figure 3-11 appears.
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MGC Viewer W

Figure 3-11 Select MGC

% Open MGC Config x|

Hoztname | |

) Login mgcusr |

Pazsword || |

(K Cancel

Step2  Enter the host name of the MGC in the Hostname box, enter the MGC login and password, and click
OK. A screen similar to the one in appears and lists all configurations on the specified MGC.

& MGC Configurations =10 x|

File Miew Configuration
2 nEsuvEcdd
— acause [May 23 2002 103331
— bCausze [May 10 2002 10:57]
= jhios10-1 [Jun 3 2002 13:521
— jho510-2 [May 30 2002 11:531
— kaiTest [May 3 2002 15:22]
- kaiw [May 10 2002 15:061
- Miztral93l_sw_a [May & 2002 15:49]
— HMiztrald931_sw_b [May 21 2002 18:24]
— Miztral _93_switched [Jun 18 2002 16:31]
— newtest [Jun 3 2002 17:071
- rn—test-1 [Jun 3 2002 15:08]
- rm—test-2 [Jun 3 2002 14:15]
— rm-test-3 [Jun 3 2002 15:101
- & rml [Jun 4 2002 131041
— testocl [Jun 3 2002 13:35]
L tr [Jun 3 2002 14:171
B =
z

Step3  Click Configuration on the MGC Viewer menu bar, and select one of the following actions:
Activate—
Synchronize—

Delete—
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State Operation

The State Operation utility provides the ability to query the active configuration on the Cisco MGC for
the state of managed objects. After a query, you can modify the state of an object and apply the update
to the MGC.

Use the following procedure to query the state of managed objects on the Cisco MGC:

Step1  Click Tools > State Operation on the main VSPT menu. A screen similar to the one in appears.

Figure 3-12 State Operation Dialog

i% State Dperations =10 x|

File

& Unknown host
| Interface :

&= Signaling : X
Trunk Group : O X
External Made

Retrieve state information from nssuwsc2d 7

[k Cancel

Step2  Click OK. The VSPT queries the MGC and a screen similar to the one in appears.
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Figure 3-13 MGC Managed Objects

[¥1 State Operations -0 x|

File
G nssUVsCEE
Interface
5 Signaling
Apc
Faint Code
&= Linksets
557 Service :
“- 557 Signaling Ga| -
Lsip :
— Trunk Group
¢ External Mode

]

g4140

Step3  Expand the hierarcal tree in the left pane of the State Operations window to locate and highlight the
object for which you want to know the state. In this example, we will display the state of linkset2. A
window similar to the one in will appear and the right pane will display information about the state of
the object you selected.

Figure 3-14
_ioi ]
File
ST
~ Point Code
2 Linksets Linkset serwvice state: Az of Fri Jun 23 14:12:193 EDT 2002
- 1s1 Linkzet name: |s2
Clkz Current state:
| 123 : AO0S
L s4 ChangeTo |<UN5ET> =
- Is5
]
=17
: :23 | Modify | | Commit | | Refresh
4] 7
&l
&

Step4  From this window, you can modify the state by selecting the desired state in the ChangeTo box. Click
M odify to change the state in this window, and click Commit to change the state on the Cisco MGC. To
guery the object again, click Refresh.

Perform an Audit

You can use an audit to ensure that both the Cisco MGC and a BAMS server supporting the MGC host
have consistently configured signal paths. The audit involves examines signal path and bearer channel
data on both servers, comparing the data, and reporting any differences.

Use the following procedure to perform an audit:

Cisco Voice Services Provisioning Tool Release 2.3(1) User's Guide
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Step 1

Step 1
Step 2
Step 3
Step 4
Step 5

Click Tools > Audit on the main VSPT menu. The screen shown in Figure 3-15 appears.

Figure 3-15 Perform an Audit

Y5C information
Hostname | |
Login [mgcusr |
Passuord | |
Lonfig | || Select |
BAMS information
Hostname | |
Hode |1 - |
Login [bams |
Passuord | |
Lonfig | || Select |
Audit Close

70480

Enter the MGC hostname, login, and password in the top pane of the window.

To specify the configuration to audit, click Select, highlight the configuration to audit, and click OK.

Enter the BAM S hostname, login, and password in the bottom pane of the window.

To specify the configuration to audit, click Select, highlight the configuration to audit, and click OK.

Click Audit. A screen similar to the one displayed in Figure 3-16 appears.
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Figure 3-16 Audit Results

0 =10]x]
Trunkarp | # of Circuits | Trunkarp | # of Circuits

2182 120 [

4040 30

2181 30

2016 1710

4012 120

4011 30

4010 30

2012 120

2011 30

1221 120

1021 30

4032 1200

2173 E

4031 120

2172 30

4030 30

2171 30

1181 30

3012 210

1015 1710

3011 30 |7

1012 L

Close é
=

The left pane displaysthe signal path and bearer channel data configured on the MGC host, and the right
pane displays the same data configured on the BAMS server.

Back Up and Restore

The VSPT backup and restore tool allows you to create, modify, and delete scheduled backups and
restores hourly, daily, weekly, monthly, or on demand. You can perform back up and restore activitieson
any of the following devices if they have been configured for the MGC:

Note

MGC Host—Active configuration
CAT5500—Configuration and image in Flash
CAT2900X L—Running-config and image in Flash
SLT2600—Running-config and image in Flash
BAMS P2—Active configuration

BAMS P3—Active configuration

HSI Adjunct Server—Active configuration

The backup and restore tool also provides the status of each activity and generates user-viewable status
logs.

Thistool operates in coordination with the MGC server operating system and can be performed by one
UNIX login (specified during the installation process).

[ oL-1910-02
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Schedule a Backup or Restore

To schedule a backup or restore, use the following procedure:

Step1  Click Tools > Backup and Restore on the main VSPT menu bar. The screen shown in Figure 3-17
appears.

Figure 3-17 Backup and Restore Utility

File

g My Schedule

= MGC

= CATZ2a00xL
& CATSE00
e CATES0D

— SLTZ2E800

— BamsPZ

— BamsP3

= HE5|

B

Step2  Click the component for which you want to schedule a backup. In the following example, the MGC
component configuration is backed up. A screen similar to the one shown in Figure 3-18 appears when
you click the MGC component.

g4130

Figure 3-18 Scheduling a Backup or Restore

RI=TEY

File

o My [Elél::edme | [Add/View Schedules [Status |

- CATZO00% L Schedule ID || Host || Schedule Tupe
&= CATSS00 :

& CATE509
L L2600
L BamsP2
L BamsP3

= H5|

| Add || Hodify || View H Telete |

El

84131
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Step 3

Note

Step 4
Step 5
Step 6
Step 7
Step 8

Step 9
Step 10
Step 11

Step 12

Back Up and Restore

If you want to perform arestore, you must have a backup file alreadycreated and available on the MGC.

Highlight the component you want to back up or restore in the left pane of the main backup and restore

tool window, and click Add. A screen similar to the one shown in Figure 3-19 appears.

Figure 3-19 Schedule an Activity

%1 Add MGC Schedule

Actiong |Backup -

HGE IP: |
MGE Loging [
HEC Password: |

File Mame: [

File Type: |E0nFiguration hd

|
|
|
|
|
|
TFTP IP: | |
|
|
|
|
|

TFTP Loging [
TFTP Password: |

Log Yerbose: |No v

Schedule Tupe: | Harthly v

Select/View Files on TFTP

Hinute 3 ’—0 :
Hour ¢ ,m
Day Of Month &[4 -

70484

The fields available on the Schedule an Activity screen vary according to the component selected.

In the Activity field, select the action you want to perform. Choices include backup and restore.
Enter the | P address of the Cisco MGC.

Enter the MGC login and password.

Enter a name for the backup file.

In the File Type drop-down list, select one of the following:

¢ MGC System—Backs up datafiles for the active configuration, the Times Ten database, the
XEconfigParm.dat file, and UNIX configuration files.

e MML Config—Backs up exported MML files for the active configuration on the MGC
Enter the | P address of the TFTP server.
Enter the TFTP login and password.

Specify whether or not to use verbose log mode. Verbose mode records all commands issued by the

V SPT and any system responses.
Select the schedule type. Choices include:

[ oL-1910-02
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e Monthly
e Daily
e Hourly
o Weekly
e Now
e Later
Step13  Select the hour and minute that the backup should begin.

Step14 Click OK. The backup activity is scheduled, and a screen similar to the one shown in Figure 3-20
appears.

Figure 3-20 Display Activity Schedule

¥l Backup and Restore - O] x|
File

% My Schedule rﬂdd.f"v'iew Schedules rStatus |
ES.'(I':ZQOOXL ‘|Schedule ID]_ Host | Schedule | Minutes | Hour |  Day | Month | ‘week
3 f e e #*
? CATSS00 5510029044m1?238J1”.DaHy E 3

& CATES09
SLTZ600
BamsPZ2
BamsP3
HSI

B

3

| hdd || Modify || View || Delete

After the backup has been completed, the status of the activity isimmediately available. The backup file
with the name you specified is available for use with the VSPT.

Check Status of Backup or Restore
The VSPT generates status logs that provide information about each scheduled activity. The status log
displays the following information for the activity:
¢ Date and time when activity began
e Success or failure
¢ File name on the TFTP server
¢ Directory of configuration files
¢ Imagefile name

If you specified verbose log mode, the status log also displays the sequence of commands issued by the
V SPT and any system responses.

Use the following procedure to check the status of a backup or restore activity:

Step1  In theleft pane of the backup and restore tool window, click the device that has been backed up or
restored. Click the Status tab in the right pane.

Step2  Highlight the backup or restore for which you want information.

Step3  Select the appropriate button for the action you want to perform. Choices are:
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¢ Show status—Displays the log file for the activity.
¢ Acknowledge—Removes the text from the Status window and deletes the log file from the server.

¢ Clear—Removes the text from the Status window, but the log file remains on the server.

Make a Seed File

A seed fileis afile created by the VSPT that contains the |P addresses of all of the devicesin the
Cisco MGC network, plus the relationship (hierarchy) between the devices. With thisfile, Cisco MNM
can automatically deploy all the elements in the network that have been configured with the VSPT.

For information about deploying a seed file, refer to the Cisco MNM Release 2.1or 2.3 User’s Guide.
Use the following procedure to make a seed file;

Step1  Click Tools > Make a Seed File on the main VSPT menu. The screen shown in Figure 3-21 appears:

Figure 3-21 Make a Seed File

1% Seed File Dialog x|

|fvarfopthSCOvs p22/data/mac/mistral/Cancun—1/wORKING/see d.file" Select |

Cancel

70493

Step2  Enter the path and afilename, or click Select and specify a directory for the file. You can also choose
the default, which is /var/opt/<basedir>/data/mgc/mistral/<configuration name>/WORKING/seed file.

Step3  Click OK. A seed fileis created in the directory you specified.
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