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Preface

This preface describes the objectives, audience, organization, and conventions of this document. It 
contains the following sections:

• Document Objective, page v

• Audience, page vi

• Document Organization, page vi

• Terminology, page vi

• Document Conventions, page vii

• Documentation Suite, page vii

• Obtaining Documentation, page viii

• Obtaining Technical Assistance, page ix

• Document Change History, page xi

Document Objective
This document provides the information you need to install, configure, and use the Voice Services 
Provisioning Tool (VSPT), Release 2.2. You should read the system-level documentation supplied with 
your system before using this guide. A complete list of these documents is included in the Cisco Media 
Gateway Controller Software Release 9 Installation and Configuration Guide that ships with your 
system.

Note This document uses the term media gateway controller software or MGC application to mean the 
Cisco MGC software that runs in the UNIX environment on a server. The term MGC refers to the 
combination of this software and the server. The Cisco MGC communicates with the SS7 network to 
process and route calls between a traditional time-division multiplexing (TDM) network and a packet 
data network. This routing takes place through a variety of media gateways, standalone devices that 
perform the conversion between the TDM and data network formats.

Note The Cisco PGW 2200 PSTN Gateway (hereafter referred to as the Cisco PGW 2200) was formerly called 
the Cisco VSC3000. Some parts of this document might use this older name. 
v
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Preface
Audience
Audience
This document is designed for network operators and administrators who have experience with 
telecommunications networks, protocols, and equipment and who have familiarity with data 
communications networks, protocols, and equipment. Software and hardware installers and network 
designers will also find this document useful.

Document Organization
Table 1 describes the major sections of this document.

Terminology
The following terms are used in this document:

Cisco MGC host—A Sun host server running Cisco MGC software. If your product is the Cisco SC2200, 
this is also known as an SC host. If your product is the Cisco PGW 2200, this is also known as a PSTN 
Gateway host.

Cisco SC node—The combination of the Cisco SC2200 product and the control signaling network. The 
SC node consists of all solution components except the media gateway. 

Cisco MGC node—The logical grouping of the active and standby MGC hosts, the control signaling 
network, and the Cisco Signaling Link Terminals (SLTs). 

Simplex MGC node—A node that uses a single Cisco MGC host. Typically, nodes of this type are used 
for solution evaluation tests or for small installations. Any loss of service in the Cisco MGC host 
disrupts all call traffic. If your product is the Cisco SC2200, this is also called a simplex SC node.

Continuous-service MGC node—A node that uses two Cisco MGC hosts to prevent system downtime 
that might otherwise result from the failure of a single MGC host. Calls in progress are maintained when 
one MGC host fails. Continuous-service nodes use SLTs to preprocess SS7 signaling and distribute 
signaling to both MGC hosts. If a failover occurs, all stable calls are maintained. If your product is the 
Cisco SC2200, this is also called a continuous-service SC node. 

Table 1 Document Organization

Chapter Title Description

Chapter 1 Voice Services Provisioning 
Tool Overview

This chapter introduces VSPT, 
Release 2.2, and provides directions for 
obtaining and installing the software. In 
addition, it provides basic information for 
using the tool.

Chapter 2 Provisioning with VSPT Wizards This chapter introduces VSPT wizards 
and provides an example of configuring a 
Cisco Media Gateway Controller (MGC) 
through the use of a wizard.

Chapter 3 Voice Services Provisioning 
Tool Utilities

This chapter introduces additional tools 
included with VSPT 2.2 and provides 
directions for using them.
vi
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Document Conventions
Document Conventions
Notes use the following conventions:

Caution Means reader be careful. In this situation, you might do something that could result in equipment 
damage or loss of data.

Note Means reader take note. Notes contain helpful suggestions or references to material not covered in the 
publication.

Documentation Suite
The following documentation provides information about the Cisco MGC software and the solutions it 
supports, including the Cisco SS7 Interconnect for Access Servers Solution, the Cisco SS7 Interconnect 
for Voice Gateways Solution, and the Cisco Packet Tandem Solution.

Hardware Documentation
• Cisco Media Gateway Controller Hardware Installation Guide

• Regulatory Compliance and Safety Information for Cisco Media Gateway Controller Hardware

Software Installation and Configuration Documentation
• Cisco Media Gateway Controller Software Release 9 Installation and Configuration Guide

• Cisco Media Gateway Controller Software Release 9 Provisioning Guide

• Cisco Media Gateway Controller Software Release 9 Dial Plan Guide

• Cisco Media Gateway Controller Software Release 9 Operations, Maintenance, and 
Troubleshooting Guide

• Release Notes for the Cisco Media Gateway Controller Software Release 9

• Cisco Media Gateway Controller Online Documentation Notice

• Cisco Media Gateway Controller SLT Documentation Notice

Gateway Documentation
Cisco DAS and H.323 VoIP Gateway Installation and Configuration Guide

Documentation Map
Figure 1 shows the sequence in which the various manuals documenting Cisco telephony solutions 
should be read.
vii
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Obtaining Documentation
Figure 1 Documentation Map

Obtaining Documentation
The following sections provide sources for obtaining documentation from Cisco Systems.

World Wide Web
You can access the most current Cisco documentation on the World Wide Web at the following sites:

• http://www.cisco.com
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Obtaining Technical Assistance
• http://www-china.cisco.com

• http://www-europe.cisco.com

Documentation CD-ROM
Cisco documentation and additional literature are available in a CD-ROM package, which ships 
with your product. The Documentation CD-ROM is updated monthly and may be more current than 
printed documentation. The CD-ROM package is available as a single unit or through an 
annual subscription.

Ordering Documentation
Cisco documentation is available in the following ways:

• Registered Cisco Direct Customers can order Cisco Product documentation from the Networking 
Products MarketPlace:

http://www.cisco.com/cgi-bin/order/order_root.pl

• Registered Cisco.com users can order the Documentation CD-ROM through the online Subscription 
Store:

http://www.cisco.com/go/subscription

• Nonregistered Cisco.com users can order documentation through a local account representative by 
calling Cisco corporate headquarters (California, USA) at 408 526-7208 or, in North America, by 
calling 800 553-NETS(6387).

Documentation Feedback
If you are reading Cisco product documentation on the World Wide Web, you can submit technical 
comments electronically. Click Feedback in the toolbar and select Documentation. After you complete 
the form, click Submit to send it to Cisco.

You can e-mail your comments to bug-doc@cisco.com.

To submit your comments by mail, use the response card behind the front cover of your document, or 
write to the following address:

Attn Document Resource Connection
Cisco Systems, Inc.
170 West Tasman Drive
San Jose, CA 95134-9883

We appreciate your comments.

Obtaining Technical Assistance
Cisco provides Cisco.com as a starting point for all technical assistance. Customers and partners can 
obtain documentation, troubleshooting tips, and sample configurations from online tools. For Cisco.com 
registered users, additional troubleshooting tools are available from the TAC website. 
ix
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Obtaining Technical Assistance
Cisco.com
Cisco.com is the foundation of a suite of interactive, networked services that provides immediate, open 
access to Cisco information and resources at any time, from anywhere in the world. This highly 
integrated Internet application is a powerful, easy-to-use tool for doing business with Cisco.

Cisco.com provides a broad range of features and services to help customers and partners streamline 
business processes and improve productivity. Through Cisco.com, you can find information about 
Cisco and our networking solutions, services, and programs. In addition, you can resolve technical 
issues with online technical support, download and test software packages, and order Cisco learning 
materials and merchandise. Valuable online skill assessment, training, and certification programs are 
also available.

Customers and partners can self-register on Cisco.com to obtain additional personalized information and 
services. Registered users can order products, check on the status of an order, access technical support, 
and view benefits specific to their relationships with Cisco.

To access Cisco.com, go to the following website:

http://www.cisco.com

Technical Assistance Center
The Cisco TAC website is available to all customers who need technical assistance with a Cisco product 
or technology that is under warranty or covered by a maintenance contract.

Contacting TAC by Using the Cisco TAC Website

If you have a priority level 3 (P3) or priority level 4 (P4) problem, contact TAC by going to the TAC 
website:

http://www.cisco.com/tac

P3 and P4 level problems are defined as follows:

• P3—Your network performance is degraded. Network functionality is noticeably impaired, but most 
business operations continue.

• P4—You need information or assistance on Cisco product capabilities, product installation, or basic 
product configuration.

In each of the above cases, use the Cisco TAC website to quickly find answers to your questions. 

To register for Cisco.com, go to the following website:

http://www.cisco.com/register/

If you cannot resolve your technical issue by using the TAC online resources, Cisco.com registered users 
can open a case online by using the TAC Case Open tool at the following website:

http://www.cisco.com/tac/caseopen

Contacting TAC by Telephone 

If you have a priority level 1 (P1) or priority level 2 (P2) problem, contact TAC by telephone and 
immediately open a case. To obtain a directory of toll-free numbers for your country, go to the following 
website:
x
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Document Change History
http://www.cisco.com/warp/public/687/Directory/DirTAC.shtml

P1 and P2 level problems are defined as follows:

• P1—Your production network is down, causing a critical impact to business operations if service is 
not restored quickly. No workaround is available.

• P2—Your production network is severely degraded, affecting significant aspects of your business 
operations. No workaround is available. 

Document Change History
Table 2 Change History

Subject Document #, Change Date Change Summary

Initial release OL-1910-01, February 15, 2002 Initial online release
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C H A P T E R 1

Voice Services Provisioning Tool Overview

Cisco Open Packet Telephony (OPT) provides the framework for delivering voice services over 
packet-based data, voice, and video networks. OPT encompasses a broad range of hardware platforms 
and Cisco software, delivering a continuum of voice solutions from core infrastructure to enhanced 
services over circuit and packet networks. The Cisco Media Gateway Controller (MGC) is at the center 
of all Cisco OPT solutions.

Provisioning an MGC is the process of preparing it to communicate with an SS7 network, with 
Cisco media gateways, and with the other components of an OPT solution. The Cisco Voice Services 
Provisioning Tool (VSPT) provides an easy-to-use graphical tool to provision Cisco MGCs. 

This chapter introduces the VSPT, Release 2.2, and provides directions for obtaining, installing, and 
using the software. 

Note VSPT Release 2.2 is designed to be used with Cisco MGC software Release 9.2. If you are using an 
earlier release of the MGC software, you must use VSPT Release 1.6 or 2.1.

This chapter contains the following sections:

• Provisioning Introduction, page 1-1

• VSPT Introduction, page 1-2

• Installing the VSPT, page 1-2

• VSPT Basics, page 1-6

• Starting the VSPT, page 1-8

• Using the VSPT, page 1-9

• Defining Users and Permissions, page 1-11

• Exiting the VSPT, page 1-12

Provisioning Introduction
All solutions involving the Cisco MGC are configured through the use of one or more Cisco MGC hosts, 
one or more Signaling System 7 (SS7) network signaling options, and one or more media gateways that 
control bearer-traffic routing. 
1-1
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Chapter 1      Voice Services Provisioning Tool Overview
VSPT Introduction
Note In this document, a solution is a logical combination of Cisco hardware and software configured to 
perform a specific network task.

Prior to starting any provisioning session, you should have a clear understanding of the network 
topology for your solution. Create a network drawing, and refer to it while configuring your network.

In addition, you should perform the following tasks before starting a provisioning session:

• Thoroughly plan your network configuration. Refer to the documentation for your solution for 
detailed network configuration information.

• Set up your system hardware, and install all required software. For more information, refer to 
Prerequisites, page 1-3, and the following documents

– Cisco Media Gateway Controller Hardware Installation Guide

– Cisco Media Gateway Controller Software Release 9 Installation and Configuration Guide

VSPT Introduction
The VSPT can be deployed as an integrated component of the Cisco MGC Node Manager or as a 
standalone application. If it is installed on the Cisco MGC, call throughput might be impacted when the 
VSPT is active. It typically runs on a standalone UNIX server that is also running the Cisco MGC Node 
Manager (CMNM) and supports multiple users and provisioning sessions. You can launch the VSPT 
from the managed object icon in the CMNM map viewer. For informtion about CMNM, refer to the 
CMNM Release 2.1 User’s Guide.

VSPT allows you to import an existing configuration, modify the configuration, and export it to the same 
or different devices. Wizards guide you through high-level configuration steps to create the initial 
network provisioning information for a newly installed node, creating iterative entries from a single 
operation. VSPT can also facilitate provisioning of individual call parameters, simplifying the 
provisioning of a large live network.

During a provisioning session, the VSPT automatically generates the Man Machine Language (MML) 
or command line interface (CLI) scripts used to configure network elements, assembles these commands 
into a batch file, and deploys the file to the appropriate network device. 

Note This document does not include instructions for dial plan provisioning. For dial plan information, refer 
to the Cisco Media Gateway Controller Software Release 9 Dial Plan Guide.

Installing the VSPT
If you are a registered Cisco.com user, you can download the VSPT software from the Cisco web site. 
Before installing the VSPT, you must verify the following:

• You have the latest release of the VSPT software. Visit the following Cisco web site to check the 
VSPT release number (a valid login to the VSPT Cisco web site is required):

http://www.cisco.com > Software Center > Voice Software > Cisco Voice Services 
Provisioning Tool

• You have met the workstation hardware and software requirements.
1-2
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Chapter 1      Voice Services Provisioning Tool Overview
Installing the VSPT
• You have established network connectivity between your workstation and the network elements. 

• The network elements have the correct release of software installed. 

Note Make sure you have root access on your Sun workstation (sudo access is not adequate).

Tip Before you begin provisioning, you should have a list of components you want to provision, including 
the component names, IP addresses, properties, and other parameters. To create this list, use the 
instructions provided in the Cisco Media Gateway Controller Software Release 9 Provisioning Guide. 
In addition, descriptions of the properties and values contained in the VSPT are included in Appendix 
A of the Cisco Media Gateway Controller Software Release 9 Provisioning Guide and in the following 
chapters. Review this information before you begin provisioning, and keep it available for reference 
during provisioning.

Prerequisites
To install the VSPT software, you must have the following:

• Sun SPARCstation running Solaris Version 2.8 or earlier 

• Sun Ultra-5 workstation (333 MHz or faster)

• Sun Solaris 2.8 or earlier

• Open Windows with the Common Desktop Environment

• Latest Solaris 2.8 recommend patch set (log in to http://sunsolve.sun.com and click on Patches)

• Cisco Media Gateway Controller software Release 9.2

• 8-bit video graphics card

• Disk space:

– Approximately 20 MB of disk space for installation

– Directory /var/opt/data/:

Approximately 1 MB for each configuration

Approximately 1 MB for each configuration snapshot

– Directory /var/opt/log/:

Approximately 0.5 MB for each deployment

• RAM:

– Minimum: 128 MB

– Recommended: 256 MB or greater

• Swap space:

– Minimum: 128 MB

– Recommended: 256 MB or greater

Note Running the VSPT on the same host as the Cisco MGC can adversely affect performance. We 
recommend using a standalone server.
1-3
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Chapter 1      Voice Services Provisioning Tool Overview
Installing the VSPT
Preplanning
VSPT supports multiple solutions and offers the option to provision components for these solutions. 
Some components might not apply to your solution. Make sure you understand your solution component 
requirements. For information, refer to the provisioning guide for your solution.

Upgrading VSPT Software
If you have a previous release of the VSPT installed (such as VSPT Release  2.0) and you are upgrading 
incrementally to VSPT Release  2.2, the existing VSPT data is automatically moved to VSPT 
Release 2.2. However, if a major earlier release  is detected during the upgrade, (such as VSPT 
Release 1.6) and you are upgrading to VSPT Release 2.2, the existing VSPT data is not formatted for 
use with VSPT Release 2.2 and is not be moved.

Two versions of the VSPT (such as VSPT 1.6 and 2.2) can exist on the same system; when you are 
upgrading, the older version is not automatically removed and must be manually uninstalled if you want 
to remove it. See the “Uninstalling the VSPT Software” section on page 1-5 for information.

Note Since the uninstall directory and files are removed during uninstall, do not change to the /opt/CSCO21 
directory to run the uninstall script.

Saving Configuration Files

Before uninstalling the VSPT software, you can save current configuration data and administrative 
information so users and logins do not need to be recreated after the upgrade. Use the following 
procedure to save data and user information:

Step 1 Log in to the server as root.

Step 2 Create a temporary directory to hold the pertinent files.

Step 3 Use the following command to copy the password file, /var/opt/CSCOvspXX/etc/dartpwd.txt, to the 
temporary directory:

# cp -p /var/opt/CSCOvspXX/etc/dartpwd.txt /<temporary directory>/dartpwd.txt

Step 4 Change to the /var/opt/CSCOvspXX/data directory.

Step 5 Use the tar commend to archive all files in the directory.

Note The tar command preserves file permissions.

Step 6 Copy the archive file to the temporary directory.

After you upgrade the VSPT software, replace the /var/opt/CSCOvsp<New>/etc/dartpwd.txt file and the 
/var/opt/CSCOvsp<New>/data directory with the archive files you saved in the temporary directory.
1-4
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Installing the VSPT
Uninstalling the VSPT Software

The uninstallation process removes the /var/opt/CSCOvspt21 directory created by the installation 
process. If a directory contains a file that was not created during the installation process, it is not 
removed and is logged in the uninstall.log file. This might occur in the data and logs directories, and all 
application data stored in the /var/opt/CSCOvsp21 directory will not be deleted.

Use the following procedure to uninstall the software:

Step 1 Enter the following commands:

>su -root

>cd /

>/opt/CSCO21/uninstall/uninstall

Step 2 Proceed with the VSPT software installation (see “Installing the VSPT Software” section on page 1-5).

Installing the VSPT Software
To install the software from the Cisco web site, follow this procedure:

Step 1 Verify that the requirements listed in the “Prerequisites” section on page 1-3 have been met.

Step 2 Become the root user by entering the following command: 

>su - root

Step 3 Create the temporary directory /var/tmp/CSCOvsp22-install by entering the following command:

#mkdir -p /var/tmp/CSCOvsp22-install

Step 4 Open a web browser and browse to the following site: 

http://www.cisco.com> Software Center > Network Management> Cisco Voice Services 
Provisioning Tool

Step 5 Select the desired release number.

Step 6 Download the software to the temporary directory /var/tmp/CSCOvsp22-install.

Step 7 Extract the software image using the following tar command:

#tar xvf <filename>.tar

Step 8 Run the setup program by entering the following command:

#./setup

Note As an alternative to Step 8, you can avoid the GUI and install the VSPT in TTY mode by entering the 
command ./setup -nodisplay and following the onscreen prompts. An X-server must be running, and the 
DISPLAY environment variable must be properly configured. Use one of the following commandsto set 
the x-display variable. Your choice of a command depends on which shell you are using.

In “csh” or “tcsh”: setenv DISPLAY <hostname>:0
In “sh” or “ksh”: DISPLAY=<hostname>:0;export $DISPLAY
1-5
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VSPT Basics
Step 9 Follow the onscreen prompts.

Note If a previous version of the Cisco VSPT is installed on the workstation, you will be asked if you want to 
uninstall it. If you answer no, the installation is aborted.

Step 10 Remove the /var/tmp/CSCOvsp22-install directory when the installation is complete by entering the 
following command:

#rm -rf /var/tmp/CSCOvsp22-install

Step 11 Change to the installation directory, /opt/CSCOvsp22, by entering the following command:

#cd /opt/CSCOvspt22

Step 12 Run the CSCOvsp22 program by entering the following command:

#./vspt

Installation of the VSPT software is now complete. Table 1-1defines the default VSPT directories and 
files. If you have questions or need assistance, see the Obtaining Technical Assistance section.

.

VSPT Basics
This section describes the requirements for entering provisioning data using the VSPT.

VSPT Field Definitions
Table 1-2 lists VSPT field names, which correspond to system components in the Cisco MGC, and their 
definitions. For more information about system components, refer to the Cisco Media Gateway 
Controller Software Release 9 Provisioning Guide.

Table 1-1 VSPT Installation Directories and Files

/opt/CSCOvsp22

vspt VSPT application script

classes/ Class and property files

images/

jre/ Java Runtime Environment

uninstall/ Uninstall script directory

version VSPT version

/var/opt/CSCOvsp22 (home directory)

data/ Configuration files

logs/ Log files

/etc
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.

Table 1-2 Field Name Definitions

Field Name Definition

MGC Host An origination point code (OPC) is the address of the 
Cisco MGC you are provisioning.

Interfaces (Cards) Ethernet hardware cards and virtual interfaces (connections) 
for the Ethernet cards in the Cisco MGC host.

Adjacent Point Code An adjacent point code (APC) is the address of an STP1 that 
sends and receives signaling messages to and from the 
Cisco MGC.

1. STP = signal transfer point.

LinkSet A LinkSet is a set of links from the MGC to an endpoint, such 
as an adjacent STP.

C7 IP Link A link to the SS7 network (for example, an SSP2 or STP) from 
the Cisco MGC through a Cisco SLT.

2. SSP = service switching point.

Mated Pair (SS7 
Subsystem)

A logical connection between a pair of mated STPs that allows 
the Cisco MGC to route through either STP to an endpoint.

Point Code A destination point codes (DPC) is the address of an endpoint, 
such as a PSTN3 switch that carries the bearer traffic.

3. PSTN = Public Switched Telephone Network.

SS7 Path(SS7 
Signaling Service)

An SS7 path is a connection between the Cisco MGC and a 
specified point code.

SS7 Route An SS7 route is a route for each signaling path from the 
Cisco MGC to the PSTN switch through the linksets you have 
created to the STPs.

External Node An external node is any object in the network that is connected 
to the Cisco MGC, for example, media gateways 
(Cisco MGWs) and associated BSCs4.

4. BSC = Broadband Service Card.

MGCP5 Signaling 
Service

5. MGCP = Media Gateway Control Protocol.

Figure 1-1 shows the relationship of VSPT field names and the corresponding system 
components.

An MGCP signaling service is a signaling service between the 
Cisco MGC and a media gateway. 

IPFAS Signaling 
Service

An IPFAS signaling service is a signaling service (over IP) 
between the Cisco MGC and a media gateway.

IP Link for MGCP 
and IPFAS

An IP Link for MGCP and IPFAS is a link for the MGCP and 
IPFAS signaling services.
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Figure 1-1 Component Relationships

VSPT Data Entry Requirements
When you are entering data into the VSPT windows, follow standard MML conventions for names and 
descriptions. Each MML name must have the following characteristics:

• A maximum of 20 alphanumeric characters, including dashes

• No space, underscore, or special characters

• Must start with an alphabetic character

• Must be lowercase

For example: name="dpc1"

MML descriptions can be as many as 128 characters and can include spaces and symbols. You should 
use a description that helps to identify the component or link that you are provisioning. For example, for 
an SS7 route, which indicates the signaling path from the Cisco MGC to a switch through a linkset, you 
could create a description “SS7 Route to PSTN Switch A through Linkset 1.” For more information 
about MML, refer to the Cisco Media Gateway Controller Software Release 9 MML Command 
Reference Guide.

The VSPT GUI enables you to step through the provisioning process in a logical sequence. The sequence 
of steps is described in the Cisco Media Gateway Controller Software Release 9 Provisioning Guide.

Starting the VSPT

Note See the Cisco Media Gateway Controller Software Release 9 Installation and Configuration Guide for 
information on setting up user privileges and access rights.

Perform the following steps to start the VSPT:

IP
link

External
Node

Point
Code

Adjacent
Point
Code

Ethernet
interface

Ethernet
adapter

MGCP
signaling

Linkset

IPFAS
signaling

SS7
signaling

(SS7 path)

C7 IP
link

SS7
subsystem

(mated pairs)

SS7
route

38
63

6

Adapter
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Step 1 Log in to the VSPT server or access it from a machine with X-window capability.

Step 2 In a terminal window, change to the default directory:

>cd /opt/CSCOvsp22

Navigate to the appropriate directory if you installed the VSPT in a different location.

Step 3 Enter the following command to start the VSPT:

>./vspt

The system opens X-windows, and the login screen shown in Figure 1-2 appears.

Figure 1-2 Login Screen

Step 4 Enter your user name and password and click OK.

The default Beta user uame is admin, and the password is also admin. The Welcome screen is displayed 
briefly during the login process, and the main window appears (see Figure 1-3).

Figure 1-3 Main VSPT Window

Using the VSPT
This section describes the VSPT menus and buttons and provides directions for using the tool functions.

Menu Bar
The VSPT provides a menu bar that contains the following selections:

• File

• View

• Tools
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• Help

Table 1-3 lists the File menu choices.

Table 1-4 lists the View menu command choices.

Table 1-5 lists the Tools menu command choices.

Table 1-3 File Menu Command Choices

Command Description

New Begin a new configuration session

Open Open an existing configuration

Import Import an existing configuration from an MGC or import trunk group, 
trunk, routing, or dial plan files into the VSPT

Export Export files from the VSPT

Save Save the current configuration:

• As Working

• As Snapshot

• As New Config

Note For more information on the different save options, see the 
“Starting a New Provisioning Session” section on page 3-6.

Exit Stop any open provisioning sessions and close the VSPT

Table 1-4 View Menu Command Choices

Command Description

MML Show generated MML for the current configuration

MGW Commands Show generated Cisco MGX 8850 commands for the current 
configuration

Trunk Group File Show generated trunk group file for the current configuration

Trunk File Show generated trunk file for the current configuration

Table 1-5 Tools Menu Command Choices

Command Description

Integrity Check Check your configuration for inconsistencies and missing information

Deploy Move the configuration to one or more target hosts and Cisco media gateways 
(MGWs)

Telnet Open a telnet session

MGC Viewer View MGC configuration.

MGX-8850 Wizard View and configure MGX 8850 hosts

BAMS Config View and configure a Billing and Measurements Server (BAMS)
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Table 1-6 lists the Help menu command choices.

Buttons
The VSPT provides buttons and explorer trees that you can use to move through the system. Click these 
buttons to add or change network components. The VSPT contains the following buttons:

• MGC Config—Add components and provision component properties

• Traffic—Create customer-specific files, including trunk groups, trunks, and routing

• Number Analysis—Provision a dial plan

The left pane of the main VSPT screen displays selectable components. The right pane of the screen 
displays data entry fields. Click a component to select it. To see all of the subcomponents for the 
component you select, click the icon next to the component name to expand the component list.

The Help menu selection displays the information about the current build release number.

Defining Users and Permissions
After you install the VSPT, you should define users and their respective permissions.

Use the following procedure to define users and their permissions:

Step 1 Log in to the server as root and start VSPT 2.2.

Step 2 Click Tools > User Admin on the menu bar.

The screen in Figure 1-4 appears.

State Operation View and configure the state of MGC components

Screening Editor View and configure screening number provisioning

Audit

Backup and Restore Create, modify, or delete scheduled backups or restores on the MGC Host, 
CAT5500, CAT2900XL, SLT2600, BAMS P2, or BAMS P3 components

Make a Seed File Use an existing configuration to create a text file that can be used by the 
Cisco MGC Node Manager (CMNM) to deploy or discover devices in the 
network

Table 1-5 Tools Menu Command Choices (continued)

Command Description

Table 1-6 Help Menu Command Choices

Command Description

About VSPT View information about the current version of VSPT, including the version 
number

VSPT User’s Menu View online help information
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Figure 1-4 VSPT User Administration

Step 3 Add, modify, or delete user definitions as follows:

• To add a user, enter a user name and password, click Permission, select the permission level, and 
click Add.

• To modify a user, select the user name, change the password or permission level, and click Modify.

• To delete a user, select the user name, and click Delete.

Exiting the VSPT
You can exit the VSPT at any time by performing one of these actions:

• Click File > Exit. Click OK at the resulting prompt.

• Click the close box in the upper right of the VSPT screen. Click OK at the prompt.
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Provisioning with VSPT Wizards

Wizards are utilities included in the Cisco Voice Services Provisioning Tool (VSPT) that can help you 
rapidly create a new MGC configuration deployment by providing a graphical user interface (GUI) for 
provisioning specific solutions. A wizard leads you through the steps of provisioning the Cisco  MGC 
and the external components of the solution you choose. 

Note A solution is a logical combination of Cisco hardware and software configured to perform a specific 
network task.

This chapter provides an example of using a wizard to configure a solution. It includes the following 
sections:

• Starting a New Provisioning Session, page 2-1

• Overview of the VSPT Wizards, page 2-2

• Using the Tandem Transit with STP Solution Wizard, page 2-3

Starting a New Provisioning Session
When you start a new provisioning session, you can choose to base the configuration on an existing 
configuration, by using the Import from MGC option, or you can use a configuration wizard, or you can 
perform the configuration manually. 

Use the following procedure to start a new VSPT provisioning session:

Step 1 Start and log in to the VSPT.

Step 2 Select File > New on the menu bar.

Step 3 Enter a name for the new configuration you will create, and click OK. The screen shown in Figure 2-1 
appears.
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Figure 2-1 Select Method for Creating Configuration

Step 4 If you want to import an existing configuration, click the Import from MGC radio button, and click 
Select; otherwise, click Perform Manual Configuration and proceed to Chapter 3, or choose the 
solution wizard to use.

Note This imports the Cisco MGC configuration only; it does not import gateway configurations. To 
import configurations for gateways, after importing the MGC configuration, select each gateway 
and import its configuration.

If you import an existing configuration, the screen shown in Figure 2-2 appears.

Figure 2-2 Select Configuration

Step 5 Select the configuration to import, and click OK. The configuration will be imported from your 
Cisco MGC.

Overview of the VSPT Wizards
The VSPT includes the following solution provisioning wizards:
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• SS7-PRI Gateway—Offloads modem dial traffic from competitive local exchange carrier (CLEC) 
switches and either forwards the calls, using SS7, to the destination CLEC switches or translates the 
primary rate access calls to integrated services digital network (ISDN PRI) to terminate them on the 
network access server (NAS) gateways.

• Tandem Transit with STP Links—Offloads modem dial traffic from CLEC switches and forwards 
the calls to the IP network through a signal transfer point (STP).

• Tandem Transit with SSP Links—Offloads modem dial traffic from CLEC switches and forwards 
the calls to the Interne Protocol (IP) network with no intermediate connection to STPs.

Each wizard automatically guides you through the steps involved in creating a provisioning 
configuration for a specific solution. A VSPT wizard:

• Lets you create configuration files across multiple devices, for example, MGCs 
and Cisco MGX 8850s

• Helps you avoid common errors when you are provisioning devices independently (for example, 
ensuring that you correctly match D-channels for PRI)

• Lets you avoid having to repeatedly enter duplicate data

• Creates the MML files and the Cisco  MGX 8850 command files you use to provision the 
Cisco MGC and MGX 8850

The example in this chapter uses a wizard to provision a tandem transit with STP links solution, but the 
process is similar for all VSPT wizards. Specific components and steps vary, depending on the solution 
wizard you are using; for a complete description of solution components, refer to the documentation for 
that solution.

When you finish the provisioning session, the VSPT wizard saves your configuration as the “active” 
configuration, and that configuration cannot be modified. To make changes, you must save the 
configuration with another name and deploy the new provisioning session to make it active.

The number of configurations you can store might be limited by available disk space. Consider deleting 
old or unwanted configurations, or save them to another machine, if you do not have sufficient disk 
space.

Note The provisioning procedures described in this chapter follow the sequence for provisioning a “typical” 
Cisco MGC described in the Cisco Media Gateway Controller Software Release 9 Provisioning Guide.

Using the Tandem Transit with STP Solution Wizard
The VSPT utility, Solution Wizard: Tandem Transit with STP Links, guides you step-by-step through 
the following procedures:

• Configuring the Cisco MGC, page 2-4

• Configuring SS7 Signaling Services, page 2-6

• Configuring Media Gateway Control Links, page 2-8

When you finish using the VSPT wizard, you must still configure the trunk groups, trunks, and routes. 
For more information, see the Cisco Media Gateway Controller Software Release 9 Provisioning Guide.
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Tip Before you begin provisioning, compile information about the solution components, including their 
names, IP addresses, and properties. Worksheets designed for collecting this information are provided 
in the Cisco  Media Gateway Controller Software Release 9 Provisioning Guide. Complete them before 
you begin provisioning, and refer to them during provisioning.

Configuring the Cisco MGC
Use the following procedure to provision a Cisco MGC using the Tandem Transit with STP solution 
wizard:

Step 1 Start a new provisioning session, and click File > New on the menu bar.

Step 2 Click the Solution Wizard: Tandem Transit with STP radio button, and click OK. A screen similar 
to the one in Figure 2-3 appears.

Figure 2-3 Specifying Cisco MGC Properties

Step 3 Enter the MGC IP address, for example, 172.31.157.1, in the MGC Hostname field.

Step 4 Enter a login ID and a password. 

Step 5 Click Next. A screen similar to the one in Figure 2-4 appears.
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Figure 2-4 Specifying MGC IP Addresses

Step 6 Enter the network addresses of the MGC (IP_Addr1 and IP_Addr2) in dotted decimal notation, for 
example, 172.18.145.38.

Step 7 Click Next.

Step 8 If the Cisco  MGC has a failover Cisco MGC, click the radio button next to Has a failover MGC, and 
enter the network addresses of the failover Cisco MGC (IP_Addr1 and IP_Addr2). Use dotted decimal 
notation. If there is no failover Cisco MGC, click the radio button next to Does not have a failover 
MGC. The IP_Addr 1 and IP_Addr 2 fields are not valid and are grayed out when there is no failover 
MGC. 

Step 9 Click Next. A screen similar to the one in Figure 2-5 appears, and SS7 signaling service provisioning 
begins.

Figure 2-5 Specifying a Point Code
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Configuring SS7 Signaling Services
Use the following procedure to configure SS7 signaling services:

Step 1 Enter a name, for example, OPC, in the Name field on the screen shown in Figure 2-5.

Step 2 Enter a description of the OPC, for example, Originating Point Code.

Step 3 Enter the OPC network address (NetAddr) in dotted notation, for example, 1.1.2.

Step 4 From the NetIndicator drop-down menu, choose a network indicator menu. There are four options.

• International—Used if the node is an international gateway.

• Spare—In countries where multiple carriers share point codes, networks are differentiated by this 
indicator.

• National—Used if the node routes calls through the national network (default value).

• Reserved—For national use. Do not use.

Step 5 From the OPC type indicator, choose either TRUEOPC or CAPOCP.

Step 6 Leave the True OPC indicator at <UNSET>.

Step 7 Click Next. 

Step 8 Enter the number of adjacent point codes (APCs) to create, corresponding to the number of Cisco  
MGX 8850 switches to be provisioned. Click Next. screen similar to the one in Figure 2-6 appears.

Figure 2-6 Specifying Properties for Each APC

Step 9 Enter the APC name.

Step 10 Enter a description of the APC.

Step 11 Enter the network address (NetAddr) in dotted notation; for example, 2.2.1.

Step 12 From the NetIndicator drop-down menu, choose the network indicator:

• International—Used if the node is an international gateway.

• Spare—In countries where multiple carriers share point codes, networks are differentiated by this 
indicator.

• National—Used if the node routes calls through the national network (default value).

• Reserved—For national use. Do not use.
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Step 13 Click Next. A series of screen similar to the one in Figure 2-6 appears sequentially for each APC you 
specified in Step 8.

Step 14 Repeat Step 9 through Step 13 for each APC screen. After you have configured properties for each APC 
you specified in Step 8, a screen similar to the one shown in Figure 2-7 appears. 

Figure 2-7 Specifying Properties for Mating APCs

Step 15 Enter the name prefix for the subsystem (default is mate).

Step 16 Choose the protocol family.

Step 17 Choose the transport protocol.

Step 18 Click Next. A screen similar to the one in Figure 2-8 appears.

Figure 2-8 Specifying a Protocol for Linksets

Step 19 Enter the name prefix for the linkset (default is lnkset).

Step 20 From the Linkset protocol drop-down menu, choose the linkset protocol for the linkset you are 
configuring. 

Step 21 Click Next. A screen similar to the one in Figure 2-9 appears.
2-7
Cisco Voice Services Provisioning Tool Release 2.2 User’s Guide

OL-1910-01



 

Chapter 2      Provisioning with VSPT Wizards
Using the Tandem Transit with STP Solution Wizard
Figure 2-9 Specifying Values for C7 IP lnks

Step 22 Enter the name prefix (the default is c7ip).

Step 23 Enter the network addresses (IP addr for SLT 1 and IP addr for SLT 2) in dotted notation; for example, 
172.16.145.38 and 172.16.145.40.

Step 24 Enter the local port on the SLT. 

Step 25 Click Next. A screen similar to the one in Figure 2-10 appears, and you can begin configuring media 
gateway control links.

Figure 2-10 Specifying the Number of Destination Point Codes
 

Configuring Media Gateway Control Links
Use the following procedure to configure MGC links for this solution.

Step 1 Enter the number of DPCs to create, in the window shown in Figure 2-10. 

Step 2 Click Next. A screen similar to the one in Figure 2-11 appears.
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Figure 2-11 Specifying Properties for Each DPC

Step 3 Enter the DPC name.

Step 4 Enter the network address of the destination network element in dotted notation; for example, 
172.16.145.38.

Step 5 Enter the SS7 path name.

Step 6 From the MDO drop-down menu, choose the protocol for this signaling service, for example, 
ANSISS7_STANDARD.

Step 7 Enter the Customer group ID.

Step 8 Click Next. 

Step 9 Enter the SS7 route name prefix, and click Next. 

Step 10 A screen similar to the one in Figure 2-12 appears.

Figure 2-12 Importing VISMs from the MGX 8850 Chassis

Step 11 Enter the name of the MGX 8850 host in which the VISM cards are installed.
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Step 12 Enter the login ID for the MGX 8850 host.

Step 13 Enter the password.

Step 14 Click Import VISMs. A list of the imported MGX 8850 switches appears in the lower portion of the 
screen.

Step 15 Click Finish. You can now provision trunk groups, trunks, and routes for this solution. Refer to the 
Cisco Media Gateway Controller Software Release 9 Provisioning Guide.

Provisioning Session Results
The results of the provisioning session you just completed are visible in the hierarchical tree in the left 
pane of the main VSPT screen, as shown in Figure 2-13.

Figure 2-13 Expanded Hierarchical Tree Showing Results of Provisioning Session

You can expand the branches to view individual components. To view the provisioning information for 
a particular system component, click on the component name. Information about the selected component 
is shown on the right-hand side of the screen (see Figure 2-14 for an example).
2-10
Cisco Voice Services Provisioning Tool Release 2.2 User’s Guide

OL-1910-01



 

Chapter 2      Provisioning with VSPT Wizards
Using the Tandem Transit with STP Solution Wizard
Figure 2-14 View a Selected Component Configuration

You cannot use the VSPT wizard to provision trunk groups, trunks, and routes. For more information 
about provisioning these components using the VSPT, see the Cisco Media Gateway Controller 
Software Release 9 Provisioning Guide.

Viewing Generated MML
To view the MML commands generated by the VSPT wizard, refer to the “View Generated MML 
Commands” section on page 3-3. 
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Voice Services Provisioning Tool Utilities

VSPT 2.2 provides many utilities, including tools to accomplish the following tasks:

• Perform an Integrity Check, page 3-1

• View Generated MML Commands, page 3-3

• View Generated Cisco MGW Commands, page 3-4

• Deploy a Configuration, page 3-5

• Perform an Audit, page 3-9

• Back Up and Restore, page 3-11

Perform an Integrity Check
When provisioning is complete, you can perform an integrity check to prevent possible configuration 
errors. The integrity check involves:

• Checking Integrity for MGC Signaling Configuration

• Checking Traffic Against MGC Configuration

• Checking Dial Plan Results

Each integrity check is explained in more detail in the following subsections.

Checking Integrity for MGC Signaling Configuration
When you perform an integrity check for MGC signaling configuration, the VSPT does the following:

• Checks that the hostname is specified for MGC

• Checks that login/passwords are specified for MGC

• Checks that MGC ipaddrs are specified

• Checks that if MGC failover is specified, the failover IPs are specified

• Checks that MGX hostname is specified

• Checks that MGX login/password is specified

• Checks the MGX IPaddrs

• For EXTNODES where the configuration refers to an MGX, checks PeerAddrs on IPLNK to ensure 
that they are addresses on the specified MGX
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• For IPFAS IPLNK:

– Ensures that SigSlot/SigPort is specified

– Checks SigSlot/SigPort on MGX to ensure that the values are valid as specified on the MGX 

– Ensures that MGC ports and MGX ports match on the IPLNK

– Checks that all IPLNK under a single IPFASPATH map to the same port number 

Note The number of IPFAS sessions utilizing a given port is displayed because some IPLNKs might 
use different port IDs.

Checking Traffic Against MGC Configuration
When you perform an integrity check of traffic against the MGC configuration, the VSPT does the 
following:

• When D-channels are defined as FAS and NFAS PRI in the trunk group/trunk section, verifies that 
there are corresponding IPFASPATH signaling services with corresponding IPLNKs

• Checks if there are any defined IPFASPATH signaling services defining a D-channel but no 
corresponding trunk group/trunk in the traffic information with a corresponding NFAS/FAS PRI.

• Checks that signaling services defined for trunk groups exist in the configuration

For information about an integrity check of dial plan results, refer to the Cisco  Media Gateway 
Controller Software Release 9 Dial Plan Guide.

Use the following procedure to perform an integrity check of your configuration:

Step 1 Click Tools > Integrity Check. The screen shown in Figure 3-1 appears.

Figure 3-1 Integrity Check

Step 2 Indicate the tests you want to run, and click Start.

When the tests finish, a screen similar to the one in Figure 3-2 appears showing the results of the 
integrity checks.
3-2
Cisco Voice Services Provisioning Tool Release 2.2 User’s Guide

OL-1910-01



 

Chapter 3      Voice Services Provisioning Tool Utilities
View Generated MML Commands
Figure 3-2 Integrity Check Results

View Generated MML Commands
The VSPT automatically generates MML commands to provision your Cisco MGC and saves these 
commands in a file to be executed when you deploy the configuration. To view the MML commands 
generated from your VSPT provisioning session, click View > MML on the VSPT menu bar. A screen 
displaying generated MML, similar to the one shown in Figure 3-3, appears.
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Figure 3-3 First Generated MML Screen

View Generated Cisco MGW Commands
To view the Cisco  MGW commands generated from your provisioning session, click View > MGW 
Commands on the main VSPT menu bar. A screen with generated Cisco MGW commands, similar to 
that shown in Figure 3-4, appears.
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Figure 3-4 Example of Generated Cisco MGW Commands

Deploy a Configuration
When you finish defining a configuration, you must deploy that configuration to the Cisco MGC. You 
can deploy to the Cisco MGC alone, to the Cisco MGC and one or more gateways, or to gateways only.

Note A new configuration should not be deployed during times of peak load on the Cisco MGC. 

A configuration created in VSPT can be deployed to a Cisco MGC as a new configuration or 
incrementally. Deploying incrementally allows you to more quickly deploy modifications to an existing 
configuration without having to redeploy the entire configuration. VSPT also allows you to visually 
check the incremental commands it generates before deploying those commands to the MGC.

Deploying a New Configuration
Use the following procedure to deploy a new configuration.

Note If you want to delete a component and plan to reuse the component name, first delete the component, 
deploy the session, and verify that the component name has been deleted before reusing the name.
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Step 1 Click Tools > Deploy on the main VSPT menu bar ( see Figure 1-3 on page 1-9). The screen shown in 
Figure 3-5 appears.

Figure 3-5 Deploying a Configuration

Step 2 Indicate how you want to deploy the configuration:

• To deploy to the Cisco MGC only, do one of the following: 

– If you want to send the configuration to the MGC but not activate it, click the button next to 
Send Configuration to MGC Only.

– If you want to send the configuration to the MGC and activate it, click the button next to Send 
and Activate Configuration.

– If you have a continuous-service configuration with two Cisco MGC hosts, click the button next 
to Send, Activate and Synchronize failover. The configuration is saved on the active host and 
copied to the standby host. You must restart the standby server after reconfiguration to apply 
changes.

• To deploy to the Cisco MGC and one or more selected gateways, select one of the above three 
options and in Step 4 also select one or more gateways from the list in Specify media gateways for 
deployment. 

• To deploy to selected gateways only (and not the Cisco MGC): Check the box next to Do not deploy 
to MGC and in Step 4 select one or more gateways from the list in Specify media gateways for 
deployment. 

Note If you select an option other than New, the Advanced button is enabled. For information about 
the options this button provides, see the “Configuring an Incremental Deployment” section on 
page 3-8.
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Step 3 Select a configuration in the Based on configuration drop-down list. This list displays all existing 
configurations on the selected MGC and the [LAST IMPORT] and [NEW] options.

• Last Import—The VSPT compares your provisioning session to the last imported configuration and 
deploys only changes you have made.

Note The LAST IMPORT option allows multiple users to modify an existing configuration. However, 
they must each be modifying a different area of the configuration for this option to work 
properly.

• New—Your entire provisioning session is deployed as a new configuration.

• Existing Configurations—VSPT imports the selected configuration from the Cisco MGC, compares 
the differences between that configuration and your current provisioning session, and deploys 
changes you have made.

Note Since you are deploying a new configuration, make sure to choose the New option in the Based 
on configuration drop-down list.

Step 4 Select the gateways you want to deploy, if applicable.

Note To select multiple gateways, you can use standard selection methods: Shift+click to select a 
contiguous range, Ctrl+click to select or deselect noncontiguous gateways.

Step 5 Click OK. The screen shown in Figure 3-6 appears and displays the status as the current provisioning 
session is deployed.

Figure 3-6 Deployment Progress
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Note In a continuous-service configuration, the XECfgParm.dat file on each machine must be configured. If 
you experience problems, verify the integrity of the XECfgParm.dat files on both machines. Refer to 
Chapter 2, “Installing Cisco  Media Gateway Controller Software,” in the Cisco  Media Gateway 
Controller Software Release 9 Installation and Configuration Guide. 

Configuring an Incremental Deployment
An incremental deployment allows you to verify each component type configuration before proceeding 
to the next component deployment. 

Note The Cisco MGC does not support some incremental deployment processes. If you have a problem with 
an incremental deployment, examine the MML commands to ensure that you have properly configured 
the desired components. Modify the component presenting the problem, or cancel the deployment and 
redeploy the component as a new configuration.

Use the following procedure to configure an incremental deployment:

Step 1 Follow Step 1 and Step 2 in the “Deploying a New Configuration” section on page 3-5

Step 2 Click Advanced in the window shown in Figure 3-5. The screen shown in Figure 3-7 appears.

Figure 3-7 Incremental Deployment Component Selector

Step 3 Select one or more component types to deploy, and click OK.

Step 4 Go to Step 3 in the “Deploying a New Configuration” section on page 3-5, and complete the procedure 
described there. When you click OK, a screen similar to the one displayed in Figure 3-8 appears.
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Figure 3-8 Confirm MML Commands

Step 5 Inspect the MML commands, modify them if desired, and click Yes to continue with the incremental 
deployment. Click No to reissue the deployment as a new configuration.

Perform an Audit
You can use an audit to ensure that both the Cisco MGC and a BAMS server supporting the MGC host 
have consistently configured signal paths. The audit involves examines signal path and bearer channel 
data on both servers, comparing the data, and reporting any differences.

Use the following procedure to perform an audit:

Step 1 Click Tools > Audit on the main VSPT menu. The screen shown in Figure 3-9 appears.
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Figure 3-9 Perform an Audit

Step 1 Enter the MGC hostname, login, and password in the top pane of the window.

Step 2 To specify the configuration to audit, click Select, highlight the configuration to audit, and click OK.

Step 3 Enter the BAMS hostname, login, and password in the bottom pane of the window.

Step 4 To specify the configuration to audit, click Select, highlight the configuration to audit, and click OK.

Step 5 Click Audit. A screen similar to the one displayed in Figure 3-10 appears.

Figure 3-10 Audit Results
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The left pane displays the signal path and bearer channel data configured on the MGC host, and the right 
pane displays the same data configured on the BAMS server.

Back Up and Restore
The VSPT backup and restore tool allows you to create, modify, and delete scheduled backups and 
restores hourly, daily, weekly, monthly, or on demand. You can perform back up and restore activities 
on any of the following devices if they have been configured for the MGC:

• MGC Host—Active configuration

• CAT5500—Configuration and image in Flash

• CAT2900XL—Running-config and image in Flash

• SLT2600—Running-config and image in Flash

• BAMS P2—Active configuration

• BAMS P3—Active configuration

The backup and restore tool also provides the status of each activity and generates user-viewable status 
logs.

Note This tool operates in coordination with the MGC server operating system and can be performed by one 
UNIX login (specified during the installation process).

Schedule a Backup or Restore

To schedule a backup or restore, use the following procedure:

Step 1 Click Tools > Backup and Restore on the main VSPT menu bar. The screen shown in Figure 3-11 
appears.

Figure 3-11 Backup and Restore Utility

Step 2 Click the component for which you want to schedule a backup. In the following example, the MGC 
component configuration is backed up. A screen similar to the one shown in Figure 3-12 appears when 
you click the MGC component.
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Figure 3-12 Scheduling a Backup or Restore

Note If you want to perform a restore, you must have a backup file alreadycreated and available on the MGC.

Step 3 Highlight the component you want to back up or restore in the left pane of the main backup and restore 
tool window, and click Add. A screen similar to the one shown in Figure 3-13 appears.

Figure 3-13 Schedule an Activity

Note The fields available on the Schedule an Activity screen vary according to the component selected. 

Step 4 In the Activity field, select the action you want to perform. Choices include backup and restore.

Step 5 Enter the IP address of the Cisco MGC.
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Step 6 Enter the MGC login and password.

Step 7 Enter a name for the backup file.

Step 8 Enter the IP address of the TFTP server.

Step 9 Enter the TFTP login and password.

Step 10 Specify whether or not to use verbose log mode. Verbose mode records all commands issued by the 
VSPT and any system responses.

Step 11 Select the schedule type. Choices include:

• Monthly

• Daily

• Hourly

• Weekly

• Now

• Later

Step 12 Select the hour and minute that the backup should begin.

Step 13 Click OK. The backup activity is scheduled, and a screen similar to the one shown in Figure 3-14 
appears.

Figure 3-14 Display Activity Schedule

After the backup has been completed, the status of the activity is immediately available. The backup file 
with the name you specified is available for use with the VSPT.

Check Status of Backup or Restore

The VSPT generates status logs that provide information about each scheduled activity. The status log 
displays the following information for the activity:

• Date and time when activity began

• Success or failure

• File name on the TFTP server

• Directory of configuration files

• Image file name 
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If you specified verbose log mode, the status log also displays the sequence of commands issued by the 
VSPT and any system responses.

Use the following procedure to check the status of a backup or restore activity:

Step 1 In the left pane of the backup and restore tool window, click the device that has been backed up or 
restored. Click the Status tab in the right pane. 

Step 2 Highlight the backup or restore for which you want information.

Step 3 Select the appropriate button for the action you want to perform. Choices are:

• Show status—Displays the log file for the activity.

• Acknowledge—Removes the text from the Status window and deletes the log file from the server.

• Clear—Removes the text from the Status window, but the log file remains on the server.

Make a Seed File
A seed file is a file created by the VSPT that contains the IP addresses of all of the devices in the 
Cisco MGC network, plus the relationship (hierarchy) between the devices. With this file, Cisco MNM 
can automatically deploy all the elements in the network that have been configured with the VSPT. 

For information about deploying a seed file, refer to the Cisco MNM Release 2.1 User’s Guide.

Use the following procedure to make a seed file:

Step 1 Click Tools > Make a Seed File on the main VSPT menu. The screen shown in Figure 3-15 appears:

Figure 3-15 Make a Seed File

Step 2 Enter the path and a filename, or click Select and specify a directory for the file. You can also choose 
the default, which is /var/opt/<basedir>/data/mgc/mistral/<configuration name>/WORKING/seed.file.

Step 3 Click OK. A seed file is created in the directory you specified.
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