
 

Cisco Media Gateway Controller No
OL-3869-02
C H A P T E R 3

Getting Started with Cisco MGC Node Manager

This chapter describes the basics of working with Cisco MGC Node Manager. Topics include:

• Starting and Quitting a Cisco MGC Node Manager Session, page 3-1

• Opening, Closing, and Switching Cisco MGC Node Manager Applications, page 3-3

• Basic Operations in Cisco MGC Node Manager, page 3-6

• Using the Map Viewer, page 3-10

• Understanding Cisco MGC Node Manager Dialog Boxes, page 3-28

Starting and Quitting a Cisco MGC Node Manager Session
This section describes how to start and quit a Cisco MGC Node Manager session.

Starting a Cisco MGC Node Manager Session
You can start a Cisco MGC Node Manager session when Cisco EMF is running. Use the following steps 
to start a Cisco MGC Node Manager session:

Step 1 Log in as root.

Step 2 From the command line on the terminal window, type:

#cd CMNM_ROOT/bin

where CMNM_ROOT is the Cisco MGC Node Manager installation root directory (for example, 
/opt/CSCOcemf).

Step 3 Verify that Cisco EMF is running. Enter:

#cemf query

You should see CEMF Manager 3.2 initialized followed by a list of running Cisco EMF processes.

Step 4 If Cisco EMF is not running, start it by entering the following command:

#cemf start

Step 5 From the command line on the terminal window, type:

#CMNM_ROOT/bin/cemf session

Where CMNM_ROOT is the Cisco MNM installation root directory (for example, /opt/CSCOmgcm). 
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You see the Cisco EMF Login screen shown in Figure 3-1.

Figure 3-1 Cisco EMF Login Screen

Step 6 Enter your user name and password, and click OK. The default user ID is admin and the default password 
is admin.

When you specify a valid user name and password, the session starts and the Cisco EMF Launchpad 
screen, shown in Figure 3-2, displays.

Note If you enter an unknown user name or password, you see an error message. You have three 
attempts to specify a valid user name and corresponding password. If, after three attempts, you 
do not specify a valid user name and password, the session does not start and the Login window 
closes. 

Step 7 Go on to the “Opening an Application” section on page 3-4.

Quitting a Cisco MGC Node Manager Session
You can quit a Cisco MGC Node Manager session at any time. Quitting Cisco MGC Node Manager 
closes any open applications or dialog boxes, but does not stop Cisco EMF. Use the following procedure 
to quit a Cisco MGC Node Manager session:

Step 1 Do one of the following:

• From the File menu, select Quit.

• Press Ctrl-Q.

• Click the Close tool on the toolbar. 

You are asked if you want to quit the Cisco EMF Manager system.

Step 2 Click Yes, to quit the session.

All active applications are closed and the session terminates. Cisco EMF continues to run. 

Note To stop Cisco EMF, you must be the root user. 
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Opening, Closing, and Switching Cisco MGC Node Manager 
Applications

Cisco MGC Node Manager applications are the major groupings of network management functions. 
They include:

• Map Viewer—You can view, build, and monitor a network with the Map Viewer. You can monitor 
the networks using network and network object connections.

• Object Group Manager—You can organize network elements into object groups with the Object 
Group manager. You can create, delete, and modify object groups.

• Access Manager—The Access menu allows an administrator to set up users and user groups, assign 
passwords, and define access parameters.

• Event Browser—Clicking the Events button brings up the Event Browser and Query Editor. You can 
create object groups or browse events from these screens.

• Discovery—Because Cisco MGC Node Manager requires the login and password in order to 
communicate with a device, the Cisco EMF Automatic Discovery feature is not supported by 
Cisco MGC Node Manager. Cisco MGC Node Manager discovers (and can automatically 
rediscover) device components and configurations once the device has been deployed (IP address, 
host name, and login information entered into Cisco MGC Node Manager, as described in 
Chapter 5, “Deploying Your Network in Cisco MGC Node Manager.”)

• CMGC Node Manager Manuals—Opens a Netscape browser window and displays links to the 
following documents:

– A local copy of the Cisco MGC Node Manager User’s Guide, Release 2.5(2). From here you 
may also open a booklength PDF of the User’s Guide. The master version of the User’s Guide 
is available online a 
http://www.cisco.com/en/US/products/sw/netmgtsw/ps1912/products_user_guide_list.html. 
The online version may have minor enhancements or corrections.

– The following online documents, which can be accessed if you have an internet connection: 
Cisco Media Gateway Controller Software Release 9 Documentation, Cisco Media Gateway 
Controller Release 7 Documentation, Cisco Dial, Voice, and Telephony Solutions, Cisco 
Element Management Framework 3.2. 

Note If you have installed Cisco MGC Node Manager co-resident with another element manager, a button for 
that product’s manuals also appears. 

• Event Manager

– Notify—You can create notification profiles that consist of a series of notifications that should 
be carried out as a result of the profile being triggered.

– Thresholds—You can configure the management system to actively monitor the network and 
notify the operator when some aspect of the network performance has deviated from preset 
criteria.

– Event Groups—Using Event Groups, you can filter and organize events based on specified 
criteria, such as severity, state, or type of network element, then create a scoreboard to show the 
state of the group at a glance.

Once you have started a Cisco MGC Node Manager session, you can open, close, and switch between 
applications.
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Opening an Application
The Cisco EMF Launchpad, shown in Figure 3-2, is used to access Cisco MGC Node Manager 
applications. You can, and typically will, open multiple applications, and you can open more than one 
instance of an application.

Note Figure 3-2 depicts the complete Launchpad as you might see it when Cisco MGC Node Manager is 
running co-resident with Cisco Media Gateway Manager (Cisco MGM). The actual view you see when 
you open Cisco MGC Node Manager shows the CEMF Manager applications only; you must scroll to 
see the Event Manager applications.

Figure 3-2 Cisco EMF Launchpad 

Use the following procedure to open an application:

On the Launchpad, click the icon for the desired application. The selected application opens. A busy icon 
and a message in the status bar are displayed while it is opening. 
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Note If an application is already open, it appears in the Windows list. Click Window, and choose the desired 
application.

Closing an Application
Closing an application closes only the current instance of the application. Other instances of the 
application are unaffected. For example, if you have separately opened the Event Browser for a BAMS 
and for a Cisco MGC host, closing the Cisco MGC host Event Browser window does not close the 
BAMS Event Browser window.

Use one of the following procedures to close an application:

• Choose File > Close

• Click the window Close button

• If the window has a toolbar, click the Close tool 

• Press Alt-F4

Switching Between Open Application Windows
Typically, your work in Cisco MGC Node Manager involves having several windows open at the same 
time. You can view the list of open windows and switch between them from the Window menu on the 
application menu bar. The window menu for the Launchpad is shown in Figure 3-3.

Use the following steps to switch between windows:

Step 1 Select Window. The Window menu appears and lists open windows.

Figure 3-3 Window Pull-Down Menu

Step 2 Choose the desired window. 
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Basic Operations in Cisco MGC Node Manager
This section describes basic operations that apply throughout Cisco MGC Node Manager:

• Using the mouse, shortcut keys, or toolbar to access Cisco MGC Node Manager features

• Selecting items in lists

• Printing the contents of a window

• Viewing Cisco MGC Node Manager status information

Note If you have problems printing the contents of a window, consult your system administrator to verify that 
your operating system is configured for printing.

Using the Mouse
Throughout Cisco MGC Node Manager, the left, middle, and right mouse buttons are used for the 
following functions.

• Click the left mouse button to:

– Select

– Activate

– Set the location of the cursor

• Click the middle mouse button to:

– Copy

– Move

– Drag

• Click the right mouse button to access context menus by clicking and holding the right mouse button 
on a managed object within applications, such as the Map Viewer and the Object Group Manager, 
and events in the Event Browser.

Using Shortcut Keys

Ctrl-Key

Standard Cisco MGC Node Manager menus are available from the Toolbar. Items can be selected from 
the menus or by typing the keys in Table 3-1 and Table 3-2.

Table 3-1 File Menu Shortcut Keys

Key Sequence File Menu Function

Ctrl-Q Quit

Ctrl-W Close

Ctrl-P Print

Ctrl-S Save
3-6
Cisco Media Gateway Controller Node Manager User’s Guide Version 2.5(2)

OL-3869-02



 

Chapter 3      Getting Started with Cisco MGC Node Manager
Basic Operations in Cisco MGC Node Manager
Note When a menu option is grayed out, it is not available for selection.

Alt-Key

Items in the Cisco MGC Node Manager menus and dialog boxes may be presented with the first (initial) 
letter underlined (for example, Actions.) This means that you can either select this option by clicking the 
mouse, or you can press Alt-A. 

Tip You can use the X windows standard Alt-4 to close the current window.

Using the Toolbar
In Cisco MGC Node Manager application windows, a toolbar contains tool buttons for commonly used 
menu options. You can toggle the toolbar on or off and choose to display or hide tooltips.

In Figure 3-4, the toolbar contains tool buttons for the following functions common to many dialog 
boxes:

• Close the current window

• Print the contents of the window

Note If you have problems printing the contents of a window, consult your system administrator to verify that 
your operating system is configured for printing.

• Toggle dynamic update mode, to allow viewing or not viewing real-time changes

• Refresh the window, to update the information when dynamic update mode is off

• Acknowledge that you have seen dynamically updated dialog box changes 

Ctrl-N New

Ctrl-O Open

Table 3-2 Edit Menu Shortcut Keys

Key Sequence File Menu Function

Ctrl-Z Undo

Ctrl-X Cut

Ctrl-C Copy

Ctrl-V Paste

Ctrl-A Select all

Ctrl-D Deselect all

Table 3-1 File Menu Shortcut Keys (continued)
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Figure 3-4 Example Toolbar

Hiding or Showing the Toolbar

To toggle the display of the toolbar for the current window, choose Options > Show Toolbar.

Hiding or Showing Tooltips

Tooltips provide a brief description of a toolbar button or window panel. Tooltips appear when the cursor 
is positioned over the item. You can choose to show or hide tooltips. 

To toggle the display of tooltips for the toolbar in the current window, choose Options > Enable Tooltip.

Selecting from Lists
If you want to perform an operation on more than one item, you can select:

• A block of items

• Multiple noncontiguous items

• All items

You can also quickly deselect all items. For example, if you want to make sure that you do not have the 
wrong item selected before opening a function, you can first deselect all items and then select the desired 
item.

Use the following steps to select a block of items:

Step 1 Select the first item.

The item is highlighted.

Step 2 Press and hold the Shift key.

Step 3 Select the last item in the sequence.

Step 4 Release the Shift key.

All items between the first and last item are highlighted.

Use the following steps to select multiple noncontiguous items:

Step 1 Select the first desired item.

The item is highlighted.

Step 2 Point to the next item to be selected.

Step 3 Press Ctrl and click.

The item is highlighted.
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Step 4 Repeat Step 2 and Step 3 until all the desired items are highlighted.

Use the following steps to select all items:

Step 1 Place the cursor anywhere in the relevant window. 

Step 2 Press and hold the right mouse button.

A context menu is displayed. 

Step 3 Choose Select All.

Note This option is not available in all windows.

All items in the list are highlighted. 

Use the following steps to deselect all items:

Step 1 Place the cursor anywhere in the relevant window. 

Step 2 Press and hold the right mouse button.

A context menu is displayed. 

Step 3 Choose Deselect.

Note This option is not available in all windows.

All items in the list are deselected. 

Printing the View Displayed in the Window
In many windows, you can print the contents of the window.

Note If you have problems printing the contents of a window, consult your system administrator to verify that 
your operating system is configured for printing.

To print the contents of the current window, do one of the following:

• From the File menu, select Print.

• Press Ctrl-P.

• Click the Print tool on the toolbar.

The current view is printed.
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Viewing Cisco MGC Node Manager Status Information
The status bar at the bottom of most windows displays status information about the current Cisco MGC 
Node Manager application status (not about network status). 

To view previous status messages, double-click in the status bar. The Status Dialog appears, as shown in 
Figure 3-5. 

Figure 3-5 Status Dialog 

Using the Map Viewer
The Map Viewer organizes the network display into various views and is the starting point for most 
Cisco MGC Node Manager network management operations. Each view represents a different way of 
containing and grouping the network elements, such as by device type, by Cisco MGC node, and by 
physical or network view. 

From the Map Viewer you can:

• Deploy an entire network or a single new device.

• See at a glance which devices have generated alarms. Because the alarm display is propagated from 
the originating object up through the containing objects, you can quickly drill down to find the 
source of the problem. 

Note Propagation applies to the node and physical views. Alarms are not propagated in device views.

• Instantly identify information about a device by its graphical representation. State icon, color, 
cross-hatching pattern are some of the indicators that give you a quick graphical read of the network 
condition.

• Access network devices by navigating through one of the views to the desired object and then 
right-click to open any of the Cisco MGC Node Manager services relevant to that device.
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• View the network in different ways, depending on your purpose. For example, you can use the 
physical view to see where devices are located, the device view to perform an operation on all the 
devices of a particular type, and the node view to see node-specific elements such as signaling 
components.

Note We use the term “object” to refer to the graphical representation of a network element in Cisco MGC 
Node Manager and the term “device” to refer to the real-world counterpart that is represented and 
manipulated by the object.

This section describes the basics of how to use the Map Viewer. The Map Viewer display is based on the 
Cisco MGC Node Manager object model of the network. For an explanation of the concepts and some 
of the technical details behind the Map Viewer, see the “Overview of Cisco Media Gateway Controller 
Node Manager,” “How Cisco MNM Models the Network” section on page 1-10. 

This section describes:

• The Map Viewer window and views.

• How to expand a view, to get to an object, and collapse a view.

• How to read the visual symbols associated with objects in the Map Viewer.

• How to use the context menu to open a Cisco MGC Node Manager service for the current object. 
This is your entry point to most network management functions.

For more information on the Map Viewer, refer to “Map Viewer” in the Cisco EMF online help.

The Map Viewer Window
Until you have deployed a network in Cisco MGC Node Manager, the Map Viewer displays only empty 
container objects.
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Figure 3-6 Map Viewer Before a Network Is Deployed

When you deploy a network, as you will learn how to do in Chapter 5, “Deploying Your Network in 
Cisco MGC Node Manager,”the views are populated with the graphical objects that represent your 
network devices. Initially, the view is collapsed, as shown in Figure 3-7.

Figure 3-7 Map Viewer After Deployment

When a view is expanded, the Map Viewer looks similar to the illustration shown in Figure 3-8.
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Figure 3-8 Typical Appearance of the Map Viewer 

• The Map Viewer window is divided into two panes. The left pane is a hierarchy browser. The right 
pane displays a map of the object selected in the right pane. The map is a detailed depiction of the 
selected device or site.

• Resize the hierarchy browser pane and map pane by positioning your cursor over the boundary and 
dragging.

• Use the scroll bars to view all information in the left and right panes. 

• You can open a service on a device object by right-clicking the object and choosing the service from 
the context menu. To open a service on multiple devices, select the devices, and then right-click.

Note The context menu displays the list of services available for the selected device or devices. Services 
available depend on your access privileges. If multiple objects are selected, only services common to all 
selected objects are available. 

Map Viewer Views
This section describes the various Map Viewer views.

The Node View

The node view shows all the devices in the node, as well as the Cisco MGC host signaling, dial plan, and 
trunking components. 
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Use the node view to: 

• Deploy a node and devices within a node. In a conventional node, you deploy one or a pair of 
Cisco MGC hosts under the node. In a farm, you deploy a farm under the node, and then deploy one 
or a pair of Cisco MGC hosts under the farm, as shown in Figure 3-13.

• View alarm propagation. Alarms are propagated from child devices to parent devices anywhere in 
the node, and you can drill down through the tree to find the element raising the alarm. 

• View signaling, trunking, and dial plan information.

• Open applications for signaling, trunking, and dial plan components.

Figure 3-9 shows an example of the node view. Figure 3-10, Figure 3-11, and Figure 3-12 show 
expansions of the signaling, trunking, and dial plan folders. Figure 3-13 shows an example of a farm 
folder.

Figure 3-9 The Node View
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Figure 3-10 The Signaling Folder

Figure 3-11 The Trunking Folder 

Figure 3-12 The Dial Plan Folder
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Figure 3-13 The Farm Folder

Device Views

The device views group devices by their type. Use device views to view and manage all the devices of a 
particular type.

Note Alarms are not propagated in device views. Use the node view or physical view to propagate alarms.

Tip To open a Cisco MGC Node Manager service for a group of devices, open the service from the device 
view. The dialog box lists all the devices. You can select each desired device in turn.

The Cisco MGC Host View

This view shows all the Cisco MGC hosts. Use host view to:

• View and manage all hosts

• View and manage host system components, such as disk, RAM, memory, processor, and interfaces
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Figure 3-14 Cisco MGC Host View 

The Cisco SLT View

This view shows all the Cisco SLTs, integrated SLTs and integrated SLT coresident EMs. Use Cisco SLT 
view to:

• View and manage all Cisco SLTs

• View and manage SLT interfaces, including TDM interfaces

Different icons are used for the different types of SLT, as shown below.

Type of SLT Icon

Standalone SLT

Integrated SLT
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Figure 3-15 Cisco SLT View

The Cisco LAN Switch View

This view shows all the Cisco LAN switches. Use this view to:

• View and manage all Cisco LAN switches

• View and manage switch components, such as interfaces, modules, and ports
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Figure 3-16 LAN Switch View

The BAMS View

This view shows all the BAMS machines. Use BAMS view to:

• View and manage all BAMS

• View and manage BAMS system components, including disk, RAM, memory, and interfaces
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Figure 3-17 BAMS View 

The HSI View

This view shows all the HSI servers. Use this view to:

• View and manage all HSI servers

• View and manage HSI system components, including disk, RAM, memory, and interfaces

The Physical View

This view organizes the network by physical location. You can define a hierarchy of regions and sites, 
such as cities, buildings, and floors. Figure 3-18 shows an example. When you deploy the network, you 
identify the physical region or site associated with each network device. 

Use the physical view to:
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• Deploy regions and sites. To do this, select the container object for the level you want to deploy. For 
example, select a Southeast region object to deploy an Atlanta site.

• View alarm propagation. Alarms are propagated from child devices to parent devices, and you can 
drill down through the tree to find the element raising the alarm. 

• Identify where a problem device is located. For example, in Figure 3-18 there is a problem in the 
Stonybrook building, which is propagated upward to the Raleigh and Southeast sites.

• Visualize the physical network.

Figure 3-18 Physical View 

The Network View

This view shows the IP addresses of the network devices. 

Figure 3-19 Network View 

Expanding or Collapsing a View
In the left hierarchy browser pane, a plus sign (+) next to an object means it contains other objects and 
can be expanded. A minus sign (-) means that the object is fully expanded.

• To expand a view, click the + next to the object, as shown in Figure 3-20. 

• To drill down to an object, continue expanding the view until you see the desired object.
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• To collapse a view, click the - next to the object.

Tip When you see an alarm symbol next to an object, drill down to find the object generating the alarm.

Figure 3-20 Expanding a View in the Map Viewer

Understanding Map Viewer Symbols
Indicators in the Map Viewer reflect the status of the associated object and the occurrence of alarm 
events. For example, a polling icon indicates that a device or its child is being polled. In this way, the 
states of the Cisco  MGC subobjects are propagated up to the Cisco MGC node object. 

Similarly, alarm events, indicated with a color-coded circle in the left pane and a balloon in the right 
pane, are propagated up in the physical and node view. 

For some states, a small symbol is placed near the top of the icon. Cross-hatching is used to indicate state 
information. 

Table 3-3 lists and describes status and event symbols. Table 3-4 displays the color-coding used for 
alarm events. For more information about alarm events, see Chapter 6, “Managing Faults with 
Cisco MGC Node Manager.”

Collapsed View Expanded View

Table 3-3 Status and Event Symbols

Symbol Description

(In the left pane) Indicates the number of child devices. In the physical and network 
views, a circle indicates an event on one or more child devices, color-coded to severity. 
The highest severity is displayed. 

(In the right pane) A balloon indicates events, color-coded to severity. The number 
indicates the number of the most severe events in the category. The letter indicates the 
highest unacknowledged event severity in the category. 

Indicates that the device has not been discovered. (This is the icon when the device is 
initially deployed.)
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Opening a Cisco MGC Node Manager Function for a Device
Use the Map Viewer to open a function, such as the Performance Manager or a Properties dialog box, 
for a device or group of devices.Use the following steps to open a function for a device:

Step 1 In the Map Viewer, navigate to the desired object and select it. 

Indicates that the device is in the process of discovering or rediscovering. The object icon 
itself has a hatch pattern.

Indicates that the device has some outage or operational problem and is, therefore, 
out-of-service. Icons also have a hatch pattern.

Indicates that the device is performing polling.

Indicates that the device is not SNMP reachable. This may be because the device is off 
the network or its SNMP agent is not responding.

Indicates that some major service or software process on the device has failed. The icons 
also have a hatch pattern.

Indicates that the device is off-duty or administratively down.

Indicates that the device is providing service.

Indicates that the device is running in warm-standby mode.

Indicates that the device is running in an unknown (other) mode.

Indicates that the device is being tested.

A hatch-pattern (without any corresponding state symbol) is used to indicate that the 
device is not being managed.

Table 3-4 Colors Used to Indicate Event Severity

Color Severity of Event

Red Critical

Orange Major

Yellow Minor

Cyan Warning

Green Normal

White Informational

Table 3-3 Status and Event Symbols (continued)

Symbol Description
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Note To open a Cisco MGC Node Manager service for a group of devices, open the service from the 
device view. The dialog box contains a list box listing all the devices. You can select each desired 
device in turn.

Step 2 Right-click. The context menu appears showing functions available for the selected object or objects. 

Step 3 Choose the desired option. Table 3-5 summarizes how to access various services. 

A window opens for the service. For example, if you choose Properties, a Properties dialog box displays 
the properties of the selected device.

Note Some functions can be opened from the Event Browser as well as the Map Viewer. 

Note If SSH is enabled, functions that normally invoke Telnet or ftp instead invoke their SSH 
counterparts, ssh or sftp. 

Table 3-5 Opening Cisco MGC Node Manager Functions

Function Select This View or Object
Command: Right-Click and 
Choose... Description

MGC Node Deployment MGC-Node-View Deployment > Deploy MGC 
Node

Deploys a new Cisco MGC node

MGC Host Deployment Host-View

MGC Node

Deployment > Deploy MGC 
Host

Deployment > Deploy MGC 
Node Component

Deploys a new Cisco MGC host 

SLT Deployment SLT-View

MGC Node

Deployment > Deploy SLT

Deployment > Deploy MGC 
Node Component

Deploys a new Cisco SLT or 
integrated SLT

LAN Switch Deployment Switch-View

MGC Node

Deployment > Deploy LAN 
Switch

Deployment > Deploy MGC 
Node Component

Deploys a new Cisco LAN 
switch 

BAMS Deployment BAMS-View

MGC Node

Deployment > Deploy BAMS

Deployment > Deploy MGC 
Node Component

Deploys a new BAMS

HSI Deployment HSI-View

MGC Node

Deployment > Deploy HSI

Deployment > Deploy MGC 
Node Component

Deploys a new HSI host device
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Seed File Deployment Any view icon (action 
applies to entire network)

Deployment > Deploy Network 
Seed File

Displays Seed File deployment 
dialog

Performance Manager MGC Node, BAMS, HSI, 
SLT, or LAN Switch at 
level of managed element

Tools > Performance Manager Opens Performance Manager 
application to monitor 
performance measurements

MGC Node States MGC-Node-View, MGC 
Node

MGC Node States Opens MGC Node States dialog

MGC Host Properties Host-View or Node View, 
MGC Host

Properties Opens Host Properties dialog

MGC Host File System 
Properties

Host-View or Node View, 
MGC Host

File Systems Opens Host File System 
properties dialog

MGC Host System 
Component Properties

MGC Host Devices, then the desired 
component: Disk Partition, 
Processor, RAM, or Virtual 
Memory

Opens the properties dialog for 
the selected system component

MGC Host States Host-View or Node View, 
MGC Host

States Opens Host States dialog

MGC Host Accounts Host-View or Node View, 
MGC Host

Accounts Opens Host Accounts dialog

MGC Host Diagnostics Host-View or Node View, 
MGC Host

Tools > MGC Host Diagnostics Opens Host Diagnostic dialog

SLT Properties SLT-View or Node View, 
SLT

Properties Opens SLT Properties dialog

SLT States SLT-View, SLT States Opens SLT States dialog

SLT Accounts SLT-View, SLT Accounts Opens SLT Accounts dialog

SLT Diagnostics SLT-View, SLT Tools > SLT Diagnostics Opens SLT Diagnostic dialog

LAN Switch Properties Switch-View or Node 
View, LAN Switch

Properties Opens LAN Switch Properties 
dialog

LAN Switch States Switch-View or Node 
View, LAN Switch

States Opens LAN Switch States dialog

LAN Switch Accounts Switch-View or Node 
View, LAN Switch

Accounts Opens LAN Switch Accounts 
dialog

LAN Switch Diagnostics Switch-View or Node 
View, LAN Switch

Tools > LAN Switch 
Diagnostics

Opens LAN Switch Diagnostic 
dialog

BAMS Properties BAMS-View or Node 
View, BAMS

Properties Opens BAMS Properties dialog

BAMS File System 
Properties

BAMS-View or Node 
View, BAMS

File Systems Opens BAMS File System 
properties dialog

Table 3-5 Opening Cisco MGC Node Manager Functions (continued)

Function Select This View or Object
Command: Right-Click and 
Choose... Description
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BAMS System 
Component Properties

BAMS Devices, then the desired 
component: Disk Partition, 
Processor, RAM, or Virtual 
Memory

Opens the properties dialog for 
the selected system component

BAMS States BAMS-View or Node 
View, BAMS

States Opens BAMS States dialog

BAMS Accounts BAMS-View or Node 
View, BAMS

Accounts Opens BAMS Accounts dialog

BAMS Diagnostics BAMS-View or Node 
View, BAMS

Tools > BAMS Diagnostics Opens BAMS Diagnostic dialog

BAMS Node Properties BAMS-View or Node 
View,

Properties Opens BAMS Node Properties 
dialog

BAMS Node Diagnostics BAMS-View or Node 
View,

Tools > BAMS Diagnostics Opens BAMS Node Diagnostic 
dialog

Trunking Configuration 
Audit

BAMS Tools > BAMS Diagnostics > 
Audit

Opens the Configuration Audit 
dialog

H323 Properties HSI-View, HSI Host Properties Opens the H323 Properties 
dialog

H323 File Systems HSI-View, HSI Host File Systems Opens the H323 File Systems 
dialog

H323 States HSI-View, HSI Host States Opens the H323 States dialog

H323 Accounts HSI-View, HSI Host Accounts Opens the H323 Accounts dialog

H323 Diagnostics HSI-View, HSI Host Tools > Diagnostics Opens the H323 Diagnostics 
dialog

H323 Administration 
Tool

HSI-View, HSI Host Administration Tool Opens the H323 Administration 
Tool dialog

Signaling Dialogs Signaling Folder, All 
Signaling components

Properties Opens the various signaling 
component property dialogs, one 
for each type of signaling 
component

Trunking Dialogs Trunking Folder, All 
Trunking components

Properties Opens the various trunking 
component property dialogs, one 
for each type of trunking 
component

Dial Plan Properties 
Dialogs

Dial plan folder, all 
routing components

Properties Opens the various dial plan 
component property dialogs, one 
for each type of routing 
component

Network Interface or 
Component Properties

The individual interface or 
component under a device

Properties Opens the properties dialog for 
the selected network interface or 
component (interface, port, slot, 
and so on)

Table 3-5 Opening Cisco MGC Node Manager Functions (continued)

Function Select This View or Object
Command: Right-Click and 
Choose... Description
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Network Interface or 
Component Properties, a 
set of components

The device Component Type > 
Component Properties, for 
example, Interfaces > TDM 
Properties

Opens the properties dialog for 
all components of that type on 
the selected device

Event Browser (can also 
be opened from 
Launchpad)

Any device that forwards 
traps to Cisco MGC Node 
Manager

Tools > Open Event Browser Opens Event Browser for the 
selected device(s)

Performance Manager Any device that collects 
performance data and is in 
polling state

Tools > Performance Manager Opens Performance Manager for 
the selected device(s)

Provisioning Tool MGC Host Tools > Provisioning Tool Starts Provisioning Tool 
application (detects correct 
release for Cisco MGC software 
and correct level of user 
privileges).

MGC Toolbar MGC Host Tools > MGC Host Toolbar Opens MGC Host toolbar 
applications

HSI Alarm Viewer HSI Host Tools > HSI Alarm Viewer Launches HSI Alarm Viewer 
application

HSI Log Viewer HSI Host Tools > HSI Log Viewer Launches HSI Log Viewer 
application

CMM MGC Host Tools > Cisco MGC Manager Opens Cisco MGC Manager 
(CMM)

XTerm MGC Host, BAMS, HSI 
server

Tools > Xterm Opens an XTerm window

CiscoView LAN Switch, SLT Tools > CiscoView Opens CiscoView application

Connection Service MGC Host, BAMS, HSI 
server, SLT, LAN Switch

Tools > Connection Service Opens UNIX Telnet application 
or SSH ssh, depending on 
whether SSH is enabled on both 
Cisco MGC Node Manager and 
the device being connected to

Web Browser (Netscape) SLT, LAN Switch Tools > Web Browser Opens a web browser, pointing 
to the internal web server on 
Cisco SLTs

Administration tool 
(system administrators 
only)

MGC Host, BAMS, HSI 
server, SLT, LAN Switch, 
or device view for all 
devices of the same type

Tools > Administration Tool Opens the device administration 
dialog box to allow rebooting or 
shutting down the device

Table 3-5 Opening Cisco MGC Node Manager Functions (continued)

Function Select This View or Object
Command: Right-Click and 
Choose... Description
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Understanding Cisco MGC Node Manager Dialog Boxes
Cisco MGC Node Manager dialog boxes to aid your productivity:

• Many dialog boxes display popup field descriptions when you pass your pointer over a field name. 

• If a container object is selected when the dialog box is opened, the dialog box can be used to view 
or manipulate properties for any of the selected devices.

• Because Cisco MGC Node Manager supports multiple releases of the Cisco MGC host software, 
some fields in properties dialog boxes may not apply to your release.

• Some dialog boxes display information received from a managed device and others display 
information about that device residing in the Cisco  MGC Node Manager database. Toolbar buttons 
in the dialog box can help you recognize which is which and how the information can be updated.

These features are described below.

Displaying Field Descriptions
In many dialog boxes, you can view a description of the current field by slowly passing the cursor across 
the field name. A description of the field is displayed, as shown in Figure 3-21.

Figure 3-21 Context Help

Displaying Information for Multiple Devices 
You can open a dialog box on multiple devices of the same type. For example, you can:

• Select a device view to open a service on all devices of that type.

• Select a device chassis to open a Properties dialog box on all subcomponents of a particular type.

Use the following steps to display information for multiple devices:

Step 1 Select the devices. See the “Selecting from Lists” section on page 3-8 for details on selecting multiple 
objects.

Step 2 Right-click, and choose the desired option. 

Note If an option is not available for the multiple devices you have selected, the option name is 
dimmed.

The dialog box opens. A list box in the left pane lists the selected devices. Figure 3-22 shows an example 
(properties for all TDM interfaces of a Cisco SLT). 

Step 3 To view or manipulate information for a particular device, select the device in the list box. The 
information on the right changes to reflect the current selection.
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Figure 3-22 A Dialog Box with Information on Multiple Devices

Properties for Multiple Releases of the Cisco MGC Host Software 
Each new release of the Cisco MGC host software supports additional properties of the Cisco MGC node 
elements. 

Because Cisco MGC Node Manager supports multiple Cisco MGC host software releases, some dialog 
boxes may display some fields that might not be applicable to your release of the Cisco MGC software. 
For example, the Trunk Group Properties dialog box includes properties for Cisco MGC host software 
Release 7 and 9. It also contains a tab that includes some fields that apply only to Release 9 and are empty 
if you are using Release 7.
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Figure 3-23 A Dialog Box with Properties for Multiple Cisco MGC Releases

Working with Various Types of Dialog Box Information
Cisco MGC Node Manager dialog boxes display two kinds of information about network devices:

• Information that comes from the device itself, such as properties or alarm events, or from 
Cisco MGC Node Manager’s interaction with the device, such as state information

• Information that resides in the Cisco MGC Node Manager database and is used by Cisco MGC Node 
Manager to communicate with the device, such as account information

Information that comes from the device is display-only and cannot be edited or modified. To turn on 
“Dynamic Update” mode for real-time monitoring of the device, see the “Monitoring 
Dynamically-Updated Information” section on page 3-31.

Note Information that resides in the Cisco MGC Node Manager database can typically be changed. However, 
you are changing only the Cisco MGC Node Manager database and not information stored on the device 
itself. 

This section describes:

• How to recognize and work with a dialog box that displays dynamically updated information

• How to recognize and use field changes that are applied to the device from a dialog box where 
information is display only
3-30
Cisco Media Gateway Controller Node Manager User’s Guide Version 2.5(2)

OL-3869-02



 

Chapter 3      Getting Started with Cisco MGC Node Manager
Understanding Cisco MGC Node Manager Dialog Boxes
Monitoring Dynamically-Updated Information

Many dialog boxes display in near real-time information received from a managed device. With dynamic 
update on, incoming changes from a device are highlighted in blue (see Figure 3-24). The status bar 
indicates whether dynamic updating is on or off. This kind of information is display only; you cannot 
change it.

Figure 3-24 Dialog Box with Dynamic Updating

The toolbar in these dialog boxes includes the three tool buttons in Figure 3-25 used for managing 
updates:

• Toggle dynamic update mode, to allow viewing of real time changes.

• Refresh the window, to update the information manually when dynamic update mode is off.

• Acknowledge that you have seen dynamically updated dialog box changes. When you click this, the 
blue highlighting is removed.

Note Some dialog boxes include both dynamically updatable information from managed devices and 
information about the network maintained in the Cisco MGC Node Manager database. The toolbar in 
Figure 3-25 also includes a Save tool, used for saving changes to database information, as described in 
“Making Changes to Cisco MGC Node Manager Device Information” section on page 3-32. 

Field contents
highlighted in
blue after an
update

Update mode
Status of
last update
or save
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15

0
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Figure 3-25 Dialog Box Toolbar with Dynamic Update and Database Save Functions

Making Changes to Cisco MGC Node Manager Device Information

Some dialog boxes display information that you can edit. For example, if the login ID for a device 
changes, you can use the Accounts dialog box for that device to update the information in the 
Cisco MGC Node Manager database. In dialog boxes that include editable information, the toolbar 
includes a Save tool button, as shown in Figure 3-25. 

To make changes to the Cisco MGC Node Manager database, enter the new information, and click the 
Save tool button.

Note If you try to make a change but the Save tool button remains dimmed, the field is not editable.

Navigating between Dialog Boxes for a Given Component
For most Cisco MGC node components, you can navigate from one dialog box to another without having 
to reselect the component in the Map Viewer and right-click. For example, from the File Systems dialog 
box for a given BAMS, you can navigate to the Properties, Accounts, States, or Diagnostics dialog box 
for that BAMS. 

Perform the following steps to navigate from one dialog box to another not-yet-open dialog box for a 
given component:

Step 1 In the open dialog box, choose Navigation. A menu appears listing options to open other dialog boxes 
for this component. See Table 3-6 for a list of components and dialog boxes that provide the Navigation 
menu.

Step 2 Choose the desired menu option. The selected dialog box opens. 

Note Once a dialog box is open, use the Window menu to navigate between windows.

Toggle dynamic
update mode

Refresh

Acknowledge
changesInformation

from the
device

Information
in the 

Cisco MNM
database Save 62

15
1
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Table 3-6 Components with Dialog-Box Navigation Menus 

Component Dialog Boxes with the Navigation Menu

Cisco MGC Host Properties, Accounts, File Systems, States, 
Diagnostics

BAMS Properties, Accounts, File Systems, States, 
Diagnostics

HSI server Properties, Accounts, File Systems, States, 
Diagnostics

SLT Properties, Accounts, States, Diagnostics

LAN switch Properties, Accounts, States, Diagnostics

All components that have Properties dialog boxes Properties: You can navigate from any Properties 
dialog box for the component to any other valid 
Properties dialog box for that component

Note The Navigation menu may display options 
that are not valid for the current 
component. Service invocation fails if you 
select an invalid properties dialog box. 
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