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Service Inventory > Inventory and Connection 
Manager

From the Home window you receive upon logging in, click the Service Inventory tab and you receive 
a window, as shown in Figure 4-1, “Service Inventory Selections.”

Figure 4-1 Service Inventory Selections

Click on Inventory and Connection Manager and a window as shown in Figure 4-2, “Inventory and 
Connection Manager Selections,” appears.
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Figure 4-2 Inventory and Connection Manager Selections

From Inventory and Connection Manager, you can navigate to any of the following functions:

• Service Requests, page 4-3 Create, deploy, and manage Service Requests (SRs).

• Inventory Manager, page 4-5 Bulk-manage inventory elements.

• Topology, page 4-76 View topology maps.

• Devices, page 4-96 Create and manage Devices.

• Device Groups, page 4-131 Create and manage Device Groups.

• Customers, page 4-137 Create and manage Customers.

• Providers, page 4-144 Create and manage Providers.

• Resource Pools, page 4-151 Create and manage pools for IP address, Multicast address, Route 
Distinguisher, Route Target, Site of Origin, VC ID, and VLAN.

• CE Routing Communities, page 4-162 Create and manage CE Routing Communities.

• VPNs, page 4-165 Create and manage VPNs.

• AAA Servers, page 4-168 Create and manage AAA Servers.

• Named Physical Circuits, page 4-171 Create and manage Named Physical Circuits (NPCs).
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Service Requests
Service Requests are explained in each of the User Guides for each of the licensed services.

Table 4-1, “Summary of IP Solution Center Service Request States,” describes each ISC service request 
state. The states are listed in alphabetical order.

Table 4-1 Summary of IP Solution Center Service Request States

Service Request Type Description

Broken The router is correctly configured but the service is unavailable (due to a 
broken cable or Layer 2 problem, for example).

An MPLS service request moves to Broken if the auditor finds the routing 
and forwarding tables for this service, but they do not match the service 
intent.

An IPsec service request moves to Broken if a ping fails for all the remote 
peers of the current device.

Closed A service request moves to Closed if the service request should no longer be 
used during the provisioning or auditing process. A service request moves to 
the Closed state only upon successful audit of a decommission service 
request. ISC does not remove a service request from the database to allow 
for extended auditing. Only a specific administrator purge action results in 
service requests being removed.

Deployed A service request moves to Deployed if the intention of the service request 
is found in the router configuration file. Deployed indicates that the 
configuration file has been downloaded to the router, and the intent of the 
request has been verified at the configuration level. That is, ISC downloaded 
the configlets to the routers and the service request passed the audit process.

Failed Audit This state indicates that ISC downloaded the configlet to the router 
successfully, but the service request did not pass the audit. Therefore, the 
service did not move to the Deployed state. The Failed Audit state is 
initiated from the Pending state. Once a service request is deployed 
successfully, it cannot re-enter the Failed Audit state (except if the service 
request is redeployed). 

Failed Deploy The cause for a Failed Deploy status is that DCS reports that either the 
upload of the initial configuration file from the routers failed or the 
download of the configuration update to the routers failed (due to lost 
connection, faulty password, and so on).

Functional An MPLS service request moves to Functional when the auditor finds the 
VPN routing and forwarding tables (VRF) for this service and they match 
with the service intent. This state requires that both the configuration file 
audit and the routing audit are successful.

An IPsec service request moves to Functional when the auditor finds that the 
router is configured properly and the IPsec traffic is flowing (ping is used to 
determine if IPsec traffic is flowing).
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Figure 4-3, “Service Request States Transition Diagram,” shows the transitions of states.

Invalid Invalid indicates that the service request information is incorrect in some 
way. A service request moves to Invalid if the request was either internally 
inconsistent or not consistent with the rest of the existing network/router 
configurations (for example, no more interfaces were available on the 
router). The Provisioning Driver cannot generate configuration updates to 
service this request. 

Lost A service request moves to Lost when the Auditor cannot find a 
configuration-level verification of intent in the router configuration files. 
The service request was in the Deployed state, but now some or all router 
configuration information is missing. A service request can move to the Lost 
state only when the service request had been Deployed.

Pending A service request moves to Pending when the Provisioning Driver 
determines that the request looks consistent and was able to generate the 
required configuration updates for this request. Pending indicates that the 
service request has generated the configuration updates and the 
configuration updates are successfully downloaded to the routers.

The Auditor regards pending service requests as new requests and begins the 
audit. If the service has been freshly provisioned and not yet audited, it is not 
an error (pending audit). However, if an audit is performed and the service is 
still pending, it is in an error state.

Requested If the service is newly entered and not yet deployed, it is not an error. 
However, if a Deploy is done and it remains Requested, the service is in an 
error state.

Wait Deployed This service request state pertains only when downloading configlets to a 
Cisco CNS-CE server, such as a Cisco CNS IE2100 appliance. Wait 
Deployed indicates that the configlet has been generated, but it has not been 
downloaded to the Cisco CNS-CE server because the device is not currently 
online. The configlet is staged in the repository until such time as the Cisco 
CNS-CE server notifies ISC that it is up. Configlets in the Wait Deployed 
state are then downloaded to the Cisco CNS-CE server.

Table 4-1 Summary of IP Solution Center Service Request States (continued)

Service Request Type Description
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Figure 4-3 Service Request States Transition Diagram

Inventory Manager
This section describes how to install, configure, and use Inventory Manager (IM) to prepare for 
provisioning services with ISC. It contains the following subsections:

• Overview of Inventory Manager, page 4-5

• Launching Inventory Manager, page 4-7

• Preparing Inventory with Inventory Manager, page 4-13

• Inventory Manager GUI Reference, page 4-20

Overview of Inventory Manager
Service providers and enterprise customers need a way to efficiently manage a large number of physical 
and logical devices. The IM application within ISC enables an operator to import network specific data 
into the ISC database in bulk mode. IM performs three primary functions:

• Collection—provides bulk collection of configuration files from a variety of devices in a network.

• Autodiscovery—provides bulk discovery of logical, physical, and service level connectivity in a 
network. 

• Administration—provides a method of managing bulk changes to inventory and service model data 
in the ISC provisioning process.

There are three different ways to get started with deploying services in ISC. 
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The quickest method is to import the configuration files of all of the target devices (for example, routers, 
firewalls, and switches) from a known location. These configuration files do not need to be the most 
current version of the device configuration but, to ease the set up process, the files should be from the 
current hardware configuration. 

The second most common method is creation of devices without configuration files with subsequent 
collection from live routers to determine the current setup. In order to use this method you must know 
the host name, management address, and password for each device. Once collection is completed you 
can move the devices to a new or existing customer or provider, which is also known as the provider 
administrative domain (PAD).

The primary method for initializing target devices is autodiscovery. From an address and some 
parameters, the autodiscovery process uses Cisco Discovery Protocol (CDP) to discover devices within 
a specified number of hops from the starting point. 

Prerequisites and Limitations

This document is intended for network engineers who have sufficient experience with MPLS VPN, 
L2VPN, and IPsec to provision these technologies using ISC.

All of the network elements that you plan to provision should support the required hardware features and 
Cisco IOS versions.

Client Requirements

To launch IM, the client device needs to run Java VM 1.4.0 and Java WebStart 1.0.1.

Name Resolution

IM requires name resolution. The ISC HTTP server host must be in the Domain Name System (DNS) 
that the web client is using or the name and address of the ISC server must be in the client host file.

SNMP

Prior to device discovery, SNMP must be enabled. All devices in the ISC provisioning environment must 
support SNMP. ISC supports SNMP versions 1, 2c, and 3.

CDP

Prior to device discovery, CDP must be enabled. IM uses CDP to perform the service discovery task. 
CDP should be enabled globally and at the interface level for each device in the ISC provisioning 
environment.

NAT

Prior to device discovery, no Network Address Translation (NAT) mapping for router IP addresses is 
allowed.

Group Membership Requirements

To run the Inventory Manager you need both the Collection_Task and the Device_Import_Task group 
memberships. This is the minimum requirement to successfully create physical or logical devices and to 
upload configuration files from the client to the ISC server.
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Launching Inventory Manager
The first time you launch IM, perform these required tasks:

• Install Java SDK 1.4.0, page 4-7

• Install Java WebStart 1.0.1, page 4-11

• Launch Inventory Manager, page 4-12

IM runs as a stand-alone Java application on a client machine. It also runs outside of the Java Virtual 
Machine (VM) on the main ISC master server. The current release of the IM application requires the 
client device to run Java VM 1.4.0 and Java WebStart 1.0. 

If you do not have Java Runtime Environment (JRE) version 1.4.0, run the 
j2sdk-1_4_0_03-windows-i586.exe program to install it onto your client device. You can download this 
program for Solaris, Linux, and Windows workstations from the following Sun archive URL:

http://java.sun.com/products/archive/j2se/1.4.0_03/

You can download the Java Web Start update package for Solaris, Linux, and Microsoft Windows from 
these URLs:

http://java.sun.com/products/javawebstart/download-windows.html

http://java.sun.com/products/javawebstart/download-solaris.html

http://java.sun.com/products/javawebstart/download-linux.html

The following description assumes you are using a PC based system running Microsoft Windows 2000 
Professional Build 5.00.2195 with Service Pack 2 applied.

Install Java SDK 1.4.0

To install Java Software Development Kit (SDK) 1.4.0 on the client device, follow these steps:

Step 1 Run j2sdk-1_4_0_03-windows-i586.exe, as shown in Figure 4-4.

Figure 4-4 Run j2sdk-1_4_0_03-windows-i586.exe

Follow the prompts and respond accordingly.

Step 2 Click Next when the Install Shield Wizard appears, as shown in Figure 4-5.
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Figure 4-5 Install the Java SDK on the Client Device

The License Agreement window appears.

Step 3 Click Yes to accept the license agreement.

The Choose Folder dialog box appears.

Step 4 Set the correct path, then click OK, as shown in Figure 4-6.

Figure 4-6 Choose the Installation Folder

The Choose Destination Location window appears.

Step 5 To accept the new path, click Next, as shown in Figure 4-7.
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Figure 4-7 Choose Destination Location

The Select Components dialog box appears.

Step 6 To accept the default components, click Next, as shown in Figure 4-8.

Figure 4-8 Accept the Default Components

The Select Browsers dialog box appears.

Step 7 Select the appropriate browser, then click Next, as shown in Figure 4-9.
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Figure 4-9 Select Browser

Step 8 Click Finish to complete setup, as shown in Figure 4-10.

Figure 4-10 Complete Setup

The Client Java 2 SDK installation is complete. 

Step 9 Proceed to the section “Install Java WebStart 1.0.1.”
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Install Java WebStart 1.0.1 

To install Java WebStart 1.0.1, follow these steps:

Step 1 Run javaws-1_0_1-rt.exe, as shown in Figure 4-11.

Figure 4-11 Run javaws-1_0_1-rt.exe

Step 2 Accept the license agreement by clicking Accept.

The Installation Directory dialog box appears.

Step 3 Set the correct path, then click Next, as shown in Figure 4-12.

Figure 4-12 Set the Correct Path

The Java WebStart installation begins. 

Step 4 When it is completed, you are asked whether you want to view the Readme.html file. Click No, as 
shown in Figure 4-13.
4-11
Cisco IP Solution Center Infrastructure Reference, 3.0

OL-4342-01



  

Chapter 4      Service Inventory > Inventory and Connection Manager
Inventory Manager
Figure 4-13 Finish Install

The Java WebStart installation is complete. 

Step 5 Proceed to the section “Launch Inventory Manager.”

Launch Inventory Manager

To launch IM, follow these steps:

Step 1 Log in to ISC.

Step 2 From the Welcome to ISC window, choose Service Inventory > Inventory and Connection Manager > 
Inventory Manager.

Step 3 From the Service Inventory panel, launch the IM application on the web client. The Java Web Start 
window appears.

Step 4 From the Security Warning window, click Start to automatically complete the configuration, as shown 
in Figure 4-14. 

Figure 4-14 Start Java WebStart

You receive the Java Web Start ISC - Inventory Manager window, as shown in Figure 4-15.
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Figure 4-15 Java Web Start ISC - Inventory Manager 

You should receive a splash image of Cisco Systems, if the installation is successful, as shown in 
Figure 4-16.

Figure 4-16 Java WebStart Splash Image

The Inventory Manager launches automatically and is connected to the Master ISC server.

Preparing Inventory with Inventory Manager
This section contains the following subsections:

• Importing Devices from Configuration Files, page 4-14

• Importing Devices with Autodiscovery, page 4-15

• Configuring the Devices, page 4-16

• Collecting Configuration Files, page 4-17

• Creating a New Customer with Devices, page 4-17
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• Creating a New Provider with Devices, page 4-18

• Importing Connections with Autodiscovery, page 4-18

• Importing Services with Autodiscovery, page 4-19

• Marking Interfaces for IPsec, Firewall, NAT, or QoS, page 4-19

Importing Devices from Configuration Files

If the configuration files are for a particular customer or provider, you can create a new customer or 
provider and associate the configuration files with CPEs or PEs. If the customer or provider currently 
exists in the repository, you can open them and insert more CPEs or PEs to be associated with new or 
existing sites or regions. 

To import devices with configuration files, follow these steps:

Step 1 From the Inventory Manager, choose File > New > New Device Group.

This step creates a container for target devices that can be moved to a provider or customer during the 
initialization process.

Step 2 Enter a device group name and click OK.

You receive a prompt to import configuration files. You probably have a repository of configuration files 
on an existing network management device or TFTP server. Copy these files to the web client machine 
for import or make them available with a shared directory. 

Step 3 At the No Config Files Specified for Import prompt, click Yes.

The configuration files on the web client can be located by normal file browsing with both Shift and 
Control+Click select for multiple selections. When creating a new device group, only one filtering 
option is available: All Files.

Note When creating new Providers, there are filters for files containing a specific BGP autonomous system 
number, or files that do not contain BGP configuration. The BGP filters can also be used to select PE 
devices that must have BGP configured or CE devices that do not require BGP.

Step 4 At the Open dialog box, browse to the location of the configuration files you want to import.

The IM now imports a row in a spreadsheet workbook for each selected configuration file. By default, 
the IM inspects the configuration files and determines the device type, which includes Cisco IOS, CatOS, 
PIX, and VPN 3000. It also parses passwords, SNMP information, interfaces, and virtual circuits. 

If cells in the resulting spreadsheet are empty, IM was not able to determine the value and, if it is 
required, the operator must provide the data or choose the information from a defined set of choices 
before saving.

These operations are described in more detail in the following sections as they are common to all 
methods of importing device information and administration.

Step 5 Once the appropriate files are selected, click Open, then click OK.
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Importing Devices with Autodiscovery

Note The autodiscovery process can either be activated from the IM application or from the command line on 
the ISC server using the Cisco Cornerstone autodiscovery scripts.

To import devices with Autodiscovery, follow these steps:

Step 1 From the Inventory Manager, select File > New > New Dynamic Device List. 

This creates a spreadsheet where each row represents a potential seed device for discovery. For each seed 
device, the management interface must be provided. The management interface is the address on the 
device that the ISC host uses to reach the device.

After creating a new device list, a discovery starting point needs to be configured. This starting point is 
a device that can be reached from the ISC host. For each seed device, an accessible interface on the 
starting point is configured, because the management interface must be provided. The management 
interface is the address on the device that the ISC host uses to reach the device.

New dynamic device discovery requires the following manual tasks:

• Entering a seed IP address

• Entering a maximum hop count on the initialization of the task

A policy.xml file is created and a hop count is set automatically.

To choose the seed devices and hub, pick a seed device that can reach a large section of the network. Pick 
one or more of them until you think these devices will enable you to reach your entire managed network.

Point-of-presence (POP) routers are usually good choices. If you choose all the POPs in your network 
as the collection of seed devices and put in the appropriate number of hubs, you discover the entire 
managed network. 

To pick the hub number, go to the CE that is the furthest from its associated POP, and count the number 
of devices between them. If this number is N, the hub number is N+1, assuming you are picking the POP 
as the seed.

Step 2 Click on the Management Address cell and enter the seed IP address for the new dynamic device list

Step 3 Choose Tasks > Start Autodiscovery.

A maximum hop count is specified for the autodiscovery process. The autodiscovery process queries the 
starting point device for its CDP table. From this table, all of those devices are queried for their CDP 
information. This CDP query process continues until the maximum hop count from the starting point is 
reached. Please note that only devices running the CDP process are discovered.

The autodiscovery process queries the starting point device for its CDP table. From this table, all of those 
devices are queried for their CDP information. This CDP query process continues until the maximum 
hop count from the starting point is reached. 

Step 4 Specify the maximum hop count when you receive the prompt. 

Note Only devices running the CDP process are discovered.

You are prompted to save two files. One file contains the list of the discovered devices and the other 
contains information related to connectivity between the devices. The discovered device information can 
be saved in XML to use as a starting point for future discovery efforts.
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Step 5 Save the devices discovery.

Step 6 To view the autodiscovery logs, go to Administration > Control Center > Hosts > machine-name > 
cornerstone bridge.

Configuring the Devices 

After the discovered devices are rendered in the spreadsheet, they must have several parameters set 
before the devices can be saved to the repository and perform a successful live configuration collection. 
These parameters include:

• SNMP read and write community strings

• Telnet login password

• Device enable password

Note The reachable management address is usually Loopback 0.

First remove any devices that are not required in the provisioning process. These items include core 
network devices or non-PE, CPE, and CLE devices that are used within the operator’s network.

To remove unwanted devices, follow these steps:

Step 1 Select the rows for the devices to de deleted.

Shift-select and Control-select are useful for multiple devices. 

Step 2 Choose Edit > Remove Selected Devices.

It is common in networks for devices to share many parameters. The Defaults option allows these 
common parameters to be entered for many devices at the same time; for example, login password, 
enable password, and SNMP strings.

To edit multiple devices, follow these steps:

Step 1 Choose Edit > Edit Default Attributes.

A row for default values can be edited for each tab of the device list. The next step of the configuration 
process collects live configurations that require login and enable passwords.

Step 2 Enter login and enable passwords into the defaults row.

After entering the default values, select all of the devices that share those common parameters. For 
devices that have values other than the default values, you can perform multiple editing techniques. 

Step 3 Select multiple rows or columns using standard selection techniques and choose Edit > Edit Selected 
Devices.

A dialog box, similar to the defaults window appears, allowing you to enter values to be applied to the 
selection.

Note You can right click on the column name and a menu appears showing you choices for sorting and 
selecting or deselecting of columns.
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Step 4 To configure these devices, choose Load Default Attributes to Selected Cells.

The management IP address is the address that ISC uses to communicate with the element. This address 
must be reachable from the ISC host. When the devices were imported or discovered, ISC attempts to 
select the proper address as a management address starting with a loopback address. Verify the selected 
address for accessibility from the ISC host. ISC must be able to reach the network element for the 
configuration process to progress.

Step 5 Click on the Management Address cell and enter the IP address in the dialog box.

Collecting Configuration Files 

Collecting configuration files serves two purposes. It loads the current configuration information for the 
device, which populates many of the cells. It also verifies reachability and passwords for the reachable 
devices.

This task is created in the repository and starts up right away. Logs can be viewed as normal for a 
collection spawned using only the Web GUI.

The task name is Inventory_Manager_Collection_xxxxxx_username, where xxxxxx is a unique number 
and the username is admin, or whatever the logged in username is in ISC.

To collect configurations, follow these steps:

Step 1 Select all the devices that have valid passwords and could be reached.

Step 2 Choose Tasks > Collect Latest Configuration Files.

Creating a New Customer with Devices

The devices should now be assigned roles, either PE or CE. You can assign roles by highlighting each 
device group and adding it to a new or existing Provider or Customer. Routers can be moved in bulk to 
customers with IM. 

To move CE routers to a new customer, follow these steps:

Step 1 Select the desired routers and choose Edit > Move to New Customer.

Step 2 You are prompted to enter a customer name.

Step 3 Enter a customer name and click OK.

A new tab is created at the bottom of the device list and the routers are associated with the customer.

Each customer router must be put into a site. A site can have more than one router in it. All routers in a 
site should share routing information with the external provider network.

Step 4 Shift-select the Site Name cells for each customer router in the CPE Attributes tab.

Step 5 Choose Edit Selected Devices.

Step 6 Choose CUSTOMER_ID+”SITE”+HOST_NAME.

Repeat this process for all the CPEs.

All customer routers must have a Management Type selected. As with customer site, a range of router 
Management Type cells can be selected for bulk editing
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Step 7 Click the Management Type cell for all CEs.

Step 8 Choose Edit Selected Devices.

Step 9 Select the Management Type.

Creating a New Provider with Devices 

A provider or provider administrative domain (PAD) is a group of Provider Edge (PE) devices that share 
a common BGP AS. 

To move PE routers to a new provider and create a region, follow these steps:

Step 1 Highlight the devices with a common BGP AS to be added to a new provider.

Step 2 Choose Edit > Move to New Provider.

When the devices are assigned a PAD, they become Provider Edge (PE) routers. PEs must be placed into 
regions. Each PAD must have one or more regions. A region is a collection of PEs that may share an 
address pool. 

Step 3 To place a PE into a region, click on the Region cell for the PE. 

If the desired region has already been created, it can be selected. 

Step 4 Choose Create Region to add a region. 

You can also add multiple PEs to a single region in one step using standard multiple selection techniques 
and choosing the Edit > Edit Selected Devices menu. As with single PE editing, you are prompted to 
choose an existing region or create a new region.

This completes the assignment of roles to devices. 

Note The tabs at the top of the device list pane of the Inventory Manager window corresponds to a grouping 
of information about the devices. The symbol to the left of the tab name indicates whether all the 
information required on that tab has been configured. A red X means that additional information is 
required. A yellow check mark indicates that all required information has been entered but not all 
possible information. A green check mark shows that all information for that tab has been entered. To 
save the devices to the repository, each tab must show a check mark of either color.

Importing Connections with Autodiscovery

To discover connections, Named Physical Circuits (NPC), run NPC Autodiscovery. This task defines the 
PE and CE link information, which is used by Common Discovery in the final stage of the autodiscovery 
process. NPC Autodiscovery has one prerequisite, the connection.xml file. Ensure that this file has been 
uploaded from the ISC server to the client workstation before running this task. 
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To import connections with NPC Autodiscovery, follow these steps:

Step 1 Choose Tasks > Start NPC Autodiscovery.

You are prompted to provide the path to the correct connection.xml file. 

Step 2 Select the correct connection.xml file and click OK.

A dialog box appears, indicating that the NPC discovery process has started.

Step 3 You are prompted if the task completes successfully. Select OK to finish this portion of the NPC 
autodiscovery process.

To find the discovered NPCs, go to Service Inventory > Inventory and Connection Manager > 
Named Physical Circuits.

Importing Services with Autodiscovery

At this point, you can choose to run the Common Discovery process. ISC manages Ethernet over MPLS 
(L2VPN) and MPLS networks with IPsec. To detect free interfaces on each device for provisioning 
purposes, existing services either need to be discovered automatically or entered into the system 
manually.

For very large networks with many provisioned services, manual entry is time consuming and prone to 
human error. These issues are alleviated by the Common Discovery process. The Common Discovery 
process discovers:

• Layer 3 MPLS VPN services 

• Layer 2 VPN services

To import services with Autodiscovery, follow these steps:

Step 1 Choose Tasks > Start Service Discovery.

You are prompted to select which type of Common Discovery to perform. 

Step 2 To select both MPLS and L2VPN discovery, choose Both MPLS and L2VPN.

You are notified when service discovery is finished.

Step 3 To find the discovered service requests, go to Service Inventory > Inventory and Connection 
Manager > Service Requests.

Marking Interfaces for IPsec, Firewall, NAT, or QoS

The interface marking process is only required for provisioning IPsec, Firewall, NAT, or QoS services. 
Marking interfaces on a one-by-one basis can be a very time consuming and tedious task. IM provides a 
helpful tool to create rules for marking interfaces based on predefined criteria. You can apply one or 
more rules to selected devices to mark the interfaces in a bulk fashion.

For IPsec, the public interfaces are the interfaces where the IPsec or GRE tunnels terminate and the 
private interfaces are the interfaces behind which the subnets to be protected reside.

For firewalls, the outside interfaces connect to the outside, typically unsecured, networks and the inside 
interfaces are for the subnets residing behind the firewall.
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To mark interfaces with IM, follow these steps:

Step 1 Choose Tools > Interface Rule Marking Editor. 

A window appears allowing you to create, modify, or delete existing rules or folders. One simple rule 
can mark all Loopback0 interfaces as public for IPsec. 

Step 2 To apply a rule to one or more devices, select the device(s) in the spreadsheet.

Step 3 Choose Edit > Apply Interface Marking Rule(s) to the selection. A rule chooser appears allowing you 
to select one or more rules to be applied.

Note After completing the device configuration process, all of the red X marks on the Device List tabs should 
be converted to either yellow or green Check Marks. These marks indicate that you have completed the 
required configuration and can save the device list, provider, and/or customer. Save all of the completed 
lists by selecting Save under the file menu. Now all the device preparation should be complete and 
provisioning setup can begin.

Inventory Manager GUI Reference
This section describes how to use the Inventory Manager (IM) GUI in ISC. It is organized by the external 
design of the GUI: what you see when you look at the windows, menus, and options. It is intended for 
new users who want to get started with IM, and for experienced users who need a reference for the GUI 
workflow.

This section contains the following sections:

• Introducing IM GUI, page 4-21

• File Menu, page 4-23

• Edit Menu, page 4-68

• View Menu, page 4-74

• Tasks Menu, page 4-74

• Tools Menu, page 4-75

• Logging Menu, page 4-75

• Help, page 4-76
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