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Object Group Manager
The Cisco EMF Object Group Manager is an application opened from the Cisco EMF Launchpad. 
It provides you the opportunity to organize network elements into object groups. The Object Group 
Manager allows you to create, delete, and modify object groups. Object groups can be any 
combination of objects derived from the Cisco EMF managed object class. Objects can be added 
manually or on the basis of some query criteria. The Object Group Manager window is similar to 
Figure 7-1. 

Figure 7-1 Object Group Manager Window

You can use the objects in an object group to invoke any services available on those objects. This is 
a powerful facility in Cisco EMF that allows you to group objects based on a particular criteria and 
then perform a desired operation on those objects.
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Services on Object Groups and Folders
To create, delete, or manage object groups, you must have Read-Write or Read-Write-Admin access 
to features in the Object Group Manager, set up in Access Control. If you have Read Only access, 
you would only be able to view the object group information. See Chapter 9, “User Access Control,” 
for more information.

In Cisco EMF, a network element could belong to more than one object group. For example:

• It could belong to a group of DSLAMs. This would be a physical classification and it would be 
useful when downloading software.

• It could also belong to a domain group based on the ISP it serves; in this way it would be possible 
to evaluate performance and fault information.

• It could belong to a group based on geographic location; the impact of a local event such as a 
power failure could be assessed and managed.

• It could belong to a customer group so that performance and usage could be assessed to affect 
inventory levels. 

All object groups created in the Object Group Manager are persistent. This means an object group 
is available to you whenever the Object Group Manager is launched. Object groups also survive a 
Cisco EMF restart.

Two object group types exist. This information is shown for each object in the Type field in the 
Information panel:

• Manual

• Query populated.

The Object Group Editor is launched from services in the pop up menu available on object group(s).

Services on Object Groups and Folders
Object Group services can be invoked on either object groups or folders. You can select one or more 
object groups and/or folders and right click. This displays the list of services available on the 
selection in a pop up menu. The services available depend on the class(es) of the selection and the 
access of the user. Access to the features in the Object Group Manager application is managed by 
Access Control (refer to Section Chapter 9, “User Access Control.”)

Note If multiple objects are selected, only the services common to all of the objects are available.
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Launching the Object Group Manager
Figure 7-2 Example of Services Available to Object Groups

Launching the Object Group Manager
The Object Group Manager is launched using the  icon in the Cisco EMF Launchpad 
window. A window similar to Figure 7-3
is displayed.

The Object Group Manager Window
The Object Group Manager window is divided into two panels. Both can be resized by dragging the 
boundary. The left panel displays the Object Groups view, which contains all object groups and 
folders. A number in brackets to the right of each folder indicates the number of child folders or 
object groups at the next level in the hierarchy. Click on the “+” sign or double-click on a folder to 
expand that folder and show its children. An object group can have no children in the Objects Groups 
view and as such, has no number after it in the hierarchy panel. The number of objects in a selected 
object group is shown in the Object Count field in the right hand panel. 
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The Object Group Manager Window
Figure 7-3 Object Group Manager Window

The Object Group Information panel on the right hand side shows the following information about 
a single object group selected in the Object Group view.

• Type—can be manual or query populated

• Object Count—is the number of objects in an object group

• Creator—is the Cisco EMF user ID of the user who created the object group

• Query Run Time—is the time the last query was run

• Description—is optional.

Note The panel is grayed out when no information is available. No information is available when 
multiple object groups or a folder is selected.

Drop down menus available from the Menu bar provide you options to exit the Object Group 
Manager.
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The Object Group Editor Window
The Object Group Editor Window
The Object Group Editor window is used to create, edit, and view object groups. It is launched from 
the pop up menus available on object groups and folders in the Object Groups view. 

Figure 7-4 Object Group Editor Window

The Object Group Editor window consists of three main components:

• the Object Group Details panel at the top of the window

• the Object List in the center of the window

• the Status bar at the bottom of the window.

The Object Group Details panel at the top of the window is used to enter the following object group 
information:

• Name—each name must be unique. You can use any alphanumeric combination. This is editable.

• Type—toggle buttons allow you to select either Manual or Query Populated types when 
creating the object group. This option is editable when creating the Object Group, but not after 
creation.

• Description—this is optional and is editable.
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The Object Group Editor Window
The Object List displays the member objects for an object group. The following attributes are 
displayed for each object:

• Object Path (physical view)

• IP Address

• Comment.

To see the available services on each object, right click on the object in the Object List (a pop up 
menu shows the available options.) You can select more than one object. Right click to display the 
pop up menu with the available options for the selected objects.

You can search for a specific object in the Object List by performing a string search on any column. 
Enter the search string in the search string field for the column. Press Enter. The first matching 
object found is highlighted. If the search item cannot be found, the list heading is highlighted and No 
match found is displayed in the Status bar at the bottom of the window. Press Enter again to find 
the next occurrence of the search item.

Note The Object Group Manager has a wrap-around search facility. 

The Status bar shows the following information:

• Object Count—this field is completed automatically

• Creator—this field is completed automatically

• Query Run Time—this field is completed automatically.

Note This information is auto-generated and is not user editable.

An Edit Query option is available for selection when query populated is chosen as a type. From the 
Edit menu, select Edit Query or click the Edit Query icon to open the Query Editor (refer to 
the “Query Configuration” section on page 7-15.

You can perform a query re-run. From the Edit menu, select Re-run Query or click the Re-run

Query icon on the Toolbar. 

This action re-populates the object group displaying all objects which meet the query criteria in the 
Object List. The Query Run Time is also updated.

Note Any manual object additions or removals which do not satisfy the query criteria are lost.
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Resizing Columns in the Object List
From the Edit menu, you can also select Add Objects and Remove Object(s). This gives you the 
option to manually add or remove objects.

From the File menu select Close or click on the  icon.

The message Save Object Group changes? is displayed. Click Yes to save the changes. Clicking 
No exits without creating the object group or saving the changes. You return to the Object Group 
Manager window.

Changes to the Object Group views may be made by other users. The changes to the Object Group 
view are displayed to all users.

Note An object group must be created before it can be query populated, refer to Creating an Object 
Group, page 7-8 for more information.

If a user in one Cisco EMF session saves updates to an object group currently being edited or viewed 
in other Cisco EMF sessions, all other Object Group Editors currently editing or viewing the object 
group are automatically updated with the changes. 

If an object group currently being viewed or edited in one Cisco EMF session is deleted by a user in 
another Cisco EMF session, the This Object Group has been deleted message is displayed.Click 
Ok and the Object Group Editor window closes.

Resizing Columns in the Object List
You can resize each column in the Object List as follows:

Step 1 Place the cursor over the left or right hand edge of the column adjacent to the data entry 
box. The cursor changes. 

Step 2 Press and hold the left mouse button. 

Step 3 Drag the mouse until the required size is reached. 

Step 4 Release the mouse.
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The Object Group List Window
The Object Group List Window
The Object Group List window is launched from the Display Object Group Membership service 
on the pop up menu available on each object on the network. It is displayed when the selected object 
is a member of one or more object groups. 

Figure 7-5 Object Group List Window

This window lists all Object Groups the selected object is a member of. Select Close from the File 
menu or click the icon to return to the previous window.

Note If the selected object is not a member of any object group, the Selected object is member 
of no object groups message is displayed.

Creating an Object Group
You can create an object group in a folder in one of the following ways:

• you can create a new object group

• you can replicate an existing object group to create a new object group.

A new object group can be created in the root folder or in any sub-folder. A reference to the new 
object group is also created automatically in the system folder. You cannot create a new object group 
directly into the system folder.
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Creating an Object Group
Note To create a new folder, refer to the “Creating Folders” section on page 7-14.

Step 1 Right click on the root folder or a sub-folder. From the pop up menu, select Create 
Object Group.

The Object Group Editor window is displayed.

Step 2 Enter a unique object group name.

Step 3 Select the type of object group:

• Manual—populated by manually adding/removing network objects to or from the 
object group

• Query Populate—populated as the result of a query.

Note You can edit the name or description after an object group is created, however, you 
cannot change the object group’s type.

Step 4 Enter a Description (this is optional).

The Creator, Object Count, and Query Run Time information is displayed in the lower 
status section. This information is added automatically. 

Step 5 If the object group is to be query populated, you must set the query criteria to be used to 
create the object group (refer to the “Query Populating an Object Group” section on 
page 7-12.) 

Step 6 From the File menu select Close or click on the  icon.

The Save Object Group changes? message is displayed.

Step 7 Click Yes to save the changes or No to exit without creating the object group. You return 
to the Object Group Manager window.

Note An object group must be created before it can be manually populated. Close the Object Group 
Editor window, then select the Edit Object Group option to add objects (refer to the “Editing an 
Object Group” section on page 7-10.)

Note If a query has been set up, the objects added as a result of the query are only seen after exiting 
the Object Group Editor, when the object group has been created.
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Editing an Object Group
Replicating an Object Group
You can create a new object group using the settings of an existing object group by using Replicate 
Object Group. This option replicates an existing object group, which must then be given a new 
name. This option is available from a selected object group’s pop up menu in the Object Group 
Manager window.

Step 1 Right click on the object group you want to replicate. From the pop up menu select 
Replicate Object Group.

The Please enter new object group name prompt is displayed.

Step 2 Enter a unique object group name. Click Ok to proceed or Cancel to return to the Object 
Group Manager window.

The new object group is shown in the same folder as the original object group that was 
used for replication and is also added to the system folder.

Editing an Object Group
This option is available on a single selected object. You can use this option to:

• rename an object group

• change the query criteria for query populated object groups

• change the description

• re-run a query

• manually add and remove object(s).

Step 1 In the Object Group Manager window, select the object group to be edited.

Step 2 Right click to display the pop up menu. Select Edit Object Group.

The Object Group Editor window is displayed.

Step 3 Edit the object group name, if required.

Note An object group name must be unique.

Step 4 Edit the description if desired (this is optional).

You cannot complete the Creator, Object Count, or Query Run Time information as 
this is created automatically. 

Note You cannot change the object group’s type.

Step 5 If the object group is a query populated group, you can edit the query criteria which will 
be used to populate the object group (refer to the “Query Configuration” section on 
page 7-15.) The object group is then re-populated when the Object Group Editor is closed 
and saved, the query is run, and the objects added or removed, if appropriate, when the 
query is re-run. The Query Run Time information is updated automatically.
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Viewing an Object Group
Step 6 From the File menu, select Close or click on the icon.

The Save Object Group changes? message is displayed. Click Yes to save the changes 
or No to exit without saving the object group changes. You return to the Object Group 
Manager window.

Note Manual object additions or removals are committed (saved) immediately and not 
upon closing the editor window.

Note If a query is edited and the Re-run query option is selected before the Editor has 
been closed, you are warned that rerunning the query will commit the query edits. You 
are asked if you want to continue.

Viewing an Object Group
This option allows you to view the object group and its member objects, however, you cannot 
perform edits. You also cannot view or rerun the query.

Step 1 Select the object group to be viewed.

Step 2 Right click to display the pop up menu. Select View Object Group.

The Object Group Editor window is displayed.

Note No editing is possible in this window.

Step 3 From the File menu, select Close or click on the  icon. You return to the Object 
Group Manager window.

Manually Adding Object(s)
To manually add objects to an object group, proceed as follows:

Step 1 Select the object group you want to add objects to. Right click and select Edit Object 
Group from the pop up menu. The Object Group Editor window is displayed.

Step 2 In the Object Group Editor window, from the Edit menu, select Add Object(s)
or
click the Add Object(s) icon from the Toolbar.
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Manually Removing Object(s)
Step 3 The Object Selector window is displayed. This window shows all managed object views. 
You can expand or collapse the view(s). Select the object(s) you wish to add.

Step 4 Click Apply. The selected object(s) are displayed in the List in the Object Group Editor 
window. The Object Count in the Object Group Editor window is updated. Click Cancel 
to close the Object Selector window without adding objects.

Note Manually added objects are committed (saved) immediately and not upon closing the editor.

Manually Removing Object(s)
To manually remove objects from an object group, proceed as follows:

Step 1 Select the object group from which you want to remove objects. Right click and select 
Edit Object Group from the pop up menu. The Object Group Editor window is 
displayed.

Step 1 Select the object(s) you want to remove.

Step 2 From the Edit menu, select Remove Object(s), or click the icon, or right click 
on the object(s) and select 
Remove Object(s) from the pop up menu. The object(s)
are removed.

Query Populating an Object Group
If the object group is to be query populated, you must set the query criteria to used to create the object 
group (refer to “Query Configuration” section on page 7-15.) The object group is then populated 
when that query is run and the objects are added or removed, if appropriate, when the query is rerun. 
The Query Run Time information is created or updated automatically.

Copying an Object Group
You may want an object group to appear in more than one place in the Object Groups view. You can 
copy a reference to an object group and paste it into another folder in the view.

Note Only one actual object group exists, however, you can have more than one reference to that 
group in the Object Groups view.

Step 1 Right click on the object group to be copied. From the pop up menu, select Copy.

Step 2 Select the new location folder for the object group reference.

Note This is the folder in which you want to have a new reference to the object group.

Step 3 Right click on the folder. From the pop up menu, select Paste. The new reference to the 
object group is added to this folder.
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Removing Object Group References
Removing Object Group References
A reference to an object group can be located in more than one folder in the Object Groups view. For 
example, it may be referenced as a group of the same object type, such as DSLAMs created in a 
physical classification folder, and also as a reference to an object group location or a similar group 
of hardware items located at a particular NOC. Each instance is simply a reference to that object 
group.

You may want to remove an object group reference from one folder but retain it in others. Use 
Remove Object Group Reference(s) to do this. This option removes only the selected object group 
reference(s) from their folder(s). All references to the selected object group(s) in other folder(s), 
remain intact.

Note When an object group reference is removed from a folder, it is reflected in all instances of that 
folder within the Object Groups view.

Note This option does not delete the object group and is not available in the system folder.

To remove the selected reference to an object group:

Step 1 Select the object group(s) to be removed.

Step 2 Right click to display the pop up menu. Select Remove Object Group Reference(s).

The reference to the object group is removed.

Deleting Object Groups
If you want to delete the object group so it is removed completely from your Object Groups view, 
use Delete Object Group(s). This option deletes the object group and removes all reference(s) to 
that object group from the view.

To delete an object group:

Step 1 Select the object group(s) to be deleted.

Step 2 Right click to display the pop up menu. Select Delete Object Group(s).

Step 3 The This operation will delete selected object group(s) message is displayed. 
Click Yes to proceed or No to cancel.
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Creating Folders
Creating Folders
You can create a folder from the root folder or any other folder in the Object Groups view as follows:

Step 1 Right click on the root folder or any other folder. From the pop up menu select Create 
Folder.

Step 2 The Please enter folder name prompt is displayed. Enter the folder name. 

Note A folder name must be unique. A folder may have the same name as an object 
group.

Step 3 Click Ok to proceed or Cancel to return to the Object Group Manager window.

Copying Folders
You may want a folder to be located in more than one place in the Object Groups view. You can 
create another reference to an existing folder, as follows:

Step 1 Right click on the folder to be copied. From the pop up menu select Copy.

Step 2 Select the new location for the folder.

Step 3 Right click on the location folder. From the pop up menu, select Paste. The reference to 
the new folder is shown in the new folder.

Removing a Folder Reference(s)
A folder can be located in more than one parent folder in the Object Groups view. Each instance of 
a folder is a reference to that folder. You may want to remove a folder from one or more parent 
folders, but retain it in others. Use the Remove Folder Reference(s) option to do this. This option 
removes only the selected folder reference(s) from their parent folder(s). All references to the 
selected folder(s) in other parent folder(s) remain intact.

Note When a folder reference is removed from a parent folder, it is reflected in all instances of that 
parent folder within the Object Groups view.

Note You can only remove a folder instance that contains objects if there is another reference to 
that folder elsewhere in the Object Group view.

Note Removing the last reference to a folder in the Object Groups view deletes the folder.

To remove the selected reference to a folder:

Step 1 Select the folder(s) to be removed.

Step 2 Right click to display the pop up menu. Select Remove Folder Reference(s).

The reference(s) to the folder is removed.
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Deleting Folders
Deleting Folders
To delete all references to a folder:

Step 1 Select the folder(s) to be deleted.

Step 2 Right click to display the pop up menu. Select Delete Folder(s).

The This operation will delete selected folder(s) message is displayed.

Step 3 Click Yes to proceed or No to cancel.

Note The folder must be empty. If object groups or sub-folders exist in the folder, the 
message Selected folder is not empty is displayed. 

Query Configuration
The Object Group Manager gives you the option to create object groups based on a query. The 
criteria are set up using queries which can be configured to match your requirements. With queries, 
you can choose to include or exclude devices or criteria (for example, you could choose to group 
particular devices or choose to create object groups with the same IP address). You define query 
criteria so the Object Group Manager will populate a query populated group that meets this criteria.

All query based object groups have a time stamp called Query Run Time that shows when the query 
was last run. 

You can set up the following query criteria:

• Object Scope

• Object Class

• Object Attribute Presence

• Object Attribute Value.

Refer to Chapter 11, “Query Editor,” for more information.
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Query Configuration
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