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Map Viewer
The Cisco EMF Map Viewer application provides you with complete flexibility in viewing, building, 
and monitoring your network using graphical representations of network elements. You open the 
Map Viewer from the Cisco EMF Launchpad. A window similar to Figure 3-1 is displayed.

Figure 3-1 Cisco EMF Map Viewer Window

The Map Viewer is a window that allows you to see your network by providing a hierarchical view 
of all of your network alongside topology views.

A Network Map provides a graphical representation of a level in a user’s network and the status of 
network elements within it. For example, if you are building a map to represent a network in 
California, there may be a top level map of the USA, with each of the major sites on it. Each site may 
be represented by a separate map which may contain each of the network objects for that site. 
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Objects
Network maps make it easy to navigate through a large number of objects on a network. Maps can 
also be used to invoke the services on network objects. Refer to Chapter 10, “Managing Objects in 
Cisco EMF,” for more information.

Maps are a representation of a level in the network and need not be defined in a geographical context. 
The Cisco EMF Network Maps application provides complete flexibility in defining and monitoring 
a view. Network elements could be organized into different views according to requirements, for 
example, into a domain because they serve a common function or have a common geographic 
location or support a common service.

Maps may be built automatically using the Cisco EMF Deployment Wizard (refer to Chapter 4, 
“Deployment Wizard,”) and may then be edited. Access to maps and services available on objects is 
controlled through Cisco EMF Access Control (refer to Chapter 9, “User Access Control.”)

Only users with the appropriate access can edit maps. However, that map may be used by a number 
of users, so Cisco EMF ensures that those users should be informed of any changes to that map. It is 
important that every user work with the same version of a map.

When you begin to edit a map, it is locked. This means no other user can edit the same map until 
your edit session is complete and the changes have been saved. If another user attempts to edit the 
same map, a dialog box informs them the map is locked.

Objects
An object is a representation of a network element. For example, this could be a node, a shelf, a shelf 
item, or a link. Each object shown in the right hand window provides graphical cues which provide 
information about its associated network element (refer to the “Graphical Cues” section on 
page 3-4.) The information can be structural information, for example, a network element name, or 
state and event information, such as “out of service.”

Each object may display the following information about its associated network element:

• Object name

• Object class

• Object state

• Event unacknowledged count

• Event unacknowledged state

• Event outstanding state.

Figure 3-2 Information Displayed on an Object
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Object Class
Note Events shown visually are the most severe.

• The object base shows the event status color

— an event counter is displayed in the balloon

— a number indicates the number of the most severe events in the category

— a letter indicates the highest unacknowledged event severity in the category

— a plus sign appears if there are other less severe, unacknowledged events in the category.

• The object has a colored outline which shows the event status color.

When the event status of an object changes in the network, the graphical cues change to reflect the 
new status.

The event status of objects contained in a map can affect the event status of the parent icon. In other 
words, if the event status changes on a map object, this is propagated to the parent icon. The event 
status is changed to reflect the most severe event severity of its map.

Object Class
Objects which represent nodes, shelves, and shelf items have a bitmap graphic which shows the 
object class (for example, SNMP). 

Object State
The graphic also shows the object state. An object state is a possible condition in which an object 
may exist. A state can be a primary state (shown by hatching) or a secondary state (shown by icons). 

An object shows only one primary state, whereas it can have a number of secondary states. Refer to 
the “Primary States” section on page 3-8 for full details of primary states.

A secondary state can only be set on an object if the network element is in a predefined primary state. 
Secondary states are shown as small icons in the top left corner of each object. Refer to the 
“Secondary States” section on page 3-10 for full details of secondary state icons.

The representation of states is based on Telecom standards and includes:

• OSI state dictionary (based on the OSI SMF 10164-2 standard)

• Event state dictionary to display the set of events.
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Objects
Graphical Cues
This section provides information about the graphical cues as they correspond to event status.

Status on Objects - Graphical Cues
Each object in the right hand panel also indicates the most severe object status. Events are shown 
graphically on each object as follows:

Events on Objects - Graphical Cues
Each object in the right hand panel also indicates the event status. Events are shown graphically on 
each object as shown in Figure 3-3.

Figure 3-3 Event Status Displayed on an Object
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Informational Icons
Informational Icons
Secondary states are shown as small icons in the top left corner of each object. Refer to the 
“Secondary States” section on page 3-10 for more information. When an object holds several 
secondary states they are displayed as follows:

• Two secondary state icons are displayed simultaneously:

• When more than two secondary states are to be displayed, an information icon replaces the 
individual icons. Click on this icon with the left mouse button to view a list of secondary states.

• When the information window has been viewed and closed by left clicking on the window, the 
information icon becomes transparent until any new secondary state change occurs on the 
network element:.
 Map Viewer 3-5



Services on Maps
Services on Maps
Services, such as Object Configuration, can be invoked on an object selected in either the hierarchy 
panel or the map panel. You can select one or more object(s) and right click. This displays the list of 
services available on an object in a pop up menu. The services available depends on the class of that 
object and on the access of the user. Access to the features in the Map Viewer application is managed 
by Access Control (refer to Chapter 9, “User Access Control.”)

Note When multiple objects are selected, only the services common to all of the objects are 
available.

Launching the Map Viewer
The Map Viewer is launched using the  icon on the Cisco EMF Launchpad window or
as a service from the pop up menu
available on a selected object.

A window similar to Figure 3-4 is displayed:

Figure 3-4 Map Viewer Window
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Hierarchy Panel
The Map Viewer window is divided into two panels. The left hand panel shows the objects in a 
hierarchy browser format. An object selected in the browser has its map displayed in the right hand 
panel. You can view several maps at once in different windows.

The Hierarchy panel and Map panel can be resized by positioning your cursor over the boundary; 
left click with the mouse, then drag the boundary. You can view all information in the left and right 
hand panels by using the scroll bars.

You can exit the Map Viewer from the File menu.

You can print the map hierarchy or map, showing the currently visible map nodes (refer to “Printing 
a Map” section on page 3-16.) The printed map shows the status of network objects at the time of 
printing.

You can invoke a service on an object (refer to Chapter 10, “Managing Objects in Cisco EMF,” for 
more information on services.) You can select one or more object(s) and right click. This displays 
the list of services available on an object in a pop up menu. The services available depends on the 
class of that object and is enabled or disabled according to the access of the user. 

Note If multiple objects are selected, only the services common to all of the objects is available.

Hierarchy Panel
This panel always contains the Physical view and the Network view. The window shows multiple 
views of objects on the system and lists the object groups and objects by name. You can also:

• View the map hierarchy tree

• Navigate through the map hierarchy by expanding and contracting objects to expose their 
children. A number in brackets indicates the number of children at the next level in the hierarchy. 
The number of children objects is shown in the right hand window. Click on the + sign, or 
double-click on the object to show all of the children of the selected object. Each object in the 
left hand window shows two event indicators (colored dots, refer to the “Severity Colors” section 
on page 1-9). The one to the right of the object name shows the event severity status of that object, 
and the one in brackets, with the number of children of that object, shows the most severe event 
status of the child objects.

• Open a selected map.

Sorting the Hierarchy List
The View menu allows you to sort the hierarchy list using the following options:

• Sort by Class

• Sort by Name.
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Map Panel
Map Panel
When an object is selected, the associated map is shown in the right hand panel of the Map Viewer 
window. You can also:

• View a map and all of the objects shown on that map

• Navigate downwards through the map hierarchy by double-clicking on an object in the current 
map

• Navigate upwards through the map hierarchy by viewing a parent map (refer to “Viewing a Parent 
Map” section on page 3-16.)

An object’s map can be opened to replace the current map. Double-click on the selected object, or 
select an object and from the pop up menu. Select Map, then select Open Map. 

You can open a different map in the view section of the window by double-clicking on an object in 
the right hand panel of the window. The map currently being viewed is clearly indicated in the 
hierarchy tree.

Primary States
By default, an object shows one primary state, whereas it can have a number of secondary states. A 
primary state is one of the following:

• Out of Service (OOS)—shows a bitmap with diagonal hatching and corresponds to the following 
statuses:

Operational: Disabled
Usage: Idle
Administrative: Unlocked

or

Operational: Disabled
Usage: Idle
Administrative: Locked
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Primary States
• No Traffic (NT)—shows bitmap with no cross hatching and corresponds to the following 
statuses:

Operational: Enabled
Usage: Idle
Administrative: Unlocked

or

Operational: Enabled
Usage: Idle
Administrative: Locked

• Carrying Traffic (CT)—shows a bitmap with no cross hatching and corresponds to the following 
statuses:

Operational: Enabled
Usage: Active
Administrative: Unlocked

or

Operational: Enabled
Usage: Active
Administrative: Shutting down

or

Operational: Enabled
Usage: Busy
Administrative: Unlocked

or

Operational: Enabled
Usage: Busy
Administrative: Shutting down
 Map Viewer 3-9



Map Panel
• Not installed (NI) - shows bitmap with cross hatching

Note An Element Manager may use other bitmaps to show primary states. Refer to the specific 
Element Manager manual.

Secondary States
Secondary states are shown as small icons in the top left corner of each object. 

OSI Status Icons
The OSI status set is divided into five groups:

1 Procedural status used to report if the managed object has been properly or improperly initialized 
or is finally reporting. It can be one of the following:

Initialization Required:

Initializing:

Terminating:

Initialization Required (OSI status)

Initializing (OSI status)

Terminating (OSI status)
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Secondary States
Reporting:

2 Availability status determines the status of the managed object and can be one of the following:

Degraded:

Failed:

In Test:

Log Full:

Off Duty:

Reporting (OSI status)

Degraded (OSI status)

Failed (OSI status)

In-test (OSI status)

Log full (OSI status)

Off duty (OSI status)
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Map Panel
Power Off:

3 Control status shows if a managed object is:

Reserved for Test:

Subject to Test:

4 Standby status identifies a managed object which does not provide a service but which can 
immediately take over the role of a primary resource:

Cold Standby:

Hot Standby:

Providing Service:

Power off (OSI status)

Reserved for test (OSI status)

Subject to test (OSI status)

Cold standby (OSI status)

Hot standby (OSI status)

Providing service (OSI status)
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Non OSI Secondary State Icons
5 The Repair status is:

Under Repair:

Non OSI Secondary State Icons
The following icons show secondary miscellaneous states. This is useful for efficient network 
supervision and management. For example, you can be informed that an element is being repaired 
or that high or low temperatures may be causing large numbers of minor events to be generated.

Note Facility states are connected with links.

Under repair (OSI status)

Door ajar (Miscellaneous state)

Exerciser (Facility state)

High temperature warning (Miscellaneous state)

Locked (Facility state)

Low temperature warning (Miscellaneous state)

Mismatched card (Miscellaneous state)

Plan to remove (Miscellaneous state)

Software downloading (Miscellaneous state)
 Map Viewer 3-13



Map Panel
Links 
A link is a connection between two nodes. If two or more links occur between the same pair of nodes, 
all the links are shown on the map. A link also shows graphical cues to provide information.

Graphical cues on links are used to display the transmission equipment making up the telecom 
network links. The link state is shown as follows:

• Disabled:

Software limit exceeded (Miscellaneous state)

Software upload (Miscellaneous state)

Test failure (Miscellaneous state)

Test passed (Miscellaneous state)

Threshold crossing (Miscellaneous state)

Under repair (Miscellaneous status)

Unknown card (Miscellaneous state)
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Selecting One or More Objects in the Map Panel
• Inactive:

• Active: 

Icons are used on links to represent the link status. Links can also contain event information.

The link media (for example, CNET, Fiber, or Electrical is shown by an icon placed in the center of 
the link).

Selecting One or More Objects in the Map Panel
You can select objects in Map Builder mode. Objects can be selected by clicking or dragging the 
cursor around the objects, or by using an option from the Edit menu. When an object is selected, a 
white outline appears:

Left clicking on an object selects that object.

Holding down Ctrl and left clicking on more than one object selects all of the selected objects.

Communication network link (Link media type)

Electrical link (Link media type)

Fiber link (Link media type)
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Viewing a Parent Map
Holding down the left mouse button and dragging around one or more objects selects those objects. 

Note You must drag around the outside of the complete object or it will not be selected.

From the Edit menu, you have the option to Select all or Deselect all.

Viewing a Parent Map
You can view a parent map in Map Viewer mode.

From the View menu, select Open Parent Map
or
click the Open Parent Map icon,  available in the Map Viewer window. 

The selected object’s parent map is displayed in the right hand panel of the Map Viewer window.

Note The icon is grayed out when not available.

Printing a Map
You can print a map in Map Viewer or Map Builder mode.

From the File menu, select Print or
press Ctrl + P or
click the Print icon  from the Toolbar. 

The displayed map is printed.
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The Map Builder Window
The Map Builder Window
The Map Builder window is launched with the Edit Map option on the pop up menu, available for 
a selected object. The path of the selected object is shown as part of the window title.The associated 
Class Palette is also opened (refer to “Opening the Class Palette” section on page 3-22 for more 
information.)

Figure 3-5 Map Builder Window

Note When a map is being edited it is locked. Only one user can edit a map at any one time. Any 
other user can view the map, without any changes. When a user attempts to edit the map, the Map 
Builder window is displayed, and a dialog box informs the user that the map is locked. Click Ok to 
close the Map Builder window. 
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The Map Builder Window
Step 1 Right click on the selected object(s). From the pop up menu select Edit Map.

The Map Builder window is displayed. From this window you can:

• Move/reposition objects

• Set annotated text

• Save a map

• Set a map background

• Clear a map background

• Create a link

• Add objects

• Remove objects

• Open the Class Palette

Step 2 You can also run Map Builder services from objects in the Map Builder window.

Note When any changes are saved, all opened maps in Map Viewer and Map Builder modes are 
updated automatically. These may be a result of changes made in the Map Builder window or actions 
elsewhere in the Cisco EMF applications (for example, deployment of new devices). The
Map Updating message is displayed in the status bar. 

Moving/Repositioning Object(s) on a Map
In Map Builder mode, you can reposition any object(s) as follows:

Step 1 Select the object and hold down the left mouse button. 

Note Links can only be repositioned with objects.

Step 2 Move the object to the new position and release the mouse button.

Note Any links are repositioned.

Step 3 To reposition a number of objects at one time, select the objects. Hold down Ctrl and left 
click on one object and move the selected objects. 
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Setting Map Description
Setting Map Description
In Map Builder mode, the Map Description option allows you to include annotated text. This could 
be notes, date and time, comments etc. To set annotated text, proceed as follows:

Step 1 From the Edit menu in the Map Builder window, select Set Map Description.

The Map Description window, shown in Figure 3-6 is displayed.

Figure 3-6 Map Description Window

Step 2 Enter the desired text.

Step 3 Click Apply to proceed or Close to cancel.

Setting a Map Background
You may want the maps to reflect the geography of the network, or to reflect the structure of 
components in the network. Cisco EMF gives you flexibility to define a map with a geographical 
picture in the background. 

In Map Builder mode, you can choose a background from your system to apply to a map. Cisco EMF 
supports the following formats for map backgrounds:

• bmp, dib (Windows Bitmaps)

• gif (GIF87, GIF89a)

• pbm, ppm, pgm (all treated as PBM files).

To set a map background proceed as follows:

Step 1 From the Edit menu in the Map Builder window, select Set Map Background.

The Background Selector window, shown in Figure 3-7 is displayed. 
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The Map Builder Window
Figure 3-7 The Background Selector Window

This window displays a list of available backgrounds or if the background you require is 
not available, you can browse any directory on your system.

Step 2 Click the disk icon. 

The File Chooser window is displayed.

Step 3 Use the scroll bars to locate the desired image file.

Step 4 Select the file. The full path name of the selected file appears in the Choice box.

Step 5 Click the Apply button.

The Background Selector window is redisplayed.

Step 6 Select the background you require, then click Apply.

The background is shown in the Map Builder window.

Step 7 Click Close to cancel changes.

Note The map background is not re-sized.

Step 8 To save the changes, from the File menu, select Save Map or
from the File menu select Close or 
press Ctrl + W or

click the Close icon  from the Toolbar.

Step 9 If no changes have been made to the map, a dialog box asking Proceed with close? is 
displayed. Click Yes to proceed or No to cancel.

Step 10 If changes have been made to the map, a dialog box asking Save changes before 
closing? is displayed. Click Yes to save changes before closing or No to disregard 
changes before closing, or Cancel to cancel any changes.
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Clearing a Map Background
Clearing a Map Background
In Map Builder mode, you can clear a map background. Proceed as follows:

Step 1 From the Edit menu in the Map Builder window, select Clear Background. 

A dialog box asking Clear Background? is displayed.

Step 2 To save the changes, from the File menu select Save Map or
from the File menu select Close or 
press Ctrl + W or

click the Close icon  from the Toolbar.

Step 3 If no changes have been made to the map, a dialog box asking Proceed with close? is 
displayed. Click Yes to proceed or No to cancel.

Step 4 If changes have been made to the map, a dialog box asking Save changes before 
closing? is displayed. Click Yes to save changes before closing or No to disregard 
changes before closing, or Cancel to cancel any changes.

Creating a Link
To create a link between two objects in Map Builder mode, proceed as follows:

Step 1 From the Edit menu in the Map Builder window, select Create Link or select the 
appropriate icon from the toolbar. 

There are three types of links available for selection:

• Fiber link:

• Network link: 

• Electrical link: 

Note A link can be created between two objects. It cannot start or finish at another link. 

Step 2 Select the type of link you require. The cursor changes to a cross hair shape.

Step 3 Position the cursor over the object, press and hold the left mouse button and move the 
cursor to the second object. Release the mouse button. The link appears between the two 
objects. The Deployment Wizard then opens (refer to Chapter 4, “Deployment Wizard.”)

An icon indicates the type of link you have created. Refer to the “Links” section on 
page 3-14. All opened map(s) are updated automatically.

Note You need only move the mouse button directly between the objects. Cisco EMF 
then shows the link with the most logical path.
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The Map Builder Window
Adding an Existing Object
This is used in Map Builder mode when you want an existing object to be shown in your view. To 
add objects to a map, proceed as follows:

Step 1 From the Edit menu in the Map Builder window, select Add Objects.

Step 2 Select the object you require from Object Selector dialog box, then click Apply.

The object now exists on the system and appears in the Map Viewer window.

Removing an Object
In Map Builder mode, an object may be removed from the map. When the object being removed has 
a connected map, the connected map is also removed. 

When the object is removed in another Cisco EMF application, the object is automatically removed 
from the map. 

In Map Viewer mode, when an object is removed:

• Every user viewing that object is notified, through a message, that the object has been removed.

• All open instances of the object are removed

• When the removed object has a root map, the root map is displayed

• The map hierarchy tree is updated to delete the removed map.

Two options are available in the Map Builder window to remove an object:

• Remove Objects—available as a service on a selected object in the map window

• The Edit menu’s Remove Objects option.

To remove objects from a map, proceed as follows:

Step 1 In the Map Viewer or Map Builder window, select the object(s) to be removed.

Step 2 From the pop up menu on the selected object(s) or from the Edit menu in the Map Builder 
window, select Remove Objects. 

Step 3 A dialog box asking Are you sure? is displayed. Click Yes to proceed or No to cancel.

Step 4 If no changes have been made to the map, a dialog box asking Proceed with close? is 
displayed. Click Yes to proceed or No to cancel.

Step 5 If changes have been made to the map, a dialog box asking Save changes before 
closing? is displayed. Click Yes to save changes before closing or No to cancel changes 
before closing.

Opening the Class Palette
The Class Palette displays a set of icons, each of which represents a class in the system. The Class 
Palette is context sensitive and its contents depends upon the type of map that is currently active. The 
Deployment Wizard is launched when an icon is selected from the Class Palette and moved to a map 
(refer to Chapter 4, “Deployment Wizard.”)

The Class Palette opens automatically when the Edit Map option is selected from an object.
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Saving a Map
To open the Class Palette window, proceed as follows:

Step 1 Select the View menu’s Open Class Palette option in the Map Builder window.

The Class Palette window, similar to Figure 3-8, is displayed.

Figure 3-8 Class Palette Window

Step 2 Place the cursor over the active icon that represents the object class to be added. 

Step 3 Press and hold the left mouse button.

Step 4 Move the selected icon to the desired location on the map, then release the mouse button.

The selected icon is now displayed on the map. The Deployment Wizard is launched and 
the object can be deployed. All maps are updated if an object is successfully deployed. 
Refer to Chapter 4, “Deployment Wizard,” for full details. 

Note You can reposition any object. Select the object and hold down the left mouse 
button. Move the object to the new position, then release the mouse button. Any links are 
repositioned.

Saving a Map
This option is used in Map Builder mode to save changes to the map. When a map is modified and 
the changes are saved, every user viewing that map is notified that the map was modified. The map 
is updated to reflect the changes made.

To save a map when a change is made in the Map Builder window, select Save Map from the File 
menu. A dialog box asking Save changes? is displayed. Click Yes to proceed or No to cancel.

Note Save Map is grayed out when the option is not available for selection.
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The Map Builder Window
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