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Documentation Conventions

OPNET documentation uses specific formatting and typographic conventions to present 
the following types of information:

• Objects, examples, and system I/O

• Object hierarchies, notes, and warnings

• Computer commands

• Lists and procedures

Objects, Examples, and System I/O

• Directory paths and file names are in plain Courier typeface:

opnet\release\models\std\ip

• Function names in body text are in italics:

op_dist_outcome()

• The names of functions of interest in example code are in bolded Courier 
typeface:

/* determine the object ID of packet’s creation module */
src_mod_objid = op_pk_creation_mod_get (pkptr);

• Variables are enclosed in angle brackets (< >):

<opnet_user_home>/op_admin/err_log

Object Hierarchies, Notes, and Warnings

Menu hierarchies are indicated by right angle brackets (>); for example:

Open File > Print Setup > Properties...

Attribute hierarchies are represented by angled arrows (➘ ) that indicate that you must 
drill down to a lower level of the hierarchy:
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Attribute level 1 ➘ Attribute level 2 ➘ Attribute level 3

Note—Notes are indicated by text with the word Note at the beginning of the 
paragraph. Notes advise you of important supplementary information.

WARNING—Warnings are indicated by text with the word WARNING at the 
beginning of the paragraph. Warnings advise you of vital information about an 
operation or system behavior.

Computer Commands

These conventions apply to Windows systems and navigation methods that use the 
standard graphical-user-interface (GUI) terminology such as click, drag, and dialog box.

• Key combinations appear in the form “press <button>+x”; this means press 
the <button> and x keys at the same time to do the operation.

• The mouse operations left-click (or click) and right-click indicate that you 
should press the left mouse button or right mouse button, respectively.

Lists and Procedures

Information is often itemized in bulleted (unordered) or numbered (ordered) lists:

• In bulleted lists, the sequence of items is not important.

• In numbered lists, the sequence of items is important.

Procedures are contained within procedure headings and footings that indicate the start 
and end of the procedure. Each step of a procedure is numbered to indicate the 
sequence in which you should do the steps. A step may be followed by a description of 
the results of that step; such descriptions are preceded by an arrow.

Procedure FM-1 Sample Procedure Format 

1 Procedure step.

➥ Result of the procedure step.

2 Procedure step.

End of Procedure FM-1

For more information about using and maintaining OPNET documentation, see the 
OPNET IT Guru Documentation Guide.
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About the Tutorials in This Book

The tutorials in this book are the same tutorials that are delivered on the 
Documentation CD that comes with the OPNET software installation package. 
You can access the tutorials by choosing Help > Tutorials from the main menu 
of your OPNET application.

The tutorials are printed here in the same format as they appear online. This 
ensures page-by-page equivalency with the electronic version. Consequently, 
any hypertext links or action buttons that help you navigate the tutorials online 
are not active in the printed version. However, because it is frequently 
referenced from many of the tutorials, App A Troubleshooting Sentinel Tutorials 
on page TUT-A-1 has been included in this book.

For best results, do the tutorials in the order in which they appear in the book. 
The tutorials are in the same order in which they appear on the menus of the 
electonic version.
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1 IT Sentinel Quick Start
SP Sentinel Quick Start

Introduction

SP Sentinel provides the capability to perform tasks 
such as network configuration import, validation, and 
security analyses automatically. The tasks run 
unattended at scheduled times and the task results 
are available for viewing from the Report Server.

This tutorial gives an overview of the SP Sentinel 
workflow. You will

1) Configure Device Configuration Import to import 
configuration files from a particular directory and 
save the settings for use during the automated 
run.

2) Configure NetDoctor to run a selected set of 
rules to identify relevant configuration errors and 
save the NetDoctor settings for use during the 
automated run.

3) Set up an automation task to run the actions you 
specify within a schedule that you specify.

4) View the reports published to the Report Server 
during the automation run after the task 
completes.
1.0 TUT-1-1
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Before You Begin

This tutorial can be done independently or as part of a 
suite. If you are doing this tutorial as part of a suite, do 
the tutorials in this order:

1) SP Sentinel Quick Start (this tutorial)

2) Setting Up Sentinel Automation

3) NetDoctor Notification in SP Sentinel

4) Using Flow Analysis with Sentinel

5) Comparing Networks with Sentinel

6) Working with the Report Server

Prerequisite Tutorials

There are no prerequisite tutorials.
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Tutorial Workflow

The following figure shows the workflow of the tutorial.

SP Sentinel Quick Start Tutorial Workflow

Configure OPNET to work 
with the Report Server

Configure NetDoctor

Configure the Task Schedule

Verify Sentinel Activity

View Reports

Start

End

Set up automation for 
Device Configuration Import  
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Configuring Report Server Preferences

The results of the automated task runs are published 
to the Report Server. Therefore, if you have not 
already done so, you must install and configure the 
Report Server. For information, see the Report 
Server User Guide.

You must also ensure that the Report Server 
preferences are specified correctly in SP Sentinel. 
The SP Sentinel software installer prompted you for 
the name of your Report Server as well as the 
username and password that should use when 
publishing reports. If you did not enter this information, 
or would like to verify your settings, choose Edit > 
Preferences and search for the string “report_server”. 

1 If SP Sentinel is not already running, start it.

2 Choose Edit > Preferences to open the 
Preferences dialog box.
IT Sentinel/Release 11.0
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3 Type report_server in the Find field and click on 
the Find button.

➥ The Report Server preferences are listed in 
the dialog box.

4 Make sure that the computer on which the Report 
Server is running is listed in the value of the 
report_server_name preference, and that the 
correct port is listed in the value of the 
report_server_port preference.

Contact your system administrator if you are not 
sure about these values.

5 Also make sure that the username/password 
combination that is used to publish reports to the 
Report Server is specified correctly in the 
report_server_username and 
report_server_password preferences. 

The username and password are provided by 
your Report Server administrator, who specifies 
this information in the Report Server 
1.0 TUT-1-5
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configuration file. For more information, see the 
Report Server Administration chapter of the 
Report Server User Guide.

6 Make any needed changes and then click OK to 
close the Preferences dialog box.
IT Sentinel/Release 11.0



Sentinel Tutorials

IT Sentinel/Release 1
Configuring Automation for Device 
Configuration Import

In this section, you configure the Device Configuration 
Import dialog box to import network configuration files 
from the correct location, and with the desired 
settings, for use during the automated run. Then, you 
save these settings to an automation settings file.

1 If SP Sentinel is not already running, start it.

2 Select File > New…

3 From the pull-down menu, select Project, then 
click OK.

4 Enter <your_initials>_Test as the project name 
and use the default name, scenario1, for the 
scenario name, then click OK.

(When you save create a file as part of a tutorial, 
it is good practice to include your initials in the file 
name. If multiple users do the same tutorial, the 
initials ensure that each user has a unique copy 
and does not interfere with the work of others.)
1.0 TUT-1-7
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5 The Startup Wizard: Initial Topology dialog box 
appears.

6 Select Import from Device Configurations and 
click Next.

➥ The Import Device Configurations dialog 
appears.

7 Make sure that only the Cisco (IOS, CatOS, PIX) 
checkbox is checked.

Uncheck the Juniper JunOS checkbox if it is 
checked.

8 Click on the Browse... button for the 
Cisco (IOS, CatOS, PIX).

➥ A file browser dialog box appears.

9 Choose the following directory:

<opnet_dir>\models\std\tutorial_req\sentinel\ 
quickstart_configs
IT Sentinel/Release 11.0
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<reldir> refers to the SP Sentinel release 
installation directory.

10 Click on the “Save settings for automation” button 
 in the bottom left corner of the dialog box.

➥ A file browser dialog box appears that prompts 
you for the name of the automation settings 
file.

11 Select your default models directory from the 
directories listed on the left.

12 Type <Initials>_DCI_Settings in the File name 
field and click Save.

➥ Your Device Configuration Import settings are 
now saved.
1.0 TUT-1-9
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This file will be used later when setting up the 
automation tasks.

13 You do not need to import device configurations 
at this time. (In later tutorials, you will learn how 
to test configurations as part of the automation 
workflow.) Click Cancel to close the Import 
Device Configurations dialog box.

➥ The blank scenario is now displayed.
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Configuring NetDoctor Automation

NetDoctor identifies current or potential trouble spots 
in your network by applying selected rules to your 
network model and indicating how the network 
configuration deviates from the rules.

In this section, you will configure NetDoctor and save 
the settings for use during the automated task run.

1 Choose NetDoctor > 
Configure/Run NetDoctor… or use the toolbar 
button.  

➥ The Configure/Run NetDoctor dialog box 
appears.

You are interested in running only the OSPF rule 
suite to check for OSPF-related configuration 
problems.

2 Select the OSPF tree branch in the Rule Suites 
tree view.

➥ All the OSPF rules are selected.

Make sure you do not select the tree branch 
OSPF (Advanced).
1.0 TUT-1-11
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You can click on the “+” next to the OSPF tree 
branch to expand the tree and verify that all 
the OSPF rules are selected.

3 Click on the Settings tab.

4 From the Output Format list, choose Web 
Report.
IT Sentinel/Release 11.0
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5 Make sure that the Send report to Report 
Server checkbox is checked.

6 Click on Save As…

➥ The Save As dialog box appears.

7 Select your default models directory from the 
directories listed on the left.

8 Enter <Initials>_OSPF_Template in the File 
name field, and click on Save.

➥ Your OSPF-specific NetDoctor template is now 
saved in this file.

9 Click on the “Save settings for automation” 
button.

➥ The Save As dialog box for the settings file 
appears.

10 Select your default models directory from the 
directories listed on the left.

11 Enter <initials>_NetDoctor_Settings in the File 
name field and click Save.

➥ Your NetDoctor settings are now saved in this 
automation task step file. 
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This file will be used in a later step when setting 
up the automation tasks.

12 Click Cancel to close the Configure/Run 
NetDoctor dialog box, since you do not want to 
run NetDoctor at this time.
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Configuring Automation Tasks

In the previous sections, you saved the Device 
Configuration Import and NetDoctor settings to use 
during the automated run. In this section, you will 
configure an automation task to use these settings 
and set up a schedule for running the task.

1 Open the Configure/Run Automation Tasks 
dialog box. To do this, choose File > 
Automation > Configure/Run Automation 
Tasks or click the toolbar button.

This dialog box lists the automation tasks that are 
currently configured. You can create, edit, or 
delete tasks using this dialog box.

The default task, Task1, is selected.
1.0 TUT-1-15
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2 Click in the Name column of the task table and 
then rename the task <initials>_Quickstart.

3 Click Edit to configure this task.

➥ The Edit Task Details dialog box appears.

4 In the Task Steps table, you can specify the 
number and sequence of steps that you want to 
include in the automation task. Click on the first 
row in the Task Step Type column and then hold 
down the mouse button.

➥ The available types of automation task steps 
are displayed.

5 Your task has two steps in the following order:

• Import Topology from Device Configurations

• Generate NetDoctor Report

5.1 Select Import Topology from Device 
Configurations from the list.

5.2 Click on the first row in the column 
Automation Settings File.

➥ The available Device Configuration Import 
settings files are displayed.
IT Sentinel/Release 11.0
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5.3 Select the <Initials>_DCI_Settings file, 
which you saved earlier in this tutorial.

5.4 To add the second step, click Add Step.

➥ Another row is added for the second task 
step.

5.5 Click in the Task Step Type column of the 
second row, then select Generate 
NetDoctor Report from the list.
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5.6 Click on the second row in the Automation 
Settings File column, and select 
<Initials>_NetDoctor_Settings from the 
list.

6 Select the None option for the Source 
Project/Scenario task option, and Do not save 
changes for the Destination Project/Scenario 
task option.

➥ When the task runs, a new (blank) project and 
scenario will be used. After the automation 
run, the project will not be saved.
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7 Verify that the Exit after task completion 
checkbox is selected.

This specifies that SP Sentinel should exit after 
the automation run.

8 Verify that the Hide OPNET windows during 
automation checkbox is not selected.

Typically, you would leave this option selected 
since you normally run Sentinel in an automated 
and unattended mode; therefore, you do not want 
its windows appearing on the screen.

However, for purposes of running this tutorial and 
knowing when Sentinel finishes, you will turn this 
option off. 
1.0 TUT-1-19
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You have now specified the steps that will be executed 
as part of this automation task and the task options. 
Next, you will schedule the task to run daily at a 
specified time.

1 Click on the Edit Schedule… button.

➥ The Edit Task Schedule dialog box appears.

2 Make sure that the Active checkbox is selected.

3 Select Daily in the Schedule Details pop-up 
menu, and select Every 1 day for the frequency 
at which the task will run.

4 Specify the time at which the task will run by 
selecting the hour and minutes in the Time 
pop-up menus.

Specify the time to be two minutes from the 
current time. For example, if the current time is 
2:15 pm (14:15), select 14:17 in the Time pop-up 
menus.
IT Sentinel/Release 11.0
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5 Specify the Start Date to be the current date.

6 Select the End Date checkbox and specify the 
end date to be the current date. This will ensure 
that your tutorial automation task will run today 
only. If this checkbox is cleared, the task will run 
every day indefinitely. 

7 Click OK to close the Edit Task Schedule dialog 
box.

8 Click OK to close the Edit Task Details dialog 
box.

9 Click OK in the Configure/Run Automation 
Tasks dialog box.
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The configured automation tasks are now 
scheduled and the Configure/Run Automation 
Tasks dialog box closes.

The automation task is scheduled to run five 
minutes from now.

10 Select File > Exit, and choose not to save the 
project when prompted.

➥ In a few minutes, Sentinel will start running 
and execute your scheduled automation task.

11 Wait for the automation task to finish. 
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Viewing Reports in the Report Server

When the automation task executes at the specified 
time, the network device configurations are imported 
into a temporary project and the selected NetDoctor 
rules are applied. The results of the NetDoctor run are 
saved in a web report and published to the Report 
Server.

In this section, you will view the published NetDoctor 
report in the Report Server.

1 Wait a few minutes after the automation task has 
ended to ensure that the report has been 
published.

2 Start SP Sentinel.

3 Select Automation > Web – Open Report 
Server Home.

➥ A browser window appears with the 
Report Server home page.
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If no browser appears, check your preferences. 
Set the preference “browser_prog” so that it 
specifies the full path and file name of your web 
browser. This ensures that Sentinel will launch 
the appropriate web browser on your workstation.

4 Enter your Report Server username and 
password and click on Login.
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5 Click on the All Reports link that corresponds to 
your Sentinel product.

➥ The list of available published reports appears.

6 Find the NetDoctor report with a Date/Time that 
corresponds to your scheduled automation run 
and click on the report name.

➥ The NetDoctor report appears in a new 
browser window.

7 View the web report.

The Executive Summary report shows that there are 
several OSPF errors.
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Summary

With SP Sentinel, you can do network configuration 
import, validation, and reporting automatically.

In this tutorial, you learned how to

• Configure automation for Device Configuration 
Import

• Configure automation for NetDoctor

• Schedule and run automation tasks

• Set preferences for the Report Server and view 
reports from the Report Server

If you have any problems, use the Automation > 
Open Automation Log Manager menu to view the 
automation logs. The logs will tell you if there was a 
configuration problem.
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What’s Next?

Other tutorials are available on the following topics:

• Setting Up Sentinel Automation

• NetDoctor Notification in SP Sentinel

• Using Flow Analysis with Sentinel

• Comparing Networks with Sentinel

• Working with the Report Server
1.0 TUT-1-27
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2 Setting Up Sentinel Automation
Setting Up Sentinel Automation

Introduction

SP Sentinel provides the capability to perform tasks 
such as network configuration import, validation, and 
security analyses automatically. The tasks run 
unattended at scheduled times and the task results 
are available for viewing from the Report Server.

This tutorial shows how you can use SP Sentinel to do 
the following:

• Configure, modify, and automate Device 
Configuration Imports

• Configure, verify, refine, and automate NetDoctor 
analyses

• Create and schedule an automation task

• Execute and verify an automation task

Prerequisite Tutorials

To learn the topics presented in this tutorial effectively, 
complete the SP Sentinel Quick Start tutorial before 
you do this tutorial.
1.0 TUT-2-1
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Workflow

The following figure shows the workflow of this tutorial.

Workflow for Setting Up SP Sentinel Automation

No

Yes

Configure DCI

Import configuration files

Set up NetDoctor Reports

Set up error suppression

Configure and run a scheduled task

View the Automation Log

Start

End

Fix configuration data
with Model Assistant

All data present?
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Tutorial Objective

Middletown Bell provides local phone service and 
Internet access to one million homes and businesses. 
Your department is responsible for monitoring the 
state of the network and repairing any system 
outages. You would like to be more proactive in 
detecting and fixing potential problems before they 
cause problems for your customers. As part of this 
effort, you will use SP Sentinel to routinely import your 
network to test the configuration.

First, you will configure an automation task that you 
will run each night. Then, you will test that task to 
verify that it works as expected. To accomplish this 
you will

1) Create an automation file to import your device 
configuration files

2) Use the Import Assistant to solve problems 
related to the import

3) Configure NetDoctor to do configuration checks

4) Schedule an automation task to run the network 
configuration tests
1.0 TUT-2-3
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Configuring the Network Import

Each night, you want SP Sentinel to import your 
current network configuration for validation by 
NetDoctor.

To create an automation file that stores information 
about your network import, do the following:

1 Choose File > New…

2 Select Project from the pull-down menu and click 
OK.

3 Accept the default project name, then click OK.

4 Click Quit to exit the Startup Wizard.

5 Choose Topology > Import Topology > From 
Device Configurations…

➥ The Import Device Configurations dialog 
box appears.

You will be importing Cisco router configurations 
to produce an up-to-date topology. First, you will 
do this manually to validate the import.

5.1 Check the Cisco (IOS, CatOS, PIX) 
checkbox.
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5.2 Uncheck the Juniper (JunOS) checkbox, if 
checked.

5.3 Click the Browse button for Cisco (IOS, 
CatOS, PIX).

➥ A file browser dialog box appears.

5.4 For this lesson, there is a set of ready-made 
router configuration files. Choose the 
directory <reldir>\models\std\tutorial_req\ 
module\configs\with_areas_broken and 
click OK (Select on UNIX platforms).

➥ The file browser closes and the Cisco 
(IOS, CatOS, PIX) field of the Import 
Device Configurations dialog box shows 
the correct directory path.

5.5 Make sure that the Create fully meshed 
PVCs checkbox is selected.

5.6 If any files are listed under Specify Model 
Assistant Files, remove them by clicking on 
each file and selecting NONE.
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5.7 The completed dialog box should look 
similar to this:

5.8 Click Import.

➥ SP Sentinel finds the configuration files and 
imports them.

While importing the files, SP Sentinel checks 
your model directories for node models that 
match the devices you are importing. If 
IT Sentinel/Release 11.0
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SP Sentinel does not find a matching node 
model for a device, it creates one during 
import. 

➥ The Open Import Assistant dialog box 
appears. This happens when SP Sentinel 
cannot find some of the information it needs 
from the configuration files being imported.
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5.9 Click Open.

➥ The Import Assistant dialog box 
appears.
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Correcting the Configuration Import with the 
Import Assistant

The Import Assistant lets you specify information that 
is required to build a correct network. The information 
is saved in a model assistant file named 
<project-name>-<scenario-name>.ma and can be 
applied automatically when you import the router 
configuration again. You will follow this workflow when 
using the Import Assistant:

• Examine the dialog box to understand the 
information presented

• Correct problems with unnumbered interfaces

• Correct problems with data rates

• Verify that all routers are connected correctly

1 The Show drop-down list controls which routers 
appear in the pane below it.

1.1 Select the Devices with unspecified 
interface data rates option and notice that 
four routers (Atlanta-Core, DC-Core, 
Denver-Core, and SF-Core) are listed. This 
means that SP Sentinel did not find interface 
data rates in the router configuration import 
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file for at least one interface on these 
routers. You must supply the information for 
these four routers.
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1.2 Select the Routers with unnumbered 
interfaces option and notice that the 
Boston-Edge and NY-Edge routers are 
shown in red. You must supply information 
about those two routers.
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Correcting Problems with Unnumbered Interfaces

When SP Sentinel imports a router configuration file, it 
determines how a router is connected by analyzing 
the IP addresses of the router interfaces. If an 
interface does not have an IP address, SP Sentinel 
cannot determine where the interface should be 
connected and leaves it unconnected. As the system 
administrator, you know how interfaces are connected 
and can give this information to SP Sentinel.

Follow these steps to supply the needed information.

1 Verify that the Show drop-down list shows 
Routers with unnumbered interfaces.

2 Expand the Boston-Edge router.

➥ The router’s ports appear.

Notice the phrase <unconnected> in the 
Connected to column for the Serial0/1 port.

3 Expand the Serial0/1 port and click on 
(<IP unnumbered>).

➥ The NY-Edge router appears in the Select 
interface B to connect: pane.
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NY-Edge also has an unconnected interface, so 
SP Sentinel is suggesting that the two 
unconnected interfaces could be connected to 
each other.

This tutorial presents the simple case of two 
disconnected interfaces. In a production network, 
you might have multiple disconnected interfaces 
(all would be listed in the interface B pane), and 
you might have to examine the routers to 
determine the correct connections.

4 Select the IP address for NY-Edge (<IP 
unnumbered>).

4.1 In the interface B pane, expand NY-Edge.
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4.2 Select the IP address (<IP unnumbered>) 
for port Serial0/1 of NY-Edge.

5 Click the Connect button.

➥ Both routers with disconnected interfaces are 
now connected. The router icons change from 
red to light green.
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Correcting Problems with Unspecified Data Rates

When SP Sentinel imports a router configuration file, it 
determines the interface data rate by obtaining the 
rate from the file or by inferring the rate from the 
interface technology specified in the file. For example, 
an ATM interface is assumed to have an OC3 data 
rate.

When SP Sentinel infers the data rate this way, the 
routers that might need to be corrected are listed in 
the Import Assistant dialog box. This allows you to 
change the data rate if the inferred rate is incorrect.

In this tutorial, you will change the rate for one 
interface and confirm the inferred rate for the other 
three interfaces. You will then save the import 
assistant file with this information.

1 In the Show drop-down list, select Devices with 
unspecified interface data rates.

2 Expand all the routers.

➥ The router interfaces appear.

Notice that each interface has a data rate of 
SONET/OC3.
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3 Change the data rate to SONET/OC1 for the 
Atlanta-Core interface.

3.1 Expand the Atlanta-Core interface (ATM0/0) 
to see the IP address (192.68.0.113/29).

3.2 Select the interface. You can select either 
the name or the IP address.

3.3 In the Apply data rate to selected 
interfaces drop-down list, select 
SONET/OC1 and click Apply.

➥ The new rate is applied to the interface 
and the router icon becomes light green. 
The light green indicates that you 
modified the router configuration.

4 Confirm the SONET/OC3 data rate for the 
DC-Core interface.

4.1 In the Apply data rate to selected 
interfaces drop-down list, reset the data 
rate to SONET/OC3.

4.2 Select the DC-Core interface (ATM1/0).

4.3 Click Apply.

➥ The router icon becomes light green.
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5 Confirm the SONET/OC3 data rate for the 
Denver-Core and SF-Core interfaces.

6 Click on Apply Changes.

Verifying Other Configuration Details

Follow these steps.

1 Select All devices from the Show drop-down list 
and verify that all router icons are green.

➥ Some router icons appear light green if you 
modified their configurations.

2 Click Save changes...

3 Change the name of the file to 
<initials>_daily_model_assistant, then click 
OK.

4 Click OK in the Import Assistant dialog box.

➥ The Import Assistant dialog box closes.

Now the network topology is complete. SP Sentinel 
has chosen router and link models and configured 
model attributes according to the information in the 
router configuration files.
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Testing the New Import

You have already imported the topology and created a 
model assistant file that includes information needed 
to ensure a smooth import. In this section you see 
how to specify the model assistant (.ma) file you 
created.

1 Choose Topology > Import Topology > From 
Device Configurations...

➥ The Import Device Configurations dialog 
box appears.

2 Click on <click to add> in the Specify Model 
Assistant Files pane.

➥ A file list appears.

Notice that the model assistant file you just saved 
appears in the list. 

3 Select the file 
<initials>_daily_model_assistant.

4  Click Import.

Notice that SP Sentinel imports the topology 
without assistance from you.
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Saving the Import Settings for Automation

Now that you have tested your import settings 
manually, you can be confident that the import will 
work correctly when it is done as part of an 
automation task.

To save the settings for use in an automation task, do 
the following:

1 Choose Topology > Import Topology > From 
Device Configurations…

➥ The Import Device Configurations dialog 
box appears.

2 SP Sentinel saved the settings from the previous 
import. You want your automated task to use 
these settings regardless of any imports that 
have been done before. To do this, you must save 
your settings to an automation (.af) file, as 
follows:
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2.1 Click the automation save button. This is the 
button with a picture of a gear box.

2.2 At the prompt, name your automation file 
<initials>_daily_dci_import (use a name 
that describes the purpose of the file). 

2.3 Make sure your default models directory is 
selected in the left-hand Model directory 
panel, then click Save to save the file.

2.4 Click Cancel to close the Import Device 
Configurations dialog box.
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Configuring NetDoctor

Your automation task will have two parts: importing 
the topology and validating the topology by running a 
suite of NetDoctor rules. In previous steps, you 
configured the import part of your task. Now, you will 
configure NetDoctor to run the rules that interest you.

1 Choose NetDoctor > Configure/Run 
NetDoctor…

➥ The Configure/Run NetDoctor dialog box 
appears.

2 You want to begin with a blank template, so verify 
that the Template is set to Default NetDoctor 
Report.

3 In the network you are studying, you are 
interested primarily in verifying that the IP and 
OSPF settings are correct.

3.1 Scroll down to the IP Addressing rule suite. 
This is a collection of rules that test common 
errors related to IP address configurations.

3.2 Expand the IP Addressing rule suite, which 
contains several rules.
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After inspecting the rules, you decide to 
include all of them in your study. Click on 
IP Addressing to select the entire rule suite.

3.3 Make sure there is a green checkmark next 
to IP Addressing.

If there is a green dot or no mark at all, click 
on IP Addressing again to select it. The 
green checkmark means that all the rules in 
the suite are selected.
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3.4 Scroll down to the IP Routing rule suite.

3.5 Expand the IP Routing suite, then click on 
IP Routing to select all the rules in that rule 
suite.

3.6 Note that the last two options (Multiple Next 
Hops to Destination and Routing Loops 
in Network) require output from Flow 
Analysis. You will not be running Flow 
Analysis in this tutorial.

Click on Multiple Next Hops to Destination 
to turn off that rule.

➥ The green checkmark next to IP Routing 
changes to a green dot.

This shows that some, but not all the rules in 
the suite are selected.
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3.7 Click on Routing Loops in Network to turn 
off that rule.

3.8 Scroll down to the OSPF rule suite.

3.9 Click on OSPF to turn on all the rules in that 
suite.

➥ A green checkmark appears next to 
OSPF.
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4 The report title—as it will appear in your report 
and on the report server—is at the top of the 
dialog box.

To help you distinguish between reports, you 
should give your new NetDoctor report a 
meaningful title.

Replace the generic title with IP and OSPF 
Configuration.

5 Now that you have configured your report 
template, you need to save it.

5.1 Click Save As…

5.2 When prompted, enter <initials> Daily IP 
and OSPF Rules for the file name.

5.3 Verify that your default models directory is 
selected in the left pane, then click Save.

➥ The report template is saved.
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The dialog box should now look similar to 
the one below.

6 To test your NetDoctor template, click Run.

➥ SP Sentinel runs each of the rules you 
specified in your template.
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7 After the rules complete, the report appears in a 
web browser.

8 From the Executive Summary, you can see that 
NetDoctor found several errors and warnings. 
The legend on the left shows that the errors and 
warnings generated by multiple rules.
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Refining the NetDoctor Results

When you review your NetDoctor report, you may find 
errors or warnings that are not important to you.

For example, NetDoctor may warn you about a 
configuration error that is known to you, but that you 
do not plan to fix immediately. If you do not want this 
error to appear in each report, you can choose to turn 
off the rule that reports the error. However, this means 
that the rule will be skipped for all devices. If you want 
to turn off a rule for specific devices only, you can use 
a suppression file to list all the error messages you 
want omitted from your report.

In the left pane, you see that NetDoctor reported three 
invalid IP addresses. You suspect that these errors 
are not important to your network’s operation.

1 To view the specific error messages, click on IP 
Addressing: Invalid Interface IP Address.

➥ The specific rule report appears.

2 The three errors apply to Ethernet interfaces on 
three routers: DC-Edge, Denver-Edge, and 
Seattle-Edge. You know that these three routers 
are no longer connected to Ethernet links.
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Because these errors are not important, you want 
to suppress these errors in future NetDoctor 
reports.

2.1 Close the web browser.

2.2 In SP Sentinel, choose NetDoctor > 
Suppress Messages…

➥ The Edit Suppressions dialog box will 
appear.

2.3 Verify that <initials> Daily IP and OSPF 
Rules is the selected report.

This is the report template you want to use 
when selecting rules to suppress.

2.4 The errors you would like to suppress are 
generated by the Invalid IP Address rule. 
Expand Rule Suites > IP Addressing > 
Invalid Interface IP Address.

➥ There are three errors listed. These are 
the three that you want to suppress.
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2.5 Select all the errors under Invalid Interface 
Address.

➥ A red ‘X’ appears next to each error.

2.6 To save this information to a suppression 
file, click Save As…

2.7 When prompted, enter 
<initials>_ip_addressing for the file name 
and click Save.
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2.8 Click Cancel to close the dialog box.

3 Now that you have a suppression file, you must 
modify your template to use the file.

3.1 Choose NetDoctor > Configure/Run 
NetDoctor…

4 Verify that <initials> Daily IP and OSPF Rules 
is the selected template in the template field.

4.1 Click on the Settings tab.
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4.2 Click on the Suppression file pull-down 
menu and select <initials>_ip_addressing.

4.3 Click Save to save the changes to your 
template.

5 To verify that this template generates the report 
you want, click Run to test the changes.

6 When the report appears, note that the IP 
addressing errors no longer appear in the legend. 
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The Executive Summary now shows that three 
errors are suppressed; the other errors appear as 
before.

7 Close the web browser.

Now that you have configured and verified a 
NetDoctor analysis run, you want to save its settings 
to an “automation task step” file. This file enables you 
to use this analysis in an automated run.
1.0 TUT-2-33



 Sentinel Tutorials

TUT-2-34
1 Select NetDoctor > 
Configure/Run NetDoctor...

2 Make sure that <initials> Daily IP and OSPF 
Rules is the selected template in the top 
pull-down menu.

3 Click on the “Save current settings for 
automation” button.  

4 At the prompt, name your automation file 
<initials>_Daily_IP_and_OSPF_Rules.

5 Make sure that your default models directory is 
selected in the Model directories treeview, then 
click Save to save the file.

6 Click Cancel in the Configure/Run NetDoctor 
dialog box, since you will not be running 
NetDoctor at this time.

7 Choose File > Close to close the project; when 
asked if you want to save the project, choose No.
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Creating the Automated Task

In the previous steps, you created automation files 
that contain the configuration information for your 
topology import and NetDoctor rules. Now, you want 
to run configuration validation tests automatically 
every night.

To accomplish this, you must create an automation 
task. The Configure/Run Automation Tasks dialog 
box is used to manage tasks. Each task is a sequence 
of automation steps like “Import Topology from Device 
Configurations.” The tasks can be scheduled to run at 
any time during the day. You would like to create a 
task to import your topology and run NetDoctor.

1 In the project editor, choose Automation > 
Configure/Run Automation Tasks.

➥ The Configure/Run Automation Tasks 
dialog box appears, with the default task 
(Task1) selected.

2 Click Rename and rename your task Daily IP 
and OSPF Validation.

3 Click Edit.

➥ The Edit Task Details dialog box appears.
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4 Each task consists of a series of steps. Each step 
defines an operation that SP Sentinel should run. 
Your task will consist of two steps: importing your 
topology and running NetDoctor.

4.1 Click in the first row under Task Step Type 
and select Import Topology from Device 
Configurations as your first step type.

4.2 You must now specify an automation file that 
contains settings for importing from device 
configuration files. Click in the first row under 
Automation Settings File. 

➥ A list of all automation files that contain 
information about importing from device 
configuration files appears.

4.3 Choose <initials>_daily_dci_import.

This is the automation file you created at the 
beginning of this tutorial. SP Sentinel will 
use these settings when importing your 
topology.

4.4 To add a new step to run NetDoctor, click 
Add Step.

➥ A new row appears below the selected 
row.
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4.5 Click on *None* and select Generate 
NetDoctor Report.

4.6 Click in the second row under Automation 
Settings File column.

4.7 Choose 
<initials>_Daily_IP_and_OSPF_Rules. 
This is the automation file associated with 
the NetDoctor template you created earlier. 
Your dialog box should look similar to the 
one below.
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When SP Sentinel runs your task, it opens 
an existing project or creates a new one 
according to the settings you specified in 
Source Project/Scenario.

When importing a topology, you generally 
want to begin with a new project and 
scenario.

4.8 Click the None radio button to specify that 
SP Sentinel should start with a new project.

5 After SP Sentinel runs through the steps, you can 
choose to save the output. You will use this 
project for later tutorials, so you should save the 
new project.

5.1 Click the Specify radio button under Output 
Project/Scenario.

5.2 Replace –Enter Project Name– with 
<initials>_daily_config_validation to 
name the new project you save.

5.3 Replace –Enter Scenario Name– with 
ip_and_ospf_network to name the new 
scenario.
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5.4 If you want to see the history of your network 
or run Network Difference reports to 
understand how your network has changed, 
make sure to generate a unique scenario 
name. SP Sentinel will use the scenario 
name you provide and append the date and 
time of the automated task to the name.

Select the Generate unique scenario 
name checkbox.

6 SP Sentinel gives you the option to exit the 
application after the automation task finishes. 
When running an automated task in a production 
environment, you normally choose to exit after 
the task completes so that you do not take up 
system resources and licenses longer than 
necessary. However, when you are designing an 
automated task, it is helpful if SP Sentinel stays 
open after the task completes. This allows you to 
make any modifications to your task without 
having to restart the software.

Uncheck the Exit after task completion 
checkbox.
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7 Your dialog box should look similar to the one 
below.

8 When you deploy the automated task, you most 
likely want to schedule it to run on a regular 
basis. In this initial testing phase, you do not want 
to schedule a test run for some time in the future. 
Clicking the Run Now button closes SP Sentinel 
and runs the automated task immediately.

8.1 Click Run Now.
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8.2 When prompted, click OK to exit.

➥ SP Sentinel restarts in automated mode 
and begins your automated task. If 
prompted, choose not to save any 
existing projects.
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Verifying the Automation Task

After you create an automation task, make sure you 
test it at least once to verify that it works as expected. 
This includes watching the run to verify that all the 
task steps are executed and reviewing the automation 
log for any errors.

1 As SP Sentinel runs through the automation task, 
you should see a progress indicator dialog box. 
This dialog box lists all the steps that are 
executed as part of the task and indicate which 
step is in progress.

You should see the two steps you configured:

• Import Topology from Device 
Configurations

• Generate NetDoctor Report

You will also see SP Sentinel execute these 
steps.
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The project editor will appear as if someone is 
going through each of the automation task steps 
manually.

2 After the task finishes, SP Sentinel keeps the 
project editor open and reverts to manual-mode. 
You can now examine the network model and 
view the NetDoctor reports to verify they are what 
you expected.

3 If SP Sentinel encounters an error while 
executing an automation task, it writes the error 
to the task’s automation log. This log also 
contains helpful information such as when steps 
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began and whether their output was sent to the 
Report Server. If there is any problem with an 
automation task, the first place to look for 
information is in the log. The last step in 
validating your automation task is verifying that 
the automation log does not contain any 
unexpected messages.

3.1 Choose File > Automation > Open 
Automation Log Manager.

➥ The Automation Log Manager appears. 

The Automation Log Manager lets you 
view or delete any of the logs created while 
executing automation tasks.

3.2 Click on the column heading labeled Date 
until it has a down-facing arrow.

➥ This sorts the logs based on the date and 
time they were created.

The log from your most recent task should 
now be at the top.

3.3 Click on the first entry to select the most 
recent log.
IT Sentinel/Release 11.0



Sentinel Tutorials

IT Sentinel/Release 1
3.4 Click Open.

➥ The Log Browser appears.

The log lists any messages that were 
generated during your automation task.

3.5 To view a message, click in the Message 
column. You can then read the full text.

3.6 To view the log based on task step, expand 
the Automation Log entry in the treeview at 
the left.

3.7 Expand the Categories item.

➥ A list of all of the operations that created 
entries in the log appears.

3.8 Click on the NetDoctor item to show only 
the messages generated by NetDoctor.

Now that you have created and tested your 
automation task, you can schedule your task to run 
every night to test your network configuration. Before 
deploying automation, make sure you change your 
task to exit SP Sentinel after your task completes and 
set the task schedule.
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SP Sentinel will run your task unattended and output 
its results to the Report Server, from which the 
published reports can be retrieved and viewed.
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Summary

In this tutorial, you learned how to do the following:

• Configure, correct, and automate Device 
Configuration Imports

• Configure, verify, refine, and automate NetDoctor 
analyses

• Create and schedule an automation task

• Execute and verify an automation task by looking 
in the Automation Log
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What’s Next?

Other tutorials are available on the following topics:

• NetDoctor Notification in SP Sentinel

• Using Flow Analysis with Sentinel

• Comparing Networks with Sentinel

• Working with the Report Server
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3 NetDoctor Notification in IT Sentinel
NetDoctor Notification in 
SP Sentinel

Introduction

In the previous tutorial, you created an automation 
task that routinely imports your up-to-date network 
topology, then uses NetDoctor to detect configuration 
problems.

During deployment, you would like to be notified as 
soon as NetDoctor detects an error. The Notification 
feature of NetDoctor can be used to send you e-mail 
about potential network problems. E-mail notification 
messages can be sent to a standard e-mail account or 
to a pager.

In this lesson, you will learn how to configure 
NetDoctor Notification.
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Before You Begin

To do this tutorial, you need to know the following:

• General knowledge

— Your email account settings

— The name of your mail server

— The email address of your mail server

• OPNET-specific knowledge: You need to know 
how to configure NetDoctor automations (see the 
SP Sentinel Quick Start and Setting Up Sentinel 
Automation tutorials).

Prerequisite Tutorials

To learn the topics presented in this tutorial effectively, 
complete the following tutorials before you do this 
tutorial:

• SP Sentinel Quick Start

• Setting Up Sentinel Automation
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Workflow

The following figure shows the workflow for 
configuring NetDoctor to generate an email 
notification when NetDoctor detects errors or 
warnings.

Workflow for Using NetDoctor Notification

Start

Verify successful notification (email)

      Set up NetDoctor notification     

          Schedule and run task          

      View the NetDoctor report      

Done
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Configuring NetDoctor Notification

1 Start SP Sentinel if it is not running already.

2 Open the project that you created in the previous 
tutorial: <initials>_daily_config_validation.

3 Choose NetDoctor > 
Configure/Run NetDoctor...

➥ The Configure/Run NetDoctor dialog box 
appears.

4 Click on the Template pull-down menu and 
select <initials> Daily IP and OSPF Rules. This 
is the NetDoctor template you created in the 
previous lesson.

5 Click on the Notification tab.

The Notification tab contains controls for 
configuring how SP Sentinel should notify you of 
the configuration issues it detects.

6 Make sure the Enabled checkbox is selected. 
This activates the e-mail notification feature.

7 Before you can receive notifications, you must 
configure NetDoctor Notification according to 
your needs:
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7.1 Enter your mail server in the SMTP Server 
setting.

The SMTP Server setting directs 
SP Sentinel to the correct mail server to use 
when sending the e-mail notifications.

7.2 Put your e-mail address in the Send To field.

The Send To field is a comma-separated list 
of addresses that will receive the 
notifications. 

7.3 Put your e-mail address in the From field.

The From address is the sender of the 
notifications. It is generally a good idea to 
use the address of the person or group 
responsible for the automation task.

7.4 Leave the Reply-To field the same as the 
From field.

The Reply-To address directs responses to 
e-mail notifications to the designated e-mail 
address. This field should contain the e-mail 
address of the person who is responsible for 
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handling enquiries about the task. If it is the 
same as From, the Reply-To field is not 
added to the outgoing e-mail.

7.5 Enter [Daily NetDoctor Results] for the 
E-mail Subject Prefix.

All NetDoctor Notification messages have a 
subject line that contains the E-mail Subject 
Prefix and the name of the rule (or rule 
summary) that triggered the message. You 
should use an E-mail Subject Prefix that is 
specific to your report so that you can filter 
the different messages easily.

7.6 Enter [Daily NDR] for the Pager Prefix.

The Pager Prefix is similar to the E-mail 
Subject Prefix. If you opt to send your 
messages in the “pager” format, SP Sentinel 
uses the Pager Prefix to construct the 
subject of the message. The Pager Prefix is 
usually much shorter than the E-mail 
Subject Prefix to allow for the limited 
display size of most pagers.

7.7 Set the Threshold to Errors.
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The Threshold allows you to specify the 
types of messages NetDoctor should send 
notifications for. The Threshold setting can 
be changed to send messages for anything 
from just errors to all of the rules NetDoctor 
ran. Depending on your policies, you can 
modify the Threshold to meet your needs. 

7.8 Change the Notifications to Per Rule and 
Summary so that you receive all the 
possible messages.

The Notifications setting allows you to 
specify how many messages you want to 
receive. You can choose to receive a 
separate message for each rule that is 
triggered or one message that summarizes 
the results.

7.9 Leave Messages Included set to 
New Messages Only.

The Messages Included setting also lets 
you limit the number of messages you 
receive. If you enabled Report Comparison 
on the Settings tab, you can specify that you 
would like to receive New Messages Only. 
SP Sentinel will only send messages that do 
not appear in the report it is comparing 
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against. All Messages means that you want 
to receive all notifications regardless of 
whether they are unique to the current 
report.

7.10 Set Send Start/End to No.

NetDoctor can also send you separate 
messages immediately before the NetDoctor 
run begins and after the end of the 
NetDoctor run.

7.11 Set the Format to E-mail.

NetDoctor can send messages in either an 
E-mail or Pager format. The pager format is 
terser to allow for limited display size.

7.12 Set the Max. Message Count to 10.

The Max. Message Count allows you to 
limit the number of notifications you should 
receive for any single NetDoctor run.

7.13 Set the Max. Object Count preference to 5.

The Max. Object Count limits the length of 
the messages according to the number of 
devices that triggered the rule. If the rule is 
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triggered for more devices than the 
maximum, NetDoctor truncates the 
message.

7.14 Set the Max. Pager Length to 120.

NetDoctor allows you to specify the 
maximum message size to use when 
sending messages to pagers. 

7.15 Set the Pager Msg. Location to Subject.

Some pagers expect the message content to 
be in the subject of the e-mail message 
while others expect it in the body. You can 
specify where NetDoctor places the content 
of the message by changing the Pager Msg. 
Location preference.
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7.16 The following figure shows what the dialog 
box should look like now.

➥ Your dialog box will have your own mail server 
and address settings.

When you set up notification for the first 
time, it is a good idea to send a test 
notification. This does not test the NetDoctor 
rules themselves. Instead, it sends a test 
message to verify that your SMTP Server 
and Send To settings are correct.
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8 Click Send Test Notification.

➥ A test message with a list of notification 
preferences and their settings is sent.

Make sure you receive the test notification before 
you save your settings to a template.

• If a message window appears when you try to 
send the notification, check the information 
you typed into the SMTP Server and Send To 
fields.

• If you do not see a message window and do 
not receive the expected notification, check 
with your e-mail administrator.

9 After you configure notification, click Save to 
save the settings in your template, then Cancel 
to close the dialog box.
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Scheduling the Automation Task

Now that you have configured NetDoctor to send 
notifications, you can get messages about the state of 
your network when your automation task runs.

1 Choose File > Automation > Configure Run 
Automation Tasks.

2 Select the Daily IP and OSPF Validation task 
and click Edit.

3 In the Edit Task Details dialog box, click 
Edit Schedule…

➥ The Edit Task Schedule dialog box appears.

4 Verify that the Active checkbox is on.

5 Change the schedule to run Daily and occur 
every 1 day.

6 Change the Start Date to today’s date.

7 Make sure the End Date checkbox is selected 
and set it to today’s date.
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8 Change the Time to 2 minutes from now. Your 
dialog box should look like the one below.

9 Click OK.

10 Click OK to close the Edit Task Details dialog 
box.

11 Click OK to close the Automation Task 
Manager.

12 Choose File > Exit to quit SP Sentinel.

If prompted, choose not to save changes. In a few 
minutes, your automation task should run.
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Examining the Notification Messages

After the automation task completes, you will receive 
multiple messages. These messages will list the 
specific errors that NetDoctor found. To see the details 
of the errors, click on the Report Server link found in 
any of the messages and then open the report that 
corresponds to your task.
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Summary

Lessons learned

• You learned the basic workflow for configuring 
the NetDoctor notification process

• You learned how to configure NetDoctor to 
generate automatic email notifications

• You learned how to schedule the automation task
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What’s Next?

Other tutorials are available on the following topics:

• Using Flow Analysis with Sentinel

• Comparing Networks with Sentinel

• Working with the Report Server
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4 Using Flow Analysis with Sentinel
Using Flow Analysis with Sentinel

Introduction

In a previous tutorial, you created an automation task 
that routinely imports your up-to-date network 
topology and uses NetDoctor to detect any 
configuration problems.

Flow Analysis can also be used as part of an 
automation task—separately or with NetDoctor—to 
diagnose configuration problems like routing loops 
and multiple next hops to a destination. 

In this lesson, you will learn how to configure Flow 
Analysis automation and feed the results into 
NetDoctor.

Prerequisite Tutorials

To learn the topics presented in this tutorial effectively, 
complete the following tutorials before you do this 
tutorial:

• SP Sentinel Quick Start

• Setting Up Sentinel Automation

• NetDoctor Notification in SP Sentinel
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Workflow

The following figure shows the workflow for 
incorporating Flow Analysis information in an 
automated NetDoctor analysis.

Workflow for Automating Flow Analysis

Start

View the NetDoctor report

Done

  Configure NetDoctor for  
Flow Analysis output

  Configure Flow Analysis
for automation  

Configure and run 
the automation task
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Configuring Flow Analysis

The process used to configure Flow Analysis for 
automation is similar to the process used to configure 
Device Configuration import.

1 Open the project from the previous tutorial: 
<initials>_daily_config_validation

2 Choose Flow Analysis > Configure/Run Flow 
Analysis...

➥ The Configure/Run Flow Analysis dialog box 
appears.

3 Flow Analysis has many reports to choose from.

3.1 Click Select Reports…

➥ The Choose IP Flow Analysis Reports 
dialog box appears.

3.2 Clear the selection by clicking on IP Flow 
Analysis Reports in the tree view.

➥ The green dot indicating that reports are 
selected disappears.

3.3 In the Quick Select group at the right of the 
dialog box, make sure the following 
checkboxes are selected:
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• IP forwarding table report

• Routing table reports

3.4 Click OK to save your changes.
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3.5 In the Configure/Run IP Flow Analysis 
dialog box, you will see that seven reports 
are selected. These reports contain the 
routing table information NetDoctor will use 
to diagnose configuration problems.
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4 After Flow Analysis is configured, you must save 
the settings to an automation file as follows:

4.1 Click the save automation settings button 
 to save your Flow Analysis settings for 

automation.

4.2 Enter the following file name: 
<initials>_flan_routing_table_reports
then click Save.

4.3 Click Cancel to close the Configure/Run IP 
Flow Analysis dialog box.
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Configuring NetDoctor

Now that you have saved an automation file for 
running Flow Analysis, you need to revisit your 
NetDoctor template. In a previous lesson, you omitted 
certain rules that rely on simulation input. Now that 
you will be running Flow Analysis, you can take 
advantage of these rules.

1 Choose NetDoctor > Configure/Run 
NetDoctor...

2 Click on the Template pull-down menu and 
select the <initials> Daily IP and OSPF Rules 
template you created in a previous tutorial.

3 Expand the IP Routing rule suite.

4 The Multiple Next Hops to Destination and 
Routing Loops in Network rules detect 
configuration problems that are not apparent 
from the device configuration data but that cause 
network performance degradation. These rules 
rely on simulation output. Flow Analysis will 
provide these results.

4.1 Click on Multiple Next Hops to Destination 
to select it with a green checkmark.
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4.2 Click on Routing Loops in Network to 
select it with a green checkmark.

➥ The green dot next to IP Routing 
changes to a green checkmark to indicate 
that all the rules in the suite are selected.

4.3 Click Save to save the changes to your 
template.
IT Sentinel/Release 11.0



Sentinel Tutorials

IT Sentinel/Release 1
4.4 Click Cancel to close the dialog box.
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Configuring the Automation Task

Now that your settings have been saved, you need to 
add Flow Analysis to your automation task.

1 Choose File > Automation > Configure/Run 
Automation Tasks.

2 Click on the <initials> Daily IP and OSPF 
Validation task that you created in a previous 
tutorial.

3 Click Edit to edit the task.

4 You need to add a Flow Analysis step to your 
task. Because NetDoctor relies on the output of 
Flow Analysis, make sure that the Flow Analysis 
step is before NetDoctor.

4.1 Click Add Step to add a new row.

4.2 Click *None* and select Run Flow Analysis 
in the new row.

4.3 Click on the Automation Settings File 
column for the Run Flow Analysis row. 
Select the file that you created earlier:

<initials>_flan_routing_table_reports
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4.4 Click Move Up/Move Down if necessary to 
move the Run Flow Analysis entry before 
NetDoctor, but after the topology import.

This ensures that Flow Analysis and 
NetDoctor are run in the correct sequence 
so that the output of Flow Analysis is 
available to NetDoctor for its run.

5 Unless you want to keep an historical record of 
the network state and its analysis, you do not 
need to keep the project you used during the 
automation run. To prevent the project from being 
saved to disk, select the Do not save changes 
radio button.

6 You can now execute a test of your new 
automation task.

6.1 Make sure that Exit after task completion 
is selected. You will not need SP Sentinel to 
run after the automation task finishes.

6.2 Make sure Hide all windows during 
automation is not selected. This allows you 
to see the progress of your task as it runs.
1.0 TUT-4-11



 Sentinel Tutorials

TUT-4-12
Your dialog box should look like this.

7 Click Run Now.

8 When prompted, click OK to begin the 
automation task and exit SP Sentinel.

If prompted to save the current scenario, choose 
NOT to save it.

➥ SP Sentinel runs the automation task, then 
exits when the task finishes.
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You can now view the reports that were created 
during the automation run.

Normally, the automation task is scheduled to run 
unattended—usually at night. Therefore, the next steps 
in the tutorial would be done the next morning, long 
after SP Sentinel has finished its work.
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Viewing Reports

By default, all reports generated during an automation 
task are sent to the Report Server.

The Report Server is a central repository that allows 
you to view the output of your analyses without having 
to run SP Sentinel. You must have an account—set up 
by your Report Server administrator—before you can 
access reports on the Report Server.

1 Start SP Sentinel.

2 Choose Automation > 
Web – Open Report Server Home.

➥ The main page of the Report Server appears 
in a browser window.

3 Enter your username and password, then click 
Login.

➥ The Report Server home page appears.

4 To view all the reports generated by SP Sentinel, 
click on SP Sentinel/All Reports.

You can now view your Flow Analysis and 
NetDoctor reports. The most recent reports are 
at the top of the list.
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4.1 Click on the link IP and OSPF 
Configuration.

➥ The NetDoctor report appears.

The IP Routing notes show that NetDoctor 
found some cases of routing tables that 
contain multiple next hops to a destination. 
This analysis relies on output from Flow 
Analysis.

4.2 Close the NetDoctor report.

4.3 To view the Flow Analysis report, click on the 
report from the Flow Analysis Report Set in 
your reports listing on the Report Server.

➥ The Flow Analysis report appears.
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Summary

In this tutorial you learned how to use Flow Analysis to 
augment the data NetDoctor draws from when 
running its rules.

In the next tutorial, you will learn how to generate 
Network Difference reports automatically to track 
changes in your network.
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What’s Next?

Other tutorials are available on the following topics:

• Comparing Networks with Sentinel

• Working with the Report Server
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5 Comparing Networks with Sentinel
Comparing Networks with Sentinel

Introduction

A key component to diagnosing problems in your 
network is understanding how that network has 
changed over time. SP Sentinel Network Difference 
reports show the differences between two topologies 
of the same network.

In this tutorial, you will learn how to use automation to 
use SP Sentinel to generate Network Difference 
reports and find changes in your network. After you 
finish this tutorial, you will know how to generate 
network difference reports as part of an automation 
task.

Prerequisite Tutorials

To learn the topics presented in this tutorial effectively, 
complete the following tutorials before you do this 
tutorial:

• SP Sentinel Quick Start

• Setting Up Sentinel Automation

• NetDoctor Notification in SP Sentinel

• Using Flow Analysis with Sentinel
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Workflow

The following figure shows the workflow for creating 
automated network difference reports from 
successive network imports.

Workflow for Automating Network Difference Reports

End

View the Difference Report

Run the task

Configure a  task

Configure Network Diff

Configure DCI

Start
IT Sentinel/Release 11.0



Sentinel Tutorials

IT Sentinel/Release 1
Importing a New Topology

In previous tutorials, you imported a set of 
configuration files for a network with mismatched 
OSPF areas. In this tutorial, you will create an 
automation file to import a set of configuration files in 
which the OSPF problems have been corrected.

1 Open the project 
<initials>_daily_config_validation.

2 Choose Topology > Import Topology > 
From Device Configurations…

➥ In the Import Device Configurations dialog 
box, make sure that only the Cisco (IOS, 
CatOS, PIX) checkbox is selected.

3 Click the Browse button for Cisco (IOS, CatOS, 
PIX).

➥ A file browser dialog box appears.

For this tutorial, a set of ready-made router 
configuration files is supplied.
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4 Choose the directory 
<reldir>\models\std\tutorial_req\module\ 
configs\baseline and click OK (Select on UNIX 
platforms).

➥ The file browser closes and the Cisco (IOS, 
CatOS, PIX) field of the Import Device 
Configurations dialog box shows the correct 
directory path.

5 Make sure that the Create fully meshed PVCs 
checkbox is selected.

6 Under Specify Model Assistant Files, make 
sure that <initials>_daily_model_assistant is 
listed.

7 Click on the “save settings for automation” button 
 and do the following:

7.1 Enter <initials>_repaired_dci_import for 
the file name.

7.2 Click Save.

8 Click Cancel to close the Import Device 
Configurations dialog box.
IT Sentinel/Release 11.0



Sentinel Tutorials

IT Sentinel/Release 1
Configuring the Network Difference Report

Network Difference reports are the result of 
comparing two scenarios. In automation, the first 
scenario is always the active scenario used in the 
automation task. The second scenario is specified in 
the network difference automation file. You will now 
create an automation file to compare against a 
scenario created in a previous tutorial.

1 Select Scenarios > Network Difference Report 
> Generate Report…

2 Specify the project and scenario to compare 
against. 

You can choose a scenario by name or specify a 
base name and time parameter. If you choose to 
specify a base name and time, SP Sentinel uses 
the timestamp in the scenario name to find the 
scenario.

2.1 Set the project to 
<initials>_daily_config_validation.

2.2 Select Specified project, and the scenario 
with given base name that was created
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You can choose to specify a time range. For 
example, if you want to compare against a 
scenario you created last week, compare it 
against the scenario created seven days 
ago. You can also choose to compare 
against the most recent scenario. For this 
exercise, use the latter option.

2.3 Click on the Most recently radio button.

3 Make sure Send reports to the Report Server 
is enabled.

This stores your reports on your OPNET Report 
Server.

4 In the report name field, enter 
<project> Differences. 

Give your report a name that describes what it 
contains. The report name field allows for any 
text and accepts two variables: <project> and 
<scenario>. In the report name, the string 
<project> will be replaced with the name of the 
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automation project. The variable <scenario> will 
be replaced with the name of the automation 
scenario.

5 Save the current settings to an automation file.

5.1 Click on the “save settings for automation” 
button. 

5.2 Enter <initials>_most_recent_differences 
for the automation file name.

5.3 Click Save.

6 Click Cancel to close the Generate Network 
Difference dialog box.
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Configuring the Automation Task

After you save your automation files, you can create 
an automation task to import your new configuration 
files and generate a network difference report to show 
the changes. This report will be sent to the Report 
Server for viewing later.

1 Select File > Automation > Configure/Run 
Automation Tasks.

2 Click New to create a new task.

3 Click Rename and enter Daily Network 
Differences for the task name.

4 Click Edit to edit the new task.

5 Click on *None* and select Import Topology 
from Device Configurations.

6 Click in the cell under Automation Settings File 
and select <initials>_repaired_dci_import.

7 Click in the cell below Import Topology from 
Device Configurations and select Generate 
Network Difference Report.
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8 Click in the cell to the right of Generate Network 
Difference Report and select 
<intials>_most_recent_differences.

9 Click the None radio button next to 
Source/Project scenario.

Because you are importing a new topology, there 
is no reason to use an existing scenario when 
starting SP Sentinel.

10 You want to store your new scenario in the same 
project as the previous tutorials.

10.1 Under Output Project/Scenario, click on 
the Specify radio button.

10.2 Enter <initials>_daily_config_validation in 
the project field.

10.3 Enter ip_and_ospf_network in the scenario 
field.

If you choose to generate a unique scenario 
name, SP Sentinel appends a timestamp to 
the name you specified in the scenario field. 
SP Sentinel uses this timestamp to locate 
the correct scenario to generate a Network 
Difference report. You may want to use this 
topology again for other difference reports.
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10.4 Make sure Generate Unique Scenario 
Name is selected.

11 Make sure Hide OPNET windows during 
automation is not checked so you can see your 
automation as it runs.

12 Click Run Now to run the automation task now.
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Viewing the Report

Now that you have generated a network difference 
report, you can access the Report Server to view it.

1 Restart SP Sentinel.

2 Choose Automation > Web – OPNET Report 
Server Home.

➥ A web browser appears with the home page of 
your Report Server.

3 Enter your username and password.

4 Click Login.

5 Click on the All Reports link next to SP Sentinel.

➥ A list of all the reports you have published 
using SP Sentinel appears.

6 The top entry should be for 
<initials>_daily_config_validation 
Differences. 

This is the report you just created.
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7 Click on the link to view the report.

➥ The report appears and indicates that 
there are several differences between the 
new network and the previous network.

8 Click on Objects with differences to jump to 
that section of the report.

➥ The results indicate that changes to the OSPF 
Parameters.Interface Information.Area ID 
attribute were found.
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Summary

• In this tutorial, you learned how to generate 
network difference reports as part of an 
automated task. This enables you to see how 
your network has changed over time.
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What’s Next?

Other tutorials are available on the following topics:

• Working with the Report Server
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6 Working with the Report Server
Working with the Report Server

Introduction

With SP Sentinel, you can search for reports 
published to the Report Server using several different 
search methods. If you are not using SP Sentinel, but 
another OPNET product, see Using the Report Server 
With Other OPNET Products.

This tutorial shows how you can:

• View reports by application

• View reports by date and time

• Use the advanced search page

Prerequisite Tutorials

To learn the topics presented in this tutorial effectively, 
complete the following tutorials before you do this 
tutorial:

• SP Sentinel Quick Start

• Setting Up Sentinel Automation

• NetDoctor Notification in SP Sentinel

• Comparing Networks with Sentinel
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Workflow

The following figure shows the workflow for a report 
search using three different methods.

Report Server Workflow

Navigation bar search:
Report Server search

page appears

      Specify search      
parameters

   Start   

Open web browser and navigate
to the Report Server home page

   Log in - enter username and   
password

Application Advanced
Search: Advanced

Search Wizard page
appears

Specify advanced
  search parameters  

Application All Reports
search:

List of All Reports
page appears

Save search
parameters for future

use (optional)

        Select report from list        

  Report Server generates web  
page with specified report

               View results               

   Done   

Select
  method of viewing  

available reports
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Viewing Reports By Application

In previous tutorials, you used automated tasks to 
generate reports. These reports were sent to the 
OPNET Report Server for view later. This tutorial 
walks you through some commonly used Report 
Server features. A variety of applications might send 
reports to your Report Server. For example, IT Guru, 
SP Guru, and IT Sentinel might all publish 
reports.

To view reports organized according to the OPNET 
application, follow these steps.

1 Run a web browser such as Mozilla, Opera, or 
Internet Explorer.

2 Enter the following URL: 

http://<report server>:<port>/rs 

where <report server> is the machine hostname 
running your Report Server and <port> is the port 
on which the Report Server is running. The 
default port is 9090.

➥ A web browser appears with the login page of 
your Report Server.
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Report Server Login Page

3 Enter your username and password.

4 Click Login.

➥ The Report Server home page appears.

Report Server Home Page
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5 Click on the All Reports link next to the label 
SP Sentinel.

➥ This takes you to a list of all reports you 
published using SP Sentinel.

SP Sentinel Reports on the All Reports Page

• The Date/Time column lists when the reports 
were published.

• The Report Set Title column contains the 
type of reports. For example, Flow Analysis 
reports are listed as “Flow Analysis.”

• The Report column shows the names of the 
reports.
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6 Click on the <initials>_daily_config_validation 
Differences link.

➥ This launches a report browser window that 
shows the Network Difference report you 
created in the previous tutorial.

7 Click on <initials>_daily_config_validation 
Flow Analysis. 

➥ The flow analysis report now appears in the 
browser window.
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Viewing Reports by Date and Time

You might want to view a report based on when the 
report was generated.

To view reports based on date and time, follow these 
steps.

1 Click on Search in the navigation bar. 

➥ The Report Server search page appears.
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2 Under Application(s), put a check in the 
SP Sentinel checkbox to search the reports 
generated by SP Sentinel.

3 In the Date-time range fields, specify the time 
range for which you would like to see reports.

3.1 In the from: date, enter the beginning date 
of the search.

If the reports were sent to the Report Server 
on a date before today’s date, note the 
earlier date with a time of 00:00.

3.2 In the from: time, enter 00:00.

3.3 In the to: date, enter today’s date.

3.4 In the to: time, enter the current time.

4 Scroll to the bottom of the screen.

5 In the Save search as text box, enter “One Day 
Search.”

➥ The parameters of this search will be saved so 
that you can perform the same search later 
with a single click.
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6 Click Search. 

➥ A list of all of the reports created today 
appears.

7 Click on the Saved Search link at the top of the 
page.

➥ This takes you to a list of all your saved 
searches.

8 Click on the One Day Search link.

➥ The same list of reports you saw in the 
previous step appears.
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Using the Advanced Search Page

The advanced search page lets you refine your search 
criteria based on publication time, report set, and 
report title. For example, you might want to list only 
the Network Difference reports generated today.

To perform an advanced search, follow these steps.

1 Click on the Home link at the top of the page.

2 Click on Advanced Search link next to 
SP Sentinel.

➥ The advanced search page appears.
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Report Server Advanced Search Wizard

3 Scroll to the Network Difference section.

4 Put a check in the include all reports checkbox 
to include Network Difference reports in your 
search.
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5 In the Date-time range fields, specify the time 
range for which you would like to see reports.

5.1 In the from: date, enter the beginning date 
of the search.

If the reports were sent to the Report Server 
on a date before today’s date, note the 
earlier date with a time of 00:00.

5.2 In the from: time, enter 00:00.

5.3 In the to: date, enter today’s date.

5.4 In the to: time, enter the current time.

➥ In the Available Reports section, you 
see a list of the names of Network 
Difference reports stored on the Report 
Server. For this example, include reports 
only named 
<initials>_daily_config_validation 
Differences.

5.5 Put a check next to 
<initials>_daily_config_validation 
Differences.
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6 Scroll down the page. 

➥ Note there are sections for each type of report 
on the Report Server.

7 Click Search. 

➥ The results of your search appear. 
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Using the Report Server With Other OPNET 
Products

If you are using an OPNET product other than 
SP Sentinel and you want to use the Report Server, 
send a report to the Report Server using a feature that 
is available to all OPNET clients. For example, if you 
are using something other than SP Sentinel, send a 
Network Difference report to the Report Server, and 
then try to view that report.
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Summary

In this tutorial, you learned how to do the following.

• Log on to the Report Server

• View reports by application

• View reports by time and date

• Use the advanced search page
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What’s Next?

Other tutorials are available on the following topics:

• SP Sentinel Quick Start

• Setting Up Sentinel Automation

• NetDoctor Notification in SP Sentinel

• Comparing Networks with Sentinel
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App A Troubleshooting Sentinel Tutorials
Troubleshooting Sentinel Tutorials

Introduction

This document contains information that can help you 
correct common problems.

• The OPNET Installation Directory

• The tutorial_req Files

• Saving Tutorial Files

• Additional Help
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The OPNET Installation Directory

To complete the tutorials, you must install the Sentinel 
standard models, which include the required tutorial 
models. The standard models are normally installed 
when you install the Standard Model Library.

Sentinel standard models apply to common protocols 
and vendor devices. The standard models are in the 
subdirectories under the OPNET release directory 
(<reldir>):

<reldir>\models\std\<protocol_name>

<reldir> describes the directory that contains the 
current Sentinel software.
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You can find your <reldir> by doing the following:

1 In the main menu, select Help > About This 
Application.

2 In the About SP Sentinel dialog box, click on the 
Environment tab, then expand the System 
Information section.

3 Under System Information, find the 
OPNET release directory.

For example, the <reldir> for a default installation of 
this release of Sentinel on Windows is

C:\Program Files\OPNET\10.5.A

The tutorials use the Windows convention of the 
backslash character (\) as the separator in directory 
pathnames.
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The tutorial_req Files

When you do a tutorial, you are asked to open specific 
tutorial model files. These model files are required to 
do the tutorial; they are located in the 
<reldir>\models\std\tutorial_req directory or its 
subdirectories.

When you are asked to open supplied model files, 
make sure you navigate the directory structure in 
OPNET's open file browser (in the left pane) to the 
tutorial_req directory.

Navigating to the tutorial_req Directory
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Saving Tutorial Files

In several tutorials, you will be asked to open an 
OPNET model file and save it with a unique prefix, 
such as your initials (<your_initials>). This way, 
several users can create and complete their own copy 
of the same tutorial without interfering with each 
others' work.

When you save a new model file, or use the 
Save As... command to save an edited model file with 
your initials, remember to navigate to your OPNET 
default model directory (normally 
<home>\op_models) to save your files.

Navigating to the op_models Directory

If you do not navigate to your default model directory 
(normally <home>\op_models) when you do a 
Save As... operation, the file is automatically saved in 
the current model directory.
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Additional Help

If an analysis does not complete, the problem might 
be with the installation.

1 Read the installation instructions on the CD case.

2 Check the website for recent updates to the 
tutorials, models, and product installation 
instructions (www.opnet.com/support).

3 Check the FAQ section of the OPNET website 
(www.opnet.com/support).
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