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C H A P T E R 2

Monitoring Voice Network Health 

These topics describe how to use the fault event browsers within the VHM folder 
to monitor the health of your voice network:

• Using the Real-Time Dashboard, page 2-1

• Using the Monitoring Console, page 2-14

Using the Real-Time Dashboard
The Real-Time Dashboard provides an overall picture of voice network health. 
The Summary View displays managed voice device groups and the number of 
devices in the groups with faults in each fault category. Starting from the 
Summary View, you can open more detailed views:

• Status View—Displays the status of managed devices in the selected voice 
device group. From this view you can open a more detailed view of a 
particular device, called the Device Detail View.

• Device Detail View—Displays relevant details for a particular managed 
device. 

Note Unmanaged devices do not appear in the Real-Time Dashboard.

Both the Summary View and the Status View use System Status indicators to 
display VHM system health. The status indicator is green if all the processes in 
the VHM system are communicating with each other correctly. The status 
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indicator is red if one or more processes in the VHM system lose contact with the 
ESS Bus (CMF Event bus) or the VHM server. When you move the mouse over 
the System Status indicator, system status information is displayed as a tooltip.

The DFM System Status Indicator shows the DFM server's connectivity with 
VHM backend processes.

While you are browsing the status of voice devices on the Real-Time Dashboard, 
you can quickly open an Administration Console (if you have administrative 
privileges), a Monitoring Console, or other Cisco applications, to provide:

• More data, such as alarms that have been logged—for example, you can view 
alarms on the Monitoring Console.

• The ability to take an action based on what you have already seen—for 
example, you can send email about an alarm from the Monitoring Console.

See the “Starting Additional Consoles and Views from the Summary View” 
section on page 2-8 and the “Starting Additional Consoles and Views from the 
Status View” section on page 2-12 for more information. 

Managing Data in the Real-Time Dashboard
To help you organize and search the information in the views that the Real-Time 
Dashboard offers, you can sort the information in any order. You can also use the 
Find capability to look for a particular device group or device. 

For more information, see the following topics:

• Real-Time Dashboard Buttons, page 2-3

• Sorting the Data in a View, page 2-4

• Searching for a Device or a Device Group, page 2-4
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Real-Time Dashboard Buttons

In the VHM Real-Time Dashboard, certain file menu commands can be performed 
through a toolbar button. They are summarized in the Real-Time Dashboard 
Toolbar Buttons table.

Table 2-1 Real-Time Dashboard Toolbar Buttons

Button Description

Search for a device or device group

Print summary information

Display legend

Display Monitoring Console

Display Status View

Display Device Detail View

Display CiscoView

Expand/Collapse ICS 7750
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Sorting the Data in a View

The Real-Time Dashboard views present information in a tabular format. You can 
sort the information by any column or by the contents of the entire table, in 
ascending or descending order. In the Status View, you can also sort by severity 
level or device type.

To sort the data in the Summary View or Status View in the Real-Time Dashboard:

• To sort by column, select any column header. You can toggle the sort order 
between ascending and descending by selecting the column header again.

• To sort the entire table, select View > Sort Table and select either the 
Ascending or Descending radio button. 

• To sort by device type or severity level, in the Status View, select View > Sort 
Table. Select either the Ascending or Descending radio button and select 
either the Device Type or Severity Level radio button.

Searching for a Device or a Device Group

The Real-Time Dashboard–Summary View displays a table of voice device 
groups, while the Status View displays a table of devices within a selected voice 
device group. You can search either table for specific entries. 

To find a particular device or device group:

Step 1 To search for a specific group from a list of voice device groups, or for a device 
from a list of devices, select Edit > Find or click the search button.

Step 2 Enter the device name or device group name in the search field. (Substring 
matching is also available.)
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Sharing Data from the Real-Time Dashboard
A user in a Network Admin or Network Operator role can export data from 
Real-Time Dashboard views. Users in any role can print information from the 
views. 

To export data:

Step 1 Select File > Export. 

Step 2 In the Export dialog box, select the location where you want to save the file. Doing 
so creates a file with data from the view that is currently displayed.

To print data:

Step 1 Select File > Print or click the Print Summary Info button. 

Accessing Help
Selecting the Help button provides the following options in addition to online 
help:

• Using Voice Health Monitor—Displays the Voice Health Monitor User 
Guide.

• Legend—Explains the color schemes and device icons. You can also click the 
Display Legend button on the toolbar to access this information. 

• About—Displays product information such as version, copyright, and date.
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Using the Summary View 
The Real-Time Dashboard–Summary View presents the overall status of the voice 
network. It is updated in real time; if a device status is changed (from managed to 
unmanaged or vice versa) the Real-Time Dashboard–Summary View will update 
automatically.

Table 2-2 lists all the elements available within the Real-Time 
Dashboard–Summary View window.

For more information about the Summary View, please see the following topics:

• Grouping Devices: Voice Device Groups, page 2-7

• Starting Additional Consoles and Views from the Summary View, page 2-8

Table 2-2 Real-Time Dashboard—Summary View Elements

Element Description

Voice Device Group See Table 2-3 on page 2-7.

Number of Devices The number of devices in the voice 
device group.

Critical The number of devices that have 
Critical as their highest fault level.

Warning The number of devices that have 
Warning as their highest fault level.

If a device displays both Warning and 
Critical faults, the device will display a 
fault level of Critical.

Indeterminate The number of devices that have a fault 
level of Indeterminate.
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Grouping Devices: Voice Device Groups

Table 2-3 lists the voice device groups used throughout VHM.

Table 2-3 Voice Device Groups

Group Description

VC (voice clusters) Consists of all the members of a 
CallManager voice cluster and the 
voice gateways that are registered with 
any of the CallManagers. In the 
Summary View each cluster is 
summarized into one row.

VoiceServices Voice-enabled PCs running workflow 
applications. There is only one 
workflow application entry.

InlinePowerSwitches Catalyst switches that supply power to 
phones connected on Ethernet. There is 
only one Inline Power Switch entry. In 
the Summary View, all 
InlinePowerSwitches are summarized 
in one row.
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Starting Additional Consoles and Views from the Summary View

Select any of the following options from the Tools menu, or right-click any row 
in the Summary View and select among these options: 

• Administration Console—Change administrative options. You must be 
logged on to CiscoWorks2000 in a Network Admin or Network Operator role 
to open this console.

• Monitoring Console—View and take action on alarms: send a page or mail, 
or start a script. You can also open a Monitoring Console by clicking the 
Display Monitoring Console button. 

VoiceGateways In the Summary View, all 
VoiceGateways are summarized in one 
row. These include:

• Catalyst switches with:

– Voice T1/E1

– Transcoder

– Conference bridge

– Media termination points 
(MTPs)

– Voice FXS

• IOS routers with:

– FXS

– FXO

– T1 PRI/E1 PRI

Table 2-3 Voice Device Groups (continued)

Group Description
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• Real-Time Dashboard–Status View—Open a Status View for a voice device 
group listing each device in the group and its status. You can also open a 
status view by clicking the Display Status View button. 

Note Opening a Monitoring Console from the Real-Time Dashboard displays one 
alarm log that includes both VHM and DFM alarms. To display two alarm logs 
(one for VHM and another for VHM and DFM combined), start the 
Monitoring Console from the CiscoWorks2000 desktop. 

Using the Status View
From the Summary View, you can get more information about a particular voice 
device group by starting a Status View. The Status View lists details for all devices 
in a selected voice device group. It is updated in real time; if a device status is 
changed (from managed to unmanaged or vice versa) the Status View will update 
automatically.

To view the status of a voice device group:

Step 1 Perform one of the following steps from the Real-Time Dashboard–Summary 
View window:

• Double-click any row that includes the voice device group of interest to you. 

• Right-click any row that includes the voice device group of interest to you and 
select Status View from the newly displayed menu.

• Select a voice device group and click the Display Status View button.

The Real-Time Dashboard–Status View is displayed. You can start additional 
status view windows for other voice device groups in the same way.

Step 2 From a Status View window, view another voice device group by selecting one 
from the drop-down list box.
2-9
Voice Health Monitor User Guide

78-11324-01



Chapter 2      Monitoring Voice Network Health
Using the Real-Time Dashboard
Examining Fault Categories 

The Real-Time Dashboard–Status View window groups faults into six categories. 
Table 2-4 lists each fault category and describes what a fault in each category 
means. 

.
Table 2-4 Fault Categories

Fault Category Description

Reachability Reflects whether or not DFM can reach the device. If DFM can reach 
the device, it checks the status of the SNMP agent on the device. If 
DFM can reach the agent, then the device is considered reachable. 
Reachability includes both IP and SNMP connectivity.

Note When DFM and VHM run on separate machines, VHM 
may display a device that DFM cannot reach even when 
VHM can reach the device.

Environment Reflects device parameters. The following environment parameters 
are monitored:

• Power Supply

• Fan Status

• Chassis Operating Temperature

• Battery State

• Temperature Sensor Status

Note Depending on the system class that the device belongs to, 
these parameters may vary.

System Reflects those attributes of a device that impact the normal 
functioning of software on the device. The following system 
parameters are monitored:

• CPU Usage

• Memory Free (physical and virtual)

• Disk Utilization

Interfaces Reflects the status and connectivity of the interface cards (NIC cards, 
voice cards) on the device. Interfaces are monitored to determine 
whether the interface types are functional or nonfunctional.
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Determining the Severity Level of a Fault 

When a fault is detected in any category for a device, the cell for that device and 
that fault category changes color to reflect the severity level of the fault in that 
particular fault category. Table 2-5 lists the colors for each severity level.

Applications—Specific to 
Media Servers, ICS 7750, 
Primary SBC hosts, and 
Application SBC hosts only

Reflects the conditions of the applications on the Media Servers. The 
following applications are monitored:

• CallManager

• Synthetic transactions

• Workflow Application

• TFTP Server

• Database Server

Gateway—Applies only to 
Media Servers that have 
CallManager running on them

Reflects whether gateways are registered with the CallManager. 

Table 2-4 Fault Categories (continued)

Fault Category Description

Table 2-5 Color Code for Fault Severity Levels

Severity Level Color Code

Critical Red

Warning Orange

Normal Green

Indeterminate Grey

Not Applicable White
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Starting Additional Consoles and Views from the Status View

You can open the Administration Console, the Monitoring Console, and Inventory 
Collection Scheduling from either the Summary View or the Status View using the 
same methods described in the “Starting Additional Consoles and Views from the 
Summary View” section on page 2-8.

The Status View additionally provides a starting point for applications that can 
provide more details for a specific device:

• Real-Time Dashboard–Device Detail View—Opens a detailed view of the 
device. See the “Using the Device Detail View” section on page 2-13 for 
more information.

• Display CiscoView—Starts the CiscoView application for the selected 
device. 

• Expand/Collapse ICS 7750—Applies only to the ICS 7750 device. If an ICS 
7750 device is not detected, this button is dimmed. You can also expand or 
collapse an ICS 7750 by right-clicking a device and selecting either Expand 
(which displays the ICS 7750 device) or Collapse (which displays the ICS 
7750 logical device only).

• CallManager Administration—Applies only to devices running the 
CallManager. Opens the CallManager Administration pages. 

• Workflow Administration—Applies only to devices running a workflow 
application. Opens the Workflow Application Admin pages.

Note CiscoView, CallManager, and Workflow applications are additional products 
that are not provided with VHM. These products can be started from the Status 
View if they are already available.
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To start an application for a particular device from the Status View:

Step 1 Click a device to select it.

Step 2 Perform one of the following steps:

• Click the button for the application you want to start.

• Select the application from the Tools menu.

• Right-click the device and select the application from the context-sensitive 
menu that is displayed as a result.

Using the Device Detail View
For each device listed in the Status View, you can start a Device Detail View. The 
Device Detail View window provides the status reported for the device, as well as 
general device information. The status values in the Device Detail View window 
are updated only when you click the Refresh button. 

To display the Device Detail View for a device:

Step 1 Perform one of the following steps:

• Double click on the device in the Status View window.

• Right-click a device on the Status View window and select the Device Detail 
View option.

• Select a device on the Status View window and click the Display Device 
Detail View button.

• Select Tools > Real Time Dashboard–Device Detail View.

Note The Device Detail View is not real time; use the Refresh button to update the 
current device status.
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The Device Detail View window displays one tab with status information for each 
applicable category for the device:

• Environment

• System

• Interface

• Application

• Device Information

The number of categories varies with each device. For example, for the ICS 7750, 
the Device Detail View window contains only two tabs: Environment and Device 
Information. Other than the power supply, the ICS 7750 device has no system 
level entities or interfaces and applications; therefore, other tabs are not displayed 
for this particular device.

Using the Monitoring Console
From the Monitoring Console, you can view alarm logs, obtain more information 
about alarms and the conditions that may be causing them, and take action in 
response to alarms. Some examples of voice-specific alarms that may appear in 
the alarm logs are:

• Voice application problems such as voice applications failing or not 
responding. 

• Gateways losing connectivity with CallManager.

• Virtual memory usage on a media server reaching high levels.
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Starting the Monitoring Console
To start a Monitoring Console:

Step 1 Use one of the following procedures:

• From the Voice Health Monitor drawer, select Monitoring Console. 

This opens a Monitoring Console that by default:

– Displays two alarm logs: one with VHM alarms only and one with VHM 
and DFM alarms combined

– Does not display an Inventory Browser

• From any running Administration or Monitoring Console, select File > New 
> Monitoring Console. This opens a Monitoring Console that displays a 
single alarm log that includes both VHM and DFM alarms. 

• From any Summary View or Status View in the Real-Time Dashboard, select 
Tools > Voice Fault Monitoring Console. This opens a Monitoring Console 
that displays a single alarm log that includes both VHM and DFM alarms. 

When presented with an alarm log that includes both VHM and DFM alarms, you 
can identify the server that generated the alarm by examining the domain manager 
column. The domain manager will be either VHM or DFM. 

Note When you open a Monitoring Console using the toolbar button, the console 
includes an Inventory Browser display. If you open a Monitoring Console by 
selecting Voice Health Monitor > Monitoring Console, the console does not 
display the Inventory Browser. 
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The following related topics are described in the Device Fault Manager User 
Guide:

• Customizing and saving a console for later use

• Opening a remote console; that is, a console that was saved on another VHM 
server host

Note For descriptions of all menu options and toolbar buttons in the Monitoring 
Console, refer to the Device Fault Manager User Guide.

The Monitoring Console gives users the ability to specify which notifications they 
want to receive on the alarm log display and to further filter those alarms 
interactively as they view them. See the “Managing Events in the Monitoring 
Console” section on page 2-17 for more information. 

Displaying Alarm Notifications
VHM generates notifications for two kinds of events:

• Symptoms—Indicate fault conditions.

• Compounds—Indicate one or more symptomatic events associated with a 
managed object. 

Events are correlated to symptoms for analysis. Notifications are displayed in an 
Alarm Log whenever events occur, and on the Events Tab of the property sheet for 
the object where the event occurs. Table 2-6 lists the types of notifications and 
how they are color-coded in the Alarm Log.

Table 2-6 Alarm Log Color Coding

Notification Description Displayed in Console

Compound Event Represents one or more specific 
events

Purple

Symptomatic 
Event

An event that DFM uses as a 
symptom for root-cause analysis 
or for compound events

Orange or yellow

Inactive Cleared State changes to inactive and 
notification turns transparent

White with blue text
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Managing Events in the Monitoring Console
To use the Monitoring Console most effectively, you must be able to perform the 
following tasks:

• Apply filters to the alarm log—A user can further refine the list of displayed 
events by applying alarm log filters while viewing an alarm log. 

• Take actions based on an alarm—A user can send email or a page or start a 
script for a particular alarm. 

Instructions for setting up the system to perform these tasks, and instructions for 
the tasks themselves, are provided in the Device Fault Manager User Guide. 

Inactive 
Unsubscribed

State changes to inactive as a 
result of unsubscribing using a 
subscription profile

White with gray text

Selected Clicking on the notification Blue

Table 2-6 Alarm Log Color Coding (continued)

Notification Description Displayed in Console
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Changing Your Subscription Profile
A subscription profile is a saved list of events that have been subscribed to for 
notification. The events you subscribe to determine the notifications that are 
displayed in the Monitoring Console. By editing a profile, you can change the 
notifications that are reported. All users automatically subscribe to the default 
profile, which subscribes to all types of events (symptoms and compounds). If a 
user edits the profile, the profile is named according to the user’s login and saved 
in the VHM repository (when you save the inventory). If a user has edited the 
profile, it is applied whenever the user opens a console.

Caution Be careful when modifying a subscription profile, because changes can have 
a major effect on what is displayed by your consoles.

Note You can also directly edit the VHM adapter configuration files to either use an 
existing subscription profile or establish specific classes, instances, and events 
you want the adapters to track. This information is provided in the Device 
Fault Manager User Guide.

You can subscribe to (and unsubscribe from) the events you want to be notified of 
by changing your individual subscription profile, as described in the Device Fault 
Manager User Guide. 

Configuring the Monitoring Console to Remove Cleared Events
To configure the Monitoring Console to automatically remove events on 
unmanaged devices, you must create a filter.

To create a filter to automatically remove cleared events:

Step 1 Start the Monitoring Console. See the “Starting the Monitoring Console” section 
on page 2-15.

Step 2 Select an event from the VHM pane of the Monitoring Console.

Step 3 Select Log from the menu bar.
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Step 4 Select Filter from the drop-down menu.

The Alarm Filter Criteria dialog box opens.

Step 5 In the dialog box, under the General tab, select the Automatically remove cleared 
events check box.

Step 6 Click OK. 
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