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Preface

This document provides instructions for installing and configuring Resource 
Manager Essentials 4.0 (RME) on Solaris.

Audience
This document is for anyone who installs, configures and uses RME software. 
Network administrators and operators should have these skills:

• Basic Solaris system administrator skills

• Basic network management skills 

Conventions
This document uses the following conventions:

Item Convention

Commands and keywords boldface font

Variables for which you supply values italic font

Displayed session and system information screen font

Information you enter boldface screen font

Variables you enter italic screen font
ix
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Preface
Product Documentation
Note Means reader take note. Notes contain helpful suggestions or references to 
material not covered in the publication. 

Caution Means reader be careful. In this situation, you might do something that could 
result in equipment damage or loss of data.

Product Documentation
The following product documentation is available: 

Note Although every effort has been made to validate the accuracy of the information 
in the printed and electronic documentation, you should also review the Resource 
Manager Essentials documentation on Cisco.com for any updates.

Release Notes for Resource Manager Essentials

• Release Notes for Resource Manager Essentials on Solaris, Software Release 
4.0.

• Release Notes for Resource Manager Essentials on Windows, Software 
Release 4.0. 

These documents are available in the following formats: 

• As hard copies with your product. 

• PDF on the Resource Manager Essentials CD-ROM. 

Menu items and button names boldface font

Selecting a menu item in paragraphs Option> Network Preferences

Selecting a menu item in tables Option > Network Preferences

Item Convention
x
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Product Documentation
• On Cisco.com at 
http://www.cisco.com/univercd/cc/td/doc/product/rtrmgmt/cw2000/cw2000
e/e_4_x/4_0/index.htm

Installation Guide for Resource Manager Essentials

• Installation and Setup Guide for Resource Manager Essentials on Solaris, 
Software Release 4.0. 

• Installation and Setup Guide for Resource Manager Essentials on Windows, 
Software Release 4.0. 

These document are available in the following formats: 

• PDF on the Resource Manager Essentials CD-ROM. 

• On Cisco.com at 
http://www.cisco.com/univercd/cc/td/doc/product/rtrmgmt/cw2000/cw2000
e/e_4_x/4_0/index.htm. 

• Printed document available by order. 

User Guide for Resource Manager Essentials

This document is available in the following formats:

• PDF on the Resource Manager Essentials CD-ROM.

• From the Resource Manager Essentials online help.

• On Cisco.com at 
http://www.cisco.com/univercd/cc/td/doc/product/rtrmgmt/cw2000/cw2000
e/e_4_x/4_0/index.htm. 

• Printed document available by order. 

Supported Devices Table

• Supported Devices for Resource Manager Essentials 4.0

• Supported Devices for Software Management Application

• Supported Devices for Configuration Management Application

These documents are available on Cisco.com at 
http://www.cisco.com/univercd/cc/td/doc/product/rtrmgmt/cw2000/cw2000e/e_
4_x/4_0/index.htm.
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Preface
Related Documentation
Context-Sensitive Online Help for Resource Manager Essentials

You can access the online help by selecting an option from the navigation tree, 
then click Help (extreme right corner of your browser window).

The RME device package support for RME 4.0 is available at install time. You can 
access the device package help from the Online help.

Step 1 Select an option from RME desktop and click Help.

The Help launches in a separate browser window.

Step 2 Click Main at the extreme right corner of the page.

The Help window is refreshed and you see these nodes in the left navigation pane:

• CiscoWorks Common Services

• Resource Manager Essentials

Step 3 Expand the Resource Manager Essentials node.

The following leaf and node appear in the left navigation pane:

• RME User Guide (leaf)

• Device Packages (node)

Step 4 Expand the Device Packages node to view the help for device packages.

Related Documentation

Note Although every effort has been made to validate the accuracy of the information 
in printed and electronic documentation, you should also review Cisco product 
documentation on Cisco.com for any updates.
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Preface
Related Documentation
The following additional documentation is available:

Quick Start Guide for LAN Management Solution, Release 3.0

This document provides basic requirements for installing, upgrading, and setting 
up LAN Management Solution (LMS) 3.0 so you can get your server up and 
running as quickly as possible. In addition, the document also contains an 
exhaustive list of documentation for LMS 3.0. This document is available in the 
following formats:

• On Cisco.com at 

http://www.cisco.com/univercd/cc/td/doc/product/rtrmgmt/cw2000/cw2000
_b/lms/lms25/index.htm

• As hardcopies with your product.

User Guide for CiscoWorks Server

This document describes CiscoWorks Common Services, gives an overview of the 
applications that make up Common Services, provides conceptual information 
about network management, and describes common tasks you can accomplish 
with CiscoWorks Common Services. This document is available in the following 
formats:

• PDF on the CiscoWorks Common Services CD-ROM and from the 
CiscoWorks Common Services online help. 
Help > Server Configuration> User Guide for Common Services.

• On Cisco.com at

http://www.cisco.com/univercd/cc/td/doc/product/rtrmgmt/cw2000/cw2000
_d/comser30/usrguide/index.htm

• Printed document available by order.

Installation and Setup Guide for CiscoWorks Common Services

This document describes instructions for installing and configuring CiscoWorks 
Common Services. This document is available in the following formats:

• On Cisco.com at

http://www.cisco.com/univercd/cc/td/doc/product/rtrmgmt/cw2000/cw2000
_d/comser30/index.htm

• Printed document available by order.
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Additional Information Online
Additional Information Online
You can download device packages for new devices from Cisco.com and find 
information about all supported devices by logging into Cisco.com at 
http://www.cisco.com/univercd/cc/td/doc/product/rtrmgmt/cw2000/cw2000e/dev
_sup/index.htm.

Obtaining Documentation
Cisco documentation and additional literature are available on Cisco.com. Cisco 
also provides several ways to obtain technical assistance and other technical 
resources. These sections explain how to obtain technical information from Cisco 
Systems.

Cisco.com
You can access the most current Cisco documentation at this URL:

http://www.cisco.com/univercd/home/home.htm

You can access the Cisco website at this URL:

http://www.cisco.com

You can access international Cisco websites at this URL:

http://www.cisco.com/public/countries_languages.shtml

Documentation DVD
Cisco documentation and additional literature are available in a Documentation 
DVD package, which may have shipped with your product. The Documentation 
DVD is updated regularly and may be more current than printed documentation. 
The Documentation DVD package is available as a single unit. 

Registered Cisco.com users (Cisco direct customers) can order a Cisco 
Documentation DVD (product number DOC-DOCDVD=) from the Ordering tool 
or Cisco Marketplace.
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Documentation Feedback
Cisco Ordering tool:

http://www.cisco.com/en/US/partner/ordering/

Cisco Marketplace:

http://www.cisco.com/go/marketplace/

Ordering Documentation
You can find instructions for ordering documentation at this URL:

http://www.cisco.com/univercd/cc/td/doc/es_inpck/pdi.htm

You can order Cisco documentation in these ways:

• Registered Cisco.com users (Cisco direct customers) can order Cisco product 
documentation from the Ordering tool:

http://www.cisco.com/en/US/partner/ordering/

• Nonregistered Cisco.com users can order documentation through a local 
account representative by calling Cisco Systems Corporate Headquarters 
(California, USA) at 408 526-7208 or, elsewhere in North America, by 
calling 1 800 553-NETS (6387).

Documentation Feedback
You can send comments about technical documentation to bug-doc@cisco.com.

You can submit comments by using the response card (if present) behind the front 
cover of your document or by writing to the following address:

Cisco Systems
Attn: Customer Document Ordering
170 West Tasman Drive
San Jose, CA 95134-9883

We appreciate your comments.
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Cisco Product Security Overview
Cisco Product Security Overview
Cisco provides a free online Security Vulnerability Policy portal at this URL:

http://www.cisco.com/en/US/products/products_security_vulnerability_policy.ht
ml

From this site, you can perform these tasks:

• Report security vulnerabilities in Cisco products.

• Obtain assistance with security incidents that involve Cisco products.

• Register to receive security information from Cisco.

A current list of security advisories and notices for Cisco products is available at 
this URL:

http://www.cisco.com/go/psirt

If you prefer to see advisories and notices as they are updated in real time, you 
can access a Product Security Incident Response Team Really Simple Syndication 
(PSIRT RSS) feed from this URL:

http://www.cisco.com/en/US/products/products_psirt_rss_feed.html

Reporting Security Problems in Cisco Products
Cisco is committed to delivering secure products. We test our products internally 
before we release them, and we strive to correct all vulnerabilities quickly. If you 
think that you might have identified a vulnerability in a Cisco product, contact 
PSIRT:

• Emergencies— security-alert@cisco.com

• Nonemergencies— psirt@cisco.com
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Obtaining Technical Assistance
Tip We encourage you to use Pretty Good Privacy (PGP) or a compatible product to 
encrypt any sensitive information that you send to Cisco. PSIRT can work from 
encrypted information that is compatible with PGP versions 2.x through 8.x. 

Never use a revoked or an expired encryption key. The correct public key to use 
in your correspondence with PSIRT is the one that has the most recent creation 
date in this public key server list:

http://pgp.mit.edu:11371/pks/lookup?search=psirt%40cisco.com&op=index&ex
act=on

In an emergency, you can also reach PSIRT by telephone:

• 1 877 228-7302

• 1 408 525-6532

Obtaining Technical Assistance
For all customers, partners, resellers, and distributors who hold valid Cisco 
service contracts, Cisco Technical Support provides 24-hour-a-day, 
award-winning technical assistance. The Cisco Technical Support Website on 
Cisco.com features extensive online support resources. In addition, Cisco 
Technical Assistance Center (TAC) engineers provide telephone support. If you 
do not hold a valid Cisco service contract, contact your reseller.

Cisco Technical Support Website
The Cisco Technical Support Website provides online documents and tools for 
troubleshooting and resolving technical issues with Cisco products and 
technologies. The website is available 24 hours a day, 365 days a year, at this 
URL:

http://www.cisco.com/techsupport
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Obtaining Technical Assistance
Access to all tools on the Cisco Technical Support Website requires a Cisco.com 
user ID and password. If you have a valid service contract but do not have a user 
ID or password, you can register at this URL:

http://tools.cisco.com/RPF/register/register.do

Note Use the Cisco Product Identification (CPI) tool to locate your product serial 
number before submitting a web or phone request for service. You can access the 
CPI tool from the Cisco Technical Support Website by clicking the Tools & 
Resources link under Documentation & Tools. Choose Cisco Product 
Identification Tool from the Alphabetical Index drop-down list, or click the 
Cisco Product Identification Tool link under Alerts & RMAs. The CPI tool 
offers three search options: by product ID or model name; by tree view; or for 
certain products, by copying and pasting show command output. Search results 
show an illustration of your product with the serial number label location 
highlighted. Locate the serial number label on your product and record the 
information before placing a service call.

Submitting a Service Request
Using the online TAC Service Request Tool is the fastest way to open S3 and S4 
service requests. (S3 and S4 service requests are those in which your network is 
minimally impaired or for which you require product information.) After you 
describe your situation, the TAC Service Request Tool provides recommended 
solutions. If your issue is not resolved using the recommended resources, your 
service request is assigned to a Cisco TAC engineer. The TAC Service Request 
Tool is located at this URL:

http://www.cisco.com/techsupport/servicerequest

For S1 or S2 service requests or if you do not have Internet access, contact the 
Cisco TAC by telephone. (S1 or S2 service requests are those in which your 
production network is down or severely degraded.) Cisco TAC engineers are 
assigned immediately to S1 and S2 service requests to help keep your business 
operations running smoothly.

To open a service request by telephone, use one of the following numbers:

Asia-Pacific: +61 2 8446 7411 (Australia: 1 800 805 227)
EMEA: +32 2 704 55 55
USA: 1 800 553-2447
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Obtaining Additional Publications and Information
For a complete list of Cisco TAC contacts, go to this URL:

http://www.cisco.com/techsupport/contacts

Definitions of Service Request Severity
To ensure that all service requests are reported in a standard format, Cisco has 
established severity definitions.

Severity 1 (S1)—Your network is “down,” or there is a critical impact to your 
business operations. You and Cisco will commit all necessary resources around 
the clock to resolve the situation. 

Severity 2 (S2)—Operation of an existing network is severely degraded, or 
significant aspects of your business operation are negatively affected by 
inadequate performance of Cisco products. You and Cisco will commit full-time 
resources during normal business hours to resolve the situation.

Severity 3 (S3)—Operational performance of your network is impaired, but most 
business operations remain functional. You and Cisco will commit resources 
during normal business hours to restore service to satisfactory levels.

Severity 4 (S4)—You require information or assistance with Cisco product 
capabilities, installation, or configuration. There is little or no effect on your 
business operations.

Obtaining Additional Publications and Information
Information about Cisco products, technologies, and network solutions is 
available from various online and printed sources.

• Cisco Marketplace provides a variety of Cisco books, reference guides, and 
logo merchandise. Visit Cisco Marketplace, the company store, at this URL:

http://www.cisco.com/go/marketplace/

• Cisco Press publishes a wide range of general networking, training and 
certification titles. Both new and experienced users will benefit from these 
publications. For current Cisco Press titles and other information, go to Cisco 
Press at this URL:

http://www.ciscopress.com
xix
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Obtaining Additional Publications and Information
• Packet magazine is the Cisco Systems technical user magazine for 
maximizing Internet and networking investments. Each quarter, Packet 
delivers coverage of the latest industry trends, technology breakthroughs, and 
Cisco products and solutions, as well as network deployment and 
troubleshooting tips, configuration examples, customer case studies, 
certification and training information, and links to scores of in-depth online 
resources. You can access Packet magazine at this URL:

http://www.cisco.com/packet

• iQ Magazine is the quarterly publication from Cisco Systems designed to 
help growing companies learn how they can use technology to increase 
revenue, streamline their business, and expand services. The publication 
identifies the challenges facing these companies and the technologies to help 
solve them, using real-world case studies and business strategies to help 
readers make sound technology investment decisions. You can access iQ 
Magazine at this URL:

http://www.cisco.com/go/iqmagazine

• Internet Protocol Journal is a quarterly journal published by Cisco Systems 
for engineering professionals involved in designing, developing, and 
operating public and private internets and intranets. You can access the 
Internet Protocol Journal at this URL:

http://www.cisco.com/ipj

• World-class networking training is available from Cisco. You can view 
current offerings at this URL:

http://www.cisco.com/en/US/learning/index.html
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Installing RME

This chapter describes installing Resource Manager Essentials 4.0 on a Solaris 
system. It consists of:

• Product Overview

• Installation Overview

• Preparing to Install RME

• Installing RME

• Post Installation Checklist

• Uninstalling RME

After installing RME 4.0, if you want to avail these features and additional device 
support, you must download Resource Manager Essentials 4.0 Service Pack 1 
(RME 4.0 SP 1). 

• NetShow

• Contract Connection

• SmartCase

• Support for SSHv2 

• Bug fixes on RME 4.0 

For more information, see Readme for Resource Manager Essentials 4.0 Service 
Pack 1.

RME 4.0 SP 1 is available at the location:

http://www.cisco.com/cgi-bin/tablebuild.pl/cw2000-rme
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Product Overview
Resource Manager Essentials (RME), one of the major components of 
CiscoWorks, enables the deployment, monitoring, and configuration of devices 
across your network. 

RME is a suite of web-based network management tools integrated into a network 
desktop that includes web-based tools, and web-browser capability. This product 
is based on a client/server network architecture that connects multiple web-based 
clients to a network server.

The RME CD-ROM contains the Resource Manager Essentials 4.0 installable 
package.

Installation Overview
Table 1-1 is an overview of the RME installation. It contains references to more 
detailed information about each task.

Table 1-1 Installing RME Task Overview

Task Steps References

1. Prepare to install 
RME.

Verify that server 
requirements are met.

“RME Migration Paths” section on page 1-4

“Server Requirements and Recommendations” 
section on page 1-5

2. Install RME. a. Mount the CD-ROM.

b. Run the installation 
program.

“Performing a New Installation” section on 
page 1-11

or

“Data Migration From an Earlier Version” 
section on page 1-17

and

“Validating the Upgrade” section on page 1-20

or 

“Reinstalling or Upgrading From the 
Evaluation Version” section on page 1-31
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3. Troubleshoot the 
installation.

Analyze installation error 
messages.

Appendix A, “Troubleshooting the 
Installation”

4. Perform 
post-installation 
tasks.

Configure the system and set 
up RME applications.

 Chapter 2, “Preparing to Use RME 
Applications”

Table 1-1 Installing RME Task Overview (continued)

Task Steps References
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Preparing to Install RME
This section describes prerequisites and other factors you should consider before 
installing RME. This consists of:

• RME Migration Paths

• Server Requirements and Recommendations

• Client Requirements

• Supported Devices

• RME Port Usage

Caution Do not change the system time after installing RME. Such changes may affect the 
working of some time-dependent features. For more information, see “Frequently 
Asked Questions” section on page A-9.

RME Migration Paths
Migration refers to the migration of RME data from an older version of RME to 
a newer version. Migration from RME 3.4.x or RME 3.5.x is permitted (.x stands 
for the IDU upgrades). RME 3.4.x or RME 3.5.x backup data is essential for 
migration. 
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You can migrate to RME 4.0 from:

Caution The migration data also includes Netshow data. If you plan to migrate Netshow 
data later, you must retain a backup of the RME 3.x data. Netshow will be part of 
a drop-in release.

For more details see, “Data Migration From an Earlier Version” section on 
page 1-17.

Server Requirements and Recommendations
This section describes the server requirements and recommendations for 
CiscoWorks Common Services (Common Services) and RME 4.0.

Minimum Server Requirements

The minimum system requirements for a CiscoWorks Server running the 
Common Services 3.0 and Resource Manager Essentials 4.0 software are shown 
in Table 1-2.

RME Releases Incremental Device Updates (IDU)s / Patches

RME 3.4 You can migrate to RME 4.0 with or without using the following combinations of 
software releases on RME 3.4:

• All IDU releases on RME 3.4

• All patches released till date on RME 3.4 except point patches

• Data Extracting Engine (DEE) V2

RME 3.5 You can migrate to RME 4.0 with or without using the following combinations of 
software releases on RME 3.5:

• All the IDU releases on RME 3.5

• All the patches released till date on RME 3.5 except point patches
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To verify the amount of available disk space in each of the specified partitions and 
directories, enter:

# df -k directory

where directory is the partition or directory for which you want to check the 
available disk space.

Table 1-2 Server System Minimum Requirements 

Requirement Type Minimum Requirements

System hardware • Sun UltraSPARC IIIi1

• Color monitor.

• CD-ROM drive

1. Common Services supports Ultra SPARC III systems such as Sun-Fire-280R, Netra-T4, Sun Blade 1000.

System software Solaris 2.8 and Solaris 2.9

RME supports only US-English and Japanese versions of Solaris Operating 
Systems. It does not support any other language version. Set the default locale 
to US-English for US-English version of RME and Japanese for Japanese 
version of RME.

Memory (RAM) 1 GB

Available drive 
space

• 4 GB on the partition on which you install the product 
(the default is /opt) 2

• Enough space for storing device software image files3

• Swap space must be double the amount of memory (RAM). For example, if 
your system has 512 MB of RAM, you need 1024 MB of swap space

2. RME 4.0 is installed in the same directory as Common Services.

3. For information about downloaded files, see the “Setting Up Configuration Management” section on page 2-30.

Additional required 
software

Common Services must be installed before you install RME. For installation 
instructions, see Installation and Setup Guide for Common Services 3.0 
(Includes Ciscoview) on Solaris

Additional optional 
software

• Netscape Navigator 7.0 (if you are using the desktop on the server system) 4

• Mozilla 1.7

4. Use Netscape Navigator downloaded only from the Sun site.
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Server Recommendations

To select or configure a server system that best meets your needs, you must 
consider the number of managed devices expected in the Inventory, Configuration 
Management, and Software Management applications.

These factors affect server performance and user report response time.

Table 1-3 shows the recommendations for a server running Common Services and 
RME. These recommendations produce optimal response time while running 
user reports.

Client Requirements
The minimum client system requirements for Common Services and RME are 
shown in Table 1-4.

Before you access RME from a client system, the system must be properly 
configured. For more information about configuring clients, see Installation and 
Setup Guide for Common Services 3.0 (Includes Ciscoview) on Solaris. 

Table 1-3 Server System Recommendations

Minimum System Configuration Inventory
Configuration 
Management Software Management

UltraSPARC IIIi

Memory: 1 GB
Swap space: 2 GB
Available disk space: 40 GB 

0–300 devices 0–300 devices 0–300 devices

Dual Processor UltraSPARC IIIi

Memory: 2 GB
Swap space: 4 GB
Available disk space: 80 GB 

Up to 3000 devices Up to 2000 devices Up to 1700 devices
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RME Port Usage
Table 1-5 lists the ports used by RME:

Table 1-4 Client System Requirements Summary

 Requirement Type Minimum Requirement

System Software and 
Hardware

• Client system:

– IBM PC-compatible system with at least a 300 MHz Pentium 
processor running Windows 2000 (Professional and Server) 
with Service Pack 3 or Service Pack 4, Windows XP (SP1 and 
SP2), Windows Server 2003 (Standard and Enterprise Edition). 

RME supports only US-English and Japanese versions of 
Windows OS. Set the default locale to US-English for 
US-English version of RME and Japanese for Japanese version 
of RME.

– Sun UltraSPARC IIIi, running Solaris 2.8 or 2.9. 

• Color monitor with video card set to 24 bits color depth.

Memory (RAM) 512 MB

Browser One of these browsers:

• On Windows 2000 and Windows XP clients: 

– Microsoft Internet Explorer 6.0 (version 6.0.3790.0) in 
Windows 2003 with SP1

– Microsoft Internet Explorer 6.0.26 and 6.0.28 for Windows 
2000 and Windows XP 

– Netscape Navigator 7.1

– Mozilla 1.7.1.

• On Solaris clients:

– Netscape Navigator 7.0 1 for Solaris 2.8 and 2.9

– Mozilla 1.7 for Solaris 2.8 and 2.9

1. Use Netscape Navigator downloaded only from the Sun site.
1-8
Installation and Setup Guide for Resource Manager Essentials 4.0 on Solaris

78-16504-01



 

Chapter 1      Installing RME
Preparing to Install RME
Table 1-5 RME Port Usage

Protocol
Port 
Number Service Name Direction (of Establishment) of Connection

ICMP – Ping Server to Device

TCP 22 Secure Shell (SSH) Server to Device

TCP 23 Telnet Server to Device

TCP 25 Simple Mail Transfer 
Protocol (SMTP)

Server Internal

TCP 514 rsh Daemon Server to Device

TCP 1742 SSL (HTTPS)

For SSL, by default, the port 
is 443.

Client to Server.

TCP 3333 Syslog Collector Service and 
Syslog Analyzer Service

Server Internal

TCP 43455 RME Database Server Internal

TCP 4444 Syslog Collector Service and 
Syslog Analyzer Service

Server Internal

TCP 47000 - 
47020 

RME CSTM (Common 
Services Transport 
Mechanism) Server. 

Used for internal application 
communication.

Server Internal

UDP 69 Trivial File Transfer Protocol 
(TFTP)

Server to Device

Device to Server

UDP 161 Simple Network 
Management Protocol 
(SNMP)

Server to Device

Device to Server

UDP 162 SNMP Traps (Standard Port) Device to Server only (nGenius Real-Time 
Monitor);

Server to Device Device to Server (all others)
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Supported Devices
RME 4.0 supports some of the devices supported in previous versions of RME as 
well as new devices. Device packages for all supported devices are installed when 
you install RME. Information about these devices is at:

http://www.cisco.com/univercd/cc/td/doc/product/rtrmgmt/cw2000/cw2000e/dev
_sup/index.htm

You can login to Cisco.com as a registered user for:

• Downloading device packages.

You can download device packages for RME from: 

http://www.cisco.com/cgi-bin/tablebuild.pl/cw2000-rme

• More information about new device support

To see a list of the device packages installed in the CiscoWorks homepage, 
select Software Center > Resource Manager Essentials.

Installing RME
This section describes:

• Performing a New Installation

• Data Migration From an Earlier Version

• Reinstalling or Upgrading From the Evaluation Version

While performing RME installation you might be prompted to enter a new RME 
Database password. For details, see “Troubleshooting the Installation” section on 
page A-1.

UDP 514 Syslog Device to Server

UDP 42342 OSAGENT Server Internal (Common Services); RSAC to 
Server via OSAGENT (RME)

Table 1-5 RME Port Usage (continued)

Protocol
Port 
Number Service Name Direction (of Establishment) of Connection
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For more information on creating a new password see the “Password Information” 
Appendix in Installation and Setup Guide for Common Services 3.0 (Includes 
Ciscoview) on Solaris.

Installation Notes
Before you begin your installation, note the following:

• Run the installation from a local CD or a local hard drive to avoid errors 
caused by network inconsistencies.

• Install CiscoWorks Common Services 3.0 (Common Services) before 
installing RME 4.0. 

For more information, see the Installation and Setup Guide for Common 
Services 3.0 (Includes Ciscoview) on Solaris. The install script finds the 
Common Services directory and installs RME at the same location 
(/opt/CSCOpx by default). This location is referred to as $NMSROOT in this 
document.

• You can migrate to RME 4.0 only from RME 3.4 and RME 3.5 with 
Incremental Device Update (IDU) packages for the respective versions. No 
other migration paths are supported. RME 3.4 or RME 3.5 backup data is 
essential for migration. For more information, see RME Migration Paths, 
page 1-4.

• For information on different installation options, see What are the various 
installation switches supported?, page A-10.

Performing a New Installation
This section describes how to perform a new installation.

If you are upgrading on a system that had a previous version of RME installed, 
see the “Data Migration From an Earlier Version” section on page 1-17. 

Note To import data from a previous version of RME, after installation follow the 
procedure in the “Data Migration From an Earlier Version” section on page 1-17.
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Running the Installation Program for a New Installation

The RME installation takes approximately 30 minutes.

You can press Ctrl-C at any time to cancel the installation. However, any changes 
to your system (for example, installation of new files or changes to system files) 
will not be undone. 

Hence, we do not recommend ending the installation, using Ctrl-C. You will be 
required to manually cleanup the installation directories. For more information, 
see “Frequently Asked Questions” section on page A-9.

The installation program installs RME 4.0 in the same location as Common 
Services 3.0 (/opt/CSCOpx by default) and starts CiscoWorks.

Step 1 As root, mount the RME 4.0 CD-ROM. You can either:

• Mount the CD-ROM on the CiscoWorks Server system. (Direct installation)

or

• Mount the CD-ROM on a remote Solaris system, then access the CD-ROM 
from the CiscoWorks Server system. (Remote installation)

Run the installation from a local CD or a local hard drive to avoid errors caused 
by network inconsistencies.

See Appendix B, “Mounting and Unmounting the CD-ROM,” for detailed 
mounting instructions.

Step 2 Start the installation program.

• For a local installation, enter:

# cd /cdrom/cdrom0/
# cd RME
# ./setup.sh 

• For a remote installation, enter:

# cd remotedir
# cd RME
# ./setup.sh

where remotedir is the remote location where the CD-ROM is mounted.

The installation prompts you to press Enter to display the License Agreement.

Step 3 Press Return. 
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The License Agreement page appears.

Step 4 Press Return to scroll forward one page, or q to quit the License Agreement page. 
A message appears:

You must accept this License Agreement to proceed with the 
installation.
If you enter N/n, the installation will exit.
Do you accept all the terms of the License Agreement? (y/n) [n]

Step 5 Press y to accept the agreement, or n to quit installation.

A message appears:

To ensure full use of the product features, please select one of the 
following:
(L) If you have a license file for this product,
you will then be prompted for the license file location.
(S) If you know only the serial number and PIN,
but have not obtained the license file.
(E) To evaluate the product only.
You can provide licensing information later if you want to fully 
enable the product.

Step 6 Enter one of these:

• L for License File

• S for Serial number and PIN

• E for Evaluation

• Q to quit.

The installation program checks for required patches and other dependencies and 
displays:

1) "Typical installation is recommended for all computers."
2) "Custom installation can be selected if you want to customize the 
setup options."

Select one of the installation modes using its number or enter q to 
quit [1]

If you choose the Typical installation mode, the RME database password is 
randomly generated for you. You can view the password at the end of installation. 
To proceed with a Typical installation, go to “New Installation—Typical” section 
on page 1-15. 
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If you choose the Custom installation mode, you will be prompted to enter the 
RME database password. To proceed with a Custom installation, go to “New 
Installation—Custom” section on page 1-16.
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New Installation—Typical

To install RME using the Typical option:

Step 1 Enter 1 (for Typical) and press Return.

The installation program checks dependencies and system requirements: For 
details, see “Server Requirements and Recommendations” section on page 1-5.

• If your system does not meet the requirements a warning appears:

System memory is less than the minimum requirement, which may 
affect performance.

• If the partition does not have enough space, an error message appears:

There is not enough space in partition drive name.

Select another partition, or free some space on partition drive name.

The installation proceeds without displaying more prompts. This message appears 
at the end of installation:

Do you want to see the passwords that were entered/randomly 
generated ? If yes, please remember that passwords are security 
sensitive data and hence make sure they are kept secure. [y/n]

• If you enter y, the password appears in clear text on the console.

Note Memorize your password displayed on the console. We recommend 
you do not write it down.

• If you enter n, the password does not appear.

The installation completes without displaying more prompts and the system 
prompt appears.

Step 2 Unmount and eject the CD-ROM. For details, see Appendix B, “Mounting and 
Unmounting the CD-ROM”.
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New Installation—Custom

To install RME using the Custom option:

Step 1 Enter 2 (for Custom) and press Return. 

The installation program checks dependencies and system requirements: (For 
details, see “Server Requirements and Recommendations” section on page 1-5)

• If your system does not meet the requirements a warning appears:

System memory is less than the minimum requirement, which may 
affect performance.

• If the partition does not have enough space, an error message appears:

There is not enough space in partition drive name.

Select another partition, or free some space on partition drive name.

The installation program displays:

Enter RME database password:

Step 2 Enter a new password. Password should have minimum five characters.

A message appears:

Confirm Password

Step 3 Enter the password again to confirm.

The installation completes without displaying more prompts and the system 
prompt appears.

Step 4 Unmount and eject the CD-ROM. For details, see Appendix B, “Mounting and 
Unmounting the CD-ROM”

If the system returned any errors, check the installation log file 
/var/tmp/ciscoinstall.log. For other troubleshooting information, see Appendix A, 
“Troubleshooting the Installation”.
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Data Migration From an Earlier Version
Data Migration refers to the migration of RME data from an older version of RME 
to a newer version. Migration from RME 3.4.x or RME 3.5.x is permitted. 
RME 3.4.x or RME 3.5.x backup data is essential for migration. 

This section describes how to migrate to RME 4.0, if you have RME 3.4.x or 
RME 3.5.x installed on the server. 

• To migrate RME on the same server see, “Migrating on the Same Server” 
section on page 1-17. 

• To migrate RME on a different server see, “Migrating on a Different Server” 
section on page 1-18. All data available in the RME 3.x backup is not 
migrated to RME 4.0. For details see, “Data Migrated” section on page 1-24 
and “Data Not Migrated” section on page 1-27.

If you had installed a version of IDU later than 2.0 on a previous version of RME, 
and then want to migrate to RME 4.0, you will lose support for new devices.

To retain support for those devices, we recommend that you download and install 
the latest device packages for RME 4.0 after upgrading to RME 4.0.

Note Data migration across operating systems is not supported.

Migrating on the Same Server

To migrate RME on the same server:

Step 1 Upgrade to Common Services 3.0. For more information, see Installation and 
Setup Guide for Common Services 3.0 (Includes Ciscoview) on Solaris.

The Common Services 3.0 install script ensures that application data is backed up 
before migration. During backup, you are prompted to enter the backup directory. 
For more details see, “Backing Up Your Data” section on page 1-23.

Step 2 Install RME 4.0.

The RME 4.0 install script uninstalls older versions of RME (3.4.x or 3.5.x) along 
with dependent applications installed in the system.
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For example, consider Access Control List Manager (ACLM) and VPN/Security 
Management as RME dependant applications. During RME 4.0 installation, 
ACLM, VPN and the older version of RME (3.x) is uninstalled. 

For more details, see the “Performing a New Installation” section on page 1-11.

Step 3 Run the migration script to migrate RME 3.4.x or RME 3.5.x data. For more 
details, see the “Running the Migration Script” section on page 1-19.

Migrating on a Different Server

To migrate RME on a different server:

Step 1 Backup RME 3.4.x or RME 3.5.x data on the system where RME 3.4.x or RME 
3.5.x is installed. For more details see, “Backing Up Your Data” section on 
page 1-23.

Step 2 Install Common Services 3.0 on a clean system. For more information, see 
Installation and Setup Guide for Common Services 3.0 (Includes Ciscoview) on 
Solaris.

Step 3 Install RME 4.0 on the system where you just installed Common Services 3.0. 

For details see, “Performing a New Installation” section on page 1-11. 

Step 4 Transfer the backup data to this server.

Step 5 Run the migration script to migrate RME 3.4.x or RME 3.5.x data. For more 
details, see the “Running the Migration Script” section on page 1-19.
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Running the Migration Script

The installation program installs RME 4.0 in the same location as Common 
Services (/opt/CSCOpx by default) and starts CiscoWorks.

We recommend that you do not cancel migration to avoid errors.

Step 1 As root, login to the system on which you installed RME 4.0.

Step 2 Shut down the daemon manager. To do this, enter:

/etc/init.d/dmgtd stop

Step 3 Run the command:

/opt/CSCOpx/bin/perl /opt/CSCOpx/bin/restorebackup.pl -d backup 
location -gen version -t tempbackup dir

Example:

/opt/CSCOpx/bin/perl /opt/CSCOpx/bin/restorebackup.pl 
-d /ciscoworks/rmebackupdata -gen 2 -t /tmp

where: 

• /opt/CSCOpx is the CiscoWorks installation directory.

• -d backup location is the location where RME 3.4 or RME 3.5. backup data 
is available. This is mandatory.

• -gen version is the version to be migrated to RME 4.0. This is optional. By 
default, it will restore the latest backup data.

• -t tempbackup dir is used to extract files from the backup into a temporary 
location. These files are used by the restore backup script. This will be 
deleted after the data restoration is complete. This is optional. By default, 
restore backup script uses /opt/CSCOpx/tempbackupdata directory.

The migration script checks the details of the applications installed in the system 
and applications in the backup archive.

You are prompted to migrate syslog information. A message appears:

Do you want to migrate syslogs [y / n]? Enter y to continue.

If you want to migrate syslog information, choose Y, otherwise choose N.
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You are prompted to collect inventory data. A message appears:

Do you want to collect Inventory [y/n]?

If you want to collect inventory information during migration, choose Y, otherwise 
choose N.

Inventory collection during migration is not recommended. Time taken to 
complete inventory data collection is considerable.

It depends on number of devices, network speed and device response time. 
Schedule inventory collection after migration using the user interface. From the 
CiscoWorks homepage, select RME > Devices > Inventory.

Step 4 Start daemon manager after the migration is completed. To do this, enter:

/etc/init.d/dmgtd start

You have migrated to RME 4.0.

Validating the Upgrade
If you purchased an upgrade license of RME 4.0, you must validate the upgrade 
on the system where RME 4.0 is installed. 

Proof of Purchase (POP) is required to validate an upgrade license of RME 4.0. 
You are prompted to run a CLI script to validate this upgrade license. This script 
is available at this location, /opt/CSCOpx/bin/validateupgrade.

• If you plan to use the same machine (that has RME 3.4.x or RME 3.5.x) for 
RME 4.0 installation, you will not be prompted to run this CLI script. 

In this case, Proof of Purchase validation is done automatically.

• If you plan to use a new/different server for RME 4.0 (that has 3.4.x or 3.5.x 
installed on a different server), a message appears at the end of the RME 4.0 
installation to validate the upgrade license. 
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The product will be in the nag mode until POP is validated. This message 
appears till you complete the upgrade validation:

This software installation requires reusing a license provided in 
a previous version. If a previous license is not available or 
proof of purchase validation was not performed, you may continue 
to install in NAG mode, while arranging with your Cisco 
representative to return this product and purchase a full licensed 
version.

To validate the upgrade license:

Step 1 Go to C Shell by running the command csh.

Step 2 Set the environment using the command:

setenv LD_LIBRARY_PATH 
/opt/CSCOpx/objects/db/lib:/opt/CSCOpx/lib:/opt/CSCOpx/MDC/lib

Step 3 Change the directory to /opt/CSCOpx/bin using the command:

cd /opt/CSCOpx/bin

Step 4 Run the CLI script:

./validateupgrade

The following prompt appears:

This utility will validate your proof of purchase of the product and 
allow you to obtain an upgrade license.
Please enter the CiscoWorks product for the proof of purchase 
validation (such as LMS, ITEM, VMS):

Step 5 Enter the bundle name and press the Return key.

The following prompt appears:

Please select the source for upgrade validation from the following
1. Validate from a CD (older version of RME).
2. Validate from a remote server (where older version of RME is 
installed).
Please enter 1 to upgrade from a CD; enter 2 to upgrade from a remote 
server  [1 / 2] :
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• If you select 1, a prompt appears:

Please insert the previous versions of RME CD into the CDROM drive 
and provide the absolute path to the CD drive:

Enter the CDROM drive path. For example, /cdrom/cdrom0

• If you select 2, a prompt appears:

Please enter the remote CiscoWorks server host name or the IP 
address : 
Please enter the remote CiscoWorks server http or https port 
number :
Please enter the remote CiscoWorks server login name :
Please enter the remote CiscoWorks server login password :
Please be patient. Upgrade validation is in progress from a remote 
server.

Enter the following details of the remote CiscoWorks server:

– Host name or the IP address. For example, ciscoworks-rme

– http or https port number. For example, 1741

– Login name. For example, admin

– Login password. 

This message is appears after you enter the above details:

Please be patient. Upgrade validation is in progress from a remote 
server.

After the RME upgrade validation completes, this message is appears:

Validation succeeded.
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Backing Up Your Data

To backup your data:

Step 1 Access the CiscoWorks Server and log in.

For information, see Invoking CiscoWorks HomePage and Logging in to Common 
Services sections in the User Guide for CiscoWorks Common Services. 

Step 2 From CiscoWorks Homepage, select Common Services > Server > Admin > 
Backup.

The Backup page appears.

Step 3 Enter the path name of the target directory in the Set Backup Schedule dialog box. 

We recommend that you use a different directory from the directory where 
CiscoWorks is located, for example, /cw/backups.

Step 4 Check the Immediate radio button in the Set Backup Schedule dialog box.

Step 5 Click Apply to begin the backup. 

This process may take some time to complete. For more information, see the 
Online help.

Backing up Data Using CLI

To backup your data using CLI, run the following command at your command 
prompt:

NMSROOT/bin/backup.pl BackupDirectory LogFile Num_Generations

BackupDirectory—Directory that you want to be your Backup directory.

LogFile—Log file name

Num_Generations—Maximum backup generations to be kept in the backup 
directory.

Before starting migration, all currently scheduled jobs must be suspended.
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Data Migrated

The data migrated from RME 3.4.x or 3.5.x to RME 4.0:

• Devices and its credentials are updated in the Device Credential Repository 
(DCR).

• Device configurations collected from devices using Config Archive.

• Change Audit history of all devices. This includes details changes that each 
application maintains.

• Images in Software Management repository.

• NetConfig user defined templates and Syslog custom filters.

Caution The migration data also includes Netshow data. If you plan to migrate Netshow 
data later, you must retain a backup of the RME 3.x data. Netshow will be part of 
a drop-in release.

See the following sections for application specific details on data migrated:

• Device Selector

• Inventory

• Config Archive

• NetConfig

• Config Editor

• Software Management

• Syslog

• Change Audit

Device Selector 

Public and Private Static Device Views

For private views, device groups are created with the RME 3.4 or RME 3.5 
username. You may use groups if the same username exists in RME 4.0. If the 
username does not exist in RME 4.0, the group is assigned to NetAdmin.
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Inventory

The inventory data migrated from RME 3.4.x or 3.5.x to RME 4.0: 

• Change History

• User defined fields and their display names

• Device attributes and credentials

• RME Device Management Application updates 

RME Device Management Application updates DCR with the list of devices 
and appropriate credentials.

Migration Strategy

All devices in the managed state in RME 3.4.x and RME 3.5.x are migrated to 
RME 4.0. The migration strategy is: 

For the list of devices maintained in RME 3.4 or RME 3.5:

1. Device Management Application is supplied with the list of devices migrated 
from RME 3.4 or RME 3.5.

2. Device Management Application assigns the device ID to the device. The 
device ID is the same ID the device used in RME 3.4 or RME 3.5. Device 
Management Application also marks the state of the devices as normal. 

3. You are prompted to initiate inventory collection. 

If you choose to collect inventory data during migration, inventory collection 
is triggered towards the end of migration.

We recommend that you do not perform Inventory collection during migration. 
This is because it takes a long time to complete inventory data collection.It 
depends on number of devices, network speed and device response time. 

Schedule inventory collection after migration using the user interface. To do this 
select RME > Devices > Inventory. from the CiscoWorks homepage.

For devices in other states in RME 3.4 or RME 3.5 (unreachable, aliased, or 
suspended):

Credentials are associated. These devices and their associated credentials are 
migrated to DCR. For details, select Devices > Device Management > RME 
Devices, from the CiscoWorks homepage
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Config Archive 

The Config Archive data migrated from RME 3.4.x or 3.5.x to RME 4.0: 

• Raw Configuration files

All running, startup and VLAN configurations

• Shadow directory.

• ChangeAudit records. This includes Configuration change details.

• Archived configuration versions

NetConfig

The NetConfig data migrated from RME 3.4.x or 3.5.x to RME 4.0: 

• User Defined Templates (UDT)

UDT RouterUDT in RME3.5 is migrated as RouterUDTTask with the UDT 
template, RouterUDT in RME4.0. 

• Default Template Usage

All templates are assigned to Admin on migration by default. If your 
RME 3.4 or RME 3.5 user exists in RME 4.0, the task mappings are migrated. 
However, device to task mapping is not migrated.

Config Editor

Editing Mode in which the files are opened. It is either ‘Raw’ or ‘Processed’.

Software Management 

The Software Management data migrated from RME 3.4.x or 3.5.x to RME 4.0 
are Image Libraries.

Exceptions

• Images of device types that do not have device support are not migrated. The 
corresponding device package may not be installed.

• Images are migrated with default attributes. If you made any changes to the 
image attributes in RME 3.4 or RME 3.5, you must redo the changes after 
migrating the image to RME 4.0.
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Syslog

The Syslog data migrated from RME 3.4.x or 3.5.x to RME 4.0: 

• Automated Actions and Filters

Automated Actions and Filters are migrated. However, the scripts associated 
with the automated actions are not migrated. 

Hence, you must manually copy the scripts from RME 3.4 or RME 3.5 
installation to the required location in RME 4.0. Ensure that the scripts are 
operational on the RME 4.0 system for the automated tasks to function 
properly.

• Syslog messages

Syslog messages are critical. However, the data volume is huge. Hence, you 
may choose to migrate the Syslog messages during migration.

• RME 4.0 retains data up to 7 days by default. During migration, if you 
attempt to restore RME 3.4 or RME 3.5 data older than the configured 
number of days on RME 4.0, messages are purged when the next Syslog purge 
job is triggered. 

• Custom reports

Change Audit

All change records with the details are migrated.

Data Not Migrated

This section lists the data that is not migrated RME 3.4.x or 3.5.x to RME 4.0. It 
also states the tasks that you need to recreate.

• Scheduled jobs that are yet to be executed. 

These jobs must be recreated with required approvals sought anew. 

• Application execution logs. 

The structure and components of earlier versions of RME in comparison to 
RME 4.0 are different. Hence, earlier versions of logs are irrelevant.

• Completed jobs.
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Completed jobs cannot be edited or used to create new jobs. However, the 
details of job execution are available. View the Change Audit reports for 
details about how devices were affected. 

• Admin Settings

RME 4.0 default configuration overrides configurations of earlier versions of 
RME. For the admin settings of your RME 3.x system, see AdminSettings.txt 
file. The file is usually available in $NMSROOT. You may use this file as a 
baseline to configure your RME 4.0 system, if required. 

See the following sections for application specific details on data not migrated:

• Device Selector

• Inventory

• Config Archive

• NetConfig

• Config Editor

• Software Management

• Syslog

• Change Audit

• Jobs

Device Selector

Dynamic Views

RME 3.4 or RME 3.5 dynamic views are not migrated because of the device 
classification changes to Meta Data Format (MDF) in RME 4.0.

Inventory

The inventory data not migrated from RME 3.4.x or 3.5.x to RME 4.0: 

• Detailed Device Data

Importing a device in RME4.0 fetches device data from the managed device.

• Scan History

This feature is not supported in RME 4.0.
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• Collection and Polling Interval

Default system inventory collection and polling job is created.

• Inventory Change Filter

Inventory change filter details are not backed up in RME 3.4 and RME 3.5. 
This data must be recreated in RME4.0.

• Check device attributes

Check device attribute data is overwritten when invoked.

Config Archive 

The Config Archive data not migrated from RME 3.4.x or 3.5.x to RME 4.0: 

• Protocol order and archive location

The RME 4.0 settings take precedence.

• Admin settings

Default update schedule, purge policy and syslog policy.

• Label information.

• Custom queries

• Last Configuration change time for devices.

• Running startup out of synchronized data.

NetConfig

The NetConfig data not migrated from RME 3.4.x or 3.5.x to RME 4.0: 

• Template to Device Type Assignment 

In RME 3.4 or RME 3.5, User Defined Templates are associated with a device 
category, while in RME 4.0 the categorization is based on MDF type. Hence, 
the translation from RME 3.4 or RME 3.5 categorization to RME 4.0 is not 
feasible.

• Jobs and details

• User Preferences and Admin Settings
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Config Editor

The Config Editor data not migrated from RME 3.4.x or 3.5.x to RME 4.0: 

• Negation rules

In RME 3.4 or RME 3.5, negation rules are maintained in flat files. In RME 
4.0, RME device packages handle this task. 

• Insertion rules

In RME 4.0, insertion rules are maintained by Config archive.

• User Preferences and Admin Settings

Software Management 

The Software Management data not migrated from RME 3.4.x or 3.5.x to 
RME 4.0 is: 

• Admin Settings 

Admin settings are stored in a flat file. You may access the file after 
migration. Refer to your old admin settings from the text file and configure 
RME 4.0.

• Jobs and details

Syslog

The Syslog data not migrated from RME 3.4.x or 3.5.x to RME 4.0: 

• Admin settings

The devices that are not managed in RME 4.0 and are represented using 
wildcards, are ignored during migration of automated action, message filters 
and custom reports.

Change Audit

The Change Audit data not migrated from RME 3.4.x or 3.5.x to RME 4.0: 

• Admin settings

• Exception periods
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Jobs

In RME 3.x, jobs are serialized objects. You could copy the RME job objects from 
one 3.x version to another. In RME 4.0, the job data structures are not serialized 
objects. Hence, you cannot migrate jobs.

Reinstalling or Upgrading From the Evaluation Version
This section explains how to reinstall RME 4.0 or upgrade from an evaluation 
version of RME 4.0.

The installation program is able to detect whether you have already installed 
RME 4.0. Your existing database is not affected by the reinstallation. However, 
you should back up the database before installing to prevent any possible loss of 
data. Your CiscoWorks Server configuration is also preserved.

Running the Installation Program to Reinstall

The RME installation takes approximately 30 minutes.

You can press Ctrl-C at any time to cancel the installation. However, any changes 
to your system (for example, installation of new files or changes to system files) 
will not be undone. 

Hence, we do not recommend aborting installation using Ctrl-C. You will be 
required to manually cleanup the installation directories. For more information, 
see the “Frequently Asked Questions” section on page A-9.

The installation program installs RME in the same location as Common Services 
(/opt/CSCOpx by default) and starts CiscoWorks.

Step 1 As root, mount the RME CD-ROM. You can either:

• Mount the CD-ROM on the CiscoWorks Server system.

or

• Mount the CD-ROM on a remote Solaris system, then access the CD-ROM 
from the CiscoWorks Server system.
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Run the installation from a local CD or a local hard drive to avoid errors due to 
network inconsistencies.

See Mounting a Local CD-ROM Drive, page B-1 for detailed mounting 
instructions.

Step 2 Start the installation program.

• For a local installation, enter:

# cd /cdrom/cdrom0/
# cd RME
# ./setup.sh

• For a remote installation, enter:

# cd remotedir
# cd RME
# ./setup.sh

where remotedir is the remote location where the CD-ROM is mounted.

The installation program displays the License agreement.

Step 3 Select I Agree.

The installation options appear:

Choose the type of Setup you prefer.
1) "Typical installation is recommended for all computers."
2) "Custom installation can be selected if you want to customize the 
setup options."

Select one of the installation modes using its number or enter q to 
quit [1]

• If you choose the Typical installation mode, the password assigned to the 
previous installation of RME database will be retained.

• If you choose the Custom installation mode, you will be prompted to enter a 
password for the RME database.

Step 4 Do either of the following:

• To use the Typical reinstallation mode, go to 
“Reinstalling RME—Typical” section on page 1-33.

• To use the Custom reinstallation mode, go to 
“Reinstalling RME—Custom” section on page 1-34.
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Reinstalling RME—Typical

To use the Typical option:

Step 1 Enter 1 (Typical) and press Return. 

The installation program checks dependencies and system requirements (For 
details, see “Server Requirements and Recommendations” section on page 1-5)

• If your system does not meet the requirements a warning appears:

System memory is less than the minimum requirement, which may 
affect performance.

• If the partition does not have enough space, an error message appears:

There is not enough space in partition drive name.

Select another partition, or free some space on partition drive name.

The installation program checks dependencies and displays the following:

Resource Manager Essentials 4.0 has been detected on your system, are 
you sure you want to reinstall (y/n):

Step 2 Enter y to reinstall, or n to quit.

The installation completes without displaying more questions and the system 
prompt appears.

Step 3 Unmount and eject the CD-ROM. For details, see Appendix B, “Mounting and 
Unmounting the CD-ROM”.
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Reinstalling RME—Custom

To use the Custom option:

Step 1 Enter 2 (for Custom) and press Return. 

Step 2 The installation program checks dependencies and system requirements: (For 
details, see “Server Requirements and Recommendations” section on page 1-5)

• If your system does not meet the requirements a warning appears:

System memory is less than the minimum requirement, which may 
affect performance.

• If the partition does not have enough space, an error message appears:

There is not enough space in partition drive name.

Select another partition, or free some space on partition drive name.

The installation program checks dependencies and displays the following:

Resource Manager Essentials 4.0 has been detected on your system. Are 
you sure you want to reinstall this software? (y/n) [n]

Step 3 Enter y to reinstall, or n to quit.

The installation program displays:

Enter RME database password:

Step 4 Enter a new password.

The following message appears:

Confirm Password

Step 5 Enter the password again to confirm.

The installation completes without displaying more prompts and the system 
prompt appears.

Step 6 Unmount and eject the CD-ROM. For details, see Appendix B, “Mounting and 
Unmounting the CD-ROM”
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If the system returned any errors, check the installation log file 
/var/tmp/ciscoinstall.log. For other troubleshooting information, see Appendix A, 
“Troubleshooting the Installation”.

Post Installation Checklist
Table 1-6 lists the common post-installation that are required to be configured 
after installing RME. For details, see Chapter 2, “Preparing to Use RME 
Applications”.

Table 1-6 Post Installation Checklist

Task How to get there...

Verifying System Settings RME > Administration > System Preferences

Or

Common Services > Server > Admin > System Preferences

Job Approval

Creating approver list RME > Administration > Approval > Create/Edit

Enabling job approval RME > Administration > Approval > Approval Policies

Inventory Management

Add Devices RME > Devices > Device Management > RME Devices.

Checking Add / Import 
Summary

RME > Devices > Device Management.

Checking device attributes RME >Devices > Device Management> Device Credential 
Verification > Select Devices > View Credential Verification Report

Changing device attributes RME >Devices > Device Management > Device Credential 
Verification > Select Devices > Edit Device Credentials

Deleting unwanted devices RME > Devices > RME Devices > Select Devices > Delete 

Scheduling collection RME >Devices > Inventory > Inventory Jobs > Create

Manually updating inventory RME >Devices > Inventory > Inventory Jobs > Create> Choose 
Immediate Job 
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Configuration Management

Performing general setup tasks RME > Admin > Config Mgmt

Config Editor Administration RME > Admin > Config Mgmt > Config Editor 

Or 

RME > Admin > Config Mgmt > Config Job Policies > 
ConfigEditor

NetConfig Administration RME > Admin > Config Mgmt > Config Job Policies > NetConfig

Software Management

Establishing Software 
Management Preferences

RME > Administration > Software Management > View/Edit 
Preferences

Importing Baseline of Software 
Images

RME > Software Management > Software Repository

Scheduling Synchronization Job RME > Software Management > Software Repository > Software 
Repository Synchronization

Change Audit

Defining Exception Periods RME > Tools > Change Audit > Exception Periods

Forwarding Traps RME > Tools > Change Audit > Automated Actions

Syslog Analyzer

Verifying Storage Options RME > Admin > Syslog > Set Backup Policy

Defining Message Filters RME > Tools > Syslog > Message Filter

Defining Automated Actions RME > Tools > Syslog > Automated Action

Creating Custom Syslog Reports RME > Reports > Custom Templates

Table 1-6 Post Installation Checklist (continued)

Task How to get there...
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Uninstalling RME
The uninstallation program removes files and settings. Uninstallation allows you 
to remove the product alone or remove Common Services as well. To remove 
Common Services, you must first remove RME.

Before removing the RME, you must remove any applications that depend on the 
product. That is, the applications for which installing RME is a prerequisite.

Caution You must use the uninstall program to remove the product. If you try to remove 
RME manually, CiscoWorks may stop functioning. Uninstalling the product 
software removes the database as well.

Uninstallation takes about 30 minutes.

Step 1 Enter these commands as root to start the uninstall program:

# cd /
# /opt/CSCOpx/bin/uninstall.sh

where /opt/CSCOpx is the default installation directory. If you specified a 
different directory when you installed Common Services, use the name of that 
directory.

Note You cannot uninstall Common Services without uninstalling RME.

A message similar to the following appears at command prompt:

1) CiscoView 6.1
2) Integration Utility 1.6
3) CiscoWorks Common Services 3.0
4) Resource Manager Essentials 4.0
5) All of the above

Select one or more of the items using its number separated by comma or 
enter q to quit [q]

Note You cannot uninstall Common Services without uninstalling RME.
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Step 2 Enter 1, 2, 3 or 4 and press Return. The following prompt similar to the following 
appears:

A prompt similar to the following appears:

Are you sure you want to uninstall: CiscoWorks Common Services, 
Resource Manager Essentials? (y/n) [n]

Step 3 Enter y and press Return to remove the applications you selected, or n to quit the 
uninstallation.

The installation program checks for CiscoWorks packages on the system and the 
following prompt appears:

Delete the CiscoWorks packages? (y/n) [n]

Step 4 Enter y and press Return to remove packages, or n to quit.

Messages prompting you to remove packages, may appear. You may ignore them 
since they are only for information. The installation program does not accept input 
to these questions.

After the uninstallation program completes, this message appears:

All files were deleted successfully.

When you remove Common Services or RME, the uninstallation program 
removes changes made to the /etc/services file. The /etc directory still contains all 
system file changes. The uninstallation messages are written to the 
/var/tmp/ciscouninstall.log file.

To reinstall RME, follow the instructions in the “Reinstalling or Upgrading From 
the Evaluation Version” section on page 1-31.
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C H A P T E R 2

Preparing to Use RME Applications

After installing and setting up Resource Manager Essentials (RME 4.0), you must 
configure the server for RME and configure the RME applications for use.

This chapter assumes that you have performed the client setup tasks described in 
Installation and Setup Guide for Common Services 3.0 (Includes Ciscoview) on 
Solaris.

This chapter consists of:

• Preparation Overview

• Accessing the Server

• Logging In

• Configuring the Server

• Configuring the Proxy Server

• Setting Device Credentials

• Setting Up Inventory

• Setting Up Syslog Analyzer

• Setting Up Software Management

• Setting Up Configuration Management 
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Preparation Overview
Table 2-1 lists the prerequisite tasks for using RME applications. It contains 
references to more detailed information about each task.

 
Table 2-1 Preparing To Use RME Applications Task Overview

Task Steps References

1. Configure the 
system.

Enter information about the proxy server, 
SMTP, and rcp

“Configuring the Server” section 
on page 2-6.

2. Setting device 
credentials

Configure items on the devices that are to be 
monitored by RME.

“Setting Device Credentials” 
section on page 2-8

3. Set up 
Inventory.

a. Create network inventory by adding 
device information one device at a 
time.

“Adding Devices in RME to 
Collect Inventory Data” section on 
page 2-9.

b. (Optional) Obtain login privileges to 
Cisco.com (Cisco.com).

If you do not have login privileges, 
go to the Cisco.com home page, 
www.cisco.com, to obtain a login.

c. (Optional) Perform the following 
Inventory setup tasks:

• Schedule inventory polling and 
collection.

• Set change report filters.

• Display a detailed device report.

Inventory Online help.

4. Set up Syslog 
Analyzer.

a. Configure your routers and switches for 
Syslog Analyzer.

“Configuring Devices for Syslog 
Analyzer” section on page 2-12. 

b. Verify settings in the Syslog 
configuration file.

“Verifying the Settings in the 
Syslog Configuration File” section 
on page 2-16.

c. Verify Syslog messages are being 
processed by Syslog Analyzer.

“Verifying the Syslog Collector” 
section on page 2-17.
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5. Set up 
Software 
Management.

d. Set Software Management preferences. “Setting Software Management 
Preferences” section on page 2-19.

e. Obtain login privileges to Cisco.com. If you do not have login privileges, 
go to the Cisco.com, to obtain a 
login.

f. Set up Trivial File Transfer Protocol 
(TFTP).

“Setting Up TFTP” section on 
page 2-19.

g. Set up rcp. “Setting Up rcp” section on 
page 2-22.

h. Allow user casuser to use at and cron. “Allowing the User casuser to Use 
at and cron” section on page 2-29.

i. (Optional) Perform setup tasks:

• Create a baseline of the devices in 
your network and populate the 
software image library.

• Schedule the Synchronize Library 
job to run periodically.

• Create one or more approver lists if 
you want to use the Job Approval 
option.

• Distribute a software image to a 
device or group of devices.

Software Management Online 
help.

Table 2-1 Preparing To Use RME Applications Task Overview (continued)

Task Steps References
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Accessing the Server
When you access the CiscoWorks Server, the CiscoWorks Login Manager 
appears. 

To access the server from a client system, enter any one of these URLs in your 
web browser:

• If SSL is disabled and if you installed CiscoWorks Common Services 
(Common Services) on the default port, and enter:

http://server_name:1741

6. Set up 
Configuration 
Management.

j. Modify device security. “Modifying Device Security” 
section on page 2-34.

k. Set up NetConfig:

• Verify device configurations in 
configuration archive.

• Modify device security.

• Verify device prompts.

“Setting Up NetConfig” section on 
page 2-35 and NetConfig online 
help.

l. (Optional) Perform NetConfig setup 
tasks:

• Configure default job properties.

• Assign template access privileges 
to users.

• Enable Job Approval.

NetConfig Online help.

Table 2-1 Preparing To Use RME Applications Task Overview (continued)

Task Steps References
2-4
Installation and Setup Guide for Resource Manager Essentials 4.0 on Solaris

78-16504-01



 

Chapter 2      Preparing to Use RME Applications
Logging In
• If SSL is enabled, and if you installed CiscoWorks Common Services 
(Common Services) on the default port, enter:

https://server_name:443

where server_name is the hostname of the server on which you installed 
RME. If an alternative port was assigned during Common Services 
installation, enter:

http://server_name:port_number

where server_name is the name of the server on which you installed Common 
Services and RME, and port_number is the alternative port assigned during 
the installation. 

You may enter http://server_name:1741 in the SSL mode. The URL gets 
redirected to https and it still works.

See the User Guide for CiscoWorks Server for information about administrator 
logins.

Logging In
To perform server setup tasks, you must log in as the system administrator:

Step 1 Enter the administrator username and password in the Login Manager dialog box:

User Name: admin
Password: password

Step 2 Click Login. 

The CiscoWorks homepage appears.
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Configuring the Server
You can configure system-wide information for RME applications using the 
System Configuration option. You should verify that the defaults are correct, if 
not enter the corrections.

Step 1 Select Common Services > Server > Admin > System Preferences.

The View / Edit System Preferences dialog box appears.

Step 2 Select one of the following textboxes to enter information or to verify that the 
configured information is correct:

• SMTP Server

• RCP User

• CiscoWorks Email ID

See Table 2-2 for descriptions of the information in each dialog box tab.

Step 3 Click Apply to save the changes, or click Defaults to apply the default.

Step 4 Repeat Step 2 and Step 3 until you have verified or corrected all the information 
displayed in the System Configuration dialog box.

The dialog box is displayed until you select another option from the
navigation tree.

Configuring the Proxy Server
To configure the proxy server:

Step 1 Select Common Services > Server > Security > Cisco.com Connection 
Management > Proxy Server Setup.

The Proxy Server Setup dialog box appears.

Step 2 Enter the following information:

• Host name/IP address—Proxy host or IP address.

• Port—Proxy port Number.
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• Username—Login ID of the proxy server. This is optional.

• Password—Password of the proxy server. This is optional.

• Verify—Re-enter the same password as in Password, to confirm.

See Table 2-2 for descriptions of the information in each dialog box tab.

Step 3 Click Apply to save the changes.

This dialog box is displayed until you select another option from the navigation 
tree.

Table 2-2 System Configuration Dialog Box Information

Tab Name Description Fields—Values to Enter

HTTP Proxy Connects to Cisco.com. If server access 
to the outside world is controlled through 
a proxy server, you must configure this 
setting.

Proxy URL—System-wide proxy URL. 
There is no default.

RCP User Specifies the user during remote file 
transfers from devices. Authenticates rcp 
transfers between devices and server.

User account must exist on UNIX 
systems and should also be configured on 
devices as local user in the ip rcmd 
configuration command.

See “Setting Up rcp” section on 
page 2-22.

User Name—Name used by a network 
device when it connects to the server to run 
rcp.

SMTP 
Server

Sends E-mail. SMTP Server—Server name. Default is 
localhost.

CiscoWorks 
Email ID

Specifies the E-mail ID of the user. Enter the E-mail ID.
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Setting Device Credentials
Several important items must be configured correctly on every Cisco device that 
will be managed and monitored through RME.

Details about each application and the tasks involved in setting the credentials are 
available later in this document. For details see Table 2-1 on page 2-2.

Table 2-3 lists all the applications and the device credentials required for proper 
functioning of the applications.

Table 2-3 Applications and the Device Credentials

Application Telnet Password Enable Password SNMP Read Only SNMP Read / Write

NetConfig Required Required Required Not required1

1. After execution of a job, NetConfig provides an option to fetch the configuration using TFTP. SNMP Read/Write credentials 
are required in such cases.

Config Editor Required Required Required Not required2

2. After execution of a job, Config Editor provides an option to fetch the configuration using TFTP. SNMP Read/Write 
credentials are required in such cases.

ChangeAudit Not required Not required Required Not required

Configuration 
Management 
(Telnet)

Required Required Required Not required

Configuration 
Management3 
(TFTP)4

3. Configuration download also uses TFTP. Hence, SNMP Read/Write credentials are required.

4. The file vlan.dat can be fetched only if telnet password and enable password are supplied.

Not required Not required Required Required

Inventory Not required Not required Required Not required

SWIM Required5

5. Required in case of few devices like PIX devices, Cisco 2950 series switches.

Required5 Required Required

Syslog Not required Not required Required Not required
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Setting Up Inventory
As a network administrator, you need to be able to quickly troubleshoot problems 
on the network, know the Inventory of the devices RME manages and run various 
kinds of reports both pre-canned reports and custom reports. The Inventory 
application in RME caters to these requirements.

This section describes the tasks that you must perform to set up the Inventory 
application.

For detailed information see User Guide for Resource Manager Essentials 3.5.

Adding Devices in RME to Collect Inventory Data
You must have at least one managed device (a device whose inventory information 
is tracked by RME) to verify correct RME installation. To manage your network, 
you need to add the device information for all your managed devices.

You can add devices to RME either manually or automatically.

By default, devices are added to RME from Common Services’ Device and 
Credential Repository automatically.

If you have disabled the option Automatically Manage Devices from Credential 
Repository using RME > Admin > Device Mgmt > Device Management 
Settings, you have to follow the procedure as described below (step 1 through
step 3).

To populate your network inventory:

Step 1 Select RME > Devices > Device Management > RME Devices.

Step 2 Select the list of devices that you want RME to manage from the device credential 
repository.

Step 3 Click Add Devices.

The Device Management Status Summary dialog box appears.
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Step 4 Use the Device Management Status Summary dialog box to check the status of the 
device you specified. 

The dialog box should contain:

If the device responded quickly, the Managed row might already contain one 
device.

Step 5 Refresh the screen to update device status. 

If the pending count goes from 1 to 0 after you click Device Management and the 
Managed row has one device, RME was installed and configured correctly.

You might need to wait several minutes for the device to become managed. 

Step 6 Click Device Management on the Device Management Status Summary dialog 
box every minute or so to check current device status.

For additional information, see the Online help.

If you added a device and the Device Management Status Summary dialog box 
shows that the device status has not changed from Pending even after 15 minutes, 
check the status of all processes to make sure they are running normally.

• To view the latest device status information, select Resource Manager 
Essentials > Devices > Device Management.

Device State Number of Devices

Normal 0

Pending 1

Pre-deployed 0

Suspended 0

Alias 0

Conflicting 0

Total Number of Devices 1
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• To determine if the ICServer process is running, select Common services > 
Server > Admin > Processes. (The ICServer and Config Management are the 
processes responsible for validating devices and changing their status from 
Pending.)

Even if the ICServer process has the state Running Normally, it might be in 
an error state. You need to stop and restart it.

• To stop the ICServer process:

a. Select Common Services > Server > Admin > Processes. 

The Process Management dialog box appears.

b. Select the process.

c. Click Stop.

• To restart the ICServer process:

a. Select Common Services > Server > Admin > Processes. 

The Process Management dialog box appears.

b. Select ICServer from the list of processes 

c. Click Start.

The device status should change to Managed within a couple of minutes. 

Setting Up Syslog Analyzer
Syslog Analyzer lets you centrally log and track messages generated by devices. 
You can use the logged error message data to analyze device and network 
performance. You can customize Syslog Analyzer to produce the information and 
message reports that are important to your operation.

See the Online help for more information about Syslog Analyzer.

Setting up Syslog Analyzer involves:

• Configuring Devices for Syslog Analyzer

• Verifying the Syslog Collector
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Configuring Devices for Syslog Analyzer
Before you can use Syslog Analyzer, you must configure your devices to forward 
messages to RME or to a system on which you have installed the distributed 
Syslog Analyzer Collector. For more information about setting up devices for 
message logging, see the online help, the Cisco IOS software documentation on 
Cisco.com (for Cisco IOS devices), and the appropriate reference guides.

Configuring Cisco IOS Devices

To configure Cisco IOS devices:

Step 1 Use Telnet to access the device and log in. 

The prompt changes to host>.

Step 2 Enter enable.

Step 3 Enter the enable password. 

The prompt changes to host#.

Step 4 Enter configure terminal. 

You are now in configuration mode, and the prompt changes to host(config)#.

• To make sure logging is enabled, enter logging on.

• To specify the RME server to receive the router syslog messages, enter 
logging 123.45.67.89 (where 123.45.67.89 is the IP address of the 
CiscoWorks server). 

Step 5 Set the logging trap level by entering logging trap informational. 

Severity level informational means all alert and informational messages will be 
logged to the server. 

Step 6 Verify that Syslog is running:

a. From the CiscoWorks desktop, select Common Services > Server > 
Admin > Processes. 

The Process Management dialog box appears.
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b. Verify that the entry for Syslog Collector has the status, Running normally.

Also, verify the entry for status SyslogCollector, if you are directing syslogs to 
that server.

Step 7 Verify that the Syslog configuration file settings are correct. See the ““Verifying 
the Settings in the Syslog Configuration File” section on page 2-16 for 
instructions.

Configuring Catalyst Devices

To configure Catalyst devices:

Step 1 Use Telnet to access the device and log in. 

The prompt changes to host>.

Step 2 Enter enable and the enable password. 

The prompt changes to host(enable)

Step 3 To make sure logging is enabled, enter set logging server enable. 

Step 4 Enter set logging server 123.45.67.89 (where 123.45.67.89 is the IP address of 
the server) to specify the server that is to receive the Catalyst switch syslog 
messages. 

Step 5 Set the logging trap level by entering set logging all level 6 default. 

Severity level 6 means all messages from levels 0-6 (from alerts to notifications) 
will be logged to the server.

Step 6 Verify that Syslog is running. To do this:

a. From the CiscoWorks desktop, select Common Services > Server > 
Admin > Processes. 

The Process Management dialog box appears.

b. Verify that the entry for Syslog Analyzer has the status, Running normally.

Step 7 Verify that the Syslog configuration file settings are correct. See the “Verifying 
the Settings in the Syslog Configuration File” section on page 2-16 for 
instructions.
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Content Service Switches Devices

To configure Content Service Switches (CSS) devices using Telnet:

Step 1 Telnet to the device and enter into the Global Configuration mode. 

Step 2 Run the following commands: 

logging commands enable
logging host CiscoWorks IP address
logging facility local7

Content Engine Devices

To configure Content Engine (CE) devices using Telnet:

Step 1 Telnet to the device and enter into the Global Configuration mode. 

Step 2 Run the following commands: 

logging host CiscoWorks IP address
logging facility local7

NAM Devices

To configure NAM devices using Telnet:

Step 1 Telnet to the device and enter into the Global Configuration mode. 

Step 2 Run the following commands: 

remote-host CiscoWorks IP address
logging facility local7
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PIX Devices

To configure PIX devices using Telnet:

Step 1 Telnet to the device and enter into the Global Configuration mode. 

Step 2 Run the following commands: 

logging host CiscoWorks IP address [in_if_name] CiscoWorks IP address 
[protocol /port] [format emblem]

logging facility local7

where,

• in_if_name is the interface on which the syslog server resides.

• CiscoWorks IP address is the address of the CiscoWorks server.

• protocol is the protocol over which the syslog message is sent; either tcp or 
udp. PIX Firewall only sends TCP syslog messages to the PIX Firewall 
Syslog Server. 

You can only view the port and protocol values you previously entered by using 
the write terminal command and finding the command in the listing—the TCP 
protocol is listed as 6 and the UDP protocol is listed as 17. 

port is the port from which the PIX Firewall sends either UDP or TCP syslog 
messages. This must be same port at which the syslog server listens.

• For the UDP port, the default is 514 and the allowable range for changing the 
value is 1025 through 65535. 

• For the TCP port, the default is 1470, and the allowable range is 1025 through 
65535. TCP ports only work with the PIX Firewall Syslog Server.

format emblem is the option that enables EMBLEM format logging on a 
per-syslog-server basis. EMBLEM format logging is available for UDP syslog 
messages only and is disabled by default. 

Note For details on how to configure devices using the NetConfig Syslog task, refer to 
the Configuring the Device Using NetConfig Syslog Task section in the User 
Guide for Resource Manager Essentials 4.0. 
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Verifying the Settings in the Syslog Configuration File 
To check the path and permissions of the file pointed to by local7.info in the 
syslog configuration file /etc/syslog.conf on the server:

The first occurrence of local7 in the syslog.conf file, must contain the path for the 
Syslog message source.

Step 1 Make sure the facility.level definition is set to local7.info, and that the following 
line is present (note that there must be a tab between local7.info and the 
path/filename):

local7.info path/filename

where path/filename is the full path to a file.

Step 2 Make sure the syslog process (syslogd) can both read and write to the file. 

If you modified the /etc/syslog.conf file, you must restart the syslog process 
(syslogd). Enter the following command to stop and restart syslogd:

/etc/init.d/syslog start and /etc/init.d/syslog stop 

If the start and stop command does not work, enter:

kill -HUP ‘cat /etc/syslog.pid‘

Step 3 Make sure the Message Source in the CiscoWorks Server is the same as the 
filename you specified in the syslog.conf file. 

To check the path for the syslog.conf, look for the SYSLOG_FILES variable in 
the Collector.properties file available at the following location:

$NMSROOT/MDC/tomcat/webapps/rme/WEB-INF/classes/com/cisco/nm/rmeng/csc
/data.
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Verifying the Syslog Collector
To verify that the Syslog Collector is processing syslog messages from the 
network:

Step 1 Log in to a managed router that is configured to send Syslog messages to the 
server. You must have appropriate login privileges to make configuration changes.

Step 2 Make a nondestructive change to the router configuration. For example, to change 
the contents of the login banner enter:

# enable
# configure terminal

The prompt changes to #>.

#> banner motd /
This is a test /
#> end

Step 3 Wait approximately 2 minutes for the server to process the Syslog message

Step 4 Select RME > Reports > Report Generator.

The Report Generator dialog box appears.

Step 5 Select Syslog from the Select an Application drop-down menu.

Step 6 Select Standard Report from the Select a Report drop down menu.

The Standard Reports dialog box appears.

Step 7 Select the device for which you made a change. For more information, see the 
Online help.

Step 8 Click Finish.

The Syslog-Standard report appears.

Verify that the report contains the Syslog message that the configuration change 
generated.
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Setting Up Software Management
Cisco is constantly improving the quality and functionality of device software. As 
a network administrator, you need to know what versions are currently running on 
your devices, and you must be aware of new software versions available to 
identify when upgrades are needed. 

When software upgrades are required, you must plan for and manage the upgrade 
to minimize the disruption to the end users. The process of manually upgrading 
multiple devices on the network can be a very time-consuming and error-prone 
process. 

Software Management application performs system software upgrades, boot 
loader upgrades, and software configuration operations on groups of routers and 
switches. For more information about setting up Software Management, see the 
Online help.

Setting up Software Management involves the following:

• Verifying Space Requirements for Downloaded Files

• Setting Software Management Preferences

• Setting Up TFTP

• Setting Up rcp

• Allowing the User casuser to Use at and cron

Verifying Space Requirements for Downloaded Files
Software Management files downloaded to the server from the Cisco.com or the 
product CD-ROM are stored in the /var directory or its subdirectories. Make sure 
there is enough space in the /var directory for all files that you plan to download.

Before you can use Software Management, you must have sufficient space to store 
the software image files. You should have 4 to 20 MB of space for each IOS and 
Catalyst image. For, NAM and Content Engine images you must have 150 MB of 
space. 
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In addition, you need space for some smaller downloaded files and temporary 
files. To accommodate these needs, add at least 20% to the space needed for 
software image files for your final space calculation in the /var directory. 

Note The space for each image varies according to the device type. 

Setting Software Management Preferences
Software Management has many preferences you can set to control how the 
application behaves. To set preferences:

Step 1 Select RME > Admin > Software Mgmt > View/Edit Preferences.

The Edit Preferences dialog box appears.

Step 2 Change preferences as appropriate. For more information, see the Online help.

Step 3 After you complete the changes:

• Click Apply to save your changes.

• Click Defaults to display the default configuration.

Setting Up TFTP
A file transfer server must be installed on your system. You must enable a Trivial 
File Transfer Protocol (TFTP) server because it is the default file transfer server 
type.

During Software Management installation, if the installation tool cannot find a 
TFTP server, it tries to add one. If the installation tool cannot find or create a 
TFTP server, install and enable the TFTP server and verify that a /tftpboot 
directory exists, as explained in the following sections.
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Enabling the TFTP Daemon

If you are using standard Solaris software, you can add and configure the TFTP 
server (TFTPD).

Step 1 Log in as superuser.

Step 2 Using a text editor, edit the /etc/inetd.conf file. 

a. Look in the file /etc/inetd.conf for the line that invokes TFTPD. If the line 
begins with a pound sign (#), remove the pound sign with your text editor. 
Depending on your system, the line that invokes the TFTP server might look 
similar to: 

tftp dgram udp wait root /usr/sbin/in.tftpd in.tftpd -s /tftpboot

b. Save the changes to the edited file and exit your text editor. 

Step 3 At the UNIX prompt, enter the following command to display the process 
identification number for the inetd configuration: 

# /usr/bin/ps -ef | grep -v grep | grep inetd 

The system response is similar to:

root 119 1 0  12:56:14 ?  0:00 /usr/bin/inetd -s

The first number in the output (119) is the process identification number of the 
inetd configuration.

Step 4 To enable your system to read the edited /etc/inetd.conf file, enter: 

# kill -HUP 119

where 119 is the process identification number identified in Step 3.

Step 5 Verify that TFTP is enabled by entering either: 

# netstat -a

or 

# grep tftp

which should return output similar to:

*.tftp Idle
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or enter:

# /opt/CSCOpx/bin/mping -s tftp localhost_machine_name

which returns the number of modules sent and received, for example:

sent:5 recvd:5 . ..

If the output shows that zero modules were received, TFTP is not enabled. Repeat 
these steps, beginning with Step 1, to make sure you have enabled TFTP.

Creating the /tftpboot Directory

RME uses the /tftpboot directory when transferring files between the RME server 
and network devices. The files are removed after the transfer is complete, but 
multiple jobs (for example, image distribution, image import, or config file scan) 
could be running at the same time.

Each of these jobs requires its own space. Software image sizes, for example, can 
be up to 20 MB. To ensure that jobs run successfully, make sure there is sufficient 
space available in the /tftpboot directory.

If the /tftpboot directory does not exist on your system, you must create it:

Step 1 Enter:

# mkdir /tftpboot

Step 2 Make sure all users have read, write, and execute permissions to the /tftpboot 
directory by entering:

# chmod 777 /tftpboot

The /tftpboot directory now exists and has the correct permissions.
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Setting Up rcp
You can enable a remote copy (rcp) server on the server and select it as the active 
file transfer server. If you select rcp as the active server and then try to transfer 
files to a device that does not support rcp, RME uses TFTP to transfer the files.

Creating the rcp Remote User Account

To use rcp, you must create a user account on the system to act as the remote user 
to authenticate the rcp commands issued by devices. This user account must own 
an empty .rhosts file in its home directory to which the user casuser has write 
access.

You can choose the name of this user account because you can configure the RME 
server to use any user account. The default user account name is cwuser. The 
examples in this procedure use the default name cwuser. If you choose to use a 
different name, substitute that name for cwuser.

To create and configure the rcp remote user account, follow these steps while 
logged in as root:

Step 1 To add a user account named cwuser to the system, enter:

# useradd -m -c “user account to authenticate remote copy operations” 
\ cwuser

Step 2 Navigate to the cwuser home directory.

• To create the .rhosts file, enter:

# touch .rhosts

• To change the owner of the .rhosts file, enter:

# chown cwuser:casusers .rhosts

• To change the permissions of the .rhosts file, enter:

# chmod 0664 .rhosts
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• If you did not use the default user name cwuser, use the user account that you 
created as the rcp remote user account.

a. Log on to the server as admin.

b. From the CiscoWorks Homepage, select Common Services > Server > 
Admin > System Preferences. 

The System Preferences dialog box appears.

c. In the RCP User field, enter the name of the user account that you just created 
in the User Name field, then click Apply.

Enabling the rcp Daemon

To add and configure standard Solaris rcp server software:

Step 1 Log in as superuser. 

Step 2 Using a text editor, edit the /etc/inetd.conf file. 

a. Look in the file /etc/inetd.conf for the line that invokes rshd. If the line begins 
with a pound sign (#), remove the pound sign with a text editor. Depending 
on your system, the line that invokes the rshd server might look similar to:

shell stream tcp nowait root /usr/sbin/in.rshd in.rshd

b. Save the changes to the edited file and exit the text editor. 

Step 3 At the UNIX prompt, enter the following to display the process identification 
number for the inetd configuration: 

# /usr/bin/ps -ef | grep -v grep | grep inetd 

The system response is similar to: 

root 119 1 0  12:56:14 ?  0:00 /usr/bin/inetd -s

The first number in the output (119) is the process identification number of the 
inetd configuration.

Step 4 To enable your system to read the edited /etc/inetd.conf file, enter: 

# kill -HUP 119

where 119 is the process identification number identified in Step 3.
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Step 5 Verify that rshd is enabled by entering: 

# netstat -a | grep shell

which should return output similar to:

*.shell *.* 0 0 0 0 LISTEN

Selecting rcp as the Active File Transfer Method

If you have enabled rcp as the file transfer method, RME uses rcp to transfer 
device software images. For devices that do not support rcp, RME uses TFTP to 
transfer files.

You can disable rcp if you do not want RME to use it with any devices.

Step 1 Select RME > Admin > Software Mgmt > View/Edit Preferences.

Step 2 Set the protocol order so that RCP is the first protocol in the order.

Step 3 Click Apply.

Setting Up SCP
RME supports the Secure Copy (SCP) file transfer. It is a secure and authenticated 
method for copying router configuration or router image files. SCP relies on 
Secure Shell (SSH). 

RME uses rcp with devices that support rcp. For other devices, RME uses TFTP.

The devices that support SCP protocol are Cisco 7200 series, Cisco 7500 series, 
Cisco 12000 series, Cisco 1700 series, Cisco 2600 series, Cisco 3620, Cisco 3640, 
Cisco 3660.
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Using SCP For File Transfer

SCP is derived from rcp.

The following are the prerequisites for Secure Copy:

• Configure SSH, authentication, and authorization on the router. 

• Ensure the router has a Rivest, Shamir, and Adelman (RSA) key pair. SCP 
relies on SSH for its secure transport.

The behavior of SCP is similar to that of remote copy (rcp), except that SCP relies 
on SSH for security. In addition, SCP requires that authentication, authorization, 
and accounting (AAA) authorization be configured so the router can determine 
whether you have the correct privilege level. 

SCP allows anyone who has appropriate authorization to copy any file that exists 
in the Cisco IOS File System (IFS) to and from a router by using the copy 
command. An authorized administrator may also perform this action from a 
workstation. 

Prerequisites for Secure Copy 
• Before enabling SCP, you must correctly configure SSH, authentication, and 

authorization on the router. 

• Because SCP relies on SSH for its secure transport, the router must have an 
Rivest, Shamir, and Adelman (RSA) key pair. 

Information About Secure Copy 
To configure Secure Copy feature, you should understand the following concepts. 

• How SCP Works

• How to Configure SCP
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How SCP Works 

The behavior of SCP is similar to that of remote copy (rcp), which comes from 
the Berkeley r-tools suite, except that SCP relies on SSH for security. In addition, 
SCP requires that authentication, authorization, and accounting (AAA) 
authorization be configured so the router can determine whether the user has the 
correct privilege level. 

SCP allows a user who has appropriate authorization to copy any file that exists 
in the Cisco IOS File System (IFS) to and from a router by using the copy 
command. An authorized administrator may also perform this action from a 
workstation. 

How to Configure SCP 

This section contains the following procedures: 

• Configuring SCP

• Verifying SCP

• Troubleshooting SCP 

Configuring SCP 

To enable and configure a Cisco router for SCP server-side functionality, perform 
the following steps: 

Command Purpose

Step 1 enable

Example:

Router > enable 

Enables privileged EXEC mode.

Enter your password if prompted. 

Step 2 configure terminal 

Example: 

Router# configure terminal 

Enters global configuration mode. 
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Step 3 aaa new-model 

Example: 

Router (config)# aaa new-model 

Enables the AAA access control system. 

Step 4 aaa authentication login {default | 
list-name} method1 [method2...] 

Example: 

Router (config)# aaa authentication 
login default local

Sets AAA authentication at login. 

Step 5 aaa authentication enable {default | 
list-name} method1 [method2...] 

Example: 

Router (config)# aaa authentication 
enable default none

Sets AAA authentication at enable.

Step 6 aaa authorization {network | exec | 
commands level | reverse-access | 
configuration} {default | list-name} 
[method1 [method2...]] 

Example: 

Router (config)# aaa authorization 
exec default local 

Sets parameters that restrict user access to a 
network. 

Note The exec keyword runs authorization 
to determine if the user is allowed to 
run an EXEC shell; therefore, you 
must use it when you configure SCP. 

Command Purpose
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Verifying SCP 

To verify SCP server-side functionality, perform the following steps: 

Step 7 username name [privilege level] 
{password encryption-type 
encrypted-password} 

Example: 

Router (config)# username superuser 
privilege 15 password 0 superpassword 

Establishes a username-based authentication 
system. 

Note You may skip this step if a 
network-based authentication 
mechanism—such as TACACS+ or 
RADIUS—has been configured. 

Step 8 ip scp server enable 

Example: 

Router (config)# ip scp server enable 

Enables SCP server-side functionality. 

Command Purpose

Command or Action Purpose

Step 1 enable 

Example: 

Router> enable 

Enables privileged EXEC mode. 

Enter your password if prompted. 

Step 2 show running-config 

Example: 

Router# show running-config 

Verifies the SCP server-side functionality. 
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Troubleshooting SCP 

To troubleshoot SCP authentication problems, perform the following steps. 

Allowing the User casuser to Use at and cron
Software Management uses at and cron to schedule Software Management image 
transfers to devices. The process that performs the download is executed as 
casuser, so the user casuser must be allowed to use at and cron.

To allow the user casuser to use at:

• If an at.deny file exists in the /usr/lib/cron directory, make sure casuser is not 
listed in it. If necessary, remove casuser from the at.deny file using a text 
editor.

• If an at.allow file exists in the /usr/lib/cron directory, make sure casuser is 
listed in it. If necessary, add casuser to the at.allow file, using a text editor.

• If neither an at.allow nor an at.deny file exist in the directory /usr/lib/cron, 
create an at.allow file and add casuser to it, using a text editor.

Command or Action Purpose 

Step 1 enable 

Example: 

Router> enable 

Enables privileged EXEC mode. 

Enter your password if prompted. 

Step 2 debug ip scp 

Example: 

Router# debug ip scp 

Troubleshoots SCP authentication problems.
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To allow the user casuser to use cron:

• If a cron.deny file exists in the /usr/lib/cron directory, make sure casuser is 
not listed in it. If necessary, remove casuser from the cron.deny file, using a 
text editor.

• If a cron.allow file exists in the /usr/lib/cron directory, make sure casuser is 
listed in it. If necessary, add casuser to the cron.allow file, using a text editor.

• If neither a cron.allow nor a cron.deny file exists in the /usr/lib/cron directory, 
create a cron.allow file and add casuser to it, using a text editor.

Setting Up Configuration Management
One of the most difficult but most important things to manage on network devices 
is the device configuration. Often a change to the device configuration leads to 
network performance issues and faults. The device configuration is the key to how 
a device operates on the network and traffic is passed. 

As the network administrator, you need to be able to control and track changes to 
device configurations in order to minimize errors and assist in troubleshooting 
problems. 

This can be very difficult if several people are making changes to the device 
configurations. It can also become very repetitive and time-consuming to make 
the same update to each individual device on the network. Configuration 
Management application can help simplify and automate these tasks.

Before Configuration Management can gather device configurations, you need to 
update the RME database with passwords (credentials) and modify device 
configurations.

Note rcp and SSH are required only if you wish to use them.

Modifying Device Configurations
You need to modify your device configurations so that Configuration 
Management can gather the configurations. After you perform the following 
procedures and your devices become managed, the configuration files are 
collected and stored in the configuration archive.
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Ensuring Devices are rcp-enabled

Make sure the devices are rcp-enabled by logging into each device and entering 
the following commands in the device configurations:

# ip rcmd rcp-enable
# ip rcmd remote-host local_username 123.45.678.90 remote_username 
enable

where 123.45.678.90 is the IP address or hostname of the system on which RME 
is installed. The default remote_username and local_username are casuser.

Ensuring Devices are SSH-enabled

Make sure the devices are SSH-enabled by logging into each device and entering 
the commands for the following kinds of devices:

• For Catalyst Switches Running Cat OS

• For Cisco IOS Routers

For Catalyst Switches Running Cat OS

To enable SSH on Catalyst switches:

Step 1 Generate an RSA key, by entering:

sec-cat6000> (enable) set crypto key rsa 1024

A message similar to the following appears:

Generating RSA keys..... [OK]

Step 2 Verify the RSA key, by entering:

sec-cat6000> (enable) ssh_key_process: host/server key size: 1024/768

Step 3 Display the RSA key, by entering:

sec-cat6000> (enable) show crypto key
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A message similar to the following appears:

RSA keys were generated at: Mon Jul 23 2001, 15:03:30 1024 65537 
1514414695360
5773328536717047857098506066347687468697169639403524406206785753387015
50888525
6996914783305378400669569876102078109594986481799653300180108447858634
72773067
6971852564183862430018810088305612411373816928200786743760582755731334
48529332
1996682019301329470978268059063378215479385405498193061651

Step 4 Specify the host or subnets which are allowed to use SSH to communicate with 
the switch. 

For example, to specify that the IP addresses 172.18.124.0 and 255.255.255.0 
be allowed to use SSH, enter:

If you do not perform this step, the switch will display the following error:
WARNING!! IP permit list has no entries!

sec-cat6000> set ip permit 172.18.124.0 255.255.255.0

A message similar to the following appears:

172.18.124.0 with mask 255.255.255.0 added to IP permit list.

Step 5 To enable SSH, enter:

sec-cat6000> (enable) set ip permit enable ssh

A message similar to the following appears:

SSH permit list enabled.
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Step 6 Verify the SSH permit list, by entering:

sec-cat6000> (enable) sho ip permit

A message similar to the following appears:

Telnet permit list disabled.
Ssh permit list enabled.
Snmp permit list disabled.
Permit List Mask Access-Type
---------------- ---------------- -------------
172.18.124.0 255.255.255.0 telnet ssh snmp

Denied IP Address Last Accessed Time Type
----------------- ------------------ ------

For Cisco IOS Routers

To enable SSH on Cisco IOS Routers:

For example, if you want router1 to act as an SSH client to the another router, you 
can add SSH to a second router, say router2. The routers will then be in a 
client-server arrangement, with router1 acting as the server and router2 acting as 
the client. 

The IOS SSH client configuration on router2 is the same as required for the SSH 
server configuration on router1.

Step 1 Configure the hostname for router1, by entering:

hostname router1

A message similar to the following appears:

username username password 0 password
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Step 2 Configure the DNS domain on router1, by entering:

ip domain-name domain-name

Step 3 Generate the SSH key to be used, by entering:

cry key generate rsa

A message similar to the following appears:

ip ssh time-out 60
ip ssh authentication-retries 2

Step 4 Enable SSH transport support for vtys:

By default, vtys transport is through Telnet. In this case, Telnet has been disabled 
and only SSH is supported.

line vty 0 4
transport input SSH

Configuring Devices for Syslog Analyzer

Configure your devices for Syslog Analyzer if you want the device configurations 
to be gathered and stored automatically in the configuration archive when syslog 
messages are received. See the “Setting Up Syslog Analyzer” section on 
page 2-11 or refer to the online help for more information.

Modifying Device Security
Configuration Management must be able to run certain commands on devices to 
archive their configurations. You must disable the security on devices that 
prevents Configuration Management from running the commands shown in 
Table 2-4.
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Setting Up NetConfig
The NetConfig function provides wizard-based templates to simplify and reduce 
the time it takes to roll out global changes to network devices. These templates 
can be used to execute one or more configuration commands on multiple devices 
at the same time. 

For example, if you want to change passwords on a regular basis to increase 
security on devices, you can use the appropriate password template to update 
passwords on all devices at once. A copy of all updated configurations will be 
stored in the configuration archive.

This section describes how to set up NetConfig. This involves:

• Verifying Device Configurations

• Modifying Device Security

• Verify Device Prompts

• Transport Settings Setup

Table 2-4 Required Configuration Management Commands 

Command Type Command Description

Catalyst commands set len 0 Turns paging off for the Telnet 
session.

write term Gets the running configuration.

IOS commands term len 0 Turns paging off for the Telnet 
session.

show run Gets the running configuration.

show config Gets the startup configuration.
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Verifying Device Configurations

NetConfig can configure devices that do not have archived configurations. 
However, rollback command generation may be faulty if the archived 
configuration is not present. Use the Configuration Archival Summary to:

• Verify that devices you want to configure have an archived configuration.

• Troubleshoot the devices that do not have an archived configuration.

To verify configuration archive status:

Step 1 Select RME > Config Mgmt > Archive Mgmt. 

The Configuration Archival Summary dialog box appears with the archival status.

Step 2 Click on a device status to view details:

• Click Successful to display information on archived configurations. 

• Click Failed to display information on configurations that could not be 
obtained. To update the archive for failed devices.

• Click Partially Successful to display the Catalyst 5000 devices whose 
submodules were not pulled into the archive.

Step 3 Click Sync Archive.

For more information, see the Configuration Management Online help

Modifying Device Security

In addition to running the configuration commands that you assign to each job, 
NetConfig must be able to run certain commands on devices to configure them. 
You must disable the security on devices that prevents NetConfig from running 
the commands listed in Table 2-5.
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Verify Device Prompts

NetConfig requires particular CLI prompt formats:

If the Telnet transport mechanism is used, the following prompts are applicable.

• For IOS-based devices, Content Engine devices, and Content Service Switch 
devices:

– The login prompt must end with a greater-than symbol (>).

– The enable prompt must end with a pound sign (#).

• For Catalyst devices:

– The login prompt must end with a greater-than symbol (>).

– The enable prompt must end with the text (enable).

Table 2-5 Required NetConfig Commands 

Command Type Command Description

IOS Commands term len 0 Turns paging off for Telnet session

write term Gets running configuration

show config Gets startup configuration

write mem Writes running configuration to startup configuration

config t Enters config mode

exit Exits config mode

Catalyst Commands set len 0 Turns paging off for Telnet session

write term Gets running configuration

Content Service Switch 
Commands

no terminal more Disables support for more functions with the terminal.

show 
running-config

Gets all components of the running configuration.

show startup-config Gets the CSS startup configuration (startup-config).

Content Engine Commands term len 0 Turns paging off for Telnet session.

show run Gets running configuration.

show config Gets startup configuration.
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If the secure shell (SSH) transport mechanism is used, the following prompts are 
applicable.

• For IOS-based devices, Content Engine devices, and Content Service Switch 
devices:

– The login prompt may end with any one of the following: (>), (#), 
(:), (%).

– The login prompt may end with any one of the following: (>), (#), (:), 
enable prompt must end with a pound sign (#).

• For Catalyst devices:

– The login prompt may end with any one of the following: (>), (#), (:), 
(%).

– The enable prompt must end with the text (enable).

Default prompts use this formatting. If you have changed your defaults, verify that 
the prompts meet these requirements, and change them if they do not.

Transport Settings Setup

Transport Settings Setup Window allows you to setup:

• Transport Protocol Order for NetConfig, Archive Management and Config 
Editor Jobs 

• Password Policy for NetConfig, Archive Management and Config Editor Jobs

Transport Protocol Order for NetConfig, Archive Management and Config Editor Jobs

You can set the protocol order for NetConfig, Config Editor and Config Archive 
Jobs to download configurations and for NetConfig and Config Editor to fetch 
configurations.

This setup provides the flexibility of using your preferred protocol order for 
fetching and downloading the configuration.

Step 1 Select Resource Manager Essentials > Admin > Config Mgmt

The Transport Settings page appears. 

Step 2 Select the Application Name from the drop down menu.
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Step 3 Select a protocol from the Available Protocols pane and click Add. Then do the 
following:

If you want to remove a protocol or change the protocol order, you can remove the 
protocol using the Remove button and re-add the protocol, again. 

The list of protocols that you have selected appears in the Selected Protocol Order 
pane.

If a configuration fetch or update operation fails, an error message appears. This 
message gives details only about the supported protocol for the particular device. 

For the list of supported protocols, see Supported Device Table for Configuration 
Management application on Cisco.com. 

Step 4 Click Apply. 

A confirmation message appears.

Step 5 Click OK.

For more information, see Configuring Transport Protocols online help.

Password Policy for NetConfig, Archive Management and Config Editor Jobs 

You have the option of entering your user name and password for job execution. 

• If you enter your username and password, RME ignores the username and 
password in the database and uses the newly entered username and password, 
instead. 

• If you do not enter your username and password, RME uses the username and 
password in its database.

This option of entering the username and password for job execution helps in high 
security installations where device passwords are changed at frequent intervals. 
In such instances, the passwords may be changed every 60-90 seconds.

Step 1 Select RME > Admin > Config Mgmt > Config Job Policies. 

The Config Job Policies dialog box appears.

Step 2 Select Enable Job Password check box.
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Step 3 Click Apply. 

A confirmation message appears.

Step 4 Click OK.

For more information, see the Configuring Default Job Policies online help.

Logging Out 
To end your administrator tasks, you must log out of CiscoWorks.

Step 1 Close all secondary browser windows. You should have only one browser window 
opened, displaying the CiscoWorks interface.

Step 2 Click Logout.

The Login Manager dialog box replaces the CiscoWorks homepage.
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Licensing

This chapter provides Licensing information for Resource Manager 
Essentials 4.0. This appendix contains these sections:

• Licensing Overview

• Licensing for a Fresh Installation

• Registering Your License

Licensing Overview
To install this application you must have a registered and a licensed copy of 
RME 4.0. You can select either of these two versions of the RME license:

• Enterprise Restricted: Allows you to manage upto 300 devices.

• Large Enterprise Unrestricted: There is no limit on the number of managed 
devices.

The installation script prompts for the first application that you install on 
Common Services 3.0 to enter licensing information. 

Table 3-1 describes PAK, PIN, License file and their usage:
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Table 3-1 Understanding PAK, PIN and License file

Field Description

Product 
Identification 
Number (PIN)

The PIN is printed on the software claim certificate. The RME installation 
program prompts you to enter the PIN during installation. 

If you cannot get an authenticated license during installation, use the PIN to 
proceed with the installation.

If you enter only a PIN, RME will run normally, but you will be periodically 
reminded to complete the licensing process.

Product 
Authorization Key 
(PAK)

The PAK is printed on the software claim certificate. Use the PAK to get your 
license file from Cisco.com. 

PAK is used to register RME 4.0 on Cisco.com. You may obtain and install your 
license file at any time while you are working on RME, not necessarily when 
you install the product.

We recommend that you complete the RME license registration and receive the 
product license before installing RME 4.0.

If the person installing RME is not authorized to obtain the license on behalf of 
the administrator, the product can be successfully installed for a period of time 
using only the PIN. In this case, the product will automatically remind the 
administrator to complete the licensing process.

License file When you register your RME purchase on the product licensing area of 
Cisco.com, you will receive a license file. You must provide your PAK to 
receive a license file. 

If you are a registered user of Cisco.com, get your license file from:

http://www.cisco.com/go/license

If you are not a registered user of Cisco.com, use this site to get your license 
file:

http://www.cisco.com/go/license/public

When you log into Cisco.com, it allows your Cisco user profile information to 
auto-populate many of the product registration fields. Login is case sensitive.
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Licensing for a Fresh Installation
When you install RME 4.0 over CiscoWorks Common Services 3.0, the installer 
checks whether the system already has the PIN, PAK and license file details. 

These details are available if the information was provided earlier using another 
CiscoWorks application such as, DFM, IPM and so on.

During RME 4.0 installation, if PIN, PAK and licence details are not available in 
the system, the installer prompts you enter the licence file location.

For details see, “Registering Your License” section on page 3-3. 

Registering Your License 
We recommend that before you install RME, you must register the product and 
receive a permanent license.

To license RME, you must:

Step 1 Register RME using the PAK with Cisco.com to get your license file.

The PAK is printed on the software claim certificate. 

• If you are a registered user of Cisco.com, get your license file from:
http://www.cisco.com/go/license

• If you are not a registered user of Cisco.com, use this site to get your license 
file: http://www.cisco.com/go/license/public

When you log into Cisco.com, it allows your Cisco user profile information 
to auto-populate many of the product registration fields. Login is case 
sensitive.

Step 2 After you install Common Services 3.0, copy the new license file to the 
CiscoWorks Common Services server into a directory. This directory must have 
read permissions for the user name casuser or the user group casusers.
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Step 3 Install the license file.

• If you have got the RME license before installation, select L for License File 
after you accept the Licensing Agreement and continue installing RME.

• If you have completed RME installation by entering the PAK and PIN, or if 
you want to convert an evaluation copy to a licensed copy:

a. From the CiscoWorks Homepage, select Common Services > Server > 
Admin > Licensing. 

The License Administration page appears.

b. Click Update. 

A file browser dialog box appears.

c. Enter the path to the new license file in the License field, or click Browse to 
locate the license file you copied to the server in step 2.

d. Click OK.

The system verifies whether the license file is valid, and updates the license. 

The updated licensing information appears in the License Information page. If 
you encounter errors, repeat all of the steps.

Upgrading Your Evaluation License
For an evaluation copy of Resource Manager Essentials 4.0, licensing details are 
not required. Select E for Evaluation copy after you accept the Licensing 
Agreement to get an evaluation copy of RME 4.0.

If you choose to run RME in evaluation mode, RME will not function after 90 
days. The evaluation period cannot be extended.

If you have a purchased copy and you decide to install it in evaluation mode, 
please use your PAK to register the product on the Cisco online licensing site to 
receive a valid license.

If you have not purchased the product, you can reactivate the CiscoWorks 
evaluation server by purchasing the product from your authorized Cisco reseller. 
License the product using the PAK and PIN provided with the product. 

For details see, “Registering Your License” section on page 3-3.
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Validating Your Upgrade License
Proof of Purchase (POP) is required to validate an upgrade license of RME 4.0. If 
you purchased an upgrade license, at the end of the RME installation, you are 
prompted to run a CLI script to validate the upgrade license.

This script prompts you to do either of these: 

• Insert the original CD containing RME 3.4 or RME 3.5. 

• Enter the login information for a remote server where the earlier version of 
RME is running. 

To run the script, see “Validating the Upgrade” section on page 1-20

If you do not run the script or if upgrade validation fails, RME is licensed for 
evaluation only and operates in nag mode for only 90 days. After that period RME 
stops running. See “Upgrading Your Evaluation License” section on page 3-4. 

Licensing Reminders
RME 4.0 displays licensing reminders in the following circumstances:

• Evaluation Version—Before Expiry

• Purchased Version—No License File

• Device Limit—Approaching the Actual Limit

• Device Limit—Number of Devices Exceeded

Evaluation Version—Before Expiry
If you have installed the evaluation version of RME, you must obtain the license 
file from Cisco.com before the evaluation license expires.

During the evaluation period, RME will remind to purchase a licence. The 
reminder will appear from the first day. 
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Ten days before the evaluation license expires, you are prompted with a message 
that the evaluation licence is about to expire. The prompted message is,

This software is provided for evaluation purposes only and will expire 
in number of days. If this is not an evaluation copy, click this link 
for information about obtaining a valid purchase license or click here 
for current licensing information. Otherwise, please contact your 
Cisco representative for purchasing information.

Where number of days is the total number of days available before the license 
expire.

If you fail to upgrade your evaluation license, all RME process will run but access 
to RME functionality will be denied. After license expiry, this message is 
prompted,

This software is provided for evaluation purposes only and had 
expired. If this is not an evaluation copy, click this link for 
information about obtaining a valid purchase license or click here for 
current licensing information. Otherwise, please contact your Cisco 
representative for purchasing information.

Purchased Version—No License File
If you have installed a purchased version of RME, you must register RME using 
the PAK number. 

For details see,“Registering Your License” section on page 3-3.

You must register RME within 90 days of installation. If you fail to register RME, 
a message appears from the first day, prompting you to register it. 
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RME 4.0 is fully functional. However, you will be prompted with a message 
reminding you to register RME:

This software is provided for evaluation purposes only and will be 
operational for 90 days. If this is not an evaluation copy, click this 
link for information about obtaining a valid purchase license or click 
here for current licensing information. Otherwise, please contact your 
Cisco representative for purchasing information.

Register your license to avoid these messages.

Device Limit—Approaching the Actual Limit
While you add devices to RME, if you are approaching the actual device limit, this 
message appears:

Total devices approaching the actual limit. Devices selected will be 
added to RME. Click on Pending Devices to verify the progress.

Contact your Cisco representative to determine if additional licenses can be 
purchased for this server.

Device Limit—Number of Devices Exceeded
While you add devices to RME, you are allowed to exceed the device limit either 
by 10% of your existing limit or by 100 devices (whichever is less).

For instance, if you have a license for 5000 devices, you are allowed to manage 
upto 5100 devices only. This is because 10% of 5000 devices is 500 devices which 
is greater than 100 devices. After reaching this limit (5100), you cannot add 
another device into RME. When you try to add another device, RME displays a 
warning message,

Total devices crossed the actual limit. Devices selected will be added 
to RME.Click on Pending Devices to verify the progress.

During migration, if you have RME 3.5, managing 400 devices and have upgraded 
to RME 4.0, but purchased a license for 300 devices, all 400 devices are managed 
in RME 4.0. However, you cannot add a new device or delete and add the device 
once again to RME.
3-7
Installation and Setup Guide for Resource Manager Essentials 4.0 on Solaris

78-16504-01



 

Chapter 3      Licensing
Licensing Reminders
Similarly, when you run a backup of a Unrestricted licensed server (for example, 
with 1000 devices) and try to restore the backed-up data on another server with 
Enterprise Restricted device limit (for example, with 300 devices), all device data 
is restored. 

If you have exceeded the device limit, you will be prompted with a message, 
reminding you to apply for an additional licence,

This software has a RESTRICTED license for managing a limited number 
of devices. Click here for current licensing information. Please 
contact your Cisco representative to determine if additional licenses 
can be purchased for this server.
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Installing the Remote Syslog Collector

This chapter provides general information on how to install the Remote Syslog 
Collector (RSC) on a remote Windows system to process syslog messages. If 
necessary, it can also filter the Syslog messages before forwarding them to the 
Analyzer process on the RME server. If you do not want to run it on the remote 
UNIX or Windows system, you can uninstall the Remote Syslog Collector later.

Note Do not install Remote Syslog Collector on a system that has CiscoWorks and 
Resource Manager Essentials already installed.

The Remote Syslog Collector and Syslog Analyzer Service on the RME server 
uses SSL sockets to communicate with each other. 

It functions as follows:

1. At startup, the Remote Syslog Collector looks for Syslog Analyzers already 
subscribed on the RME Server and requests for the latest filter definitions. 

• If the Syslog Analyzer is not reachable when queried, the Remote Syslog 
Collector logs all emblem compliant syslogs in the specified downtime file 
after filtering. This file can be configured at: 

The Syslog Collector Properties file is available at this location:

On Solaris:

$NMSROOT/MDC/tomcat/webapps/rme/WEB-INF/classes/com/cisco/nm/r
meng/csc/data/Collector.properties
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On Windows:

%NMSROOT%\MDC\tomcat\webapps\rme\WEB-INF\classes\com\cisco\nm
\rmeng\csc\data\Collector.properties

• If the Syslog Analyzer responds with the latest filters, the Remote Syslog 
Collector forwards only the filtered syslogs to the Syslog Analyzer.

2. At startup, the Syslog Analyzer tries to connect to all the subscribed Remote 
Syslog Collectors by passing the latest filters. 

To subscribe or unsubscribe from a Remote Syslog Collector, select RME > 
Tools > Syslog > Syslog Collector Status > Subscribe using the RME user 
interface.

After the Remote Syslog Collector and Syslog Analyzer connect to the RME 
Server, the Remote Syslog Collector entry is added to the Collector Status 
window of the Syslog Analyzer. 

To view the status of the Common Syslog Collector to which the Syslog Collector 
is subscribed to, select Resource Manager Essentials > Tools > Syslog > Syslog 
Collector Status.

The connection to the RME server is lost, when the connection between the 
Remote Syslog Collector and Syslog Analyzer is broken. 

This may be because either the Remote Syslog Collector, or the Syslog Analyzer, 
or both of them were shutdown. The connection is automatically restored when 
both the services are functional.

This section describes how to set up Syslog. This involves:

• Verifying RSC Server Requirement

• Installing the Remote Syslog Collector

• Starting the Remote Syslog Collector

• Stopping the Remote Syslog Collector

• Uninstalling the Remote Syslog Collector
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Verifying RSC Server Requirement
Table 4-1 provides the server requirements for RSC:

Note RSAC 3.x does not work with RME 4.0.
RME 3.x does not work with the new Remote Syslog Collector (RSC) 4.0. 
You cannot upgrade RSAC 3.x to RSC 4.0. 
You must uninstall the previous version of RSAC before installing the new 
RSC 4.0 which is provided with RME 4.0. To install RSC 4.0, see “Installing the 
Remote Syslog Collector”.

Installing the Remote Syslog Collector
Prerequisites for installing a Remote Syslog Collector:

• Common Services 3.0 should be installed.

Table 4-1 RSC Server Minimum Requirements

Requirement Type Minimum Requirements

Hardware Sun Sparc Ultra 10

Memory (RAM) 512 MB

Available disk drive space • 2 GB on the partition on which you install RSC (the default is 
/opt).

• Swap space equal to double the amount of memory (RAM). For 
example, if your system has 512 MB of RAM, you need 1024 MB 
of swap space.

Software Solaris 2.8 and 2.9

Browser

(You need a browser only if 
you download the RSC 
installation files from the 
Essentials server.)

• Netscape Navigator 7.0 (if you are using the desktop on the server 
system).

• Mozilla 1.7
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• RME should not be installed on the server where the Remote Syslog Collector 
is to be installed. (If RME is installed, the Syslog Collector is installed by 
default)

To install the Remote Syslog Collector:

Step 1 Mount the RME 4.0 CD-ROM. See Appendix B, “Mounting and Unmounting the 
CD-ROM,” for detailed mounting instructions.

The RSC installables are available in the RSC directory on RME 4.0 CD-ROM.

Step 2 To start the installation, enter:

# cd RSC
# ./setup.sh

Step 3 Follow the wizard instructions to install the product.

After Installation, you need to configure the collector.properties file if required. 
If not, you can use the defaults. See “Understanding the Syslog Collector 
Properties File”.

Subscribing to a Common Syslog Collector

Step 1 Download the Peer certificate from the system where Remote Syslog Collector is 
running.

Step 2 Upload the Peer certificate to the system where Remote Syslog Collector is 
running.

Step 3 Select Resource Manager Essentials > Tools > Syslog > Syslog Collector 
Status.
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The Collector Status dialog box appears with this information:

Step 4 Click Subscribe.

The Subscribe Collector dialog box appears.

Step 5 Enter the address of the Common Syslog Collector to which you want to subscribe 
to.

Step 6 Click OK.

The Syslog Analyzer is subscribed the Syslog Collector that you specified. This 
can be either the Syslog Collector on the RME server, or a remotely installed 
Syslog Collector.

Starting the Remote Syslog Collector
To start the Remote Syslog Collector, enter pdexec SyslogCollector at the 
command prompt on the system where Syslog Collector is installed. 

Column Description

Name Hostname or the IP address of the host on which the Collector is installed.

Update Time Date and time of the last update. By default, this dialog box is updated every 5 
minutes.

Time and time zone are those of the CiscoWorks Server.

Uptime Time duration for which the Syslog Collector has been up.

Forwarded Number of forwarded Syslog messages.

Dropped Number of unsent Syslog messages.

Invalid Number of invalid Syslog messages.

Filtered Number of filtered messages. Filters are defined with the Define Message Filter 
option (For details about defining filters, see the User Guide for Resource Manager 
Essentials).

Received Number of Syslog messages received.
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Stopping the Remote Syslog Collector
To stop the Remote Syslog Collector, enter pdterm SyslogCollector at the 
command prompt on the system where Syslog Collector is installed. 
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Understanding the Syslog Collector Properties File
Uninstalling the Remote Syslog Collector

Step 1 Enter these commands as root to start the uninstall program:

# cd /
# $NMSROOT/bin/uninstall.sh

A message similar to the following appears at command prompt:

1) CiscoView 6.1
2) Integration Utility 1.6
3) CiscoWorks Common Services 3.0
4) Resource Manager Essentials 4.0
5) Remote Syslog Collector
6) All of the above

Select one or more of the items using its number separated by comma or 
enter q to quit [q]

Step 2 Enter 1, 2, 3, 4, 5 or 6 and press Return. 

Step 3 Follow the prompts from the uninstallation wizard.

Understanding the Syslog Collector Properties File
After installing the Syslog Collector on a remote system, you need to check the 
Syslog Collector Properties file to ensure that the Collector is configured 
properly.

The Syslog Collector Properties file is available at this location:

On Solaris:

$NMSROOT/MDC/tomcat/webapps/rme/WEB-INF/classes/com/cisco/nm/rmeng
/csc/data/Collector.properties

On Windows:

%NMSROOT%\MDC\tomcat\webapps\rme\WEB-INF\classes\com\cisco\nm\rm
eng\csc\data\Collector.properties
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Understanding the Syslog Collector Properties File
The following table describes the Syslog Collector Properties file:

Timezone-Related Properties Description

TIMEZONE The timezone of the system where the Syslog Collector is running. 
Enter the correct abbreviation for the timezone. For example, the 
time zone for India is IST.

For the correct Timezone abbreviation, see the Timezone file in the 
following location:

$NMSROOT/MDC/tomcat/webapps/rme/WEB-INF/classes/com/ci
sco/nm/rmeng/fcss/data/TimeZone.lst

COUNTRY_CODE Country code for the Syslog Collector.

We recommend that you set the country code variable with the 
appropriate country code, to make sure that the Syslog timestamp 
conversion works correctly.

For example, if you are in Singapore, you must set the country code 
variable as COUNTRY=SGP.

TIMEZONE_FILE The path of the Timezone file. This file contains the offsets for the 
time zones. 

After installing the Syslog Collector, ensure that the offset specified 
in this file is as expected. If it is not present or is incorrect, you can 
add the Timezone offset as per the convention.

The default path is:

$NMSROOT/MDC/tomcat/webapps/rme/WEB-INF/classes/com/ci
sco/nm/rmeng/fcss/data/TimeZone.lst

General Properties

SYSLOG_FILES Filename and location of the file from which syslog messages 
are read. 

The default location is:

On Solaris:

/var/log/syslog_info

On Windows:

$NMSROOT/log/syslog.log
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DEBUG_CATEGORY_NAME Name Syslog Collector uses for printed ERROR or DEBUG 
messages. 

The default category name is SyslogCollector.

We recommend that you do not change the default value.

DEBUG_FILE Filename and location of the Syslog Collector log file containing 
debug information:

The default location is:

On Solaris,

/var/adm/CSCOpx/log/CollectorDebug.log

On Windows,

$NMSROOT/log/CollectorDebug.log

DEBUG_LEVEL Debug levels in which you run the Syslog Collector.

We recommend that you retain the default INFO, which reports 
informational messages. Setting it to any other value might result in 
a large number of debug messages being reported. 

If you change the debug level, you must restart the Syslog Collector.

The values for the Debug levels are: 

• Warning

• Debug

• Error

• Info

DEBUG_MAX_FILE_SIZE The maximum size of the log file containing the debug information.

The default is set to 5 MB.

If the file size exceeds the limit that you have set, Syslog Collector 
writes to another file, based on the number of backup files that you 
have specified for the DEBUG_MAX_BACKUPS property.

For example, if you have specified the number of backups as 2, 
besides the current log file, there will be two backup files, each 
5MB in size. When the current file exceeds the 5 MB limit, Syslog 
Collector overwrites the oldest of the two backup files. 

Timezone-Related Properties Description
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DEBUG_MAX_BACKUPS The number of backup files that you require. The size of these will 
be the value that you have specified for the 
DEBUG_MAX_FILE_SIZE property.

Miscellaneous Properties

READ_INTERVAL_IN_SECS The interval at which the Collector polls the syslog file.

The default is set to 1 second.

QUEUE_CAPACITY The size of the internal buffer, for queuing syslog messages.

The default is set to 100000

PARSER_FILE The file that contains the list of parsers used while parsing syslog 
messages.

The default path of the parser file:

$NMSROOT/MDC/tomcat/webapps/rme/WEB-INF/classes/com/ci
sco/nm/rmeng/fcss/data/FormatParsers.lst

SUBSCRIPTION_DATA_FILE The Syslog Collector data file that contains the information about 
the Syslog Analyzers that are subscribed to the Collector.

The default path of the data file:

$NMSROOT/MDC/tomcat/webapps/rme/WEB-INF/classes/com/ci
sco/nm/rmeng/csc/data/Subscribers.dat

FILTER_THREADS The number of threads that operate at a time for filtering syslog 
messages. The default is set to 1.

COLLECTOR_PORT The default port of the Syslog Collector. The default is set to 4444.

The port where the collector listens for registration requests from 
Syslog Analyzers.

Timezone-Related Properties Description
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Configuring RME with Cisco Secure 
ACS

This chapter describes how RME is configured with Cisco Secure ACS:

• CiscoWorks Login Module

• CiscoWorks Server Authentication Roles

• Integration Notes

• Configuring RME on Cisco Secure ACS

• Verifying the RME and the Cisco Secure ACS Configuration

CiscoWorks Login Module
The CiscoWorks Server provides the mechanism used to authenticate users for 
CiscoWorks applications. CiscoWorks Common Services supports two modes of 
user authentication and authorization:

• ACS—In this mode authentication and authorization services are provided by 
an Access Control Server. To use this mode, you must have a Cisco Secure 
ACS (Access Control Server) installed on your network. 

The supported Cisco Secure ACS for Windows are:

– Cisco Secure ACS 3.2

– Cisco Secure ACS 3.2.3

– Cisco Secure ACS 3.3.2
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CiscoWorks Server Authentication Roles
• Non ACS—In this mode authentication and authorization services are 
provided by CiscoWorks Server. 

Fallback option in ACS mode is different from non-ACS mode. Here, fallback is 
provided only for authentication. 

• If the user authentication with ACS fails, the authentication is tried with 
CiscoWorks local mode. 

• If it succeeds, the user is allowed to change the login module to non-ACS 
mode, provided the user has permission to do that operation in non-ACS 
mode. 

For more information, see User Guide for CiscoWorks Common Services 3.0 and 
CiscoWorks Common Services 3.0 Online Help.

CiscoWorks Server Authentication Roles
By default, the CiscoWorks server authentication provides five roles in the ACS 
mode. They are listed here from least privileged to most privileged:

1. Help Desk—User with this role has the privileges to access network status 
information from the persisted data. User does not have the privilege to 
contact any device or schedule a job that will reach the network.

For example: Inventory data, configuration archives, reports, Syslog 
messages, jobs status, etc.

2. Approver—User with this role has the privileges to approve all RME tasks. 

3. Network Operator—User with this role has the privileges to perform all tasks 
that involve collecting data from the network. User does not have write access 
on the network. User can also perform all the Help Desk tasks.

For example: Scheduling jobs for inventory, configuration collection, etc.

4. Network Administrator—User with this role has the privilege to change the 
network. User can also perform the Network Operator tasks.

For example: Software Management tasks such as image distribution, 
NetConfig tasks such as changing the device passwords, configuration 
downloads etc. 
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5. System Administrator—User with this role has privilege to perform all 
CiscoWorks system administration tasks. See Permissions Report on 
CiscoWorks server (Common Services > Server > Reports > Permission 
Report).

For example: Changing the RME Administration setting, defining the purge 
policy, etc.

We recommend that you do not modify the default CiscoWorks roles. 

You can create your own custom roles on Cisco Secure ACS. See User Guide for 
CiscoWorks Common Services 3.0 and CiscoWorks Common Services 3.0 Online 
Help for further details.

Integration Notes
This section contains notes that you should read before you begin Cisco Secure 
ACS and CiscoWorks server integration:

• We recommend that you integrate CiscoWorks server and Cisco Secure ACS 
after installing all LAN Management Solution applications.

• For RME, you must ensure that the CiscoWorks server System Identity Setup 
user has the privilege to perform all RME tasks on Cisco Secure ACS.

• If you have installed your application after configuring the CiscoWorks Login 
Module to ACS mode then the application users are not granted any 
permission. 

However, the application is registered to the Cisco Secure ACS. On the Cisco 
Secure ACS server, you must assign the appropriate permissions to the 
application.

See Configuring RME server with Cisco Secure ACS.

• Multiple instances of same application using same Cisco Secure ACS will 
share settings. Any changes will affect all instances of that application.

• If application is configured with Cisco Secure ACS and then application is 
reinstalled, the application will inherit the old settings.

This is applicable if you are using Cisco Secure ACS version 3.2.3.
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Configuring RME on Cisco Secure ACS
• The role which you create is not shared across all the LAN Management 
Solution applications. The role which you create is shared across all 
CiscoWorks server that is configured to that particular Cisco Secure ACS.

You have to create new roles for each of the LAN Management Solution 
applications that are running on the CiscoWorks server.

For example, if you have configured 10 CiscoWorks servers with an Cisco 
Secure ACS. You have created a role in RME (For instance, RMESU). This 
role is shared for RME application that is running in all 10 CiscoWorks 
server. 

This role is not shared for any other LAN Management Solution applications 
that is running on the CiscoWorks server.

• You can have different users having different access privileges to the 
CiscoWorks applications.

For example, you have a user CWSU, this user can be System Administrator 
in Common Services, Approver in RME, Network Operator for Campus, 
Network Administrator for DFM, and Help Desk for IPM.

• For details on configuring CiscoWorks Server in ACS mode, see chapter, 
Configuring the Server in the User Guide for Common Services.

Configuring RME on Cisco Secure ACS
After registering the CiscoWorks Server with Cisco Secure ACS perform the 
following on Cisco Secure ACS:

1. Click Shared Profile Components to view the Resource Manager Essentials 
application entry is present.

2. Based on your authentication setting (per user or per group) on Cisco Secure 
ACS, click either User Setup or Group Setup.

On Cisco Secure ACS, you can verify the per user or per group setting for 
Resource Manager Essentials using Interface Configuration > TACACS + 
(Cisco IOS).

3. Assign the appropriate privileges to the User/Group to use the Resource 
Manager Essentials.

For RME, you must ensure that the CiscoWorks server System Identity Setup 
user has the privilege to perform all RME tasks on Cisco Secure ACS.
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Verifying the RME and the Cisco Secure ACS 
Configuration

After performing the above mentioned tasks on Cisco Secure ACS server, 

1. Login to CiscoWorks with the username as defined in the Cisco Secure ACS.

2. Based on your privilege on the Cisco Secure ACS, you can perform only 
certain tasks on the CiscoWorks server.

For example: If your privilege is of Help Desk, then you can only View the 
Device Summary.

3. Based on the Network Device setting for the User/Group on the Cisco Secure 
ACS, you can view only certain devices in the CiscoWorks server.
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Verifying the RME and the Cisco Secure ACS Configuration
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 P P E N D I X A

Troubleshooting the Installation

This appendix provides troubleshooting information for Resource Manager 
Essentials (RME 4.0) installation and setup. It contains these sections:

• Logging In After Upgrading

• Understanding Installation Messages

• Installing Syslog Analyzer

• Failure to Delete a Package During Uninstallation

• CiscoWorks Server Access Problems

• Viewing Process Status

• Browser Problems

• Improving Server Performance

• Frequently Asked Questions

• Troubleshooting Tips

Logging In After Upgrading
If the Login Manager dialog box on the CiscoWorks desktop does not appear 
correctly when you try to log in for the first time after upgrading, clear your 
browser cache as follows, then reenter the server URL in your browser.

Wait for a few seconds after the server starts before logging in. If you have trouble 
logging in, use the Reload button on your browser.
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Clearing the Cache in Microsoft Internet Explorer

Step 1 Select Tools > Internet Options. 

The Internet Options dialog box appears.

Step 2 Select the General tab.

Step 3 Click Delete Files, then click OK in the Delete Files dialog box.

Clearing the Cache in Netscape Navigator

Step 1 Select Edit > Preferences.

The Preferences dialog box appears.

Step 2 Select Advanced > Cache.

Step 3 Click Clear Memory Cache, then click OK in the Memory Cache dialog box.

Step 4 Click Clear Disk Cache, then click OK in the Disk Cache dialog box.

Understanding Installation Messages
The messages that might appear during installation are:

• Information messages, which give you important details

• Warning messages, which tell you that something might be wrong with a 
particular process, but the process will complete

• Error messages, which tell you that a particular process could not complete

All messages that appear during installation are logged in the 
/var/tmp/ciscoinstall.log file.

Table A-1 shows messages that might occur during installation and describes their 
reasons.
A-2
Installation and Setup Guide for Resource Manager Essentials 4.0 on Solaris

78-16504-01



 

Appendix A      Troubleshooting the Installation
Understanding Installation Messages
Table A-1 Installation Messages

Message Reason for Message User Action

Base package did not install. 
Exiting.

Installation program cannot install 
a required package.

Contact your technical support 
representative.

Cannot backup /etc/services, no 
change will be made.

Installation program cannot make a 
copy of /etc/services before 
modifying it.

Make sure there is enough 
space in /tmp.

Cannot change ownership of 
library. Exiting.

Installation program cannot write 
to product root directory.

Check the permissions on the 
directory you specified.

Cannot create directory. Installation program cannot write 
to the directory you specified.

Check the permissions on the 
directory you specified.

Cannot create symlink: ln -s root 
/opt/CSCOpx.

Installation program cannot create 
a link from /opt/CSCOpx to the 
product root directory you 
specified.

Contact your technical support 
representative.

Cannot determine the RME 
version.

Installation disk is corrupted. Contact your technical support 
representative.

Cannot determine the version of 
product.

Installation program cannot 
determine product version.

Contact your technical support 
representative.

Cannot make list of packages for 
installation.

Installation suffered a major 
failure.

Contact your technical support 
representative.

Copy setupdir to nmsroot failed. Installation program could not 
write to product root directory.

Check the permissions on the 
root.

Installation in progress You are already running an 
installation on this machine.

Run only one installation 
program at a time. 

For more information, see 
Frequently Asked Questions, 
page A-9.

Missing file file. Installation program cannot find a 
file.

Contact your technical support 
representative.

No Syslog facility is available. No available Syslog facilities. Make one of the facilities 
available.
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Not enough disk space: root. File system has insufficient space 
to load RME.

Make at least 4 GB of disk 
space available on the partition 
on which you install RME.

Package verification failed: pkg 
aborting.

While loading packages, one 
loaded incorrectly.

Contact your technical support 
representative.

Syslog is not running. Installation program cannot start 
syslogd on this machine.

Restart syslogd.

The components have 
dependency errors.

Installation program suffered a 
major failure.

Contact your technical support 
representative.

User must be root. You must be root to install. Log in as root and enter the 
correct password.

User casuser appears in 
/usr/lib/cron/at.deny. Software 
Image Manager requires casuser 
to be able to run at. Contact your 
local technical support 
representative to edit the file 
/usr/lib/cron/at.deny and remove 
the entry for casuser.

User casuser appears in 
/usr/lib/cron/cron.deny. 
Software Image Manager 
requires casuser to be able to run 
crontab. Contact your local 
technical support representative 
to edit the file 
/usr/lib/cron/cron.deny and 
remove the entry for casuser. 

Software Management requires 
that the user casuser be allowed to 
use at and cron.

Edit the relevant files to allow 
the user casuser to use at and 
cron. For details, see 
“Allowing the User casuser to 
Use at and cron” section on 
page 2-29.

Wrong OS. Operating system is not Solaris or 
not a supported version of Solaris.

Make sure you are running 
Solaris 2.8 or 2.9.

Table A-1 Installation Messages (continued)

Message Reason for Message User Action
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Installing Syslog Analyzer
If the RME installation fails during Syslog Analyzer installation, make sure you 
do not have the Cisco DNS/DHCP Manager (CDDM) installed on the same 
machine as RME. CDDM provides syslog and TFTP daemons as part of its 
product. CDDM can be downloaded from Cisco.com.

You cannot run CDDM Syslog or TFTP on the same machine as RME because 
they are not compatible. Make sure the server on which you install RME is not 
running CDDM Syslog or TFTP.

Caution The tftp directory ‘/tftpboot’ appears to be NFS mounted. Using NFS directories 
often increases the software transfer time and may cause a failure during 
distribution of the software to the device. Contact your local technical support 
representative to make ‘/tftpboot’ a local directory.

Failure to Delete a Package During Uninstallation
If you try to remove RME but the uninstallation program fails to delete a package, 
try running the uninstall program again. Several circumstances can cause a 
package to remain after uninstallation. Usually, running the uninstall program 
again, removes the package.

CiscoWorks Server Access Problems
The CiscoWorks Server uses port 1741 by default. This port is normally used by 
web servers. If you receive an error message that an existing web server is already 
configured to run on port 1741, and the alternative port is used instead, verify that 
you entered the correct URL for the server:

http://server_name:port_number
A-5
Installation and Setup Guide for Resource Manager Essentials 4.0 on Solaris

78-16504-01



 

Appendix A      Troubleshooting the Installation
CiscoWorks Server Access Problems
where server_name is the name of the machine where CiscoWorks was installed, 
and port_number is the alternative port on which CiscoWorks is installed if port 
1741 is in use.

• If SSL is enabled using the default port, enter:

https://server_name:443 

where server_name is the name of the machine where CiscoWorks was 
installed.

• If SSL is enabled using the custom port, enter:

https://server_name:customport

where server_name is the name of the machine where CiscoWorks was 
installed.

Verify Server Status
To make sure your server is running, enter:

ping server_name

where server_name is the name of the machine where CiscoWorks was installed.

Proxy Server Problems
If you get a message that the server is “alive,” and get a proxy error when you try 
to connect to the server, make sure the proxy is set up correctly. 

You will get proxy errors if both these conditions are true:

• Your server is configured to use a proxy server outside the firewall.

• You configured the proxy to ignore requests to a certain machine, set of 
machines, or domain.

You should specify a proxy server in Netscape Navigator under Edit > 
Preferences > Advanced > Proxies and in Internet Explorer under Tools > 
Internet Options > Connections > LAN Settings.
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Your proxy is set up incorrectly if: 

• You receive an error message that you are using a proxy outside the firewall.

• The proxy server recognizes www-int as an internal server, so it does not 
proxy requests to that server.

• You set up a new internal server, www-nms, but when you make a request to 
the proxy server, it does not recognize www-nms as an internal server and 
proxies the request.

• The proxy server outside the firewall tries to request data from a server inside 
the firewall, and the request is blocked.

• You get a Connection Refused error from the proxy server.

Daemon Manager Not Running
You can use the following command to verify whether the daemon manager is 
running:

# /opt/CSCOpx/bin/pdshow

If the daemon manager is not running, following error message is displayed:

connect to dmgtd process on "127.0.0.1" on port 42340 failed: 

If the Daemon Manager is not running, CiscoWorks cannot run. When you install 
or uninstall CiscoWorks, the Daemon Manager is temporarily stopped and then 
restarted. If the install or uninstall process is interrupted, the Daemon Manager 
might remain in the stopped state.

Note Wait a few seconds after the server starts before logging in. If you have trouble 
logging in, use the “Reload” button on your browser.

To start or stop the Daemon Manager:

Step 1 Log in as root.

Step 2 Open a shell window.
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Step 3 Start the server by entering:

# /etc/init.d/dmgtd start

Step 4 Stop the server by entering:

# /etc/init.d/dmgtd stop

Viewing Process Status
You can check back-end server process failures by selecting Common Services > 
Server > Admin > Processes. Only users with administrator privileges can start 
and stop processes. For details, refer to User Guide for CiscoWorks Server.

Browser Problems
If the desktop buttons do not work, Java and JavaScript are not enabled. Make sure 
you enable Java and JavaScript.

Make sure the browser cache is not set to zero.

Do not resize the browser window while the desktop main page is loading. This 
can cause a Java error.

For more information about setting up browsers, refer to Installation and Setup 
Guide for Common Services 3.0 (Includes Ciscoview) on Solaris.

Improving Server Performance
To improve system performance for RME:

• Reduce the number of syslog messages saved to the CiscoWorks database.

• Increase the interval used by Configuration Management to collect 
information about managed devices.
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• While using CMF Syslog Service, you can turn off DNS lookup to improve 
performance of Syslog Collector. 

To turn off, set the registry key HKEY_LOCAL_MACHINE > System > 
CurrentControlSet > Services > crmlog > Parameters > 
CrmDnsResolution to 0.

Frequently Asked Questions
• What are the various installation switches supported?

• I modified the date and time on the CiscoWorks Server, but RME does not 
reflect the change. What should I do?

• Can I use RME within a network containing firewalls? If so, what are special 
configurations I need to take care of?

• Can I change the RME Database password? If so, how?

• When I perform a backup of the RME database, what data is backed up?

• I performed a fresh installation of RME 4.0 on a machine. I also reinstalled 
RME 4.0 on another machine. Why did the installation prompt me for new a 
password in the latter scenario?

• Where are the RME installation logs?

• How can I tell which version of Internet Information Server/Service Pack 
(IIS/SP) is installed?

• How do I cleanup my system after an aborted installation of RME?

• How do I change the Hostname of the CiscoWorks Solaris Server after 
installing it, or after running it for a while?
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Q. What are the various installation switches supported?

A. The following options are supported during installation:

Q. I modified the date and time on the CiscoWorks Server, but RME does not 
reflect the change. What should I do?

A. Time related functions may not work if the system date is changed after RME 
is installed. You must stop and restart the CiscoWorks Daemon Manager for 
RME to reflect the changes in date, time or timezone.

For more information on stopping and starting the Daemon Manager, see 
“Daemon Manager Not Running” section on page A-7.

Q. How do I re-initialize the RME database on a Solaris system, if the RME 
database is corrupted and the database restore operation has failed?

A. You can use the dbRestoreOrig.pl utility to re-initialize the RME database. To 
reinitialize the database, follow this procedure:

Step 1 Stop the daemon manager by entering:

/etc/init.d/dmgtd stop

Step 2 At the prompt, run the PERL script dbRestoreOrig.pl:

/opt/CSCOpx/bin/perl /opt/CSCOpx/bin/dbRestoreOrig.pl

The usage details for dbRestoreOrig.pl appear.

Step 3 Enter the required variable parameters and the corresponding values based on 
your application (see Table A-2). 

Caution All the user configurable variable parameters are case-sensitive. Ensure that you 
enter the exact value as mentioned in the table—if not, the database will get 
corrupted.

Command What it does

setup.sh -d Running installation in the debug mode.
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We recommend that you reinitialize the database for both the 
applications—Common Services and RME. Else, the database may become 
inconsistent. You can follow any order for reintialization.

A message appears that the initialization is complete.

Step 4 Restart the daemon manager by entering:

/etc/init.d/dmgtd start

Q. Can I use RME within a network containing firewalls? If so, what are special 
configurations I need to take care of?

A. Yes, you can use RME in a network containing firewalls.

Let us consider a few scenarios here:

Your server is behind a firewalled network, while your clients are outside the firewall.

In this scenario, you have to open ports on the firewall for your clients. 

• If you are interested in only RME, you must open TCP 1741 (or whichever 
port cscoweb is set to) as well as all established TCP connections. 

• If you require client support for Campus Manager, ACLM, or IPM, you have 
to take into account CORBA which requires you to open all TCP ports above 
1023 on your firewall. In such a case, a better solution would be to create 
VPN tunnels for your clients.

Table A-2 Variable Parameters

Variable Parameter
For Common 
Services enter For RME enter

dsn cmf rmeng

dmprefix Cmf RME

npwd

It is optional to enter a new 
password for this variable. Enter a 
new password only if you want to 
change your database password.

Your new password Your new password
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You want to manage devices outside a firewall.

In this scenario, you need to open a few ports. For maximum manageability, 
ensure that the ports listed in Table A-3 are open.

Your firewall is engaged in NAT (Network Address Translation).

In this scenario, if you need to manage devices outside the NAT boundary, 

Step 1 Select Admin > System Preferences > RME Device Attributes

Step 2 Enter the public address of the server in the NAT ID field.

Consequently, when you perform Software Image Management operations, and 
configuration TFTP operations, this IP address will be used as the TFTP server 
address. Note, you must still open all the ports listed in Table A-3.

Q. Can I change the RME Database password? If so, how?

A. Yes, you can change the RME Database password. To do so:

Step 1 On the CiscoWorks Server, using a CLI, enter:

# /etc/init.d/dmgtd stop

This stops the daemon manager.

Table A-3 Devices Outside Firewall

Path Ports

From RME server to 
device.

• UDP 161, 

• TCP 80, 

• TCP 23 (and/or 22 (SSH) and/or 514 (RCP))

From device to RME 
server.

• UDP sourced from 161, 

• UDP 69 (TFTP), 

• UDP 514 (syslog), 

• All established TCP sessions
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Step 2 Enter:

# cd /opt/CSCOpx/bin
# ./dbpasswd.pl dsn=rmeng

For detailed usage information, you can enter the following:
# ./dbpasswd.pl

The following message appears:

Please enter the new password for database rme:

Step 3 Enter the new password. 

The following message appears:

Please enter the new password again for verification:

Step 4 Enter the password again for verification. The following message appears:

Do you want to encrypt the database username and password, YES[Y] or 
keep the encryption mode as it is [N]:

Step 5 Enter Y to encrypt.

Step 6 Start the daemon manager. Enter:

# /etc/init.d/dmgtd start

Q. When I perform a backup of the RME database, what data is backed up?

A. The following data files are backed up:

• Properties file for performing Configuration Management.

• Directory containing Device Configurations

• Configuration Jobs and NetConfig Templates

• Software Image Management image repository

• Properties file for syslog collector and the list of TimeZones

• All admin settings

• All jobs, those that have been executed and those that have been scheduled

• All change audit records
A-13
Installation and Setup Guide for Resource Manager Essentials 4.0 on Solaris

78-16504-01



 

Appendix A      Troubleshooting the Installation
Frequently Asked Questions
Q. I performed a fresh installation of RME 4.0 on a machine. I also reinstalled 
RME 4.0 on another machine. Why did the installation prompt me for new a 
password in the latter scenario?

A. When you perform an installation of RME 4.0 and choose the typical 
installation mode, the installation will generate a random password for the 
RME database. In the second scenario, you might have opted for a custom 
installation. 

For more information see the table below:

Q. Where are the RME installation logs? 

A. On Solaris RME installation logs are located here: 

     /var/tmp/ciscoinstall.log 
     /var/tmp/ciscouninstall.log

For a product upgrade, the database upgrade log information appears in the 
installation log file and in
/var/adm/CSCOpx/log/migration.log. 

Q. How can I tell which version of Internet Information Server/Service Pack 
(IIS/SP) is installed? 

A. The following server software installation verification acronyms are used in 
this answer: 

– IE - Internet Explorer 

– IIS- Internet Information Server 

– ISM - Internet Service Manager 

– MMC - Microsoft Management Console 

– SP n - Service Pack n 

Installation Type Typical Mode Custom Mode

New installation Installation generates a random password.

You are prompted to view the generated 
password after installation completes.

You are prompted to enter a new 
password.

Reinstallation Password from previous installation of 
RME is restored.

You are prompted to enter a new 
password.
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To verify the Windows 2000 SP4 install: 

Select Start > Programs > Administrative Tools > Computer 
Management > System Tools > System Information > System Summary.

You should see: 

Version 5.0.2195 Service Pack 4 Build 2195

To verify the IE 6.0.2800 SP1 installation: 

Select Internet Explorer > Help > About Internet Explorer

You should see: 

Microsoft Internet Explorer 
Version: 6.0.2800.1106CO
Update versions:;SP1;

To verify Windows Scripting Host (WSH):

a. Select Start > Programs > Accessories > Command Prompt to open a 
DOS window.

b. Type the command script cscript.exe

The following will appear if WSH is installed: 

Microsoft (R) Windows Scripting Host Version 5.1 for Windows

Q. How do I cleanup my system after an aborted installation of RME?

A. To revert your system back to its pre-install state, you might have to cleanup 
your machine after:

• An aborted installation of RME, as a result of pressing Ctrl-C.

Or

• A corrupted installation of RME.

Use the procedure below only as a last resort after exhausting all other 
options, like reinstalling RME.

Caution The script will remove all the files installed by CiscoWorks applications.

Step 1 Copy the following lines into a text editor:
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# BEGIN COPY

#!/usr/bin/sh

PromptResponse ()
{
RESPONSE=""
VALID_RES=""
if [ -n "$2" ] ; then VALID_RES="$2" ; fi
DEF_ARG=""
if [ -n "$3" ] ; then DEF_ARG="$3" ; fi

until [ "${RESPONSE}" != "" ];
do
if [ "${DEF_ARG}" = "" ] ; then
echo "$1 \c"

else
echo  "$1 [${DEF_ARG}] \c"

fi

read RESPONSE

if [ "$VALID_RES" = "1" ]; then
case "${RESPONSE}" in
"")
RESPONSE="${DEF_ARG}"
;;

[Yy]|[Yy][Ee][Ss])
RESPONSE="y"
;;

[Nn]|[Nn][Oo])
RESPONSE="n"
;;

*)
RESPONSE=""
;;

esac
else
case "${RESPONSE}" in
"")
RESPONSE="${DEF_ARG}"
;;

1)
RESPONSE="1"
;;

2)
RESPONSE="2"
;;
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3)
RESPONSE="3"
;;

*)
RESPONSE=""
;;

esac
fi

done

unset DEF_ARG
return 0

}

# Main

if [ "`uname`" != "SunOS" ]; then
echo "This script can only run on Solaris."
exit 0

fi

if [ `/bin/id | sed -e 's/(.*$//' -e 's/^.*=//'` != 0 ] ; then
echo "ERROR: You must be logged in as root to run this script."
exit 0

fi

echo "\nThis script will try to remove CiscoWorks from the system.\
 It is kind of risky to do it especially when you have bundles installed.\
 Please make sure you already tried any of these TWICE:"
echo "\n\t* /opt/CSCOpx/bin/uninstall.sh"
echo "\t* pkgrm CSCOxxx"
echo "\t  (CSCOxxx is one of CiscoWorks packages)"
echo "\nWARNING: Don't try this script unless the system"
echo "WARNING: contents file corrupted (bad or garble"
echo "WARNING: entry) which makes above commands failed.\n"

PromptResponse "Do you want to continue (y/n)?" 1 n
if [ "$RESPONSE" != "y" ]; then
exit 0

fi

Backup_c=0
Backup_s=0

echo "\nStop daemon manager ..."
if [ -x /etc/init.d/dmgtd ]; then
/etc/init.d/dmgtd stop 2> /dev/null
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sleep 10
fi

echo "\nChecking CSCO packages installed ... \c"
csco_pkgs=`ls -d /var/sadm/pkg/CSCO* 2> /dev/null |sed -e 's#/var/sadm/pkg/##' -e 's#/##'`
if [ "$csco_pkgs" = "" ]; then
csco_pkgs=`grep " CSCO" /var/sadm/install/contents |awk '{print $NF}' |grep CSCO |sort 

-u`
fi

if [ "$csco_pkgs" = "" ]; then
echo "No"

else
echo "Yes\n"

for pkg in `echo $csco_pkgs`; do echo "\t$pkg"; done
echo "\nAbove packages found in the system. Some of them might not belong\

 to CiscoWorks when you have other Cisco product installed. If you are\
 not sure about this, verify these packages with Cisco TAC before go ahead."
echo "\n\t1. Clean them all in one step."
echo "\t2. Clean them one by one. (later you can select to skip any of them)"
echo "\t3. Quit.\n"

PromptResponse "Please input your decision -->" 2
if [ "$RESPONSE" != "1" -a "$RESPONSE" != "2" ]; then
exit 0

fi
METHOD=$RESPONSE

echo "\nBackup contents file in /var/sadm/install/contents.save.$$"
cp /var/sadm/install/contents /var/sadm/install/contents.save.$$
Backup_c=1
echo "\nCleaning packages from system registry ..."
cp /var/sadm/install/contents /tmp/contents
for pkg in `echo $csco_pkgs`;
do
if [ "$METHOD" = 2 ]; then
PromptResponse "Clean $pkg ?" 1
if [ "$RESPONSE" != "y" ]; then continue; fi

fi
grep -v $pkg /tmp/contents > /tmp/contents.tmp
mv /tmp/contents.tmp /tmp/contents
rm -rf /var/sadm/pkg/$pkg
echo "$pkg cleaned"

done
mv /tmp/contents /var/sadm/install/contents

fi
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if [ "`grep CSCO /etc/services`" != "" ]; then
echo "\nBackup system services file in /etc/services.save.$$"
cp /etc/services /etc/services.save.$$
Backup_s=1
echo "Cleaning system services file ..."
grep -v CSCO /etc/services > /tmp/remove.tmp
mv /tmp/remove.tmp /etc/services

fi

echo "\nCleaning CiscoWorks runtime trees ..."

if [ -d /opt/CSCOpx -o -h /opt/CSCOpx ]; then
PromptResponse "Remove /opt/CSCOpx ?" 1
if [ "$RESPONSE" = "y" ]; then
rm -rf /opt/CSCOpx/*
rm -rf /opt/CSCOpx

fi
fi

if [ -d /var/adm/CSCOpx ]; then
PromptResponse "Remove log directory /var/adm/CSCOpx ?" 1
if [ "$RESPONSE" = "y" ]; then
rm -rf /var/adm/CSCOpx

fi
fi

if [ -d /tmp/cscotmp -o -f /tmp/csco* ]; then
PromptResponse "Remove temp files /tmp/csco* ?" 1
if [ "$RESPONSE" = "y" ]; then
rm -rf /tmp/csco*

fi
fi

echo
if [ "$Backup_c" = "1" ]; then
echo "INFO: Original contents file saved in /var/sadm/install/contents.save.$$"

fi
if [ "$Backup_s" = "1" ]; then
echo "INFO: Original system services file saved in /etc/services.save.$$"

fi

echo "\nCleaning is done."

# END COPY

Step 2 Save the text in the text editor as a shell script, with a .sh extension. 

For example, you can save the file as cleanup.sh.
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Step 3 Using a CLI, modify the permissions on the file to allow script execution. 

For example if you saved the file as cleanup.sh, enter:

# chmod 750 cleanup.sh

Step 4 Navigate to the directory where you saved the file, and enter:

# ./cleanup.sh

The script removes files installed by all CiscoWorks applications.

Q. How do I change the Hostname of the CiscoWorks Solaris Server after 
installing it, or after running it for a while?

A. Follow the procedure as described in the CiscoWorks Common Services User 
Guide:

http://www.cisco.com/univercd/cc/td/doc/product/rtrmgmt/cw2000//cw2000_d/c
omser30/usrguide/diagnos.htm#wp1078582

In addition to that, before rebooting the CiscoWorks server, you must change 
the hostname for CTMJrmServer daemon registration. 

a. Go to /opt/CSCOpx/objects/dmgt/dmgtd.conf 

b. Search for CTMJrmServer and change the old hostname to new hostname.

After making the changes in the CTMJrmServer, the new hostname entry 
appears as follows,

CTMJrmServer y y 120000 

RMEDbMonitor,jrm,TomcatMonitor,RMECSTMServer 

/opt/CSCOpx/bin/cwjava -cw /opt/CSCOpx -cw:jre lib/jre -server 

-cp:p 

MDC/tomcat/webapps/rme/WEB-INF/classes:MDC/tomcat/webapps/rme

/WEB-INF/lib/ctm.jar:MDC/tomcat/webapps/rme/WEB-INF/lib/log4j

.jar com.cisco.nm.rmeng.jrmwrapper.server.CTMJobManagerServer 
CW-Server1

Where, CW-Server1 is the new hostname.
A-20
Installation and Setup Guide for Resource Manager Essentials 4.0 on Solaris

78-16504-01

http://www.cisco.com/univercd/cc/td/doc/product/rtrmgmt/cw2000//cw2000_d/comser30/usrguide/diagnos.htm#wp1078582


 

Appendix A      Troubleshooting the Installation
Troubleshooting Tips
Troubleshooting Tips

Message ID Error Message Probable Cause Possible Action

INST0001 File [$1] does not 
exist

Not applicable since this is a 
generic file.

INST0002 Error reading file 
[$1].

Cannot read the 
file/directory.

Ensure that file/directory has 
appropriate permissions.

INST0003 Error writing file 
[$1].

Cannot write into the 
file/directory.

Ensure that file/directory has 
appropriate permissions.

INST0004 Syntax error in line 
[$1]

Syntax of the CCR input file 
is not proper. The 
ccrInput.txt may have been 
edited.

Contact your Cisco 
representative to get the proper 
file.

INST0005 Unable to fetch 
CCR (Core Client 
Registry) entry for 
[$1]. 

Reported entry is missing in 
CCR.

Check the restorebackup.log 
under /var/adm/CSCOpx/log for 
SOL and nmsroot/log for more 
information.
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A
 P P E N D I X B

Mounting and Unmounting the 
CD-ROM

This appendix gives general information on how to mount the Resource Manager 
Essentials (RME) CD-ROM on a Solaris 2.8 or 2.9 system. For more detailed 
instructions, consult your Sun documentation.

You can install RME from a CD-ROM mounted on the CiscoWorks Server system 
or from a CD-ROM mounted on a remote Solaris system.

This appendix contains these sections:

• Mounting a Local CD-ROM Drive

• Mounting a Remote CD-ROM Drive

• Unmounting the CD-ROM Drive

Mounting a Local CD-ROM Drive
Insert the RME CD-ROM into the CD-ROM drive and:

Step 1 Become the superuser by entering the command su and the root password at the 
command prompt, or log in as root. 

The command prompt changes to the pound sign (#).

Step 2 If the /cdrom directory does not already exist, enter the following command to 
create it:

# mkdir /cdrom
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Step 3 Mount the CD-ROM drive. 

Note The vold process manages the CD-ROM device and performs the 
mounting. The CD-ROM might automatically mount onto the 
/cdrom/cdrom0 directory. 

• If you are running File Manager, a separate File Manager window displays the 
contents of the CD-ROM. 

a. From the File Manager, double click on setup.sh file. 

The Action: Run box appears. 

b. Click OK to continue installation.

• If the /cdrom/cdrom0 directory is empty because the CD-ROM was not 
mounted, or if File Manager did not open a window displaying the contents 
of the CD-ROM, verify the vold daemon is running by entering:

# ps -e | grep vold | grep -v grep

• If vold is running, the system displays the process identification number of 
vold. If the system does not display anything, restart the daemon by entering:

# /usr/sbin/vold &

• If the vold daemon is running but did not mount the CD-ROM, stop the vold 
daemon and then restart it. 

To stop the vold process, you must know the process identification number. 
If you do not know the process identification number, you can get it by 
entering:

# ps -ef | grep vold | grep -v grep

Step 4 Stop the vold process by entering:

# kill -15 process_ID_number
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Step 5 Restart the vold process by entering:

# /usr/sbin/vold &

If you encounter problems using the vold daemon, enter the following command 
to mount the CD-ROM:

# mount -F hsfs -r ro /dev/dsk/cxtyd0sz /cdrom/cdrom0

where x is the CD-ROM drive controller number, y is the CD-ROM drive SCSI ID 
number, and z is the slice of the partition on which the CD-ROM is located.

You have now mounted the CD-ROM drive. See Chapter 1, “Installing RME”, for 
instructions on installation.

Mounting a Remote CD-ROM Drive
Insert the RME CD-ROM into the CD-ROM drive of the remote machine and 
perform Step 1 through Step 12 on the remote machine.

Step 1 Become the superuser by entering the command su and the root password at the 
command prompt, or log in as root.

The command prompt changes to the pound sign (#). If the /cdrom directory does 
not already exist, enter:

# mkdir /cdrom

Step 2 Mount the CD-ROM drive. 

Note The vold daemon process manages the CD-ROM device and performs the 
mounting. The CD-ROM might automatically mount onto the 
/cdrom/cdrom0 directory. 
B-3
Installation and Setup Guide for Resource Manager Essentials 4.0 on Solaris

78-16504-01



 

Appendix B      Mounting and Unmounting the CD-ROM
Mounting a Remote CD-ROM Drive
• If you are running File Manager, a separate File Manager window displays the 
contents of the CD-ROM. 

a. From the File Manager, double click on setup.sh file. 

The Action: Run box appears. 

b. Click OK to continue installation.

• If the /cdrom/cdrom0 directory is empty because the CD-ROM was not 
mounted, or if File Manager did not open a window displaying the contents 
of the CD-ROM, verify that the vold daemon is running by entering:

# ps -e | grep vold | grep -v grep

• If vold is running, the system displays /usr/sbin/vold. If the system does not 
display anything, restart the daemon by entering:

# /usr/sbin/vold &

• If the vold daemon is running but did not mount the CD-ROM, stop the vold 
daemon and then restart it. To stop the vold process, you must know the 
process identification number. If you do not know the process identification 
number, you can get it by entering:

# ps -ef | grep vold | grep -v grep

Step 3 Stop the vold process by entering:

# kill -15 process_ID_number

Step 4 Restart the vold process by entering:

# /usr/sbin/vold &

Step 5 If you encounter problems using the vold daemon, enter the following to mount 
the CD-ROM:

# mount -F hsfs -r ro /dev/dsk/cxtyd0sz /cdrom/cdrom0

where x is the CD-ROM drive controller number, y is the CD-ROM drive SCSI ID 
number, and z is the slice of the partition on which the CD-ROM is located.

Step 6 Use a text editor to create an /etc/dfs/dfstab file, if one does not exist. 

Step 7 Add the following line to the /etc/dfs/dfstab file:

share -F nfs -o ro /cdrom/cdrom0
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Mounting a Remote CD-ROM Drive
Step 8 Make sure your remote machine is enabled as an NFS server by entering:

# ps -ef | grep nfs | grep -v grep

The output of this command indicates whether the /usr/lib/nfs/nfsd and 
/usr/lib/nfs/mountd daemons are running. If they are not running, enable your 
machine as an NFS server by entering:

# /etc/init.d/nfs.server start

If your machine is enabled as an NFS server, enter one of the following:

• # share

Or

• # shareall

Step 9 Go to the machine on which you want to install RME.

Step 10 Log on as superuser by entering the command su and the root password, or log in 
as root.

Step 11 Create a /cdrom directory, if one does not already exist, by entering:

# mkdir -p /cdrom/rme40

Step 12 To mount the CD-ROM drive, enter:

# /usr/sbin/mount -r remote_machine_name:/cdrom/cdrom0 /cdrom/rme40

You have now mounted the CD-ROM drive. See Chapter 1, “Installation 
Overview” for instructions on installation.
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Unmounting the CD-ROM Drive
Unmounting the CD-ROM Drive
After you complete the RME installation, you need to unmount the CD-ROM 
drive and eject the CD-ROM.

To unmount a local CD-ROM drive, as root, enter: 

# cd
# umount /cdrom/cdrom0 
# eject

To unmount a remote CD-ROM drive:

Step 1 As root, enter the following on the local machine:

# umount /cdrom/rme40

Step 2 As root, enter the following on the remote machine:

# umount /cdrom/cdrom0
# eject

Note Instead of using the eject command, you can select File > Eject from the 
File Manager.
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A
 P P E N D I X C

Changes from RME 3.x to RME 4.0

This section provides information about the changes in RME 4.0 compared to 
RME 3.5.

The following describes the major changes in RME 4.0:

• To add devices in RME, you have to first add the devices in Common Services 
and then add the devices to RME from Common Services. 

The workflow for adding the devices in RME is:

a. Add devices to Common Services using Common Services > Device 
and Credentials > Device Management.

b. Devices get automatically added to RME.

If you have disabled the Automatically Manage Devices from Credential 
Repository option in the Device Management Settings window (Resource 
Manager Essentials > Admin > Device Mgmt > Device Management 
Settings), you can add devices manually to RME using the RME Devices 
window (Resource Manager Essentials > Devices > Device Management > 
RME Devices).

• You can select the check device credentials at time of adding devices to RME 
using Device Management Settings window (Resource Manager 
Essentials > Admin > Device Mgmt > Device Management Settings) and 
select Verify Device Credentials During Import.

You can set the device credentials that need to be verified at the time of 
adding devices to RME using Resource Manager Essentials > Admin > 
Device Mgmt > Device Credential Verification Settings.
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The supported device credentials in Common Services 3.0 is:

The order of preference used to set these values in CSV 3.0 is:

– If Tacacs username, password, enable password is set, then these values 
will be set as primary_username, primary_password and 
primary_enable_password.

– If Local username and password is set, then the values will be set as 
primary_username and primary_password.

– If Telnet password, Enable Password, and Enable Secret are set, then the 
values will be set as primary_password, and primary_enable_password 
(for both Enable Password, and Enable Secret).

• The Software Management tasks Browse bugs by device and Locate devices 
by bugs is now part of Bug Toolkit application. You can generate these reports 
using Resource Manager Essentials > Reports > Generator.

Table C-1 RME 3.5 Device Credentials Mapped to CS 3.0 Device 

Credentials

RME 3.5 Common Services 3.0

RO community string snmp_v2_ro_comm_string

RW community string snmp_v2_rw_comm_string

Serial Number Not used in CSV 3.0

Telnet password primary_password

Enable password primary_enable_password

Enable secret primary_enable_password

Tacacs user primary_username

Tacacs password primary_password

Tacacs enable user Not used in CSV 3.0

Tacacs enable password primary_enable_password

Local user primary_username

Local password primary_password

rcp user Not used in CSV 3.0

rcp password Not used in CSV 3.0
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• You can generate various reports for these applications in a centralized 
location using Reports tab:

– Audit Trail (New for RME 4.0)

– Bug Toolkit (Moved from Software Management application)

– Change Audit

– Inventory

– Syslog

• In Config Editor, earlier you had to checkout files and lock them for editing. 
In RME 4.0 editing of configuration files simultaneously is supported. You 
do not have to check out files. Also, there is no locking of config files.

• In RME 4.0, the following config editor labels are changed:

– Diffs-only is known as Overwrite

– Download is known as Deploy

• The syntax for handling interactive commands has changed from:

CLI Command<R>command response 1 <R>command response 2

to 

#INTERACTIVE
command1<R>response1<R>response2
command2<R>response1<R>response2<R>response3 
command3<R>response1 
command4<R>response1<R>response2
#ENDS_INTERACTIVE

• In 3.x you could view the list of checked out files by selecting Resource 
Manager Essentials > Configuration Management > Config Editor > 
Tools > List Checked Out Files. In RME 4.0, the checked out files are 
referred to as private files. You can view private files using RME > Config 
Mgmt > Config Editor. 

• The Data Extracting Engine (DEE) is now part of common CWCLI 
framework. You can use the cwcli export command to generate the 
Inventory and Configuration data in XML format. In addition to this, you can 
also export Change Audit data.

• You can set the HTTP Proxy, SMTP Server, CiscoWorks E-mail ID, and RCP 
User using Common Services > Server > Admin > System Preferences.
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• These applications are not supported in RME 4.0, However they will be 
supported in RME 4.0 drop-in release.

– Case Management (to open a TAC case)

– Contract Connection

– Network Show Commands

• Availability application is not supported in RME 4.0.

For the RME 4.0 new features, see this URL:

http://www.cisco.com/univercd/cc/td/doc/product/rtrmgmt/cw2000/cw2000e/e_
4_x/4_0/rmeapp.htm

The changes in the navigation for all RME applications are described in the 
following tables:

• Inventory Tasks

• Device View Tasks

• Configuration Management Archive-Specific Tasks

• NetConfig Tasks

• Config Editor Tasks

• Data Extracting Engine (DEE)

• Software Management Tasks

• Syslog Tasks 

• Change Audit Tasks

• Job Approval Tasks

• System Configuration Tasks

To avail these features, you must download Resource Manager Essentials 4.0 
Service Pack 1. This is available at the location,

http://www.cisco.com/cgi-bin/tablebuild.pl/cw2000-rme 

The Readme for Resource Manager Essentials 4.0 Service Pack 1 is also available 
at the same location.

• Network Show Commands Tasks

• Contract Connection Tasks

• Case Management Tasks (SmartCase)
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Appendix C      Changes from RME 3.x to RME 4.0
Note Availability Tasks—This feature is not supported in RME 4.0 and in RME 4.0 SP1 
releases.

Table C-2 Inventory Tasks

Task RME 3.5 Navigation RME 4.0 Navigation

List managed 
devices.

Resource Manager RME > 
Administration > Inventory > List 
Devices.

Resource Manager Essentials > Devices > 
Device Management

Add devices. Resource Manager RME > 
Administration > Inventory > Add 
Devices.

You have to add devices to Common 
Services (Common Services > Device 
and Credentials > Device Management).

Devices gets automatically added to 
RME.

If you have disabled the Automatically 
Manage Devices from Credential 
Repository option in the Device 
Management Settings window (Resource 
Manager Essentials > Admin > Device 
Mgmt > Device Management Settings), 
then you can add devices manually to 
RME using the RME Devices window 
(Resource Manager Essentials > 
Devices > Device Management > RME 
Devices).

You can set the verify device credentials 
while adding devices to RME using 
Resource Manager Essentials > Admin > 
Device Mgmt > Device Management 
Settings

Import devices 
from a file.

Resource Manager RME > 
Administration > Inventory > Import 
from File.

Common Services > Device and 
Credentials > Device Management
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Import device 
data from a 
local host.

Resource Manager RME > 
Administration > Inventory > Import 
from Local NMS.

Common Services > Device and 
Credentials > Device Management

Import device 
data from a 
remote host.

Resource Manager RME > 
Administration > Inventory > Import 
from Remote NMS. 

Common Services > Device and 
Credentials > Device Management

Proxy 
Management

Resource Manager RME > 
Administration > Inventory > Proxy 
Management.

Common Services > Device and 
Credentials > Device Management

Click Add and select Auto Update.

Check status of 
import from 
local host, 
remote host, or 
file.

Resource Manager RME > 
Administration > Inventory > Import 
Status.

Resource Manager Essentials > Devices > 
Device Management

Delete 
managed 
devices.

Resource Manager RME > 
Administration > Inventory > Delete 
Devices. 

You can delete RME devices using 
Resource Manager Essentials > Devices 
Device Management > RME Devices.

You can delete devices from CiscoWorks 
server using Common Services > Device 
and Credentials > Device Management

Delete devices 
from a file.

Resource Manager RME > 
Administration > Inventory > Delete from 
File.

You can delete RME devices using the 
command line tool,
cwcli inventory deletedevice

View status of 
deleted 
devices.

Resource Manager RME > 
Administration > Inventory > Delete 
Device Status. 

Not available. 

Table C-2 Inventory Tasks (continued)

Task RME 3.5 Navigation RME 4.0 Navigation
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Change device 
attributes.

Resource Manager RME > 
Administration > Inventory > Change 
Device Attributes.

You can edit RME device attributes using 
Resource Manager Essentials > Devices 
Device Management > RME Devices

You can edit the RME device credentials 
using 

Common Services > Device and 
Credentials > Device Management > Edit

or 

Resource Manager Essentials > 
Devices > Device Management > Device 
Credential Verification > Edit Device 
Credentials

Export devices 
to a file.

Resource Manager RME > 
Administration > Inventory > Export to 
File. 

You can export RME devices using 
Resource Manager Essentials > Devices 
Device Management > RME Devices

Exporting Data 
for AVVID 
Tool

Resource Manager Essentials > 
Administration > Inventory > Export 
Data for AVVID Tool.

Not available. 

Table C-2 Inventory Tasks (continued)

Task RME 3.5 Navigation RME 4.0 Navigation
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Create and 
view inventory 
custom reports.

Resource Manager Essentials > 
Administration > Inventory > Custom 
Reports.

To view a previously-created report, 
select Resource Manager Essentials > 
Inventory > Custom Reports.

Resource Manager Essentials > Reports > 
Custom Report Templates. The Custom 
templates dialog box appears. Click 
Create. The Application Selection dialog 
box appears. Select Inventory and click 
Next.

To view previously created custom 
reports:

1. Select Resource Manager 
Essentials > Reports > Report 
Generator.

2. Select the Inventory option from the 
Application drop-down list. 

3. Select the required custom report 
from the Report drop-down list. 
Custom reports appear separated by a 
line from standard reports.

Define filters 
for change 
reports.

Resource Manager Essentials > 
Administration > Inventory > Inventory 
Change Filter.

Resource Manager Essentials > Admin > 
Inventory > Inventory Change Filter.

Schedule 
inventory 
collection

Resource Manager Essentials > 
Administration > Inventory > Schedule 
Collection. 

Resource Manager Essentials > Admin > 
Inventory > System Job Schedule

Update 
inventory 
collection.

Resource Manager Essentials > 
Administration > Inventory > Update 
Inventory.

You can schedule a job to update 
Inventory (Resource Manager 
Essentials > Devices > Inventory > 
Inventory Jobs and then click Create.)

Schedule 
device polling.

Resource Manager Essentials > 
Administration > Inventory > Inventory 
Poller.

Resource Manager Essentials > Admin > 
Inventory > System Job Schedule.

Table C-2 Inventory Tasks (continued)

Task RME 3.5 Navigation RME 4.0 Navigation
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Run an 
inventory 
24-hour report.

Resource Manager Essentials > 24-Hour 
Reports > Inventory Change Report.

Resource Manager Essentials > Reports > 
Report Generator. 

1. Select the Inventory option from the 
Application drop-down list. 

2. Select 24 Hour Reports Inventory 
Change Report from the Report 
drop-down list.

View a 
hardware 
report.

Resource Manager Essentials > 
Inventory  > Hardware Report.

Resource Manager Essentials > Reports > 
Report Generator. 

1. Select the Inventory option from the 
Application drop-down list. 

2. Select Hardware Report from the 
Report drop-down list.

View a 
software 
report.

Resource Manager Essentials > 
Inventory  > Software Report.

Resource Manager Essentials > Reports > 
Report Generator. 

1. Select the Inventory option from the 
Application drop-down list. 

2. Select Software Report from the 
Report drop-down list.

View 
information 
about devices.

Resource Manager Essentials > 
Inventory  > Detailed Device Report.

Resource Manager Essentials > Reports > 
Report Generator. 

1. Select the Inventory option from the 
Application drop-down list. 

2. Select Detailed Device Report from 
the Report drop-down list.

View a device 
Y2K 
compliance 
report.

Resource Manager Essentials > 
Inventory  > Year 2000 Report.

Not Available.

Table C-2 Inventory Tasks (continued)

Task RME 3.5 Navigation RME 4.0 Navigation
C-9
Installation and Setup Guide for Resource Manager Essentials 4.0 on Solaris

78-16504-01



 

Appendix C      Changes from RME 3.x to RME 4.0
View device 
information 
within device 
classes.

Resource Manager Essentials > 
Inventory  > Hardware Summary Graph.

Resource Manager Essentials > Reports > 
Report Generator. 

1. Select the Inventory option from the 
Application drop-down list. 

2. Select Hardware Summary Graph 
from the Report drop-down list.

View the 
software 
versions in 
each device 
class.

Resource Manager Essentials > 
Inventory > Software Version Graph.

Resource Manager Essentials > Reports > 
Report Generator. 

1. Select the Inventory option from the 
Application drop-down list. 

2. Select Software Version Graph from 
the Report drop-down list.

View device 
information in 
each device 
class.

Resource Manager Essentials > 
Inventory > Chassis Summary Graph.

Resource Manager Essentials > Reports > 
Report Generator. 

1. Select the Inventory option from the 
Application drop-down list. 

2. Select Chassis Summary Graph from 
the Report drop-down list.

View a 
summary of 
chassis slots.

Resource Manager Essentials > 
Inventory  > Chassis Slot Summary.

Resource Manager Essentials > Reports > 
Report Generator. 

1. Select the Inventory option from the 
Application drop-down list.

2. Select Chassis Slot Summary from 
the Report drop-down list.

View the 
chassis slot 
details.

Resource Manager Essentials > 
Inventory  > Chassis Slot Details.

Resource Manager Essentials > Reports > 
Report Generator. 

1. Select the Inventory option from the 
Application drop-down list. 

2. Select Chassis Slot Details from the 
Report drop-down list.

Table C-2 Inventory Tasks (continued)

Task RME 3.5 Navigation RME 4.0 Navigation
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View details on 
multiservice 
ports.

Resource Manager Essentials > 
Inventory  >  MultiService Port Details.

Resource Manager Essentials > Reports > 
Report Generator. 

1. Select the Inventory option from the 
Application drop-down list.

2. Select MultiService Port Details 
from the Report drop-down list.

Verify 
community 
strings, 
usernames, and 
passwords.

Resource Manager Essentials > 
Administration > Inventory > Check 
Device Attributes.

Resource Manager Essentials > Devices 
> Device Management > Device 
Credential Verification > Check Device 
Credential

View attribute 
check results.

Resource Manager Essentials > 
Administration > Inventory > View 
Check Results.

Resource Manager Essentials > 
Devices > Device Management > Device 
Credential Verification > View Credential 
Verification Report 

View historical 
data.

Resource Manager Essentials > 
Inventory  > Scan History.

Available as a part of job details.

Command line 
utilities

Command line utilities for Inventory 
applications such as, crmimport, 
deletedevice, etc.

• You can check the specified device 
credentials for the RME devices 
using cwcli inventory cda.

• You can export device credentials of 
one or more RME devices in clear 
text using cwcli inventory 
crmexport.

• You can delete the specified RME 
devices using cwcli inventory 
deletedevice.

• You can view the RME devices state 
using cwcli inventory 
getdevicestate.

• You can import device using 
Common Services CLI tool, dcrcli

Table C-2 Inventory Tasks (continued)

Task RME 3.5 Navigation RME 4.0 Navigation
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Running CLI 
Custom 
Reports

cwinvcreport cwcli invreport 

Device List 
Manipulation 
Service 

• List managed and unmanaged 
devices and their status

• Add managed devices and update 
unmanaged device information and 
credentials

• Get and set device credentials

• Get device IP addresses 

• Add devices 

• List the RME devices and their status 

• Get the device credentials data 

• Set the device credentials data 

• Get the device IP address 

Table C-3 Device View Tasks

Task RME 3.5 Navigation RME 4.0 Navigation

Add static 
views.

Select Resource Manager Essentials > 
Administration > Device Views > Add 
Static Views.

Resource Manager Essentials > Devices > 
Group Administration > Create

Select Only upon user request as the 
Membership Update.

Add dynamic 
views.

Select Resource Manager Essentials > 
Administration > Device Views > Add 
Dynamic Views.

Resource Manager Essentials > Devices > 
Group Administration > Create

Select Automatic as the Membership 
Update.

Change static 
views.

Select Resource Manager Essentials > 
Administration > Device Views > Change 
Static Views.

Resource Manager Essentials > Devices > 
Group Administration > Edit

Delete views. Select Resource Manager Essentials > 
Administration > Device Views > Delete 
Views.

Resource Manager Essentials > Devices > 
Group Administration > Delete

Table C-2 Inventory Tasks (continued)

Task RME 3.5 Navigation RME 4.0 Navigation
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Browse 
dynamic views.

Select Resource Manager Essentials > 
Administration > Device Views> Browse 
Dynamic Views.

Resource Manager Essentials > Devices > 
Group Administration > Details

In the Property Details window, click 
Membership Details.

Browse device 
membership.

Select Resource Manager Essentials > 
Administration > Device Views > Browse 
Device Membership.

Resource Manager Essentials > Devices > 
Group Administration > Details

Table C-4 Configuration Management Archive-Specific Tasks

Task RME 3.5 Navigation RME 4.0 Navigation

Search for 
configuration 
files.

Configuration > Management > Search 
Archive by Device.

or

Resource Manager Essentials > 
Configuration Management > Search 
Archive by Pattern.

Resource Manager Essentials > Config 
Mgmt > Archive Mgmt > Search Archive

Create, run, 
modify, and 
delete custom 
reports.

Resource Manager Essentials > 
Configuration Management > Custom 
Reports.

Resource Manager Essentials > Config 
Mgmt > Archive Mgmt > Search 
Archive > Custom Queries

Compare 
device 
configuration 
files.

Resource Manager Essentials > 
Configuration Management > Compare 
Configurations.

Resource Manager Essentials > Config 
Mgmt > Archive Mgmt > Compare 
Configs

Find 
out-of-sync 
configurations.

Resource Manager RME > Configuration 
Management > Startup/Running Out of 
Sync Report

or

Select Resource Manager RME > 
24 Hour Reports > Configuration Sync 
Report.

Resource Manager RME > Config 
Mgmt > Archive Mgmt > Out-of-Sync 
Summary

Table C-3 Device View Tasks (continued)

Task RME 3.5 Navigation RME 4.0 Navigation
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Move the 
Configuration 
Archive.

Resource Manager Essentials > 
Administration > Configuration 
Management > General Setup, then select 
the Archive Setup tab.

Resource Manager Essentials > Admin 
Config Mgmt > Archive Mgmt

Specify criteria 
for purging the 
archive.

Resource Manager Essentials > 
Administration > Configuration 
Management > General Setup, then select 
the Archive Setup tab.

Resource Manager Essentials > Admin > 
Config Mgmt > Archive Mgmt > Purge 
Settings

Modify 
Configuration 
Archive 
retrieval.

Resource Manager Essentials > 
Administration > Configuration 
Management > General Setup, then select 
the Change Probe Setup tab.

Resource Manager Essentials > Admin > 
Config Mgmt > Archive Mgmt > 
Collection Settings

Change the 
transport 
protocol order 
used by the 
Configuration 
Archive.

Resource Manager Essentials > 
Administration > Configuration 
Management > General Setup, then select 
the Transport Setup tab.

Resource Manager Essentials > Admin > 
Config Mgmt and select Archive Mgmt 
from the drop-down list.

Configure Job 
Policies for 
Config Archive

Select Configuration Management > 
Administration > Configuration Job 
Setup

Select Resource Manager Essentials > 
Admin > Config Mgmt > Config Job 
Policies and select Archive Mgmt from 
the drop-down list.

Update the 
Configuration 
Archive.

Resource Manager Essentials > 
Configuration Management > Update 
Archive.

Resource Manager Essentials > Config 
Mgmt > Archive Mgmt > Sync Archive.

Check the 
archive status.

Resource Manager Essentials > 
Administration > Configuration 
Management > Archive Status.

Resource Manager Essentials > Config 
Mgmt > Archive Mgmt.

Configure 
labels.

Resource Manager Essentials > 
Administration > Configuration 
Management > Label Configuration.

Resource Manager Essentials > Config 
Mgmt > Archive Mgmt > Label Configs

Table C-4 Configuration Management Archive-Specific Tasks (continued)

Task RME 3.5 Navigation RME 4.0 Navigation
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Use the 
cwconfig 
command at 
the command 
line.

This command cannot be entered from 
the desktop; use the command line.

Use the cwcli config command.

Locate the 
Configuration 
Archive 
shadow 
directory.

The shadow directories cannot be 
accessed from the desktop.

• On Solaris, as root or casuser, enter: 
/var/adm/CSCOpx/files/rme/archi

ve shadow

• On Windows, as admin, enter:
NMSROOT\files\archive\shadow

The shadow directories cannot be 
accessed from the desktop.

• On Solaris, as root or casuser, enter
/var/adm/csopx/files/rme/dcma/shad
ow

• On Windows, as admin, enter: 
NMSROOT/files/rme/dcma/shadow

Table C-5 NetConfig Tasks

Task RME 3.5 Navigation RME 4.0 Navigation

Define and 
schedule a 
NetConfig job.

1. Select Resource Manager Essentials > 
Configuration Management > 
NetConfig > Jobs > New Job.

or

Click the New Job button.

2. Complete the job definition wizard.

Resource Manager Essentials > Config 
Mgmt > NetConfig > NetConfig Jobs.

Select the Create button.

Browse and 
edit NetConfig 
jobs.

1. Select Resource Manager Essentials > 
Configuration Management > 
NetConfig > Jobs > Job Browser.

or

Click the Job Browser button.

2. Select a job record.

3. Click Edit Job, Copy Job, Remove 
Job, Stop Job, or Job Details.

Resource Manager Essentials > Config 
Mgmt > NetConfig > NetConfig Jobs.

Select Edit.

Table C-4 Configuration Management Archive-Specific Tasks (continued)

Task RME 3.5 Navigation RME 4.0 Navigation
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View 
NetConfig job 
details.

1. Select Resource Manager Essentials > 
Configuration Management > 
NetConfig > Jobs > Job Browser.

or 

Click the Job Browser button.

2. Select a job record.

3. Click Job Details.

4. Click Edit Job, Copy Job, Remove 
Job, Stop Job, Retry Job (for failed 
jobs), or Print.

Resource Manager Essentials > Config 
Mgmt > NetConfig > NetConfig Jobs.

Click on the Job ID hyperlink in the Job 
Browser.

Launch RME. Select Resource Manager Essentials > 
Configuration Management > 
NetConfig >Tools > Launch RME.

or

Click the Launch RME button.

Not Available.

Create and edit 
user-defined 
configuration 
templates.

Select Resource Manager Essentials > 
Configuration Management > 
NetConfig >Admin> Create/Edit User 
Templates.

Resource Manager Essentials > Config 
Mgmt > NetConfig > User-defined 
Tasks.

Assign 
configuration 
template access 
privileges to 
users.

Select Resource Manager Essentials > 
Configuration Management > NetConfig > 
Admin > Assign Template Users.

Resource Manager Essentials > Config 
Mgmt > NetConfig > Assigning Tasks

Table C-5 NetConfig Tasks (continued)

Task RME 3.5 Navigation RME 4.0 Navigation
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Set default 
template 
policies.

Select Resource Manager Essentials > 
Configuration Management > NetConfig > 
Admin > Set Template Policies.

Select Resource Manager Essentials > 
Admin > Config Mgmt > Config Job 
Policies and select NetConfig from the 
drop-down list.

Use the 
NetConfig 
command to 
make batch 
configuration 
changes.

Enter the NetConfig command at the 
command line with the appropriate syntax.

For more information, see the online help 
and the netconfig man page.

To view the man page, add the path 
install_dir/CSCOpx/man to the 
MANPATH variable.

Command line tool: cwcli netconfig

Table C-6 Config Editor Tasks

Task RME 3.5 Navigation RME 4.0 Navigation

Open a 
configuration 
file.

1. From the CiscoWorks desktop, select 
Resource Manager Essentials > 
Configuration Management > Config 
Editor.

2. Select File > Open 

Select Resource Manager Essentials > 
Config Mgmt > Config Editor

Edit 
configuration 
files from the 
archives.

1. From the CiscoWorks desktop, select 
Resource Manager Essentials > 
Configuration Management > Config 
Editor.

2. Select File > Open > By Device and 
Version.

Select Resource Manager Essentials > 
Config Mgmt > Config Editor > Config 
Files > Device and Version > Go

Edit a 
configuration 
file by pattern

1. From the CiscoWorks desktop, select 
Resource Manager Essentials > 
Configuration Management > Config 
Editor.

2. Select File > Open > By Pattern 
Search.

Resource Manager Essentials > Config 
Mgmt > Config Editor > Config Files > 
Pattern Search > Go

Table C-5 NetConfig Tasks (continued)

Task RME 3.5 Navigation RME 4.0 Navigation
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Remove 
configuration 
file

From the CiscoWorks desktop, select 
Resource Manager Essentials > 
Configuration Management > Config 
Editor > List Checked Out files> Undo 
Checkout

1. Select Resource Manager 
Essentials > Config Mgmt > Config 
Editor > Private Configs/User 
Archive

2. Select the configuration file(s) that 
needs to be removed.

3. Click Delete.

Save 
configuration 
File in public 
(config 
archive) work 
area.

1. From the CiscoWorks desktop, select 
Resource Manager Essentials > 
Configuration Management > Config 
Editor.

2. Select File > Save.

1. Select Resource Manager 
Essentials > Config Mgmt > Config 
Editor.

2. Select the configuration file and click 
Edit.

3. Edit the configuration file.

4. Click Save.

5. Select public (config archive) 
location to save file.

Save modified 
configuration 
file in private 
(config editor) 
work area.

1. From the CiscoWorks desktop, select 
Resource Manager Essentials > 
Configuration Management > Config 
Editor.

2. Select File > Save.

1. Select Resource Manager 
Essentials > Config Mgmt > Config 
Editor.

2. Select the configuration file and click 
Edit.

3. Edit the configuration file.

4. Click Save.

5. Select private (config archive) 
location to save file.

Table C-6 Config Editor Tasks (continued)

Task RME 3.5 Navigation RME 4.0 Navigation
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Undo editing or 
typing changes

1. From the CiscoWorks desktop, select 
Resource Manager Essentials > 
Configuration Management > Config 
Editor.

2. Select Edit > Undo.

1. Select Resource Manager 
Essentials > Config Mgmt > Config 
Editor.

2. Select the configuration file and click 
Edit.

3. Edit the configuration file.

4. Click Undo All.

Inserting 
Comment 
Lines

1. From the CiscoWorks desktop, select 
Resource Manager Essentials > 
Configuration Management > Config 
Editor.

2. Select Tools > Insert Comment Line.

Not available.

Find and 
replace text

1. From the CiscoWorks desktop, select 
Resource Manager Essentials > 
Configuration Management > Config 
Editor.

2. Select Edit > Find.

1. Select Resource Manager 
Essentials > Config Mgmt > Config 
Editor.

2. Select the configuration file and click 
Edit.

3. Click Replace All.

Close 
Configuration 
File

1. From the CiscoWorks desktop, select 
Resource Manager Essentials > 
Configuration Management > Config 
Editor.

2. Select File > Close.

1. Select Resource Manager 
Essentials > Config Mgmt > Config 
Editor.

2. Select the configuration file and click 
Edit.

3. Click Close.

Configure Job 
Policies.

Select Configuration Management > 
Administration > Configuration Job 
Setup

1. Select Resource Manager 
Essentials > Admin > Config 
Mgmt > Config Job Policies 

2. Select Config Editor 

Table C-6 Config Editor Tasks (continued)

Task RME 3.5 Navigation RME 4.0 Navigation
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Set up default 
editing mode.

1. From the CiscoWorks desktop, select 
Resource Manager Essentials > 
Configuration Management > Config 
Editor.

2. Select Edit > Preferences.

Resource Manager Essentials > Admin > 
Config Mgmt > Config Editor

View changes. 1. From the CiscoWorks desktop, select 
Resource Manager Essentials > 
Configuration Management > Config 
Editor.

2. Select Tools > Show changes made.

Resource Manager Essentials > Config 
Mgmt > Config Editor> Device and 
Version > Edit > Tools >View Changes

Compare 
versions of the 
configuration 
files.

1. From the CiscoWorks desktop, select 
Resource Manager Essentials > 
Configuration Management > Config 
Editor.

2. Select Tools > Compare.

Resource Manager Essentials > Config 
Mgmt > Config Editor> Device and 
Version > Edit > Tools > Compare Config

List of opened 
files.

1. From the CiscoWorks desktop, select 
Resource Manager Essentials > 
Configuration Management > Config 
Editor.

2. Select Tools > List Checked Out 
Files.

Not available.

Browse and 
edit Config 
Editor jobs.

From the CiscoWorks desktop, select 
Resource Manager Essentials > 
Configuration Management > Config 
Editor > Tools > Job Browser > Edit Job

Resource Manager Essentials > Config 
Mgmt > Config Editor > Config Editor 
Jobs > Edit

View job 
details.

From the CiscoWorks desktop, select 
Resource Manager Essentials > 
Configuration Management > Config 
Editor > Tools > Job Browser > Job 
Details

1. Resource Manager Essentials > 
Config Mgmt > Config Editor > 
Config Editor Jobs

2. Click a Job ID

Table C-6 Config Editor Tasks (continued)

Task RME 3.5 Navigation RME 4.0 Navigation
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Create a job 1. From the CiscoWorks desktop, select 
Resource Manager Essentials > 
Configuration Management > Config 
Editor.

2. Select File > Download.

Resource Manager Essentials > Config 
Mgmt > Config Editor> Config Editor 
Jobs > Create

Copy a job From the CiscoWorks desktop, select 
Resource Manager Essentials > 
Configuration Management > Config 
Editor > Tools > Job Browser > Copy Job

Resource Manager Essentials > Config 
Mgmt > Config Editor > Config Editor 
Jobs > Copy

Delete a job From the CiscoWorks desktop, select 
Resource Manager Essentials > 
Configuration Management > Config 
Editor > Tools > Job Browser > Remove 
Job

Resource Manager Essentials > Config 
Mgmt > Config Editor > Config Editor 
Jobs > Delete

Stop a job From the CiscoWorks desktop, select 
Resource Manager Essentials > 
Configuration Management > Config 
Editor > Tools > Job Browser > Stop Job

Resource Manager Essentials > Config 
Mgmt > Config Editor > Config Editor 
Jobs > Stop

Check the 
configuration 
file syntax.

Not applicable. 1. Select Resource Manager 
Essentials > Config Mgmt > Config 
Editor.

2. Select the configuration file and click 
Edit.

3. Edit the configuration file.

4. Click Save.

5. Click Tools.

6. Click External Syntax Checker.

Table C-6 Config Editor Tasks (continued)

Task RME 3.5 Navigation RME 4.0 Navigation
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Table C-7 Data Extracting Engine (DEE) 

Task RME 3.5 Navigation RME 4.0 Navigation

Generating 
inventory data 
in XML format

cwexport inventory cwcli export config

Generating 
configuration 
data in XML 
format

cwexport config cwcli export inventory 

In RME 4.0, you can also export Change 
Audit data using
cwcli export changeaudit

Table C-8 Software Management Tasks

Task RME 3.5 Navigation RME 4.0 Navigation

Set up your 
Software 
Management 
preferences.

Resource Manager Essentials > 
Administration > Software 
Management > Edit Preferences.

Resource Manager Essentials > Admin 
Software Mgmt > View/Edit Preferences

Add images to 
the library

Resource Manager Essentials > Software 
Management > Library > Add Images.

Resource Manager Essentials > Software 
Mgmt > Software Repository.

You can add devices through:

• Cisco.com 

• Device 

• File System 

• URL — New for RME 4.0

• Network 

Browse the 
library.

Resource Manager Essentials > Software 
Management > Library > Browse 
Images.

Resource Manager Essentials > Software 
Mgmt > Software Repository.

Search the 
library.

Resource Manager Essentials > Software 
Management > Library > Search for 
Images.

Resource Manager Essentials > Software 
Mgmt > Software Repository and use the 
Filter button.
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View a 
synchronization 
report.

Resource Manager Essentials > Software 
Management > Library > 
Synchronization Report.

Select Resource Manager Essentials > 
Software Mgmt > Software Repository > 
Software Repository Synchronization.

Schedule a 
synchronization 
job.

Resource Manager Essentials > 
Administration > Software 
Management > Schedule 
Synchronization Job.

Resource Manager Essentials > Software 
Mgmt > Software Repository > Software 
Repository Synchronization.

Schedule image 
upgrade jobs.

Resource Manager Essentials > Software 
Management > Distribution > Distribute 
by Devices.

Resource Manager Essentials > Software 
Management > Distribution > Distribute 
by Images.

Resource Manager Essentials > Software 
Management > Remote Staging > 
Remote Staging and Distribution.

Resource Manager Essentials > Software 
Mgmt > Software Distribution.

• By devices [Basic] 

• By devices [Advanced] — New for 
RME 4.0

• By image 

• Use remote staging 

View the upgrade 
jobs

Resource Manager Essentials > Software 
Management > Job Management > 
Browse Jobs.

Resource Manager Essentials > Software 
Mgmt > Software Mgmt Jobs

Plan an upgrade 
from Cisco.com.

Resource Manager Essentials > Software 
Management > Distribution > CCO 
Upgrade Analysis.

Resource Manager Essentials > Software 
Mgmt > Software Distribution > 
Upgrade Analysis

Plan an upgrade 
from the library.

Resource Manager Essentials > Software 
Management > Distribution > Library 
Upgrade Analysis.

Resource Manager Essentials > Software 
Mgmt > Software Distribution > 
Upgrade Analysis

Review 
scheduled jobs or 
undo an upgrade.

Resource Manager Essentials > Software 
Management > Job Management > 
Browse Jobs.

Resource Manager Essentials > Software 
Mgmt > Software Mgmt Jobs

View 
consolidated job 
information.

Resource Manager Essentials > Software 
Management > Job Management > 
Consolidated Job Report.

Resource Manager Essentials > Software 
Mgmt > Software Mgmt Jobs

Table C-8 Software Management Tasks (continued)

Task RME 3.5 Navigation RME 4.0 Navigation
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Update upgrade 
information.

Resource Manager Essentials > 
Administration > Software 
Management > Update Upgrade Info.

Resource Manager Essentials > Admin 
Software Mgmt > Update Upgrade 
Information 

View recent 
software upgrade 
results.

Resource Manager Essentials > 24-Hour 
Reports > Software Upgrade Report.

Not available.

Mail or copy log 
files.

Resource Manager Essentials > Software 
Management > Job Management > Mail 
or Copy Log File.

Not available.

Browse history. Resource Manager Essentials > Software 
Management > History > Browse 
History.

Not available.

Search history by 
device.

Resource Manager Essentials > Software 
Management >History > Search History 
by Device.

Not available.

Search history by 
user.

Resource Manager Essentials > Software 
Management > History > Search History 
by User.

Not available.

Browse bugs. Resource Manager Essentials > Software 
Management > Bug Reports > Browse 
Bugs.

Moved to Bug Toolkit application

Resource Manager Essentials > 
Reports > Report Generator 

Schedule a 
Browse Bugs 
job.

Resource Manager Essentials > 
Administration > Software 
Management > Schedule Browse 
Bugs Job.

Moved to Bug Toolkit application

Resource Manager Essentials > 
Reports > Report Generator 

Browse bugs by 
device.

Resource Manager Essentials > Software 
Management > Bug Report > Browse 
Bugs by Device.

Moved to Bug Toolkit application

Resource Manager Essentials > 
Reports > Report Generator 

Locate devices 
by bugs.

Resource Manager Essentials > Software 
Management > Bug Report > Locate 
Devices by Bugs.

Moved to Bug Toolkit application

Resource Manager Essentials > 
Reports > Report Generator 

Table C-8 Software Management Tasks (continued)

Task RME 3.5 Navigation RME 4.0 Navigation
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Syslog Analysis module of RME 3.5 is termed Syslog. The following table maps 
the RME 3.5 Syslog option to the ones in RME 4.0:

Table C-9 Syslog Tasks

Task RME 3.5 Navigation RME 4.0 Navigation

Generate a 
severity level 
summary.

Resource Manager Essentials > Syslog 
Analysis > Severity Level 
SummarySeverity Level Summary 

Resource Manager Essentials > Reports > 
Report Generator. 

1. Select the Syslog option from the 
Application drop-down list. 

2. Select Severity Level Summary 
Report from the Report drop-down 
list.drop-down list.

Generate a 
standard 
report.

Resource Manager Essentials > Syslog 
Analysis > Standard Reports 

Resource Manager Essentials > Reports > 
Report Generator. 

1. Select the Syslog option from the 
Application drop-down list.

2. Select Standard Report from the 
Report drop-down list.d

Generate a 
custom report.

Resource Manager Essentials > Syslog 
Analysis > Custom Reports 

Resource Manager Essentials > Reports > 
Custom Report Templates. The Custom 
templates dialog box appears. 

1. Click Create. 

The Application Selection dialog box 
appears. 

2. Select Syslog and click Next.

To view previously created custom 
reports, select Resource Manager 
Essentials > Reports > Report Generator.

1. Select the Inventory option from the 
Application drop-down list.

2. Select the required custom report 
from the Report drop-down list. 
Custom reports appear separated by a 
line from standard reports.
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Generate a 
custom report 
summary.

Resource Manager Essentials > Syslog 
Analysis > Custom Report Summary 

Resource Manager Essentials > Reports > 
Generator. 

1. Select the Syslog option from the 
Application drop-down list.

2. Select Custom Report Summary from 
the Report drop-down list.

Generate a 
report for 
unmanaged 
devices.

Resource Manager Essentials > Syslog 
Analysis > Unexpected Device Reports

Resource Manager Essentials > Reports > 
Report Generator. 

1. Select the Syslog option from the 
Application drop-down list.

2. Select Unexpected Device Report 
from the Report drop-down list.

Generate a 
report for 
workflow 
devices.

Resource Manager Essentials > Syslog 
Analysis > Workflow Report

Not available.

View status Resource Manager Essentials > 
Administration > Syslog Analysis > 
Syslog Collector Status

Resource Manager Essentials > Tools 
Syslog > Syslog Collector Status

Set up data 
storage 
options.

Resource Manager Essentials > 
Administration > Syslog Analysis > 
Change Storage Options

Set the backup policy using Resource 
Manager Essentials > Admin > Syslog > 
Set Backup Policy

Set the purge policy using Resource 
Manager Essentials > Admin > Syslog > 
Set Purge Policy

Define custom 
reports.

Resource Manager Essentials > 
Administration > Syslog Analysis > 
Define Custom Reports

Resource Manager Essentials > Reports > 
Custom Report Templates. The Custom 
templates dialog box appears. 

1. Click Create. The Application 
Selection dialog box appears. 

2. Select Syslog and click Next.

Table C-9 Syslog Tasks (continued)

Task RME 3.5 Navigation RME 4.0 Navigation
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Define 
message filters.

Resource Manager Essentials > 
Administration > Syslog Analysis > 
Define Message Filter

Resource Manager Essentials > Tools > 
Syslog > Message Filters

Define 
automated 
actions.

Resource Manager Essentials > 
Administration > Syslog Analysis > 
Define Automated Action

Resource Manager Essentials > Tools > 
Syslog > Automated Actions

Change URL. Resource Manager Essentials > 
Administration > Syslog Analysis > 
Change User URL

Not available. 

Generate 24 
hour reports.

Resource Manager Essentials > 24-Hour 
Reports > Syslog Messages

Resource Manager Essentials > Reports > 
Generator. 

1. Select the Syslog option from the 
Application drop-down list. 

2. Select 24 Hour Reports from the 
Report drop-down list.

Table C-10 Change Audit Tasks

Task RME 3.5 Navigation RME 4.0 Navigation

Delete records 
from the log.

Resource Manager Essentials > 
Administration > Change Audit > Delete 
Change History.

Admin > Change Audit > Set Purge 
Policy 

or

Admin > Change Audit > Force Purge

Convert change 
records to 
SNMP traps.

Resource Manager Essentials > 
Administration > Change Audit > 
Administer Trap Generator.

Resource Manager Essentials > Tools > 
Change Audit > Automated Action

Define an 
exceptions 
period.

Resource Manager Essentials > 
Administration > Change Audit > Define 
Exceptions Summary.

Resource Manager Essentials > Tools > 
Change Audit > Exception Periods

Set up filtering 
options.

Resource Manager Essentials > Change 
Audit > Search Change Audit.

Not available.

Table C-9 Syslog Tasks (continued)

Task RME 3.5 Navigation RME 4.0 Navigation
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View changes 
in an exception 
period.

Resource Manager Essentials > Change 
Audit > Exceptions Summary.

Resource Manager Essentials > Reports > 
Report Generator. 

1. Select the Change Audit option from 
the Application drop-down list.

2. Select Exception Period Report from 
the Report drop-down list.

View all 
change 
records.

Resource Manager Essentials > Change 
Audit > All Changes.

Resource Manager Essentials > Reports > 
Report Generator.

1. Select the Change Audit option from 
the Application drop-down list.

2. Select Standard Report from the 
Report drop-down list.

View a 
summary of 
changes made 
in the last 
24-hours.

Resource Manager Essentials > 24-Hour 
Reports > Change Audit Report.

Resource Manager Essentials > Reports > 
Report Generator

1. Select the Change Audit option from 
the Application drop-down list.

2. Select 24 Hour Report from the 
Report drop-down list.

Table C-11 Job Approval Tasks

Task RME 3.5 Navigation RME 4.0 Navigation

Approve or 
reject jobs.

Resource Manager Essentials > 
Administration > Job Approval > 
Approve or Reject Jobs.

Resource Manager Essentials > Job 
Mgmt > Job Approval.

Set up Job 
Approval.

Resource Manager Essentials > 
Administration > Job Approval > Edit 
Preferences.

Resource Manager Essentials > Admin > 
Approval > Approval Policies.

Create an 
approver list.

Resource Manager Essentials > 
Administration > Job Approval > Create 
Approver List.

Resource Manager Essentials > Admin > 
Job Approval > Create/Edit Approver 
Lists.

Table C-10 Change Audit Tasks (continued)

Task RME 3.5 Navigation RME 4.0 Navigation
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Edit an 
approver list.

Resource Manager Essentials > 
Administration > Job Approval > Edit 
Approver List.

Resource Manager Essentials > Admin > 
Job Approval > Create/Edit Approver 
Lists.

Enable jobs Resource Manager Essentials > 
Administration > Job Approval > Enable 
Jobs.

Not available. You cannot migrate the 
RME 3.x jobs.

Table C-12 System Configuration Tasks

Task RME 3.5 Navigation RME 4.0 Navigation

Set up a proxy 
URL.

Select Resource Manager Essentials > 
Administration > System Configuration, 
then select the Proxy tab.

Common Services > Server > Security > 
Cisco.com Connection Management > 
Proxy Server Setup

Define SNMP 
timeouts and 
retries.

Select Resource Manager Essentials > 
Administration > System Configuration, 
then select the SNMP tab.

Resource Manager Essentials > Admin > 
System Preferences > RME Device 
Attributes

Define the 
SMTP server 
name.

Select Resource Manager Essentials > 
Administration > System Configuration, 
then select the SMTP tab.

Common Services > Server > Admin > 
System Preferences

Define rcp 
usernames.

Select Resource Manager Essentials > 
Administration > System Configuration, 
then select the rcp tab.

Common Services > Server > Admin > 
System Preferences

Table C-11 Job Approval Tasks (continued)

Task RME 3.5 Navigation RME 4.0 Navigation
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Table C-13 Network Show Commands Tasks1

Task RME 3.5 Navigation RME 4.0 

Browse 
NetShow Jobs

Select Resource Manager Essentials > 
Configuration Management > Network 
Show Commands > Batch Reports > Job 
Browser.

1. Select a job record.

2. Click Edit Job, Stop Job, Remove 
Job, Copy Job, or Job Details.

Select Resource Manager Essentials > 
Tools > NetShow > NetShow Jobs.

NetShow Batch 
Reports

Select Resource Manager Essentials > 
Configuration Management > Network 
Show Commands > Batch Reports.

Associating Devices and Command Sets 
can be done in the Job flow. There is no 
Batch Reports in 4.0 SP1.

View Job 
Details

Select Resource Manager Essentials > 
Configuration Management > Network 
Show Commands > Batch Reports > Job 
Browser.

1. Select a job record.

2. Click Job Details.

Select Resource Manager Essentials > 
Tools > NetShow > NetShow Jobs.

Click the Job ID hyperlink of the job 
whose details you want to see.

Create 
NetShow Jobs

Select Resource Manager Essentials > 
Configuration Management > Network 
Show Commands > Batch Reports> 
Schedule Reports.

Or

Select Resource Manager Essentials > 
Configuration Management > Network 
Show Commands > Immediate 
Execution. 

Select Resource Manager Essentials > 
Tools > NetShow > NetShow Jobs.

Click Create in the NetShow Job 
Browser.

Edit NetShow 
Jobs

Select Resource Manager Essentials > 
Configuration Management > Network 
Show Commands > Batch Reports > Job 
Browser.

1. Select a job record.

2. Click Edit Job.

Select Resource Manager Essentials > 
Tools > NetShow > NetShow Jobs.

1. Select a scheduled job. 

2. Click Edit in the NetShow Job 
Browser.
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Copy NetShow 
Jobs

Select Resource Manager Essentials > 
Configuration Management > Network 
Show Commands > Batch Reports > Job 
Browser.

1. Select a job record.

2. Click Copy Job.

Select Resource Manager Essentials > 
Tools > NetShow > NetShow Jobs.

1. Select the job you want to create a 
copy of.

2. Click Copy. 

Stop NetShow 
Jobs

Select Resource Manager Essentials > 
Configuration Management > Network 
Show Commands > Batch Reports > Job 
Browser.

1. Select a job record.

2. Click Stop Job.

Select Resource Manager Essentials > 
Tools > NetShow > NetShow Jobs.

1. Select the job you want to stop. 

2. Click Stop.

Delete 
NetShow Jobs

Select Resource Manager Essentials > 
Configuration Management > Network 
Show Commands > Batch Reports > Job 
Browser.

1. Select a job record.

2. Click Remove Job.

Select Resource Manager Essentials > 
Tools > NetShow > NetShow Jobs.

1. Select a job or a number of jobs that 
you want to delete.

2. Click Delete in the NetShow Job 
Browser.

View NetShow 
Output

Select Resource Manager Essentials > 
Configuration Management > Network 
Show Commands > Batch Reports > 
View Report Output.

Select Resource Manager Essentials > 
Tools > NetShow > Output Archive.

1. Select an Archive ID.

2. Click View.

View 
Command Set 
Details

Select Resource Manager Essentials > 
Administration > Configuration 
Management > Network Show > Define 
Command Set.

Select Resource Manager Essentials > 
Tools > NetShow > Command Sets.

Click the name of a Command Set in the 
List of Command Sets.

Create 
Command Sets

Select Resource Manager Essentials > 
Administration > Configuration 
Management > Network Show > Define 
Command Set.

Select Resource Manager Essentials > 
Tools > NetShow > Command Sets.

Click Create in the Command Sets 
window.

Table C-13 Network Show Commands Tasks1 (continued)

Task RME 3.5 Navigation RME 4.0 
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Edit Command 
Sets

Select Resource Manager Essentials > 
Administration > Configuration 
Management > Network Show > Define 
Command Set.

Select Resource Manager Essentials > 
Tools > NetShow > Command Sets.

1. Select the name of the Command Set 
in the List of Command Sets. 

2. Click Edit.

Delete 
Command Sets

Select Resource Manager Essentials > 
Administration > Configuration 
Management > Network Show > Define 
Command Set.

Select Resource Manager Essentials > 
Tools > NetShow > Command Sets.

1. Select the Command Set(s) you want 
to delete in the List of Command 
Sets. 

2. Click Delete.

Add Adhoc 
Commands

Select Resource Manager Essentials > 
Administration > Configuration 
Management > Network Show > Define 
Command Set.

Enter adhoc commands in the Custom 
Command Definition field.

Select Resource Manager Essentials > 
Tools > NetShow > Command Sets.

1. Enter the adhoc commands in the 
Adhoc Commands text box.

2. Click Add Adhoc.

Delete Adhoc 
Commands

Select Resource Manager Essentials > 
Administration > Configuration 
Management > Network Show > Define 
Command Set.

1. Select the custom command in the 
column on the right.

2. Click Delete in the Custom 
Command Definition field.

Select Resource Manager Essentials > 
Tools > NetShow > Command Sets.

1. Enter the adhoc commands in the 
Adhoc Commands text box.

2. Click Delete Adhoc.

Show Assigned 
Command Sets

Select Resource Manager Essentials > 
Administration > Configuration 
Management > Network Show > Assign 
Users.

Select Resource Manager Essentials > 
Tools > NetShow > Assigning Command 
Sets.

Enter the username in the Username field 
and click Show Assigned.

Table C-13 Network Show Commands Tasks1 (continued)

Task RME 3.5 Navigation RME 4.0 
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Assign 
Command Sets 

Select Resource Manager Essentials > 
Administration > Configuration 
Management > Network Show > Assign 
Users.

Select Resource Manager Essentials > 
Tools > NetShow > Assigning Command 
Sets.

1. Enter the username in the Username 
field.

2. Select the Command Sets that you 
want to allocate to the user from the 
Available User-Defined Command 
Sets list. 

3. Click Add. 

4. After you have added all the required 
Command Sets to the Selected 
User-Defined Command Sets list 
box, click Assign to assign the 
Command Sets access privileges to 
the specified user.

Assign Custom 
Command 
Execution 
Privilege

Select Resource Manager Essentials > 
Administration > Configuration 
Management > Network Show > Assign 
Users.

Select Resource Manager Essentials > 
Tools > NetShow > Assigning Command 
Sets.

1. Enter the username in the Username 
field.

2. Check the Custom Command 
Execution check box to assign 
custom command execution privilege 
to the user.

NetShow 
command line 
execution 

Use the cwconfig netshowbatch 
command.

Use the cwcli netshow command.

Configure Job 
Policies

Select Resource Manager Essentials > 
Configuration Management > Network 
Show Commands > Batch Reports > Set 
Job Policies.

Select Resource Manager Essentials > 
Admin > Config Mgmt > Config Job 
Policies and select NetShow from the 
drop-down list.

Table C-13 Network Show Commands Tasks1 (continued)

Task RME 3.5 Navigation RME 4.0 
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1.  NetShow tasks will be available after you install RME 4.0 SP1. RME 4.0 SP1 is available at 
http://www.cisco.com/cgi-bin/tablebuild.pl/cw2000-rme. The Readme for Resource Manager Essentials 4.0 Service Pack 1 
is also available at the same location.

Table C-14 Contract Connection Tasks1

Task RME 3.5 Navigation RME 4.0 

Access and use 
Contract 
Connection

Select Resource Manager Essentials > 
Contract Connection > Check Contract 
Status.

Select Resource Manager Essentials > 
Reports > Report Generator.

1. Select Contract Connection from the 
drop-down list box on the left.

2. Select Report Based on Contract from 
the drop-down list box on the right.

1. Contract Connection tasks will be available after you install RME 4.0 SP1. RME 4.0 SP1 is available at 
http://www.cisco.com/cgi-bin/tablebuild.pl/cw2000-rme. The Readme for Resource Manager Essentials 4.0 Service Pack 1 is 
also available at the same location.

Table C-15 Case Management Tasks (SmartCase)1

1. Case Management tasks will be available after you install RME 4.0 SP1. RME 4.0 SP1 is available at 
http://www.cisco.com/cgi-bin/tablebuild.pl/cw2000-rme. The Readme for Resource Manager Essentials 4.0 Service Pack 1 is 
also available at the same location.

Task RME 3.5 Navigation RME 4.0 

Open/Query or 
Update a case 
on Cisco.com

Select Management Connection > 
Case Management > Open Case.

or

Select Management Connection >
Case Management > Query or Update 
Case.

Select Resource Manager Essentials > 
Tools > SmartCase.

Table C-16 Availability Tasks

Task RME 4.0 

All Availability tasks These are not supported in RME 4.0.
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tasks (table) C-28

applications, preparing for use 2-1

CiscoWorks Server

accessing 2-4

configuring 2-6

Configuration Management 2-30

device configurations, modifying 2-30

device credentials, modifying 2-30

device security, modifying 2-34

NetConfig, setting up 2-35

device credentials, setting 2-8

Inventory 2-9

data, adding or importing 2-9

setting up 2-9

logging in 2-5

logging out 2-40

Software Management 2-18

casuser, allowing to us at and cron 2-29

downloaded files, space required for 2-18

preferences, setting 2-19

rcp, setting up 2-22
SCP, setting up 2-24

TFTP, setting up 2-19

Syslog Analysis, setting up 2-11

devices, configuring for 2-12

settings, verifying 2-17

Syslog Analyzer, verifying 2-17

task overview 2-2

attributes (see device credentials) 2-8

audience for this document ix

B

backing up your database before migration 1-23

browser

problems, troubleshooting A-8

requirements on client systems 1-8

C

casuser, allowing use of at and cron 2-29

Catalyst devices, configuring 2-13

cautions

regarding

cleanup after discontinued installation 
attempts A-15
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Index
system time, changing after installing 
RME 1-4

/tftp directory A-5

uninstalling RME, correct method 1-37

user configurable variable parameters A-10

significance of x

CD-ROM, mounting and unmounting B-1

mounting

local drive B-1

remote drive B-3

ummounting B-6

CE (Content Engine) devices

configuring using Telnet 2-14

Cisco IOS devices, configuring 2-12

CiscoWorks Server

accessing 2-4

access to, troubleshooting A-5

daemon manager not running A-7

proxy server problems A-6

verifying server is running A-6

configuring 2-6

performance, improving A-8

client requirements 1-7

browser 1-8

memory (RAM) 1-8

system hardware 1-8

system software 1-8

Configuration Management, setting up 2-30

device configurations, modifying 2-30

ensuring devices are rcp-enabled 2-31
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device security, modifying 2-34

NetConfig, setting up 2-35

device configurations, verifying 2-36

device prompts, verifying 2-37

device security, modifying 2-36

Syslog Analysis, configuring devices 
for 2-12, 2-34

Catalyst devices 2-13

Cisco IOS devices 2-12

Configuration Management application

Config Editor option

tasks (table) C-17

NetConfig option

tasks (table) C-15

configuring

CiscoWorks Server 2-6

devices for Syslog Analysis 2-12, 2-34

Catalyst devices 2-13

Cisco IOS devices 2-12

Content Engine (CE) devices

prompts 2-37

space for downloaded images 2-18

Content Service Switch (CSS) device

commands 2-37

prompts 2-37

credentials (see under device) 2-8

CSS (Content Service Switch) devices

configuring using Telnet 2-14
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D
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CiscoWorks Server daemon manager not 
running, troubleshooting A-7

rcp, enabling 2-23

TFTP, enabling 2-20

vold, and mounting the CD-ROM

local B-2

remote B-3

database password, changing (FAQ) A-12

device

Catalyst devices, configuring 2-13

Cisco IOS devices, configuring 2-12

configurations

for Syslog Analysis 2-12, 2-34

modifying 2-30

verifying 2-36

credentials

setting 2-8

verifying 2-36

importing devices 2-9

prompts, verifying for NetConfig 2-37

security, modifying

Configuration Management 2-34

NetConfig 2-36

device packages, downloading xiv

documentation

audience for this ix

device packages xiv
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drive space requirements for server 1-6

E

evalation version, upgrading from 1-31

F

file transfer servers, setting up

rcp 2-22

SCP 2-24

SCP, using for file transfers 2-25

TFTP 2-19

H

hardware requirements

client 1-8

server 1-6

I

IDUs (Incremental Device Updates), 
downloading xiv

importing devices 2-9

installing RME 1-1
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data migration from previous version 1-17

backing up data 1-23

migration script, running 1-19

installation notes 1-11

post-installation checklist 1-35

procedures 1-11

custom installations 1-16

general notes 1-10

typical installations 1-15

reinstallations 1-31

task overview 1-2

uninstalling 1-37

upgrades

from previous versions 1-4

from the evaluation version 1-31

installation program, running 1-31

installing RSAC (see RSAC) 4-1

Inventory, setting up 2-9

data, adding or importing 2-9

file transfer servers, setting up

rcp 2-22

SCP 2-24

TFTP 2-19

Inventory application

functional flow

tasks (table) C-5

IOS devices, configuring 2-12
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Job Approval application

tasks (table) C-28

L

licensing 3-1

nagging feature 3-5

device limit exceeded 3-7

evaluation version, before expiry 3-5

purchased version without a license 
file 3-6

new installations 3-3

overview 3-1

registering your license 3-3

licensing reminder feature 3-5

logging and tracking messages generated by 
devices, setting up 2-11

logging in

after upgrading A-1

Microsoft Internet Explorer A-2

Netscape Navigator A-2

as system administrator 2-5

logging out as system administrator 2-40

M

memory (RAM) requirements
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understanding A-2

generated by devices, logging and tracking, 
setting up 2-11

mounting and unmounting the CD-ROM B-1

mounting

local drive B-1

remote drive B-3

unmounting B-6

N

nagging feature

device limit exceeded 3-7

evaluation version, before expiry 3-5

purchased version without a license 3-6

NetConfig (Configuration Management option)

tasks (table) C-15

NetConfig, setting up 2-35

device

configurations, verifying 2-36

prompts, verifying 2-37

security, modifying 2-36

job setup

password policy 2-39

transport protocol order 2-38

Netra-T4 support (footnote) 1-6
Installation and Setup Guide fo
78-16504-01
O
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RME 1-2
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P

package deletion, troubleshooting failure 
of A-5

prerequisites 1-4

client requirements 1-7

browser 1-8

hardware 1-8
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software 1-8

server requirements 1-5

drive space 1-6

hardware 1-6

memory (RAM) 1-6

minimum requirements 1-5

recommended requirements 1-7

software, additional optional 1-6
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software, basic 1-6

supported device information 1-10

previous versions, upgrading from
IN-5
r Resource Manager Essentials 4.0 on Solaris



 

Index
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(FAQ) A-12

migration paths 1-4

process status, viewing A-8

proxy server problems, troubleshooting A-6

R

rcp, setting up 2-22

daemon, enabling 2-23

remote user account, creating 2-22

selecting as active file transfer method 2-24

reinstalling RME 1-31

custom reinstallation 1-34

typical reinstallation 1-33

RSAC (Remote Syslog Analyzer Collector)

Common Syslog Collector, subscribing 
to 4-4

installing 4-1

Remote Syslog Collector 4-3

Syslog Analyzer Collector 4-3

uninstalling RSAC 4-7
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COLLECTOR_PORT 4-10
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DEBUG_FILES 4-9
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TIMEZONE_FILE 4-8
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stopping 4-6

uninstalling 4-7

upgrading 4-3

S

SCP (Secure Copy) file transfer

setting up 2-24

using 2-25

server requirements and recommendations 1-5
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system hardware 1-6
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file transfer, using for 2-25

supported by RME 2-24

TFTP, setting up 2-19
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software requirements
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server

basic 1-6

optional additional 1-6

required additional 1-6
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Cisco IOS routers 2-33

stopping RSAC 4-6
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supported devices 1-10
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devices, configuring for 2-12

Catalyst devices 2-13

Cisco IOS devices 2-12

installing A-5
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Analyzer

CE devices 2-14

CSS devices 2-14

TFTP, setting up 2-19

daemon, enabling 2-20

/tftp directory, considerations when installing 
Syslog Analysis A-5

/tftpboot directory, creating 2-21

troubleshooting

CiscoWorks Server performance, 
improving A-8
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FAQs about A-9
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database backup, what data is 
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RME A-10
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process status, viewing A-8
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