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Troubleshooting the Installation

This appendix provides troubleshooting information for Essentials installation 
and setup. It contains these sections:

• Logging In After Upgrading

• Understanding Installation Messages

• Installing Syslog Analysis

• Failure to Delete a Package During Uninstallation

• Accessing the CiscoWorks2000 Server

• Viewing Process Status

• Browser Problems

• Improving Server Performance

Logging In After Upgrading
If the Login Manager dialog box on the CiscoWorks2000 desktop does not appear 
correctly when you try to log in for the first time after upgrading, clear your 
browser cache as follows, then reenter the server URL in your browser.

Note Wait for a few seconds after the server starts before logging in. If you have 
trouble logging in, use the Reload button on your browser.
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Understanding Installation Messages
For Microsoft Internet Explorer:

Step 1 Select View > Internet Options. The Internet Options dialog box appears.

Step 2 Select the General tab.

Step 3 Click Delete Files.

For Netscape Navigator:

Step 1 Select Edit > Preferences. The Preferences dialog box appears.

Step 2 Select Advanced > Cache.

Step 3 Click Clear Memory Cache, then click OK in the Memory Cache dialog box.

Step 4 Click Clear Disk Cache, then click OK in the Disk Cache dialog box.

Understanding Installation Messages
The messages that might appear during installation are:

• Information messages, which give you important details

• Warning messages, which tell you that something might be wrong with a 
particular process, but the process will complete

• Error messages, which tell you that a particular process could not complete

All messages that appear during installation are logged in the 
/var/tmp/ciscoinstall.log file.

Table A-1 shows messages that might occur during installation and describes their 
reasons.
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Understanding Installation Messages
Table A-1 Installation Messages

Message Reason for Message User Action

Base package did not install. 
Exiting.

Installation program cannot 
install a required package.

Contact your technical support 
representative.

Cannot backup /etc/services, no 
change will be made.

Installation program cannot make 
a copy of /etc/services before 
modifying it.

Make sure there is enough 
space in /tmp.

Cannot become owner of file in 
directory directory.

You cannot become the owner of 
a file in the directory you 
specified as the product root.

Check the permissions on the 
directory you specified.

Cannot change ownership of 
library. Exiting.

Installation program cannot write 
to product root directory.

Check the permissions on the 
directory you specified.

Cannot create directory. Installation program cannot write 
to the directory you specified.

Check the permissions on the 
directory you specified.

Cannot create symlink: 
ln -s root /opt/CSCOpx.

Installation program cannot 
create a link from /opt/CSCOpx 
to the product root directory you 
specified.

Contact your technical support 
representative.

Cannot determine the CD One 
version.

Installation disk is corrupted. Contact your technical support 
representative.

Cannot determine the version of 
product.

Installation program cannot 
determine product version.

Contact your technical support 
representative.

Cannot make list of packages for 
installation.

Installation suffered a major 
failure.

Contact your technical support 
representative.

Cannot make root dir. You do not have permission to 
make the product directory you 
gave the program.

Check the permissions on the 
root.

Cannot upgrade. Upgrade failed. Contact your technical support 
representative.

Copy setupdir to nmsroot failed. Installation program could not 
write to product root directory.

Check the permissions on the 
root.

Installation in progress. You are already running an 
installation on this machine.

Run only one installation 
program at a time.
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Understanding Installation Messages
Missing file file. Installation program cannot find a 
file.

Contact your technical support 
representative.

mkdir -p root failed. Exiting. Installation program was not able 
to create the product installation 
root you specified.

Check the permissions on the 
root.

No Syslog facility is available. No available Syslog facilities. Make one of the facilities 
available.

Not enough disk space: root. File system has insufficient space 
to load Essentials.

Make at least 4 GB of disk 
space available on the partition 
on which you install 
Essentials.

Package verification failed: pkg 
aborting.

While loading packages, one 
package loaded incorrectly.

Contact your technical support 
representative.

Syslog is not running. Installation program cannot start 
syslogd on this machine.

Restart syslogd.

The components have dependency 
errors.

Installation program suffered a 
major failure.

Contact your technical support 
representative.

User casuser appears in 
/usr/lib/cron/at.deny. Software 
Image Manager requires casuser 
to be able to run at. Contact your 
local technical support 
representative to edit the file 
/usr/lib/cron/at.deny and remove 
the entry for casuser.

User casuser appears in 
/usr/lib/cron/cron.deny. Software 
Image Manager requires casuser 
to be able to run crontab. Contact 
your local technical support 
representative to edit the file 
/usr/lib/cron/cron.deny and 
remove the entry for casuser. 

Software Management requires 
that the user bin be allowed to use 
at and cron.

Edit the relevant files to allow 
the user bin to use at and cron. 
For information, see 
“Allowing the User casuser to 
Use at and cron” section on 
page 2-27.

Table A-1 Installation Messages (continued)

Message Reason for Message User Action
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Installing Syslog Analysis
Installing Syslog Analysis
If the Essentials installation fails during Syslog Analysis installation, make sure 
you do not have the Cisco DNS/DHCP Manager (CDDM) installed on the same 
machine as Essentials. CDDM, which can be downloaded from CCO, provides 
syslog and TFTP daemons as part of its product. You cannot run CDDM Syslog 
or TFTP on the same machine as Essentials because they are not compatible. 
Make sure the server on which you install Essentials is not running CDDM Syslog 
or TFTP. The following message is displayed:

WARNING: The tftp directory ‘/usr/tftpdir’ appears to be NFS mounted.
Using NFS directories often increases the software transfer time and 
may cause a failure during distribution of the software to the device.
Contact your local technical support representative to make 
‘/usr/tftpdir’ a local directory.

Failure to Delete a Package During Uninstallation
If you try to remove Essentials but the uninstallation program fails to delete a 
package, try running the uninstall program again. Several circumstances can 
cause a package to remain after uninstallation. Usually, running the uninstall 
program again removes the package. 

There may be times when the installation process is interrupted or aborted. The 
uninstallation program may not work in such cases.

User must be root. You must be root to install the 
product.

Log in as root and enter the 
correct password.

Wrong OS. Operating system is not HP-UX 
or not a supported version of 
HP-UX.

Make sure that you are running 
HP-UX 11.0.

Table A-1 Installation Messages (continued)

Message Reason for Message User Action
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Failure to Delete a Package During Uninstallation
To Clean Up a Broken Install
If you have interrupted the installation process by pressing Ctrl-C or the process 
was abandoned before installation was complete, the install gets broken. If the 
uninstallation program fails to delete a package, you can use the fpkgdel.sh script 
to remove all packages. 

Step 1 As root, mount the Essentials CD-ROM. You can either:

• Mount the CD-ROM on the CiscoWorks2000 Server system.

or

• Mount the CD-ROM on a remote AIX system, then access the CD-ROM from 
the CiscoWorks2000 Server system.

See Appendix B, “Mounting and Unmounting the CD-ROM” for detailed 
mounting instructions.

Step 2 Start the delete packages program.

• For a local installation, enter:

# cd /cdrom/install
# ./fpkgdel.sh 

• For a remote installation, enter:

# cd remotedir/install
# ./fpkgdel.sh

where remotedir is the remote location where the CD-ROM is mounted.

To reinstall Essentials, follow the instructions in the “Reinstalling or Upgrading 
from the Evaluation Version” section on page 1-17.
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Accessing the CiscoWorks2000 Server
Accessing the CiscoWorks2000 Server
The CiscoWorks2000 Server uses port 80 by default. This port is normally used 
by web servers. If you receive an error message that an existing web server is 
already configured to run on port 80, and the alternative port 1741 is used instead, 
verify that you entered the correct URL for the server:

http://server_name:1741 

where server_name is the name of the machine where Ciscoworks2000 was 
installed, and 1741 is the alternative port on which CiscoWorks2000 is installed 
if port 80 is in use.

Verify the Server Is Running
To make sure your server is running, enter:

ping server_name

Proxy Server Problems
If you get a message that the server is “alive,” and get a proxy error when you try 
to connect to the server, make sure the proxy is set up correctly. If your server is 
configured to use a proxy server outside the firewall (specified in Netscape 
Navigator under Options > Network Preferences > Proxies), you will get proxy 
errors if you configured the proxy to ignore requests to a certain machine, set of 
machines, or domain. 

Your proxy is set up incorrectly if: 

• You receive an error message that you are using a proxy outside the firewall.

• The proxy server recognizes www-int as an internal server, so it does not 
proxy requests to that server.

• You set up a new internal server, www-nms, but when you make a request to 
the proxy server, it does not recognize www-nms as an internal server and 
proxies the request.
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Viewing Process Status
• The proxy server outside the firewall tries to request data from a server inside 
the firewall, and the request is blocked.

• You get a “Connection Refused” error from the proxy server.

Daemon Manager Not Running
If the Daemon Manager is not running, CiscoWorks2000 cannot run. When you 
install or uninstall CiscoWorks2000, the Daemon Manager is temporarily stopped 
and then restarted. If the install or uninstall process is interrupted, the Daemon 
Manager might remain in the stopped state.

Note Wait a few seconds after the server starts before logging in. If you have trouble 
logging in, use the Reload button on your browser.

To start or stop the Daemon Manager:

Step 1 Log in as root.

Step 2 Open a shell window.

Step 3 Start the server by entering:

# /sbin/init.d/dmgtd start

Step 4 Stop the server by entering:

# /sbin/init.d/dmgtd stop

Viewing Process Status
You can check back-end server process failures by selecting Server 
Configuration > Administration > Process Management > Process Status. 
Only users with administrator privileges can start and stop processes. For details, 
refer to Getting Started with the CiscoWorks2000 Server.
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Browser Problems
Browser Problems
If the desktop buttons do not work, Java and JavaScript are not enabled. Make sure 
you enable Java and JavaScript.

Make sure the browser cache is not set to zero.

Do not resize the browser window while the desktop main page is loading. This 
can cause a Java error.

For more information about setting up browsers, refer to Installing and Setting Up 
CD One on HP-UX.

Improving Server Performance
To improve system performance for Essentials:

• Reduce the number of managed devices polled by Availability.

• Increase the interval used by Availability to poll managed devices.

• Reduce the number of syslog messages saved to the CiscoWorks2000 
database.

• Increase the interval used by Configuration Management to collect 
information about managed devices.
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Improving Server Performance
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