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M Description

Description

CiscoWorks LMS 2.2/LMS 1.3 Update 1 contains the following updates:

CiscoWorks Common Services 2.2 with Service Pack 2 (includes
CiscoView 5.5 Update 1 and CiscoWorks Common Services 2.2 Service
Pack 1)

Resource Manager Essentials 3.5 Update 1
Campus Manager 3.3 Update 1
Device Fault Manager 1.2 Updated for Common Services Version 2.2

Real-Time Monitor 1.4 Service Pack 8

CiscoWorks LMS 2.2/LMS 1.3 Update 1 provides new support for the following:

Java Plug-in 1.4.1_02

Windows 2000 Service Pack 4 (SP4) (client and server)
Windows XP Service Pack 1a (SP1a) (client)

Netscape Navigator 7.0 (Solaris)

Netscape Navigator 7.1 (Windows)

Secure Shell 1.99

Table 1 describes the content of each update.

CiscoWorks LMS 2.2/LMS 1.3 Update 1 also provides resolutions to known
problems for individual applications (see the “Resolved Problems” section on
page 41).

This Update is cumulative for all applications in the

LAN Management Solution (LMS), Release 2.2 bundle that use the
CiscoWorks Common Services 2.2 framework. It is provided as a single
installable and contains updates for the following applications:

CiscoWorks Common Services 2.2 (includes CiscoView 5.5)
Resource Manager Essentials 3.5
Campus Manager 3.3 Update 1

Device Fault Manager 1.2 Updated for Common Services Version 2.2
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If you are using more than one bundled product (e.g., you use LMS and RWAN),
you must install the Update for each bundled product on all servers where that
bundled product or any part of it is installed. This will ensure that all applications
work properly. You may install the bundle Updates in any order.

Changes for NetScout nGenius Real-Time Monitor 1.4 Service Pack 8 (RTM) are
part of this update. However, the RTM upgrade is located in a different directory
and will not install with the Update 1 installation. To install RTM Service Pack 8,
see the “Installing Real-Time Monitor SP 8” section on page 23.

Table 1 CiscoWorks LMS 2.2/LMS 1.3 Update 1 Contents

Update Contents

CiscoWorks Common e Java Plug-in 1.4.1_02 support
Services 2.2 Service Pack 2
(Includes CiscoView 5.5

Update 1 and CiscoWorks
Common Services 2.2 e  Windows 2000 SP4 support (client and server)

Service Pack 1) e Windows XP SPla support (client)

e Netscape Navigator 7.x support (Netscape Navigator 7.0 on
Solaris and Netscape Navigator 7.1 on Windows)

¢ Fixes for problems in CiscoWorks Common Services 2.2.

Resource Manager e Java Plug-in 1.4.1_02 support

Essentials 3.5 Update 1(RME) e Netscape Navigator 7.x support (Netscape Navigator 7.0 on
Solaris and Netscape Navigator 7.1 on Windows)

e Windows 2000 SP4 support (client and server)

e Windows XP SP1la support (client).

Campus Manager 3.3 Update 1 e Java Plug-in 1.4.1_02 support

(Campus) e Netscape Navigator 7.x support (Netscape Navigator 7.0 on

Solaris and Netscape Navigator 7.1 on Windows.)

e  Windows 2000 SP4 support (client and server)

e Windows XP SP1la support (client).
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Table 1 CiscoWorks LMS 2.2/LMS 1.3 Update 1 Contents (continued)

Update Contents

Device Fault Manager 1.2 e Java Plug-in 1.4.1_02 support
Updated for Common Services

Version 2.2 (DFM) e Netscape Navigator 7.x support (Netscape Navigator 7.0 on

Solaris and Netscape Navigator 7.1 on Windows.)
e  Windows 2000 SP4 support (client and server)
e Windows XP SP1la support (client)
e Fixes for DFM-specific problems.

Real-Time Monitor 1.4 Service | ¢ Java Plug-in 1.4.1_02 support

Pack 8 e Netscape Navigator 7.x support (Netscape Navigator 7.0 on

Solaris and Netscape Navigator 7.1 on Windows)

e  Windows 2000 SP4 support (client and server)

e Windows XP SP1la support (client).
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CiscoWorks LMS 2.2 Documentation

CiscoWorks LMS 2.2 Documentation

For information about installing, troubleshooting, and using the LMS 2.2
products, consult the documentation described in Table 2.

~

Note = We sometimes update printed and online product documentation after the original
publication. For this reason, you should always review the documentation on
Cisco.com for any updates.

Table 2 LMS 2.2 Documentation

Document Title Available Formats

Quick Start Guide for LAN e Printed document included with the product.
Management Solution, Release 2.2

¢ On Cisco.com:
a. Log in to Cisco.com

b. Select Products and Services > Network
Management CiscoWork > CiscoWorks LAN
Management Solution Software > Technical
Documentation > Quick Start > Quick Start Guide
for LAN Management Solution, Release 2.2.
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Hardware and Software Requirements

Hardware and software requirements for CiscoWorks LMS 2.2/LMS 1.3 Update 1
are the same as those for initial installation of CiscoWorks LMS 2.2, except for
the following:

e Specific updates to browser support (see the “Changes in Browser Support”
section on page 6)

e Specific updates to Java support (see the “Changes in Java Support” section
on page 7)

For a listing of the basic hardware and software requirements, see the Quick Start
Guide listed in the “CiscoWorks LMS 2.2 Documentation” section on page 5.

Changes in Browser Support

CiscoWorks LMS 2.2/LMS 1.3 Update 1 supports the following browsers:
¢ On Solaris:
— Netscape Navigator 7.0
— Netscape Navigator 4.76
* On Windows:
— Internet Explorer 6.0 and 6.0 SP1
— Netscape Navigator 7.1, 4.78, and 4.79

~

Note Do not select the option Edit > Preferences > Advanced > Enable Java Plug-in
in Netscape Navigator 4.7x, if available. Some CiscoWorks applets may not load
properly if this option is selected.
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Changes in Java Support

Note

Since the Microsoft Virtual Machine (VM) has been removed from new Microsoft
products going into distribution, CiscoWorks Common Services 2.2 SP2 provides
Java Plug-in 1.4.1_02 support to users who prefer to continue using Internet
Explorer as their browser.

This support is provided as an alternative to the Microsoft VM, not as a
replacement for it. If the Microsoft VM is still present in the version of Internet
Explorer you use, you can continue using it. If no browser VM is present,
CiscoWorks applets will use Java Plug-in 1.4.1_02 as the default.

Providing support for Java Plug-in 1.4.1_02 ensures that CiscoWorks Common
Services and the applications it supports remain stable across all current browsers,
browser versions, and operating systems. It affects only those CiscoWorks
applications that use Java applets, such as CiscoView and NetConfig.

You may see special behaviors the first time you run the updated version of
CiscoWorks Common Services 2.2 on Internet Explorer or Netscape Navigator.
These behaviors will vary with the operating system, browser, browser version,
and Java VM you are currently using.

Table 3 summarizes the conditions under which you will see these behaviors and
the actions you should take in each case. See also the “General Recommendations
on Java Plug-in 1.4.1_02” section on page 10.

Sun has issued an Alert Notification for Java Plug-in 1.4.1_02. For details, see
http://sunsolve.sun.com. Customers who are concerned about this Alert
Notification should see the “Using Sun Java Plug-in 1.4.1_05" section on page 13.

In Internet Explorer, a dummy applet is loaded before the login page in order to
detect whether the browser has a Java VM. This may cause a slight delay in
getting to the login page.

[ 78-16054-01
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Table 3

Java Plug-in First-Time Setup Behaviors

Browser

Symptom

Recommended Action

Any supported browser

The first time you run ACL
Manager or IPM, a message
appears, prompting you to

download the file vbjorb.jar.

1. Click OK to download the file.

2. Close and restart your browser.

Internet Explorer with an
unsupported Java Plug-in (e.g.,
1.4.1_03) as your default Java
VM

If you use an unsupported Java
Plug-in and chose the Internet
Explorer option Use

< JPI version > for

< applet >, a message
appears, indicating that you
are using an unsupported Java
Plug-in.

1. Click OK.
You are directed to a help
page.

2. Follow the instructions given
in the help page.

Internet Explorer with Microsoft
VM

You are prompted to install
Java Plug-in 1.4.1_02 only
when you run a Plug-in
application, such as
CiscoView or NetConfig.

Follow the recommended
installation instructions.

You may check or uncheck Tools >
Internet Options > Advanced >
UseJava2v 1.4.1_02 for <applet>.

If you check it, all CiscoWorks
applets will run in Java Plug-in
1.4.1_02.

If you uncheck it, only CiscoWorks
applications that require it (e.g.,
CiscoView, NetConfig) will use
Java Plug-in 1.4.1_02. Others will
use the Microsoft VM.
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Table 3

Java Plug-in First-Time Setup Behaviors (continued)

Hardware and Software Requirements

Browser

Symptom

Recommended Action

Internet Explorer without
Microsoft VM (on Windows XP)

Instructions to install Java
Plug-in 1.4.1_02 appear as
soon as you run CiscoWorks
Common Services 2.2.

Follow the recommended
installation instructions.

If you have the Internet Explorer
option Install on demand (on
Windows XP) enabled, you are
prompted to download the Java
VM.

1. Click Cancel (not OK).

2. Follow the recommended
installation instructions.

Netscape Navigator 4.76 on

You are prompted to install

Follow the installation

Solaris, Netscape Navigator 4.78 |Java Plug-in 1.4.1_02 only instructions.
or 4.79 on Windows when you run a plug-in

application, such as

CiscoView, NetConfig, etc.
Netscape Navigator 7.x with an |A message appears, indicating | 1. Click OK.

unsupported Java Plug-in
installed (e.g., 1.4.1_03)

that you are using an
unsupported Java Plug-in.

You are directed to a help
page.

2. Follow the instructions given
in the help page.

Netscape Navigator 7.x with no
Java Plug-in installed

Instructions to install Java
Plug-in 1.4.1_02 appear when
you run CiscoWorks Common
Services 2.2.

Follow the installation
instructions.

[ 78-16054-01
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General Recommendations on Java Plug-in 1.4.1_02

The following sections give general recommendations and procedures to follow
when installing and using the Java Plug-in (JPI):

Installing and Using Java Plug-in 1.4.1_02 on Windows, page 10
Before Using Java Plug-in 1.4.1_02 on Solaris, page 11

Installing and Uninstalling Java Plug-in 1.4.1_02 on Solaris, page 12
Using Sun Java Plug-in 1.4.1_05, page 13

Installing and Using Java Plug-in 1.4.1_02 on Windows

See the help pages for instructions on installing or using Java Plug-in 1.4.1_02 on
Windows. You should also be aware of the following:

Uninstall any older or later Java Plug-in versions and install only the
supported Java Plug-in version (1.4.1_02). If you do not follow the
uninstall/reinstall sequence, it may cause some co-existence issues.

In some cases, uninstalling Java Plug-in 1.4.1_02 disables the Microsoft VM
in Internet Explorer. To enable the Microsoft VM again, you must install Java
Plug-in 1.4.1_02 again.

If you are using Internet Explorer, we recommend that you set the Security
Settings (Tools > Internet Options > Security) to the default level for
security zones such as Internet and Local Intranet. If you customize the
options, some of the functionality may not work as expected.

Java Plug-in 1.4.1_02 has some co-existence issues with Java Plug-in 1.3.1,
as given below:

— In the same browser session, if one of the applets uses JPI 1.4.1_02 and
another tries to use JPI 1.3.1, the browser crashes.

— If you run an applet using JPI 1.3.1 first, and then try to run another
applet using JPI 1.4.1_02, the server displays the error message
Attachment to a running Virtual Machine failed. Sun JPIs do not
support multiple VMs in the same browser session.

In general, avoid using applets with different Java Plug-in versions in the
same browser session.

Readme for CiscoWorks LMS 2.2/LMS 1.3 Update 1
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e Select Yes for all the Java Plug-in dialog boxes. If you select No in any of the
Java Plug-in dialog boxes, exceptions appear on the Java Console. In such a
case, close the browser session and start the Java Plug-in again.

When you run CiscoWorks Server in SSL mode, a dialog box prompts you to
accept or deny the Certificate. The certificate gives the details about the
hostname mismatch, certificate validity and so on.

Select Yes and accept these certificates to get the login Panel. Do not select
No in the Certificate dialog boxes.

e Do not resize the browser windows after starting the applet.

While using Internet Explorer 6.0 with Service Pack 1 and Java Plug-in
1.4.1_02, if you run an applet and resize Internet Explorer, only part of the
applet is displayed.

If you resize the window to full screen, part of the applet that was not covered
will not be displayed properly. To correct this, start the applet again.

You must do the same if you are using Netscape.

e If you are using Netscape 7.1 on Windows: Some CiscoWorks applications
that are launched in new browser windows may not start properly if you have
the following option enabled: Edit > Preferences > Privacy & Security >
Popup Windows > Block unrequested popup windows.

We recommend that you leave this option disabled. It is possible to enable this
option and still allow popups for CiscoWorks only; see the Netscape Help for
details on how to do this.

Before Using Java Plug-in 1.4.1_02 on Solaris

When installing or using Java Plug-in 1.4.1_02 on Solaris, we recommend:

e Be sure to install only the version of Netscape available from the Sun site:
http://wwws.sun.com/software/solaris/netscape/get.html.

e Install all the recommended and required Solaris patches for Netscape and
Java Plug-in 1.4.1_02. If you do not install the operating system patches, you
may experience browser crashes, core dumps, bus errors, or other abnormal
behavior when you access CiscoWorks.

[ 78-16054-01
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¢ Be sure to install Java Plug-in 1.4.1_02 using the wrapper script provided
with CiscoWorks (pam.sh). This script sets up the environment required to
access CiscoWorks through Netscape. Do not download and install the Java
Plug-in directly.

e If you are using Netscape 7.0, ensure that you have write access to the

Netscape 7.0 directory, as you need to configure it to work with Java Plug-in
1.4.1_02.

e Ifyou have installed Java Plug-in 1.4.1_02 using pam.sh, it will overwrite the
previous configurations of Java Plug-in 1.3.1.

e Do not access CiscoWorks through ReflectionX. You should access
CiscoWorks directly from Solaris systems. Otherwise, the browser may crash
if you do not have the required Solaris patches.

Installing and Uninstalling Java Plug-in 1.4.1_02 on Solaris
When you access an application that requires Java Plug-in 1.4.1_02, you will be
redirected to a help page. This page contains instructions to install the Plug-in.

From the help page, download the installable image of the Java Plug-in. You must
uncompress and untar the installable image. When you untar the image, you get
the plug-in installation script (pam.sh), a directory named plugin, and a README
file.

To install Java Plug-in 1.4.1_02 on Solaris:

Step 1 Run pam. sh.
Step2  Select Option 1.
Step3  Configure Java Plug-in with Netscape 4.76 or Netscape 7.0.

To use CiscoWorks, you must configure the Java Plug-in to work with at least one
of the Netscape versions mentioned in this document.

You can also modify the configurations with Netscape later by choosing Option 3
in the pam.sh script.

Step4  Before accessing CiscoWorks, source the corresponding file (/jpi.cshrc or
/jpi.profile) before restarting your browser, to get the correct environment.

Readme for CiscoWorks LMS 2.2/LMS 1.3 Update 1
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To uninstall Java Plug-in 1.4.1_02 on Solaris:

Step 1 Run pam. sh.
Step2  Select Option 2.

The Plug-in is uninstalled from your system.

Using Sun Java Plug-in 1.4.1_05

Sun Alert Notification 56380 concerns a security vulnerability in

Java Plug-in 1.4.1_02. Customers using LMS’ SSL features should review the Sun
Alert and determine their level of risk. If you are not using SSL with LMS, you
should use the Java Plug-in 1.4.1_02, which is installed with

CiscoWorks LMS 2.2/LMS 1.3 Update 1.

At the time of this release (October 2003), Java Plug-in 1.4.1_02 was the only
version tested and recommended for use with

CiscoWorks LMS 2.2/LMS 1.3 Update 1. Cisco will examine additional
alternatives, including Sun Java Plug-in 1.4.1_05. Information released after this
print about supported versions of the Java Plug-in will be posted on the
CiscoWorks Server software download page on Cisco’s web site:
http://www.cisco.com/cgi-bin/tablebuild.pl/cw2000-cd-one.

Customers who want to use Sun’s Java Plug-in 1.4.1_05 instead of the one
provided in CiscoWorks LMS 2.2/LMS 1.3 Update 1 can apply the plug-in
manually using the procedure given below.

If you change to Java Plug-in 1.4.1_05 on the server and one client, you must
change to version 1.4.1_05 on all of your clients. You cannot run the updated
version of LMS using clients with a mix of different Java Plug-in versions.

Also, since Cisco has not fully tested LMS with Java Plug-in 1.4.1_05, you may
encounter problems.

Readme for CiscoWorks LMS 2.2/LMS 1.3 Update 1
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Step 1

Step 2

Step 3

Step 4
Step 5
Step 6

Step 7

To modify your CiscoWorks installation to use Sun Java Plug-in 1.4.1_05:

Install CiscoWorks CiscoWorks LMS 2.2/LMS 1.3 Update 1 normally.

This includes installation of Java Plug-in 1.4.1_02 on Solaris and Windows clients
the first time you run CiscoWorks.

On the updated CiscoWorks Server (either Solaris or Windows): Locate the Java
Plug-in properties file /NMSROOT/1ib/classpath/javaplugin.properties (where
NMSROOT is the path to the CiscoWorks Server directory)

Change the following entries in the javaplugin.properties file to reflect the new
Java Plug-in version:

e Existing entries for Java Plug-in 1.4.1_02:

WIN_IE_VERSION=clsid:CAFEEFAC-0014-0001-0002-ABCDEFFEDCBA
WIN_NS_VERSION=application/x-java-applet;jpi-version=1.4.1_02
SOL_VERSION=application/x-java-applet;jpi-version=1.4.1_02

e Modified entries for Java Plug-in 1.4.1_05:
WIN_IE_VERSION=clsid:CAFEEFAC-0014-0001-0005-ABCDEFFEDCBA

WIN_NS_VERSION=application/x-java-applet;jpi-version=1.4.1_05
SOL_VERSION=application/x-java-applet;jpi-version=1.4.1_05

N
Note Do not change the following entry:
IE_PLUGINS_PAGE=/plugin/j2re-1_4_1_02-windows-1i586-1.exe

Save the modified javaplugin.properties file

Restart the CiscoWorks Common Services Daemon Manager.

Update each Windows client as follows:

a. Download Java Plug-in 1.4.1_05 for Windows.

b. Install the Java Plug-in on the client according to Sun’s instructions.
c. Close any running browser instances and start them again.

Update each Solaris client as follows:

a. Download Java Plug-in 1.4.1_05 for Solaris

b. Install the Java Plug-in on the client according to Sun’s instructions.

Readme for CiscoWorks LMS 2.2/LMS 1.3 Update 1
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¢. Locate the jpi.profile and jpi.cshrc files on the client and change the
MOZ_PLUGIN_PATH, NPX_PLUGIN_PATH, NPX_JRE_PATH, and similar variables
in these files to reflect the path to Java Plug-in 1.4.1_05. For example,
assuming that 1.4.1_02 was installed in /opt/jre14102, and that 1.4.1_05 is
installed in /opt/jre14105:

Change:
MOZ_PLUGIN_PATH=/opt/jreld102/j2rel.4.1_02/plugin/sparc/ns610

To:
MOZ_PLUGIN_PATH=/opt/jreld105/j2rel.4.1_05/plugin/sparc/ns610.

d. Close any running browser instances and start them again.
Step8  Update each Solaris client using Netscape 7.0 as follows:
a. Modify the links to point to the links for Java Plug-in 1.4.1_05:
Change: "NS7_HOME" /plugins/libjavaplugin_oji.so
To: "gPI1.4.1_05_HOME"/plugin/sparc/ns610/libjavaplugin_oji.so
b. Source /jpi.cshrc or /jpi.profile.

¢. Close any running browser instances and start them again.
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Prerequisites for CiscoWorks LMS 2.2/LMS 1.3
Update 1

Ensure that you have completed the following tasks before installing
CiscoWorks LMS 2.2/LMS 1.3 Update 1. After you have completed these tasks,
you can install this Update using the instructions in the

“Installing CiscoWorks LMS 2.2/LMS 1.3 Update 1” section on page 18.

Install CiscoWorks Common Services 2.2 and the LMS applications to be
updated. For details, see the Quick Start Guide for your LMS bundle listed in the
“CiscoWorks LMS 2.2 Documentation” section on page 5.

Please note:

e If you decide not to install one or more of the LMS applications at this point,
then install them later, you must remember to reapply
CiscoWorks LMS 2.2/LMS 1.3 Update 1 after you install the missing
applications.

e If you have installed Resource Manager Essentials (RME), you must also
install Incremental Device Update (IDU) 5.0 for Resource Manager
Essentials 3.5 before you attempt to install
CiscoWorks LMS 2.2/LMS 1.3 Update 1. The IDU 5.0 for RME 3.5 and the
accompanying README explaining how to install it are available:

— On the IDU Prerequisite CD in your product package. For the Solaris
version, see the folder /Solaris/IDU for Resource Manager Essentials.
For the Windows version, see the folder \Windows\IDU for Resource
Manager Essentials.

— Through download from Cisco.com at the following URL:
http://www.cisco.com/cgi-bin/tablebuild.pl/cw2000-rme.

e If you have installed Campus Manager (CM), you must also install
Incremental Device Update (IDU) 5.0 for Campus Manager 3.3 before you
attempt to install CiscoWorks LMS 2.2/LMS 1.3 Update 1. The IDU 5.0 for
CM 3.3 and the accompanying README explaining how to install it are
available:

— On the IDU Prerequisite CD in your product package.

For the Solaris version, see the folder /Solaris/IDU for Campus Manager.
For the Windows version, see the folder \Windows\IDU for Campus
Manager.
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— Through download from Cisco.com at the following URL:
http://www.cisco.com/cgi-bin/tablebuild.pl/cw2000-campus.

e If you have installed Device Fault Manager (DFM), you must also install
either the DFM 1.2 Patch/Incremental Device Update (IDU) 1.2.5, or the
latest DFM patch/IDU, before you attempt to install CiscoWorks LMS
2.2/LMS 1.3 Update 1.

— The DFM 1.2 Patch/IDU 1.2.5 and the accompanying README
explaining how to install it are available on the IDU Prerequisite CD in
your product package.

For the Solaris version, see the folder /Solaris/IDU for Device Fault
Manager.

For the Windows version, see the folder \Windows\IDU for Device Fault
Manager.

— The latest DFM 1.2 patch/IDU and the accompanying README
explaining how to install it are available through download from
Cisco.com at the following URL:
http://www.cisco.com/cgi-bin/tablebuild.pl/cw2000-dfm.

e If you have received the OpenSSL 0.9.7¢ patch for
CiscoWorks Common Services 2.2 (see bug ID CSCec43722), be sure to
install it after you install CiscoWorks LMS 2.2/LMS 1.3 Update 1.

If you have already installed the OpenSSL patch, you must reinstall it after
you install CiscoWorks LMS 2.2/LMS 1.3 Update 1.

e RTM 1.4 must be installed before you upgrade to
Real-Time Monitor 1.4 Service Pack 8.

Downloading CiscoWorks LMS 2.2/LMS 1.3 Update 1

CiscoWorks LMS 2.2/LMS 1.3 Update 1 is available for download from the
Cisco.com Software Center site:

1. Log into Cisco.com.

2. Go to www.cisco.com/kobayashi/sw-center/cw2000/lan-planner.shtml
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Installing CiscoWorks LMS 2.2/LMS 1.3 Update 1

~

Note

Before installing this Update on either platform, make sure you have completed
the tasks listed in the “Prerequisites for CiscoWorks LMS 2.2/LMS 1.3 Update 1”
section on page 16.

CiscoWorks LMS 2.2/LMS 1.3 Update 1 is provided as a single installable. Use
the appropriate procedure to install it:

¢ Installing CiscoWorks LMS 2.2/LMS 1.3 Update 1 on Solaris
e Installing CiscoWorks LMS 2.2/LMS 1.3 Update 1 on Windows, page 21

You cannot uninstall CiscoWorks LMS 2.2/LMS 1.3 Update 1 after you install it.

Installing CiscoWorks LMS 2.2/LMS 1.3 Update 1 on Solaris

Step 1

Step 2

If you have downloaded the Update for Solaris, you must first extract the
installable files from CiscoWorks-LMS-2.2-LMS-1.3-Update-1-k9.tar.

To install the Update on Solaris:

Log in as root on the system on which you installed Common Services.

To install the Update, you must have superuser privileges on the system being
updated.

Mount the Update CD-ROM using one of the following methods:
e Mount the CD-ROM on the CiscoWorks Server system.
or

¢ Copy the file setup.sh to the appropriate directory.
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Step 3

Step 4

Step 5

Step 1
Step 2

Installing CiscoWorks LMS 2.2/LMS 1.3 Update1

Start the installation using one of the following methods:
e For a local installation, enter:

# cd /cdrom/cdrom0/
# sh ./setup.sh

e For a remote installation, enter:

# cd remotedir
# sh ./setup.sh

where remotedir is the remote location where the CD-ROM is mounted.
The Software License Agreement (SLA) appears.
Accept the SLA to continue.
The setup script displays a list of the updates to be installed or reinstalled.

Press any key to install or reinstall all of the updates, or enter q to cancel
installation.

If the system you are updating has had some, but not all, of these updates
previously installed, the install script will list the new updates and those it will
reinstall:

e Enter 1 to install only the new updates not yet present on the system.
e Enter 2 to install all new updates and reinstall all old updates.

When you press Enter, files are copied and applications are configured.
Installation takes approximately 15 minutes.

After the installation is completed, the setup script exits.

After you install the Update on Solaris, you must verify the installation. To do
this:

Launch CiscoWorks.
Select Server Configuration > About the Server > Applications and Versions.

The About the Server page appears.
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For each application you have chosen to install: If Update installation was
successful, you will see the following entries in the Packages Installed table on

this page:

Update Columns in the Packages Installed Table
Name Version | Installed Patches

CiscoWorks Common |CiscoWorks Common |2.2 2

Services 2.2 with SP2 |Services with SP2

Resource Manager Resource Manager 3.5 3

Essentials with Essentials with

Update 1 Update 1

Campus Manager Campus Manager with |3.3 3

with Update 1 Update 1

Device Fault Manager |DFMSD 1.2 5!

with Update 1

1. If you installed a later DFM 1.2 Patch/IDU, this number should match the last number of the

patch/IDU version—for example, 6 for 1.2.6, 7 for 1.2.7, and so forth.

i Readme for CiscoWorks LMS 2.2/LMS 1.3 Update 1

78-16054-01 |



Installing CiscoWorks LMS 2.2/LMS 1.3 Update1

Installing CiscoWorks LMS 2.2/LMS 1.3 Update 1 on Windows

Step 1

Step 2

Step 3

Step 4

Step 5

To install the Update on Windows:

Start the Update installation using either of the following methods:

e If you have the Update on CD-ROM and autorun is enabled on your system,
place the CD-ROM in the CD-ROM drive.

e If autorun is not enabled on your system or you are using a downloaded copy
of the Update:

— Run the installation setup script by double-clicking the file
CiscoWorks-LMS-2.2-LMS-1.3-Update-1-k9.exe.

or

— Select Start > Run, navigate to the location of the file
CiscoWorks-LMS-2.2-LMS-1.3-Update-1-k9.exe, and click OK.

The CiscoWorks LMS 2.2/LMS 1.3 Update 1 confirmation screen appears.
Click Yes.

The Welcome screen appears.

Click Next to continue.

The Software License Agreement window appears. You must accept this
agreement to install CiscoWorks LMS 2.2/LMS 1.3 Update 1.

Click Yes to continue.

The installation program checks dependencies and system requirements. The
System Requirements window appears.

The System Requirements window displays the system requirements, available
space in the disk drive and temp directory, and available memory in megabytes.

Click Next to continue.

The Summary window appears, displaying the updates that will be installed and
the settings for the installation.

[ 78-16054-01

Readme for CiscoWorks LMS 2.2/LMS 1.3 Update 1 g




M Installing CiscoWorks LMS 2.2/LMS 1.3 Update 1

Step6  Click Next to continue.
The Setup window appears, displaying installation progress while files are copied
and applications are configured. Installation takes approximately 15 minutes.
After the installation is complete, the Setup Complete window appears.

Step 7 Click Finish.
After you install the Update on Windows, you must verify the installation. To do
this:

Step 1 Launch CiscoWorks.

Step2  Select Server Configuration > About the Server > Applications and Versions.

The About the Server page appears.

For each application you have chosen to install: If Update installation was
successful, you will see the following entries in the Packages Installed table on
this page:

Update Columns in the Packages Installed Table

Name Version |Installed Patches

CiscoWorks Common |CiscoWorks Common 2.2 2

Services 2.2 with SP2

Services with SP2

Resource Manager Resource Manager 3.5 3

Essentials with Essentials with

Update 1 Update 1

Campus Manager Campus Manager with 3.3 3

with Update 1 Update 1

Device Fault Manager |DFMSD 1.2 5!

with Update 1

1. If you installed a later DFM 1.2 Patch/IDU, this number should match the last number of the

patch/IDU version—for example, 6 for 1.2.6, 7 for 1.2.7, and so forth.

i Readme for CiscoWorks LMS 2.2/LMS 1.3 Update 1

78-16054-01 |



Installing Real-Time Monitor SP8

Installing Real-Time Monitor SP 8

Before you begin:

Ensure that you install Real Time Monitor 1.4 before upgrading to Real Time
Monitor SP 8.

Installing Real-Time Monitor SP 8 on Solaris

Step 1
Step 2

Step 3
Step 4
Step 5

Step 6
Step 7

Step 8

To install the Update on Solaris:

Close all client browsers.

Enter /RTM installation root directory/rtm/bin/stop to stop the nGenius Server.
For example, /opt/NetScout/rtm/bin/stop.

Wait until all processes shut down.

Log in as root.

Copy rtm140-sp8-unix.sh to SNSHOME.

SNSHOME is the RTM home directory

Execute rtm140-sp8-unix.sh available at SNSHOME.

Enter /RTM installation root directory/rtm/bin/start to restart the nGenius
Server:

Clear the jar cache on every client system.

Installing Real-Time Monitor SP 8 on Windows

Step 1
Step 2

To install the Update on Windows:

Close all client browsers.

Select Start > Programs > NetScout nGenius Server > Stop nGenius Server to
stop the nGenius Server
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Step3  Wait until all processes shut down.

Step4  Execute rtm140-sp8-win.exe available at the following directory in the LMS
Update 1 CD:

RTM1.4_SP8/

Step5  Select Start > Programs > NetScout nGenius Server > Start nGenius Server
to restart the nGenius Server.

Step6  Clear the jar cache on every client system.

Readme for CiscoWorks LMS 2.2/LMS 1.3 Update 1
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Known Problems

The following topics describe known problems in this Update:

~

CiscoWorks Common Services SP2: Known Problems, page 26

Java Plug-in 1.4.1_02: Known Problems, page 34

Resource Manager Essentials 3.5 Update 1: Known Problems, page 35
Campus Manager 3.3 Update 1: Known Problems, page 37

Device Fault Manager 1.2: Known Problems, page 40

Note To obtain more information about known problems, access the Cisco Software
Bug Toolkit at http://www.cisco.com/cgi-bin/Support/Bugtool/home.pl. You will
be prompted to log in to Cisco.com.
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CiscoWorks Common Services SP2: Known Problems

Table 4 lists problems that affect CiscoWorks Common Services 2.2 with Service
Pack 2 (including CiscoView 5.5 Update 1) on Solaris.

Table 4 CiscoWorks Common Services 2.2 SP2: Known Problems on Solaris
Bug ID Summary Explanation
None Nessus reports false TRACE / TRACK vulnerability reported by

TRACE/TRACK vulnerability

Nessus on CiscoWorks Common Services 2.2
web server ports is a false positive in
CiscoWorks Common Services 2.2 Service
Pack 1.

It is caused by a flaw in the NASL script that
Nessus uses to test this vulnerability. Since
TRACK is not implemented in Apache web
server, Apache replies to TRACK requests with
aMethod Not Implemented message. The NASL
script fails to handle this reply properly, and
signals a false positive.

Workaround:

You can ignore these false reports.

CSCsa01906

On Solaris, Netscape 4.76 crashes
inconsistently while starting online
help.

Netscape crashes while you run help from a
plug-in applet such as a CiscoView, or a
Resource Manager Essentials application like
NetConfig or Config Editor.

Workaround:

Start online help by clicking Help in the main
CiscoWorks Desktop (next to Logout).

You can browse through the contents from the
help page.

i Readme for CiscoWorks LMS 2.2/LMS 1.3 Update 1
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Table 4 CiscoWorks Common Services 2.2 SP2: Known Problems on Solaris (continued)
Bug ID Summary Explanation
CSCsa01571 |Unable to specify host name of This occurs on Solaris clients running
(CiscoView) |device list import source. Netscape 7.0 when you:
1. Start Common Services 2.2.
2. Select Device Manager > Administration >
CiscoView Server > CiscoView Device
List > Import Device List.
3. Update the Host Name field with the
correct information while the Campus or
RME radio button is selected.
You cannot select or modify the field’s
contents.
Workaround:
1. Click the window of any other open
application.
You must open another application if one is
not open already.
2. Return to the CiscoView Import Device List
window to specify a host name.
CSCin54021 |While executing pam.sh to install | The Java Plug-in does not get installed, although
Java Plug-in 1.4.1_02, you reject a message confirms it.
Fhe Sun .11cense agreement and the Workaround:
installation proceeds, but the Java
Plug-in is not installed. Accept the License agreement to install the Java
Plug-in properly.
CSCin50966 |While backing up data using The Progress Bar applet flickers during the
VPN/Security Management backup process and the bar may not display
Solution > Administration > consistently.
Common Services > Backup Workaround:
database, the popup Progress Bar
applet displays incorrectly. You can ignore this behavior. It does not affect
the backup functionality.
Readme for CiscoWorks LMS 2.2/LMS 1.3 Update 1
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Table 4 CiscoWorks Common Services 2.2 SP2: Known Problems on Solaris (continued)
Bug ID Summary Explanation
CSCin50174 |You see exceptions in the Java Exceptions sometimes appear when you use

Console while accessing the options
in the dropdown list boxes in
MAAS applets or in RME
applications.

MAAS applets or RME applications.
Workaround:

You can ignore these exceptions.

CSCec35611
(CiscoView)

Unable to launch Telnet on
Windows XP.

This problem occurs when you do the following
on a Windows XP client that uses either
Netscape 4.78 or Netscape 7.1 or Internet
Explorer 6.0:

1. Click Device Manager > Cisco View
CiscoView window appears.
2. Select any device from the menu.
3. Click the Telnet button.
Telnet does not launch.
Workaround:

None.

CSCeb62374
(CiscoView)

Unable to print chassis view.

This problem occurs on Solaris clients. When
you click the printer icon in the lower the
right-hand corner of the CiscoView screen to
print the chassis view, the view sometimes may
not be printed.

Workaround:

Select File > Print from the browser's Main
Menu.

i Readme for CiscoWorks LMS 2.2/LMS 1.3 Update 1
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Table 5 lists problems that affect CiscoWorks Common Services 2.2 with Service
Pack 2 (including CiscoView 5.5 Update 1) on Windows.

Table 5 CiscoWorks Common Services 2.2 SP2: Known Problems on Windows
Bug ID Summary Explanation
None Nessus reports false TRACE / TRACK vulnerability reported by Nessus on
TRACE/TRACK CiscoWorks Common Services 2.2 web server ports is a
vulnerability. false positive in CiscoWorks Common Services 2.2
Service Pack 1.
It is caused by a flaw in the NASL script that Nessus
uses to test this vulnerability. Since TRACK is not
implemented in Apache web server, Apache replies to
TRACK requests with a Method Not Implemented
message. The NASL script fails to handle this reply
properly, and signals a false positive.
Workaround:
You can ignore these false reports.
CSCin50359 You are using Internet If you have enabled the Internet Explorer Install on
(related bug) Explorer to run demand option, you will see dialogs prompting you to
CiscoWorks, do not have download the Java Plug-in. However, you cannot
the Microsoft VM download it from these links.
1ns.ta11ed, and are promp.ted Workaround:
to install the Java Plug-in.
However, you cannot Click Cancel on these dialogs. You are redirected to a
download the Java Plug-in. |help page that instructs you to download the Java
Plug-in for CiscoWorks.
If you do not have Install on demand enabled, you are
redirected to the help page while starting CiscoWorks.
CSCin53036 Selecting different JRE If you use the Plug-in Control Panel to select a different
versions to be used for Java |JRE version, unexpected results occur.
Plugin 1.4.1_02, other than Workaround:
the default JRE (through
the Plug-in Control Panel) |Use only the default JRE for the Plug-in. Other JRE
results in unexpected versions are not recommended.
behavior.
Readme for CiscoWorks LMS 2.2/LMS 1.3 Update 1
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Table 5 CiscoWorks Common Services 2.2 SP2: Known Problems on Windows (continued)

Bug ID Summary Explanation

CSCin51984 You see Java exceptions The exceptions appear in the Java Console and include
while using Resource java.lang.IllegalArgumentException: null
Manager Essentials source.

applications like Hardware

. Workaround:
Report and Device Center.

You can ignore this behavior. It does not affect
functionality.

CSCin53880 The Contents and Index This happens when you use Internet Explorer 6.0.26 on
panels in the online help Windows 2000 Professional or Server with Service
appear blank. Pack 4 and Java Plug-in 1.4.1_02.

Workaround:

Use Internet Explorer 6.0 with Service Pack 1 on
Windows 2000 Professional or Server with Service
Pack 4.

CSCin57604 The Contents and Index This happens when you use Internet Explorer 6.0 with

panels in the Online help |Service Pack 1 and the Internet Explorer patch Q822925
appear blank. on Windows 2000 Professional or Server with Service

Pack 3.

Workaround:

Use Internet Explorer 6.0 with Service Pack 1 on
Windows 2000 Professional or Server with Service
Pack 4.

Readme for CiscoWorks LMS 2.2/LMS 1.3 Update 1
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Table 5 CiscoWorks Common Services 2.2 SP2: Known Problems on Windows (continued)
Bug ID Summary Explanation
CSCec03791 On Netscape 7.1: Closing |When using Netscape 7.1 on Windows clients, you see
the Help window throws Java Exceptions when you close the Help window.
Java Exceptions. Workaround:
You can ignore this behavior. It does not affect
functionality.
On Netscape 7.1: The first |When using Netscape 7.1 on Windows clients, the first
element in the Help element appears to be blank.
Contents tree appears Workaround:
empty.
1. Click on the Index tab.
2. Click on the Contents tab.
All elements in the Contents tree will be displayed.
CSCin50966 While backing up data The Progress Bar applet flickers during the backup
using VPN/Security process and the bar may not display consistently.
Manggfamen.t Solution > Workaround:
Administration > Common
Services > Backup You can ignore this behavior. It does not affect
database, the popup functionality.
Progress Bar applet
displays incorrectly.
CSCeb73291 | While backing up data This sometimes occurs when using a Windows XP
using VPN/Security client.
Manggfamen.t Solution > Workaround:
Administration > Common
Services > Backup Resize the popup up window to display the text
database, the popup properly.
Progress Bar applet’s text
Backup Job progress
status is not visible.
Readme for CiscoWorks LMS 2.2/LMS 1.3 Update 1
[ 78-16054-01 .“




Il Known Problems

Table 5 CiscoWorks Common Services 2.2 SP2: Known Problems on Windows (continued)
Bug ID Summary Explanation
CSCin51794 While backing up data This problem occurs only on Windows 2000 with
using VPN/Security Service Pack 4 as client and Netscape 4.78 as the
Management Solution > browser.
Adm.mlstratlon >Common Workaround:
Services > Backup
database, the popup Restart the browser.
Progress Bar applet hangs
and you cannot exit from
the applet.
CSCdz34376  |During installation of This occurs when:
updates, themessage files | Server and client are running on the same system.
locked appears.
e A browser session which uses the Java Plug-in is
open.
* You have started reinstallation.
The reinstallation may abort after displaying the files
locked messages for the files jpishare.dll and
jpins32.dl1l.
Workaround:
Close all browser sessions and any plug-in applets
before the installation starts.
CSCin53790 You cannot use the Tab key |This occurs in some applets running in the plug-in
to select components. environment.
Workaround:
If this occurs, use the mouse to navigate among
components.
CSCeb60816  |Printout of chassis view is |This occurs on Windows clients.
(CiscoView) sometimes grayed out.

When you click the Printer icon in the lower right-hand
corner of the CiscoView screen to print the chassis view,
in some instances, the resulting printout is grayed out.

Workaround:

None.

i Readme for CiscoWorks LMS 2.2/LMS 1.3 Update 1
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Table 5 CiscoWorks Common Services 2.2 SP2: Known Problems on Windows (continued)
Bug ID Summary Explanation
CSCin51727 Java Plugin 1.4.1_02 This problem also occurs if Netscape 7.x Quick Launch

installation on Windows
hangs with 100 percent
CPU usage if the Netscape
7.x browser is open.

is running in the system tray.
Workaround:

Close all running Netscape 7.x instances and Netscape
7x Quick Launch before installing Java Plugin 1.4.1_02.

If installation hangs with 100 percent CPU usage and
you use Task Manager to kill the process IKernel.exe
(Doing this is not recommended), recover and reinstall
the Plug-in as follows:

1. Access the Windows registry.
2. Backup the registry contents.

3. Delete the key
HKEY_LOCAL_MACHINE/Software/JavaSoft
(Check the contents for JRE 1.4.1_02 before
deleting).

4. Delete the uninstall key that mentions
j2re/1.4.1_02 / Java run time
(HKEY_LOCAL_MACHINE/Software/Microsoft/Wind

ows/CurrentVersion/Uninstall).

5. Find the uninstall directory (The values in the
uninstall Registry keys will say where it is) and
delete it.

For example: In C:\Program Files\InstallShield
Installation Information\{registry id}, check the
Setup.ini file content for values like
j2re/jre/1.4.1_02 before deleting.
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Java Plug-in 1.4.1_02: Known Problems

Table 6 lists problems that affect Java Plug-in 1.4.1_02.

Table 6 Java Plug-in 1.4.1_02: Known Problems

Bug ID Summary

Explanation

None. JPI 1.4.1_02 does not coexist
with Java Plug-in 1.3.1.

The following problems occur:

e The browser crashes if, in the same browser
session, one of the applets uses Java
Plug-in 1.4.1_02 and the other tries to use Java
Plug-in 1.3.1.

e The error message Attachment to a running
Virtual Machine failed is displayed if you
start an applet using Java Plug-in 1.3.1 and then
start an applet using Java Plug-in 1.4.1_02.

Workaround:

Uninstall all previous versions of the Java Plug-in and
install only Java Plug-in 1.4.1_02.

None Uninstalling 1.4.1_02 disables
Internet Explorer JVM.

Uninstalling Java Plug-in 1.4.1_02 disables
Microsoft VM in Internet Explorer.

Workaround:

Install Java Plug-in 1.4.1_02 again to re-enable the
Microsoft VM.

None SSL mode requires certificate
acceptance.

When you run CiscoWorks server in SSL mode, a
Plug-in dialog box appears. This dialog box prompts
you to accept or deny a certificate.

Accept the certificate to continue working. If you
click No in the dialog box, a series of exceptions
appears in the Java console.

Workaround:

Close the browser, start CiscoWorks again, and this
time choose to accept the certificate.

Readme for CiscoWorks LMS 2.2/LMS 1.3 Update 1
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Resource Manager Essentials 3.5 Update 1: Known Problems

Table 7 lists problems that affect RME 3.5 Update 1.

Table 7 Resource Manager Essentials 3.5 Update 1: Known Problems

Bug ID

Summary

Explanation

None

On Windows only: RME Reports get
minimized when Java Plug-in
1.4.1_02 is in use.

When you try to generate an RME report, the
report gets minimized. For example, if you:

1. Click on Resource Manager Essentials >
Administration > Inventory > Check
Device Attributes.

2. Select the devices whose device
information you want to view.

3. Click Finish.

The Check Device Attributes Report
window will be minimized as a taskbar
icon.

Workaround:

Use the browser VM, if your browser has VM.

CSCsa01609

On Windows only: Some buttons are
not aligned properly on the
Distribution Sequence Window of
Software Management.

This problem occurs on Netscape 7.1 when you
perform any one of the following tasks using
Software Management:

e Distribute by Devices.
e Distribute by Images.
e Remote Staging and Distribution.

On the software Distribution Sequence
window, the buttons Back, Next, Details, and
Help are not aligned properly.

Workaround:

Use either of these browsers:
e Internet Explorer 6.0 or 6.0 SP1.
e Netscape Navigator 4.78 or 4.79.
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Table 7 Resource Manager Essentials 3.5 Update 1: Known Problems (continued)

Bug ID Summary Explanation
CSCin57076 |On Solaris only: Netscape 7.0 does | This problem occurs when you start NetConfig
not resize the NetConfig window (Resource Manager Essentials > Configuration
properly. Management). A part of the screen is not
visible and prevents you from proceeding to the
next step in the job creation panes.
Workaround:
This problem has no consistent workaround.
However, you can close NetConfig and then
restart NetConfig again.
CSCin49900 |On Solaris only: Netscape 7.0 This problem occurs when you try to perform a

crashes randomly.

task while another task is still processing. For
example, Netscape may crash if you:

1. Click on Resource Manager Essentials >
Administration > Inventory > Custom
Reports.

2. Click Create.

3. Select View by launching the device
selector.

4. Select Report Type before the Device
Selection screen appears.

Workaround:

Wait until the previous task is completed.

i Readme for CiscoWorks LMS 2.2/LMS 1.3 Update 1
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Campus Manager 3.3 Update 1: Known Problems

Table 8 lists the problems known to affect Campus Manager 3.3 Update 1.

Table 8 Campus Manager 3.3 Update 1 Known Problems

Bug ID Summary Explanation

CSCin57957 Campus OGSServer fails to |The problem occurs when you install FH on a
start in the LMS or RWAN |server that has the LMS or RWAN installed.
bundle when Fault History |Campus OGSServer uses xerces.jar located in
(FH) is installed. (Solaris NMSROOT/MDC/tomcat/lib/apps/ directory for
with Netscape 7.0) document traversal.

FH extracts the Sun XML parser jar file onto the
NMSROOT/Nib/classpath directory. This XML
parser does not support document traversal that
the Campus OGSServer requires.

Workaround:

Reorder the classpath of Campus OGSServer as
follows:

On Solaris:

1. Opendmgtd.conf inthe edit mode. The file is
available at the following location:

NMSROOT/objects/dmgt/dmgtd.conf

Readme for CiscoWorks LMS 2.2/LMS 1.3 Update 1
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Table 8 Campus Manager 3.3 Update 1 Known Problems (continued)

Bug ID Summary

Explanation

2. Change the launch path of the
CMFOGSServer to the following:

CampusOGSServer y CmfDbMonitor,ESS
/opt/CSCOpx/bin/

cwjava -cpNMSROOT/MDC/tomcat/webapps/
campus/WEB-INF/classes:NMSROOT/MDC/
tomcat/webapps/campus/WEB-INF/lib/
ctm. jar :NMSROOT/MDC/tomcat /webapps/
campus/WEB-INF/1lib/
ogs-serverl.0.jar:NMSROOT/MDC/tomcat/
webapps/campus/WEB-INF/1lib/
ogs-sharedasal.0.jar :NMSROOT/MDC/
tomcat/webapps/campus/WEB-INF/1lib/
ogs-sglasal.0.jar :NMSROOT/MDC/tomcat/
webapps/campus/WEB-INF/1lib/
ogs-utill.0.jar:NMSROOT/MDC/tomcat/
webapps/campus/WEB-INF/
1lib/ogs-clientl.0.jar:NMSROOT/MDC/
tomcat/webapps/campus/WEB-INF/lib/
ogs-cmasal.0.jar:NMSROOT/MDC/tomcat/
webapps/campus /WEB-INF/
lib/ogs-cmclientl.0.jar :NMSROOT/MDC/
tomcat/lib/apps/xerces.jar :NMSROOT/MDC/tom
cat/lib/apps/logdj.jar:NMSROOT/MDC/
tomcat/webapps/campus/WEB-INF/lib/
jconnect5.2.jar :NMSROOT/1lib/
classpath:NMSROOT/www/
classpath:NMSROOT/MDC/tomcat/lib/
appscom.cisco.nm.xms.ogs.server.0GSServer

In the above line, the variable, NMSROOT should
be replaced with the CiscoWorks installation
directory.

Restart the daemon manager by typing
/etc/init.d/dmgtd stop and

/etc/init.d/dmgtd start.

Readme for CiscoWorks LMS 2.2/LMS 1.3 Update 1
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Table 8 Campus Manager 3.3 Update 1 Known Problems (continued)

Bug ID Summary

Explanation

On Windows:
1. Click Start > Run
2. Enter regedit
The registry editor appears.
3. Click Edit > Find
4. Enter keyword campusoGsServer.
This search will yield the key with this name.
5. Right click on value Args and choose Modify
6. Copy the following line:

-DNMSROOT=NMSROOT -cp

MDC\ tomcat\webapps\campus\WEB-INF\1lib\ctm.
jar;MDC\tomcat\lib\apps\xerces.jar; MDC\
tomcat\webapps\campus\WEB-INF\1lib\
ogs-serverl.0.jar;MDC\tomcat\webapps\
campus \WEB-INF\1lib\
ogs-sharedasal.0.jar;MDC\tomcat\webapps\
campus \WEB-INF\lib\ogs-sglasal.0.jar;MDC\
tomcat\webapps\campus\WEB-INF\1lib\
ogs-utill.0.jar;MDC\tomcat\webapps\campus\
WEB-INF\lib\ogs-clientl.0.jar;MDC\tomcat\
webapps\campus\WEB-INF\1ib\
ogs-cmasal.0O.jar;MDC\tomcat\webapps\
campus \WEB-INF\1lib\
ogs-cmclientl.0.jar;MDC\tomcat\webapps\
campus \WEB-INF\lib\jconnect5.2.jar;MDC\
tomcat\lib\apps\log4j.jar;MDC\tomcat\
webapps\campus\WEB-INF\classes;www\
classpath;1lib\
classpathcom.cisco.nm.xms.ogs.server.0GSSe
rver

In the above line, the variable, NMSROOT should
be replaced with the CiscoWorks installation
directory.

7. Restart the daemon manager by typing net
stop crmdmgtd and then net start
crmdmgtd.
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Device Fault Manager 1.2: Known Problems

Table 9 lists the problems known to affect Device Fault Manager Update 1.

Table 9 Device Fault Manager 1.2 Known Problems

Bug ID Summary Explanation

CSCec31624 DFM update information is not provided |The problem occurs when you do the
in the Selected Component Screen of the |following:

LMS 2.2/LMS 1.3 Update 1. 1. Install Common Services 2.2,

RME 3.5,CM 3.3, DFM 1.2
Updated for Common Services 2.2
and Fault History

2. Install LMS 2.2/LMS 1.3 Update 1

In the Summary window, the current
settings field does not list DFM as part
of the Selected Components although
DFM 1.2 Update 1 is installed.

Workaround: None.

CSCed48695 LMS 2.2 Update 1: Resizing Monitoring |When LMS 2.2 Update 1 is installed on
Console does not resize the columns a DFM server, Solaris clients may
experience browser problems when
resizing the Monitoring Console. If the
Monitoring Console is resized,
columns and rows do not adjust to fit
the expanded/compressed window.
(Scrolling bars may disappear after
compressing the window, and when the
window is expanded, black patches
may appear on the vertical and
horizontal sides.) This problem has
only been observed on Netscape 7.0
when Java Plugin 1.4.1_02 is installed.

Workaround: None. Contact the
Technical Assistance Center for the
availability of a patch.

Readme for CiscoWorks LMS 2.2/LMS 1.3 Update 1
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Resolved Problems

The following topics describe previously reported problems resolved by installing
CiscoWorks LMS 2.2/LMS 1.3 Update 1:

Resolved Problems W

e (CiscoWorks Common Services SP2: Resolved Problems, page 41

e Device Fault Manager 1.2: Resolved Problems, page 42

e Real Time Monitor 1.4: Resolved Problems, page 43

CiscoWorks Common Services SP2: Resolved Problems

Table 10 lists reported problems with CiscoWorks Common Services 2.2 which

this Update resolves.

Table 10  CiscoWorks Common Services 2.2 SP2: Resolved Problems

Bug ID Summary Additional Information

CSCin50393 |CiscoWorks Common Services 2.2 SSH  |CiscoWorks Common Services 2.2 SP2
package should support SSH version 1.99. |supports secure shell 1.99.

CSCin44573 |Solaris Restore DB after password change |This problem has been resolved.
failed.

CSCin43722 |SqlcoreDB terminated before dependent | This problem has been resolved.
daemons shut down.

CSCeb49238 |Increased default tomcat heap size for This problem has been resolved.
Solaris.

CSCeb46559 |MICE/CAM to communicate via HTTPS |This problem has been resolved.
with ACS3.2.

CSCeb45532 |Apache child process crashed and Apache |This problem has been resolved.
parent process restarted the child process.

CSCeb44684 |Unnecessary jars were set to the This problem has been resolved.
CLASSPATH in tomcat.sh.

CSCeb37909 |Temporary directories are not removed Remove files with sensitive data, and.
after installation. possible leftovers from previous

installations.
CSCeb15620 |PixMC backup failed even after 50 tries. | This problem has been resolved.
Readme for CiscoWorks LMS 2.2/LMS 1.3 Update 1
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Table 10 CiscoWorks Common Services 2.2 SP2: Resolved Problems (continued)

Bug ID Summary Additional Information

CSCeb08489 |Login panel showed the username of the |These problems have been resolved.
previous user and inherited privileges of
this user.

CSCeb08436 |The CiscoWorks ESS process broadcast on |This problem has been resolved.
UDP port 42350.

CSCeb06767 |Consolidated bug to track a patch for These problems have been resolved.
Apache and security fix (consolidates
CSCea72180,CSCea91777,CSCeb15839,

CSCeb13529).

CSCea56786 |String size change in License.dll corrupted |This problem has been resolved.
system memory.

CSCdx74061 |Two steps needed to schedule backups and |This problem has been resolved.

compacts.

Device Fault Manager 1.2: Resolved Problems

Table 11 lists previously reported DFM problems which this Update resolves.

Table 11  Device Fault Manager 1.2 Resolved Problems

Bug ID

Summary

Additional Information

CSCdz09238

Unable to resize the Monitoring Console
columns

This problem has been resolved.

i Readme for CiscoWorks LMS 2.2/LMS 1.3 Update 1
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Real Time Monitor 1.4: Resolved Problems

Table 12 lists previously reported RTM problems which this Update resolves.

Table 12  Device Fault Manager 1.2 Resolved Problems

Bug ID Summary Additional Information

CSCea73863 Unable to add Cat4k IOS switch access for |This problem has been resolved.
port-channel configuration.

CSCdz90082 SMON Monitor menu is not disabled for |This problem has been resolved.
NetFlow interface

Readme for CiscoWorks LMS 2.2/LMS 1.3 Update 1
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