CHAPTER 1

Prerequisites

This chapter describes the factors that you should consider before installing
CD One on a Solaris system. It contains:

Product Overview
Server Requirements
Client Requirements
Supported Devices

Supported Network Management System Environments

Product Overview

CD One software, the foundation for the CiscoWorks2000 family of products and
other Cisco product families, enables the deployment, monitoring, and
troubleshooting of devices across your network. CD One includes:

CiscoView—A graphical device management tool

Common Management Foundation (CMF)—A set of shared application
services

CMF Base Desktop—A subset of the CMF components

Integration Utility—An integration module that provides support for
third-party network management systems (NMS)

[ 78-71122-04

Installing and Setting Up CD One on Solaris g




Chapter1  Prerequisites |

Il Product Overview

CD One Upgrade

Table 1-1 describes the different upgrade paths and results. See the “Installing CD
One” chapter for installation instructions.

A

Caution  This table covers local upgrades. Remote upgrades may not preserve data.
Refer to the “Installing CD One” chapter for more details.
Table 1-1  Upgrade Paths

Existing Software

Results

Clean machine

CD One, 4th Edition is installed in the specified directory.

CD One, 4th Edition

Reinstallation of CD One, 4th Edition overwrites the previously installed CD
One components. All data is preserved.

CD One, 3rd Edition

CD One, 4th Edition overwrites the previously installed CD One components.
All data is preserved.

CD One, 2nd Edition

CD One, 4th Edition overwrites the previously installed CD One components.
All data is preserved.

CD One, 1st Edition

CD One, 4th Edition overwrites the previously installed CD One components.
All data is preserved.

Previous
CiscoWorks2000
applications (prior to
CD One, 1st Edition)

Previous product versions are removed, but the database, ANI information,
community strings, user and host information, and application-specific data
files are preserved and are restored during the new product version installations.

Note  Refer to your specific application installation guide for detailed

upgrade information.

Previous
CiscoWorks2000
applications (prior to
Essentials 2.2 and
CWSI 2.4)

A warning message is displayed, and installation aborts.
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Server Requirements

The minimum system requirements for installing CD One are shown in Table 1-2.

Table 1-2  Server System Requirements1

Requirement Type Minimum Requirements

System hardware e Sparc Ultra 10.
¢ 17-inch color monitor.

e CD-ROM drive.

Memory (RAM) 256 MB (all CD One components).
Available drive space e 2 GB on the partition on which you install the product (the
default is /opt).

e Swap space equal to the amount of memory (RAM). For
example, if your system has 256 MB of RAM, you need
256 MB of swap space.

System software Solaris 2.6 or Solaris 2.7

Additional software (Optional) |Netscape Navigator 4.75 (if you are using the desktop on the server
system).

1. Minimum requirements vary, depending on which components you choose to install:
Integration Utility alone requires 128 MB RAM and 50 MB disk space.
CiscoView alone requires 128 MB RAM and 96 MB disk space.

To verify the amount of available disk space in each of the specified partitions and
directories, enter:

# df -k directory

where directory is the partition or directory for which you want to check the
available disk space.
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Solaris Patches

Table 1-3 lists the required and recommended patches for Solaris 2.6 and 2.7.

Table 1-3  Solaris Patches

Operating
System

Required

Recommended

Solaris 2.6

105181-19
105210-27

105490-07 (or
107733-01)

105568-16
105591-06
105633-36 (Asian only)

106040-13 (Japanese
only)

106409-01 (traditional
Chinese only)

108091-03 (ISO 8859-1
and 8859-15 only)

e 105284-31
¢ 105669-10

Solaris 2.7

106327-05
106980-10
107081-11
107636-03
108376-03 (Asian only)

Use the showrev -p command to verify that these patches have been applied.
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Client Requirements

The minimum system requirements for the client are shown in Table 1-4. For
information about configuring client systems, see the “Preparing to Use CD One”
chapter.

Table 1-4  Client System Requirements

Requirement Type |Minimum Requirements

System hardware ¢ Client system:

and software — IBM PC-compatible computer with at least a 300 MHz Pentium

processor running Windows NT 4.0, Windows 95, Windows 98, or
Windows 2000.

— SPARC Ultra 10 running Solaris 2.5.1, Solaris 2.6, Solaris 2.7.
- IBM RS/ 6000 workstation running AIX 4.33.
- HP9000 workstation running HP-UX 10.20 or 11.0.

e Color monitor with video card set to 256 colors.

Memory (RAM) 128 MB.

Browser e Netscape Navigator 4.75.

(Windows NT 4.0 Workstation and Server, Windows 98, Windows 2000
Professional and Server, Solaris 2.5.1, Solaris 2.6, Solaris 2.7, AIX 4.33,
HP-UX 11.0)

* Microsoft Internet Explorer 5.5 with Service Pack 1.
Java Virtual Machine (JVM) version 5.0.0.3167 or current shipping version.
To verify the JVM, select View > Java Console.
(Windows NT, Windows 95, Windows 98, Windows 2000)

If Java Console is not listed in View, you must enable it.

Step1  Select Tools > Internet Options > Advanced.
Step2  In the Java VM section, select the Java Console option.

Step3  Restart Internet Explorer.

Installing and Setting Up CD One on Solaris
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Supported Devices

CiscoView, a major component of CD One, manages and configures different
types of Cisco devices. Refer to Using CiscoView for supported device
information.

Supported Network Management System
Environments

The network management system (NMS) supported for importing device
information into the CiscoView application is HP OpenView Network Node
Manager. Refer to Using CiscoView and the online help for information about
importing devices.

Note Please stop HP OpenView before installing CD One, then restart HP
OpenView after you have installed CD One.

Installing and Setting Up CD One on Solaris
m. 78-1122-04 |




	Prerequisites
	Product Overview
	CD One Upgrade

	Server Requirements
	Solaris Patches

	Client Requirements
	Supported Devices
	Supported Network Management System Environments



<<
  /ASCII85EncodePages false
  /AllowTransparency false
  /AutoPositionEPSFiles true
  /AutoRotatePages /All
  /Binding /Left
  /CalGrayProfile (Dot Gain 20%)
  /CalRGBProfile (sRGB IEC61966-2.1)
  /CalCMYKProfile (U.S. Web Coated \050SWOP\051 v2)
  /sRGBProfile (sRGB IEC61966-2.1)
  /CannotEmbedFontPolicy /Warning
  /CompatibilityLevel 1.4
  /CompressObjects /Tags
  /CompressPages true
  /ConvertImagesToIndexed true
  /PassThroughJPEGImages true
  /CreateJDFFile false
  /CreateJobTicket false
  /DefaultRenderingIntent /Default
  /DetectBlends true
  /DetectCurves 0.0000
  /ColorConversionStrategy /LeaveColorUnchanged
  /DoThumbnails false
  /EmbedAllFonts true
  /EmbedOpenType false
  /ParseICCProfilesInComments true
  /EmbedJobOptions true
  /DSCReportingLevel 0
  /EmitDSCWarnings false
  /EndPage -1
  /ImageMemory 1048576
  /LockDistillerParams false
  /MaxSubsetPct 100
  /Optimize true
  /OPM 1
  /ParseDSCComments true
  /ParseDSCCommentsForDocInfo true
  /PreserveCopyPage true
  /PreserveDICMYKValues true
  /PreserveEPSInfo true
  /PreserveFlatness true
  /PreserveHalftoneInfo false
  /PreserveOPIComments false
  /PreserveOverprintSettings true
  /StartPage 1
  /SubsetFonts true
  /TransferFunctionInfo /Apply
  /UCRandBGInfo /Preserve
  /UsePrologue false
  /ColorSettingsFile ()
  /AlwaysEmbed [ true
  ]
  /NeverEmbed [ true
  ]
  /AntiAliasColorImages false
  /CropColorImages true
  /ColorImageMinResolution 300
  /ColorImageMinResolutionPolicy /OK
  /DownsampleColorImages true
  /ColorImageDownsampleType /Bicubic
  /ColorImageResolution 300
  /ColorImageDepth -1
  /ColorImageMinDownsampleDepth 1
  /ColorImageDownsampleThreshold 1.50000
  /EncodeColorImages true
  /ColorImageFilter /DCTEncode
  /AutoFilterColorImages true
  /ColorImageAutoFilterStrategy /JPEG
  /ColorACSImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /ColorImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000ColorACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000ColorImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasGrayImages false
  /CropGrayImages true
  /GrayImageMinResolution 300
  /GrayImageMinResolutionPolicy /OK
  /DownsampleGrayImages true
  /GrayImageDownsampleType /Bicubic
  /GrayImageResolution 300
  /GrayImageDepth -1
  /GrayImageMinDownsampleDepth 2
  /GrayImageDownsampleThreshold 1.50000
  /EncodeGrayImages true
  /GrayImageFilter /DCTEncode
  /AutoFilterGrayImages true
  /GrayImageAutoFilterStrategy /JPEG
  /GrayACSImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /GrayImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000GrayACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000GrayImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasMonoImages false
  /CropMonoImages true
  /MonoImageMinResolution 1200
  /MonoImageMinResolutionPolicy /OK
  /DownsampleMonoImages true
  /MonoImageDownsampleType /Bicubic
  /MonoImageResolution 1200
  /MonoImageDepth -1
  /MonoImageDownsampleThreshold 1.50000
  /EncodeMonoImages true
  /MonoImageFilter /CCITTFaxEncode
  /MonoImageDict <<
    /K -1
  >>
  /AllowPSXObjects false
  /CheckCompliance [
    /None
  ]
  /PDFX1aCheck false
  /PDFX3Check false
  /PDFXCompliantPDFOnly false
  /PDFXNoTrimBoxError true
  /PDFXTrimBoxToMediaBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXSetBleedBoxToMediaBox true
  /PDFXBleedBoxToTrimBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXOutputIntentProfile ()
  /PDFXOutputConditionIdentifier ()
  /PDFXOutputCondition ()
  /PDFXRegistryName ()
  /PDFXTrapped /False

  /Description <<
    /CHS <FEFF4f7f75288fd94e9b8bbe5b9a521b5efa7684002000500044004600206587686353ef901a8fc7684c976262535370673a548c002000700072006f006f00660065007200208fdb884c9ad88d2891cf62535370300260a853ef4ee54f7f75280020004100630072006f0062006100740020548c002000410064006f00620065002000520065006100640065007200200035002e003000204ee553ca66f49ad87248672c676562535f00521b5efa768400200050004400460020658768633002>
    /CHT <FEFF4f7f752890194e9b8a2d7f6e5efa7acb7684002000410064006f006200650020005000440046002065874ef653ef5728684c9762537088686a5f548c002000700072006f006f00660065007200204e0a73725f979ad854c18cea7684521753706548679c300260a853ef4ee54f7f75280020004100630072006f0062006100740020548c002000410064006f00620065002000520065006100640065007200200035002e003000204ee553ca66f49ad87248672c4f86958b555f5df25efa7acb76840020005000440046002065874ef63002>
    /DAN <>
    /DEU <>
    /ESP <>
    /FRA <>
    /ITA <>
    /JPN <>
    /KOR <FEFFc7740020c124c815c7440020c0acc6a9d558c5ec0020b370c2a4d06cd0d10020d504b9b0d1300020bc0f0020ad50c815ae30c5d0c11c0020ace0d488c9c8b85c0020c778c1c4d560002000410064006f0062006500200050004400460020bb38c11cb97c0020c791c131d569b2c8b2e4002e0020c774b807ac8c0020c791c131b41c00200050004400460020bb38c11cb2940020004100630072006f0062006100740020bc0f002000410064006f00620065002000520065006100640065007200200035002e00300020c774c0c1c5d0c11c0020c5f40020c2180020c788c2b5b2c8b2e4002e>
    /NLD (Gebruik deze instellingen om Adobe PDF-documenten te maken voor kwaliteitsafdrukken op desktopprinters en proofers. De gemaakte PDF-documenten kunnen worden geopend met Acrobat en Adobe Reader 5.0 en hoger.)
    /NOR <>
    /PTB <>
    /SUO <>
    /SVE <>
    /ENU (Use these settings to create Adobe PDF documents for quality printing on desktop printers and proofers.  Created PDF documents can be opened with Acrobat and Adobe Reader 5.0 and later.)
  >>
  /Namespace [
    (Adobe)
    (Common)
    (1.0)
  ]
  /OtherNamespaces [
    <<
      /AsReaderSpreads false
      /CropImagesToFrames true
      /ErrorControl /WarnAndContinue
      /FlattenerIgnoreSpreadOverrides false
      /IncludeGuidesGrids false
      /IncludeNonPrinting false
      /IncludeSlug false
      /Namespace [
        (Adobe)
        (InDesign)
        (4.0)
      ]
      /OmitPlacedBitmaps false
      /OmitPlacedEPS false
      /OmitPlacedPDF false
      /SimulateOverprint /Legacy
    >>
    <<
      /AddBleedMarks false
      /AddColorBars false
      /AddCropMarks false
      /AddPageInfo false
      /AddRegMarks false
      /ConvertColors /NoConversion
      /DestinationProfileName ()
      /DestinationProfileSelector /NA
      /Downsample16BitImages true
      /FlattenerPreset <<
        /PresetSelector /MediumResolution
      >>
      /FormElements false
      /GenerateStructure true
      /IncludeBookmarks false
      /IncludeHyperlinks false
      /IncludeInteractive false
      /IncludeLayers false
      /IncludeProfiles true
      /MultimediaHandling /UseObjectSettings
      /Namespace [
        (Adobe)
        (CreativeSuite)
        (2.0)
      ]
      /PDFXOutputIntentProfileSelector /NA
      /PreserveEditing true
      /UntaggedCMYKHandling /LeaveUntagged
      /UntaggedRGBHandling /LeaveUntagged
      /UseDocumentBleed false
    >>
  ]
>> setdistillerparams
<<
  /HWResolution [2400 2400]
  /PageSize [612.000 792.000]
>> setpagedevice


