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Preface

This manual describes Campus Manager 4.0.6 and provides instructions for installing and configuring it.

Audience
This document is for anyone who installs, configures, verifies, and uses Campus Manager 4.0.6 
software. Network administrators or operators should have the following skills:

• Basic Windows system administrator skills

• Basic network management skills

• Basic Internet browser skills

Conventions
This document uses the following conventions:

Note Means reader take note. Notes contain helpful suggestions or references to material not covered in the 
publication. 

Item Convention

Commands and keywords boldface font

Variables for which you supply values italic font

Displayed session and system information screen font

Information you enter boldface screen font

Variables you enter italic screen font

Menu items and button names boldface font

Selecting a menu item in paragraphs Option > Network Preferences

Selecting a menu item in tables Option > Network Preferences
vii
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Preface
  Product Documentation
Caution Means reader be careful. In this situation, you might do something that could result in equipment 
damage or loss of data.

Product Documentation

Note We sometimes update the printed and electronic documentation after original publication. Therefore, 
you should also review the documentation on Cisco.com for any updates.

Table 1 describes the product documentation that is available.

Table 1 Product Documentation

Document Title Available Formats

Release Notes for Campus Manager 4.0.6 on 
Solaris

• Printed document that was included with the product.

• PDF on the product CD-ROM

• On Cisco.com at this URL:
http://cisco.com/en/US/products/sw/cscowork/ps563/
prod_release_notes_list.html

Release Notes for Campus Manager 4.0.6 on 
Windows (This document.)

• Printed document that was included with the product.

• PDF on the product CD-ROM

• On Cisco.com at this URL:
http://cisco.com/en/US/products/sw/cscowork/ps563/
prod_release_notes_list.html

Installation and Setup Guide for Campus 
Manager 4.0.6 on Solaris

• Printed document that was included with the product.

• PDF on the product CD-ROM.

• On Cisco.com at this URL:
http://cisco.com/en/US/products/sw/cscowork/ps563/
prod_installation_guides_list.html

• Printed document available by order (part number DOC-7817187=).1

Installation and Setup Guide for Campus 
Manager 4.0.6 on Windows

• Printed document that was included with the product.

• PDF on the product CD-ROM.

• On Cisco.com at this URL:
http://cisco.com/en/US/products/sw/cscowork/ps563/
prod_installation_guides_list.html

• Printed document available by order (part number DOC-7817188=).1

User Guide for Campus Manager 4.0.6 • PDF on the product CD-ROM.

• On Cisco.com at this URL:
http://cisco.com/en/US/products/sw/cscowork/ps563/
products_user_guide_list.html

• Printed document available by order (part number DOC-7817186=).1
viii
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Preface
  Related Documentation
Related Documentation

Note We sometimes update the printed and electronic documentation after original publication. Therefore, 
you should also review the documentation on Cisco.com for any updates.

Table 2 describes the additional documentation that is available.

Supported Devices Table for Campus 
Manager 4.0.6

On Cisco.com at this URL:
http://cisco.com/en/US/products/sw/cscowork/ps563/
products_device_support_tables_list.html

Context-sensitive online help • Select an option from the navigation tree, then click Help.

• Click the Help button in the dialog box.

1. See the “Obtaining Documentation” section on page x.

Table 1 Product Documentation (continued)

Document Title Available Formats

Table 2 Related Documentation

Document Title Available Formats

Release Notes for CiscoWorks Common 
Services 3.0.5 (Includes CiscoView 6.1.5) on 
Solaris

• Printed document that was included with the product.

• PDF on the product CD-ROM.

• On Cisco.com at this URL:
http://cisco.com/en/US/products/sw/cscowork/ps3996/
prod_release_notes_list.html

Release Notes for CiscoWorks Common 
Services 3.0.5 (Includes CiscoView 6.1.5) on 
Windows

• Printed document that was included with the product.

• PDF on the product CD-ROM.

• On Cisco.com at this URL:
http://cisco.com/en/US/products/sw/cscowork/ps3996/
prod_release_notes_list.html

Installation and Setup Guide for CiscoWorks 
Common Services 3.0.5 (Includes CiscoView 
6.1.5) on Solaris

• Printed document that was included with the product.

• PDF on the product CD-ROM.

• On Cisco.com at this URL:
http://cisco.com/en/US/products/sw/cscowork/ps3996/
prod_installation_guides_list.html

• Printed document available by order (part number DOC-7817183=).
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Preface
  Additional Information Online
Additional Information Online
Service Pack (SP) contains updated files necessary for the latest device support and fixes to known 
problems that are not available in Campus Manager. If you are a registered user, you can download SP 
for Campus Manager from:

http://www.cisco.com/cgi-bin/tablebuild.pl/cw2000-campus

Obtaining Documentation
Cisco documentation and additional literature are available on Cisco.com. This section explains the 
product documentation resources that Cisco offers.

Cisco.com
You can access the most current Cisco documentation at this URL:

http://www.cisco.com/techsupport

You can access the Cisco website at this URL:

http://www.cisco.com

You can access international Cisco websites at this URL:

http://www.cisco.com/public/countries_languages.shtml

Installation and Setup Guide for CiscoWorks 
Common Services 3.0.5 (Includes CiscoView 
6.1.5) on Windows

• Printed document that was included with the product.

• PDF on the product CD-ROM.

• On Cisco.com at this URL:
http://cisco.com/en/US/products/sw/cscowork/ps3996/
prod_installation_guides_list.html

• Printed document available by order (part number DOC-7817184=).

User Guide for CiscoWorks Common Services 
3.0.5

• PDF on the product CD-ROM.

• On Cisco.com at this URL:
http://cisco.com/en/US/products/sw/cscowork/ps3996/
products_user_guide_list.html

• Printed document available by order (part number DOC-7817182=).

Table 2 Related Documentation (continued)

Document Title Available Formats
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Preface
  Documentation Feedback
Product Documentation DVD
The Product Documentation DVD is a library of technical product documentation on a portable medium. 
The DVD enables you to access installation, configuration, and command guides for Cisco hardware and 
software products. With the DVD, you have access to the HTML documentation and some of the 
PDF files found on the Cisco website at this URL:

http://www.cisco.com/univercd/home/home.htm

The Product Documentation DVD is created monthly and is released in the middle of the month. DVDs 
are available singly or by subscription. Registered Cisco.com users can order a Product Documentation 
DVD (product number DOC-DOCDVD= or DOC-DOCDVD=SUB) from Cisco Marketplace at the 
Product Documentation Store at this URL:

http://www.cisco.com/go/marketplace/docstore

Ordering Documentation
You must be a registered Cisco.com user to access Cisco Marketplace. Registered users may order 
Cisco documentation at the Product Documentation Store at this URL: 

http://www.cisco.com/go/marketplace/docstore

If you do not have a user ID or password, you can register at this URL:

http://tools.cisco.com/RPF/register/register.do

Documentation Feedback
You can provide feedback about Cisco technical documentation on the Cisco Technical Support & 
Documentation site area by entering your comments in the feedback form available in every online 
document.

Cisco Product Security Overview
Cisco provides a free online Security Vulnerability Policy portal at this URL:

http://www.cisco.com/en/US/products/products_security_vulnerability_policy.html

From this site, you will find information about how to do the following:

• Report security vulnerabilities in Cisco products

• Obtain assistance with security incidents that involve Cisco products

• Register to receive security information from Cisco

A current list of security advisories, security notices, and security responses for Cisco products is 
available at this URL:

http://www.cisco.com/go/psirt

To see security advisories, security notices, and security responses as they are updated in real time, you 
can subscribe to the Product Security Incident Response Team Really Simple Syndication (PSIRT RSS) 
feed. Information about how to subscribe to the PSIRT RSS feed is found at this URL:

http://www.cisco.com/en/US/products/products_psirt_rss_feed.html
xi
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Preface
  Cisco Product Security Overview
Reporting Security Problems in Cisco Products
Cisco is committed to delivering secure products. We test our products internally before we release them, 
and we strive to correct all vulnerabilities quickly. If you think that you have identified a vulnerability 
in a Cisco product, contact PSIRT:

• For emergencies only — security-alert@cisco.com

An emergency is either a condition in which a system is under active attack or a condition for which 
a severe and urgent security vulnerability should be reported. All other conditions are considered 
nonemergencies.

• For nonemergencies— psirt@cisco.com

In an emergency, you can also reach PSIRT by telephone:

• 1 877 228-7302

• 1 408 525-6532

Tip We encourage you to use Pretty Good Privacy (PGP) or a compatible product (for example, GnuPG) to 
encrypt any sensitive information that you send to Cisco. PSIRT can work with information that has been 
encrypted with PGP versions 2.x through 9.x. 

Never use a revoked encryption key or an expired encryption key. The correct public key to use in your 
correspondence with PSIRT is the one linked in the Contact Summary section of the Security 
Vulnerability Policy page at this URL:

http://www.cisco.com/en/US/products/products_security_vulnerability_policy.html

The link on this page has the current PGP key ID in use.

If you do not have or use PGP, contact PSIRT to find other means of encrypting the data before sending 
any sensitive material.
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Preface
  Product Alerts and Field Notices
Product Alerts and Field Notices
Modifications to or updates about Cisco products are announced in Cisco Product Alerts and Cisco Field 
Notices. You can receive Cisco Product Alerts and Cisco Field Notices by using the Product Alert Tool 
on Cisco.com. This tool enables you to create a profile and choose those products for which you want to 
receive information.

To access the Product Alert Tool, you must be a registered Cisco.com user. (To register as a Cisco.com 
user, go to this URL: http://tools.cisco.com/RPF/register/register.do) Registered users can access the 
tool at this URL: http://tools.cisco.com/Support/PAT/do/ViewMyProfiles.do?local=en

Obtaining Technical Assistance
Cisco Technical Support provides 24-hour-a-day award-winning technical assistance. The 
Cisco Technical Support & Documentation website on Cisco.com features extensive online support 
resources. In addition, if you have a valid Cisco service contract, Cisco Technical Assistance Center 
(TAC) engineers provide telephone support. If you do not have a valid Cisco service contract, contact 
your reseller.

Cisco Technical Support & Documentation Website
The Cisco Technical Support & Documentation website provides online documents and tools for 
troubleshooting and resolving technical issues with Cisco products and technologies. The website is 
available 24 hours a day at this URL:

http://www.cisco.com/techsupport

Access to all tools on the Cisco Technical Support & Documentation website requires a Cisco.com 
user ID and password. If you have a valid service contract but do not have a user ID or password, you 
can register at this URL:

http://tools.cisco.com/RPF/register/register.do

Note Use the Cisco Product Identification Tool to locate your product serial number before submitting a 
request for service online or by phone. You can access this tool from the Cisco Technical Support & 
Documentation website by clicking the Tools & Resources link, clicking the All Tools (A-Z) tab, and 
then choosing Cisco Product Identification Tool from the alphabetical list. This tool offers three search 
options: by product ID or model name; by tree view; or, for certain products, by copying and pasting 
show command output. Search results show an illustration of your product with the serial number label 
location highlighted. Locate the serial number label on your product and record the information before 
placing a service call.
xiii
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  Obtaining Technical Assistance
Tip Displaying and Searching on Cisco.com

If you suspect that the browser is not refreshing a web page, force the browser to update the web page 
by holding down the Ctrl key while pressing F5.

To find technical information, narrow your search to look in technical documentation, not the entire 
Cisco.com website. On the Cisco.com home page, click the Advanced Search link under the Search box 
and then click the Technical Support & Documentation.radio button.

To provide feedback about the Cisco.com website or a particular technical document, click Contacts & 
Feedback at the top of any Cisco.com web page.

Submitting a Service Request
Using the online TAC Service Request Tool is the fastest way to open S3 and S4 service requests. (S3 and 
S4 service requests are those in which your network is minimally impaired or for which you require 
product information.) After you describe your situation, the TAC Service Request Tool provides 
recommended solutions. If your issue is not resolved using the recommended resources, your service 
request is assigned to a Cisco engineer. The TAC Service Request Tool is located at this URL:

http://www.cisco.com/techsupport/servicerequest

For S1 or S2 service requests, or if you do not have Internet access, contact the Cisco TAC by telephone. 
(S1 or S2 service requests are those in which your production network is down or severely degraded.) 
Cisco engineers are assigned immediately to S1 and S2 service requests to help keep your business 
operations running smoothly.

To open a service request by telephone, use one of the following numbers:

Asia-Pacific: +61 2 8446 7411
Australia: 1 800 805 227
EMEA: +32 2 704 55 55
USA: 1 800 553 2447

For a complete list of Cisco TAC contacts, go to this URL:

http://www.cisco.com/techsupport/contacts

Definitions of Service Request Severity
To ensure that all service requests are reported in a standard format, Cisco has established severity 
definitions.

Severity 1 (S1)—An existing network is “down” or there is a critical impact to your business operations. 
You and Cisco will commit all necessary resources around the clock to resolve the situation. 

Severity 2 (S2)—Operation of an existing network is severely degraded, or significant aspects of your 
business operations are negatively affected by inadequate performance of Cisco products. You and 
Cisco will commit full-time resources during normal business hours to resolve the situation.
xiv
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Preface
  Obtaining Additional Publications and Information
Severity 3 (S3)—Operational performance of the network is impaired while most business operations 
remain functional. You and Cisco will commit resources during normal business hours to restore service 
to satisfactory levels.

Severity 4 (S4)—You require information or assistance with Cisco product capabilities, installation, or 
configuration. There is little or no effect on your business operations.

Obtaining Additional Publications and Information
Information about Cisco products, technologies, and network solutions is available from various online 
and printed sources.

• The Cisco Product Quick Reference Guide is a handy, compact reference tool that includes brief 
product overviews, key features, sample part numbers, and abbreviated technical specifications for 
many Cisco products that are sold through channel partners. It is updated twice a year and includes 
the latest Cisco channel product offerings. To order and find out more about the Cisco Product Quick 
Reference Guide, go to this URL: 

http://www.cisco.com/go/guide

• Cisco Marketplace provides a variety of Cisco books, reference guides, documentation, and logo 
merchandise. Visit Cisco Marketplace, the company store, at this URL:

http://www.cisco.com/go/marketplace/

• Cisco Press publishes a wide range of general networking, training, and certification titles. Both new 
and experienced users will benefit from these publications. For current Cisco Press titles and other 
information, go to Cisco Press at this URL:

http://www.ciscopress.com

• Packet magazine is the magazine for Cisco networking professionals. Each quarter, Packet delivers 
coverage of the latest industry trends, technology breakthroughs, and Cisco products and solutions, 
as well as network deployment and troubleshooting tips, configuration examples, customer case 
studies, certification and training information, and links to scores of in-depth online resources. You 
can subscribe to Packet magazine at this URL:

http://www.cisco.com/packet

• Internet Protocol Journal is a quarterly journal published by Cisco Systems for engineering 
professionals involved in designing, developing, and operating public and private internets and 
intranets. You can access the Internet Protocol Journal at this URL:

http://www.cisco.com/ipj

• Networking products offered by Cisco Systems, as well as customer support services, can be 
obtained at this URL:

http://www.cisco.com/en/US/products/index.html

• Networking Professionals Connection is an interactive website where networking professionals 
share questions, suggestions, and information about networking products and technologies with 
Cisco experts and other networking professionals. Join a discussion at this URL:

http://www.cisco.com/discuss/networking
xv
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  Obtaining Additional Publications and Information
• “What’s New in Cisco Documentation” is an online publication that provides information about the 
latest documentation releases for Cisco products. Updated monthly, this online publication is 
organized by product category to direct you quickly to the documentation for your products. You 
can view the latest release of “What’s New in Cisco Documentation” at this URL:

http://www.cisco.com/univercd/cc/td/doc/abtunicd/136957.htm

• World-class networking training is available from Cisco. You can view current offerings at 
this URL:

http://www.cisco.com/en/US/learning/index.html
xvi
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C H A P T E R 1

Prerequisites

This chapter describes the factors that you should consider before installing Campus Manager 4.0.6 on 
a Windows system.

This chapter contains:

• Product Overview

• Campus Manager Upgrade Paths

• Server Requirements

• Client Requirements

• Supported Devices
1-1
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Chapter 1      Prerequisites
  Product Overview
Product Overview
Campus Manager, a member of the CiscoWorks Family of Products, is a suite of web-based network 
management tools that enable administrators to obtain various types of graphical views of their network 
topology and end-user information. Campus Manager is based on a client-server architecture that 
connects multiple web-based clients to a server on the network. 

Campus Manager server discovers information about network devices and saves it in the Campus 
Manager database so that the applications can access it. For more information, see User Guide for 
Campus Manager 4.0.6.

The Campus Manager applications and what they allow you to do are as follows:

• Path Analysis—View the path that packets take between end nodes/devices on your network. 

• User Tracking—Locate and display data about users, IP Phones, hosts, and wireless clients in your 
network. 

• Topology Services—Discover, view, and monitor the physical and logical services on your network. 
View detailed network information about all devices, links, and ports in your network. 

• VLAN Port Assignment—View port information, create trunk, configure VLANs on a trunk, and 
move ports between VLANs on your network. 

• Discrepancy Reports—Discover and view physical and logical discrepancies in your network. 

Campus Manager Upgrade Paths
You can upgrade to Campus Manager 4.0.6 suing LAN Management Solution 2.6 Update CD-ROM. You 
must install the following applications before installing the LAN Management Solution 2.6 Update:

• Common Services 3.0.3 or higher 

• Campus Manager 4.0.3

You can upgrade to Campus Manger 4.0.6 by either:

• Using the Campus Manager 4.0.6 CD-ROM. 

For more details, see Installing Campus Manager 4.0.6, page 2-2.

Or

• Using LAN Management Solution 2.6 on Windows. You can download this from: 

http://www.cisco.com/kobayashi/sw-center/cw2000/lan-planner.shtml 

For more details see, Readme for LAN Management Solution 2.6 on Windows that can be downloaded 
from the same location. 
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Server Requirements
The server requirements for Campus Manager 4.0.6 are the same as that of 
LMS 2.6.

The minimum system requirements for CiscoWorks Common Services 3.0.5 and Campus Manager 4.0.6 
are shown in Table 1-1.

Table 1-1 Server System Requirements Summary

Requirement Type Minimum Requirement1

1. If other applications are installed, or the number of devices on your network exceeds 500, the requirements might be greater.

System hardware • IBM PC-compatible computer with 500 MHz Intel Pentium processor

• CD-ROM drive

Memory (RAM) 512 MB

Available drive space2

2. Do not install CiscoWorks on a FAT file system.

• 2 GB

• Virtual memory equal to double the amount of memory (RAM). For example, if 
your system has 1 GB of RAM, you need 2 GB of virtual memory

• NTFS file system required for secure operation

• At least 16 MB in Windows temporary directory (TEMP)

System software • ODBC Driver Manager 3.5.10 or later 

• Windows 2000 Professional or Server with Service Pack 1or later, Windows 2003 
Server Standard and Enterprise Edition

• Windows Advanced Server without enabling terminal Services

Campus Manager supports only the US-English and Japanese versions of the Windows 
Operating System. It does not support any other language version. Set the default locale 
to US-English for US-English version and Japanese for Japanese version. 

Additional software

(Optional)

Any one of these browsers:

• Microsoft Internet Explorer 6.0 (version 6.0.2600.0000), and Internet Explorer 6.0 
with Service Pack 1 (version 6.0.2800.1106)

Java Virtual Machine (JVM) 5.0.0.3802 and above. To verify JVM:

– From Internet Explorer, select Tools > Sun Java Console

– From Netscape Navigator, select Tools > Web Development > Java Console

– From Mozilla, Help > About Plug-ins

• Java plug-in version 1.4.2_08

• Netscape 7.2

• Mozilla 1.7 and Mozilla 1.7.5
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Maximum Recommended Load
The maximum recommended load on servers configured with the minimum server requirements shown 
in Table 1-1 is 500 Cisco devices and one client at a time.

If other network management applications are installed on your server, additional resources might be 
required.

Server Recommendations
To select or configure a server system that best meets your needs, consider the number of managed 
devices. These factors affect server performance and user report response time.

Table 1-2 shows the recommendations for a server running Common Services and Campus Manager. 
These recommendations produce optimal response time when running user reports.

Client Requirements
The minimum client system requirements for CiscoWorks 
Common Services 3.0.5 and Campus Manager 4.0.6 are shown in Table 1-3. The maximum 
recommended load on clients configured with the minimum requirements shown in Table 1-3 is 1000 
Cisco devices.

Table 1-2 Server System Recommendations

Minimum System Configuration No. of Managed Devices

Pentium III, 450 MHz
Memory: 512 MB
Virtual memory: 1 GB
Available disk space: 40 GB

0–500 managed devices

Pentium III, 450 MHz
Memory: 1 GB
Virtual memory: 2 GB 
Available disk space: 80 GB

500–2,500 managed devices

Dual Pentium III, 550 MHz
Memory: 2 GB
Virtual memory: 4 GB
Available disk space: 80 GB

2,500–5,000 managed devices
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Supported Devices
For information about supported devices, access the Supported Devices table at the following location 
on cisco.com:

http://cisco.com/en/US/products/sw/cscowork/ps563/products_device_support_tables_list.html

Table 1-3 Client System Requirements Summary

 Requirement Type Minimum Requirement

System Software and Hardware • Client system:

– IBM PC-compatible computer with 300 MHz Intel Pentium processor running on 
Windows 2000 with SP1 or later (Professional and Server), Windows XP with SP1 
or Windows 2003

Or

– Solaris SPARC station or Sun Ultra 10 running Solaris 2.8 or 2.9. 

• Color monitor with video card set to 256 colors

Memory (RAM) 512 MB

Browser One of these browsers:

• On Windows 2000 and Windows XP clients:

– Microsoft Internet Explorer 6.0.26 and Microsoft Internet Explorer 6.0.28

– Netscape Navigator 7.1 and Netscape Navigator 7.2

– Mozilla 1.7 and 1.7.5

• On Solaris clients:

– Netscape Navigator 7.0 

– Mozilla 1.7 and Mozilla 1.7.5
1-5
Installation and Setup Guide for Campus Manager on Windows

OL-11284-01

http://cisco.com/en/US/products/sw/cscowork/ps563/products_device_support_tables_list.html


 

Chapter 1      Prerequisites
  Supported Devices
1-6
Installation and Setup Guide for Campus Manager on Windows

OL-11284-01



 

Installation and Setup G
OL-11284-01
C H A P T E R 2

Installing Campus Manager

This chapter describes how to install, uninstall, and reinstall Campus Manager 4.0.6. 

This chapter contains:

• Installation Overview

• Installing Campus Manager 4.0.6

• Reinstalling Campus Manager

• Backing Up and Restoring Data After Installation

• Uninstalling Campus Manager
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Installation Overview
Table 2-1 is an overview of the Campus Manager 4.0.6 installation tasks. It contains references to more 
detailed information about each task.

Installing Campus Manager 4.0.6
Campus gets installed in the same directory where you have installed CiscoWorks Common Services 
3.0.5.

The Campus Manager 4.0.6 installer automatically updates program files and data from previous 
versions of Campus Manager.

All device updates up to Campus Manager 4.0 SP 5 have been incorporated into Campus Manager 4.0.6. 
This section contains the following topics:

• Licensing in Campus Manager 4.0.6, page 2-2

• Running the Installation Program, page 2-3

Licensing in Campus Manager 4.0.6
Campus Manager 4.0.6 uses the license of Campus Manager 4.0. If you have a licensed version of 
Campus Manager 4.0, you can install Campus Manager 4.0.6. 

Campus Manager 4.0.6 emulates the licensing behavior of Campus Manager 4.0. For example, if the 
Campus Manager 4.0 license is restricted, Campus Manager 4.0.6 is also restricted.

For information on the licensing mechanism in Campus Manager 4.0, see Installation and Setup Guide 
for Campus Manager 4.0 on Windows.

Table 2-1 Installation Tasks

Task Steps References

1. Prepare to install Campus. Verify that server requirements are met. “Server Requirements” section on page 1-3

2. Install Campus Manager. Run the installation program. “Installing Campus Manager 4.0.6” section on 
page 2-2

3. Verify and troubleshoot 
installation.

a. Verify the correct files and directories 
are installed.

b. Analyze installation error messages.

“Understanding Installation Messages” section 
on page A-2

4. Set up Campus Manager Prepare the system for Campus Manager 
applications and set up the applications.

Chapter 3, “Preparing to Use Campus 
Manager”
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Running the Installation Program
Before installing Campus Manager 4.0.6, you must install Campus Manager 4.0.3, from the LMS 2.5.1 
CD, and then proceed with installing Campus Manager 4.0.6 from the LMS 2.6 Update CD-ROM. 

To install Campus Manager 4.0.3:

Step 1 Insert the Campus Manager 4.0.3 CD-ROM into the CD-ROM drive.

The Installer window opens. 

If the Installer window does not open: 

• Select Start > Run. 

The Run dialog box opens. 

• In the Open field, enter drive:\autorun.exe 

where drive is the CD-ROM drive letter. 

The Installer window opens. 

Campus Manager 4.0.3 is installed in the same location as CiscoWorks Common Services. The default 
is C:\Program Files\CSCOpx. 

Step 2 Click Install.

The Welcome window appears.

Step 3 Click Next to continue.

The Software License Agreement window opens. To install Campus Manager 4.0.3, you must accept this 
agreement.

If you are upgrading from Campus Manager 4.0, the license agreement does not appear.

Step 4 Click Accept to continue.

The Licensing Information dialog box appears.

Step 5 Do either of the following:

• If you have a license file for CiscoWorks Common Services 3.0.3, click on the radio button to 
browse for the file and select it. 

• If you do not have a license, enter the serial number and the Permanent Index Number (PIN) from 
the product packaging. 

You can also proceed with the installation without a PIN number for an evaluation copy of Campus 
Manager 4.0.3.

Step 6 Click Next.

A window appears prompting you to enter your Campus database password.

Step 7 Enter your Campus database password. 

If you do not enter a password, the existing password is retained.

Step 8 Click Next to continue.

The System Requirements Window opens. 

Step 9 Verify whether you have the minimum system requirements to install Campus Manager 4.0.3.
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Step 10 Click Next to continue.

The Summary dialog box opens, displaying the target directory and program folder. The target directory 
is the directory in which you installed CiscoWorks Common Services 3.0.3.

Note Click Show Details in the Summary dialog box to view the Campus Manager database password. Store 
the password in a secure location. You may need it for debugging.

The following message appears:

Exiting installation beyond this point (after clicking the Next button) may result in 
system instability.

Step 11 Click Next to continue installation.

After installation is complete the following message appears:

To ensure that you retain the latest device support and bug 

fixes, please install the latest Service Pack (SP) 

for Campus Manager 4.0.3. You can download the latest SP from

http://www.cisco.com/cgi-bin/tablebuild.pl/cw2000-campus.

Please refer to the Installation and Setup Guide for details.

Step 12 Click OK. 

The following message about UTU appears:

User Tracking Utility 1.0 is not compatible with Campus Manager 4.0.3

User Tracking Utility 1.1.1 is available for Campus Manager 4.0.3.

You can download the latest UTU from 
http://www.cisco.com/cgi-bin/tablebuild.pl/cw2000-campus-crypto.

Please refer to the Installation and Setup Guide for details

Step 13 Click OK. 

The Setup Complete dialog box appears.

Step 14 Click Finish. 

Your Windows machine has Campus Manager 4.0.3 installed successfully. Now, from the LMS 2.6 
Update CD-ROM you need to install Campus Manager 4.0.6 by following the steps as below. 

To install Campus Manager 4.0.6:

Step 15 Insert the LMS 2.6 Update CD-ROM into the CD-ROM drive.

The Installer window opens. 

If the Installer window does not open: 

a. Select Start > Run. 

The Run dialog box opens. 

b. In the Open field, enter drive:\autorun.exe 

where drive is the CD-ROM drive letter. 

The Installer window opens. 

Step 16 Click Install.

The Welcome window appears.
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Step 17 Click Next to continue.

The Software License Agreement window opens. To install Campus Manager 4.0.6, you must accept this 
agreement.

If you are upgrading from Campus Manager 4.0, the license agreement does not appear.

Step 18 Click Accept to continue.

The System Requirements Window opens. 

Step 19 Verify whether you have the minimum system requirements to install Campus Manager 4.0.6.

Step 20 Click Next to continue.

The Install Updates screen appears displaying the new updates that needs to be installed as well as the 
updates that are already installed.

Step 21 Do either of the following:

• If you want to install only the new updates, select the Install new updates only radio button.

• If you want to uninstall or reinstall all the updates, select the Uninstall/ Re-install all updates radio 
button.

Step 22 Click either Next to proceed with the installation or Cancel to exit from the installation.

The System Requirements screen appears:

Step 23 Click Next to continue.

The following message appears:

If no other CiscoWorks application installations are pending, you can choose to start 
CiscoWorks Daemons.

Do you want to restart CiscoWorks Daemons at the end of this installation?

If you want to start CiscoWorks daemons, click Yes.

If you do not want to start CiscoWorks daemons, click No.

Step 24 Click Yes or No depending on whether you want to restart CiscoWorks daemons after installation.

The Summary dialog box opens, displaying the target directory and program folder. The target directory 
is the directory in which you installed CiscoWorks Common Services 3.0.5.

The following message appears:

Exiting installation beyond this point (after clicking the Next button) may result in 
system instability.

Step 25 Click Next to continue installation.

After installation is complete the following message appears:

If you plan to install any of the LMS 2.5.1 applications, you must reinstall CiscoWorks 
LMS 2.6 Update after installing these applications. 

For more information about restoring the LMS data, see the Data Migration Guide for LAN Management 
Solution 2.5.1 on Cisco.com. 

Step 26 Click OK.

The Setup Complete dialog box appears.

Step 27 Click Finish. 

The installation is complete.
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Note After installing Campus Manager 4.0.6, you can verify the process status by running NMSROOT/bin 
pdshow

If errors occurred during installation, check the installation log file in the root directory on the drive 
where the operating system is installed. The default is C:\Ciscoworks_setup00x.log. Each installation 
creates a new installation log that is saved as a different file. 

For other troubleshooting information, see Appendix A, “Troubleshooting the Installation.”

After the installation completes, do either of the following:

• If you have to import data from the earlier version of Campus Manager, see “Backing Up and 
Restoring Data After Installation” section on page 2-7.

• If you do not have data to import, continue to Chapter 3, “Preparing to Use Campus Manager.”

After Campus Manager 4.0.6 is installed, Topology Services allows you to either convert the saved views 
into the new Campus Manager 4.0.6 format or directly use the default views generated by Campus 
Manager 4.0.6. See “Upgrading Saved View Layouts From Topology Services” section for more 
information.

Reinstalling Campus Manager
If you had any problems during previous installation, you can reinstall Campus Manager.

For detailed steps to install Campus Manager 4.0.6, see Installing Campus Manager 4.0.6, page 2-2

The installation program can detect whether you have already installed Campus Manager 4.0.6. 
Reinstalling Campus Manager does not affect your existing database. However, we recommend that you 
back up the database before reinstallation to prevent any possible loss of data. Your CiscoWorks Server 
configuration is also preserved.

Upgrading Saved View Layouts From Topology Services
Use the following procedure to upgrade saved topology view layouts generated by the previous version 
of Campus Manager to the new Campus Manager 4.0.6 format. The following view layouts are upgraded:

• Layer 2 View

• Unconnected Device View

• LAN Edge View

To upgrade saved view layouts:

Step 1 Start Topology Services. (Campus Manager > Topology Services)

Step 2 Select File > Upgrade View Layouts.

Step 3 Select the view layout you want to upgrade.

Step 4 Click Upgrade to upgrade the selected view layout.

Topology Services upgrades the selected view layout to the 
Campus Manager 4.0.6 format. 
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Step 5 Select the corresponding view layout from the side panel in Topology Services to display this layout.

The upgraded view layout might not be formatted exactly the same manner as the previous version of 
the view layout.

Backing Up and Restoring Data After Installation
This section describes how to manually restore data from previous versions of Campus Manager. You 
can back up and restore data from:

• Campus Manager 3.2.x

• Campus Manager 3.3.x

• Campus Manager 4.0

• Campus Manager 4.0 Service Pack 1

• Campus Manager 4.0 Service Pack 2

• Campus Manager 4.0 Service Pack 3

• Campus Manager 4.0 Service Pack 4

• Campus Manager 4.0 Service Pack 5

where .x refers to the IDU upgrades.

This section contains:

• Backing Up Data Using GUI

• Backing Up Data Manually From Campus Manager

• Restoring Data Manually From Campus Manager

Backing Up Data Using GUI 
You can schedule immediate, daily, weekly, or monthly automatic database backups. 

To back up data:

Step 1 Go to the CiscoWorks Homepage and select Common Services > Server  > Admin > Backup. 

The Backup page appears. 

Step 2 Enter the appropriate information in the fields explained in Table 2-2 

Table 2-2 Backing Up Data

Field Description

Backup Directory Location of the backup directory. We recommend that 
your target location be on a different partition than the 
CiscoWorks installation location. 

Runtype Select the desired check box. You have options to 
schedule immediate, daily, weekly, or monthly 
backups. 
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Step 3 Click Apply. 

Backing Up Data Manually From Campus Manager
To manually back up saved data in earlier versions of Campus Manager:

Step 1 Stop the daemon manager on the local machine on which the previous version of Campus Manager is 
installed. Enter net stop crmdmgtd

Step 2 Export CiscoWorks data by entering:

NMSROOT\bin\perl NMSROOT\bin\backup.pl -d \backup dir

You should enter the path where you want to export the data. The script command will back up the 
CiscoWorks data.

Step 3 Start the daemon manager by entering net start crmdmgtd

Step 4 Copy the backed up directory to the remote machine.

Restoring Data Manually From Campus Manager 
To restore data manually:

Step 1 Stop the daemon manager on the local machine on which the previous version of Campus Manager is 
installed. Enter net stop crmdmgtd

Step 2 Restore CiscoWorks data by entering:

NMSROOT\bin\perl NMSROOT\bin\restorebackup.pl -d \backup dir

You should enter the path where you want the data to be restored.

Step 3 Start the daemon manager by entering net start crmdmgtd

Time From the drop-down lists, select the time and date. 

• If you schedule a weekly backup, select the day of 
the week from the drop-down list. 

• If you schedule a monthly backup, select the day of 
the month from the drop-down list. 

Generations Maximum number of backups to be stored in the backup 
directory. 

Table 2-2 Backing Up Data (continued)
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Uninstalling Campus Manager
The uninstallation program removes Campus Manager files and settings. Uninstallation allows you to 
remove only Campus Manager or remove CiscoWorks Common Services as well.

You must use the Campus Manager uninstallation program to remove the product. You could damage 
your system, if you try to remove Campus Manager 4.0.6 or its components manually.

Caution Uninstalling Campus Manager deletes its database. 

To remove Campus Manager or other major components:

Step 1 Select Start > Programs > CiscoWorks > Uninstall CiscoWorks. 

The Uninstallation dialog box appears, displaying all the installed components.

Step 2 Deselect the components you want to keep or click Select All 

Step 3 Click Next to continue. 

Uninstallation dialog box appears displaying details of the selected components.

Messages showing the progress of the uninstallation appear.

The following message appears:

Uninstallation is complete. Click OK to finish.

Step 4 Click OK.
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Preparing to Use Campus Manager

This chapter describes the various administrator and application setup tasks that you must perform after 
installing Campus Manager 4.0.6. 

This chapter contains:

• Overview of Campus Manager Setup Tasks

• Accessing the CiscoWorks Server

• Performing Administrator Tasks

• Setting Up Campus Manager Applications

• Logging Out as Administrator
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Overview of Campus Manager Setup Tasks
Table 3-1 provides an overview of Campus Manager 4.0.6 setup tasks and gives references to detailed 
information about each task. 

Accessing the CiscoWorks Server
To access Campus Manager, enter the URL of the CiscoWorks Server in your web browser:

http://server_name:1741
https://server_name:443 (for SSL mode)

where server_name is the name of the CiscoWorks Server and 443 is the port on which it was installed. 
If you were prompted to supply a different port number for the CiscoWorks Server during the 
installation, use that port number in the URL.

If you cannot access the CiscoWorks Server or the CiscoWorks Home page is not displayed correctly, 
see Appendix A, “Troubleshooting the Installation”.

After you access the CiscoWorks Server, continue to the “Performing Administrator Tasks” section on 
page 3-2.

Performing Administrator Tasks
To perform administrator tasks, you must log in as administrator and set up the server for other users.

Logging In as Administrator
To log in as administrator:

Step 1 Enter the system administrator username and password in the Login page.

Step 2 Click Login.

The CiscoWorks Homepage appears.

After you log in as the administrator, continue to the section Setting Up Campus Manager Applications, 
page 3-3

Table 3-1 Overview of Campus Manager setup tasks

Tasks References

1. Access the CiscoWorks server “Accessing the CiscoWorks Server” section on page 3-2

2. Perform administrator setup tasks “Logging In as Administrator” section on page 3-2

3. Start and configure applications “Setting Up Campus Manager Applications” section on 
page 3-3

4. Log out of the server “Logging Out as Administrator” section on page 3-7
3-2
Installation and Setup Guide for Campus Manager on Windows

OL-11284-01



 

Chapter 3      Preparing to Use Campus Manager
  Setting Up Campus Manager Applications
To log out of the CiscoWorks Server, see the section Logging Out as Administrator, page 3-7 for 
information.

Setting Up Campus Manager Applications
This section describes the tasks that you must perform to set up the 
Campus Manager 4.0.6 applications. Some of these tasks require the administrator login.

This section contains:

• Setting Up Your Network

• Configuring Device Discovery

• Setting Up Topology Services

• Setting Up Path Analysis

Setting Up Your Network
To ensure that the Campus Manager Server successfully discovers the devices in your network, you must 
set up your network correctly. Table 3-2 lists the required tasks for each application, marked by x. 

See the User Guide for Campus Manager 4.0.6 for more information.

After you set up your network, continue to the “Configuring Device Discovery” section on page 3-4. 

Table 3-2 Network Setup Tasks

Network Setup Requirement
Topology 
Services 

User 
Tracking 

Path 
Analysis 

VLAN Port 
Assignment

Discrepancy 
Reports

Connect to seed device x x x x x

Enable Simple Network Management Protocol 
(SNMP)

x x x x x

Enable Cisco Discovery Protocol (CDP) x x x x x

Enable Call Detail Record (CDR) – – x – –

Set a unique sysName variable on devices x x x x –

Enable Integrated Local Management Interface 
(ILMI) on ATM devices

x x x x x

Configure DNS x x x x x

Configure VLAN Trunk Protocol (VTP) x x x x x

Configure VLAN trunks on Fast Ethernet and 
Gigabit Ethernet

x x x x x

Create the default configuration server for ATM 
LAN Emulation (LANE)

x x x x x

Enable source routing – – x – –
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Configuring Device Discovery
You can modify SNMPv2 and SNMPv3 credentials using the Discovery > SNMP Settings option from 
the Admin tab in the Campus Manager Administration window.

To configure Device Discovery Settings:

Step 1 Go to the Campus Manager > Administration > Device Discovery > Discovery Settings.

The Device Discovery Settings dialog box appears.

Step 2 Specify the seed device and IP address range.

Step 3 Click Apply to save the changes.

Step 4 Click OK to start Device Discovery.

If you do not specify the IP address range, Device Discovery tries to discover as many devices as it can 
based on the community strings and connectivity.

For more information, see Specifying Seed Device Online help.

After you set up your network, you must configure data collection. See the “Configuring Data 
Collection” section on page 3-4. 

Verifying Device Discovery

To verify the status of Device Discovery, go to Campus Manager > Administration. In the Campus 
Manager Administration dashboard that appears, you can view the status of Device Discovery. 

Configuring Data Collection
You should have run Device Discovery atleast once before starting Data Collection, or the devices should 
be available in Device and Credential Repository (DCR).

To configure Data Collection, go to Campus Manager > Administration > Campus Data Collection > 
Data Collection Filters. The Data Collection Filter Settings dialog box appears.

To Specify VTP Domain

Step 1 Go to the Data Collection Filter Settings dialog box and select VTP Domain and click Configure.

The VTP Domain Filter dialog box appears.

Step 2 Go to the drop-down list and select either of these options:

– Manage devices in specified VTP domains.

– Do not manage devices in specified VTP domains.

Step 3 Enter the VTP domains that are to be used to limit data collection and click Apply.

You will be prompted to click OK to start Data Collection or to click Cancel to apply only the settings.
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To Specify IP Address Range

Step 1 Go to the Data Collection Filter Settings dialog box and select IP Address Range and click Configure.

The IP Range Filter dialog box appears.

Step 2 Go to the drop-down list and select either of these options:

• Manage devices in specified IP Address Range

• Do not manage devices in specified IP Address Range

Step 3 Specify the IP Address Range and click Apply.

A confirmation dialog box appears.

Step 4 Click OK to start Data Collection.

Note You can apply either the VTP domain or the IP Address Range, but not both.

If you do not specify the IP address range or VTP domain, Campus Manager takes all devices from the 
Device and Credential Repository. The number of devices for which data can be collected depends upon 
your licence limit.

Verifying Data Collection

To verify the status of Data Collection, go to Campus Manager > Administration. In the Campus 
Manager Administration dashboard that appears, you can view the status of Data Collection.

Setting Up Topology Services
To set up Topology Services:

Step 1 Verify that the Campus Manager Server is running.

Step 2 Make sure the Campus Manager Server has managed the devices. 

To verify this, go to the Data Collection Metrics page. (Campus Manager > Administration > Campus 
Data Collection > Data Collection Metrics)

Step 3 Select Campus Manager > Topology Services from CiscoWorks Homepage.

For more information, see the Topology Services Online help.
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Verifying Topology Services

To verify that Topology Services is working correctly:

• Verify that all devices and interfaces are discovered. 

Correctly discovered devices and interfaces appear in green in the Topology Services window.

• Verify that devices displayed in red are SNMP reachable and have correct community strings.

• Verify that all VLANs and ELANs are discovered and that their port assignments are correct.

The devices are displayed in Topology services only after data collection.

For more information, see the Topology Services Online help.

Setting Up Path Analysis
To set up Path Analysis:

Step 1 Install and configure a DNS server on your network. 

A DNS server is required for Campus Manager. For devices with multiple IP addresses, there should be 
a single DNS entry that includes all IP addresses.

Step 2 Specify correct read community strings on all devices. 

Step 3 Specify correct write community strings for multi-layer switching shortcut path determination on 
Catalyst 5000 devices.

Step 4 Edit the VLAN/ELAN Mapping Table. 

This table provides mapping of VLANs and ELANs to subnets. 

These mappings are auto-discovered based on information gathered by Topology Services and User 
Tracking. 

In some cases, the information might be incomplete. In these cases, you can edit a VLAN/ELAN 
mapping table to supplement the Topology Services and User Tracking information. If subnet mappings 
are not correct, Layer 2 traces on those subnets might fail.

Step 5 Enable Cisco Discovery Protocol (CDP) on all Cisco devices. 

If CDP is not enabled, these devices will not appear on Layer 2 path traces.

Step 6 Enable source routing on your network. 

This is required if you plan to run path traces outside of the domain known to Topology Services.

For more information, see the Path Analysis Online help.
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Verifying Path Analysis

To verify that Path Analysis is working correctly, do the following:

• Start Topology Services and make sure that all devices, interfaces, and links are managed correctly. 

Correctly managed devices appear in green in the Topology Services window. 

• Verify that all VLANs and ELANs are managed with correct port assignments.

• Start User Tracking and run User Tracking major acquisition with the Ping Sweep option enabled to 
verify that all end-user stations are managed.

• Run nslookup on several known devices in the command shell. 

• Verify that DNS lookup works and takes one second or less.

• Verify the Subnet Mapping table entries. 

Each VLAN and ELAN entry should have any corresponding subnets listed. Any subnets that do not 
correspond to a VLAN or ELAN should be in a Subnet row.

• Run a few traces between endpoints known to User Tracking or Topology Services and verify that 
the trace completed successfully.

For troubleshooting information, see the Path Analysis Online help.

Logging Out as Administrator
To end your administrator tasks, you must log out of Campus Manager 4.0.6. 

To logout as administrator:

Step 1 Close all secondary browser windows. 

You should have only one browser window opened displaying the 
Campus Manager interface.

Step 2 Click Logout. 

The Login page replaces the navigation tree.
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Troubleshooting the Installation

This appendix provides troubleshooting information for Campus Manager 4.0.6 installation and setup.

This appendix contains:

• Logging In After Upgrading

• Understanding Installation Messages

• Accessing the CiscoWorks Server

• FAQs On Service Packs
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Logging In After Upgrading
If the Login window on the CiscoWorks Home page does not appear correctly when you try to log in for 
the first time after upgrading, clear your browser cache and re-enter the server URL in your browser.

To clear the browser cache in Microsoft Internet Explorer:

Step 1 Select Tools > Internet Options. 

The Internet Options dialog box appears.

Step 2 Click the General tab.

Step 3 Click Delete Files and click OK in the Delete Files dialog box.

To clear the browser cache in Netscape Navigator:

Step 1 Select Edit > Preferences. 

The Preferences dialog box opens.

Step 2 Select Advanced >  Cache.

Step 3 Click Clear Cache and click OK.

Understanding Installation Messages
After verifying that the correct files are installed, check the C:\Ciscoworks_setup002.log file (or the log 
file with the highest number, for example Ciscoworks_setup003.log) for installation errors. 

The following types of installation messages might appear:

• Information messages—Display important details

• Warning messages—Inform you that something might be wrong with a particular process, but the 
process will complete

• Error messages—Inform you that a particular process could not complete

Table A-1 shows error messages that might occur during installation and describes the reasons for the 
errors.

Table A-1 Installation Error Messages

Message Reason for Message User Action

CiscoWorks installation cannot proceed 
because you are not logged in as an 
administrator.

You are not logged in to Windows with 
administrator privileges.

Log in with local administrator 
privileges and try installing again.

Decompression failed on file. The error 
was for error code per CompressGet.

If Campus Manager was downloaded, a 
transmission error occurred, or 
installation media is damaged.

Retry the download. If you still have 
errors, contact your technical support 
representative.
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General file transmission error. Please 
check your target location and try again. 
Error number: error code.

If Campus Manager was downloaded, a 
transmission error might have 
occurred. 

Retry the download. If you still have 
errors, contact your technical support 
representative.

Unable to write infoFile or Unable to 
create infoFile.

A file write operation failed. 1. Run the file system checking utility.

2. Repeat the installation.

Cannot stop service servicename. The installation (or reinstallation) tried 
to stop service servicename 
unsuccessfully.

1. Select Control Panel > Services 
and try to stop service servicename 
manually,

2. Continue installing or uninstalling.

UseDLL failed for dll. dll is supposed to be available at any 
time for any process, but Windows 
could not load it.

• Check permissions on Windows 
System32. If the dll is secure.dll or 
r_inst.dll, check product 
installation medium for errors.

Or

• Reinstall Windows.

OpenFile failed: pathname A File Open operation failed. Run the files system checking utility, 
then repeat installation.

ProtectFile failed: file: error. WWW 
admin security may be incomplete.

Setting file permissions failed because 
you may not be allowed to change 
them.

Log in as administrator.

Launch of isql script failed. The existing database file is broken, or 
the previous version of Campus 
Manager is destroyed.

This message might appear during 
reinstallation.

Contact your support representative.

You have less than 1M free space on drive 
name. Free up some space and try again.

Insufficient drive space for temporary 
installation files.

1. Make more drive space available.

2. Rerun the installation program.

This program requires to run on 
Windows.

You attempted to install on a system 
that does not have Windows with 
Service Pack 3 installed.

Install Campus on a Windows 
Professional system that is not 
configured as a PDC or BDC.

Could not determine the type of operating 
system. Campus Manager can be installed 
only on Windows with SP3.

Installation program could not 
determine which operating system is 
running.

Install on a Windows Professional 
system that is not configured as a PDC 
or BDC.

Physical memory is <...>M Paging File 
Size is: File Size is: <...>M(initial), 
<...>M(maximum).

We recommend that initial paging file 
size is bigger than physical memory and 
maximum paging file size is at least twice 
as big as physical memory.

(Maximum paging file size might not 
appear.)

The paging file size is smaller than 
recommended.

Finish installation, then increase paging 
file size.

Table A-1 Installation Error Messages (continued)

Message Reason for Message User Action
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There is not enough space available on 
the disk drive: This drive has <...> bytes 
in a cluster. Total required <...> clusters 
(<...> bytes), only <...> clusters (<...> 
bytes) available. Please free up some 
space or change the target location to a 
different disk.

(The second sentence might also appear 
as “Please free up some space and rerun 
installation.”)

Insufficient disk space available on 
drive to install the product.

• Create additional free space on the 
drive.

Or 

• Install on a different drive.

Cannot determine the local 
Administrators group.

Installation program cannot find one of 
the built-in Windows user groups. This 
prevents setup of Campus Manager 
security.

1. Check the Windows operating 
system. Reinstall Windows if 
necessary.

2. Rerun installation.

Cannot determine the local Everyone 
group.

The installation program cannot find 
one of the built-in Windows user 
groups.

1. Check the Windows operating 
system. Reinstall Windows if 
necessary.

2. Rerun installation.

Failed to set file permissions. The installation program cannot set file 
permissions. The most likely causes 
are:

• The account you used to log in to 
the system has insufficient 
permissions.

• The drive on which you are 
installing the product has a FAT 
file system.

1. Fix problem.

2. Rerun installation.

<...> is already running! Wait for it to 
finish and press the OK button.

One of the installation subtasks is still 
running.

1. Wait for subtask to finish running.

2. Click OK to proceed.

Unable to create/open log file. The installation program could not 
create or open installation log file (in 
the root directory of the drive on which 
you are installing) named 
Ciscoworks_setupxxx.log, where xxx is 
a sequential number starting from 001).

This may have occurred because of lack 
of disk space or write protection on the 
file.

1. Determine why file could not be 
created or opened and correct the 
problem.

2. Rerun installation. 

Error creating user bin <... more info 
here> See troubleshooting section in the 
User Manual

The installation program could not 
create the user account bin.

1. Fix problem.

2. Rerun installation.

Cannot find script to upgrade database There was a problem with the database 
upgrade.

Contact your technical support 
representative.

Table A-1 Installation Error Messages (continued)

Message Reason for Message User Action
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Accessing the CiscoWorks Server
The CiscoWorks server uses port 1741 by default (443 if SSL is enabled). If you receive an error message 
that an alternative port is used instead, verify that you entered the correct URL for the server:

http://server_name:port

where server_name is the name of the machine on which CiscoWorks was installed and port is the port 
number 1741 or the number supplied during installation.

If you still cannot access the server, enter the following command at a DOS prompt to make sure your 
server is running:

ping server_name

If you get a message that the server is alive and get a proxy error when you try to connect to the server, 
make sure the proxy is set up correctly. If your server is configured to use a proxy server outside the 
firewall, you will get proxy errors if you configured the proxy to ignore requests to a certain machine, 
set of machines, or domain. 

You specify a proxy server in Netscape Navigator under Edit > Preferences > Advanced > Proxies and 
in Internet Explorer under Tools >  Internet Options > Connections > LAN Settings. 

Your proxy is set up incorrectly if: 

• You receive an error message informing you that you are using a proxy outside the firewall.

• The proxy server recognizes www-int as an internal server, so it does not send proxy requests to that 
server.

• You set up a new internal server, www-nms, but when you make a request to the proxy server, it does 
not recognize www-nms as an internal server and proxies the request.

• The proxy server outside the firewall tries to request data from a server inside the firewall, and the 
request is blocked.

• You get a Connection Refused error from the proxy server.

Database upgrade failed There was a problem with the database 
upgrade.

Contact your technical support 
representative.

Database upgrade result unknown There was a problem with the database 
upgrade.

Contact your technical support 
representative.

Table A-1 Installation Error Messages (continued)

Message Reason for Message User Action
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FAQs On Service Packs
The following are the Frequently Asked Questions (FAQs) on Service Packs.

Q. What is an SP? Why should I install the latest SP?

A. SP (Service Pack) for Campus Manager is a downloadable package containing a collection of 
updated files to provide you with support for new devices. In addition, the SP contains fixes to 
certain known problems, as well as fixes to newly discovered problems. SPs are available for 
downloading from Cisco.com.

Q. From where can I download a Service Pack?

A. To retain support for new devices, we recommend that you download and install the latest SP for 
Campus Manager from:

http://www.cisco.com/cgi-bin/tablebuild.pl/cw2000-campus

Q. How do I know which version of SP I have installed?

Q. To check the version of SP installed on your system, from the CiscoWorks Homepage, go to 
Software Center > Software Update > Campus Manager.
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User Tracking Utility

CiscoWorks User Tracking Utility 1.1.1 (UTU) is a Windows desktop utility that provides quick access 
to useful information about users or hosts discovered by the Campus Manager User Tracking application. 

This chapter contains:

• Understanding UTU

• Hardware and Software Requirements for UTU

• Downloading UTU

• Installing UTU

• Accessing UTU

• Configuring UTU

• Uninstalling UTU

• Upgrading to UTU 1.1.1

• Reinstalling UTU

Understanding UTU
User Tracking Utility allows users with Help Desk access to search for users or hosts discovered by 
Campus Manager User Tracking application. UTU comprises a server-side component and a client 
utility.

To use UTU, Campus Manager must be installed and accessible through the network.

Definitions
Table B-1 explains certain terms and definitions used in User Tracking Utility.

Table B-1 Definitions

Term Definition

Host Any UNIX or Windows system discovered by User Tracking.

Host Name Name of the discovered host.
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Hardware and Software Requirements for UTU
Table B-2 lists the minimum system requirements for UTU 1.1.1.

Downloading UTU
UTU requires CiscoWorksUserTrackingUtility1.1.1.exe file to be downloaded and installed. To 
download:

Step 1 Locate the file CiscoWorksUserTrackingUtility1.1.1-k9.zip at:

http://www.cisco.com/cgi-bin/tablebuild.pl/cw2000-campus-crypto

This zip file contains CiscoWorksUserTrackingUtility1.1.1.exe and setup.iss file (required for silent 
installation).

Step 2 Extract the file using any file extractor such as WinZip.

Campus Manager Server Host name or IP address of CiscoWorks server on which you have installed 
Campus Manager.

Port • Port number to which the host is connected

• Port number on which Campus Manager is running on the CiscoWorks 
server

Subnet Subnet to which the host belongs.

User Name Name of the user who has logged into the host.

Table B-1 Definitions (continued)

Term Definition

Table B-2 System Requirements

Requirement Type Minimum Requirements

System hardware IBM PC–compatible computer with Intel Pentium processor.

System software Windows 2000 (Professional or Server) with Service Pack 3 or higher, 
Windows XP with Service Pack 2 or higher.

Memory (RAM) 128 MB

Additional required 
software

Campus Manager 4.0.6

Network Connectivity Campus Manager 4.0.6 must be running and accessible through the 
network
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Installing UTU
To install UTU in normal installation mode:

Step 1 Log into the system with local system administrator privileges.

Step 2 Navigate to the directory that contains CiscoWorksUserTrackingUtility1.1.1.exe.

Step 3 Double-click CiscoWorksUserTrackingUtility1.1.1.exe to begin installation.

The User Tracking Utility Welcome screen appears.

Step 4 Click Next.

The Choose Destination Location dialog box appears. By default, UTU is installed in the directory 
C:\Program Files\CSCOutu.

Step 5 Click Next to install UTU in the default directory.

To modify the default directory:

a. Click Browse to choose a different directory and click OK.

b. Click Next to continue with the installation.

The Configure CiscoWorks LMS Server Details dialog box appears.

Step 6 Enter the name or IP address of the server on which Campus Manager is installed. 

Step 7 Enter the port number of the Campus Manager server. The default port number is 1741.

Step 8 Click Next.

The following message appears:

Is CiscoWorks LMS Server SSL Enabled?

Step 9 Click Yes if the Campus Manager server is SSL enabled, otherwise, click No.

The Configure LMS Server Authentication dialog box appears. You can also configure these server 
details after installation.

Step 10 Enter a valid CiscoWorks Campus Manager server user name and password.

This is used to verify the validity of the user when searching for users or hosts.

Step 11 Confirm the password and click Next.

The Setup Complete dialog box appears.

Step 12 Click Finish to complete the installation.

User Tracking Utility is installed at the destination location you specified in Step 5 above. However, it 
does not create a program group under Start > Programs.

You cannot re-install UTU on a system that already has this application installed on it. You must check 
for existing installations of UTU before beginning a fresh installation.

To install UTU in silent mode, enter the following at the command prompt:

exe-location\CiscoWorksUserTrackingUtility1.1.1.exe –a –s –f1file-location\setup.iss

where

• exe-location is the directory where you have CiscoWorksUserTrackingUtility1.1.1.exe

• file-location is the directory where you have the setup.iss file.
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Do not use space after the -f1 option. Use the complete path for file-location.

For example: 

If the install directory for UTU is c:\utu, enter the following at the command prompt:

c:\utu\CiscoWorksUserTrackingUtility1.1.1.exe -a -s -f1c:\utu\setup.iss

To configure the server information, modify the setup.iss file before running the silent install. Edit the 
following fields:

[SdShowDlgEdit2-0]
szEdit1= <hostname>
szEdit2= <server-port>
Result=1
[AskYesNo-0]
Result=1           <1- SSL Enabled, 0 - SSL Disabled>
[SdShowDlgEdit3-0]
szEdit1=<username>
szEdit2=<password>
szEdit3=<password>

You cannot re-install UTU on a system that already has this application installed on it. You must check 
for existing installations of UTU before beginning a fresh installation.

To confirm UTU installation on your system, right-click the taskbar and select the Toolbar option in 
your machine. You can find the User Search Band option in the popup menu.

Accessing UTU
To display the UTU desktop band on the taskbar: 

Step 1 Right-click the taskbar of the machine on which you installed UTU.

Step 2 Select Toolbars > User Search Band, as shown in Figure B-1.

Figure B-1 Selecting the Toolbar

The UTU desktop band appears on the taskbar with the title User Information.
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Configuring UTU
You must configure UTU only if you want to change the Campus Manager server configurations that you 
entered while installing UTU.

To configure UTU:

Step 1 Right-click the User Information search area on the taskbar of the machine on which you installed UTU.

A popup menu appears.

Step 2 Select Configure.

The Campus Manager Server Configuration dialog box appears.

Step 3 Modify the settings as required.

Step 4 Click Enable SSL for communicating with an SSL enabled server. 

The port is changed to 443, which is the default port for SSL. See Figure B-2.

Figure B-2 Enabling SSL

Step 5 Click OK to configure or Cancel to quit.

Uninstalling UTU
Before you uninstall UTU 1.1.1, you must hide the UTU desktop band. To do that, right-click the taskbar 
of the machine on which you installed UTU, and deselect User Search Band in the Toolbars popup 
menu.

To uninstall UTU:

Step 1 Go to the Windows taskbar and select Start > Settings > Control Panel > Add/Remove Programs.

The Add/Remove Programs dialog box appears.

Step 2 Select CiscoWorks User Tracking Utility.

Step 3 Click Change/Remove.

The system prompts you to confirm uninstallation.
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Step 4 Click Yes.

The Remove Programs From Your Computer dialog box appears.

Step 5 Click Yes to remove the shared DLL, UTBand.dll, and click OK.

Or

Click No. 

The uninstallation proceeds, but it does not completely uninstall UTU. 

Step 6 Go to the directory where have you installed UTU to complete the uninstallation process. The default 
directory is C:\Program Files\CSCOutu.

a. Enter regsvr32 /u UTBand.dll

The following message appears:

DLLUnregisterServer in UTBand.dll failed

b. Click OK.

c. Enter del UTBand.dll

This removes the UTU installation completely from the machine. 

Step 7 Restart your system.

Upgrading to UTU 1.1.1
You can upgrade User Tracking Utility from UTU 1.1 to UTU 1.1.1.

When you install UTU 1.1.1 above UTU 1.1, UTU prompts you to uninstall the previous version. A 
message appears:

WARNING: The setup program has detected a previous version of CiscoWorks 
User Tracking Utility. To install CiscoWorks User Tracking Utility 1.1.1, previous 
version of the product must be uninstalled. Do you want to uninstall CiscoWorks 
User Tracking Utility 1.1.1 now?

Yes/No

Click Yes to upgrade, or No to quit.

Reinstalling UTU
You must not install UTU 1.1.1 on a system that already has this application installed on it. You must 
check for existing installations of UTU 1.1.1 before attempting to reinstall it.

To check for an existing installation of UTU 1.1.1:

Step 1 Right-click on the Taskbar of the machine. 

Step 2 Select Toolbars.

If you see the User Search Band option, it means you have UTU 1.1.1 already installed on the system.

You must first uninstall the current installation of UTU 1.1.1, and only then reinstall it.
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Changes and Enhancements in Campus Manager 
4.0.6

Campus Manager 4.0.6 provides management support for Layer 2 technologies. It is built on 
CiscoWorks Common Services 3.0.5 and is an integral component of CiscoWorks LAN Management 
Solution 2.6 (LMS 2.6).

In this release, the Campus Manager Admin Dashboard, Setup Center, and the Device Selector, have 
been improved with advanced search features. These improvements have been explained in the following 
sections:

• Enhanced Homepage

• Setup Center

• Enhanced Device Selector

Enhanced Homepage
The Campus Manager Homepage provides information on status of Device Discovery, Data Collection, 
and User Tracking Acquisition. It also provides information on the physical and logical discrepancies 
and also the details of the jobs that have been completed recently. You can easily access frequently used 
features in the application from the homepage. 

For more details, see User Guide for Campus Manager 4.0.6.

Setup Center
Setup Center enables the grouping of different categories of configurations. This helps the user configure 
and check all necessary server settings from a single place.

For more details, see User Guide for Common Services 3.0.5.

Enhanced Device Selector
The new Device Selector supports search and advanced search capabilities. For more details, see User 
Guide for Common Services 3.0.5.
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