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New Features
New Features
Campus Manager Release 3.3 contains the following new features:

• Improved workflow and ease-of-use and intuitiveness in launching tasks from 
Campus applications.

• Fixes to problems that existed in previous releases (for more information 
about release notes.

In addition, the following enhancements have been made to individual Campus 
applications:

Topology Services

• Ability to create Topology Groups.

• Ability to locate devices in switch-clouds and fabrics using LAN edge view. 

• Provides a new device status filter.

• Ability to generate a report to list all unused ports.

• Ability to copy the the running configuration to the startup configuration of 
IOS devices when VLAN related changes are made.

Path Analysis

• Support for batch job processing and archiving in Path Analysis.

• Support for sorting subnet-to-VLAN Mapping table.

• Improved Path Analysis tracing capabilities. For details of the improvements, 
see “Path Analysis” section on page 61.

• Support for CCM login.

• Improved GUI—Pull down menu in Path Analysis connected to the source 
and destination field.

• Support for displaying error messages on unsuccessful Path Analysis for 
Layer 3 and Layer 2.

User Tracking

• Ability to define acquisition based on a subnet range.

• Support for scheduled archive and export feature in User Tracking.

• Enhanced troubleshooting support using a new debugger utility.
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Product Documentation
• Improved GUI—Addition of two new columns to the User Tracking tables 
(duplex type and port speed).

Discrepancy Reports

• Support for enhanced discrepancy reporting.

• Support for duplicate sysName, ErrDisabl and timestamps for discrepancy.

Administration

• Support for administering Topology Groups.

• Ability to configure scheduling of Path Analysis traces, and archiving of 
User Tracking data.

Product Documentation

Note We sometimes update the printed and electronic documentation after original 
publication. Therefore, you should also review the documentation on Cisco.com 
for any updates.

Table 1 describes the product documentation that is available.

Table 1 Product Documentation

Document Title Available Formats

Quick Start Guide for LAN 
Management Solution, Release 2.2

• Printed document that was included with the product.

• On Cisco.com:

a. Log into Cisco.com.

b. Select Products & Services > Network Management 
CiscoWorks > CiscoWorks LAN Management Solution > 
Versions and Options > CiscoWorks LAN Management 
Solution 2.2.
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Product Documentation
Release Notes for Campus 
Manager 3.3 on Windows

• Printed document that was included with the product.

• On Cisco.com:

a. Log into Cisco.com.

b. Select Products and Services > Network Management 
CiscoWorks > CiscoWorks Campus Manager > Versions 
and Options > CiscoWorks Campus Manager 3.3 .

Installation and Setup Guide for 
Campus Manager on Solaris

• PDF on the product CD-ROM.

• On Cisco.com:

a. Log into Cisco.com.

b. Select Products and Services > Network Management 
CiscoWorks > CiscoWorks Campus Manager > Versions 
and Options > CiscoWorks Campus Manager 3.3 .

• Printed document available by order (part number 
DOC-7815049=).1

User Guide for Campus Manager • PDF on the product CD-ROM.

• On Cisco.com:

a. Log into Cisco.com.

b. Select Products and Services > Network Management 
CiscoWorks > CiscoWorks Campus Manager > Versions 
and Options > CiscoWorks Campus Manager 3.3 .

• Printed document available by order (part number 
DOC-7815051=).1

Supported Devices Table for 
Campus Manager 3.3

1. Log into Cisco.com.

2. Select Products and Services > Network Management 
CiscoWorks > CiscoWorks Campus Manager > Versions and 
Options > CiscoWorks Campus Manager 3.3 .

Context-sensitive online help • Select an option from the navigation tree, then click Help.

• Click the Help button in the dialog box.

1. See the “Obtaining Documentation” section on page 69.

Table 1 Product Documentation (continued)

Document Title Available Formats
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Related Documentation
Related Documentation

Note We sometimes update the printed and electronic documentation after original 
publication. Therefore, you should also review the documentation on Cisco.com 
for any updates.

Table 2 describes the additional documentation that is available.

Additional Information Online
The following product specific information is available online:

• For the latest technical tips, suggestions for troubleshooting common issues, 
and frequently asked questions (FAQs) about most Campus applications, you 
can go to the following URL:

Table 2 Related Documentation

Document Title Description and Available Formats

User Guide for CiscoWorks 
Common Services

Describes CiscoWorks Common Services, gives an overview of 
the applications that make up Common Services and provides 
conceptual information about network management. 

This describes common tasks you can accomplish with Common 
Services. This document is available in the following formats: 

• PDF on the product CD-ROM.

• On Cisco.com:

a. Log into Cisco.com.

b. Select Products and Services > Network Management 
CiscoWorks > CiscoWorks Common Services > Versions 
and Options > CiscoWorks Common Services 2.2.

• Printed document available by order (part number 
DOC-7815049=).1

1. See the “Obtaining Documentation” section on page 69.
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Support Information
http://www.cisco.com/pcgi-bin/Support/browse/psp_view.pl?p=Software:Ca
mpus_Manager&s=Implementation_and_Configuration#Samples_and_Tips

• You can find information about all supported devices by logging into 
Cisco.com at:

http://www.cisco.com/univercd/cc/td/doc/product/rtrmgmt/cw2000/camp_m
gr/sup_dev/index.htm

• You can also obtain any published patches and download device packages for 
new devices from Cisco.com. If you are a registered user, you can download 
Incremental Device Updates (IDU) for Campus from:

http://www.cisco.com/cgi-bin/tablebuild.pl/cw2000-campus

Device packages are released cumulatively; that is, new device packages 
contain the contents of any previous packages.

To determine which packages are installed on your CiscoWorks Server, select 
Server Configuration> About the Server> Applications and Versions.

Support Information
Campus 3.3 supports only US-English and Japanese versions of Windows 
Operating Systems. It does not support any other language version. Set the default 
locale to US-English for US-English version and Japanese for Japanese version.

Known Problems
This section describes problems known to exist in this release:

• General Notes and Known Problems, page 7

• General Known Problems, page 9

• Browser Known Problems, page 14

• Path Analysis Known Problems, page 15

• User Tracking Known Problems, page 24

• Topology Services Known Problems, page 33

• ANI Server Known Problems, page 51
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Known Problems
• Device/Agent Known Problems Impacting ANI Server, page 60

• VLAN Port Assignment Known Problems, page 61

Note To obtain more information about known problems, access the Cisco Software 
Bug Toolkit at http://www.cisco.com/cgi-bin/Support/Bugtool/home.pl. (You will 
be prompted to log into Cisco.com.)

General Notes and Known Problems
Note the following:

• Your browser must be properly configured. If it is not properly configured, 
Campus might not work correctly. See the Installation and Setup Guide for 
Common Services on Windows 2000 for information on properly setting up 
client systems.

• Campus requires a DNS server to function properly. Many commands operate 
erratically or not at all if there is no DNS server on the network.

• Running Campus from a browser invoked from an x-window connection is 
not supported. Install a browser on the client from which you wish to connect.

• Virus checker applications on Windows NT and Windows 2000 systems 
might slow Campus response times.

• You can upgrade your operating system (OS) either before or after you 
upgrade Campus. However, if you upgrade the OS after upgrading Campus, 
you will not receive any OS-related patch warnings or service pack-related 
warnings.

• Verify that the latest version of all required operating system (OS) patches, 
service packs, and third-party device drivers are installed before proceeding 
with an OS upgrade.

• We recommended that any Windows 2000 server running Netscape Navigator 
should not also be used as a client.

• Visio Caveats:

– Do not export an entire topology map to Visio. Instead, select and export 
particular devices or a segment of the network.
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Known Problems
– After selecting Export to Visio, be sure to enter a filename in the Export 
to Visio dialog box for the file Visio will generate.

– Before opening a topology map exported to Visio, you need to download 
the cm_cisco.vss file and place it in the Visio/Solutions directory.
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Known Problems
General Known Problems
Table 3 General Known Problems

Bug ID Summary Explanation

None Catalyst 3500 series is supported 
in IP mode only.

Campus supports Catalyst 3500 series in IP mode 
only. Cluster mode is not supported. If your 
network has a Catalyst 3500 in cluster mode, the 
links display incorrectly.

Workaround:

None.

CSCin23883 Jobs created in Path Analysis or 
User Tracking are listed in Job 
Management page even after 
uninstalling Campus.

If you have scheduled Path Analysis or 
User Tracking jobs and then uninstall Campus 
Manager, the jobs are not deleted from 
CiscoWorks Job Management page.

Workaround;

Delete the Path Analysis or User Tracking jobs 
from Job Management page.

CSCdu51651 ATM:Create SPVC/SPVP: 
problem to select first template.

Under ATM if you create SPVC/SPVP/Advanced 
parameters, it is not possible to select the first 
template from the drop-down box. This is because 
the traffic parameters fields are not populated.

Workaround:

• Go to Select/Edit. Select the template. 
Click OK.

Or

• Select the second template, and then select 
first template.
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Known Problems
CSCdt55303 Launching a Campus application 
with the Print dialog box open in 
another Campus application 
results in error.

The following actions result in a problem:

1. Select Print from active Campus application.

2. With Print dialog box displayed, launch 
another Campus application. 

The new application window does not respond 
to user input.

Workaround:

Close the Print dialog box and relaunch the 
application.

CSCdt42318 Unable to copy and paste IP 
addresses from Topology 
Services to Path Analysis when 
keyboard shortcuts are used.

This problem occurs if you do the following:

1. After selecting an IP address in Topology 
Services, enter Ctrl-C to copy address.

2. With cursor active in Path Analysis “From” 
field, enter Ctrl-V; the following is pasted in 
instead of IP address:

java.lang.nullPointerException

Ctrl-X, Ctrl-C, and Ctrl-V (keyboard shortcuts for 
cut, copy, and paste commands) are not supported 
by summary tables in the Topology Services main 
window or most tables displayed by Campus 
applications.

Also, in applications that support the copying of 
table cells by selecting Edit > Copy, a carriage 
return is added to the end of the last cell copied.

Workaround:

None.

Table 3 General Known Problems (continued)

Bug ID Summary Explanation
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Known Problems
CSCdt22462 Download of Java applets on 
Windows 2000 machines may 
take longer than expected if virus 
checker application is enabled.

On some Windows systems, the initial download 
of large Java applets (or subsequent downloads of 
the same applets that are not cached locally) might 
take longer than expected (up to six minutes in 
some instances). 

After the applet has been loaded and cached 
locally, the problem no longer occurs.

The delay is caused by client side filtering 
mechanisms such as virus scanning. Some virus 
scanners are configured to automatically scan 
content downloaded by browsers. Scanning 
consumes a lot of memory and results in disk 
paging on most systems.

Owing to this, downloading is significantly slower 
than expected. (The effect is less on systems with 
large amounts of RAM and virtual memory.)

Workaround:

Disable the automatic scanning of all downloaded 
files, and instead enable the scanning of program 
files only (specified by file extension).

Exact instructions vary depending on the virus 
scanner installed on your system.

Table 3 General Known Problems (continued)

Bug ID Summary Explanation
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Known Problems
CSCds88388 Cannot launch CiscoView on an 
IGX series device.

The following procedure results in this problem:

1. Launch Topology Services.

2. Open LAN Edge view.

3. Right-click on IGX series device and select 
CiscoView from context menu.

4. A dialog box appears. Enter appropriate 
community strings, and CiscoView attempts 
to launch. However, an error message is 
displayed.

Workaround:

Launch CiscoView on IGX series devices via 
Cisco WAN Manager.

CSCdp74251 Application performance is very 
slow with HTTP proxy.

Accessing Campus through the HTTP proxy might 
cause significant performance degradation.

Workaround:

Access CiscoWorks Server directly from client.

CSCdp48040 When you attempt to launch an 
application, the message

application already running

displays, where application is 
the name of the application you 
attempted to launch.

If you close the application window and the 
Loading Files popup window while the 
application is loading, this message appears:

Problem occurs because browser is still 
loading files.

Workaround:

Close all browser windows, then start the 
application again.

Table 3 General Known Problems (continued)

Bug ID Summary Explanation
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Known Problems
CSCdm88520 Minimized windows do not 
become visible when selected 
from a Window menu.

If a window is minimized, you cannot make it 
visible by selecting it from a Window menu. 

Workaround: 

• On Solaris, double-click the icon of the 
window on the desktop.

• On Windows, click the icon of the window in 
the task bar.

CSCdm83204 Campus applications do not 
work when CiscoWorks is 
accessed using 
http://localhost:1741

If you access CiscoWorks applications using 
http://localhost:1741 from browser on same 
machine CiscoWorks server is installed on, 
Campus suite of applications will not work.

Workaround:

Use full DNS name or IP address of server, even 
when accessing it locally.

CSCdm77812 Non-empty CLASSPATH 
environment variable might 
produce erratic browser 
behavior.

If your system has a non-empty CLASSPATH 
environment variable, your browser might behave 
unpredictably. 

For example, you may see the following error 
message appear for for no apparent reason:

ClassNotFound Exception 

Workaround:

Unset CLASSPATH variable non globally:

• Solaris—Reset the CLASSPATH variable 
from terminal window from which you launch 
browser.

• Windows—Unset CLASSPATH variable in 
MS-DOS prompt window and launch browser 
from the prompt.

Table 3 General Known Problems (continued)

Bug ID Summary Explanation
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Known Problems
Browser Known Problems

Table 4 Browser Known Problems

Bug ID Summary Explanation

CSCin39472 Problems with Campus Manager 
applications after logout.

When you logout from CiscoWorks, Campus 
Manager applications will continue to function. 
However, the following functionalities will not be 
available:

• Launching Help.

• Tasks in Campus which require user action 
between applications do not function 
properly. For example, highlighting a device 
in Topology Services using Path Analysis.

Workaround:

1. Close all Campus applications.

2. Login into CiscoWorks.

3. Launch Campus applications.

CSCdt11838 You are not prompted to install 
the Java plug-in when launching 
an application that utilizes the 
plug-in for the first time.

If RealJukebox Plug-in for Navigator is already 
installed on a Windows client before the first 
launch of application utilizing Java Plug-in, you 
will not be prompted to install Java Plug-in.

Workaround:

Uninstall RealJukebox Plug-in. Another option is 
to rename nprjplug.dll file in Navigator Plug-ins 
directory with new extension—for example, 
nprjplug.dll.bak.

After Java Plug-in is installed, you can reactivate 
RealJukebox Plug-in by changing renamed file 
back to nprjplug.dll.
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Known Problems
Path Analysis Known Problems

CSCdp43999 Maps and configuration dialogs 
display offset menus and list 
boxes in Netscape on a Solaris 
client.

Sometimes, when a map or a configuration dialog 
is launched, menus or list boxes are not displayed 
below the menu. This offset occurs in Navigator 
on a Solaris client.

Workaround:

Move or resize window.

Table 5 Path Analysis Known Problems

Bug ID Summary Explanation

CSCin37938 Interface Type displays

Unknown 

for phones in Path Analysis 
Table.

This problem occurs when you run path traces 
between IP Phones or between a device and IP 
Phone.

Workaround:

None.

CSCin36351 Bad host value error results in 
Path Analysis displaying 
interface type as 

Unknown

in Path Analysis table.

When you perform a trace between one interface 
of an MLS enabled router to a switch (internal 
MLS), the following error message appears in the 
Path Analysis log:

ERROR IA: IA(host): bad host value.

This problem is observed when you enable MLS 
on Catalyst 6000 devices.

Workaround:

None.

Table 4 Browser Known Problems (continued)

Bug ID Summary Explanation
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Known Problems
CSCin36082 Additional hop is displayed 
when you perform a trace using 
HSRP virtual IP address.

An additional hop is displayed if you perform a 
trace by providing an HSRP virtual IP address as 
the source or destination in the path trace.

Workaround:

None.

CSCin35773 Map displays self loop when 
routing loop occurs.

Occasionally, when the potential first hop learnt 
by Path Analysis is not discovered successfully by 
ANI, the map displays a self loop.

Workaround:

None.

CSCin30899 Path Analysis does not work 
when LSR Traceroute is 
disabled.

Occasionally, if you disable source route trace 
route in routers, Path Analysis is unable to display 
the trace.

Workaround:

None.

CSCin30678 Error printing from the 
Path Analysis Trace tab.

After performing a path trace, if you print the 
browser output by selecting the table tab, the 
characters in the first column are garbled.

Workaround:

None.

CSCin28223 CORBA related error message is 
logged into the log file during 
path trace.

Occasionally, during path trace, a CORBA related 
error message is logged into the ani.log file.

Workaround:

Close the client browser window and relaunch 
Path Analysis.

CSCin00624 Path trace involving HSRP 
router results in an empty 
IfIndex entry in the 
Path Analysis table.

The problem occurs when you run a Path trace 
which includes the IP address of an HSRP router 
in the From field of a path trace.

Workaround:

None.

Table 5 Path Analysis Known Problems (continued)

Bug ID Summary Explanation
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Known Problems
CSCdw15555 Voice trace fails to get CCM 
cluster information if CCM 
HTTPD shuts down.

Path Analysis Voice Trace needs to query call 
managers known to ANI to see what the cluster 
membership is.

This is done through a HTTP query

http://ccm-name/ccn/clusterinfo.asp

As a security precaution, you might disable the 
webserver on all cluster members except one. This 
is because CCMs use IIS, and can be badly 
damaged by viruses such as Code Red and 
NIMDA.

However, if cluster members have webserver shut 
off, then Path Analysis cannot obtain information 
on cluster membership and cannot retrieve CDRs.

Workaround:

Turn the webserver on the CCM back on.

Table 5 Path Analysis Known Problems (continued)

Bug ID Summary Explanation
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Known Problems
CSCdw03410 Path Voice Trace does not 
consider transcoding points.

Current Campus Path Analysis Voice Trace is 
valid only in the case where the two endpoints are 
IP Phones registered with the same CCM cluster.

For other cases (involving transcoding), Path does 
not get correct path information. 

Examples: 

• Phone call from IP phone to POTS phone off 
H.323 gateway (e.g. 3640) 

• Phone call from one CCM cluster to another.

In such a case the path would be:

a. From phone 1 to CCM 1

b. From CCM 1 to CCM 2 through H.323 
inter-cluster trunk

c. From CCM 2 to phone 2

• Phone call to gateway (PSTN, analog, etc.) 

• Phone call to other servers (voicemail, 
conference, etc.)

This is a very complex issue, and most likely will 
require new instrumentation from telephony 
servers, etc.

Workaround:

None.

CSCdt42600 To and From fields may not 
function properly after selecting 
Print in Path Analysis. 

This problem is caused by Java Virtual Machine 
bug. After selecting Print in Path Analysis, the To 
and From fields may not accept mouse focus, or 
focus may appear in both fields simultaneously. 

Workaround:

Resize Java console window. If the problem 
persists, close Path Analysis window and open 
another window. 

Table 5 Path Analysis Known Problems (continued)

Bug ID Summary Explanation
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Known Problems
CSCdt42404 Trace tab displays GMT as time 
zone, even though server is set to 
local time zone.

A number of Java bugs involve incorrect 
interpretation of time zones. Usually, the correct 
time zone is displayed if the local time zone is set 
to appropriate three-letter abbreviation—for 
example, PST for Pacific Standard Time.

This problem is observed on Solaris clients with 
TZ environment variable set to American/Tijuana. 

Workaround:

If the TZ environment variable is instead set to 
PST8PDT, then Java interprets local time zone 
correctly.

CSCdt23712 Path Analysis displays the Elvis 
module of Catalyst 6000 devices 
as:

unknown

Since Path Analysis depends on ANI for its tracing 
capabilities, if a device-related discovery problem 
occurs in ANI, it results in an unsuccessful trace. 

For more information, see CSCin29281.

Workaround :

None.

Table 5 Path Analysis Known Problems (continued)

Bug ID Summary Explanation
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Known Problems
CSCdt16279 Uninformative or confusing 
error message displayed in Voice 
Trace Query Status tab after 
running CDR query.

Status tab of Voice Trace Query window may 
display uninformative error message. For 
example:

Error querying CCM noname
Probable cause
noname

Workaround:

1. Verify that CCM machine is accessible by 
pinging it from your Campus server. 

2. If CCM host is accessible, then verify that 
web server is running. Open web browser and 
navigate to the following URL:

http://ccm_ip_address/ccn/cdr.asp
?type=all

3. If web server is running, you will see a 
response to your URL request in browser 
window. This response may provide more 
detailed diagnostic information to 
troubleshoot problem: 

a. If web browser response indicates 
database query error, contact TAC for 
help in diagnosing this CCM database 
layer problem. 

b. If 404 Not Found error message is 
displayed, web server is probably 
running, however ASP script that queries 
CDR records cannot be located. Ensure 
that Cisco CallManager Serviceability 
software is installed on this CCM. 

c. If The page cannot be displayed error 
message is displayed, then web server 
may not be running—start it on 
CCM host.

Table 5 Path Analysis Known Problems (continued)

Bug ID Summary Explanation
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Known Problems
CSCdt04978 Highlighted path trace in 
Topology Services map may be 
difficult to view.

It may be difficult to view highlighted path trace 
in Topology Services map, especially if the Fit to 
Window view is selected.

Workaround:

Zoom into Topology Services Map view by 
selecting 
Select All Highlighted Objects > Zoom to 
Selected.

Table 5 Path Analysis Known Problems (continued)

Bug ID Summary Explanation
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Known Problems
CSCds92510 ICS 7750 device running Cisco 
CallManager does not appear in 
list of Cisco call managers.

To verify that software is installed and configured 
correctly, open web browser and navigate to 
following URL:

http://hostname/ccn/clusterinfo.asp

One line of alphanumeric characters should be 
displayed. 

If software is installed and configured correctly, 
then the problem occurred because ccmStatus 
cannot be retrieved via SNMP from ICS 7750 
device (both primary and secondary SBC).

By default, log tracing is disabled for performance 
reasons when System Manager and Cisco 
CallManager are both installed on device. Since 
log tracing is disabled, you cannot retrieve 
ccmStatus with SNMP.

Workaround:

Manually enable tracing through Cisco 
CallManager:

1. Ensuring SDI Trace settings as follows: 

– User Mask: 11 

– Level: ERROR 

– Event: INFORMATION

2. Enabling the SNMP agent by : 

– Enabling SNMP in CCM Service 
Parameters.

– Turning Trace On in CCM Trace 
Configuration.

Table 5 Path Analysis Known Problems (continued)

Bug ID Summary Explanation
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Known Problems
CSCds92510 
(continued)

ICS 7750 device running Cisco 
CallManager does not appear in 
list of Cisco call managers.

3. Restarting SPE through System Manager: 

a. Enter following URL in browser:

\\ip_address\icsconfig

b. Click Shutdown/Restart link.

c. Click Restart for Primary SPE in list.

On dual SPE systems, this will trigger a failover. 
However, when procedure is repeated to restart 
secondary SPE, box will switch back to primary 
SPE.

See CSCds07414 and CSCdt54829 for more 
information.

CSCds79693 Voice trace query results are 
always displayed using local 
time zone. 

Local time zone always displayed in voice trace 
query results, even if user selects GMT time zone 
when specifying call start time. 

Workaround:

None.

CSCds77461 Call Detail Records (CDR) 
query results are sometimes 
displayed after pressing Cancel.

Multiple threads are launched to query every 
Cisco CallManager for information specified in 
user's CDR query. 

Since all query activities can take a second or two 
to cancel, query results are sometimes displayed 
even after pressing Cancel.

Workaround:

None.

Table 5 Path Analysis Known Problems (continued)

Bug ID Summary Explanation
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User Tracking Known Problems
Information displayed in a row might not reflect the most current network state. 
This is because User Tracking discovery takes information from routers and 
switches. Since these switches collect their information at different times, the 
information in a row reflects the state of the network or subnet at the time 
displayed in the Last Seen field.

CSCds77438 Path Analysis Map tab does not 
refresh properly.

This problem mainly occurs when running both 
the client and the server on the same machine. It 
occurs after running a large number of Path traces 
on client browser.

Workaround:

Close browser and relaunch Campus.

We recommend that you run client and server on 
different machines. Doing so does not eliminate 
problem, however it does limit its occurrence 
because you need to run a large number of traces 
before problem manifests itself.

Table 5 Path Analysis Known Problems (continued)

Bug ID Summary Explanation

Table 6 User Tracking Known Problems

Bug ID Summary Explanation

None User Tracking discovery could 
span more than desired subnet.

When you start subnet discovery of user nodes, 
devices in that subnet are marked for discovery. 
Since switches support multiple VLANs, 
discovery could span more than the subnet that 
you selected. User Tracking could discover 
additional end host nodes not in selected subnet.

Workaround:

Query only the required VLAN option in the 
subnet discovery window.
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Known Problems
CSCin33604 User Tracking buttons not 
displayed in Netscape Navigator 
in SSL mode.

This problem is caused by a jar caching problem in 
the java plug-in.

Workaround:

1. Close User Tracking window.

2. Restart User Tracking.

CSCin28994 Highlight Device always opens 
layer 2 view map.

Even if device is displayed in the Unconnected 
Views, if you try to highlight the device only the 
layer 2 view map is displayed.

Workaround:

None.

CSCin26128 The command ut -cli -host 
does not work with SSL servers.

This problem occurs because User Tracking does 
not work on the command line for remote servers 
in SSL mode.

Workaround:

Disable SSL on the remote server.
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CSCin24106 User Tracking client displays 
OutOfMemoryError in the 
javaplugin console and stops 
loading records.

When User Tracking discovers more than 60000 
end hosts, and loads the data into the User 
Tracking client an OutofMemoryError message 
might appear in the java plugin console. The client 
stops loading the records.

Workaround:

For User Tracking to load more than 60,000 
records, do the following in the client browser:

1. Select Start > Settings > Control Panel > Java 
Plugin 1.3.1.

2. Select Basic.

3. In the Java Runtime Parameters field, add or 
append the following:

-Xmx256m

4. Click Apply.

5. Restart browser.

6. Invoke User Tracking.

CSCin19358 Unable to use “|” in the 
Scheduling User Tracking tasks 
fields.

You cannot use “|” in the Scheduling 
User Tracking tasks fields. This is because 
Scheduling uses this symbol for internal 
processing.

Workaround:

None.
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CSCin08287 User Tracking fails to recognize 
IP change when you set 
UTIPChange to 1 under DHCP.

In a network using DHCP, with the UTIPChange 
set to 1, User Tracking often fails to recognize 
changes in IP address when an end-host is moved 
across VLANs. In this case, IP address changes 
across subnets.

When you set UTIPChange to 0, User Tracking 
detects the change of IP address across VLANs.

Workaround:

None.

CSCin00365 A change of CCM registration 
adds a new record in phone table.

CCM entries themselves respond with two entries. 
The change should be done in the CCM and not in 
the User Tracking.

Workaround: 

None.

CSCin00363 End host is not showing if 
obsolete ANI device IP address 
is assigned.

If a CDP device is connected to the port and then 
a new end host is added, this new end host will not 
be learnt. This is because ANI is not aware of such 
a change. 

Workaround: 

Delete the specific device and then perform a ANI 
device specific discovery, followed by 
User Tracking discovery.

CSCin00181 Last seen field gets updated for 
disconnected ip phones.

The Last Seen in Phone Tracking corresponds 
only to Last Seen on CCM and not to Last Seen on 
Network.

Workaround: 

None.
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CSCdw15109 User Tracking does not 
recognize VLAN change to 
default-VLAN.

When a switch port is moved from an externally 
reachable VLAN to an unreachable VLAN, 
User Tracking will not recognize the change in 
VLAN.

Workaround: 

None.

CSCdw13857 User Tracking does not work for 
C4224 devices.

This is caused by the agent not supporting 
VLAN-indexing for the BRIDGE-MIB. Hence the 
end hosts/phones connected to this device will not 
appear in the User Tracking table.

Workaround: 

None.

CSCdw09818 VLANE: Port attribute shows 
incorrect information.

This problem is observed only with down ports, 
and the mib values returned by the devices seem to 
latch on the previous up speed and duplex.

This is a problem on the agent side.

Workaround: 

None.

CSCdw04499 User Tracking does not work for 
Catalyst 3550 running Cisco IOS 
release 12.1(6)EA1 or earlier.

User Tracking does not work for Catalyst 3550 XL 
running Cisco IOS release 12.1(4)EA1 and Cisco 
IOS release 12.1(6)EA1. This is caused by an 
agent bug (Bug ID CSCdu55510).

Hence, User Tracking will not be able to show up 
end hosts connected to the devices which run the 
above releases.

Workaround:

This problem has been fixed in Cisco IOS 
release 12.1(6)EA1a. Upgrade to this version.

Table 6 User Tracking Known Problems (continued)

Bug ID Summary Explanation
28
Release Notes for Campus Manager 3.3 on Windows

78-15053-01



 

Known Problems
CSCdw04486 User Tracking does not work for 
Catalyst 2950 running a software 
release earlier than Cisco IOS 
release 12.0(5)WC2.

This is caused by a defect (Bug ID CSCdu88701) 
in the SNMP agent in the Catalyst 2950 running 
Cisco IOS release 12.0*WC(1). Hence, 
User Tracking does not discover some endhosts.

Hence, User Tracking will not be able to show up 
the end hosts connected to this version of the 
device.

Workaround:

This problem has been fixed in Cisco IOS 
release 12.0(5)WC2. Upgrade to this version.

CSCdv18014 UTlite process utlite.exe does 
not terminate after running.

UTLite process utlite.exe does not terminate after 
utlite runs on a workstation and sends the data to 
CiscoWorks server.

Workaround:

None.

CSCdv17242 Printing User Tracking entries to 
a printer does not work on a 
Windows 2000 client.

This problem occurs because Java Plug-in for 
Windows 2000 can generate hundreds of MB of 
data for the print job. 

Java Plug-in converts the print job to a graphics 
(Postscript) format. For User Tracking with 250 
entries, if the client is an Windows NT 4.0 system, 
the print job is around 50MB. 

If the client is a Windows 2000 system, then the 
print job is more than 160MB. Most printers may 
not have enough memory or spooler space to hold 
huge print jobs. It may take a long time to print. 

Workaround: 

Export User Tracking data to a .txt file and then 
use Microsoft Excel to print it out.
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CSCdt42619 Unable to save changes using 
keyboard shortcut (Ctrl-S).

After modifying a cell, if you use the keyboard 
shortcut (Ctrl-S) with cursor in editable cell, 
changes are not saved. 

This problem also occurs if you use any shortcut 
involving the Ctrl key and then select File > Save 
Changes.

Workaround:

Do not use any keyboard shortcuts involving the 
Ctrl key when the cursor is in a editable cell.

CSCdt25525 User Tracking main table 
sometimes displays 
CDP-enabled devices that are 
outside of ANI discovery 
boundary.

During User Tracking discovery, User Tracking 
reads entries from the CAM table. These entries 
may include MAC addresses of devices that fall 
outside of ANI discovery boundary. 

Workaround:

None.

CSCdt21834 Modify LANE Services window 
does not get updated.

After you delete all available LECS, the Modify 
LANE Services window does not get updated.

Workaround:

Close and reopen Modify LANE Services window.

CSCdt06183 User Tracking Main Table may 
not display all entries displayed 
in phone table.

User Tracking entries shown in the main table are 
discovered from network. However, 
User Tracking entries shown in phone table are 
read from Cisco CallManager. 

If User Tracking cannot discover particular 
phones in network, entries for such phones in the 
User Tracking phone table will not have device 
and port information. 

Workaround:

None.
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CSCds90003 Configuration server details do 
not refresh after creating 
configuration server

This problem occurs if you:

1. Select Managed Domains > ATM Domains.

2. Select Tools > LANE Management > 
Configure Configuration Server.

3. Select any Configuration Server displayed 
whose Operational Status is Not Configured.

4. Click Apply.

The table that displays configuration server details 
is not refreshed and appears blank. Also, the latest 
status of configuration server does not appear.

Workaround:

Close and relaunch Configure Configuration 
Server window to view details for the 
configuration server.

CSCds81070 IP phone entry in User Tracking 
main table may not have subnet 
information.

When User Tracking discovers MAC entry 
belonging to network IP phone but cannot find the 
corresponding ARP (from router) to resolve its 
MAC to IP address, User Tracking attempts to 
match the IP address with entries from the phone 
table.

When this happens, subnet information will be 
missing from the phone entry. 

Workaround:

None.

CSCds01217 Change in IP phone directory 
number is not recognized by 
User Tracking.

When you add, delete, or change an IP phone 
directory number, you must restart Cisco 
CallManager before User Tracking recognizes 
changes.

See Bug ID CSCdr55953 for more information. 

Workaround:

None.
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CSCdr85384 Phone entries displayed by 
User Tracking differ from 
entries displayed by Cisco 
CallManager.

User Tracking phone entries acquired through 
SNMP for each Cisco CallManager may be 
different from entries in Cisco CallManager.

The Cisco CallManager database displays 
historical record of all phones registered to Cisco 
CallManager. 

The SNMP agent retains only record of phones 
registered since agent was started, accounting for 
differences.

Workaround:

None.

CSCdr53022 Cisco CallManagers are not 
discovered if there are CDP 
devices connected to the same 
hub.

When you connect Cisco CallManager (or host or 
IP phone) and CDP device to the same hub, 
User Tracking cannot discover that Cisco 
CallManager.

Workaround:

None.

CSCdr45212 IP phone table does not display 
SoftPhone entries.

SNMP agent in Cisco CallManager 3.0 does not 
report any SoftPhone entries. Thus, User Tracking 
will not display SoftPhone entries in IP phone 
table. 

See CSCdr55949 for more information.

Workaround:

None.

CSCdk20561 Catalyst 3000 devices shown as 
multiple host entries with same 
MAC addresses but different 
VLAN information, causing 
duplicate entries after each 
User Tracking discovery.

Catalyst 3000 devices appear as multiple host 
entries with same MAC addresses but different 
VLAN information. This causes duplicate entries 
after each User Tracking discovery.

Workaround:

None.
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Topology Services Known Problems

Table 7 Topology Services Known Problems

Bug ID Summary Explanation

None Multilayer Switch Module 
gigabit ports displayed as 
unknown-duplex.

Multi layer Switch Module does not have the MIB 
to support half and full-duplex on gigabit ports. 
Therefore, those ports are displayed as 
unknown-duplex.

Workaround:

None.

None OAM Ping is only supported if 
ATM Switch Processor version 
is 4.0 or above for devices with 
FC-PFQ card.

If a device has an FC-PFQ feature card, OAM 
Ping is supported only if ATM Switch Processor 
version is 4.0 or later.

Workaround:

None.

None The supported ILMI 
configuration interface types are 
UNI, PNNI, and IISP.

In ATM Management Interface Configuration 
window, the only supported choices for ILMI 
Configuration Interface Type are UNI, PNNI, and 
IISP.

Workaround:

None.

CSCsa11230 When a port is part of channel 
and configured as trunk, Campus 
Manager does not display the 
port as trunking for Catalyst 
2950 Switches.

This problem is seen in Topology Services:

1. Select Layer 2 View.

2. Go to any Catalyst 2950 series device.

3. Right-click to open its Port Attributes.

Is.Trunk is always shown de-selected, though the 
port might be trunking on the device.

Workaround:

None.
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CSCin36988 Unable to calculate utilization of 
VCs in tunnel.

This occurs if you perform the following in 
Topology Services:

1. Setup a tunnel between two atm devices and 
let the devices see each other as Interim Local 
Management Interface (ILMI) neighbors on 
their tunnel interfaces (subinterfaces) only.

2. Select Fabric view.

3. Select a device and its associated vp tunnel 
link.

4. Select Tools > Display VCs > Per device.

5. Click Get Info.

An error appears:

Throws error Failed to compute 
utilization for some or all rows

Workaround:

None.
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CSCin36950 Unable to view VCs in a tunnel 
from Topology Services main 
window.

This occurs if you perform the following in 
Topology Services:

1. Setup a tunnel between two atm devices and 
let the devices see each other as Interim Local 
Management Interface (ILMI) neighbors on 
their tunnel interfaces (subinterfaces) only.

2. Select Fabric view.

3. Select a device and its associated vp tunnel 
link.

4. Select Tools > Atm Management > Display 
VCs > Per device.

The device/port chooser does not list not 
subinterfaces.

Workaround:

None.

CSCin34586 Deletion of System or User 
defined groups allowed.

An Admin user is allowed to delete top level 
System Defined Group or User Defined Group but 
such a user cannot recreate these groups.

Workaround:

To recreate the System Defined or User Defined 
Groups:

1. Login as admin.

2. Delete all groups under Campus Manager > 
Administration > Topology Groups. 

3. Restart the daemon manager.
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CSCin34249 Write to startup config does not 
work for some devices running 
Cisco IOS release 11.2 in VLAN 
Port Assignment.

This is because in some devices such as Catalyst 
2900XL, Catalyst 2950, Catalyst 3500XL, 
Catalyst 3550 switches running Cisco IOS release 
11.2, MIB support is not available to perform a 
write operation.

The support is available in Cisco IOS release 12.0 
and later.

Workaround:

This problem has been resolved in the Incremental 
Device Update (IDU) on Campus Manager 3.3.

Install IDU, available at:

http://www.cisco.com/cgi-bin/tablebuild.pl/cw20
00-campus

CSCin30389 On Netscape Navigator, for 
System Defined Groups, the 
Create, Edit, and Delete buttons 
appear enabled for all users.

On Netscape Navigator, for System Defined 
Groups, the Create, Edit, and Delete buttons 
appear enabled for all users.

When you click on the Create, Edit, and Delete 
buttons without access rights, the Admin Client 
displays a message that you do not have access 
rights.

Workaround:

None.
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CSCin29281 Device Attribute of 
Catalyst 6000 devices does not 
display the IP address.

Device Attribute of Catalyst 6000 devices does 
not display the IP address of WS-X6624-FXS 
module.

Instead, the IP address of supervisory engine is 
displayed.

This problem is caused by a defect in the SNMP 
agent on the device. For more information, see 
CSCin33075.

Workaround:

None.

CSCin27895 No VLANs are displayed if the 
VTP Domain is set to NULL 
folder.

VLANs in VTP server devices with no VTP 
domain name configured will be displayed as 
inactive in Topology Services > VTP Domains > 
NULL folder.

These VLANs will be shown as inactive even 
though the state of the VLAN on the switch may 
be active.

Workaround:

Either: 

• Configure VTP domain name in the device 
and rediscover.

Or

• Configure the VTP domain mode of the 
device as transparent and rediscover.
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CSCin25679 Icon for EtherChannel not 
available in Visio Stencil.

The icon for Ether Channel is not available in Viso 
Stencil. This causes an error 

Cannot find master Ethernet Channel

to appear when a map containing “Ethernet 
Channel” links is exported and opened in Visio.

Workaround:

None.
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CSCin22459 Topology Groups membership 
update does not work as 
expected.

This occurs if you:

1. Select Campus Manager > Administration > 
Topology Groups.

2. Select a parent group and Click Create.

Enter the group name.

3. Click Next, to create a rule for the group.

4. Click Next.

The Group Membership page appears. 

On this page, if you select devices from the 
Objects Matching Membership Criteria list 
and click Remove, the devices are moved to 
the Available Objects list.

5. Click Next. 

The Access Control page appears.

If you click Back, to return to the membership 
page, the devices that were removed, appear 
in the Objects Matching Membership Criteria 
list, and not in the Available Objects list.

Workaround:

1. Click Back from the membership page to go 
to rule creation page.

2. Click Next again to return to the membership 
page. 

The removed objects will be shown in the 
Available Objects list.
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CSCin22400 Unable to add deleted members 
after moving out of step 3 in the 
Topology Groups wizard.

This occurs if you perform the following:

1. Select Campus Manager > Administration > 
Topology Groups.

2. Select a parent goup and Click Create.

Enter the group name.

3. Click Next, to create a rule for the group.

4. Click Next.

The group membership page appears. On the 
page, if you select devices from the Objects 
Matching Membership Criteria list and click 
remove, the devices are moved to the 
Available Objects list.

5. Click Next. 

The access control page appears.

Now if you click Back, to return to the 
membership page, the devices that were 
removed appear in the Objects Matching 
Membership Criteria list, and not in the 
Available Objects list.

Workaround:

1. Click Back from the membership page to go 
to rule creation page.

2. Click Next again to return to the membership 
page. The removed objects will be shown in 
the Available Objects list.
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CSCin09070 Unable to invoke simultaneous 
sessions of Topology Services 
from separate servers using 
Internet Explorer.

When you try to invoke simultaneous sessions of 
Topology Services from separate servers using 
Internet Explorer, either of the following errors 
appear:

• 403 forbidden Error

or

• The previously launched session of Topology 
Services is replaced with the later session.

This is beacuse only one instance of Topology 
Services can be running at any point of time.

Workaround:

None.

CSCin01977 Position of devices connected to 
SwitchCloud changed after 
upgrade.

Switch clouds and fabrics represent the collection 
of LAN switches and ATM switches respectively.

These logical entities are very specific to the 
currently discovered network. That is, if there is a 
new switch discovered it can affect either of them 
to a very large extent. 

This means that you cannot uniquely identify a 
switch cloud/fabric across ANI databases.

Workaround:

None.

CSCin01451 Cannot launch Customer 
Response Application URLs 
from Service Attributes window.

The sysApplInstallPkgLocation MIB object 
returns /AppAdmin/ whereas 
http://ip-address/AppAdmin cannot launch the 
application.

This is because the application web server was 
running in a different port 6293. 

Workaround:

Use CRA version 3.0(0.25) or later to avoid this 
problem.
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CSCin00665 Voice Port information not 
shown for Catalyst 4224 running 
a Cisco IOS release earlier than 
release 12.1(5)YE3.

This is caused by a bug in the agent on the device 
(Bug ID CSCdu08256).

Workaround:

This problem has been fixed in the Cisco IOS 
release 12.1(5)YE3. Upgrade to this version.

Table 7 Topology Services Known Problems (continued)

Bug ID Summary Explanation
42
Release Notes for Campus Manager 3.3 on Windows

78-15053-01



 

Known Problems
CSCea17100 Topology Group Administration 
not accessible using Internet 
Explorer 6.0 with Service Pack 1 
(version 6.0.2800.1106).

When you use Internet Explorer 6.0 with Service 
Pack 1 (version 6.0.2800.1106), in the non-SSL 
mode, applets under Campus Manager > 
Administration > Topology Groups, appear as 
blank grey boxes.

Also, output in the Java Console displays 
IOExceptions when these applets are invoked.

Workaround 1

If you do not want to enable SSL on the 
CiscoWorks Server:

1. Invoke CiscoWorks Server and then Choose 
any of the Common Services Applets (Backup 
Database or Restore Database, Licensing 
Information etc).

2. If the server uses a self-signed Certificate 
(default), a message appears 

The Certificate is issued by an 
untrusted site....Do you want to 
Proceed?

3. Select View Certificate Option.

4. In the Certificate dialog box , select Install 
Certificate.

5. In the Certificate Import Wizard, select the 
default options.

6. Close the browser.

7. Invoke the CiscoWorks Server Again.

Workaround 2

1. Enable SSL on the CiscoWorks Server (Server 
Configuration > Administration > Security 
Management > Enable/Disable SSL). 

2. Invoke Common Services Applets.
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CSCdz82384 Topo Groups displays Java 
console error:

AggregateModel: Unable to 
find node

When you invoke Topology views from Topology 
Groups, the Java Console displays:

ERROR: AggregateModel: Unable to find node 
<nodename>
Cannot create link id=<id> in map <map>

Workaround:

None. This error message, does not impede the 
functioning of Topology Views.

CSCdy08502 Unable to print Topology Map 
view on large-format printer.

When you print to a large-format printer using 42" 
roll of paper, Campus Manager formats the output 
to 8.5” x 11” paper size.

Workaround:

None.

CSCdx07224 LECs discovered multiple times. Sometimes, LANE Clients (LECs) are discovered 
and displayed multiple times in the LE Client list 
in Topology Services.

Workaround:

None.

CSCdw78798 Campus Map does not print well 
for a large map with more than 
180 devices.

This problem occurs when Campus has more than 
180 devices on the Layer 2 topology map.

If you use the Print All option, it prints the map on 
one page but the font size is too small and illegible

Workaround: 

None

CSCdw66262 ANI does not show devices using 
sysName.

ANI does not show discovered devices using 
sysName although sysName is defined. 

Workaround:

None.
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CSCdw49136 A break in connection between 
LANE and VLAN.

When the LEC from the Catalyst is removed the 
connection between ATM-VLAN and VLAN is 
broken for Catalyst 2900XL devices. 

This is caused by the bug in the Catalyst 2900XL 
agent devices wherein the CISCO-LEC-EXT-MIB 
is not supported.

Workaround: 

None

CSCdw23594 ATM cloud appears in layer 2 
map but not in Campus.

Sometimes the layer 2 map displays an ATM cloud 
which does not appear in Campus.

Workaround:

None.

CSCdw20967 VLANE: Missing information in 
Client ARP Information window.

This occurs if you:

1. Create ELAN, LECS, LES, a backup LES and 
LEC.

2. Select the ATM-VLAN, invoke view of the 
ATM-VLAN

3. Invoke VTP domain map of the ATM-VLAN.

4. Select a switch that has LECS and LEC 
configured.

5. Select Diagnosis > LE Client > ARP 
Information

This list shows all information for other clients in 
the same device, but does not show Host and 
Interface in other devices. 

Workaround: 

None.
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CSCdw19584 VLANE: Error on invoking LES 
status whose mastership is 
unknown.

This occurs if you:

1. Invoke VTP domain map of the atm-vlan and 
select a switch that has LES configured whose 
mastership state is unknown.

2. From the map, select Diagnosis > LE/BU 
server > LE Server Status. 

This gives an exception. 

Workaround: 

None.

CSCdw19557 LANE: Peer Host and elan not 
shown for backup peers (LES).

This occurs if you:

1. Select a switch that has LECS configured in a 
VTP domain map of the atm-vlan.

2. Invoke Diagnosis > LE Config Server > 
Control Connections.

3. Open Config Server control Connections for 
The list of control connections does not show 
the peer host and elan name. 

Workaround: 

None.

CSCdw13002 Campus does not discover 
Catalyst 2924 XL Standard 
Edition switches.

Campus does not discover Cisco Catalyst 2924 XL 
Standard Edition switches in a topology map even 
if the switches are defined as seed devices.

Workaround:

None.
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CSCdv41860 Topo Map: Fetching LANE 
components details gives 
AniSQLException.

In Topology Services, if you create a LANE 
component in an ATM switch(LS1010) and launch 
its view, all the Profile and Diagnosis menu items 
related to this component displays an exception.

It displays the error message

Internal error

Workaround: 

None.

CSCdv00136 VLAN management always adds 
VLAN 1 to trunk.

If the trunk does not forward traffic for VLAN 1 
(VLAN 1 is not added to the trunk) and you add 
any other VLAN, such as VLAN 7, to the trunk, 
VLAN 1 is also added to the trunk. 

This happens although it was not included in the 
Add operation.

Workaround:

This has been fixed in the CatOS release 6.3. 
Upgrade to this version.

CSCdt50619 Two devices, connected by 
multiple links, appear to be 
connected by only one link.

When two devices are connected by multiple links, 
deleting and you rediscover either devices or links, 
all of the links are stacked on one another. 

This causes the devices to appear as if they are 
connected by only one link.

Workaround:

Perform a relayout.
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CSCdt50396, 
CSCdt51095

Display VC Per Device window 
unusable after selecting a row 
and clicking Get Info.

This problem occurs if you do the tasks in either of 
these scenarios.

Scenario 1

1. Launch Display VC Per Device window.

2. With all VCs highlighted, select a device/port 
and click Get Info.

3. After the Get Info button becomes active 
again, select a different device/port.

4. Select one of the displayed rows and click Get 
Info.

Scenario 2

1. Launch Display VC Per Device window. 

2. With all VCs highlighted, select a device/port 
and click Get Info. 

3. Before the Get Info button becomes active 
again, select one of the displayed rows. 

An exception is returned in Java console, and 
Display VC Per Device window becomes 
unusable.

Workaround:

Close and relaunch Display VC Per Device 
window.
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CSCdt33558 ICS System Manager does not 
launch from Topology Services 
context menu.

With Topology Services running in Internet 
Explorer browser, if you select ICS System 
Manager from context menu, it does not launch. 

Workaround: 

• Open a new Internet Explorer browser 
session, and type device IP address as URL:

http://device_ip_address

Or

• Launch ICS System Manager from Topology 
Services running in Navigator browser.

CSCdt28061 Unable to view map displaying 
highlighted device in Trace 
Report window.

This problem occurs when you:

1. Install Campus.

2. Click Display VCs Per Device.

3. Select device and click Get Info. All VCs in 
device are displayed.

4. Select a VC and click Trace Report.

5. In Trace Report window, click Highlight 
Map.

Workaround:

None.

CSCdt27824 Entire list of ports in a VTP 
domain is displayed when 
certain Transparent VTP 
domains are selected from 
VLAN Assignment dialog box.

When similar VLAN definitions exist on a VTP 
server and transparent devices, VLAN is added 
under the parent folder and all transparent devices. 
Thus, VLAN ports are displayed under all 
transparent devices.

Workaround:

Run Find Ports query and enter only device 
name/address to view ports for a particular device.
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CSCdt18293 Visio drawing does not imported 
cleanly into Microsoft Visio.

If you export a Topology map as a Visio drawing, 
it is not imported cleanly into Microsoft Visio. 
Links are drawn out of place, and some incorrect 
links appear to be drawn between devices.

Workaround: 

Clean the Visio drawing manually after import.

CSCds61359, 
CSCds71941

Unable to select Main Topology 
Window from the Window menu.

The Main Topology Windows does not appear 
when you:

1. Launch Topology Services.

2. Open Layer 2 topology map.

3. Select the Main Topology Window from the 
Window menu.

Workaround:

None.

CSCdr11577 Virtual Circuit (VC) error chart 
is blank.

A blank chart could mean either a continuous 
polling failure or a failure caused by other 
problems. 

For example, a blank VC error chart might be due 
to a continuous polling failure (of VC error related 
data). It could also be because these statistics 
might not be supported on certain image versions 
of the ATM switch, being polled.

Workaround:

None.

CSCdp88318 Link attributes are not updated 
after a change is made.

If you change link attributes, ANI Server does not 
properly discover and display the change in 
reports. 

Workaround:

To update link attributes, close and relaunch 
Topology Services.
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CSCdp47638, 
CSCdp47670

After a port change, both the old 
and the new link are displayed.

After a link is changed to a different port on the 
same device, both the old and new links appear. 
Instead of being displayed as a dashed red line, the 
old link continues to appear as a solid red line.

Workaround:

Delete all links originating from both devices and 
rediscover the two devices.

Table 8 ANI Server Known Problems

Bug ID Summary Explanation

CSCin33112 Unable to delete devices on a 
remote system in SSL mode 
through the command line 
interface.

The DeleteDevice command line utility will fail if 
you use it on a remote server in the SSL mode.

Workaround:

None.
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CSCin25757 Stopping or starting the 
ANIServer also requires JRun 
to be stopped or restarted.

Occasionally, when you select Server 
Configuration > Setup > ANI Server Admin, an error 
appears: 

Not all data can be read from server

At other times, when you try to invoke Campus 
applications, the product will fail and will stay in 
Loading mode.

The following exceptions can be seen in Java 
console.

DEBUG-JSComm()^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
java.lang.ClassCastException: 
java.lang.StackOverflowError
<<no stack trace available>>
DEBUG-JSComm()

This problem occurs when you stop and restart only 
the ANIServer, and not JRun.

Workaround:

1. Close all client windows.

2. Stop JRunProxyServer, enter:

pdterm JRunProxyServer

3. Start JRunProxyServer, enter:

pdexec JRunProxyServer
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CSCin25185 Pdterm results in error. When you stop ANIServer by using:

$NMSROOT/bin/pdterm ANIServer

an error message is displayed:

ERROR: cmd failed. Server reason: No such 
process

Workaround:

None. Ignore the error message,

CSCin03204 Device sync between 2 SSL 
enabled servers not supported

Device sync is not supported for the following 
combinations:

1. Between two separate SSL Servers (one running 
ANI and other running Essentials); however if 
both ANI and Essentials are in same box 
running in SSL mode, The device sync is 
supported.

2. From a non-SSL ANI server to SSL enabled 
Essentials, Common Services should provide 
API for transferring the certificates. Currently 
no such service exists.

Workaround: 

Disable SSL and then run device sync.

Table 8 ANI Server Known Problems (continued)

Bug ID Summary Explanation
53
Release Notes for Campus Manager 3.3 on Windows

78-15053-01



 

Known Problems
CSCdy31689 Discovery hangs when 
discovery metrics page is 
refreshed.

In large networks, sometimes ANI hangs with 
discovery partially complete and it does not display 
any CPU usage. This happens when discovery 
metrics page is being refreshed.

The problem is caused by a bug in JRE caching of 
DNS lookups.

Workaround:

1. Stop Daemon manager.

2. Edit the registry key, 

HKEY_LOCAL_MACHINE\SOFTWARE\
Cisco\Resource Manager\CurrentVersion\
Daemons\ANIServer from

Dvbroker.orb.gcTimeout=90 -mx1024m

to

-Xminf0.1 -Xmaxf0.1 -cp:a 
C:\PROGRA~1\CSCOpx\lib\classpath\
servlet.jar -Dvbroker.orb.gcTimeout=90 
-Dsun.net.inetaddr.ttl=0 -mx1024m"

3. Start Daemon manager.

CSCdx59035 ANI does not discover one of 
dual MSFCs running HSRP.

CiscoWorks does not discover the device. ANI does 
not discover one of dual MSFCs running HSRP.

Workaround:

None.
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CSCdw68571 Device Synchronization does 
not support sysNames.

ANI to Essentials device import only looks for the 
hostname or IP address. sysNames are not 
supported. The IP address are used as Device Name 
although the sysName was successfully discovered.

Workaround:

This problem is caused by the Java DNS caching 
problem. Java caches negative lookup which caused 
the problem in the customer's scenario. Hence a 
property sun.net.inetaddr.ttl=0 is used to set the 
JVM not to cache the DNS lookup.

The above property is used to start the ANI JVM. It 
instructs the ANI/JVM not to use the cache. Instead, 
to use a new lookup each time when queried for DNS 
resolution.

Enter the following:

1. #pdreg -u ANIServer

2. #pdreg -r ANIServer -e 
/opt/CSCOpx/bin/cwjava -d 
EDS,ANIDbEngine -f

"-cp:a^/opt/CSCOpx/lib/classpath/servlet.
jar^-Dvbroker.orb.gcTimeout=90^-Dsun.n
et.inetaddr.ttl=0^-mx512m^com.cisco.nm.an
i.server.frontend.AniMain"
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CSCdw67129 Topology Services unable to 
resolve the hostname of newly 
discovered devices.

If the DNS entry for the device is added after initial 
discovery, Topology Services cannot resolve the 
hostname of the newly discovered devices. 

The subsequent discoveries do not resolve the IP 
address to a hostname until the ANIServer reloads.

This occurs only in devices that do not have a DNS 
entry before discovery. Devices that have a DNS 
entry before ANI discovers them, do not have this 
problem.

Workaround:

Do either of the following: 

• Restart CiscoWorks Server. ANI resolves the 
IP address to a hostname after restart.

Or

• Display the sysName in Topology Services 
(does not require a restart):

Topology Services > Layer 2 View > View > 
Display Labels > Show Sysname

Alternatively, you can do any of the following:

• Run the ANI discovery again.

• Stop and start the ANIServer.

• If you require Campus to ignore the cache and 
always look up the DNS server, add the 
following variable in the java command line of 
the ANIServer:

Dnetworkaddress.cache.ttl=0
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CSCdw05781 switches are placed in 
NO_VTP domain improperly

Inconsistency exists in the map display of some of 
the switches (non-VTP aware ones)under the VTP 
domain category. 

They are placed in NO_VTP domain while they have 
neighbors in normal VTP domain AAA.

CSCdv55105 anisnmp.conf should allow 
name wildcarding.

This problem occurs if you have a set up similar to 
the following:

• Switches: RO public, RW private

• Routers: RO hello, RW goodbye

In this case, all switches have names that start with 
S and all routers have names that start with R.

Workaround:

None. 

However, you can set up the SNMP Settings in the 
following manner:

S*:public::::::private
C*:hello::::::goodbye

CSCdu10180 Campus VC trace does not 
work over VP tunnels.

When you perform a VC trace between devices over 
a VP tunnel, it results in an empty Trace Report.

Workaround:

This problem has been resolved in the Incremental 
Device Update (IDU) on Campus Manager 3.3.

Install IDU, available at:

http://www.cisco.com/cgi-bin/tablebuild.pl/cw2000
-campus

CSCdt69570 Permissions report not very 
specific.

The current Permission report provides permissions 
at the module level and not at task level

Workaround:

None

Table 8 ANI Server Known Problems (continued)

Bug ID Summary Explanation
57
Release Notes for Campus Manager 3.3 on Windows

78-15053-01

http://www.cisco.com/cgi-bin/tablebuild.pl/cw2000-campus


 

Known Problems
CSCdt56346 Discovery filter does not 
permit discovery of single 
device.

Specifying a single device in ANI Discovery Filter 
section does not work. The filter string will be 
accepted, but ANI will not discover the device.  

Workaround:

Specify a wildcard.

To specify a wildcard, replace the last part of 
IP address with the character *. 

For example, if IP address is 209.165.200.224, 
wildcard is 209.165.200.*.

CSCdt20329 ATM switches, for which 
Remote Monitoring (RMON) 
is enabled, not highlighted 
when Show Enabled Devices 
selected.

This problem occurs if you:

1. Select Topology Services.

2. Highlight an ATM fabric under Managed 
Domains/ATM Domains

3. Select Display View.

4. Select devices, and click Tools > RMON Data 
Collection > Show Enabled Devices

Workaround:

None.

CSCdr84799 Applications not functioning 
across Network Address 
Translator (NAT).

Applications not functioning across Network 
Address Translator (NAT).

Workaround:

None

CSCdp76410 Campus client cannot connect 
to server using proxies.

Common Services does not support proxies.

Workaround:

None
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CSCdm58624 LANE trunks are not 
considered when determining 
a VTP disconnected domain 
discrepancy.

If VTP domain spans across ATM cloud and default 
ATM-VLAN is configured to carry VTP 
advertisements across cloud, the domain is still 
displayed as disconnected domain discrepancy. 
This is caused by lack of support.

Workaround: 

None.

CSCdm48015 An ATM trunk port is shown 
as belonging to a VLAN, even 
if there is no corresponding 
LANE client associated with 
that VLAN.

In VLAN-to-port association, all ATM ports on 
switches (except ATM switches) belonging to 
VLAN will be displayed.

Workaround:

Ignore ATM ports in VLAN-to-port association.

CSCdj60832 All configuration changes lost 
when device accidently shut 
down, if device running Cisco 
IOS software.

Configuration changes are only applied to the 
device's running configuration. Because the changes 
are not stored in start-up configuration, if the device 
is accidentally shut down, all changes are lost.

Workaround:

Open Telnet session to device, and save 
configuration changes by entering write mem from 
command line interface.
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Table 9 Device/Agent Known Problems Impacting ANI Server

Bug ID Summary Explanation

CSCin05978 ANI upgrade failure. ANI upgrade failure message appears when 
upgrading ANI in machines with Common Services 
and Resource Manager Essentials installed. This 
happens because the ANI server is not active and no 
data is available for ANI upgrade. 

Workaround:

None. This error message do not affect the 
functionality

CSCdp00593 SNMP report displays
wrong HwVersion and 
HwVersionMinor for 
Cisco LS1010 devices.

The SNMP report displays

Wrong HwVersion and HwVersionMinor for LS1010 
device

Workaround:

Enter show hardware in command line interface of 
Cisco LS1010 devices.

CSCdm91634 In Campus device report, 
number of ports in a device’s 
ATM module are incorrectly 
displayed as zero.

This problem, which occurs in Catalyst 5000 devices 
running Catalyst operating system software 
release 4.3(1a), is caused by missing ifEntry for 
device ATM module. ANI Server depends on ifEntry 
to determine number of ports in a particular module.

Workaround:

None.
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Resolved Problems
The following table lists the problems resolved since the last release of Campus.

Table 10 VLAN Port Assignment Known Problems

Bug ID Summary Explanation

CSCin37108 VLAN Port Assignment not 
reflected in running-config for 
3550. Startup configuration 
does not reflect the changes 
when ports are moved using 
VLAN Port Assignment.

Running configuration and startup configuration do 
not reflect the changes done through VLAN Port 
Assignment after you enable the write run to startup 
configuration.

Workaround:

None.

Table 11 Resolved Problems

Bug ID Summary Additional Information

CSCds05957 The gatekeeper configuration 
file had to be modified to run 
Campus on multi-homed 
machines.

This problem has been resolved.

You are no longer required to modify the 
gatekeeper configuration.

CSCdy29879 Campus failed to install on a 
machine which has its CPU in 
slots other than zero (0).

This problem has been resolved.

Path Analysis
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CSCdv70125 Path Analysis failed to obtain the 
layer 2 path trace for layer 2 
devices. 

It listed IfType=unknown for 
both layer 2 devices across the 
trace.

Path Analysis is now able to obtain the layer 2 
path trace information for layer 2 devices.

Furthermore, an Error tab has been added to the 
Path Analysis window which displays appropriate 
error messages after an unsuccessful 
Path Analysis for Layer 3 and Layer 2 devices.

CSCdr37333 Path Analysis required DNS to 
perform correct path discovery.

Path Analysis no longer requires a DNS to 
perform a discovery. Furthermore, Path Analysis 
reports now display DNS names.

CSCdw03315 Path Analysis failed to display 
layer 2 using RFC 1918 private 
addressing IP phone endstations.

In situations where the network 
devices use one address space 
for their management addresses 
(sc0 on switches, etc.), but the 
endstations use a different 
(private) address space (such as 
10.x.x.x), path was unable to 
provide layer 2 information.

This problem has been resolved.

Furthermore, an Error tab has been added to the 
Path Analysis window which displays appropriate 
error messages after every unsuccessful path trace.

CSCdw03353 Path Analysis failed to show 
layer 2 information for certain 
configurations of devices such as 
Catalyst 2900XL Catalyst 
3500XL switches.

Path Analysis is now able to obtain the layer 2 
path trace information for layer 2 devices.

CSCdw80793 When you performed a trace 
between two devices, and the 
trace traversed through an 
MSFC, the layer 2 trace 
displayed was incorrect.

Path Analysis is now able to obtain the layer 2 
path trace information for layer 2 devices.
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CSCds70102 When you ran a trace between 
two devices connected by a Fast 
Ethernet Channel or a Gigabit 
Ethernet Channel, the 
Path Analysis Main Table 
displayed interface type as 
Unknown although devices were 
in a managed state.

Path Analysis is now able to obtain the layer 2 
path trace information for layer 2 devices.

CSCdw36518 When a trace was performed 
between switches lying in 
different VTP domains, layer 2 
trace was not be displayed.

Path Analysis is now able to obtain the layer 2 
path trace information for layer 2 devices.

CSCdw03370 Path Analysis did not provide 
sufficient detailed information in 
situations where there are 
multiple paths.

This problem has been resolved.

CSCdw03400 Path trace provided little or no 
information when path trace 
failed, limiting the usefulness of 
the tool for troubleshooting.

This problem has been resolved.

Furthermore, an Error tab has been added to the 
Path Analysis window which displays appropriate 
error messages after every unsuccessful path trace.

CSCea28603 The GUI hung if you performed 
a Path Analysis trace while a 
User Tracking discovery was in 
progress.

This problem has been resolved.

User Tracking

CSCdp83349 You were required to set the 
DISPLAY environment variable 
to run User Tracking through 
command line or in the 
standalone mode.

This problem has been resolved.
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CSCdw44519 UTLite did not work for 
Windows 98 clients.

This problem has been resolved.

A new UTLite executable, UTLite33.exe, is now 
available in Campus which works on Windows 98 
clients too.

CSCdt35200 On Windows 95, Windows NT 
and Windows 2000 systems, 
UTLite tool sometimes sent an 
empty username.

This problem has been resolved.

CSCdt60682 User Tracking did not display 
port speed and duplex mode 
information.

User Tracking now displays port speed and duplex 
mode information.

CSCdx27527 User Tracking did not update the 
ARP cache.

User Tracking now gets the latest IP address from 
the ARP cache.

CSCdx58960 User Tracking did not allow 
more than 31 characters in the 
phoneDescr column of an IP 
phone table.

The phoneDescr column now accepts upto 256 
characters.

CSCin23872 User Tracking and Summary 
tables did not print correctly.

This problem has been resolved.

CSCin06554 Discover Subnet field was empty 
sometimes. Initially, it listed all 
the discovered subnets.

However, after the last discovery 
(for example, discovery of a 
specific end host), the subnet list 
became empty.

This problem has been resolved.

Topology Services

CSCdv42025 Export of Campus map to 
Microsoft Visio 2002 failed.

This problem has been resolved.

Table 11 Resolved Problems (continued)

Bug ID Summary Additional Information
64
Release Notes for Campus Manager 3.3 on Windows

78-15053-01



 

Resolved Problems
CSCdv01183 Topology Services maps did not 
display correctly when running 
on systems with European 
Locales.

This problem has been resolved.

CSCdv55569 Topology Services table did not 
display sysName.

While there is no separate column for sysName 
table, Topology Services now resolves sysName to 
IP address.

CSCdw13266 Topology Services did not group 
devices in a large map.

Topology Groups, a new feature in Campus 3.3, 
allows you to group devices.

CSCdx38913 In the Topology Services map 
screen the icon sizes changed 
automatically after a screen 
refresh.

This problem has been resolved.

CSCdy07145 In the Topology map the ports 
are reversed when comparing the 
spanning configuration and the 
view on the map.

This problem has been resolved.

CSCin12044 Visio Stencil did not have some 
icons for devices that were 
supported.

This problem has been resolved.

CSCin13557 No error message was displayed 
when you attempted to delete 
aggregate links.

This problem has been resolved.

CSCin06940 All Catalyst 3550 series devices 
supported in Campus are shown 
as switch in Topology Services 
and as router in Path Analysis.

This problem has been resolved.

CSCin08900 Port Attributes displayed the 
port type as other for certain 
Catalyst 3550 series devices.

This problem has been resolved.

CSCds01210 Delete VLAN window remained 
open after a VLAN was deleted.

This problem has been resolved.
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CSCdw83624 ANI did not support more than 
2 GB physical memory.

This problem has been resolved.

CSCdt21487 When the topology map of a 
large network was exported to 
Visio, an illegible Visio file was 
created.

This problem has been resolved.

CSCdt00478 Printing Display View map from 
Topology Services sometimes 
resulted in errors.

This problem has been resolved.

CSCdp69800 Correct last fail cause was not 
displyed for LAN Emulation 
client.

This problem has been resolved.

ANI Server

CSCdp41757 Running SNMP query on 
ciscoAtmSvcAddrTable returned 
empty table for devices. Problem 
observed in LS1010 devices 
running Cisco IOS release 12.0.

This problem has been resolved.

CSCds54219 ANI discovery of routers did not 
use management IP address.

ANI provides features to resolve management IP 
address using DNS, sysName. You can also 
change the management IP address using 
Topology Services view and map.

CSCdv86837 Earlier, when you performed a 
User Tracking discovery, ANI 
reported a failure to map some 
Catalyst XL switch interfaces to 
physical ports.

This problem, which occurred in Catalyst XL 
switches running Cisco IOS software, has been 
resolved.

CSCdt24535 Discrepancy reports did not 
display the date or time when the 
discrepancy was discovered.

This problem has been resolved.
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CSCdu70168 Device Synchronization to 
Resource Manager Essentials 
did not work if server was not 
specified.

This problem has been resolved.

CSCdz44403 Topology Services incorrectly 
categorized inactive ports in 
speed mismatch.

This problem has been resolved.

CSCdx54256 Campus did not display from 
which device CDP cache a 
particular unconnected device 
was learned from.

This problem has been resolved.

Furthermore, you can see the neighbors of a device 
on the ANI Discovery details page.

CSCdx60994 ANI discovery filter did not 
work unless you reinitliaze ANI 
database.

You are no longer required to reinitialize the ANI 
database.

CSCdz44348 Topology Services incorrectly 
reported ATM subinterfaces as 
half-duplex.

This problem has been resolved.

CSCdy75725 For Catalyst 1900 series 
switches, Campus did not 
display the number of ports on 
the switch.

This problem has been resolved.

CSCdy74197 ANI discovery failed when you 
ran it a second time.

This problem has been resolved.

CSCdy71670 The discrepancy report VTP 
Disconnected Domain was 
created even for a NULL 
domain.

This problem has been resolved.

CSCdx32591 Discovery filter did not work in 
range.

This problem has been resolved.
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CSCdy59782 If ANI performed a 
synchronization with Resource 
Manager Essentials, and the 
write community contained a 
‘&’, ANI deleted the portion of 
write community after the ‘&’.

This problem has been resolved.

CSCin26831 reinitdb.pl -restore failed 
with error and ANIServer failed 
to start.

This problem has been resolved.

VLAN Port Assignment

CSCds32015 Earlier, when you used VLAN 
Port Assignment to add or delete 
ports to or from VLANs, the 
changes were correctly 
registered in the running 
configuration of switches.

However, after a reboot, the 
modifications were lost because 
Campus did not modify the 
startup configuration.

This problem has been resolved.

CSCdt46180 When selecting to delete a 
VLAN from Campus, a 
confirmation dialog box appears.

After you deleted the VLAN, the 
dialog box got locked and you 
could remove it only by using the 
Window Close widget in the title 
bar.

This problem has been resolved.

CSCin25038 When you modified the polling 
options using Setup > ANI 
Server Admin > Discovery 
Schedule, the changes did not 
come into effect immediately.

This problem has been resolved.

Documentation
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Obtaining Documentation
Cisco documentation and additional literature are available on Cisco.com. Cisco 
also provides several ways to obtain technical assistance and other technical 
resources. These sections explain how to obtain technical information from Cisco 
Systems.

Cisco.com
You can access the most current Cisco documentation on the World Wide Web at 
this URL:

http://www.cisco.com/univercd/home/home.htm

You can access the Cisco website at this URL:

http://www.cisco.com

International Cisco websites can be accessed from this URL:

http://www.cisco.com/public/countries_languages.shtml

CSCdx70235 Cisco 805 Router was 
incorrectly shown as supported 
by Topology Services in the 
Supported Devices Table for 
Campus Manager 3.2.

This problem has been resolved.

CSCdy20047 Campus documentation did not 
contain details about the the 
links displayed in a 
Topology Map.

The lines and dashes displayed in a Topology Map 
have now been documented as an FAQ in 
Chapter 2, User Guide for Campus Manager.
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Ordering Documentation
You can find instructions for ordering documentation at this URL:

http://www.cisco.com/univercd/cc/td/doc/es_inpck/pdi.htm

You can order Cisco documentation in these ways:

• Registered Cisco.com users (Cisco direct customers) can order Cisco product 
documentation from the Ordering tool:

http://www.cisco.com/en/US/partner/ordering/index.shtml

• Nonregistered Cisco.com users can order documentation through a local 
account representative by calling Cisco Systems Corporate Headquarters 
(California, USA) at 408 526-7208 or, elsewhere in North America, by 
calling 800 553-NETS (6387).

Documentation Feedback
You can submit e-mail comments about technical documentation to 
bug-doc@cisco.com.

You can submit comments by using the response card (if present) behind the front 
cover of your document or by writing to the following address:

Cisco Systems
Attn: Customer Document Ordering
170 West Tasman Drive
San Jose, CA 95134-9883

We appreciate your comments.

Obtaining Technical Assistance
For all customers, partners, resellers, and distributors who hold valid Cisco 
service contracts, the Cisco Technical Assistance Center (TAC) provides 
24-hour-a-day, award-winning technical support services, online and over the 
phone. Cisco.com features the Cisco TAC website as an online starting point for 
technical assistance. If you do not hold a valid Cisco service contract, please 
contact your reseller.
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Obtaining Technical Assistance
Cisco TAC Website
The Cisco TAC website provides online documents and tools for troubleshooting 
and resolving technical issues with Cisco products and technologies. The Cisco 
TAC website is available 24 hours a day, 365 days a year. The Cisco TAC website 
is located at this URL:

http://www.cisco.com/tac

Accessing all the tools on the Cisco TAC website requires a Cisco.com user ID 
and password. If you have a valid service contract but do not have a login ID or 
password, register at this URL: 

http://tools.cisco.com/RPF/register/register.do

Opening a TAC Case
Using the online TAC Case Open Tool is the fastest way to open P3 and P4 cases. 
(P3 and P4 cases are those in which your network is minimally impaired or for 
which you require product information.) After you describe your situation, the 
TAC Case Open Tool automatically recommends resources for an immediate 
solution. If your issue is not resolved using the recommended resources, your case 
will be assigned to a Cisco TAC engineer. The online TAC Case Open Tool is 
located at this URL:

http://www.cisco.com/tac/caseopen

For P1 or P2 cases (P1 and P2 cases are those in which your production network 
is down or severely degraded) or if you do not have Internet access, contact Cisco 
TAC by telephone. Cisco TAC engineers are assigned immediately to P1 and P2 
cases to help keep your business operations running smoothly.

To open a case by telephone, use one of the following numbers:

Asia-Pacific: +61 2 8446 7411 (Australia: 1 800 805 227) 
EMEA: +32 2 704 55 55 
USA: 1 800 553-2447

For a complete listing of Cisco TAC contacts, go to this URL:

http://www.cisco.com/warp/public/687/Directory/DirTAC.shtml
71
Release Notes for Campus Manager 3.3 on Windows

78-15053-01

http://www.cisco.com/tac
http://tools.cisco.com/RPF/register/register.do
http://www.cisco.com/tac/caseopen
http://www.cisco.com/warp/public/687/Directory/DirTAC.shtml


 

Obtaining Additional Publications and Information
TAC Case Priority Definitions
To ensure that all cases are reported in a standard format, Cisco has established 
case priority definitions.

Priority 1 (P1)—Your network is “down” or there is a critical impact to your 
business operations. You and Cisco will commit all necessary resources around 
the clock to resolve the situation. 

Priority 2 (P2)—Operation of an existing network is severely degraded, or 
significant aspects of your business operation are negatively affected by 
inadequate performance of Cisco products. You and Cisco will commit full-time 
resources during normal business hours to resolve the situation.

Priority 3 (P3)—Operational performance of your network is impaired, but most 
business operations remain functional. You and Cisco will commit resources 
during normal business hours to restore service to satisfactory levels.

Priority 4 (P4)—You require information or assistance with Cisco product 
capabilities, installation, or configuration. There is little or no effect on your 
business operations.

Obtaining Additional Publications and Information
Information about Cisco products, technologies, and network solutions is 
available from various online and printed sources.

• Cisco Marketplace provides a variety of Cisco books, reference guides, and 
logo merchandise. Go to this URL to visit the company store:

http://www.cisco.com/go/marketplace/

• The Cisco Product Catalog describes the networking products offered by 
Cisco Systems, as well as ordering and customer support services. Access the 
Cisco Product Catalog at this URL:

http://cisco.com/univercd/cc/td/doc/pcat/

• Cisco Press publishes a wide range of general networking, training and 
certification titles. Both new and experienced users will benefit from these 
publications. For current Cisco Press titles and other information, go to Cisco 
Press online at this URL:

http://www.ciscopress.com
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Obtaining Additional Publications and Information
• Packet magazine is the Cisco quarterly publication that provides the latest 
networking trends, technology breakthroughs, and Cisco products and 
solutions to help industry professionals get the most from their networking 
investment. Included are networking deployment and troubleshooting tips, 
configuration examples, customer case studies, tutorials and training, 
certification information, and links to numerous in-depth online resources. 
You can access Packet magazine at this URL:

http://www.cisco.com/packet

• iQ Magazine is the Cisco bimonthly publication that delivers the latest 
information about Internet business strategies for executives. You can access 
iQ Magazine at this URL:

http://www.cisco.com/go/iqmagazine

• Internet Protocol Journal is a quarterly journal published by Cisco Systems 
for engineering professionals involved in designing, developing, and 
operating public and private internets and intranets. You can access the 
Internet Protocol Journal at this URL:

http://www.cisco.com/ipj

• Training—Cisco offers world-class networking training. Current offerings in 
network training are listed at this URL:

http://www.cisco.com/en/US/learning/index.html

This document is to be used in conjunction with the documents listed in the “Product Documentation” section.

Copyright © 2004, Cisco Systems, Inc.
All rights reserved.

CCVP, the Cisco logo, and the Cisco Square Bridge logo are trademarks of Cisco Systems, Inc.; Changing the Way We
Work, Live, Play, and Learn is a service mark of Cisco Systems, Inc.; and Access Registrar, Aironet, BPX, Catalyst,
CCDA, CCDP, CCIE, CCIP, CCNA, CCNP, CCSP, Cisco, the Cisco Certified Internetwork Expert logo, Cisco IOS,
Cisco Press, Cisco Systems, Cisco Systems Capital, the Cisco Systems logo, Cisco Unity, Enterprise/Solver,
EtherChannel, EtherFast, EtherSwitch, Fast Step, Follow Me Browsing, FormShare, GigaDrive, HomeLink, Internet
Quotient, IOS, iPhone, IP/TV, iQ Expertise, the iQ logo, iQ Net Readiness Scorecard, iQuick Study, LightStream,
Linksys, MeetingPlace, MGX, Networking Academy, Network Registrar, Packet, PIX, ProConnect, ScriptShare,
SMARTnet, StackWise, The Fastest Way to Increase Your Internet Quotient, and TransPath are registered trademarks of
Cisco Systems, Inc. and/or its affiliates in the United States and certain other countries. 

All other trademarks mentioned in this document or Website are the property of their respective owners. The use of the
word partner does not imply a partnership relationship between Cisco and any other company. (0705R)
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