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C H A P T E R 3

Locating Users in the Network with 
User Tracking

User Tracking allows you to locate end-user hosts and IP phones in the network. 
It uses information gathered from network devices to display data about users, 
hosts, and IP phones in the network.

Use User Tracking to:

• Discover and display information about users, hosts, and IP phones in your 
network

• Query for users, hosts, and IP phones

• Modify, add, and delete username and notes in the main User Tracking table

• Highlight devices on the Layer 2 view in Topology Services

• View reports about duplicate IP addresses, duplicate MAC addresses, and 
duplicate MAC addresses and VLAN names

The following topics provide you with information about:

• Starting and Navigating in User Tracking, page 3-2

• Using User Tracking, page 3-5

• User Tracking Concepts, page 3-14

• Troubleshooting User Tracking, page 3-14
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Starting and Navigating in User Tracking
From the CiscoWorks2000 desktop, select Campus Manager >User Tracking. 
The main User Tracking window appears (see Figure 3-1). 

When you start User Tracking, the Startup dialog box appears. From this dialog 
box, you can choose to:

• Show all users and hosts currently in the ANI database—this is the default 
choice.

• Display a simple query dialog box.

• Display a User Tracking table with no entries.

To change the default startup mode, select Edit > Preferences... 

The User Tracking table displays discovery results and data about workstations, 
users, and hosts in the network. Refer to Table 3-1 for a description of the 
elements in the User Tracking window.

The User Tracking IP Phone table displays discovery results and provides data 
about IP phones registered with discovered Media Convergence Servers. The IP 
Phone table appears in a window separate from the main User Tracking window.
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Figure 3-1 Main User Tracking Window
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Table 3-1 User Tracking Window Elements

Item Description

Menu Bar Contains User Tracking 
Commands

Tool Bar Provides quick access to 
frequently used menu options

Main User Tracking Table Contains fields providing details 
about end-user stations

Status Bar Displays the number of entries in 
the User Tracking table or the 
status of the last action that was 
performed.

Double-clicking on the status 
light displays the Discovery 
Information dialog box, which 
tells you your ANI Server and 
User Tracking login status and 
the completion time of the last 
ANI Server and User Tracking 
discoveries.
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Using User Tracking
Table 3-2 lists the main tasks that you can perform using User Tracking. All 
actions begin from the User Tracking main window, unless otherwise specified. 
For more information about each task, refer to the User Tracking online help.

Table 3-2 User Tracking Tasks

Task Purpose Action

Enable or disable the Ping 
Sweep option. 

Obtains the latest Address 
Resolution Protocol (ARP) 
information in routers and 
bridge table information in 
switches.

By default, the Ping Sweep 
option is enabled.

1. Select Edit > Preferences....

2. Select the Discovery tab.

3. Select the check box next to the Ping 
Sweep option to enable it. Deselect 
the check box to disable Ping Sweep.

Note Pinging large networks can be 
time-consuming.

Discover all users and 
hosts.

Discovers all users and 
hosts on the network and to 
update the ANI Server 
database. 

1. Enable the Ping Sweep option to 
ensure that the most recent network 
information is discovered.

2. Select Actions > Discover All.

Discover IP phones. Discovers IP phones 
registered with discovered 
Media Convergence 
Servers. 

1. Enable the Ping Sweep option to 
ensure that the most recent network 
information is discovered.

2. Select Actions > Discover IP 
Phones.
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Discover hosts in a subnet. Initiates the User Tracking 
discovery process for a 
specific subnet. This is less 
time-consuming than 
rediscovering all users and 
hosts.

1. Enable the Ping Sweep option to 
ensure that the most recent network 
information is discovered.

2. Select Actions >Discover Subnet....

3. Enter the IP address or host name in 
the Hostname or IP Address field.

4. Enter the subnet mask in the Subnet 
Mask field.

5. Click Discover.

Discover hosts on a 
specific device.

Initiates the User Tracking 
discovery process for a 
specific device. This is less 
time-consuming than 
rediscovering all users and 
hosts.

1. Enable the Ping Sweep option to 
ensure that the most recent network 
information is discovered.

2. Select Actions >Discover Device....

3. Enter the IP address or device name 
in the Device Name or IP Address 
field.

4. Click Discover.

Display all users and hosts. Displays all discovered 
users and hosts in the User 
Tracking database.

Select Query > Main Table Query > all.

Display IP phones in your 
network.

Displays IP phones in your 
network.

Select Query > IP Phone Table Query > 
all.

Table 3-2 User Tracking Tasks (continued)

Task Purpose Action
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Display selected users and 
hosts with a simple query.

Displays only those entries 
that match your specified 
criteria.

1. Select Query > Simple Query....

2. Select the Main Table or Phone 
Table tab.

3. Specify up to three search criteria.

4. Choose either:

• Match all of the following—to 
display only the entries that 
match all of the criteria.

• Match any of the following—to 
display all entries that match at 
least one of the criteria.

5. To make your query case-sensitive, 
click the Match case check box. 

6. Click Apply.

Create and save an 
advanced query.

Creates queries with 
complex search criteria 
and saves them.

You can also view, edit, 
and delete saved queries.

1. Select Query >Advanced Query....

2. Select the Main Table or Phone 
Table tab.

3. To create subqueries:

a. Click the Conditions tab.

b. Click Add.

c. Enter conditions as you would 
for a simple query.

4. To run the query, click Apply.

5. To save the query, enter a name in the 
Save Query as field and click Save.

To use a saved query, select Query 
and then the name of the query you 
want to run.

Table 3-2 User Tracking Tasks (continued)

Task Purpose Action
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Customize the table 
format.

Customizes the User 
Tracking table or IP Phone 
Table to include only 
specific columns in a 
preferred order.

You can also view, rename, 
modify, and delete saved 
layouts.

1. Select Layout>Add Layout....

2. Select:

• Main Table tab—to create a 
layout for the User Tracking 
main table.

• IP Phone Table tab—to create a 
layout for the IP phone table.

3. To specify a column that you want to 
include, select the check box next to 
that column’s name.

4. To alter the positions of a column 
relative to others, highlight a column 
name and use the blue arrows.

5. Save the layout by entering a name in 
the Save Layout as field and clicking 
Save.

To use a saved layout, select Layout, 
then Main Table Layout or IP 
Phone Table Layout, and then the 
name of your saved layout.

Find entries. Searches for a specific 
entry or range of entries in 
the displayed User 
Tracking table or IP phone 
table.

1. Select Edit > Find in Table....

2. In the Find field, enter the string for 
the entry you want to locate. 

3. Select the Main Table or IP Phone 
Table radio button.

4. Enter the appropriate settings in the 
From, Ignore Case, Match Cell, and 
By Row fields.

5. Click Next for the next match below 
the selected row or Previous for a 
match above the selected row.

Table 3-2 User Tracking Tasks (continued)

Task Purpose Action
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Delete a selected entry. Deletes a selected entry 
from the main User 
Tracking table.

1. Highlight the cells you want to clear 
by clicking and dragging the cursor 
over them, or by clicking the first and 
last consecutive cells while pressing 
Shift.

2. Select Edit> Clear. 

To delete entire rows, select 
Edit> Delete Selected Rows. You 
can choose to delete selected entries 
from the main table, the IP phone 
table, or both.

3. To reverse the deletion, select Undo.

Delete old entries from the 
User Tracking table.

Delete entries for hosts 
that are not rediscovered in 
a major acquisition.

You can configure it to 
delete them once manually 
or automatically after 
every major acquisition.

1. Select Edit> Preferences.

2. Select the Delete tab. You can choose 
to delete entries from the main table, 
the IP phone table, or both.

3. Enter the number of days, hours, and 
minutes for entries you would like 
deleted in the Delete entries older 
than field.

4. If you would like to delete:

• Immediately—select Delete 
Now.

• After every major 
acquisition—select the Delete 
after every discovery check 
box.

Table 3-2 User Tracking Tasks (continued)

Task Purpose Action
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Save User Tracking table 
changes to the ANI Server 
database.

Save changes to the ANI 
Server database.

When you make changes to 
the User Tracking table, 
the changes remain local to 
the session in which you 
are running User Tracking 
until you send the 
information to the ANI 
Server database.

Select File > Save Changes to Server. 

Add Notes and Usenames 
to entries.

Allows you to add notes 
and usernames to entries in 
the main User Tracking 
table.

1. Click the table cell you want to 
modify.

2. Enter the text and press Enter.

Note The next time the ANI Server 
performs a discovery, the cells 
will be overwritten if the ANI 
Server discovers different 
information.

Export user data to a text 
file.

Saves information added to 
the UserName and Notes 
fields to a text file.

You can import this 
information if the data are 
overwritten.

1. Select File > Export. 

2. Choose Main Table or IP Phone 
Table.

3. Select the directory that you want to 
export and enter a file name.

4. Click Save to close the Export dialog 
box and save the file.

Table 3-2 User Tracking Tasks (continued)

Task Purpose Action
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Import data from a 
previously saved file.

Imports lost or deleted 
UserName and Notes 
fields from a previously 
exported file.

1. Select File > Import > Main Table.

2. Select the text file you want to import 
and click OK.

Note If the next discovery discovers 
different values, it overwrites the 
data.

Collect username 
information.

Configures the ANI Server 
to automatically acquire 
username information 
from UNIX, Windows NT, 
and Novell systems.

You can also add 
usernames and notes 
manually, but if the ANI 
Server discovers 
conflicting username 
information, it overwrites 
the database.

You must configure the ANI Server to 
acquire the information:

• UNIX hosts—enable rusersd on 
the host.

• Windows NT hosts—install the 
UTLite script on the NT Primary 
Domain Controllers.

• Novell hosts—install the UTLite 
script on the Novell Server.

Refer to the ANI Server online help for 
information on these steps. 

Start an application server. Starts an application 
server. Please refer to the 
application server’s 
manual for more 
information.

1. Select the workflow host in the User 
Tracking display.

2. Select Actions > Display Service 
Attributes.

Table 3-2 User Tracking Tasks (continued)

Task Purpose Action
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Highlight a device on the 
Layer 2 view.

Highlights a selected 
device from User Tracking 
on the Layer 2 view in 
Topology Services.

1. Open the Layer 2 view in Topology 
Services. Refer to the Topology 
Services online help for more 
information.

2. Select an entry from the Device 
column in the User Tracking table.

Note If you select multiple entries, 
User Tracking uses the entry you 
selected first.

3. Select Actions >Highlight Devices 
on Map.

Display detail on a device 
with CiscoView.

Starts CiscoView to 
display details about a 
particular device.

1. Select the device in the User 
Tracking table.

Note If you attempt to start CiscoView 
for multiple devices by selecting 
more than one device, User 
Tracking uses the last selected 
device.

2. Select Actions >Launch CiscoView.

Start a telnet session. Starts a remote terminal 
connection on a device.

1. Select a device in the main User 
Tracking table by clicking anywhere 
in that row.

2. Select Actions > Telnet Device.

Table 3-2 User Tracking Tasks (continued)

Task Purpose Action
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Display discovery 
statistics.

Displays statistics about 
the most recent discovery.

Statistics reported include 
the start time, end time, 
total number of hosts, total 
number of Media 
Convergence Servers, total 
number of IP phones, and 
number of duplicate MAC 
or IP addresses found.

Select Reports > Discovery Statistics.

Find duplicate IP 
addresses.

Finds duplicate IP 
addresses. 

Typically, each host should 
have its own, unique IP 
address. If two hosts have 
the same IP address, your 
network might not function 
correctly.

Select Reports > Duplicate IP.

Find duplicate MAC 
addresses.

Finds duplicate MAC 
addresses. 

Typically, each host has its 
own, unique MAC address. 
If two hosts have the same 
MAC address in the same 
VTP domain and VLAN, 
you have a 
misconfiguration.

Select Reports > Duplicate MAC.

Table 3-2 User Tracking Tasks (continued)

Task Purpose Action
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User Tracking Concepts
User Tracking uses the user and host acquisition service module in the ANI Server 
to discover end-user nodes. IP phones are discovered by querying the Media 
Convergence Servers. Refer to the Getting Started with the CiscoWorks2000 
Server guide or the ANI Server online help for more information about the 
ANI Server and user and host acquisition.

Troubleshooting User Tracking
Use the information in the following topics to help you troubleshoot User 
Tracking:

• Frequently Asked Questions, page 3-15

• Troubleshooting Suggestions, page 3-18

Find duplicate MAC 
addresses and VLAN 
names.

Finds duplicate MAC 
addresses and VLAN 
names. 

Typically, each host has a 
unique MAC/VTP/VLAN 
combination. Multiple 
hosts with the same MAC 
address and VLAN name 
indicate a network 
problem.

Select Reports > Duplicate MAC & 
VLAN.

Find ports with multiple 
MAC addresses.

Finds ports with multiple 
MAC addresses (hubs). 

Ports being shared by 
multiple hosts may not 
yield the best performance.

Select Reports > Ports with Multiple 
MAC.

Table 3-2 User Tracking Tasks (continued)

Task Purpose Action
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Frequently Asked Questions
Use the information in these sections to answer some of your common questions:

• How does the User Tracking discovery process differ from that of the ANI 
Server?, page 3-15

• How does the ANI Server’s user and host acquisition process work?, 
page 3-16

• Why isn’t User Tracking performing ping sweeps on some subnets?, 
page 3-17

• Why are outdated entries showing up in my User Tracking table?, page 3-17

• How long does User Tracking maintain data?, page 3-18

• Does User Tracking discover users and hosts connected to non-Cisco 
Discovery Protocol (CDP) discovered/managed devices?, page 3-18

• How does User Tracking log errors?, page 3-18

How does the User Tracking discovery process differ from that of the ANI Server?

User Tracking is an ANI client application. The ANI Server provides several 
types of global discoveries, including:

• Device and physical topology discovery, resulting in baseline network 
information such as device identity, module and port information, and 
physical topology. This type of discovery is required for logical, user, and 
path discovery.

• User discovery, resulting in information about users and hosts on the network.

The ANI Server stores this information in the ANI database. User Tracking 
discovers the host and user information in the ANI database, correlates this 
information, and displays it in the User Tracking table.

Refer to the ANI Server online help for more information about the ANI discovery 
process.
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How does the ANI Server’s user and host acquisition process work?

Before collecting user and host information, the ANI Server first must complete 
a global discovery. During global discovery, the ANI Server generates a device 
list to determine which switches and routers it should look at to obtain MAC and 
IP address information.

With these device lists in place, the User Tracking service module of the 
ANI Server performs the following steps.

Refer to the ANI Server online help for further information about ANI Server 
discovery.

Process Description

Performs Ping Sweeps Pings every IP address on all known subnets, as 
long as you have ping sweeps enabled (the 
default). This process updates the switch and 
router tables before User Tracking reads those 
tables, ensuring that User Tracking displays the 
most recent information about users and hosts.

Obtains MAC addresses from 
switches

Reads the switch’s bridge forwarding table. The 
bridge forwarding table provides the MAC 
addresses of end stations, and maps these MAC 
addresses to the switch port on which each 
workstation resides.

Obtains IP and MAC 
addresses from routers

Reads the Address Resolution Protocol (ARP) 
table in routers to obtain the IP and 
corresponding MAC addresses.

Obtains hostnames Performs a Domain Name System (DNS) 
lookup to obtain the hostname for every IP 
address.

Obtains usernames Attempts to locate the users currently logged in 
to the hosts and tries to obtain their username or 
login ID.

Records discovered 
information

Records the discovered information in the ANI 
database.
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Why isn’t User Tracking performing ping sweeps on some subnets?

The criterion for whether or not User Tracking performs ping sweeps on a subnet 
is the number of hosts in the subnet:

• If a subnet has 256 or fewer hosts, User Tracking performs ping sweeps on 
that subnet.

• If a subnet has more than 256 hosts, User Tracking does not perform ping 
sweeps on that subnet.

If ping sweeps are not performed, User Tracking still obtains information from the 
router and switch mapping tables during a discovery. Refer to the User Tracking 
online help for more information on ping sweep.

Why are outdated entries showing up in my User Tracking table?

Outdated entries result when:

• A user or host is assigned to new VLAN/port/VTP domain.

• A power failure occurred.

• A workstation has been switched off or removed from the network.

User Tracking does not automatically delete outdated end-user host entries. To 
delete these entries:

• Manually delete selected entries.

• Schedule User Tracking to remove old entries.

Why doesn’t the IP phone display act like the User Tracking table? 

The IP phone table appears in a separate window from the window that displays 
the main User Tracking table. You cannot run any commands from this window. 
You can only run commands from the main User Tracking table. Refer to the 
User Tracking command reference for more information.

Also, the IP phone table and the main User Tracking table display different kinds 
of information. Refer to the User Tracking table and the User Tracking table for 
IP Phone data to see what kinds of information each table displays.
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How long does User Tracking maintain data?

Indefinitely, until you delete the information.

Does User Tracking discover users and hosts connected to non-Cisco Discovery 
Protocol (CDP) discovered/managed devices?

User Tracking discovers all users and hosts in the network from the list of devices 
known to the ANI Server. Refer to Getting Started with the CiscoWorks2000 
Server or the ANI Server online help for more information about ANI discovery.

How does User Tracking log errors?

User Tracking errors are logged in the ANI Server error log. Refer to Getting 
Started with the CiscoWorks2000 Server or the ANI Server online help for more 
information.

Troubleshooting Suggestions
Use the information in Table 3-3 to troubleshoot the User Tracking application.

Table 3-3 Troubleshooting User Tracking

Symptom Probable Cause Possible Solution

User Tracking cannot discover 
any users or hosts, or

User Tracking cannot display 
any IP phones.

There may be no information in 
the ANI database. You must have 
valid ANI seed device(s) and run 
an ANI discovery prior to 
running a User Tracking 
discovery.

See the ANI Server online help 
for further information.

User Tracking cannot discover 
certain users or hosts.

The ANI Server might not have 
discovered one or more devices 
to which users and hosts are 
connected.

Check the CiscoWorks2000 
topology for the missing devices, 
make sure that CDP and SNMP 
are enabled on the devices, 
rediscover these devices, and 
verify that they appear on the 
topology view.
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User Tracking cannot discover 
certain IP phones.

The ANI Server might not have 
discovered the specific Media 
Convergence Server (MCS) that 
runs the instance of 
Cisco CallManager to which the 
IP phones are registered.

Check the CiscoWorks2000 
topology for the missing MCS 
that runs the instance of 
Cisco CallManager to which the 
phones are registered. Make sure 
that Cisco CallManager is shown 
as a service running on the MCS 
shown in the topology view if it 
is discovered by the ANI Server. 

Rediscover all IP phones.

User Tracking table is missing 
hostname, IP address, and subnet 
information for some hosts.

User Tracking is not finding the 
most recent network 
information. Network changes 
are not currently reflected in 
ARP information (routers) or 
bridge tables (switches).

Enable ping sweeps when User 
Tracking performs discovery. 
ping sweeps are enabled by 
default. 

You made changes to the 
network and then ran User 
Tracking discovery, but the 
changes are not showing in the 
User Tracking display.

A complete ANI discovery has 
not finished since you added 
your changes.

Try running a complete ANI 
Server discovery.

Reload data from the ANI Server 
by selecting Query > Reload 
Data. 

User Tracking discovery is not a 
full network discovery; it only 
discovers the user and host data 
in your network. 

Changes that you make to your 
network might not appear after a 
User Tracking discovery.

Table 3-3 Troubleshooting User Tracking (continued)

Symptom Probable Cause Possible Solution
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