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Getting Started with CVDM-C6500

CiscoView Device Manager for the Cisco Catalyst 6500 Series (CVDM-C6500) 
is an embedded device manager for single chassis setup, switch and services 
configuration, and monitoring of the Cisco Catalyst 6500 family of products. 
CVDM-C6500 makes initial switch, VLAN, port, and service module 
configuration easier by allowing you to perform all these operations using one 
graphical user interface (GUI) tool. 

You use wizards and dialog boxes to make your configurations; CVDM-C6500 
then designs best-practice command line interface (CLI) configurations based on 
your GUI configurations. You can view the CLI configurations generated by 
CVDM-C6500 and deploy them to the device immediately or save them for future 
editing.

More importantly, CVDM-C6500 shows you a graphical view of LANs 
configured across service modules and enables basic setup of each module so that 
its own embedded device manager (if available) can be launched. In addition to 
these features, CVDM-C6500 shows you a summary of the device and allows you 
to perform basic switch configuration tasks such VLAN, port, and spanning tree 
configuration.

You can also configure global settings, such as spanning tree, banners, and 
connectivity to individual service modules; after performing such tasks, you can 
start the embedded device managers for each of the installed service modules 
(such as the SSL Device Manager on the SSL) for more in-depth service module 
configuration.

Note CVDM-C6500 supports the deployment of native Cisco IOS commands only.
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Chapter 1      Getting Started with CVDM-C6500
Key Features in CVDM-C6500
This section includes the following topics:

• Key Features in CVDM-C6500, page 1-2

• Starting CVDM-C6500, page 1-4

• Navigating in CVDM-C6500, page 1-9

• Starting Embedded CiscoView from CVDM-C6500, page 1-20

• Saving Startup Configurations, page 1-23

• Editing Preferences, page 1-23

• Viewing the Running Configuration Information for a Device, page 1-25

• Viewing the Device Transport Log, page 1-25

• Refreshing CVDM-C6500, page 1-26

• Delivering CLI Commands to the Device, page 1-26

• Resetting Service Modules, page 1-27

• Understanding Your User Role, page 1-28

• What’s Next?, page 1-33

Key Features in CVDM-C6500
The following table describes the key features of CVDM-C6500.
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Key Features in CVDM-C6500
Table 1-1 Key Features

Feature Description

Basic switch, port, 
VLAN, spanning tree, 
VPN and forwarding 
instances (VRFs), and 
SVI configuration

CVDM-C6500 provides functions for port, VLAN, spanning tree, VRF, 
and SVI configuration.

Initial service module 
setup

CVDM-C6500 provides functions for the initial configuration of the 
following service modules:

• Firewall Services Module (FWSM)

• Content Switching Module (CSM)

• Secure Socket Layer (SSL) Services Module

• Virtual Private Network (VPN) Services Module

• Network Analysis Module (NAM)

• Intrusion Detection System Module (IDSM)

• Wireless LAN Services Module (WLSM)

• Content Switching Module with SSL (CSM-S)

CVDM-C6500 also provides deployment templates, based on 
Cisco-recommended configurations, that perform VLAN setup between 
the service modules, including any configurations required for traffic flow 
across them.

Graphical and wireless 
service visualization

CVDM-C6500 provides a topology map that displays VLAN connectivity 
between service modules and allows you to perform certain configuration 
tasks on service modules. 

CVDM-C6500 also provides a wireless view map that displays 
information about the wireless networks configured on your device, such 
as the number of mobile nodes and number of access points on the wireless 
network. You can also configure wireless networks and search for wireless 
networks from this map.

Integration of service 
module device managers

CVDM-C6500 performs initial setup of device managers through 
encrypted communication with the switch using the method you selected 
during setup. You can also start device managers within CVDM-C6500.
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Starting CVDM-C6500
Starting CVDM-C6500

Note To start CVDM-C6500, you must enter your device credentials. You must also 
enter credentials for any installed service modules to populate the data for each 
module. For more information, see Understanding User Credentials, page 1-29.

Step 1 Open a web browser.

Step 2 In your browser, enter the IP address or DNS hostname of the device. The Enter 
Network Password dialog box appears (see Figure 1-1), prompting you for your 
level 15 credentials.

Note If you are using a Cisco IOS 12.1.(13)E image, enter the following in your 
web browser:
http://<ip-address>/flash/cv/applet.html?dynarchives=cvdm-c6500-1.1.sgz 
or
http://<ip-address>/flash/cv/applet.html?dynarchives=cvdm-c6500-1.1_K9.sgz 
(if you installed Cisco IOS Cryptographic software)

where <ip-address> is the IP address of the switch. It may be useful to 
bookmark this URL for future use.
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Starting CVDM-C6500
Figure 1-1 Enter Network Password Dialog Box

Step 3 Enter your username and password for level 15 access. If you do not have level 15 
access to the device, CVDM-C6500 will not start.

Note If enable password is used for HTTP authentication, use enable password 
only.

Step 4 Click OK. The device home page appears.

Step 5 Click the CVDM-C6500 link on the device home page.

Step 6 The CVDM-C6500 splash screen is displayed, and the Password Needed - 
Networking dialog box appears (see Figure 1-2).
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Starting CVDM-C6500
Figure 1-2 Splash Screen and Password Needed - Networking Dialog box

Note If you do not have Java Plug-in version 1.4.2_06, you will be prompted to 
install it. If you are not prompted, go to 
http://java.sun.com/products/archive/j2se/1.4.2_06/index.html and install 
the Java plug-in. 

This website is Copyright © 1994-2005, Sun Microsystems, Inc.

The CVDM-C6500 splash screen must remain open in order for the application to 
function properly. Do not close this window until you log out. CVDM-C6500 will 
appear in a separate window. 

Note It may take some time before CVDM-C6500 appears.
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Starting CVDM-C6500
Step 7 In the Password Needed - Networking dialog box, enter your username and 
password. 

Note If enable password is used for HTTP authentication, use enable password 
only.

Step 8 Click Yes. The Warning - Security dialog box appears (see Figure 1-3). 

Figure 1-3 Warning - Security Dialog Box

Step 9 To accept the security certificate and continue, click Yes. A dialog box appears 
(see Figure 1-4), prompting you for your username and password.
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Starting CVDM-C6500
Figure 1-4 Enter Credentials for <IP Address> Dialog Box (Username and 

Password)

Step 10 If SSH is enabled on the device, enter your username and password. If SSH is not 
activated on the device, you are prompted to authenticate using Telnet instead. 
Follow the prompts to enter your username and Telnet password; it also asks if 
you want to enable SSH on the device. To enable SSH, follow the prompts 
provided by the application. 

If you are not using a Cisco IOS cryptographic image, you are prompted to 
authenticate using Telnet; follow the prompts to enter the appropriate credentials.

Step 11 Click OK. 

• If enable is not configured on the device, CVDM-C6500 starts. Skip the 
remaining steps in this procedure.

• If enable is configured on the device, a dialog box appears (see Figure 1-5), 
asking you to input your enable password. 

Figure 1-5 Enter Credentials for <IP Address> Dialog Box (Enable Password)
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Step 12 Enter your enable password.

Step 13 Click OK. CVDM-C6500 starts.

Installing the Java Plug-in
CVDM-C6500 requires Java Plug-in version 1.4.2_06. The first time you invoke 
any Java Plug-in enabled window, you are alerted if the plug-in has not been 
installed. CVDM-C6500 prompts you to download and install the plug-in files, 
using the installation screens or the procedure displayed. The next time you start 
the application, CVDM-C6500 automatically uses the plug-in. Install the Java 
Plug-in 1.4.2_06 provided with CVDM-C6500 (not from any other source).

Navigating in CVDM-C6500
Before you begin using CVDM-C6500, you must understand the basic operation 
of the user interface, including the login procedure and user interface elements. 
See the following sections for more information:

• What Does the Home Page Show Me?, page 1-9

• What Does the Switch Page Show Me?, page 1-13

• What Does the Services Page Show Me?, page 1-14

• Understanding the CVDM-C6500 Desktop, page 1-14

• Understanding the Action Buttons, page 1-20

What Does the Home Page Show Me?
The home page is the first screen that comes up when CVDM-C6500 is started. It 
gives a quick overview of the services running on the device and a snapshot of the 
overall health of the system. It displays high-level system information; any 
service modules, ports, VLANs, and spanning trees CVDM-C6500 has 
discovered; and the status of each service module installed (see Figure 1-6).
1-9
User Guide for CiscoView Device Manager for the Cisco Catalyst 6500 Series Switch

OL-6896-01



Chapter 1      Getting Started with CVDM-C6500
Navigating in CVDM-C6500
Figure 1-6 CVDM-C6500 Home Page Components and Descriptions
1-10
User Guide for CiscoView Device Manager for the Cisco Catalyst 6500 Series Switch

OL-6896-01



Chapter 1      Getting Started with CVDM-C6500
Navigating in CVDM-C6500
Figure 1-6
Reference Location Description

1 System Overview tab Provides high-level information about the device and shows 
the following information:

• Hostname—The hostname of the device.

• Serial Number—The serial number of the device.

• Description—A brief description of the device.

• Model—The model type of the device.

• IOS version—The Cisco IOS image version the device is 
running.

• Image—The name of the image running on the device.

• Up Since—The length of time the device has been 
operational.

The supervisor pane displays the percentage of CPU, 
memory, and Flash used by the supervisor card. 

2 Switch Dashboard tab Provides information about ports, VLANs, spanning trees, 
and VRFs discovered by the device, such as the number of 
access ports and the number of Layer 2 VLANs.

Click the link for any switch object to open the corresponding 
page for that object.
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Navigating in CVDM-C6500
No Service Modules Installed

If no service modules are installed, the No Services available link is displayed on 
the Services Dashboard.

3 Services Dashboard tab Provides information about the service modules on the 
device. Click the link for any service to open the 
corresponding page for that service module. 

If there are no service modules installed, a No Service 
Modules link appears. For more information, see No Service 
Modules Installed, page 1-12.

If credentials are not available for a service module, the Enter 
Credentials link appears. Click this link to open the Enter 
Credentials dialog box and enter the desired credentials. For 
more information, see Understanding User Credentials, 
page 1-29.

4 Reset button After selecting a service module from the table in the Module 
Status pane, click to reset the service module. See Resetting 
Service Modules, page 1-27 for more information.

5 Module Status tab Provides an overview of installed service modules and 
provides a table that displays the following information:

• Slot—The slot to which the service module is attached.

• Status—Status of the service module. A  icon 
indicates that the module is operationally up; a  icon 
indicates that the module is operationally down.

• Description—A brief description of the service module.

• Serial Number—The serial number of the service 
module.

• Model—The model type of the service module.

• Software Version—The Cisco IOS version running on 
the service module.

Figure 1-6
Reference Location Description
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Navigating in CVDM-C6500
To view available Cisco service modules, see 
http://www.cisco.com/en/US/products/hw/modules/ps2706/prod_models_home.
html.

For more information on the types of data that CVDM-C6500 can display for each 
service module, see Chapter 9, “Service Module Setup.”

What Does the Switch Page Show Me?
The Switch page allows you to view and configure Layer 2 and Layer 3 switch 
features, such as port, VLAN, VRF, and spanning tree features. You can also edit 
your global settings from the Switch page (see Figure 1-7).

Figure 1-7 CVDM-6500 Switch Page
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What Does the Services Page Show Me?
The Services page allows you to view and configure services running on the 
device. This page provides summary information about service modules. The 
Services page also provides a graphical view of VLANs across service modules 
and setup wizards that enable you to configure the services on the device (see 
Figure 1-8).

Figure 1-8 CVDM-C6500 Services Page

Understanding the CVDM-C6500 Desktop
This section describes the main GUI elements of the CVDM-C6500 application.
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Figure 1-9 CVDM-C6500 GUI Elements
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Navigating in CVDM-C6500
Figure 1-9 
Reference Location Description

1 Menu bar Provides File, Edit, View, and Help options.

• File

– File > Save to Startup—Saves the configuration running on 
the device and on the service modules as the startup 
configuration. For more information, see Saving Startup 
Configurations, page 1-23.

– File > Exit—Logs you out of CVDM-C6500 and closes the 
application window.

• Edit

– Edit > Credentials...—Displays the Enter Credentials dialog 
box. For more information, see Understanding User 
Credentials, page 1-29.

– Edit > Preferences...—Displays the Preferences dialog box 
from which you can edit application preferences. See 
Editing Preferences, page 1-23 for more information.

• View

– View > Home—Displays the Home page. See What Does the 
Home Page Show Me?, page 1-9 for more information.

– View > Switch —Displays the Switch page. See What Does 
the Switch Page Show Me?, page 1-13 for more information. 

– View > Services—Displays the Services page. See What 
Does the Services Page Show Me?, page 1-14 for more 
information.

– View > Running Config —Opens the Show Running 
Configuration dialog box for the supervisor card, SSL 
Services Module, FWSM, IDSM, NAM, WLSM, or CSM-S 
(only options for installed service modules can be selected). 
It displays information about the configuration running on 
the selected component. See Viewing the Running 
Configuration Information for a Device, page 1-25 for more 
information.
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Figure 1-9 
Reference Location Description

1 (continued) Menu bar 
(continued)

• View (continued)

– View > Refresh—Collects the most recent device 
information and updates the CVDM-C6500 data. See 
Refreshing CVDM-C6500, page 1-26 for more information.

– View > Transport Log...—Displays the transport log of the 
device. The transport log displays all communication 
between CVDM-C6500 and the device. See Viewing the 
Device Transport Log, page 1-25 for more information.

• Help

– Help > Help Topics—Displays online help.

– Help > About CVDM-C6500...—Displays CVDM-C6500 
version information.

2 Task bar Provides the following buttons:

• Home—Displays the home page. See What Does the Home Page 
Show Me?, page 1-9 for more information on the home page.

• Switch—Displays the Switch page for Layer 2 and Layer 3 
switching. See What Does the Switch Page Show Me?, page 1-13 
for more information on the Switch page.

• Services—Displays the Services page for Layer 4 and higher 
services. See What Does the Services Page Show Me?, page 1-14 
for more information on the Services page.

• Refresh—Collects the most recent device information and 
updates CVDM-C6500 data.

• Deliver—Opens the Deliver Configuration to Switch/Module(s) 
dialog box, from which you can send accumulated CLI 
commands to the device. See Delivering CLI Commands to the 
Device, page 1-26 for more information.

• Help—Displays context-sensitive help.

Note The task bar displays the Chassis button if Embedded 
CiscoView is installed with CVDM-C6500. For more 
information, see Starting Embedded CiscoView from 
CVDM-C6500, page 1-20.
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Selector

The selector is a tree that appears on most Switch and Services pages. Figure 1-10  
shows what the selector looks like when folders, subfolders, and objects are 
displayed. Not all selectors contain all of these elements.

Figure 1-9 
Reference Location Description

3 Page CVDM-C6500 working area in which you perform tasks.

4 Pane One part of a divided page or dialog box.

5 Status bar Provides the following information:

• Application user and privilege level.

• Icon showing the security level of the connection.

• Time stamp showing the last time CVDM-C6500 collected data.

6 Selector Hierarchy of the groups and objects available in the Switch or 
Services page that allows you to access specific functions for a switch 
or service object. See Selector, page 1-18 for more information.

7 Left-most pane Contains buttons, on the Switch or Services page, that allow you to 
access switch or services functions.
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Figure 1-10 Selector

Figure 1-10 
Reference Location Description

1 Group folder Displays a group of objects. Click the plus 
(+) symbol to see the contents of this folder.

2 Selector handle Click the handle to open and close the 
selector, or click the handle and drag it to 
resize it.

3 Subgroup folder Displays a subgroup of objects. Click the 
plus (+) symbol to see the contents of this 
folder.

4 Object Displays the individual entity contained in 
the group or subgroup. Click an object to 
open the page for that object.
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Understanding the Action Buttons
This section describes the action buttons that commonly appear in CVDM-C6500 
dialog boxes and wizards. For a description of the wizard action buttons, see 
Table 1-2; for a description of the dialog box action buttons, see Table 1-3.

Note Some dialog boxes may contain additional buttons not described in this 
table.

Starting Embedded CiscoView from CVDM-C6500
If Embedded CiscoView is installed, you can start Embedded CiscoView from 
CVDM-C6500. The Chassis button is displayed in the task bar when Embedded 
CiscoView is installed (see Figure 1-11). 

Table 1-2 Wizard Action Buttons

Button Action

Back Takes you to the previous page.

Next Takes you to the next page.

Finish Takes you to the wizard summary page.

Cancel Exits the wizard without making any 
changes.

Help Displays context-sensitive online help.

Table 1-3 Dialog Box Action Buttons

Button Action

OK Saves your changes.

Cancel Exits the dialog box without making 
any changes.

Help Displays context-sensitive online help.
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Figure 1-11 CVDM-C6500 Home Page with Chassis Button

Step 1 Click the Chassis button at the top of the window. The Community String dialog 
box appears.

Step 2 Edit the appropriate values:

Step 3 Click OK. CiscoView starts (see Figure 1-12).

GUI Element Action/Description

Read Community field Enter the read community string.

Write Community field Enter the write community string.
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Figure 1-12 CiscoView

To download Embedded CiscoView and to obtain Embedded CiscoView 
documentation, go to:

http://www.cisco.com/kobayashi/sw-center/netmgmt/ciscoview/embed-cview-pl
anner.shtml.
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Saving Startup Configurations
You can save your device and service module configuration as the startup 
configuration.

Step 1 Select File > Save to Startup. A warning dialog box appears, asking if you want 
to continue. 

Step 2 To proceed, click Yes. CVDM-C6500 saves the configuration as your startup 
configuration. 

Editing Preferences

Step 1 Select Edit > Preferences.... The Preferences dialog box appears. 

Step 2 Edit the appropriate values:
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Editing Preferences
GUI Element Action

Show CLI Preview for 
Wizards check box

Select this check box if you want CVDM-C6500 to display the CLI 
commands to be delivered to the device after you have completed a 
wizard. By default, this check box is deselected.

When this check box is selected, when you click Finish in a wizard, 
the Deliver Configuration to the Switch/Module(s) dialog box opens 
and displays the CLI commands. For more information, see 
Delivering CLI Commands to the Device, page 1-26.

Show CLI Preview on 
Delivery check box

Select this check box if you want CVDM-C6500 to display the CLI 
commands to be delivered to the device. By default, this check box is 
selected.

When this check box is selected, if you click Deliver, then the Deliver 
Configuration to Switch/Module(s) dialog box opens and displays the 
CLI commands. For more information, see Delivering CLI Commands 
to the Device, page 1-26.

Refresh After Delivery check 
box

Select this check box to automatically refresh CVDM-C6500 after 
you deliver commands to the device. Refreshing CVDM-C6500 
allows you to obtain the latest service module information and update 
the CVDM-C6500 data. By default, this check box is selected.

When this check box is deselected, when you click Finish in a wizard, 
CVDM-C6500 prompts you to optionally refresh the application after 
delivering commands to the device. For more information, see 
Refreshing CVDM-C6500, page 1-26.

Confirm before Exiting check 
box

Select this check box if you want CVDM-C6500 to ask you to confirm 
that you want to exit the application. By default, this check box is 
selected.

When this check box is selected, CVDM-C6500 displays a dialog box 
asking you if you want to exit CVDM-C6500. From this dialog box, 
you can select the Always display this dialog box before exiting check 
box if you always want CVDM-C6500 to confirm that you want to exit 
CVDM-C6500.
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Viewing the Running Configuration Information for a 
Device

Step 1 Select View > Running Config, then select one of the following:

• Supervisor...

• SSL: Slot X...

• Firewall: Slot X...

• NAM: Slot X...

• IDS: Slot X...

• WLSM: Slot X...

Note Only options for installed service modules are available to be selected.

Step 2 The Show Running Configuration dialog box appears. Information about the 
running configuration for the selected component is displayed.

You can click the Save to File... button to save this information as a text file.

Viewing the Device Transport Log

Step 1 Select View > Transport Log... A warning dialog box appears.

Step 2 To proceed, click OK. The Transport Log dialog box appears, displaying 
information about communication between CVDM-C6500 and the device. You 
can do the following:

• Click Clear Log to clear the information in the transport log.

• Click Save to File... to save the transport log information as a text file.
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Refreshing CVDM-C6500
You can refresh CVDM-C6500 at any time to obtain the latest device and service 
module information and update the CVDM-C6500 data. 

Note You can specify that CVDM-C6500 automatically refresh after you deliver 
commands to the device; see Editing Preferences, page 1-23 for more 
information.

Step 1 Click Refresh at the top of the window or select View > Refresh from the Menu 
bar.

Step 2 A dialog box appears, asking if you want to proceed with the refresh. To proceed, 
click Yes. The most recent device information is collected and is populated in 
CVDM-C6500.

Delivering CLI Commands to the Device

Note You must deliver accumulated CLI commands to the device before any changes 
you make in CVDM-C6500 will be applied. 

Step 1 Click the Deliver button at the top of the window. The Deliver Configuration to 
Switch/Module(s) dialog box appears if you have configured CVDM-C6500 to 
display the accumulated CLI commands when you click the Deliver button (for 
more information on configuring this option, see Editing Preferences, page 1-23).

Note The Deliver Configuration to Switch/Module(s) dialog box also appears 
when you click the Finish button in a wizard if you have configured 
CVDM-C6500 to display the accumulated CLI commands after you have 
completed a wizard.

Step 2 Edit the appropriate values.
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Resetting Service Modules
Note The Deliver Configuration to Switch/Module(s) dialog box displays all 
accumulated CLI commands that will be delivered to the device; therefore, any 
previous CLI commands that were not sent to the device are shown in this dialog 
box, as well as the CLI commands you have generated in this session.

Resetting Service Modules

Step 1 From the CVDM home page, select the service module you want to reset in the 
table in the Module Status pane.

Step 2 Click Reset. A dialog box appears. 

Step 3 To proceed, click Yes. A dialog box appears. 

GUI Element Action

Window Displays the accumulated CLI commands to be 
delivered to the device.

Deliver button Click to send the accumulated CLI commands to the 
device.

Save to File... button Click to save the CLI commands as a text file.

Close button1

1. This button is available only in the Deliver Configuration to Switch/Module(s) dialog box that is 
displayed after you click Deliver at the top of the window.

Close the dialog box without delivering any CLI 
commands.

Deliver Later button2

2. This button is available only in the Deliver Configuration to Switch/Module(s) dialog box that is 
displayed after you click Finish in a wizard.

Click to deliver the wizard CLI commands to the 
device at a later time.
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Step 4 To proceed, click Yes.

CVDM-C6500 issues the command:

hw-module module n reset

Step 5 Refresh CVDM-C6500 to obtain the current state of the device. See Refreshing 
CVDM-C6500, page 1-26 for more information.

Understanding Your User Role
CVDM-C6500 can be used by three types of users: Network Operations, Security 
Operations, and Super Admin users. CVDM-C6500 is structured so that functions 
specific to each type of user are consolidated in a single place in the application. 
For example, all of the Layer 2 and Layer 3 switch features are grouped under the 
Switch tab, and all of the services running on the device are grouped under the 
Services tab. Network Operations users will typically use the functions on the 
Switch page, while Security Operations users will typically use the functions on 
the Services page. Certain features are available only to a specific type of user:

• Network Operations users are typically responsible for configuring, 
maintaining, and managing connectivity between Layer 2 and 3 devices. 
Network Operations users can perform Layer 2 and 3 configuration functions 
but do not have access to Layer 4 and higher functions such as configuring 
security devices.

• Security Operations users are typically responsible for configuring, 
maintaining, and managing security devices such as SSL and firewalls. 
Security Operations users can configure the security on service blades and 
apply policies to them.

• Super Admin users have access to all CVDM-C6500 functionality. For 
example, these users can create VLANs on the supervisor, have access to 
service blade configurations, and can inspect and edit firewall VLAN 
interfaces.

Note Your user role is based on device credentials. For more information, see 
Understanding User Credentials, page 1-29.
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Understanding User Credentials
CVDM-C6500 uses role-based access control, dependent upon device credentials. 
The following list provides important information about user roles and necessary 
credentials:

• If you do not have level 15 access to the device, CVDM-C6500 will not start.

• You must have level 15 access (Super Admin user privileges) to the device 
and its service modules to access all of the features of CVDM-C6500.

• If you have level 15 access to the supervisor card and some service modules, 
you can only edit the configuration of those service modules to which you 
have access. Although other service modules may be present on the device, 
you cannot make configuration changes or view all service module data.

After you start CVDM-C6500, CVDM-C6500 uses the device credentials to log 
into the device and populate data from the device. If you provide full credentials 
for all installed service modules, then data for all service modules are populated 
in CVDM-C6500.

However, if credentials are not available for one or more service modules, then 
data for the service modules are not populated in CVDM-C6500. To enter 
credentials for a service module, open the Enter Credentials dialog box and edit 
the appropriate values. 

Step 1 Do one of the following:

• Click the Enter Credentials link on the Services Dashboard in the 
CVDM-C6500 home page.

• Click the Enter Credentials link on the SSL, Firewall, IDS, NAM, or WLSM 
page.

• Select Edit > Credentials... from the menu bar (you can open the Enter 
Credentials dialog box at any time from the menu bar).
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Step 2 Edit the appropriate values.

GUI Element Action/Description

IP Address pane

IP Address check box Device IP address; grayed out because you 
cannot edit this field.

Username Supervisor card username; grayed out because 
you cannot edit this field.

Password Supervisor card password; grayed out because 
you cannot edit this field.

Enable Username Supervisor card username; grayed out because 
you cannot edit this field.

Enable Password Supervisor card enable password; grayed out 
because you cannot edit this field.

SSL: Slot X pane

SSL: Slot X check box Click this check box to enter your SSL service 
module credentials, then enter the desired 
credentials.

Username Enter your SSL service module username.

Password Enter your SSL service module password.

Enable Username Enter your SSL service module enable 
username.

Enable Password Enter your SSL service module enable 
password.

Firewall: Slot X pane

Firewall: Slot X check box Click this check box to enter your Firewall 
service module credentials, then enter the 
desired credentials.

Username Enter your Firewall service module username.

Password Enter your Firewall service module password.

Enable Username Enter your Firewall service module enable 
username.
1-30
User Guide for CiscoView Device Manager for the Cisco Catalyst 6500 Series Switch

OL-6896-01



Chapter 1      Getting Started with CVDM-C6500
Understanding Your User Role
Enable Password Enter your Firewall service module enable 
password.

NAM: Slot X pane

NAM: Slot X check box Click this check box to enter your NAM service 
module credentials, then enter the desired 
credentials.

Username Enter your NAM service module username.

Password Enter your NAM service module password.

IDS: Slot X pane

IDS: Slot X check box Click this check box to enter your IDS service 
module credentials, then enter the desired 
credentials.

Username Enter your IDS service module username.

Password Enter your IDS service module password.

WLSM: Slot X pane

WLSM: Slot X check box Click this check box to enter your WLSM 
credentials, then enter the desired credentials.

Username Enter your WLSM username.

Password Enter your WLSM password.

Enable Username Enter your WLSM enable username.

Enable Password Enter your WLSM enable password.

CSM-S: Slox X pane

CSM-S: Slot X check box Click this check box to enter your CSM-S 
credentials, then enter the desired credentials.

Note CSM-S credentials are used to log in to 
the SSL portion of the CSM-S.

Username Enter your CSM-S username.

Password Enter your CSM-S password.

Enable Username Enter your CSM-S enable username.

Enable Password Enter your CSM-S enable password.

GUI Element Action/Description
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Note Only fields for installed service modules are displayed in this dialog box.

After you provide the credentials, CVDM-C6500 populates the corresponding 
Services pages and the Services Dashboard rows in the home page with the 
service module data. If the page for the service module is displayed when you 
enter the corresponding credentials, CVDM-C6500 refreshes the page and 
displays the service module data.

If you do not provide credentials for all service modules, CVDM-C6500 displays 
only partial information for the service modules. In addition, the Services 
Dashboard on the CVDM-C6500 home page does not display information for the 
service modules, and the corresponding services page displays only partial data. 

If the supervisor credentials are changed through CLI while a CVDM-C6500 
session is open, a dialog box appears and prompts for the new credentials during 
a refresh or delivery if there is no active CVDM-C6500 session to the supervisor; 
if there is an active session to the supervisor, CVDM-C6500 prompts for the new 
credentials when the application session times out or during a refresh or delivery.

Clicking Cancel in this dialog box closes CVDM-C6500; if you enter the wrong 
credentials, CVDM-C6500 prompts you again to enter the correct credentials. If 
you enter incorrect credentials a second time, CVDM-C6500 closes. You will not 
be able to edit the supervisor credentials through the Credentials dialog box.

If the credentials are changed on a service module after its data has been 
populated in CVDM-C6500, a dialog box appears and prompts for the new 
credentials during a refresh or delivery. If you enter the wrong credentials, 
CVDM-C6500 prompts you again to enter the correct credentials. If you enter the 
incorrect credentials a second time, or if you click Cancel in this dialog box, 
CVDM-C6500 refreshes and does not populate any data for the service module. 
You must enter the correct credentials in the Credentials dialog box to populate 
the data. 

If you are prompted to enter the new credentials while delivering commands to the 
device and you click Cancel or enter the incorrect credentials, commands will not 
be delivered to the device and data for the service module will not be populated.
1-32
User Guide for CiscoView Device Manager for the Cisco Catalyst 6500 Series Switch

OL-6896-01



Chapter 1      Getting Started with CVDM-C6500
What’s Next?
What’s Next?
If your main task is to manage port, VLAN, and spanning tree configurations, then 
almost all of your operations can be performed using the Switch tab. If your main 
task is to manage and configure service modules on the device, then your 
operations can be performed using the Services tab.

Table 1-4 Quick Reference

If you want to... Then see...

View and edit global switch 
settings

Chapter 2, “System Settings 
(Switch > System)”

Configure physical ports and 
logical interfaces

Chapter 3, “Ports/Interface 
Management (Switch > Ports)”

Configure VLANs and VTPs Chapter 4, “VLAN and VTP 
Management 
(Switch > VLANs)”

Configure VLAN and port STP 
settings

Chapter 5, “Spanning Tree 
Settings (Switch > Spanning 
Tree)”

Configure VRF settings Chapter 6, “VPN Routing and 
Forwarding Instances 
Management (Switch > VRFs)”

Set up service modules Chapter 9, “Service Module 
Setup”
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