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Preface

This manual describes Cisco Unified Provisioning Manager (Provisioning Manager) and provides
instructions for using and administering it.

Audience

The audience for this document includes network administrators and operators who monitor, maintain,
and configure the status of the IP telephony systems and applications.

Conventions

This document uses the following conventions:

Item Convention
Commands and keywords boldface font
Variables for which you supply values italic font

Displayed session and system information screen font

Information you enter boldface screen font
Variables you enter italic screen font

Menu items and button names boldface font

Selecting a menu item in paragraphs Option >Network Preferences
Selecting a menu item in tables Option>Network Preferences

S,
Note = Means reader take note. Notes contain helpful suggestions or references to material not covered in the
publication.

A

Caution  Means reader be careful. In this situation, you might do something that could result in equipment
damage or loss of data.

Installation Guide for Cisco Unified Provisioning Manager
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Product Documentation
N~

Note = We sometimes update the printed and electronic documentation after original publication. Therefore,
you should also review the documentation on Cisco.com for any updates.

Table 1 describes the product documentation that is available.

Table 1 Product Documentation
Document Title Available Formats
Supported Devices Table for Cisco Unified On Cisco.com at the following URL:

Provisioning Manager 1.3 http://www.cisco.com/en/US/products/ps7125/products_device_sup

port_tables_list.html

Release Notes for Cisco Unified Provisioning e In PDF on the product CD-ROM
Manager 1.3

¢ On Cisco.com at the following URL.:
http://www.cisco.com/en/US/products/ps7125/prod_release_no
tes_list.html

Installation Guide for Cisco Unified Provisioning e In PDF on the product CD-ROM
Manager 1.3

e On Cisco.com at the following URL.:
http://www.cisco.com/en/US/products/ps7125/prod_installation
_guides_list.html

User Guide for Cisco Unified Provisioning e In PDF on the product CD-ROM
Manager 1.3

e On Cisco.com at the following URL:
http://www.cisco.com/en/US/products/ps7125/products_user_g
uide_list.html

Obtaining Documentation and Submitting a Service Request

For information on obtaining documentation, submitting a service request, and gathering additional
information, see the monthly What’s New in Cisco Product Documentation, which also lists all new and
revised Cisco technical documentation, at:

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html

Subscribe to the What’s New in Cisco Product Documentation as a Really Simple Syndication (RSS) feed
and set content to be delivered directly to your desktop using a reader application. The RSS feeds are a free
service and Cisco currently supports RSS version 2.0.

Installation Guide for Cisco Unified Provisioning Manager
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Open Source License Acknowledgements [l

Open Source License Acknowledgements

The following acknowledgements pertain to this software license.

OpenSSL/Open SSL Project

License Issues

This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit
(http://www.openssl.org/).

This product includes cryptographic software written by Eric Young (eay @cryptsoft.com).
This product includes software written by Tim Hudson (tjh@cryptsoft.com).

The OpenSSL toolkit stays under a dual license, i.e. both the conditions of the OpenSSL License and the
original SSLeay license apply to the toolkit. See below for the actual license texts. Actually both licenses
are BSD-style Open Source licenses. In case of any license issues related to OpenSSL please contact
openssl-core @openssl.org.

OpenSSL License:
© 1998-1999 The OpenSSL Project. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided
that the following conditions are met:

1. Redistributions of source code must retain the copyright notice, this list of conditions and the
following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions, and
the following disclaimer in the documentation and/or other materials provided with the distribution.

3. All advertising materials mentioning features or use of this software must display the following
acknowledgment: “This product includes software developed by the OpenSSL Project for use in the
OpenSSL Toolkit. (http://www.openssl.org/)”

4. The names “OpenSSL Toolkit” and “OpenSSL Project” must not be used to endorse or promote
products derived from this software without prior written permission. For written permission, please
contact openssl-core @openssl.org.

5. Products derived from this software may not be called “OpenSSL” nor may “OpenSSL” appear in
their names without prior written permission of the OpenSSL Project.

6. Redistributions of any form whatsoever must retain the following acknowledgment:

“This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit
(http://www.openssl.org/)”

THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT “AS IS”" AND ANY EXPRESSED OR
IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN
NO EVENT SHALL THE OpenSSL PROJECT OR ITS CONTRIBUTORS BE LIABLE FOR ANY
DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT

| oL-17005-01
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M Open Source License Acknowledgements

LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY
OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH
DAMAGE.

This product includes cryptographic software written by Eric Young (eay @cryptsoft.com). This product
includes software written by Tim Hudson (tjh@cryptsoft.com).

Original SSLeay License:
© 1995-1998 Eric Young (eay @cryptsoft.com). All rights reserved.

This package is an SSL implementation written by Eric Young (eay @cryptsoft.com).
The implementation was written so as to conform with Netscapes SSL.

This library is free for commercial and non-commercial use as long as the following conditions are
adhered to. The following conditions apply to all code found in this distribution, be it the RC4, RSA,
lhash, DES, etc., code; not just the SSL code. The SSL documentation included with this distribution is
covered by the same copyright terms except that the holder is Tim Hudson (tjh@cryptsoft.com).

Copyright remains Eric Young’s, and as such any Copyright notices in the code are not to be removed.
If this package is used in a product, Eric Young should be given attribution as the author of the parts of
the library used. This can be in the form of a textual message at program startup or in documentation
(online or textual) provided with the package.

Redistribution and use in source and binary forms, with or without modification, are permitted provided
that the following conditions are met:

1. Redistributions of source code must retain the copyright notice, this list of conditions and the
following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and
the following disclaimer in the documentation and/or other materials provided with the distribution.

3. All advertising materials mentioning features or use of this software must display the following
acknowledgement:

“This product includes cryptographic software written by Eric Young (eay @cryptsoft.com)”.

The word ‘cryptographic’ can be left out if the routines from the library being used are not
cryptography-related.

4. If you include any Windows specific code (or a derivative thereof) from the apps directory
(application code) you must include an acknowledgement: “This product includes software written
by Tim Hudson (tjh@cryptsoft.com)”.

THIS SOFTWARE IS PROVIDED BY ERIC YOUNG “AS IS” AND ANY EXPRESS OR IMPLIED
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT,
INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT
NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF
THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

The license and distribution terms for any publicly available version or derivative of this code cannot be
changed. i.e. this code cannot simply be copied and put under another distribution license [including the
GNU Public License].

Installation Guide for Cisco Unified Provisioning Manager
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CHAPTER

Prerequisites

This chapter describes the prerequisites for installing Cisco Unified Provisioning Manager on a
Windows system. It includes:

e Product Overview, page 1-1

e New Features in Cisco Unified Provisioning Manager 1.3, page 1-2
e Server Requirements, page 1-3

¢ Client Requirements, page 1-4

e Additional Server Software, page 1-4

Product Overview

Cisco Unified Provisioning Manager (Provisioning Manager) is a provisioning tool for Cisco Unified
Communications initial deployments and implementations.. Provisioning Manager manages IP
communication services in an integrated IP telephony, voicemail, and unified messaging environment
that includes Cisco Unified Communications Manager, Cisco Unified Communications Manager
Express, Cisco Unity, Cisco Unity Express, and Cisco Unity Connection systems.

Provisioning Manager is a product from the Cisco Unified Communications Management Suite. It
provides provisioning for Cisco Unified Communications initial deployments and implementations, and
then remains deployed to provide ongoing operational provisioning and activation services for individual
subscriber changes. Provisioning Manager provides a single, consolidated view of subscribers across the
organization. It provides a set of business-level management abstractions, which are policy-driven
through the use of automation, for managing subscriber services across the Cisco Unified
Communications infrastructure.

A template capability permits defining standard configurations that can be reused for new sites or
location deployments. Batch provisioning permits the rollout of large numbers of subscribers at the same
time.

Administrators can configure policy at various levels to determine who can do delegated management,
for whom that delegation applies, and how business-level services apply to Cisco Unified
Communications voice and messaging applications and which types of end users (subscribers) are
permitted to order which standard services. Through the use of this policy and standard configuration
approach, provisioning and activating subscriber services is greatly simplified, while retaining the
overall ability to manage and provide services that make use of the underlying Cisco Unified
Communications applications.

| oL-17005-01
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I New Features in Cisco Unified Provisioning Manager 1.3

New Features in Cisco Unified Provisioning Manager 1.3

Cisco Unified Provisioning Manager adds the following:
e The following provisioning attributes:
- Remote Node ID
- Legacy Mailbox
= Owner User ID
— ASCII Alerting Name
— ASCII Display (Internal Caller ID)
— ASCII Line Text Label
e The following business rules:
— Non-RestrictedDomainSyncDomain
— AssociateOnlyExistingUsers

¢ Enhancements to the Line Text Label provisioning attribute so that a transformation mask template
can be use to manipulate the directory number displayed.

¢ Bulk add and delete for subscribers and users using batch provisioning.
e USERID keyword for the DescriptionString business rule.

e Keyword formatting to the Alerting Name provisioning attribute.

¢ Support for Cisco Unified IP Phones 7921 and 7937.

e Support for Cisco Unified Personal Communicator 2.0.

¢ Support for Cisco Unified IP Phone Expansion Module 7915 and 7916.
¢ Support for Cisco Unified Communications Manager 4.3(2), 6.1(2), and 7.0(1).
e Support for Cisco Unified Communications Manager Express 7.0.

¢ Support for Cisco Unity 7.0.

¢ Support for Cisco Unity Express 3.2.

¢ Support for Cisco Unity Connection 7.0.

Installation Guide for Cisco Unified Provisioning Manager
m. 0L-17005-01 |



| Chapter1 Prerequisites

Server Requirements

Server Requirements

Table 1-1 lists the minimum server system requirements for different levels of performance and scale.

Table 1-1 Server System Requirements
Requirement Type Minimum Requirements
System Processor Server platform with one of the following processor configurations:

e (Up to 1,000 phones) Single Intel Pentium 4, 3.0 GHz.

e (Up to 10,000 phones) Dual-core Intel Pentium 4, 3.0 GHz.

e (Up to 30,000 phones) Two-system deployment, with the following configuration:
— Two Intel Xeon processors, 3.0 GHz, for the Web and application server.
— Two Intel Xeon processors, 3.0 GHz, for the database.

Note If you will have more than five operators placing concurrent orders,
you should use two dual-core Intel Xeon processors.

Other System Hardware e Color monitor.

e CD-ROM drive.

e 100 Mbps NIC.

Memory (RAM)! e 2 GB—Up to 1000 phones.

e 4 GB—Up to 10,000 phones.

e 4 GB on each system—Up to 30,000 phones.

Swap File Space Same as RAM, with a maximum size of twice that of RAM.
Available Drive Space? e 30 GB—Up to 1000 phones.
e 60 GB—Up to 10,000 phones.

e Two-system configuration (up to 30,000 phones); requires the following:
— 30 GB on the Web and application system.
-~ 80 GB on the database system.

3

System Software Windows Server 2003 with Service Pack 1 or Service Pack 2, Standard or Enterprise

Edition.

1. Provisioning Manager will not install either the medium (up to 10,000 phones) or the large (up to 30,000 phones) configuration if Windows 2003 reports
that less than 4 GB of memory is installed. There is a known issue with Windows 2003 when working with certain hardware. Even though 4 GB of memory
is installed on the system, Windows 2003 reports that there is less than 4 GB of memory installed. For more details, see
http://msdn2.microsoft.com/en-us/library/ms791485.aspx.

2. SAS or SCSI drives in a RAID configuration are recommended for servers supporting 1000 to 10,000 phones. SAS drives in a RAID (140) configuration
are recommended for servers supporting over 10,000 phones.

3. You must install Provisioning Manager on a dedicated system. Do not install Provisioning Manager on a Primary Domain Controller (PDC) or Backup
Domain Controller (BDC).

Installation Guide for Cisco Unified Provisioning Manager
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M Client Requirements

Client Requirements

Table 1-2 lists the minimum client system requirements for installing Provisioning Manager.

Table 1-2 Client System Requirements
Requirement Type Minimum Requirements
System Hardware e Any PC or server platform with a Pentium 4 processor greater than 1.0 GHz.

¢ Color monitor with video card set to 24 bits color depth.

e Screen resolution of 1024 x 768 dpi.

N

On LCD projectors and monitors, dot pitch impacts the readability of the screen.

Note Not every LCD projector or monitor provides a clear display at the minimum resolution.

System Software ¢ One of the following:

- Windows XP with Service Pack 2.

¢ One of the following

— Internet Explorer 6.0 with Service Pack 2 or 7.0.
- Mozilla 1.7.x.

- Windows Server 2003 with Service Pack 1 or Service Pack 2, Standard or Enterprise Edition.

- Firefox 2.0
Memory (RAM) 1 GB recommended.
Environment Clients must be able to access Provisioning Manager:

¢ From outside a firewall—Refer to the documentation for your firewall for information on how to
configure client access.

e Across a Virtual Private Network (VPN)—The VPN tunnel should connect the client and a VPN
router or similar device. See Ports that Provisioning Manager Uses, page 2-9.

Additional Server Software

Provisioning Manager has undergone interoperability testing with the following software:

e Cisco Security Agent 5.0

)

Note  Cisco Security Agent must be disabled during installation of Provisioning Manager.

e Third-party virus protection software:

— McAfee Virus Scan Enterprise 8.0

Installation Guide for Cisco Unified Provisioning Manager
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Additional Server Software

For McAfee Enterprise VirusScan 8.0, you must have patch version 11 installed. Install the
McAfee VirusScan Enterprise 8.0 Patch Version 11 before installing Provisioning Manager on
the system.

S

Note  You should exclude the following from virus scanning:

e The pgsql folder (if you selected the default location during installation, it is C:\CUPM\pgsql).
e The postmaster.exe file (located in the CUPM\pgsql\bin folder).

Installation Guide for Cisco Unified Provisioning Manager
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I Additional Server Software
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CHAPTER

Installing, Upgrading and Uninstalling Cisco
Unified Provisioning Manager

This chapter describes installing Cisco Unified Provisioning Manager.

It includes:

Preparing to Install Provisioning Manager, page 2-1

Installing Provisioning Manager, page 2-11

Upgrading Provisioning Manager 1.2 to Provisioning Manager 1.3, page 2-15
Uninstalling Provisioning Manager, page 2-25

Preparing to Install Provisioning Manager

The information in this section helps you to deploy Provisioning Manager in your network. Do the
following before you install Provisioning Manager:

Make sure that hardware and software requirements for the server are met. (See Server
Requirements, page 1-3.)

Preparing the Provisioning Manager server for installation. (See Preparing the Server, page 2-2.)

Configure end systems so that Provisioning Manager can obtain correct information from them.
(Preparing End Systems, page 2-4.)

Determine whether your existing applications are already using ports that Provisioning Manager
uses. (Existing applications should not use the ports that Provisioning Manager requires.) See Ports
that Provisioning Manager Uses, page 2-9.

Gather information that you might need to provide during the Provisioning Manager installation.
(See Gathering Information to Provide During Installation, page 2-10.)

| oL-17005-01
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| Preparing to Install Provisioning Manager

Preparing the Server

A

Note

This section describes procedures that you may need to perform to prepare your server for installing
Provisioning Manager on it.

The system that you use for your Provisioning Manager server should meet all the security guidelines
that Microsoft recommends for Windows 2003 Server. See the Microsoft website for security guidance
(http://www.microsoft.com/technet/security/prodtech/WindowsServer2003.mspx).

Enabling the Full 4 GB of RAM

Step 1
Step 2
Step 3
Step 4
Step 5
Step 6
Step 7

Provisioning Manager will not install either the medium (up to 10,000 phones) or the large (up to 30,000
phones) configuration if Windows 2003 reports that less than 4 GB of memory is installed. There is a
known issue with Windows 2003 when working with certain hardware. Even though 4 GB of memory is
installed on the system, Windows 2003 reports that there is less than 4 GB of memory installed. For more
details, see http://msdn2.microsoft.com/en-us/library/ms791485.aspx.

To enable all 4 GB of RAM on the system, use the following procedure:

On the Provisioning Manager system, in Windows right-click My Computer.

Select Properties.

Select the Advanced tab.

Under Startup and Recovery, click Settings.

Click Edit. The boot.ini file opens.

In the file, add »/paE" in line starting with "multi(0)disk(0)rdisk(0)partition(1) \WINDOWS=..."

Restart the system.

Enabling SSL on the Provisioning Manager Server

Secure Socket Layer (SSL) is an application-level protocol that enables secure transactions of data
through privacy, authentication, and data integrity. It relies upon certificates, public keys, and private
keys.

Provisioning Manager supports SSL between clients and the server. When you start Provisioning
Manager, the login page always opens in secure mode, providing secure access between the client
browser and the Provisioning Manager server. In secure mode, SSL is used to encrypt the transmission
channel between the browser and the server. To use secure mode throughout Provisioning Manager, you
must enable SSL.

To enable SSL, you must install Win32 OpenSSL and then configure the Apache server.

Installing OpenSSL and Generating a Certificate

Step 1

Step 2

On the Provisioning Manager system, install Win32 OpenSSL v0.9.7m in C:\OpenSSL. You can find
Win32 OpenSSL at http://www.slproweb.com/products/Win320OpenSSL.html.

In a command prompt, go to <Install directory>\httpd\conf.

Installation Guide for Cisco Unified Provisioning Manager
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Installing, Upgrading and Uninstalling Cisco Unified Provisioning Manager

Step 3

Step 4
Step 5

Step 6
Step 7
Step 8

Step 9

Step 10

Preparing to Install Provisioning Manager ||

S

Note If you accepted the default location during installation, the installation directory is C:\CUPM.

In the command prompt, run the following command:

c:\OpenSSL\bin\openssl.exe genrsa -des3 -out server.key 1024
A prompt appears, asking for a passphrase. Enter a phrase.

Run the following command:

c:\OpenSSL\bin\openssl.exe req -new -x509 -days 365 -key server.key -out server.crt

S

Note  This command assumes the certificate is valid for 365 days. If you need a longer license, enter
a higher number of days.

At the prompted, enter the passphrase you entered previously. Enter it again.
Enter the information for the Distinguished Name fields for the certificate.

Run the following command:

copy server.key server.key.orig

Run the following command:

c:\OpenSSL\bin\openssl.exe rsa -in server.key.orig -out server.key

Enter the passphrase you used previously. This removes the need to enter the passphrase every time you
start Provisioning Manager.

Configuring the Apache Server

Step 1

Step 2

Step 3

Note

On the Provisioning Manager system, in the httpd.conf file (located at <install directory>/httpd/conf),
uncomment the line LoadModule ssl_module modules/mod_ssl.so.

If you upgraded from Provisioning Manager 1.2 you must update the ssl.conf file.
Set @DOCROOT @ to <install directory>/httpd/htdocs (it should be changed in two places).

If this is a new installation, you can skip this step.
Restart the Apache2 Windows Service.

Now you can log into Provisioning Manager using HTTPS.

When using SSL, remember the following:
e The URL for logging in uses HTTPS (For example, https://<host name or IP address>/cupm/Login).

e Ifyouupgraded from Provisioning Manager 1.2, the ssl.conf file may be read only. Remove the read
only property using Windows Explorer.

| oL-17005-01
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| Preparing to Install Provisioning Manager

e By default, port 443 is configured in the ssl.conf file. If you need to change the port number, in the
ssl.conf file, change the line Listen 443 to the desired port.

e If you want to exclusively run only HTTPS, you must disable the nonsecure HTTP by commenting
out the line Listen 80 in the C:\CUPM\httpd\conf\httpd.conf file, and then restart the Apache server.

Preparing End Systems

In Provisioning Manager, the physical resources (end systems that deliver voice and messaging services)
are modeled as Processors. For example, a Cisco Unified Communications Manager or Cisco Unified
Communications Manager Express system is modeled as a Call Processor and a Cisco Unity, Cisco Unity
Express, or Cisco Unity Connection voicemail/unified messaging system is modeled as a Unified
Message Processor.

Using Provisioning Manager, an administrator creates and configures these various processors. After the
processors have been configured, all configuration and interaction with the end systems is handled by
Provisioning Manager.

Some minimal configuration is required on the end systems before you can use them with Provisioning
Manager. This section describes the preconfiguration steps required for Cisco Unified Communications
Manager, Cisco Unified Communications Manager Express, Cisco Unity systems, Cisco Unity
Connection, and Cisco Unity Express.

Cisco Unified Communications Manager Preconfiguration Dependencies

The Cisco Unified Communications Manager is the software-based, call-processing component of the
Cisco IP telephony solution, and is part of Cisco Architecture for Voice, Video and Integrated Data
(AVVID).

Additional data, voice, and video services such as unified messaging, multimedia conferencing,
collaborative contact centers, and interactive multimedia response systems interact with the IP telephony
solution through Cisco Communications Manager’s open telephony application programming interface
(API). Cisco Communications Manager is installed on the Cisco Media Convergence Server (MCS).

No specific preconfiguration is generally required on the Cisco Unified Communications Manager for
Provisioning Manager. However, the following conditions should already have been met during a normal
installation or upgrade, and are noted here as installation dependencies for creating a Call Processor in
Provisioning Manager:

¢ Install Cisco Unified Communications Manager.

e If Cisco Unity is used in this configuration, configure the Cisco Unified Communications Manager
voicemail ports.

¢ Create a user and password with administrator privileges that can be used by Provisioning Manager
to access Cisco Unified Communications Manager. The requirements of the user and password vary
depending on whether multilevel administration access (MLA) is enabled (see Table 2-1).

~
Note  All interactions with Cisco Unified Communications Manager and Provisioning Manager are through
the AVVID XML Layer APIs (AXL/SOAP).
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Determining the Media Server Account to Use for Cisco Unified Communications Manager Access

To enable Provisioning Manager to access a Cisco Unified Communications Manager, you must supply
the username and password for an account on the media server. The account to use depends upon the
Cisco Unified Communications Manager version and might also depend on whether MLA is enabled for
the Cisco Unified Communications Manager. Table 2-1 lists the options.

Table 2-1 Accounts Required to Access Cisco Unified Communications Manager
MLA Enabled
Cisco Unified or Disabled for
Communications Cisco Unified
Manager Version on Communications
Media Server Manager Required Account
4.x Enabled Multilevel administration access account with full
access to the Standard Serviceability Functional
Group.
Disabled Valid Windows 2000 administrator account on the

media server.

5.x, 6.x, or 7.x N/A A Unified Communications Manager user who is
assigned a role with the privilege to use the AXL
Database API resource in the Cisco Call Manager
AXL Database application.

Standard AXL API Access is one of the predefined
roles in Unified Communications Manager that has
this privilege.

Cisco Unified Communications Manager Express Preconfiguration Dependencies

Cisco Unified Communications Manager Express is a solution, embedded in Cisco IOS Software, that
provides call processing for Cisco Unified IP Phones.

Like Cisco Unified Communications Manager, Cisco Unified Communications Manager Express is
modeled in Provisioning Manager as a Call Processor. The only difference from an administrative aspect
is that it is represented by a different type of Call Processor.

Provisioning Manager requires that the Cisco Unified Communications Manager Express be installed on
a supported platform with the appropriate Cisco IOS Software version and Cisco Unified
Communications Manager Express load.

Before you can create a Call Processor based on a Cisco Unified Communications Manager Express in
Provisioning Manager, you must do the following:

e Disable the auto-allocation of directory numbers. Do this through the Cisco I0S interface (see
Disabling the Auto-Allocation of Directory Numbers and Ephone Auto-Registration, page 2-6).

e Disable the ephone auto-registration. You must do this through for Cisco Unified Communications
Manager Express 4.0 or later (see Disabling the Auto-Allocation of Directory Numbers and Ephone
Auto-Registration, page 2-6).

e Ifyou have changed the Rivest, Shamir, and Adelman (RSA) key pair for Secure Shell Version 2 (on
the router where Cisco Unified Communications Manager Express resides) to a length less than 512
bits, you must reconfigure the RSA key back to a length equal to or greater than 512 bits. For
information on configuring the RSA keys in Secure Shell Version 2, see your router’s
documentation.
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Disabling the Auto-Allocation of Directory Numbers and Ephone Auto-Registration

Do the following configurations through the Cisco IOS interface.

Step 1 First, verify that auto-allocation is enabled.

$ telnet 172.19.50.247
Trying 172.19.50.247...
Connected to 172.19.50.247.
Escape character is '~]'.

User Access Verification
Password:

CCME-1>enable
Password:

CCME-1#show telephony
CONFIG (Version=3.0)

Cisco Communications Manager Express
ip source-address 172.19.50.247 port 2000
max-ephones 24
max-dn 100
max-conferences 4
max-redirect 5
time-format 12
date-format mm-dd-yy
keepalive 30
timeout interdigit 10
timeout busy 10
timeout ringing 180
web admin system name root password cisco
web admin customer name cisco password cisco
edit DN through Web: enabled.
edit TIME through web: enabled.
Log (table parameters) :
max-size: 150
retain-timer: 15
(password) : abcd
create cnf-files version-stamp 7960 Jan 15 2004 16:48:05
auto assign 1 to 100 type 7960 cfw 5001 timeout 30
local directory service: enabled.
xml schema http://gkar.cisco.com/schema/axlsoap.xsd

In this case, auto-allocation is on, as shown by the auto assign line.
Step2  To disable auto-allocation, run the following command at the enable prompt:

CCME-1l#config term

Enter configuration commands, one per line. End with CNTL/Z.

CCME-1 (config) #telephony-service

CCME-1 (config-telephony) #no auto assign 1 to 100 type 7960 cfw 5001 timeout 30
CCME-1 (config-telephony) #no auto-reg-ephone

S

Note  The no auto-reg-ephone command is required for Cisco Unified Communications Manager
Express 4.0 or later.

CCME-1 (config-telephony) #exit
CCME-1 (config) #fexit
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CCME-1l#show telephony

To verify that the change has taken effect, run another show telephony command. The auto assign line
should no longer appear.

Run a write memory command, which will write the changes out to the system’s nonvolatile memory
in case of a reboot.

How Provisioning Manager Manages Communications Manager Express

Note

Cisco Unified Communications Manager Express uses two main commands to provision phones for end
subscribers:

¢ telephony ephone-dn—Manages directory numbers.
e telephony ephone—Assigns directory numbers to lines on one or more phones.

Both commands allow subscriber information to be associated to the directory number or the line.
Provisioning Manager uses these native abilities in Cisco Unified Communications Manager Express to
store and synchronize subscriber information.

Provisioning Manager is able to synchronize back the phones, lines, directory numbers, and subscriber
information from an existing Cisco Unified Communications Manager Express. Depending on how the
subscriber information was used in the telephony ephone and telephony ephone-dn commands,
Provisioning Manager is able to fully construct a user account for that subscriber. Provisioning Manager
supports shared lines and directory numbers while doing this.

When provisioning, Provisioning Manager uses the description command in the ephone configlet to
hold the subscriber name and department information. Provisioning Manager also uses the name
command in the ephone-dn configlet to hold the subscriber's first and last names.

The Cisco Unified Communications Manager Express ephone-dn name field is limited to 30 characters.
If the subscriber’s first and last names (combined) exceed that limit, you may get an error.

Cisco Unity and Cisco Unity Connection System Preconfiguration Dependencies

A

Note

Provisioning Manager does not support Cisco Unity when it is configured with multiple Cisco Unified
Communications Manager clusters.

Before you can create a Unified Message Processor based on Cisco Unity in Provisioning Manager, you
must do the following:

¢ Install and configure the message store using Microsoft Exchange 2000 or 2003. (Required for Cisco
Unity only.)

¢ Configure an integration with one corresponding Cisco Unified Communications Manager.

e Create a SQL Server user and password that can be used by Provisioning Manager to access the SQL
Server database on Cisco Unity. The SQL Server user requires access to both the Cisco Unity and

master databases. See Creating an SQL Server User and Password for Cisco Unity, page 2-8.
(Required for Cisco Unity only.)

e Verify the TCP/IP port used by Cisco Unity. This port number is required when you create a Unified
Message Processor. (Required for Cisco Unity only.)

| oL-17005-01

Installation Guide for Cisco Unified Provisioning Manager ]



Chapter2 Installing, Upgrading and Uninstalling Cisco Unified Provisioning Manager

| Preparing to Install Provisioning Manager

e Define Class of Service and Subscriber templates.

e Configure IMAP in Cisco Unity Connection. This is required so that Provisioning Manager can
provision email and Unified Messaging Services in Cisco Unity Connection. (Required for Cisco
Unity Connection only.)

A

Note  To configure IMAP: on the Cisco Unity Connection system, go to System Settings > External
Services > Add New, and fill in all the fields required to add external services.

Creating an SQL Server User and Password for Cisco Unity

Step 1

Step 2
Step 3

Step 4
Step 5
Step 6
Step 7

On the Cisco Unity system, select Start > SQL Server > Enterprise Manager. The Enterprise Manager
window appears.

In the navigation tree, select Microsoft SQL Servers > SQL Server Group > (local) (Windows NT).

Right-click (local) (Windows NT) and select Properties. The SQL Server Properties (Configure)
window appears.

Click the Security tab.
Under Authentication, select SQL Server and Windows.
In the navigation tree under (local) (Windows NT), select Security > Logins.
Create a new login. Do the following:
a. Right-click Logins. The SQL Server Login Properties - New Login window appears.
b. Enter a name for the login.
c. Select SQL Server Authentication.
d. Select UnityDb.
e. Click the Database Access tab.
f. Select both the UnityDb and the master database.
g. For both databases, select the following roles: db_owner, db_datareader, and db_datawriter.

h. Reboot the SQL server.

Verifying the TCP/IP Port Used by Cisco Unity

Step 1

Step 2

Step 3
Step 4
Step 5

On the Cisco Unity system, select Start > SQL Server > Enterprise Manager. The Enterprise Manager
appears.

From the menu, click Action. Then select Properties. The SQL Server Properties (Configure) dialog
box appears.

In the General tab, click Network Configuration. The SQL Server Network Utility window appears.
Select TCP/IP, then click Properties.

In the window that appears, the default TCP/IP port is displayed. You will need to know this port number
when you create a Unified Message Processor.
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Cisco Unity Express Preconfiguration Dependencies
Before you can create a Unified Message Processor based on Cisco Unity Express in Provisioning
Manager, you must do the following:

e If you have changed the RSA key pair for Secure Shell Version 2 (on the router where Cisco Unity
Express resides) to a length less than 512 bits, you must reconfigure the RSA key back to a length
equal to or greater than 512 bits. For information on configuring the RSA keys in Secure Shell
Version 2, see your router’s documentation.

e Determine the Service Engine Interface number for Cisco Unity Express. The Service Engine
Interface number is required when adding a Cisco Unity Express to Provisioning Manager (see
Determining the Service Engine Interface Number for Cisco Unity Express, page 2-9).

Determining the Service Engine Interface Number for Cisco Unity Express

The Service Engine Interface number is located on the router that hosts Cisco Unity Express.

Step 1 Log in to the router that hosts Cisco Unity Express.
Step 2 Run the command show running-config.

In the resulting output, look for the following:

Interface Service-Engine 2/0

In this example, 2/0 is the Service Engine Interface number.

Interfaces that Provisioning Manager Uses

Table 2-2 lists the interfaces that Provisioning Manager uses to communicate with the end systems.

Table 2-2 Interfaces that Provisioning Manager Uses

Call Processor/ Unified Message Processor Interface

Cisco Unified Communications Manager AXL and SOAP

Cisco Unified Communications Manager Express |CLI over Telnet and SSH
Cisco Unity JDBC

Cisco Unity Connection Webservice API

Cisco Unity Express CLI over Telnet and SSH

Ports that Provisioning Manager Uses

Before installing Provisioning Manager, make sure that the appropriate ports are available.

Table 2-3 lists the ports that need to be open on the Provisioning Manager system. Table 2-4 lists the
ports that need to be open on the firewall between Provisioning Manager and the device.
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Table 2-3 Ports Used on the Provisioning Manager System

Port Numbers Additional Information

1098 —

1099 —

1602 Network Interface and Configuration Engine (NICE). This is configurable
during the advanced installation process.

4444 —

4445 —

5432 PostgreSQL database. This is configurable during the advanced installation
process.

8008 JBoss Application Sever. This is configurable during the advanced
installation process.

8009 —

8083 —

8093 —

80 HTTP/Apache Web Server. This is configurable during the advanced
installation process.

Table 2-4 Ports Used to Communicate with Other Devices

Port Numbers |Service Name/Protocols Application

80 HTTP/Apache Web Server Cisco Unified Communications Manager.

8443 HTTPS Cisco Unified Communications Manager 5.0.

22 SSH Cisco Unified Communications Manager Express

and Cisco Unity Express.
23 Telnet Cisco Unified Communications Manager Express
and Cisco Unity Express.

Gathering Information to Provide During Installation

You might need to supply the following information while you are installing Provisioning Manager:
e For a simple installation, you will need to have the following:
— A license file, or you can choose to use the evaluation version.
— Password for the administrator user.
— Username and password for the PostgreSQL administrator (default is postgres).

¢ For an advanced installation, what you need depends on your installation. The following list
contains information you may need to have:

— A license file, or you can choose to use the evaluation version.
— A port number for the Apache web server.

— A port number for the PostgreSQL database.
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— Hostname or IP address for the systems that can connect to the PostgreSQL database.
— Username and password for the Windows user that the PostgreSQL database uses.

— Username and password for the PostgreSQL administrator (default is postgres).

— The JBoss application server name.

— The port number for the JBoss application server.

— Username and password for the application database user.

— Password for the administrator user.

— Port number for the NICE service.

Installing Provisioning Manager

Step 1

Step 2
Step 3

Step 4
Step 5
Step 6

The installation process takes approximately 60 minutes to complete.
Follow these guidelines when installing Provisioning Manager:
e Provisioning Manager requires a dedicated system; do not install it on a system with:
— Third-party management software (such as HP OpenView or NetView).
— Cisco Secure Access Control Server (ACS).

— Any Cisco applications other than those that are documented to be able to coexist with
Provisioning Manager.

e Ifinstalling on a system with Cisco Security Agent, before installing Provisioning Manager disable
Cisco Security Agent.

¢ Do notinstall on any of your voice application servers on a Cisco Unified Communications Manager
server.

e Verify that the system date and time are set properly.

e To speed up installation, disable all virus-scan software while installing.

Make sure your system meets these prerequisites:
e Required (or desired) operating system upgrades have been performed.
e Required service packs are installed.
For system requirements, see Server Requirements, page 1-3.
Close all open or active programs. Do not run other programs during the installation process.

As the local administrator, log in to the machine on which you will install the Provisioning Manager
software, and insert the Cisco Unified Provisioning Manager CD-ROM into the CD-ROM drive. The
Cisco Unified Provisioning Manager 1.3 window opens.

N

Note Ifthe CD-ROM is already in the CD-ROM drive and you stopped the installation process to close
programs or if Autostart is disabled, click cupm1.3-setup.exe to restart the process.

Click Install. The Welcome window appears.
Click Next. The Software License Agreement window appears.

Accept the Software License Agreement and then click Next.
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Step 7

Step 8

Step 9
Step 10

In the Destination Directory window, click Next to accept the default installation directory.

A
Note Do not install Provisioning Manager under any directory where the directory name contains a
space (for example, Program Files).

Select the appropriate sizing for your Provisioning Manager installation.

~

Note  The options that appear depend on the amount of memory that your system has.

Click Next.
Choose an installation type, Simple or Advanced:
¢ Select Simple, and click Next.
a. Select one of the following, and then click Next:
— If you have a license file for this product, specify its location—Browse to enter the location.

— Select this option to evaluate the product—You can complete the installation and then register
the license file later.

b. Enter a username and password for the PostgreSQL administrator (default is postgres), then
click Next.

S
Note  Enter only alphanumeric characters for the password. Do not enter any special
characters.

c. Enter a password for the Provisioning Manager administrator user.

A

Note Provisioning Manager is preconfigured with a permanent administrator account (pmadmin).

d. Click Next.
e. Select the appropriate time zone, then click Next. The Summary page appears.
f. Click Install.

e Select Advanced, and click Next. The advanced installation has two distribution options. In the
first, all of Provisioning Manager (application and database) is installed on one system. In the
second, the Provisioning Manager application and database are installed on separate systems. This
scenario requires that you enter the IP address of the two systems.

a. Choose the components:
— Database—Installs the Provisioning Manager database only.

— CUPM—Installs the Provisioning Manager application only.

~

Note If you choose to install the database and the application on separate systems, Provisioning
Manager is not completely installed until both the database and application are installed.
When you install the database on a separate machine, at the end of the installation you will
receive a message that states Provisioning Manager was installed successfully. But only the
database is installed on that system.
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Advanced installation enables you to configure the following information, depending on which
components you are installing:
— Port number for the Apache web server.
— Port number for PostgreSQL database.
— Hostname or IP address for the Provisioning Manager application server that can connect to the
PostgreSQL database. This is required if the database or the application is being installed on a
separate system.
— Username and password for the Windows user that the PostgreSQL database uses—Enter only
alphanumeric characters for the password. Do not enter any special characters.
>
Note If the username already exists on the system, the password entered must be the current
password for that user. Also, the Windows user should not have administrator privileges.
— Username and password for the PostgreSQL administrator (default is postgres)—Enter only
alphanumeric characters for the password. Do not enter any special characters.
— Application (JBoss) server name.
— Port number for the JBoss application server.
— Username and password for the application database user—Enter only enter alphanumeric
characters for the password. Do not enter any special characters.
— Password for the Provisioning Manager administrator user.
— Port number for the NICE service.
b. Select one of the following, and then click Next:
— If you have a license file for this product, specify its location—Browse to enter the location.
- Select this option to evaluate the product—You can complete the installation and then register
the license file later.
c. Select the appropriate time zone, then click Next. The Summary page appears.
d. Click Install.
>
Note If an error message appears similar to the following appears, it means that the installation has failed:
Postgres install failed with error code 1603
Before trying to install Provisioning Manager again, you must clean up the system. See Cleaning Up a
Failed New Installation, page 2-14.
Step11  Eject the CD-ROM.
A
Note  Store the CD-ROM in a secure, climate-controlled area for safekeeping.

Step12 Click Finish.

Step 13 After the installation completes, verify that Provisioning Manager is installed correctly by accessing the
Provisioning Manager login page. From the Windows desktop, select Start > Programs > Cisco Unified
Provisioning Manager > Log in to Cisco Unified Provisioning Manager.
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S

Note

If Enhanced Security is enabled on the Windows 2003 system, you must add the Provisioning Manager
home page to the Internet Explorer Trusted Sites Zone. You will not be able to access the Cisco Unified
Provisioning Manager home page until it is added to the trusted sites. See Adding the Provisioning
Manager Home Page to the Internet Explorer Trusted Sites Zone, page 2-14.

Adding the Provisioning Manager Home Page to the Internet Explorer Trusted

Sites Zone

Step 1
Step 2
Step 3
Step 4
Step 5
Step 6
Step 7

If Enhanced Security is enabled on the Windows 2003 system, you must perform the following
procedure before you can access the Provisioning Manager home page.

Open Provisioning Manager and select Start > Programs > Cisco Unified Provisioning Manager.
From the File menu, select Add this site to.

Click Trusted Sites Zone.

In the Trusted Sites dialog box, click Add to move the site to the list.

Click Close.

Refresh the page to view the site from its new zone.

Check the Status bar of the browser to confirm that the site is in the Trusted Sites Zone.

Cleaning Up a Failed New Installation

If Provisioning Manager did not install correctly, you must first clean up the system before trying to
install Provisioning Manager again. These procedures are for a failed new installation of Provisioning
Manager 1.3. If you need to clean up a failed upgrade of Provisioning Manager 1.2 to 1.3, see Restoring
Provisioning Manager 1.2 If the Provisioning Manager 1.3 Installation Fails, page 2-20.

After a failed installation, do the following:

e Delete the CUPM installation folder. If you selected the default location during installation, it is
C:\CUPM.

e Delete the folder C:\Program Files\Common Files\InstallShield\Universal\common\Gen]1.
¢ Delete the Documents and Settings\cupmuser folder.

¢ Remove the Windows user cupmuser (cupmuser is the default name provided during installation).
The Windows username can be different, if you changed it during installation. For instructions on
removing the Windows cupmuser, see Removing the CUPM Windows User, page 2-15.
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Removing the CUPM Windows User

Step 1
Step 2
Step 3
Step 4
Step 5

Step 6

On the Windows desktop, select Start > Settings > Control Panel.
Double-click Administrative Tools.

Double-click Computer Management.

In the console tree, under Local Users and Groups, click Users.
Right click the user account cupmuser and delete it.

~

Note The Windows username, cupmuser, is the default name provided during installation. The
Windows username can be different, if you changed it during installation.

Delete cupmuser’s home direcotry. The default location is in the directory C:\Documents and Settings\.

Upgrading Provisioning Manager 1.2 to Provisioning
Manager 1.3

There are two upgrade scenarios; select the procedure that matches your scenario:

e Upgrading Provisioning Manager on One System (Application and Database on the Same System),
page 2-15

e Upgrading Provisioning Manager on a Distributed System (Application and Database Are on
Separate Systems), page 2-17

Upgrading Provisioning Manager on One System (Application and Database on
the Same System)

Step 1

Step 2

Step 3

Manually back up your database. For instructions, see Provisioning Manager Database Backup,
page 2-18.
S,

Note  This manual backup is not the same backup that occurs automatically during upgrade. Both
backups must be performed.

On the system where Provisioning Manager 1.2 is installed, make sure the following prerequisites are
met:

¢ Required (or desired) operating system upgrades have been performed.
e Required service packs are installed.
For system requirements, see Server Requirements, page 1-3.

Close all open or active programs. Do not run other programs during the installation process.
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Step 4

Step 5
Step 6
Step 7
Step 8

Note

Step 9

Step 10

Note

As the local administrator, log in to the machine on which you will install the Provisioning Manager
software, and insert the Cisco Unified Provisioning Manager CD-ROM into the CD-ROM drive. The
Cisco Unified Provisioning Manager 1.3 window opens.

S

Note Ifthe CD-ROM is already in the CD-ROM drive and you stopped the installation process to close
programs or if Autostart is disabled, click cupm1.3-setup.exe to restart the process.

Click Install. The Welcome window appears.
Click Next. The Software License Agreement window appears.
Accept the Software License Agreement and then click Next.

A confirmation box appears, telling you that an upgrade to Provisioning Manager 1.3 will occur. Click
Next. A check of the system is performed, which verifies the following:

e No orders are in the Released state.

e All service actions are in the Closed state.

e All workflows are in the Finished state.

¢ No infrastructure, subscriber, or Domain synchronizations are running.
¢ No batch projects are running or are in the Active state.

e That there are not any unsupported devices configured in Provisioning Manager.

N

Note For device support information, see the Supported Devices Table for Cisco Unified
Provisioning Manager 1.3 at
http://www.cisco.com/en/US/products/ps7125/products_device_support_tables_list.html.

If any of these conditions are not met, the installation will stop.

If you are upgrading only the database or only the application (because you have a distributed setup) not
all the screens will appear during the upgrade process. Also, to complete the upgrade of a distributed
setup, you must run the Cisco Unified Provisioning Manager 1.3 installation CD on both systems.

When only upgrading the database (for distributed setup), you will be required to re-enter the
PostgreSQL database administrator password and the application database user username (the default is
cupm) and password.

Select a directory in which to back up the Provisioning Manager 1.2 data during upgrade. Click Next.
The Summary page appears.

Click Install.

If an error message similar to the following appears, it means that the installation has failed:

C:\CUPM\httpd\conf\httpd.conf exists on this system and it has been modified since

instllation. Do you want to remove this file?

Before trying to install Provisioning Manager again, you must clean up the system. See Provisioning
Manager Database Backup, page 2-18.
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Eject the CD-ROM.

A

Note  Store the CD-ROM in a secure, climate-controlled area for safekeeping.

Click Finish.

After the installation completes, verify that Provisioning Manager is installed correctly by accessing the
Provisioning Manager login page. From the Windows desktop, select Start > Programs > Cisco
Unified Provisioning Manager > Log in to Cisco Unified Provisioning Manager.

After upgrading Provisioning Manager, you must synchronize all of your Unified Message Processors
in Provisioning Manager before placing any orders for a processor.

If Enhanced Security is enabled on the Windows 2003 system, you must add the Provisioning Manager
home page to the Internet Explorer Trusted Sites Zone. You will not be able to access the Cisco Unified
Provisioning Manager home page until it is added to the trusted sites. See Adding the Provisioning
Manager Home Page to the Internet Explorer Trusted Sites Zone, page 2-14.

Upgrading Provisioning Manager on a Distributed System (Application and
Database Are on Separate Systems)

Step 1

Step 2

Step 3

Note

You must upgrade both the Provisioning Manager application and the Provisioning Manager database
systems.

Back up the Provisioning Manager 1.2 database. For information, see Provisioning Manager Database
Backup, page 2-18.

Upgrade the Provisioning Manager 1.2 database to 1.3. The installation program will only take you
through the applicable upgrade screens. If you need additional information, see Upgrading Provisioning
Manager on One System (Application and Database on the Same System), page 2-15.

Upgrade the Provisioning Manager 1.2 application to 1.3. The installation program will only take you
through the applicable upgrade screens. If you need additional information, see Upgrading Provisioning
Manager on One System (Application and Database on the Same System), page 2-15.

After upgrading Provisioning Manager, you must synchronize all of your Unified Message Processors
in Provisioning Manager before placing any orders for a processor.
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Provisioning Manager Database Backup

~

Note

There are two backup scenarios; select the procedure that matches your scenario:

e Backing up on a single machine; see Backing Up the Single-Machine Provisioning Manager
Database, page 2-18.

e Backing up for a distributed scenario; see Backing Up Provisioning Manager on a Distributed
Database, page 2-19.

When backing up files, you should place the files on a different file server. Also, you should burn the
backup data onto a CD.

Backing Up the Single-Machine Provisioning Manager Database

Step 1

Step 2

Step 3

Step 4

This procedure requires that you have administrator-level access to the Provisioning Manager database
(the PostgreSQL database).

On the Provisioning Manager system, stop the following services:

e Apache

e cupm JBossService

e cupm NiceService

a. On the Windows desktop, select Start > Control Panel > Administrative Tools > Services.

b. Right-click each of the services and click Stop.
On the Windows desktop, select Start > All Programs > PostgreSQLS8.2 > Command Prompt. A

command prompt opens in the <Install directory>\pgsql\bin directory.

)

Note If you accepted the default location during installation, the installation directory is C:\CUPM.

In the command prompt, run the following command and enter the PostgreSQL administrator password
when prompted:

pg_dumpall -o -U<username> > <directory>\<backup file name>

where:

e <username> is the username of the PostgreSQL administrator. If you accepted the default, the
administrator username is postgres.

e <directory> is an existing directory.

e <backup file name> is a filename that does not currently exist.

N

Note  Enter the password each time that you are prompted.

Use this command to back up the database. The command tells Provisioning Manager to store the
database information in a file.

If you are backing up for the same installation, proceed to the next step. If you are backing up for a new
installation, make backup copies as described in this step.
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In a backup folder, make copies of the following files and directories:
e <Installation directory>\install.log
¢ <Installation directory>\sep\dfc.properties
¢ <Installation directory>\sep\dfc.keystore
¢ <Installation directory>\jboss-4.0.3SP1\server\cupm\conf\login-config.xml
Start the following services:
e Apache
e cupm JBossService
e cupm NiceService
a. On the Windows desktop, select Start > Control Panel > Administrative Tools > Services.

b. Right-click each of the services and click Start.

Backing Up Provisioning Manager on a Distributed Database

Step 1

Step 2

Step 3

This procedure requires that you have administrator-level access to the Provisioning Manager database
(the PostgreSQL database).

On the system where Provisioning Manager is running, stop the following services:
e Apache
e cupm JBossService
e cupm NiceService

a. On the Windows desktop where Provisioning Manager is running, select Start > Control Panel >
Administrative Tools > Services.

b. Right-click each of the services and click Stop.

On the Windows desktop where the Provisioning Manager database is running, select Start > All
Programs > PostgreSQLS8.2 > Command Prompt. A command prompt opens in the
<Installation directory>\pgsql\bin directory.

N

Note If you accepted the default location during installation, the installation directory is C:\CUPM.

In the command prompt, run the following command and enter the PostgreSQL administrator password
when prompted:

pg_dumpall -o -U<username> > <directory>\<backup file name>

where:

e <username> is the username of the PostgreSQL administrator. If you accepted the default, the
administrator username is postgres.

e <directory> is an existing directory.

e <backup file name> is a filename that does not currently exist.
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Step 4

Step 5

S

Note  Enter the password each time that you are prompted.

This command is used to backup the database, by storing the database information in a file.

If you are backing up for the same installation, proceed to the next step. If you are backing up for a new
installation, either with the same IP address or a new one, do the following. On the machine where
Provisioning Manager is running, in a backup folder, make copies of the following files and directories:

e <Installation directory>\install.log
¢ <Installation directory>\sep\dfc.properties
¢ <Installation directory>\sep\dfc.keystore
e <Installation directory>\jboss-4.0.3SP1\server\cupm\conf\login-config.xml
Start the following services:
e Apache
e cupm JBossService
e cupm NiceService
a. On the Windows desktop, select Start > Control Panel > Administrative Tools > Services.

b. Right-click each of the services and click Start.

Restoring Provisioning Manager 1.2 If the Provisioning Manager 1.3 Installation

Fails

If Provisioning Manager did not upgrade correctly, you must first clean up the system before trying to
install Provisioning Manager again. These procedures are only for a failed upgrade. If you need to restore
a failed new installation of Provisioning Manager, see Cleaning Up a Failed New Installation, page 2-14.

After a failed upgrade, do the following:

¢ Clean up the old installation of Provisioning Manager 1.2 (see Cleaning Up the Old Installation,
page 2-20).

e Restore Provisioning Manager 1.2 (see Restoring Provisioning Manager 1.2, page 2-21).

Cleaning Up the Old Installation

Step 1

Step 2

Uninstall the Provisioning Manager installation. Depending upon where the installation failed, the
installed application may appear as Provisioning Manager 1.2 or Provisioning Manager 1.3. Try to use
the standard uninstallation process (see Uninstalling Provisioning Manager, page 2-25).

If the standard uninstallation process does not work, go to Step 2.
If standard uninstallation fails, you will have to perform some or all of the following steps:

a. Uninstall Postgres 8.2 if it still exists. If PostgreSQL 8.2 is listed under Windows Control Panel >
Add or Remove Programs, click Remove to uninstall it.

b. Remove the installation directory CUPM. This step may require a system reboot if the Provisioning
Manager services are still running and using the resources from the installation location.
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N

Note If you selected the default location during installation, it is C:\CUPM.

c. Remove the cupmuser (Windows user) if it still exists:
1. Select Start > Settings > Control Panel.
Double-click Administrative Tools.
Double-click Computer Management.
In the console tree, under Local Users and Groups, click Users.

Right-click the user account cupmuser and delete it.

o &1 & W DN

Delete cupmuser’s home directory. The default location is in the directory C:\Documents and
Settings\.

d. Remove the folder C:\Program Files\Common Files\InstallShield\Universal\common\Gen]1.

e. (Optional) You may need to delete the Provisioning Manager services. Make sure the services are
not running before you delete them.

Provisioning Manager services that need to be deleted:
e Apache2
e cupm JbossService
e cupm NICEService
e pgsql-8.2

Use the following command to delete Windows services: sc.exe delete <service name>.

Restoring Provisioning Manager 1.2

There are two restore scenarios; select the procedure that matches your scenario:

e Restoring on a single machine, see Restoring the Single-Machine Provisioning Manager Database,
page 2-21.

e Restoring for a distributed scenario, see Restoring Provisioning Manager for a Distributed Database,
page 2-23.

Restoring the Single-Machine Provisioning Manager Database
If you are restoring to a new installation, have the system with the new installation up and running before
beginning this procedure.

This procedure requires that you have administrator-level access to the Provisioning Manager database
(the PostgreSQL database).

Before You Begin

If you are restoring the database on a new system, you must verify that the following ports are not being
used by another application:

e dfc.jboss.port=8008
e dfc.postgres.port=5432

Installation Guide for Cisco Unified Provisioning Manager
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Step 2

Step 3

Step 4

Step 5
Step 6

Step 7

e dfc.nice.rmi.registry.internal.port=1602
e dfc.webport=80

If a port is being used by another application, you must change the port number to a vacant port. These
settings are defined in the <Installation directory>\sep\dfc.properties file. (If you accepted the default
location during installation, the installation directory is C:\CUPM.)

Stop Provisioning Manager services (for information on which services to stop, see Step 1 on
page 2-18).

On the Windows desktop, select Start > All Programs > PostgreSQLS8.2 > Command Prompt.

A command prompt opens in the <Installation directory>\pgsql\bin folder.

~

Note  If you accepted the default location during installation, the installation directory is C:\CUPM.

To enter the PostgreSQL prompt, run the following command and enter the PostgreSQL administrator
password for the current installation when prompted:

psqgl.exe -U<username>
where <username> is the username of the PostgreSQL administrator. If you accepted the default, the
administrator username is postgres.

Before restoring the database, you must drop the database name and role. In the command prompt, run
the following commands exactly as shown, one at a time and in the following order:

® DROP DATABASE cupm;
where cupm is the database name to be removed.
Expected output: DROP DATABASE

® DROP ROLE <rolemame>;

where <rolename> is the username for the SEP database user. If you accepted the default, the username
is cupm.

Expected output: DROP ROLE
® ALTER ROLE <username> WITH PASSWORD ‘<password>’;

where username is the username of the PostgreSQL administrator user, and <password> should be the
password that was set for the PostgreSQL administrator with backed-up data. If you accepted the default
administrator username, the username is postgres.

Expected output: ALTER ROLE
Enter \q to quit the PostgreSQL prompt.

From the command line, run the following command; when prompted, enter the password that was set
in the previous step for the PostgreSQL user:

psql.exe -U<username> -d postgres < <directory>\<file name to be restored from>

where <username> is the username of the PostgreSQL administrator. If you accepted the default, the
administrator username is postgres.

This command restores the database.

Copy the following backed-up files to the location where they were backed up from:

e <Installation directory>\install.log
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e <Installation directory>\sep\dfc.properties
e <Installation directory>\sep\dfc.keystore
e <Installation directory>\jboss-4.0.3SP1\server\cupm\conf\login-config.xml
Start the following services:
e Apache
e cupm JBossService
e cupm NiceService
a. On the Windows desktop, select Start > Control Panel > Administrative Tools > Services.

b. Right-click each of the services and click Start.

Restoring Provisioning Manager for a Distributed Database

Step 1

Step 2

If you are restoring to a new installation, either with the same or a new IP address, have the system with
the new installation up and running before beginning this procedure.

This procedure requires that you have administrator-level access to the Provisioning Manager database
(the PostgreSQL database).

Before You Begin

If you are restoring the database on a new system, you must verify that the following ports are not being
used by another application:

e dfc.jboss.port=8008

e dfc.postgres.port=5432

e dfc.nice.rmi.registry.internal.port=1602
e dfc.webport=80

If a port is being used by another application, you must change the port number to a vacant port. These
settings are defined in the <Installation directory>\sep\dfc.properties file. (If you accepted the default
location during installation, the installation directory is C:\CUPM.)

Also, you will need to change the system name in one of the following settings:
e dfc.postgres.host=<system name> (If the database is on one system.)

e dfc.postgres.hostlist=<system names> (If the database is on multiple systems.)

On the Provisioning Manager application system, stop the Provisioning Manager services (for
information on which services to stop, see Step 1 on page 2-19).

On the Windows desktop where the Provisioning Manager database is running, select Start > All
Programs > PostgreSQLS.2 > Command Prompt.

A command prompt opens in the <Installation directory>\pgsql\bin folder.

A

Note If you accepted the default location during installation, the installation directory is C:\CUPM.
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Step 3

Step 4

Step 5
Step 6

Step 7

Step 8

To enter the PostgreSQL prompt, run the following command and enter the PostgreSQL administrator
password for the current installation when prompted:

psqgl.exe -U<username>
where <username> is the username of the PostgreSQL administrator. If you accepted the default, the
administrator username is postgres.

Before restoring the database, you must drop the database name and role. In the command prompt, run
the following commands exactly as shown, one at a time and in the following order:

® DROP DATABASE cupm;
where cupm is the database name to be removed.
Expected output: DROP DATABASE

® DROP ROLE <rolemame>;

where <rolename> is the username for the SEP database user. If you accepted the default, the username
is cupm.

Expected output: DROP ROLE
¢ ALTER ROLE <username> WITH PASSWORD ‘<password>’;

where <username> is the username of the PostgreSQL administrator, and <password> is the password
that was set for the PostgreSQL administrator with backed-up data. If you accepted the default
administrator username, the username is postgres.

Expected output: ALTER ROLE
Enter \q to quit the PostgreSQL prompt.

From the command line, run the following command; when prompted, enter the password that was set
in the previous step for the PostgreSQL user:

psql.exe -U<username> -d postgres < <directory>\<file name to be restored from>

where <username> is the username of the PostgreSQL administrator. If you accepted the default, the
administrator username is postgres.

This command restores the database.

Copy the following backed-up files to the machine where the Provisioning Manager application is
running:

e <Installation directory>\install.log
¢ <Installation directory>\sep\dfc.properties
e <Installation directory>\sep\dfc.keystore
e <Installation directory>\jboss-4.0.3SP1\server\cupm\conf\login-config.xml
On the system where the Provisioning Manager application is running, start the following services:
e Apache
e cupm JBossService
e cupm NiceService
a. On the Windows desktop, select Start > Control Panel > Administrative Tools > Service.

b. Right-click each of the services and click Start.
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Uninstalling Provisioning Manager

A

Caution

Step 1
Step 2

Step 3

Step 4

Step 5

Step 6

Step 7
Step 8
Step 9

You must use the Provisioning Manager uninstallation program to remove Provisioning Manager from
your system. If you try to remove the files and programs manually, you can seriously damage your
system.

Close all applications that are using Provisioning Manager files.

As the local administrator, log in to the system on which Cisco Unified Provisioning Manager is
installed.

To start the uninstallation process, from the Windows desktop select Start > Programs > Cisco Unified
Provisioning Manager > Uninstall Cisco Unified Provisioning Manager.

Click Next to begin uninstalling.

A window appears, listing the components selected for uninstallation.
Click Uninstall.

Messages showing the progress of the uninstallation appears.

A message appears, reminding you that the cupmuser (Windows user) directory and the CUPM
installation folder must be removed manually. Click Next.

~

Note  The default Windows user name provided during installation is cupmuser. If you changed it
during installation, the Windows user name may be different.

Click Finish.
If you want to reboot the system, select Yes, restart my computer, then click Finish.
Manually delete the following folders from the Provisioning Manager system:

e The CUPM installation folder. If you selected the default location during installation, it is
C:\CUPM.

e The Documents and Settings\cupmuser folder.

| oL-17005-01

Installation Guide for Cisco Unified Provisioning Manager ]



Chapter2 Installing, Upgrading and Uninstalling Cisco Unified Provisioning Manager |

W Uninstalling Provisioning Manager

Installation Guide for Cisco Unified Provisioning Manager
m. 0L-17005-01 |



APPENDIX A

Licensing

This appendix provides licensing information for Cisco Unified Provisioning Manager (Provisioning
Manager). It contains the following sections:

e Licensing Overview, page A-1

e Licensing Warnings, page A-4

Licensing Overview

Provisioning Manager features software-based product registration and license key technologies.
Licensing ensures that you possess a licensed copy of Provisioning Manager 1.3.

N

Note Licensing uses node-locking technology. The license file can only be used with the MAC address that
you supply.

To determine whether Provisioning Manager is licensed, see Verifying Provisioning Manager License
Status, page A-1. If you do not have a license or you want to upgrade your license, see Licensing
Scenarios, page A-2.

Verifying Provisioning Manager License Status

Step1  Select System Administration > License Information. The Licensing Status Information page
appears, displaying the following information:

¢ Unavailable features—Any features in Provisioning Manager that you do not have access to,
because you do not have the appropriate license or because you have reached the limit for the use of
the feature.

e Features in overdraft state—Any features that you are using that have exceeded their allowable use
limit.

e All valid features—List of features and their corresponding use limit (Available), overuse allowed
(Overdraft), current use (Used) and date of expiration (Expiry).
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Licenses that Can Be Purchased

The license that you purchase determines the number of phones that Provisioning Manager can

provision.

You can purchase licenses in the following increments:

e Up to 500 phones.

e Up to 1,000 phones.
e Up to 2,000 phones.
e Up to 5,000 phones.
e Up to 10,000 phones.
e Up to 20,000 phones.
e Up to 30,000 phones.

~

Note
support.

Licenses are cumulative. Meaning you can combine licenses to increase the number of phones you can

Licensing Scenarios

Table A-1 describes what to do in different scenarios if you do not have a licensed, registered copy of
Provisioning Manager or if you want to increase phone support.

Table A-1

How to Obtain and Register a License

Scenario

What to Do

Installing with a purchased license.

1. Before installing, obtain a license file. See Licensing
Process, page A-3.

Note  You can install Provisioning Manager without the
license file. You can upgrade your license after
installation. See Registering a License File with

Provisioning Manager, page A-4.

2. During installation, select License File Location, and
provide the location of your license file.

Installing with an evaluation license.

Note  The evaluation license is
limited to monitoring 100
phones, 5 Call Processors, and

2 Unified Message Processors.

During installation, select the option to evaluate the product.
Evaluation versions are active for 90 days before you are
required to purchase a license.

If you want to upgrade to a purchased license after
installation, obtain a PAK and license file for the installed
version of Provisioning Manager. For information on the
licensing process, see Licensing Process, page A-3.
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Table A-1 How to Obtain and Register a License (continued)
Scenario What to Do
Getting a license for additional See Licensing Process, page A-3.

devices (either upgrading from an
evaluation license, or increasing the
number of supported devices).

Moving Provisioning Manager to Call the Cisco TAC for assistance.
another server.

Licensing Process

The Provisioning Manager license file includes support for at least 500 phones. You can purchase
incremental licenses for additional phone support and register up to 30,000 phones with a single
Provisioning Manager. For each incremental license that you purchase, you will receive a Product
Authorization Key (PAK), and you must use that PAK to obtain a license file.

This process applies to new installations and license upgrades.

1. Obtain a PAK—The PAK is used to register Provisioning Manager, and any additional device
support that you might purchase for Provisioning Manager, on Cisco.com, and it contains resource
limitations. See Obtaining a PAK, page A-3.

2. Obtain a license file—A license file is sent to you after you register the PAK on Cisco.com. See
Obtaining a License File, page A-3.

3. Copy the license file to the server where Provisioning Manager is to be installed. If Provisioning
Manager is already installed and you are upgrading your license file, you must register the license
file with Provisioning Manager. See Registering a License File with Provisioning Manager,
page A-4.

Obtaining a PAK

The PAK is located on the software claim certificate that is shipped with the Provisioning Manager
product CD.

Obtaining a License File

Step 1

Register the PAK and the MAC address of the system where Provisioning Manager is installed with
Cisco.com at http://www.cisco.com/go/license. You will be asked to log in. You must be a registered user
of Cisco.com to log in.

S

Note The MAC address is required because licensing uses node-locking technology. The license file
can only be used with the MAC address that you supply.

The license file will be emailed to you. After you obtain a license file, register the license with the
Provisioning Manager server.
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M Licensing Warnings

Registering a License File with Provisioning Manager

Step1  Copy the license file to the Provisioning Manager server, in the folder <Install Directory>\license.

The system validates the license file and updates the license. The updated licensing information appears
on the Licensing Status Information page.

Step2  The license should automatically take effect in a few minutes. If it does not, select System
Administration > License Information.

Step3  Click PERFORM AUDIT. You will see the phones that you are licensed to update.

Step4  If you purchased more than one license, repeat Step 1 to install each additional license.

Provisioning Manager provides a licensing warning mechanism. A licensing warning icon ( /i) appears
in the top right corner of the Provisioning Manager page when one of the following occurs:

¢ A license file does not exist or cannot be read.

¢ One or more features have reached or exceeded the limit specified in the licensing file.

e Entries for one or more features do not exist in the license file (this occurs only when the license file
is not generated correctly or if the file is manually edited).

Evaluation Version: Before Expiry

If you have installed the evaluation version of Provisioning Manager, you must obtain the license file
from Cisco.com if you want to continue to use the product after the 90-day evaluation period. For details,
see Licensing Process, page A-3.

If you go past the 90-day evaluation period, you will see a licensing warning icon (/i) in the top right
corner of Provisioning Manager. You can view the expiry date on the Licensing Information page.

Purchased Version: Phone Limit Exceeded

If you have a restricted license, Provisioning Manager displays the information on which of the phones
have exceeded the limit on the Licensing Information page (see Verifying Provisioning Manager License
Status, page A-1). You will not be able to add more phones.

If you go past the phone phone limit for your license, you will see a licensing warning icon (/i) in the
top right corner of Provisioning Manager.
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