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Preface

This manual describes Cisco Unified Provisioning Manager (Provisioning Manager) and provides 
instructions for using and administering it.

Audience
The audience for this document includes network administrators and operators who monitor, maintain, 
and configure the status of the IP telephony systems and applications.

Conventions
This document uses the following conventions:

Note Means reader take note. Notes contain helpful suggestions or references to material not covered in the 
publication. 

Caution Means reader be careful. In this situation, you might do something that could result in equipment 
damage or loss of data.

Item Convention

Commands and keywords boldface font

Variables for which you supply values italic font

Displayed session and system information screen font

Information you enter boldface screen font

Variables you enter italic screen font

Menu items and button names boldface font

Selecting a menu item in paragraphs Option > Network Preferences

Selecting a menu item in tables Option > Network Preferences
v
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Preface
Product Documentation

Note We sometimes update the printed and electronic documentation after original publication. Therefore, 
you should also review the documentation on Cisco.com for any updates.

Table 1 describes the product documentation that is available.

Obtaining Documentation and Submitting a Service Request
For information on obtaining documentation, submitting a service request, and gathering additional 
information, see the monthly What’s New in Cisco Product Documentation, which also lists all new and 
revised Cisco technical documentation, at:

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html

Subscribe to the What’s New in Cisco Product Documentation as a Really Simple Syndication (RSS) feed 
and set content to be delivered directly to your desktop using a reader application. The RSS feeds are a free 
service and Cisco currently supports RSS version 2.0. 

Table 1 Product Documentation 

Document Title Available Formats

Supported Devices Table for Cisco Unified 
Provisioning Manager 1.3.1

On Cisco.com at the following URL: 

http://www.cisco.com/en/US/products/ps7125/products_device_sup
port_tables_list.html

Release Notes for Cisco Unified Provisioning 
Manager 1.3.1

 • In PDF on the product CD-ROM

 • On Cisco.com at the following URL: 
http://www.cisco.com/en/US/products/ps7125/prod_release_no
tes_list.html

Installation Guide for Cisco Unified Provisioning 
Manager 1.3.1

 • In PDF on the product CD-ROM

 • On Cisco.com at the following URL: 
http://www.cisco.com/en/US/products/ps7125/prod_installation
_guides_list.html

User Guide for Cisco Unified Provisioning 
Manager 1.3.1

 • In PDF on the product CD-ROM

 • On Cisco.com at the following URL: 
http://www.cisco.com/en/US/products/ps7125/products_user_g
uide_list.html
vi
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Preface
Open Source License Acknowledgements
The following acknowledgements pertain to this software license.

OpenSSL/OpenSSL Project
This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit 
(http://www.openssl.org/).

This product includes cryptographic software written by Eric Young (eay@cryptsoft.com).

This product includes software written by Tim Hudson (tjh@cryptsoft.com).

License Issues

The OpenSSL toolkit stays under a dual license, i.e. both the conditions of the OpenSSL License and the 
original SSLeay license apply to the toolkit. See below for the actual license texts. Actually both licenses 
are BSD-style Open Source licenses. In case of any license issues related to OpenSSL please contact 
openssl-core@openssl.org.

OpenSSL License:

© 1998-1999 The OpenSSL Project. All rights reserved.

Redistribution and use in source and binary forms, with or without modification, are permitted provided 
that the following conditions are met:

1. Redistributions of source code must retain the copyright notice, this list of conditions and the 
following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions, and 
the following disclaimer in the documentation and/or other materials provided with the distribution.

3. All advertising materials mentioning features or use of this software must display the following 
acknowledgment: “This product includes software developed by the OpenSSL Project for use in the 
OpenSSL Toolkit. (http://www.openssl.org/)”

4. The names “OpenSSL Toolkit” and “OpenSSL Project” must not be used to endorse or promote 
products derived from this software without prior written permission. For written permission, please 
contact openssl-core@openssl.org.

5. Products derived from this software may not be called “OpenSSL” nor may “OpenSSL” appear in 
their names without prior written permission of the OpenSSL Project.

6. Redistributions of any form whatsoever must retain the following acknowledgment:

“This product includes software developed by the OpenSSL Project for use in the OpenSSL Toolkit 
(http://www.openssl.org/)”

THIS SOFTWARE IS PROVIDED BY THE OpenSSL PROJECT “AS IS”' AND ANY EXPRESSED OR 
IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES 
OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN 
NO EVENT SHALL THE OpenSSL PROJECT OR ITS CONTRIBUTORS BE LIABLE FOR ANY 
DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES 
(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR 
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER 
CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT 
vii
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Preface
LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY 
OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH 
DAMAGE.

This product includes cryptographic software written by Eric Young (eay@cryptsoft.com). This product 
includes software written by Tim Hudson (tjh@cryptsoft.com).

Original SSLeay License:

© 1995-1998 Eric Young (eay@cryptsoft.com). All rights reserved.

This package is an SSL implementation written by Eric Young (eay@cryptsoft.com).

The implementation was written so as to conform with Netscapes SSL.

This library is free for commercial and non-commercial use as long as the following conditions are 
adhered to. The following conditions apply to all code found in this distribution, be it the RC4, RSA, 
lhash, DES, etc., code; not just the SSL code. The SSL documentation included with this distribution is 
covered by the same copyright terms except that the holder is Tim Hudson (tjh@cryptsoft.com).

Copyright remains Eric Young’s, and as such any Copyright notices in the code are not to be removed. 
If this package is used in a product, Eric Young should be given attribution as the author of the parts of 
the library used. This can be in the form of a textual message at program startup or in documentation 
(online or textual) provided with the package.

Redistribution and use in source and binary forms, with or without modification, are permitted provided 
that the following conditions are met:

1. Redistributions of source code must retain the copyright notice, this list of conditions and the 
following disclaimer.

2. Redistributions in binary form must reproduce the above copyright notice, this list of conditions and 
the following disclaimer in the documentation and/or other materials provided with the distribution.

3. All advertising materials mentioning features or use of this software must display the following 
acknowledgement:

“This product includes cryptographic software written by Eric Young (eay@cryptsoft.com)”.

The word ‘cryptographic’ can be left out if the routines from the library being used are not 
cryptography-related.

4. If you include any Windows specific code (or a derivative thereof) from the apps directory 
(application code) you must include an acknowledgement: “This product includes software written 
by Tim Hudson (tjh@cryptsoft.com)”.

THIS SOFTWARE IS PROVIDED BY ERIC YOUNG “AS IS” AND ANY EXPRESS OR IMPLIED 
WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF 
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO 
EVENT SHALL THE AUTHOR OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, 
INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT 
NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, 
DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY 
THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT 
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF 
THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

The license and distribution terms for any publicly available version or derivative of this code cannot be 
changed. i.e. this code cannot simply be copied and put under another distribution license [including the 
GNU Public License].
viii
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C H A P T E R 1

Prerequisites

This chapter describes the prerequisites for installing Cisco Unified Provisioning Manager on a 
Windows system. It includes:

 • Product Overview, page 1-1

 • New Features in Cisco Unified Provisioning Manager 1.3.1, page 1-2

 • Server Requirements, page 1-3

 • Client Requirements, page 1-6

Product Overview
Cisco Unified Provisioning Manager (Provisioning Manager) is a provisioning tool for Cisco Unified 
Communications initial deployments and implementations. Provisioning Manager manages IP 
communication services in an integrated IP telephony, voicemail, and unified messaging environment 
that includes Cisco Unified Communications Manager, Cisco Unified Communications Manager 
Express, Cisco Unity, Cisco Unity Express, and Cisco Unity Connection systems.

Provisioning Manager is a product from the Cisco Unified Communications Management Suite. It 
provides provisioning for Cisco Unified Communications initial deployments and implementations, and 
then remains deployed to provide ongoing operational provisioning and activation services for individual 
subscriber changes. Provisioning Manager provides a single, consolidated view of subscribers across the 
organization. It provides a set of business-level management abstractions, which are policy-driven 
through the use of automation, for managing subscriber services across the Cisco Unified 
Communications infrastructure.

A template capability permits defining standard configurations that can be reused for new sites or 
location deployments. Batch provisioning permits the rollout of large numbers of subscribers at the same 
time.

Administrators can configure policy at various levels to determine who can do delegated management, 
for whom that delegation applies, and how business-level services apply to Cisco Unified 
Communications voice and messaging applications and which types of end users (subscribers) are 
permitted to order which standard services. Through the use of this policy and standard configuration 
approach, provisioning and activating subscriber services is greatly simplified, while retaining the 
overall ability to manage and provide services that make use of the underlying Cisco Unified 
Communications applications.
1-1
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Chapter 1      Prerequisites
New Features in Cisco Unified Provisioning Manager 1.3.1
New Features in Cisco Unified Provisioning Manager 1.3.1
Cisco Unified Provisioning Manager adds the following:

 • Set-only Provisioning Attributes—Provisioning attributes that can only be set. You can provision 
their settings, but they are not stored once they are set, and they are not retrieved from the Call 
Processor during a synchronization. 

Following is a list of the new set-only provisioning attributes:

 – BLF Directed Call Park

 – Device Mobility Mode

 – DND Incoming Call Alert 

 – DND Option

 – Do Not Disturb

 – Call Pickup Group Audio Alert Setting (Phone Active)

 – Call Pickup Group Audio Alert Setting (Phone Idle)

 – Ignore Presentation Indicators (Internal Calls Only)

 – Presence Group 

 – Primary Phone

 – Rerouting Calling Search Space

 – Secondary Calling Search Space for Forward All

 – SIP Profile 

 – Subscribe Calling Search Space

 • The following provisioning attributes: 

 – Busy Lampfield Info

 – Enable ResyncMWI

 • The following provisioning attributes for Extension Mobility Line:

 – Alerting Name

 – ASCII Alerting Name

 – ASCII Display (Internal Caller ID)

 – ASCII Line Text Label

 – Line Groups

 • The following business rules: 

 – AssociateUsersByDevicePool

 – AssociateUsersByLocation

 • Enhancements to the Call Pickup Group configuration template.

 • Ability to unlock voicemail accounts.

 • Ability for users to have privilages for multiple Domains.

 • Ability to add external AAA servers (LDAP servers) for user authentication.

 • Support for third-party SIP phones.
1-2
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Chapter 1      Prerequisites
Server Requirements
 • Support for Cisco Unified Communications Manager 6.1(3).

 • Support for Cisco Unified Communications Manager Express 7.0(1).

 • Support for Cisco Unity Express 7.0.1.

 • Support for Third-party SIP Device (Advanced and Basic).

 • Support for VMware.

Server Requirements
Table 1-1 lists the minimum server system requirements for different levels of performance and scale. 

Table 1-1 Server System Requirements (Standalone) 

Requirement Type Minimum Requirements

System Processor Server platform with one of the following processor configurations:

 • (Up to 1,000 phones) Single Intel Pentium 4, 3.0 GHz. 

 • (Up to 10,000 phones) Dual-core Intel Pentium 4, 3.0 GHz. 

 • (Up to 30,000 phones) Two-system deployment, with the following configuration:

 – Two Intel Xeon processors, 3.0 GHz, for the Web and application server.

 – Two Intel Xeon processors, 3.0 GHz, for the database.

Note If you will have more than five operators placing concurrent orders,  
you should use two dual-core Intel Xeon processors.

Other System Hardware  • Color monitor.

 • CD-ROM drive.

 • 100 Mbps NIC.

Memory (RAM)1

1. Provisioning Manager will not install either the medium (up to 10,000 phones) or the large (up to 30,000 phones) configuration if Windows 2003 reports 
that less than 4 GB of memory is installed. There is a known issue with Windows 2003 when working with certain hardware. Even though 4 GB of memory 
is installed on the system, Windows 2003 reports that there is less than 4 GB of memory installed. For more details, see 
http://msdn2.microsoft.com/en-us/library/ms791485.aspx.

 • 2 GB—Up to 1000 phones.

 • 4 GB—Up to 10,000 phones.

 • 4 GB on each system—Up to 30,000 phones.

Swap File Space Same as RAM, with a maximum size of twice that of RAM. 

Available Drive Space2 

2. SAS or SCSI drives in a RAID configuration are recommended for servers supporting 1000 to 10,000 phones. SAS drives in a RAID (1+0) configuration 
are recommended for servers supporting over 10,000 phones.

 • 30 GB—Up to 1000 phones.

 • 60 GB—Up to 10,000 phones.

 • Two-system configuration (up to 30,000 phones); requires the following:

 – 30 GB on the Web and application system.

 – 80 GB on the database system.

System Software3 Windows Server 2003 with Service Pack 1 or Service Pack 2, Standard or Enterprise 
Edition. 
1-3
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Chapter 1      Prerequisites
Server Requirements
3. You must install Provisioning Manager on a dedicated system. Do not install Provisioning Manager on a Primary Domain Controller (PDC) or Backup 
Domain Controller (BDC). 

Coresident Guidelines
Operations Manager, Service Monitor, Service Statistics Manager, and Provisioning Manager can be coresident with up to 
10,000 phones. Table 1-2 provides the minimum requirements for a coresident installation.

Table 1-2 Installation Server System Minimum Requirements for Coresidence 

Requirement 
Type Minimum Requirements for Coresident Deployment of up to 10,000 Phones

Processor Two-way quad-core Xeon X5365 processors at 3 GHz.

Note A two-way quad-core processor is a system that contains 2 physical processors—each of which is 
a quad-core processor—effectively containing 8 (2x4) logical CPUs. 

Memory (RAM) 16 GB (PAE enabled)

Page File Space1 32 GB.

Disk Space  • 320 GB recommended. (Minimum four SAS drivers.) 

For optimal I/O throughput, you must have a Battery Backed Write Cache (BBWC); we also 
recommend two I/O controllers (with two disks on each controller). 

 • NTFS file system (required for secure operation).

 • At least 16 MB in Windows temporary directory (%TEMP%).

Hardware  • Color monitor. ((For optimum viewing on the Operations Manager display, Cisco recommends that 
you use the highest native resolution supported by the client PC and monitor. A large, high resolution 
display will also allow for less scrolling through information presented and increase operator 
efficiency. The minimum resolution recommended is 1024 x 768 on a 17” monitor.)

 • CD-ROM drive.

 • Support for one or two 1-GB NICs (one is required, and the second is for failover support; both NIC 
cards must have the same IP address).
1-4
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Chapter 1      Prerequisites
Server Requirements
 • Install each application along with its databases on a separate drive. You can install one of the 
applications on the system drive (C:), but, if you have a sufficient number of drives, we recommend 
that none of the applications be installed on the system drive. 

 • Install applications in this order (recommended, not required):

1. Operations Manager (includes Service Monitor)

2. Service Statistics Manager

3. Provisioning Manager (in Advanced mode)

Note If Operations Manager and Provisioning Manager are using the same port number for SSL, 
you must change the port used by SSL for one of the applications (see Changing the Port 
Used By SSL, page 2-4.

Software One of these:

 • Windows Server 2003 Enterprise Edition SP2 (32-version)

 • Windows Server 2003 R2 Enterprise Edition SP2 (32-version)

Note The system that you use for your Operations Manager server should meet all the security 
guidelines that Microsoft recommends for Windows 2003 Server. See the Microsoft website 
for security guidance: 
http://www.microsoft.com/technet/security/prodtech/WindowsServer2003.mspx 
(This website is Copyright © 2009, Microsoft Corporation.)

 • ODBC Driver Manager2 3.5.10 or later.

Note • If you are going to use Cisco Unified Service Monitor, configure the server to 
use Network Time Protocol (NTP) to synchronize with the time server that is 
used by Cisco Unified Communications Managers in your network. See 
Installation Guide for Operations Manager 2.2.

 • Windows Terminal Services is supported in Remote Administration mode only. 
Use of Windows Terminal Services or Remote Desktop and Virtual Network 
Computing (VNC) to remotely control the server is not recommended for 
performing day-to-day operations (for example, running reports, keeping 
dashboards and Service Level View open, and so on). For more information, see 
Installation Guide for Operations Manager 2.2.

1. When configuring the page file, you should set both the minimum and maximum file size parameters to 32 GB. This will ensure that Windows creates a 
32-GB page file.

2. To verify the version of ODBC Driver Manager, from the Windows desktop, select Start > Settings > Control Panel > Administrative Tools > Data 
Sources (ODBC). Select the About tab. If necessary, install Microsoft Data Access Component (MDAC) 2.5 or later. 

Table 1-2 Installation Server System Minimum Requirements for Coresidence (continued)

Requirement 
Type Minimum Requirements for Coresident Deployment of up to 10,000 Phones
1-5
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Chapter 1      Prerequisites
Client Requirements
Client Requirements
Table 1-3 lists the minimum client system requirements for installing Provisioning Manager.

IPv6-Aware Support in Provisioning Manager
Provisioning Manager is IPv6 aware. IPv6 aware is defined as containing IPv6 functional information, 
but using IPv4 for transport.

As an IPv6-aware application, Provisioning Manager continues to communicate with Cisco Unified 
Communications Manager devices through an IPv4 link. 

The following also apply to IPv6-aware support in Provisioning Manager: 

 • In the Call Processor Configuration page, you can only enter an IPv4 IP address. If you enter an IPv6 
address, an error message appears.

Table 1-3 Client System Requirements 

Requirement Type Minimum Requirements

System Hardware  • Any PC or server platform with a Pentium 4 processor greater than 1.0 GHz.

 • Color monitor with video card set to 24 bits color depth.

 • Screen resolution of 1024 x 768 dpi.

Note Not every LCD projector or monitor provides a clear display at the minimum resolution. 
On LCD projectors and monitors, dot pitch impacts the readability of the screen.

System Software  • One of the following:

 – Windows XP with Service Pack 2. 

 – Windows Server 2003 with Service Pack 1 or Service Pack 2, Standard or Enterprise Edition.

 • One of the following

 – Internet Explorer 6.0 with Service Pack 2 or 7.0.

 – Mozilla 1.7.x.

 – Firefox 2.0

Memory (RAM) 1 GB recommended.

Environment Clients must be able to access Provisioning Manager:

 • From outside a firewall—Refer to the documentation for your firewall for information on how to 
configure client access. 

 • Across a Virtual Private Network (VPN)—The VPN tunnel should connect the client and a VPN 
router or similar device. See Ports that Provisioning Manager Uses, page 2-11.
1-6
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Chapter 1      Prerequisites
VMware Support in Provisioning Manager
 • Configuring an IP phone for IPv6-only does not affect Provisioning Manager functionality.

 • The support for IPv6-aware functions does not affect Provisioning Manager support for Cisco 
Unified Communications Manager Express, Cisco Unity Express, Cisco Unity, or Cisco Unity 
Connection devices. 

VMware Support in Provisioning Manager
Provisioning Manager supports VMware environments. For Provisioning Manager to meet its minimum 
system requirements (Table 1-1) in a virtual environment, Provisioning Manager must have the same 
resources available to it inside the virtual environment that it does for a standard (non-virtual) 
installation. When determining the performance of Provisioning Manager in your virtual setup, you must 
take into account that the VMware instance will use up system resources that would normally be 
available to Provisioning Manager in a standard installation. 

Provisioning Manager has been tested on VMware ESX Server 3i version 3.5 and VMware ESX 
Server 3.5.

When setting up Provisioning Manager in a VMware environment, keep in mind the following 
guidelines:

 • To enable you to use Provisioning Manager in a VMware environment, you must configure your 
virtual machine with a static MAC address. If you try to install Provisioning Manager on a virtual 
machine that does not have a static MAC address, a message appears stating that a static MAC 
address is required.

 • Resources must be dedicated to the virtual machines, resources cannot be shared.

 • For better performance in a distributed deployment, it is recommended that you install the 
application and the database on the same physical server.

 • Due to the additional resource requirements of virtualization, it is recommended that you do not 
have more than five concurrent client (browser) logins to Provisioning Manager running at one time.

Note Using VMWare snapshots in a product environment will drastically degrade performance and may even 
impact stability. You should not have any snapshots on a production system.

To set up a static MAC address, do the following:

Step 1 Power down the virtual machine.

Step 2 In the Inventory Panel, select the virtual machine.

Step 3 Click the Summary tab and then click Edit Settings.

Step 4 In the Hardware list, select Network Adapter.

Step 5 For MAC address, select Manual.

Step 6 Change the current MAC address of the virtual machine to a static MAC address in the following range: 
00:50:56:00:00:00 to 00:50:56:3F:FF:FF.

Step 7 Click OK.
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C H A P T E R 2

Installing, Upgrading and Uninstalling Cisco 
Unified Provisioning Manager

This chapter describes installing Cisco Unified Provisioning Manager.

It includes:

 • Preparing to Install Provisioning Manager, page 2-1

 • Installing Provisioning Manager, page 2-13

 • Upgrading Provisioning Manager 1.3 to Provisioning Manager 1.3.1, page 2-17

 • Uninstalling Provisioning Manager, page 2-26

Preparing to Install Provisioning Manager
The information in this section helps you to deploy Provisioning Manager in your network. Do the 
following before you install Provisioning Manager:

 • Make sure that hardware and software requirements for the server are met. (See Server 
Requirements, page 1-3.)

 • Preparing the Provisioning Manager server for installation. (See Preparing the Server, page 2-2.)

 • Configure end systems so that Provisioning Manager can obtain correct information from them. 
(Preparing End Systems, page 2-5.)

 • Determine whether your existing applications are already using ports that Provisioning Manager 
uses. (Existing applications should not use the ports that Provisioning Manager requires.) See Ports 
that Provisioning Manager Uses, page 2-11.

 • Gather information that you might need to provide during the Provisioning Manager installation. 
(See Gathering Information to Provide During Installation, page 2-12.)
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Preparing the Server
This section describes procedures that you may need to perform to prepare your server for installing 
Provisioning Manager on it.

Note The system that you use for your Provisioning Manager server should meet all the security guidelines 
that Microsoft recommends for Windows 2003 Server. See the Microsoft website for security guidance 
(http://www.microsoft.com/technet/security/prodtech/WindowsServer2003.mspx).

Enabling the Full 4 GB of RAM

Provisioning Manager will not install either the medium (up to 10,000 phones) or the large (up to 30,000 
phones) configuration if Windows 2003 reports that less than 4 GB of memory is installed. There is a 
known issue with Windows 2003 when working with certain hardware. Even though 4 GB of memory is 
installed on the system, Windows 2003 reports that there is less than 4 GB of memory installed. For more 
details, see http://msdn2.microsoft.com/en-us/library/ms791485.aspx.

To enable all 4 GB of RAM on the system, use the following procedure: 

Step 1 On the Provisioning Manager system, in Windows right-click My Computer. 

Step 2 Select Properties.

Step 3 Select the Advanced tab.

Step 4 Under Startup and Recovery, click Settings.

Step 5 Click Edit. The boot.ini file opens.

Step 6 In the file, add "/PAE" in line starting with "multi(0)disk(0)rdisk(0)partition(1)\WINDOWS=..." 

Step 7 Restart the system.

Enabling SSL on the Provisioning Manager Server

Secure Socket Layer (SSL) is an application-level protocol that enables secure transactions of data 
through privacy, authentication, and data integrity. It relies upon certificates, public keys, and private 
keys. 

Provisioning Manager supports SSL between clients and the server. When you start Provisioning 
Manager, the login page always opens in secure mode, providing secure access between the client 
browser and the Provisioning Manager server. In secure mode, SSL is used to encrypt the transmission 
channel between the browser and the server. To use secure mode throughout Provisioning Manager, you 
must enable SSL. 

To enable SSL, you must install Win32 OpenSSL Light and then configure the Apache server.

Installing OpenSSL and Generating a Certificate

Step 1 On the Provisioning Manager system, install the latest version of Win32 OpenSSL v0.9.8 Light in 
C:\OpenSSL. You can find Win32 OpenSSL Light at 
http://www.slproweb.com/products/Win32OpenSSL.html (Provisioning Manager was last tested 
with v9.8i).
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Note If you receive an error message stating that Visual C++ 2008 Redistributables are missing, you 
must download and install the them before proceeding. They are available at the same location 
as Win32 OpenSSL Light (http://www.slproweb.com/products/Win32OpenSSL.html).

When installing Win32 OpenSSL, do the following:

 • In the Copy OpenSSL DLLs to dialog box, select the OpenSSL binaries (\bin) directory. 

 • After the Win32 OpenSSL installation is complete, copy the libraries ssleay32.dll and libeay32.dll 
(located in the C:\OpenSSL\bin folder) to the C:\CUPM\httpd\bin folder (if you accepted C:\CUPM 
as the default location for Provisioning Manager during installation, and if you accepted 
C:\OpenSSL as the location for Win32 OpenSSL during installation).

Step 2 In a command prompt, go to <Install directory>\httpd\conf. 

Step 3 In the command prompt, run the following command:

c:\OpenSSL\bin\openssl.exe genrsa -des3 -out server.key 1024

Step 4 A prompt appears, asking for a passphrase. Enter a phrase.

Step 5 Run the following command:

c:\OpenSSL\bin\openssl.exe req -new -x509 -days 365 -key server.key -out server.crt

Note This command assumes the certificate is valid for 365 days. If you need a longer license, enter 
a higher number of days.

Step 6 At the prompt, enter the passphrase you entered previously. Enter it again.

Step 7 Enter the information for the Distinguished Name fields for the certificate.

Step 8 Run the following command:

copy server.key server.key.orig 

Step 9 Run the following command:

c:\OpenSSL\bin\openssl.exe rsa -in server.key.orig -out server.key

Step 10 Enter the passphrase you used previously. This removes the need to enter the passphrase every time you 
start Provisioning Manager.

Configuring the Apache Server

Step 1 On the Provisioning Manager system, back up the httpd.conf file (located at <install 
directory>/httpd/conf).

Step 2 In the httpd.conf file, uncomment the line LoadModule ssl_module modules/mod_ssl.so.

Note When editing the httpd.conf file, be aware that some text editors may overwrite the file format. 
If this happens, an error will occur when you restart the Apache2 Windows Service. If you are 
using Notepad, you can avoid this problem by turning off word wrap in Notepad before opening 
the file. 
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Step 3 If your original version of Provisioning Manager was earlier than 1.2 and you have continually upgraded 
through the versions, you may need to update the ssl.conf file. Perform a search for @DOCROOT@ in 
<install directory>/httpd/conf/ssl.conf.

 • If the search does not find @DOCROOT@, you do not need to make any updates. Go to step Step 4.

 • If the search finds @DOCROOT@ (it should appear in two places), set @DOCROOT@ to <install 
directory>/httpd/htdocs.

Step 4 Restart the Apache2 Windows Service.

Now you can log into Provisioning Manager using HTTPS. 

Note When using SSL, remember the following: 

 • The URL for logging in uses HTTPS (for example, https://<host name or IP address>/cupm/Login).

 • If you upgraded from Provisioning Manager 1.2, the ssl.conf file may be read only. Remove the read 
only property using Windows Explorer.

 • By default, port 443 is configured in the ssl.conf file. If you need to change the port number, in the 
ssl.conf file, change the line Listen 443 to the desired port.

 • If you want to exclusively run only HTTPS, you must disable the nonsecure HTTP by commenting 
out the line Listen 80 in the C:\CUPM\httpd\conf\httpd.conf file, and then restart the Apache server.

Changing the Port Used By SSL

If Provisioning Manager is installed on a coresident system (with Operations Manager), you must change 
the port used by SSL of one of the applications. This section describes how to change the port used for 
SSL by Provisioning Manager.

Step 1 On the Provisioning Manager system, open the ssl.conf file (located at <install directory>/httpd/conf).

Step 2 Change the port number in the following lines to a different number (46443 is recommended):

 • Listen 443

 • VirtualHost _default_:443

Step 3 Save the changes and close the file.

Note After you change this port number, when you access Provisioning Manager you must enter the new port 
number. For example, http://<hostname> :46443.
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Additional Server Software
The software applications listed in this section have undergone interoperability testing with Provisioning 
Manager. These applications are optional, they are not required to run Provisioning Manager on your 
system.

 • Cisco Security Agent 5.0 and 6.0—Provisioning Manager has been tested to work with Cisco 
Security Agent, however support is not provided. 

Note Cisco Security Agent must be disabled during installation of Provisioning Manager. 

 • Third-party virus protection software: 

 – McAfee Virus Scan Enterprise 8.0 

For McAfee Enterprise VirusScan 8.0, you must have patch version 11 installed. Install the 
McAfee VirusScan Enterprise 8.0 Patch Version 11 before installing Provisioning Manager on 
the system.

Note You should exclude the following from virus scanning:

 • The pgsql folder (if you selected the default location during installation, it is C:\CUPM\pgsql).

 • The postmaster.exe file (located in the CUPM\pgsql\bin folder).

Preparing End Systems
In Provisioning Manager, the physical resources (end systems that deliver voice and messaging services) 
are modeled as Processors. For example, a Cisco Unified Communications Manager or Cisco Unified 
Communications Manager Express system is modeled as a Call Processor and a Cisco Unity, Cisco Unity 
Express, or Cisco Unity Connection voicemail/unified messaging system is modeled as a Unified 
Message Processor. 

Using Provisioning Manager, an administrator creates and configures these various processors. After the 
processors have been configured, all configuration and interaction with the end systems is handled by 
Provisioning Manager.

Some minimal configuration is required on the end systems before you can use them with Provisioning 
Manager. This section describes the preconfiguration steps required for Cisco Unified Communications 
Manager, Cisco Unified Communications Manager Express, Cisco Unity systems, Cisco Unity 
Connection, and Cisco Unity Express. 

Cisco Unified Communications Manager Preconfiguration Dependencies

The Cisco Unified Communications Manager is the software-based, call-processing component of the 
Cisco IP telephony solution, and is part of Cisco Architecture for Voice, Video and Integrated Data 
(AVVID). 

Additional data, voice, and video services such as unified messaging, multimedia conferencing, 
collaborative contact centers, and interactive multimedia response systems interact with the IP telephony 
solution through Cisco Communications Manager’s open telephony application programming interface 
(API). Cisco Communications Manager is installed on the Cisco Media Convergence Server (MCS). 
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No specific preconfiguration is generally required on the Cisco Unified Communications Manager for 
Provisioning Manager. However, the following conditions should already have been met during a normal 
installation or upgrade, and are noted here as installation dependencies for creating a Call Processor in 
Provisioning Manager:

 • Install Cisco Unified Communications Manager.

 • If Cisco Unity is used in this configuration, configure the Cisco Unified Communications Manager 
voicemail ports.

 • Create a user and password with administrator privileges that can be used by Provisioning Manager 
to access Cisco Unified Communications Manager. The requirements of the user and password vary 
depending on whether multilevel administration access (MLA) is enabled (see Table 2-1).

Note All interactions with Cisco Unified Communications Manager and Provisioning Manager are through 
the AVVID XML Layer APIs (AXL/SOAP).

Determining the Media Server Account to Use for Cisco Unified Communications Manager Access 

To enable Provisioning Manager to access a Cisco Unified Communications Manager, you must supply 
the username and password for an account on the media server. The account to use depends upon the 
Cisco Unified Communications Manager version and might also depend on whether MLA is enabled for 
the Cisco Unified Communications Manager. Table 2-1 lists the options.

Cisco Unified Communications Manager Express Preconfiguration Dependencies

Cisco Unified Communications Manager Express is a solution, embedded in Cisco IOS Software, that 
provides call processing for Cisco Unified IP Phones. 

Like Cisco Unified Communications Manager, Cisco Unified Communications Manager Express is 
modeled in Provisioning Manager as a Call Processor. The only difference from an administrative aspect 
is that it is represented by a different type of Call Processor. 

Table 2-1 Accounts Required to Access Cisco Unified Communications Manager 

Cisco Unified 
Communications 
Manager Version on 
Media Server 

MLA Enabled  
or Disabled for 
Cisco Unified 
Communications 
Manager Required Account

4.x Enabled Multilevel administration access account with full 
access to the Standard Serviceability Functional 
Group.

Disabled Valid Windows 2000 administrator account on the 
media server. 

5.x, 6.x, or 7.x N/A A Unified Communications Manager user who is 
assigned a role with the privilege to use the AXL 
Database API resource in the Cisco Call Manager 
AXL Database application. 

Standard AXL API Access is one of the predefined 
roles in Unified Communications Manager that has 
this privilege.
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Provisioning Manager requires that the Cisco Unified Communications Manager Express be installed on 
a supported platform with the appropriate Cisco IOS Software version and Cisco Unified 
Communications Manager Express load. 

Before you can create a Call Processor based on a Cisco Unified Communications Manager Express in 
Provisioning Manager, you must do the following:

 • Disable the auto-allocation of directory numbers. Do this through the Cisco IOS interface (see 
Disabling the Auto-Allocation of Directory Numbers and Ephone Auto-Registration, page 2-7).

 • Disable the ephone auto-registration. You must do this through for Cisco Unified Communications 
Manager Express 4.0 or later (see Disabling the Auto-Allocation of Directory Numbers and Ephone 
Auto-Registration, page 2-7).

 • If you have changed the Rivest, Shamir, and Adelman (RSA) key pair for Secure Shell Version 2 (on 
the router where Cisco Unified Communications Manager Express resides) to a length less than 512 
bits, you must reconfigure the RSA key back to a length equal to or greater than 512 bits. For 
information on configuring the RSA keys in Secure Shell Version 2, see your router’s 
documentation.

Disabling the Auto-Allocation of Directory Numbers and Ephone Auto-Registration

Do the following configurations through the Cisco IOS interface.

Step 1 First, verify that auto-allocation is enabled.

$ telnet 172.19.50.247
Trying 172.19.50.247...
Connected to 172.19.50.247.
Escape character is '^]'.

User Access Verification

Password:

CCME-1>enable
Password:
CCME-1#show telephony
CONFIG (Version=3.0)
=====================
Cisco Communications Manager Express
ip source-address 172.19.50.247 port 2000
max-ephones 24
max-dn 100
max-conferences 4
max-redirect 5
time-format 12
date-format mm-dd-yy
keepalive 30
timeout interdigit 10
timeout busy 10
timeout ringing 180
web admin system name root  password cisco
web admin customer name cisco  password cisco
edit DN through Web:  enabled.
edit TIME through web:  enabled.
Log (table parameters):
     max-size: 150
     retain-timer: 15
    (password): abcd
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create cnf-files version-stamp 7960 Jan 15 2004 16:48:05
auto assign 1 to 100 type 7960 cfw 5001 timeout 30
local directory service: enabled.
xml schema http://gkar.cisco.com/schema/axlsoap.xsd

In this case, auto-allocation is on, as shown by the auto assign line. 

Step 2 To disable auto-allocation, run the following command at the enable prompt:

CCME-1#config term
Enter configuration commands, one per line.  End with CNTL/Z.
CCME-1(config)#telephony-service
CCME-1(config-telephony)#no auto assign 1 to 100 type 7960 cfw 5001 timeout 30
CCME-1(config-telephony)#no auto-reg-ephone

Note The no auto-reg-ephone command is required for Cisco Unified Communications Manager 
Express 4.0 or later.

CCME-1(config-telephony)#exit
CCME-1(config)#exit
CCME-1#show telephony

Step 3 To verify that the change has taken effect, run another show telephony command. The auto assign line 
should no longer appear. 

Step 4 Run a write memory command, which will write the changes out to the system’s nonvolatile memory 
in case of a reboot.

How Provisioning Manager Manages Communications Manager Express

Cisco Unified Communications Manager Express uses two main commands to provision phones for end 
subscribers:

 • telephony ephone-dn—Manages directory numbers.

 • telephony ephone—Assigns directory numbers to lines on one or more phones.

Both commands allow subscriber information to be associated to the directory number or the line. 
Provisioning Manager uses these native abilities in Cisco Unified Communications Manager Express to 
store and synchronize subscriber information.

Provisioning Manager is able to synchronize back the phones, lines, directory numbers, and subscriber 
information from an existing Cisco Unified Communications Manager Express. Depending on how the 
subscriber information was used in the telephony ephone and telephony ephone-dn commands, 
Provisioning Manager is able to fully construct a user account for that subscriber. Provisioning Manager 
supports shared lines and directory numbers while doing this.

When provisioning, Provisioning Manager uses the description command in the ephone configlet to 
hold the subscriber name and department information. Provisioning Manager also uses the name 
command in the ephone-dn configlet to hold the subscriber's first and last names.

Note The Cisco Unified Communications Manager Express ephone-dn name field is limited to 30 characters. 
If the subscriber’s first and last names (combined) exceed that limit, you may get an error.
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Cisco Unity and Cisco Unity Connection System Preconfiguration Dependencies

Note Provisioning Manager does not support Cisco Unity when it is configured with multiple Cisco Unified 
Communications Manager clusters.

Before you can create a Unified Message Processor based on Cisco Unity in Provisioning Manager, you 
must do the following:

 • Install and configure the message store using Microsoft Exchange 2000 or 2003. (Required for Cisco 
Unity only.)

 • Configure an integration with one corresponding Cisco Unified Communications Manager.

 • Create a SQL Server user and password that can be used by Provisioning Manager to access the SQL 
Server database on Cisco Unity. The SQL Server user requires access to both the Cisco Unity and 
master databases. See Creating an SQL Server User and Password for Cisco Unity, page 2-9. 
(Required for Cisco Unity only.)

 • Verify the TCP/IP port used by Cisco Unity. This port number is required when you create a Unified 
Message Processor. (Required for Cisco Unity only.)

 • Define Class of Service and Subscriber templates.

 • Configure IMAP in Cisco Unity Connection. This is required so that Provisioning Manager can 
provision email and Unified Messaging Services in Cisco Unity Connection. (Required for Cisco 
Unity Connection only.)

Note To configure IMAP: on the Cisco Unity Connection system, go to System Settings > External 
Services > Add New, and fill in all the fields required to add external services.

Creating an SQL Server User and Password for Cisco Unity

Step 1 On the Cisco Unity system, select Start > SQL Server > Enterprise Manager. The Enterprise Manager 
window appears.

Step 2 In the navigation tree, select Microsoft SQL Servers > SQL Server Group > (local) (Windows NT).

Step 3 Right-click (local) (Windows NT) and select Properties. The SQL Server Properties (Configure) 
window appears.

Step 4 Click the Security tab. 

Step 5 Under Authentication, select SQL Server and Windows.

Step 6 In the navigation tree under (local) (Windows NT), select Security > Logins. 

Step 7 Create a new login. Do the following:

a. Right-click Logins. The SQL Server Login Properties - New Login window appears.

b. Enter a name for the login.

c. Select SQL Server Authentication.

d. Select UnityDb. 

e. Click the Database Access tab.

f. Select both the UnityDb and the master database.
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g. For both databases, select the following roles: db_owner, db_datareader, and db_datawriter.

h. Reboot the SQL server.

Verifying the TCP/IP Port Used by Cisco Unity

Step 1 On the Cisco Unity system, select Start > SQL Server > Enterprise Manager. The Enterprise Manager 
appears.

Step 2 From the menu, click Action. Then select Properties. The SQL Server Properties (Configure) dialog 
box appears.

Step 3 In the General tab, click Network Configuration. The SQL Server Network Utility window appears.

Step 4 Select TCP/IP, then click Properties.

Step 5 In the window that appears, the default TCP/IP port is displayed. You will need to know this port number 
when you create a Unified Message Processor.

Cisco Unity Express Preconfiguration Dependencies

Before you can create a Unified Message Processor based on Cisco Unity Express in Provisioning 
Manager, you must do the following:

 • If you have changed the RSA key pair for Secure Shell Version 2 (on the router where Cisco Unity 
Express resides) to a length less than 512 bits, you must reconfigure the RSA key back to a length 
equal to or greater than 512 bits. For information on configuring the RSA keys in Secure Shell 
Version 2, see your router’s documentation.

 • Determine the Service Engine Interface number for Cisco Unity Express. The Service Engine 
Interface number is required when adding a Cisco Unity Express to Provisioning Manager (see 
Determining the Service Engine Interface Number for Cisco Unity Express, page 2-10). 

Determining the Service Engine Interface Number for Cisco Unity Express

The Service Engine Interface number is located on the router that hosts Cisco Unity Express.

Step 1 Log in to the router that hosts Cisco Unity Express.

Step 2 Run the command show running-config.

In the resulting output, look for the following:

Interface Service-Engine 2/0

In this example, 2/0 is the Service Engine Interface number.
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Interfaces that Provisioning Manager Uses
Table 2-2 lists the interfaces that Provisioning Manager uses to communicate with the end systems.

Ports that Provisioning Manager Uses
Before installing Provisioning Manager, make sure that the appropriate ports are available.

Table 2-3 lists the ports that need to be open on the Provisioning Manager system. Table 2-4 lists the 
ports that need to be open on the firewall between Provisioning Manager and the device.

Table 2-2 Interfaces that Provisioning Manager Uses 

Call Processor/ Unified Message Processor Interface

Cisco Unified Communications Manager AXL and SOAP

Cisco Unified Communications Manager Express CLI over Telnet and SSH

Cisco Unity JDBC

Cisco Unity Connection Webservice API

Cisco Unity Express CLI over Telnet and SSH

Table 2-3 Ports Used on the Provisioning Manager System 

Port Numbers 
Used—Standalone1

1. These are the ports used by Provisioning Manager when it is the only Cisco Unified Communications Management Suite 
product installed on a system.

Port Numbers 
Used—Coresident2 Additional Information

1098 46098 —

1099 46099 —

1602 46001 Network Interface and Configuration Engine (NICE). This 
is configurable during the advanced installation process.

4444 46444 —

4445 46445 —

5432 5432 PostgreSQL database. This is configurable during the 
advanced installation process.

8008 46008 JBoss Application Sever. This is configurable during the 
advanced installation process.

8009 46009 —

8083 46083 —

8093 46093 —

80 80 HTTP/Apache Web Server. This is configurable during the 
advanced installation process.

— 46443 HTTPS/Apache Web Server. To configure SSL, see 
Enabling SSL on the Provisioning Manager Server, 
page 2-2.
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Gathering Information to Provide During Installation
You might need to supply the following information while you are installing Provisioning Manager: 

 • For a simple installation, you will need to have the following:

 – A license file, or you can choose to use the evaluation version.

 – Password for the administrator user.

 – Username and password for the PostgreSQL administrator (default is postgres).

 – Time zone.

 • For an advanced installation, what you need depends on your installation. The following list 
contains information you may need to have:

 – A license file, or you can choose to use the evaluation version.

 – A port number for the Apache web server.

 – A port number for the PostgreSQL database.

 – Hostname or IP address for the systems that can connect to the PostgreSQL database.

 – Username and password for the Windows user that the PostgreSQL database uses.

 – Username and password for the PostgreSQL administrator (default is postgres).

 – The JBoss application server name.

 – The port number for the JBoss application server.

 – Username and password for the application database user.

 – Password for the administrator user.

 – Port number for the NICE service.

 – Time zone.

2. These are the ports used by Provisioning Manager when it is installed (coresident) on a system with other Cisco Unified 
Communications Management Suite products. The ports used are changed to avoid conflicts with other applications.

Table 2-4 Ports Used to Communicate with Other Devices 

Port Numbers Service Name/Protocols Application

80 HTTP/Apache Web Server Cisco Unified Communications Manager.

8443 HTTPS Cisco Unified Communications Manager 5.0.

22 SSH Cisco Unified Communications Manager Express 
and Cisco Unity Express.

23 Telnet Cisco Unified Communications Manager Express 
and Cisco Unity Express.
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Installing Provisioning Manager
The installation process takes approximately 60 minutes to complete.

Follow these guidelines when installing Provisioning Manager:

 • Provisioning Manager requires a dedicated system; do not install it on a system with: 

 – Third-party management software (such as HP OpenView or NetView).

 – Cisco Secure Access Control Server (ACS). 

 – Any Cisco applications other than those that are documented to be able to coexist with 
Provisioning Manager. 

 • If installing on a system with Cisco Security Agent, before installing Provisioning Manager disable 
Cisco Security Agent. 

 • Do not install on any of your voice application servers on a Cisco Unified Communications Manager 
server.

 • Verify that the system date and time are set properly.

 • To speed up installation, disable all virus-scan software while installing.

Step 1 Make sure your system meets these prerequisites:

 • Required (or desired) operating system upgrades have been performed.

 • Required service packs are installed.

For system requirements, see Server Requirements, page 1-3.

Step 2 Close all open or active programs. Do not run other programs during the installation process.

Step 3 As the local administrator, log in to the machine on which you will install the Provisioning Manager 
software, and insert the Cisco Unified Provisioning Manager CD-ROM into the CD-ROM drive. The 
Cisco Unified Provisioning Manager 1.3.1 window opens.

Note If the CD-ROM is already in the CD-ROM drive and you stopped the installation process to close 
programs or if Autostart is disabled, click cupm1.3.1-setup.exe to restart the process.

Step 4 Click Install. The Welcome window appears. 

Step 5 Click Next. The Software License Agreement window appears.

Step 6 Accept the Software License Agreement and then click Next.

Step 7 In the Destination Directory window, click Next to accept the default installation directory.

Note Do not install Provisioning Manager under any directory where the directory name contains a 
space (for example, Program Files). 

Step 8 Select the appropriate sizing for your Provisioning Manager installation.

Note The options that appear depend on the amount of memory that your system has.

Step 9 Click Next.
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Step 10 Choose an installation type, Simple or Advanced:

 • Select Simple, and click Next.

a. Select one of the following, and then click Next:

 – If you have a license file for this product, specify its location—Browse to enter the location. 

 – Select this option to evaluate the product—You can complete the installation and then register 
the license file later. 

b. Enter a username and password for the PostgreSQL administrator (default is postgres), then 
click Next.

Note Enter only alphanumeric characters for the password. Do not enter any special 
characters.

c. Enter a password for the Provisioning Manager administrator user.

Note Provisioning Manager is preconfigured with a permanent administrator account 
(pmadmin).

d. Click Next.

e. Select the appropriate time zone, then click Next. The Summary page appears.

f. Click Install.

 • Select Advanced, and click Next. The advanced installation has two distribution options. In the 
first, all of Provisioning Manager (application and database) is installed on one system. In the 
second, the Provisioning Manager application and database are installed on separate systems. This 
scenario requires that you enter the IP address of the two systems.

a. Choose the components: 

 – Database—Installs the Provisioning Manager database only. 

 – CUPM—Installs the Provisioning Manager application only.

Note If you choose to install the database and the application on separate systems, Provisioning 
Manager is not completely installed until both the database and application are installed. 
When you install the database on a separate machine, at the end of the installation you will 
receive a message that states Provisioning Manager was installed successfully. But only the 
database is installed on that system.

Advanced installation enables you to configure the following information, depending on which 
components you are installing:

 – Port number for the Apache web server.

 – Port number for PostgreSQL database.

 – Hostname or IP address for the Provisioning Manager application server that can connect to the 
PostgreSQL database. This is required if the database or the application is being installed on a 
separate system.

 – Username and password for the Windows user that the PostgreSQL database uses—The 
username is limited to 20 characters. Enter only alphanumeric characters for the password. Do 
not enter any special characters.
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Note The Windows Users group must have read and write access to the root directory of the 
hard disk drive on which Provisioning Manager is installed.

Note If the username already exists on the system, make sure of the following: that the 
password entered is the current password for that user, that the user belongs to the 
Windows Users group, that the setting User must change password at next login is not 
set, and the setting Password never expires is set. Also, the Windows user should not 
have administrator privileges.

 – Username and password for the PostgreSQL administrator (default is postgres)—Enter only 
alphanumeric characters for the password. Do not enter any special characters.

 – Application (JBoss) server name.

 – Port number for the JBoss application server.

 – Username and password for the application database user—Enter only enter alphanumeric 
characters for the password. Do not enter any special characters.

 – Password for the Provisioning Manager administrator user.

 – Port number for the NICE service.

b. Select one of the following, and then click Next:

 – If you have a license file for this product, specify its location—Browse to enter the location. 

 – Select this option to evaluate the product—You can complete the installation and then register 
the license file later. 

c. Select the appropriate time zone, then click Next. The Summary page appears.

d. Click Install.

Note If an error message appears similar to the following appears, it means that the installation has failed:

Postgres install failed with error code 1603

Before trying to install Provisioning Manager again, you must clean up the system. See Cleaning Up a 
Failed New Installation, page 2-16.

Step 11 Eject the CD-ROM.

Note Store the CD-ROM in a secure, climate-controlled area for safekeeping.

Step 12 Click Finish.

Step 13 After the installation completes, verify that Provisioning Manager is installed correctly by accessing the 
Provisioning Manager login page. From the Windows desktop, select Start > Programs > Cisco Unified 
Provisioning Manager > Log in to Cisco Unified Provisioning Manager.
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Note If Enhanced Security is enabled on the Windows 2003 system, you must add the Provisioning Manager 
home page to the Internet Explorer Trusted Sites Zone. You will not be able to access the Cisco Unified 
Provisioning Manager home page until it is added to the trusted sites. See Adding the Provisioning 
Manager Home Page to the Internet Explorer Trusted Sites Zone, page 2-16.

Adding the Provisioning Manager Home Page to the Internet Explorer Trusted 
Sites Zone

If Enhanced Security is enabled on the Windows 2003 system, you must perform the following 
procedure before you can access the Provisioning Manager home page.

Step 1 Open Provisioning Manager and select Start > Programs > Cisco Unified Provisioning Manager. 

Step 2 From the File menu, select Add this site to.

Step 3 Click Trusted Sites Zone.

Step 4 In the Trusted Sites dialog box, click Add to move the site to the list.

Step 5 Click Close.

Step 6 Refresh the page to view the site from its new zone.

Step 7 Check the Status bar of the browser to confirm that the site is in the Trusted Sites Zone.

Cleaning Up a Failed New Installation
If Provisioning Manager did not install correctly, you must first clean up the system before trying to 
install Provisioning Manager again. These procedures are for a failed new installation of Provisioning 
Manager 1.3.1. If you need to clean up a failed upgrade of Provisioning Manager 1.3 to 1.3.1, see 
Restoring Provisioning Manager 1.3 If the Provisioning Manager 1.3.1 Installation Fails, page 2-22.

After a failed installation, do the following:

 • Delete the CUPM installation folder. If you selected the default location during installation, it is 
C:\CUPM.

 • Delete the folder C:\Program Files\Common Files\InstallShield\Universal\common\Gen1.

 • Delete the Documents and Settings\cupmuser folder.

 • Remove the Windows user cupmuser (cupmuser is the default name provided during installation). 
The Windows username can be different, if you changed it during installation. For instructions on 
removing the Windows cupmuser, see Removing the CUPM Windows User, page 2-16.

Removing the CUPM Windows User

Step 1 On the Windows desktop, select Start > Settings > Control Panel.
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Step 2 Double-click Administrative Tools.

Step 3 Double-click Computer Management. 

Step 4 In the console tree, under Local Users and Groups, click Users.

Step 5 Right click the user account cupmuser and delete it.

Note The Windows username, cupmuser, is the default name provided during installation. The 
Windows username can be different, if you changed it during installation.

Step 6 Delete cupmuser’s home directory. The default location is in the directory C:\Documents and Settings\.

Upgrading Provisioning Manager 1.3 to Provisioning 
Manager 1.3.1

There are two upgrade scenarios; select the procedure that matches your scenario:

 • Upgrading Provisioning Manager on One System (Application and Database on the Same System), 
page 2-17

 • Upgrading Provisioning Manager on a Distributed System (Application and Database Are on 
Separate Systems), page 2-19

Upgrading Provisioning Manager on One System (Application and Database on 
the Same System)

Step 1 Manually back up your database. For instructions, see Provisioning Manager Database Backup, 
page 2-19. 

Note This manual backup is not the same backup that occurs automatically during upgrade. Both 
backups must be performed.

Step 2 On the system where Provisioning Manager 1.3 is installed, make sure the following prerequisites are 
met:

 • Required (or desired) operating system upgrades have been performed.

 • Required service packs are installed.

For system requirements, see Server Requirements, page 1-3.

Step 3 Close all open or active programs. Do not run other programs during the installation process.

Step 4 As the local administrator, log in to the machine on which you will install the Provisioning Manager 
software, and insert the Cisco Unified Provisioning Manager CD-ROM into the CD-ROM drive. The 
Cisco Unified Provisioning Manager 1.3.1 window opens.
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Note If the CD-ROM is already in the CD-ROM drive and you stopped the installation process to close 
programs or if Autostart is disabled, click cupm1.3.1-setup.exe to restart the process.

Step 5 Click Install. The Welcome window appears. 

Step 6 Click Next. The Software License Agreement window appears.

Step 7 Accept the Software License Agreement and then click Next.

Step 8 A confirmation box appears, telling you that an upgrade to Provisioning Manager 1.3.1 will occur. Click 
Next. A check of the system is performed, which verifies the following:

 • No orders are in the Released state.

 • All service actions are in the Closed state.

 • All workflows are in the Finished state.

 • No infrastructure, subscriber, or Domain synchronizations are running.

 • No batch projects are running or are in the Active state.

 • That there are not any unsupported devices configured in Provisioning Manager.

Note For device support information, see the Supported Devices Table for Cisco Unified 
Provisioning Manager 1.3.1 at 
http://www.cisco.com/en/US/products/ps7125/products_device_support_tables_list.html.

If any of these conditions are not met, the installation will stop.

Note If you are upgrading only the database or only the application (because you have a distributed setup) not 
all the screens will appear during the upgrade process. Also, to complete the upgrade of a distributed 
setup, you must run the Cisco Unified Provisioning Manager 1.3.1 installation CD on both systems.

When only upgrading the database (for distributed setup), you will be required to re-enter the 
PostgreSQL database administrator password and the application database user username (the default is 
cupm) and password. 

Step 9 Select a directory in which to back up the Provisioning Manager 1.3 data during upgrade. Click Next. 
The Summary page appears.

Step 10 Click Install.

Step 11 Eject the CD-ROM.

Note Store the CD-ROM in a secure, climate-controlled area for safekeeping.

Step 12 Click Finish.

Step 13 After the installation completes, verify that Provisioning Manager is installed correctly by accessing the 
Provisioning Manager login page. From the Windows desktop, select Start > Programs > Cisco 
Unified Provisioning Manager > Log in to Cisco Unified Provisioning Manager.
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Note After upgrading Provisioning Manager, you must synchronize all of your Unified Message Processors 
in Provisioning Manager before placing any orders for a processor.

Note If Enhanced Security is enabled on the Windows 2003 system, you must add the Provisioning Manager 
home page to the Internet Explorer Trusted Sites Zone. You will not be able to access the Cisco Unified 
Provisioning Manager home page until it is added to the trusted sites. See Adding the Provisioning 
Manager Home Page to the Internet Explorer Trusted Sites Zone, page 2-16.

Upgrading Provisioning Manager on a Distributed System (Application and 
Database Are on Separate Systems)

You must upgrade both the Provisioning Manager application and the Provisioning Manager database 
systems. 

Step 1 Back up the Provisioning Manager 1.3 database. For information, see Provisioning Manager Database 
Backup, page 2-19.

Step 2 Upgrade the Provisioning Manager 1.3 database to 1.3.1. The installation program will only take you 
through the applicable upgrade screens. If you need additional information, see Upgrading Provisioning 
Manager on One System (Application and Database on the Same System), page 2-17. 

Step 3 Upgrade the Provisioning Manager 1.3 application to 1.3.1. The installation program will only take you 
through the applicable upgrade screens. If you need additional information, see Upgrading Provisioning 
Manager on One System (Application and Database on the Same System), page 2-17. 

Note After upgrading Provisioning Manager, you must synchronize all of your Unified Message Processors 
in Provisioning Manager before placing any orders for a processor.

Provisioning Manager Database Backup
There are two backup scenarios; select the procedure that matches your scenario:

 • Backing up on a single machine; see Backing Up the Single-Machine Provisioning Manager 
Database, page 2-20.

 • Backing up for a distributed scenario; see Backing Up Provisioning Manager on a Distributed 
Database, page 2-21.

Note When backing up files, you should place the files on a different file server. Also, you should burn the 
backup data onto a CD.
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This procedure requires that you have administrator-level access to the Provisioning Manager database 
(the PostgreSQL database).

Step 1 On the Provisioning Manager system, stop the following services:

 • Apache

 • cupm JBossService

 • cupm NiceService

a. On the Windows desktop, select Start > Control Panel > Administrative Tools > Services.

b. Right-click each of the services and click Stop.

Step 2 On the Windows desktop, select Start > All Programs > PostgreSQL8.2 > Command Prompt. A 
command prompt opens in the <Install directory>\pgsql\bin directory.

Note If you accepted the default location during installation, the installation directory is C:\CUPM.

Step 3 In the command prompt, run the following command and enter the PostgreSQL administrator password 
when prompted:

pg_dumpall -o -U<username> > <directory>\<backup file name>

where:

 • <username> is the username of the PostgreSQL administrator. If you accepted the default, the 
administrator username is postgres.

 • <directory> is an existing directory.

 • <backup file name> is a filename that does not currently exist.

Note Enter the password each time that you are prompted. 

Use this command to back up the database. The command tells Provisioning Manager to store the 
database information in a file.

Step 4 If you are backing up for the same installation, proceed to the next step. If you are backing up for a new 
installation, make backup copies as described in this step.

In a backup folder, make copies of the following files and directories:

 • <Installation directory>\install.log

 • <Installation directory>\sep\dfc.properties

 • <Installation directory>\sep\dfc.keystore

 • <Installation directory>\jboss-4.0.3SP1\server\cupm\conf\login-config.xml

Step 5 Start the following services:

 • Apache

 • cupm JBossService

 • cupm NiceService
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a. On the Windows desktop, select Start > Control Panel > Administrative Tools > Services.

b. Right-click each of the services and click Start.

Backing Up Provisioning Manager on a Distributed Database

This procedure requires that you have administrator-level access to the Provisioning Manager database 
(the PostgreSQL database).

Step 1 On the system where Provisioning Manager is running, stop the following services:

 • Apache

 • cupm JBossService

 • cupm NiceService

a. On the Windows desktop where Provisioning Manager is running, select Start > Control Panel > 
Administrative Tools > Services.

b. Right-click each of the services and click Stop.

Step 2 On the Windows desktop where the Provisioning Manager database is running, select Start > All 
Programs > PostgreSQL8.2 > Command Prompt. A command prompt opens in the 
<Installation directory>\pgsql\bin directory.

Note If you accepted the default location during installation, the installation directory is C:\CUPM.

Step 3 In the command prompt, run the following command and enter the PostgreSQL administrator password 
when prompted:

pg_dumpall -o -U<username> > <directory>\<backup file name>

where:

 • <username> is the username of the PostgreSQL administrator. If you accepted the default, the 
administrator username is postgres.

 • <directory> is an existing directory.

 • <backup file name> is a filename that does not currently exist.

Note Enter the password each time that you are prompted. 

This command is used to backup the database, by storing the database information in a file.

Step 4 If you are backing up for the same installation, proceed to the next step. If you are backing up for a new 
installation, either with the same IP address or a new one, do the following. On the machine where 
Provisioning Manager is running, in a backup folder, make copies of the following files and directories:

 • <Installation directory>\install.log

 • <Installation directory>\sep\dfc.properties

 • <Installation directory>\sep\dfc.keystore

 • <Installation directory>\jboss-4.0.3SP1\server\cupm\conf\login-config.xml
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Step 5 Start the following services:

 • Apache

 • cupm JBossService

 • cupm NiceService

a. On the Windows desktop, select Start > Control Panel > Administrative Tools > Services.

b. Right-click each of the services and click Start.

Restoring Provisioning Manager 1.3 If the Provisioning Manager 1.3.1 
Installation Fails

If Provisioning Manager did not upgrade correctly, you must first clean up the system before trying to 
install Provisioning Manager again. These procedures are only for a failed upgrade. If you need to restore 
a failed new installation of Provisioning Manager, see Cleaning Up a Failed New Installation, page 2-16.

After a failed upgrade, do the following:

 • Clean up the old installation of Provisioning Manager 1.3 (see Cleaning Up the Old Installation, 
page 2-22).

 • Restore Provisioning Manager 1.3 (see Restoring Provisioning Manager 1.3, page 2-23).

Cleaning Up the Old Installation

Step 1 Uninstall the Provisioning Manager installation. Depending upon where the installation failed, the 
installed application may appear as Provisioning Manager 1.3 or Provisioning Manager 1.3.1. Try to use 
the standard uninstallation process (see Uninstalling Provisioning Manager, page 2-26). 

If the standard uninstallation process does not work, go to Step 2.

Step 2 If standard uninstallation fails, you will have to perform some or all of the following steps:

a. Uninstall Postgres 8.2 if it still exists. If PostgreSQL 8.2 is listed under Windows Control Panel > 
Add or Remove Programs, click Remove to uninstall it.

b. Remove the installation directory CUPM. This step may require a system reboot if the Provisioning 
Manager services are still running and using the resources from the installation location.

Note If you selected the default location during installation, it is C:\CUPM.

c. Remove the cupmuser (Windows user) if it still exists:

1. Select Start > Settings > Control Panel.

2. Double-click Administrative Tools.

3. Double-click Computer Management. 

4. In the console tree, under Local Users and Groups, click Users.

5. Right-click the user account cupmuser and delete it.

6. Delete cupmuser’s home directory. The default location is in the directory C:\Documents and 
Settings\.
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d. Remove the folder C:\Program Files\Common Files\InstallShield\Universal\common\Gen1.

e. (Optional) You may need to delete the Provisioning Manager services. Make sure the services are 
not running before you delete them.

Provisioning Manager services that need to be deleted:

 • Apache2

 • cupm JbossService

 • cupm NICEService

 • pgsql-8.2

Use the following command to delete Windows services: sc.exe delete <service name>.

Restoring Provisioning Manager 1.3

There are two restore scenarios; select the procedure that matches your scenario:

 • Restoring on a single machine, see Restoring the Single-Machine Provisioning Manager Database, 
page 2-23.

 • Restoring for a distributed scenario, see Restoring Provisioning Manager for a Distributed Database, 
page 2-25.

Restoring the Single-Machine Provisioning Manager Database

If you are restoring to a new installation, have the system with the new installation up and running before 
beginning this procedure.

This procedure requires that you have administrator-level access to the Provisioning Manager database 
(the PostgreSQL database).

Before You Begin

If you are restoring the database on a new system, you must verify that the following ports are not being 
used by another application: 

 • dfc.jboss.port=8008 

 • dfc.postgres.port=5432 

 • dfc.nice.rmi.registry.internal.port=1602 

 • dfc.webport=80 

If a port is being used by another application, you must change the port number to a vacant port. These 
settings are defined in the <Installation directory>\sep\dfc.properties file. (If you accepted the default 
location during installation, the installation directory is C:\CUPM.)

Step 1 Stop Provisioning Manager services (for information on which services to stop, see Step 1  on 
page 2-20).

Step 2 On the Windows desktop, select Start > All Programs > PostgreSQL8.2 > Command Prompt. 

A command prompt opens in the <Installation directory>\pgsql\bin folder.

Note If you accepted the default location during installation, the installation directory is C:\CUPM.
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Step 3 To enter the PostgreSQL prompt, run the following command and enter the PostgreSQL administrator 
password for the current installation when prompted:

psql.exe -U<username>

where <username> is the username of the PostgreSQL administrator. If you accepted the default, the 
administrator username is postgres.

Step 4 Before restoring the database, you must drop the database name and role. In the command prompt, run 
the following commands exactly as shown, one at a time and in the following order:

 • DROP DATABASE cupm;

where cupm is the database name to be removed. 

Expected output: DROP DATABASE

 • DROP ROLE <rolemame>;

where <rolename> is the username for the SEP database user. If you accepted the default, the username 
is cupm.

Expected output: DROP ROLE

 • ALTER ROLE <username> WITH PASSWORD ‘<password>’;

where username is the username of the PostgreSQL administrator user, and <password> should be the 
password that was set for the PostgreSQL administrator with backed-up data. If you accepted the default 
administrator username, the username is postgres.

Expected output: ALTER ROLE

Step 5 Enter \q to quit the PostgreSQL prompt.

Step 6 From the command line, run the following command; when prompted, enter the password that was set 
in the previous step for the PostgreSQL user:

psql.exe -U<username> -d postgres < <directory>\<file name to be restored from>

where <username> is the username of the PostgreSQL administrator. If you accepted the default, the 
administrator username is postgres.

This command restores the database.

Step 7 Copy the following backed-up files to the location from which they are backed up:

 • <Installation directory>\install.log

 • <Installation directory>\sep\dfc.properties

 • <Installation directory>\sep\dfc.keystore

 • <Installation directory>\jboss-4.0.3SP1\server\cupm\conf\login-config.xml

Step 8 Start the following services:

 • Apache

 • cupm JBossService

 • cupm NiceService

a. On the Windows desktop, select Start > Control Panel > Administrative Tools > Services.

b. Right-click each of the services and click Start.
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Restoring Provisioning Manager for a Distributed Database

If you are restoring to a new installation, either with the same or a new IP address, have the system with 
the new installation up and running before beginning this procedure.

This procedure requires that you have administrator-level access to the Provisioning Manager database 
(the PostgreSQL database).

Before You Begin

If you are restoring the database on a new system, you must verify that the following ports are not being 
used by another application: 

 • dfc.jboss.port=8008 

 • dfc.postgres.port=5432 

 • dfc.nice.rmi.registry.internal.port=1602 

 • dfc.webport=80 

If a port is being used by another application, you must change the port number to a vacant port. These 
settings are defined in the <Installation directory>\sep\dfc.properties file. (If you accepted the default 
location during installation, the installation directory is C:\CUPM.)

Also, you will need to change the system name in one of the following settings:

 • dfc.postgres.host=<system name> (If the database is on one system.)

 • dfc.postgres.hostlist=<system names> (If the database is on multiple systems.)

Step 1 On the Provisioning Manager application system, stop the Provisioning Manager services (for 
information on which services to stop, see Step 1 on page 2-21).

Step 2 On the Windows desktop where the Provisioning Manager database is running, select Start > All 
Programs > PostgreSQL8.2 > Command Prompt. 

A command prompt opens in the <Installation directory>\pgsql\bin folder.

Note If you accepted the default location during installation, the installation directory is C:\CUPM.

Step 3 To enter the PostgreSQL prompt, run the following command and enter the PostgreSQL administrator 
password for the current installation when prompted:

psql.exe -U<username>

where <username> is the username of the PostgreSQL administrator. If you accepted the default, the 
administrator username is postgres.

Step 4 Before restoring the database, you must drop the database name and role. In the command prompt, run 
the following commands exactly as shown, one at a time and in the following order:

 • DROP DATABASE cupm;

where cupm is the database name to be removed. 

Expected output: DROP DATABASE

 • DROP ROLE <rolemame>;

where <rolename> is the username for the SEP database user. If you accepted the default, the username 
is cupm.

Expected output: DROP ROLE
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 • ALTER ROLE <username> WITH PASSWORD ‘<password>’;

where <username> is the username of the PostgreSQL administrator, and <password> is the password 
that was set for the PostgreSQL administrator with backed-up data. If you accepted the default 
administrator username, the username is postgres.

Expected output: ALTER ROLE

Step 5 Enter \q to quit the PostgreSQL prompt.

Step 6 From the command line, run the following command; when prompted, enter the password that was set 
in the previous step for the PostgreSQL user:

psql.exe -U<username> -d postgres < <directory>\<file name to be restored from>

where <username> is the username of the PostgreSQL administrator. If you accepted the default, the 
administrator username is postgres.

This command restores the database.

Step 7 Copy the following backed-up files to the machine where the Provisioning Manager application is 
running:

 • <Installation directory>\install.log

 • <Installation directory>\sep\dfc.properties

 • <Installation directory>\sep\dfc.keystore

 • <Installation directory>\jboss-4.0.3SP1\server\cupm\conf\login-config.xml

Step 8 On the system where the Provisioning Manager application is running, start the following services:

 • Apache

 • cupm JBossService

 • cupm NiceService

a. On the Windows desktop, select Start > Control Panel > Administrative Tools > Service.

b. Right-click each of the services and click Start.

Uninstalling Provisioning Manager

Caution You must use the Provisioning Manager uninstallation program to remove Provisioning Manager from 
your system. If you try to remove the files and programs manually, you can seriously damage your 
system.

Step 1 Close all applications that are using Provisioning Manager files.

Step 2 As the local administrator, log in to the system on which Cisco Unified Provisioning Manager is 
installed.

Step 3 To start the uninstallation process, from the Windows desktop select Start > Programs > Cisco Unified 
Provisioning Manager > Uninstall Cisco Unified Provisioning Manager. 

Step 4 Click Next to begin uninstalling.

A window appears, listing the components selected for uninstallation.
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Step 5 Click Uninstall.

Messages showing the progress of the uninstallation appears. 

Step 6 A message appears, reminding you that the cupmuser (Windows user) directory and the CUPM 
installation folder must be removed manually. Click Next.

Note The default Windows user name provided during installation is cupmuser. If you changed it 
during installation, the Windows user name may be different.

Step 7 Click Finish.

Step 8 If you want to reboot the system, select Yes, restart my computer, then click Finish.

Step 9 Manually delete the following folders from the Provisioning Manager system:

 • The CUPM installation folder. If you selected the default location during installation, it is 
C:\CUPM.

 • The Documents and Settings\cupmuser folder.
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Licensing

This appendix provides licensing information for Cisco Unified Provisioning Manager (Provisioning 
Manager). It contains the following sections:

 • Licensing Overview, page A-1

 • Licensing Warnings, page A-4

Licensing Overview
Provisioning Manager features software-based product registration and license key technologies. 
Licensing ensures that you possess a licensed copy of Provisioning Manager 1.3.1.

Note Licensing uses node-locking technology. The license file can only be used with the MAC address that 
you supply.

To determine whether Provisioning Manager is licensed, see Verifying Provisioning Manager License 
Status, page A-1. If you do not have a license or you want to upgrade your license, see Licensing 
Scenarios, page A-2.

Verifying Provisioning Manager License Status

Step 1 Select System Administration > License Information. The Licensing Status Information page 
appears, displaying the following information:

 • Unavailable features—Any features in Provisioning Manager that you do not have access to, 
because you do not have the appropriate license or because you have reached the limit for the use of 
the feature.

 • Features in overdraft state—Any features that you are using that have exceeded their allowable use 
limit.

 • Valid features—List of features and their corresponding use limit (Available), overuse amount 
(Overdraft), current use (Used) and date of expiration (Expiry).
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Licensing Overview
Licenses that Can Be Purchased
The license that you purchase determines the number of phones that Provisioning Manager can 
provision.

Note CTI Ports do not count toward the number of phones.

You can purchase licenses in the following increments:

 • Up to 500 phones.

 • Up to 1,000 phones.

 • Up to 2,000 phones.

 • Up to 5,000 phones.

 • Up to 10,000 phones.

 • Up to 20,000 phones.

 • Up to 30,000 phones.

Note Licenses are cumulative. Meaning you can combine licenses to increase the number of phones you can 
support.

Licensing Scenarios
Table A-1 describes what to do in different scenarios if you do not have a licensed, registered copy of 
Provisioning Manager or if you want to increase phone support.

Table A-1 How to Obtain and Register a License 

Scenario What to Do

Installing with a purchased license. 1. Before installing, obtain a license file. See Licensing 
Process, page A-3.

Note You can install Provisioning Manager without the 
license file. You can upgrade your license after 
installation. See Registering a License File with 
Provisioning Manager, page A-4.

2. During installation, select License File Location, and 
provide the location of your license file.

Installing with an evaluation license.

Note The evaluation license is 
limited to monitoring 100 
phones, 5 Call Processors, and 
2 Unified Message Processors.

During installation, select the option to evaluate the product. 
Evaluation versions are active for 90 days before you are 
required to purchase a license.

If you want to upgrade to a purchased license after 
installation, obtain a PAK and license file for the installed 
version of Provisioning Manager. For information on the 
licensing process, see Licensing Process, page A-3.
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Licensing Process
The Provisioning Manager license file includes support for at least 500 phones. You can purchase 
incremental licenses for additional phone support and register up to 30,000 phones with a single 
Provisioning Manager. For each incremental license that you purchase, you will receive a Product 
Authorization Key (PAK), and you must use that PAK to obtain a license file.

This process applies to new installations and license upgrades.

1. Obtain a PAK—The PAK is used to register Provisioning Manager, and any additional device 
support that you might purchase for Provisioning Manager, on Cisco.com, and it contains resource 
limitations. See Obtaining a PAK, page A-3.

2. Obtain a license file—A license file is sent to you after you register the PAK on Cisco.com. See 
Obtaining a License File, page A-3.

3. Copy the license file to the server where Provisioning Manager is to be installed. If Provisioning 
Manager is already installed and you are upgrading your license file, you must register the license 
file with Provisioning Manager. See Registering a License File with Provisioning Manager, 
page A-4.

Obtaining a PAK 
The PAK is located on the software claim certificate that is shipped with the Provisioning Manager 
product CD.

Obtaining a License File

Step 1 Register the PAK and the MAC address of the system where Provisioning Manager is installed with 
Cisco.com at http://www.cisco.com/go/license. You will be asked to log in. You must be a registered user 
of Cisco.com to log in.

Note The MAC address is required because licensing uses node-locking technology. The license file 
can only be used with the MAC address that you supply.

The license file will be emailed to you. After you obtain a license file, register the license with the 
Provisioning Manager server. 

Getting a license for additional 
devices (either upgrading from an 
evaluation license, or increasing the 
number of supported devices).

See Licensing Process, page A-3.

Moving Provisioning Manager to 
another server.

Call the Cisco TAC for assistance. 

Table A-1 How to Obtain and Register a License (continued)

Scenario What to Do
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Registering a License File with Provisioning Manager

Step 1 Copy the license file to the Provisioning Manager server, in the folder <Install Directory>\license.

The system validates the license file and updates the license. The updated licensing information appears 
on the Licensing Status Information page.

Step 2 The license should automatically take effect in a few minutes. If it does not, select System 
Administration > License Information. 

Step 3 Click PERFORM AUDIT. You will see the phones that you are licensed to update. 

Step 4 If you purchased more than one license, repeat Step 1 to install each additional license.

Licensing Warnings
Provisioning Manager provides a licensing warning mechanism. A licensing warning icon ( ) appears 
in the top right corner of the Provisioning Manager page when one of the following occurs:

 • A license file does not exist or cannot be read.

 • One or more features have reached or exceeded the limit specified in the licensing file.

 • Entries for one or more features do not exist in the license file (this occurs only when the license file 
is not generated correctly or if the file is manually edited).

Evaluation Version: Before Expiry
If you have installed the evaluation version of Provisioning Manager, you must obtain the license file 
from Cisco.com if you want to continue to use the product after the 90-day evaluation period. For details, 
see Licensing Process, page A-3.

If you go past the 90-day evaluation period, you will see a licensing warning icon ( ) in the top right 
corner of Provisioning Manager. You can view the expiry date on the Licensing Information page.

Purchased Version: Phone Limit Exceeded
If you have a restricted license, Provisioning Manager displays the information on which of the phones 
have exceeded the limit on the Licensing Information page (see Verifying Provisioning Manager License 
Status, page A-1). You will not be able to add more phones.

If you go past the phone limit for your license, you will see a licensing warning icon ( ) in the top right 
corner of Provisioning Manager. 
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