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This manual describes Cisco Unified Provisioning Manager (Provisioning Manager) and provides
instructions for using and administering it.

Audience

The audience for this document includes network administrators and operators who monitor, maintain,
and configure the status of the IP telephony systems and applications.

Conventions

This document uses the following conventions:

Item Convention
Commands and keywords boldface font
Variables for which you supply values italic font

Displayed session and system information screen font

Information you enter boldface screen font
Variables you enter italic screen font

Menu items and button names boldface font

Selecting a menu item in paragraphs Option>Network Preferences
Selecting a menu item in tables Option>Network Preferences

>
Note = Means reader take note. Notes contain helpful suggestions or references to material not covered in the
publication.

A

Caution  Means reader be careful. In this situation, you might do something that could result in equipment
damage or loss of data.

Installation Guide for Cisco Unified Provisioning Manager
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Preface

Ml Product Documentation

Product Documentation
~

Note = We sometimes update the printed and electronic documentation after original publication. Therefore,
you should also review the documentation on Cisco.com for any updates.

Table 1 describes the product documentation that is available.

Table 1 Product Documentation

Document Title

Available Formats

Supported Devices Table for Cisco Unified
Provisioning Manager 1.1

On Cisco.com at the following URL:

http://www.cisco.com/en/US/products/ps7125/products_device_sup
port_tables_list.html

Release Notes for Cisco Unified Provisioning
Manager 1.1

In PDF on the product CD-ROM

On Cisco.com at the following URL:
http://www.cisco.com/en/US/products/ps7125/prod_release_no
tes_list.html

Installation Guide for Cisco Unified Provisioning
Manager 1.1

In PDF on the product CD-ROM

On Cisco.com at the following URL:
http://www.cisco.com/en/US/products/ps7125/prod_installation
_guides_list.html

User Guide for Cisco Unified Provisioning
Manager 1.1

In PDF on the product CD-ROM

On Cisco.com at the following URL:
http://www.cisco.com/en/US/products/ps7125/products_user_g
uide_list.html

Obtaining Documentation, Obtaining Support, and Security

Guidelines

For information on obtaining documentation, obtaining support, providing documentation feedback,
security guidelines, and also recommended aliases and general Cisco documents, see the monthly
What’s New in Cisco Product Documentation, which also lists all new and revised Cisco technical

documentation, at:

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html
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CHAPTER

Prerequisites

This chapter describes the prerequisites for installing Cisco Unified Provisioning Manager on a
Windows system. It includes:

e Product Overview, page 1-1

e New Features in Cisco Unified Provisioning Manager 1.1, page 1-2
e Server Requirements, page 1-2

e C(Client Requirements, page 1-3

e Additional Server Software, page 1-4

Product Overview

Cisco Unified Provisioning Manager (Provisioning Manager) provides a scalable web-based solution to
manage a company’s next-generation communication services. Provisioning Manager manages IP
communication services in an integrated IP telephony, voicemail, and unified messaging environment
that includes Cisco Unified Communications Manager, Cisco Unified Communications Manager
Express, Cisco Unity, Cisco Unity Express, and Cisco Unity Connection systems.

Provisioning Manager is a product from the Cisco Unified Communications Management Suite. It
provides provisioning for Cisco Unified Communications initial deployments and implementations, and
then remains deployed to provide ongoing operational provisioning and activation services for individual
subscriber changes. Provisioning Manager provides a single, consolidated view of subscribers across the
organization. It provides a set of business-level management abstractions, which are policy-driven
through the use of automation, for managing subscriber services across the Cisco Unified
Communications infrastructure.

A template capability permits defining standard configurations that can be reused for new sites or
location deployments. Batch provisioning permits the rollout of large numbers of subscribers at the same
time.

Administrators can configure policy at various levels to determine who can do delegated management,
for whom that delegation applies, and how business-level services apply to Cisco Unified
Communications voice and messaging applications and which types of end users (subscribers) are
permitted to order which standard services. Through the use of this policy and standard configuration
approach, provisioning and activating subscriber services is greatly simplified, while retaining the
overall ability to manage and provide services that make use of the underlying Cisco Unified
Communications applications.

[ oL-13917-01
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B New Features in Cisco Unified Provisioning Manager 1.1

New Features in Cisco Unified Provisioning Manager 1.1

Cisco Unified Provisioning Manager adds the following:
e Support for Cisco Unified Communications Manager 5.1(1), 5.1(2), and 6.0(1).
e Support for Cisco Unified Communications Manager Express 4.1.
e Support for Cisco Unified Personal Communicator 1.1 and 1.2.

e Support for Cisco Unified MobilityManager through Cisco Unified Communications
Manager 6.0(1).

¢ Support for Cisco Unity 5.0.

¢ Support for Cisco Unity Connection 2.0.

e Support for Cisco Unity Express 3.0.

¢ Support for Cisco Unified IP Phone 7931G.

e The ability to delete the following from Provisioning Manager:
— Call Processors
— Unified Message Processors
- Domains

— Service Areas

Server Requirements

Table 1-1 lists the minimum server system requirements for installing Provisioning Manager.

Table 1-1 Server System Requirements
Requirement Type Minimum Requirements
System Processor Server platform with one of the following processor configurations:

e (Up to 1,000 phones) Single Pentium 4, 3.0 GHz.

e (Up to 10,000 phones) Single Pentium 4, 3.0 GHz.

e (Up to 30,000 phones) Two-system deployment, with the following configuration:
— Dual Pentium 4, 3.0 GHz processor, for the Web and application servers.

— Dual Pentium 4, 3.0 GHz processor, for the database.

Other System e Color monitor.

Hardware « CD-ROM drive.

¢ 100 Mbps NIC

Memory (RAM) e 2 GB—Up to 1000 phones.

e 4 GB—Up to 10,000 phones.

e 4 GB on each system—Up to 30,000 phones.

Swap File Space Same as RAM, with a maximum size of twice that of RAM.

Installation Guide for Cisco Unified Provisioning Manager
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Client Requirements W

Table 1-1 Server System Requirements (continued)

Requirement Type

Minimum Requirements

Available Drive Space

e 30 GB—Up to 1000 phones.

e 60 GB—Up to 10,000 phones.

e Two-system configuration (up to 30,000 phones); requires the following:
— 30 GB on the Web and application system.
— 80 GB on the database system.

System Software!

Windows Server 2003 with Service Pack 1, Standard or Enterprise Edition.

1. You must install Provisioning Manager on a dedicated system. Do not install Provisioning Manager on a Primary Domain Controller (PDC) or Backup
Domain Controller (BDC).

Client Requirements

Table 1-2 lists the minimum client system requirements for installing Provisioning Manager.

Table 1-2 Client System Requirements

Requirement Type

Minimum Requirements

System hardware

¢ Any PC or server platform with a Pentium 4 processor greater than 1.0 GHz.
e Color monitor with video card set to 24 bits color depth.
e Screen resolution of 1024 x 768 dpi.

Note Not every LCD projector or monitor provides a clear display at the minimum resolution. On
LCD projectors and monitors, dot pitch impacts the readability of the screen.

System software

¢ One of the following:

- Windows XP with Service Pack 2.

- Windows Server 2003 with Service Pack 1, Standard or Enterprise Edition.
¢ One of the following

— Internet Explorer 6.0 with Service Pack 2.

— Mozilla 1.7.8.

Memory (RAM)

1 GB recommended.

Environment Clients must be able to access Provisioning Manager:
e From outside a firewall—Refer to the documentation for your firewall for information on how to
configure client access.
e Across a Virtual Private Network (VPN)—The VPN tunnel should connect the client and a VPN
router or similar device. See Ports that Provisioning Manager Uses, page 2-8.
Installation Guide for Cisco Unified Provisioning Manager
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I Additional Server Software

Additional Server Software

Provisioning Manager has undergone interoperability testing with the following software:

e Cisco Security Agent 5.0

S

Note  Cisco Security Agent must be disabled during installation of Provisioning Manager.

e Third-party virus protection software:
— McAfee Virus Scan Enterprise 8.0

For McAfee Enterprise VirusScan 8.0, you must have patch version 11 installed. Install the
McAfee VirusScan Enterprise 8.0 Patch Version 11 before installing Provisioning Manager on
the system.

~

Note  You should exclude the following from virus scanning:

e The pgsql folder (if you selected the default location during installation, it is C:\CUPM\pgsql).
e The postmaster.exe file (located in the CUPM\pgsql\bin folder).

Installation Guide for Cisco Unified Provisioning Manager



CHAPTER

Installing, Upgrading and Uninstalling Cisco
Unified Provisioning Manager

This chapter describes installing Cisco Unified Provisioning Manager.

It includes:

Preparing to Install Provisioning Manager, page 2-1
Installing Provisioning Manager, page 2-9

Uninstalling Provisioning Manager, page 2-20

Preparing to Install Provisioning Manager

The information in this section helps you to deploy Provisioning Manager in your network. Do the
following before you install Provisioning Manager:

Make sure that hardware and software requirements for the server are met. (See Server
Requirements, page 1-2.)

Preparing the Provisioning Manager server for installation. (See Preparing the Server, page 2-1.)

Configure end systems so that Provisioning Manager can obtain correct information from them.
(Preparing End Systems, page 2-2.)

Determine whether your existing applications are already using ports that Provisioning Manager
uses. (Existing applications should not use the ports that Provisioning Manager requires.) See Ports
that Provisioning Manager Uses, page 2-8.

Gather information that you might need to provide during the Provisioning Manager installation.
(See Gathering Information to Provide During Installation, page 2-9.)

Preparing the Server

This section describes procedures that you may need to perform to prepare your server for installing
Provisioning Manager on it.

[ oL-13917-01
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| Preparing to Install Provisioning Manager

Enabling the Full 4 GB RAM

On 4 GB system, Windows only detects 3.5 GB of RAM even though your system has 4 GB installed. If
you want to choose the medium or large installation when installing Provisioning Manager, you must
first enable all 4 GB of RAM on the system. Do the following:

Step 1 On the Provisioning Manager system, in Windows right-click My Computer.

Step2  Select Properties.

Step3  Select the Advanced tab.

Step4  Under Startup and Recovery, click Settings.

Step5  Click Edit. The boot.ini file opens.

Step6  In the file, add »/paE" in line starting with "multi(0)disk(0)rdisk(O)partition(1) \WINDOWS=..."
Step7  Restart the system.

Preparing End Systems

In Provisioning Manager, the physical resources (end systems that deliver voice and messaging services)
are modeled as Processors. For example, a Cisco Unified Communications Manager or Cisco Unified
Communications Manager Express system is modeled as a Call Processor and a Cisco Unity, Cisco Unity
Express, or Cisco Unity Connection voicemail/unified messaging system is modeled as a Unified
Message Processor.

Using Provisioning Manager, an administrator creates and configures these various processors. After the
processors have been configured, all configuration and interaction with the end systems is handled by
Provisioning Manager.

Some minimal configuration is required on the end systems before you can use them with Provisioning
Manager. This section describes the preconfiguration steps required for Cisco Unified Communications
Manager, Cisco Unified Communications Manager Express, Cisco Unity systems, Cisco Unity
Connection, and Cisco Unity Express.

Cisco Unified Communications Manager Preconfiguration Dependencies

The Cisco Unified Communications Manager is the software-based, call-processing component of the
Cisco IP telephony solution, and is part of Cisco Architecture for Voice, Video and Integrated Data
(AVVID).

Additional data, voice, and video services such as unified messaging, multimedia conferencing,
collaborative contact centers, and interactive multimedia response systems interact with the IP telephony
solution through Cisco Communications Manager’s open telephony application programming interface
(API). Cisco Communications Manager is installed on the Cisco Media Convergence Server (MCS).

No specific preconfiguration is generally required on the Cisco Unified Communications Manager for
Provisioning Manager. However, the following conditions should already have been met during a normal
installation or upgrade, and are noted here as installation dependencies for creating a Call Processor in
Provisioning Manager:

¢ Install Cisco Unified Communications Manager.

Installation Guide for Cisco Unified Provisioning Manager
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Installing, Upgrading and Uninstalling Cisco Unified Provisioning Manager

~

Note

Preparing to Install Provisioning Manager

e For Cisco Unified Communications Manager release 4.x, ensure that the Cisco Unified
Communications Manager service and Internet Information Service (IIS) (at minimum) are running
on the Cisco Unified Communications Manager.

e If Cisco Unity is used in this configuration, configure the Cisco Unified Communications Manager

voicemail ports.

¢ Configure Cisco Unified Communications Manager to not allow autoregistration of phones, which
indicates that the Cisco Unified Communications Manager can assign phone numbers. When
Provisioning Manager is deployed, this functionality exists within Provisioning Manager.

e C(Create a user and password with administrator privileges that can be used by Provisioning Manager
to access Cisco Unified Communications Manager. The requirements of the user and password vary
depending on whether multilevel administration access (MLA) is enabled (see Table 2-1).

All interactions with Cisco Unified Communications Manager and Provisioning Manager are through
the AVVID XML Layer APIs (AXL/SOAP).

Determining the Media Server Account to Use for Cisco Unified Communications Manager Access

To enable Provisioning Manager to access a Cisco Unified Communications Manager, you must supply
the username and password for an account on the media server. The account to use depends upon the
Cisco Unified Communications Manager version and might also depend on whether MLA is enabled for
the Cisco Unified Communications Manager. Table 2-1 lists the options.

Table 2-1 Username and Password for Accessing the Cisco Unified Communications Manager
MLA Enabled
Cisco Unified or Disabled for
Communications Cisco Unified
Manager Version on Communications
Media Server Manager Required Account
4.x Enabled Multilevel administration access account with full
access to the Standard Serviceability Functional
Group.
Disabled Valid Windows 2000 administrator account on the
media server.
5.x N/A A Unified Communications Manager user that is
assigned a role with the privilege to use the AXL
Database API resource in the Cisco Call Manager
AXL Database application.
Standard AXL API Access is one of the predefined
roles in Unified Communications Manager that has
this privilege.
6.x N/A A Unified Communications Manager user that is

assigned a role with the privilege to use the AXL
Database API resource in the Cisco Call Manager
AXL Database application.

Standard AXL API Access is one of the predefined
roles in Unified Communications Manager that has
this privilege.

[ oL-13917-01
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| Preparing to Install Provisioning Manager

Cisco Unified Communications Manager 4.x with More than 500 Users

Step 1
Step 2
Step 3

Step 4
Step 5
Step 6
Step 7
Step 8
Step 9

Step 10
Step 11

Cisco Unified Communications Manager 4.x has a default search results limit of 500 for listing users. If
you have more than 500 users, you must increase the setting for “Maximum Search Results” on the Cisco
Unified Communications Manager.

On the Cisco Unified Communications Manager server, start DC Directory Administrator.
Log in using Directory Manager with the Cisco Unified Communications Manager password.

Click the cisco.com node. Admin, CCN, Groups and Users should appear.

S

Note If these do not appear select View > Zoom To Admin Node.

Click CCN.

Select systemProfile. On the right, you should see Hoteling Profile and System Profile.
Double-click System Profile.

Select the CCM Configuration tab.

Click Modify.

Change Maximum Search Results to a value higher than the number of users that you expect to have
(maximum supported is 30,000).

Click OK.
You can verify your changes by doing the following:
a. Open Internet Explorer and log into Cisco Unified Communications Manager.

b. Select User > Global Directory, then click Search. This lists all users. You should not receive any
warning messages if you get more than 500 results.

Cisco Unified Communications Manager Express Preconfiguration Dependencies

Cisco Unified Communications Manager Express is a solution, embedded in Cisco IOS Software, that
provides call processing for Cisco Unified IP phones.

Like Cisco Unified Communications Manager, Cisco Unified Communications Manager Express is
modeled in Provisioning Manager as a Call Processor. The only difference from an administrative aspect
is that it is represented by a different type of Call Processor.

Provisioning Manager requires that the Cisco Unified Communications Manager Express be installed on
a supported platform with the appropriate Cisco IOS Software version and Cisco Unified
Communications Manager Express load.

Provisioning Manager requires the following preconfiguration be performed on Cisco Unified
Communications Manager Express:

¢ Disabling of auto-allocation of directory numbers. This is done through the Cisco IOS interface.

e Disabling of ephone auto-registration. This is required for Cisco Unified Communications Manager
Express 4.0 or later.

These configurations are done through the Cisco IOS interface.

Installation Guide for Cisco Unified Provisioning Manager
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Step 1

Step 2

Step 3

Preparing to Install Provisioning Manager ||

First, verify that auto-allocation is enabled.

S telnet 172.19.50.247
Trying 172.19.50.247...
Connected to 172.19.50.247.
Escape character is '~]'.

User Access Verification
Password:

CCME-1>enable
Password:

CCME-1l#show telephony
CONFIG (Version=3.0)

Cisco Communications Manager EXpress
ip source-address 172.19.50.247 port 2000
max-ephones 24
max-dn 100
max-conferences 4
max-redirect 5
time-format 12
date-format mm-dd-yy
keepalive 30
timeout interdigit 10
timeout busy 10
timeout ringing 180
web admin system name root password cisco
web admin customer name cisco password cisco
edit DN through Web: enabled.
edit TIME through web: enabled.
Log (table parameters):
max-size: 150
retain-timer: 15
(password) : abcd
create cnf-files version-stamp 7960 Jan 15 2004 16:48:05
auto assign 1 to 100 type 7960 cfw 5001 timeout 30
local directory service: enabled.
xml schema http://gkar.cisco.com/schema/axlsoap.xsd

In this case, auto-allocation is on, as shown by the auto assign line.
To disable auto-allocation, run the following command at the enable prompt:

CCME-1l#config term

Enter configuration commands, one per line. End with CNTL/Z.

CCME-1 (config) #telephony-service

CCME-1 (config-telephony) #no auto assign 1 to 100 type 7960 cfw 5001 timeout 30
CCME-1 (config-telephony) #no auto-reg-ephone

~

Note  The no auto-reg-ephone command is required for Cisco Unified Communications Manager
Express 4.0 or later.

CCME-1 (config-telephony) #exit
CCME-1 (config) #exit
CCME-1l#show telephony

To verify that the change has taken effect, run another show telephony command. The auto assign line
should no longer appear.

[ oL-13917-01
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| Preparing to Install Provisioning Manager

Step 4

Run a write memory command, which will write the changes out to the system’s nonvolatile memory
in case of a reboot.

How Provisioning Manager Manages Communications Manager Express

~

Note

Cisco Unified Communications Manager Express uses two main commands to provision phones for end
subscribers:

¢ telephony ephone-dn—Manages directory numbers.
e telephony ephone—Assigns directory numbers to lines on one or more phones.

Both commands allow subscriber information to be associated to the directory number or the line.
Provisioning Manager uses these native abilities in Cisco Unified Communications Manager Express to
store and synchronize subscriber information.

Provisioning Manager is able to synchronize back the phones, lines, directory numbers, and subscriber
information from an existing Cisco Unified Communications Manager Express. Depending on how the
subscriber information was used in the telephony ephone and telephony ephone-dn commands,
Provisioning Manager is able to fully construct a user account for that subscriber. Provisioning Manager
supports shared lines and directory numbers while doing this.

When provisioning, Provisioning Manager uses the description command in the ephone configlet to
hold the subscriber name and department information. Provisioning Manager also uses the name
command in the ephone-dn configlet to hold the subscriber's first and last names.

The Cisco Unified Communications Manager Express ephone-dn name field is limited to 30 characters.
If the subscriber’s first and last names (combined) exceed that limit, you may get an error.

Cisco Unity and Cisco Unity Connection System Preconfiguration Dependencies

Before you can create a Unified Message Processor based on Cisco Unity or Cisco Unity Connection
(only required for Cisco Unity Connection 1.1.1) in Provisioning Manager, you must do the following:

¢ Install and configure the message store using Microsoft Exchange 2000 or 2003. (Required for Cisco
Unity only.)

¢ Configure an integration with one or more corresponding Cisco Unified Communications Manager
systems.

e Create a SQL Server user and password that can be used by Provisioning Manager to access the SQL
Server database on Cisco Unity or Cisco Unity Connection (only required for Cisco Unity
Connection 1.1.1). The SQL Server user requires access to both the Cisco Unity (or Cisco Unity
Connection) and master databases. See Creating a SQL Server User and Password for Cisco Unity
or Cisco Unity Connection, page 2-7.

e Verify the TCP/IP port used by Cisco Unity or Cisco Unity Connection (only required for Cisco
Unity Connection 1.1.1). This port number is required when you create a Unified Message
Processor.

e Define Class of Service and Subscriber templates.
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Creating a SQL Server User and Password for Cisco Unity or Cisco Unity Connection

Step 1

Step 2
Step 3

Step 4
Step 5
Step 6
Step 7

On the Cisco Unity (or Cisco Unity Connection) system, select Start > SQL Server > Enterprise
Manager. The Enterprise Manager window appears.

In the navigation tree, select Microsoft SQL Servers > SQL Server Group > (local) (Windows NT).

Right-click (local) (Windows NT) and select Properties. The SQL Server Properties (Configure)
window appears.

Click the Security tab.

Under Authentication, select SQL Server and Windows.

In the navigation tree under (local) (Windows NT), select Security > Logins.

Create a new login. Do the following:

a. Right-click Logins. The SQL Server Login Properties - New Login window appears.
b. Enter a name for the login.

c. Select SQL Server Authentication.

d. Select UnityDb (this is for Cisco Unity, for Cisco Unity Connection the database is UnityDirDb)
for the default database.

e. Click the Database Access tab.

f. Select both the UnityDb and the master database.

g. For both databases, select the following roles: db_owner, db_datareader, and db_datawriter.
h. Reboot the SQL server.

Verifying the TCP/IP Port Used by Cisco Unity or Cisco Unity Connection

Step 1

Step 2

Step 3
Step 4
Step 5

On the Cisco Unity system, select Start > SQL Server > Enterprise Manager. The Enterprise Manager
appears.

From the menu, click Action. Then select Properties. The SQL Server Properties (Configure) dialog
box appears.

In the General tab, click Network Configuration. The SQL Server Network Utility window appears.
Select TCP/IP, then click Properties.

In the window that appears, the default TCP/IP port is displayed. You will need to know this port number
when you create a Unified Message Processor.

Cisco Unity Express Preconfiguration Dependencies

Before you can create a Unified Message Processor based on Cisco Unity Express in Provisioning
Manager, you must determine the Service Engine Interface number for Cisco Unity Express. The Service
Engine Interface number is required when adding a Cisco Unity Express to Provisioning Manager.
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Determining the Service Engine Interface Number for Cisco Unity Express

The Service Engine Interface number is located on the router that hosts Cisco Unity Express.

Step1  Log in to the router that hosts Cisco Unity Express.
Step 2 Run the command show running-config.

In the resulting output, look for the following:

Interface Service-Engine 2/0

In this example, 2/0 is the Service Engine Interface number.

Ports that Provisioning Manager Uses

Before installing Provisioning Manager, make sure that the appropriate ports are available.

Table 2-2 lists the ports that need to be open on the Provisioning Manager system. Table 2-3 lists the
ports that need to be open on the firewall between Provisioning Manager and the device.

Table 2-2 Ports Used on the Provisioning Manager System

Port Numbers Service Name/Protocols

1098 JBoss RMI activation.

1099 JBoss JNDI.

1602 Network Interface and Configuration Engine (NICE). This is configurable
during the advanced installation process.

4444 JBoss RMI/JRMP.

4445 JBoss pooled invoker.

5432 PostgreSQL database. This is configurable during the advanced installation
process.

8008 JBoss Application Sever. This is configurable during the advanced
installation process.

8009 AJP Connector.

8083 JBoss Webservice.

8093 JBoss UILServerILService.

80 HTTP/Apache Web Server. This is configurable during the advanced
installation process.

Table 2-3 Ports Used to Communicate with Other Devices

Port Numbers |Service Name/Protocols Application

80 HTTP/Apache Web Server Cisco Unified Communications Manager.
443 HTTPS Cisco Unified Communications Manager 4.x.
8443 HTTPS Cisco Unified Communications Manager 5.0.
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Installing Provisioning Manager

Table 2-3 Ports Used to Communicate with Other Devices (continued)

Port Numbers |Service Name/Protocols Application

22 SSH Cisco Unified Communications Manager Express
and Cisco Unity Express.

23 Telnet Cisco Unified Communications Manager Express
and Cisco Unity Express.

1433 MS SQL Cisco Unity and Cisco Unity Connection(1.1.1
only).

Gathering Information to Provide During Installation

You might need to supply the following information while you are installing Provisioning Manager:
e For a simple installation, you will need to have the following:
— A license file, or you can choose to use the evaluation version.
— Password for the administrator user.
— Username ans password for the PostgreSQL administrator (default is postgres).

e For an advanced installation, what you need depends on your installation. The following list
contains information you may need to have:

— A license file, or you can choose to use the evaluation version.

— A port number for the Apache web server.

— A port number for the PostgreSQL database.

— Hostname or IP address for the systems that can connect to the PostgreSQL database.
— Username and password for the Windows user that the PostgreSQL database uses.

— Username and password for the PostgreSQL administrator.

— The JBoss application server name.

— The port number for the JBoss application server.

— Username and password for the application database user.

— Password for the administrator user.

— Port number for the NICE service.

Installing Provisioning Manager

The installation process takes approximately 60 minutes to complete.
Follow these guidelines when installing Provisioning Manager:
e Provisioning Manager requires a dedicated system; do not install it on a system with:
— Third-party management software (such as HP OpenView or NetView).
— Cisco Secure Access Control Server (ACS).

— Any Cisco applications other than those that are documented to be able to coexist with
Provisioning Manager.

Installation Guide for Cisco Unified Provisioning Manager
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M Installing Provisioning Manager

Step 1

Step 2
Step 3

Step 4
Step 5
Step 6
Step 7

Step 8

Step 9
Step 10

e Ifinstalling on a system with Cisco Security Agent, before installing Provisioning Manager disable
Cisco Security Agent.

¢ Do notinstall on any of your voice application servers on a Cisco Unified Communications Manager
server.

e Verify that the system date and time are set properly.

e To speed up installation, disable all virus-scan software while installing.

Make sure your system meets these prerequisites:
e Required (or desired) operating system upgrades have been performed.
e Required service packs are installed.
For system requirements, see Server Requirements, page 1-2.
Close all open or active programs. Do not run other programs during the installation process.

As the local administrator, log in to the machine on which you will install the Provisioning Manager
software, and insert the Cisco Unified Provisioning Manager CD-ROM into the CD-ROM drive. The
Cisco Unified Provisioning Manager 1.1 window opens.

~

Note Ifthe CD-ROM is already in the CD-ROM drive and you stopped the installation process to close
programs or if Autostart is disabled, click capm1.1-setup.exe to restart the process.

Click Install. The Welcome window appears.
Click Next. The Software License Agreement window appears.
Accept the Software License Agreement and then click Next.

In the Destination Directory window, click Next to accept the default installation directory.

a~

Note Do not install Provisioning Manager under any directory where the directory name contains a
space (for example, Program Files).

Select the appropriate sizing for your Provisioning Manager installation.

~

Note  The options that appear depend on the amount of memory that your system has.

Click Next.
Choose an installation type, Simple or Advanced:
e Select Simple, and click Next.
a. Select one of the following, and then click Next:
— If you have a license file for this product, specify its location—Browse to enter the location.

— Select this option to evaluate the product—You can complete the installation and then register
the license file later.

b. Enter a username and password for the PostgreSQL administrator, then click Next.
c. Enter a password for the administrator user.

d. Click Next.
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e.
f.
Sele

Installing Provisioning Manager

Select the appropriate time zone, then click Next. The Summary page appears.
Click Install.

ct Advanced, and click Next. The advanced installation has two distribution options. In the

first, all of Provisioning Manager (application and database) is installed on one system. In the
second, the Provisioning Manager application and database are installed on separate systems. This
scenario requires that you enter the IP address of the two systems.

~

Note

Adv
com

~

Choose the components:
Database—Installs the Provisioning Manager database only.

CUPM—Installs the Provisioning Manager application only.

If you choose to install the database and the application on separate systems, Provisioning
Manager is not completely installed until both the database and application are installed.
When you install the database on a separate machine, at the end of the installation you will
receive a message that states Provisioning Manager was installed successfully. But only the
database is installed on that system.

anced installation enables you to configure the following information, depending on which
ponents you are installing:

Port number for the Apache web server.
Port number for PostgreSQL database.

Hostname or IP address for the systems that can connect to the PostgreSQL database. This is
required if the database is being installed on a separate system.

Host name or IP Address of the computers that can connect to the PostreSQL database. This is
required if the application is being installed on a separate system.

Username and password for the Windows user.

Note  If the username already exists on the system, the password entered must be the current
password for that user.

Username and password for the PostgreSQL administrator.

The JBoss application server name.

Port number for the JBoss application server.

Username and password for the application database user.

Password for the Provisioning Manager administrator user.

Port number for the NICE service.

Select one of the following, and then click Next:

If you have a license file for this product, specify its location—Browse to enter the location.

Select this option to evaluate the product—You can complete the installation and then register
the license file later.

Select the appropriate time zone, then click Next. The Summary page appears.

Click Install.
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~

Note

Step 11

Step 12
Step 13

Note

Installing Provisioning Manager

If an error message appears similar to the following appears, it means that the installation has failed:

Postgres install failed with error code 1603

Before trying to install Provisioning Manager again, you must clean up the system. See Cleaning Up a
Failed New Installation, page 2-13.

Eject the CD-ROM.

S

Note  Store the CD-ROM in a secure, climate-controlled area for safekeeping.

Click Finish.

After the installation completes, verify that Provisioning Manager is installed correctly by accessing the
Provisioning Manager login page. From the Windows desktop, select Start > Programs > Cisco Unified
Provisioning Manager > Log in to Cisco Unified Provisioning Manager.

If Enhanced Security is enabled on the Windows 2003 system, you must add the Provisioning Manager
home page to the Internet Explorer Trusted Sites Zone. You will not be able to access the Cisco Unified
Provisioning Manager home page until it is added to the trusted sites. See Adding the Provisioning
Manager Home Page to the Internet Explorer Trusted Sites Zone, page 2-12.

Adding the Provisioning Manager Home Page to the Internet Explorer Trusted

Sites Zone

Step 1
Step 2
Step 3
Step 4
Step 5
Step 6
Step 7

If Enhanced Security is enabled on the Windows 2003 system, you must perform the following
procedure before you can access the Provisioning Manager home page.

Open Provisioning Manager and select Start > Programs > Cisco Unified Provisioning Manager.
From the File menu, select Add this site to.

Click Trusted Sites Zone.

In the Trusted Sites dialog box, click Add to move the site to the list.

Click Close.

Refresh the page to view the site from its new zone.

Check the Status bar of the browser to confirm that the site is in the Trusted Sites Zone.
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Cleaning Up a Failed New Installation

If Provisioning Manager did not install correctly, you must first clean up the system before trying to
install Provisioning Manager again. These procedures are for a failed new installation of Provisioning
Manager 1.1. If you need to clean up a failed upgrade of Provisioning Manager 1.0 to 1.1, see Restoring
Provisioning Manager 1.0 when Provisioning Manager 1.1 Installation Fails, page 2-16.

After a failed installation, do the following:

e Delete the CUPM installation folder. If you selected the default location during installation, it is
C:\CUPM.

e Delete the Documents and Settings\cupmuser folder.

¢ Remove the Windows user; cupmuser (cupmuser is the default name provided during installation).
The Windows user name can be different, if you changed it during installation. For instructions on
removing the Windows cupmuser, see Removing the CUPM Windows User, page 2-13.

Removing the CUPM Windows User

Step 1
Step 2
Step 3
Step 4
Step 5

Step 6

On the Windows desktop, select Start > Settings > Control Panel.
Double-click Administrative Tools.

Double-click Computer Management.

In the console tree, under Local Users and Groups, click Users.
Right click the user account cupmuser and delete it.

~

Note  The Windows username, cupmuser, is the default name provided during installation. The
Windows username can be different, if you changed it during installation.

Delete cupmuser’s home direcotry. The default location is in the directory C:\Documents and Settings\.

Upgrading Provisioning Manager 1.0 to Provisioning
Manager 1.1

There are two upgrade scenarios; select the set of procedures that matches your scenario:

e Upgrading Provisioning Manager on One System (Application and Database on the Same System),
page 2-14

e Upgrading Provisioning Manager for a Distributed System (Application and Database are on
Separate Systems), page 2-15
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Upgrading Provisioning Manager on One System (Application and Database on the Same System)

Step 1

Step 2

Step 3
Step 4

Step 5
Step 6
Step 7
Step 8

Note

Step 9

Manually backup your database. For instructions, see Backing Up The Provisioning Manager 1.0
Database, page 2-16.

~

Note  This manual backup is not the same backup that occurs automatically during upgrade. Both
backups must be performed.

On the system where Provisioning Manager 1.0 is installed, make sure the following prerequisites are
met:

e Required (or desired) operating system upgrades have been performed.
e Required service packs are installed.
For system requirements, see Server Requirements, page 1-2.
Close all open or active programs. Do not run other programs during the installation process.

As the local administrator, log in to the machine on which you will install the Provisioning Manager
software, and insert the Cisco Unified Provisioning Manager CD-ROM into the CD-ROM drive. The
Cisco Unified Provisioning Manager 1.1 window opens.

~

Note If the CD-ROM is already in the CD-ROM drive and you stopped the installation process to close
programs or if Autostart is disabled, click cupm1.1-setup.exe to restart the process.

Click Install. The Welcome window appears.
Click Next. The Software License Agreement window appears.
Accept the Software License Agreement and then click Next.

A confirmation box appears, asking if you want to upgrade to Provisioning Manager 1.1. Click Install.
A check of the system is performed, which verifies the following:

¢ No orders are in the Released state.

e All service actions are in the Closed state.

e All workflows are in the Finished state.

e No infrastructure, subscriber, or Domain synchronizations are running.
e No batch projects are running or are in the Active state.

If any of these conditions are not met, the installation will stop.

If you are upgrading only the database or only the application (because you have a distributed setup) not
all the screens will appear during the upgrade process. Also, to complete the upgrade of a distributed
setup, you must run the Cisco Unified Provisioning Manager 1.1 installation CD on both systems.

When only upgrading the database (for distributed setup), you will be required to re-enter the
PostgreSQL database administrator password and the application database user username (the default is
cupm) and password.

In the resulting dialog box, click Ok.
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Step 10

Step 11
Step 12

Note

Step 13

Step 14
Step 15

Note

Upgrading Provisioning Manager 1.0 to Provisioning Manager 1.1 ||

Either re-enter the old password for the cupmuser (Windows user), or leave the field empty (a random
password will be generated). Do not enter a new password. Click Next.

Select a directory to backup the Provisioning Manager 1.0 data in, during upgrade.

Select the appropriate time zone, then click Next. The upgrade proceeds.

If an error message appears, similar to the following:

C:\CUPM\httpd\conf\httpd.conf exists on this system and it has been modified since
instllation. Do you want to remove this file?

The installation failed. Before trying to install Provisioning Manager again, you must clean up the
system. See Restoring Provisioning Manager 1.0 when Provisioning Manager 1.1 Installation Fails, page
2-16.

Eject the CD-ROM.

~

Note  Store the CD-ROM in a secure, climate-controlled area for safekeeping.

Click Finish.

After the installation completes, verify that Provisioning Manager is installed correctly by accessing the
Provisioning Manager login page. From the Windows desktop, select Start > Programs > Cisco Unified
Provisioning Manager > Log in to Cisco Unified Provisioning Manager.

If Enhanced Security is enabled on the Windows 2003 system, you must add the Provisioning Manager
home page to the Internet Explorer Trusted Sites Zone. You will not be able to access the Cisco Unified
Provisioning Manager home page until it is added to the trusted sites. See Adding the Provisioning
Manager Home Page to the Internet Explorer Trusted Sites Zone, page 2-12.

Upgrading Provisioning Manager for a Distributed System (Application and Database are on
Separate Systems)

Step 1

Step 2

You must upgrade both the Provisioning Manager application and the Provisioning Manager database
systems.

Backup the Provisioning Manager 1.0 database. For information, see Backing Up The Provisioning
Manager 1.0 Database, page 2-16.

Upgrade the Provisioning Manager 1.0 database to 1.1. Since only the database is installed on the
system, the installation program will only take you through the aplicable database upgrade screens. If
you need additional information, see Upgrading Provisioning Manager on One System (Application and
Database on the Same System), page 2-14.
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Step 3

Upgrading Provisioning Manager 1.0 to Provisioning Manager 1.1

Upgrade the Provisioning Manager 1.0 application to 1.1. Since only the application is installed on the
system, the installation program will only take you through the aplicable application upgrade screens. If
you need additional information, see Upgrading Provisioning Manager on One System (Application and

Database on the Same System), page 2-14.

Backing Up The Provisioning Manager 1.0 Database

Step 1

Step 2

Step 3

S

Note  This procedure requires postgres administrator level access.

Shut down Provisioning Manager:
On the Windows desktop, select Start > All Programs > Cisco Unified Provisioning Manager >
Stop Cisco Unified Provisioning Manager.

~

Note Alternately, you can stop the postgres process; go to Control Panel > Administrative Tools >
Services > cupmPostgreSQL, select the service and click Stop.

In a backup folder, make copies of the following files and directories (preferably on a different file
server, also it is recommended that you burn the backup data onto a CD):

¢ <Installation directory>\install.log

¢ <Installation directory>\pgsql\data

e <Installation directory>\sep\dfc.properties

e <Installation directory>\sep\dfc.keystore

e <Installation directory>\jboss-4.0.3SP1\server\cupm\conf\login-config.xml

~

Note If you accepted the default location during installation, the installation directory is C:\CUPM.

Restart Provisioning Manager (Start > All Programs > Cisco Unified Provisioning Manager > Start
Cisco Unified Provisioning Manager).

Restoring Provisioning Manager 1.0 when Provisioning Manager 1.1
Installation Fails

If Provisioning Manager did not upgrade correctly, you must first clean up the system before trying to
install Provisioning Manager again. These procedures are only for a failed upgrade. If you need to restore

a failed new installation of Provisioning Manager, see Cleaning Up a Failed New Installation, page 2-13.

After a failed upgrade, do the following:
e Clean up the old installation of Provisioning Manager 1.0 (see Cleaning Up the Old Installation,
page 2-17).
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e Restore Provisioning Manager 1.0 (see Restoring Provisioning Manager 1.0, page 2-18).

If the database and the application are installed on separate systems, you must perform additional steps.
See Additional Steps for Restoring a Provisioning Manager 1.0 Distributed Deployment to a Different
Set of Hosts, page 2-19.

Cleaning Up the Old Installation

Step 1

Step 2

Uninstall the Provisioning Manager installation. Depending upon where the installation failed, the
application installed may appear as Provisioning Manager 1.0 or Provisioning Manager 1.1. Try to use
the standard uninstallation process (see Uninstalling Provisioning Manager, page 2-20).

If the standard uninstallation process does not work, go to Step 2.
If standard uninstallation fails, you will have to perform some or all of the following steps:

a. Remove the installation directory CUPM. This step may require a system reboot if the Provisioning
Manager services are still running and using the resources from the installation location.

~

Note If you selected the default location during installation, it is C:\CUPM.

b. Remove the cupmuser (Windows user) if it still exists:
1. Select Start > Settings > Control Panel.
Double-click Administrative Tools.
Double-click Computer Management.
In the console tree, under Local Users and Groups, click Users.

Right-click the user account cupmuser and delete it.

U

Delete cupmuser’s home directory. The default location is in the directory C:\Documents and
Settings\.

c. Uninstall Postgres 8.1/8.2 if still exists.
d. Remove the folder C:\Program Files\Common Files\InstallShield\Universal\common\Gen]1.

e. (Optional) You may need to delete the Provisioning Manager services. Make sure the services are
not running before you delete them.

Provisioning Manager 1.0 services that need to be deleted:
e Apache2
e cupm JbossService

e cupm NICEService

e pgsql-8.1
Provisioning Manager 1.1 services that need to be deleted:
e Apache2

e cupm JbossService
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e cupm NICEService
e pgsql-8.2

Use the following command to delete Windows services: sc.exe delete <service name>.

Restoring Provisioning Manager 1.0

~

Note  These instructions assume that you are backing up and restoring on the same system.

Step1  Shut down Provisioning Manager.

Step2  Place copies of the the backup files into their original folders. Make sure you use the original names of
the files and folders.

~

Note  You must restore on the same drive that you backed up from. If you backed up from drive C:\,
you must restore on drive C:\.

Step3  Change the permission of the database directory:
a. Open Windows Explorer.
b. Right click the <Installation directory>/pgsql/data folder.
>

Note If you accepted the default location during installation, the installation directory is
C:\CUPM.

Click Properties.

e o

Click the Security tab.
e. Click Advanced.
f. Click cupmuser (if it is not present, add it).

~

Note Two cupmuser may appear, one will have Deny in the Type column. If there are two, delete
the cupmuser that displays Deny in the Type column.

g. Click Edit ....
h. Select all the checkboxes in the Allow column, except for the following:
— Full Control
— Delete Subfolder and Files
— Take Ownership
— ChangePermission

i. Make sure the following checkbox is not selected: Apply these permissions to objects and/or
containers within this container only.

j. Click OK..
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k. Make sure the following checkbox is not selected: Allows inheritable permissions from the parent
to propagate to this object and all child objects. Include these with entries explicitly defined here.

If this check box is selected, unchecking the box causes a warning dialogue box to appear. Click
Remove.

I. Select the following checkbox: Replace permission entries on all child objects with entries shown
here that apply to child objects.

m. Click OK..

Start and stop the postgres service.

a. Go to Control Panel > Administrative Tools > Services > cupmPostgreSQL.
b. Click Start. Make sure that the service can be started.

¢. Click Stop.

Restart the system.

Additional Steps for Restoring a Provisioning Manager 1.0 Distributed Deployment to a Different Set

of Hosts

Step 1

Step 2

Step 3

Step 4

Step 5
Step 6

If the database and the Provisioning Manager application are installed on separate systems, you must
perform specific procedures on each system.

On the system where the database is installed, you must change the following file:
<installLocation>\pgsql\data\pg_hba.conf
Add the line, host all all <New App Server IP Address>/32 mdS.

On the system where Provisioning Manager is running, in the file dfc.properties, find the property
dfc.postgres.host, and change it to:

dfc.postgres.host=<New DB Server IP Address>

On the system where the database is installed, open Start > Programs > PostgresSQL 8.2 > pgAdmin
III. Login using the postgres admin password.

On the system where the database is in installed, run the following:

delete from nicesyseng where host='<0ld NICE Server IP Address>'

On the system where the database is installed, restart the capmPostgreSQL service.
On the system where Provisioning Manager is running, restart the following services:
e cupm JbossService

e cupm NICEService
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W Uninstalling Provisioning Manager

Uninstalling Provisioning Manager

A

Caution

Step 1
Step 2

Step 3

Step 4

Step 5

Step 6

Step 7
Step 8
Step 9

You must use the Provisioning Manager uninstallation program to remove Provisioning Manager from
your system. If you try to remove the files and programs manually, you can seriously damage your
system.

Close all applications that are using Provisioning Manager files.

As the local administrator, log in to the system on which Cisco Unified Provisioning Manager is
installed.

To start the uninstallation process, from the Windows desktop select Start > Programs > Cisco Unified
Provisioning Manager > Uninstall Cisco Unified Provisioning Manager.

Click Next to begin uninstalling.

A window appears, listing the components selected for uninstallation.
Click Uninstall.

Messages showing the progress of the uninstallation appears.

A message appears, reminding you that the cupmuser (Windows user) directory and the CUPM
installation folder must be removed manually. Click Next.

~

Note  The default Windows user name provided during installation is cupmuser. If you changed it
during installation, the Windows user name may be different.

Click Finish.
If you want to reboot the system, select Yes, restart my computer, then click Finish.
Manually delete the following folders from the Provisioning Manager system:

e The CUPM installation folder. If you selected the default location during installation, it is
C:\CUPM.

e The Documents and Settings\cupmuser folder.
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Licensing

This appendix provides licensing information for Cisco Unified Provisioning Manager (Provisioning
Manager). It contains the following sections:

e Licensing Overview, page A-1

e Licensing Warnings, page A-4

Licensing Overview

Provisioning Manager features software-based product registration and license key technologies.
Licensing ensures that you possess a licensed copy of Provisioning Manager 1.1.

~

Note Licensing uses node-locking technology. The license file can only be used with the MAC address that
you supply.

To determine whether Provisioning Manager is licensed, see Verifying Provisioning Manager License
Status, page A-1. If you do not have a license or you want to upgrade your license, see Licensing
Scenarios, page A-2.

Verifying Provisioning Manager License Status

Step1  Select System Administration > License Information. The Licensing Status Information page
appears, displaying the following information:

¢ Unavailable features—Any features in Provisioning Manager that you do not have access to,
because you do not have the appropriate license or because you have reached the limit for the use of
the feature.

e Features in overdraft state—Any features that you are using that have exceeded their allowable use
limit.

e All valid features—List of features and their corresponding use limit (Available), overuse allowed
(Overdraft), current use (Used) and date of expiration (Expiry).

Installation Guide for Cisco Unified Provisioning Manager
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M Licensing Overview

Licenses that Can Be Purchased

The license that you purchase determines the number of phones that Provisioning Manager can

provision.

You can purchase licenses in the following increments:

e Up to 1,000 phones.
e Up to 2,000 phones.
e Up to 5,000 phones.
e Up to 10,000 phones.
e Up to 20,000 phones.
e Up to 30,000 phones.

~

Note
support.

Licenses are cumulative. Meaning you can combine licenses to increase the number of phones you can

Licensing Scenarios

Table A-1 describes what to do in different scenarios if you do not have a licensed, registered copy of
Provisioning Manager or if you want to increase phone support.

Table A-1

How to Obtain and Register a License

Scenario

What to Do

Installing with a purchased license.

1. Before installing, obtain a license file. See Licensing
Process, page A-3.

Note  You can install Provisioning Manager without the
license file. You can upgrade your license after
installation. See Registering a License File with

Provisioning Manager, page A-3.

2. During installation, select License File Location, and
provide the location of your license file.

Installing with an evaluation license.

The evaluation license is
limited to monitoring 100
phones, 5 Call Processors, and

Note

2 Unified Message Processors.

During installation, select the option to evaluate the product.
Evaluation versions are active for 90 days before you are
required to purchase a license.

If you want to upgrade to a purchased license after
installation, obtain a PAK and license file for the installed
version of Provisioning Manager. For information on the
licensing process, see Licensing Process, page A-3.

Getting a license for additional
devices (either upgrading from an
evaluation license, or increasing the
number of supported devices).

See Licensing Process, page A-3.

Moving Provisioning Manager to
another server.

Call the Cisco TAC for assistance.
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Licensing Overview 1l

Licensing Process

The Provisioning Manager license file includes support for at least 1,000 phones. You can purchase
incremental licenses for additional phone support and register up to 30,000 phones with a single
Provisioning Manager. For each incremental license that you purchase, you will receive a Product
Authorization Key (PAK), and you must use that PAK to obtain a license file.

This process applies to new installations and license upgrades.

1. Obtain a PAK—The PAK is used to register Provisioning Manager, and any additional device
support that you might purchase for Provisioning Manager, on Cisco.com, and it contains resource
limitations. See Obtaining a PAK, page A-3.

2. Obtain a license file—A license file is sent to you after you register the PAK on Cisco.com. See
Obtaining a License File, page A-3.

3. Copy the license file to the server where Provisioning Manager is to be installed. If Provisioning
Manager is already installed and you are upgrading your license file, you must register the license
file with Provisioning Manager. See Registering a License File with Provisioning Manager, page
A-3.

Obtaining a PAK

The PAK is located on the software claim certificate that is shipped with the Provisioning Manager
product CD.

Obtaining a License File

Step 1

Register the PAK and the MAC address of the system where Provisioning Manager is installed with
Cisco.com at http://www.cisco.com/go/license. You will be asked to log in. You must be a registered user
of Cisco.com to log in.

a~

Note The MAC address is required because licensing uses node-locking technology. The license file
can only be used with the MAC address that you supply.

The license file will be emailed to you. After you obtain a license file, register the license with the
Provisioning Manager server.

Registering a License File with Provisioning Manager

Step 1

Step 2

Copy the license file to the Provisioning Manager server, in the folder <Install Directory>\license.

The system validates the license file and updates the license. The updated licensing information appears
on the Licensing Status Information page.

The license should automatically take effect in a few minutes. If it does not, select System
Administration > License Information.

[ oL-13917-01
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Step3  Click PERFORM AUDIT. You will see the phones that you are licensed to update.

Step4  If you purchased more than one license, repeat Step 1 to install each additional license.

Licensing Warnings

Provisioning Manager provides a licensing warning mechanism. A licensing warning icon ( /i) appears
in the top right corner of the Provisioning Manager page when one of the following occurs:

¢ A license file does not exist or cannot be read.
¢ One or more features have reached or exceeded the limit specified in the licensing file.

¢ Entries for one or more features do not exist in the license file (this occurs only when the license file
is not generated correctly or if the file is manually edited).

Evaluation Version: Before Expiry

If you have installed the evaluation version of Provisioning Manager, you must obtain the license file
from Cisco.com if you want to continue to use the product after the 90-day evaluation period. For details,
see Licensing Process, page A-3.

If you go past the 90-day evaluation period, you will see a licensing warning icon ( /&) in the top right
corner of Provisioning Manager. You can view the expiry date on the Licensing Information page.

Purchased Version: Phone Limit Exceeded

If you have a restricted license, Provisioning Manager displays the information on which of the phones
have exceeded the limit on the Licensing Information page (see Verifying Provisioning Manager License
Status, page A-1). You will not be able to add more phones.

If you go past the phone phone limit for your license, you will see a licensing warning icon (/&) in the
top right corner of Provisioning Manager.
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