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1 Installation
471.1
What should I check before installing Operations Manager?


471.2
I get a message that one or more files may be locked while upgrading from Operations Manager 2.0 or reinstalling. What should I do?


471.3
Installation/uninstallation of Operations Manager failed midway through. How do I clean up before trying the operation again?


471.4
The UI doesn't come up after a fresh install.  -OR-  Why do I see a blank screen on logging into the Cisco Unified Operations Manager evaluation version?


471.5
What are the basic checks and fixes to be done for licensing issues?


1.1 What should I check before installing Operations Manager?
A: Check the following:
· Make sure you have only one NIC card enabled on the machine.
· Critical: Check the time on the machine. If you change the time later, you may need to reinstall the OS to get Operations Manager to work

· Ensure that the DNS name and Operations Manager server hostname are same:
· In the command prompt, run nslookup. This should show you the hostname of the machine.

· Run ipconfig /all and check the hostname and domain name. They should be the same as what you obtained in nslookup.
· Finally, from the command prompt, run ping where hostname is the fully qualified name of the machine that you got from nslookup.

· If this is a reinstall, click Run and enter %temp%, then delete all the contents in temp folder.

· Ensure that SNMP has been enabled. If it is not enabled, then:
· Go to Control Panel > Add or Remove Programs >, then click Add/Remove Windows Components.
·  In the dialog box, look for Management and Monitoring Tools. Enable the check box corresponding to that item.
· Click Details and ensure that Simple Network Management Protocol is checked and enabled.
1.2 I get a message that one or more files may be locked while upgrading from Operations Manager 2.0 or reinstalling. What should I do?
A: Do the following:
· Stop the upgrade or reinstallation immediately.
· Go to Control Panel > Administrative Tools > Services.
· In the window, find the CW2000 Daemon Manager Service. Right-click and choose Properties.
· In the dialog box, find Startup Type and change it from Automatic to Manual.
· Reboot the machine and restart the upgrade or reinstallation.
1.3 Installation/uninstallation of Operations Manager failed midway through. How do I clean up before trying the operation again?
A: Do the following:
· Delete all files in the folder where the Operations Manager was attempted to install.
· Go to Start > Run and enter regedit.
· Go to HKEY_LOCAL_MACHINE\SOFTWARE\Cisco.

· Delete the following keys:
· MDC

· Resource Manager

· Reboot the machine and try installing again.
Caution: Registry operations must be done carefully, or you may encounter unexpected problems.
1.4 The UI doesn't come up after a fresh install.  -OR-  Why do I see a blank screen on logging into the Cisco Unified Operations Manager evaluation version?
A: This could be due multiple instances of the following DLLs in the system:
· Ssleay32.dll
· Libeay32.dll

These DLLs must be present only in the CSCOpx/bin directory. If duplicates are found, install the CSCsg58599 patch from Common Services on Cisco.com: http://www.cisco.com/cgi-bin/tablebuild.pl/cd-one-3des
1.5 What are the basic checks and fixes to be done for licensing issues?

A: Do the following:

1. Verify that the MAC address in the license file is the same as the MAC address for the Operations Manager server.
2. Use the Common Services "reset casuser" tool to fix file permission issues resulting from files being patched.
3. Because the system does not recognize %USERPROFILE%, which has a dot (.) between the administrator name and the hostname, you must manually change to c:\temp, after which the application installation wizard will accept the license file.
2 Device Auto Discovery
472.1
What are the criteria for seed devices?


472.2
Why do Unity/Unified Contact Center/Personnel Assistant devices go into the Partially Monitored state?


472.3
Please describe the fields in the Device Credentials UI.


472.4
Discovery takes too long.


472.5
Discovery says it has "processed x devices," but I don't see any devices in Operations Manager.


2.1 What are the criteria for seed devices?
A: The criteria are as follows:
· Auto-discovery will be able to find all the nodes in the cluster and associated devices, provided that HTTP credentials are given for the seed devices.
· Seed devices must be reachable via SNMP for non-Unified Communications devices (switches, routers, voice gateways). They should be running CDP. If they are not, ping sweep must be enabled.

2.2 Why do Unity/Unified Contact Center/Personnel Assistant devices go into the Partially Monitored state?

A: WMI credentials must be specified in the auto-discovery configuration.
2.3 Please describe the fields in the Device Credentials UI.
A: Use the Device Credentials user interface to provide lists of the various types of device credentials. These lists of credentials are used to ascertain the right credentials for the devices discovered. There are four types of credentials that can be provided:
· SNMPv1/v2(Read Only and Read Write credentials.

SNMPv3(Username/Password and Authentication Protocol

· HTTP(HTTP Username/Password for Unified CM
· WMI(Windows domain/Username and password for Unity and Unified Contact Center
Note: Once you provide these credentials, they are stored in the system. When you come back to this screen again, you will not see the entered credentials. If you reenter the credentials, the old credentials are overwritten.

2.4 Discovery takes too long.
A: There can be multiple reasons for this:

· There are too many unreachable devices. The devices may not be pingable or may not be SNMP reachable.

· It’s better to exclude specific IP ranges which do not have SNMP-manageable devices, such as IP phones, in order to reduce the discovery time.

· Too many credentials. Discovery tries each credential to ascertain the right one. This processing is sequential, which can prolong the discovery time.

· The SNMP timeout is high. This will compound the problem mentioned in the second bullet.

· A high hop count, which can result in a greater number of devices and a longer discovery time.

2.5 Discovery says it has "processed x devices," but I don't see any devices in Operations Manager.
A: Discovery processes all the devices and then applies the filters. Only after the entire process is completed are the devices added to Operations Manager.

3 Device Management
473.1
Devices are stuck in the In Progress or Unreachable state. How do I debug this?


473.2
Why are some devices going into the Partially Monitored state?


473.3
What roles does the http user need to monitor Unified CM  in Operations Manager ?


473.4
What is the impact of devices going into Partially Monitored status?


473.5
What credentials do I need to enter to manage a device?


473.6
Why do devices move into the Unsupported state?


473.7
What are the recommendations for rediscovery of devices?


473.8
Devices are not moving from the DCR to Operations Manager even though the device selection mode is Automatic.


473.9
Device is discovered with a capability of Unknown MDF type.


473.10
Unified CM is not discovered with the capability “CallManager.”


473.11
On an IBM system, unable to see environmental components such as power supply, fan, etc.


473.12
What are the MIB OIDs queried by Operations Manager during discovery?


473.13
What can I do if there are problems with device discovery?


473.14
Auto-discovery is not working because Operations Manager is in manual mode, even though the UI shows automatic.


473.15
Why does auto-discovery sometimes get stuck?


473.16
What does “Unknown MDF type for device” mean?


473.17
Operations Manager shows a service down event even though the Unified CM shows the service as up.


473.18
Cluster name change is not reflected in Operations Manager.


473.19
The Unified CM goes into the Partially Monitored state, with the message “Wrong HTTP Credentials,” even though the credentials work on the Unified CM Administrator page.


473.20
Device is stuck at 10% during inventory collection.


473.21
The VHM server fails to start up due to a FlexLM error in VHM.log.


473.22
Will services always keep the same service number per server in Operations Manager?


473.23
How can I get a service down event to give me the service name in a trap, instead of the service number?


473.24
A device is added in Operations Manager but is not collected during inventory collection.


473.25
What Windows WMI events are supported for Unity?


473.26
I’m seeing service down events for a service that is actually running.


473.27
From a firewall perspective, which TCP ports need to be opened for WMI communication to happen?


473.28
Does Operations Manager make HTTP calls to Unified CM 4.2 and above?


473.29
Although a device acts as the MOH Server, the device capability in Operations Manager does not indicate that it does so.


473.30
Devices are stuck in 10% InventoryCollection even though both DFMServer and VHMServer are successfully connected to the Broker.


473.31
The Phone Access switch is not recognized as such.


473.32
The VHM.log file is growing indefinitely without any roll-up.


473.33
How do I configure a non-Administrator WMI login for Unified CM, Unity, and Unified Contact Center machines?


3.1 Devices are stuck in the In Progress or Unreachable state. How do I debug this?

A: Devices will remain in the InProgress State for a long time if SNMP responses are slow. Eventually the devices will move into either the Monitored or Unreachable state. 

Try the following:

· If all devices are in the Unreachable state, do the following: 

a. Open the Windows command prompt from Start > Run, enter cmd, and click OK.

b. Execute the  following command:

<NMSROOT>\CSCOpx\objects\smarts\bin\brcontrol 

The output should look like this:

C:\Documents and Settings\Administrator>c:\progra~1\CSCOpx\objects\smarts\ bin\brcontrol

Broker is located at: ipcomtest-3:9002      Started: May 27 09:25:34 2006

Domain          Host Name         Port Proc ID State   Last Chg Time

------          ---------       ------ ------- -----   -------------

PollingServer   ipcomtest-3       4345    6592 RUNNING May 27 09:27:56 2006

VHM             ipcomtest-3       4355    6592 RUNNING May 27 09:28:02 2006

DFM             ipcomtest-3       4838    6416 RUNNING May 27 09:28:43 2006

c. Check for entries for both DFM and VHM. 

d. If you see an entry for DFM but no entry for VHM, then in the command prompt, run pdexec VHMServer.

e. If you see no entries in the list, it means that both DFM and VHM are down. In the command prompt, execute the following commands:

pdexec DFMServer

pdexec VHMServer

f. Execute the command mentioned in Step b. 

g. If you do not see the entries mentioned in Step c, zip all the logs under <NMSROOT>\log\itemlogs and send them to the Cisco Technical Assistance Center (TAC) for analysis. 

h. If both entries show up, rediscover all of the devices by going into Devices > Modify/Delete.

· If only a few devices are in the Unreachable state, follow the steps listed below. Operations Manager has two SNMP stacks: one from Cisco and the other from SMARTS. For a device to be managed, both SNMP stacks must work on the device.

· To check the Cisco stack:

a. Verify that the SNMP credentials are correctly entered.

b. Export the device details from the DCR and make a note of the read community string.

c. Go to:

http://<serverip>:1741/cwhp/device.center.do?device=<deviceIP>

d. At the bottom of the page, go to Functions Available > Tools > Management Station to Device.

d. In the window that appears, choose SNMP v1/v2 or SNMP v3, depending on what is configured on the device.

e. Enter the community string in v2 (obtained from Step b). By default, Public and Private are entered in the edit field.

f. If the device uses SNMP v3, enter the v3 username and password.

g. Click OK. If the result shows “Failed,” then try increasing the SNMP timeout. 

h. If still unsuccessful, recheck the credentials that have been set up on the device.

· To check the SMARTS stack for v1 devices, execute the following:
<NMSROOT>\objects\smarts\bin\sm_snmp -d <deviceName> -s 1 -c <community> walk .1

· To check the SMARTS stack for v2C devices, execute the following:
<NMSROOT>\objects\smarts\bin\sm_snmp -d <deviceName> -s 2c -c <community> walk .1

· To check the SMARTS stack for v3 devices, execute the following:
<NMSROOT>\objects\smarts\bin\sm_snmp -d <deviceName> -s 3 -u <username> -a <authProtocol> -x <authpwd> walk .1

If the device is reachable through the SMARTS stack but not through the Cisco stack, contact the Cisco Technical Assistance Center (TAC) for support.
3.2 Why are some devices going into the Partially Monitored state?

A: The answer to this varies by version:
· Check details under Devices > Device Management > Modify/Delete Devices to find the error code. See the online help for possible reasons for this error code. You can find the online help under Device Management > Using Device Management > Working with Device Management > Understanding the Modify/Delete Devices page.
· Verify that you provided the correct http credentials during Add Device by using the credentials to log in to the Unified CM Admin page.

For Unified CM:

· Verify that you have provided the correct http credentials in the DCR by using the credentials to log in to the Unified CM Admin page.
· Verify that the firewall is blocking the http/https (ports 80/443) connection between Unified CM and Operations Manager. For Unified CM 5.0, make sure that 8433 and 8080 are not blocked.
· If this is a MultiLevel Administration (MLA) installation, make sure that you are able to log in to the device and that the user has access to the AXL API.

· Verify that the RIS Data Collector Service is running on the Unified CM machine.

· Verify that the AXL API Service is enabled:
· In Unified CM versions earlier than 5.0, enable the following from Control Center:

· Cisco Serviceability Reporter

· Cisco RIS Data Collector

· In Unified CM versions later than 5.0, enable the following:
· From Control Center - Feature Services:
· Database and Admin Services > Cisco AXL Web Service

· Performance and Monitoring Services > Cisco Serviceability Reporter

· From Control Center - Network Services:   

· SOAP Services > SOAP - Real-Time Service APIs

· SOAP Services > SOAP - Performance Monitoring APIs

· CM Services > Cisco RIS Data Collector

· Look at the device details under Devices > View/Rediscover/Delete, check the error, and use the following table.

Data Collector Error Status and Resolution Steps

	Error Shown on the Modify/Delete Devices Page 
	Reason 
	Resolution Steps 

	Error Code = CCM Authentication Failure 

Error Message = Success:WrongCredentials 
	This message indicates that either ccm http credentials are not entered or the credentials provided are incorrect. 
	Verify that you provided the correct http credentials in the DCR by using the credentials to log in to the Cisco Unified Communications Manager Admin page and rediscover the device. 

	Error Code= CCM Authentication Failure 

Error Message= Success:UnknownCredentialError 
	This message indicates that SNMP management MIBs are not responding. The MIBs and their associated errors could be any of: 

· MIB-2—The ipAddressTable is not responding. 

· CISCO-CCM-MIB—The ccmTable is not responding. Specifically the ccmClusterId attribute is not responding. 

· Inventory collection could not find the ccmVersion detail. This may be because the ccmVersion attribute in the CISCO-CCM-MIB is not responding. 
	Restart the SNMP Agent on the system and rediscover the device. 

	Error Code = CCM Authentication Failure 

Error Message = Success:WebServiceDown 
	Http service is not running or responding to requests from Operations Manager. 
	Verify that the web server is running by launching the Cisco Unified Communications Manager Admin page. 

Check the firewall to see if it is blocking the http/https connection between Cisco Unified Communications Manager and Operations Manager. 

	Error Code = CCM Authentication Failure 

Error Message = Success: HTTPSCertificateNotImported 
	The Cisco Unified Communications Manager certificate has failed. 
	Do the following: 
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Check the file IPToHostName.txt in the CSCOpx\lib\jre\lib\security folder. It should contain an entry like the following: 

deviceip>=<hostname> record

for each CCM. For example:
10.76.91.115=blrsd1
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Go to the keytool utility location <NMSROOT>\CSCOpx\lib\jre\bin. 
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Run the following command: 

keytool -list -keystore 

<NMSROOT>\CSCOpx\lib\jre\lib\security\cacerts

The downloaded certificates are displayed. 
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Verify that there is an entry similar to the following for the Cisco Unified Communications Manager: 

Certificate fingerprint (MD5): 

AC:B6:94:A5:9C:17:E0:D7:91:52:9B:B1:

97:06:A6:E4 

cn=ct-sd, ou=nmtg, o=cisco systems, l=bangalore, st=Karnataka, c=in, Oct 26, 200 5, trustedCertEntry
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Rediscover the device. 


For Unified Contact Center and Unity:

Verify that the WMI username (with domain name; for instance, APAC\shaj) and password are entered in the Primary Credential field in the DCR. If not, enter them.

To verify the credentials for any of the machines on Operations Manager, do the following:

· Click Start > Run. In the dialog box, enter the command wbemtest.
· In the dialog box that opens, click Connect, which opens another dialog box.
· Click Connect. If you get an error, this indicates one of the following:
· Incorrect credential.
· Inability to connect to the device. 
· Presence of a firewall that is blocking WMI access.

3.3 What roles does the http user need to monitor Unified CM  in Operations Manager ?
A: The http user can have "CCMAdministrator" or any of the following other roles:
· Standard CCM Admin Users

· Standard CCMADMIN Read Only
· Standard SERVICEABILITY Read Only
· Standard AXL API Access

3.4 What is the impact of devices going into Partially Monitored status?

A: The following could happen:
· HTTP credentials missing:

· Performance data will be missing for the device.
· Route list/route group information will be missing in the Service Level View
· SRST information will be missing in the Service Level View
· WMI credentials missing(WMI-specific events will be missing.
3.5 What credentials do I need to enter to manage a device?

A: Enter the following:
· CCM(HTTP, SNMP Read credential
· Unity, IPCC(SNMP Read, Windows credential 
· All other devices(SNMP Read credential
3.6 Why do devices move into the Unsupported state?

A: Do the following:
· Check if the device is responding to SNMP
· Check the SNMP version and credentials
· Check if CDP is enabled on the device and responding to the cdpCacheGlobalId
· Get the value of the sysObjectID (.1.3.6.1.2.1.1.2) and check if the value is listed in one of the oid*.conf files under \CSCOpx\objects\smarts\conf\discovery
· Send the OID with details to cs-operationsmanager@cisco.com.
3.7 What are the recommendations for rediscovery of devices?

A: Note the following:
· When a device is added, discovery happens automatically.

· When you add new modules to a Cat6k or change the topology drastically,  choose all the devices from Device> View > Rediscovery > Delete Devices, and run a rediscovery.
3.8 Devices are not moving from the DCR to Operations Manager even though the device selection mode is Automatic.

A: Try the following:
· Reapply the selection mode settings by going to Devices > Device Management > Device Selection.

· Change the device selection mode to Manual and then manually import the devices to Operations Manager.
3.9 Device is discovered with a capability of Unknown MDF type.

A: Check the device support table to make sure device sysObjectID (.1.3.6.1.2.1.1.2) is supported. The device support table is available at: http://www.cisco.com/en/US/products/ps6535/products_device_support_tables_list.html
3.10 Unified CM is not discovered with the capability “CallManager.”
A: Check if the following MIB variable in sysApplMIB returns the right values: snmpwalk of sysApplInstallPkgProductName (.1.3.6.1.2.1.54.1.1.1.1.3) should return "Cisco CallManager."
3.11 On an IBM system, unable to see environmental components such as power supply, fan, etc.

A: Try the following:
· Check if "IBM Director Agent WMI CIM Server" service is running. If not, start the service. If it is running, check the director agent version installed. See the device support table for Operations Manager, and check whether the particular version is supported.
· Verify that the following IBM OIDs, which Operations Manager uses to collect environmental components, are responding
:
· For TempSensors: .1.3.6.1.4.1.2.6.159.1.1.80.1.1.2

· For PowerSupply: .1.3.6.1.4.1.2.6.159.1.1.130.1.1.9

3.12 What are the MIB OIDs queried by Operations Manager during discovery?

A: The following MIB OIDs are queried:
1. sysObjectID (.1.3.6.1.2.1.1.2)

(This is compared to check if it is a supported device.)
2. ccmtable (.1.3.6.1.4.1.9.9.156.1.1.2)

(For 5.x and above only.)

3. sysApplInstallPkgProductName (.1.3.6.1.2.1.54.1.1.1.1.3)

(For 4.x and below only.)

4. sysApplRunCurrentState (.1.3.6.1.2.1.54.1.2.1.1.3)

This is used to find out the running state of an installed application or service.
5. ipAddressTable (.1.3.6.1.2.1.4.34)

ccmClusterId (.1.3.6.1.4.1.9.9.156.1.1.2.1.8)

This is used to get the cluster ID of the Unified CM.
6. ccmVersion (.1.3.6.1.4.1.9.9.156.1.1.2.1.4)
If the MIB is not responding or the data returned is incorrect, try the workaround of restarting the Unified CM SNMP service.
It is advisable to involve the Unified CM SNMP serviceability team in debugging MIB/SNMP issues, if any.
3.13 What can I do if there are problems with device discovery?

A: Try the following:

1. Enable debug logs in Operations Manager, then delete and readd the device to Operations Manager. Also, get the vhm.log from the CSCOpx\objects\smarts\local\log directory.

2. If device inventory collection or discovery is being performed over a slow network connection, or if the devices are unusually slow in responding to SNMP or HTTP requests, you can change the ivr.properties file to prevent Operations Manager from timing out during discovery or inventory collection. The file is located in the NMSROOT/conf/ivr folder. To increase the time allocated for discovery or inventory collection, change the property messageFactor:6 to messageFactor:10. The higher the number, the longer Operations Manager waits before timing out.
3.14 Auto-discovery is not working because Operations Manager is in manual mode, even though the UI shows automatic.

A: Some times the UI is out of sync. You can reconfigure the discovery as automatic and reapply the settings.
3.15 Why does auto-discovery sometimes get stuck?

A: Verify that the hop count is not more than 3, and that filters are set with exclude and include clauses. If these settings are not done, then the devices to be searched will be huge and won’t complete or will take a long time.

3.16 What does “Unknown MDF type for device” mean?

A: Check the sysObjectID (.1.3.6.1.2.1.1.2). If it is not supported, you will get this error.
3.17 Operations Manager shows a service down event even though the Unified CM shows the service as up.

A: Get an SNMP walk of "SysApplyInstallPkgTable" (shows the package instance) and

"SysApplRunCurrentState" tables (shows if it is running), and check if the MIB data is wrong. If so, contact the Unified CM SNMP Serviceability team.
3.18 Cluster name change is not reflected in Operations Manager.

A: Check the Unified CM ccmClusterId (.1.3.6.1.4.1.9.9.156.1.1.2.1.8) MIB walk to see if the data is correct. If not, restart the Unified CM SNMP Service, and then delete and readd the device in Operations Manager. The change is reflected in the Service Level View after the next polling, so wait for 30 minutes for the Service Level View to be updated.

3.19 The Unified CM goes into the Partially Monitored state, with the message “Wrong HTTP Credentials,” even though the credentials work on the Unified CM Administrator page.

A: The credentials that work on the Unified CM Administration page will not work with all HTTP URLs exposed on the Unified CM system. This could be because of insufficient privileges or MLA configuration. On a browser, open the following URL:
http://<Unified CM Device IP address>/ast/astisapi.dll?QueryService

You will be prompted for credentials. If the credentials entered here work successfully, then these credentials should be used in Operations Manager while adding the device.
Note: For Unified CM version 4.1 and later, “https” should be used instead of “http” in the URL.

For Unified CM 5.X and later, additional portInformation (“:8443”) should be suffixed to the Unified CM device IP address.
3.20 Device is stuck at 10% during inventory collection.

A: A device becomes stuck at 10% when there is an issue with the InCharge Servers (VHM and DFM). 

Do the following:
1. Execute <CSCOPX>\objects\smarts\bin\brcontrol.
You should see at least two entries indicating that VHM and DFM are attached and running. If you do not see them, restart Operations Manager.

2. Check the FQDN of the Operations Manager system, and ping the FQDN name from the DOS console. If the ping fails or reports a different IP address, then the DNS configurations need to be verified.
3.21 The VHM server fails to start up due to a FlexLM error in VHM.log.

A: This issue is due to the specified functionality of the FLEXlm license server in enforcing temporary licenses. FLEXlm detects system clock changes for this reason, and it does this by checking the dates of various files in certain directories. If it finds any files that have dates into the future, the license keys will not work. Therefore, there is only one possible workaround to this scenario when using temporary licenses (other then rebuilding the system): locating all files that are dated into the future and deleting them or changing their time stamps.

The following is a method for finding all such files in Windows:

1. Open Windows Explorer and select Tools > Folder Options, then click the View tab.
2. Click Show hidden files and folders.
3. Uncheck Hide protected operating system files (Recommended).
4. Select Start > Search, then click For files or folders.
5. Click Search Options.
6. Click when it is modified?
7. Choose from date as today's date and to as a date several years into the future.
8. Click More Advanced Options.
10. Click Search Subfolders.
11. Click Search.
12. Determine if any of the files listed in the search results are needed. If not, delete the files. Otherwise, for required files (for example, Windows system files), modify the time stamps as required.

Note: There are shareware programs for Windows that you might like to use for changing file and folder time stamps; for example, Attribute Magic Pro can be downloaded from: www.elwinsoft.com.
3.22 Will services always keep the same service number per server in Operations Manager?

A: No. The numbers attached to Voice Services are based on the SNMP index and will vary from time to time, as well as from system to system.
3.23 How can I get a service down event to give me the service name in a trap, instead of the service number?

A: The trap contains the service name. Look at the details in ProductName.

3.24 A device is added in Operations Manager but is not collected during inventory collection.

A: When you are adding the device, ensure that the device selection is Automatic, and that no device filters match the device being added.
3.25 What Windows WMI events are supported for Unity?

A: Operations Manager supports two Windows events for Unity:

· UnityFailoverOrRestart(This is based on a Windows event with ID=1047.
· UMRCommunicationFailure(This is based on a Windows event with ID=110.

3.26  I’m seeing service down events for a service that is actually running.

A: Operations Manager detects whether or not a service is down by checking the SYS-APPL MIB. Perform an SNMP walk on the following MIB: .1.3.6.1.2.1.54. Then send the output to the support alias, cs-operations-manager@cisco.com, for further analysis.
3.27  From a firewall perspective, which TCP ports need to be opened for WMI communication to happen?

A: WMI communication uses port 135 and a random port in the range 1024-65535. So from a firewall perspective, all TCP ports should be opened. However, as a workaround, you can limit the range of ports to be used for WMI communication by

configuring the ports on that device. Only this range of ports, along with port 135, can then be enabled in the firewall.
3.28 Does Operations Manager make HTTP calls to Unified CM 4.2 and above?

A: Yes. Although Unified CM 4.2 uses secure HTTPS communication, Operations Manager sends HTTP packets and relies on URL redirection to use secure HTTPS communication. Therefore, firewall settings should not block HTTP access to any Unified CM systems.
3.29 Although a device acts as the MOH Server, the device capability in Operations Manager does not indicate that it does so.

A: Device capability indicated in Operations Manager includes high-level capabilities such as router, Unified CM, Unity, voice, gateway, etc. It does not indicate lower-level functionalities such as MOH, MTP, Transcoder, etc.
3.30 Devices are stuck in 10% InventoryCollection even though both DFMServer and VHMServer are successfully connected to the Broker.

A: The Operations Manager process requires the FQDN of the machine on which Operations Manager is installed to be fully resolvable. If the FQDN of the machine is not fully resolvable, then Operations Manager processes cannot communicate with the VHMServer and DFMServer. Use "ping <hostname>.<domainname>" to verify whether the FQDN is fully resolvable. For example, ping cuombox.cisco.com executed from the Operations Manager machine should work successfully.
3.31 The Phone Access switch is not recognized as such.

A: Telnet to the switch and execute the following Cisco IOS command: show module.
Also, SNMP walk the OID 1.3.6.1.4.1.9.5.1.3.1.1. Collect the information, and e-mail it to the cs-operations-manager@cisco.com alias.
3.32 The VHM.log file is growing indefinitely without any roll-up.

A: To roll up the VH<.log file, you must execute a manual script as shown below:
C:\progra~1\cscopx\objects\smarts\bin\> dmctl -s VHM exec roll_log VHM.log

When this script is invoked, an informational message is written to the end of the current log file, it is renamed, and a new log file is created. Best practice is to create a script that will test the log file size and make a call to dmctl roll_log, perhaps on a daily basis.
3.33 How do I configure a non-Administrator WMI login for Unified CM, Unity, and Unified Contact Center machines? 

A: Create a user "abc"; then:
1. Add the user "abc" to one of the following groups: Users, Power Users, or Administrator.

2. In WMI control (wmimgmt.msc), add the "abc" user to ROOT and ROOT\CIMV2 namespace, and give the user "abc" all of the WMI privileges.

4 Service Level View
474.1
Why do I get an error message when I try to launch the Service Level View immediately after rebooting?


474.2
How are T1/E1 ports on Cat6k that are registered to Unified CM shown in the Service Level View?


474.3
One of the clusters is not shown in the Service Level View.


474.4
Why doesn’t the Unified CM that I added into Operations Manager show in the Service Level View?


474.5
I have changed the cluster name in the Unified CM. Why is it still shown under the Standalone cluster?


474.6
Why are RouteLists and RouteGroups that are configured in the Unified CM not shown the Service Level View?


474.7
Why are the changes done in the RL/RG configuration not reflected in the Service Level View?


474.8
Why does the link between the device and the Unified CM/Cluster show as being up in the Service Level View when the device itself is shown as being down (shown in red)?


474.9
Why are some of the gateways not shown in the Service Level View?


474.10
Why are some of the gateways shown in the Service Level View as APP servers or other devices, or shown two or three times?


474.11
The gateways are not part of RL/RG, but they are still not shown in the Service Level View.


474.12
Why is the Unity Server that I configured with Unified CM missing in the Service Level View?


474.13
Why is the SIP device that I configured with Unified CM missing in the Service Level View?


474.14
When launching the Service Level View, I get an error telling me that the server is down.


474.15
Why is the intercluster trunk now shown for a Unified CM cluster?


474.16
Why is the DBReplication Failure red icon present in the Service Level View?


474.17
Why does the Service Level View show the Cat6K media resources (conference bridges) in the Unmanaged report?


474.18
Why am I seeing some device types grouped to report icons?


474.19
Does the Service Level View show unmanaged Unified Contact Center devices and Unified CM Express devices anywhere?


474.20
Where can I see unmanaged devices?


474.21
Why does the report icon tooltip show the wrong number of devices, and why doesn’t the report show deleted devices?


474.22
Which logs are used to collect debug Service Level View issues?


474.23
Why are some Unified CMs in the cluster missing in the Service Level View cluster view?


474.24
Why don’t ICT and RLRG mini-clouds show up in the Service Level View cluster view?


4.1 Why do I get an error message when I try to launch the Service Level View immediately after rebooting?

A: The Service Level View depends on SIR to complete discovery before showing data, so it takes a few minutes after the reboot and system initialization for the data to show up in SIR.

4.2 How are T1/E1 ports on Cat6k that are registered to Unified CM shown in the Service Level View?

A: In a Cat6k T1/E1 scenario, each port has its own IP address and registers with Unified CM. However, to understand that these ports are part of the same card and chassis, the Cat6k that hosts the T1 card needs to be added into Operations Manager. Then the ports collapse into a single IP address of the Cat6k in the Service Level View. 

4.3 One of the clusters is not shown in the Service Level View. 

A: If the Unified CM service is down or the SNMP agent is not responsive on all members of a cluster when Operations Manager starts up, the cluster is not shown in the Service Level View. The easiest way to check this is to see if the ccmTable in CISCO-CCM-MIB contains the list of all Unified CMs.

4.4 Why doesn’t the Unified CM that I added into Operations Manager show in the Service Level View?

A: The list of capabilities shown on the Device Management page should contain Unified CM. If it doesn't contain it, try restarting the SNMP service of the Unified CM and rediscover the device. If the Device Management page still doesn't show the Unified CM in the list of capabilities, restart "CCM Service" of the Unified CM and rediscover the device. Wait a while for the discovery process to complete and show the Unified CM in the Service Level View.

4.5 I have changed the cluster name in the Unified CM. Why is it still shown under the Standalone cluster?

A: After you change the cluster name, make sure you restart the service. For a cluster name change to be reflected in the Service Level View, you need to restart SIRServer and TopoServer processes. Execute the following commands to restart these processes:
> pdterm SIRServer

> pdexec TopoServer
4.6 Why are RouteLists and RouteGroups that are configured in the Unified CM not shown the Service Level View?

A: SIR uses AXL to compute RL/RG information. Make sure that at least one of the Unified CMs in the cluster is added with http credentials. If not, enter the http credentials and rediscover the device. If the http credentials have already been provided for the Unified CM, try restarting the AXL service in the Unified CM, and rediscover the Unified CM.

4.7 Why are the changes done in the RL/RG configuration not reflected in the Service Level View?

A: Any changes done in the RL/RG configuration in the Unified CM are reflected only after the next mjor discovery. Otherwise, the Unified CM must be rediscovered if it is to be reflected in the Service Level View before the next major discovery. Major discovery runs once per hour.

4.8 Why does the link between the device and the Unified CM/Cluster show as being up in the Service Level View when the device itself is shown as being down (shown in red)?

A: A device is shown in red when the management interface on that device is down. But the connectivity between Unified CM and the device is computed based on the registration status held by the Unified CM. 
4.9 Why are some of the gateways not shown in the Service Level View?

A: Check whether the gateways are part of RL/RG. If they are, they will be shown in the RL/RG report only, and not in the map view of the Service Level View.

4.10 Why are some of the gateways shown in the Service Level View as APP servers or other devices, or shown two or three times?

A: When the gateway in question has multiple capabilities such as MGCP, H323, and SIP registration with a Unified CM, one virtual device for each capability is shown separately in the Service Level View. If the gateway has all of the above capabilities, then it is shown three times, but with different capabilities.
Sometimes a virtual node may also go into the RL/RG report based on the configuration, in which case that particular virtual node is not shown in the map view. If the gateway is configured with a Media Resource (Transcoder/hardware conferencing resources/software conferencing resources) and registered with Unified CM, it is shown as an App Server in the Service Level View regardless of whether or not the gateway or port is configured under RL/RG.
Also, a single gateway can appear both in the Service Level View map and the RL/RG report, based on port configuration. For example, if a gateway has two MGCP ports registered with Unified CM, and one of the ports is configured under a route pattern under RL/RG, then the gateway is shown as an MGCP gateway in the Service Level View map, as well as in the RL/RG report, with corresponding port details. If both (or all) ports are configured under RL/RG, the gateway is shown only in the RL/RG report.
4.11 The gateways are not part of RL/RG, but they are still not shown in the Service Level View.
A: The gateways are shown in the Service Level View only if they have a proper registration with any Unified CM. If the gateways have a proper registration and it is not shown in the Service Level View, check the following MIBs to see if either of them contains the gateway entry:
· 1.3.6.1.4.1.9.9.156.1.11 (if the gateway is of type H323)
· 1.3.6.1.4.1.9.9.156.1.3 (if the gateway is of type MGCP)
4.12 Why is the Unity Server that I configured with Unified CM missing in the Service Level View?

A: Do a MIB walk for the following table on the Unified CM to make sure the Unified CM MIB is responding properly:

.1.3.6.1.4.1.9.9.156.1.12.1 (ccmVoiceMailDeviceTable)

4.13 Why is the SIP device that I configured with Unified CM missing in the Service Level View?

A: Make sure that the Unified CM is in the Fully Monitored state and that AXL Service is enabled on one of the Unified CMs in the Unified CM Cluster. SIP device information is obtained using HTTP/AXL from Unified CM.
4.14 When launching the Service Level View, I get an error telling me that the server is down.

A: Try the following:
1. If you restart the daemon manager or the SIR/SLV, wait for a half-hour and then try relaunching.

2. If the problem persists, check csocpx/objetcs/sir/work/sir.xml. This file might not have been generated, in which case the Service Level View will not come up.

3. If Operations Manager has been installed on an IBM server, then shut down the IBM WMI CIM Service:
a. Go to Control Panel >Administrative Tools > Services.

b. Locate the IBM WMI CIM Server in the Services window; right-click and choose Properties.
c. In the dialog box, find Startup type and change it from Automatic to Manual.

d. Stop the service.
e. From a command prompt, execute o pdterm SIRServer o pdexec TopoServer
4. If all is fine and the problem persists, enable logging for the Service Level View and SIR and execute the following:
> pdterm SIRServer

> pdexec TopoServer
5. Wait for a half-hour and email the following logs to the cs-operations-manager@cisco.com alias:
CSCOpx\objects\topo\work

CSCOpx\log\CUOM\topo

CSCOpx\log\TopoServer.log

CSCOpx\log\SIRServer.log

CSCOpx\log\CUOM\sir\sir.log

CSCOpx\objects\sir\work\sir.xml

CSCOpx\objects\sir\work\Thread-xx-sirxx.xml

6. Disable logging for SIR/SLV. 
4.15 Why is the intercluster trunk now shown for a Unified CM cluster?

A: Check intercluster trunk details by walking MIB OID ccmH323DevName .1.3.6.1.4.1.9.9.156.1.11.1.1.2 on both endpoint Unified CMs. Each of the Unified CMs should respond to the other Unified CM name.
If the intercluster trunk is part of the RG/RL list, it isn’t shown in the map view.

4.16  Why is the DBReplication Failure red icon present in the Service Level View?

A: Note the following:
1. The DBReplicationFailure event is not auto-cleared in Operations Manager. You must ensure that the problem is resolved, and acknowledge (not manually clear) the event in Operations Manager. Until the event is acknowledged, the Service Level View will continue to show a red database icon.

2. Ensure that all DBReplicationFailure events that occurred on Unified CM and belong to the cluster are acknowledged. (You will see a green database icon in the Service Level View.)
3. If you have already manually cleared the events, Operations Manager will have no mechanism to remove the red Database icon from the Service Level View. This bug is being tracked with defect CSCso02084.

4.17 Why does the Service Level View show the Cat6K media resources (conference bridges) in the Unmanaged report?

A: On CAT 6K, each card has an independent IP address, and when those IP addresses are not managed within Operations Manager, they are grayed out.

4.18 Why am I seeing some device types grouped to report icons?

A: To keep the Service Level View clean and usable, when the number of logical devices per cluster exceeds 50, the Service Level View regroups (based on device capability) until the total icons in the cluster view is less than or equal to 50. This number can be changed as follows:
· Edit the the property DEVICE_MAX_COUNT_FOR_STARTING_REPORT in CSCOpx\MDC\tomcat\webapps\triveni\topo_flash\topo.properties.

· Restart TopoServer by typing 
pdterm TopoServer

pdexec TopoServer

4.19 Does the Service Level View show unmanaged Unified Contact Center devices and Unified CM Express devices anywhere?

A: No, the Service Level View doesn't show unmanaged Unified Contact Center devices or Unified CM Express devices. The Service Level View shows unamaged devices that are part of Unified CM clusters.

4.20 Where can I see unmanaged devices?

A: In each cluster's drilled-down view, there is a report icon named UNMANAGED. Clicking this report icon opens a report with all unmanaged devices of that cluster.

4.21 Why does the report icon tooltip show the wrong number of devices, and why doesn’t the report show deleted devices?

A: This is because SIR takes some time to update the Service Level View. The device is immediately removed from the report. So you need to wait for some time for the tooltip to be updated.

4.22 Which logs are used to collect debug Service Level View issues?

A: Enable debug logging for the Service Level View (Administration > Logging > Service Level View > All; click Apply.
Collect the following logs:

CSCOpx\objects\topo\work*.*

CSCOpx\objects\sir\work\SIRCIM*.xml

CSCOpx\log\TopoServer.log

CSCOpx\log\SIRServer.log

CSCOpx\log\CUOM\topo\ *.log

CSCOpx\log\CUOM\sir\ *.log

4.23 Why are some Unified CMs in the cluster missing in the Service Level View cluster view?

A: SIR (the Service Level View backend server) needs certain configurations in a Unified CM cluster, without which it may not be able to fully discover the topology. To discover the entire topology, AXL service must be running on any one of the non-Call Processing nodes. 
4.24 Why don’t ICT and RLRG mini-clouds show up in the Service Level View cluster view?

A: If ICT and RLRG are configured in a cluster, they are obtained through AXL query to Unified CM and shown in the Service Level View. If they are missing, there is an issue with the AXL/http credential, or the Operations Manager machine is unable to communicate with the Unified CM machine. One reason is that the Operations Manager IP address was not added to the Unified CM Access Control List. To summarize, the Operations Manager server IP address was not permitted for the SOAP and CCMApi directories under IIS.
Do the following to add the Operations Manager IP address to the Unified CM ACL.
On a Unified CM machine:

1. Under Administrative tools, go to IIS.
2. Right-click CCMApi directory and go to Properties.
3. Choose the Directory security tab.
4. Under "IP address and domain name restrictions," choose Edit.
5. Add the following IP addresses for Operations Manager:
· 158.137.35.32(Primary interface Operations Manager IP address
· 172.18.186.32(Secondary interface Operations Manager IP address
6. Do the same for the SOAP directory.
7. Repeat for all nodes in all clusters.
5 Alerts and Events Display 
475.1
I get the error "Unable to launch AAD. See AAD.log for details" when trying to launch the Alerts and Events Display.


475.2
I get a DynAPI error when the Alerts and Events display is open.


475.3
I’m not seeing any alerts in the Alerts and Events window.


475.4
What does the entry "Unidentified trap" in an Alerts and Events display mean?


475.5
Why do I get an insufficient physical memory alert in Unified CM 5.x?


475.6
Why am I no longer receiving any new events in either the Alerts and Events display or the Service Quality Alerts display?


475.7
There is a delay in receiving new events.


475.8
I can see the event in the Alerts and Events display, but on launching the Event History tool, it says there is no data.


475.9
There are alerts without any events.


5.1 I get the error "Unable to launch AAD. See AAD.log for details" when trying to launch the Alerts and Events Display.
A: If the Alerts and Events display is launched immediately after restarting the daemon manager (either after a fresh install or after applying a patch), this error message can be seen. The daemon manager takes up to 30 minutes to come up completely, so launching the Alerts and Events display after 30 minutes of Daemon Manager startup should eliminate the problem.

5.2 I get a DynAPI error when the Alerts and Events display is open.

A: If you get a DynAPI? error upon clicking an alert or event, refresh the page. This issue is fixed in Operations Manager 2.0.1 .

5.3 I’m not seeing any alerts in the Alerts and Events window.

A: Rarely, there are no alerts on any devices being monitored in Operations Manager. In such a case, no alerts are seen. 

5.4 What does the entry "Unidentified trap" in an Alerts and Events display mean?

A: Please search for the phrase "Unidentified trap" in the help document.

5.5 Why do I get an insufficient physical memory alert in Unified CM 5.x?

A: This is a known bug in Unified CM. Contact the Unified CM team for the fix.

5.6 Why am I no longer receiving any new events in either the Alerts and Events display or the Service Quality Alerts display?

A: Verify that the EPMServer is running by executing the command pdshow EPMServer from the command prompt. If it is running normally, then check the EPMServer.log under /CSCOpx/logs/CUOM/ for an out-of-memory error. If you find such an error, send the EPM.log under /CSCOpx/logs/CUOM/EPM to the cs-operations-manager@cisco.com alias for analysis.

5.7 There is a delay in receiving new events.

A: Check for a burst of events (more than 2000 events per polling cycle) in the Fault History during that time stamp. If you find one, this is an expected behavior. The system should come back to normal in no more than two-and-a-half hours.

5.8 I can see the event in the Alerts and Events display, but on launching the Event History tool, it says there is no data.

A: This is seen if the event is older than 24 hours. The cross-launch tool for Event History shows event information for 24 hours only. This information can be viewed from the Alert and Event History by selecting the appropriate options as described in the help document.

5.9 There are alerts without any events.

A: This happens when the last event is auto-cleared. This situation does no harm. The alert can be manually cleared to remove it from the Alerts and Events display.

6 Service Quality Alerts Display
476.1
I don't see any alerts in the Service Quality Alerts display. What could be the problem?


476.2
Which logs should I collect to debug Service Quality Alerts display issues?


6.1 I don't see any alerts in the Service Quality Alerts display. What could be the problem?

A: The Service Moniter may not be configured to receive traps. 
6.2 Which logs should I collect to debug Service Quality Alerts display issues?

A: Enable debug logging for Service Quality Alerts display/QoVM (Administraton > Logging >):
1. iGo to Service Quality Alerts Display > Service Quality Manager.  

2. Select All and click Apply.  

3. Collect the following logs:
CSCOpx/log/QoVMServer.log

CSCOpx/MDC/Tomcat/logs/*.*

CSCOpx/log/CUOM/QoVM/*.*

CSCOpx/log/CUOM/QOVAD/*.*

7 Fault History
477.1
What are the logs to collect to debug Fault History issues?


7.1 What are the logs to collect to debug Fault History issues?

A: Enable debug logging for Fault History (Administraton > Logging):
1. iGo to Alert and Event History.  

2. Select All and click Apply.  

3. Collect the following logs:
CSCOpx/log/FHServer.log

CSCOpx/log/CUOM/FH/*.*

CSCOpx/MDC/Tomcat/logs/*.*

8 IP Phone Report
478.1
The Device Management page shows no phones/Unable to discover phones for a particular Unified CM.


478.2
The switch details are missing for some phones.


478.3
Unable to discover phones of a specific model.


478.4
The phone count in the Inventory Analysis report is different from the phone count in the All IP Phones/Lines report.


478.5
Why does the registration status for phones registered to a particular Unified CM show “No”?


478.6
The phone discovery process is stuck. What should I do?


478.7
What are suspect phones?


478.8
How do I run a manual phone discovery?


478.9
How do I enable logging for IPIF?


478.10
Where are IPIU logs located?


478.11
Why is some physical phone data not yet updated?


8.1 The Device Management page shows no phones/Unable to discover phones for a particular Unified CM.

A: Try the following:
• Verify that Unified CMs are in Monitored/Partially Monitored state in the system (in the Device report).

• Check whether or not "Cisco CallManager" capability is discovered properly for the Unified CM. (See section 3.9 for more details.)

• Check if the phones are registered to the Unified CM by doing an SNMP walk on

ccmPhoneTable (OID .1.3.6.1.4.1.9.9.156.1.2.1).
• Make sure ccmPhoneProductTypeIndex (OID .1.3.6.1.4.1.9.9.156.1.2.1.1.18) returns nonzero values. If values are zero, restart the SNMP service on Unified CM.
• Check the SNMP walk of ccmPhoneExtnTable OID .1.3.6.1.4.1.9.9.156.1.2.5.
8.2 The switch details are missing for some phones.

A: Try the following:

• Check whether or not the switch model is supported by Operations Manager.
• Check if the switch is in the Monitored state.

• Check if SNMP walk on switch cdpCacheTable .1.3.6.1.4.1.9.9.23.1.2.1 returns phone information.
8.3 Unable to discover phones of a specific model.

A: Check whether or not the phone model is supported by Operations Manager.

8.4 The phone count in the Inventory Analysis report is different from the phone count in the All IP Phones/Lines report.

A: The Inventory Analysis report contains suspected phones in addition to registered phones.
8.5 Why does the registration status for phones registered to a particular Unified CM show “No”?

A: Check whether or not the SNMP walk for the following variables in sysApplMIB returns values:

­ sysApplInstallPkgProductName(OID -> .1.3.6.1.2.1.54.1.1.1.1.3)

­ sysApplRunCurrentState(OID-> .1.3.6.1.2.1.54.1.2.1.1.3)
If no values are returned, restart the SNMP service on the Unified CM and try again.
8.6 The phone discovery process is stuck. What should I do?

A: Restart the phone discovery process by executing the following commands:
pdterm PIFServer

pdexec SRSTServer
8.7 What are suspect phones?

A: Phones that are connected to a switch and not registered to any Unified CM are detected as suspect phones. In addition, all entries in ccmPhoneFailedTable for each Unified CM are shown as suspect phones.
8.8 How do I run a manual phone discovery?

A: Go to Devices > Device Management > IP Phone and schedule an immediate discovery. You can check the status of the discovery under IP Phone Collection Status on the same page.

8.9 How do I enable logging for IPIF?

A: Go to Administration >Logging.
Check all the boxes under IP Phone Information Facility and IP Phone Information Facility Server. Click Apply to save the changes.

8.10 Where are IPIU logs located?

A: The following is a list of the IPIU log locations:

CSCOpx\log\pif.log

CSCOpx\log\PIFServer.log

CSCOpx\log\ipiu\ipiuapp.log

CSCOpx\MDC\tomcat\logs\stdout.log

CSCOpx\MDC\tomcat\webapps\triveni\WEB-INF\classes\pif.conf

8.11  Why is some physical phone data not yet updated?

A: Physical phone data (serial number, load ID, application ID) is collected every day at 4:00 a.m. It is independent of the phone inventory collection.
9 Notifications
479.1
How do I decode the trap sent from Operations Manager?


479.2
What are some guidelines for setting up notifications?


479.3
Why I am not receiving clear events even when I have selected "Critical"?


479.4
I have customized "Critical" event severity as "Informational" in Event Customizations. However, I still receive e-mails on notification groups for which "Informational" severity is not selected.


479.5
I have configured an event set with a list of events for a notification group. Why am I still seeing alert notifications for other events that are not selected in the event set?


479.6
Can I set the SMTP server (e-mail server) default?


479.7
Which log should I enable for notifications? What are the logs to be collected?


479.8
Traps are not received by Operations Manager even though a device is configured to send traps.


479.9
Notifications are not working.


479.10
How do I test the connection to the SMTP server?


479.11
E-mail notification is no long working. See the following error message from the logs:


479.12
After removing a particular type of event from an event set, why do I continue to receive notifications for that type of event?


9.1 How do I decode the trap sent from Operations Manager?

A: The trap sent from Operations Manager is based on CISCO-EPM-NOTIFICATION-MIB. To learn more about the CISCO-EPMNOTIFICATION MIB, please go to the following link:
http://www.cisco.com/en/US/docs/net_mgmt/mobile_wireless_transport_manager/6.0/developer/guide/appD.html
9.2 What are some guidelines for setting up notifications?

A: Do the following:

• To receive alert-based notifications, select the corresponding alert severity and alert status.

• To receive event-based notifications, select the corresponding event severity and event status (event set is applicable only for event-based notification).
• Select "Include updates to group membership" for automatic update of devices in the group for notification.
• Check and enter the correct port number and trap destination IP address. The default port is 162.

• Check and enter the correct SMTP server and destination e-mail address.

• Check and enter the correct port number and syslog destination IP address. The default port is 514.

• If you have configured multiple notification groups, enter Customer Identification or Customer Revision in the notification configuration. This will help in identification of the notification group from the e-mail received.
9.3 Why I am not receiving clear events even when I have selected "Critical"?

A: All clear events are of Informational severity. You must select "Informational" in the notification criteria.

9.4 I have customized "Critical" event severity as "Informational" in Event Customizations. However, I still receive e-mails on notification groups for which "Informational" severity is not selected.

A: Event Customizations are applicable only for outbound notifications as per design, However, Operations Manager internally processes an event’s default severity only.

9.5 I have configured an event set with a list of events for a notification group. Why am I still seeing alert notifications for other events that are not selected in the event set?

A: Whenever an alert on the device is updated because of any event, you will get an alert notification. It is not based on the event set you select. Event-set selection is only for filtering event notifications.

9.6 Can I set the SMTP server (e-mail server) default?

A: Yes. In Administration > Preferences, you can apply the default SMTP server to be configured in notification groups.

9.7 Which log should I enable for notifications? What are the logs to be collected?

A: Enable logging in Administration > Logging > Notification Services. Collect all the logs avaliable under CSCOpx/log/CUOM/NOTS.

9.8 Traps are not received by Operations Manager even though a device is configured to send traps.

A: Check to see if port 162 is being used by other devices. UDP ports 162 and 9009 (the SNMP trap port) must be free and used by Operations Manager only. Use net stat -a -b to verify that the process using the port is Operations Manager. Go to Windows Management to check the process details.

9.9 Notifications are not working.

A: In some setups, notifications won’t work for bulk e-mails. Check McAfee antivirus; the "bulk message" check box must be disabled.
9.10 How do I test the connection to the SMTP server?

A: Do the following:
1. Open a Windows command prompt on the Operations Manager/Service Monitor server.
2. Enter the command telnet <customer's smtp server IP> 25.
You should be connected to the SMTP server at this point. If you are not connected, then one of the following conditions exist:
· A firewall on the Operations Manager/Service Monitor server is blocking port 25.

· Something on the network is blocking port 25.

· The SMTP server is not set to accept connections on port 25.
If you get a response that says "250 messages accepted for delivery" and still don't receive the contents in the e-mail, contact the system administrator to find out why the e-mail is not sent.

The following is sample output that you should see when connecting to the SMTP server and sending a test e-mail:

------------------

C:> telnet beasley.cisco.com 25 <--------------put here yoursmtp server

220 beasley.cisco.com ESMTP Sendmail 8.8.6 (PHNE_14041)/CISCO.SERVER.1.2

ready at Mon, 11 Oct 2004 10:24:29 -0700 (PDT)

C:> EHLO beasley.cisco.com

250 beasley.cisco.com Hello [172.30.224.18] (may be forged), pleased to

meet you

C:>MAIL FROM :drizvi <-------------a real user

250 drizvi... Sender ok

C:>RCPT TO :drizvi@cisco.com <-------------the email address you can check for emails

250 drizvi@cisco.com... Recipient ok

C:>DATA

354 Enter mail, end with "." on a line by itself

subject:Hello how are you

250 KAA08192 Message accepted for delivery

quit

221 beasley.cisco.com closing connection

Connection to host lost.

C:>

------------------

9.11 E-mail notification is no long working. See the following error message from the logs:

"22-Sep-2008|16:14:51.836|INFO |NOTSNOTIFYFAIL|EmailProcessorWorker|EmailUtility|

createAndSendMail()|E-mail send failed from:operationmanager@ciscoworks.com

to: *XXXX@XXX.XXX *for Event:ServiceDown|javax.mail.SendFailedException: Sending failed;

nested exception is: javax.mail.SendFailedException: Invalid Addresses;

nested exception is: javax.mail.SendFailedException: 550 5.7.1 Unable to relay for

XXXX@XXX.XXX

at javax.mail.Transport.send0(Transport.java:219)

at javax.mail.Transport.send(Transport.java:81)

at com.cisco.nm.trx.nots.notsproc.EmailUtility.sendEmail(Unknown Source)

at com.cisco.nm.trx.nots.notsproc.EmailProcessor$EmailProcessorWorker.run(Unknown

Source)"
A: Many SMTP servers use some sort of protection against e-mail spamming. This allows only trusted users or computers to send e-mail via the server.

Possible causes:

· The SMTP server does not allow relaying unless you are sending e-mail from a trusted IP address or use proper authentication.

· The Microsoft Exchange server is set up to block SMTP relaying.

· Some servers allow you to send e-mail internally but not externally.

· Some SMTP servers require the e-mail user to log in and check their POP3 e-mail at least once on a given IP address before allowing that user to send SMTP e-mail from that IP address. Once the POP3 e-mail is checked using a valid username and password, the computer’s IP address is then automatically added to a safe list on the server. This is another way to prevent spamming.

· Relaying Denied is a common safety measure used by SMTP servers when a certain e-mail address and its mail server are put on a blacklist for e-mail relay spam violations. Many honest e-mail servers are put on this list because someone broke through and used their server to relay spam. Various blacklists are available and SMTP servers may subscribe to none, a few, or many of these lists. Therefore you may be able to send e-mail to a blacklisted address through one SMTP server but not through another.
Possible solutions:

· Verify with your e-mail administrator that your e-mail server is set up to allow SMTP relaying from trusted local internal IP addresses.

· Make sure that your computer’s IP address is on the list of trusted clients on the e-mail server.

· Some e-mail servers may allow relaying only if you log in and check e-mail at least once from a given IP address. In this case, you can check your POP3 e-mail first before sending SMTP e-mail from a new computer.

· Some e-mail servers allow SMTP relaying only if you log in and check e-mail within the last hour, day, etc. In this case, you should use the POP3 authentication method to send e-mail.

· Some servers require you to authenticate before sending e-mail. In this case, use the SMTP or Java authentication methods.

· Make sure that your Microsoft Exchange server is configured to allow SMTP relaying either for trusted IP addresses or for authenticated users.

· Make sure that your e-mail administrator has configured your IP address and account to send internal and external e-mail.

9.12 After removing a particular type of event from an event set, why do I continue to receive notifications for that type of event?

Check if the alert-based notification criterion is selected. If so, the event sets configured are not applicable. Choosing the alert-based criterion means that any update in the alert (a status change in any event) will result in notifications being sent.

10 Performance Polling
4710.1
I’m unable to launch a performance graph for CPU, memory, and utilization data.


4710.2
Unable to launch a performance graph for Unified CM 4.1.


4710.3
Perfomance graph launches a blank window. Navigating through the UI gives the message “Check TGU.log for details.”


4710.4
How do I enable performance polling?


4710.5
I get the message "No Data available for the last xx minutes" when I try to launch a performance graph. How do I debug this?


4710.6
What does the asterisk (*) mean in the data files for GSU?


4710.7
I am not seeing any trunk (T1/E1) data for the gateways. How do I troubleshoot this?


4710.8
Where is the performance data collected and stored?


4710.9
How do I enable debug/trace logging for the GPF process?


10.1  I’m unable to launch a performance graph for CPU, memory, and utilization data.

A: Try the following:
· Make sure the device is in the Monitored state. If the device is in the Partially Monitored state, verify that its credentials are correct.
· Check the error log file (NMSROOT\data\gsu_#GSUDATA#_\Error.log) to see whether there have been any errors while collecting data for the device.
· Check the data file (NMSROOT\data\gsu#GSUDATA#\<device-ip date>.csv) for any errors

· Check the GSU log files (NMSROOT\log\gpf\poller.log) for any errors related to the devices.

Unified CM-specific errors such as HTTP error 500 are due to the settings on the Unified CM. To fix this:
1. Open the Unified CM Admin page.
2. Select System > Enterprise Parameters.
3. Set the Unified CM Web Services parameters to the maximum values. If it still doesn’t work, the other option is to set the Unified CM’s Cisco Database Layer Monitor Service Parameter 'Maximum AXL Writes Allowed per Minute' which has a default value of 20.

10.2 Unable to launch a performance graph for Unified CM 4.1.

A: Sometimes performance data is not collected due to a Unified CM 4.1 WebKnight firewall problem. WebKnight filters potentially harmful XML snippets that are submitted to the web server. It was added in a recent release for security against 'injection' attacks. However, WebKnight has been found to filter out a couple of valid perfmon counter-related serviceability SOAP requests that contain the characters '<object', resulting in HTTP 999 errors.

Check the ethereal capture of GSU to see if the "999 No hack Inc" error is seen in the SOAP packet. If you see this error, then Unified CM needs the 4.1.SR5V patch. If you do not see this error, send the logs mentioned in the 'Troubleshooting with Logs' section to the cs-operations-manager@cisco.com alias.

10.3 Perfomance graph launches a blank window. Navigating through the UI gives the message “Check TGU.log for details.”

A: This happens when the connection between the server and client (over a WAN) is slow. Try launching the graph on the same machine where the Operations Manager server is installed.

10.4 How do I enable performance polling?

A: Do the following:
1. From Administration -> Polling and Threshold -> Polling, select the group for which to enable polling.
2. Select voice utilization settings from the drop-down list, and enable the check boxes for the polling parameters listed.

10.5 I get the message "No Data available for the last xx minutes" when I try to launch a performance graph. How do I debug this?

A: This message indicates that polling data has not been collected for the device. Verify that the device is fully monitored and send the log files under CSCOpx\log\gpf folder to the cs-operations-manager@cisco.com alias.
10.6 What does the asterisk (*) mean in the data files for GSU?

A: An asterisk (*) indicates that the data is either not relevant for that type of record for that device, or the data is not being collected for that record type.

10.7 I am not seeing any trunk (T1/E1) data for the gateways. How do I troubleshoot this?

A: Try the following:
• Check whether the capability is H323 or MGCP in the Detailed Device View for the gateways. If either is not present, no trunk data can be collected.

• For a H323 gateway, make sure that polling is enabled for "H323 gateways" or that the specific cluster polling is enabled (if it is part of a Route group).

• The H323 gateway CSV data file should contain the relevant records (112, 113, 114, 115, 117) depending on the configuration (T1 PRI, E1 PRI, or ISDN). If the device is configured for these trunks and the data file is not present, check the Error.log (grep on the device IP address). You may have an unsupported software version or model.

• For an MGCP gateway, make sure that polling is enabled for "Voice gateways" or that the specific cluster polling is enabled (if it is part of RG).
• The Unified CM under which MGCP is registered should be shown in the gateway’s Detailed Device View under cluster connectivity as registered. The Unified CM should be fully monitored, and Unified CM polling should be enabled so that CSV data files are present for the Unified CM. If this condition is met, the MGCP gateway CSV data file should contain records 110, 111, 116, depending on the configuration. If none of these records are present, check the Unified CM to see whether this gateway is registered. From the RTMT tool, check whether this device is listed under "Cisco MGCP Gateways."

10.8 Where is the performance data collected and stored?

A: GSU data is available in the /data/gsu/#gsudata directory.
10.9 How do I enable debug/trace logging for the GPF process?

A: Enable GSU debug logging as follows:

1. Go to CSCOpx/gpf.

2. Open the gpflog4j.properties.

3. Change the following entries:

    Original: log4j.category.GpfPoller=warn, pollerlog
    Change to: log4j.category.GpfPoller=debug, pollerlog

    Original: log4j.appender.pollerlog.MaxBackupIndex=6
    Change to: log4j.appender.pollerlog.MaxBackupIndex=60

    Original: log4j.category.GpfAdapter=warn, adapterlog
    Change to: log4j.category.GpfAdapter=debug, adapterlog

4. Run the logreload.bat.

5. Wait for 10 minutes.

6. Send the following files:

    CSCOpx/log/gpf/*

    CSCOpx/log/gpf

    and the latest CSCOpx\data\gsu_#GSUDATA#_*.*
11 Synthetic Testing
4711.1
How do I configure phones for synthetic tests?


4711.2
Synthetic phones fail to register.


4711.3
Is there a way to set up a synthetic test in Operations Manager to allow testing of outbound calls? A customer has a problem with gateways accepting calls and dropping them, but they are calls to an outside line. Can these tests be done using a batch job? The circuit pings fine, and the gateway is responsive.


4711.4
The Synthetic Tests database is corrupt. How do I clean it up?


4711.5
An End-to-End Call test is failing. How do I debug this?


4711.6
A Unity Message-Waiting Indicator test is failing. How do I debug this?


4711.7
How can I debug if phones are unable to call each other?


4711.8
How can I back up and restore tests?


4711.9
Other Tips?


11.1  How do I configure phones for synthetic tests?

A: When configuring phones:

· Create one phone extension number and one MAC address for each test and use it for that test only. Make sure that the combination of the phone extension number and the MAC address used in a test is unique across the voice cluster.

· The MAC address for synthetic phones must be between 00059a3b7700 and 00059a3b8aff.

· The SIP URI should be in the format sip:extn@ccm; for example, sip:7690@ctsd.cisco.com.
Failure to follow these recommendations may result in synthetic test failures.

For the following synthetic tests, there are special requirements for the target phones:

· Message-Waiting Indicator Test(When creating the subscriber on Cisco Unity that you will use for synthetic testing, configure the subscriber according to the following:

· Deselect the ‘Set subscriber for self-enrollment at next login’ check box; otherwise, you will have to use a real phone to dial into the Cisco Unity device and complete the personalization process.

· Set the password option to ‘Password never expires.’
· Emergency Call Test(The outgoing PSAP must use a local phone (not 911). Also, for the OSAN, use a synthetic phone only (do not use your local onsite security phone).
11.2 Synthetic phones fail to register.

A: Try the following:

· Verify that the phones are configured with the correct MAC address in Unified CM and that the call-processing Unified CM is used in the tests.

· If you originally installed Operations Manager 2.0 and have upgraded to 2.0.1 (if this is not a fresh install), you may find that Operations Manager cannot register synthetic phones with Unified CM.

For this issue, follow the steps under question 11.4.

11.3 Is there a way to set up a synthetic test in Operations Manager to allow testing of outbound calls? A customer has a problem with gateways accepting calls and dropping them, but they are calls to an outside line. Can these tests be done using a batch job? The circuit pings fine, and the gateway is responsive.

A: Using an End-to-End Call test, you can make the destination phone an outbound PSTN number. However, that may not help to test call-dropping, because the media stream is played in synthetic tests only for a small constant duration that cannot be increased. If a call drops after a longer duration, this End-to-End Call test may not be helpful.
11.4 The Synthetic Tests database is corrupt. How do I clean it up?

If there are too many tests configured on the database, do a backup of the synthetic tests, by exporting, before cleaning the database. You can recreate the tests by importing the back again.
1. Go to the directory "CSCOpx\objects\ama\definitions" and check its contents. It should contain only the following two files:
· AMACore_23.definitions.xml
· AMAIPServices_21.definitions.xml
You may have an additional file, AMACore_xx.definitions.xml. If you see this file or any others, delete them  and retain only the above-mentioned two files.
2. Clean the Synthetic Test database:
a. Stop STServer (pdterm STServer).
b. Using a browser, log in to Operations Manager: http://[server-name]:1741
c. In the same browser window, type the following URL:
http://[server-name]:1741/dbreader/dbreader.html[image: image7.png]



d. Enter "itemInvUser" as the database username.
e. Enter "itemInv" as the database name.
f. Enter <data base passwd> (try "c2kY2k" as the default password). If this password doesn’t work, you need to change the database password by doing the following:
1)
Stop the CUOM daemon manager: Run the following command:
net stop CRMDmgtd
2)
Go to the c:\<CUOM Install dir>\bin directory.
3)
Run the following command:

perl.exe c:\>CUOM Installdir>\conf\itemDb\bin\ChangeItemDbPasswd.pl <New Password>
g.
Start the CUOM Daemon Manager: Run the following command:
net start CRMDmgtd
Note:
If you have changed the database password and restarted the daemon manager, start again from the beginning (from Step 2).

h.
Copy the SQL statements (below) into the text area and click Execute SQL.
 -------------------------------------------------------------------------------------------------
DROP TABLE AMACiscoActivationDependency;
DROP TABLE AMACiscoActivationPeriod;
DROP TABLE AMACiscoAMACyclePartHeader;
DROP TABLE AMACiscoAMACyclePrompt;
DROP TABLE AMACiscoAMACyclePromptIPServices;
DROP TABLE AMACiscoAMACyclePromptSkinny;
DROP TABLE AMACiscoAMACyclePromptTextual;
DROP TABLE AMACiscoAMACyclePromptSIP;
DROP TABLE AMACiscoAMACycleReplyHeader;
DROP TABLE AMACiscoAMACycleReplyMustExist;
DROP TABLE AMACiscoAMACycleReplyMustExistIPServices;
DROP TABLE AMACiscoAMACycleReplyMustExistSkinny;
DROP TABLE AMACiscoAMACycleReplyMustExistTextual;
DROP TABLE AMACiscoAMACycleReplyMustExistSIP;
DROP TABLE AMACiscoAMACycleReplyMustNotExist;
DROP TABLE AMACiscoAMACycleReplyMustNotExistIPServices;
DROP TABLE AMACiscoAMACycleReplyMustNotExistSkinny;
DROP TABLE AMACiscoAMACycleReplyMustNotExistTextual;
DROP TABLE AMACiscoAMACycleReplyMustNotExistSIP;
DROP TABLE AMACiscoAMAPhaseCycle;
DROP TABLE AMACiscoAMAPhaseCycleMustExists;
DROP TABLE AMACiscoAMAPhaseCycleMustNotExists;
DROP TABLE AMACiscoAMAPhaseCyclePrompts;
DROP TABLE AMACiscoAMAPhaseTestCycle;
DROP TABLE AMACiscoAMARemotePortAccessor;
DROP TABLE AMACiscoAMAService;
DROP TABLE AMACiscoAMATestPhase;
DROP TABLE AMACiscoAssociatedStatistics;
DROP TABLE AMACiscoCollection;
DROP TABLE AMACiscoComponent;
DROP TABLE AMACiscoComputerSystem;
DROP TABLE AMACiscoCSEDependency;
DROP TABLE AMACiscoDependency;
DROP TABLE AMACiscoDiagnosticResult;
DROP TABLE AMACiscoDiagnosticTest;
DROP TABLE AMACiscoElementProfile;
DROP TABLE AMACiscoElementSetting;
DROP TABLE AMACiscoLogicalElement;
DROP TABLE AMACiscoManagedElement;
DROP TABLE AMACiscoManagedNetworkElement;
DROP TABLE AMACiscoManagedSystemElement;
DROP TABLE AMACiscoMemberOfCollection;
DROP TABLE AMACiscoMetaMTD;
DROP TABLE AMACiscoMonitorDefinitionForCase;
DROP TABLE AMACiscoMonitoredApplication;
DROP TABLE AMACiscoMonitorPhaseGroup;
DROP TABLE AMACiscoMonitorPhaseIterator;
DROP TABLE AMACiscoMonitorPhaseParameter;
DROP TABLE AMACiscoMonitorResult;
DROP TABLE AMACiscoMonitorService;
DROP TABLE AMACiscoMonitorServiceStatistics;
DROP TABLE AMACiscoMonitorSpecificService;
DROP TABLE AMACiscoMonitorSummary;
DROP TABLE AMACiscoMonitorTestCase;
DROP TABLE AMACiscoMonitorTestCaseParameter;
DROP TABLE AMACiscoMonitorTestDefinition;
DROP TABLE AMACiscoMonitorTestPhase;
DROP TABLE AMACiscoMonitorTestPhaseIterator;
DROP TABLE AMACiscoMonitorTestPhaseParameter;
DROP TABLE AMACiscoMTDComponent;
DROP TABLE AMACiscoNetworkElement;
DROP TABLE AMACiscoOrderedMemberOfCollection;
DROP TABLE AMACiscoPhaseThresholdTriggers;
DROP TABLE AMACiscoProfile;
DROP TABLE AMACiscoRemotePort;
DROP TABLE AMACiscoRemotePortAccessor;
DROP TABLE AMACiscoRemoteServiceAccessPoint;
DROP TABLE AMACiscoScheduledOutage;
DROP TABLE AMACiscoSeeAlso;
DROP TABLE AMACiscoService;
DROP TABLE AMACiscoServiceAccessPoint;
DROP TABLE AMACiscoServiceServiceDependency;
DROP TABLE AMACiscoSetting;
DROP TABLE AMACiscoSoftwareElement;
DROP TABLE AMACiscoSoftwareElementServiceImplementation;
DROP TABLE AMACiscoStatisticalInformation;
DROP TABLE AMACiscoSystem;
DROP TABLE EmbuClass;
 --------------------------------------------------------------------------------------------------
i.
Restart TOMCAT: Run the commands net stop tomcat and net start tomcat.
j.
Start STServer (pdexec STServer)
3. Wait for 30 minutes. (The synthetic tests won’t run for 30 minutes after restart.)
4. Launch Operations Manager and create the synthetic tests.
11.5 An End-to-End Call test is failing. How do I debug this?

A: Do not create more than 100 End-to-End Call Tests that run at 1-minute intervals. Configure any additional End-to-End Call Tests to run at various intervals greater than 1 minute.

11.6 A Unity Message-Waiting Indicator test is failing. How do I debug this?

A: After you perform a Cisco Unified Communications Manager version upgrade, Cisco Unity synthetic tests that use the Cisco Unified Communications Manager that you upgraded might stop working. If this problem occurs, you should delete the Cisco Unity synthetic test, and then add the synthetic test again. If a Cisco Unity synthetic test fails and the Message-Waiting Indicator light is on, you must configure a real phone with the same extension number used in the test and delete the voicemails manually. Alternatively, you can use the Message Store Manager tool to remove the voice mails. Once this is completed, the test will pass.
For the MWI Test, Operations Manager expects the following keys on the IP phone to work as described:
· #(When pressed, takes the caller to the voicemail recorder after the call has gone unanswered and been forwarded to voicemail. 

· Messages(When pressed, takes the caller to the voicemail login prompt.

· 1(When pressed, take the caller to “New Messages” in the voicemail menu when logged in.

· 3(When pressed, deletes voicemail message after new messages have been accessed.

If the above keys are customized or modified in the actual setup, the Message-Waiting Indicator Test will fail. The workaround is to configure the keys to work in the default fashion described.

11.7 How can I debug if phones are unable to call each other?

A: Your calls may fail with one of the following errors:
· "The dialed number is invalid or busy."

· "The Receiver phone did not go off hook or was not ready to accept the call. If the destination is a real phone, the phone must be configured to answer the call either via VoiceMail or IVR."

If you get one of these errors, do the following:
· Verify that auto-answer is configured on your lines. (This is required if the "Wait for Answer" and "Enable RTP" options are selected in the Operations Manager synthetic test).
· Verify that you can route to the number you are trying to call (check your Calling Search Spaces/Partitions in Unified CM).
· Ensure that your synthetic phone can call your real destination.
· Using the Dialed Number Analyzer, a tool built into Unified CM 5.X or higher, check your calling plans:
1.
Go to Unified Serviceability > Tools > Dialed Number Analyzer.
2.
Select Analysis > Phones.
3.
Find your registered SEP00059A3B7700 phone.
4.
Select the line number.
5.
Type the number you wish to call.
6.
Do an analysis.

The result should be "Match Result = RouteThisPattern." If you do not get this result, it means you need to check your call routing. Correct as needed, then retry your test.

The following shows the Dialed Number Analyzer output:
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You can also use the Real Time Monitoring Tool (RTMT) on your Unified CM to see whether or not calls are in progress.

The following shows RTMT output:
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11.8 How can I back up and restore tests?

A: Do the following:

· Export(Synthetic tests can be exported by selecting all or selective tests in the GUI and clicking Export.

· Import(Synthetic tests can be imported by clicking Import. You must provide the file that contains the tests. Please refer to the user guide for the format of the Synthetic Tests import file.
11.9 Other Tips?

A: Note the following:
· Synthetic tests do not run for 30 minutes after Operations Manager processes are started. However, during this time, you can still create, edit, or delete tests.

· Starting Operations Manager processes places a high load on the system. To prevent synthetic tests from failing during this time, Operations Manager delays starting them.

· You can change the default setting by doing the following:
1. Edit  the “AMAMonitor.InitialDelay “ parameter in the “AMAServer.properties” file located in <NMSRoot>\etc\cwsi
2. Stop and restart the synthetic transaction server using the following commands:
pdterm STServer
pdexec STServer

3. Start the VHMSTIntegrator process using the pdexec VHMSTIntegrator command.

· When the interval of a synthetic test is decreased from a high value to a low value, the first results for the new value may take longer than the new interval to report. Each synthetic test executes at a time that is controlled by its interval setting. Immediately after you decrease the interval setting for a synthetic test, that transaction might not execute again until a total elapsed time that is longer than the new interval. For example, if you decrease an interval from 180 seconds to 60 seconds, the first results for the new interval may take as long as 240 seconds to report.

· One-time synthetic test failures sometimes occur. Such failures can be due to high loads on the Operations Manager system or other factors that cause Operations Manager to be unable to receive some events from applications.

· Cisco Unity Message-Waiting Indicator synthetic tests may fail. If a Cisco Unity synthetic test fails and the Message-Waiting Indicator light is on, you must configure a real phone with the same extension number used in the test and delete the voicemails manually. Alternatively, you can use the Message Store Manager tool to remove the voice mails. Once this is completed, the test will pass.

12 Batch Testing
4712.1
Any batch-testing tips?


4712.2
Phone/Batch Tests fail with the error "Unable to create provider" or "Cannot connect to provider."


12.1 Any batch-testing tips?

A: Note the following:
· In a single batch test, do not create phone tests that include both Cisco Unified Communications Manager 4.x and Cisco Unified Communications Manager 5.x. You can create a single batch test that includes different versions of Cisco Unified Communications Manager 4.x, or a single batch test that includes different versions of Cisco Unified Communications Manager 5.x, but do not combine 4.x with 5.x.

· The Phone Tests take control of real IP phones and run phone operations on them, so it’s better to schedule them when phones are unlikely to be used.

· Operations Manager takes control of IP phones through Unified CM using JTAPI. Create the JTAPI user in Unified CM, and add the required phones to this user, so that the phones can be controlled. The same JTAPI user is provided in Operations Manager while configuring the phone tests. (The JTAPI user is the same as the application user in Unified CM terminology, so you must create an application user in Unified CM and assign phones to this user.)
12.2 Phone/Batch Tests fail with the error "Unable to create provider" or "Cannot connect to provider."

A: This can happen if the JTAPI username and password provided are wrong. The JTAPI jar files shipped and used by Operations Manager by default may be outdated. If so, they must be updated in Operations Manager.

The following are the steps for updating the JTAPI jar files:
1. Log into Unified CM and go to Applicaton > Plugins.
2. Click the Find button.

3. From the list of displayed plugins, click Download Cisco JTAPI for Windows.
4. Save this file on your PC and execute it to install the Cisco JTAPI client on your PC.

5. In the Operations Manager <install Directory>\objects\bt\lib directory, you will find directories for each Unified CM version.

6. Go to the directory of the Unified CM version that you are using (under 5.0 if your Unified CM version is 5.0), and replace the jar files in that location with the jar files available in the newly installed Cisco JTAPI client. (By default, they are in c:\WINNT\java\lib, if you have not modified the location during Cisco JTAPI client installation.)

13 SRST Testing
4713.1
SNMP V3-SHA1 doesn’t work for SRST tests.


4713.2
Please explain SRST tests.


13.1 SNMP V3-SHA1 doesn’t work for SRST tests.

A: This is a known limitation. For V3 MD5, you need read/write permissions.

13.2 Please explain SRST tests.

A: Note the following:

· Both SRST and the destination router must support IPSLA. 
· (Only Cisco routers running above IOS version 12.4T have the SRST MIB).
· The RTR responder must be enabled for the DST router.
· Operations Manager creates a jitter test between the two routers. When the jitter test fails, it generates an “SRST-entered” event. 
· When phones are shown as unregistered in IPIU for some reason, Operations Manager raises the event SRST SUSPECTED, but when the SRST-MIB is available, it is not generated, because Operations Manager can query the SRST-MIB to get the SRST status.

· When the PIFServer is down, the SRST server will also be down, as they are interdependent.

· IPR (IP phone reachability) runs on the PIF Server. The PIF server must be up, and traces should show that IPR is loaded.

14 Node-to-Node Testing
4714.1
Where are graphs for Node-to-Node tests stored?


4714.2
Why are some fields disabled for Node-to-Node tests?


4714.3
Why is the codec file grayed out in the configuration page of UDP Jitter for VoIP?


4714.4
Where are Node-to-Node test logs located?


4714.5
Why am I unable to select some particular devices alone as source while creating Node-to-Node tests?


4714.6
Can  the Node-to-Node test be configured between two routers that route calls through PSTN?


4714.7
Why do I get the message "No data available" while invoking a trend?


4714.8
Where can I see the reason why a test is in the Error state?


14.1 Where are graphs for Node-to-Node tests stored? 

A: CSCOpx/data/N2Ntests/studyname/*.csv

14.2 Why are some fields disabled for Node-to-Node tests?

A: Some fields are disabled because the Cisco IOS versions don’t support them.

14.3  Why is the codec file grayed out in the configuration page of UDP Jitter for VoIP?

A: This configuration is supported only on Cisco IOS versions  higher than 12.3(4)T. For further information, refer to the “Required Cisco IOS and IP SLA Versions” section in the Online help.

14.4 Where are Node-to-Node test logs located?

A: Logs are available at:
CSCOpx/log/IPSLAServer.log

CSCOpx/log/CUOM/IPSLA/*
14.5 Why am I unable to select some particular devices alone as source while creating Node-to-Node tests?

A: Check whether you are experiencing this bug: CSCsd56824. If this looks like the problem, apply the patch from the following location:
http://wwwin-nmbu.cisco.com/Patches/patch-publisher/listbyproduct.cfm?searchbug=CSCsd56824
14.6 Can  the Node-to-Node test be configured between two routers that route calls through PSTN?
A: A Node-to-Node test is executed between two routers for VoIP related-traffic analysis. It doesn't test PSTN and it cannot be used for monitoring PSTN; therefore, it won't be able to detect PSTN failures.
14.7 Why do I get the message "No data available" while invoking a trend?

A: Check if the record time stamp contains an old date value. If that is the case, check if you are experiencing this bug: CSCin66315. If the device has a Cisco IOS version older than 12.2(15)T and the router uptime is more than 49 days, there is a possibility of experiencing this issue. The workaround is to reload the router or move it to a Cisco IOS version later than 12.2(15)T.
14.8 Where can I see the reason why a test is in the Error state?

A: Select the test and click View. Check the Current Status field.
15 System
4715.1
What is the idle timeout setting on Operations Manager and how do I modify it?


4715.2
What is the recovery procedure if the Operations Manager system runs out of disk space?


4715.3
Is Operations Manager supported over a NAT environment? In the Operations Manager design guide, on pages 10 and 11, there is a service provider scenario. How would a service provider handle an Operations Manager deployment for multiple customers? Would I use multiple instances of Operations Manager reporting to a master Operations Manager?


15.1 What is the idle timeout setting on Operations Manager and how do I modify it?

A: The default timeout setting is 2 hours. To modify the default, edit the file CSCopx/MDC/tomcat/webapps/classic/WEB-IN/web.xml. Enter a new value, in minutes, in place of 120.

15.2 What is the recovery procedure if the Operations Manager system runs out of disk space?

A: The Operations Manager UI may hang and become unresponsive if the system runs out of space on its primary drive or on the drive where Operations Manager is installed if it not the primary drive. Operations Manager will not automatically recover from this situation if disk space is freed up by deleting, archiving, or compressing files. The recovery procedure is to shut down Operations Manager, clean up the files on the disk, and restart Operations Manager. To make the job easier, the logrot tool can be used to keep the log files under control as per the user configuration. The logrot utility helps you to better manage the log files. The utility is included with the Operations Manager image.
Follow this procedure to configure and use the logrot tool:
1. Enter NMSROOT \ bin\perl.exe NMSROOT \bin\logrot.pl -c (on Windows). The logrot configuration menu appears. You have the following options:

· Edit variables.

· Edit log files.

· Quit and save changes.

· Quit without saving changes.

2. Select the Edit variables option to set your backup directory. If you do not set a backup directory, each log will be rotated in its current directory.

3. Select the Edit log files option to add log files you wish logrot to rotate. You can specify log files using fully qualified or relative paths. If a relative path is specified, and the log file does not exist in that path, the default log file path for your operating system will be added during rotation (for example, /var/adm/CSCOpx/log on UNIX).

4. Specify the number of archive revisions. If you do not want to keep any archives, enter 0 (the default) for this option.

5. Specify the maximum file size. The log will not be rotated until this size is reached. The unit is kilobytes (KB). The default is 1024 KB or 1 MB.

6. Specify the file compression type to be used. It can be any of the following:

· * Z(UNIX

· * gz(GNU gzip (available by default on Windows only)

· * bz2(bzip2 (available by default on Solaris 8 and above only)

When deleting log files, you can choose to delete an individual file, a list of files, or all files matching a certain pattern. For example, 1-3 means delete files numbered 1 through 3. A list of comma-separated file numbers(for example, 1,21(means delete files numbered 1 and 21. The pattern string *.log means delete all files that match the pattern *.log .You can also specify the special pattern, * , which means delete all logfiles in the configuration.

To run logrot on Windows, enter NMSROOT \bin\perl.exe NMSROOT \bin\logrot.pl.
15.3 Is Operations Manager supported over a NAT environment? In the Operations Manager design guide, on pages 10 and 11, there is a service provider scenario. How would a service provider handle an Operations Manager deployment for multiple customers? Would I use multiple instances of Operations Manager reporting to a master Operations Manager?

A: Operations Manager can communicate and manage devices over NAT using SNMP, but management capabilities are limited. Many features won’t work; for example, AXL/SOAP-based management will be affected in the NAT environment..
Operations Manager can manage multiple customer deployments as long as there is no overlap in the IP addresses of these multiple customers. If there is an overlap, you will need to deploy multiple Operations Manager instances to handle it. There is no concept of a master Operations Manager sitting on top of multiple Operations Manager instances. Each individual Operations Manager is a standalone manager.

16 Personalized Reports
4716.1
What logs do I collect for Personalized Report issues?


16.1 What logs do I collect for Personalized Report issues?

A: Collect the following logs:
CSCOpx\log\CUOM\IPTHR\ipthr*.log

CSCOpx\log\ITMDiagServer.log
For the Personalized Report, you must enable "IPT Health Report" debug logs in the Administration >Logging page.
Do the following to collect logs:

1. Configure a new Personalized Report.
2. Schedule an export of the report.
3. Wait for the Personalized Report to be generated.
