CHAPTER1

Using Maps

Map View shows a graphical representation of the devices in a group. Map View can be used to:

Organize devices into user-specified groups, for example, all HTTP servers.
Customize individual device icons such as workstations, containers, routers, and bridges.

Indicate relationships among devices by using annotation objects such as rectangles, ellipses, text,
and attached or free lines to. Annotation objects let you organize your map to best represent your
network. Attached lines show a connection between devices and move with the device.

Show status of network link lines.

Map View is accessed from the console on the Devices tab under View > Map View.

Using Map Display Options

Display options let you change the visual representation of a map, and add annotations that help you
monitor dependencies and active monitors. Right-click on the Map View, then select from the following
Display options.

Device Icons. By default the map will show an icon for each device. If you only want to show a dot,
or node, to represent each device, then clear this selection.

Polling Dependency Arrows. If you have set up a device so that it gets polled only if a second
device is down or up (a dependency), then by default you will see an arrow that shows this
dependency. For example, if polling of device A is dependent on the state of device B, the arrow will
point from device A to device B.

Unconnected Links. Select this option to make the map display short lines for links that are not
connected anywhere. If this is cleared, only connected links are displayed. This could be a network
interface that is not connected to another device. It could also be any active monitor (such as HTTP,
or SMTP), in which case, the short line will show green when up and red when down.

Snap to Grid. Select this option to display a grid and automatically align objects along your grid
when they come within a certain distance of it.

Clip Device Names. Select this option if you want to shorten the device display names. The display
names will be terminated at the first space or period in the name. If the display name is a dotted
decimal IP address, Clip Device Names shows only the last digits of the IP address.

Wrap Device Names. Select this option to wrap long display names. The display names will be
wrapped at every space or period in the name.
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Using Arrange Options

Step 1

Step 2

Use the Arrange options to position device icons and annotations (such as lines, rectangles, text) on a
map.

For example, you can automatically arrange device icons:

In the toolbar, click the Select (arrow) tool, then click in the Map view and drag the cursor to draw a
box around the icons you want to select.

Then select Arrange > Arrange All Device Icons. This feature arranges all device icons on the current
map in equally spaced rows starting in the top left corner.

Other ways to arrange map objects include:
¢ Order. You can arrange which annotations are moved to the foreground or background.
e Align. You can arrange icons or annotations so they share a common edge or centerline.

¢ Distribute. You can arrange icons or annotations so they are spaced evenly along a line. You can
arrange icons in a radial format, in rows, or by links.

e Grouping. You can group selected annotations so that they can be arranged or moved as a unit.

e Flip. You can transpose the location of two selected annotations.

Using Device Layout

Step 1
Step 2

Step 3

Map View has a number of options you can use to organize your view of devices. Arrange options are
available from the Arrange menu on the main menu bar and right-click menu. Display options are
available from the View menu on the main menu bar and the right-click menu.

Try the different functions on the Arrange menu until you are satisfied with the device layout.

For example, to clean-up a map, after completing discovery, you can try the following display options:

Select the device group, then click the Map View tab.

Right-click in the Map View, then select Display > Clip Device Names. This removes the domain part
of the device name and shows only the host name.

Select all devices in the view by clicking and dragging a selection box around all devices. Then, from
the Arrange menu, select Distribute > Device Icons in Rows.

If you have a large set of devices or want to represent a topology specific to your network, you can also
use the graphics annotations (such as lines, text, circles) and attached lines to create custom map views.

Lock position can be useful in positioning objects on the map.
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Using Device Types

The Device pool provides Device Types for ten standard device types; and some custom host types. It
also displays any galleries that have been created. When you click one of these devices, it becomes the
active tool. To add the device to the map, select and drag it to the map.

Using Grid Properties

Set these properties from the Cisco netManager console Map view toolbar.

To view the toolbar:

Step 1 Select View > Toolbars > Grid.

¢ Snap to the grid. Select this option to display a grid and automatically align objects along your grid
when they come within a certain distance of it.

e Increase the number of gridlines. This allows you to display more gridlines, letting you place
items closer together when using Snap to the grid.

¢ Decrease the number of gridlines. This lowers the number of gridlines on your map view, spacing
them further apart when using Snap to the grid.

Grouping Objects

The Group function lets you change the layout of multiple map annotations in the Map view.

¢ Group. Allows multiple objects to be grouped together as a single object, which will make all of
the objects react to drawing transformations as one.

e Ungroup. Undoes the group effect so that all the objects that were originally grouped are now
separated objects once again. All transformations done when the object was grouped are kept when
the object is ungrouped.

Note  Youcan also use these features together. For example: You could take 4 different objects and group them
together to form 1 object. Then you could take the grouped object and flip it horizontally or vertically.

Using the Lock Position

To lock objects on the map:

Step1  Right-click and select Lock Position from the menu.

Lock Position keeps an object from moving as you move other items around, or when adding devices to
the map. If you want to change an object position on the map, remove the lock position selection. It is
helpful to lock images or text you place in the background to protect them from changes.
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Mapping Fonts

Specifies the font used for device display names. Click Change Font to open the standard Windows font
selection dialog box. Select the font properties you want to use and click OK. The Sample Label
(AaBbYyZz) shows the new font selection.

Organizing Devices

Step 1
Step 2

Step 3

Map View has a number of options you can use to organize your view of devices. Arrange options are
available from the Arrange menu on the main menu bar and right-click menu. Display options are
available from the View menu on the main menu bar and the right-click menu.

Try the different functions on the Arrange menu until you are satisfied with the topology.

If you have a large set of devices or want to represent a topology specific to your network, you can also
use the graphics tools to create custom map views.

For example, to clean-up a map, after completing discovery, you can try the following display options:

Select the device group, and click the Map View tab.

Right-click in the Map View and select Display > Clip Device Names. This removes the domain part of
the device name and shows only the host name.

Select all devices in the view by clicking and dragging a selection box around all devices. Then, from
the Arrange menu, select Distribute > Device Icons in Rows.

Using Link Lines

In Map View, you can use Link lines to get a graphical view of the network link (the Interface service)
between two devices. Link lines can also show the status of any service which has an Active Monitor on
the device.

The following example shows a map with link lines displayed.

e Router 1 shows a connecting link (see “Connecting Links” section on page 12-5) to device RRA and
this link is currently up. Also shown are eight unconnected links, all of which represent interfaces
on the router. One of the unconnected links is disabled.

e JMA is a workstation that shows two unconnected links that are currently up. These are Ping and
FTP monitors, found under Device Properties > Active Monitors.

¢ RRA is an FTP Server that is currently down and shows five unconnected links, two of which are
down.

By default, links can be rendered in one of three colors:

e Green indicates a service (such as, but not limited to, Interface) that is up. This includes services
that have not yet been polled.

¢ Red indicates a service that is down.

e Gray indicates a service listed in the devices’ Active Monitors list, but not currently monitored.
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e Orange indicates that the device is currently in maintenance mode.

Using Attached Lines

Step 1
Step 2
Step 3

Attached lines show an arbitrary connection between devices and move with the device. These are visual
representations assigned by the user, and not a reflection of a true connection between the two devices.
The true connection between the two devices is done with Link lines.

To draw an attached line:

In Map View, right-click a device. The context menu opens.
Click Attach > Attach to. A line displays next to the curser.

Click the device icon you want to attach to. Cisco netManager draws an attached line between the two
devices.

~

Note  The root device can attach to up to five other devices.

Connecting Links

Connecting links represent a service, for example an interface, that connects two devices. They are
drawn as lines from one device to another. If two devices have mutual links, the single line can consist
of more than one color (if one object is up and the other is down). The center-point of the line back to
the up object is green, while the other half of the line going to the down object is red. In essence, the
color of the line represents the state of the service on the host that the color touches.

Example

If the red part of the line touches "System A" and the green part of the line touches "System B", then we
know that some service on "System A" is the problem.

About Unconnected Links

Unconnected links represent a service that is not connected to some other host, for instance an unused
interface on a router. They are drawn as short lines extending out from the host. The first unconnected
interface is drawn straight up ("12 noon") and the rest are evenly distributed around the host in a
clockwise fashion. You can choose to display or not display the unconnected links.

As these unconnected links show any service for which the device has an active monitor, you can use
this feature to show a visual status of the services. For example, though the device is up (green), you may
see that one of the unconnected links is down (red) and will know to check the services on the device.

Showing Unconnected Links

Unconnected links must be shown for all or none of the devices in a map.

To show unconnected links for all devices:
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Step 1
Step 2

Right-click in Map View to display the pop-up menu.
Then, select Display > Unconnected Links.
Repeat these steps to disable Unconnected Links.

The Unconnected Links option makes the map display short lines for links that are not connected
anywhere. If this is cleared, only connected links are displayed. This could be a network interface that
is not connected to another device. It could also be any active monitor (such as HTTP, or SMTP), in
which case, the short line will show green when up and red when down.

Creating Connected Link Lines

Step 3

Step 4

Step 5

Note

Map View

There are three ways to set up the connecting link lines:

Manually, in the Map View select a device, then right-click the Link > Link to option on the context
menu. (Click Link > Disconnect link to remove the link between devices)

a. Select a monitor for which you want to display a link line, then click OK. The link line cursor
appears.

b. Drag the cursor to another device and click to create a link.

Automatically, during device discovery when using SNMP SmartScan (Click File > Discover Devices
> SNMP SmartScan)

S

Note  The Interface service must be included in the scan.

Automatically, when you right-click a device, then click Properties > Active Monitors > Discover.

e When you use one of the automatic discover options, particularly when discovering interfaces on a
router or switch, you need to enter the SNMP community string in the appropriate scan dialog. This
lets the scan identify all the interfaces on the device.

If scanning a specific device (from the Device Properties > Active Monitors dialog), with the
device selected, right-click Properties, then select Credentials. In the SNMP v1/v2/v3 credentials
box, select the Public Read Community. Click Active Monitors, then click Discover.

e When creating links manually, you are always creating a connected link. If there was an unconnected
link for the service, it will be replaced by the connected link.
Both connect and disconnect skips the dialog if there is only one active monitor on the device
because it assumes you meant that monitor.

Map View shows a graphical representation of your devices. As in Device View, each device's icon
provides information about its device type and status. Map View can also show the status of network
interfaces (by Using Link Lines, page 12-4) and provide visual indications of polling dependencies.

Current device state is shown by the color and shape of a device icon.

e Device ASA is a workstation that is currently up.
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e Device HRA is a workstation that is currently in maintenance mode.
e Device JMA is an FTP server that is currently down.
e Device PDA has missed a poll, but has not yet missed enough polls to be considered down.

e Devices ASA, HRA, RRA, JMA, and PDA are Up dependent on Router 1, as shown by the green
arrows pointing to the Router 1 device. These devices get polled only if Router 1 is Up.

The above image shows a device that is considered up because the device is accessible, but a monitor
configured on the device is down.

You can also use Map View to:
e Indicate relationships among devices by using annotation objects.

e Change the layout of devices and annotations.

Passive Monitors Icon

When a passive monitor is configured on a device, the device icon displays a diamond shape on the upper
left side.

This shape changes color when an unacknowledged state change occurs on the monitor. Once the device
has been acknowledge, the icon returns to the above appearance.

Map Limitations

Note

Step 1

Step 2

By default, Cisco netManager will not display a map with more than 256 devices. You can change this
default within the registry keys, with the understanding that it will cause lengthy delays by specifying
larger device defaults.

The more devices you allow on a map, the longer time you will wait for the map to load.

To change map device limitations:

Go to HKEY LOCAL MACHINE\Software\Ipswitch\Network Monitor\WhatsUp
Professional\2007\Settings.

Change the MapView-MaxDevices registry key to a number greater than 256 (Decimal).

~

Note If you want to change the text that displays when you reach the maximum device limit, you can
change it in the MapView-MaxDevicesMessage registry value. The default text is:
There are more devices on this Map than can be |drawn in a
reasonable time. Use the Device List |to manage devices for this

Group. | |To increase the maximum of (%1d) devices that |can be
drawn per Map, look in the online help |system for Map Device
Limits.

The pipes (I) in the default text indicate line breaks in the text and the (%1d) is a variable for the
MapView-MaxDevicesMessage value.
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