
 

Cisco I
OL-4814-01
C H A P T E R 8

Objective View Map Editor

This chapter describes the Objective View Map Editor and provides information about configuring maps.

This chapter includes the following sections:

• Introduction

• Configuring Map Books and Pages, page 8-4

• Configuring Layers, page 8-7

• Configuring Symbols, page 8-9

• Configuring Entities, page 8-23

• Configuring Styles, page 8-26

• Using the Access Control List, page 8-30.

Introduction
The Objective View Map Editor allows you to create interactive, graphical representations of your 
network topologies that can be viewed in the Objective View Desktop tool. The interactive maps 
represent and reflect the status of the network.

The following sections contain some useful terminology and concepts for configuring maps.

Map Books and Pages
A map book is a collection of Map pages. Map books are created in the Objective View Map Editor and 
used by the Objective View. All objective views start with a map book.

Map pages have unique names and contain the visible parts of an Objective View map.

For information about creating and editing map books and pages, see Configuring Map Books and Pages, 
page 8-4.
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Layers
Layers enable you to separate different objects on a Map page. For example, you may create one layer 
containing only a background image over which your network elements are placed. A second layer may 
contain symbols for the network elements, and a third may contain text labels for those symbols. You 
can then select and move, for example, the text labels without disturbing the positions of the symbols.

The default Map page is made up of three layers; however, you can create any number of layers.

For information about configuring layers, see Configuring Layers, page 8-7.

Symbols
Each layer of a Map page can contain any number of symbols. A symbol is a graphical representation of 
a network element. There are three major groups of symbols:

• drawn

• image

• link.

For information about creating and editing symbols, see Configuring Symbols, page 8-9.

Drawn Symbols

A drawn symbol can be:

• a circle

• an ellipse

• a line

• a rectangle

• a round-cornered rectangle

• text.

Image Symbols

An image symbol is a rectangular area filled with a bitmap image. This is typically used for icons or 
background images.

Link Symbols

A link symbol is a line which links two other symbols. This is used to represent an interconnection 
between two network elements.

Symbol Properties
A symbol can carry one or more of the following attributes: 

• an association with a style

• an association with an entity
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• a position

• text for labelling

• a double-click action

• a setting to define how the symbol displays status.

Symbol Groups

Symbols can be grouped together and manipulated as a single symbol. A symbol group cannot be 
associated with an entity.

Entities
Entities are used for deriving the status of network elements being monitored by Cisco Info Center. 
There are two forms of entities:

• Filtered

• Dependent.

Entities are shared between all Map pages and layers. For information about creating entities, see 
Configuring Entities, page 8-23.

Styles
Styles are used to define the visual appearance of symbols. A style defines color, line drawing style, and 
fill colors. Each style has a name. Styles are shared between all Map pages and layers.

For information about configuring styles, Configuring Styles, page 8-26.

Symbols and Styles

Each symbol can be associated with a named style to define most of its visual appearance. If no style is 
associated with a symbol, the Default style is used.

The feedback option in the Symbol Inspector window defines the way in which a symbol graphically 
displays it status.

Actions
One of the properties of a symbol is its action. This defines what happens when you double-click the 
symbol.
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Relationship Between Maps, Layers, Symbols, and Entities
Figure 8-1 shows the relationship between maps, layers, symbols, and entities.

Figure 8-1 Relationship Between Maps, Layers, Symbols, and Entities

In the Objective View Map Editor, the entities are not evaluated so there is no status display. It is only 
in the Objective View the evaluation takes place.

Configuring Map Books and Pages
This section describes how to use the Objective View Map Editor to create and edit map books and pages.

Starting the Objective View Map Editor
You can start the Objective View Map Editor using the following methods:

• select the Map Editor button in the Conductor

• from an existing map, move the mouse pointer over a map icon in the Conductor; then, right-click 
and choose Start Map Editor.

• enter the following on the command line:

$OMNIHOME/bin/nco_ove &

The Objective View Map Editor is shown in Figure 8-2.
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Figure 8-2 Objective View Map Editor

Creating a New Map Book
To create a new map book, from the Objective View Map Editor, choose File > New. This displays an 
empty Objective View Map Editor. You can then name the book and create new Map pages.

Opening a Map Book
To load a map book from the Objective View Map Editor:

Step 1 Choose File > Open. 

A file selection window appears.

Step 2 Select a map book file to load. 

Map book files are identified by the file name extension .map.

Creating a New Map Page
From the Objective View Map Editor, click the Create button. Use the Create Map Page window to 
create the new Map page.

Editing a Map Page
To edit a Map page from the Objective View Map Editor, double-click the Map page in the list. The Map 
Page Editor window appears.

Map page windows are described in Map Page Window, page 8-6.
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Deleting a Map Page
To delete a page from the map book, from the Objective View Map Editor, select the Map page in the 
list, then click the Delete button.

Renaming a Map Page
To rename a Map page from the Objective View Map Editor:

Step 1 Select the Map page to rename.

Step 2 Click the Rename button. 

Use the Rename Page window to rename the Map page.

Saving Map Books
To save a map book, from the Objective View Map Editor, choose File > Save.

If you are saving a new map book, a file selection window appears allowing you to enter a file name. The 
file name is displayed in the Title bar of the Objective View Map Editor. If the Title bar displays [None] 
as the file name, this option operates as the File > Save As option.

The File > Save As option displays a file selection window and allows you to select a directory and file 
name to save the map book.

Note Map book file names must end with the file name extension .map.

Map Page Window
The Map Page window is where a Map page can be manipulated and edited. Layers can be created, 
renamed, and deleted. Symbols can then be added, positioned, modified, associated with entities and 
styles, or deleted on those layers.

The Map Page window is shown in Figure 8-3.
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Figure 8-3 Map Page Window

Map Page Window Menu Bar

The Map Page window has the following menus: File, Edit, Layer, Windows, and Help. A Tools menu 
may or may not be active. When active, it shows an administrator-defined menu of tools.

Configuring Layers
When a Map page is created, it is given three default layers. It is suggested you use these three layers 
for their recommended purposes and add extra layers, if required. The default layers are:

• Object layer—use for symbols. This is the front layer, by default.

• Annotation layer—use for text and other annotations

• Background—use for background images and maps.

Figure 8-4 shows an example Map page and how it is broken down into the three default layers.
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Figure 8-4 Default Map Page Layers

Creating and Managing Layers
To create and manage layers, on the Map Page window, choose Layer > Edit. As shown in Figure 8-4, 
you can do the following from the Layers window.

Current Layer Button

The Current Layer button in the Map Page window shows which layer is currently in use for selection 
and editing. You can click this button to select another layer to work on.

Background layer

UK map for management control

14
76

2

Annotation layer

Object layer

The map on the left is made up of three 
layers. The diagram below shows the 
same map, broken down by layer

UK map for management control

Table 8-1 Using the Layers Window

Function Action

Create a new layer Click the Create button. A window appears prompting for the new layer 
name. Enter the name, then click OK.

Delete a layer Select the layer in the layer list, then click Destroy. All symbols on the layer 
are deleted with the layer.

Rename a layer Select the layer in the layer list, then click Rename. A window appears 
prompting for the new layer name. Enter the new name, then click OK.

Move a layer Select the layer in the layer list, then click the Move Up and Move Down 
buttons to move the layer up and down the list, respectively.

The order of the list sets the layer stacking order when displayed at the same 
time. A layer higher up in the list appears on top of the layers below it.
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Configuring Symbols
A symbol is a graphical representation of a network element that appears on the Objective View. This 
section contains information about creating and manipulating symbols.

Using the Symbol Palette
The Symbol Palette window is used for creating symbols on any layer. To display it, from the Map Page 
window, choose Windows > Symbol Palette. 

The symbol palette contains the symbols that can be created on a layer. There may be more symbols on 
the palette than in the above example. These extra symbols appear if there are classes defined in the 
Cisco Info Center system. The extra class symbols are functionally the same as the Image symbol except 
they have a pre-defined icon. The Image symbol is used for creating bitmap symbols.

Note For information about creating classes see Classes, page 3-29.

Creating Symbols on the Current Layer
To create a symbol on the current layer:

Step 1 Move the mouse pointer to the appropriate symbol in the symbol palette and press the middle mouse 
button.

Step 2 Drag the symbol over the map where you wish to place it and release the middle mouse button to drop 
the symbol at that position.

Figure 8-5 shows the Symbol Palette and Map Page windows.
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Figure 8-5 Drag and Drop From the Symbol Palette

Selecting Symbols
You can select symbols on the currently selected layer. To select a single symbol, click the symbol with 
the mouse.

To select multiple symbols, do one of the following:

• press and hold the Control key, then click the symbols to select or

• use the mouse to drag a rectangle around the symbols to select.

When a symbol is selected, small squares appear at its corners. You can use these selection markers to 
change the shape of some symbols. See Changing the Shape of Symbols.
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Changing the Shape of Symbols
When you select a symbol, corner markers appear. You can use the mouse to click and drag these corner 
markers to change the size of the symbol. 

This method works differently for line, text and image symbols, as follows:

• Line symbols show only start and end points when selected. You can drag these start and end points 
to change the position and length of the line.

• Text symbols show corner markers to indicate the text is selected. The size of the text symbol is 
derived from the font, which is in turn derived by the symbol’s style. See Using the Symbol 
Inspector, page 8-15 and Configuring Styles, page 8-26 for details on modifying a symbol’s style 
and font.

• Image symbols show the corner markers to indicate the image is selected. The size of the image 
symbol is derived from the image associated with it.

Moving Symbols
To move a symbol on the currently selected layer:

Step 1 Select the symbol.

See Selecting Symbols, page 8-10.

Step 2 Click and drag the symbol to a new location in the current layer.

When a number of symbols are selected, the symbols are moved as a group, retaining positions relative 
to each other.

Modifying Symbol Properties
You can change the following symbol properties:

• Style

• Layer

• Associated entity

• Position

• Associated image

• Action

• Feedback style

Step 1 Right-click the symbol. 

A popup menu appears. The title of the popup menu is the type of symbol you are viewing.

Step 2 Choose Edit from the menu. 

If the Symbol Inspector window is not already displayed, it appears.
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For details on using the Symbol Inspector window see Using the Symbol Inspector, page 8-15.

Creating Link Symbols
A link symbol is a special type of symbol. It is not available on the symbol palette because it only acts 
as a link between two other symbols. To create a link symbol:

Step 1 Position the mouse pointer within the first symbol to link (the source symbol).

Step 2 Press Shift and click the mouse button. 

The pointer changes to a filled circle.

Step 3 Drag the pointer to the second (destination) symbol. 

This is shown in Figure 8-6.

Figure 8-6 Linking Symbols

Note When the pointer is over a valid destination symbol, it changes into an unfilled circle. When the pointer 
is not over a valid symbol it appears as a cross-hair.

Step 4 Release the mouse button and Shift key. The link between the two symbols is created. If either the source 
or destination symbols are moved, the link moves with them.

Modifying Link Symbols
You can move link symbols in the same way as line symbols; however, the symbol at the other end of 
the link is moved as well.

For information about moving symbols, see Moving Symbols, page 8-11.

Starting the link from
the source symbol

The pointer is over a valid
destination symbol

Dragging the link to
the destination symbol
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Dragging and Dropping Symbols
The Objective View Map Editor allows you to drag and drop symbols within and between Map pages. 
To drag and drop a symbol:

Step 1 Click and hold the middle mouse button on a symbol.

Step 2 Drag the mouse pointer to another Map page or within the same Map page.

Step 3 To drop the symbol, release the mouse button.

Dragging and Dropping a Group

If you drag and drop a symbol that is part of a group, the operation applies to the entire group.

Using Drag and Drop to Copy a Symbol

To drag a copy of the selected symbol to another location, press the Control key while dragging with 
the middle mouse button.

Grouping Symbols
You can combine multiple symbols into a single group. A group can be manipulated as a single object. 
To create a group:

Step 1 Select the symbols to include in the group. 

See Selecting Symbols, page 8-10.

Step 2 Choose Edit > Group. 

The symbols are combined into a single group. When you select a group, it is selected as a single object, 
as shown in Figure 8-7.
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Figure 8-7 Symbol Groups

Using Groups
When symbols are grouped, you can no longer access the individual symbol properties that make up the 
group. The group has its own properties that obscure the properties of the individual symbols.

You can access the group’s properties by right-clicking the group and choosing Edit from the popup 
menu.

Deleting Symbols
You can delete symbols using the following methods:

• To delete a single symbol, right-click the symbol. A popup menu appears. Choose the Delete option 
from the popup menu. 

• To delete multiple symbols, select the symbols, then choose Edit > Delete from the menu. All 
selected symbols are deleted. 

For information about selecting multiple symbols, see Selecting Symbols, page 8-10.

Grid Options
You can use the grid to help you precisely position symbols and other objects on the Map page. Choose 
Windows > Grid Options to display the Grid Options window as shown in Figure 8-8.
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Edit->Group selected
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Figure 8-8 Grid Options

You can configure the grid using the following buttons and fields:

• click the Snap To Grid button to turn on the snap function. If you move objects, they will snap to 
the nearest point on the fixed grid.

• click the Show Grid Lines button to display the grid lines

• in the Grid Size field, enter the spacing between the grid lines.

Note The visual appearance of the grid is determined by the built in style called Grid. See Configuring Styles, 
page 8-26 for details on how to change the style.

Using the Symbol Inspector
The Symbol Inspector window allows you to modify the state of a symbol. The following states can be 
changed:

• Appearance

• Associations

• Notes.

Displaying the Symbol Inspector

To display the Symbol Inspector window, do one of the following:

• choose Windows > Symbol Inspector from the Map page menu or

• right-click a symbol, then choose Edit from the pop-up menu.

Using the Symbol Inspector

The Symbol Inspector window shows the settings of the currently selected symbol in the Map page. The 
symbol type is displayed in the top left corner, unless the symbol has a label, in which case it displays 
the label name.

When a symbol is selected, the Apply and Undo buttons are active. Apply sets any changes made in the 
inspector to the symbol. Undo resets the inspector to the state it was in when the symbol was originally 
selected, or when Apply was last pressed (whichever is most recent).

If no symbol is selected, the inspector displays the message Inspecting: Nothing in the top left corner of 
the inspector. The rest of the Symbol Inspector window is disabled, apart from the Close and Help 
buttons.
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Symbol Appearance

To display the visual attributes of the selected symbol, set the Symbol Inspector window Showing option 
button to Appearance. An example Symbol Inspector window is shown in Figure 8-9.

Figure 8-9 Symbol Inspector - Appearance

Note Some of the attributes shown in Figure 8-9 may be disabled because they do not apply to the symbol 
being examined.

Symbol Appearance Information

The Symbol Inspector window displays the symbol appearance information in Table 8-2.

Table 8-2 Symbol Inspector Appearance Fields and Options

Field Description

Style The Style option button controls the style with which the symbol is drawn. The styles 
are edited using the Style Editor window as described in Configuring Styles, page 
8-26.

Layer When a symbol is created, it is placed on the current layer. This layer name is 
displayed for each symbol in the Layer option button. To move a symbol between 
layers, select a new layer on the Layer button.

Position Most symbols have X and Y coordinates to set their position on the Map page. The 
position may be changed in the Position X and Y fields to fine tune positions on the 
Map page. This entry is not available for lines and links.
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Symbol Associations

To display the entity and action attributes of the selected symbol, set the Symbol Inspector window 
Showing option to Associations. The Symbol Inspector window is shown in Figure 8-10.

Size Many symbols are defined with the Size, Width, and Height fields, which indicate 
how wide and tall a symbol is. The Size field is disabled for group, text, image, link, 
and line symbols, which all derive their size in a different way.

Label For text symbols the label defines the text string displayed by the symbol. For all 
other symbols, it defines a text string which appears beneath the symbol as its visual 
label.

Filled For rectangle, circle, ellipse, and rounded rectangle symbols, you can fill the symbol 
with the background color.

Select Yes on the Filled option button to enable the filling option. Select No on the 
Filled option button to make the symbol transparent.

Line Line symbols are defined by a start position (X1,Y1) and an end position (X2,Y2). 
The Line X1, Y1, X2, and Y2 fields allow you to edit the start and end positions. The 
line option is only available for line symbols.

Arrows Line and link symbols can have arrows (or other end markers defined by the style) at 
the ends of the line or link. The Arrows option button allows you to select:

• None (no arrows)

• Source (arrow at the X1,Y1 position)

• Destination (arrows at the X2,Y2 position)

• Both (arrows at both positions).

Image For image symbols, the image selector allows you to select a bitmap image. Move 
the slider to step through the available images.

If a required image is not preloaded, click the Add Image button to display a list of 
GIF files present in the $OMNIHOME/backdrops directory. These are usually 
large images of maps for backgrounds.

Select one of these images from the list to load it into the image cache, at which point 
it can be selected using the slider. The image is available to any other image symbol 
as it is now present in the cache.

Table 8-2 Symbol Inspector Appearance Fields and Options (continued)

Field Description
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Figure 8-10 Symbol Inspector - Associations

Symbol Associations Information

The Symbol Inspector window displays the symbol association information shown in Table 8-3.

Table 8-3 Symbol Inspector Association Fields and Options

Field Description

Class The Class field allows you to select a class value for the symbol. The class determines 
the tools appearing for the symbol in the Objective View.

Creating menus and classes is covered in Introduction to Process Control, page 7-1.

Entity You can associate a symbol with an entity by selecting an entity from the list. This 
entity has a status based on its own association with a filter. In the Objective View, 
each symbol associated with an entity displays the entity’s status. If no entity is 
selected, the symbol has no status information.

For information about entities, see Entities, page 8-3.
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Feedback When a symbol is associated with an entity, it needs to display the entity status. The 
Feedback selector allows you to select the way to display that status. Choose from the 
following feedback settings:

Fill Background—the background of the symbol is filled with the status color. For 
lines and links, Fill Background changes the line/link color. For images, the rectangle 
behind the image is filled with the status color.

Highlight Bar—a bar is drawn below the symbol in the status color.

Outline—for most symbols, the line color of the symbol changes to the status color. 
For text and image symbols, a box is drawn around the symbol in the status color.

Overlay Bar—this is similar to Highlight Bar except the bar is drawn over the middle 
of the symbol. For text symbols, the background color of the text changes to the status 
color.

Overlay String—this is similar to Overlay Bar except the string value of the status 
(for example, Critical or Warning) is drawn over the middle of the symbol. This 
option operates in the same way as the Overlay Bar option on text, line, or link 
symbols.

Action A symbol may have an action associated with it. The Action option button setting 
determines what the symbol does when you double-click the symbol in the Objective 
View. Choose from the following action settings:

Show List—if a symbol is associated with an entity, this displays the currently open 
Event List with the filter and view of the associated entity.

If an Event List is not running, one is started that has no Filter/View bar. Instead, it 
uses the entity’s filter and view settings. This special Event List does not appear in the 
Monitor box window of the Event List tool.

Show Map—displays a map. Enter the map name in the Action field below the Action 
option button. You can use this option to link maps so an entire map book can be easily 
navigated. See Map Books and Pages, page 8-1.

Execute—executes an external command. The Action field becomes a command 
field, as described in Using the Entity Manager, page 8-24.

None—gives the symbol no action.

Redirect This option is used in conjunction with the Execute action.

The Redirect Output toggle button controls what happens to the output when a 
command is run. When selected, output is displayed in a read-only window. When not 
selected, output is discarded.

The Redirect Errors toggle button controls what happens to the errors when a 
command is run. When selected, errors are displayed in a read-only window. When not 
selected, error messages are discarded.

Table 8-3 Symbol Inspector Association Fields and Options (continued)

Field Description
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Creating Commands for Symbols

When a symbol has an execute action defined, it requires a command. This section contains information 
about creating:

• simple commands

• commands with elements

• commands with parameters.

To define a command you must have:

• an open Symbol Inspector window with symbol Associations displayed

• execute selected as the symbol action.

Simple Commands

A command may not require any substituted information. For example, if a menu item is required which 
runs the xterm program, the command would be:

xterm

Simple commands are ideal for starting local tools.

Commands with Elements

A command may require extra information while it is running (for example, a password). You can 
indicate this extra information using a command element.

To insert an element:

Step 1 Move the cursor to the position in the command where you want the information to be inserted.

Step 2 Click the Elements button. 

The Command Elements window appears, as shown in Figure 8-11.

Figure 8-11 Command Elements Window
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Step 3 Click the Type button at the top of the window to select the type of element to insert. 

You can choose from:

• Internal Variables

• Environment Variables

Step 4 Select the element to insert, then click Apply. 

The Elements window stays open, but the appropriate string is inserted into the command string.

Step 5 Click Close to close the Elements window.

Commands with Parameters

When information is required before starting a command, a parameter must be used. For example, 
starting a telnet session may require a host name and password. The command in this case would contain 
two parameters: one for the host name and one for the password.

These parameters are gathered before a tool starts running and the information entered is used in the 
command. To enter a command parameter:

Step 1 Position the cursor within the Command field to where you want the substitution to take place.

Step 2 Click the Parameters button. 

The Parameter Builder window appears.

Figure 8-12 Command Parameters Window

Step 3 Enter a parameter name in the Name field.

Step 4 Enter the command prompt in the Prompt field.

Step 5 Click the Type button to select one of the parameter types shown in Table 8-4.
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Step 6 Click Apply to insert the parameter. 

The Parameter Builder window stays open, however, the parameter is inserted into the command string.

Step 7 Click Close to close the Parameter Builder window.

Notes
To display the note attributes of the selected symbol, set the Symbol Inspector window to Notes. An 
example Symbol Inspector window is shown in Figure 8-13.

Table 8-4 Command Parameters

Parameter Type Description

String

Integer

Float

For String, Integer, and Float parameters, the only active field is the Default 
field, which should contain the string which initially appears in the field. The 
only difference between these three types of parameters is the characters each 
field accepts. A String parameter takes any character, Integer accepts 0-9, and 
Float accepts 0-9 and decimal point (.). 

Choice The parameter type allows you to create an option button with a fixed set of 
options. Select Choice to enable the scrolling list below the Default entry. The 
Clear button deletes all the entries in the list.

Lookup The Lookup parameter type works like Choice except instead of entering the 
choices into the scrolled list, the parameter refers to a file on disk. Each line of 
this file is used as a choice.

To select the file, enter either the file name in the Filename field or click the 
Browse button, which brings up a file selection window where you can select 
the file. This file must be available on the machine running the Desktop tools.

Password The parameter type operates in the same way as the String type; however, at 
the prompt, the characters appear as asterisks as you type.
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Figure 8-13 Symbol Inspector - Notes

A note may be displayed on request inside the Objective View. Enter the required text into the text panel, 
then click Apply to add the note to the symbol.

Configuring Entities
You can associate entities with symbols so that symbols can display status information about the 
Objective View. An entity is comprised of two components: a filter and a view.

The filter determines what status information is displayed by symbols associated with the entity. For 
example, if you want a symbol to display the highest severity alert related to a node named node1, you 
can create an entity with a filter that reads Node=’node1’. You then associate this entity with a symbol 
using the Symbol Inspector window. When the symbol is used in the Objective View, it shows the highest 
severity alert related to node1.

For information about symbols and the Symbol Inspector window, see Configuring Symbols, page 8-9.

Types of Entities
There are two types of entities: filtered and dependent.

A filtered entity displays the highest alert severity resulting from a filtered interrogation of the 
alerts.status table. The severity color is displayed on an Objective View symbol.

A dependent entity has no filter. Instead, you associate it with multiple filtered entities. It then derives 
its status from these filtered entities.
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Using the Entity Manager
To create and manage entities, use the Entity Manager window, as shown in Figure 8-14. This is 
displayed by clicking the Entity button in the Objective View Map Editor’s main window.

Figure 8-14 Entity Manager Window

Creating an Entity

To create an entity:

Step 1 Click the New button.

Step 2 Enter the entity name into the Name field. 

The Update button turns red.

Step 3 Click the Update button to complete the addition.

Step 4 Select the type of entity from the Derive State From button.

The options are:

• Filter, which activates the Edit Filter and Edit View buttons

• Dependants, which activates the entity dependencies list.
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Step 5 Do one of the following:

• If you are creating a filtered entity, click the Edit Filter button. The Filter Builder window appears. 
For information about using the filter builder, see the Cisco Info Center User Guide, 3.6.

• If you are creating a dependant entity, the entity dependencies list shows all other entities as entries. 
Entries in italics are not used to derive the entity status. Entries in normal text are used. To change 
any entry in the list, double-click it.

Note When you use the Filter Builder from the Objective View Map Editor, you cannot create subqueries or 
change the name of the filter.

Step 6 When you finish entering the entity details, click the Update button. 

The entity is created. You can now associate symbols with the new entity.

Modifying an Entity

To modify an entity:

Step 1 Select the entity in the list.

Its name is displayed in the Name field.

Step 2 You can now change the type of entity, edit the filter or view the filter (for a filter entity), or change the 
dependency list for a dependent entity.

Any change makes the Update button turn red.

Step 3 Click the Update button to apply the changes.

Renaming an Entity

To rename an entity:

Step 1 Select the entity in the list.

Step 2 Click the Rename button. 

A window appears prompting you for the new name.

Step 3 Enter the new name, then click OK. 

The name is then changed.

Deleting an Entity

To delete an entity, select the entity in the list, then click the Delete button.
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Configuring Styles
A style defines attributes connected with the appearance of symbols, such as foreground and background 
colors, line appearance, and fonts. Styles allow symbol appearance to be defined and modified globally.

For information about configuring symbols, see Configuring Symbols, page 8-9.

Using the Style Editor
To display the Style Editor window, shown in Figure 8-15, click the Styles button in the Objective View 
Map Editor.

Figure 8-15 Style Editor Window

Style Color
A style has a foreground and background color. The colors are defined as black, white, and a range of 
grays. Styles do not allow for other colors because color is used in the Objective View to show severity 
and highlight symbols. For example, it would be confusing to have a red line highlighted in red.

You can select colors in the Style Editor window using the Foreground and Background option buttons.

Style Lines
You can use the Style Editor window to define a style specifically for use with lines in the Objective 
View.
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Selecting the Line Style Width

The width of any lines drawn using the style is defined by the Width slider, which can range from 0 to 8.

Selecting the Line Style Appearance

Select the line appearance using the Style option button. There are three line drawing styles, as shown 
in Figure 8-16:

• solid draws a straight line

• on off dash draws a dashed line using only the foreground color

• double dash draws a dashed line using the foreground and background colors.

Figure 8-16 Line Styles

When using a dash style, the Dashes slider allows you to set the length of the dash from 1 to 25.

Selecting the Cap

The Cap allows the style to set how a line ends. There are four cap styles:

• Not Last stops drawing one pixel short of the end of the line

• Butt draws the line right up to the last point

• Round puts a rounded end on drawn lines, going past the end of the line by approximately half the 
width for the line

• Projecting overshoots the end of the line and draws a square end.

Selecting the Join Option

The Join option controls how lines in rectangles are joined:

• Miter extends the lines to a point

• Bevel crops the lines at the end

• Round rounds the line.

Selecting the Line End

Where a line or other symbol is set to have arrows, the Ends option button allows you to define the type 
of arrow to use. The choices include arrows, square ends, and circle ends, both filled and unfilled.

Click the Ends button to select the end type. The arrow types are shown in Figure 8-17.

Background
Solid

14
91

5Foreground
On off dash

Double dash
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Figure 8-17 Arrow Types

Style Font
You can select a font for every style. The font is used for all text used by symbols with that style. To set 
the style font on the Style Editor window:

Step 1 Click the Select button in the Font pane. 

The Font Selector window appears, as shown in Figure 8-18.

Figure 8-18 Font Selector Window

Step 2 Select the font name, style, and size from the three lists.

Step 3 Click the Add button to add the font set. 

The font settings appear in the Font Set field. If a character set cannot be rendered using the selected 
font, a message appears in the Font Selector window.

Note The ability to select more than one font is to allow for support of multibyte character sets.

Step 4 Select the Show Size in Points check box to display font sizes in points (instead of pixels).

Step 5 Select the Show Proportional Fonts check box to show all fonts including proportional fonts (instead 
of only fixed width fonts).
8-28
Cisco Info Center Administrator Reference, 3.6

OL-4814-01



 

Chapter 8      Objective View Map Editor
Configuring Styles
Built in Styles
• There are two built in styles:

• Default, which is given to all new symbols when you first create them

• Grid, which is used to draw a grid on the background.

These styles cannot be deleted.

Creating a New Style
To create a new style on the Style Editor window:

Step 1 Click the New button.

Step 2 Enter the style name in the Name field. 

The Update button turns red.

Step 3 Enter the style settings.

Step 4 Click the Update button to save the style and add it to the style list.

Modifying a Style
To modify a style on the Style Editor window:

Step 1 Select the style in the style list. 

Its name and settings appear.

Step 2 Modify the style, as needed. 

The Update button turns red.

Step 3 Click the Update button to save your changes.

Renaming a Style
To rename a style on the Style Editor window:

Step 1 Select the style in the style list.

Step 2 Click the Rename button. 

A window appears prompting for the new name.

Step 3 Enter the new name.

Step 4 Click OK to change the name.
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Deleting a Style
To delete a style on the Style Editor window:

Step 1 Select the style in the style list.

Step 2 Click Delete. 

If the style is referenced by existing symbols, a prompt appears allowing you to change all references to 
that style to refer to the Default style.

Using the Access Control List
You can use the Access Control List window to:

• select the first Map page that appears when a map is opened in the Objective View

• control the users allowed to access the map.

To display the Access Control List window, shown in Figure 8-19, click the Access button in the 
Objective View Map Editor.

Figure 8-19 Access Control List Window

Creating a New Access List Entry
To create an access list entry on the Access Control List window:

Step 1 Click the New button.

Step 2 Enter the user name in the User field.
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Step 3 Enter the name of a Map page in the Map field. 

The Update button turns red.

Step 4 Click the Update button to add the user.

Modifying an Access List Entry
To modify an access list entry on the Access Control List window:

Step 1 Select a user in the list. 

The user’s details appear.

Step 2 Modify the Map field.

Step 3 Click the Update button.

Deleting an Access List Entry
To delete an entry from the access list on the Access Control List window:

Step 1 Select a user from the list.

Step 2 Click the Delete button.
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