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Documentation Conventions General Tutorials
Documentation Conventions

OPNET documentation uses specific formatting and typographic conventions to present 
the following types of information:

• Objects, examples, and system I/O

• Object hierarchies, notes, and warnings

• Computer commands

• Lists and procedures

Objects, Examples, and System I/O

• Directory paths and file names are in plain Courier typeface:

opnet\release\models\std\ip

• Function names in body text are in italics:

op_dist_outcome()

• The names of functions of interest in example code are in bolded Courier 
typeface:

/* determine the object ID of packet’s creation module */ 
src_mod_objid = op_pk_creation_mod_get (pkptr);

• Variables are enclosed in angle brackets (< >):

<opnet_user_home>/op_admin/err_log

Object Hierarchies, Notes, and Warnings

Menu hierarchies are indicated by right angle brackets (>); for example:

Open File > Print Setup > Properties...

Attribute hierarchies are represented by angled arrows (➘ ) that indicate that you must 
drill down to a lower level of the hierarchy:
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Attribute level 1 ➘  Attribute level 2 ➘  Attribute level 3

Note—Notes are indicated by text with the word Note at the beginning of the 
paragraph. Notes advise you of important supplementary information.

WARNING—Warnings are indicated by text with the word WARNING at the 
beginning of the paragraph. Warnings advise you of vital information about an 
operation or system behavior.

Computer Commands

These conventions apply to Windows systems and navigation methods that use the 
standard graphical-user-interface (GUI) terminology such as click, drag, and dialog box.

• Key combinations appear in the form “press <button>+x”; this means press 
the <button> and x keys at the same time to do the operation.

• The mouse operations left-click (or click) and right-click indicate that you 
should press the left mouse button or right mouse button, respectively.

Lists and Procedures

Information is often itemized in bulleted (unordered) or numbered (ordered) lists:

• In bulleted lists, the sequence of items is not important.

• In numbered lists, the sequence of items is important.

Procedures are contained within procedure headings and footings that indicate the start 
and end of the procedure. Each step of a procedure is numbered to indicate the 
sequence in which you should do the steps. A step may be followed by a description of 
the results of that step; such descriptions are preceded by an arrow.

Procedure FM-1 Sample Procedure Format 

1 Procedure step.

➥ Result of the procedure step.

2 Procedure step.

End of Procedure FM-1

For more information about using and maintaining OPNET documentation, see the 
OPNET IT Guru Documentation Guide.
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About the Tutorials in This Book

The tutorials in this book are the same tutorials that are delivered on the 
Documentation CD that comes with the OPNET software installation package. 
You can access the tutorials by choosing Help > Tutorials from the main menu 
of your OPNET application.

The tutorials are printed here in the same format as they appear online. This 
ensures page-by-page equivalency with the electronic version. Consequently, 
any hypertext links or action buttons that help you navigate the tutorials online 
are not active in the printed version. However, because it is frequently 
referenced from many of the tutorials, App A Troubleshooting Tutorials on 
page TUT-A-1 has been included in this book.

For best results, do the tutorials in the order in which they appear in the book. 
The tutorials are in the same order in which they appear on the menus of the 
electonic version.

If you have multiple tutorial books and you are new user of OPNET, it is a good 
idea to go through the tutorial books in the following order:

1) General Tutorials

2) <Product-specific> Tutorials (not available for all products)

3) ACE Tutorials and Examples
IT Guru/Release 11.5 TUT-INTRO-1
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1 Introduction to IT Guru
Introduction

Overview

Welcome to IT Guru!

This tutorial teaches you the basics of using IT Guru. 
If you are new to IT Guru, this short introduction will 
help get you started.

If you are performing this tutorial for the first time, read 
the following pages for important information about 
using this tutorial and IT Guru.
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About the Models

This tutorial was written for use with release 11.5.A of 
the IT Guru software and the September 2005 
models. If you are using a different release, you might 
get different results or be unable to complete some 
lessons.

To complete the tutorials, you must install the IT Guru 
standard models, which include the required tutorial 
models. These models are normally installed when 
you install the Standard Model Library.

IT Guru standard models cover common protocols 
and vendor devices. The standard models are in the 
subdirectories under the OPNET release directory 
(<reldir>):

<reldir>\models\std\<protocol_name>

<reldir> describes the directory that contains the 
current IT Guru software.
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You can find your <reldir> by performing the following 
steps:

1 Select Help > About This Application in the 
main menu.

2 In the About OPNET IT Guru dialog box, click on 
the Environment tab, and then expand the 
System Information section.

3 Under System Information, find the 
OPNET release directory.

For example, the <reldir> for a default installation of 
this release of IT Guru on Windows is

C:\Program Files\OPNET\11.5.A

The tutorials use the Windows convention of the 
backslash character (\) as the separator in directory 
pathnames. If you are using Solaris, replace the 
backslash with a forward slash (/).
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Opening Tutorial Files

Several tutorials will direct you to open an OPNET 
model file and save it with a unique prefix, such as 
your initials (<your_initials>). This way, several users 
can create and complete their own working copy of 
the same tutorial.

When you perform a tutorial, you are asked to open 
special tutorial model files. These model files are 
required to complete the tutorial; they are located in 
the <reldir>\models\std\tutorial_req directory or its 
subdirectories.

When you are asked to open model files that are NOT 
prefixed with your initials, make sure you navigate the 
directory structure in OPNET's open file browser (in 
the left pane) to the tutorial_req directory.

Navigating to the tutorial_req Directory
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When you save a new model file, or use the 
Save As... command to save an existing model file 
with your initials, remember to navigate to the OPNET 
working directory (normally <home>\op_models) to 
save your files.

Navigating to the op_models Directory
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TUT-1-6
About the Lessons

In this tutorial, you learn how to use the IT Guru 
features to build and analyze network models.

You can download the latest version of this tutorial 
from the OPNET Web site. Visit 
www.opnet.com/support/home.html and select the 
Product Updates link.

Each lesson presents a modeling problem for you to 
solve by building a network model, gathering 
statistical information about the network, and 
analyzing those results.

Each lesson helps you become familiar with IT Guru 
and demonstrates the range of problems IT Guru can 
solve.

We suggest that you perform the lessons and topics in 
sequence.

Most lessons have Key Concept paragraphs, like this 
one, that contain new information about IT Guru or 
describe important aspects of modeling theory.
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Position this tutorial window next to IT Guru on your 
screen so that you can view both windows at the same 
time.

By default, the tutorial window always stays below the 
OPNET window. If you are using a Windows 
computer, you can change this behavior by setting the 
itguru.tutorial_top preference to TRUE (for 
information about changing preferences, see the 
Productivity Features lesson, Preferences topic).

Note that after setting the itguru.tutorial_top 
preference to TRUE, you must exit and restart Adobe 
Reader before the new behavior takes affect.
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About IT Guru

Before you start, you should understand the IT Guru 
workflow, the workspace, and the editors. Become 
familiar with these essential features, and then begin 
the tutorial lessons.

The workflow for IT Guru (that is, 
the steps you use to build a 
network model and run 
simulations) centers around the 
Project Editor.

In this editor, you can create a 
network model, choose statistics 
to collect from each network 
object or from the whole 
network, execute a simulation, 
and view results. 

Your first look at IT Guru in 
Lesson 1 shows you how to use 
the Project Editor to build a small 
internetwork.

Choose 
Statistics

Run Simulations

View and Analyze 
Results

Create 
Network 
Models
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The Project Editor

The Project Editor is the main staging area for 
creating a network simulation. From this editor, you 
can build a network model using models from the 
standard library, choose statistics about the network, 
run a simulation, and view the results.

A Network Model in the Project Editor
TUT-1-9
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The Project Editor Window

There are several areas in the Project Editor window 
that are important for building and executing a model. 
These are shown on the following pages.

When you open an existing project, your screen 
should look similar to the following figure:

Project Editor Window

Toolbar Buttons

Message Area

Menu Bar

Message Buffer Icon

Workspace
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The Menu Bar

The menu bar is at the top of the editor window. It 
organizes all the non-context-sensitive editor 
operations into a set of topical menus.

The exact set of menus and menu operations 
available change according to the product modules 
that are enabled.

Context-sensitive editor operations are available by 
right-clicking on an object or on the background of the 
workspace.

Toolbar Buttons

Several of the more commonly used menu bar 
selections can be activated through toolbar buttons. 
The following figure shows toolbar buttons that can 
appear in the Project Editor. You will use many of 
these toolbar buttons in the tutorial. (Note: Depending 
on your specific product and modules, you might not 
see all of the buttons shown here.)
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Toolbar Buttons in the Project Editor

The Workspace

The central, scrollable region of the editor window is 
the workspace. This is where the network model 
appears; you can select and drag network objects in 
the workspace, and choose context-sensitive menu 
operations by right-clicking on the background.

The Message Area

The message area is located at the bottom of the 
editor window. It provides information about the status 
of the tool.

 1 Open Object Palette   9 Configure/Run Flow Analysis

 2 Verify Links 10 Configure/Run Failure Analysis

 3 Fail Selected Objects 11 Configure/Run Discrete Event 
Simulation (DES)

 4 Recover Selected Objects 12 Configure/Run Design Action

 5 Go to Parent Subnet 13 Configure/Run Automation Tasks

 6 Zoom to Rectangle 14 View Results

 7 Zoom to Previous 15 Hide/Show Graph Panels

 8 Configure/Run NetDoctor 16 Generate Network Inventory 
Summary

1 3 4 5 6 7 8 9 10 11 12 13 14 15 162
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Message Area

You can click on the icon next to the message 
area to open the message buffer window.

The message buffer window shows a list of messages 
that have appeared in the message area. You can 
open the message buffer window if part of the 
message line is truncated in the message area or if 
you think a later message has replaced an important 
alert or notification.

Tooltips

If you rest your cursor over a tool button or a network 
object in the workspace, a help balloon appears. The 
tooltip describes one of the following:

• the action that occurs if the button is pressed

• information about the network object

Tooltip
TUT-1-13
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Documentation

Occasionally, you might have questions about certain 
aspects of the tutorial, the tool, or the models. You can 
refer to these sources:

• Built-in documentation is available throughout 
the tool. For example, you can get model 
descriptions, attribute definitions, and statistic 
descriptions by selecting an item and clicking on 
the Details button. Some dialog boxes also have 
Help buttons that bring up additional descriptive 
information.

• OPNET product documentation. Select 
Help > Product Documentation.

• FAQ (Frequently Asked Questions). Point your 
browser to www.opnet.com/support.

You need your user name and password to 
access the Web FAQ. OPNET Technical Support 
normally sends your user name and password by 
email after you register your OPNET software for 
purchase or evaluation.

• Recent updates to the tutorial lessons and 
models can be downloaded from the Web site: 
www.opnet.com/support.
IT Guru/Release 11.5
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• Model User Guides provide the latest 
information on the protocol models and how to 
use them. In the Project Editor window, choose 
Protocols > <protocol name> > Model User 
Guide.

Now you are ready to begin the tutorial. Return to the 
main tutorial menu and choose Small Internetworks 
from the list of available lessons. Have fun learning 
IT Guru!
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2 Small Internetworks
Small Internetworks

Introduction

In this lesson, you will see how IT Guru can do 
organizational scaling to solve a typical “what if” 
problem. You will learn how to use IT Guru features to 
build and analyze network models. In this lesson, you 
will

• Build a network quickly

• Collect statistics about network performance

• Analyze these statistics

In this lesson, you use the Project Editor to build a 
topology of a small internetwork, choose statistics to 
collect, run a simulation, and analyze the results.

In this lesson, you plan for the expansion of a small 
company’s intranet. Currently, the company has a star 
topology network on the first floor of its office building 
and plans to add an additional star topology network 
on another floor. You will build and test this “what-if” 
scenario to ensure that the load added by the second 
network will not cause the network to fail.
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The Final Network

First floor

Planned expansion
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Getting Started

When creating a new network model, you must first 
create a new project and scenario. A project is a 
group of related scenarios that each explore a 
different aspect of the network. Projects can contain 
multiple scenarios.

After you create a new project, you use the Startup 
Wizard to set up a new scenario. The options in the 
Wizard let you

• Define the initial topology of the network

• Define the scale and size of the network

• Select a background map for the network

• Associate an object palette with the scenario

The Startup Wizard automatically appears each time 
you create a new project. The Startup Wizard lets you 
define certain aspects of the network environment.
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To use the Startup Wizard to set up a new scenario, do 
the following:

1 If IT Guru is not already running, start it.

2 Select File > New...

3 Select Project from the pull-down menu and click 
OK.

4 Name the project and scenario, as follows:

4.1 Name the project <initials>_Sm_Int 

Include your initials in the project name to 
distinguish it from other versions of this 
project.

4.2 Name the scenario first_floor.

4.3 Click OK.

➥ The Startup Wizard opens.

5 Enter the values shown in the following table in 
the dialog boxes of the Startup Wizard.
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Values to Enter in the Startup Wizard

➥ A workspace of the size you specified is 
created. The object palette you specified 
opens in a separate window.

Dialog Box Name Value

1. Initial Topology Select the default value: 
Create empty scenario.

2. Choose Network Scale Select Office. Select the 
Use metric units checkbox.

3. Specify Size Select the default size: 
100 m x 100 m

4. Select Technologies Include the Sm_Int_Model_List 
model family.

5. Review Check values, then click Finish.
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Creating the Network

Network models are created in the Project Editor using 
nodes and links from the object palette. 

Node—A representation of a real-world network 
object that can transmit and receive information.

Nodes

Link—A communication medium that connects nodes 
to one another. Links can represent electrical or fiber 
optic cables.

A Link

These objects are found in the object palette, a 
dialog box that contains graphical representations of 
node and link models.

If it is still open, close the object palette.
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You can use any of three methods to create a network 
topology, or a combination of all three. One method is 
to import the topology (discussed in a later lesson). 
Another is to place individual nodes from the object 
palette into the workspace. The third method is to use 
Rapid Configuration.

Rapid Configuration creates a network in one action 
after you select a network configuration, the types of 
nodes within the network, and the types of links that 
connect the nodes.

To create the first-floor network using Rapid 
Configuration:

1 Select Topology > Rapid Configuration.

2 Select Star from the pull-down menu of available 
configurations, then click OK...

Available Configurations Pull-Down Menu
TUT-2-7
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Specify the node models and link models in the 
network. Models follow this naming scheme:

<protocol1>_..._<protocoln>_<function>_<mod>

where:

• <protocol> specifies the specific protocol(s) 
supported by the model

• <function> is an abbreviation of the general 
function of the model

• <mod> indicates the level of derivation of the 
model

For example: 

ethernet2_bridge_int

specifies the intermediate (int) derivation of a 2-port 
Ethernet (ethernet2) bridge (bridge).

Vendor models have an additional prefix that specifies 
the vendor and the vendor product number for that 
particular network object.
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For example, the 3Com switch used in this lesson is 
named:

 3C_SSII_1100_3300_4s_ae52_e48_ge3

This node is a stack of two 3Com SuperStack II 1100 
and two Superstack II 3300 chassis 
(3C_SSII_1100_3300) with four slots (4s), 52 
auto-sensing Ethernet ports (ae52), 48 Ethernet ports 
(e48), and 3 Gigabit Ethernet ports (ge3).

To specify the nodes and links to use to build the 
network:

1 Set the Center Node Model to 
3C_SSII_1100_3300_4s_ae52_e48_ge3. This is 
a 3Com switch.

2 Set the Periphery Node Model to 
Sm_Int_wkstn, and change the Number of 
periphery nodes to 30. This sets 30 Ethernet 
workstations as the peripheral nodes.

3 Set the Link Model to 10BaseT.
TUT-2-9
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Specify where the new network will be placed:

1 Set the X center and Y center to 25.

2 Set the Radius to 20.

Rapid Configuration Dialog Box

3 Click OK.

➥ The network is drawn in the Project Editor.
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The First Floor Network

Now that the general network topology has been built, 
you need to add a server. You will use the second 
method of creating network objects: dragging them 
from the object palette into the workspace.

1 If it is not already open, open the 
object palette by clicking on the 
Object Palette toolbar button.

2 Find the Sm_Int_server object in the palette and 
drag it into the workspace. 
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You will not find this exact server model on other 
object palettes because we created it with the 
correct configuration for this tutorial.

By default, you can create additional instances of 
the same object by left-clicking after the initial 
“drag-and-drop” from the palette.

3 Because you do not need additional copies of 
this model, right-click to turn off node creation.
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You also need to connect the server to the star 
network.

1 Find the 10BaseT link object in the palette and 
click on it.

2 Click on the server object, then click on the switch 
object in the center of the star.

➥  A link is drawn, connecting the two objects.

3 Right-click to turn off link creation.

Finally, you need to add configuration objects to 
specify the application traffic that will exist on the 
network. Configuring the application definition and 
profile definition objects can be complicated, so you 
do not have to do these tasks right now. For this 
tutorial, we included, on the object palette:

• an application definition object with the default 
configurations of the standard applications, and 

• a profile definition object with a profile that 
models light database access
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You need only drag the objects into your network. 
Doing so means that the traffic caused by 
workstations accessing a database at a low rate will 
be modeled.

1 Find the Sm_Application_Config object in the 
palette and drag it into the workspace

2 Right-click to turn off object creation.

3 Find the Sm_Profile_Config object in the 
palette, drag it into the workspace, and right-click.

4 Close the object palette.
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The network is now built and should look similar to the 
following figure.

The Finished First Floor Network

You are now ready to begin collecting statistics.
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Collecting Statistics

You can collect statistics from individual nodes in your 
network (object statistics) or from the entire network 
(global statistics).

Now that you have created the network, you should 
decide which statistics you need to collect to answer 
the questions presented earlier in this lesson:

• Will the server be able to handle the additional 
load of the second network?

• Will the total delay across the network be 
acceptable once the second network is installed?

To answer these questions, you need a snapshot of 
current performance for comparison. To get this 
baseline, you will collect one object statistic, Server 
Load, and one global statistic, Ethernet Delay.
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Server load is a key statistic that reflects the 
performance of the entire network. To collect statistics 
related to the server’s load, do the following steps: 

1 Right-click on the server node (node_31) and 
select Choose Individual DES Statistics from 
the server’s Object pop-up menu.

➥ The Choose Results dialog box for node_31 
appears.

The Choose Results dialog box hierarchically 
organizes the statistics you may collect. To collect 
the Ethernet load on the server:

2 Expand the treeview for Ethernet in the 
Choose Results dialog box to see the Ethernet 
statistic hierarchy.
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Choose Results Dialog Box

3 Click the checkbox next to Load (bits/sec) to 
enable collection for that statistic.

4 Click OK to close the dialog box.
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Global statistics can be used to gather information 
about the network as a whole. For example, you can 
find out the delay for the entire network by collecting 
the global Delay statistic:

1 Right-click in the workspace (but not on an 
object) and select Choose Individual DES 
Statistics from the Workspace pop-up menu.

Global Statistic Chosen
TUT-2-19
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2 Expand the Global Statistics hierarchy.

3 Expand the Ethernet hierarchy.

4 Click the checkbox next to Delay (sec) to enable 
data collection.

5 Click OK to close the Choose Results dialog box.

It is good to get into the habit of saving your project 
every so often. To save the project:

1 Choose File > Save, then click Save (the project 
already has a name, so you don’t need to rename 
it).

Now that you have specified the statistics to collect 
and saved the project, you are almost ready to run 
your simulation. 

First, though, verify that your repositories preference 
is set appropriately.

1 Choose Edit > Preferences.

2 Type repositories in the Find field and click on 
the Find button.
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3 If the value for repositories is not stdmod, click 
on the field.

4 When the repositories dialog box appears, click 
the Insert button then enter stdmod in the dialog 
box.

5 Click OK to close the repositories and 
Preferences dialog boxes.

To run a simulation:

1 Select DES > Configure/Run Discrete Event 
Simulation….

You can also open the Configure 
Discrete Event Simulation dialog box by 
clicking on the Configure/Run Discrete 
Event Simulation (DES) toolbar button.

Configure Discrete Event Simulation Dialog Box
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2 Type 0.5 in the Duration: field to simulate 
one-half hour of network activity.

In this case, the simulation calculates and 
displays events/second data at 10,000-event 
intervals. The default setting for this is 500,000 
for larger network simulations.

3 Click the Run button to begin the simulation.

While the simulation runs, a dialog box appears 
showing the simulation’s progress.

Simulation Sequence Dialog Box

Elapsed Time: Number of seconds the simulation has run

Simulated Time: Minutes of network time
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The dialog box above shows that, in 1 second of 
elapsed (actual) time, IT Guru has simulated 10 
minutes and 49 seconds of network time. The 
entire simulation should take less than one 
minute to complete—the elapsed time varies 
according to the speed of your computer.

4 When the simulation finishes, the contents of the 
Messages tab appears. Click the Close button in 
the Simulation Sequence dialog box.

5 If your simulation does not complete, if no results 
were collected, or if the results vary significantly 
from those shown, you will have to troubleshoot 
your simulation. See "Troubleshooting IT Guru 
Tutorials".
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Viewing Results

You can view results graphically in the Project Editor by 
selecting View Results from the Workspace pop-up 
menu.

After your simulation has executed, you will want to 
see the information collected for each statistic. There 
are several ways to view results; in this lesson you will 
use the View Results option in the Workspace pop-up 
menu.

You will learn different ways to view results in later 
lessons. 

To view the server Ethernet load for the simulation:

1 Right-click on the server node (node_31) choose 
View Results from the server’s Object pop-up 
menu.

➥ The node’s View Results dialog box opens.

2 Expand the Office network.node_31 > Ethernet 
hierarchy.

3 Click on the checkbox next to Load (bits/sec) to 
indicate that you want to view that result.
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4 Click the Show button in the View Results dialog 
box.

➥ The graph of the server load appears in the 
Project Editor, as shown in the following figure.

The graph of the server load should resemble the 
following graph. Your results may differ slightly due to 
differences in node placement and link length, but the 
general trends should be consistent.

Server Load Graph

Simulation time, in 
minutes

bits/second. The 
unit of measure 
on this axis is 
shown in the 
statistic in the 
Choose Results 
dialog box
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Note that at its peak, the load on the server is about 
7,000 bits/second. You will need this baseline for 
comparison after you add the second network.

When you finish viewing the server load graph, close 
this dialog box and the View Results dialog box. (If the 
system prompts you, choose to delete the graph 
panel.)

You also should look at the Global Ethernet Delay on 
the network. To view this statistic:

1 Right-click in the workspace, then select 
View Results from the pop-up menu.

2 Check the box next to Global Statistics > 
Ethernet > Delay (sec), then click the Show 
button to view the Ethernet delay for the whole 
network.
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Viewing Ethernet Delay for the Whole Network

➥ The Ethernet delay graph appears in the 
Project Editor. The graph should resemble the 
following figure.
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Ethernet Delay Graph

Note that after the network reaches steady state the 
maximum delay is around 0.4 milliseconds.

When you finish viewing the graph, close the graph 
and the View Results dialog box.

Simulation time, in minutes

Seconds
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Expanding the Network

You have created a baseline network and gathered 
statistics about it. Now you are ready to expand the 
network and verify that it still operates sufficiently well 
with the additional load.

When performing a “what-if” comparison, it is 
convenient to store the baseline network as one 
scenario and create the experimental network as a 
different scenario. You will duplicate the existing 
scenario and make changes to it instead of building 
the new topology from the beginning. 

To duplicate a scenario:

1 Choose Scenarios > Duplicate Scenario...

2 Enter expansion as the name for the new 
scenario.

3 Click OK.

➥ The scenario, with all the nodes, links, 
statistics, and the simulation configuration, is 
duplicated and named expansion.
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The second-floor segment will resemble the first-floor 
segment, but will not have a server of its own. To build 
the new segment:

1 Select Topology > Rapid Configuration.

2 Choose Star for the topology and click OK...

3 Complete the Rapid Configuration dialog box with 
these values:

— Center Node Model: 
3C_SSII_1100_3300_4s_ae52_e48_ge3

— Periphery Node Model: Sm_Int_wkstn

— Number: 15

— Link model: 10BaseT

— X: 75, Y: 62.5, Radius: 20

Rapid Configuration Dialog Box
IT Guru/Release 11.5



General Tutorials

IT Guru/Release 11.5
4 Click OK to create the network.

Join the two networks:

1 If it is not already open, click the 
toolbar button to open the object 
palette.

2 Drag the Cisco 2514 router icon into the 
workspace between the two networks. Right-click 
to turn off node creation.

3 Click on the 10BaseT link icon in the object 
palette.

4 Create 10BaseT links between the Cisco router 
(node_50) and the 3Com switches at the center 
of each star.

5 Right-click to turn off link creation.

6 Close the object palette.

7 Select File > Save.
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The final network should look like this:

The Final Network

To run the expansion scenario:

1 Select DES > Configure/Run Discrete Event 
Simulation….

2 Verify that the Duration is set to 0.5 hours and 
the Update interval is set to 10000.
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3 Click the Run button to begin the simulation.

Simulation Sequence Dialog Box, Simulation Speed Tab 
Selected

➥ As before, a window displays simulation 
start-up messages first, and then an animated 
graph shows both the current and average 
speed in events per second during the 
simulation. When the simulation is completed, 
you can view the event/second graph results 
from the Simulation Speed tab.
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4 When the simulation is done, close the 
Simulation Sequence dialog box. If you had 
problems, see "Troubleshooting IT Guru 
Tutorials".
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Comparing Results

To answer the questions posed about the addition of a 
second network to the existing LAN, you need to 
compare the results from both of the simulations you 
ran.

You will use the Compare Results menu item in the 
Object and Workspace pop-up menus to combine 
statistics from different scenarios in the same graph. 

To look at the server load from both scenarios at once:

1 Right-click on the server node (node_31) to bring 
up its Object pop-up menu.

2 Choose Compare Results (you can do this from 
either scenario in the project).

➥ A Compare Results dialog box appears 
containing a hierarchical representation of 
statistics collected for the server node.

If your results differ radically from those shown in the 
following figures, you will have to troubleshoot your 
simulation. See "Troubleshooting IT Guru Tutorials".
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When comparing results, choosing a statistic in one 
scenario produces a graph showing the value of that 
statistic in all scenarios. To view the results:

1 Select the Office Network.node_31 > Ethernet 
> Load (bits/sec) statistic and click the Show 
button. Your results should resemble those in the 
following figure (but may not be identical):

Server Load Compared

Simulation time, in minutes

bits/second
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The following graph is the time average of the 
Ethernet load between the baseline (first_floor) 
scenario and the expansion scenario. You will learn 
how to create a graph of the time average in the next 
lesson. 

Time-averaged Server Load Compared

Note that while the average load for the expansion 
scenario is higher (as expected), the load as a whole 
appears to be leveling off (that is, not monotonically 
increasing), indicating a stable network.
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The last step is to see how much the network’s delay 
is affected by adding a second floor. To compare 
Ethernet delay for the two scenarios:

1 Close the graph and the Compare Results dialog 
box for the server.

2 Right-click in the workspace, then select 
Compare Results from the Workspace pop-up 
menu.

3 Select the Global Statistics > Ethernet > 
Delay (sec) statistic.

4 Click Show to display the graph.

➥ The graph of the Global Ethernet Delay 
appears.

Your graph of Ethernet Delay should resemble 
the following:
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Ethernet Delay Compared

This graph shows that there is no significant 
change in Ethernet delay on the network. 
Although server load has increased, delay has 
not.

5 Close the open graph and the View Results 
dialog box.

6 Select File > Close and save changes before 
closing.

Simulation time, in minutes

Seconds
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Now you are ready to go on to the LAN Networks 
tutorial. This lesson explores the use of LAN objects in 
building networks, as well as background traffic. 
Return to the main tutorial menu and choose LAN 
Networks from the list of available lessons. 
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3 LAN Modeling
LAN Modeling

Overview

This lesson focuses on the use of LAN models and 
background link utilization. You will learn how to

• Configure the object palette with the models you 
need

• Set up application and profile configurations

• Model a LAN as a single node

• Specify background utilization that changes over 
time on a link

• Simulate multiple scenarios simultaneously

• Apply filters to graphs of results and analyze the 
results

This lesson focuses on two features, LAN models, 
which model entire LANs, and the link 
Background Load attribute, which is used to model 
existing link traffic.
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• LAN Models: If you are 
modeling a medium or large 
internetwork, you may only be 
interested in specific aspects of 
the network’s behavior (whether 
a key router will be overloaded, 
for example). In such cases, 
single nodes can model entire LANs.

• Link Background Load: Use the 
Background Load attribute to model existing 
traffic on a link instead of explicitly modeling each 
packet. You can also specify changes in this 
background traffic over the course of a 
simulation.
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Background Load Attribute Dialog Box
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Setting Up the Scenario

In this lesson, your job is to model an east coast 
company’s WAN. The company has offices in Atlanta, 
Philadelphia, New York, and Boston, which are 
connected to the central network in Washington, D.C. 
The offices use phone lines to connect to each other, 
and are therefore susceptible to delays caused by 
additional, unrelated traffic on the lines.

This company wants you to determine how this 
background traffic is affecting FTP traffic on their 
network. To do this, you will model FTP performance 
on the network, first without background traffic and 
then with background traffic. Because you are not 
interested in modeling the details of each office’s LAN, 
you will use LAN models to model the individual LANs 
as single nodes.

The first step in setting up the WAN is to specify the 
overall context for the network with the Startup 
Wizard. Once that is done, you can proceed with 
building the network itself. This topic focuses on:

• Configuring an object palette

• Specifying a map background

• Zooming in on a background
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Begin by opening a new project in IT Guru and 
configuring the scenario context using the Startup 
Wizard:

1 If is not already running, start it, select File > 
New... > Project, then click OK.

2 Name the new project <initials>_LAN_Mod and 
the scenario no_back_load, then click OK.

3 Click Next > when the Startup Wizard opens and 
select “Create empty scenario” for the 
Initial Topology.

You can specify a map to use as a background for 
your network. To set a map background:

1 Click Choose from maps for Network Scale and 
click Next >.

2 Choose usa from the Border Map list.

3 Choose usa from the MapInfo Maps list and click 
>> to move it to the Selected (background first) 
pane.
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Choose Map Wizard

4 Click Next >.

5 Select LAN_Mod_Model_List to be included in 
your network by clicking on the Include? cell and 
changing the value from No to Yes. Click Next >.

6 Review your settings and click Finish to close the 
Startup Wizard.

➥ The workspace now shows the specified map 
and object palette.
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IT Guru’s full set of node and link models would be 
overwhelming to work with all at once, so the object 
palette can be configured to show only a specific 
subset, or model list. You can use the standard model 
lists, adapt them for your own needs, or make your 
own list. 

You can create your own custom object palettes for 
use in modeling projects. 

For this lesson, we created the 
LAN_Mod_Model_List. Now you will adapt that 
model list by adding the LAN node model to it:

1 Click the Object Palette Icon or click on Open 
Object Palette under the Topology menu.

➥ The Object Palette dialog box opens.
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Object Palette Dialog Box

The Object Palette dialog box lets you change 
the object palette and then save it.

2 Click the Node Models button in the Object 
Palette dialog box.

Under Node Models, click on Fixed Node 
Models> By Name>10BaseT

3 Under 10BaseT, right click on 10BaseT_LAN 
and click on Add to Default Palette: 
LAN_Mod_Model_List
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10BaseT LAN Added to Object Palette

➥ The 10BaseT_LAN icon appears in the 
LAN_Mod_Model_List in the object palette.

4 Click Close on the Object Palette.

Because the network you will create is on the east 
coast of the U.S., there is no need to view the entire 
map. To zoom in on the east coast:

1 Click the Zoom toolbar 
button.

2 Select the top left corner 
of the area to zoom in on and drag a rectangle to 
bottom right corner. Be certain that both Atlanta 
and Boston are included in the zoomed view.
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Using the Zoom Button

Tip: If you are not happy with your first zoom, you 
can click the Zoom to Previous toolbar button, 
next to the Zoom toolbar button, and then zoom 
in again.

3 Continue to zoom until the names of cities, 
including Boston and Atlanta, appear on the map.
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Configuring Applications

It is a good idea to define the profiles and applications 
that will be used by the LAN before you begin 
constructing the network. You define the profiles in the 
profile definition object and applications in the 
application definition object.

• A profile is applied to a workstation, server, or 
LAN. It specifies the applications used by a 
particular group of users. You might have one 
profile for Marketing (heavy use of email; light 
use of file transfer) and another profile for 
Engineering (light use of email; heavy use of file 
transfer).

• An application may be any of the common 
applications (email, file transfer) or a custom 
application you define. Eight common 
(“standard”) applications are already defined: 
Database Access, Email, File Transfer, File Print, 
Telnet Session, Video conferencing, Voice over 
IP Call, and Web Browsing.

Profile Definition and Application Definition Objects
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To Configure the Application Configuration Object

Follow these steps.

1 Open the object palette if it is not already open.

2 Drag an Application Config object to the project 
workspace.

3 Right-click on the new object and select 
Edit Attributes.

➥ The Attributes dialog box opens.

4 Click on the question mark next to the name 
attribute to see a description of the attribute. 
Close the attribute description dialog box when 
done.

Application Definitions Set to Default

5 Set the name attribute to 
Application Configuration.

Click here 
to see a 
description
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6 Change the Application Definitions attribute to 
Default by clicking in the attribute’s Value column 
and selecting Default from the drop-down list.

➥ Selecting Default configures the application 
definition object to make 16 pre-configured 
applications available for use. These 
applications are different configurations of the 
eight standard applications mentioned earlier. 
Now you will be able to include these 
applications in the profile you are about to 
create.

7 Click OK to accept the changes and close the 
Attributes dialog box.
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To Configure the Profile Configuration Object

Follow these steps.

1 Drag a Profile Config object from the object 
palette to the project workspace.

2 Right-click on the object and select 
Edit Attributes.

3 Set the name attribute to Profile Configuration.

4 Change the Profile Configuration attribute by 
clicking in its Value column and selecting Edit... 
from the drop-down list.

Selecting Edit... from the Menu

➥ The Profile Configuration dialog box appears.
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Profile Configuration Dialog Box
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To Define a New Profile and Add It to the Table

Follow these steps.

1 Change the number of rows to 1.

2 Name the new profile LAN Client by clicking in 
the Profile Name column of the first row.

3 Skip the next column, Application. We’ll configure 
the other attributes first and come back to this 
one later.

4 Change the Operation Mode to Simultaneous.

5 Click in the profile’s Start Time (seconds) cell to 
open the Start Time Specification dialog box.

6 Select constant from the Distribution Name 
pull-down menu.

Start Time Specification Dialog Box
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7 Set Mean Outcome to 100, then click OK to 
close the Start Time Specification dialog box.

➥ The Start Time attribute has a value of 
constant (100).

Do not close the profile configuration attribute 
dialog box.

You will be modeling FTP performance. That 
application should be included in the profile.

1 Click in the Applications column and choose 
Edit... from the pop-up menu.

➥ The Applications dialog box appears.

2 Change the number of rows to 1.

3 Set the Name to File Transfer (Heavy) by 
clicking in the cell and selecting the application 
from the drop-down list.

The contents of the drop-down list are controlled 
by the Applications Configuration object. When 
you selected Default as the value for the 
Application Definitions attribute in this object, 
you enabled this list of applications.
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Note that the list includes 16 entries, a heavy and 
light version for each of the eight standard 
applications.

4 Set the Start Time Offset to uniform (0, 300). 

4.1 Verify that the Distribution Name is 
uniform.

4.2 Set the Minimum Outcome to 0.

4.3 Set the Maximum Outcome to 300, then 
click OK.

5 Verify that the completed dialog box looks like 
this:

Completed Applications Dialog Box
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6 Click OK to close the Applications Table dialog 
box.

7 Click OK to close the Profile Configuration Table, 
then click OK again to close the Attributes dialog 
box.
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Building the Network

Now that you have set up the scenario, configured the 
application, and created a profile that uses the 
application, you are ready to begin constructing the 
WAN. Because the network contains four identical 
subnets, you can create the first subnet in Atlanta, 
with its nodes inside it, and then copy the subnet to 
Boston, New York, and Philadelphia. You will also 
copy it to Washington, D.C. and modify it further. This 
topic focuses on:

• Building subnets

• Copying and pasting network objects

• Modifying subnets

• Connecting subnets

A subnet is a single network object that contains other 
network objects (links, nodes, and other subnets). 
Subnetworks allow you to simplify the display of a 
complex network through abstraction. 
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Subnets help you logically organize your network 
model. You can nest subnets within subnets to an 
unlimited degree. For this lesson, you can use 
subnets as logical containers for the offices in each of 
the cities. To create a subnet:

1 Open the object palette if it is not already open, 
and move it to the lower right corner of the screen 
so that it is out of the way.

2 Place a subnet over Atlanta. 

2.1 Click the subnet icon in the object palette 
and drag it to the workspace. 

2.2 Right-click to turn off node creation.

3 Modify the subnet extent of the Atlanta subnet. 
The subnet extent is the geographic area covered 
by the subnet, which may be much larger than 
the actual area you wish to model.

Subnet Extent

Subnet Extent
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3.1 Right-click and select Advanced Edit 
Attributes.

3.2 Set the name attribute to Atlanta.

3.3 Change the x span and y span attributes to 
.25. The unit of measure of these attributes 
is determined by the unit of measure of the 
top-level area, degrees in this case. The 
area covered by .25 is the area covered by 
one-quarter of one degree of latitude or 
longitude.

3.4 Click OK. Notice that the subnet extent is 
now much smaller (it may be hidden 
underneath the subnet icon).

Double-clicking on a subnet object allows you to see 
what is “inside” the subnet.

When you double-click on a subnet, IT Guru changes 
the view to show you what is inside that subnet. 
Subnets can contain nodes, links, and other subnets. 
An example topology follows. You will not see this 
topology right now. You are about to create it.
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A Subnet Hierarchy

Initially, a subnet’s grid properties are based on its 
parent subnet. If the subnet’s grid settings are 
inappropriate, you can change them to fit your 
network. To change the grid inside a subnet:

1 Double-click on the Atlanta subnet.

2 Select View > Background > Set Properties.

➥ Note that the display grid is in degrees, which 
is not appropriate for an office.

3 Set units to Meters.

4 Set resolution to 10 pixels/m.

5 Uncheck the Visible checkbox for Satellite orbits.
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6 Verify that Drawing is set to Dashed.

7 Set division to 10.

Set View Properties Dialog Box

8 Click the Close button.

Modeling the East Coast company’s network does not 
require modeling the precise nature of each node in 
each subnet, so you can represent the subnets with a 
LAN model. To create a LAN model:

1 Place a 10BaseT_LAN in the 
workspace.

2 Right-click on the 10BaseT_LAN 
and choose the Edit Attributes 
menu item.
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You can change a LAN model’s attributes so that it 
represents a network with a certain number of 
workstations and a particular traffic profile. To 
represent one of the East Coast company’s satellite 
offices:

1 Change the LAN model’s name attribute to 
Office_LAN.

2 Expand the Applications attribute group.

3 Choose Edit... for the Application: 
Supported Profiles attribute.

4 Change the number of rows to 1.

5 Change the Profile Name to LAN Client, then 
click OK.

➥ Now this LAN will use the LAN Client profile 
you created earlier. This profile includes the 
File Transfer (Heavy) application. The LAN will 
receive and send traffic that models heavy 
FTP use.

6 Expand the LAN attribute group.

7 Verify that the Number of Workstations attribute 
is set to 10, then click OK.
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You have now modeled a 10 workstation LAN inside 
the Atlanta subnet. This single object is equivalent to a 
10-workstation star topology LAN. 

A Single LAN Object is Equivalent to a LAN Composed of Many Objects

Because this LAN model is composed of workstations 
and links only, it must be connected to a router. The 
router can then be connected to other routers in the 
network. 

To create a router:

1 Drag a BN_BLN_4s_e4_f_sl8_tr4 node (a 
Nortel Networks router) from the object palette to 
the workspace near the Office_LAN node.

2 Name the new node router.

A LAN object

A 10BaseT LAN  
with 10 workstations
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3 Connect the router and the Office_LAN nodes 
with a 10BaseT link. Right-click to turn off link 
creation.

The Atlanta subnet is now configured. Because the 
subnets in the other cities are identical, you can copy 
the Atlanta subnet and place it appropriately.

When several subnets or network objects have an 
identical configuration, you can copy and paste these 
objects.

To copy the subnet:

1 Return to the parent 
subnet view by clicking on 
the Go to Parent Subnet 
button (you can also 
right-click on the workspace to bring up the 
workspace pop-up menu, then choose Go to 
Parent Subnet from the menu).

2 Select the subnet.

3 Select Edit > Copy or press <Control>+c.
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Paste the subnet to each of the four different cities.

1 Select Edit > Paste or press <Control>+v and 
click on the Washington, DC icon.

Pasting the Subnet

➥ A new subnet appears.

2 Press <Control>+v again to paste subnets over 
Philadelphia, New York, and Boston.

3 Right-click on each subnet and select Set Name 
to rename each city’s subnet as follows:

— Washington, D.C.: Washington_DC

— Philadelphia: Philadelphia

— New York: New_York

— Boston: Boston
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Connect each subnet to the Washington_DC office:

1 Select the 
LAN_Mod_PPP_DS0 
link in the object palette.

2 Draw a 
LAN_Mod_PPP_DS0 link from Atlanta to 
Washington_DC.

➥ A Select Nodes dialog box appears asking 
which nodes in each subnet are to be 
endpoints of the link.

3 For node a, choose the Atlanta.router node.

4 For node b, choose the Washington_DC.router 
node.

Select Nodes Dialog Box

5 Click OK to establish the link.
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6 Repeat this process, drawing links from each city 
to Washington_DC, specifying each city’s router 
as the links’ endpoints.

To prevent overlapping links, you can click on 
intermediate points in the workspace to make a 
link follow a path before finally clicking on its 
destination node.

7 Right-click to turn off link creation.

The network should resemble the following:

The Initial Topology

Draw links from each 
city to Washington_DC. 
Make sure the links do 
not overlap.
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To complete the network, the main office in 
Washington D.C. needs to have a switch and a server 
added to it. To configure the network in D.C.:

1 Double-click on the Washington_DC subnet to 
enter its subnet view.

2 Place one <Bay Network Accelar1050> switch 
and one ethernet_server node in the 
workspace.

3 Rename the <Bay Network Accelar1050> node 
to switch.

4 Rename the ethernet_server to FTP.

5 Connect the “router” and the “FTP” nodes to the 
switch with 10BaseT links. Right-click to turn off 
link creation.

6 Close the object palette.
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Configure the Server to Support the FTP 
Application

Follow these steps.

1 Open the Attributes dialog box for the FTP server.

2 Expand the Applications attribute group.

3 Choose Edit... for the Application: 
Supported Services attribute.

4 Change the number of rows to 1.

5 Select File Transfer (Heavy) from the Name 
column pop-up menu.

Configure the Server to Support the Application

6 Click OK to close the Supported Services dialog 
box, and then click OK to close the (FTP) 
Attributes dialog box.

The Washington, D.C. subnet is now complete 
and should resemble the following figure.
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Washington, D.C. Subnet

7 Use the workspace pop-up menu to return to the 
parent subnet view.

8 Save the project by selecting File > Save.
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Background Load

Now that you have created a model to act as a 
baseline for the performance of the East Coast 
company’s network, you can add background traffic to 
the links connecting the cities and compare the results 
from the two scenarios.

This topic focuses on

• Duplicating a scenario

• Implementing a varying background load on the 
links

Background loading is an efficient means of 
modeling a known traffic load on a link.

Network studies show that traffic rises gradually over 
the course of the day as employees arrive and begin 
work. You can use background link utilization to model 
this pattern.

Because you want to compare the performance of the 
network with and without background utilization, you 
need to prepare two scenarios, one for each situation. 
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You will duplicate the existing scenario, then add 
background traffic to it: 

1 Select Scenarios > Duplicate Scenario...

Scenarios Menu

2 Name the scenario back_load. and click OK.

Background Load is an attribute of each link. To set 
background load on the links between the cities:

1 Select the links between subnets. Right-click on 
the link between Washington, D.C. and Atlanta, 
then choose Select Similar Links from the 
pop-up menu.

2 Display the Attributes dialog box for the link 
between Washington, D.C. and Atlanta.

3 Click in the Value cell for the Background Load 
attribute and select Edit... from the pop-up menu.

➥ A Background Load table appears.
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Background Load Table

4 Click on the Value cell for “Intensity (bps) 
[Atlanta.router -> Washington_DC.router]” and 
select Edit... from the pop-up menu.

➥ The Traffic Intensity (A -> B) Attribute 
Profile dialog box appears.

5 Set the Profile name to “My_WAN_Load”.

6 Complete the Profile table as shown in the 
following figure.
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Profile Table

The intensity table above indicates that for the 
first 300 seconds of the simulation, the 
background load on this link will be 19,200 bps 
(that is, 30 percent of the DS0 capacity of the 
link). For the next 200 seconds, the background 
load on the link will be 25,600 bps (about 
40 percent of the link capacity), and for the last 
part of the simulation, the load will be 32,000 bps 
(about 50 percent of the link capacity).

7 Click OK to close the profile table.
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8 Click in the Value cell of the Intensity (bps) 
[Washington_DC.router -> Atlanta.router] 
attribute and choose Select... from the pop-up 
list.

➥ The following table appears.

Attribute Profile Table

9 Select <Local Profiles> from the Profile Library 
list and “My_WAN_Load” from the Profile list.

10 Click OK to close the Profile Selection dialog 
box.

11 Click OK to close the Background Load table 
dialog box.

Do not close the link attributes dialog box.
IT Guru/Release 11.5



General Tutorials

IT Guru/Release 11.5
The last step in setting background load is to apply the 
changes made to the Atlanta–Washington, D.C. link to 
all selected links. 

1 Check the Apply changes to selected objects 
check box in the Atlanta <-> Washington_DC 
Attributes dialog box.

Link Attributes Dialog Box

2 Click OK to close the Attributes dialog box, then 
click Yes if you are prompted to continue.

➥ Note that “4 objects changed.” appears in the 
message area.

Confirming Message

3 Save the project by selecting File > Save.
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Collecting Statistics

Now that you have configured both scenarios (one 
without background load as a baseline, and one with 
background load), you are ready to collect data and 
analyze it. 

The relevant statistics for this network are the 
throughput and utilization statistics for the links and 
the global FTP download time for the network.

This topic focuses on:

• Specifying statistics to collect in each scenario

• Switching between scenarios

• Running multiple simulations
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To Collect Statistics in the back_load Scenario

Follow these steps.

1 Right-click in the workspace to display the 
workspace pop-up menu, and select Choose 
Individual DES Statistics.

2 Select the Global Statistics > Ftp > Download 
Response Time (sec) statistic.

Selecting the FTP Download Response Time Statistic

3 Select the Link Statistics > point-to-point > 
throughput (bits/sec) --> and utilization --> 
statistic.
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Selecting the Throughput and Utilization Statistics

4 Click OK to close the Choose Results dialog 
box.

The throughput and utilization statistics that you have 
specified will be collected for every link in the 
simulation. In order to compare the statistics in the 
back_load scenario to the no_back_load scenario, 
the same statistics must be collected in the 
no_back_load scenario. To change scenarios and 
collect statistics:

1 Select Scenarios > Switch To Scenario, then 
choose no_back_load.
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Selecting the no_back_load Scenario

2 Collect the same statistics that you did in the 
back_load scenario:

— Global Statistics > Ftp > Download Response 
Time (sec)

— Link Statistics > point-to-point > throughput 
(bits/sec)-->

— Link Statistics > point-to-point > utilization -->

3 Close the Choose Results dialog box and save 
the project.

You are now ready to run the simulations to collect the 
statistics you have specified. 

Using the Manage Scenarios dialog box, you can 
rename scenarios, change their order, and run single 
or multiple simulations. 
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Instead of running each simulation separately, you 
can batch them together to run consecutively. To run 
multiple simulations:

1 Select Scenarios > Manage Scenarios...

➥ The Manage Scenarios dialog box appears.

Manage Scenarios Dialog Box

2 Click on the Results value for the no_back_load 
and back_load scenarios and change the value 
to <collect>.

3 Set the Sim Duration value for each scenario to 
2,000 and the Time Units to seconds.

Running the Simulation from the Manage Scenarios Dialog Box
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4 Click OK.

➥  This runs simulations for both scenarios. A 
Simulation Sequence dialog box shows the 
simulation progress. Close the dialog box 
when the simulations are done.

➥ If your simulation does not complete, if no 
results were collected, or if the results vary 
significantly from those shown, you will have to 
troubleshoot your simulation. See 
"Troubleshooting IT Guru Tutorials".
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Comparing Results

You are now ready to examine the results of the two 
scenarios. Because you collected the same statistics 
in each scenario, you can use the Compare Results 
feature to look at them together. 

To view the results from two or more different 
scenarios against each other, you can use the 
Compare Results feature. You can also apply different 
built-in filters to the graphs.

This topic focuses on:

• Comparing results between scenarios

• Applying filters to graphs

The Compare Results feature shows results from two 
or more scenarios. To look at link utilization:

1 Right click on the workspace to display the 
pop-up menu and choose Compare Results.

2 In the Compare Results dialog box, select 
Object Statistics > Network >  
Atlanta <-> Washington_DC [0] > 
point-to-point > utilization -->.
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3 Because utilization varies over the course of a 
simulation, it is helpful to look at the time average 
for this statistic. Change the Filter menu from 
As Is to average.

Setting the Filter

4 Click Show to display the graph. Your graph 
should resemble the following figure, though it will 
not match exactly:

Filter menu
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Average Utilization Compared

The network with the background load (back_load) 
shows higher utilization. You may want to look at the 
utilization of other links to determine the maximum 
utilization of any link.

You can also compare the link throughputs (bps) by 
selecting Object Statistics > Network >  
Atlanta <-> Washington_DC [0] > point-to-point > 
throughput (bits/sec) -->.
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Next, let’s look at Global FTP response time:

1 Move the link utilization graph aside and click the 
Unselect button in the Compare Results dialog 
box.

2 Check the Global Statistics > Ftp > 
Download Response Time (sec) statistic in the 
Compare Statistics dialog box.

3 Verify that the Filter menu shows average, then 
click Show.

Select Average from the Filter Menu

The graph should resemble the following figure:
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Average Download Response Time Compared

This graph shows that, as steady state is reached, 
response time increases by several seconds when the 
link is heavily loaded.

1 Select File > Close and save changes before 
closing.

back_load

no_back_load
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Now that you have completed the LAN lesson, you 
can move on to the Web Reporting lesson. This 
lesson presents ’s web reporting feature and how it 
can help you to make informed decisions about a 
network’s behavior. Return to the main tutorial menu 
and choose Web Reporting from the list of available 
lessons.
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4 Web Reporting
Web Reporting

Overview

This lesson focuses on using web reports to view and 
analyze the results of your simulations.

You will learn how to

• Choose a report

• Generate a web report

• Use the information provided in the report to 
make informed decisions about a network’s 
behavior

Web reports allow you to look at the results of your 
simulations in several different ways and to make 
those results available to many people. You can begin 
with a high-level summary of the results, then use 
hyperlinks within the reports to focus on problem 
areas in a network. In this lesson, we will create a web 
report and use it to analyze the performance of two 
different traffic contracts (ABR and CBR) on a small 
ATM network.
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Getting Started

Because this lesson focuses on web reports, you will 
use an existing project instead of creating a new 
network model. To load the project

1 Start IT Guru, if it is not already running.

2 Select File > Open..., and select Project from 
the pull-down menu.

3 Navigate the tree to the directory where the 
required tutorial resides. The default location is:

<opnet_dir>\models\std\tutorial_req\basic

4 Select web_report from the list of available 
projects, and click Open.

➥ The web_report project (an ATM network) 
opens in the Project Editor.

5 Select File > Save As..., rename the project 
<initials>_web_report, then save it in your 
op_models directory.
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The ATM network used in this lesson is designed to 
show the differences in performance between two 
types of ATM traffic contracts, CBR (constant bit rate) 
and ABR (available bit rate).

In the CBR scheme, the traffic contract guarantees a 
certain amount of bandwidth at all times for each user. 
The advantage to this scheme is that each user gets a 
pre-defined amount of bandwidth, regardless of other 
traffic on the link. However, this limits the total number 
of users on a link at any one time. This scheme is 
useful when a high quality of service is required, as 
with voice or video traffic.

In the ABR scheme, the traffic contract does not 
guarantee a certain bandwidth; traffic uses whatever 
is left after the CBR traffic is handled. The advantage 
to this is that a large number of users can access the 
same link at the same time. However, the available 
bandwidth is divided among those users, possibly 
increasing response time. This scheme is useful when 
a high quality of service is not necessary, as with FTP 
traffic.
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Specifying and Generating a Web Report

The ATM network used for this lesson consists of

• an FTP client using the ABR scheme

• a voice client using the CBR scheme

• 2 switches

• an FTP server

• a voice server

You can view the attributes for the client and server 
objects for more details on the setup of the network. 
For this network we are interested in the following 
statistics:

• Client Traffic Sent

• Client FTP Response Time

• Voice Application Packet End-to-End Delay
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Instead of selecting Choose Individual Statistics to 
collect these statistics, you can choose them as part 
of a report whose statistics are collected in report form 
during the simulation. You can choose a report before 
you run a simulation:

1 Click the Configure/Run 
Discrete Event Simulation (DES) 
toolbar button.

2 Select Outputs > Reports from the treeview.

“Reports” Page in Configure/Run Simulation Dialog Box

3 In the Statistics Reports pane, select 
FTP&VOICE.

You can also define your own report that contains 
any of the available statistics.
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Next, you can run the simulation:

1 Select Common in the treeview.

➥ Note that the simulation is set to run for 1,000 
seconds of simulation time.

2 Click the Run button.

➥ The simulation should take about two minutes 
to run, depending on the speed of your 
machine.

3 When the simulation completes, close the 
Simulation Sequence dialog box. 
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Before generating a web report, you can include some 
graphs that would not normally appear in a report (for 
example, graphs that show results stacked or overlaid). 
To include graphs, first display them in the Project 
Editor, then generate the report with the “Include 
graphed results” option selected in the Specify Report 
dialog box:

1 Right-click anywhere in the workspace, and 
select View Results from the pop-up menu.

2 Expand the Report FTP&VOICE hierarchy.

➥ The hierarchical view appears.

3 Select the following two statistics under 
Report FTP&VOICE > Object Statistics:

• stn_abr_ftp_client > Client Ftp > Upload 
Response Time (sec) <FTP/File Transfer 
(heavy)>

• stn_cbr_voice_client > Voice Application > 
Packet End-to-End Delay (sec)
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4 Set the view (left pull-down menu) for 
Overlaid Statistics. Verify that the filter (bottom 
pull-down menu) is set to As Is, then click Show.

➥ The graph opens in the workspace.

The significance of this graph is discussed later. 
For now, you are ready to generate and view the 
web report.

5 Click Close in the View Results dialog box, but 
leave the graph window open.

There are two steps to creating a web report: 
generating it and viewing it in a web browser. To 
generate the report

1 Select DES > Results > 
Generate Web Report...

➥ The Specify Report dialog box displays.
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2 Click OK to generate a report with the default 
name.

➥ A web report is generated and placed in the 
directory specified by the 
web_rep_storage_dir preference. If 
web_rep_storage_dir is unspecified, the web 
report will be placed in 
<user_home_dir>\op_admin\tmp.

To view the report

1 Select DES > Results > 
Launch Last Web Report.

➥  IT Guru launches the web browser specified 
by the browser_prog preference and opens 
the report index page. 

If the browser does not open, check that the 
browser_prog preference specifies the 
correct path. You can also open the browser 
manually and point to the index.html file in 
the directory specified by the 
web_rep_storage_dir preference.
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General Report Format

When a web report opens, the index page is 
displayed. The index page has several links, as shown 
in the following figure.

Index Page of a Web Report 

Link display area Data display area

Summary report for 
this simulation

Project and 
scenario displayed

Results you graphed 
earlier in this lesson
IT Guru/Release 11.5



General Tutorials

IT Guru/Release 11.5
Results by Node and Statistic

Web reports present data about a simulation in 
several different kinds of reports.

Let’s look at the FTP & Voice report:

1 In the Results area, click on the Report: 
FTP&VOICE link.

➥ Links to information collected in the Custom 
Application report appear in the link display 
area.

Link Display Area of a Web Report
TUT-4-11



 General Tutorials

TUT-4-12
2 First, let’s look at the global statistics collected. 
Under the Global Statistics link, click on Voice.

➥ A table of the Voice global statistics appears.

The main statistics of interest in this table are Traffic 
Sent and Traffic Received. Note that in this main table, 
the number of packets/second received network-wide 
equals the number of packets/second sent, so we 
know that no traffic is being dropped.

Global Statistics for the Voice Application

From this table, you can click on the links and view the 
graphs of each of the global statistics. However, for 
this particular scenario, you are primarily interested in 
the traffic sent and received at the ABR FTP node and 
CBR Voice node, so global statistics are of less 
interest.
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Of particular interest in this report is the Top Nodes 
and Links section, which provides you with a quick, 
comprehensive view of which objects in your network 
may be problems. It lists objects that were most 
“active” during a simulation. “Active” in this context 
means that the object generated the highest values for 
any statistic.

In this network, there were only two nodes for which 
statistics were collected, the ABR and CBR client 
nodes. The performance of these nodes can be 
compared in the tables in the Top Nodes and Links 
section.

Top Nodes and Links
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1 In the link display area, click on the By Node link, 
under Top Nodes and Links.

The Top Nodes Summary displays.

Top Nodes Summary Report

Any object that generates an extreme value for any 
collected statistic is considered a top node or link. In 
this example, there are only three objects. Larger 
networks with more nodes and additional collected 
statistics could have more entries in the table.

You can specify the number of objects considered 
“top” by setting the report_top_n preference before 
you generate the report.

From the Top Nodes and Links table, you can see that 
the overall results are as expected: the ABR client 
running FTP produced more traffic than the CBR 
client running voice.
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Each of the statistic names in the table is a link to 
another table that shows each statistic on a per-node 
basis. Let’s take a closer look at the response time:

1 Click on the Voice Application Packet 
End-to-End Delay (sec) heading, which is also a 
link (you might need to scroll to the right to see 
this column heading).

➥ The Top Objects for Voice Application report 
opens. Similar graphs for the other statistics 
collected on a per-node basis also appear on 
this page.

Top Objects for Voice Application Report

For each statistic discussed, your results may vary 
slightly, but general trends should be the same.
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Click on the headings to sort the table by Node, 
Average, or Peak. Sorting the table by different 
measures makes it easy to see which objects have 
the highest average values versus which objects have 
the highest peak values for a particular statistic. Let’s 
take a closer look at stn_cbr_voice_client in the 
Voice Application Traffic Sent (bytes/sec) table. 

1 Click on the stn_cbr_voice_client link in the 
Voice Application Traffic Sent (bytes/sec) 
table. (You might need to scroll down to see this 
table.) The graph is shown in the following figure.

CBR Client Sending Voice Application Traffic
IT Guru/Release 11.5



General Tutorials

IT Guru/Release 11.5
Next, let’s look at the traffic received at the ABR client 
and see how its traffic pattern differs from the CBR 
client.

1 Click the Back button in your browser until the 
Top Nodes Summary page appears.

2 Click on the Client Ftp Traffic Sent (bytes/sec) 
heading.

3 Click on the stn_abr_ftp_client link in the 
Client Ftp Traffic Sent (bytes/sec) table.

➥ The graph should resemble the following 
figure.

ABR Client Sending FTP traffic
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Compare the graph of the ABR client sending FTP 
traffic with the graph of the CBR client sending voice 
application traffic. The ABR client, as expected, sends 
traffic less frequently.

In addition to looking at the tables and graphs 
generated by the web report, you can view the graphs 
that were displayed in the Project Editor window when 
you generated the web report. This can be especially 
useful when you want to have graphs that compare 
two or more objects or statistics (rather than 
comparing them in a table).

These graphs are contained in the Graphed Results 
link in the report. To view this information:

1 Click on the Report: Graphed Results link.

➥ Links to the graphs that were open in the 
Project Editor when you generated the web 
report appear in the link area.

2 Click on the link to FTP&VOICE. 

➥ The graph of response time should resemble 
the following figure.
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Response Times for CBR and ABR Clients

As expected, the response time for the CBR client 
running the voice application is less than that for the 
the ABR client running the FTP application.

You have now completed the Web Reporting lesson. If 
you wish, you can explore the web report further on 
your own. When you are finished, close the web 
browser and save your project.
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The next lesson, Importing Traffic, illustrates the traffic 
import capabilities of IT Guru. If you will not be using 
IT Guru’s import capabilities, you might want to skip 
the Importing Traffic lesson and move on to the ESP 
lesson. Return to the main tutorial menu, and choose 
the desired tutorial from the list of available lessons. 
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5 Importing Traffic
Importing Traffic

Overview

This lesson demonstrates the traffic import 
capabilities of IT Guru. In this lesson, you will

• Examine a ready-made model that contains 
explicit traffic

• Import conversation pair traffic

• Run several simulations to see the effect of traffic 
growth on the network

In earlier tutorials, you built a network manually by 
dragging objects from a palette, then you added 
background load traffic by specifying throughput.

This tutorial shows how you can import traffic from 
external sources. You might import a router 
configuration file or VNE database to create the 
topology, then import data from different tools, such as 
NetScout nGenius, Cisco Netflow, or a custom text file 
to create the traffic.
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Reviewing the Ready-made Model

This tutorial uses a ready-made model with explicit 
traffic.

1 Choose File > Open.

➥ The Open dialog box appears.

2 With Files of type: set to Project, navigate the 
treeview in Model directories: to the basic 
folder using the following path:

<opnet_dir>\models\std\tutorial_req\basic

➥ When you select basic, the names of the files 
in the basic folder appear in the Files: pane.

3 Select Imp_Data from the list of files, then click 
Open.

➥  The network model opens in the workspace.

4 Choose File > Save As, select your default 
models directory in the treeview, and save the 
project as <your_initials>_Imp_Data.
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There are several types of traffic in IT Guru:

• Explicitly generated traffic is user-created; you 
specify the size of the transactions and the 
number of transactions per time unit according to 
a chosen distribution. You create explicit traffic by 
configuring Application Definition and 
Profile Definition objects.

• Traffic flows (also called conversation pairs or 
background routed traffic) are special objects that 
specify end-to-end traffic between source and 
destination nodes. You can create traffic flows 
manually using demand objects from the object 
palette or import them from an external source 
(Traffic > Import Traffic Flows…).

• Link Baseline Load traffic specifies the 
background traffic in bits per second. You can 
create this traffic by configuring the Background 
Load attribute of a link or by importing traffic from 
various sources using Traffic > 
Import Baseline Loads.
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In the LAN Modeling tutorial, you used link baseline 
load (background load) traffic when you created traffic 
on the links between subnets in the network. In this 
lesson you will use

• Explicitly-generated traffic to test a “what-if” 
scenario

• End-to-end traffic flows imported from an ASCII 
traffic archive

To get values for such statistics as delay and response 
time on a network with background traffic, you must 
have explicit traffic.

To create explicit traffic (such as an FTP application), 
you would normally do the following:

• Add and configure Application Definition and 
Profile Definition objects

• Choose statistics

To run a baseline simulation, you would also need to 
configure the simulation.
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Because you’ve done these tasks in earlier tutorials, 
you do not have to repeat them here. The ready-made 
network model is already configured correctly.

However, to help you become more familiar with the 
configuration tasks, we will look briefly at the following:

• Application Definition and Profile Definition 
objects

• Choose Statistics dialog box

• Configure Discrete Event Simulation dialog box
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Review the Application Definition and Profile 
Configuration objects.

1 If you are not already in the 192_9_200 subnet, 
double-click on it.

2 In the Application Definition object’s Edit 
Attributes dialog box, verify that the 
Application Definitions attribute is set to 
Default. Click OK to close the dialog box.

3 In the Profile Configuration object’s Edit 
Attributes dialog box, open the Profile 
Configuration attribute table by clicking in the 
Value field and choosing Edit… from the 
pull-down menu.

4 Verify that the attributes are set as follows: 

• Profile Name: FTP (Light)

• Applications: Choose Edit… to display the 
Applications table, verify that the File 
Transfer (Light) application is set, then click 
OK.

• Operation Mode: Serial (Ordered)

• Start Time (seconds): uniform (100, 110)

• Duration (seconds): End of Simulation
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• Repeatability: Once at Start Time

5 Click OK to close the Profile Configuration 
table, then OK to close the Edit Attributes dialog 
box.

Verify that the FTP (Light) profile is assigned to the 
LAN objects and that the application 
File Transfer (Light) is supported on the LAN server.

To do this, you will use the Select Objects… 
command, specifying that the Supported Profile value 
be FTP (Light) and that the Supported Services value 
be File Transfer (Light). You know that the network 
contains six LAN objects, so if these attribute values 
are assigned to every LAN object, the command will 
report six objects selected.

1 Choose Edit > Select Objects…

2 Configure the dialog box as shown in the 
following figure BUT DO NOT CLICK OK.
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Logical Object Selection Dialog Box
.

3 Specify the value for the Application: 
Supported Profiles attribute.

3.1 Click in the Value cell of the first row in the 
Attribute Criteria table and select Edit…

➥ The Application: Supported Profiles 
Table dialog box appears.

Search scope is 
current subnet

Object type to be 
selected is node

Proposition is 
Require

Attribute Name 
is Application: 
Supported 
Profiles

Click in the 
Value cell for this 
row and select 
Edit…
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3.2 Click in the Rows field and add a row to the 
table.

3.3 Click on the None text string in the 
Profile Name column and type FTP (Light).

Application: Supported Profiles Dialog Box

3.4 Click OK to close the Application: 
Supported Profiles dialog box.

4 In the Logical Object Selection dialog box, add a 
second row to the Attribute Criteria table and 
configure it as follows:

— Proposition: Require

— Attr. Name: Application: 
Supported Services

5 Adapt the procedure above to specify the value 
for the Application: Supported Services 
attribute.

Enter FTP (Light) as the Profile Name
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5.1 Click in the Value cell of the Application: 
Supported Services row in the Attribute 
Criteria table and select Edit…

➥ The Application: Supported Services 
Table dialog box opens.

5.2 Add a row to the table.

5.3 Click on the None text string in the Name 
column, select Edit…, and type File 
Transfer (Light).

5.4 Click OK to close the Application: 
Supported Services dialog box.

6 Click OK in the Logical Object Selection dialog 
box.

➥ The six LAN objects are selected. You 
conclude that the FTP (Light) profile is 
assigned to each client in the LAN, and that 
the application File Transfer (Light) is 
supported at the LAN’s server.

7 Click once in the workspace to deselect the 
LANs.
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Next, review the statistics specified for collection, as 
follows:

1 Right-click in the workspace and select Choose 
Individual DES Statistics from the pop-up 
menu.

➥ Notice the green dot in the checkboxes next to 
Global Statistics and Link Statistics. This 
indicates that statistics in these hierarchies 
have been chosen for collection.

2 Verify that the following statistics are selected by 
expanding the hierarchies until you see them, 
with a green dot in the checkbox.

— Global Statistics > Ftp > 
Download Response Time (sec)

— Link Statistics > point-to-point > 
utilization -->
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Choose Individual DES Statistics Dialog Box

3 Click OK to close the Choose Results dialog 
box.
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Importing the Traffic Archive

Now that you are familiar with the ready-made model, 
you can import end-to-end background traffic from a 
captured traffic archive.

To import a traffic archive, you must do the following: 

1 Capture or create the traffic (this has already 
been done for you).

2 Configure IT Guru to locate the traffic archive file. 
This directory is defined by the 
traffic_archive_dir preference.

3 Import the traffic into a scenario.

This section covers items 2 and 3.

The exact location of the traffic archive directory 
differs according to platform. Click to view the 
procedure that applies to the platform you are using:

• Windows Configuration

• UNIX Configuration
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Windows Configuration

To configure IT Guru to locate the traffic archive file in 
Windows:

1 Select Edit > Preferences.

2 In the Find field, type traffic_archive and click 
Find.

➥ The traffic_archive_dir preference appears.

3 Click in the Value column to expand it.

Make sure this preference is set to 
<reldir>\models\std\tutorial_req\basic\traffic.

4 Click OK to close the Preferences dialog box.

<reldir> describes the directory that contains the 
current IT Guru software. You can find your <reldir> 
directory by doing the following:

1 Select Help > About This Application in the 
main menu.

➥ The About IT Guru window appears.

2 Click on the Environment tab.
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3 Expand the System Information line, then find the 
OPNET Release directory entry. This path is the 
<reldir> on the host system.

The <reldir> path for a Windows computer is 
typically

C:\Program Files\OPNET\<release_number>

4 Continue with Import Procedure.
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UNIX Configuration

To configure IT Guru to locate the traffic archive file in 
UNIX:

1 Select Edit > Preferences.

2 In the Find field, type traffic_archive and click 
Find.

➥ The traffic_archive_dir preference appears.

3 Click in the Value column to expand it.

Make sure this preference is set to 
<reldir>/models/std/tutorial_req/basic/traffic.

4 Close the traffic_archive_dir and Preferences 
dialog boxes.

<reldir> describes the directory that contains the 
current IT Guru software. You can find your <reldir> 
directory by choosing Help > 
About This Application, then clicking on the 
Environment tab. Under System Information, find the 
OPNET Release directory entry.

The suggested <reldir> for a UNIX system is 
/usr/opnet/<release_number>.
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Import Procedure

After the traffic archive files have been placed in the 
correct directory, they can be imported into IT Guru 
and applied to the network in the current scenario.

1 Choose Traffic > Import Traffic Flows > 
From Text (.tr1, .tr2) Files…

➥ The Traffic Import dialog box appears.

2 A treeview of directories appears in the upper-left 
pane. Expand the hierarchy to display the 
directory where your archive files reside 
(<reldir>\models\std\tutorial_req\basic\traffic)
.

3 From the list of available files, select 
Imp_Data_Traf.tr1.

Probe information appears in the Start and End 
fields and the file name appears in the Selected 
archives pane.
TUT-5-17



 General Tutorials

TUT-5-18
Traffic Import Dialog Box

When importing a traffic file, you can specify several 
different settings, including the time period of the traffic 
you want to import.

For this lesson, we will use the entire traffic file, which 
was collected from 04:00–04:30. Note that this time 
period is set in the From and To options in the Traffic 
Selection section of the dialog box. You can type 
different times in the From and To fields if you need to 
use a subset of the entire traffic collection period.

Probe 
information

Selected 
file name
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Traffic Selection Section of Traffic Import Dialog Box

.

Another attribute that can be set during import is the 
Archive merging mode. This specifies how IT Guru 
should handle duplicate traffic.

The Archive Merging Mode option specifies how 
multiple archives of the same traffic data will be 
handled. Say, for example, that you collected data for 
the following traffic flows at the same time:

• Archive 1 comes from a probe on node 1 that 
collects traffic sent to node 2

• Archive 2 comes from a probe on node 2 that 
collects traffic received from node 1
TUT-5-19



 General Tutorials

TUT-5-20
If both probes report the same value, it does not 
matter if you choose maximum or minimum mode: 
both modes report the same value. However, if these 
probes report different values, the specified mode 
determines which value is used:

• Maximum means the larger amount of traffic is 
used

• Minimum means the smaller amount of traffic is 
used

In some cases, the Addition mode is the correct 
choice. Say, for example, a flow from node 1 to node 2 
is split into pieces and sent on multiple paths (one 
through node A, another through node B).

• If you are collecting traffic only at node 1 or 
node 2, use either the minimum or maximum 
mode.

• But if you are, instead, collecting traffic at 
intermediate nodes A and B, then use the 
addition mode to correctly consolidate the traffic.

In this case, you will use the most common mode.

1 Make sure Archive merging mode is set to 
Maximum.
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Archive Merging Mode Section of Traffic Import Dialog Box

.

2 Click Import.

➥ A window appears and shows statistics about 
the import.

Traffic Flow Import Statistics Window

➥ A set of blue dashed lines (with arrowheads at 
both ends) appears in the network. These 
objects are traffic flows, which model 
end-to-end background traffic. Each pair of 
LANs has two connecting traffic flows, each of 
which specifies traffic from a single source to a 
single destination. 

.
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Sometimes during import, IT Guru cannot associate all 
the imported traffic with the appropriate network 
objects. This traffic is called unmapped traffic. After an 
import with unmapped traffic, you have the option to 
examine the unmapped traffic in the Flows Browser 
and assign unmapped traffic as needed. Otherwise, 
you can assign unmapped traffic at any time after the 
import by selecting the Show Unmapped Traffic 
checkbox in the Flows Browser.

During import, IT Guru matches imported traffic with 
endpoints in the network using the node’s network 
alias (usually the node’s IP address).

Sometimes IT Guru cannot match endpoints to 
network objects for one of the following reasons:

1) the node was omitted from the network

2) the traffic endpoint is not actually part of the 
network

In this import, all traffic is matched to an endpoint 
without a problem. Had a problem occurred, 
unmapped traffic endpoints can be associated with a 
network object by selecting the Show Unmapped 
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Traffic checkbox in the Flows Browser and assigning 
unmapped traffic to specific nodes. For more 
information about this feature, see the Importing 
Network Traffic chapter of the User Guide.

A traffic flow appears as an arrow that connects two 
nodes, and specifies end-to-end-traffic between those 
nodes. You can import traffic flows from external 
programs and files or you can create them manually.

Each traffic flow contains one or more attributes that 
describe the traffic in that flow.

The OPNET model library allows you to create 
“demand” objects in a network. Traffic flow objects are 
a type of demand object. Demand objects are used to 
specify demands for network resources such as traffic 
demands or reserved pipelines.
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Traffic Flows

In this section we will examine the traffic you just 
imported. In the process, you will learn how OPNET 
models end-to-end background traffic using traffic flow 
objects.
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View the Traffic in a Traffic Flow Object

When you imported traffic into the network, OPNET 
created traffic flow objects (blue dashed arrows) to 
represent this traffic. In this section, we’ll examine one 
of these objects.

1 Right-click on the blue dashed line between the 
segment_1 LAN (top right) and the center switch.

➥ A pop-up menu appears and displays 
submenus for three different objects: the link 
object (brown rectangle) and two traffic flow 
objects (blue arrows).

OPNET uses lines to represent relationships 
between nodes, such as blue dashed lines (traffic 
flows) for end-to-end traffic and solid black lines 
(links) for cables and other physical connections. 
A link or flow object might be hidden by other 
objects. To view all objects at a specific point in 
the network, right-click and examine the pop-up 
menu.

2 Click in the workspace to close the pop-up menu.
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3 Right-click on the blue arrow between the 
segment_1 LAN and the segment_2 LAN.

➥ A pop-up menu appears and displays 
submenus for two different traffic flow objects. 
One specifies traffic from segment_1 to 
segment_2, and the other specifies traffic from 
segment_2 to segment_1. Because 
segment_1 and segment_2 are not connected 
directly, a link submenu does not appear.

Although what you see looks like a blue dashed 
line with two arrowheads, it is two overlapping 
flow objects; each flow has a single arrowhead to 
indicate the direction of the traffic. (The 
underlying model for these flows supports 
unidirectional traffic only.) 

4 Click in the project workspace.

5 Open the Edit Attributes dialog box for the 
segment_1 --> segment_2 traffic flow:

5.1 Right-click on the traffic flow between the 
segment_1 and segment_2 LAN. 
IT Guru/Release 11.5



General Tutorials

IT Guru/Release 11.5
UNIX: Do not release the right mouse 
button.

5.2 Select the segment1-->segment_2 traffic 
flow. This opens the context-sensitive menu 
for this object.

5.3 Select the Edit Attributes menu item. 
(UNIX: Release the right mouse button.)

➥ The Attributes dialog box for this traffic 
flow opens.

The model (ip_traffic_flow) used to create this 
flow object has two attributes that specify the 
source-to-destination traffic:

• Traffic (bits/second)

• Traffic (packets/second)

These attributes describe the traffic data you just 
imported.
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6 Click in the Value field of the Traffic 
(bits/second) attribute and choose Edit… from 
the pull-down menu.

➥ The Profile attribute dialog box opens.

Each flow object contains one or more traffic 
profiles that specify the rate of traffic for that flow. 
A “profile” is an attribute that specifies data in an 
x-y format. In this case, the x scale specifies time 
intervals in seconds and the y scale specifies the 
traffic rate in bits/second over each interval.

7 Click OK to close the Profile dialog box, then OK 
to close the Attributes dialog box.

x axis

y axis
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Organizational Scaling

Now that you have a network loaded with traffic, you 
can begin to explore what will happen as the 
organization grows and traffic increases, first by 
50 percent and then by 75 percent.

IT Guru can be used to model organizational scaling 
quickly and easily.

First, you need a baseline.
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Run the Simulation

1 Choose DES > Configure/Run Discrete Event 
Simulation.

2 Click on the Common item in the treeview and 
verify that the Duration is 360 seconds.

3 Click on Inputs > Global Attributes and verify 
that

— The Traffic Scaling Factor is 1.0

— The Traffic Scaling Mode is Background 
Traffic

(You might need to scroll down in the Global 
Attributes table to see these attributes.)

Configure Discrete Event Simulation Dialog Box
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4 Click Run.

➥ The simulation begins execution. When it is 
finished, click the Close button in the 
Simulation Sequence dialog box.

➥ If you had problems, see "Troubleshooting 
IT Guru Tutorials".

You have generated a baseline for the results, but 
don’t look at them just yet. Our interest is in seeing the 
effect of traffic growth, so we will look at these 
statistics when we can compare the results among all 
three scenarios.

Your task now is to create additional scenarios in 
which the background traffic is increased by 
50 percent and 75 percent. The best way to do this is 
to duplicate the original scenario and then scale the 
traffic for each additional scenario.
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For Traffic Increased by 50 Percent

1 Choose Scenarios > Duplicate Scenario…

2 Name the new scenario scaled_50_percent.

3 In the new scenario, choose DES > 
Configure/Run Discrete Event Simulation.

3.1 Click Inputs > Global Attributes in the tree 
view and change the Traffic Scaling Factor 
simulation attribute to 1.5.

3.2 Verify that the Traffic Scaling Mode is set to 
Background Traffic (that is, flow traffic and 
baseline load traffic, but not explicitly generated 
traffic).

Traffic Scaling Factor is Set to 1.5

The next time you run a discrete event simulation, 
the background traffic in the network will be 
increased by 50 percent.

4 Click Apply to save your DES configuration and 
then click Cancel.

5 Save the project by choosing File > Save.
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For Traffic Increased by 75 Percent

Follow the same method:

1 Choose Scenarios > Switch To Scenario > 
original_traffic.

2 Duplicate the scenario and name the new 
scenario scaled_75_percent.

3 In the new scenario, choose DES > 
Configure/Run Discrete Event Simulation.

3.1 Change the Traffic Scaling Factor 
simulation attribute to 1.75.

3.2 Verify that the Traffic Scaling Mode is set to 
Background Traffic.

The next time you run a discrete event 
simulation, the background traffic in the 
network will be increased by 75 percent.

4 Click Apply to save your DES configuration and 
then click Cancel.

5 Save the project by choosing File > Save.
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You can run simulations for multiple scenarios with a 
single command from the Manage Scenarios... dialog 
box. You can also duplicate, delete, and rename 
scenarios.

Now that each scenario has been created with the 
appropriately scaled traffic, you can run the two new 
scenarios as a batch.

1 Choose Scenarios > Manage Scenarios…

➥ Notice that the Results for the original_traffic 
scenario are shown as up to date, while they 
are uncollected for the two new scenarios.

2 In the Results field, change scaled_50_percent 
and scaled_75_percent to <collect>.

Running Simulations from the Manage Scenarios... Dialog Box
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3 Click OK. 

➥ The simulations begin execution. The two 
simulations should take about one minute to 
run. Close the Simulation Sequence dialog 
box when complete. 

➥ If you had problems, see "Troubleshooting 
IT Guru Tutorials".

Now that all the results have been collected, you can 
view utilization on the links and FTP download 
response time to see how the network performs under 
various loads. To view utilization:

1 Right-click in the workspace and choose 
Compare Results from the pop-up menu.

2 Verify that the Discrete Event Graphs tab is 
selected.

3 Expand Object Statistics > 192_9_200 > 
192_9_200_Segment1_link_0[0] > 
point-to-point. Select utilization --->.

The utilization statistic will be more meaningful if 
viewed as the average utilization over time. You can 
apply a filter to the results to view the average 
utilization:
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1 At the bottom of the Compare Results dialog box, 
click on the filter pull-down menu (it shows the 
default value, As Is) and select average.

Compare Results Dialog Box (detail)

2 Click Show to display the graph.

➥ The utilization in each scenario for the 
192_9_200_Segment1_link_0 object is 
graphed.

The graph for average utilization should be similar to 
the following figure:

Set the filter pull-down 
menu to average
IT Guru/Release 11.5



General Tutorials

IT Guru/Release 11.5
Average Utilization Graph

Note that although utilization has not yet reached 
steady state, its low value (less than 15 percent for the 
scaled_75_percent scenario) indicates that the 
between-LAN links are not the bottleneck in this 
network.
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Also note that the x-axis is labeled with the actual 
times at which the data was collected. This 
information was contained as part of the imported 
traffic and was automatically set as the network start 
time.
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The other statistic you collected was Download 
Response Time:

1 Move the Utilization graph out of the way, but 
don’t close it.

2 In the Compare Results dialog box, click the 
Unselect button.

3 Expand Global Statistics > Ftp. Select 
Download Response Time (sec).

Compare Results Dialog Box, Filter Set to Average

4 Verify that the graph filter is set to average.
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5 Click on the Show button.

➥ The resulting graph should resemble the 
following figure:

Average of FTP Download Response Time Graph

6 Notice the following:

• Download response time increases when 
traffic is scaled 50 percent.

• Response time continues to increase when 
traffic is scaled up to 75 percent.
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• But the increases are very small: far less than 
one second.

Although these increases are minor, you have run 
only one simulation set. For the results to be 
statistically useful, you might want to try different 
types of explicit traffic and vary the simulation seed.

You have now completed the Importing Traffic lesson. 

• Select File > Save. We suggest saving the 
project so you can refer to it again if needed.

• Return to the Tutorials main menu and continue 
with the Expert Service Prediction (ESP) tutorial.
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6 Expert Service Prediction
Expert Service Prediction

Overview

This lesson explores practical applications of 
IT Guru’s Expert Service Prediction (ESP) features for 
service level management, including:

• Specifying service level agreement (SLA) 
thresholds for different scenarios

• Configuring simulations to study the impact of 
network traffic growth

• Generating and interpreting Web reports

An SLA typically specifies certain levels of 
service—server response time, router-processing 
delay, link utilization—that the network provider 
promises. Within IT Guru, an SLA is a set of 
thresholds that IT Guru applies to statistics you 
specify. IT Guru then shows violations of those 
thresholds in graphs and Web reports.

In the scenario used for this tutorial, TENPO software 
company has six LANs in their main office, all 
connected to a single switch. Their Information 
Systems (IS) group must guarantee a response time 
of less than 11 seconds among the LANs during 
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system backups when the network load is greatest. 
The IS group has already imported a LAN-level model 
of their network and imported baseline background 
traffic.

Your job is to take the existing models and specify 
SLA thresholds, and then run simulations to 
determine how long it will be before the network, at its 
current growth level, will violate its SLA. Your 
supervisor wants a report of your findings.
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Examining Traffic in the Existing Model

To load the existing model that the IS group has 
already created, follow these steps:

1 If IT Guru is not already running, start it. 

2 Select File > Open, and then choose 
<reldir>\models\std\tutorial_req\basic.

3 Choose ESP_tutorial from the Files: list, and 
then click Open.

➥ The network model opens in the Project Editor.

The Existing Model
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4 Select File > Save As..., and then save the 
network as <your_initials>_ESP_tutorial in 
your <home>\op_models directory.

You can now examine the existing background traffic 
on the network. 

1 Select Traffic > Open Flows Browser.

2 Examine the traffic associated with segment_0.

2.1 Expand segment_0.

2.2 Select the flow segment_0 --> segment_1.

➥ Two graphs display under the network 
model. The graphs show the traffic for the 
selected flow, which now appears blue in 
the model.
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Flows Browser Dialog Box

The graph on the left shows traffic in bits 
per second during a 30-minute period. It 
shows traffic ranging from about 600,000 
to 1,700,000 bits per second.

Expand segment_0 in 
the Source Nodes pane,
then select 
segment_0-->segment_1
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The graph on the right shows traffic in 
packets per second during the same 
period. It shows traffic ranging from about 
600 to 1,700 packets per second.

3 You can repeat the procedure to examine traffic 
for other segments.

4 Close the Flows Browser.
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Setting SLA Thresholds

Now that you have reviewed the IS network model, 
your goal is to set an SLA that will tell you if the IS 
guarantee is being violated. For TENPO’s network, IS 
has guaranteed an FTP response time of 11 seconds. 

To set the SLA thresholds, follow these steps:

1 Select DES > Expert Service Prediction > 
Define Service Level Agreement...

2 From the list of available statistics, choose 
Global Statistics > Ftp > Download Response 
Time (sec).

Define Service Level Agreement Dialog Box

Choose Global 
Statistics: Ftp: 
Download Response 
Time (sec)
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3 Define the SLA as shown in the following figure:

Defining the Download Response Time SLA

➥ FTP response time is in compliance if more 
than 50 percent of the response times, in any 
1-minute period, are 11 seconds or less. So 
IT Guru reports an SLA violation if more than 
50 percent of the response times, in any 
1-minute period, are above 11 seconds.

4 Save the SLA for Download Response Time, 
naming it <initials>_11_sec_resp_time.

“11” means “11 seconds.” 
The unit of measure is 
taken from the statistic (in 
this case, response time).
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Next, specify an SLA for utilization:

1 Click the Clear button.

2 Select the following statistic:

Link Statistics > point-to-point > 
utilization ––> 

3 Define the SLA as shown in the following figure:

Defining the Utilization SLA

Utilization is in compliance if utilization for a link is 
lower than 75 percent for more than half of a 
1-minute period. Therefore, IT Guru will report an 
SLA violation if utilization for a link is higher than 
75 percent for more than half of a 1-minute 
period.

“75” means 75 percent. 
The unit of measure is 
taken from the statistic (in 
this case, utilization rate).
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4 Click Save when you are done. Name the SLA 
<initials>_75percent_util, and then close the 
Define Service Level Agreement dialog box.

Now that you have defined the response time and 
utilization SLAs, you must apply them to the scenario.

1 Select DES > Configure/Run Discrete Event 
Simulation....

2 Expand the Outputs treeview branch and click 
on Outputs > Reports.

3 From the list of available SLAs, check 
<initials>_11_sec_resp_time and 
<initials>_75percent_util.

Applying the SLA

Note: You can also use the Define SLA Report... 
button to define reports.
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For your supervisor, you will generate a Web report. To 
specify the results contained in the report, perform the 
following steps:

1 In the Statistics Reports section, click the 
Define Statistics Report... button.

2 Enable the New Report radio button, and then 
click OK.

3 From the available statistics, select the following:

• Global Statistics > Ftp > Download 
Response Time (sec)

• Link Statistics > point-to-point > 
utilization ––>

• Link Statistics > point-to-point > 
utilization <––

4 When you have finished selecting statistics for 
the Web report, click Save, and then name the 
report <initials>_ESP_report.

Note that you can reuse any report template, including 
predefined templates, in other scenarios.
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Now that you have defined the report template, you 
must apply it to the scenario:

1 In the Statistics Reports section, from the list of 
available reports, choose 
<initials>_ESP_report.

2 Click on the Common treeview branch.

3 Verify that the Duration field is set to 15 
minutes.

4 Expand the Inputs treeview and click on 
Inputs > Global Attributes.

5 Verify that the simulation attribute Traffic Scaling 
Mode is set to All Traffic.

Do not close the Configure/Run DES dialog box.
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Specifying Traffic Growth

Instead of creating multiple scenarios and scaling the 
traffic by hand, you can use the Specify Traffic 
Growth feature to scale traffic growth automatically 
within a single scenario.

Now that you have created a baseline scenario and 
defined the SLAs for response time and utilization, 
you can use the Specify Traffic Growth feature to 
study the effects of increased traffic on the network. 
You can define either simple or compound traffic 
growth without having to duplicate the baseline 
scenario or scale the network traffic manually. 

To scale the traffic growth for this scenario, follow 
these steps:

1 In the treeview of the Configure/Run DES dialog 
box, select Inputs > Traffic Growth.

2 In the Traffic Growth page, select 4 in the 
Iterations field and select 2 in the Months field. 
You will study TENPO’s traffic growth over the 
next 6 months in 2-month intervals.
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Traffic Growth Page

3 Enable the Use growth rate of checkbox and set 
the value to 15% per iteration.

4 Enable the Use compound growth checkbox.

For this study, you are only interested in the 
summary results, so make sure the Store only 
summary results checkbox is selected.

5 Click Run to begin the simulations.

6 Click Close when the simulations finish.
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Viewing a Web Report

Although you can always view the results of your 
simulations in IT Guru, the Web report feature allows 
you to organize and distribute the results of your 
simulations.

When your simulations have executed, you can view 
the Web report that includes all results.

To generate the Web report, perform the following 
steps:

1 Select DES > Results > Generate Web 
Report....

➥ The Specify Report dialog box displays.

2 Click OK to generate a report with the default 
name.

➥ A Web report is generated and placed in the 
directory specified by the preference 
web_rep_storage_dir.

If web_rep_storage_dir is not set, the Web 
report is placed in 
<user_home_dir>\op_admin\tmp.
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Follow these steps to view the Web report:

1 Choose DES > Results > Launch Last Web 
Report.

➥ The Select Report dialog box opens, showing 
a list of reports generated (by name or by 
date).

(If there is only one Web report, it will open 
automatically and you can skip the next step.)

2 Left-click on the View Most Recent button.

➥  IT Guru launches the Web browser specified 
by the browser_prog preference and opens 
the Report Index page. If the browser does not 
open, check that the browser_prog 
preference specifies the correct path.

There are two types of graphs available for displaying 
SLA compliance information, depending on whether 
you ran a single simulation scenario or a multiple 
simulation scenario.

When the Web report opens, you will see the Index 
page, which displays several links. These links are 
described in detail on the following pages.
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Web Report Index Page

 

First, look at the response time global statistic you 
collected:

1 In the Results area, click on the SLA: 
<initials>_11_sec_resp_time link.

➥ Links to information about SLA violations and 
close calls display in the lower section of the 
link display area.

Summary of 
each SLA and a 
link to the 
report

Data display area

Link display area
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Links on 11_sec_resp_time SLA

2 Click on the Violations:Text Summary link.

➥ The text summary indicates that during the 
worst period of violation, the FTP download 
response time was above the 11-second SLA 
nearly all the time. You can view the graph of 
this SLA by clicking on the Global Ftp 
Download Response Time (sec) link.

The graph of FTP Download Response Time is shown 
in the following figure. The months shown in the time 
axis may be different in your graphs because the 
starting month depends on when you run the 
simulation:
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FTP Download Response Time

Note that the 11-second SLA is violated during 3 
simulation periods, beginning 2 months in the future.

Next, look at the link utilization object statistic:

1 Click on the SLA: <initials>_75percent_util link.

➥ Links to information about SLA violations and 
close calls, plus reports on the top nodes 
and links display in the lower section of the 
link display area.
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Links on 75percent_util SLA

For information about violations, you can examine the 
text summary, the summary by link, and the summary 
by statistic.

1 Click on the Violations: Text Summary link.

➥ The text summary lists each network link that 
violated the SLA. Each network link was above 
the SLA limit during at least one period; some 
violated the SLA during two periods, and the 
network link to segment_0 was above the SLA 
nearly all the time during its worst period.
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2 Click on the link for the 192_9_200_81 <--> 
segment_2 network link. 

➥ The report shows graphs that correspond to 
the link display. 

This network link violated the SLA during two 
periods. During the worst period, it was above the 
limit most of the time. Utilization rose steadily 
over the eight months covered, exceeding the 
SLA during the third period.

Violations for the Utilization Statistic

From the data seen so far, you can answer the 
question initially posed: If traffic continues to grow 
at the current rate, how long will it be before an 
SLA is violated? 
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Answer: Both SLAs will be violated two periods from 
now, in 4 months.

To give your supervisor the comprehensive report 
requested, you can simply provide the URL to the 
top-level page in the report.

Return to the main tutorial menu and choose the next 
tutorial, Productivity Features, from the list of 
available lessons.
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7 Productivity Features
Productivity Features

Overview

This lesson explores IT Guru productivity 
features—tools that improve model-building efficiency 
and usability. This lesson focuses on the following 
tools:

• Preferences

• Device Creator

• Derived Models

• Logical Object Selection

• Network Browser

• Annotation Palette

This lesson focuses on several special tools, called 
“Productivity Features,” that you can use to improve 
your model-building efficiency.
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IT Guru has a number of built-in features that have not 
been used in previous lessons. Although these tools 
are not essential to model building, they can greatly 
improve your understanding of models and your 
modeling efficiency. To familiarize yourself with these 
tools, you will use each of them to create a network 
model.

Prod_Features Network Model
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Getting Started

For this lesson, you will start with an existing network 
and use several features to add to and enhance the 
network.

1 Choose File > Open... and select Project from 
the Files of type pull-down menu.

2 Open the Prod_Features project, which is 
located in the following directory:

<opnet_dir>\models\std\tutorial_req\basic

➥ The Prod_Features project and scenario 
open in the Project Editor.

3 Choose File > Save As... and save your project 
as <initials>_Prod_Features in your default 
model directory.

The Prod_Features project contains a network of 
three subnets, each representing a floor of a building. 
The first and second floors contain star-topology 
10BaseT Ethernet networks. The third floor, which you 
will build, is the location of the network’s two e-mail 
servers and a switch that connects the three floors to 
the outside world. You will use Device Creator to 
create a special switch and two e-mail servers for the 
third floor.
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In addition, a brief overview of customizing the user 
interface in IT Guru is provided.

To start, you will change the name of the object 
palette’s model list to reflect your initials.

1 Open the object palette.

➥ The object palette opens with the 
Prod_Features_Model_List model list active.

2 Right click on the palette’s folder and select 
Configure in Icon View.

3 Click Save As... in the Configure Palette dialog 
box.

4 Save the model list as <initials>_Prod_Features 
in your default model directory.

5 Click OK to close the Configure Palette dialog 
box.

6 Close the object palette.

You can now add or delete models from the model list 
you created without changing the original model list.
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Preferences

Preferences are used to customize IT Guru to your 
specifications.

You can change preferences to customize many 
aspects of IT Guru, including the user interface. For 
example, you can use the following procedure to 
change the background color of the workspace:

1 Choose Edit > Preferences.

2 Find the ui_colors.tool_back preference.

To find this preference, either scroll to its location 
in the list or type “tool_back” in the edit field at the 
top, then click Find to view a subset of 
preferences that mention “tool_back.”

3 Change the ui_colors.tool_back preference by 
clicking in its value field and choosing a 
background color from the color chooser. Click 
OK when you are done. 

4 Click OK to close the Preferences.

➥ The background color has been changed and 
will take effect after the screen is refreshed (for 
example, when you open a subnetwork).
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Device Creator

Device Creator lets you customize devices and save 
them.

We will use this feature to create a new 3Com switch 
for the third floor of your network. You need to modify 
the standard 3Com switch to a different port 
configuration.

1 Choose Topology > Create Custom Device 
Model.

2 In the Create Custom Device dialog box, 
expand Vendor Device.

3 Expand the 3Com folder from the list of available 
vendors.

4 Select CoreBuilder 3500 from the available 
devices.

Because you need five 10BaseT ports for the 
network—one port per server (2), one port for 
each of the other floors (2), and one port to 
connect to the outside world (1)—you would 
probably purchase a 3C35210 card, which has 
six ports, for the switch. You can specify this in 
the Port Count setting.
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5 Change the value of Port Count to 6.

Create Custom Device Dialog Box

6 You can specify a new palette for the new device. 
Set the Destination Palette menu to 
<initials>_Prod_Features.

7 Click Create As.

8 In the Model name field, enter 
<initials>_Prod_Features_Switch.

➥ A message appears when your device is 
ready.

9 Click OK to close the notification dialog box.
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10 Click Close to close the Create Custom Device 
dialog box
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Derived Models

You can derive customized network models—called 
derived models—from existing models.

Another way to create a customized model is to derive 
it from an existing model. This is useful when you 
have an object with a complex configuration and do 
not want to configure the object each time you use it. 
You can create one instance of the object with the 
necessary configuration and use it wherever 
necessary. You can also derive models for vendor 
models that do not come standard with IT Guru.

Standard models often have a suffix modifier that 
indicates the level of derivation of the model. An 
advanced model (_adv suffix) shows all attributes and 
sets them to their default values. An intermediate 
model (_int suffix) shows the most important attributes 
with their most useful values and hides attributes that 
are unlikely to be changed.

In this section, you will derive a new server from an 
existing model. The derived server will have over 
90 percent of its CPU resources devoted to 
background processing.
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1 Open the object palette if it is not already open.

➥ The 3Com CoreBuilder switch that you just 
created is now listed in the object palette 
under the 3Com CB 3500 subfolder.

2 Select the ethernet_server object, and click on 
the Model Details button.

➥ This opens its node model description, which 
contains an object description and other 
important information. You cannot edit the 
information in this dialog box.

3 Click on the Derive New button.

➥ The Derive New Model dialog box opens; you 
can edit the fields in this dialog box.

4 In the CPU Background Utilization row of the 
Attributes table, select Edit... from the list in the 
Initial Value column.

5 In the CPU Background Utilization table, change 
the background utilization (%) value from 0.0 to 
90.
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Changing the Background Utilization Attribute

6 Click OK when finished.

When you create a derived model from another 
model, you might want to change other aspects of the 
model, such as the keywords, the icon used to 
represent the object, and the object description. In this 
case, you will change the object description only.

1 Add a sentence to the end of the first paragraph, 
noting that this model has 90 percent of its CPU 
resources in use for the entire simulation.

Sentence Added to Comments
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2 Click on the Save... button when you finish 
editing the comments.

➥ The Save As... dialog box appears.

3 Select your default model directory in the 
Model directories treeview, type 
<initials>_Prod_Features_Server in the 
File name field, and click Save.

➥ Your derived model is saved as 
<initials>_Prod_Features_Server.

4 Close the Edit Derived Model dialog box.

Now that you have created the new derived model, 
you must add it to the object palette.

1 Open the object palette if it is not already open.

2 Right-click on the My_Prod_Features palette 
folder, and select Configure In Icon View. 

➥ The object palette switches from the tree view 
to the icon view.

➥ The Configure Palette dialog box appears.

3 Click on the Node Models button.
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4 Scroll down until you see the server you just 
created.

5 Change the status of the 
<initials>_Prod_Features_Server node model 
from not included to included, then click OK.

Including the Custom Node Model

6 Click OK in the Configure Palette dialog box, then 
save the palette as <initials>_Prod_Features. 
Click OK when you are asked to confirm the 
overwrite.

➥ The derived model 
<initials>_Prod_Features_Server appears in 
the object palette.
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Now you can create the third floor subnet, which 
contains two e-mail servers and the derived 3Com 
switch. This switch connects to the switches on the 
other two floors.

1 Double-click to enter the third_floor subnet.

2 Drag two <initials>_Prod_Features_Servers 
from the object palette to the left side of the 
workspace.

3 Now you will add the 
<initials>_Prod_Features_switch to the model. 

3.1 Expand the 3Com CB 3500 subfolder to 
display the models in this group (in this case 
there is only one model in the group).

Object Palette for 3Com CB 3500 Group
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3.2 Place an <initials>_Prod_Features_switch 
to the right of the servers.

4 Connect the two servers to the switch using 
10BaseT links.

5 Using the Set Name item from the Object pop-up 
menu, name one server Bell, the other server 
Red, and the switch 3rd_switch.

The Finished third_floor Subnet

To connect the first and second floors to the third floor:

1 Return to the parent subnet by using the Go to 
Parent Subnet command in the Workspace 
pop-up menu or by clicking on the toolbar button.

U
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2 Connect the first_floor subnet to the third_floor 
subnet with a 10BaseT link. When prompted to 
select the nodes to connect, select 
first_floor.1st switch and 
third_floor.3rd_switch. Click OK.

Select Nodes Dialog Box

3 Connect the second_floor subnet to the 
third_floor subnet with a 10BaseT link. Select 
the second_floor.2nd switch and the 
third_floor.3rd_switch. Click OK.

Connecting Subnets

4 Right-click to turn off link creation.
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5 Click in the workspace to unselect all objects.

6 Save the project.

7 Close the object palette.

At this point, your network should be fully functional. 
However, because this lesson is about productivity 
tools, we will not run any simulations using the 
network.
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Logical Object Selection

Instead of selecting objects individually, you can use 
Logical Object Selection to select objects with similar 
attributes or associations. 

Now that you have created the servers for the 
network, you should check to make sure that all of the 
workstation nodes are configured correctly, especially 
because you don’t know how the original model 
developer set the attributes. Because there are 
workstations in two different subnets of this model, 
selecting the nodes one-by-one would be tedious and 
time-consuming. Instead, you can use Logical Object 
Selection to select all the workstations at the same 
time.

To select all the workstations in the network:

1 Choose Edit > Select Objects...

➥ The Logical Object Selection dialog box 
opens.

2 In the Object Types section, use the default 
settings.
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3 In the Include Objects In section, select 
Current subnet, Child subnets, and 
Other subnets.

4 In the Attribute Criteria section, set the 
Proposition field to Require, Attribute Name 
field to model, and Value to ethernet_wkstn.

5 Click OK.

Logical Object Selection Dialog Box

When you click OK in the Logical Object Selection 
dialog box, IT Guru selects any objects that match the 
criteria you specified. In this case, IT Guru displays 
the first subnet found that contains selected objects.

Now that you have selected all the necessary nodes, 
set their attributes so that 75% of every workstation’s 
CPU is “background-utilized” during a simulation.

1 Right-click on any workstation and select Edit 
Attributes from the Object pop-up menu.
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2 Expand the CPU compound attribute by clicking 
on the “+”, then change the value of 
CPU Background Utilization to Edit…

3 In the CPU Background Utilization table, change 
the background utilization (%) attribute to 75 
and leave the time (sec) attribute at 0.0. Click 
OK.

4 Select the Apply changes to selected objects 
checkbox to ensure that the changes you made 
are propagated to the other selected 
workstations.

5 Click OK.

(A message might appear warning you that 
attribute changes to multiple objects cannot be 
reverted using the Undo command. Because you 
are sure you want to make these changes, click 
Yes to accept them.)

➥ The message “27 objects changed.” appears 
in the message area at the bottom of the 
Project Editor window.

6 You can look at the background utilization 
attribute of a workstation in the other subnet to 
verify that it has been changed.
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Another way to select objects in the network is with the 
Select Similar Nodes/Select Similar Links option on 
the Object pop-up menu. This enables you to select 
every node or link object in the network whose model 
attribute is the same as the original object. This 
function is not available on subnet objects.

Select Similar Nodes/Links Option on Object Pop-Up Menu
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Network Browser

The Network Browser uses a treeview to organize and 
display objects in the network. The browser view and 
the topology view give different views of the same 
network. However, the treeview can make it easier to 
find and edit objects, especially in large networks.

In addition to providing an overview of the network 
with two views, you can use the Network Browser to 
traverse the network quickly.

To open the Network Browser:

1 Choose View > Show Network Browser.

➥ The browser opens. There are now two 
different views of the network objects: a tree 
view on the left side of the window and a 
network topology view on the right side of the 
window.

2 In the tree view, expand the first_floor subnet to 
view a list of its contents.

3 Double-click on 1st switch.

➥ 1st switch becomes highlighted in the tree 
view and in the network topology view.
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4 Right-click on the 1st switch object (in the tree 
view or in the network topology view) and select 
Edit Attributes from the pop-up menu.

5 Change the model attribute to 
<initials>_Prod_Features_Switch, then click 
OK.

➥ This replaces the existing switch with the 
derived 3Com switch you created with Device 
Creator.

6 Collapse the first_floor subnet, then repeat this 
procedure for the switch on the second_floor 
subnet.

7 Choose View > Show Network Browser again 
to close the Network Browser.
TUT-7-23



 General Tutorials

TUT-7-24
Annotation Palette

You can add graphic or text annotations to a network 
model to improve its readability and understandability. 
Annotation objects do not affect the functionality of the 
network model.

The Annotation tool lets you add text, arrows, and 
other objects to your model to improve readability or to 
call attention to important features. In this section, you 
will use the Annotation tool to clarify several points in 
the building model. Annotation objects do not affect 
the functionality of a network model.

Annotation Palette

To activate the annotation palette:

1 Choose Topology > Open Annotation Palette.

➥ The annotation palette opens in the 
workspace.
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Use the annotation tool to show that each subnet 
represents a floor within a building:

1 Traverse the network until the first-, second-, and 
third-floor networks appear as icons (as shown).

Network Model with Annotations

2 Click on the rectangle button in the annotation 
palette, then draw a rectangle around the three 
subnets.

3 Click on the text button in the palette and type the 
annotation “Building Model” in the text edit pad, 
then choose File > Save from the text edit pad’s 
menu.

4 Specify the location for the text annotation by 
dragging a box to the right of the rectangle you 
drew in step 2. Right-click to stop placing text.
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You can also annotate some objects on the third floor 
to make that part of the model more understandable. 
Links indicate that the 3rd floor switch is connected to 
the outside world, but you can add an annotation to 
make the concept more explicit.

1 Double-click on the third_floor subnet.

2 Add an arrow:

2.1 Click the line button in the palette, then draw 
a line extending to the right from the switch 
(left-click at the start point, drag the mouse 
to draw the line, double-click to end the line 
at the desired point, then right-click to end 
line drawing).

2.2 Right-click on the line and select 
Edit Attributes.

2.3 Change the line style attribute to dashed.

2.4 Change the head arrow attribute to yes and 
click OK.

3 Add the text “To Outside World” to the right of 
the arrow:
IT Guru/Release 11.5



General Tutorials

IT Guru/Release 11.5
3.1 Click on the text tool and type the text in the 
text edit pad.

3.2 Save the text.

3.3 Drag the cursor to place the text in the 
workspace. (Right-click to stop placing text.)

3.4 Draw an ellipse around the text.

The third floor subnet should now look like this:

Third Floor Subnet with Annotations

You can add more annotations to the network model if 
you want. You can also change the color of any 
annotation object by changing its color attribute. To 
hide all annotations, choose View > Annotations > 
Show in Subnet.
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When you finish adding annotations to your model, 
save it.

Congratulations! You have completed the core tutorial 
lessons. Now you can build your own network model, 
collect statistics, run a simulation, and analyze the 
results.

If you purchased additional modules, such as 
Multi-Vendor Import or ACE, continue with the 
tutorials that illustrate these capabilities. Return to the 
main tutorial menu and choose the desired tutorial 
from the list of available lessons.

From time to time, you might have questions about 
certain aspects of IT Guru. For answers, see Help > 
Product Documentation or visit the OPNET 
Technical Support website by choosing  
Help > Web - Support Center.

Good luck model building!
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App A Troubleshooting Tutorials
Troubleshooting IT Guru Tutorials

Introduction

This document contains information that can help you 
correct common problems.

• The OPNET Installation Directory

• The tutorial_req Files

• Saving Tutorial Files

• The tutorial_ref Directory

• Troubleshooting Simulations

• Additional Help
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The OPNET Installation Directory

To complete the tutorials, you must install the IT Guru 
standard models, which include the required tutorial 
models. The standard models are normally installed 
when you install the Standard Model Library.

IT Guru standard models apply to common protocols 
and vendor devices. The standard models are in the 
subdirectories under the OPNET release directory 
(<reldir>):

<reldir>\models\std\<protocol_name>

<reldir> describes the directory that contains the 
current IT Guru software.
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You can find your <reldir> by performing the following 
steps:

1 In the main menu, select Help > About This 
Application.

2 In the About IT Guru dialog box, click on the 
Environment tab, and then expand the System 
Information section.

3 Under System Information, find the 
OPNET release directory.

For example, the <reldir> for a default installation of 
this release of IT Guru on Windows is

C:\Program Files\OPNET\11.5.A

The tutorials use the Windows convention of the 
backslash character (\) as the separator in directory 
pathnames. If you are using Solaris, replace the 
backslash with a forward slash (/).
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The tutorial_req Files

When you perform a tutorial, you are asked to open 
specific tutorial model files. These model files are 
required to complete the tutorial; they are located in 
the <reldir>\models\std\tutorial_req directory or its 
subdirectories.

When you are asked to open supplied model files, 
make sure you navigate the directory structure in 
OPNET's open file browser (in the left pane) to the 
tutorial_req directory.

Navigating to the tutorial_req Directory
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Saving Tutorial Files

In several tutorials, you will be asked to open an 
OPNET model file and save it with a unique prefix, 
such as your initials (<your_initials>). This way, 
several users can create and complete their own copy 
of the same tutorial without interfering with each 
others' work.

When you save a new model file, or use the 
Save As... command to save an edited model file with 
your initials, remember to navigate to your OPNET 
default model directory (normally 
<home>\op_models) to save your files.

Navigating to the op_models Directory

If you do not navigate to your default model directory 
(normally <home>\op_models) when you perform a 
Save As... operation, the file is automatically saved in 
the current model directory.
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The tutorial_ref Directory

The tutorial_ref directory contains completed 
reference models for many tutorials.

If you are unable to complete a tutorial lesson, you 
can compare your model to the tutorial_ref model to 
help you determine the cause of the problem.

The tutorial_ref directory for IT Guru is

<reldir>\models\tutorial_ref\<subdirectory>

The subdirectory contains models according to the 
category under which they are listed on the Tutorials 
menu for your product (for example, basic or module).

If the tutorial_ref directory is not available in the 
browser, use the following procedure at add the 
tutorial_ref directory to your model directories.
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To add the tutorial_ref directory to your model 
directories list, perform the following steps:

1 Select File > Model Files > 
Add Model Directory.

Adding a Model Directory

➥ The Browse For Folder dialog box opens.

Locating the tutorial_ref Directory
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2 In the Browse For Folder dialog box, navigate the 
directory tree to the tutorial_ref directory, 
choose the directory, and then click OK (or 
Choose in Solaris).

➥ The Confirm Model Directory dialog box 
opens.

Adding a Model Directory

3 Select the Include all subdirectories checkbox, 
and then click OK.

➥ The tutorial_ref directory displays under 
Model directories (and is also included in your 
mod_dirs Preferences) making the reference 
models available to you.

The tutorial_ref Directory and Its Subdirectories
IT Guru/Release 11.5



General Tutorials

IT Guru/Release 11.5
Troubleshooting Simulations

If your simulation did not complete as expected, you 
will need to discover the problem, which is usually with 
your project or with the product installation.

If a simulation does not run successfully with your 
model, but does run successfully using the 
tutorial_ref model, you can assume that the problem 
is with your model.

Run the simulation in the <tutorial_lesson>_ref 
model:

1 Select File > Open....

2 Navigate to the correct folder in the tutorial_ref 
directory, and then click on the 
<tutorial_lesson>_ref model. One example of a 
completed tutorial can be found at 
tutorial_ref/basic/Sm_Int_ref.

3 Select a scenario and then run the simulation.

If the simulation runs successfully, the problem is in 
your model.
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Start with the first page of the tutorial and carefully 
compare the instructions with your model 
configuration.

You can also compare your model with the 
<tutorial_lesson>_ref model.
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Additional Help

If a simulation or analysis does not complete, the 
problem might be with the installation.

1 Read the installation instructions on the CD case.

2 Check the Website for recent updates to the 
tutorials, models, and product installation 
instructions (www.opnet.com/support).

3 Check the FAQ section of the OPNET Website 
(www.opnet.com/support).
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