EIGRP Support for MTR

EIGRP Support for MTR

Last Updated: July 23, 2010

The EIGRP Support for MTR feature provides Enhanced Interior Gateway Routing Protocol (EIGRP) support for multiple logical topologies over a single physical network. This module describes how to configure EIGRP for Multitopology Routing (MTR).

Finding Feature Information

Your software release may not support all the features documented in this module. For the latest feature information and caveats, see the release notes for your platform and software release. To find information about the features documented in this module, and to see a list of the releases in which each feature is supported, see the Feature Information Table at the end of this document.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Prerequisites for EIGRP Support for MTR

  • Be familiar with the concepts in the "Routing Protocol Support for MTR" section.
  • Configure and activate a global topology configuration.

Restrictions for EIGRP Support for MTR

Graceful restart in the Enhanced Interior Gateway Routing Protocol (EIGRP) works only for base topologies. All other service topologies reset with new adjacencies.

Information About EIGRP Support for MTR

Routing Protocol Support for MTR

You must enable IP routing on the router for MTR to operate. MTR supports static and dynamic routing in Cisco IOS software. You can enable dynamic routing per-topology to support inter-domain and intra-domain routing. Route calculation and forwarding are independent for each topology. MTR support is integrated into Cisco IOS software for the following protocols:

  • Border Gateway Protocol (BGP)
  • Enhanced Interior Gateway Routing Protocol (EIGRP)
  • Integrated Intermediate System-to-Intermediate System (IS-IS)
  • Open Shortest Path First (OSPF)

You apply the per-topology configuration in router address family configuration mode of the global routing process (router configuration mode). The address family and subaddress family are specified when entering address-family configuration mode. You specify the topology name and topology ID by entering the topology command in address-family configuration mode.

You configure each topology with a unique topology ID under the routing protocol. The topology ID is used to identify and group NLRI for each topology in updates for a given protocol. In OSPF, EIGRP, and IS-IS, you enter the topology ID during the first configuration of the topology command for a class-specific topology. In BGP, you configure the topology ID by entering the bgp tid command under the topology configuration.

You can configure class-specific topologies with different metrics than the base topology. Interface metrics configured on the base topology can be inherited by the class-specific topology. Inheritance occurs if no explicit inheritance metric is configured in the class-specific topology.

You configure BGP support only in router configuration mode. You configure Interior Gateway Protocol (IGP) support in router configuration mode and in interface configuration mode.

By default, interfaces are not included in non-base topologies. For routing protocol support for EIGRP, IS-IS, and OSPF, you must explicitly configure a non-base topology on an interface. You can override the default behavior by using the all-interfaces command in address family topology configuration mode. The all-interfaces command causes the non-base topology to be configured on all interfaces of the router that are part of the default address space or the VRF in which the topology is configured.

Interface Configuration Support for MTR

The configuration of a Multitopology Routing (MTR) topology in interface configuration mode allows you to enable or disable MTR on a per-interface basis. By default, a class-specific topology does not include any interfaces.

You can include or exclude individual interfaces by configuring the topology interface configuration command. You specify the address family and the topology (base or class-specific) when entering this command. The subaddress family can be specified. If no subaddress family is specified, the unicast subaddress family is used by default.

You can include globally all interfaces on a device in a topology by entering the all-interfaces command in routing topology configuration mode. Per-interface topology configuration applied with the topology command overrides global interface configuration.

The interface configuration support for MTR has these characteristics:

  • Per-interface routing configuration: Interior Gateway Protocol (IGP) routing and metric configurations can be applied in interface topology configuration mode. Per-interface metrics and routing behaviors can be configured for each IGP.
  • Open Shortest Path First (OSPF) interface topology configuration: Interface mode OSPF configurations for a class-specific topology are applied in interface topology configuration mode. In this mode, you can configure an interface cost or disable OSPF routing without removing the interface from the global topology configuration.
  • Enhanced Interior Gateway Routing Protocol (EIGRP) interface topology configuration: Interface mode EIGRP configurations for a class-specific topology are applied in interface topology configuration mode. In this mode, you can configure various EIGRP features.
  • Intermediate System-to-Intermediate System (IS-IS) interface topology configuration: Interface mode IS-IS configurations for a class-specific topology are applied in interface topology configuration mode. In this mode, you can configure an interface cost or disable IS-IS routing without removing the interface from the global topology configuration.

How to Configure EIGRP Support for MTR

Activating an MTR Topology by Using EIGRP

Before You Begin

Note


Only MTR commands are shown in this task.
  • Be familiar with the concepts in the Routing Protocol Support for MTR section.
  • Configure and activate a global topology configuration.

Note


  • Graceful restart in EIGRP works only for base topologies. All other service topologies reset with new adjacencies.


SUMMARY STEPS

1.    enable

2.    configure terminal

3.    router eigrp name

4.    address-family ipv4 [unicast | multicast | vrf vrf-name ] autonomous-system as-number

5.    topology {base | topology-name tid number}

6.    end

7.    show ip protocols topology name [summary]

8.    show ip eigrp topology name


DETAILED STEPS
 Command or ActionPurpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
router eigrp name


Example:

Router(config)# router eigrp MTR

 

Configures an EIGRP process for MTR, and enters router configuration mode.

  • You can use the command without configuring MTR, but it defaults to the base topology.
 
Step 4
address-family ipv4 [unicast | multicast | vrf vrf-name ] autonomous-system as-number


Example:

Router(config-router)# address-family ipv4 autonomous-system 1

 

Enters router address family configuration mode to configure EIGRP for MTR.

 
Step 5
topology {base | topology-name tid number}


Example:

Router(config-router-af)# topology VIDEO tid 100

 

Configures an EIGRP process to route IP traffic under the specified topology instance and enters router address family topology configuration mode.

  • Each topology must be configured with a unique topology ID. The topology ID must be entered each time this command is entered.
 
Step 6
end


Example:

Router(config-router-af-topology)# end

 

Exits router address family configuration mode and returns to privileged EXEC mode.

 
Step 7
show ip protocols topology name [summary]


Example:

Router# show ip protocols topology VIDEO

 

Displays the status of routing protocols configured in a topology.

Tip   

This command can be entered to display the status, under a topology, of any configured routing protocol.

 
Step 8
show ip eigrp topology name


Example:

Router# show ip eigrp topology VIDEO

 

Displays the routing table of an EIGRP process configured under a topology.

 

What to Do Next

If an IS-IS topology configuration is required, proceed to the next task. If a BGP topology configuration is required, proceed to the Activating an MTR Topology by Using BGP section.

Activating an MTR Topology in Interface Configuration Mode by Using EIGRP

SUMMARY STEPS

1.    enable

2.    configure terminal

3.    interface type number

4.    topology ipv4 [multicast | unicast] {topology-name [disable] | base}

5.    eigrp as-number delay value

6.    eigrp as-number next-hop-self

7.    eigrp as-number shutdown

8.    eigrp as-number split-horizon

9.    eigrp as-number summary-address ip-address wildcard-mask [distance]

10.    end

11.    show ip eigrp topology name interfaces


DETAILED STEPS
 Command or ActionPurpose
Step 1
enable


Example:

Router> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
configure terminal


Example:

Router# configure terminal

 

Enters global configuration mode.

 
Step 3
interface type number


Example:

Router(config)# interface Ethernet 0/0

 

Specifies the interface type and number, and enters interface configuration mode.

 
Step 4
topology ipv4 [multicast | unicast] {topology-name [disable] | base}


Example:

Router(config-if)# topology ipv4 VOICE

 

Configures an MTR topology instance on an interface and enters interface topology configuration mode.

Note    Entering this command with the disable keyword disables the topology instance on the interface. This form is used to exclude a topology configuration from an interface.
 
Step 5
eigrp as-number delay value


Example:

Router(config-if-topology)# eigrp 1 delay 100000

 

Configures the delay value that EIGRP uses for interface metric calculation.

  • The value argument is entered in microseconds. The example configures an interface delay metric of 100 milliseconds.
 
Step 6
eigrp as-number next-hop-self


Example:

Router(config-if-topology)# eigrp 1 next-hop-self

 

Configures an EIGRP process to advertise itself as the next hop.

  • This command is enabled by default.
 
Step 7
eigrp as-number shutdown


Example:

Router(config-if-topology)# eigrp 1 shutdown

 

Disables an EIGRP process on the interface without disabling the global topology configuration on the interface.

 
Step 8
eigrp as-number split-horizon


Example:

Router(config-if-topology)# eigrp 1 split-horizon

 

Configures an EIGRP process to use split horizon.

  • This command is enabled by default.
 
Step 9
eigrp as-number summary-address ip-address wildcard-mask [distance]


Example:

Router(config-if-topology)# eigrp 1 summary-address 10.1.1.0 0.0.0.255

 

Configures an EIGRP summary address.

  • An administrative distance of 5 is applied to EIGRP summary routes if the distance is not specified.
 
Step 10
end


Example:

Router(config-if-topology)# end

 

Exits interface topology configuration mode and returns to privileged EXEC mode.

 
Step 11
show ip eigrp topology name interfaces


Example:

Router# show ip eigrp topology VOICE interfaces

 

Displays information about interfaces, on which EIGRP is configured, in a topology.

 

Monitoring Interface and Topology IP Traffic Statistics for MTR

Use any of the following commands in any order to monitor interface and topology IP traffic statistics for Multitopology Routing (MTR).

SUMMARY STEPS

1.    enable

2.    show ip interface [type number] [topology {name | all | base}] [stats]

3.    show ip traffic [topology {name | all | base}]

4.    clear ip interface type number [topology {name | all | base}] [stats]

5.    clear ip traffic [topology {name | all | base}]


DETAILED STEPS
 Command or ActionPurpose
Step 1
enable


Example:

Device> enable

 

Enables privileged EXEC mode.

  • Enter your password if prompted.
 
Step 2
show ip interface [type number] [topology {name | all | base}] [stats]


Example:

Device# show ip interface FastEthernet 1/10 stats

 

(Optional) Displays IP traffic statistics for all interfaces or statistics related to the specified interface.

  • If you specify an interface type and number, information for that specific interface is displayed. If you specify no optional arguments, information for all the interfaces is displayed.
  • If the topology name keyword and argument are used, statistics are limited to the IP traffic for that specific topology.
  • The base keyword displays the IPv4 unicast base topology.
 
Step 3
show ip traffic [topology {name | all | base}]


Example:

Device# show ip traffic topology VOICE

 

(Optional) Displays global IP traffic statistics (an aggregation of all the topologies when MTR is enabled) or statistics related to a particular topology.

  • The base keyword is reserved for the IPv4 unicast base topology.
 
Step 4
clear ip interface type number [topology {name | all | base}] [stats]


Example:

Device# clear ip interface FastEthernet 1/10 topology all

 

(Optional) Resets interface-level IP traffic statistics.

  • If the topology keyword and a related keyword are not used, only the interface-level aggregate statistics are reset.
  • If all topologies need to be reset, use the all keyword as the topology name.
 
Step 5
clear ip traffic [topology {name | all | base}]


Example:

Device# clear ip traffic topology all

 

(Optional) Resets IP traffic statistics.

  • If no topology name is specified, global statistics are cleared.
 

Configuration Examples for EIGRP Support for MTR

Examples Activating an MTR Topology by Using EIGRP

The following example shows how to activate the VIDEO topology using EIGRP:

router eigrp MTR 
 address-family ipv4 autonomous-system 1
  network 10.0.0.0 0.0.0.255 
  topology VIDEO tid 10
   redistribute connected 
   end 

The following example shows how to display the status of routing protocols configured in the VIDEO topology. EIGRP information is shown in the output.

Router# show ip protocols topology VIDEO 
*** IP Routing is NSF aware ***
Routing Protocol is "eigrp 1"
  Outgoing update filter list for all interfaces is not set
  Incoming update filter list for all interfaces is not set
  Default networks flagged in outgoing updates
  Default networks accepted from incoming updates
  EIGRP metric weight K1=1, K2=0, K3=1, K4=0, K5=0
  EIGRP maximum hopcount 100
  EIGRP maximum metric variance 1
  Redistributing: eigrp 1
  EIGRP graceful-restart disabled
  EIGRP NSF-aware route hold timer is 240s
  Topologies : 100(VOICE) 0(base) 
  Automatic network summarization is in effect
  Maximum path: 4
  Routing for Networks:
  Routing Information Sources:
    Gateway         Distance      Last Update
  Distance: internal 90 external 170

The following example shows the EIGRP routing table configured under the VIDEO topology:

Router# show ip eigrp topology VIDEO
 
EIGRP-IPv4 Topology Table for AS(1)/ID(10.1.1.2) Routing Table: VOICE
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status 
P 10.1.1.0/24, 1 successors, FD is 281600
        via Connected, Ethernet0/0

Examples MTR EIGRP Topology in Interface Configuration Mode

The following example shows how to set the EIGRP delay calculation on interface Ethernet 0/0 to 100 milliseconds:

interface Ethernet 0/0
 topology ipv4 VOICE
  eigrp 1 delay 100000 
  eigrp 1 next-hop-self
  eigrp 1 shutdown
  eigrp 1 split-horizon
  eigrp 1 summary-address 10.1.1.0 0.0.0.255
  end

The following example shows how to display EIGRP information about interfaces in the VOICE topology:

Router# show ip eigrp topology VOICE interfaces
 
EIGRP-IPv4 interfaces for process 1
                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Et0/0              1        0/0        20       0/2            0           0

The following example shows how to display EIGRP information about links in the VOICE topology:

Router# show ip eigrp topology VOICE detail-links 
EIGRP-IPv4 Topology Table for AS(1)/ID(10.1.1.1) Routing Table: VOICE
Codes: P - Passive, A - Active, U - Update, Q - Query, R - Reply,
       r - reply Status, s - sia Status 
P 10.1.1.0/24, 1 successors, FD is 25856000, serno 5
        via Connected, Ethernet0/0

Additional References

Related Documents

Related Topic Document Title

Cisco IOS commands

Cisco IOS Master Command List, All Releases

Multitopology Routing (MTR) commands

Cisco IOS Multitopology Routing Command Reference

Enhanced Interior Gateway Routing Protocol (EIGRP) commands

Cisco IOS IP Routing: EIGRP Command Reference

EIGRP concepts and tasks

IP Routing: EIGRP Configuration Guide

Technical Assistance

Description Link

The Cisco Support and Documentation website provides online resources to download documentation, software, and tools. Use these resources to install and configure the software and to troubleshoot and resolve technical issues with Cisco products and technologies. Access to most tools on the Cisco Support and Documentation website requires a Cisco.com user ID and password.

http://www.cisco.com/cisco/web/support/index.html

Feature Information for EIGRP Support for MTR

The following table provides release information about the feature or features described in this module. This table lists only the software release that introduced support for a given feature in a given software release train. Unless noted otherwise, subsequent releases of that software release train also support that feature.

Use Cisco Feature Navigator to find information about platform support and Cisco software image support. To access Cisco Feature Navigator, go to www.cisco.com/go/cfn. An account on Cisco.com is not required.

Table 1Feature Information for EIGRP Support for MTR
Feature Name Releases Feature Information

EIGRP Support for MTR

12.2(33)SRB

15.0(1)S

This feature provides Enhanced Interior Gateway Routing Protocol (EIGRP) support for multiple logical topologies over a single physical network.

The following commands were introduced or modified: address-family ipv4, clear ip eigrp neighbor, eigrp delay, eigrp next-hop-self, eigrp shutdown, eigrp split-horizon, eigrp summary-address, router eigrp, show ip eigrp topology, topology.

Cisco and the Cisco Logo are trademarks of Cisco Systems, Inc. and/or its affiliates in the U.S. and other countries. A listing of Cisco's trademarks can be found at www.cisco.com/go/trademarks. Third party trademarks mentioned are the property of their respective owners. The use of the word partner does not imply a partnership relationship between Cisco and any other company. (1005R)

Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any examples, command display output, network topology diagrams, and other figures included in the document are shown for illustrative purposes only. Any use of actual IP addresses or phone numbers in illustrative content is unintentional and coincidental.

© 2007-2012 Cisco Systems, Inc. All rights reserved.