
  

Cisco ACNS Software 
OL-4406-01
C H A P T E R 8

Managing Online Presentations

This chapter describes how to set up and create online presentations using the 
features provided by Cisco IP/TV. This chapter includes the following topics:

• Features for Delivering Presentations, page 8-1

• About Web Presenter, page 8-4

• Using ScreenCaster, page 8-22

• Using SlideCast, page 8-30

• Active Streaming Format Marker File Feature, page 8-35

Features for Delivering Presentations
Cisco IP/TV provides the following ways to deliver online presentations:

• Web Presenter

• ScreenCaster

• SlideCast

Each of these features lets you send slide presentations to viewers using your 
TCP/IP internetwork. However, each feature has its own distinct advantages and 
limitations. This section introduces these features and describes the advantages 
and limitations of each.
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Note Web Presenter and ScreenCaster features are not supported when IP/TV is 
integrated into an ACNS network. You may not be able to create a Web Presenter 
program as part of an ACNS channel.

Web Presenter
Web Presenter lets you create and direct web-based presentations. The types of 
web presentations you can create include the following:

• Live web presentation with a live-capture video and audio program. 

• Live web presentation with a playback-from-file program.

• Playback from an MP4 (.mp4) file with an embedded URL track recorded by 
IP/TV Server. The web presentation consists of HTML pages browsed in the 
Web Presentation application or of content captured from the screen using the 
ScreenCaster feature of Web Presenter. The video format must be ISO 
MPEG-4 and the audio format can be MP3 or AAC. The audio and video 
server must be on the same host as the Web Presenter server.

• Playback from an Advanced Streaming Format (.asf) file with an embedded 
URL track. The web presentation consists of HTML pages that are flipped in 
a designated sequence and at a designated time as determined by the URLs 
embedded in the .asf file of the program. 

Advantages of using Web Presenter include the following:

• You can achieve better quality and increased clarity for text and images.

• Only one server is required to serve the entire presentation.

• You can publish HTML pages from local files.

• You can quickly convert files you have created using common business tools 
such as Microsoft PowerPoint and Microsoft Word into web pages.

• You can incorporate other published websites into your presentation.

• Web Presenter streams can be shared with other audio or video programs.
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Limitations of Web Presenter include the following:

• Web Presenter streams can only be recorded when the video stream is ISO 
MPEG-4 and the audio stream is either AAC or MP3. 

• Clients must have Internet Explorer installed to view the presentation.

• Presentations must be authored in standard web formats.

ScreenCaster

With ScreenCaster you can:

• Add dynamically captured screen shots to a Web Presenter broadcast or 
recording from various applications running in real time.

• Include screen shots of any size, up to the full desktop.

• Broadcast a web-based version of a PowerPoint presentation without 
preprocessing.

• Broadcast a PowerPoint presentation in “native” format, including animation 
and transition effects.

Advantages of ScreenCaster include the following:

• No web authoring is required; any screen image from any application up to 
the full desktop area can be captured and transmitted.

• Cross-platform viewers are supported.

• Support for native PowerPoint presentations allows viewers to use a local 
PowerPoint viewer or application to see animation and transition effects.

A limitation of ScreenCaster is that clients must have Internet Explorer installed 
to view the presentation.
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SlideCast
The SlideCast feature allows you to capture screen information for transmission 
over a network.

SlideCast enables IP/TV Server to serve the following:

• Live or prerecorded video and audio together with a separate SlideCast 
presentation (requires two servers)

• SlideCast together with the audio of the presenter 

• Audio of the presenter with alternating SlideCast and live video

Advantages of SlideCast include the following:

• The entire presentation can be recorded to a media file and replayed later.

• No web authoring is required; whatever can be displayed on the desktop 
screen can be transmitted using SlideCast.

• Cross-platform viewers are supported. (An H.261-based SlideCast 
presentation is viewable on Macintosh and UNIX platforms.)

• SlideCast streams can be shared with other audio or video programs.

Limitations of SlideCast include the following:

• Two servers are generally required if SlideCast is used with another video 
source.

• Text clarity may not be of high quality.

• SlideCast is CPU-intensive.

About Web Presenter
Web Presenter lets you create and direct web-based presentations. The types of 
web presentations you can create include the following:

• Live web presentation with a live-capture video and audio program. 

• Live web presentation with a playback-from-file program.
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• Playback from an MP4 (.mp4) file with an embedded URL track recorded by 
IP/TV Server. The web presentation consists of HTML pages browsed in the 
web presentation application or of content captured from the screen using the 
ScreenCaster feature of Web Presenter. The video format must be ISO 
MPEG-4 and the audio format must be AAC or MP3. The audio and video 
server must be on the same host as the Web Presenter server.

• Playback from an Advanced Streaming Format (.asf) file with an embedded 
URL track. The web presentation consists of HTML pages that are flipped in 
a designated sequence and at a designated time as determined by the URLs 
embedded in the .asf file of the program. Refer to Appendix A of the Cisco 
IP/TV Broadcast Server User Guide for more information about .asf files.

Creating and Directing a Live Web Presentation
This section lists and describes the steps for creating a live presentation. Although 
the web presentation is always live, the audio and video program can be live 
capture or playback-from-file. The basic steps you need to perform are as follows:

Step 1 Prepare HTML presentation pages.

Step 2 Create a scheduled program using IP/TV Program Manager.

Note IP/TV does not support SmallCasting of Web Presenter programs.

Step 3 Direct the presentation. Use the Presenter Server application (PresenterServerApp 
window) to enter URLs and control the presentation.

Step 4 View the presentation using IP/TV Viewer.

The following sections describe, in detail, how to perform each of these steps.
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Preparing HTML Presentation Pages

Before directing the presentation, you need to set up the HTML pages that the 
director (the person who is flipping URLs) flips during the presentation. Setup 
methods include:

• Real-time browsing from the web—You can flip URLs in a random manner 
or drag and drop shortcuts. You can enter the URLs into the Address field in 
the PresenterServerApp window as desired (see Figure 8-3 later in this 
chapter) or click HTML links to access web pages directly from the web. 

• Prebrowsing and downloading to local cache—Prebrowse the URLs so the 
contents are cached on the same device that you are directing the presentation 
from. Prebrowsing is useful, because at presentation time, the server does not 
have to access the web, and all prebrowsed URLs are accessible from the 
URL drop-down list.

Separate Browser Window

If a URL does not contain a frame name or if the frame name is “main,” the IP/TV 
Viewer application or plug-in treats it as if the frame name were “iptv_presenter.” 
This is because web pages generated by IP/TV Program Manager in the Review 
window for scheduled or on-demand programs use the frame name 
“iptv_presenter.”

If a different frame name is used, then you should author your own web pages 
using that name.  In this case, when the content is viewed using the Review 
feature, the presentation is displayed in a separate browser window.

Creating a Scheduled Program Using IP/TV Program Manager

To create a live-capture scheduled program to be used in conjunction with a live 
presentation, follow these steps:

Step 1 Go to the New Scheduled Program window in IP/TV Program Manager.

Step 2 Choose the Basic Live Capture Program option and click Create Program. The 
New Scheduled Program window for live-capture appears.

Step 3 Scroll to the Multimedia Source Information section. (See Figure 8-1.)
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Figure 8-1 Live-Capture with Live Presentation

Step 4 Choose the appropriate Multimedia Source Information options. Table 8-1 
describes Web Presenter options only. For all other options, see the “Creating a 
Scheduled Program” section on page 6-3.
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Table 8-1 Live-Capture with Live Presentation

Option Description

Play Web Presentation Indicates whether the program includes a web presentation in addition 
to video and audio.1

1. A scheduled program cannot contain both a web presentation and SlideCast.

Multicast HTML to Browser 
Cache

If checked (default), the HTML pages and embedded graphics files of 
the web presentation are uploaded to the browser of the client and 
cached. We recommend that you choose caching when the web 
presentation uses static or a mixture of static and dynamic content. If 
only dynamic content is used, then uncheck this option.

Share Presentation with Indicates whether the program you are defining includes the 
presentation stream from another program you choose in the adjoining 
pull-down list.2

2. The start and end time of the program you are defining must be within the range of the program that contains the presentation 
stream.

Start window URL (Optional) Specifies the HTML page that the user goes to at the start of the 
presentation. It can be either a URL Internet address or the full 
path name of an HTML file on the local hard drive of the server, for 
example, http://www.cisco.com or C:\BoardMtg\slide001.htm.3

3. The URLs can be either absolute or relative. Relative URLs are recommended because the actual location of the files is not 
in the .asf file, which allows the files to be relocated easily. (See Table 8-2.) If a URL does not contain a frame name or if 
the frame name is main, IP/TV Viewer or the plug-in treats it as if the frame name were iptv_presenter, which is the frame 
name used by the web pages generated by IP/TV Program Manager from the Review window for scheduled or on-demand 
programs. If a different frame name is used, be sure to author your own web pages using the same name. In this case, when 
the content is viewed using the Review feature, the presentation is displayed in a separate browser window.

SlideCast/Web Presentation 
Server

Specifies the name or IP address of the IP/TV Server that will play the 
SlideCast or web presentation portion of the program. In the case of a 
web presentation, the server can be the same server as the audio/video 
server. Choose a server from the list or enter the name of a new server.
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Step 5 Make sure that all other sections in this window are completed.

Step 6 Click Create Program at the bottom of the window to send the form to IP/TV 
Program Manager and create a live-capture scheduled program.

To create a scheduled program from a media file to be used in conjunction with a 
live presentation, follow these steps:

Step 1 Go to the New Scheduled Program window in IP/TV Program Manager.

Step 2 Choose the Advanced Program (Show All Options) option and click Create 
Program. The New Scheduled Program window for an advanced program 
appears.

Step 3 Scroll to the Multimedia Source Information section. (See Figure 8-2.)

Table 8-2 Web Presenter URLs Embedded in .asf Files

Option Description

Absolute 
(full path) URLs

Absolute URLs start with “file:” or “http:” and URL syntax. File URLs must have 
a file share server following the second slash:

file://server-name/fileshare/path-on-share/xyz.htm

If the URL does not have a server name, then the file must reside on the client 
IP/TV Viewer system, but the lack of a server name is unlikely. The following 
Microsoft syntax is also supported:

\\server-name\fileshare\path-on-share\xyz.htm

Relative URLs The web-based URL must be set in the program definition in IP/TV 
Program Manager. The syntax for the URL in the .asf file is just the 
filename, such as xyz.htm. The syntax allowed for the base URL includes 
both http: and the file, as described above, as in the following examples:

http://webserver-name/path-to-files

or

file://fileserver-name/path-to-files

or

\\fileserver-name\path-to-files
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Figure 8-2 Media File with Live Presentation—Advanced Options
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Step 4 Choose the appropriate Multimedia Source Information options. Table 8-3 
describes Web Presenter options only. For all other options, see the “Creating a 
Scheduled Program” section in Chapter 6.

Step 5 Make sure that you complete all other sections in this window.

Step 6 Click Create Program to send the form to IP/TV Program Manager and create a 
scheduled program from a media file.

Table 8-3 Media File with Live Presentation

Option Description

Play This File Choose the name of the file you want to use to 
create a scheduled program. 

Play SlideCast Indicates whether the program includes a 
SlideCast presentation. The Enable QoS? check 
box allows you to choose to enable QoS, if 
supported on your network.

Play Web Presentation Indicates whether the program includes a web 
presentation in addition to video and audio.1

1. A scheduled program cannot contain both a web presentation and SlideCast.

Multicast HTML to 
Browser Cache

If checked (default), the HTML pages and 
embedded graphics files of the web presentation 
are uploaded to the browser of the client and 
cached. We recommend that you select caching 
when the web presentation uses static or a mixture 
of static and dynamic content. If only dynamic 
content is used, then uncheck caching.

Share SlideCast with Indicates whether the program you are defining 
includes the SlideCast program you choose in the 
adjoining pull-down list.

Share Presentation with Indicates whether the program you are defining 
includes the presentation stream from the program 
you choose in the adjoining pull-down list.2

2. The start and end time of the program you are defining must be within the range of the program 
that contains the presentation stream.
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Directing the Presentation

Launch IP/TV Server on the same device that you plan to direct the live web 
presentation from. The Presenter Server (PresenterServerApp window) 
automatically launches at the time the designated web presentation program is 
scheduled to play. (See Figure 8-3.)

Figure 8-3 PresenterServerApp Window

From this window, you browse URLs, control which HTML pages are transmitted 
to IP/TV Viewers while you are browsing, and view the Web Presenter PGM 
(Pragmatic Group Multicasting) source statistics. (See Figure 8-4.)
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Figure 8-4 PGM Source Stats Window

To browse URLs in real time, enter a URL in the PresenterServerApp window. 
Each time you enter a URL, it is added to the URL field drop-down list and added 
to your local cache. You can also click links within a web page to flip to another 
URL, or drag in shortcuts from Internet Explorer favorites, history, Explorer 
folders, or your desktop. You can also drag in links from an Internet Explorer 
window. You can also open HTML files stored on the local hard drive of the 
server.

Table 8-4 lists and describes the toolbar button and menu commands in the 
PresenterServerApp window.

Table 8-4 PresenterServerApp Window Icons and Menu Items

Toolbar Button or Menu 
Command Description

Back/Forward buttons Allows you to return to the previous web page or 
forward to the next web page. 

Home button Displays the HTML web page that is defined as your 
home page on the local browser.

Refresh button Reloads the current page from the web.
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Viewing the Presentation Using IP/TV Viewer

From IP/TV Viewer, choose the desired web presentation program from the 
Program Listings window. A viewer window launches and begins to play the 
audio and video program. Simultaneously, the Presenter Client window appears 
and displays the presentation. If the Presenter Server has not yet sent a URL, then 
no Presenter Client window appears on the client side. 

Search button Displays the search page as configured in Internet 
Explorer options.

Full Screen button Toggles between maximized and normal 
PresenterServerApp window sizes.

Stop button Stops the current program.

Open command Choose File > Open to open a local .htm, .html, .gif, 
or .jpg file that you may want to use in your 
presentation.

Print command Choose File > Print to print the current page.

Stop button Stops loading the current HTML page from the web 
and prevents it from being sent to viewers.

Browse Online menu 
command

Choose File > Browse Online. Controls whether 
you are browsing from the network or local cache. 
The default is ON.

Transmit while Browsing 
menu command

Choose File > Transmit while Browsing. Controls 
whether you can transmit pages to IP/TV Viewers 
while you are browsing. The default is ON.

Presenter Stats menu 
command

Choose View > PGM Source Stats to display the 
PGM Source Stats window. (See Figure 8-4.) PGM 
is a reliable multicast streaming protocol. This 
information is provided for network administrators 
who may need it for diagnostic purposes.

Table 8-4 PresenterServerApp Window Icons and Menu Items (continued)

Toolbar Button or Menu 
Command Description
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Creating a Playback-from-File Presentation
The Web Presenter feature lets you create a playback-from-file presentation. A 
playback-from-file web presentation consists of an audio and video program that 
has an embedded URL track in an .asf or .mpg4 file.

MP4 File

A live program containing audio, video, and a web presentation can be recorded 
to a local MP4 media file.

Note The web presentation portion of the live program can consist of the HTML 
content browsed in the Web Presenter application or content captured from the 
screen using the ScreenCaster feature of Web Presenter. 

Note The live encoded streams must be ISO MPEG-4 for video and AAC or MP3 for 
audio. In addition, both the video and audio server and the Web Presenter server 
must be the same.

For information on how to record a live program containing audio, video, and a 
web presentation to a local MP4 media file, see the “Recording Scheduled 
Programs,” section in Chapter 6.
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To create and view a playback-from-file web presentation using an .mp4 file, 
follow these steps:

Step 1 Create or choose the prerecorded .mp4 file containing an embedded URL track 
that you want to use in your web presentation. The .mp4 file must be a recording 
of a live program that contains ISO MPEG-4 video, AAC or MP3 audio, and a web 
presentation.

Step 2 Using the IP/TV Program Manager, create a scheduled or on-demand program to 
play back the .mp4 file.

Step 3 View the web presentation using IP/TV Viewer. See the “Viewing the 
Playback-from-File Presentation Using IP/TV Viewer” section later in 
this chapter.

ASF File

To create and view a playback-from-file web presentation using an .asf file, follow 
these steps:

Step 1 Create or choose the prerecorded file that you want to use in your web 
presentation. The file must be in .asf format. Or, start with an .avi or.wav file.

Step 2 Convert the non-ASF media file to .asf format using the Windows Media Encoder 
tool.

Step 3 Insert URLs into the .asf file using the Windows Media ASF Indexer tool. Refer 
to the Windows Media Technologies (WMT) documentation for more 
information. 

Note When you specify a URL ScriptCommand in an .asf file, make sure that 
you enter the complete (absolute) URL, for example:
http://www.nbc.com 
You must use http:// to distinguish between an absolute and a relative 
path. Also note that when you specify a frame name in ScriptCommand, 
the frame name is case sensitive.
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Step 4 Using IP/TV Program Manager, create a scheduled or on-demand program to play 
back the .asf file. See the next section, “Creating a Scheduled or On-Demand 
Program from an .asf or .mp4 File.”

Step 5 View the web presentation using IP/TV Viewer. See the “Viewing the 
Playback-from-File Presentation Using IP/TV Viewer” section later in 
this chapter.

Creating a Scheduled or On-Demand Program from an .asf or .mp4 File

To create a scheduled program from an .asf or .mp4 file and set the web 
presentation options, follow these steps:

Step 1 Go to the New Scheduled Program window in IP/TV Program Manager.

Step 2 Choose the Basic Media File Program option and click Create Program. The 
New Scheduled Program window for a media file appears.

Step 3 Scroll to the Multimedia Source Information section. (See Figure 8-5.)
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Figure 8-5 Playback-from-File Program with Embedded URLs—Scheduled 

Program

Step 4 Click Select media file and choose either .asf or .mp4 file from the listing in the 
IP/TV Browse Media Files window. Most multimedia source information options 
are automatically checked. If the file contains URLs, the Play Web Presentation 
option is checked. Or, you can enter the full media file path and manually choose 
the multimedia source information options. Table 8-5 describes Web Presenter 
options only.
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Step 5 Make sure that you complete all other sections in this window.

Step 6 Click Create Program at the bottom of the window to send the form to IP/TV 
Program Manager and create a scheduled program from an .asf or .mp4 file.

Table 8-5 Playback-from-File Program with Embedded URLs—

Scheduled Program

Option Description

Select media file Choose the name of the file that you want to use 
to create a scheduled program. Make sure to 
enter the full path name of an .asf file.

Play Web Presentation Indicates whether the program includes a web 
presentation in addition to video and audio.1

1. A scheduled program cannot contain both a web presentation and SlideCast.

Multicast HTML to Browser 
Cache

If checked (default for scheduled programs), 
uploads and caches the pages and embedded 
graphics files of the web presentation in the 
browser of the client.2

2. We recommend that you check this check box when the web presentation uses static or a mixture 
of static and dynamic programs. If only dynamic content is used, then uncheck the check box.

Web Base URL (optional) Base portion of the URL that identifies the web 
server or local file path. This is required for .asf 
files if the .asf file was built using relative 
URLs. This option is not required for .mp4 
files.
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To create an on-demand program from an .asf or .mp4 file, follow these steps:

Step 1 Open IP/TV Program Manager and go to the New OnDemand Program page.

Step 2 Scroll to the Multimedia Information section. (See Figure 8-6.)

Figure 8-6 Playback-from-File with Embedded URLs—On-Demand Program

Step 3 Click Select media file and choose an .asf or .mp4 file from the list in the IP/TV 
Browse Media Files window. Most multimedia information options are 
automatically checked. If the file contains URLs, the Play Web Presentation 
option is checked. Table 8-6 describes Web Presenter options only.
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Step 4 Make sure that you complete all other sections in this window.

Step 5 Click Add OnDemand Program to send the form to IP/TV Program Manager 
and create an on-demand program.

Viewing the Playback-from-File Presentation Using IP/TV Viewer

From IP/TV Viewer, choose the web presentation program from the Program 
Listings window. A media window launches and begins to play the audio/video 
program. Simultaneously, a Presenter Client window appears and displays the 
web presentation portion. The web presentation consists of HTML pages that are 
flipped in a designated sequence and at a designated time as determined by the 
URLs embedded in the .asf file of the program.

Table 8-6 Playback-from-File Program with Embedded URLs—On-Demand 

Program

Option Description

Play Web Presentation Indicates whether the program includes a web 
presentation in addition to audio and video.

Transfer HTML to Browser 
Cache

If checked (the default), uploads and caches the 
pages and embedded graphics files of the web 
presentation in the browser of the client. 

Web Presentation 
Bandwidth

Sets the audio/video bandwidth in kbps. The 
default is 256.

Web Presentation Base URL 
(optional)

Base portion of the URL that identifies the web 
server or local file path. This is required for .asf 
files if the .asf file was built using relative URLs. 
It is not required for .mp4 files.
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Using ScreenCaster
ScreenCaster provides a more flexible and more powerful alternative to SlideCast. 
It allows you to perform screen captures while you use the Presentation Server for 
a live or archived slide presentation.This section describes the features and 
benefits that ScreenCaster provides and how to configure and use it.

ScreenCaster Features
With ScreenCaster you can:

• Add dynamically captured screen shots to a Web Presenter broadcast from 
various applications running in real time.

• Include screen shots of any size, up to the full desktop.

• Broadcast a web-based version of a PowerPoint presentation without 
preprocessing.

• Broadcast a PowerPoint presentation in native format, including animation 
and transition effects.

You can use ScreenCaster when it is inconvenient to have to perform 
preprocessing steps, or to have to limit the slide size or scale slides down to a 
possibly unreadable size. ScreenCaster solves these problems by integrating a 
screen capture feature with Web Presenter. Using ScreenCaster you are not 
limited to Standard Image Format (SIF) format. Instead, you can capture a 
window of any size, up to the entire desktop. 

ScreenCaster uses the JPEG format, which is supported by Web Presenter. The 
window capture feature can be used at any time in conjunction with the normal 
operation of Web Presenter. This allows you to add screen captures from various 
applications in real time.

ScreenCaster has a special mode of operation when the source window is a 
PowerPoint presentation. In this mode each PowerPoint slide is captured as the 
presenter changes slides. The PowerPoint slide show can be presented in either 
full-screen mode or a smaller window.

You can also use ScreenCaster to broadcast PowerPoint slides in native 
PowerPoint format. In this case, the PowerPoint file itself is pushed to the viewing 
audience (or can be downloaded in advance), and the presentation is controlled by 
the presenter from the IP/TV Server where ScreenCaster is launched.
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The audience uses the PowerPoint viewer or the PowerPoint application to view 
the slides, with the full benefits and features of PowerPoint, including transition 
effects and animations.

Note In order for ScreenCaster native PowerPoint to work, PowerPoint Version 8.0 
(part of Office 98 and Office 2000) must be installed. The required file is 
pptview32.exe, which is included on the Cisco IP/TV Installation CD. 

Capturing Screens in Real Time
To start capturing screens with ScreenCaster, choose File > ScreenCaster from 
the Presenter Server main menu.

Figure 8-7 ScreenCaster Dialog Box

To begin capturing the display, perform one of the following actions:

• Use the mouse to capture a region in your window.

• Point to the title bar or client area to select the whole window or a client 
window, respectively.

• Click Capture Screen to select the entire desktop, including the taskbar.

When you perform one of these actions, the ScreenCaster dialog box disappears 
so that it does not obstruct the capture.
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You can resize or minimize the PresenterServerApp main window to make room 
for the window that you want to capture.

Once transmission has begun, you can retransmit the current selected region or 
window by clicking the mouse anywhere on the screen. ScreenCaster 
automatically compares the previously captured bitmap to the current contents of 
the window or region. If the display has changed, ScreenCaster automatically 
recaptures and retransmits the selected window or region. To configure the 
amount of change in the window or region that triggers a recapture, see the 
“Configuring ScreenCaster” section on page 8-26.

To redisplay the ScreenCaster dialog box, hold the mouse over the upper right 
corner of the screen. You can also redisplay the main Presenter Server window 
and the dialog box by clicking the application icon in the Windows taskbar.

You can also use a function key (the default is F9) to restart the capture process. 
ScreenCaster captures the window that currently contains the mouse cursor. To 
change the function key used for screen capture, see the “Configuring 
ScreenCaster” section on page 8-26.

Once the window selection is done, the window is captured as a bitmap and 
encoded as a JPEG file, and sent to the destination where viewers use IP/TV 
Viewer or the IP/TV browser plug-in to view the presentation. 

The URLs are recorded to the marker text file. You can postprocess the marker 
text file, produce an .asf file, and upload the results to a web server as an 
on-demand offering. 

Broadcasting a PowerPoint Presentation
You can use ScreenCaster to broadcast a PowerPoint presentation in any of the 
following ways:

• Broadcast a web-based version of the PowerPoint slides (in JPEG format).

• Broadcast slides in native PowerPoint format, including animations and 
transition effects.

• Capture individual slides using the window capture feature.
8-24
Cisco ACNS Software Program Manager for IP/TV User Guide

OL-4406-01



  

Chapter 8      Managing Online Presentations
Using ScreenCaster
Note In order for ScreenCaster using native PowerPoint mode to work, PowerPoint 
Version 8.0 (part of Office 98 and Office 2000) must be installed. The required 
file is pptview32.exe, and it is included on the Cisco IP/TV installation CD. 

To capture and broadcast a web-based version of a PowerPoint presentation, open 
the PowerPoint file through the URL text entry field, standard web navigation in 
the Presenter Server browsing context, or the File > Open command in the 
Presenter Server.

Use the usual PowerPoint user interface for advancing each slide in the 
presentation. When the slide changes, ScreenCaster automatically broadcasts the 
necessary command to the PowerPoint Viewer or application on the 
receiving systems. 

When you open a PowerPoint slide show through Web Presenter, it is 
automatically placed in window mode. You can resize the window to the size 
desired for viewing by IP/TV clients, or you can change to full-screen mode. 

When the Presenter Server broadcasts the presentation in native PowerPoint 
format, the Presenter Server transfers the .ppt file itself, and the slide changes are 
sent automatically to the client.

PowerPoint Files with Animations

PowerPoint files containing animations may not appear correctly on the viewer 
side. In order to present PowerPoint files in native PowerPoint mode using Cisco 
IP/TV Web Presenter, you must save PowerPoint files with animations disabled. 
To disable animations, open the PowerPoint file and from the top menu choose 
Slide Show > Setup Show, check the Show without animation check box, and 
then save the file.

If this item is not chosen, the file appears properly on the server side during a live 
Web Presenter session, but is not properly displayed on the viewer side. The user 
sees the start of each slide, before the animations have been applied, but never 
sees the end state of the slide after the animations have occurred.

There is currently no way to step through the animations with Cisco IP/TV Server 
and Cisco IP/TV Viewer synchronized, because the PowerPoint automation 
application programming interfaces (APIs) do not provide this feature. You can 
author your presentation with this in mind, with each intermediate animation state 
as a separate slide.
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Alternatively, you can use the JPEG capture mode instead of the native 
PowerPoint mode (see the PresenterServerApp Options menu). In this case, 
animations do work, because each intermediate state is captured as a separate 
JPEG image file. In this case, do not disable animations and do not choose 
File > Open on the PresenterServerApp menu to open the PowerPoint 
presentation. Instead, double-click the .ppt file or open it after launching 
PowerPoint.

Configuring ScreenCaster
To configure the options available for running ScreenCaster, choose File > 
Options from the Cisco IP/TV Server main window. The system displays the 
Configure Web Presenter window. (See Figure 8-8.) After changing any 
settings, click the OK button to save your changes and close the Configure 
Web Presenter window.
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Figure 8-8 ScreenCaster Tab

Table 8-7 summarizes the meaning of each option on the ScreenCaster tab.

Table 8-7 ScreenCaster Configuration Options

Option Description

Capture and compress as 
JPEG

Broadcasts PowerPoint presentations using JPEG 
versions of the PowerPoint slides.

Native PowerPoint file Broadcasts PowerPoint presentations using native 
PowerPoint format.
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JPEG Capture directory When you enter the directory path, saves the JPEG 
files that are generated when you choose to 
broadcast PowerPoint in JPEG format. The 
captured windows or PowerPoint slides are saved 
to the system temp directory by default.

Enable automatic capture 
on change

When this option is chosen, after beginning 
transmission, retransmits the current selected 
region or window when you click the mouse 
anywhere on the screen. If the display has 
changed, ScreenCaster automatically recaptures 
and retransmits the selected window or region. 

Change threshold to trigger 
recapture

Percentage of the bitmap pixels that have to be 
different to trigger a recapture. Even if you choose 
the value “0,” retransmission has a minimum 
threshold that prevents retransmission from being 
triggered by a small animation or a blinking 
cursor.

Frequency of comparison 
for recapture

Start interval for comparing the previously 
captured version and the current contents of the 
window or region. After the initial interval, the 
interval increases exponentially (to avoid 
capturing a window too frequently and to reduce 
CPU overhead in doing frequent comparisons). 
The default is 1 second. 

Capture window on Fkey Enables screen capture using a function key.

1-12 Function key number used for initiating screen 
capture.

With Ctrl Requires pressing the Ctrl key at the same time as 
the specified function key.

Table 8-7 ScreenCaster Configuration Options (continued)

Option Description
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Scale to Fit Enables scaling of captured regions or windows. 
Bitmaps that are larger in one or both dimensions 
are scaled down to the best fit (best match for the 
width/height ratio). This is normally used for 
scaling down to 640 x 480 or 800 x 600 to match 
the expected “least capable” viewers and to reduce 
the file size and manage the bandwidth required. 
Minimum scaled values are 256 W x 192 H; 
maximum values are 1536 H x 1154 W. 

W Width to which to scale screen captures that are 
too wide or too narrow.

H Height to which to scale screen captures that are 
too tall or too short.

Allow scaling up Enables scaling up, in which case bitmaps that are 
smaller than the specified size are enlarged 
proportionally. 

JPEG Quality Sets the quality for JPEG compression. The 
permitted range is 1 to 100; the default value is 50. 
Note that below 30, quality is very poor. Above 75, 
quality does not improve substantially. 

Reset to Defaults Restores the settings to the default values.

Table 8-7 ScreenCaster Configuration Options (continued)

Option Description
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Using SlideCast
The SlideCast feature allows you to capture screen information for transmission 
over a network.

SlideCast enables IP/TV Server to serve the following:

• Live or prerecorded video and audio together with a separate SlideCast 
presentation (requires two servers)

• SlideCast together with the audio of the presenter

• Audio of the presenter with alternating SlideCast and live video

Note If one server is used for both SlideCast and live capture, the video card must be 
compatible with Video for Windows.

Note If you are using media streams from two servers for a recording, you must make 
sure that both the servers have the same time settings. If the clocks on the servers 
are not synchronized, your program also may show synchronization problems, 
such as the streams becoming unsynchronized. To synchronize clock settings on 
different devices running Microsoft Windows, use authoritative time server (ATS) 
settings in Windows. For more information on this topic, refer to the Microsoft 
Support website.

SlideCast with Live or Prerecorded Audio and Video
SlideCast allows IP/TV Server in live-capture mode to show either or both a 
presenter speaking and computer-based presentation materials (such as a 
Microsoft PowerPoint presentation or even a computer screen to demonstrate 
software) for a presentation. You specify whether a server will use SlideCast and 
the SlideCast server address in IP/TV Program Manager. See Chapter 6, 
“Managing Scheduled Programs,” for more information.

Figure 8-9 shows SlideCast with live or prerecorded audio and video.
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Figure 8-9 SlideCast Together with Live or Prerecorded Audio and Video

SlideCast with Live Audio
You can use the same server to serve both SlideCast and live audio. 
(See Figure 8-10.)

Server
Video and Audio

Server
SlideCast

Network

Viewer

Video and Audio

SlideCast
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Figure 8-10 SlideCast with Live Audio

Audio with Alternating SlideCast and Video
You can use one server and manually alternate between live video and SlideCast 
while using one audio track. (See Figure 8-11.) A good analogy for this scenario 
is a television studio switching from camera one to camera two. 

Figure 8-11 Server Shows Audio Alternating with SlideCast and Video

Server
SlideCast and audio

Network

Viewer

Server alternating
SlideCast and video

with audio

Network

Viewer
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Maximum SlideCast Presentation Capability
You can use the same server to serve both SlideCast and live capture, or you can 
use different servers. If you use one server to serve both SlideCast and live 
capture, the client sees both video and SlideCast in the same window. You must 
toggle between live capture and SlideCast on the server computer. If you use 
different servers, both windows can be viewed simultaneously.

Figure 8-12 shows an example of maximum SlideCast presentation capability. 
The presenter would be to the right, making eye contact with the live audience and 
speaking into the camera and microphone for both the live and the remote 
audience. Using Question Manager, the presenter would respond to queries from 
the live or the remote audience members. The assistant of the presenter would 
have a passive IP/TV Viewer to confirm that the audience is receiving the desired 
image or images. In addition, the assistant could alternate between live video, 
recorded video, and SlideCast presentations at the IP/TV Server console.

Note Question Manager is a feature that allows audience members to ask questions to 
the presenter. 

Figure 8-12 Maximum SlideCast Presentation Capabilities

SlideCast
presentation control

IP/TV Content Manager
Question Manager

IP/TV
Server

Network

IP/TV Viewer

Presenter's table
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Setting Up a SlideCast Presentation
The Capture Options window, accessed through IP/TV Server, is used to control 
the area of the screen captured and sent by SlideCast. If you have set up a server 
for SlideCast, the Capture Options window automatically opens when IP/TV 
Server starts serving the program.

To access the Capture Options window in a live-capture program, follow these 
steps:

Step 1 Right-click the scheduled live-capture program. 

Step 2 Click Program Details.

Step 3 Choose Window > Capture Options.

Table 8-8 describes the options in the Capture Options window.

Table 8-8 Capture Options Window Information

Option Description

Audio/Video Allows you to switch between live-capture and screen 
capture options. Only available on live-capture 
programs. 

SlideCast Partial 
Screen

Captures a partial screen. Use this option when clarity is 
more important than full-screen viewing. 

SlideCast Full Screen Captures the full screen. Note that the quality of a slide 
may degrade, depending on the type of compression 
being used.

Select Capture 
Region

Outlines the area to be captured, which you select by 
moving your mouse. This option takes effect only if the 
SlideCast Partial option is also chosen.
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To set up a SlideCast presentation, follow these steps:

Step 1 Start your computer presentation tool on the SlideCast server computer and load 
the first slide into the window.

Step 2 Click Select Capture Region. The capture region appears in a partial window. A 
box appears that you can use to select the area which you want to capture by 
moving your mouse.

Step 3 Left-click to lock in the desired position.

Step 4 Proceed with your presentation.

For a SlideCast-only server, no capture card is required. The server desktop must 
be set to use 16-bit or 24-bit color to use SlideCast.

Active Streaming Format Marker File Feature
The Web Presenter feature lets you create a playback from a live presentation 
using marker files. When you enable the marker file feature, all URL or 
PowerPoint slide changes (flips) that occur during a live presentation are recorded 
in the marker file. The marker file records the time that each slide is flipped, along 
with the title of the PowerPoint slide or the URL path name. Marker files use a 
specified format that can be used with an Active Streaming Format (.asf) media 
file to create a scheduled or on-demand program.

Note The media file must be in ASF format.
8-35
Cisco ACNS Software Program Manager for IP/TV User Guide

OL-4406-01



  

Chapter 8      Managing Online Presentations
Active Streaming Format Marker File Feature
Creating a Playback from a Live Presentation
You need to enable the Marker File option in order to capture the slide timings 
from a live web or PowerPoint presentation. The following steps are general 
guidelines for creating a marker file.

Step 1 Launch IP/TV Server and choose Settings > Configure > IP/TV Server > 
Marker File to display the Marker File tab.

See Table 8-9 for a description of Marker File tab options. 

Table 8-9 Marker File Tab Options

Option Description

Create Marker File If checked, indicates a marker file will be created that logs all the URLs 
or PowerPoint slide changes.

Folder to store marker files Location where the marker file is stored. Use the default location or 
choose your own location. 

Program Rating Rating value of the presentation. The permitted values are G, PG, 
PG-13, R, and NC-17. The default value is G.
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Note See the next section, “Marker File Format,” for more information about 
the marker file format.

Default Script Command Used when capturing PowerPoint slide changes from a browser. The 
default script command is:

URL slides/<FILE>&&rightframe

The output in the script command section of the marker file looks 
similar to this:

00.00.00.5 URL slides/sld00.htm$$rightframe

where 00.00.00.5 is the time that the slide was changed plus 0.5 
seconds, and URL slides/sld00.htm is the location and .htm filename of 
the slide.

The macro <FILE> is replaced by default with the filename portion of 
the URL. That is the portion after the final forward slash (/). 
PowerPoint slides are recorded as sld<#>.htm with the pound sign (#) 
being replaced by the slide number.

User Defined Script 
Command

Used when capturing URL slide changes. Change the default script 
command to the following:

URL <URL>&&rightframe

The output in the script command section of the marker file looks 
similar to this:

00.00.00.5 URL http://www.cisco.com/products&&rightframe

where 00.00.00.5 is the time that the slide was changed plus 0.5 
seconds, and URL http://www.cisco.com/products is the absolute path 
name of the web page. 

The macro <URL> is replaced by default with the absolute URL 
recorded. 

Table 8-9 Marker File Tab Options (continued)

Option Description
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Step 2 Launch IP/TV Server (with the Marker File option enabled) and direct the live 
Web Presenter session. The ASF Marker Script file is automatically generated 
when you disable the Web Presenter session. The marker file is located in the 
directory you selected on the Marker File tab.

The name of the marker file is automatically created and cannot be changed by the 
user. It appears as:

<ProgID>_YYMMDD_HHMM.txt

where <ProgID> is the decimal program identification given to the program on 
IP/TV Program Manager, YY is the last two digits of the year, MM is the two-digit 
month, DD is the two-digit day, HH is the hour on the 24-hour scale, and MM is 
the minute the program began.

Step 3 Open the Windows Media ASF Indexer tool and choose File > Open. Open the 
ASF media file into which you will import the marker file.

Step 4 Choose File > Import from the script file and import the generated marker file 
into the ASF file.

Step 5 Save the ASF file and exit the Indexer tool.

Step 6 Using IP/TV Program Manager, create a scheduled or on-demand program to play 
back the ASF file.

Step 7 View the web presentation using IP/TV Viewer.
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Marker File Format
The ASF marker file has three sections: program information, markers, and script 
commands. 

• The program information section contains information about the program 
such as title, creator, description, and copyright. This information is derived 
from the entries in the Program Information section when the program was 
created in IP/TV Program Manager.

• The marker section contains a time-indexed list of titles for the web page or 
PowerPoint slide accessed. 

• The script command section contains a time-indexed list of commands. Times 
in this section are 0.5 seconds later than each time in the marker section. Each 
command contains information about the change of the URL slide; that is, 
whether it is a PowerPoint slide within the browser or a URL web page.
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