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Using IP/TV Viewer
Chapter 4This chapter describes how to use IP/TV Viewer. Topics include the following:

• Displaying program information

• Playing a program

• Playing Web Presenter and SlideCast programs

• Subscribing to a program

• Assigning favorite programs

• Searching for a program

• Using the Question Manager

• About advanced topics

Displaying Program Information
You can display detailed information about any scheduled or on-demand program either 
from the IP/TV Viewer main window or from the viewer window when watching a 
program. Program information includes the following: program description and 
administrator information, associated web files, schedule and subscription information, and 
video, audio, SlideCast, Question Manager, diagnostic, and SDP information.
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Displaying Program Information
To display the Program Information window, perform the following steps:

Step 1 On the IP/TV Viewer main window, highlight the program name whose 
information you want to view. 

Step 2 Click View>Program Information. Or, after highlighting the program name, 
click the right mouse key to display a popup menu and click Program 
Information. The Program Information window appears. 

Program Description Information
The Description tab on the Program Information window displays the program description. 
If the program has a predefined URL, it is displayed in the URL field. Click Web Info to 
launch your default Web browser and jump to the URL location. The URL location is 
typically a web page that contains additional information about the program.
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Program Description Information
Figure 5-1 Description Tab Window

Click More to display more detailed information about the program. The detailed 
Description tab (see Figure 5-2) displays information such as the program administrator’s 
name, phone number and E-mail address, if available.

Click Send Mail to send E-mail to the address displayed in the E-mail field.

Using the Send Mail button invokes your E-mail application. Your E-mail application must 
support the Mail Application Programming Interface (MAPI) to use this feature. If your 
mail application does not support MAPI, then send mail through your E-mail application 
directly.
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Displaying Program Information
Figure 5-2 Detailed Description Tab Window

Video, Audio, and SlideCast Information
System administrators who want to view program video, audio, and SlideCast information 
click Advanced (see Figure 5-2) located on the detailed Description Tab window. The 
Advanced Information window appears with the Video tab on top (see Figure 5-3).
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Video, Audio, and SlideCast Information
Figure 5-3 Advanced Information—Video Tab

To view audio information, select the Audio tab (see Figure 5-4).

Figure 5-4 Advanced Information—Audio Tab

Video, audio, and SlideCast information is described in Table 5-1.
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Displaying Program Information
Table 5-1 Video and Audio Program Information

Question Manager Information
To view Question Manager information about a program, select the Question Mgr tab on 
the Advanced Information window (see Table 5-2). The Moderator: field contains the 
moderator’s web page address.

Table 5-2 Advanced Information — Question Manager Tab

Field Description

Src IP: The IP address of the media server.

SRC Port: The port number of the media server.

Dest IP: The multicast IP address to which the media is sent.

Dest Port: The port number associated with the Dest. IP.

TTL: The “Time To Live” value.

Encoding: The type of codec used.

Default FPS: The default frames per second (video only).
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Setting Maximum Bandwidth
Setting Maximum Bandwidth
The system administrator enters the maximum bit rate value while creating the program 
using the Content Manager. This value is used by the IP/TV Server as an upper boundary 
of the network resources it is permitted to use for the total combined streams associated 
with the program. Types of streams include video, audio, and SlideCast bandwidth 
resources. 

If you have a slow connection, you may want to know what the bandwidth required by the 
program in order to decide which media streams to receive.

To view a program’s maximum bandwidth, select the Misc tab on the Advanced 
Information window (see Figure 5-5).

Figure 5-5 Advanced Information—Misc Tab

This tab also indicates if the program is a local intranet program.
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Displaying Program Information
SDP File Information
To view the program’s SDP file information, click the SDP tab on the Advanced 
Information window (see Figure 5-6).

Note This information may be useful to Cisco Systems Technical Support staff.

Figure 5-6 Advanced Information—SDP Tab
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Schedule and Subscription Information
Schedule and Subscription Information
You can view schedule and subscription information about a scheduled program. Do this 
by clicking the Schedule tab on the Program Information window (see Figure 5-7).

Figure 5-7 Schedule Tab

Schedule and subscription information is described in Table 5-3. Refer to the “Subscribing 
to a Program” section for information about how to subscribe to scheduled programs.
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Playing a Program
Table 5-3 Schedule and Subscription Program Information

Playing a Program
You can play a scheduled program by selecting it from the Program Listings pane or 
subscribing to it. You can play an on-demand program by selecting it from the Program 
Listings pane or the OnDemand Playlist window. You can also play both types of programs 
by selecting them from the Favorites window.

Figure 5-8 shows a scheduled program being played. Figure 5-9 shows an on-demand 
program being played. Both program windows contain identical Change Program lists, 
toolbar buttons, and status bar information. The Change Program list, lists all the programs 
that you have assigned to the Favorites window. Use this list to quickly find your favorite 
programs.

Note The Frame Rate Statistics box, located on the status bar, is disabled for programs that 
are served by Windows Media Services.

Field Description

Current Time: The current system time.

Previous Start Time: The previous time the program was scheduled to begin.

Next Start Time: The next time the program is scheduled to begin.

Length: The length of the program in terms of days, hours, minutes.

Repeat Schedule Date and times the program is scheduled to play.

Initial Start Time: First time the program played.

Final Start Time: The last time the program will play.

Subscription: The user’s current subscription to this program. Values are: 
None, All, or a specific date and time.
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Playing a Program
Figure 5-8 Scheduled Program Playing

Note, however, that the program windows have different Video Cassette Recorder (VCR) 
controls. VCR controls let you stop or play the program, control the audio, and in the case 
of on-demand programs set the position of the video. See the “Controlling Audio and 
Video” section for more information on VCR controls.
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Playing a Program
Figure 5-9 On-Demand Program Playing

Controlling Audio and Video
You can control the audio and video portions of a program while it is playing by using the 
VCR controls located at the bottom of the viewer window. You can also control the media 
streams that are received by the program, however, you must select them before playing the 
program.

Adjusting Audio Level
Adjust the volume on both a scheduled and on-demand program by moving the slider to the 
right or left. The Mute Audio button mutes (a red slash through the icon) or resumes (no 
red slash) the audio portion of the program (see Figure 5-8).
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Controlling Audio and Video
Controlling and Setting the Media Position
Control the position of the video for an on-demand program while you are watching it by 
using the following on-demand VCR controls:

• Jump To Beginning button

• Jump Back button

• Jump Forward button

• Jump To End button

• Position Control slider bar

• Change Play Position option

The Jump To Beginning button positions the video back to its beginning with a time offset 
of zero. Refer to the “Menu Bar and Tool Icon Reference” appendix for a graphic and 
description of the VCR controls.

Note You may not be able to always view the actual or true beginning of the video until 
audio and video synchronization is achieved.

The Jump Back button positions the video back in time 10 percent of the overall duration 
of the program. If there is less than 10 percent preceding the current position, the program 
is set to position zero.

The Jump Forward button positions the video forward in time 10 percent of the overall 
duration of the program. If there is less than 10 percent remaining from the current position, 
the program is set to its end.

The Jump to End button positions the video to its end.

The Position Control slider bar lets you seek forward or rewind video segments while 
watching the program. Slide the bar to the right to fast forward, or slide it to the left to 
rewind. The highest possible precision of the slider is measured in seconds. Whenever you 
move the mouse over the Position Control slider bar, the Position button appears above the 
control. This button shows the time (hh:mm:ss) in terms of video location. Moving the 
slider bar updates the time shown on the Position button. Releasing the slider bar causes the 
program to seek that new location in time.
 Using IP/TV Viewer 5-13



Playing a Program
Note There is a slight delay, typically two to three seconds, in the video when you change 
position until the IP/TV Server and IP/TV Viewer resynchronize through the network. 
Network traffic may also affect response time.

To set the position of the video in terms of time, click Select Position to display the Change 
Play Position dialog box (see Figure 5-10).

Figure 5-10 Change Play Position Dialog Box—Time Tab

To set the position of the video, click the Time tab and enter valid entries by hours, minutes, 
and seconds into the hh.mm.ss fields and click OK. The video’s position is changed to the 
selected time and the dialog box closes.

The Bookmarks tab appears only if the author of the program used an .asf file that contains 
markers (see Figure 5-11). A marker is a pointer to a specific time in an .asf file. Markers 
allow you to move through an .asf file any way you want. You can go ahead or go back to 
a previous marker to view a portion of the video. To change the position of the video, select 
the desired marker and click OK.

Figure 5-11 Change Play Position Dialog Box—Bookmarks Tab

Selecting Media Streams
The Select Stream command lets you control the streams that are received by a given 
program. Media streams can be video, audio, SlideCast, or Web Presenter.
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Controlling Audio and Video
To select the media streams for a program, select the program whose streams you want to 
set. Then select the Select Stream command from the View menu on the IP/TV Viewer 
main window. The Select Streams dialog box appears (see Figure 5-12).

Figure 5-12 Select Streams Dialog Box

Select the Audio check box to enable audio, select the Video check box to enable video. To 
save memory or bandwidth you can clear the Audio checkbox if you only want to watch a 
program, or clear the Video checkbox if you only want to listen to a program.

If you want to enable the SlideCast feature, then select the Slidecast check box if available. 
You may want to clear the Slidecast check box if you only want to watch or listen to a 
program. See the “Playing a SlideCast Program” section in this chapter.

To enable the Web Presenter feature, select the URL Flipping check box if enabled. For 
more information, see the “Playing a Web Presenter Program” section.

Note How you set the Default Media option on the Options dialog box affects the default 
streams selected. You can select either Slidecast or URL Flipping, but not both.

If the program is scheduled and you want to subscribe to it, click Subscribe. The program 
is automatically listed on the Subscriptions window. For more information about 
subscribing to programs see the “Subscribing to a Program” section.

Note You can only subscribe to scheduled programs.
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Playing a Program
Monitoring Reception Quality and Status
Two reception quality indicators, located on the Reception toolbar on the viewer window, 
indicate reception quality levels (see Table 5-4).

Table 5-4 Reception Quality Indicators

These indicators change colors to reflect varying reception quality (see Table 5-5).

Table 5-5 Indicator Colors

Icon Description

Shows the level of reception quality on your computer as detected by 
IP/TV Viewer.

Shows the level of reception quality as detected by other workstations 
on the network that are viewing the same program. This receptor 
applies only to scheduled programs and not on-demand programs.

Color Meaning

Green Reception quality should be good. Video should be smooth and audio 
clear. If not, then the problem is usually the local machine or the content 
itself.

Yellow Reception quality is fair. Video may be slightly jerky and audio may not 
be clear.

Red Reception quality is poor. Video may be very jerky and audio may not be 
clear.

Gray Insufficient data has been reported for IP/TV to display quality levels. 
This indicator turns gray for a few seconds after a video window is 
opened, or if transmission is interrupted.
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Monitoring Reception Quality and Status
When IP/TV Viewer’s performance degrades for no apparent reason, you can use the 
reception quality indicators to determine whether the problem is local to your computer or 
common to other computers viewing the same program:

• If both indicators show poor reception quality levels, the problem is also detected by 
most or all of the computers viewing the same program. The problem is probably caused 
by a fault either in the server that is transmitting the program or in the network itself.

Contact the system administrator responsible for the server or a network manager for 
assistance.

Note If the program is an Internet accessed MBone session, the cause of poor reception 
might be external to your corporate network, and thus beyond the ability of your system 
administrator or network manager to correct.

• If the left indicator shows low reception levels, while the right indicator shows normal 
levels, the problem is likely due to a fault somewhere with the local network or your 
computer.

Note If your computer does not meet the hardware requirements listed in the 
“Requirements” chapter, your system may have insufficient processing power for the 
program you are viewing.

If these tips do not resolve the problem, contact your system administrator for assistance.
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Playing a Program
Viewing Modes
You can watch a program in one of three viewing modes: normal view, minimal view, and 
full screen view.

Normal View
The first time a program is selected, the program appears in a viewer window that is in 
normal view mode. This viewer window includes the menu bar, toolbar, VCR controls 
(on-demand programs only), and status bar, along with the video image area. Figure 5-8 is 
in the normal view mode.

You can click System menu to display the system menu commands. In normal view mode, 
the system menu contains only standard Windows commands such as: Restore, Move, Size, 
Minimize, Maximize, and Close. 

Minimal View
In minimal view mode, only the video image is present in the viewer window. The menu 
bar, toolbar, VCR controls, and status bar are hidden (see Figure 5-13).

Figure 5-13 Minimal View Mode
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Viewing Modes
In this mode, the System menu button contains additional commands that are only 
accessible through the menu bar, toolbar, and VCR control bar. 

Select Restore on the Window menu to return to normal view mode, or press the Page Up 
keyboard key.

Note You cannot select minimal view for audio only programs because they do not have 
video image areas.

Full Screen View
To watch a program in full screen view, select the Full Screen command on the View menu 
or press the Ctrl+PgUp keys. The window borders will disappear. To return to normal view 
mode from full screen, click the left mouse button anywhere on the screen or press any key 
on the keyboard.

Note Full screen view is not supported in viewer windows with SlideCast or Web 
Presenter streams.

Using Multiple Windows
IP/TV supports multiple viewer windows for both scheduled and on-demand programs. 
You may navigate among active IP/TV Viewers by clicking the window or pressing the
Alt+Tab keys. The audio will follow the active window.

Up to four viewer windows that are open at the same time are supported. However, IP/TV 
does not limit the number of viewer windows you can open at one time. If you have 
subscribed to more than four programs that run simultaneously, you will only receive four 
programs at one time. When one program ends and you close that viewer window, another 
program will begin playing.
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Playing a Web Presenter Program
Note Displaying multiple IP/TV viewer windows may result in poor video performance, 
especially on less powerful computers. If you want the best possible quality, stop playing 
all IP/TV programs you are not watching and close other applications that you are not 
using.

IP/TV Viewer performs best on faster machines, and when receiving data through less 
congested networks. When these conditions are not met, IP/TV gracefully degrades to a 
lower quality reception.

If video you are watching appears jerky and you notice that your computer has a lot of disk 
activity, your computer may be running low on memory.

Here are a few suggestions on how to get the best performance from IP/TV Viewer on your 
computer:

• Close applications you are not using, especially applications that require a lot of 
bandwidth on your local network. 

• IP/TV supports multiple windows; however, you may want to close these windows 
rather than minimize them to receive multimedia streams.

• Trade sound quality for better video quality.

• If you only want to listen to a program while you are working in another program, you 
may want to disable the video. See the “Advanced Topics” section.

• If the program is an MBone session, the cause of poor reception might be external to 
your corporate network, and thus beyond the ability of your system administrator or 
network manager to correct. Refer to the contact person on the MBone program contact 
list regarding the quality of the MBone program.

• Use the Pause button if video is not needed.

Playing a Web Presenter Program
When you play a program that contains a web presentation, the viewer window launches 
and plays the audio or video file. The Presenter Client window, which displays Web pages, 
also appears at the same time.
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Playing a Web Presenter Program
The web-based slides are HTML pages that are flipped in a designated sequence and at a 
designated time. The web-based slide presentation portion can be real-time web browsing, 
which is controlled by the person who is flipping the URLs. Or, the presentation can consist 
of a recorded .asf file that contains URL markers.

Figure 5-14 Viewing a Web Presenter Program

The viewer window behaves in the same way as it does when you are watching any type of 
scheduled or on-demand program. If desired, you can open your default browser in another 
window by clicking the Default Browser button.

Note Web Presenter does not support full screen view.
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Playing a SlideCast Program
Playing a SlideCast Program
IP/TV Viewer lets you play SlideCast presentations, which provide the following features: 

• Display an IP/TV Viewer with both audio and video together with a SlideCast 
presentation. 

• Display an IP/TV Viewer with SlideCast and audio.

• Display an IP/TV Viewer with audio, and alternating video and SlideCast images.

Figure 5-15 shows an IP/TV Viewer with both audio and video.

Figure 5-15 Viewer Audio/video with SlideCast

Figure 5-16 shows an IP/TV Viewer with SlideCast and Audio.
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Playing a SlideCast Program
Figure 5-16 IP/TV Viewer with SlideCast and Audio

Figure 5-17 shows IP/TV Viewer with audio and alternating video SlideCast.

Figure 5-17 Viewer with Audio and Alternating Video Slidecast
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Subscribing to a Program
The SlideCast window contains two toolbar buttons: Stop and Play button and the Pause 
and Restore button. Their functions are identical to the viewer window toolbar buttons.

Note SlideCast does not support full-screen mode.

Subscribing to a Program
The easiest way to launch a scheduled program that is not currently playing is to subscribe 
to that program. When you subscribe to a program, IP/TV Viewer saves the information 
about the program you want to view and automatically launches a viewer window when it 
is time for the program to begin.

Note IP/TV Viewer must be running to automatically launch a subscribed program. You 
can only subscribe to scheduled programs.

To subscribe to a scheduled program:

Step 1 From the IP/TV Viewer main window, display scheduled programs on the 
Program Listings pane.

Step 2 Select the program you want to subscribe to and click the right mouse button to 
display the right popup menu. Select the Subscribe command. The selected 
program is now listed on the Subscriptions window. You can also click 
View>Select Stream>Subscribe. 

A viewer window automatically launches and begins to play the program 
according to its play schedule.
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Assigning Favorite Programs
To learn if the program has scheduled repeated showings and to subscribe to one or more 
of the repeated showings:

Step 1 Select the scheduled program you want to subscribe to on the Program Listings 
pane.

Step 2 Click Program Information to display the Schedule tab (see Figure 5-7).

In the Repeat Schedule section of this tab are the date and times the program is 
scheduled to play. The initial and final start times of the program are also 
listed.The Repeat Schedule list displays a list of all repeats. Use the date range 
control arrows to move through the entire list.

Step 3 To subscribe to one repeat showing, select the desired repeat date from the list 
and click Subscribe to one. To subscribe to all repeats, click Subscribe to all.

Assigning Favorite Programs
You can create a customized list of favorite programs you watch frequently, and define a 
personal playlist of on-demand programs to play in succession.

Creating a Favorites List
All scheduled and on-demand programs you assign to the Favorites window will be listed 
on the Program Change list on the viewer window when watching a program. Use this list 
to quickly access your favorite programs.

To create a list of your favorite scheduled and on-demand programs:

Step 1 From the IP/TV Viewer main window, click Favorites. The Favorites window 
appears.

Step 2 Drag the desired program from the Program Listings pane directly to the 
Favorites window. You can add as many programs as you want to this window. 
You can drag both scheduled and on-demand programs (see Figure 5-18).
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Assigning Favorite Programs
Figure 5-18 Favorites Window With Sample Programs

Step 3 To remove a program from the list, highlight the program you want to remove 
and click Remove.

Creating an OnDemand Playlist
To create a list of on-demand programs that you want to play in succession:

Step 1 From the IP/TV Viewer main window, click OnDemand Playlist. The 
OnDemand Play List window appears. 

Step 2 Make sure that the on-demand programs you want to add to the playlist are 
displayed on the Program Listings pane.

Step 3 Drag the desired programs, one by one, from the Program Listings pane to the 
OnDemand PlayList pane (see Figure 5-19).
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Searching for a Program
Figure 5-19 OnDemand Playlist Window With Sample Programs

Step 4 Select the program you want to watch and click Watch Now. Only programs that 
appear below the selected program on the list will play in succession. Use the up 
and down arrows to change the order of the programs in the list.

Step 5 To remove a program from the list, highlight the program you want to remove 
and click Remove.

Searching for a Program
The IP/TV Viewer search feature lets you find a program listing by searching for selected 
keywords by field. The search feature is useful when you want to quickly locate a scheduled 
program and avoid scrolling through the program listings, or locate an on-demand program 
when you do not know under which category it is listed.
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Searching for a Program
To search for a scheduled or on-demand program listing:

Step 1 On the IP/TV Viewer main window, click Edit>Find. The Search Programs 
dialog box appears with the What, Where tab on top.

Figure 5-20 Search Dialog Box—What, Where Tab

Step 2 Enter a string in the Find What: field. 

Note A string can be a word, phrase, or number against which the contents of 
a program listing are matched.

Step 3 Select the Content Manager categories you want searched in the Look in: field. 
You can search all or only specific categories.

To select all programs, leave the Look in field as is. The default is All Programs. 
Or, to select a specific program category, click Browse. The Content Manager 
dialog box appears (see Figure 5-21). Select the desired program server and 
click OK.
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Searching for a Program
Figure 5-21 Select Programs Dialog Box

Step 4 Select the Fields tab. Check the fields where you want to search for a matching 
string. All field information originated at the time the program was created in the 
Content Manager (see Figure 5-22). Click Check All to select all fields. Click 
Clear All fields to clear all fields (see Table 5-6).
 Using IP/TV Viewer 5-29



Searching for a Program
Figure 5-22 Search Programs Dialog Box—Fields Tab

Table 5-6 Field Types 

Step 5 Select the Advanced tab (see Figure 5-23). Check the Match Case option if you 
want to match a string with specific capitalization. Check Match whole word 
only to match the whole string and not a subset.

Field Description

Session Name The program name as set up in the Content Manager.

Session Description Description of the program as set up in the Content 
Manager.

Session Keywords The session keyword as set up in the Content Manager.

User Name The user name as set up in the Content Manager.

Email The program administrator’s e-mail address.

Phone Number The program administrator’s phone number.

URL The URL path name, if specified in the Content Manager.

Copyright The copyright as set up in the Content Manager.

Administrator The program administrator’s name.
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Using the Question Manager
Figure 5-23 Search Programs Dialog Box—Advanced Tab

Step 6 Click Search Now. All programs that match the string are listed by name, media 
type, and description.

Step 7 You can watch a program, display program information, or select media streams 
by selecting the desired program listing and choosing one of the commands from 
the View menu.

Using the Question Manager
Question Manager is an integrated feature that lets you interact with the moderator of an 
IP/TV program. It is useful for environments such as distance learning and training. It 
allows remote users to participate in the Question and Answer portion of the presentation. 
Question Manager lets you send questions to a moderator, but does not return answers to 
you. 

The moderator can view the questions that apply to the program over the intranet, sort the 
questions, answer the questions as part of the presentation, export the questions to be 
stored, or delete the questions after the presentation.
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Using the Question Manager
To use Question Manager while viewing a program, the Question Manager must be 
enabled. The Ask a Question toolbar button is active when enabled, and grayed out when 
disabled (see Figure 5-24).

Note Question Manager can only be used for scheduled programs.

Figure 5-24 Ask a Question Window

To use Question Manager, do the following:

Step 1 While viewing a program that has the Question Manager enabled, click Ask a 
Question on the IP/TV viewer window. The Ask a Question dialog window 
appears next to the viewer window with your user name if entered previously in 
the Options dialog box.

Step 2 Enter your topic in the Subject: field and your question in the Question: field.

Step 3 The e-mail address and user name that you entered on the IP/TV Viewer User 
Information dialog box is received by the moderator. If no e-mail address or user 
name was entered, then the moderator will receive the question from 
anonymous.

Step 4 Click Submit. The question is sent to the Question Manager moderator.
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Advanced Topics
Advanced Topics
System administrators can choose from a list of DirectShow Filter Property windows and 
set operating parameters, perform advanced diagnostics, or adjust FlashWare options that 
can affect IP/TV Viewer performance. The list of properties windows is available when a 
program is playing and differs depending on the codec used.

On the viewer window, click Edit>Advanced Options. The DirectShow Filter Property 
windows for filters that are installed with IP/TV are described. Property windows for other 
third-party filters, such as a hardware MPEG decoder, also will be shown.

Click Controls>Advanced Options. The DirectShow Filter Property windows for the 
filters that are installed with IP/TV are: MPEG Video Decoder, MPEG Audio Decoder, and 
the Flashware Source Filter. Property windows for other third-party filters, such as a 
hardware MPEG decoder, will also be shown:

• MPEG Video Decoder

This property window lets you select either monochrome or color as the default setting. 
It also shows read-only information about the video stream, such as video settings, 
frame rate, and bit rate.

• MPEG Audio Decoder

This property window allows you to adjust the sound quality and stereo/mono settings. 
Lower quality audio settings allow the CPU to spend less time processing audio and 
more time processing video, resulting in improved video quality. For best overall 
performance on most computers, we recommend setting audio to AM radio/mono.

• Flashware Source Filter

This property window allows you to adjust various performance options, view an 
advanced Statistics Windows, and adjust audio and video synchronization.

Note When a Filter Property window is closed, all audio and video streams will 
momentarily pause and then resume.
 Using IP/TV Viewer 5-33



Advanced Topics
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