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Setting Up Web Presenter and 
SlideCast

This chapter describes how to set up and create presentations using Web Presenter or 
SlideCast. Topics include:

• Web Presenter versus Slidecast

• About Web Presenter

• Using SlideCast

Web Presenter versus SlideCast
Both the Web Presenter and SlideCast features let you create a live or prerecorded video or 
audio together with a slide presentation. However, each feature has its own distinct 
advantages and limitations. The following two subsections describe the advantages and 
limitations of each feature.

Web Presenter
Advantages of using Web Presenter include the following:

• You can achieve better quality and increased clarity for text and images.

• Only one server is required to serve the entire presentation.

• You can publish HTML pages from local files.

• You can quickly convert files you have created using common business tools such as 
Microsoft PowerPoint and Microsoft Word into Web pages.
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Web Presenter versus SlideCast
• You can incorporate other published web sites into your presentation.

• Web Presenter streams can be shared with other audio or video programs.

Limitations of Web Presenter include the following:

• The Web Presenter stream is not recordable.

• Clients must have Internet Explorer installed to view the presentation.

• Presentations must be authored in standard Web formats.

SlideCast
Advantages of SlideCast include the following:

• The entire presentation can be recorded to an RTP file and replayed later.

• No Web authoring ia required; if it can be displayed on the desktop screen, it can be 
transmitted using SlideCast.

• Cross-platform viewers are supported. (An H.261-based SlideCast presentation is 
viewable on Macintosh and UNIX platforms.)

• SlideCast streams can be shared with other audio or video programs.

Limitations of SlideCast include the following:

• Two servers are generally required if it is used with another video source.

• Text clarity may not be of high quality.

• SlideCast is CPU intensive.
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About Web Presenter
About Web Presenter
Web Presenter lets you create and direct web-based presentations. The types of Web 
presentations you can create include the following:

• A live Web presentation with a live-capture video and audio program. 

• A live Web presentation with a playback from file program.

• A playback from file program that has embedded URLs. The file must be an Advanced 
Streaming Format (.asf ) file. The Web presentation consists of HyperText Markup 
Language (HTML) pages that are flipped in a designated sequence and at a designated 
time as determined by the URLs embedded in the program’s .asf file. See Appendix B 
for more information about .asf files.

Creating and Directing a Live Web Presentation
This section lists and describes the steps for creating a live presentation. Although the web 
presentation is always live, the audio and video program can be live-capture or playback 
from file. The basic steps you need to perform are as follows:

Step 1 Prepare HTML presentation pages.

Step 2 Create a scheduled program using IP/TV Content Manager. 

Step 3 Direct the presentation. Use the Presenter Server application 
(PresenterServerApp window) to enter URLs and control the presentation.

Step 4 View the presentation using IP/TV Viewer.

The following sections describe, in detail, how to perform each of these steps.
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About Web Presenter
Preparing HTML Presentation Pages
Before directing the presentation, you need to set up the HTML pages that the director (the 
person who is flipping URLs) flips during the presentation. Setup methods include:

• Real-time browsing from the Web—You can flip URLs in a random manner or drag and 
drop shortcuts. You simply enter the URLs into the Address field on the 
PresenterServerApp window as desired (see Figure 8-3 later in this chapter) or click 
HTML links to access web pages directly from the Web. 

• Pre-browsing and downloading to local cache—Prebrowse the URLs so the contents are 
cached on the same machine you are directing the presentation from. Prebrowsing is 
useful because at presentation time the server does not have to access the Web and all 
prebrowsed URLs are accessible from the URL dropdown list.

Creating a Scheduled Program Using Content Manager
Follow these steps to create a live capture scheduled program to be used in conjunction with 
a live presentation:

Step 1 Go to the New Scheduled Program page in your Content Manager.

Step 2 Select the Basic Live Capture Program option and click Create Program. The 
New Scheduled Program page for live capture appears.

Step 3 Scroll to the Multimedia Source Information section (see Figure 8-1).
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Creating and Directing a Live Web Presentation
Figure 8-1 Live Capture with Live Presentation

Step 4 Select Multimedia Source Information options. Table 8-1 describes Web 
Presenter options. For all other options, refer to the IP/TV Content Manager 
User Guide.
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About Web Presenter
Table 8-1 Live Capture with Live Presentation

Option Description

Play Web Presentation Indicates whether the program includes a web 
presentation in addition to video and audio. 1

1 A scheduled program cannot contain both Web Presentation and SlideCast.

Transfer HTML to Browser 
Cache

If checked (default), the HTML pages and 
embedded graphics files of the web 
presentation will be uploaded to the client’s 
browser and cached. We recommend that you 
select caching when the web presentation uses 
static or a mixture of static and dynamic 
content. If only dynamic content is used, then 
unselect caching.

Share Presentation With Indicates whether the program you are defining 
includes the presentation stream from another 
program you choose in the adjoining pulldown 
list. 2

2 The start and end time of the program you are defining must be within the range of the 
program that contains the Presentation stream.

Web Presentation Bandwidth Sets the audio/video bandwidth in Kbps. The 
default is 256. You may want to use a smaller 
number for WAN or a larger number for LAN 
presentations.

Start Page URL (Optional) Specifies the HTML page that the user goes to 
at the start of the presentation. It can be either a 
URL Internet address or the full path name of 
an HTML file on the server’s local hard drive. 
For example, http://www.cisco.com or 
C:\BoardMtg\slide001.htm.

SlideCast/Web Presentation 
Server

Specifies the name or IP address of the IP/TV 
Server that will play the SlideCast or web 
presentation portion of the program. In the case 
of a web presentation, the server can be the 
same server as that of the video/audio server. 
Select a server from the list or enter the name of 
a new server.
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Creating and Directing a Live Web Presentation
Step 5 Make sure all other sections on this page are completed.

Step 6 Click Create Program to send the form to the Content Manager and create a 
live-capture scheduled program.

Follow these steps to create a scheduled program from a media file to be used in 
conjunction with a live presentation:

Step 1 Go to the New Scheduled Program page in your Content Manager.

Step 2 Select the Advanced Program (Show All Options) option and click Create 
Program. The New Scheduled Program page for an advanced program appears.

Step 3 Scroll to the Multimedia Source Information section (see Figure 8-2).
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About Web Presenter
Figure 8-2 Media File with Live Presentation

Step 4 Select Multimedia Source Information options. Table 8-1 describes Web 
Presenter options. For all other options, refer to the IP/TV Content Manager 
User Guide.
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Creating and Directing a Live Web Presentation
Table 8-2 Media File with Live Presentation 

Option Description

Play This File Enter the name of the file you want to use to 
create a scheduled program. This must be an 
.asf file.

Play Web Presentation Indicates whether the program includes a web 
presentation in addition to video and audio. 1

Transfer HTML to Browser 
Cache

If checked (default), the HTML pages and 
embedded graphics files of the web 
presentation will be uploaded to the client’s 
browser and cached. We recommend that you 
select caching when the web presentation uses 
static or a mixture of static and dynamic 
content. If only dynamic content is used, then 
unselect caching.

Share Presentation With Indicates whether the program you are defining 
includes the presentation stream from the 
program you choose in the adjoining pulldown 
list. 2

Web Presentation Bandwidth Sets the audio/video bandwidth in Kbps. The 
default is 256. You may want to use a smaller 
number for WAN or a larger number for LAN 
presentations.

Capture Live Web 
Presentation Data

Sets the program up to capture live web 
presentation data.
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About Web Presenter
Step 5 Make sure you complete all other sections on this page.

Step 6 Click Create Program to send the form to the Content Manager and create a 
scheduled program from a media file.

Directing the Presentation
Launch IP/TV Server on the same machine you plan to direct the live web presentation 
from. The Presenter Server (PresenterServerApp window) automatically launches at the 
time the designated web presentation program is scheduled to play (see Figure 8-3).

From this window you browse URLs, control which HTML pages are transmitted to IP/TV 
Viewers while you are browsing, and view the Web Presenter PGM (Pragmatic General 
Multicasting) source statistics (see Figure 8-4).

To browse URLs in real time enter a URL in the URL file on the PresenterServerApp 
window. Each time you enter a URL it is added to the URL field drop-down list and added 
to your local cache. You can also click links within a web page to flip to another URL, drag 

Start Page URL (Optional) Specifies the HTML page that the user goes to 
at the start of the presentation. It can be either a 
URL Internet address or the full pathname of an 
HTML file on the server’s local hard drive. For 
example, http://www.cisco.com or 
C:\BoardMtg\slide001.htm.

SlideCast/Web Presentation 
Server

Specifies the name or IP address of the IP/TV 
Server that will play the SlideCast or web 
presentation portion of the program. In the case 
of a web presentation, the server can be the 
same server as that of the video/audio server. 
Select a server from the list or enter the name of 
a new server.

1 A scheduled program cannot contain both Web Presentation and SlideCast
2 The start and end time of the program you are defining must be within the range of the 

program that contains the Presentation stream.

Table 8-2 Media File with Live Presentation  (continued)

Option Description
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Creating and Directing a Live Web Presentation
in shortcuts from Internet Explorer favorites, history, Explorer folders, or your desktop. You 
can also drag in links from an Internet Explorer window. You can also open HTML files 
stored on the server’s local hard drive.

Figure 8-3 PresenterServerApp Window

Table 8-3 lists and describes the toolbar button and menu commands on the 
PresenterServerApp window.
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About Web Presenter
Table 8-3 PresenterServerApp Window Icons and Menu Items

Toolbar Buttons or Menu 
Commands Description

Back/Forward buttons Allows you to return to the previous web page 
or forward to the next web page. 

Home button Displays the HTML web page that is defined as 
your Home page on the local browser.

Refresh button Reloads the current page from the Web.

Search button Displays the search page as configured in 
Internet Explorer options.

Full Screen button Toggles between maximized and normal 
PresenterServerApp window sizes.

Open command Click File>Open to open a local .htm, .html, 
.gif, or .jpg file that you may want to use in 
your presentation.

Print command Click File>Print to print the current page.

Stop button Stops loading the current HTML page from the 
Web and prevents it from being sent to viewers.

Browse Online menu 
command

Click File>Browse Online. Controls whether 
you are browsing from the network or local 
cache. The default is ON.

Transmit while Browsing 
menu command

Click File>Transmit while Browsing. 
Controls whether you can transmit pages to 
IP/TV Viewers while you are browsing. The 
default is ON.

Presenter Stats menu 
command

Click View>PGM Source Stats to display the 
PGM Source Stats window (see Figure 8-4). 
PGM is a reliable multicast streaming protocol. 
This information is provided for network 
administrators who may need it for diagnostic 
purposes.
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Creating a Playback from File Presentation
Figure 8-4 PGM Source Stats Window

Viewing the Presentation Using IP/TV Viewer
From the IP/TV Viewer, select the desired Web presentation program from the Program 
Listings window. A viewer window launches and begins to play the audio and video 
program. Simultaneously, the Presenter Client window appears and displays the 
presentation. If the Presenter Server has not yet sent a URL, then no Presenter Client 
window will appear on the client side. 

Creating a Playback from File Presentation
The Web Presenter feature lets you create a playback from file presentation. A playback 
from file web presentation consists of an audio and video program that has embedded 
URLs. 
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About Web Presenter
Follow these steps to create and view a playback from file web presentation:

Step 1 Create or select the prerecorded file you want to use in your web presentation. 
The file must be in .asf format. Or, start with an .avi or.wav file.

Step 2 Convert the non-ASF media file to .asf format using the Windows Media 
Encoder tool.

Step 3 Insert URLs into the .asf file using the Windows Media ASF Indexer tool. Refer 
to the Windows Media Technology (WMT) documentation for more 
information. 

Note When you specify a URL ScriptCommand in an .asf file make sure you 
enter the complete (absolute) URL, such as http://www.nbc.com. You need to 
use http:// to distinguish between absolute and a relative path. Also note when 
you specify a frame name in ScriptCommand, that the frame name is 
case-sensitive.

Step 4 Using IP/TV Content Manager, create a scheduled or on-demand program to 
play back the .asf file. See the “Creating a Scheduled or On Demand Program 
from an .asf File” section.

Step 5 View the web presentation using IP/TV Viewer. See the “Viewing the Playback 
from File Presentation Using IP/TV Viewer” section later in this chapter.

Creating a Scheduled or On Demand Program from an .asf File
Follow these steps to create a scheduled program from an .asf file and set the web 
presentation options:

Step 1 Go to the New Scheduled Program page in your Content Manager.

Step 2 Select the Basic Media File Program option and click Create Program. The 
New Scheduled Program page for a media file appears.

Step 3 Scroll to the Multimedia Source Information section (see Figure 8-5).
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Creating a Playback from File Presentation
Figure 8-5 Playback from File Program with Embedded URLs—Scheduled

Step 4 Click the Select media file and select the .asf file from the listing in the IP/TV 
Browse Media Files window. Most multimedia source information options are 
automatically checked. If the file contains URLs, the Play Web Presentation 
option is checked. Or, you can enter the full media file path and manually select 
the multimedia source information options. Table 8-4 describes Web Presenter 
options. For all other options, refer to the IP/TV Content Manager User Guide.
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About Web Presenter
Table 8-4 Playback from File with Embedded URLs—Scheduled

Step 5 Make sure you complete all other sections on this page.

Step 6 Click Create Program to send the form to the Content Manager and create a 
scheduled program from an .asf file.

Follow these steps to create an on-demand program from an .asf file:

Step 1 Open your IP/TV Content Manager and go to the New OnDemand Program 
page.

Step 2 Scroll to the Multimedia Information section (see Figure 8-6).

Option Description

Select media file Enter the name of the file you want to use to 
create a scheduled program. Make sure to enter 
the full path name of an .asf file.

Play Web Presentation Indicates whether the program includes a web 
presentation in addition to video and audio. 1

1 A scheduled program cannot contain both Web Presentation and SlideCast.

Transfer HTML to Browser 
Cache

If checked (default for scheduled programs), 
the pages and embedded graphics files of the 
web presentation are uploaded to the client’s 
browser and cached. 2

2 We recommend that you select caching when the web presentation uses static or a mixture 
of static and dynamic content. If only dynamic content is used, then unselect caching.

Web Presentation Bandwidth Sets the audio/video bandwidth in Kbps. The 
default is 256.You may want to use a smaller 
number for WAN or a larger number for LAN 
presentations.

Web Base URL (optional) Base portion of the URL that identifies the web 
server or local file path. This is required if the 
.asf file was built using relative URLs.
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Creating a Playback from File Presentation
Figure 8-6 Playback from File with Embedded URLs—On-Demand

Step 3 Click Select media file and select an .asf file from the list in the IP/TV Browse 
Media Files window. Most multimedia information options are automatically 
checked. If the file contains URLs, the Play Web Presentation option is checked. 
Table 8-5 describes Web Presenter options. For all other options, refer to the 
IP/TV Content Manager User Guide.
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About Web Presenter
Table 8-5 Playback from File with Embedded URLs—On-Demand

Step 4 Make sure you complete all other sections on this page.

Step 5 Click Add OnDemand Program to send the form to the Content Manager and 
create an on-demand program.

Viewing the Playback from File Presentation Using IP/TV Viewer
From the IP/TV Viewer, select the Web presentation program from the Program Listings 
window. A media window launches and begins to play the audio/video program. 
Simultaneously, a the Presenter Client window appears and displays the web presentation 
portion. The web presentation consists of HTML pages that are flipped in a designated 
sequence and at a designated time as determined by the URLs embedded in the program’s 
.asf file.

Option Description

Play Web Presentation Indicates whether the program includes a web 
presentation in addition to audio and video.

Transfer HTML to Browser 
Cache

If not checked (default), the pages and embedded 
graphics files of the web presentation will be uploaded to 
the client’s browser and cached. 

Web Presentation Bandwidth Sets the audio/video bandwidth in Kbps. The default is 
256.

Web Base URL (optional) Base portion of the URL that identifies the web server or 
local file path. This is required if the .asf file was built 
using relative URLs.
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Using SlideCast
Using SlideCast
The SlideCast feature allows you to capture screen information for transmission over a 
network.

SlideCast enables the IP/TV Server to serve the following:

• Live or prerecorded video and audio together with a separate SlideCast presentation 
(requires two servers)

• SlideCast together with the presenter’s audio

• The presenter’s audio with alternating SlideCast and live video

Note If one server is used for both SlideCast and live capture, the video card must be 
Video for Windows compatible.

SlideCast with Live or Prerecorded Audio and Video
SlideCast allows the IP/TV Server in live capture mode to show either or both a presenter 
speaking and computer-based presentation materials (such as a Microsoft PowerPoint 
presentation or even a computer screen to demonstrate software) for a presentation. You 
specify whether a server will use SlideCast and the SlideCast server address in IP/TV 
Content Manager. Refer to the IP/TV Content Manager User Guide for more information.
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Using SlideCast
Figure 8-7 shows SlideCast with live or prerecorded audio and video.

Figure 8-7 SlideCast Together with Live or Prerecorded Audio and Video
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SlideCast with Live Audio
SlideCast with Live Audio
You can use the same server to serve both SlideCast and live audio. Figure 8-8 shows 
SlideCast with live audio.

Figure 8-8 SlideCast with Live Audio
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Using SlideCast
Audio with Alternating SlideCast and Video
You can use one server and manually alternate between live video and SlideCast while 
using one audio track. A good analogy for this scenario is a television studio switching from 
camera one to camera two. Figure 8-9 shows audio with alternating SlideCast and video. 

Figure 8-9 Server Shows Audio Alternating with SlideCast and Video
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Maximum SlideCast Presentation Capability
Maximum SlideCast Presentation Capability
You can use the same server to serve both SlideCast and live-capture, or you can use 
different servers. If you use one server to serve both SlideCast and live-capture, the client 
sees both video and SlideCast on the same window. You must toggle between live-capture 
and SlideCast on the server computer. If you use different servers, both windows can be 
viewed simultaneously.

Figure 8-10 shows an example of maximum SlideCast presentation capability. The 
presenter would be to the right, making eye contact with the live audience and speaking into 
the camera and microphone for both the live and remote audience. Using Question 
Manager, the presenter would respond to queries from the live or remote audience 
members. The presenter’s assistant would have a passive IP/TV Viewer to confirm that the 
audience is receiving the desired image or images. In addition, the assistant could alternate 
between live video, recorded video, and SlideCast presentations at the IP/TV Server 
console.

Note Question Manager is a feature that allows audience members to ask questions of the 
presenter. 
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Using SlideCast
Figure 8-10 Maximum SlideCast Presentation Capabilities

Setting Up a SlideCast Presentation
The Capture Options window, accessed through IP/TV Server, is used to control the area of 
the screen captured and sent by SlideCast. If you have set up a server for SlideCast, the 
Capture Options window automatically opens when IP/TV Server starts serving the 
program.

Follow these steps to access the Capture Options window on a live-capture program:

Step 1 Right-mouse click the scheduled live-capture program. 

Step 2 Click Program Details.

Step 3 Click Window>Capture Options.
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Setting Up a SlideCast Presentation
Table 8-6 describes the options in the Capture Options window.

Table 8-6 Capture Options Window Information

Follow these steps to set up a SlideCast presentation:

Step 1 Start your computer-presentation tool on the SlideCast server computer and load 
the first slide onto the window.

Step 2 Click Select Capture Region. The capture region appears in a partial window. 
A box appears that you can use to select the area you want to capture by moving 
your mouse.

Step 3 Click the left mouse button to lock in the desired position.

Step 4 Proceed with your presentation.

For a SlideCast-only server, no capture card is required. The server desktop must be set to 
use 16-bit or 24-bit color to use SlideCast.

Option Description

Audio/Video Allows you to switch between live-capture and screen capture 
options. Only available on live-capture programs. 

SlideCast Partial Screen Captures a partial screen. Use this option when clarity is more 
important than full-screen viewing. 

SlideCast Full Screen Captures the full screen. Note that the quality of a slide may 
degrade, depending on the type of compression being used.

Select Capture Region Enables an outline of area to be captured, which you select by 
moving your mouse. This option only takes effect if the SlideCast 
Partial option is also selected
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