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Launching the Administration Console for the 
First Time

This chapter provides information about the SmartFilter Administration Console. It contains the 
following topics:

• Starting the SmartFilter Administration Console the First Time, page 4-1

• Using the SmartFilter Administration Console Windows, page 4-3

• Using the SmartFilter Software Menus and Toolbar, page 4-7

• Configuring Administration Servers, page 4-9

• Enabling SmartFilter Software on the Cisco Content Engine, page 4-11

Starting the SmartFilter Administration Console the First Time
To start the SmartFilter Administration Console for the first time, follow these steps:

Step 1 Use one of the following methods:

• For Windows:

– Double-click the SmartFilter Administration Console icon on the desktop.

or

– Choose Start > Programs > SmartFilter Administration Console > Administration 
Console.

• For UNIX:

– Go to the directory where you installed SmartFilter and run the following command:

sh sfadmin.sh

Note For example, the directory could be /usr/local/sfadmin/bin.

The Configure Admin Servers window, shown in Figure 4-1, appears. The cursor is in the 
Name field.
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Figure 4-1 Configure Admin Servers Window

Step 2 Click Add and enter the name of the Administration Server that you want to configure. 

Note The name cannot contain a space or a comma.

Step 3 Press Tab to reach the Address field, and enter the address of the Administration Server. 

You can use either the Administration Server IP address or the host name.

Step 4 Accept the default value for the Administration Server port in the Port field.

Step 5 Press Tab to reach the Max Prev/Next Size field, and enter a value that defines the maximum number of 
items that can appear at one time in windows with potentially large tables.

An example is the Search Site window in the Administration Console. If more than the maximum number 
of items exists in one of these tables, the Previous and Next buttons become active so that you can move 
back and forth.

The default value for this field is 300.

Step 6 Determine whether or not to use encrypted communications.

• Check the Encrypt Communications check box to use encrypted communications. (Note that the 
port number changes.)

• Uncheck the Encrypt Communications check box to use unsecured communications.

Step 7 Click OK. 

The name, IP address, and port for the Administration Server that you added appear in the table.

Step 8 Click Close. 

The SmartFilter Administration Console appears.

Step 9 From the menu bar of the Administrator Console, choose File > Connect to Admin Server. The Admin 
Server Login window, shown in Figure 4-2, appears.
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Figure 4-2 Admin Server Login Window

Step 10 Choose the name of the login server from the drop-down list.

Step 11 Press Tab to reach the Username field and enter the administrator username for the SmartFilter 
Administration Server.

Step 12 Press Tab to reach the Password field and enter enter the administrator password for the SmartFilter 
Administration Server.

Tip The administrator username and password entered in Step 11 and Step 12 can be the username and 
password you created during the SmartFilter Administration Server installation process or the default 
username and password (sfadmin and sfadmin).

Step 13 Click OK. 

The directory tree items of the SmartFilter Administration Console appear.

Using the SmartFilter Administration Console Windows
Once you are logged in to the Administration Server, the SmartFilter Administration Console 
Configuration window becomes active. As shown in Figure 4-3, the SmartFilter Administration Console 
Configuration window is made up of three panes: two smaller navigation panes on the left displaying 
directory trees, and a larger display pane on the right. It also contains a toolbar and a menu bar, which 
are described later in this chapter.
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Figure 4-3 SmartFilter Administration Console

When you click a folder in the directory tree of the top navigation pane, window names contained in the 
folder are listed in the bottom navigation pane. When you click a window name in the bottom navigation 
pane, the corresponding window configuration options appear in the larger display pane on the right.

Using the Enterprise Settings Windows
The Enterprise Settings folder in the directory tree consists of the windows described in Table 4-1. For 
each window, Table 4-1 lists the window name, its description, and a link to find more information about 
the window.

Table 4-1 Enterprise Settings Windows

Window Name Description

License Contains information about your SmartFilter software, including the 
license activation key and expiration date, which are based on the 
date of your subscription and used by all SmartFilter plug-ins. You 
can also set or change the expiration behavior for SmartFilter 
software in this window. For more information, see the “Entering 
Licensing Information” section on page 5-2.

Define Plugins Allows you to add, change, copy, or delete plug-ins to be managed 
by this Administration Server. For more information, see the 
“Configuring Plug-In Definition Settings” section on page 5-4.
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Using the Individual Plug-Ins and Plug-In Group Setting Windows
The individual plug-in and plug-in group directory trees consist of the windows described in Table 4-2.

Define Plugin Groups Allows you to create groups for plug-ins that have exactly the same 
configuration. You can add plug-ins to and remove plug-ins from a 
plug-in group using this window. For more information, see the 
“Configuring Plug-In Groups” section on page 5-8.

Directory Resources Allows you to define the directories that SmartFilter uses for 
dynamic querying of user group information. For more information, 
see the “Defining Directory Resources Information” section on 
page 5-12.

Manage Administrators Allows you to add, change, or delete administrator accounts. For 
more information, see the “Entering Administrator Information” 
section on page 5-15.

Table 4-1 Enterprise Settings Windows (continued)

Window Name Description

Table 4-2 Individual Plug-Ins and Plug-In Group Windows

Window Name Description

Hostname: Configuration Contains information about an individual plug-in, including 
release, platform, name, and status; control list information (last 
download, expiration date, serial number); and agent information 
(release number). For more information, see the “Reviewing 
Plug-In Information” section on page 5-7.

E-Mail Alert Contains information that allows SmartFilter software to e-mail 
status information to the primary, secondary, or both SmartFilter 
software administrators. For more information, see the “Entering 
E-Mail Alert Information” section on page 5-10.

IP Based URL Access Defines how your company controls access to URLs by IP address. 
Users can access websites by entering a host name or an IP 
address. For more information, see the “Controlling IP-Based 
URL Access” section on page 7-11.

Log Option Contains information about the items you monitor in your proxy 
logs. For more information, see the “Configuring URL Logging 
Options” section on page 8-12.

Category Names Contains information about both the 30 predefined categories plus 
the 10 user-defined categories. For more information, see the 
“Renaming Control List Categories” section on page 6-5.

Available Forbidden File 
Extensions

Displays the file extensions that can be classified as forbidden. 
You can block URL access based on the file type referenced in the 
request. SmartFilter software defines several default forbidden file 
extensions. For more information, see the “Defining Available 
Forbidden File Extensions” section on page 7-9.
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Download Setup Configures the Control List download parameters. This window 
stores the download site name, your username, and password. It 
also allows you to set the regular download schedule for the 
SmartFilter Control List. For more information, see the 
“Scheduling Control List Downloads” section on page 6-2.

Custom Site Allows you to locally add a URL to an existing category or 
recategorize an existing URL. You can also exempt a URL from 
being treated with the same policy actions assigned to the 
categories in which it exists. For more information, see the 
“Defining Custom Sites” section on page 6-7.

Trim Custom Site Allows you to remove duplicate entries that exist between your 
custom sites list and the latest SmartFilter Control List. For more 
information, see the “Trimming Custom Sites” section on 
page 6-11.

Policy Contains information about the SmartFilter software policies that 
you have set up for your company. For more information, see the 
“Defining SmartFilter Software Policies” section on page 7-3 and 
“Configuring User Groups” section on page 8-1.

User Group Contains information about the policies associated with a 
particular group of users. For more information, see the 
“Configuring User Groups” section on page 8-1.

User Directories Determines not only which of the available directories to use but 
also the order of precedence in which to query them after you have 
used the Directory Resources window (see the “Defining 
Directory Resources Information” section on page 5-12) to define 
the directories for your organization. For more information, see 
the “Configuring User Directories” section on page 8-3.

Internal User Contains information about the internal user directory created by 
the SmartFilter software administrator to control user or group 
based filtering. For more information, see the “Creating Users” 
section on page 8-5.

IP Address Range Allows you to define a user client range IP address. Like internal 
users, IP address ranges can be added to groups and have policies 
applied to them. For more information, see the “Creating IP 
Address Groups” section on page 8-8.

View and Assign User(s) Allows you to simultaneously view all groups that have been 
assigned a given policy and the individual users that are members 
of those groups. For more information, see the “Debugging 
Policies Using the View and Assign User(s) Window” section on 
page 8-10.

Search Site Restricts access to search sites when used with the Restricted 
Phrase window. It is important to define the search engines and 
their CGI1 parameters so that the proper action is taken when you 
define restricted phrases. For more information, see the “Defining 
Search Sites” section on page 7-12.

Table 4-2 Individual Plug-Ins and Plug-In Group Windows (continued)

Window Name Description
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Using the SmartFilter Software Menus and Toolbar
The SmartFilter Administration Console has File and Help pull-down menus that allow you to perform 
a variety of functions.

Using the File Menu Options
The File menu allows you to choose options that apply to your entire SmartFilter software configuration. 
The File menu options are described in Table 4-3.

Restricted Phrase Restricts access to search sites when used with the Search Site 
window. Restricted phrases are by exact match. Phrase matches 
take precedence over word matches. In this window, you can add 
a word or phrase to restrict. You can also delete restricted words 
and phrases. For more information, see the “Identifying Restricted 
Words and Phrases” section on page 7-15.

Coach Text Contains the specific message that appears to users when they 
attempt to access a site for which you have allowed coached 
access. You can compose a unique message for each category. For 
more information, see the “Creating a Message for a Coached 
Category” section on page 7-18.

Deny Text/URL Contains the specific message or URL that appears to users when 
they attempt to access a site for which you have denied access. 
You can compose a unique message for each category. For more 
information, see the “Creating a Message for a Denied Category” 
section on page 7-19.

1. CGI = Common Gateway Interface

Table 4-2 Individual Plug-Ins and Plug-In Group Windows (continued)

Window Name Description

Table 4-3 File Menu Options

Option Name Option Description

Deploy Allows you to implement the changes you have just made to your SmartFilter 
software configuration. You must click Deploy so that the changes you have 
made using the SmartFilter Administration Console are written to the 
configuration files on the remote plug-ins. For more information, see the 
“Deploying Configurations to Plug-Ins” section on page 5-17.

Import Users from 
Text File

Allows you to import user and group information into an internal user 
database of the plug-in. For more information, see the “Importing Users or 
Groups from a Text File” section on page 8-7.

Configure Admin 
Servers

Allows you to add, delete, or change the characteristics of any of the 
configured SmartFilter Administration Servers. For more information, see the 
“Configuring Administration Servers” section on page 4-9.
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Using the Help Menu
The Help menu allows you to obtain information about the SmartFilter Administration Console. It also 
provides help for entering information into the windows of the Administration Console. The Table of 
Contents for the online help follows the outline of the SmartFilter Administration Console directory tree 
structure.

You can also access online help by clicking the Help button in the toolbar of the Administration Console 
or by pressing F1 on your keyboard.

Using the SmartFilter Software Toolbar
The SmartFilter Administration Console has a toolbar that contains the buttons described in Table 4-4.

Logout
Login to Admin 
Server

Allows you to log out of the Administration Server you are managing. The 
Login to Admin Server option allows you to log in to another SmartFilter 
Administration Server.

Exit Allows you to close and shut down the SmartFilter Administration Console.

Table 4-3 File Menu Options (continued)

Option Name Option Description

Table 4-4 Administration Console Toolbar Buttons

 Icon  Name  Description

Deploy Opens a dialog box that allows you to deploy configurations 
to one or many plug-ins. For more information, see the 
“Deploying Configurations to Plug-Ins” section on 
page 5-17.

Deploy Individual Deploys the configuration to the last selected plug-in or 
group. It becomes active only when one of the plug-ins is 
selected.

Add Admin Server Allows you to add an Administration Server. For more 
information, see the “Adding an Administration Server” 
section on page 4-10.

Add Plug-in Allows you to add a plug-in. For more information, see the 
“Adding a Plug-In Definition” section on page 5-5.

Add Group Allows you to add a group of identically configured plug-ins. 
For more information, see the “Adding a Plug-In Group” 
section on page 5-9.
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Configuring Administration Servers
Using the SmartFilter Administration Console, you can manage multiple servers. The Configure Admin 
Servers window, shown in Figure 4-4, is used for these tasks:

• Adding an Administration Server

• Deleting an Administration Server

• Changing Administration Server Properties

Figure 4-4 Configure Admin Servers Window

Disconnect from 
Server/Log in to 
Server

Allows you to connect to or disconnect from the server. 

Help Allows you to obtain information about the SmartFilter 
Administration Console. It also provides help for entering 
information into the windows of the SmartFilter 
Administration Console.

Table 4-4 Administration Console Toolbar Buttons (continued)

 Icon  Name  Description
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Adding an Administration Server
To add an Administration Server, follow these steps:

Step 1 Click the Add Admin Server button in the toolbar. 

The Configure Administration Servers window appears, and the cursor appears in the Name field.

Step 2 Enter the name of the Administration Server you want to add. 

The name cannot contain a space or a comma.

Step 3 Press Tab to reach the Address field and enter the address for the Administration Server. You can use 
either the IP address or the host name of the Administration Server.

Step 4 Accept the default value in the Port field.

Step 5 Press Tab to reach the Max Prev/Next Size field and enter a value that defines the maximum number of 
items that can appear at one time in windows with potentially large tables. 

An example is the Search Site window in the Administration Console. If more than the maximum number 
of items exists in one of these tables, the Previous and Next buttons become active so that you can move 
back and forth.

Step 6 Determine whether or not to use encrypted communications.

• Check the Encrypt Communications check box to use encrypted communications. (Note that the 
port number changes.)

• Uncheck the Encrypt Communications check box to use unsecured communications.

Step 7 Click OK. 

The name, IP address, and port of the Administration Server that you added appear in the table.

Step 8 Click Close.

Deleting an Administration Server
To delete an Administration Server, follow these steps:

Step 1 Choose File > Configure Admin Servers from the SmartFilter Administration Console. 

The Configure Admin Servers window appears.

Note If you use the toolbar button to access the Configure Admin Servers window, the cursor 
appears in the Name field.



 

4-11
SmartFilter for Cisco Content Engine User’s Guide

OL-2771-01

Chapter 4      Launching the Administration Console for the First Time
Enabling SmartFilter Software on the Cisco Content Engine

Step 2 Choose the Administration Server that you want to delete.

Step 3 Click Delete. 

A warning message appears, asking whether you are sure you want to delete the Administration Server.

• If you are certain you want to delete the Administration Server, click Yes.

• If you do not want to delete the Administration Server, click No.

Note Clicking the Close button of the message indicates a Yes response.

Changing Administration Server Properties
To change the Administration Server properties, follow these steps:

Step 1 Choose File > Configure Admin Servers from the SmartFilter Administration Console. 

The Configure Admin Servers window appears.

Note If you use the toolbar button to access the Configure Admin Servers window, the cursor 
appears in the Name field.

Step 2 Choose the Administration Server that you want to change.

Step 3 Update the appropriate property fields.

Step 4 Click OK. 

The name, IP address, and port for the Administration Server that you updated appear in the table.

Step 5 Click Close.

Enabling SmartFilter Software on the Cisco Content Engine
After configuring the SmartFilter software, you must enable the SmartFilter software application 
through the Cisco Content Engine graphical user interface (GUI) or command-line interface (CLI) 
before the SmartFilter software is fully functional.

To enable the SmartFilter software through the Cisco Content Engine GUI, follow these steps:

Step 1 Log in to the web-based Administration Console on the Cisco Content Engine.

Step 2 Choose Caching > URL filtering.

Step 3 Click the SmartFilter radio button.

Step 4 Click Update.

You are now ready to begin using SmartFilter software.
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To enable SmartFilter software through the Cisco Content Engine CLI, follow these steps:

Step 1 Use Telnet to log in to the Cisco Content Engine.

Step 2 Enable SmartFilter software from the Cisco Content Engine command-line interface by using the 
following global configuration command.

ContentEngine(config)# url-filter http smartfilter enable

Refer to the Cisco Application and Content Networking Software Command Reference, Release 5.0 
publication for more information on using the command-line interface.

You are now ready to begin using SmartFilter software.
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