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  Introduction
Introduction
This document provides information about the Cisco StadiumVision solution for all releases of Cisco 
StadiumVision Director Release 3.0 cumulatively through Service Pack 2 (SP2). It includes hardware 
and software requirements, new and changed features, installation and upgrade information, known 
issues, and defects.

This document is for Cisco StadiumVision system administrators and Cisco technical field engineers 
who are responsible for designing and deploying the Cisco StadiumVision solution. Readers of this 
document should be familiar with basic IP networking technology and the Cisco StadiumVision solution.

System Requirements for Cisco StadiumVision Director 
Release 3.0

This section describes the hardware and software supported by the Cisco StadiumVision solution for 
Cisco StadiumVision Director Release 3.0. It includes the following topics:

• Browser and Flash Player Support, page 3

• Cisco Digital Media Player Support, page 4

• Cisco StadiumVision Director Server Support, page 4

• Cisco StadiumVision Headend Support, page 5

• Cisco Unified Communications Support, page 6

• Commerce Integration Systems Support, page 7

• Media Controller Systems Support, page 7

• Unsupported Hardware and Software in Cisco StadiumVision Director Release 3.0, page 7

Browser and Flash Player Support

You can use an Apple Mac or Microsoft Windows PC or laptop to access Cisco StadiumVision Director 
Release 3.0. 

Table 2 describes the browser software versions that have been tested with Cisco StadiumVision 
Director Release 3.0, with the corresponding Flash player support.

Note Unless specifically identified as unsupported, other browser versions might work, but their compatibility 
with Cisco StadiumVision Director cannot be assured.

Table 2 Tested Browser Software

PC or Laptop OS Browser Version1 Flash Player

Apple Mac OS X • Mozilla FireFox Version 10 Adobe Flash Player Version 11.1.102.55

Microsoft Windows 
(XP or Windows 7)

• Microsoft Internet Explorer 
Version 8

• Mozilla FireFox Version 10

Adobe Flash Player Version 11.1.102.55
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  System Requirements for Cisco StadiumVision Director Release 3.0
Cisco Digital Media Player Support

Note Beginning in Cisco StadiumVision Director Release 3.0, the Cisco DMP 4305G is no longer supported.

The DMP firmware image is not bundled with the Cisco StadiumVision Director software. You must 
download the firmware image separately from the software download center site.

Table 3 describes the Cisco Digital Media Player (DMP) hardware and firmware supported in 
Cisco StadiumVision Director Release 3.0.

Note To download the DMP-4310G firmware, go to the Cisco Digital Media Players product page, click the 
Download Software link, and navigate to the Cisco Digital Media Player 4310G:

http://www.cisco.com/en/US/products/ps7220/tsd_products_support_series_home.html

Version 5.3.4 is not the latest available version shown on the download site. Be sure to navigate to All 
Releases > 5 > 5.3.4 to display the supported firmware download for Cisco StadiumVision Director 
Release 3.0. 

For information about how to upgrade the DMP firmware, see the “Upgrading a Cisco StadiumVision 
Director Server From Release 2.4 SP1 to Release 3.0” module of the Cisco StadiumVision Director 
Software Installation and Upgrade Guide, Release 3.0.

Cisco StadiumVision Director Server Support

Note Beginning in Cisco StadiumVision Director Release 3.0, the Cisco ADE 2140 Series Appliance 
(CADE-2140-K9) server is no longer supported.

1. No additional browser software is tested other than what is listed in this table (for example, not Apple Safari or 
Google Chrome). However, other browser software might work.

Table 3 Supported Cisco DMP Hardware and Firmware

Hardware Firmware Version

Cisco DMP 4310G DMP-4310 Version 5.3.4 
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  System Requirements for Cisco StadiumVision Director Release 3.0
Table 4 describes the Cisco StadiumVision Director server hardware and software supported in 
Cisco StadiumVision Director Release 3.0.

Note For more information about verifying and upgrading the Cisco UCS Server firmware, see the “CIMC 
and BIOS Firmware Installation for Cisco StadiumVision Director Platform 2 Servers” section on 
page 22.

Cisco StadiumVision Headend Support

Table 5 describes the Cisco StadiumVision headend hardware and software supported in 
Cisco StadiumVision Director Release 3.0.

Table 4 Supported Cisco StadiumVision Director Server Hardware and Software

Hardware Product ID Minimum Software Version CIMC/BIOS Firmware Spare Hard Drives1

1. Two additional 300 GB hard drives are recommended for Cisco StadiumVision Director Release 3.0 and are required to support the Self-Service Content 
(SSC) feature. For more information about how to install additional hard drives, see the “Installing Additional Hard Drives in the Cisco StadiumVision 
Director Platform 2 Server” module of the Cisco StadiumVision Director Software Installation and Upgrade Guide, Release 3.0.

SV-DIRECTOR-K9 or 
SV-PLATFORM2=

Minimum upgrade path: 
2.4.0-168 SP1 to 3.0.0-247 (64-bit)

Note For details about all supported upgrade paths, 
see the “Upgrade Paths” section on page 24.

Cisco UCS Server 
Firmware 1.4(2) or 
later

SV-FRU2-HD3G= 
StadiumVision 
Platform2 300G R2 
Disk Spare

Table 5 Supported Cisco StadiumVision Headend Hardware and Software

Hardware Device Software Version

Cisco Catalyst 3750 E-series IP Services image 12.2.x or above.

Note Release 12.2(55)SE1 and 12.2(55)SE2 should 
be avoided if using PoE to power DMPs with 
serial numbers USI1434xxxx or below.

Cisco Catalyst 3560 E-Series IP Services image 12.2.x or above.

Note Release 12.2(55)SE1 and 12.2(55)SE2 should 
be avoided if using PoE to power DMPs with 
serial numbers USI1434xxxx or below.

Cisco Catalyst 6500 Series IP Services image 12.2.x or above.

Cisco Atlas MKII Digital Terrestrial Receiver The release that ships with the device is recommended.

Cisco D9022 Encoder1 V02.11.10 

Cisco D9034 Encoder2 V03.03.22 

Cisco D9050 Encoder3 V4.00.04 

Cisco D9094 HD Encoder V04L101 

Cisco D9858 Advanced Receiver Transcoder R03.02.00 or later

Cisco D9887 HDTV Modular Receiver 6.3.2

Cisco DCM Series D9900 Digital Content 
Manager (DCM) MK II 2RU Chassis

8.01.86 and later

Note Releases after 8.01.86 require16GB Flash.
5
Release Notes for Cisco StadiumVision Director Release 3.0

 

http://www.cisco.com/en/US/docs/Sports_Entertainment/StadiumVision/Director/software/install/guide/3_0/SV_Director_sw_install_upgrade.html


 

  System Requirements for Cisco StadiumVision Director Release 3.0
Cisco Unified Communications Support

The Cisco StadiumVision solution supports the Cisco Unified IP Phone 7975G only.

Table 6 lists the combinations of Cisco Unified Communications Manager (CUCM) and firmware for the 
Cisco Unified IP Phone 7975G that were tested for compatibility with Cisco StadiumVision Director 
Release 3.0.

Note CUCM 6.x is no longer supported in Cisco StadiumVision Director Release 3.0.

Note Although not all combinations have been tested, earlier maintenance versions of CUCM [such as 7.1(3)] 
are also likely to work with Cisco StadiumVision Director Release 3.0. Avoid trying to use any major 
version other than 8.5 or 7.1. CUCM 8.6 is required for IP phone localization support. For example, any 
other major version such as 5.1 or 8.0 is not supported.

Cisco 8-VSB 4-Port or 8-Port ATSC Off-Air 
Reception DCM Module4

DCM Release 8.01.86 (minimum version)

Note DCM Release 8.07.00 is recommended but 
requires 16 GB Flash.

Cisco Dense Receiver and Decrypter 
(DRD)-S2 2-Port or 4-Port DCM Module 
(DVB-S2 Satellite Receiver)5

DCM Release V9.10.00

Cisco Spectra QAM Demodulator The release that ships with the device is recommended.

Scientific Atlanta Titan S2 DVB-S2 Digital 
Satellite Receiver 

Software Version V02.01.03

Hardware Version F02 Bootloader Version 
V03.01.42528 

Technicolor COM100 with COM24 cards ST02.00.3 or later (to support 3D or sonic Tap) 

Technicolor COM200 with COM24 cards ST02.00.3 or later

1. The Cisco D9022 Encoder has reached EOS/EOL.

2. The Cisco D9034 Encoder has reached EOS/EOL.

3. The Cisco D9050 Encoder has reached EOS/EOL.

4. The Cisco DCM 8-VSB ATSC Off-Air Reception Module is the replacement for the Cisco D9887 HDTV Modular Receiver 
for US ATSC implementations only.

5. The Cisco DCM DRD DVB-S2 Module is the replacement for the Cisco Titan DVB-S2 Digital Receiver and Cisco Indus MK 
II Transport Stream Descrambler.

Table 5 Supported Cisco StadiumVision Headend Hardware and Software (continued)

Hardware Device Software Version

Table 6 Tested Cisco Unified Communications Compatibility

CUCM Version Cisco Unified IP Phone Model Cisco Unified IP Phone Firmware

8.6(2a)1

1. CUCM 8.6 is required for localization of the speed dial interface on the Cisco Unified IP Phone. 

7975G 9.2(1)SR2

7.1(5) 7975G 9.1(1)SR1
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Commerce Integration Systems Support

Table 7 provides information about the hardware and software for third-party commerce integration 
systems that have been tested with Cisco StadiumVision Director Release 3.0. 

Media Controller Systems Support

Table 8 provides information about the hardware and software for third-party media controller systems 
that have been tested to support the External Event Trigger feature in Cisco StadiumVision Director 
Release 3.0. 

Note To support the Crestron Room Media Controller with Cisco StadiumVision Director it requires that you 
work with a Crestron reseller to install the appropriate software on the QM-RMC.

Unsupported Hardware and Software in Cisco StadiumVision Director Release 3.0

This section describes the hardware products and software features that are no longer supported in 
Cisco StadiumVision Director Release 3.0. 

• Unsupported Hardware Products, page 7

• Unsupported Software Features, page 8

Unsupported Hardware Products

The following hardware products are no longer supported in Cisco StadiumVision Director Release 3.0:

Note For more information about the replacement products, see the “System Requirements for Cisco 
StadiumVision Director Release 3.0” section on page 3.

Table 7 Tested Commerce Integration Systems Compatibility

Hardware Device1

1. For supported hardware configuration, contact Micros or Quest.

Software Version

Micros 9700 Enterprise Management Console 3.60.380

Micros 9700 Suites Management Application 1.0

Micros 9700 ContentManager 1.01

Quest Venue Manager 1.5.157 Build 2

Quest Suite Catering Module 1.5.157 Build 2

Table 8 Tested Media Controller Systems Compatibility

Hardware Device
Minimum 
Firmware Version Custom Software Module1

1. Available to certified Crestron integrators through Crestron.

Crestron Room Media Controller 
(QM-RMC)

4.001.1012 Cisco_StadiumVision_Alert_Trigger-v2.spz
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  New and Changed Information in Cisco StadiumVision Director Release 3.0
• Adtec DPI-1200 Ad Server 

• Adtec TBGS 

• Cisco ADE 2140 Series Appliance (CADE-2140-K9)

• Cisco DMP 4305G

Unsupported Software Features

The following software features and integration are no longer supported in Cisco StadiumVision 
Director Release 3.0:

• Ad Insertion Manager (AIM)

• CUCM 6.x

New and Changed Information in Cisco StadiumVision Director 
Release 3.0

This section describes new features, enhancements and changes in support or behavior in Cisco 
StadiumVision Director Release 3.0. It includes the following sections:

• APIs, page 8

• Dynamic Menu Board, page 12

• External Content Integration, page 12

• External Triggers, page 13

• Event-Time Content Replacement, page 14

• Internationalization and Localization, page 15

• Self-Service Content, page 17

• Server Administration, page 18

• User Interface, page 21

• User TV Control—Album Control, page 21

APIs
The following reference Application Programming Interfaces (APIs) are introduced in Cisco 
StadiumVision Director Release 3.0:

• Event Trigger API, page 9

• Media Planner Import API, page 9

• User Control API, page 10

Note All APIs in Cisco StadiumVision Director are made available by special agreement. Contact your Cisco 
Systems representative for more information.
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  New and Changed Information in Cisco StadiumVision Director Release 3.0
Event Trigger API

Note The Event Trigger API replaces the “Emergency Alert and TV Off/On Control” support introduced in 
Cisco StadiumVision Director Release 2.4.

Cisco StadiumVision Director Release 3.0 supports an HTTP-based Representational State Transfer 
(REST) API that a software or hardware contact closure source can use to trigger one or more actions 
by the Cisco StadiumVision Director software. For more information about support for external input 
triggers, see the “External Triggers” section on page 13.

Note If you want to control external triggers from a software application, you can contact your Cisco Systems 
representative to obtain the Event Trigger API that is made available by special agreement. 
“TriggerSVD” is an example of a third-party demo application for the Event Trigger API on iOS 
(supporting Apple iTouch, iPhone, and iPad products) and is available as a free download from the 
iTunes store.

Media Planner Import API

Cisco StadiumVision Director Release 3.0 supports a new Media Planner Import API to support import 
of external, third-party generated playlists. The API can be used to support automatic updates to an 
already imported playlist that has been placed in a script, or an external playlist can be manually 
imported.

The Media Planner API supports the following features:

Import Playlist Functionality

• Automatically creates playlist and populates it with existing content.

• Automatically links missing content to playlist after each missing content item is uploaded.

• Updates to playlists tied to a script that have all content items requires no human intervention.

Special User Interface Indications

• Imported playlist are easily identifiable as “external playlist.”

• Indicates playlist with missing content.

• Warn user when trying to assign a missing content playlist to template.

• Warn user when starting a script with missing content playlist.

Proof of Play Addition

• Works in the same way as a manually created playlist, but with more granularity.

• Automatic insertion of PoP tag for each time slot play.
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  New and Changed Information in Cisco StadiumVision Director Release 3.0
User Interface Example

The API automatically creates the playlist, which you can easily identify by an icon that tags it as an 
external playlist source (Figure 1). 

Figure 1 External Playlists in Control Panel Content Screen

The playlist is populated with existing content in Cisco StadiumVision Director, and you are alerted to 
any missing content in the playlist by a red box around the external playlist icon on the Content screen. 
The missing content item is identified with a question mark. Once you import any missing content, it is 
automatically linked to the external playlist.

Current proof of play reporting is fully supported for external playlist sources and PoP tags are 
automatically created for specified sponsor IDs. Any missing content is not included in the PoP report.

User Control API

New functions have been introduced to the in-suite API as of Cisco StadiumVision Director Release 3.0 
to add support for Self-Service Content (SSC) feature. The new API allows querying as well as sending 
control information to StadiumVision Director.

The API supports the following areas:

• Album Control, page 10

• Information Retrieval, page 11

• Security, page 11

• TV Control, page 11

Album Control

The API album control capabilities for SSC include:

• Retrieve all albums available for play on a specific player.

• Retrieve common albums available for play on a one or more players.

• Retrieve all albums available for play on a one or more players.

• Retrieve the album play duration.

• Set the album play duration.

• Control album loading and unloading of content to the player.
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  New and Changed Information in Cisco StadiumVision Director Release 3.0
• Control play/pause/stop/next/previous actions of the album.

Information Retrieval

The API information capabilities include:

• Query of which suites that can be controlled.

• Query of all players that can be controlled.

• Query of all players with in a suite that can be controlled.

• Query control features that exist within all suites.

• Query control features that exist within a specific suite.

• Query control features that exist for all players.

• Query control features that exist for a specific player.

• Query A/V inputs that exist for all players.

• Query A/V inputs that exist for a specific player.

• Query of closed captioning capabilities of StadiumVision Director.

• Query the channel guide for a specific suite.

• Query the status of all players that can be controlled.

• Query the status of a specific player.

• Detailed HTTP POST response messages in XML.

Security

The API security capabilities include:

• Unique permanent PIN for each suite in order to access and control the devices within.

• Temporary PIN for each suite that changes per event script run, can be displayed on TV. The 
temporary PIN is changed every day at 4 a.m. (default) based on the default scheduled task in Cisco 
StadiumVision Director. It also can be changed on demand using the UI. 

• Common master PIN for administrative control.

TV Control

The API TV control capabilities include:

• Power on and off of the TV.

• Channel change to a channel within the guide.

• Channel change up or down from the current channel in the guide.

• Volume change to a specific value.

• Volume change up or down from current value.

• Mute the audio with a specific on or off.

• Mute and unmute the audio with a toggle.

• Closed caption on with specific CC setting.

• Closed caption off.

• A/V input change with specific input setting.
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  New and Changed Information in Cisco StadiumVision Director Release 3.0
• Show and hide of the information banner on the TV.

Dynamic Menu Board 
The following enhancements for Dynamic Menu Board support are introduced in Cisco StadiumVision 
Director Release 3.0:

• Video on menu boards is tested and supported in Cisco StadiumVision Director Release 3.0.

• The following synchronization features have been added for Stores in the DMB application, 
particularly to support Micros menu board integration:

– Ability to configure the automated store synchronization interval from 1–24 hours. The default 
is 24 hours.

– Ability to view the date and time of the last update.

– Ability to manually synchronize updates to store content in DMB by the concessionaire or an 
administrator.

• Internationalization and localization support has been implemented for:

– Menu item descriptions.

– Pricing format selection either according to locale or without formatting.

– Ability for the currently logged in user to the DMB application to set the preferred locale based 
on the installed language packs. 

For more information on the DMB application, see the Cisco StadiumVision Director Dynamic Menu 
Board and Store Configuration Guide, Release 3.0.

External Content Integration
Beginning in Cisco StadiumVision Director Release 3.0, the Cisco StadiumVision Director solution 
supports integration with external data sources for content ingestion and presentation. Figure 2 shows a 
high-level overview of the new feature support.

Figure 2 External Content Integration High-Level Overview

The following external content sources are supported in Release 3.0:

• National Football League (NFL) Game Statistics and Information System (GSIS) Cumulative 
Statistics

• NFL GSIS Game Clock

• Daktronics All Sport 5000 Scoreboard Controller (basketball and hockey only)
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• OES ISC9000 Intelligent Scoreboard Controller (basketball and hockey only)

Once you have established connectivity to the external data source and selected and mapped the data that 
you want to display in the Cisco StadiumVision Director External Content Integration interface, you can 
use the Widgets tool on the Control Panel to design a layout of those statistics.

Note The Widgets tool only supports layout design for the External Content Integration feature in Cisco 
StadiumVision Director Release 3.0.

From there, complete the following tasks to publish the content to a TV:

• Create a playlist from the Control Panel for the widget that you created.

• Create an event script to run the playlist.

• Schedule the script to display the content on a TV.

For more information on External Content Integration, see the Cisco StadiumVision Director External 
Content Integration Guide, Release 3.0.

External Triggers
Cisco StadiumVision Director Release 3.0 supports an HTTP-based Representational State Transfer 
(REST) API that a software or hardware contact closure source can use to trigger one or more actions 
by the Cisco StadiumVision Director software, such as to start an event script to control display of 
content for a desired “moment of exclusivity” or make an emergency notification at a venue.

Building management and life safety systems as well as the broadcast control room in a stadium typically 
allow external integration by using dry contact closure and/or GPIO devices. It is expected that 
networked surveillance cameras, video routers, and other broadcast equipment already have these 
input/output (I/O) modules built into the hardware.

Figure 3 shows the different sources of contact closure that can be used as external input triggers to an 
event script on the Cisco StadiumVision Director server. 

• The virtual contact closure option represents a software application that can initiate an HTTP 
request directly and also use the Event Trigger API for retrieval of input trigger configuration from 
Cisco StadiumVision Director. You can obtain a free sample third-party software application called 
“TriggerSVD” on the Apple iTunes site.

• The physical contact closure option represents a hardware device, such as those used for life safety 
or building management systems, which produce an electrical signal that requires another device to 
convert the signal to an IP-based HTTP request. Figure 3 Option B shows this conversion being done 
by a GPIO gateway to initiate the HTTP request after receiving the trigger from the physical contact 
closure device. The Crestron QM-RMC is an example of a third-party hardware device that accepts 
two-wire signals and sends commands to Cisco StadiumVision Director.
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Figure 3 Input Sources of Contact Closure to Cisco StadiumVision Director

Cisco StadiumVision Director can perform certain script actions or TV controls upon receipt of an input 
trigger. Each input trigger can be configured to have multiple actions.

You can configure the following script actions to occur upon receipt of an input trigger:

• Start a script.

• Stop a script.

• Change to an ad-hoc state.

• Leave the current ad-hoc state.

• Go to the next sequential state.

• Go to the previous sequential state.

You can configure the following TV control actions to occur upon receipt of an input trigger:

• Turn TVs off by group, zone, or device.

• Turn TVs on by group, zone or device.

Cisco StadiumVision Director has 16 default input trigger IDs (and supports a maximum of 64) that are 
initially disabled and serve as placeholders for a Cisco StadiumVision Director administrator to define 
and enable for your system. The user interface options are defined in Extensible Markup Language 
(XML) code that can be accessed by an application using the Event Trigger API.

For more information about configuring external trigger support by Cisco StadiumVision Director 
administrators who are responsible for working with third-party developers and system integrators to 
establish connectivity for external input triggers, see the Configuring Cisco StadiumVision Director for 
External Triggers guide.

Event-Time Content Replacement
The Event-Time Content Replacement feature is introduced in Cisco StadiumVision Director 
Release 3.0 to allow you to perform content updates in a playlist during content presentation. Prior to 
Release 3.0, content distribution and presentation were dependent operations and you could not update 
content while a script was already running for that content.
14
Release Notes for Cisco StadiumVision Director Release 3.0

http://www.cisco.com/en/US/docs/Sports_Entertainment/StadiumVision/Director/software/configuration/guide/SV_Director_External_Event_Trigger.html
http://www.cisco.com/en/US/docs/Sports_Entertainment/StadiumVision/Director/software/configuration/guide/SV_Director_External_Event_Trigger.html


 

  New and Changed Information in Cisco StadiumVision Director Release 3.0
Caution Event-Time Content Replacement should be used with care if you are using Proof of Play due to impact 
of Proof of Play reporting if changes are made while a script is running. The cost-benefit of replacing 
content versus PoP impact should be weighed. Once an updated event script has stopped running, the 
PoP will operate normally upon re-running of the script.

You should avoid making the following types of playlist updates when using PoP with Event-Time 
Content Replacement:

• Adding items to the end of a playlist—The new item will show up in the PoP raw data, but not the 
detailed report.

• Removing an item from a playlist—Synchronization of the PoP reporting will be mismatched. 

Figure 4 shows the recommended method of performing event-time content replacement to minimize 
impact to PoP reporting.

Figure 4 Replacement of Existing Playlist Item 

Internationalization and Localization

Note Cisco StadiumVision Director Release 3.0 supports internationalization and localization for the Cisco 
DMP 4310G only and the Cisco Unified IP Phone 7975G.

Internationalization (i18n)

Internationalization (known as i18n) support refers to the software infrastructure that is designed to 
accommodate multiple language translations (localization) without requiring additional engineering 
changes to that software. 
15
Release Notes for Cisco StadiumVision Director Release 3.0

 



 

  New and Changed Information in Cisco StadiumVision Director Release 3.0
The Cisco StadiumVision Director Release 3.0 software supports i18n for the following general areas of 
the solution:

• Control Panel in Cisco StadiumVision Director

• Dynamic Menu Board application

• Management Dashboard in Cisco StadiumVision Director

• IP Phone user interface

• TV user interface

Localization (L10n)

Localization (known as L10n) refers to the implementation of the specific regional language translation 
support within a software interface that has been designed for i18n. 

Note Infrastructure for L10n has been implemented in Cisco StadiumVision Director Release 3.0 to support 
the future introduction of multiple locales. Certain locales are not supported in Release 3.0, such as 
right-to-left languages.

In the initial release of Cisco StadiumVision Director Release 3.0 software (Release 3.0.0-247), English 
is the only supported (and default) language for the Cisco StadiumVision solution. Support for other 
language translations are introduced as they become available in Service Packs.

Service Packs for Localization

Note When a Service Pack for Cisco StadiumVision Director is installed, all languages within the SP will be 
automatically installed.

Service Pack 1 (Cisco StadiumVision Director Release 3.0.0-429) includes support for the following 
languages (associated locales are in parentheses):

– Deutsch (de_DE)

– English (en_US). This is the default locale in all Cisco StadiumVision Director 3.0 releases.

– French (fr_FR)

– Italian (it_IT)

– Japanese (ja_JP)

– Korean (ko_KR)

– Polish (pl_PL)

– Portuguese (pt_BR)

– Russian (ru_RU)

– Simplified Chinese (zh_CN)

– Spanish (es_ES) 

– Swedish (sv_SE)

– Traditional Chinese (zh_TW)
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Translated User Documents

Available versions of translated end-user documents for Cisco StadiumVision Director can be found at:

http://www.cisco.com/en/US/products/ps11274/tsd_products_support_translated_end_user_guides_list
.html

Self-Service Content
Cisco StadiumVision Director Release 3.0 introduces support for independent users to upload images 
and videos using the new Self-Service Content feature.

Note The Self-Service Content feature requires additional hard drive space and initial configuration by a Cisco 
StadiumVision Director administrator to define categories in the system registry and add self-service 
content user accounts. 

Figure 5 shows the differences in content creation abilities in Cisco StadiumVision Director Release 2 
and Release 3, where only administrator and content manager roles could manage content in Cisco 
StadiumVision Director Release 2. In Cisco StadiumVision Release 3.0, the ability to get content into 
Cisco StadiumVision Director has been expanded to include users of various functional areas in a venue 
using an account defined for the self service content role.

Figure 5 Content Creators in Cisco StadiumVision Director Release 2 and Release 3

The Cisco StadiumVision Director SSC feature provides a way for business users from a variety of 
functional areas at a venue to independently upload custom content directly to the Cisco StadiumVision 
Director server and assign it to suites and devices for later presentation. 
17
Release Notes for Cisco StadiumVision Director Release 3.0

 

http://www.cisco.com/en/US/products/ps11274/tsd_products_support_translated_end_user_guides_list.html


 

  New and Changed Information in Cisco StadiumVision Director Release 3.0
The SSC feature provides a portal for each authorized user to upload and store content in folders called 
albums. This user-specific workspace is the only area of the Cisco StadiumVision Director software that 
an individual SSC user can access. It contains only the content uploaded by that user, and only that user 
can see the content. When the content is published to specific DMPs, only those areas of the venue have 
access to the albums. 

Ways to Use SSC

The following are some of the specific ways that you can use SSC for certain business functions at your 
venue:

• Back-office administrator—Display logo of a particular sponsor while meeting with them.

• Coaches—Create and display workout schedules in the locker room.

• Concessions—Update static menu boards.

• Human resources—Announce an employee of the month.

• Security office—Display lost child message.

• Suite attendant—Display personal “Happy Birthday” message.

• Suite sales—Personalize suites by suite owner.

• Team store—Create and display store promotions.

For more information about SSC, see the following documents:

• For information about how to configure Cisco StadiumVision Director for SSC support by 
administrators, and for details about how to do a bulk upload of content in SSC using a TSV file, 
see the Cisco StadiumVision Director Self-Service Content Configuration Guide.

• For information about how to use the SSC portal to upload content by Cisco StadiumVision Director 
business users defined with the Self Service Content role, see the Cisco StadiumVision Director 
Self-Service Content User Guide.

Note SSC supports control of album content on IP phones and other devices. For more information, see the 
“User Control API” section on page 10 and “User TV Control—Album Control” section on page 21.

Server Administration
The following areas of server administration have been changed:

• Role-Based Access Control, page 18

• TUI, page 19

Role-Based Access Control

Cisco StadiumVision Director Release 3.0 introduces a new user role called “Self Service Content.”

The Self Service Content role gives users access only to the Self-Service Content application area in 
Cisco StadiumVision Director when the user logs into the server. For more information about 
Self-Service Content, see the “Self-Service Content” section on page 17.
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TUI

The following Text Utility Interface (TUI) enhancements are introduced in Cisco StadiumVision 
Director Release 3.0:

• On the TUI main menu, option “j” has been renamed to “Change StadiumVision user passwords” 
(Figure 6).

Figure 6 Updated TUI Main Menu for Release 3.0
19
Release Notes for Cisco StadiumVision Director Release 3.0

 



 

  New and Changed Information in Cisco StadiumVision Director Release 3.0
• On the TUI change password menu, option 2 has been added to change the admgr password 
(Figure 7).

Figure 7 Updated Change Password Menu for Release 3.0

• On the Services menu, new options for the CMS service (for SSC) and the Mule service (for External 
Content Integration) have been added (Figure 8).

Figure 8 Updated TUI Services Menu for Release 3.0
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• On the Logging menu, new options for the CMS logs (for SSC) and the Mule logs (for External 
Content Integration) have been added (Figure 9).

Figure 9 Updated TUI Logging Menu for Release 3.0

User Interface
The following general areas of the Cisco StadiumVision Director user interface (UI) have been changed 
in Cisco StadiumVision Director Release 3.0:

• The background theme (color) of the UI has changed.

• The main menu on the Cisco StadiumVision Director home page has changed format and adds icons.

• The Control Panel tab bar has been extended with additional tabs and supports automatic horizontal 
scrolling or an optional drop-down list box for tab selection.

• The Control Panel supports maximizing the browser page view by clicking the rectangular icon at 
the top left of the window.

User TV Control—Album Control
In Cisco StadiumVision Director Release 3.0, support to control the display of SSC album content has 
been added as a new service for the IP phone. With the album control service, you can manually select 
albums for display on a TV and use standard-style media player controls to play, pause, and move 
forward and backward in the album content.

To use an IP phone to control display of album content, the following requirements must be met:

• The SSC user has successfully published the album for the intended suite and TV.

• The IP phone has been configured by an administrator for a service type that supports on-demand 
content in Cisco StadiumVision Director.
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  Installation Notes
Table 9 identifies all of the service types supported in Cisco StadiumVision Director Release 3.0, and 
the associated services that each supports. All service types support voice.

For more information about IP phone control with SSC, see the following documents:

• For information about how to configure an IP phone in Cisco StadiumVision Director for an 
on-demand service type, or configuring the CUCM service URL for SSC album control, see the 
Cisco StadiumVision Director Self-Service Content Configuration Guide.

• For information about how to use the IP phone to display SSC album content, see the Cisco 
StadiumVision Director Self-Service Content User Guide.

Installation Notes 
This section includes the following installation information:

• CIMC and BIOS Firmware Installation for Cisco StadiumVision Director Platform 2 Servers, 
page 22

• Important Upgrade Notes, page 23

CIMC and BIOS Firmware Installation for Cisco StadiumVision Director 
Platform 2 Servers

Platform 2 (SV-DIRECTOR-K9 or SV-PLATFORM2=) of the Cisco StadiumVision Director server 
requires installation of the Unified Computing System (UCS) Server Firmware Version 1.4(2) or later to 
avoid problems powering off the server hardware.

Table 9 IP Phone Service Types in Cisco StadiumVision Director Release 3.0

Service Type Voice TV / Volume
In-Suite 
Ordering

On-Demand 
Content 

LuxurySuite

AdminOffice

LuxurySuite2

ContentOnDemandVideo

ContentOnDemandOrder

ContentOnDemand
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Verifying the BIOS Firmware Version

You can verify the firmware version installed on Platform 2 of the Cisco StadiumVision Director server 
by running a Basic System State Report from the Cisco StadiumVision Director main menu.

Note BIOS firmware version 1.4.1 is the compatible version packaged with CIMC firmware version 1.4.2.

In the OS Information section of the Basic System State Report, look for “BIOS Information” and 
“Version” below the “Handle 0x00005, DMI type 0, 24 bytes” line, as shown in the following example.

If your version is less than “1.4.1,” then an upgrade is needed:

Handle 0x0005, DMI type 0, 24 bytes.
BIOS Information
Vendor: Cisco Systems, Inc.
Version: C200.1.1.1a.0.032920100525
Release Date: 03/29/2010

Tip If the vendor information in this section is Intel Corporation, and the version begins with 
“S5000,” then this is not a Platform 2 server, but rather a Cisco ADE 2140 Series server. This 
BIOS upgrade process does not apply to the Cisco ADE 2140 Series server.

For more detailed information about verifying the BIOS firmware and instructions about how to 
upgrade, see the “Upgrading the CIMC and BIOS Firmware on a Cisco StadiumVision Director 
Platform 2 Server” module of the Cisco StadiumVision Director Software Installation and Upgrade 
Guide, Release 3.0.

Important Upgrade Notes
Consider the following important changes that are implemented in Cisco StadiumVision Director 
Release 3.0 for upgrades to existing Cisco StadiumVision Director sites:

• Installation and Upgrade Files, page 23

• Upgrade Paths, page 24

• Upgrade Process, page 24

• Important DMP 4310G Firmware Guidelines During Upgrade, page 25

Installation and Upgrade Files

Cisco StadiumVision Director Release 3.0 software is available in different types of files based on the 
installation or upgrade environment. 

ISO Files

ISO files are packaged images that are available in two versions:

• An ISO full image—The full ISO file is to be installed only on brand new Cisco StadiumVision 
Director servers that have no prior Cisco StadiumVision Director software version installed.

• An ISO upgrade image—The upgrade ISO file is built for processing using the TUI upgrade utility.
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Software Download

If you have a Cisco CCO account and a contract for software download, you can download the 
Cisco StadiumVision Director installation and upgrade files on the Cisco.com software download site at:

http://www.cisco.com/cisco/software/navigator.html?mdfid=283479662&i=rm

Upgrade Paths 

The ISO upgrade for Cisco StadiumVision Director Release 3.0 is supported only for servers currently 
installed with Release 3.0.0-333.

Note Spanish localization is not supported in Release 3.0.0-247 or Release 3.0.0-333.

Table 10 lists the supported upgrade paths for Cisco StadiumVision Director Release 3.0:

If your system is not already running Cisco StadiumVision Director Release 2.4.0-168 Service Pack 1, 
perform the appropriate upgrade process(es) from your current version before you run an upgrade to 
Cisco StadiumVision Director Release 3.0. For more information about upgrades for the prior Release 
2.4, see the Cisco StadiumVision Director Installation and Upgrade Guide, Release 2.4.

Upgrade Process

Upgrades to the Cisco StadiumVision Director software are made available using the ISO upgrade utility 
available from the TUI. The ISO upload utility uses a special upgrade ISO file available from the 
Cisco.com software download site.

There are two upgrade environments for Cisco StadiumVision Director Release 3.0, which have different 
upgrade requirements:

• Upgrading an existing server from Release 2.4.0-168 Service Pack 1 to Release 3.0.

Depending on your server environment, this requires you to upgrade DMP firmware, migrate your 
server environment, install additional hard drives, upgrade CIMC/BIOS, and perform the ISO 
upgrade.

Note Upgrading from Release 2.4 requires that you obtain two upgrade scripts from your Cisco 
Systems representative. For more information, see the Cisco StadiumVision Director Software 
Installation and Upgrade Guide, Release 3.0.

Table 10 Supported Upgrade Paths for Release 3.0

From: To:

Release 3.0.0-429 (SP1) Release 3.0.0-433 (SP2)

Release 3.0.0-333 Release 3.0.0-429 (SP1)

Release 3.0.0-247 Release 3.0.0-333

Service Pack 1 for Release 2.4.0-168 Release 3.0.0-333

Service Pack 1 for Release 2.4.0-168 Release 3.0.0-247
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• Upgrading an existing server already running Release 3.0 to a more recent 3.0 release.

This environment generally requires that you only perform an ISO software upgrade.

For more details about upgrading the Cisco StadiumVision Director software for your environment, see 
the Cisco StadiumVision Director Software Installation and Upgrade Guide, Release 3.0.

Important DMP 4310G Firmware Guidelines During Upgrade 

Note Beginning in Cisco StadiumVision Director Release 3.0, the Cisco DMP 4305G is no longer supported.

Caution When upgrading from Cisco StadiumVision Director Release 2.4 to Cisco StadiumVision Director 
Release 3.0, an upgrade of required DMP 4310G firmware between these releases is also required.

Therefore, a transition window will occur during the upgrade where firmware Version 2.2.2 Build 2744 
for Release 2.4 is not currently supported in Cisco StadiumVision Director Release 3.0, which requires 
firmware Version 5.3.4.

To avoid issues during upgrade, perform the upgrade in the following order:

1. Upgrade from Release 2.4 to 3.0, leaving all DMPs with firmware Version 2.2.2 Build 2744.

2. Once the Cisco StadiumVision Director upgrade is complete, existing Release 2.4 features can be 
expected—but not guaranteed—to work with the Release 3.0/Version 2.2.2 Build 2744 combination. 

Be sure that the following guidelines are met while in transition between supported firmware 
versions:

– Do not attempt to use any new 3.0 features, such as SSC or External Content Integration.

– Do not use the system for any public events during the upgrade window.

– Do not use the system with a mix of DMPs with firmware Version 2.2.2/b2744 and Version 5.3.4 
deployed.

3. Complete the upgrade by upgrading all DMP 4310G models to Version 5.3.4.

Note For important information about how to perform the DMP firmware upgrade, see the “Upgrading the 
DMP Firmware” section of the “Upgrading a Cisco StadiumVision Director Server from Release 2.4 SP1 
to Release 3.0” module of the Cisco StadiumVision Director Software Installation and Upgrade Guide, 
Release 3.0.

VLAN Compliance Check

A VLAN compliance check for DMPs is supported in Cisco StadiumVision Director Release 3.0. After 
you upgrade to release 3.0, you need to go to the Management Dashboard and change the Assigned 
VLAN property under Global DMP Settings for both the 4310 and 4310 v5.2.3 settings according to your 
DMP VLAN configuration as follows:

• If all of your DMPs are located on the same VLAN (recommended)—Type the number of the VLAN 
and save the configuration.

• If all of your DMPs are not located on the same VLAN, or you want to bypass any VLAN 
compliance checking—Type “$svd_ignore” and save the configuration.
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Note Beginning in Cisco StadiumVision Director Release 3.0.0-429 (SP1), the default Assigned 
VLAN property value is $svd_ignore.

The value in the Assigned VLAN property in the Management Dashboard settings for the 
DMP 4310s is checked against the value being sent by the DMP, unless you have configured 
$svd_ignore.

Caution DMP auto-registration support requires that the VLAN value is correctly set or “$svd_ignore” is used.

Figure 10 shows how to configure the Assigned VLAN property under the 4310 Settings for DMPs 
that are not located on the same VLAN using the “$svd_ignore” string. 

You will also need to set this Assigned VLAN property value for the 4310 v5.x.x Settings:

Figure 10 Assigned VLAN Property Configuration for DMPs 
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Limitations and Restrictions 
When using Cisco StadiumVision Director Release 3.0, be aware of the following limitations and 
restrictions:

Caution Proof of play raw data is not part of the backup process. Only proof of play report data that has been 
generated to the /var/sv/pofp/data directory (indicated by the green dot icon beside the script) is backed 
up. Therefore, it is very important that you transfer PoP messages from the raw data directory to 
“data/<cookie>” directory as indicated by a green dot next to the event, before 60 days of the event, after 
which time PoP messages in the raw directory will be deleted.

• If you have previously accessed a different Cisco StadiumVision Director version on your computer, 
sometimes unexpected behavior or warnings arise, or you might access an older version of the 
interface. In this case, and especially after an upgrade, you must clear your browser cache.

• The initial release of Cisco StadiumVision Director Release 3.0 implements the infrastructure only 
to support i18n and L10n to support the independent installation of other language packs with Cisco 
StadiumVision Director Release 3.0 as they become available.

• Cisco StadiumVision Director Release 3.0 does not support internationalization for back-end 
messaging or the Video Distribution Manager.

• Non-English characters are not supported as a Cisco StadiumVision Director login credential.

• Multiuser support in Cisco StadiumVision Director Release 3.0 is limited to script editing only. No 
other Control Panel functions for templates, zones, groups, and playlists support a multiuser 
environment, and these areas can be deleted by other users. However, users are notified about 
potential impact due to currently locked scripts and are prompted for confirmation of deletion and 
given an option to use instant messaging to coordinate with the script owner.

• No more than 10 users can be supported at any one time in the Management Dashboard and Control 
Panel areas. The system does not prevent more than 10 sessions to be opened, so you need to be 
careful that you do not exceed this limit.

• No more than 50 staging threads can be processing in Cisco StadiumVision Director at any one time. 
The default maximum is 10. The maximum is configured using the “stagingThreadNum” registry 
found under the Tools > Advanced > Registry section of the Management Dashboard.

Note If auto-registration is enabled and a new DMP is detected, then Cisco StadiumVision Director 
initiates staging and always uses 50 as the maximum value. In this case, the stagingThreadNum 
registry setting is ignored and remains unchanged. 

• Consider the following restrictions and expected behavior when configuring playlists:

– Single video loop—You can configure a playlist to loop continuously when you have a playlist 
with a single video content item set for a duration of zero, with the playlist duration also set to 
zero.

– Single non-video loop—You can configure a playlist to loop continuously when you have a 
playlist with a single non-video content item by setting the item duration to -1 and either: 

1) Setting the playlist duration to zero, OR 

2) Setting the playlist duration to a number greater than zero.

– All playlists will loop their content (for example, once the last item plays, the playlist restarts 
with the first item) unless a duration of zero is configured on the first playlist item.
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– To run a playlist one time, you can specify a duration of zero for the last item in the playlist, 
except for a 2-item playlist. If the last item has zero duration in a 2-item playlist, then the first 
graphic plays and then only the last graphic continuously plays.

– A 2-item playlist will not work if both items have non-zero durations, unless the last item has a 
duration of 99999. 

– Any playlist containing more than one item does not work correctly if the duration of any item 
in the playlist is zero, except for the last item in the playlist. 

Important Notes
This section includes other important information about the Cisco StadiumVision solution that you 
should know for optimal operation.

DMP Maintenance Recommendations
To avoid unexpected behavior and maintain normal operation of your devices, it is highly recommended 
that you perform a soft reboot of all of the DMPs in your system each week. You can reboot DMPs 
manually or configure a periodic task to run automatically.

Note Before you perform a reboot, be sure that there are not any active scripts running.

For more information see the “How to Configure the Reboot DMP System Task From the Management 
Dashboard” task note.

Caveats 
• Open Defects in Cisco StadiumVision Director Release 3.0.0-429 (SP1), page 29

• Resolved Defects in Cisco StadiumVision Director Release 3.0.0-429 (SP1), page 31

• Open Defects in Cisco StadiumVision Director Release 3.0.0-333, page 32

• Resolved Defects in Cisco StadiumVision Director Release 3.0.0-333, page 37

• Open Defects in Cisco StadiumVision Director Release 3.0.0-247, page 39

• Resolved Defects in Cisco StadiumVision Director Release 3.0.0-247, page 56
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Resolved Defects in Cisco StadiumVision Director Release 3.0.0-433 (SP2)
Table 11 lists the defects that are resolved in Service Pack 2 for Cisco StadiumVision Director Release 
3.0. 

Open Defects in Cisco StadiumVision Director Release 3.0.0-429 (SP1)
This section lists the defects that are newly opened in Service Pack 1 for Cisco StadiumVision Director 
Release 3.0. These defects are open in addition to those defects open in Release 3.0.0-333 that are not 
yet resolved in Service Pack 1. 

CSCtx35299—L10n: Spanish localization defect summary for 2.4.0-SP1 release.

Symptom The purpose of this caveat is to summarize the known and postponed Spanish localization 
issues in Cisco StadiumVision Director 2.4.0 SP1 that are also open in Cisco StadiumVision Director 
3.0.0-429 (SP1). 

Workaround There is no workaround. This is an informational caveat.

CSCub55272—IP Phone (model 7975) reboots when using Luxury Suite service in Traditional Chinese and Korean.

Symptom When using Luxury Suite service on an IP Phone that is configured for Traditional Chinese 
(Taiwan) or Korean, the IP Phone reboots by itself after a period of usage.

Possible Cause This seems to be a memory issue on the IP Phone.

Note There are no issues with Simplified Chinese (Mainland China). 

Workaround There is no workaround.

Table 11 Resolved Defects in Cisco StadiumVision Director Release 3.0.0-433

Resolved Defect 
Numbers Description of Original Defect

CSCuf77495 Over time VDM video logs fill up causing VDM pushes to error out. 

CSCuf74153 Scheduled events fail in Cisco StadiumVision Director when Swedish and other 
language interfaces used.

CSCue36052 Files in /var/sv/Restore are not cleaned up periodically.
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CSCub76220—In Control Panel after adding item to a large playlist the list resets to the top.

Symptom After the item is added to the playlist the list resets and now shows the beginning of the list, 
instead of your insertion point for the playlist item. 

Conditions The following steps recreate the conditions when this defect occurs:

1. Launch Control Panel and go to Content screen.

2. Select a playlist with enough items such that when using split view, you have to scroll to get to 
bottom of the playlist.

3. While in split view, click and drag a new item into the playlist. 

Workaround Manually scroll the list to the desired insertion point. 

CSCub93535—Incorrect partitioning occurs if second RAID volume built prior to full ISO installation to Release 3.0.

Symptom When installing a full ISO image for Cisco StadiumVision Director Release 3.0 with the 
additional drives inserted into the chassis and the second RAID volume already built, the operating 
system does not partition the drives correctly with the standard file system layout required for 
Self-Service Content (SSC). Cisco StadiumVision Director will function correctly, however SSC will 
not work (even with the additional drives being present) due to the invalid filesystem layout. 

Workaround Build the second RAID volume after a full ISO install for Cisco StadiumVision Director 
Release 3.0. If you re-install a full ISO image on a server already installed with Cisco StadiumVision 
Director Release 3.0 and after the additional RAID volumes have been installed, then you must 
reconfigure RAID to recognize all installed volumes using the LSI MegaRAID utility as described in the 
“Installing Additional Hard Drives in the Cisco StadiumVision Director Platform 2 Server” module of 
the Cisco StadiumVision Director Software Installation and Upgrade Guide, Release 3.0.

Note You do not have to physically remove the hard drives.

CSCuc42948—In Microsoft Internet Explorer 9 the Cisco StadiumVision Director Control Panel does not work.

Symptom You cannot click areas of the Control Panel when using Microsoft IE 9.

Conditions The following steps recreate the conditions when this defect occurs:

1. Login to Cisco StadiumVision Director using Microsoft IE9.

2. Click on the Control Panel button from the Home page.

3. Once the Control Panel page loads, you cannot click any tabs. 

Workaround Use IE8 compatibility mode when using Microsoft IE9.
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CSCuc49247—Channel visibility on guide functionality not implemented on Flash template.

Symptom Hidden channels appear on the channel guide, but they should not display there. This 
functionality was not implemented on backend even though the Cisco StadiumVision Control Panel 
interface gives you the option of setting a channel to be hidden on the channel guide. 

Workaround There is no workaround.

CSCuc51898—CMS (SSC) does not reestablish database connection automatically.

Symptom Sometimes after a long period of inactivity (1 day+), the Content Management System (CMS) 
(Self-Service Content [SSC]) will lose connection to the mysql database. Issue usually appears as a 
failed publishing operation in SSC. 

Workaround Republish the album in SSC.

CSCuc56068—For Adobe Flash Player version 11.4 to work in Microsoft Windows with Cisco StadiumVision Director, protected 
mode needs to be off.

Symptom When using the Mozilla FireFox browser, the Cisco StadiumVision Director UI freezes. 

Workaround Protected mode is On by default in Adobe Flash Player version 11.4, and it needs to be 
turned Off in Microsoft Windows. To turn Proteced mode Off in Microsoft Windows 7, open the 
following file: C:\Windows\SysWOW64\Macromed\Flash\mms.cfg. Set the “ProtectMode” value to “0” 
(ProtectMode=0). For Windows XP or Vista, the file path is 
C:\WINDOWS\System32\Macromed\Flash\mms.cfg.

CSCuc60327—L10n: Localization defect summary for 3.0.0-SP1 release.

Symptom The purpose of this caveat is to summarize the known and postponed localization issues in 
Cisco StadiumVision Director 3.0.0-429 (SP1). 

Workaround There is no workaround. This is an informational caveat.

Resolved Defects in Cisco StadiumVision Director Release 3.0.0-429 (SP1)
Table 12 lists the defects that are resolved in Service Pack 1 for Cisco StadiumVision Director Release 
3.0. 

Table 12 Resolved Defects in Cisco StadiumVision Director Release 3.0.0-429

Resolved Defect 
Numbers Description of Original Defect

CSCtl53505 Session timeout error when log in.

CSCty27558 In SSC, UI not refreshed after exiting album edit mode.
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Open Defects in Cisco StadiumVision Director Release 3.0.0-333
This section lists the defects that are newly opened in Build 333 of Cisco StadiumVision Director 
Release 3.0.0. These defects are open in addition to those defects open in Release 3.0.0-247 that are not 
yet resolved.

CSCub27643—DMPs in failover mode during an event cannot get content from Cisco StadiumVision Director to display, resulting 
in black screen.

Conditions The following steps recreate the conditions when this defect occurs:

1. Fail to stage video content to DMP (with VDM). 

2. Log into Cisco StadiumVision Director and start an event script and navigate to a state which shows 
video content.

CSCtz21878 Album expiration is off by the amount of daylight-saving time for those 
deployments with DST.

CSCub24966 If multiple DMPs are selected for an SSC album, serial commands do not work.

CSCub25014 Dashboard CPU gauge is not reliable.

CSCub29237 Staging to failover directory fails with warning message.

CSCub43834 In Dashboard the VLAN compliance setting should default to “$svd_ignore.”

CSCub70013 Adding location to group without linkage to DMP gives duplicate host error.

CSCub70776 Device specification for AccuView touchscreen needs to be added.

CSCub90154 Inbound trigger history purged early.

CSCub97215 In Control Panel, display specifications UI should accept negative and decimal 
numbers.

CSCuc09291 BAT: Bulk Administration Tool should not store IP address and MAC address 
for a Location.

CSCuc17367 Increase SSH timeout value in the installe.pl file to 10 seconds.

CSCuc24076 The overlay.swf packaged with Cisco StadiumVision Director software causes 
calibration screen to be unreachable.

CSCuc27281 In Event Triggers tab, copying does not list selected DMPs. 

CSCuc27314 Saving while Filter on causes all actions to disappear from zone/group.

CSCuc31110 In Luxury Suite Phone “Confirm Re-assign” dlg placeholder is displayed. 

CSCuc35269 Change DMP Flash template version to “3.0.0-SP1” for SP1 release. 

CSCuc35478 Red IR “B” button loads slideshow SWF.

CSCuc42234 Widget data binding name only accepts Latin.

Table 12 Resolved Defects in Cisco StadiumVision Director Release 3.0.0-429

Resolved Defect 
Numbers Description of Original Defect
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Symptom When a DMP is in failover mode during an event, and should be displaying content, the TV 
screen is black. 

Possible Cause Content cannot be retrieved from Cisco StadiumVision Director because it is not in 
the expected directory (/opt/sv/servers/control/webapps/StadiumVision/failover/content). Failover 
mode could be triggered by a missing video file or Flash memory failure. (However, video channels 
can be seen during failover because they do not depend on content stored on the file system.) 

Workaround Turn off failover on the DMPs before the event by completing the following steps:

1. Log into Cisco StadiumVision Director as an administrator.

2. Click Management Dashboard.

3. Go to DMP and TV Controls > DMP Commands.

4. Select Update MIB.

5. Click 4310 Parameters tab.

6. In the name cell, type failover.on.

7. In the value cell, type false.

8. In the Select Devices box, select all DMPs.

9. Press the Play button to execute on selected devices.

10. Turn off failover in the global MIB settings by completing the following steps:

a. From the Management Dashboard, go to SV Director Configuration > System Configuration 
> Global DMP Settings > 4310 v5.x.x Settings.

b. Find the Enable failover property.

c. Set the value to false.

d. Click Save changes.

CSCub25014—Dashboard CPU gauge is not reliable.

Conditions The following steps recreate the conditions when this defect occurs:

1. From the Management Dashboard, start a Restore task with a very large backup file.

2. After a couple of minutes, you will see the CPU gauge going to 90+ percent.

3. Log into the Cisco StadiumVision Director server using SNE TAC account and run the top 
command.

4. Confirm that actual overall CPU usage is very minimal.

Workaround Try the following alternatives:

• If TAC level access is available, log into the Cisco StadiumVision Director server using SNE TAC 
account and run the top command to confirm the actual CPU usage.

• Wait to see if the CPU gauge in the Management Dashboard goes down after the task finishes. If 
there is still concern about high CPU usage, contact Technical Support to verify the actual CPU 
usage.
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CSCub24966— If multiple DMPs are selected for an SSC album, serial commands do not work.

Conditions The following steps recreate the conditions when this defect occurs:

1. Login as an SSC user and create an album with video content.

2. On the IP phone, touch Album Control > All.

3. Select an album and then touch the Play button. 

4. Try to use the volume soft keys. 

Symptom The volume bar does not appear on the display. This only applies to playing albums from the 
IP phone.

Workaround Try the following alternatives:

1. Use the Infrared (IR) remote control instead of the volume control from the SSC album on the IP 
phone. 

2. Play the SSC album only on one display.

3. Use a device that supports the Local Control API, such as a mobile phone or tablet, to control the 
volume.

CSCub13847—In Dashboard using the refresh button for “SV Director Server Locale” resets the selection to the first item.

Conditions The following steps recreate the conditions when this defect occurs:

1. Go to the Management Dashboard.

2. Select SV Director Configuration > System Configuration > SV Director Settings.

3. Under Configuration Property, select SV Director Server Locale.

4. In the Value column, click the locale.

5. Click Refresh.

Symptom Regardless of the current selection, the first item in the list is selected. If the Save button is 
clicked, the locale will now be changed.

Workaround Avoid using the Refresh button. If the Refresh button is used, do not click the Save button 
and reload the user interface.

CSCua10086—Deleting a theme from the DMB does not automatically remove it from the Contents panel.

Conditions The following steps recreate the conditions when this defect occurs:

1. Create a theme in the Dynamic Menu Board (DMB) application. 

2. Publish the theme. 

3. Go to Control Panel > Content and confirm that the custom application instance for the theme is 
present. 

4. Go back to the DMB and delete the theme. 

5. Go to Control Panel > Content screen and refresh the page. 
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Symptom The custom application instance for the theme is still present.

Workaround After deleting a theme in DMB, manually delete its custom application instance from the 
Control Panel > Content screen. 

CSCua96689—Adding new instances of widgets to a running script is not blocked.

Conditions The following steps recreate the conditions when this defect occurs:

1. Assume that you begin with an Event Script “A” containing widget “A” in State “A,” and you start 
Event Script “A.” 

2. Navigate to State “A.” 

3. Add another instance of widget “A” to the state.

Symptom The system allows you to add another widget, which is unsupported during a running script.

Workaround Avoid adding instances of widgets to a running script.

CSCua76981—In the Serial Commands panel, using the scroll bar causes an asterisk “*”to appear.

Conditions The following steps recreate the conditions when this defect occurs:

1. Go to Control Panel.

2. Go to Device > Display Specifications > Serial Commands.

3. In the Configured Serial Commands table, either drag and release the scroll bar or click on the 
up/down arrow of the scroll bar. 

Notice an asterisk “*” appears in the left panel beside the name of the display specification 
indicating that there is a change, but no change was made. 

Workaround Ignore the asterisk “*” if no changes were made to the “Configured Serial Commands” 
table. 

CSCua69249—In the Widgets tool, “Show Bounding Box” only works after component placement.

Conditions The following steps recreate the conditions when this defect occurs:

1. Go to Control Panel > Widgets.

2. Create a new widget. 

3. From the View menu, select Show Bounding Box so that a checkmark appears.

4. Place either a text or graphic component on the canvas. 

Notice that the bounding box does not appear. 

5. From the View menu, select Show Bounding Box so that the checkmark is removed. Then, select it 
again. 

Notice that the bounding box appears now.

Workaround If a bounding box does not appear around components on the canvas, select View > Show 
Bounding Box to clear the checkmark and then reselect View > Show Bounding Box so it is checked. 
35
Release Notes for Cisco StadiumVision Director Release 3.0

 



 

  Caveats
CSCua69192—In the Widgets tool, the “Use image original size” checkbox only works after an image has been selected.

Conditions The following steps recreate the conditions when this defect occurs:

1. Go to Control Panel > Widgets.

2. Create a new widget. 

3. Double-click the “Graphic” component, or drag it onto the canvas. 

4. In the “Properties” panel select the “Use image original size” checkbox. 

5. Click Change and select an image. 

Notice that the image is not using the original size. 

6. Clear the “Use image original size” checkbox and then select it again. 

Notice that the image is using the original size now.

Workaround Clear the “Use image original size” checkbox and then select it again. 

CSCua66283 —Publishing an SSC album multiple times causes unreliable state reporting.

Conditions The following steps recreate the conditions when this defect occurs:

1. Log into the SSC portal as an SSC user. 

2. Select an existing album. 

3. Click on the publish button several times. 

Symptom The album will quickly turn green suggesting that publishing was completed. However, if the 
user clicks Refresh, the album returns to pink, indicating that the album is unpublished. 

Possible Cause This seems to be caused by having multiple instances of publishing being returned 
by the backend, where some jobs are STAGING_WAIT, and some jobs are STAGING_RUNNING 
and STAGING_COMPLETE. The issue seems to be worsened when a user has made several publish 
requests and a publish queue has developed. 

Workaround Avoid re-publishing an album when it is currently being published. 

CSCua41862—CMS content deleted are not purged until a backup is run.

Symptom The Content Management System (CMS) content that is deleted from the SSC portal does not 
get purged from Cisco StadiumVision Director until a backup is run. The next backup file that is created 
will include all of the deleted contents (videos & image files) from the CMS, potentially creating a very 
large backup file depending on the frequency of the backup task. This could also potentially lead to the 
Cisco StadiumVision Director server running out of disk space if a backup task is not run for a very long 
period. 

Workaround Avoid long periods of time between backups. Having a daily scheduled backup task will 
avoid this issue.
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Resolved Defects in Cisco StadiumVision Director Release 3.0.0-333
Table 13 lists the defects that are resolved in Cisco StadiumVision Director Release 3.0.0-333.

Table 13 Resolved Defects in Cisco StadiumVision Director Release 3.0.0-333

Resolved Defect 
Numbers Description of Original Defect

CSCub06457 Heap size for config server need to be increased. 

CSCub06274 With large amount of data Backup process might run into Timeout error.

CSCua76180 After configuring option R in TUI tomcat server restart is needed.

CSCua71476 In “my.cnf” “max_allowed_packet” should be increased to 16M.

CSCua58677 Starting CMS can sometimes take about 20 min+ during boot process.

CSCua54017 SSC CMS staging directory missing from server on ISO install.

CSCua39467 Deletion of available serial cmds need to be deleted from device specifications.

CSCua37295 Default values for certain registry keys need to be changed.

CSCua36514 Script UI does not always reflect serial cmd selection that is on backend.

CSCua35300 If snetac shell is closed abnormally tacaccess.pl runs consuming memory.

CSCua23777 Template cannot set a region’s (x,y) coordinates to any integer.

CSCua23748 Template region width and height cannot be set to any positive int value. 

CSCua23687 When copying existing templates, the source template is corrupted.

CSCua19090 DMB Theme Currency Format: Mac does not handle it correctly.

CSCua17064 Certain files do not show up under TSV file browser filter.

CSCua12465 Content update while an event script is running fails if more than one image is 
changed at a time.

CSCtz97126 User Control API command to set Closed Captioning does not work.

CSCtz95001 Emergency status will not show on IP Phone when it is controlling an album.

CSCtz92543 Unable to unlink a Device from the Location through the UI.

CSCtz89979 Album presentation widget will not load if the SSC album size is greater than 
70 items.

CSCtz84039 An SQL upgrade script will fail if there are duplicate names in certain database 
tables during a software upgrade.

CSCtz70439 In VDM when a filename has more than one period character, an invalid file 
extension is assigned to it.

CSCtz67229 In the Display Specifications Basic Info tab the Save button is disabled and 
certain fields cannot be saved.

CSCtz62446 IP phone fails to load home screen when Control Server is restarted.

CSCtz53578 SSC video albums do not change to unpublished state after adding a DMP.

CSCtz39461 User is not notified if an SSC album fails to publish to a DMP.

CSCtz38926 Some video file extensions missing from the TSV file browser filters.

CSCtz38763 In SSC when using TSV for content upload, the progress bar does not show 
completion fraction properly.
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CSCtz38685 SSC content upload never completes if TSV file maps same content twice.

CSCtz38619 Album content order not consistent with TSV import content order.

CSCtz29618 Retry/Cancel state for an SSC album that failed publish does not disappear after 
you cancel.

CSCtz22105 Flash template: Deleting gadget during event may lead to black screen.

CSCtz22038 Sometimes the Location Assignment tab in Luxury Suite tab fails to load data.

CSCtz19042 In Content tab renaming of Channel Name is allowed but does not work.

CSCtz18858 Password field does not have to be filled to create a user.

CSCtz17772 Copy icon in “Output fields” section of “External Content” tab is 
non-functional.

CSCtz13856 Restore system data might fail after a fresh ISO installation.

CSCtz13655 Wrong Phone page after channel select for luxury suites with one DMP. 

CSCtz13624 Script with a widget state listed in Script Validation Error list erroneously.

CSCtz13104 SV UI: New unsaved closed script cannot be edited or saved.

CSCty99231 SV UI: Cannot save changes to configured serial commands a second time.

CSCty92768 Backup is not automatically copied to secondary server if Cisco StadiumVision 
Director Release 3.0 was installed through a full ISO. (Note: This issue is not 
relevant for upgrades to Cisco StadiumVision Director Release 3.0 from 
Release 2.4.)

CSCty89129 Cannot delete location from luxury suite if assigned to SSC user.

CSCtx81016 Possible to create an incompletely-specified event action.

CSCtt12540 In Dashboard, server utilization graph view mouse-over popup is blank. 

CSCts68143 During start of script with large number of DMPs, script is editable without 
warning.

CSCts67380 Schedule a script using absolute time is offset by timezone difference.

CSCts54128 Save button not enabled right after you duplicate a luxury suite.

Table 13 Resolved Defects in Cisco StadiumVision Director Release 3.0.0-333

Resolved Defect 
Numbers Description of Original Defect
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Open Defects in Cisco StadiumVision Director Release 3.0.0-247
This section lists the defects that are open in Build 247 of Cisco StadiumVision Director Release 3.0.

CSCtl53505—Session timeout error when log in.

Symptom After logging into Cisco StadiumVision Director, you might get a “session timeout” message.

Conditions Clustering is used for Cisco StadiumVision Director single sign-on. User login information 
must populate to all Cisco StadiumVision Director processes. 

Workaround The session timeout problem can be overcome with a low level configuration change. Please 
contact Cisco Technical Support to apply this workaround.

CSCts68143—During start of script with large number of DMPs, script is editable without warning.

Conditions Script has to have group(s) with a large number of DMPs (test case 3000 simulated DMPs). 
The following steps recreate the conditions when this defect occurs:

1. User-1 starts running Script A with content staging on from Control Panel > Control.

2. User-2 opens Script A from Control Panel > Schedule to edit.

Symptom When a script is in the “Starting” state, another user can edit the script without triggering the 
“Confirm Editing Running Script” dialog box.

Workaround Check whether a script is in “Starting” state before attempting to modify it. 

CSCty55562—Refresh of the data source's list will show misleading message on UI.

Symptom When refreshing the data source's list in the External Content tab on the Control Panel several 
unnecessary and misleading “This field is required” warning messages appear on the UI.

Workaround There is no workaround. The messages will disappear automatically after several seconds. 

CSCty55694—Double-byte category names for SSC do not display correctly.

Conditions The following steps recreate the conditions when this defect occurs:

1. Log into Cisco StadiumVision Director as an administrator.

2. Go to Management Dashboard > Tools > Advanced > Registry.

3. Search for the “album.categories” registry key. 

4. Using “;” as a separator, enter one or more categories using double-byte strings. 

5. Save registry changes.

6. Using an SSC user account, log into the SSC portal.

7. Click on an existing album to open it for editing. 

8. On the left, click on the Category dropdown box to display the categories.
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Symptom The double-byte strings entered in the system registry do not get rendered properly in the SSC 
portal dropdown box, even though they are stored correctly in the registry table (which is set to UTF-8 
character set). 

Possible Cause This could be due to the fact that a non-double byte language pack has not been 
installed and is not in use by the UI. 

Workaround There is no workaround.

CSCty58446—Album playback gets interrupted if script starts on same endpoints.

Conditions The following steps recreate the conditions when this defect occurs:

1. Using either the IP Phone or a script, start an album (number of displays does not matter). 

2. Go to the Control Panel 

3. Skip to Step 7 if you have an existing script that targets the same DMPs that are targeted by the 
album playback. 

4. Navigate to Schedule. 

5. Create a script that targets the same DMPs that are targeted by the album playback.

6. Save script changes. 

7. Navigate to Control. 

8. Start the script you just created. 

Symptom The album presentation gets interrupted and the script is loaded. 

Workaround There is no workaround.

CSCty89129—Cannot delete location from luxury suite if assigned to SSC user.

Conditions You have locations and DMPs in the system, with an SSC user defined. The following steps 
recreate the conditions when this defect occurs:

1. Go to Control Panel > Setup > Luxury Suite > Info.

2. Create Luxury suite, such as “suite1.”

3. Click on tab “Location Assignment” and assign a location/DMP, such as “loc1” to “suite1.” 

4. Go to User Management and select user, such as “ssc1.” 

5. Click on Edit button and assign “loc1” to self service content to the SSC user, “ssc1.” 

6. Go to Setup > Luxury Suite > Location Assignment, and try to delete “loc1” by clicking “–” 
button and Save button. 

Symptom The Location assignment is not deleted, and an error message appears.

Workaround Delete location from self service content user first. Then, delete location from luxury suite. 
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CSCty92768—Backup is not automatically copied to secondary server if Cisco StadiumVision Director Release 3.0 was installed 
through a full ISO. (Note: This issue is not relevant for upgrades to Cisco StadiumVision Director Release 3.0 from Release 2.4.)

Conditions The following steps recreate the conditions when this defect occurs:

1. On the primary server, go to Management Dashboard > Tools > Advanced > Run a Task and run 
the “BackupTask.” 

2. On the secondary server, go to Management Dashboard > Tools > Advanced tab and run “Restore 
system data from backup.”

3. Look under System backup time. 

4. The backup file from the primary server does not show up in the “System backup time” box. 

Workaround Contact support for the permanent fix or manually copy the backup files from the primary 
server to /var/sv/RESTORE directory of the secondary server, every time the BackupTask is run. 

CSCty99231—SV UI: Cannot save changes to configured serial commands a second time.

Conditions The following steps recreate the conditions when this defect occurs:

1. From Control panel, go to Setup > Devices > Display Specifications > Serial Commands. 

2. Change anything in “Configured Serial Commands” list box or “Serial Strings of Selected 
Command” (for example, change value of “Input3Name” serial command) 

3. Click Save.

4. Change anything else in “Configured Serial Commands” list box or “Serial Strings of Selected 
Command” (for example, change value of “Input4Name” serial command).

5. Click Save.

6. Refresh browser.

Symptom After you click Save in the Serial Commands tab a first time, you save a second change in the 
“Configured Serial Commands” list box or “Serial Strings of Selected Command” list box. Only the first 
change takes effect.

Workaround After the first Save operation, click Refresh before making any other changes. 

CSCtz04639—Deactivating the External Content Integration application requires a restart of the Mule server.

Conditions When you deactivate the External Content Integration application from the Management 
Dashboard you must restart the Mule service.

Workaround Go to Management Dashboard > Tools > Settings > External Content Integration. Run 
the Deactivate Application command from the Management Dashboard, and then run the Restart 
Application command.
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CSCtz04762—External Content Integration is enabled by default in fresh new ISO install.

Symptom In a fresh ISO install of Cisco StadiumVision Director Release 3.0, the External Content 
Integration feature is enabled. The desired behavior is that External Content Integration i disabled by 
default.

Workaround Manually disable the feature by going to Management Dashboard > Tools > Settings > 
External Content Integration. Run the Deactivate Application command from the Management 
Dashboard, and then run the Restart Application command.

CSCtz05752—Unable to delete a PoS Store that is assigned to a Luxury Suite.

Symptom When attempting to delete a PoS store that is currently in use by at least one Luxury Suite will 
result in an unfriendly error message being displayed. 

Workaround Remove the PoS store from all Luxury Suites before attempting to delete it.

CSCtz08509—Clicking System State Reports as a Content Manager opens VDM.

Conditions The following steps recreate the conditions when this defect occurs:

1. Log into Cisco StadiumVision Director as a Content Manager.

2. Click System State Reports.

Symptom A page opens taking the Content Manager to Video Distribution Manager instead of the system 
state reporting feature.

Note This is not a security issue because a content manager is authorized to use the Video Distribution 
Manager.

Workaround There is no workaround.

CSCtz13104—SV UI: New unsaved closed script cannot be edited or saved.

Conditions The following steps recreate the conditions when this defect occurs:

1. Go to Control Panel > Schedule.

2. Click the “+” icon to start creating a new script (do not click save). 

3. Click on Close. 

4. Select the script you just created and click the pencil icon to edit it (or double-click script and click 
Edit).
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Symptom Error message appears: “Cannot edit/delete selected object. New Script Thu Apr 5 11:29:37 
GMT-0700 2012: script/0 was not found.” 

Workaround There is no way to edit the script or to save it. Any data entered into the script will be lost. 
Be sure to save a script before clicking Close. 

CSCtz29274—After content import the number of items shown might be incorrect.

Conditions The following steps recreate the conditions when this defect occurs:

1. Log into Cisco StadiumVision Director.

2. Click Control Panel.

3. Go to Content.

4. Click Import.

5. Select multiple file(s) to upload.

6. Click Open. 

Symptom The Content screen does not update correctly and a smaller number of imported content 
appears. 

Workaround Reload the UI.

CSCtz29618—Retry/Cancel state for an SSC album that failed publish does not disappear after you cancel.

Conditions You have the following configuration in Cisco StadiumVision Director: 

• At least one DMP+Location in the list of devices.

• At least one luxury suite.

• A luxury suite has at least one DMP assigned to it.

• An SSC user is created and is authorized for the luxury suite.

• The SSC user has at least one published album. 

The following steps recreate the conditions when this defect occurs:

1. Shut down the DMP to which the SSC user’s album is authorized and published.

2. Log into the SSC portal.

3. Perform a publish on the album that is associated to the DMP that you have shut down. 

The publish fails and two buttons appear on the album thumbnail to Retry or Cancel.

4. Start the DMP that you shut down. 

5. Republish the album and verify that it is successful (green). 

Symptom Even though an album has been successfully republished after a failure, the Retry/Cancel 
buttons remain on the album thumbnail in the SSC portal.

Workaround Reload the UI.
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CSCtz13624—Script with a widget state listed in Script Validation Error list erroneously.

Conditions The following steps recreate the conditions when this defect occurs:

1. Create a script with at least one state that uses a playlist with an External Content Integration widget. 

2. Notice the script is now listed in the Script Validation Error list with a “Content not ready for 
playlist” error. 

Symptom When starting this script a message appears about script start being blocked by validation 
error(s). 

Workaround Ignore the “Content not ready for playlist” error in the Script Validation Error list. When 
starting the script press Yes when the warning message appears to continue. 

CSCtz17772—Copy icon in “Output fields” section of “External Content” tab is non-functional.

Conditions The following steps recreate the conditions when this defect occurs:

1. Go to Control Panel > External Content.

2. Select the Field mapping tab. 

3. If there are no items in the Output fields section, then create a new item. 

4. With an item selected, click the Copy icon. 

Symptom No action occurs when the Copy icon is used.

Workaround There is no workaround.

CSCtz18858—Password field does not have to be filled to create a user.

Symptom When creating a user, even though the password field is shown as required, a user can be 
created without filling in this field. Cisco StadiumVision Director creates an automatic password that the 
user is unaware of.

Workaround Have a user with Administrator credentials reset the password.

CSCtz19042—In Content tab renaming of Channel Name is allowed but does not work.

Conditions Have at least one channel created. The following steps recreate the conditions when this 
defect occurs:

1. Go to Control Panel > Content.

2. Switch to list view.

3. Double-click Channel name. 

4. Change the Channel name and press Enter.
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Symptom Channel name is blank, and it is not possible to enter a name for the Channel. 

Workaround There is no workaround.

CSCtz19072—Importing into playlist not all items present after import.

Conditions The following steps recreate the conditions when this defect occurs:

1. Go to Control Panel > Content.

2. Create a new playlist. 

3. Select playlist and click button to import into playlist. 

4. Select about 10 items and import. 

Symptom All imported items do not appear in the playlist. However, all items were imported and are 
available in All Content. 

Workaround Manually add missing items into playlist after import. 

CSCtz22038—Sometimes the Location Assignment tab in Luxury Suite tab fails to load data.

Conditions The following steps recreate the conditions when this defect occurs:

1. Clear browser cache. 

2. Go to Control Panel > Luxury Suite > Location Assignment.

Symptom There is location data but it does not load.

Workaround Do one of the following:

• Click on both green refresh buttons. 

or 

• Reload the UI and go to the Luxury Suite > Location Assignment tab before visiting other tabs. 

CSCtz21878—Album expiration is off by the amount of daylight-saving time for those deployments with DST. 

Conditions The following steps recreate the conditions when this defect occurs:

1. Log into the SSC portal as an SSC user.

2. Edit an existing album and set its Expires date to a time that has already passed. 

3. Save the album. 

4. Using the IP Phone or user control API, query one of the DMPs for a list of available albums. 
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Symptom Notice that although the album is expired, it is not being filtered out when the list of available 
albums is displayed to the end user on the IP Phone or user control API. 

Workaround Set your local computer's timezone and daylight-savings time setting to be the same as the 
Cisco StadiumVision Director server. To suppress albums from being shown on the IP Phone or returned 
by the user control API, configure the album to be inactive. 

CSCtz22105—Flash template: Deleting gadget during event may lead to black screen.

Conditions You have an event script with a playlist with 5 gadgets in it. The following steps recreate the 
conditions when this defect occurs:

1. Run an event script with 5 gadgets in it. 

2. During event, from content pane, delete one gadget in the playlist. 

3. Repeat step 2 if necessary. 

Symptom 2 gadgets are deleted and another gadget is created with an undefined URL and instance which 
displays text on the TV screen “loading menu entity url = undefined ? Instance = undefined,” and the 
rest of the screen is blank. 

Workaround Restart the Flash application using the Management Dashboard.

CSCtz38619—Album content order not consistent with TSV import content order.

Conditions The following steps recreate the conditions when this defect occurs:

1. Create a TSV file (Unicode text encoding) with multiple content pieces identified. Note the order of 
the content mapped to the albums.

2. Log into the Cisco StadiumVision Director SSC portal as an SSC user.

3. Click Upload.

4. Select the option to create a new album using a TSV mapping.

5. Click Browse.

6. Select the TSV.txt file and all corresponding image and video files identified in the .txt file for 
upload.

7. Click Open.

8. If no errors are found with the TSV file, click Upload to continue with the upload process.

Symptom After the import and content upload are complete, notice that the album that was created does 
not show the content items in the same order as they were specified in the TSV file.

Workaround Manually reorder the album content after TSV upload.

CSCtz38667—Attempts to delete a large number of content items immediately after import might fail.

Conditions The following steps recreate the conditions when this defect occurs:

1. In Control Panel, go to Content screen and import 100 or more content items (e.g. image1.png 
through image100.png). 
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2. Leave all the items selected and right after importing (within 5 seconds) click Delete and confirm to 
delete all of the selected content items that you just imported. 

3. Wait about 30 seconds. Notice that the content items do not appear to be deleted, and an error 
message is displayed. 

4. Refresh the browser. Notice that some (but maybe not all) of the images are removed, depending on 
how many images were uploaded and how long you waited to delete them.

Symptom The more images you upload, and the shorter the time that you wait to delete, the more images 
remain undeleted. If you select a playlist that uses some of the deleted images, the name of an image 
might be missing but there is still an image id and duration.

Workaround Wait at least a minute after importing up to 100 images before you delete them. The larger 
the number of images imported, the longer amount of time you need to wait before being able to 
successfully delete them. 

CSCtz38685 —SSC content upload never completes if TSV file maps same content twice.

Conditions The following steps recreate the conditions when this defect occurs:

1. Create a TSV file (Unicode text encoding) with multiple content pieces identified. Make sure that 
you create at least two albums and that you assign at least one item twice to each of the albums. 

2. Log into the Cisco StadiumVision Director SSC portal as an SSC user.

3. Click Upload.

4. Select the option to create a new album using a TSV mapping.

5. Click Browse.

6. Select the TSV.txt file and all corresponding image and video files identified in the .txt file for 
upload.

7. Click Open.

8. If no errors are found with the TSV file, click Upload to continue with the upload process.

Symptom If you map two or more albums to the same content item, the content upload will not complete, 
and the album creation is not completed.

Workaround Break up the TSV into separate files so that no single TSV file refers to the same piece of 
content twice.

CSCtz38763—In SSC when using TSV for content upload, the progress bar does not show completion fraction properly.

Conditions The following steps recreate the conditions when this defect occurs:

1. Create a TSV file (Unicode text encoding) with multiple content pieces identified. 

2. Log into the Cisco StadiumVision Director SSC portal as an SSC user.

3. Click Upload.

4. Select the option to create a new album using a TSV mapping.

5. Click Browse.
47
Release Notes for Cisco StadiumVision Director Release 3.0

 



 

  Caveats
6. Select the TSV.txt file and all corresponding image and video files identified in the .txt file for 
upload.

7. Click Open.

8. If no errors are found with the TSV file, click Upload to continue with the upload process.

Symptom The content upload progress bar does not properly display the count of content that has already 
has been completed. Instead, it displays “NaN/NaN files” and no numbers.

Workaround There is no workaround. This is a cosmetic defect only and no functionality is affected.

CSCtz38926—Some video file extensions missing from the TSV file browser filters.

Conditions The following steps recreate the conditions when this defect occurs:

1. Log into the Cisco StadiumVision Director SSC portal as an SSC user.

2. Click Upload.

3. Select the option to create a new album using a TSV mapping.

4. Click Browse.

Symptom The TSV file browser filter does not show the following supported file extensions: *.mpeg, 
*.m2t and *.m2ts. Therefore, user cannot include files with those extensions. 

Workaround Rename the extension of the video file to “.mpg”. 

CSCtz39461—User is not notified if an SSC album fails to publish to a DMP.

Symptom The SSC user is not warned when publishing of an album to a DMP fails. The user only sees 
the album thumbnail appearing to be stuck with the published percentage superimposed on the 
thumbnail. The album stays in this state and no warning is provided to the user.

Workaround Contact the Cisco StadiumVision Director administrator to verify the status of the DMP.

CSCtz51366—PoS interval store sync fails to update if store refresh is occurring.

Conditions The following steps recreate the conditions when this defect occurs:

1. Log into Cisco StadiumVision Director with a role that supports DMB configuration.

2. Click Dynamic Menu Boards.

3. Click Stores. 

4. Click Browse All. 

5. Select a store (from either Quest, Cisco, or Micros vendor). 

6. Change the value of the Sync Interval (hours) option on the right side panel.

7. Click Sync store.

8. Click Save Sync Interval. 

9. Click Refresh.
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Symptom If a store refresh is currently occurring, the change to the Sync Interval value is not saved and 
returns to the last value set, and the Last updated timestamp remains unchanged.

Workaround Avoid saving the store sync interval while a store refresh is occurring. 

CSCtz53578—SSC video albums do not change to unpublished state after adding a DMP.

Conditions The following steps recreate the conditions when this defect occurs:

1. Log into the Cisco StadiumVision Director SSC portal as an SSC user.

2. Create at least one video and one image album.

3. Publish all albums and wait for them to successfully finish (green state).

4. Log off and log into Cisco StadiumVision Director as an administrator.

5. Click Control Panel.

6. Go to Setup > Luxury Suites and add a new DMP to the suite that the SSC albums are associated 
with. 

7. Go to Setup > User Management and authorize the suite and TV for the DMP that you just added 
for the SSC user. 

8. Log off and once again, and log into Cisco StadiumVision Director SSC portal with the SSC user 
account.

Symptom The SSC albums with images reflect that they need to be published again (returned to pink 
state) since a new DMP was added to the set of authorized TVs for the SSC user. However, none of the 
video albums returned to an unpublished state (pink). Instead, they remain in published state (green). 

Workaround Inform the SSC that a new authorized TV was added to the account and that all albums must 
be republished. 

CSCtz62446 —IP phone fails to load home screen when Control Server is restarted.

Symptom If an SSC album is being controlled on an IP phone when the Control Server is restarted by an 
administrator, the home screen on the phone cannot be displayed.

Workaround There is no workaround. After the initial exception is displayed, it will not be seen again 
after the control server cache is rebuilt. 

CSCtz67229—In the Display Specifications Basic Info tab the Save button is disabled and certain fields cannot be saved.

Conditions The following steps recreate the conditions when this defect occurs:

1. Log into Cisco StadiumVision Director.

2. Click Control Panel.

3. Go to Setup > Devices > Display Specifications.

4. Select an existing device.

5. On the Basic Info tab, change the setting for the Volume Strategy option.
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Symptom The Save button is disabled.

Workaround Make a change in the Device Name field to enable the Save button. 

CSCtz70439—In VDM when a filename has more than one period character, an invalid file extension is assigned to it.

Conditions The following steps recreate the conditions when this defect occurs:

1. Change a valid video filename (a video that would be playable by DMP) to have at least 2 periods 
in it. For example: homevideo.mpeg to home.video.mpeg 

2. Log into Cisco StadiumVision Director.

3. Click Video Distribution Manager.

4. Upload the renamed video file to VDM, activate it, and assign to an existing group. 

5. Navigate to the Video Activation page. 

Symptom When video files use long filenames with more than one period in them, VDM creates an alias 
for the video filename that is parsed from the beginning of the character string up through the second 
period, dropping any remaining characters in the original filename that occur after the second period. 
For example, if a file is named “home.video.mpeg,” its alias [and filename uploaded to the DMP(s)] 
becomes “home.video.” which leaves the file without a valid video file extension.

Workaround Only use video filenames with a single period followed by the file extension.

CSCtz71231—In Management Dashboard, DMPs will cycle between critical and normal.

Symptom In the Management Dashboard, once a DMP is provisioned and appears in Normal state, it will 
sometimes change to Critical state for no apparent reason and then change back to Normal state again. 

Workaround To immediately fix the issue, run a Get Status and all DMPs without problems will show the 
Normal green state. 

CSCtz80980—Template modification does not appear in Schedule tab until UI is reloaded.

Conditions You have created a template with a video region and an event script is configured using the 
template in one of its states. The following steps recreate the conditions when this defect occurs:

1. Log into Cisco StadiumVision Director.

2. Click Control Panel.

3. Go to Control.

4. Start the pre-configured event script. 

5. Go to Setup > Template Editor.

6. Change the tested template by modifying the video region to a non-video region. 

7. Change the region name. 

8. Refresh the templates screen.

9. Go to Control and stop the event script. 

10. Go to Schedule. 
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11. Select the state for the tested template. 

Symptom On the Schedule screen, the template's region type remains video, and the name is unchanged.

Workaround Reload the UI.

CSCtz83815—After system restore video thumbnails in content manager can become orphaned due to missing actual video 
content.

Conditions The following steps recreate the conditions when this defect occurs:

1. Upload the valid video contents/ files into Cisco StadiumVision Director using the Video 
Distribution Manager.

2. Perform the data backup.

3. Perform a fresh installation of Cisco StadiumVision Director.

4. Perform the restore.

Workaround Add the missing video files to Cisco StadiumVision Director.

CSCtz83852—Occasionally icons for orphaned external video content are unable to be deleted in Content Manager.

Symptom If the external video content icons in the Content Manager are orphaned by missing actual 
video content in the file system (sometimes through the backup/restore process) they occasionally 
become unable to be deleted. 

Workaround Reload the UI. 

CSCtz84039—An SQL upgrade script will fail if there are duplicate names in certain database tables during a software upgrade.

Conditions If there any duplicate names in the following tables, an SQL upgrade script will fail during 
an upgrade to Cisco StadiumVision Director Release 3.0:

• Device specifications 

• Channel names 

• Channel number 

• Channel guide name 

• Group name 

• Zone name 

• Script name 

• Playlist name 

Symptom The particular SQL upgrade script will fail, but the software upgrade itself will proceed.

Workaround Prior to upgrading from Cisco StadiumVision Director Release 2.4, verify that you do not 
have duplicate entries in the areas listed under the Conditions for this defect. A script is available from 
Cisco.com to help detect duplicate entries in your system. For more information about upgrading your 
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system and checking for duplicate entries, see the “Upgrading a Cisco StadiumVision Director Server 
From Release 2.4 SP1 to Release 3.0” module of the Cisco StadiumVision Director Software Installation 
and Upgrade Guide, Release 3.0. 

CSCtz84669—Widget with missing graphic component will not be displayed on DMP screen.

Conditions The following steps recreate the conditions when this defect occurs:

1. Create a widget and place a graphic component on the canvas but don't assign a graphic element to it. 

2. Create a script with a state that will display this widget. 

3. Run the script and select the widget state. 

Notice the widget does not appear. 

4. Stop the script and edit the widget to assign a picture to the graphic component, and start the script 
again. 

Notice the widget now displays. 

Workaround Be sure that all graphic components in a widget have graphic elements assigned to them. 

CSCtz84745—Unable to stop event script within 5 seconds of start.

Conditions The following steps recreate the conditions when this defect occurs:

1. Be sure that you have an Event script available to run. 

2. From the Control Panel, start an event script. 

3. Within 5 second stop the event script. 

Symptom “Stale Data” message is displayed and the event is not stopped.

Workaround Wait 10-20 seconds before attempting to stop a script that you just started. 

CSCtz88984—In Control Panel, when you select a running script, the Control screen occasionally shows the states belonging to 
the previous script.

Conditions The following steps recreate the conditions when this defect occurs:

1. Log into Cisco StadiumVision Director.

2. Click Control Panel.

3. Click Control.

4. Make sure a script is running or start one.

5. Select a running script other than the currently running one. 

Symptom Occasionally the states shown on the right pane will not update and will continue to show the 
states belonging to the previously selected script. 

Workaround Click on another script, and then click on the desired script again to display the correct 
states. 
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CSCtz89886—Original method of content replacement does not always work as expected with the new Event-Time Content 
Replacement feature.

Conditions The following steps recreate the conditions when this defect occurs:

1. You have a script with State 2 using Playlist 2 with two images (1.png and 2.png,) and State 3 has 
Playlist 3 with two images (3.png and 4.png), all with a duration of 5 seconds. 

2. Start the script and move to State 2.

3. Using the original content replacement method, select Playlist 2 and select the Content Replacement 
icon while the script is running.

4. Replace 2.png with 3.png and replace 1.png with 4.png:

– Drag 2.png to the From column and 3.png to the To column. 

– Drag 1.png in the From column and 4.png to the To column.

Note 3.png and 4.png display on screens.

5. Update the duration of Playlist 2 to 6 seconds.

The screens display 3.png and 1.png rotating instead of the expected 3.png and 4.png.

6. In the Content Replacement screen, remove the mappings from Step 4.

The screens show 3.png and 2.png instead of the expected 1.png and 2.png.

Workaround Restart the flash template. Avoid using the old and new content replacement methods 
together. To replace content using the new method in 3.0, turn Auto Save off for the playlist, and add or 
update only one item at a time. Add the new item A1 to replace existing item A and save. Remove 
original item A from the playlist and save. 

CSCtz89979—Album presentation widget will not load if the SSC album size is greater than 70 items.

Conditions The following steps recreate the conditions when this defect occurs:

1. Log into the Cisco StadiumVision Director SSC portal as an SSC user.

2. Create a new album.

3. Upload exactly 70 items to an album. 

4. Publish the album.

5. Using an IP phone, script, or User Control API for album control, select the album to load it. 

Note The album loads normally and will respond to commands (play, next, previous, and so on). 

6. Stop the album and exit.

7. Add a single content item to the album you created so that it now has 71 items in it. 

8. Publish the album again.

9. Using an IP phone, script, or User Control API for album control, select the album to load it. 
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Symptom An SSC album does not load when it has more than 70 items in it.

Workaround Limit the number of items in an album to no more than 70.

CSCtz92543—Unable to unlink a Device from the Location through the UI.

Conditions The following steps recreate the conditions when this defect occurs:

1. Go to Control Panel > Setup > Devices > Location.

2. Select the DMP Mapping tab.

3. Select a location and click Unlink. 

Symptom The following appears in the UI:

:false
Destination Device is null

Workaround Do one of the following:

• Use an exported BAT file to perform the unlink operation. 

or 

• Remove the DMP+Location and then add them both back. 

CSCtz92581—After link/unlink operation the UI does not refresh to show changes.

Conditions The following steps recreate the conditions when this defect occurs:

1. Log into Cisco StadiumVision Director as an administrator.

2. Go to Control Panel > Setup > Devices > Location.

3. Select the DMP Mapping tab.

4. Select a Location that does not currently have a DMP mapped on the right pane. 

5. Select a Device in the left pane. 

6. Click Link. 

Symptom The UI does not refresh automatically to show the change.

Workaround Reload the UI by clicking the Refresh icons on both panes.

CSCtz95001—Emergency status will not show on IP Phone when it is controlling an album.

Conditions The following environment is configured in Cisco StadiumVision Director when this problem 
occurs:

• An SSC album has been created.

• An event script with an emergency state has been configured. 

• An IP phone has been configured with one of the IP phone ContentOnDemand service types to 
support the display of SSC albums.
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The following steps recreate the conditions when this defect occurs:

1. Start the event script. 

2. Play the album using the IP phone touch pad.

3. Start the emergency state in the script.

Symptom The emergency state is displayed on the TV, but the corresponding emergency message does 
not appear on the IP phone as expected.

Workaround There is no workaround. However, the TV display will continue to display the emergency 
state. 

CSCtz97126—User Control API command to set Closed Captioning does not work.

Conditions The following steps recreate the conditions when this defect occurs:

1. Log into Cisco StadiumVision Director as an administrator.

2. Click Control Panel.

3. Go to Setup > Luxury Suite.

4. Create a new suite and assign at least one DMP to it. 

5. Establish a Visitor or Fixed PIN for the suite. 

6. Click Save.

7. With the User Control API, get the ID of the DMP(s) that you added to your newly created suite. 

8. Using the ID info and PIN, set the DMP’s closed captioning setting. For example:

curl -k -u "12685:" 
https://10.194.171.36/sv-openapi/ws/rest/localcontrol/control/player/cc/CC2/1036 

Symptom The CC setting in the DMP is not changed.

Workaround Configure the CC option using the Management Dashboard or IR remote. 

CSCua12465—Content update while an event script is running fails if more than one image is changed at a time.

Symptom While an event script is running, if you add or update more than one content item to the active 
playlist in the Content screen, only one item is displayed on the TV. 

Workaround Only add or update one image at a time. If you do add more than one image, restart the flash 
template to correct what is displayed on the TV.
55
Release Notes for Cisco StadiumVision Director Release 3.0

 



 

  Related Documentation
Resolved Defects in Cisco StadiumVision Director Release 3.0.0-247
Table 14 lists the defects that are resolved in Cisco StadiumVision Director Release 3.0.0-247 that were 
open in Cisco StadiumVision Director Release 2.4.0-147.

Related Documentation
For more information about Cisco StadiumVision hardware and software installation, configuration, and 
operation, see the Cisco StadiumVision documentation available on Cisco.com at: 
http://www.cisco.com/en/US/products/ps11274/tsd_products_support_series_home.html

Obtaining Documentation and Submitting a Service Request
For information on obtaining documentation, submitting a service request, and gathering additional 
information, see the monthly What’s New in Cisco Product Documentation, which also lists all new and 
revised Cisco technical documentation, at:

http://www.cisco.com/en/US/docs/general/whatsnew/whatsnew.html

Subscribe to the What’s New in Cisco Product Documentation as a Really Simple Syndication (RSS) feed 
and set content to be delivered directly to your desktop using a reader application. The RSS feeds are a free 
service and Cisco currently supports RSS Version 2.0.

This document is to be used in conjunction with the documents listed in the “Related Documentation” section.

Cisco and the Cisco logo are trademarks or registered trademarks of Cisco and/or its affiliates in the U.S. and other countries. To view a list of 
Cisco trademarks, go to this URL: www.cisco.com/go/trademarks. Third-party trademarks mentioned are the property of their respective owners. The 
use of the word partner does not imply a partnership relationship between Cisco and any other company. (1110R)

Any Internet Protocol (IP) addresses and phone numbers used in this document are not intended to be actual addresses and phone numbers. Any 
examples, command display output, network topology diagrams, and other figures included in the document are shown for illustrative purposes only. 
Any use of actual IP addresses or phone numbers in illustrative content is unintentional and coincidental.

© 2012 Cisco Systems, Inc. All rights reserved.

Table 14 Resolved Defects in Cisco StadiumVision Director Release 3.0.0-247

Resolved Defect 
Numbers Description of Original Defect

CSCts45345 Unable to delete a luxury suite if no IP Phone or 3rd Party Controller is 
assigned. 

CSCts67455 BAT—No confirmation on status of imported devices.
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