Сетевые средства MS Windows

Руководство по разработке и реализации сетей Windows

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание

Связанные обсуждения сообщества поддержки Cisco

Введение

Термин «сети» охватывает широкое многообразие технологий, которые, будучи применены в комплексе, делают возможным обмен информацией между компьютерами. Элементы сети условно подразделяются на приложения оконечных систем, сетевые операционные системы и сетевое оборудование.

Сетевая операционная система является программным обеспечением, работает на всех взаимосвязанных системах. Примеры включают Операционную систему Novell NetWare, NFS Sun (Файловая система сети), AppleShare и реализация Microsoft сетевой операционной системы обычно под названием Cетевые технологии на базе Windows. Cетевые технологии на базе Windows теперь экстенсивно развернуты с миллионами узлов.

Это руководство по дизайну объясняет базовые понятия Cетевых технологий на базе Windows и предоставляет понимание о том, как разработать сети (LAN и глобальные сети (WAN)) для лучшего использования этой операционной системы. Руководство также объясняет протоколы, обозначение и проблемы масштабирования, привязанные к Cетевым технологиям на базе Windows.

Перед началом работы

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Предварительные условия

Для данного документа отсутствуют предварительные условия.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Сведения, представленные в этом документе, были получены от устройств в специфической лабораторной среде. Все устройства, используемые в этом документе, были запущены с чистой конфигурацией (конфигурацией по умолчанию). При работе с реальной сетью необходимо полностью осознавать возможные результаты использования всех команд.

Что такое cетевые технологии на базе Windows?

Cетевые технологии на базе Windows обращаются к сетевой системе, разделенной программным обеспечением, которое идет со всеми придерживающимися операционными системами Microsoft или серверами:

  • Диспетчер локальной сети Microsoft

  • MS-DOS с Клиентом диспетчера LAN

  • Windows для рабочих групп

  • Windows 95/98, 98, и ME

  • Windows NT и 2000

Диспетчер локальной сети Microsoft, Клиент диспетчера LAN для MS-DOS и Windows NT 3.1 не обсуждены в этом документе кроме исторического контекста.

Домены по сравнению с рабочими группами

Cетевые технологии на базе Windows имеют три понятия группы связанных компьютеров - рабочие группы, домены и иерархия домена. Рабочие группы могут быть любым логическим объединением компьютеров; любой компьютер в сети может присоединиться к существующей рабочей группе или создать новую. Больше формальных единиц, домены создаются и управляются процессом контроллера первичного домена (PDC), который работает на Windows NT или Сервере Windows 2000. Домен имеет безопасность и административные свойства, которые не делает рабочая группа. Каждый домен должен иметь по крайней мере один NT или сервер 2000 года, который ответственен за процесс PDC, сведения об учетной записи пользователя в домене и безопасность в домене. Сетевые домены Windows не являются тем же как названиями Интернет-домена, как используется Системой доменных имен (DNS). Иерархия иерархии домена или Active Directory является набором доменов, организованным в родительско - дочерние отношения. Это соглашение, начатое с Windows 2000, включает более простой поиск составных доменов в едином запросе (среди прочего). Это тщательные сопоставления иерархий к Пространству имен DNS.

Какой протокол это использует?

До Windows 2000 Cетевые технологии на базе Windows использовали Протокол NETBIOS для общего файла, общего принтера, обмена сообщениями, аутентификации и разрешения имен. Чистая установка Windows 2000 потребовала бы NetBIOS только для совместимости с более ранними версиями Cетевых технологий на базе Windows с помощью однородного пространства имен NetBIOS. NetBIOS является протоколом уровня сеанса, который может работать на любом из придерживающихся транспортных протоколов:

  • NetBEUI (NetBIOS по LLC2)

  • NWLink (NetBIOS по Internetwork Packet Exchange [IPX])

  • NetBIOS по TCP (NBT)

Несмотря на то, что Microsoft рекомендует, чтобы клиенты использовали только один транспортный протокол за один раз для максимальной производительности, эта настройка является только по умолчанию для Windows 2000. Необходимо выбрать протокол, чтобы использовать для всей сети, предпочтительно TCP/IP, и затем выключить другие протоколы, потому что Сервис имен netbios поддерживает информацию об именах компьютера (пространство имен) отдельно для каждого транспорта. Пространства имен не взаимодействуют друг с другом; каждый транспорт действует в качестве отдельной сети.

NetBEUI (NetBIOS по LLC2) является наименее масштабируемым из трех протоколов, потому что это должно быть соединенный. NetBEUI включен только для поддержки очень старых сервисов (например, старые версии LAN Manager). NetBEUI не требует никакой настройки адреса клиента. Нет никакого неподвижного предела количеству Windows - клиентов, может иметь с NetBEUI, но это характерно для этого решения столкнуться с проблемами производительности, поскольку количество клиентов в одной группе мостов выходит за предел 50 - 100 пользователей. Когда трафик должен пересечь канал WAN, плоская топология и уверенность в широковещательных сообщениях не масштабируются, особенно.

NWLink уже рекомендован только для сетей рабочий IPX, который не может быть обновлен для использования TCP/IP. Подобный NetBEUI, NWLink не требует никакой настройки адреса клиента. NWLink использует пакеты type-20 IPX для обмена регистрацией и данными просмотра. Для передачи пакетов IPX type-20 по маршрутизаторам Cisco необходимо настроить распространение IPX, тип 20 на каждом интерфейсе на каждом маршрутизаторе в сети.

Рекомендуется использовать NetBIOS по TCP (NBT) для большинства сетей, или каждый раз, когда сеть включает глобальную сеть (WAN). Так как NBT использует TCP/IP, каждый компьютер должен быть настроен, чтобы использовать статический IP - адрес или выбрать IP-адрес динамично с Протоколом DHCP (динамического конфигурирования узла). Для простоты администрирования сети это настоятельно рекомендовано для использования DHCP; для оптимальной производительности сети это настоятельно рекомендовано для использования (Сервис имен Интернета для Windows) сервера WINS также. Сервер WINS позволяет клиентам получать данные просмотра, не имея необходимость к широковещательным запросам каждый раз. Существует прямая корреляция между количеством широковещательных сообщений в сети и производительностью сети; широковещательные сообщения необходимы для сети для функционирования, но уменьшение их может быть важным.

Cisco рекомендует, чтобы большинство клиентов использовало TCP/IP для Cетевых технологий на базе Windows. Объем этого руководства по дизайну фокусируется на дизайнах с помощью NBT.

Адресация динамического IP

Что такое DHCP?

Вручную адресация к клиентам TCP/IP является и трудоемкой и подверженной ошибкам. Для решения этой проблемы инженерная группа по развитию Интернета (IETF) разработала DHCP, протокол динамической конфигурации хоста. DHCP разработан для автоматического обеспечения клиентов действительным IP - адресом и информацией о связанной конфигурации (см. Параметры DHCP раздела ниже). Каждый диапазон адресов, которыми управляет DHCP server, называют областью.

Области DHCP

Необходимо настроить диапазон адресов для каждой IP-подсети, где клиенты запросят адрес DHCP; каждый диапазон адресов называют областью DHCP. Можно настроить DHCP server для обслуживания нескольких областей начиная с DHCP server, или серверы не должны быть физически связаны с той же сетью как клиент. Если DHCP server находится на другой IP-подсети от клиента, то необходимо использовать ретранслятор DHCP для передачи запросов DHCP DHCP server.

Ретрансляция DHCP

Ретранслятор DHCP, как правило, работает на маршрутизаторе, и поддержка ретрансляции доступна на версии 4.0 Сервера Windows NT Server и Сервере Windows 2000. На Маршрутизаторах серии Cisco 700 можно включить ретранслятор DHCP с командой set dhcp relay. Можно включить ретранслятор DHCP на маршрутизаторе Cisco IOS путем настройки ip helper-address с адресом DHCP server на каждом интерфейсе, который будет иметь клиентов DHCP. Команда ip helper-address вперед много других IP - трансляций, включая DNS, Протокол TFTP и пакеты Сервиса имен netbios. Для передачи только запросов DHCP посмотрите конфигурацию следующего примера. Для получения дополнительной информации посмотрите Секцию "configuring broadcast handling" в Руководстве по конфигурации сетевых протоколов, Первой части.

no ip forward-protocol udp tftp

no ip forward-protocol udp dns

no ip forward-protocol udp time

no ip forward-protocol udp netbios-ns

no ip forward-protocol udp netbios-dgm

no ip forward-protocol udp tacacs

ip forward-protocol udp bootpc

!

interface ethernet 0

ip helper-address 172.16.12.15

interface ethernet 1

ip helper-address 172.16.12.15

Параметры DHCP

В дополнение к его IP-адресу клиент DHCP может получить другие сведения о конфигурации TCP/IP от DHCP server, включая маску подсети, шлюз по умолчанию и Информацию DNS. Эти части информации, названные параметрами DHCP, могут быть настроены в Диспетчере DHCP на Windows NT или DHCP server Windows 2000.

Рис. 1: Диспетчер DHCP Microsoft

/image/gif/paws/10624/winnt_d0.gif

Если клиенты используют Сервис имен Интернета для Windows (WINS) для разрешения имен (обсудил позже), необходимо настроить адрес сервера WINS и Типа узла WINS. Краткий список типов узла включен в Раздел "Разрешение имен". P-node типа узла (0x2) строго рекомендуется.

Серверы Cisco DHCP

Cisco в настоящее время имеет интегрированный DHCP и сервер DNS для Windows NT, Windows 2000 и UNIX; сервер имеет графический интерфейс, поддержку дополнительной адресации и много других корпоративных характеристик. Маршрутизаторы серии Cisco 700 (в Выпуске 4.1 и позже) и маршрутизаторы Cisco IOS (в Релизе 11.2 (7) f и позднее) также включают DHCP server, который может назначить адреса на сегментах локальной сети. Оба стиля маршрутизатора включают переадресацию сетевого и уровня порта.

Разрешение имен

Разрешение имен является процессом соединения удобного названия, такого как FRED или fred.domain.com, с сетевым адресом (часто IP-адрес). Для текущих целей это обсуждение применяется к способу, которым Cетевые технологии на базе Windows решают NetBIOS уникальное название рабочей станции (описанный как WORKSTATION <00> в последующем разделе) к IP-адресу. Этот процесс не должен быть перепутан со связанным, но другим процессом просмотра (который использует другие типы Имен NETBIOS). С выпуска Microsoft Windows 2000 клиенты Cетевых технологий на базе Windows используют до пяти методов разрешения имен:

  • NetBIOS name cache

  • Широковещательные сообщения IP-подсети

  • LMHOSTS

  • WINS

  • Интернет-DNS

NetBIOS Name Cache

Cетевые технологии на базе Windows поддерживают маленький кэш недавно используемых Имен NETBIOS к Сопоставлениям IP-адресов. Эти записи добавлены после успешного разрешения имен и затем удалены после некоторого периода времени. Дополнительные записи могут быть предварительно загружены при запуске системы и сделаны постоянные путем создания записи в файле LMHOSTS с меткой #PRE (см. раздел LMHOSTS ниже).

Широковещательные сообщения IP-подсети

Широковещательные сообщения IP-подсети могут использоваться для разрешения имен. Широковещательные сообщения получены всеми компьютерами на подсети, требуя времени обработки в каждом компьютере. Cетевые технологии на базе Windows также поддерживают назначенное ведущее устройство обзора, которое ведет список всех ресурсов, доступных на подсети. Процесс голосования, который использует широковещательные сообщения, определяет это ведущее устройство обзора, потому что регистрация, выборы обозревателя и запросы имени могли все генерировать широковещательные сообщения, использование метода разрешения имени широковещания не рекомендуется.

LMHOSTS

Cетевые технологии на базе Windows могут консультироваться со статической таблицей в файле, названном LMHOSTS. Для использования этого метода PDC должен поддержать самое меньшее статический список всех компьютеров и их IP-адресов в том домене и именах и адресах PDC для всех других доменов в сети. У всех клиентов должен тогда быть файл LMHOSTS с IP-адресом их PDC и пути к основному файлу LMHOSTS на PDC.

Служба имен Интернет для Windows

WINS был создан, чтобы позволить клиентам на других IP-подсетях динамично решать адреса, регистрировать себя и просматривать сеть, не передавая широковещательные сообщения. Клиенты передают одноадресные пакеты к серверу WINS в известном адресе. Для совместимости с клиентами Клиента Microsoft Networking старшего возраста, однако, разрешение имени широковещания все еще включено по умолчанию, даже когда также настроен WINS.

Для повторения, что было вышеизложенным это настоятельно рекомендовано для оптимальной производительности сети для использования WINS. Снова, существует прямая корреляция между количеством широковещательных сообщений в сети и производительностью сети; широковещательные сообщения необходимы для сети для функционирования, но уменьшение их может быть важным.

Интернет-DNS

Любой сервер DNS может быть настроен статически для ответа на запросы для компьютеров с фиксированными IP - адресами. Если компьютеры в сети имеют фиксированные IP - адреса, этот сценарий полезен. Когда Системы Windows используют DHCP, чтобы заставить IP-адрес и WINS регистрировать Имя NETBIOS, можно установить Windows DNS server для запроса сервера WINS для названий или адресов, которые не были введены статически. В обоих случаях Windows и отличные от Windows система могут решить IP-адреса правильно.

Если администратор настраивает каждый сервер сети Windows со статическим IP - адресом, может быть удобно ввести каждый сервер в DNS - систему и DNS использования для разрешения имен. Иногда (например, при использовании соединения с соединением по требованию) удобно зарегистрировать клиенты в WINS и сделать запросы с DNS. Microsoft NT 3.51 Resource Kit, Сервер Windows NT 4.0 и Windows 2000, все включают сервер DNS, который может ответить на запросы DNS путем запроса сервера WINS в фоновом режиме. Для получения дополнительной информации о том, как настроить эту архитектуру, посмотрите Приложение A.

С Windows 2000 серверы DNS могут также быть динамично настроены с преобразованиями адресов в имена. Клиенты DHCP, Dhcp server и серверы динамических DN сотрудничают для обновления названия к сопоставлениям адресов в сервере DNS. DHCP server выполнит это обновление для клиентов DHCP 2000 года не-Windows.

Рис. 2: Windows и отличные от Windows система оба передают Поиски DNS за Сервером Windows NT Server под названием Бородавочник. Сервер DNS не имеет записи для Бородавочника, таким образом, это делает запрос сервера WINS и возвращает IP-адрес.

/image/gif/paws/10624/winnt_d1.gif

Порядок поиска имени

Компоненты cетевых технологий на базе Windows передают запросы разрешения имен в другом заказе, в зависимости от типа узла NetBIOS. Если системой является Windows NT 4.0, и название более длинно, чем 15 символов, то Windows NT передает только запрос DNS. Другие сетевые компоненты и сервисы могут также использовать другой заказ в зависимости от API, вызванного для выполнения разрешения имен. Например, приложение сокетов вызывает gethostbyname () будет использовать DNS для разрешения имен сначала. В противном случае поиск имени выполнен в следующем порядке:

  • Проверьте NetBIOS name cache.

  • Передайте широковещательный запрос или имя запроса WINS, в зависимости от текущего типа узла NetBIOS.

  • Проверьте файл LMHOSTS.

  • Проверьте Файл hosts (если "решение с помощью DNS" проверено).

  • Передайте интернет-запрос DNS (если решение с помощью DNS проверено).

Таблица 1: Имена NETBIOS ищутся по-другому на основе типа узла NetBIOS

Тип узла NetBIOS Порядок поиска имени
b-узел (0x1) Широковещание только
p-node (0x2) WINS только
m-узел (0x4) Широковещание, затем WINS
h-узел (0x8) WINS, затем широковещание

Microsoft LAN Services Browser

Cетевые технологии на базе Windows были первоначально разработаны для работы сегмента одиночной LAN или соединённой мостом (плоской) сети. В то время только протокол NetBEUI поддерживался.

Microsoft разработала Браузер Сервисов LAN (локальной сети), чтобы позволить пользователю просмотреть список всех компьютеров, доступных в сети. Каждый клиент Cетевых технологий на базе Windows периодически регистрировал его Имя NETBIOS путем передачи широковещательных сообщений.

Каждый компьютер также должен был передать широковещательные сообщения для избрания ведущего устройства обзора для сети. Ведущее устройство обзора (и несколько резервных ведущих устройств обзора) вели список компьютеров и их адресов. Когда пользователь просмотрел сеть, клиент передал широковещательный запрос, и одно из ведущих устройств обзора ответило.

В конечном счете Microsoft добавила поддержку NetBIOS по IPX и NetBIOS по TCP/IP, но Cетевые технологии на базе Windows все еще предположили, что все клиенты и серверы были на том же логическом IPX network или IP-подсети---, они все еще передали широковещательные сообщения, чтобы зарегистрировать и найти компьютеры в сети.

Эта архитектура, невзирая на то, что простой для осуществления, генерировала огромную нагрузку в сети и в ЦПУ каждого клиента в сети. Из-за этих проблем масштабируемости Microsoft начала предлагать другие методы просмотра и разрешения имен---способы для клиентов сопоставить название к IP-адресу других компьютеров в сети. В конечном счете Microsoft также предоставила способ просмотреть и решить названия без широковещательных сообщений.

Остаток этого раздела объясняет, как просмотр работает в различных средах. Предыдущий раздел объяснил, как решены отдельные Имена NETBIOS. Эти два действия являются подобными, но отдельными. Пользователи просматривают сеть при открытии сетевого окружения, использовании чистой команды view или вхождении в Домен Windows NT при запуске. Разрешение имен является процессом решения названий, ранее известных или найденных при просмотре. Обратите внимание на то, что это обсуждение не связано друг с другом к Web-браузерам.

Имена NETBIOS

Имена NETBIOS составляют 15 символов, прописные названия, которым добавили специальный идентификатор к 16-му байту. Также, Имена NETBIOS могут примениться к (уникальному) одному IP-адресу, или к нескольким (группа). Некоторые типы названия могут быть или уникальными или имена групп. Некоторые наиболее распространенные из этих последних знаков перечислены следующим образом (все значения находятся в шестнадцатеричном):

Таблица 2: Частичная Таблица Специальных Имен NETBIOS и их Описаний

Зарегистрированные специальные имена Описание
Имя пользователя
<USERNAME> <00> Используемый для регистрации названия в настоящее время зарегистрированного пользователя в базе данных WINS, так, чтобы пользователи могли получить команды net send, передаваемые их именам пользователей.
Имена компьютера
<COMPUTER> <00> Используемый рабочими станциями Клиента Microsoft Networking для получения запросов почтовой ячейки второго класса. Все рабочие станции должны добавить это название для получения запросов почтовой ячейки. Это - имя компьютера, зарегистрированное для служб рабочей станции клиентом WINS.
<COMPUTER> <03> Используемый в качестве имени компьютера, которое зарегистрировано для сервиса сообщений на компьютере, который является клиентом WINS.
<COMPUTER> <20> Используемый в качестве названия, которое зарегистрировано для сервиса однорангового сервера на компьютере Windows 95/98 (или сервис сервера на компьютере Windows NT), который является клиентом WINS.
<КОМПЬЮТЕР> <Быть> Используемый в качестве уникального имени, которое зарегистрировано, когда Агент для мониторинга сетей Network Monitor запущен на компьютере.
<КОМПЬЮТЕР> <Bf> Используемый в качестве имени группы, которое зарегистрировано, когда Агент для мониторинга сетей Network Monitor запущен на компьютере. Если это название не составляет 15 символов в длине, оно дополнено плюс (+) символы.
<КОМПЬЮТЕР> <1f> Используемый в качестве уникального имени, которое зарегистрировано для сетевого динамического обмена данными (DDE), когда сервис NetDDE запущен на компьютере.
Имена групп
<01> <02> MSBROWSE <02> <01> Используемый серверами основного обозревателя для периодического объявления об их домене на локальной подсети. Это объявление содержит доменное имя и название сервера основного обозревателя для домена. Кроме того, серверы основного обозревателя получают эти уведомления домена к этому названию и поддерживают их в их внутреннем списке просмотра вместе с именем компьютера диктора.
<DOMAIN> <00> Используемый рабочими станциями и серверами к объявлениям обработки сервера для поддержки диспетчера локальной сети Microsoft. Серверы, выполняющие Windows 95/98, Windows NT, Сервер Windows NT Server и Windows для рабочих групп, не передают это название, пока параметр LMAnnounce не включен в свойствах сервера.
<DOMAIN> <1b> Используемый для определения названия основного обозревателя домена, которое является уникальным именем, что только может добавить контроллер первичного домена (PDC). PDC обрабатывает запросы GetBrowserServerList на этом названии. WINS предполагает, что компьютер, который регистрирует доменное имя в символе <1b>, является PDC.
<DOMAIN> <1c> Используемый для интернет-имени группы, которое регистрируют контроллеры домена. Интернет-имя группы является динамическим списком до 25 компьютеров, которые зарегистрировали название. Это - название, используемое для обнаружения компьютера Windows NT для сквозной аутентификации.
<DOMAIN> <1d> Используемый для определения основного браузера (не основной обозреватель домена). Основной браузер добавляет это название как уникальное имя NetBIOS, когда это запускается. Рабочие станции объявляют о своем присутствии этому названию так, чтобы основные браузеры могли создать свой список просмотра. Для рабочих групп это название имеет форму <РАБОЧАЯ ГРУППА> <1d>.
<DOMAIN> <1e> Используемый для всей рабочей группы или для всего домена объявлений серверов обозревателя в сетевой рабочей группе Windows или домене Сервера Windows NT Server. Это название добавлено всеми серверами обозревателя и возможными серверами в рабочей группе или домене. Все пакеты выбора обозревателя переданы к этому названию. Для рабочих групп это название имеет форму <РАБОЧАЯ ГРУППА> <1e>.

Процесс запуска

На запуске любая сетевая система передает серию пакетов, чтобы обнаружить сетевые адреса, сам регистр, подтвердить подлинность себя и обнаружить сервисы. Системы Cетевых технологий на базе Windows, которые входят в Домен Windows NT, должны связаться с контроллером домена для аутентификации. Этот процесс использует разрешение имен и просмотр.

Сначала система запуска должна зарегистрировать имя компьютера (WORKSTATION <00>). Если параметр объявления LM идет (для совместимости с серверами LAN Manager), то система также регистрирует DOMAIN <00>. Затем система определяет местоположение контроллера домена для домена входа в систему путем попытки решить DOMAIN <1C>. До Windows 2000 это работало только с широковещанием, LMHOSTS или методами разрешения имен WINS. С Windows 2000 DNS пробуют сначала. Затем, системные журналы на контроллере домена с помощью основанных на NetBIOS сообщений почтового ящика, которые передаются на порту протокола пользовательских датаграмм (UDP) 138. Наконец, после того, как вход в систему успешен, система регистрирует пользователя, который вошел в систему (USERNAME <03>), таким образом, сервис сообщений может найти того пользователя.

Обнаружение компьютера

Когда запросы пользователя ресурс на компьютере по имени (например: чистое использование \\fred\someshare, или находит FRED), локальная система пытается решить имя компьютера. Этот запрос для уникального имени NetBIOS типа <00>, или записи Файла hosts или DNS.

Просмотр сетевого окружения

Когда пользователь откроет сетевое окружение для запроса списка доменов, система попытается получить список резервных обозревателей, или посредством радиовещания к имени основного обозревателя или посредством непосредственно соединения с основным обозревателем домена (или оба). Как только список резервных обозревателей получен, система выберет резервный обозреватель, соединится с той системой и получит список доменов. Последующие запросы для серверов в домене переданы тому же резервному обозревателю.

Просмотр подсети

В 1980-х большинство сетей было "плоским", или имело только несколько подсетей. NetBEUI и NWLink используют эту модель, и IP - трансляции можно соединить или помочь по небольшому количеству подсетей. Придерживающееся обсуждение принимает случай фиксированной сети.

Каждая подсеть имеет основной обозреватель подсети на домен или рабочую группу и может иметь некоторые резервные обозреватели подсети (также на домен или рабочую группу). После загрузки резервные обозреватели и небраузеры передают широковещательные объявления в увеличивающихся интервалах 1, 2, 4, и 8 минут; они в конечном счете широковещательные объявления только каждые 12 минут. Основные обозреватели подсети слушают эти объявления для построения списка просмотра.

Основные обозреватели подсети и резервные обозреватели ответственны за ответ, просматривают запросы от других компьютеров. Основные браузеры могут ответить на эти запросы непосредственно от списка просмотра. Резервные обозреватели также поддерживают список просмотра, который они запрашивают от основного обозревателя подсети каждые 15 минут.

Широковещание, переходящее по подсетям

В действительности большинство сетей сегодня имеет несколько подсетей. Домены часто охватывают подсети, и подсети иногда содержат системы в нескольких доменах. Обозреватель в некоторых системах может связаться с основным обозревателем домена (обычно PDC) для обмена списками просмотра от многих подсетей, но это должно знать одиночный адрес основного обозревателя домена. Основной обозреватель подсети может получить одиночный адрес PDC от файла LMHOSTS (для подробного описания, посмотрите раздел Разрешения имен), или от WINS (см. следующий раздел).

LMHOSTS является текстовым файлом, который обозреватель может считать для обнаружения одиночного адреса PDC. Выборка придерживается. Сначала IP-адрес индивидуальной рассылки PDC, затем Имя NETBIOS PDC (ENG_PDC), метка, которая хранит эту линию в NetBIOS name cache, (#PRE) и наконец, метка, которая отмечает эту систему как контроллер домена для домена ENG (#DOM).

10.1.3.4 ENG_PDC #PRE #DOM:eng

Когда основной обозреватель подсети знает одиночный адрес основного обозревателя домена, браузеры обмениваются списками просмотра каждые 15 минут (использующий пакеты одноадресного IP - трафика). Поскольку с основным браузером консультируются, клиенты могут просмотреть только домены, которые имеют систему на локальной подсети (основной обозреватель подсети). На практике этот сценарий работает достаточно хорошо для обнаружения сервера входа в систему при запуске, но не позволяет пользователям просматривать использование сетевого окружения.

ВАЖНОЕ ПРИМЕЧАНИЕ: Из-за дефекта в некоторых версиях Windows для рабочих групп 3.11 и Windows 95/98, эти системы не могут функционировать как основной обозреватель подсети или резервный обозреватель. Дефект препятствует тому, чтобы обозреватель подсети связался с основным обозревателем домена. Эта ошибка была исправлена в OSR Windows 95/98 (Выпуск Сервиса OEM) 2. Если существует Win31 или основные браузеры Win95 или резервные обозреватели на подсети, в результате просмотр на подсети отказывает.

Просмотр любого домена с WINS

В организации с несколькими доменами не разумно спроектировать сетевое на ограничениях, выделенных в предыдущем разделе. Когда WINS работает, обозреватель подсети может быть клиентом WINS и может получить IP-адрес индивидуальной рассылки основного обозревателя домена (PDC) для любого домена. Однако широковещательные сообщения все еще передаются часто и неоднократно по умолчанию (см., что таблица описывает Типы узла WINS в следующем разделе), на шансе, что могут быть некоторые клиенты не-WINS на подсети. Лучшее решение в большинстве сетей состоит в том, чтобы выключить широковещательный просмотр.

Выключение широковещательных сообщений

Самая сложная задача при выключении широковещательных сообщений избегает нестандартных мастеров обзора, которые вызывают опустошение на подсети, потому что они разрушают процесс просмотра.

Рис. 3: Нестандартный мастер обзора

/image/gif/paws/10624/winnt_d2.gif

Можно отключить разрешение имени широковещания путем установки Параметра BrowseMaster в Отключенный. В Windows для рабочих групп 3.11, широковещательные сообщения выключены путем добавления команды к файлу SYSTEM.INI. (См. Приложение B для подробных данных.) В Windows 95/98/98, Параметр BrowseMaster в Усовершенствованных Свойствах Совместного использования Файла и Печати должен быть установлен в Отключенный. В Windows NT, необязательно для выключения просмотра в большинстве случаев, невзирая на то, что это может быть выбираемо. В Windows NT, устанавливает ключ реестра Hkey_local_machine\system\CurrentControlSet\Services\Browser\Parameters\MaintainServerList в администраторов номера, может управлять широковещательными сообщениями, передаваемыми клиентами DHCP путем выбора соответствующего Типа узла WINS (p-node: 0x2). Полный список Типов узла WINS придерживается.

Таблица 3: Список типов узла WINS

Тип узла WINS Порядок поиска имени
b-узел (0x1) Широковещание только
p-node (0x2) WINS только
m-узел (0x4) Широковещание, затем WINS
h-узел (0x8) WINS, затем широковещание

Масштабирование к большим сетям

Надежные домены

При планировании Сети Windows рассмотрение какой модель домена использовать важно. Следующие параграфы обсуждают преимущества и недостатки нескольких моделей домена. Если у вас есть несколько доменов, вы, вероятно, хотите к обмену данными с другими доменами в сети. Доверительные отношения являются способом получить или предоставить доступ к домену, не имея необходимость управлять каждым пользователем индивидуально. Каждое отношение разрешает доверие одному направлению только. Для получения дополнительной информации посмотрите Комплект ресурсов сервера Windows NT 4.0, громкость 2, глава 4.

Одиночный домен

Эта модель домена является самым простым---, сеть имеет только один домен. Эта настройка работает для маленьких или установок среднего размера без глобальной сети (WAN).

Глобальное доверие

Разработанный для компаний без центрального административного или организации IS, модель глобального доверия является самым простым понять и самое трудное для управления. Каждый домен доверяет любому домену.

Основной домен

В этой модели основному домену доверяют все другие домены, но основной домен никому не доверяет. Когда отделы или подразделения хотят административный контроль по своим собственным сервисам, но все еще хотят подтвердить подлинность централизованно, эта опция выгодна.

Несколька основных доменов

Эта модель разработана, чтобы быть увеличенной версией модели основного домена. Нескольким основным доменам все доверяют друг другу и каждому из основных доменов, в свою очередь, доверяет каждый домен отдела.

Репликация WINS

Для резервирования или оптимизировать трафик глобальной сети (WAN), иногда наличие нескольких серверов WINS выбираемо. Windows NT и Серверы Windows 2000 могут реплицировать или повторно синхронизовать базы данных WINS или в или в оба направления. На рисунке 4 большая многонациональная компания имеет несколько распределенных серверов WINS, таким образом, запросы WINS не должны перемещаться по континентам.

Рис. 4: Пример для всего предприятия настройки репликации WINS

/image/gif/paws/10624/winnt_d3.gif

Доступ через модем

Windows NT/2000 и Windows 2000 идут с сервером удаленного доступа (RAS) Microsoft, который использует Протокол PPP. Клиенты могут хотеть использовать Серверы доступа Cisco вместо NT RASs для их пулов наборного (телефонный) доступа из-за лучшей плотности наборного (телефонный) доступа и производительности, доступной на Серверах доступа Cisco.

Windows поддерживает TCP/IP, IPX и NetBEUI (IP Control Protocol [IPCP], Протокол управления IPX [IPXCP] и Протокол управления передачей кадров NetBIOS [NBFCP] протоколы управления для PPP). Поддержка наборного (телефонный) доступа NetBEUI была добавлена к программному обеспечению Cisco IOS в Выпуске 11.1. Для набора NetBEUI в используйте команду netbios nbf (как показано в следующем примере) на каждом асинхронном интерфейсе или на интерфейсе group-async на сервере доступа.

interface ethernet 0

netbios nbf

Interface Group-Async 0

group-range 1 16

netbios nbf

Для настройки набора IPX в используйте команду ipx ppp-client (как показано в следующем примере) на каждом асинхронном интерфейсе или на интерфейсе group-async на сервере доступа. Эта команда требует, чтобы вы настроили сетевой адрес IPX на интерфейсе обратной связи. Клиенты с наборным (телефонным) доступом не должны слышать сообщения Сервисного протокола объявления (SAP), таким образом, эти сообщения должны быть выключены с командой ipx sap-interval 0.

Interface loopback 0

ipx network <network number>

interface group-async 0
group-range 1 16
ipx ppp-client loopback 0
ipx sap-interval 0

Для присвоения IP-адресов на клиентов с наборным (телефонным) доступом Серверы доступа Cisco могут использовать пул локальных адресов или действовать как прокси для DHCP server. Сервер доступа запрашивает адрес от DHCP server и использования тот адрес во время согласования PPP. Клиент может также выполнить согласование об адресе его сервера WINS.

ip dhcp-server n.n.n.n


async-bootp nbns-server m.m.m.m


async-bootp dns-serverp.p.p.p


ip address-pool dhcp-proxy-client

!

interface group-async 0

group-range 1 16

peer default ip address dhcp

Маршрутизация по требованию

Технология DDR предоставляет сетевые подключения по Открытой коммутируемой телефонной сети (PSTN). Традиционно, подключения к глобальной сети (WAN) были выделенными выделенными линиями. DDR предоставляет низкий объем, периодические сетевые подключения, позволяя по требованию сервисы и уменьшая сетевые затраты. Цифровая сеть с интеграцией услуг (ISDN) является технологией коммутации каналов. Как сеть аналогового телефона, ISDN - подключения сделаны только, когда существует потребность связаться.

Когда соединение должно быть сделано к другому сайту, маршрутизаторы Cisco используют DDR для определения. Пакеты классифицированы или как содержательные или как неинтересные, на основе определяемых протоколом списков доступа и списков номеронабирателя. Ненужные пакеты могут переместиться по активному соединению DDR, но они не приносят соединение, и при этом они не поддерживают соединение.

Windows для рабочих групп и Windows 95/98/98 клиенты, которые совместно используют файлы или принтеры, регистрируют себя в WINS каждые двенадцать или пятнадцать минут путем передачи одноадресного пакета к серверу WINS (на порту UDP 137---порт Сервиса имен netbios).

Системы Windows NT могут также передать множество других повторяющихся пакетов, которые могут вызвать высокие затраты на глобальную сеть WAN. Эти повторяющиеся пакеты включают синхронизацию обозревателей, репликацию WINS, SAM (база данных учетной записи пользователя) репликация, обзор принтеров и DHCP. Многие из этих сервисов имеют ключи реестра, которые могут быть настроены для внедрения соединения по требованию менее часто. Для получения дополнительной информации посмотрите Базу знаний Microsoft, статью: Q134985. Важные записи реестра включают:

Hkey_local_machine\system\CurrentControlSet\Services\Browser\Parameters\MasterPeriodicity

Hkey_local_machine\system\CurrentControlSet\Services\Browser\Parameters\BackupPeriodicity

Hkey_local_machine\system\CurrentControlSet\Services\Replicator\Interval

Hkey_local_machine\system\CurrentControlSet\Services\Netlogon\PulseMaximum

Hkey_local_machine\system\CurrentControlSet\Services\Control\Print\DisableServerThread

Рис. 5: Соединение с соединением по требованию все время

/image/gif/paws/10624/winnt_d4.gif

Передача пакета к серверу WINS обычно переводит соединение с соединением по требованию в рабочее состояние. Если, однако, этот порт классифицирован как неинтересный к программному обеспечению Cisco IOS, то маршрутизатор не переводит в рабочее состояние и не продолжает ссылку.

Interface bri 0

dialer-group 1
!

dialer-list 1 protocol ip list 101

access-list 101 deny udp any any eq netbios-ns

access-list 101 permit ip any any

Рис. 6: Порт UDP 137 является неинтересным, ссылка не работает

/image/gif/paws/10624/winnt_d5.gif

Фильтры для серии Cisco 700 доступны в Выпуске 4.1 (2). Фильтр в качестве примера для создания трафика SAM Windows NT неинтересным придерживается:

SET netbsp OFFSET 2 FROM TCPHDR PATTERN 00 8b 

SET netbnsp OFFSET 2 FROM UDPHDR PATTERN 00 89 

SET netbdgp OFFSET 2 FROM UDPHDR PATTERN 00 8a 

SET refresh OFFSET 10 FROM UDPHDR PATTERN 40 00 

SET netbsm OFFSET 20 FROM TCPHDR PATTERN 00 

SET smb OFFSET 24 FROM TCPHDR PATTERN ff 53 4d 42 

SET tcppat2 OFFSET 13 FROM TCPHDR PATTERN 02 

SET netbsr OFFSET 20 FROM TCPHDR PATTERN 81 

SET keepali OFFSET 20 FROM TCPHDR PATTERN 85 

SET tcpres OFFSET 13 FROM TCPHDR PATTERN 04 

SET IP FILTER OUT netbnsp refresh IGNORE

SET IP FILTER OUT netbdgp IGNORE

SET IP FILTER OUT netbsp netbsm smb IGNORE

SET IP FILTER OUT netbsp tcppat2 IGNORE

SET IP FILTER OUT netbsp tcpres IGNORE

SET IP FILTER OUT netbsp netbsr IGNORE

SET IP FILTER OUT netbsp keepali IGNORE

ISDN-доступ

Этот раздел покрывает платы ISDN и терминальные адаптеры (TA). Для получения информации об использовании Cетевых технологий на базе Windows с маршрутизаторами ISDN посмотрите предыдущий раздел на маршрутизации по требованию.

Adtran

Поскольку Adtran и Cisco тесно сотрудничали во время тестирования совместимости, Adtran является хорошим кандидатом для рассмотрения для внешних TA. TA Adtran поддерживают Многоканальное подключение PPP (MP), Протокол аутентификации по квитированию вызова (CHAP), Протокол аутентификации пароля (PAP), синхронный или асинхронные последовательные интерфейсы и Automatic Service Profile Identifier (AutoSPID) конфигурация.

Motorola BitSURFR

Самый простой способ сделать BitSURFR связанным со взаимодействуютом ПК с маршрутизатором Cisco состоит в том, чтобы включить асинкс/синхронное преобразование с командой AT%A2=95 (для получения дополнительной информации, посмотрите страницу 7-1 руководства по BitSURFR). При использовании BitSURFR Pro и хотите использовать оба канала B, необходимо использовать Аутентификацию PAP. BitSURFR Pro не может правильно ответить на запрос вызова CHAP, передаваемый когда внедрение второй канал B. Для заказывания телефонный разговор с помощью двух каналов B необходимо ввести номер телефона дважды. Например, если бы номер телефона 555-1212, вы ввели бы ATD555-1212&555-1212. В следующей таблице перечислены команды для введения для нескольких типов соединений:

Таблица 4: Полезные команды настройки для Motorola BitSURFR

Тип соединения Команда
Подключение Использование PPP %A2=95
Используйте оба канала B (MP) @B0=2
Используйте аутентификацию PAP @M2=P
Скорость Data termination equipment (DTE) (COM - порт ПК) &M
Разместите вызовы на 64 кбит/с %A4=0
Разместите вызовы на 56 кбит/с %A4=1
Разместите голосовые вызовы %A98

Клиентская программа

CiscoRemote Lite

CiscoRemote Lite свободный Стек TCP/IP и приложение набора номера для Windows 3.1 и Windows для рабочих групп. CiscoRemote поддерживает протоколы Internet - протокола последовательного канала (SLIP) и PPP.

Примеры

Пример 1

Пример 1 показывает маленькое, однодоменная сеть с помощью NWLink (NetBIOS по IPX). Рисунок 7 показывает рисунок настройки.

Рис. 7: Маленький, однодоменная сеть Использование NWLink

/image/gif/paws/10624/winnt_d6.gif

Конфигурация маршрутизатора Cisco 4700

hostname 4700

ipx routing

!

interface ethernet 0

ipx network 50

ipx type-20-propagation

interface ethernet 1

ipx network 60

ipx type-20-propagation

interface ethernet 2

ipx network 7B

ipx type-20-propagation

interface ethernet 3

ipx network 95

ipx type-20-propagation

Конфигурация сервера доступа Cisco 2511

hostname 2511

ipx routing

!

interface ethernet 0

ipx network 98

interface loopback 0

ipx network 163

interface group-async 0

group-member 1 16

ipx ppp-client loopback 0

ipx sap-interval 0

encapsulation ppp

async mode dedicated

!

line 1 16

modem inout

speed 115200

flowcontrol hardware

Пример 2

Пример 2 показывает сеть средних размеров с помощью NBT (NetBIOS по TCP) и разрешение статического имени (LMHOSTS). Рисунок 8 показывает рисунок настройки.

Рис. 8: Сеть средних размеров Использование NBT и LMHOSTS

/image/gif/paws/10624/winnt_d7.gif

Конфигурация файла LMHOSTS на Клоде (клиент в сфере маркетинга)

1.2.1.8 mkt_PDC #PRE
1.2.7.3 mkt_BDC #PRE
ЗАМЕНА #BEGIN
#INCLUDE \\mkt_pdc\public\lmhosts #INCLUDE \\mkt_bdc\public\lmhosts
ЗАМЕНА #END

Конфигурация файла LMHOSTS на mkt_PDC (Primary Domain Controller для Сферы маркетинга)

1.1.1.3 eng_PDC #PRE #DOM:eng
1.1.4.5 sales_PDC #PRE #DOM:sales
1.2.1.4 сонный -
1.2.1.5 sneezy -
1.2.6.2 martin -
1.2.6.78 theresa -
1.2.6.89 claude -

Конфигурация маршрутизатора Cisco 7500

hostname 7500

ip forward-protocol udp bootpc

!

interface ethernet 0

ip address 1.5.6.1 255.255.255.0

ip helper-addressn.n.n.n


...

interface ethernet 23

ip address 1.5.56.1 255.255.255.0

ip helper-addressn.n.n.n

Конфигурация AS5200 в стеке групп

hostname as5200-1

!

controller t1 0

framing esf

linecode b8zs

pri-group

controller t1 1

framing esf

linecode b8zs

pri-group

!

sgbp group as5200s

sgbp member as5200-2

sgbp member as5200-3

username as5200s password stackpassword

!

ip dhcp-servern.n.n.n


ip wins-serverm.m.m.m


ip address-pool dhcp-proxy-client

!

interface ethernet 0

ip address 192.168.2.1 255.255.255.0

!

interface group-async 0

group-member 1 48

peer default ip address dhcp

!

interface serial 0:23

dialer rotary-group 1

isdn incoming-voice modem

interface serial 1:23

dialer rotary-group 1

isdn incoming-voice modem

interface dialer 1

ip unnumbered ethernet 0

encapsulation ppp

ppp multilink

ppp authentication chap

ppp use-tacacs

dialer-group 1

!

dialer-list 1 protocol ip permit

!

line 1 48

modem inout

modem autoconfigure type microcom-hdms

speed 115200

flowcontrol hardware

Конфигурация маршрутизатора Cisco 700

set system 700

cd LAN

set ip address 1.4.3.1

set ip netmask 255.255.255.248

set ip routing on

set ip rip update periodic

CD

set user as5200s

set encapsulation ppp

set ip framing none

set ip routing on

set number 5551212

set ip route destination 0.0.0.0/0 gateway 0.0.0.0

CD

set active as5200s

set bridging off

Пример 3

Пример 3 показывает сеть средних размеров с помощью NBT (NetBIOS по TCP) и одиночный сервер WINS. Рисунок 9 показывает рисунок настройки.

Рис. 9: Сеть средних размеров Использование NBT (NetBIOS по TCP) и одиночный сервер WINS

/image/gif/paws/10624/winnt_d8.gif

Конфигурация Cisco 1600

hostname 1600

username as5200s password secret

!

interface ethernet 0

ip address 1.4.3.1 255.255.255.248

interface bri 0

ip unnumbered ethernet 0

encapsulation ppp

ppp multilink

dialer string 5551212

dialer-group 1

!

dialer-list 1 protocol ip list 101

access-list 101 deny udp any any eq netbios-ns

access-list 101 permit ip any any

Пример 4

Рисунок 10 показывает большую сеть с помощью NBT (NetBIOS по TCP) с нескольками основных доменов и реплицированными серверами WINS.

Рисунок 10: Большая сеть Использование NBT с нескольками основных доменов и реплицированными серверами WINS

winnt_d9.gif

Приложение А: Выключение разрешения имени широковещания

При использовании Windows для рабочих групп 3.11

При использовании Windows для рабочих групп 3.11, новый файл браузера, VREDIR.386, который включен с Windows NT 3.5, должен использоваться, чтобы позволить переходить для работы правильно. Windows 95/98/98 уже включает этот модифицированный браузер. Файл VREDIR.386, как правило, располагается в каталоге C:\WINDOWS\SYSTEM.

Клиенты Windows для рабочих групп должны внести придерживающееся изменение в файл SYSTEM.INI:

; SYSTEM.INI

;

[Сеть]

MaintainServerList=No

Windows 95/98/98

Рисунок 11: Выключение просматривает ведущее устройство в Windows 95/98/98

/image/gif/paws/10624/winnt_10.gif

Windows NT 3.51

Рабочие станции Windows NT 3.51 и серверы, которые настроены для разрешения имен WINS, не передают широковещательные сообщения пока другие компьютеры на сетевом запросе выбор обозревателя. Действие не требуется.

Записи реестра Windows NT

Эти записи в hkey_local_machine\system\currentcontrolset\services\browser\parameters области реестра должны быть установлены следующим образом: MaintainServerList должен быть установлен в Да, и IsDomainMaster должен быть установлен в False. Это настройки по умолчанию.

Параметр MasterPeriodicity (в секундах) задает, как часто подсеть переходит, серверы сделали запрос главного устройства домена для получения списка просмотра. Когда подсеть просматривает серверы, и главное устройство домена разделены низкоскоростной или попакетной платой ссылкой, можно установить это в час или больше.

Обнаружение нестандартных мастеров обзора

Windows 3.1 и Windows 95/98/98 рабочие станции не могут функционировать, как просматривают ведущие устройства в сети Windows NT, потому что они не обрабатывают NT - сервер и информацию домена. К сожалению, по умолчанию, Windows 95/98/98 пытается стать ведущим устройством обзора. Одна рабочая станция, неправильно утверждая быть ведущим устройством обзора препятствует просмотру для каждого компьютера на той подсети в целом. Приоритет для становления ведущим устройством обзора является PDC, BDC, NT - сервером, Рабочей станцией NT, затем Windows 95/98/98, который должен препятствовать тому, чтобы это произошло.

Комплект ресурсов сервера Windows NT 4.0 содержит утилиту, названную BROWSTAT. Самый простой способ найти постороннюю вещательную компанию на подсети состоит в том, чтобы выполнить BROWSTAT на компьютере Windows NT на подсети, на которую влияют.

Приложение Б: Разрешение DNS Настройки названий WINS

Сервер Windows NT 4.0 и Windows 2000 оба включают сервер DNS, который может ответить на запросы DNS путем запроса сервера WINS в фоновом режиме. Сервер DNS Windows 2000 также поддерживает динамические обновления на RFC 2136. Сервер WINS и сервер DNS не должны быть на том же Windows NT/2000 машиной. Все запросы DNS субдомену (в данном примере, wins.cisco.com) должны быть делегированы к серверу DNS/WINS. Настройка Windows NT/2000 сервер DNS с помощью загрузочного файла не необходим или не рекомендован Microsoft. Диспетчер DNS предоставляет богатый интерфейс для сервиса.

Загрузочный файл DNS

; НАЧАЛЬНАЯ ЗАГРУЗКА - -
кэш . КЭШ
основной domain.com domain.dom
основной 8.17.1.in-адрес. _______________ ARPA 1-17-8.rev

Файл DNS для domain.com

; domain.dom
@ В SOA ns.domain.com. rohan.domain.com. (
1 Серийный номер
10800 ; Обновление [3 ч]
3600 ; Повторите [1 ч]
604800 ; Истеките [7d]
86400) ; Минимум [1d]
@ В WINS 1.1.4.6 1.2.7.4
сервер WINS В A #1. 1.4.6
server2 wins В A #1. 2.7.4

1Albitz, Пол и крикет Лю. Sebastopol, CA: О'Райли и партнеры, 1992.


Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Document ID: 10624