Программное обеспечение Cisco IOS и NX-OS : Программное обеспечение Cisco IOS версии 12.2 T

Преобразование NAT – возможность использования карт маршрутов со статическими преобразованиями

23 марта 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Английский (14 октября 2001) | Отзыв


Содержание

Преобразование NAT — возможность использования карт маршрутов со статическими преобразованиями
Обзор функции
Поддерживаемые платформы
Поддерживаемые стандарты, базы данных MIB и документы RFC
Задачи настройки
Примеры настроек
Справочник по командам
ip nat inside source static

Преобразование NAT — возможность использования карт маршрутов со статическими преобразованиями


История функции
Версия Изменение

12.2(4)T

Команда включена впервые.

12.2(4)T2

Добавлена поддержка маршрутизаторов серии Cisco 7500

В данном документе описывается функция для преобразования NAT — возможность использования карт маршрутов со статическими преобразованиями. Документ состоит из следующих разделов:

Обзор функции

Поддерживаемые платформы

Поддерживаемые стандарты, базы данных MIB и документы RFC

Задачи настройки

Примеры настроек

Справочник по командам

Обзор функции

До появления этой функции отображение маршрутов поддерживалось только с динамическим преобразованием сетевых адресов (Network Address Translation, NAT).

Функция «NAT — возможность использования карт маршрутов со статическими преобразованиями» позволяет использовать преобразование NAT со статическим преобразованием адресов при наличии нескольких подключений. Во внутренних сетях с несколькими подключениями теперь можно размеIать общие службы, такие как Интернет и система доменных имен (Domain Name System, DNS), к которым осуществляется доступ из различных внешних сетей.


Примечание.   Эта функция не включает статическую поддержку сети.


Преимущества

  • Возможность настройки инструкций карт маршрутов позволяет использовать протокол IP Security (IPSec) с преобразованием NAT.
  • При использовании статических записей преобразования, решения о преобразовании могут приниматься на основании целевого IP-адреса.

Дополнительная документация

  • Справочник по командам Cisco IOS IP, том 1 из 3: «Адресация и службы», версия 12.2
  • Руководство по настройке Cisco IOS IP, версия 12.2

Поддерживаемые платформы

  • Cisco серии 2500
  • Cisco серии 2600
  • Маршрутизатор Cisco 3620
  • Маршрутизатор Cisco 3640
  • Маршрутизатор Cisco 3660
  • Cisco серии 7100
  • Cisco серии 7200
  • Cisco серии 7500
Определение поддерживаемых платформ с помощью инструмента Cisco Feature Navigator

Программное обеспечение Cisco IOS разбито по наборам функций, которые поддерживают определенные платформы. Для получения информации о поддержке платформ для данной функции воспользуйтесь инструментом Cisco Feature Navigator. Когда для функции добавляется поддержка новой платформы, инструмент Cisco Feature Navigator динамически обновляет список поддерживаемых платформ.

Инструмент Cisco Feature Navigator представляет собой веб-приложение, с помощью которого можно определить образы программного обеспечения Cisco IOS, поддерживающие тот или иной набор функций, и функции, поддерживаемые в определенном образе Cisco IOS.

Для доступа к инструменту Cisco Feature Navigator необходимо наличие учетной записи на веб-сайте cisco.com. При утрате данных учетной записи следует отправить пустое электронное письмо по адресу: cco-locksmith@cisco.com. Программа автоматически определит наличие регистрации на веб-сайте cisco.com адреса электронной почты, с которого пришло письмо. При положительном результате проверки на этот адрес высылаются данные учетной записи, а также новый пароль, сгенерированный случайным образом. Опытные пользователи могут создать учетную запись на веб-сайте cisco.com, следуя инструкциям по адресу https://tools.cisco.com/RPF/register/register.do.

Инструмент Cisco Feature Navigator регулярно обновляется при появлении новых основных и технологических версий программного обеспечения Cisco IOS. По состоянию на май 2001 г. инструмент Cisco Feature Navigator поддерживает версии M, T, E, S и ST. Инструмент Cisco Feature Navigator доступен по следующему адресу:

http://tools.cisco.com/ITDIT/CFN/jsp/index.jsp

Поддерживаемые стандарты, базы данных MIB и документы RFC

Стандарты

Данная функциональная возможность не поддерживает новые или измененные стандарты.

Базы данных MIB

Данная функциональная возможность не поддерживает новые или измененные базы данных MIB.

Для получения списков поддерживаемых баз административной информации Management Information Base, MIB) по платформе и версии Cisco IOS и для загрузки модулей MIB перейдите на веб-сайт MIB компании Cisco по следующему адресу:

http://www.cisco.com/public/sw-center/netmgmt/cmtk/mibs.shtml

Документы RFC

Данная функциональная возможность не поддерживает новые или измененные документы RFC.

Задачи настройки

Задачи настройки функции «NAT — возможность использования карт маршрутов со статическими преобразованиями» см. в указанных ниже разделах. Для каждой задачи списка указано, обязательна она или нет.

  • Включение статического отображения маршрутов NAT (обязательная)
  • Проверка статического отображения маршрутов NAT (необязательная)

Включение статического отображения маршрутов NAT

Для включения отображения маршрутов со статическими настройками преобразования NAT используется следующая команда в режиме глобальной конфигурации:

Команда Назначение
Router(config)# ip nat inside source {list {access-list-number | access-list-name} pool pool-name [overload] | static local-ip global-ip route-map map-name}

Включение отображения маршрутов со статическим преобразованием NAT, настроенным на внутреннем интерфейсе NAT.

Проверка статического отображения маршрутов NAT

Для проверки настройки статического отображения маршрутов NAT используется следующая команда привилегированного режима EXEC:

Команда Назначение
Router# show ip nat translations [verbose]

Вывод на экран активных преобразований NAT.

Примеры настроек

В данном разделе приведены следующие примеры настройки:

  • Включение статического отображения маршрутов NAT

Пример включения статического отображения маршрутов NAT

Следующий пример демонстрирует использование отображения маршрута со статическим преобразованием NAT:

interface Ethernet3
 ip address 172.68.1.100 255.255.255.0
 ip nat outside
 media-type 10BaseT
!
interface Ethernet4
 ip address 192.68.1.100 255.255.255.0
 ip nat outside
 media-type 10BaseT
!
interface Ethernet5
 ip address 1.1.1.1 255.255.255.0
 ip nat inside
 media-type 10BaseT
!
router rip
 network 172.68.0.0
 network 192.68.1.0
!
ip nat inside source static 11.1.1.2 192.68.1.21 route-map isp2
 ip nat inside source static 11.1.1.2 172.68.1.21 route-map isp1
 ip nat inside source static 11.1.1.1 192.68.1.11 route-map isp2
 ip nat inside source static 11.1.1.1 172.68.1.11 route-map isp1
 access-list 101 permit ip 11.1.1.0 0.0.0.255 172.0.0.0 0.255.255.255.
access-list 102 permit ip 11.1.1.0 0.0.0.255 192.0.0.0 0.255.255.255
!
route-map isp2 permit 10
 match ip address 102
 set ip next-hop 192.68.1.1
!
route-map isp1 permit 10
 match ip address 101

 set ip next-hop 172.68.1.1

Справочник по командам

В данном разделе описана измененная команда ip nat inside source. Все другие команды, используемые с этой функцией, описаны в справочниках команд настройки программного обеспечения Cisco IOS версии 12.2.

ip nat inside source

Для включения преобразования сетевых адресов (NAT) внутренних источников используется команда ip nat inside source в режиме глобальной настройки. Статическое преобразование или динамическое сопоставление пулу удаляются с помощью добавления к этой команде ключевого слова no.

ip nat inside source {list {access-list-number | access-list-name} pool pool-name [overload] | static local-ip global-ip route-map map-name}
no ip nat inside source {list {access-list-number | access-list-name} pool pool-name [overload] | static local-ip global-ip route-map map-name}

Описание синтаксиса

list access-list-number

Номер стандартного списка доступа IP. Пакеты с адресами источников, которые проходят через список доступа, динамически преобразуются с помощью глобальных адресов из именованного пула.

list access-list-name

Имя стандартного списка доступа IP. Пакеты с адресами источников, которые проходят через список доступа, динамически преобразуются с помощью глобальных адресов из именованного пула.

pool pool-name

Имя пула, из которого динамически распределяются глобальные IP-адреса.

overload

(Необязательно) Разрешает маршрутизатору использовать один глобальный адрес для нескольких локальных адресов. При настройке перегрузки номера портов TCP или UDP каждого внутреннего узла позволяют различать несколько сессий, использующих один и тот же локальный IP-адрес.

static local-ip

Задание единственного статического преобразования. Аргумент local-ip задает локальный IP-адрес, назначаемый узлу внутренней сети. Адрес может быть выбран случайным образом, взят из RFC 1918 или быть устаревшим.

global-ip

Задание единственного статического преобразования. Аргумент global-ip задает уникальный глобальный IP-адрес внутреннего узла, видимый из внешней сети.

route-map map-name

Имя конфигурации карты маршрутов на внутреннем интерфейсе NAT в статических преобразованиях.

Значения по умолчанию

Поведение или значения по умолчанию отсутствуют.

Командные режимы

Глобальная настройка

История команды

Версия Изменение

11.2

Команда включена впервые.

12.2(4)T

Команда изменена с целью включения возможности использовать карты маршрутов со статическими преобразованиями, а также добавлены ключевое слово/аргумент route-map map-name.

Инструкции по использованию

У этой команды две формы: динамическое и статическое преобразование адреса. Форма со списком доступа устанавливает динамическое преобразование. Пакеты из адресов, соответствующих стандартному списку доступа, преобразуются с помощью глобальных адресов, выделенных из пула, указанного с помощью команды ip nat pool.

В ином случае форма синтаксиса с ключевым словом static устанавливает единственное статическое преобразование.

Примеры

В следующем примере выполняется преобразование между внутренними узлами, адресуемыми либо из сети 192.168.1.0, либо из сети 192.168.2.0 в сеть с глобальным уникальным адресом 171.69.233.208/28:

ip nat pool net-208 171.69.233.208 171.69.233.223 prefix-length 28
ip nat inside source list 1 pool net-208
!
interface ethernet 0
 ip address 171.69.232.182 255.255.255.240
 ip nat outside
!
interface ethernet 1
 ip address 192.168.1.94 255.255.255.0
 ip nat inside
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 192.168.2.0 0.0.0.255

Следующий пример демонстрирует использование отображения маршрута со статическим преобразованием NAT:

!
interface Ethernet3
 ip address 172.68.1.100 255.255.255.0
 ip nat outside
 media-type 10BaseT
!
interface Ethernet4
 ip address 192.68.1.100 255.255.255.0
 ip nat outside
 media-type 10BaseT
!
interface Ethernet5
 ip address 1.1.1.1 255.255.255.0
 ip nat inside
 media-type 10BaseT
!
router rip
 network 172.68.0.0
 network 192.68.1.0
!
ip nat inside source static 11.1.1.2 192.68.1.21 route-map isp2
 ip nat inside source static 11.1.1.2 172.68.1.21 route-map isp1
 ip nat inside source static 11.1.1.1 192.68.1.11 route-map isp2
 ip nat inside source static 11.1.1.1 172.68.1.11 route-map isp1
 access-list 101 permit ip 11.1.1.0 0.0.0.255 172.0.0.0 0.255.255.255.
access-list 102 permit ip 11.1.1.0 0.0.0.255 192.0.0.0 0.255.255.255
!
route-map isp2 permit 10
 match ip address 102
 set ip next-hop 192.68.1.1
!
route-map isp1 permit 10
 match ip address 101
 set ip next-hop 172.68.1.1

Связанные команды

Команда Описание

clear ip nat translation

Удаление динамических преобразований NAT из таблицы преобразования.

ip nat

Указывает на то, что трафик, инициированный интерфейсом, или предназначенный для него, подлежит преобразованию NAT.

ip nat inside destination

Включение преобразования NAT для внутренних адресов назначения.

ip nat outside source

Включение преобразования NAT для адресов внешних источников.

ip nat pool

Определение пула IP-адресов для NAT.

show ip nat statistics

Вывод на экран статистики NAT.

show ip nat translations

Вывод на экран активных преобразований NAT.