Программное обеспечение Cisco IOS и NX-OS : Программное обеспечение Cisco IOS версии 12.3 -специальные и ранние развёртывания

Надежная статическая резервная маршрутизация с отслеживанием объектов

23 марта 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Английский (20 ноября 2003) | Отзыв

Содержание

Надежная статическая резервная маршрутизация с отслеживанием объектов

Содержание

Требования для организации надежной статической резервной маршрутизации с отслеживанием объектов

Ограничения для организации надежной статической резервной маршрутизации с отслеживанием объектов

Информация об организации надежной статической резервной маршрутизации с отслеживанием объектов

Надежная статическая резервная маршрутизация с отслеживанием объектов

Соглашения об уровне обслуживания IP в ПО Cisco IOS

Преимущества надежной статической резервной маршрутизации с отслеживанием объектов

Как настроить надежную статическую резервную маршрутизацию с отслеживанием объектов

Настройка основного интерфейса надежной статической резервной маршрутизации с отслеживанием объектов

Настройка резервного интерфейса надежной статической резервной маршрутизации с отслеживанием объектов

Настройка мониторинга сети с использованием соглашений об уровне обслуживания Cisco IOS IP для надежной статической резервной маршрутизации с отслеживанием объектов

Настройка политики маршрутизации для надежной статической резервной маршрутизации с отслеживанием объектов

Настройка маршрута по умолчанию для основного интерфейса с использованием статической маршрутизации

Настройка плавающего статического маршрута по умолчанию для вторичного интерфейса

Проверка состояния отслеживаемого объекта для надежной статической резервной маршрутизации с отслеживанием объектов

Примеры настройки надежной статической резервной маршрутизации с отслеживанием объектов

Настройка надежной статической резервной маршрутизации с отслеживанием объектов: пример для протокола PPPoE

Настройка надежной статической резервной маршрутизации с отслеживанием объектов: пример для протокола DHCP

Настройка надежной статической резервной маршрутизации с отслеживанием объектов: примеры статической маршрутизации

Проверка состояния отслеживаемого объекта: пример

Дополнительные ссылки

Дополнительная документация

Стандарты

Базы данных MIB

Документы RFC

Техническая поддержка

Справочник по командам

ip dhcp client

ip route

set ip next-hop dynamic dhcp

show ip route track-table


Надежная статическая резервная маршрутизация с отслеживанием объектов


Функция надежной статической резервной маршрутизации с отслеживанием объектов дает возможность программному обеспечению Cisco IOS использовать сообщения эхо-тестирования протокола ICMP для определения сбоя в туннелях PPPoE или IPSec VPN, что позволяет инициировать резервное соединение через альтернативный порт. Функция надежной статической резервной маршрутизации с отслеживанием объектов совместима как с заранее настроенными статическими маршрутами, так и с настройками протокола динамической настройки узлов DHCP.

Версия
Изменение

12.3(2)XE

Команда включена впервые.

12.3(8)T

Поддержка этой функции была встроена в программное обеспечение Cisco IOS версии 12.3(8)T.

12.3(14)T

Интерфейс командной строки Cisco IOS, используемый для настройки набора функций мониторинга и управления соглашений об уровне обслуживания IP в Cisco IOS, был изменен.

12.2(33)SRA

Эта функция были встроена в программное обеспечение Cisco IOS версии 12.2(33)SRA.


Предыстория функции надежной статической резервной маршрутизации с отслеживанием объектов

Поиск информации о поддержке для платформ и образов программного обеспечения Cisco IOS

Для поиска информации о поддержке платформ и образов программного обеспечения Cisco IOS воспользуйтесь инструментом Cisco Feature Navigator. Доступ к инструменту Cisco Feature Navigator можно получить по адресу http://tools.cisco.com/ITDIT/CFN/jsp/index.jsp. Необходимо наличие учетной записи на веб-сайте cisco.com. Если у вас нет учетной записи, вы забыли имя пользователя или пароль, то в диалоговом окне входа в систему нажмите кнопку Cancel (Отмена) и следуйте дальнейшим указаниям.

Содержание

Требования для организации надежной статической резервной маршрутизации с отслеживанием объектов

Ограничения для организации надежной статической резервной маршрутизации с отслеживанием объектов

Информация об организации надежной статической резервной маршрутизации с отслеживанием объектов

Как настроить надежную статическую резервную маршрутизацию с отслеживанием объектов

Примеры настройки надежной статической резервной маршрутизации с отслеживанием объектов

Дополнительные ссылки

Справочник по командам

Требования для организации надежной статической резервной маршрутизации с отслеживанием объектов

Если резервная маршрутизация настроена на интерфейсе номеронабирателя, необходимо настроить маршрутизацию с соединением по требованию (Dial-on-demand routing, DDR). Дополнительные сведения по настройке DDR см. в разделе «Настройка маршрутизации с соединением по требованию» книги Руководство по настройке технологий дозвона Cisco IOS.

Ограничения для организации надежной статической резервной маршрутизации с отслеживанием объектов

Эта функция поддерживается во всех образах программного обеспечения Cisco IOS для серии модульных маршрутизаторов доступа Cisco 1700, за исключением образа Cisco IOS IP Base.

Информация об организации надежной статической резервной маршрутизации с отслеживанием объектов

Для настройки функции надежной статической резервной маршрутизации с отслеживанием объектов необходимо ориентироваться в следующих вопросах:

Надежная статическая резервная маршрутизация с отслеживанием объектов

Соглашения об уровне обслуживания IP в ПО Cisco IOS

Преимущества надежной статической резервной маршрутизации с отслеживанием объектов

Надежная статическая резервная маршрутизация с отслеживанием объектов

Функция надежной статической резервной маршрутизации с отслеживанием объектов дает возможность надежно резервировать решения PPPoE или IPSec VPN путем инициирования соединения DDR через альтернативный порт в случае сбоя на линии основного шлюза. Функция надежной статической резервной маршрутизации с отслеживанием объектов позволяет гарантировать надежное резервирование в случае некоторых аварийных событий, например, выхода из строя Интернет-канала или отказа устройства на противоположной стороне соединения. Типовой сценарий показан на рис. 1.

Рис. 1

Схема сети для надежной статической резервной маршрутизации с отслеживанием объектов

Трафик с удаленной LAN пересылается в головной офис через основной интерфейс удаленного маршрутизатора. Если связь с головным офисом разрывается, состояние отслеживаемого объекта меняется с «Включен» («up») на «Выключен» («down»). Когда состояние отслеживаемого объекта сменяется на «Выключен», запись для основного интерфейса в таблице маршрутизации удаляется, и предварительно настроенный плавающий статический маршрут устанавливается на вторичный интерфейс. После этого трафик пересылается в заранее настроенную точку через вторичный интерфейс. Если на вторичном интерфейсе настроена DDR, содержательный трафик инициирует DDR. Резервная линия может быть настроена на использование телефонной коммутируемой сети общего пользования (ТфОП) или Интернета. Когда состояние отслеживаемого объекта изменяется с «Выключен» на «Включен», запись в таблице маршрутизации для основного интерфейса восстанавливается, а плавающий статический маршрут для вторичного интерфейса удаляется.

Соглашения об уровне обслуживания IP в ПО Cisco IOS

Функция надежной статической резервной маршрутизации с отслеживанием объектов позволяет использовать соглашения об уровне обслуживания IP в системе Cisco IOS, предоставляющие набор средств мониторинга сети. С помощью этих средств формируются эхозапросы ICMP для контроля состояния соединения с основным шлюзом. Соглашения об уровне обслуживания IP в Cisco IOS настраиваются для отправки контрольных эхозапросов на некий целевой узел, которым может быть внешний маршрутизируемый IP-адрес или узел внутри корпоративной сети. Эхо-запросы маршрутизируются только через основной интерфейс. Для отслеживания состояния конфигурации соглашения об уровне обслуживания IP в Cisco IOS создается отслеживаемый объект. Отслеживаемый объект сообщает информацию об изменении состояния клиенту, которым является статический маршрут. При изменении состояния с «Включен» на «Выключен» предварительно настроенный плавающий статический маршрут устанавливается на вторичный интерфейс.

Вместо эхозапросов ICMP можно использовать запрос HTTP GET, эхопосылки протокола дейтаграмм пользователя (User Datagram Protocol, UDP) или любой другой протокол, поддерживаемый соглашениями об уровне обслуживания IP в Cisco IOS.

Преимущества надежной статической резервной маршрутизации с отслеживанием объектов

Решения PPPoE и IPSec VPN обеспечивают экономичные и защищенные решения на базе Интернета, которые могут заменить традиционные коммутируемые линии и каналы Frame Relay.

Функция надежной статической резервной маршрутизации с отслеживанием объектов может определять состояние основного соединения, не используя протокол динамической маршрутизации.

Функция надежной статической резервной маршрутизации с отслеживанием объектов предоставляет надежное решение для резервирования систем PPPoE и IPSec VPN, позволяя использовать эти системы в критических линиях связи, которые не должны отключаться без автоматического включения резервной линии.

Как настроить надежную статическую резервную маршрутизацию с отслеживанием объектов

В этом разделе описаны следующие задачи:

Настройка основного интерфейса надежной статической резервной маршрутизации с отслеживанием объектов (обязательно)

Настройка резервного интерфейса надежной статической резервной маршрутизации с отслеживанием объектов (обязательно)

Настройка мониторинга сети средствами соглашения об уровне обслуживания IP в Cisco IOS для надежной статической резервной маршрутизации с отслеживанием объектов (обязательно)

Настройка политики маршрутизации для надежной статической резервной маршрутизации с отслеживанием объектов (обязательно)

Настройка маршрута по умолчанию для основного интерфейса с использованием статической маршрутизации (обязательно)

Настройка плавающего статического маршрута по умолчанию для вторичного интерфейса (обязательно)

Проверка состояния отслеживаемого объекта для надежной статической резервной маршрутизации с отслеживанием объектов (необязательно)

Настройка основного интерфейса надежной статической резервной маршрутизации с отслеживанием объектов

Необходимо настроить соединение между основным интерфейсом и удаленным шлюзом. Состояние этого соединения будет отслеживаться функцией надежной статической резервной маршрутизации с отслеживанием объектов.

Основной интерфейс по-разному настраивается для трех конфигураций: протоколов PPPoE, DHCP или статической маршрутизации. Необходимо выбрать один из этих способов настройки. Если неясно, какой метод используется для настройки вашей сети, обратитесь к поставщику услуг Интернета или администратору сети.

Для настройки основного интерфейса выполните одну из следующих задач:

Настройка основного интерфейса для протокола PPPoE

Настройка основного интерфейса для протокола DHCP

Настройка основного интерфейса для статической маршрутизации

Настройка основного интерфейса для протокола PPPoE

Выполнение задачи по настройке основного интерфейса при использовании протокола PPPoE.

СВОДКА ШАГОВ

1. enable

2. configure terminal

3. interface type number [name-tag]

4. description string

5. no ip address

6. pvc [name] vpi/vci [ces | ilmi | qsaal | smds | l2transport]

7. pppoe-client dial-pool-number number [dial-on-demand]

ПОДРОБНОЕ ОПИСАНИЕ ШАГОВ

 
Команда или действие
Назначение

Шаг 1 

enable

Пример.

Router> enable

Вход в привилегированный режим EXEC.

При запросе введите пароль.

Шаг 2 

configure terminal

Пример.

Router# configure terminal

Вход в режим глобальной конфигурации.

Шаг 3 

interface type number [name-tag]

Пример.

Router(config)# interface ATM 0

Настройка типа интерфейса и вход в режим настройки интерфейса.

Шаг 4 

description string

Пример.

Router(config-if)# description primary-link

Добавление описания в настройки интерфейса.

Шаг 5 

no ip address

Пример.

Router(config-if)# no ip address

Установка основного или вторичного IP-адреса интерфейса.

Шаг 6 

pvc [name] vpi/vci [ces | ilmi | qsaal | smds | 
l2transport]
Пример.

Router(config-if)# pvc 0/33

Создание или назначение имени постоянного виртуального канала (permanent virtual circuit, PVC) сети ATM (Asynchronous Transfer Mode), определение типа инкапсуляции ATM PVC и вход в режим настройки виртуального канала ATM.

Шаг 7 

pppoe-client dial-pool-number number 
[dial-on-demand]

Пример.

Router(config-if-atm-vc)# pppoe-client dial-pool-number 1

Настройка клиента PPPoE и назначение функциональности DDR.

Настройка основного интерфейса для протокола DHCP

Выполнение задачи по настройке основного интерфейса при использовании протокола DHCP.

СВОДКА ШАГОВ

1. enable

2. configure terminal

3. interface type number [name-tag]

4. description string

5. ip dhcp client route track number

6. ip address dhcp

ПОДРОБНОЕ ОПИСАНИЕ ШАГОВ

 
Команда или действие
Назначение

Шаг 1 

enable

Пример.

Router> enable

Вход в привилегированный режим EXEC.

При запросе введите пароль.

Шаг 2 

configure terminal

Пример.

Router# configure terminal

Вход в режим глобальной конфигурации.

Шаг 3 

interface type number [name-tag]

Пример.

Router(config)# interface FastEthernet 0/0

Настройка типа интерфейса и вход в режим настройки интерфейса.

Шаг 4 

description string

Пример.

Router(config-if)# description primary-link

Добавление описания в настройки интерфейса.

Шаг 5 

ip dhcp client route track number

Пример.

Router(config-if)# ip dhcp client route track 123

Настройка клиента DHCP для связывания добавленных маршрутов с указанным номером отслеживания.

route track number — Связывает отслеживаемый объект с установленным для DHCP статическим маршрутом. Допустимый диапазон значений для аргумента number — от 1 до 500.

Примечание. Необходимо настроить команду ip dhcp client перед вводом в интерфейсе команды ip address dhcp. Команда ip dhcp client проверяется только при получении IP-адреса в DHCP. Если команда ip dhcp client посылается после получения IP-адреса в DHCP, она не окажет действия до следующего получения маршрутизатором IP-адреса в DHCP.

Шаг 6 

ip address dhcp

Пример.

Router(config-if)# ip address dhcp

Назначение IP-адреса интерфейса Ethernet в DHCP.

Настройка основного интерфейса для статической маршрутизации

Выполнение задачи по настройке основного интерфейса при использовании статической маршрутизации.

СВОДКА ШАГОВ

1. enable

2. configure terminal

3. interface type number [name-tag]

4. description string

5. ip address ip-address mask [secondary]

ПОДРОБНОЕ ОПИСАНИЕ ШАГОВ

 
Команда или действие
Назначение

Шаг 1 

enable

Пример.

Router> enable

Вход в привилегированный режим EXEC.

При запросе введите пароль.

Шаг 2 

configure terminal

Пример.

Router# configure terminal

Вход в режим глобальной конфигурации.

Шаг 3 

interface type number [name-tag]

Пример.

Router(config)# interface FastEthernet 0/0

Настройка типа интерфейса и вход в режим настройки интерфейса.

Шаг 4 

description string

Пример.

Router(config-if)# description primary-link

Добавление описания в настройки интерфейса.

Шаг 5 

ip address ip-address mask [secondary]

Пример.

Router(config-if)# ip address 10.1.1.1 255.0.0.0

Установка основного или вторичного IP-адреса интерфейса.

Настройка резервного интерфейса надежной статической резервной маршрутизации с отслеживанием объектов

Необходимо настроить резервный интерфейс для связи с удаленным шлюзом. Если соединение между основным интерфейсом и удаленным шлюзом нарушено, будет использоваться резервный интерфейс.

Для настройки резервного интерфейса выполните следующие действия. Эта операция выполняется для настройки протоколов PPPoE, DHCP и статической маршрутизации.

СВОДКА ШАГОВ

1. enable

2. configure terminal

3. interface type number [name-tag]

4. description string

5. ip address ip-address mask [secondary]

ПОДРОБНОЕ ОПИСАНИЕ ШАГОВ

 
Команда или действие
Назначение

Шаг 1 

enable

Пример.

Router> enable

Вход в привилегированный режим EXEC.

При запросе введите пароль.

Шаг 2 

configure terminal

Пример.

Router# configure terminal

Вход в режим глобальной конфигурации.

Шаг 3 

interface type number [name-tag]

Пример.

Router(config)# interface Dialer 0

Настройка типа интерфейса и вход в режим настройки интерфейса.

Шаг 4 

description string

Пример.

Router(config-if)# description backup-link

Добавление описания в настройки интерфейса.

Шаг 5 

ip address ip-address mask [secondary]

Пример.

Router(config-if)# ip address 10.2.2.2 255.0.0.0

Установка основного или вторичного IP-адреса интерфейса.

Настройка мониторинга сети с использованием соглашений об уровне обслуживания Cisco IOS IP для надежной статической резервной маршрутизации с отслеживанием объектов

Функция надежной статической резервной маршрутизации с отслеживанием объектов позволяет использовать соглашения об уровне обслуживания IP в программном обеспечении Cisco IOS для создания эхозапросов ICMP и отслеживания состояния соединения с основным шлюзом.

Начиная с ПО Cisco IOS версии 12.3(14)T интерфейс командной строки, используемый для настройки функции Cisco IOS IP SLA, был изменен.

Для настройки функции Cisco IOS IP SLA выполните одно из следующих действий, в зависимости от используемой версии ПО Cisco IOS:

Настройка функции Cisco IOS IP SLA для программного обеспечения Cisco IOS версии 12.3(8)T, Cisco IOS версии 12.3(11)T и Cisco IOS версии 12.2(33)SRA

Настройка функции Cisco IOS IP SLA для программного обеспечения Cisco IOS версий 12.3(14)T, 12.4 и 12.4(2)T

Настройка функции Cisco IOS IP SLA для программного обеспечения Cisco IOS версии 12.4(4)T и более поздних версий

Настройка функции Cisco IOS IP SLA для программного обеспечения Cisco IOS версии 12.3(8)T, Cisco IOS версии 12.3(11)T и Cisco IOS версии 12.2(33)SRA

Выполните эту операцию для создания настройки функции IP SLA для эхо-тестирования адреса назначения. Эта операция выполняется для настройки протоколов PPPoE, DHCP и статической маршрутизации.

СВОДКА ШАГОВ

1. enable

2. configure terminal

3. rtr [operation-number]

4. type echo protocol ipIcmpEcho {destination-ip-address | destination-hostname} [source-ipaddr {ip-address | hostname}

5. timeout milliseconds

6. frequency seconds

7. threshold milliseconds

8. exit

9. rtr schedule operation-number [life {forever | seconds}] [start-time {hh:mm[:ss] [month day | day month] | pending | now | after hh:mm:ss}] [ageout seconds]

10. track object-number rtr rtr-operation {state | reachability}

ПОДРОБНОЕ ОПИСАНИЕ ШАГОВ

 
Команда или действие
Назначение

Шаг 1 

enable

Пример.

Router> enable

Вход в привилегированный режим EXEC.

При запросе введите пароль.

Шаг 2 

configure terminal

Пример.

Router# configure terminal

Вход в режим глобальной конфигурации.

Шаг 3 

rtr [operation-number]

Пример.

Router(config)# rtr 1

Начало настройки операций Cisco IOS IP SLA, ввод режима настройки конфигурации RTR.

Шаг 4 

type echo protocol ipIcmpEcho 
{destination-ip-address | destination-hostname} 
[source-ipaddr {ip-address | hostname} 
Пример.

Router(config-rtr)# type echo protocol ipIcmpEcho 172.16.23.7

Настройка операции проверки времени отклика для сквозного эхо-ответа функции Cisco IOS IP SLA.

Шаг 5 

timeout milliseconds

Пример.

Router(config-rtr)# timeout 1000

Установка времени ожидания ответа на пакет запроса функции Cisco IOS IP SLA.

Шаг 6 

frequency seconds

Пример.

Router(config-rtr)# frequency 3

Установка периодичности посылки запросов в сеть для указанной операции Cisco IOS IP SLA.

Шаг 7 

threshold milliseconds

Пример.

Router(config-rtr)# threshold 2

Установка верхнего порога (гистерезиса), при котором возникает ответное событие и сохраняются сведения об истории операций Cisco IOS IP SLA.

Шаг 8 

exit

Пример.

Router(config-rtr)# exit

Выход из режима настройки RTR.

Шаг 9 

rtr schedule operation-number [life {forever | seconds}] [start-time {hh:mm[:ss] [month day | day month] | pending | now | after hh:mm:ss}] [ageout seconds]

Пример.

Router(config)# rtr schedule 1 life forever start-time now

Настройка эхо-операции ICMP для функции Cisco IOS IP SLA.

Шаг 10 

track object-number rtr rtr-operation {state | reachability}

Пример.

Router(config)# track 123 rtr 1 reachability

Отслеживание состояния операций Cisco IOS IP SLA и вход в режим настройки отслеживания.

Настройка функции Cisco IOS IP SLA для программного обеспечения Cisco IOS версий 12.3(14)T, 12.4 и 12.4(2)T

Выполните эту операцию для создания настройки функции IP SLA для эхо-тестирования адреса назначения. Эта операция выполняется для настройки протоколов PPPoE, DHCP и статической маршрутизации.

СВОДКА ШАГОВ

1. enable

2. configure terminal

3. ip sla monitor [operation-number]

4. type echo protocol ipIcmpEcho {destination-ip-address | destination-hostname} [source-ipaddr {ip-address | hostname} | source-interface interface-name]

5. timeout milliseconds

6. frequency seconds

7. threshold milliseconds

8. exit

9. ip sla monitor schedule operation-number [life {forever | seconds}] [start-time {hh:mm[:ss] [month day | day month] | pending | now | after hh:mm:ss}] [ageout seconds] [recurring]

10. track object-number rtr rtr-operation {state | reachability}

ПОДРОБНОЕ ОПИСАНИЕ ШАГОВ

 
Команда или действие
Назначение

Шаг 1 

enable

Пример.

Router> enable

Вход в привилегированный режим EXEC.

При запросе введите пароль.

Шаг 2 

configure terminal

Пример.

Router# configure terminal

Вход в режим глобальной конфигурации.

Шаг 3 

ip sla monitor [operation-number]

Пример.

Router(config)# ip sla monitor 1

Начало настройки операций Cisco IOS IP SLA, ввод режима настройки конфигурации IP SLA.

Шаг 4 

type echo protocol ipIcmpEcho 
{destination-ip-address | destination-hostname} 
[source-ipaddr {ip-address | hostname} | 
source-interface interface-name]
Пример.

Router(config-sla-monitor)# type echo protocol ipIcmpEcho 172.16.23.7

Настройка операции проверки времени отклика для сквозного эхо-ответа ICMP для функции Cisco IOS IP SLA.

Шаг 5 

timeout milliseconds

Пример.

Router(config-sla-monitor-echo)# timeout 1000

Установка времени ожидания ответа на пакет запроса функции Cisco IOS IP SLA.

Шаг 6 

frequency seconds

Пример.

Router(config-sla-monitor-echo)# frequency 3

Установка периодичности посылки запросов в сеть для указанной операции Cisco IOS IP SLA.

Шаг 7 

threshold milliseconds

Пример.

Router(config-sla-monitor-echo)# threshold 2

Установка верхнего порога (гистерезиса), при котором возникает ответное событие и сохраняются сведения об истории операций Cisco IOS IP SLA.

Шаг 8 

exit

Пример.

Router(config-sla-monitor-echo)# exit

Выход из режима настройки эхо-операций ICMP для функции IP SLA.

Шаг 9 

ip sla monitor schedule operation-number [life {forever | seconds}] [start-time {hh:mm[:ss] [month day | day month] | pending | now | after hh:mm:ss}] [ageout seconds] [recurring]

Пример.

Router(config)# ip sla monitor schedule 1 life forever start-time now

Настройка параметров графика выполнения одиночной операции Cisco IOS IP SLA.

Шаг 10 

track object-number rtr rtr-operation {state | reachability}

Пример.

Router(config)# track 123 rtr 1 reachability

Отслеживание состояния операций Cisco IOS IP SLA и вход в режим настройки отслеживания.

Настройка функции Cisco IOS IP SLA для программного обеспечения Cisco IOS версии 12.4(4)T и более поздних версий

Выполните эту операцию для создания настройки функции IP SLA для эхо-тестирования адреса назначения. Эта операция выполняется для настройки протоколов PPPoE, DHCP и статической маршрутизации.

СВОДКА ШАГОВ

1. enable

2. configure terminal

3. ip sla [operation-number]

4. icmp-echo {destination-ip-address | destination-hostname} [source-ip {ip-address | hostname} | source-interface interface-name]

5. timeout milliseconds

6. frequency seconds

7. threshold milliseconds

8. exit

9. ip sla schedule operation-number [life {forever | seconds}] [start-time {hh:mm[:ss] [month day | day month] | pending | now | after hh:mm:ss}] [ageout seconds] [recurring]

10. track object-number rtr rtr-operation {state | reachability}

ПОДРОБНОЕ ОПИСАНИЕ ШАГОВ

 
Команда или действие
Назначение

Шаг 1 

enable

Пример.

Router> enable

Вход в привилегированный режим EXEC.

При запросе введите пароль.

Шаг 2 

configure terminal

Пример.

Router# configure terminal

Вход в режим глобальной конфигурации.

Шаг 3 

ip sla [operation-number]

Пример.

Router(config)# ip sla monitor 1

Начало настройки операций Cisco IOS IP SLA, ввод режима настройки конфигурации IP SLA.

Шаг 4 

icmp-echo {destination-ip-address | 
destination-hostname} [source-ip {ip-address | 
hostname} | source-interface interface-name]
Пример.

Router(config-ip-sla)# type echo protocol ipIcmpEcho 172.16.23.7

Настройка операции проверки времени отклика для сквозного эхо-ответа ICMP для функции Cisco IOS IP SLA.

Шаг 5 

timeout milliseconds

Пример.

Router(config-ip-sla-echo)# timeout 1000

Установка времени ожидания ответа на пакет запроса функции Cisco IOS IP SLA.

Шаг 6 

frequency seconds

Пример.

Router(config-ip-sla-echo)# frequency 3

Установка периодичности посылки запросов в сеть для указанной операции Cisco IOS IP SLA.

Шаг 7 

threshold milliseconds

Пример.

Router(config-ip-sla-echo)# threshold 2

Установка верхнего порога (гистерезиса), при котором возникает ответное событие и сохраняются сведения об истории операций Cisco IOS IP SLA.

Шаг 8 

exit

Пример.

Router(config-ip-sla-echo)# exit

Выход из режима настройки эхо-операций ICMP для функции IP SLA.

Шаг 9 

ip sla schedule operation-number [life {forever | seconds}] [start-time {hh:mm[:ss] [month day | day month] | pending | now | after hh:mm:ss}] [ageout seconds] [recurring]

Пример.

Router(config)# ip sla schedule 1 life forever start-time now

Настройка параметров графика выполнения одиночной операции Cisco IOS IP SLA.

Шаг 10 

track object-number rtr rtr-operation {state | reachability}

Пример.

Router(config)# track 123 rtr 1 reachability

Отслеживание состояния операций Cisco IOS IP SLA и вход в режим настройки отслеживания.

Настройка политики маршрутизации для надежной статической резервной маршрутизации с отслеживанием объектов

Для отслеживания состояния основного соединения с удаленным шлюзом эхо-посылки ICMP Cisco IOS IP SLA должны маршрутизироваться только через основной интерфейс.

Для настройки политики маршрутизации, которая будет гарантировать, что эхо-посылки Cisco IOS IP SLA всегда будут маршрутизироваться через основной интерфейс, выполните одну из следующих операций:

Настройка политики маршрутизации для PPPoE

Настройка политики маршрутизации для DHCP

Настройка политики маршрутизации для статической маршрутизации

Настройка политики маршрутизации для PPPoE

Если основной интерфейс настроен под PPPoE, для настройки политики маршрутизации выполните эту операцию.

СВОДКА ШАГОВ

1. enable

2. configure terminal

3. access-list access-list-number [dynamic dynamic-name [timeout minutes]] {deny | permit} icmp source source-wildcard destination destination-wildcard [icmp-type [icmp-code] | icmp-message] [precedence precedence] [tos tos] [log | log-input] [time-range time-range-name] [fragments]

4. route-map map-tag [permit | deny] [sequence-number]

5. match ip address {access-list-number | access-list-name} [... access-list-number | ...?access-list-name]

6. set interface type number [... type number]

7. exit

8. ip local policy route-map map-tag

ПОДРОБНОЕ ОПИСАНИЕ ШАГОВ

 
Команда или действие
Назначение

Шаг 1 

enable

Пример.

Router> enable

Вход в привилегированный режим EXEC.

При запросе введите пароль.

Шаг 2 

configure terminal

Пример.

Router# configure terminal

Вход в режим глобальной конфигурации.

Шаг 3 

access-list access-list-number [dynamic dynamic-name [timeout minutes]] {deny | permit} icmp source source-wildcard destination destination-wildcard [icmp-type [icmp-code] | icmp-message] [precedence precedence] [tos tos] [log | log-input] [time-range time-range-name] [fragments]

Пример.

Router(config)# access-list 101 permit icmp any host 172.16.23.7 echo

Определяет расширенный список доступа IP.

Шаг 4 

route-map map-tag [permit | deny] [sequence-number]

Пример.

Router(config)# route-map MY-LOCAL-POLICY permit 10

Вход в режим настройки карты маршрутизации и определение условий для перераспределения маршрутов из одного протокола маршрутизации в другой.

Шаг 5 

match ip address {access-list-number | access-list-name} [... access-list-number | ...?access-list-name]

Пример.

Router(config-route-map)# match ip address 101

Распределение маршрутов, имеющих адрес в сети назначения, разрешенной в стандартном или расширенном списке доступа, или настройка политики маршрутизации пакетов.

Шаг 6 

set interface type number [... type number]

Пример.

Router(config-route-map)# set interface null 0

Указание места выхода пакетов, удовлетворяющих условию карты маршрутизации для политики маршрутизации.

Примечание. По этому сценарию необходимо настроить интерфейс для null 0. Если следующий маршрутизатор невозможно настроить, потому что интерфейс не отвечает, пакет будет пересылаться на интерфейс null и отбрасываться. В противном случае политика маршрутизации будет нарушена, и пакет будет маршрутизироваться с помощью платы базы данных маршрутов (RIB). Маршрутизация пакетов с использованием платы RIB нежелательна.

Шаг 7 

exit

Пример.

Router(config-route-map)# exit

Выход из режима настройки карты маршрутизации.

Шаг 8 

ip local policy route-map map-tag

Пример.

Router(config)# ip local policy route-map MY-LOCAL-POLICY

Определение карты маршрутизации для использования локальной политики маршрутизации.

Настройка политики маршрутизации для DHCP

Если основной интерфейс настроен под DHCP, для настройки политики маршрутизации выполните эту операцию.

СВОДКА ШАГОВ

1. enable

2. configure terminal

3. access-list access-list-number [dynamic dynamic-name [timeout minutes]] {deny | permit} icmp source source-wildcard destination destination-wildcard [icmp-type [icmp-code] | icmp-message] [precedence precedence] [tos tos] [log | log-input] [time-range time-range-name] [fragments]

4. route-map map-tag [permit | deny] [sequence-number]

5. match ip address {access-list-number | access-list-name} [... access-list-number | ...?access-list-name]

6. set ip next-hop dynamic dhcp

7. exit

8. ip local policy route-map map-tag

ПОДРОБНОЕ ОПИСАНИЕ ШАГОВ

 
Команда или действие
Назначение

Шаг 1 

enable

Пример.

Router> enable

Вход в привилегированный режим EXEC.

При запросе введите пароль.

Шаг 2 

configure terminal

Пример.

Router# configure terminal

Вход в режим глобальной конфигурации.

Шаг 3 

access-list access-list-number [dynamic dynamic-name [timeout minutes]] {deny | permit} icmp source source-wildcard destination destination-wildcard [icmp-type [icmp-code] | icmp-message] [precedence precedence] [tos tos] [log | log-input] [time-range time-range-name] [fragments]

Пример.

Router(config)# access-list 101 permit icmp any host 172.16.23.7 echo

Определяет расширенный список доступа IP.

Шаг 4 

route-map map-tag [permit | deny] [sequence-number]

Пример.

Router(config)# route-map MY-LOCAL-POLICY permit 10

Вход в режим настройки карты маршрутизации и определение условий для перераспределения маршрутов из одного протокола маршрутизации в другой.

Шаг 5 

match ip address {access-list-number | access-list-name} [... access-list-number | ...?access-list-name]

Пример.

Router(config-route-map)# match ip address 101

Распределение маршрутов, имеющих адрес в сети назначения, разрешенной в стандартном или расширенном списке доступа, или настройка политики маршрутизации пакетов.

Шаг 6 

set ip next-hop dynamic dhcp

Пример.

Router(config-route-map)# set ip next-hop dynamic dhcp

Указать, что следующим узлом является шлюз, который был получен клиентом DHCP последним.

Шаг 7 

exit

Пример.

Router(config-route-map)# exit

Выход из режима настройки карты маршрутизации.

Шаг 8 

ip local policy route-map map-tag

Пример.

Router(config)# ip local policy route-map MY-LOCAL-POLICY

Определение карты маршрутизации для использования локальной политики маршрутизации.

Настройка политики маршрутизации для статической маршрутизации

Если основной интерфейс настроен под статическую маршрутизацию, для настройки политики маршрутизации выполните эту операцию.

Настройка политики маршрутизации для статической маршрутизации со сквозным основным шлюзом

Настройка политики маршрутизации для статической маршрутизации с многоточечным основным шлюзом

Настройка политики маршрутизации для статической маршрутизации со сквозным основным шлюзом

Если основной интерфейс настроен под статическую маршрутизацию, а основной шлюз является сквозным, для настройки политики маршрутизации выполните эту операцию.

СВОДКА ШАГОВ

1. enable

2. configure terminal

3. access-list access-list-number [dynamic dynamic-name [timeout minutes]] {deny | permit} icmp source source-wildcard destination destination-wildcard [icmp-type [icmp-code] | icmp-message] [precedence precedence] [tos tos] [log | log-input] [time-range time-range-name] [fragments]

4. route-map map-tag [permit | deny] [sequence-number]

5. match ip address {access-list-number | access-list-name} [... access-list-number | ...?access-list-name]

6. set interface type number [... type number]

7. exit

8. ip local policy route-map map-tag

ПОДРОБНОЕ ОПИСАНИЕ ШАГОВ

 
Команда или действие
Назначение

Шаг 1 

enable

Пример.

Router> enable

Вход в привилегированный режим EXEC.

При запросе введите пароль.

Шаг 2 

configure terminal

Пример.

Router# configure terminal

Вход в режим глобальной конфигурации.

Шаг 3 

access-list access-list-number [dynamic dynamic-name [timeout minutes]] {deny | permit} icmp source source-wildcard destination destination-wildcard [icmp-type [icmp-code] | icmp-message] [precedence precedence] [tos tos] [log | log-input] [time-range time-range-name] [fragments]

Пример.

Router(config)# access-list 101 permit icmp any host 172.16.23.7 echo

Определяет расширенный список доступа IP.

Шаг 4 

route-map map-tag [permit | deny] [sequence-number]

Пример.

Router(config)# route-map MY-LOCAL-POLICY permit 10

Вход в режим настройки карты маршрутизации и определение условий для перераспределения маршрутов из одного протокола маршрутизации в другой.

Шаг 5 

match ip address {access-list-number | access-list-name} [... access-list-number | ...?access-list-name]

Пример.

Router(config-route-map)# match ip address 101

Распределение маршрутов, имеющих адрес в сети назначения, разрешенной в стандартном или расширенном списке доступа, или настройка политики маршрутизации пакетов.

Шаг 6 

set interface type number [... type number]

Пример.

Router(config-route-map)# set interface dialer 0 Null 0

Указание места выхода пакетов, удовлетворяющих условию карты маршрутизации для политики маршрутизации.

Шаг 7 

exit

Пример.

Router(config-route-map)# exit

Выход из режима настройки карты маршрутизации.

Шаг 8 

ip local policy route-map map-tag

Пример.

Router(config)# ip local policy route-map MY-LOCAL-POLICY

Определение карты маршрутизации для использования локальной политики маршрутизации.

Настройка политики маршрутизации для статической маршрутизации с многоточечным основным шлюзом

Если основной интерфейс настроен под статическую маршрутизацию, а основной шлюз является многоточечным, для настройки политики маршрутизации выполните эту операцию.

СВОДКА ШАГОВ

1. enable

2. configure terminal

3. access-list access-list-number [dynamic dynamic-name [timeout minutes]] {deny | permit} icmp source source-wildcard destination destination-wildcard [icmp-type [icmp-code] | icmp-message] [precedence precedence] [tos tos] [log | log-input] [time-range time-range-name] [fragments]

4. route-map map-tag [permit | deny] [sequence-number]

5. match ip address {access-list-number | access-list-name} [... access-list-number | ...?access-list-name]

6. set ip next-hop ip-адрес [... ip-адрес]

7. set interface type number [... type number]

8. exit

9. ip local policy route-map map-tag

ПОДРОБНОЕ ОПИСАНИЕ ШАГОВ

 
Команда или действие
Назначение

Шаг 1 

enable

Пример.

Router> enable

Вход в привилегированный режим EXEC.

При запросе введите пароль.

Шаг 2 

configure terminal

Пример.

Router# configure terminal

Вход в режим глобальной конфигурации.

Шаг 3 

access-list access-list-number [dynamic dynamic-name [timeout minutes]] {deny | permit} icmp source source-wildcard destination destination-wildcard [icmp-type [icmp-code] | icmp-message] [precedence precedence] [tos tos] [log | log-input] [time-range time-range-name] [fragments]

Пример.

Router(config)# access-list 101 permit icmp any host 172.16.23.7 echo

Определяет расширенный список доступа IP.

Шаг 4 

route-map map-tag [permit | deny] [sequence-number]

Пример.

Router(config)# route-map MY-LOCAL-POLICY permit 10

Вход в режим настройки карты маршрутизации и определение условий для перераспределения маршрутов из одного протокола маршрутизации в другой.

Шаг 5 

match ip address {access-list-number | access-list-name} [... access-list-number | ...?access-list-name]

Пример.

Router(config-route-map)# match ip address 101

Распределение маршрутов, имеющих адрес в сети назначения, разрешенной в стандартном или расширенном списке доступа, или настройка политики маршрутизации пакетов.

Шаг 6 

set ip next-hop ip-адрес [... ip-адрес]

Пример.

Router(config-route-map)# set ip next-hop 10.1.1.242

Указание места выхода пакетов, удовлетворяющих условию карты маршрутизации для политики маршрутизации.

Шаг 7 

set interface type number [... type number]

Пример.

Router(config-route-map)# set interface null 0

Указание места выхода пакетов, удовлетворяющих условию карты маршрутизации для политики маршрутизации.

Шаг 8 

exit

Пример.

Router(config-route-map)# exit

Выход из режима настройки карты маршрутизации.

Шаг 9 

ip local policy route-map map-tag

Пример.

Router(config)# ip local policy route-map MY-LOCAL-POLICY

Определение карты маршрутизации для использования локальной политики маршрутизации.

Настройка маршрута по умолчанию для основного интерфейса с использованием статической маршрутизации

Выполнение задачи по настройке статического маршрута по умолчанию при использовании только статической маршрутизации.

СВОДКА ШАГОВ

1. enable

2. configure terminal

3. ip route prefix mask {ip-address | interface-type interface-number [ip-address]} [distance] [name] [permanent | track number] [tag tag]

ПОДРОБНОЕ ОПИСАНИЕ ШАГОВ

 
Команда или действие
Назначение

Шаг 1 

enable

Пример.

Router> enable

Вход в привилегированный режим EXEC.

При запросе введите пароль.

Шаг 2 

configure terminal

Пример.

Router# configure terminal

Вход в режим глобальной конфигурации.

Шаг 3 

ip route prefix mask {ip-address | interface-type interface-number [ip-address]} [distance] [name] [permanent | track number] [tag tag]

Пример.

Router(config)# ip route 0.0.0.0 0.0.0.0 10.1.1.242 track 123

Установка статических маршрутов.

track number — указывает, что статический маршрут будет установлен, только если настроенный объект отслеживания находится в рабочем состоянии.

Настройка плавающего статического маршрута по умолчанию для вторичного интерфейса

Выполнение задачи по настройке плавающего статического маршрута по умолчанию для вторичного интерфейса. Эта операция выполняется для настройки протоколов PPPoE, DHCP и статической маршрутизации.

СВОДКА ШАГОВ

1. enable

2. configure terminal

3. ip route network-number network-mask {ip-address | interface} [distance] [name name]

ПОДРОБНОЕ ОПИСАНИЕ ШАГОВ

 
Команда или действие
Назначение

Шаг 1 

enable

Пример.

Router> enable

Вход в привилегированный режим EXEC.

При запросе введите пароль.

Шаг 2 

configure terminal

Пример.

Router# configure terminal

Вход в режим глобальной конфигурации.

Шаг 3 

ip route network-number network-mask {ip-address | interface} [distance] [name name]

Пример.

Router(config)# ip route 0.0.0.0 0.0.0.0 10.2.2.125 254

Установка статических маршрутов и определение следующего узла.

Проверка состояния отслеживаемого объекта для надежной статической резервной маршрутизации с отслеживанием объектов

Выполнение задачи по определению состояния отслеживаемого объекта — «Включен» или «Выключен».

СВОДКА ШАГОВ

1. enable

2. show ip route track-table

ПОДРОБНОЕ ОПИСАНИЕ ШАГОВ

 
Команда или действие
Назначение

Шаг 1 

enable

Пример.

Router> enable

Вход в привилегированный режим EXEC.

При запросе введите пароль.

Шаг 2 

show ip route track-table

Пример.

Router# show ip route track-table

Вывод информации о таблице отслеживания маршрутов IP.

Примеры настройки надежной статической резервной маршрутизации с отслеживанием объектов

В этом разделе приведены следующие примеры конфигурации:

Настройка надежной статической резервной маршрутизации с отслеживанием объектов: пример для протокола PPPoE

Настройка надежной статической резервной маршрутизации с отслеживанием объектов: пример для протокола DHCP

Настройка надежной статической резервной маршрутизации с отслеживанием объектов: примеры статической маршрутизации

Проверка состояния отслеживаемого объекта: пример

Настройка надежной статической резервной маршрутизации с отслеживанием объектов: пример для протокола PPPoE

Ниже приведен пример настройки функции надежной статической резервной маршрутизации с отслеживанием объектов с использованием PPPoE. В качестве основного интерфейса используется интерфейс ATM, в качестве вторичного интерфейса — интерфейс BRI (Basic Rate Interface). Этот пример применим к программному обеспечению Cisco IOS версии 12.3(8)T, Cisco IOS версии 12.3(11)T и Cisco IOS версии 12.2(33)SRA.

interface ATM 0
 description primary-link
 no ip address
 pvc 0/33
  pppoe-client dial-pool-number 1
!
interface BRI 0
 description backup-link
 ip address 10.2.2.2 255.0.0.0
!
rtr 1
 type echo protocol ipIcmpEcho 172.16.23.7
 timeout 1000
 frequency 3
 threshold 2

rtr schedule 1 life forever start-time now
track 123 rtr 1 reachability

access list 101 permit icmp any host 172.16.23.7 echo
route map MY-LOCAL-POLICY permit 10
 match ip address 101
 set interface null 0
!
ip local policy route-map MY-LOCAL-POLICY

ip route 0.0.0.0 0.0.0.0 10.2.2.125 254

Настройка надежной статической резервной маршрутизации с отслеживанием объектов: пример для протокола DHCP

Ниже приведен пример настройки функции надежной статической резервной маршрутизации с отслеживанием объектов с использованием DHCP. В качестве основного интерфейса используется интерфейс Ethernet, в качестве вторичного интерфейса — последовательный интерфейс. Этот пример применим к программному обеспечению Cisco IOS версии 12.3(14)T и более поздних версий.

!
ip dhcp-client default-router distance 25 
ip sla monitor 1
  type echo protocol ipIcmpEcho 172.16.23.7
  timeout 1000
  threshold 2
  frequency 3
ip sla monitor schedule 1 life forever start-time now 
track 123 rtr 1 reachability
!
interface Ethernet0/0
  description primary-link
  ip dhcp client route track 123
  ip address dhcp
!
interface Serial2/0
  description backup-link
  ip address 10.2.2.2 255.0.0.0
!
ip local policy route-map MY-LOCAL-POLICY 
ip route 0.0.0.0 0.0.0.0 10.2.2.125 254
!
access-list 101 permit icmp any host 172.16.23.7 echo 
route-map MY-LOCAL-POLICY permit 10
  match ip address 101
  set ip next-hop dynamic dhcp

Настройка надежной статической резервной маршрутизации с отслеживанием объектов: примеры статической маршрутизации

Ниже приведен пример настройки функции надежной статической резервной маршрутизации с отслеживанием объектов с использованием статической маршрутизации для сквозного основного шлюза. В качестве основного интерфейса используется интерфейс PPPoE Fast Ethernet, в качестве вторичного интерфейса — интерфейс номеронабирателя. Этот пример применим к программному обеспечению Cisco IOS версии 12.3(14)T и более поздних версий.

interface FastEthernet 0/0
 description primary-link
 ip address 10.1.1.1 255.0.0.0

interface Dialer 0
 description backup-link
 ip address 10.2.2.2 255.0.0.0

ip sla monitor 1
 type echo protocol ipIcmpEcho 172.16.23.7
 timeout 1000
 frequency 3
 threshold 2

ip sla monitor schedule 1 life forever start-time now
track 123 rtr 1 reachability

access list 101 permit icmp any host 172.16.23.7 echo
route map MY-LOCAL-POLICY permit 10
 match ip address 101
 set interface dialer 0 null 0
!
ip local policy route-map MY-LOCAL-POLICY

ip route 0.0.0.0 0.0.0.0 10.1.1.242 track 123
ip route 0.0.0.0 0.0.0.0 10.2.2.125 254

Ниже приведен пример настройки функции надежной статической резервной маршрутизации с отслеживанием объектов с использованием статической маршрутизации для многоточечного основного шлюза. В качестве основного и вторичного интерфейса используются интерфейсы Ethernet. Этот пример применим к программному обеспечению Cisco IOS версии 12.3(14)T и более поздних версий.

interface ethernet 0
 description primary-link
 ip address 10.1.1.1 255.0.0.0

interface ethernet 1
 description backup-link
 ip address 10.2.2.2 255.0.0.0

ip sla monitor 1
 type echo protocol ipIcmpEcho 172.16.23.7
 timeout 1000
 frequency 3
 threshold 2

ip sla monitor schedule 1 life forever start-time now
track 123 rtr 1 reachability

access list 101 permit icmp any host 172.16.23.7 echo
route map MY-LOCAL-POLICY permit 10
 match ip address 101
 set ip next-hop 10.1.1.242
 set interface null 0
!
ip local policy route-map MY-LOCAL-POLICY

ip route 0.0.0.0 0.0.0.0 10.1.1.242 track 123
ip route 0.0.0.0 0.0.0.0 10.2.2.125 254

Проверка состояния отслеживаемого объекта: пример

Ниже приведен пример вывода информации об отслеживаемом объекте в таблице отслеживания маршрутов IP.

Router# show ip route track-table

ip route 0.0.0.0 0.0.0.0 10.1.1.242 track-object 123 state is [up]

Дополнительные ссылки

В следующем разделе приведены ссылки, относящиеся к функции надежной статической резервной маршрутизации.

Дополнительная документация

Смежная тема
Название документа

Задачи конфигурации IPSec

Глава «Настройка сетевой безопасности IPSec» в книге Руководство по конфигурации безопасности Cisco IOS

Команды IPSec: полный синтаксис команд, режим команд, история команд, параметры по умолчанию, руководства по использованию и примеры

Справочник по командам безопасности Cisco IOS

Задачи конфигурации VPDN

Руководство по настройке VPDN для Cisco IOS

Команды VPDN: полный синтаксис команд, режим команд, история команд, параметры по умолчанию, руководства по использованию и примеры

Справочник по командам VPDN для Cisco IOS

Задачи конфигурации PPPoE

Глава «Настройка широкополосного доступа: PPP и инкапсуляция маршрутизируемого моста» в книге Руководство по настройке глобальной сети Cisco IOS

Команды PPPoE: полный синтаксис команд, режим команд, история команд, параметры по умолчанию, руководства по использованию и примеры

Справочник по командам для глобальных сетей Cisco IOS

Задачи конфигурации DDR

Раздел «Настройка маршрутизации с соединением по требованию» в книге Руководство по настройке технологий дозвона Cisco IOS

Выполнение настроек и устранение неполадок при резервировании с соединением по требованию (DDR)

Команды DDR: полный синтаксис команд, режим команд, история команд, параметры по умолчанию, указания по использованию и примеры

Справочник по командам технологий дозвона Cisco IOS

Задачи настройки функции IP SLA

Руководство по настройке функции IP SLA для Cisco IOS

Команды IP SLA: полный синтаксис команд, режим команд, история команд, параметры по умолчанию, руководства по использованию и примеры

Справочник по командам IP SLA Cisco IOS


Стандарты

Стандарты
Название

Нет


Базы данных MIB

Базы данных MIB
Ссылка на базы данных MIB

Нет

Для поиска и загрузки баз данных управляющей информации (Management Information Base, MIB) для выбранных платформ, версий программного обеспечения Cisco IOS и наборов характеристик воспользуйтесь страницей поиска баз данных Cisco MIB Locator по следующему адресу:

http://tools.cisco.com/ITDIT/MIBS/servlet/index


Документы RFC

Документы RFC
Название

Нет


Техническая поддержка

Описание
Ссылка

Главная страница центра технической поддержки (Technical Assistance Center, TAC), содержащая 30 000 страниц технической информации с возможностью поиска, включая ссылки на продукты, технологии, решения, технические советы и инструментальные средства. Зарегистрированные пользователи веб-сайта cisco.com могут войти в систему с этой страницы и получить еще более обширную информацию.

http://www.cisco.com/cisco/web/RU/support


Справочник по командам

В этом разделе описаны новые и измененные команды.

ip dhcp client

ip route

set ip next-hop dynamic dhcp

show ip route track-table

ip dhcp client

Для настройки клиента протокола DHCP и привязки любого добавляемого маршрутизатора с отслеживаемым объектом с определенным номером воспользуйтесь командой ip dhcp client в режиме настройки интерфейса. Для восстановления настроек по умолчанию используйте эту команду с префиксом no.

ip dhcp client route track number

no ip dhcp client route track

Описание синтаксиса

route track number

Связывает номер отслеживаемого объекта с установленным для протокола DHCP статическим маршрутом. Допустимый диапазон значений для аргумента number — от 1 до 500.


Значение по умолчанию

С номером отслеживаемого объекта не связан ни один маршрут.

Командные режимы

Настройка интерфейса

История команды

Версия
Изменение

12.3(2)XE

Команда включена впервые.

12.3(8)T

Эта команда была включена в программное обеспечение Cisco IOS версии 12.3(8)T.

12.2(33)SRA

Эта команда была включена в программное обеспечение Cisco IOS версии 12.2(33)SRA.


Указания по использованию

Команду ip dhcp client следует настроить перед вводом команды ip address dhcp в интерфейсе. Команда ip dhcp client проверяется только при получении IP-адреса в DHCP. Если команда ip dhcp client посылается после получения IP-адреса в DHCP, команда ip dhcp client не окажет действия до следующего получения маршрутизатором IP-адреса в DHCP.

Примеры

Ниже приведен пример настройки протокола DHCP на интерфейсе Ethernet и привязки отслеживаемого объекта 123 к маршруту, созданному на этом интерфейсе:

interface ethernet 0/0
 ip dhcp client route track 123
 ip address dhcp

Связанные команды

Команда
Описание

ip address dhcp

Назначение IP-адреса интерфейса Ethernet средствами протокола DHCP.


ip route

Для создания статических маршрутов используйте команду ip route в режиме глобальной конфигурации. Чтобы удалить статические маршруты, используйте эту команду с ключом no.

ip route prefix mask {ip-address | interface-type interface-number [ip-address]} [dhcp] [distance] [name] [permanent | track number] [tag tag]

no ip route prefix mask

Описание синтаксиса

prefix

Префикс маршрута IP для места назначения.

mask

Маска префикса для места назначения.

ip-address

IP-адрес следующего узла, который можно использовать для перехода в нужную сеть.

interface-type interface-number

Тип и номер сетевого интерфейса.

dhcp

(Необязательно) Позволяет серверу протокола DHCP назначить статический маршрут на шлюз по умолчанию (параметр 3).

Примечание. Определите ключевое слово dhcp для каждого протокола маршрутизации.

distance

(Необязательно) Административное расстояние. Административное расстояние по умолчанию для статического маршрута равно 1.

name

(Необязательно) Назначает имя статическому маршруту.

permanent

(Необязательно) Указывает, что маршрут не может быть удален даже при закрытии сетевого интерфейса.

track number

(Необязательно) Связывает отслеживаемый объект с указанным маршрутом. Допустимый диапазон значений для аргумента number — от 1 до 500.

tag tag

(Необязательно) Значение тега может использоваться в качестве «шаблона» значения для перераспределения управления по картам маршрутов.


Значение по умолчанию

Статические маршруты не требуются.

Командные режимы

Глобальная конфигурация

История команды

Версия
Изменение

10.0

Команда включена впервые.

12.3(2)XE

Добавлены ключевое слово track и аргумент number.

12.3(8)T

Ключевое слово track и аргумент number встроены в программное обеспечение Cisco IOS версии 12.3(8)T. Добавлено ключевое слово dhcp.

12.3(9)

Изменения, сделанные в программном обеспечении Cisco IOS версии 12.3(8)T, были добавлены в Cisco IOS версии 12.3(9).

12.2(33)SRA

Эта команда была включена в программное обеспечение Cisco IOS версии 12.2(33)SRA.


Указания по использованию

Организацию статического маршрута рекомендуется производить, если программное обеспечение Cisco IOS не в состоянии динамически построить маршрут в точку назначения.

При определении DHCP-сервера для назначения статического маршрута следует также настроить тип и номер интерфейса, а кроме того административное расстояние.

При указании административного расстояния маркируется статический маршрут, который может быть заменен динамической информацией. Например, маршруты, устанавливаемые через усовершенствованный внутренний протокол маршрутизации (Enhanced Interior Gateway Routing Protocol, EIGRP), имеют по умолчанию административное расстояние 100. Чтобы получить статический маршрут, который может быть заменен на динамический маршрут по протоколу EIGRP, укажите административное расстояние больше 100. Статические маршруты по умолчанию имеют административное расстояние 1.

Статические маршруты, которые указывают на интерфейс на подсоединенном маршрутизаторе, будут заявлены при помощи протокола маршрутной информации (Routing Information Protoco, RIP) и протокола EIGRP вне зависимости от того, определена ли для этих протоколов команда redistribute static. Такая ситуация возникает из-за того, что статические маршруты, которые указывают на интерфейс, в таблице маршрутизации рассматриваются как подсоединенные, и поэтому утратившие свою статическую природу. Кроме того, целевой узел статического маршрута должен быть включен в команду network (DHCP). Если это условие не соблюдено, маршрут не будет указан протоколом динамической маршрутизации, если только для этих протоколов не определена команда redistribute static. Для следующей конфигурации:

rtr1 (serial 172.16.188.1/30)--------------> rtr2(Fast Ethernet 172.31.1.1/30) ------>

router [rip | eigrp]
 network 172.16.188.0
 network 172.31.0.0 

Протоколы RIP и EIGRP перераспределяют маршрут, если маршрут указывает на интерфейс Fast Ethernet:

ip route 172.16.188.252 255.255.255.252 FastEthernet 0/0 

Протоколы RIP и EIGRP не перераспределяют маршрут по команде ip route, из-за алгоритма разделения горизонта:

ip route 172.16.188.252 255.255.255.252 serial 2/1 

Протокол EIGRP перераспределяет маршрут по обеим командам:

ip route 172.16.188.252 255.255.255.252 FastEthernet 0/0
ip route 172.16.188.252 255.255.255.252 serial 2/1 

Если первым используется протокол открытия кратчайшего маршрута (Open Shortest Path First, OSPF), то статические маршруты, которые указывают на интерфейс, не объявляются в отсутствие команды redistribute static.

Добавление статического маршрута к Ethernet или другому широковещательному интерфейсу (например, ip route 0.0.0.0 0.0.0.0 Ethernet 1/2) приведет к вставке маршрута в таблицу маршрутизации только если этот интерфейс включен. Использовать такую конфигурацию обычно не рекомендуется. Если следующий узел статического маршрута указывает на интерфейс, маршрутизатор выбирает любой из узлов маршрута, который подключен напрямую через этот интерфейс, и посылает запросы протокола разрешения адресов (Address Resolution Protocol, ARP) на все адреса получателя, которые маршрутизируются через статический маршрут.

Практическое следствие настройки команды ip route 0.0.0.0 0.0.0.0 ethernet 1/2 состоит в том, что маршрутизатор будет считать все узлы-получатели, о доступе к которым по тому же маршруту маршрутизатор не осведомлен, подключены напрямую к интерфейсу Ethernet 1/2. Поэтому маршрутизатор будет посылать запрос ARP всем узлам, для которых он получает пакеты в этом сегменте сети. Такая конфигурация может привести к высокой нагрузке на процессор и большому кэшу ARP (что сопровождается ошибками выделения памяти). Настройка маршрута по умолчанию или другого статического маршрута, который требует от маршрутизатора пересылки пакетов на большое количество узлов получателя в связанном с ним сегменте широковещательной сети может привести к перезагрузке маршрутизатора.

Указание цифрами следующего узла, который напрямую подключен к интерфейсу, не позволит маршрутизатору использовать прокси ARP. Однако если интерфейс со следующим узлом неактивен, указанного цифрами следующего узла можно достигнуть по рекурсивному маршруту, и можно определить как следующий узел, так и интерфейс (например, ip route 0.0.0.0 0.0.0.0 ethernet 1/2 10.1.2.3) при помощи статического маршрута, чтобы предотвратить создание при помощи статического маршрута маршрутизацию с проходом через не запрашиваемый интерфейс.

Ключевое слово track number и комбинация аргументов указывают, что статический маршрут можно установить только если настраиваемый отслеживаемый объект находится в состоянии «Включен».

Примеры

В следующем примере устанавливается административное расстояние 110. В этом случае, если динамическая информация с административным расстоянием менее 110 недоступна, пакеты для сети 10.0.0.0 будут направляться через маршрутизатор по адресу 172.31.3.4.

ip route 10.0.0.0 255.0.0.0 172.31.3.4 110

Примечание. Указание следующего узла без указания интерфейса при настройке статического маршрута может привести к проходу трафика через не запрашиваемый интерфейс, если интерфейс по умолчанию не работает.


В следующем примере пакеты для сети 172.31.0.0 перенаправляются на маршрутизатор 172.31.6.6:

ip route 172.31.0.0 255.255.0.0 172.31.6.6 

В следующем примере пакеты для сети 192.168.1.0 направляются прямо на следующий узел на 10.1.2.3. Если интерфейс не работает, этот маршрут удаляется из таблицы маршрутизации и не восстанавливается, пока интерфейс не заработает.

ip route 192.168.1.0 255.255.0.0 Ethernet 0 10.1.2.3 

В следующем примере статический маршрут организуется только если состояние отслеживаемого объекта 123 активно:

ip route 0.0.0.0 0.0.0.0 Ethernet 0/1 10.1.1.242 track 123

В следующем примере показано, что использование ключевого слова dhcp при настройке интерфейсов Ethernet 1 и 2 позволяет интерфейсам получить IP-адреса следующего маршрутизатора с DHCP-сервера:

ip route 10.165.200.225 255.255.255.255 ether1 dhcp
ip route 10.165.200.226 255.255.255.255 ether2 dhcp 20

Связанные команды

Команда
Описание

network (DHCP)

Настраивает номер и маску подсети для пула адресов DHCP на DHCP-сервере Cisco IOS.

redistribute (IP)

Перераспределяет маршруты с одного домена маршрутизации на другой.


set ip next-hop dynamic dhcp

Для указания следующего узла на пути к шлюзу, который был получен клиентом DHCP последним, используйте команду set ip next-hop dynamic dhcp в режиме настройки карты маршрутизации. Для восстановления настроек по умолчанию используйте эту команду с префиксом no.

set ip next-hop dynamic dhcp

no set ip next-hop dynamic dhcp

Описание синтаксиса

У этой команды нет аргументов и ключевых слов.

Значение по умолчанию

Эта команда по умолчанию отключена.

Командные режимы

Настройка карты маршрутизации

История команды

Версия
Изменение

12.3(2)XE

Команда включена впервые.

12.3(8)T

Эта команда была включена в программное обеспечение Cisco IOS версии 12.3(8)T.

12.2(33)SRA

Эта команда была включена в программное обеспечение Cisco IOS версии 12.2(33)SRA.


Указания по использованию

Команда set ip next-hop dynamic dhcp поддерживает только один интерфейс DHCP. Если протокол DHCP настраивается на нескольких интерфейсах, шлюз, который был получен последним всеми интерфейсами DHCP, будет использоваться картой маршрутизации.

Примеры

В следующем примере настраивается локальная политика маршрутизации, в которой устанавливается следующий узел на пути к шлюзу, который был получен клиентом DHCP последним:

access list 101 permit icmp any host 172.16.23.7 echo
route map MY-LOCAL-POLICY permit 10
 match ip address 101
 set ip next-hop dynamic dhcp
!
ip local policy route-map MY-LOCAL-POLICY

Связанные команды

Команда
Описание

access list (расширенный IP)

Определяет расширенный список доступа IP.


show ip route track-table

Для вывода информации о таблице отслеживания маршрутов IP используйте команду show ip route track-table в привилегированном режиме EXEC.

show ip route track-table

Описание синтаксиса

У этой команды нет аргументов и ключевых слов.

Командные режимы

Привилегированный EXEC

История команды

Версия
Изменение

12.3(2)XE

Команда включена впервые.

12.3(8)T

Эта команда была включена в программное обеспечение Cisco IOS версии 12.3(8)T.

12.2(33)SRA

Эта команда была включена в программное обеспечение Cisco IOS версии 12.2(33)SRA.


Примеры

В следующем примере на экран выводится информация о таблице отслеживания маршрутов IP:

Router# show ip route track-table

ip route 0.0.0.0 0.0.0.0 10.1.1.242 track-object 123 state is [up]

Таблица 1 описывает важные поля, выводимые на дисплей.

Таблица 1. Описание полей команды show ip route track-table

Поле
Описание

ip route

Настроенный маршрут.

track-object

Номер отслеживаемого объекта.

state is

Состояние отслеживаемого объекта. Объект может быть включен («up») или выключен («down»).