Протокол IP : IP версии 6 (IPv6)

IPv6: Подключение к сети 6bone с использованием туннелей 6to4

23 марта 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Отзыв


Содержание

IPv6: Подключение к сети 6bone с использованием туннелей 6to4
Цели
Решения
Решение № 2, туннели 6to4
Реализация
Дополнительная документация

IPv6: Подключение к сети 6bone с использованием туннелей 6to4


История версии

Номер версии Дата Примечания

1

28 февраля 2002 г.

Дата создания этого документа.

2

19 мая 2003 г.

Обновление раздела дополнительной документации.

В этом документе описывается, как клиент корпоративного кампуса (например, учебное заведение, небольшая фирма по разработке ПО или небольшая производственная компания) может подключиться к сети 6bone с использованием туннелей 6to4. 6bone — это испытательная сеть IP версии 6 (IPv6), которая была создана для развития и внедрения протокола IPv6 в Интернете.

Этот документ включен в набор документов, которые поддерживают и дополняют публикацию Стратегии внедрения IPv6, доступную по адресу:

http://www.cisco.com/univercd/cc/td/doc/cisintwk/intsolns/IPv6_sol/IPv6dswp.pdf

Этот документ следует изучить в комплекте с публикацией Стратегии внедрения IPv6, чтобы лучше понять действия, выполняемые перед внедрением протокола IPv6.

Этот документ содержит следующие разделы:

Цели

Обсуждается слияние маленькой компании по разработке ПО (считаем ее типичной средой кампуса), имеющей сеть IPv4, с другой компанией, в сети которой используется протокол IPv6. Чтобы оценить влияние, которое окажет слияние компаний на возможности подключения, клиенту нужно расширить свои знания о IPv6, подключившись к сети 6bone. В настоящем документе рассматриваются следующие цели клиентов компоративного кампуса:

  • С минимальными затратами приобрести опыт использования протокола IPv6 в установленной сети IPv6 с использованием существующей топологии IPv4.
  • Перед внедрением протокола IPv6 выполнить проверку переходных и рабочих процедур в реальном окружении с протоколом IPv6 в пределах кампуса.

Переходные процедуры — это процедуры, необход8мые для перехода с протокола IPv4 на IPv6. Эти процедуры включают настройку маршрутизаторов с двумя стеками и конечных систем, механизмы туннелирования, серверы DNS, а в будущем планируется тестирование преобразования NAT-PT.

К рабочим процедурам относится управление сетью, управление элементами узлов с двумя стеками и конечных систем, а также другими сходными функциями.

  • Проверить использование и реализацию протокола IPv6 на локальных рабочих станциях.
  • Минимизировать служебную информацию для управления, связанную с подключением сети 6bone.

  • Примечание.   Хотя сеть 6bone включает многие типы организаций (например, учебные и правительственные организации, производителей аппаратного и программного обеспечения, поставщиков услуг), в данной документации используется термин поставщик интернет-услуг сети 6bone, если речь идет об организации, которая находится в конечной точке 6bone-туннеля.

Исходная топология сети

На рис. 1 показана исходная топология сети IPv4 для клиента корпоративного кампуса. В этой сети для обеспечения IP-соединения между локальными пользователями используется несколько маршрутизаторов. Постоянное IPv4-подключение к поставщику интернет-услуг предоставляет возможность внешнего подключения.


Рис. 1.   Исходная топология корпоративной сети IPv4


Возможные решения

Два возможных решения для подключения этого клиента корпоративного кампуса к сети 6bone с использованием существующей топологии IPv4 и туннелей — туннели с ручной настройкой и туннели 6to4. Туннелирование — это технология инкапсулирования пакетов IPv6 в пакеты IPv4 для возможности передачи через инфраструктуру маршрутизации IPv4. Оба решения требуют, чтобы узел и маршрутизатор на каждом конце туннеля использовали два стека, т.е. чтобы они одновременно поддерживали стеки протоколов IPv4 и IPv6. Оба из этих возможных решений поддерживаются программным обеспечением Cisco IOS.

Решение № 1: Туннели с ручной настройкой

Туннелирование IPv6 с ручной настройкой — это технология, с помощью которой адрес IPv6 вручную настраивается в интерфейсе туннеля и адреса IPv4 вручную настраиваются в исходной и конечной точке туннеля. Туннели с ручной настройкой можно настраивать между пограничными маршрутизаторами или между пограничным маршрутизатором и узлом. Так как для туннелей с ручной настройкой требуется настройка на обоих концах туннеля, для управления внедрением нескольких туннелей необходимо больше служебной информации по сравнению с использованием туннелей 6to4. Так как они настроены для работы в режиме «один-к-одному» между известными конечными точками, туннели с ручной настройкой делают данные трафика доступными для каждой конечной точки и обеспечивают дополнительную защиту для введенного трафика.

Решение № 2: Туннели 6to4

Туннелирование 6to4 — это технология при которой конечная точка туннеля определяется глобальным уникальным адресом IPv4, встроенным в адрес 6to4. Адрес 6to4 IPv6 — это комбинация уникального префикса маршрутизации 2002::/16 и глобального уникального 32-разрядного адреса IPv4. (Адреса IPv6, совместимые с IPv4, имеют формат, отличный от адресов 6to4 IPv6. Адреса IPv6, совместимые с IPv4, не используются при туннелировании 6to4.) Туннели 6to4 настраиваются между пограничными маршрутизаторами или между пограничным маршрутизатором и узлом. Для туннелей 6to4 требуется, чтобы передающий узел 6bone 6to4 опознавался как передающая служба 6to4 для корпоративной сети. Передающий узел 6to4 будет настраивать пограничный маршрутизатор с двумя стеками, который будет конечной точкой корпоративного туннеля 6to4. После настройки передающим узлом 6to4 туннелирования 6to4 управления практически не требуется. На корпоративном конце простая конфигурация маршрутизатора обеспечивает доступ к сети 6bone через туннель 6to4.

Хотя для соединения узлов IPv6 в корпоративной сети можно использовать туннели 6to4, это использование не описано в данном документе.

Решение № 2, туннели 6to4

Поодключение к сети 6bone с использованием туннелей 6to4 — наиболее простое решение для достижения поставленных целей.

Обзор

Туннели 6to4 обеспечивают механизм доступа конечных узлов IPv6 к сети 6bone с помощью туннелирования через Интернет IPv4. Чтобы избежать помех от корпоративной производственной сети, это решение должно изначально внедряться в изолированной сети, например, в лаборатории.

Стратегия

Начните с сети IPv4, которая имеет внешнее подключение IPv4 к поставщику интернет-услуг. Протокол IPv4 требуется потому, что туннель, создаваемый для сети 6bone, будет использовать протокол IPv4 для передачи трафика IPv6.

Выбор исходного испытательного окружения IPv6

Решите, какое из двух следующих окружений будет использоваться для реализации исходного подключения к сети 6bone:

  • Полностью изолированная испытательная сеть, например, лаборатория
  • Испытательная сеть, подключенная к остальной сети, но изолированная с помощью брандмауэра, который не пропускает трафик IPv6

В этом документе описывается второе окружение, изолированное с помощью брандмауэра, но эта конфигурация также используется для первого окружения.

Подготовка испытательной сети IPv6

Установите устройства, которые будут использоваться в испытательной сети IPv6. На рис. 2 изображена полностью ячеистая испытательная сеть IPv6, изолированная от корпоративной сети IPv4 с помощью брандмауэра, блокирующего трафик IPv6. Все маршрутизаторы в испытательной сети настроены на использование двух стеков.


Рис. 2.   Исходная топология сети с добавленной испытательной сетью IPv6


Определение маршрутизатора для подключения к сети 6bone

В испытательной сети IPv6 определите пограничный маршрутизатор, который будет использоваться для подключения к поставщику интернет-услуг сети 6bone. Этот пограничный маршрутизатор должен быть маршрутизатором с двумя стеками, который настраивается с туннелем для передачи трафика IPv6 через сеть IPv4.

Получение сетевого адреса от поставщика интернет-услуг сети 6bone

Попросите поставщика интернет-услуг сети 6bone настроить свой конец туннеля и сообщить вам адрес IPv4 маршрутизатора, который будет использоваться для доступа к сети 6bone.

Так как настраивается туннель 6to4 для сети 6bone, адрес IPv6 вашего пограничного маршрутизатора будет вашим глобально маршрутизируемым адресом IPv4, связанным с префиксом 6to4 2002::/16.


Примечание.   Поставщик интернет-услуг, используемый для подключения к сети 6bone, может не быть поставщиком интернет-услуг, используемым для подключения к сети IPv4. Ваш поставщик интернет-услуг сети 6bone обычно является ближайшим партнером, который обеспечивает вам службу передачи 6to4, поэтому для подключения к сети 6bone не обязательно использовать локального поставщика интернет-услуг.

Настройка пограничного маршрутизатора 6bone

Используя адрес IPv4, указанный поставщиком интернет-услуг сети 6bone, настройте выбранный пограничный маршрутизатор для использования двух стеков и подключите туннель 6to4 к сети 6bone. Рекомендуется, чтобы каждый узел имел только один адрес 6to4, назначенный для внешнего интерфейса маршрутизатора. Все узлы должны использовать протокол внутренней маршрутизации IPv6, например, протокол RIP next generation (RIPng) для маршрутизации IPv6 внутри узла, но внешняя маршрутизация обрабатывается соответствующим протоколом внешней маршрутизации IPv4.

Теперь вы подключили испытательную сеть к сети 6bone, как показано на рис. 3.


Рис. 3.   Настроенное подключение испытательной сети к поставщику интернет-услуг сети 6bone


Подключение корпоративной сети к сети 6bone

Когда вы готовы развернуть протокол IPv6 в корпоративной сети, подключение к поставщику интернет-услуг сети 6bone будет выполняться через поставщика интернет-услуг IPv4. Вы должны настроить пограничный маршрутизатор, подключенный к поставщику интернет-услуг IPv4 на использование двух стеков с туннелем 6to4 для подключения к поставщику интернет-услуг сети 6bone. Адрес IPv4 пограничного маршрутизатора, подключенного к поставщику интернет-услуг IPv4, будет изменяться в соответствии с адресом, указанным поставщиком интернет-услуг IPv4. Определите другие маршрутизаторы и узлы сети, которые необходимо подключить к сети IPv6. Необходимо настроить каждое из этих устройств на использование двух стеков.

Можно удалить брандмауэр между корпоративной сетью и лабораторией, чтобы трафик IPv6 проходил через сеть, и можно сохранить протокол IPv4 для участка сети, пока вы не будете готовы развернуть протокол IPv6 в этой сети. На рис. 4 показана корпоративная сеть с подключением IPv6 к сети 6bone с помощью туннеля 6to4 через поставщика интернет-услуг IPv4.


Рис. 4.   Корпоративная сеть с подключением IPv6 к сети 6bone


Топология сети

На рис. 5 изображена топология стандартного туннеля 6to4 к сети 6bone.


Рис. 5.   Туннель 6to4 к сети 6bone


Как работает это решение

Туннель 6to4 настроен на корпоративном пограничном маршрутизаторе с двойным стеком. Весь корпоративный трафик IPv6, предназначенный для 6bone, направляется через IPv4 по туннелю к передающему маршрутизатору 6bone ISP 6to4. Трафик с 6bone к корпоративному узлу направляется при помощи IPv4 через туннель к корпоративному пограничному маршрутизатору с двумя стеками, а затем к узлу назначения IPv6.

Преимущества

Использование туннелей 6to4 дает следующие преимущества корпоративным пользователям:

  • Туннели 6to4 поддерживаются программным обеспечением Cisco IOS.
  • Конфигурация узла конечного пользователя проста — для нее требуется минимальное количество служебной информации для управления.
  • Туннельное соединение является автоматическим; на передающем узле 6to4 не требуется никакой специальной конфигурации для корпоративной сети.
  • Туннели 6to4 хорошо масштабируются.
  • Это решение согласовывает динамические IP-адреса корпоративной сети.
  • Туннельное соединение существует только во время сеанса.
  • Для туннельного соединения 6to4 требуется только единоразовая настройка поставщика интернет-услуг, что делает службу передачи 6to4 доступной одновременно для нескольких корпоративных сетей.
  • Переключение на вспомогательный маршрутизатор может выполняться без помощи поставщика интернет-услуг.

Ограничения

Использование туннелей 6to4 дает следующие преимущества корпоративным пользователям:

  • Независимо управляемое преобразование сетевых адресов (NAT) не разрешается на участке туннеля.
  • Трудно внедрить многосетевую адресацию.
  • Механизм туннеля 6to4 использует адресный блок /48; другие адреса недоступны.
  • Так как они настроены для работы в режиме «многие-к-одному» и трафик туннеля может исходить из нескольких конечных точек, туннели 6to4 могут предоставлять поставщику интернет-услуг только общие сведения о трафике.
  • Так как префикс корпоративного адреса 6to4 IPv6 определяется и зависит от внутреннего адреса IPv4, переход на исходный протокол IPv6 требует повторной нумерации сети.
  • Это решение подходит только для для статической маршрутизации или марштрутизации на основе протокола BGP4+.

Реализация

В этом разделе описано, как корпоративный клиент может реализовать туннель 6to4 для подключения к сети 6bone. Он включает следующие разделы:

Предварительные условия и факторы проектирования

Прежде чем приступить к созданию туннеля 6to4 к сети 6bone, вам нужно выполнить следующие задачи:

  • Определите пограничный маршрутизатор на данном узле, который будет использовать два стека. Этот пограничный маршрутизатор должен иметь статический, глобально маршрутизируемый адрес IPv4.
  • Получите от поставщика интернет-услуг сети 6bone адрес IPv4 передающего маршрутизатора 6to4, который будет использоваться для доступа к сети 6bone.

Примечание.   Во время настройки туннелей для корпоративных пограничных маршрутизаторов следует использовать глобально маршрутизирумые адреса IPv4. Адреса IPv4, использованные в примере конфигурации в этом документе, не являются глобально маршрутизируемыми и даны для иллюстрации.

  • Убедитесь, что сервер DNS использует службу BIND версии 9 (или ее эквивалент), которая обеспечивает реализацию основных компонентов DNS для протокола IPv6. Конфигурация DNS не описывается в этом документе.
  • Убедитесь, что текущая реализация двух стеков в программном обеспечении Cisco IOS допускает решение для управления внутренней сетью, которое позволяет выполнять такие приложения как TFTP, ping, Telnet и traceroute через транспорт IPv4 или IPv6.
  • Выберите протокол внутренней маршрутизации IPv6 — например, RIPng — соответствующий конфигурации сети. Для упрощения понимания решение, описанное в этом документе, использует статический маршрут. Внешняя маршрутизация обрабатывается соответствующим протоколом внешней маршрутизации IPv4.
  • Настройте маршрутизаторы с двумя стеками для использования протокола RIP.

Для получения дополнительной информации о настройке сети для протокола IPv6 см. документацию, перечисленную в разделе «Дополнительная документация»: IPv6 для ПО Cisco IOS, файл 2 из 3: настройка.

Этапы процесса реализации

Адрес IPv6 пограничного маршрутизатора — 192.168.99.1. Выделите префикс 6to4 из адреса IPv4, преобразовав десятичные компоненты адреса IPv4 в шестнадцатеричные значения и добавив перед ними цифры «2002». Для узлов IPv6 в сети используется следующий префикс 6to4: 2002:C0A8:6301::/48.

Часть C0A8:6301 предыдущего адреса IPv6 формируется из адреса IPv4 путем преобразования каждого октета в десятичной записи через точку в шестнадцатеричный эквивалент, как показано в Таблице 1.

Таблица 1.   Преобразование десятичной записи через точку в шестнадцатеричную

Десятичная запись Шестнадцатеричная запись

192

C0

168

A8

99

63

1

01

Поставщик интернет-услуг сети 6bone указал адрес IPv4 своего пограничного маршрутизатора 6bone: 192.168.33.1

Используя предыдущие данные об адресе, настройте туннель 6to4 на своем назначенном пограничном маршрутизаторе с двумя стеками с помощью следующих команд:

Корпоративный маршрутизатор
IPv6 unicast-routing
interface Ethernet0
 description connection to 6bone ISP
 ip address 192.168.99.1 255.255.255.0
interface Tunnel2002
 description 6to4 tunnel to 6bone ISP
 no ip address
 no ip redirects
 IPv6 address 2002:C0A8:6301::1/128
 tunnel source ethernet0
 tunnel mode IPv6ip 6to4
IPv6 route 2002::/16 Tunnel2002
IPv6 route ::/0 2002:C0A8:2101::1

Запись 2002:C0A8:2101::1 во второй команде IPv6 route соответствует адресу IPv6 передающего маршрутизатора 6to4 поставщика интернет-услуг, который обеспечивает доступ к сети 6bone. Часть адреса C0A8:2101 была получена из адреса IPv4 (192.168.33.1) передающего маршрутизатора 6to4 тем же методом, который описан в таблице 1.

На другом конце туннеля у пограничного маршрутизатора 6bone поставщика интернет-услуг будет следующая конфигурация:

Маршрутизатор ISP 6to4 Relay Router
IPv6 unicast-routing
interface ethernet0/0
 description connection to enterprise
 ip address 192.168.99.1 255.255.255.0
interface Tunnel2002
 description 6to4 relay service
 no ip address
 no ip redirects
 IPv6 address 2002:C0A8:2101::1/128
 tunnel source ethernet0/0
 tunnel mode IPv6ip 6to4
IPv6 route 2002::/16 Tunnel2002

Характеристики устройств

В таблице 2 описаны устройства, используемые в этом решении.

Таблица 2.   Используемое аппаратное и программное обеспечение

Корпоративный пограничный маршрутизатор Маршрутизатор 6bone поставщика интернет-услуг
Имя узла

6bone-gw

IPv6-router

Тип корпуса

Маршрутизатор Cisco 3660

Маршрутизатор Cisco 7206

Физические интерфейсы

2 Ethernet
2 Fast Ethernet
4 последовательный

4 Ethernet
2 Fast Ethernet
4 последовательный

Загруженное программное обеспечение

Cisco IOS выпуск 12.2(4)T

Cisco IOS выпуск 12.2(4)T

Память

64 Мбайт ОЗУ; 16 Мбайт флэш-памяти

128 Мбайт ОЗУ; 20 Мбайт флэш-памяти

IP-адреса

Ethernet0:
IPv4  192.168.99.1

Tunnel2002:
IPv6 address 2002:C0A8:6301::1/128

Ethernet0/0:
IPv4  192.168.99.1

Tunnel2002:
IPv6  2002:C0A8:2101::1/128

Файлы конфигурации с комментариями

В этом разделе приведены выходные файлы конфигурации с комментариями команды show running-configuration для корпоративных пограничных маршрутизаторов и пограничных маршрутизаторов 6bone поставщика интернет-услуг, показанных на рис. 5.

Корпоративный маршрутизатор
! Определите версию ПО Cisco IOS, установленного на маршрутизаторе
!
version 12.2
!
! Включите временные отметки в записи журнала и отладки. Они будут полезны при
! диагностике неисправностей и оптимизации сети.
!
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
!
! Включите шифрование паролей в выходных данных конфигурации.
!
service password-encryption
!
! Укажите имя маршрутизатора
!
hostname 6bone-gw
!
! Настройте параметры загрузки
!
boot system flash slot0:
boot system flash bootflash:
!
! Настройте запись в журнал
!logging buffered 10000 debugging
!
! Настройте секретный пароль
!
enable secret 5 [removed]
!
! Настройте часовой пояс и правила перехода на летнее время
!
clock timezone PST -8
clock summer-time PDT recurring
!
!
ip subnet-zero
no ip source-route
no ip rcmd domain-lookup
!
! Настройте доменное имя маршрутизатора
!
ip domain-name EnterpriseDomain.com
!
! Настройте порядок опроса DNS-серверов
!
ip name-server 192.168.1.10
ip name-server 192.168.2.21
ip name-server 2002:C0A8:6301:1::21
!
! Активируйте маршрутизацию IPv6
!
IPv6 unicast-routing
!
! Настройте интерфейс туннелирования
!
interface Tunnel2002
 description 6to4 tunnel to 6bone ISP
 no ip address
 no ip redirects
 IPv6 address 2002:C0A8:6301::1/128
 tunnel source ethernet0
 tunnel mode IPv6ip 6to4
!
! Настройте физический интерфейс
!
interface Ethernet0
 description connection to 6bone ISP
 ip address 192.168.99.1 255.255.255.0
!
interface Ethernet1
 description connection to Lab interface router
 ip address 192.168.99.40 255.255.255.0
 IPv6 address 3FFE:FFFF:8023:100::1/64
 IPv6 rip v6rip enable
!
interface FastEthernet2/0
 description connection to core router
 ip address 192.168.99.41 255.255.255.0
 IPv6 address 3FFE:FFFF:8023:200::1/64
 IPv6 rip v6rip enable
!
interface FastEthernet3/0
 description connection to IPv4-only core router
 ip address 192.168.99.42 255.255.255.0
!
! Другие интерфейсы не используются
!
interface Serial4/0
 no ip address
 shutdown
!
interface Serial4/1
 no ip address
 shutdown
!
interface Serial4/2
 no ip address
 shutdown
!
interface Serial4/3
 no ip address
 shutdown
!
! Настройте базовую IP-маршрутизацию
!
ip default-gateway 192.168.33.1
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.33.1
!
! Настройте статический маршрут IPv6
!
IPv6 route 2002::/16 tunnel2002
IPv6 route ::/0 2002:C0A8:2101::1
IPv6 router rip v6rip
!
end
ISP-маршрутизатор 6bone
! Определите версию ПО Cisco IOS, установленного на маршрутизаторе
!
version 12.2
!
! Включите временные отметки в записи журнала и отладки. Они будут полезны при
! диагностике неисправностей и оптимизации сети.
!
service timestamps debug datetime localtime show-timezone
service timestamps log datetime localtime show-timezone
!
! Включите шифрование паролей в выходных данных конфигурации.
!
service password-encryption
!
! Укажите имя маршрутизатора
!
hostname IPv6-router
!
! Настройте параметры загрузки
!
boot system flash slot0:
boot system flash bootflash:
!
! Настройте запись в журнал
!
logging buffered 10000 debugging
!
! Настройте секретный пароль
!
enable secret 5 [removed]
!
! Настройте часовой пояс и правила перехода на летнее время
!
clock timezone PST -8
clock summer-time PDT recurring
!
!
ip subnet-zero
no ip source-route
no ip rcmd domain-lookup
!
! Настройте доменное имя маршрутизатора
!
ip domain-name 6boneISP.com
!
! Настройте порядок опроса DNS-серверов
!
ip name-server 192.168.33.4
ip name-server 192.168.33.5
ip name-server 3FFE:FFFF:8001::4
!
! Активируйте маршрутизацию IPv6
!
IPv6 unicast-routing
!
! Настройте интерфейс туннелирования
!
interface Tunnel2002
 description 6to4 relay service
 no ip address
 no ip redirects
 IPv6 address 2002:C0A8:2101::1/128
 tunnel source ethernet0/0
 tunnel mode IPv6ip 6to4
!
! Настройте физический интерфейс
!
interface Ethernet0/0
 description connection to enterprise
 ip address 192.168.33.1 255.255.255.0
!
interface Ethernet0/1
 no ip address
 shutdown
!
interface Ethernet0/2
 no ip address
 shutdown
!
interface Ethernet0/3
 no ip address
 shutdown
!
interface FastEthernet1/0
 description connection to ISP-core-A
 ip address 192.168.34.10 255.255.255.0
 IPv6 address 3FFE:FFFF:8023:2::6/64
 duplex auto
 speed auto
!
interface FastEthernet2/0
 description connection to ISP-core-B
 ip address 192.168.35.22 255.255.255.0
 IPv6 address 3FFE:FFFF:8023:2::8/64
 duplex auto
 speed auto
!
! Другие интерфейсы не используются
!
interface Serial4/0
 no ip address
 shutdown
!
interface Serial4/1
 no ip address
 shutdown
!
interface Serial4/2
 no ip address
 shutdown
!
interface Serial4/3
 no ip address
 shutdown
!
! Настройте базовую IP-маршрутизацию
!
ip default-gateway 192.168.30.1
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.30.1
!
! Настройте статический маршрут IPv6
!
IPv6 route 2002::/16 tunnel2002
!
end

Дополнительная документация

См. следующую документы, чтобы получить дополнительную информацию о протоколе IPv6 для программного обеспечения Cisco IOS, сети 6bone и протоколе IPv6 в целом:

  • Стратегии внедрения IPv6
  • IPv6: Подключение к сети 6bone с использованием туннелей 6to4, настраиваемых вручную
  • IPv6: предоставление услуг IPv6 Services в магистрали IPv4f Backbone с помощью туннелей
  • Соединение доменов IPv6 с использованием туннелей
  • Начните отсюда: Особенности выпуска программного обеспечения Cisco IOS для функций IPv6
  • Внедрение IPv6 для программного обеспечения Cisco IOS
  • Справочник по командам настройки IPv6 для Cisco IOS
  • RFC 2185. Аспекты маршрутизации передачи протокола IPv6 (справочник)
  • RFC 2373. Архитектура адресации IP версии 6
  • RFC 2374. Формат агрегируемого глобального индивидуального адреса IPv6
  • RFC 2460, Спецификация Интернет-протокола версии 6 (IPv6)
  • RFC 2464. Передача пакетов IPv6 по сетям Ethernet
  • RFC 2471. Проверка выделения адресов IPv6
  • RFC 2893. Механизмы перехода для хостов и маршрутизаторов IPv6
  • RFC 3056. Подключение доменов IPv6 через облака IPv4