Управление сетью и автоматизация : Cisco Router and Security Device Manager

Базовая настройка маршрутизатора с помощью SDM

23 марта 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (28 июля 2013) | Английский (27 июля 2011) | Отзыв

Содержание

Введение
Предварительные условия
      Требования
      Используемые компоненты
      Условные обозначения
Настройка
      Схема сети
      Конфигурация интерфейсов
      Конфигурация статического преобразования сетевых адресов (NAT)
      Конфигурация маршрутизации
      Другие параметры
      Конфигурация CLI
Проверка
Устранение неполадок
Связанные обсуждения сообщества поддержки Cisco
Дополнительные сведения

Введение

В этом документе приводятся инструкции по базовой настройке маршрутизатора с помощью Cisco Security Device Manager (SDM). Сюда входит настройка IP-адреса, маршрутизации по умолчанию, статической и динамической маршрутизации, статического и динамического преобразования сетевых адресов (NAT), имени хоста, баннера, секретного пароля, учетных записей пользователя и т. п. Cisco SDM позволяет настраивать маршрутизаторы во всех типах сетевых сред, в том числе "малый офис, домашний офис", внутренний офис, региональный офис и центральный узел или штаб-квартира корпорации, с помощью простого в использовании управляющего веб-интерфейса.

Предварительные условия

Требования

В этом документе предполагается, что маршрутизатор Cisco полностью исправен и в нем разрешено изменение конфигурации с помощью Cisco SDM.

Примечание: Сведения о том, как разрешить настройку HTTPS с помощью SDM см. в документе Включение HTTPS-доступа для SDM.

Используемые компоненты

Сведения, представленные в этом документе, относятся к следующим версиям программного и аппаратного обеспечения.

  • Маршрутизатор Cisco 3640 с программным обеспечением Cisco IOS® версии 12.4(8)

  • ПО Cisco Security Device Manager (SDM) версии 2.3.1

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в данном документе, начинали работу с чистой (стандартной) конфигурацией. При работе в действующей сети необходимо изучить все возможные последствия каждой команды.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Настройка

В этом разделе представлены сведения о настройке базовых параметров маршрутизатора в сети.

Примечание: Дополнительные сведения о командах, используемых в этом разделе, можно получить с помощью инструмента Command Lookup Tool (только для зарегистрированных заказчиков).

Схема сети

В этом документе использована следующая конфигурация сети:

basic-router-config-sdm-diag_rev.gif

Примечание: Схемы IP-адресации, используемые в этом документе, нельзя использовать для маршрутизации в Интернете. Это адреса RFC 1918 leavingcisco.com, которые были использованы в лабораторной среде.

Конфигурация интерфейсов

Чтобы настроить интерфейсы маршрутизатора Cisco, выполните следующие действия.

  1. Выберите Home, чтобы открыть главную страницу SDM.

    На главной странице SDM отображаются сведения о программном и аппаратном обеспечении маршрутизатора, доступности функций, а также сводные данные о конфигурации и другая сведения. Зеленые круги обозначают функции, которые поддерживаются в маршрутизаторе, красные круги обозначают неподдерживаемые функции.

    basic-router-config-sdm-1.gif

  2. Выберите Configure > Interfaces and Connections > Create Connection, чтобы настроить соединение с глобальной сетью (WAN) для интерфейса.

    Например, для последовательного интерфейса 2/0 выберите параметр Serial и нажмите Create New Connection.

    Примечание: Для интерфейсов других типов, таких как Ethernet, выберите соответствующий тип и продолжите настройку, нажав кнопку Create New Connection.

    basic-router-config-sdm-2.gif

  3. Нажмите Next, чтобы продолжить настройку после появления нужного интерфейса.

    basic-router-config-sdm-3.gif

  4. Выберите Serial interface 2/0 (нужный) в списке "Available Interfaces" и нажмите Next.

    basic-router-config-sdm-4.gif

  5. Выберите тип инкапсуляции последовательного интерфейса и нажмите Next.

    basic-router-config-sdm-5.gif

  6. Укажите статический IP-адрес интерфейса с соответствующей маской подсети нажмите Next.

    basic-router-config-sdm-6.gif

  7. Настройте параметры маршрутизации по умолчанию и дополнительные параметры, такие как IP-адрес следующего перехода (192.168.1.2, в соответствии со схемой сети), предоставленные поставщиком услуг Интернета (ISP) и нажмите Next.

    basic-router-config-sdm-7.gif

    Откроется окно со сводной информацией об изменениях, которые пользователь внес в конфигурацию. Нажмите кнопку Finish.

    basic-router-config-sdm-8.gif

    Появится следующее окно, отображающее состояние доставки команды в маршрутизатор. Кроме того, оно отображает ошибки, если доставка команды не удалась, из-за несовместимых команд или неподдерживаемых функций.

    basic-router-config-sdm-9.gif

  8. Выберите Configure > Interfaces and Connections > Edit Interfaces/Connections, чтобы добавить, изменить или удалить интерфейсы.

    basic-router-config-sdm-10.gif

    Выделите интерфейс, в который необходимо внести изменения и нажмите Edit, чтобы изменить или отредактировать конфигурацию интерфейса. Здесь можно изменить статические IP-адреса.

    basic-router-config-sdm-11.gif

Конфигурация преобразования сетевых адресов (NAT)

Конфигурация динамического преобразования сетевых адресов (NAT)

Чтобы настроить динамическое преобразование сетевых адресов (NAT) в маршрутизаторе Cisco, выполните следующие действия.

  1. Выберите Configure > NAT > Basic NAT и нажмите Launch the selected task, чтобы настроить базовое преобразование сетевых адресов.

    basic-router-config-sdm-rev1.gif

  2. Нажмите Next.

    basic-router-config-sdm-rev2.gif

  3. Выберите интерфейс, который подключается к Интернету, или поставщика услуг Интернета и задайте диапазон IP-адресов, которые смогут использовать доступ в Интернет.

    basic-router-config-sdm-rev3.gif

  4. Откроется окно со сводной информацией об изменениях, которые пользователь внес в конфигурацию. Нажмите кнопку Finish.

    basic-router-config-sdm-rev4.gif

  5. В окне "Edit NAT Configuration" отображается готовая конфигурация динамического преобразования сетевых адресов (NAT) с перегруженными преобразованными IP-адресами (PAT). Чтобы настроить динамическое преобразование сетевых адресов (NAT) для пула адресов, выберите Address Pool.

    basic-router-config-sdm-rev6.gif

  6. Нажмите Add.

    basic-router-config-sdm-rev7.gif

    На экран будут выведены сведения, такие как имя пула и диапазон IP-адресов с маской сети. Бывают ситуации, когда большая часть адресов пула назначена и в нем практически не остается IP-адресов. В этом случае для отдельного адреса можно использовать преобразование адресов портов (PAT). Оно позволяет удовлетворять дополнительные запросы выделение IP-адресов. Установите флажок Port Address Translation (PAT), если вы хотите, чтобы маршрутизатор использовал функцию PAT, когда в пуле заканчиваются IP-адреса.

    basic-router-config-sdm-rev8.gif

  7. Нажмите Add.

    basic-router-config-sdm-rev9.gif

  8. Нажмите Edit.

    basic-router-config-sdm-rev10.gif

  9. Выберите Address Pool в поле "Type", введите имя пула адресов (pool1) и нажмите OK.

    basic-router-config-sdm-rev11.gif

  10. В открывшемся окне будет отображаться конфигурация динамического преобразования адресов (NAT) для пула адресов. Нажмите кнопку Designate NAT Interfaces.

    basic-router-config-sdm-rev12.gif

    С помощью этого окна назначьте внутренние и внешние интерфейсы, которые вы хотите использовать для преобразования NAT. NAT использует внешние и внутренние назначения во время интерпретации правил преобразования, поскольку преобразование может выполняться как из внутренней сети во внешнюю, так и из внешней во внутреннюю.

    После назначения эти интерфейсы используются во всех правилах преобразования NAT. Назначенные интерфейсы отображаются над списком правил преобразования (Translation Rules) в главном окне NAT.

    basic-router-config-sdm-rev25.gif

Конфигурация статического преобразования сетевых адресов (NAT)

Для настройки статического преобразования адресов на маршрутизаторе Cisco, выполните следующие действия.

  1. Выберите Configure > NAT > Edit NAT Configuration и нажмите кнопку Add, чтобы настроить статическое преобразование адресов (NAT).

    basic-router-config-sdm-rev13.gif

  2. Выберите направление (Direction) — из внутренней сети во внешнюю (from inside to outside) или из внешней сети во внутреннюю (from outside to inside), укажите внутренний IP-адрес, для которого необходимо выполнить преобразование, в поле Translate from Interface. В области Translate to Interface выберите тип (Type).

    • Выберите IP Address, если необходимо использовать преобразование для IP-адреса, введенного в поле "IP Address".

    • Выберите Interface, если необходимо, чтобы функция Translate from Address использовала интерфейс маршрутизатора. Адрес, указанный в окне Translate from Address, преобразуется в IP-адрес, который назначен интерфейсу, указанному в поле "Interface".

    Установите флажок Redirect Port, если необходимо включить в преобразование данные о порте внутреннего устройства. Это позволяет использовать один публичный IP-адрес для нескольких устройств. При этом номера портов, назначенные устройствам, должны быть разными. Для этого адреса преобразования необходимо создать по одной записи на каждое сопоставление порта. Выберите TCP, если используется TCP-порт или UDP для UDP-порта. В поле "Original Port" введите номер порта внутреннего устройства. В поле "Translated Port" введите номер порта, который маршрутизатор должен использовать для этого преобразования. См. раздел Разрешение доступа к внутренним устройствам из Интернета документа Настройка преобразования сетевых адресов: Начало работы.

    basic-router-config-sdm-new14.gif

    В этом окне отображается конфигурация статического преобразования сетевых адресов (NAT) с включенным перенаправлением портов.

    basic-router-config-sdm-new15.gif

Конфигурация маршрутизации

Настройка маршрутизации

Чтобы настроить статическую маршрутизацию в маршрутизаторе Cisco, выполните следующие действия.

  1. Выберите Configure > Routing > Static Routing и нажмите кнопку Add, чтобы настроить статическую маршрутизацию.

    basic-router-config-sdm-rev16.gif

  2. Введите адрес сети назначения (Destination Network address) с маской и выберите исходящий интерфейс или IP-адрес следующего перехода.

    basic-router-config-sdm-rev17.gif

    В этом окне отображается статический маршрут, настроенный для сети 10.1.1.0, IP-адрес следующего перехода — 192.168.1.2.

    basic-router-config-sdm-rev18.gif

Конфигурация динамической маршрутизации

Чтобы настроить динамическую маршрутизацию в маршрутизаторе Cisco, выполните следующие действия.

  1. Выберите Configure > Routing > Dynamic Routing.

  2. Выберите RIP, а затем щелкните Edit.

    basic-router-config-sdm-rev19.gif

  3. Установите флажок Enable RIP, выберите версию RIP и нажмите кнопку Add.

    basic-router-config-sdm-rev22.gif

  4. Укажите сетевой адрес для объявления.

    basic-router-config-sdm-rev21.gif

  5. Нажмите OK.

    basic-router-config-sdm-rev22.gif

  6. Нажмите Deliver, чтобы передать команды маршрутизатору.

    basic-router-config-sdm-rev23.gif

    В этом окне отображается конфигурация динамической маршрутизации RIP.

    basic-router-config-sdm-rev24.gif

Другие параметры

Для настройки других базовых параметров маршрутизатора Cisco выполните следующие действия.

  1. Выберите Configure > Additional Tasks > Router Properties и нажмите Edit, чтобы изменить свойства Hostname (имя хоста), Domain Name (имя домена), Banner (баннер) и Enable Secret Password (включить секретный пароль) для маршрутизатора.

    basic-router-config-sdm-14.gif

  2. Выберите Configure > Additional Tasks > Router Access > User Accounts/View, чтобы добавить, удалить или изменить учетные записи пользователей маршрутизатора.

    basic-router-config-sdm-15.gif

  3. Выберите File > Save Running Config to PC..., чтобы сохранить текущую конфигурацию в энергонезависимую память (NVRAM) маршрутизатора или на ПК, а также чтобы сбросить текущую конфигурацию к заводским параметрам по умолчанию.

    basic-router-config-sdm-16.gif

  4. На панели задач выберите Edit > Preferences, чтобы включить следующие пользовательские настройки.

    • Предварительный просмотр команд перед их доставкой в маршрутизатор.

    • Сохранение подписи на Flash-диск.

    • Запрос подтверждения перед выходом из SDM.

    • Продолжение мониторинга состояния интерфейса при переключении режима или задачи.

    basic-router-config-sdm-17.gif

  5. Выберите View на панели задач, чтобы:

    • открыть страницы "Home", "Configure" или "Monitor".

    • отобразить рабочую конфигурацию маршрутизатора.

    • отобразить различные команды show.

    • отобразить правила SDM по умолчанию.

    • Выберите Refresh, чтобы синхронизировать конфигурацию маршрутизатора, отображаемую в SDM, с изменениями, сделанными из интерфейса командной строки (CLI).

    basic-router-config-sdm-18.gif

Конфигурация CLI

Конфигурация маршрутизатора

Router#show run
Building configuration...

Current configuration : 2525 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no logging buffered
enable password cisco
!
no aaa new-model
!
resource policy
!
!
!
ip cef
!
!
!

!--- Сертификат RSA, созданный после ввода команды 
!--- ip http secure-server.

crypto pki trustpoint TP-self-signed-392370502
 enrollment selfsigned
 subject-name cn=IOS-Self-Signed-Certificate-392370502
 revocation-check none
 rsakeypair TP-self-signed-392370502
!
!
crypto pki certificate chain TP-self-signed-392370502
 certificate self-signed 01
  3082023C 308201A5 A0030201 02020101 300D0609 2A864886 F70D0101 04050
  30312E30 2C060355 04031325 494F532D 53656C66 2D536967 6E65642D 43657
  69666963 6174652D 33393233 37303530 32301E17 0D303530 39323330 34333
  375A170D 32303031 30313030 30303030 5A303031 2E302C06 03550403 13254
  532D5365 6C662D53 69676E65 642D4365 72746966 69636174 652D3339 32333
  35303230 819F300D 06092A86 4886F70D 01010105 0003818D 00308189 02818
  C86C0F42 84656325 70922027 EF314C2F 17C8BBE1 B478AFA3 FE2BC2F2 3C272
  A3B5E13A 1392A158 73D8FE0D 20BFD952 6B22890C 38776830 241BE259 EE2AA
  CF4124EA 37E41B46 A2076586 2F0F9A74 FDB72B3B 6159EEF7 0DEC7D44 BE489
  9E351BF7 F5C808D9 2706C8B7 F5CE4B73 39ED8A61 508F455A 68245A6B D072F
  02030100 01A36630 64300F06 03551D13 0101FF04 05300301 01FF3011 06035
  11040A30 08820652 6F757465 72301F06 03551D23 04183016 80148943 F2369
  ACD8CCA6 CA04EC47 C68B8179 E205301D 0603551D 0E041604 148943F2 36910
  D8CCA6CA 04EC47C6 8B8179E2 05300D06 092A8648 86F70D01 01040500 03818
  3B93B9DC 7DA78DF5 6D1D0D68 6CE075F3 FFDAD0FB 9C58E269 FE360329 2CEE3
  D8661EB4 041DEFEF E14AA79D F33661FC 2E667519 E185D586 13FBD678 F52E1
  E3C92ACD 52741FA4 4429D0B7 EB3DF979 0EB9D563 51C950E0 11504B41 4AE79
  0DD0BE16 856B688C B727B3DB 30A9A91E 10236FA7 63BAEACB 5F7E8602 0C33D
  quit
!
!
!
!
!
!
!
!
!
!

!--- Создание учетной записи с именем sdmsdm и всеми привилегиями.

username sdmsdm privilege 15 password 0 sdmsdm
!
!
!
!
!
!
interface Ethernet0/0
 no ip address
 shutdown
 half-duplex
!

!--- Интерфейс локальной сети, настроенный с закрытым IP-адресом.

interface FastEthernet1/0
 ip address 172.16.1.2 255.255.255.0

!--- Назначение преобразования сетевых адресов (NAT) для трафика, 
!--- который поступает от указанного интерфейса.

 ip nat inside
 ip virtual-reassembly
 duplex auto
 speed auto
!

!--- Это интерфейс WAN, настроенный с маршрутизируемым (публичным) IP-адресом.

interface Serial2/0
 ip address 192.168.1.1 255.255.255.0

!--- Настройка интерфейса в качестве 
!--- места назначения для трафика, прошедшего через NAT.
 
ip nat outside
 ip virtual-reassembly
!
interface Serial2/1
 no ip address
 shutdown
!
interface Serial2/2
 no ip address
 shutdown
!
interface Serial2/3
 no ip address
 shutdown
!

!--- Включена маршрутизация RIP версии 2. 

router rip
 version 2
 network 172.1.0.0
 no auto-summary

!--- Здесь настраиваются команды, которые включают протоколы HTTP и HTTPS.

ip http server
ip http secure-server
!


!--- Это конфигурация динамического преобразования сетевых адресов (NAT).


!

!--- Определение пула внешних IP-адресов для преобразования сетевых адресов.

ip nat pool pool1 192.168.1.3 192.168.1.10 netmask 255.255.255.0

!--- Чтобы включить NAT для внутреннего адреса источника,
!--- укажите, что трафик от узлов, которые соответствуют списку доступа 1,
!--- преобразуются в пул адресов с именем "pool1".

ip nat inside source list 1 pool pool1
!

!--- Список доступа 1 разрешает преобразование сетевых адресов только для сети 172.16.1.0.

access-list 1 remark SDM_ACL Category=2
access-list 1 permit 172.16.1.0 0.0.0.255
!


!--- Это конфигурация статического преобразования сетевых адресов (NAT).



!--- Для преобразования пакетов между фактическим IP-адресом 172.16.1.1 с TCP-портом 
!--- 80 и сопоставленным IP-адресом 192.168.1.1 с TCP-портом 500.

ip nat inside source static tcp 172.16.1.1 80 192.168.1.3 500 extendable
!
!

!
!

!--- Маршрут по умолчанию настроен и направлен по адресу 192.168.1.2.

ip route 0.0.0.0 0.0.0.0 192.168.1.2
!
!

!--- Статический маршрут настроен и направлен по адресу 192.168.1.2.

ip route 10.1.1.0 255.255.255.0 192.168.1.2
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0

!--- Протокол Telnet включен с паролем sdmsdm.

line vty 0 4
 password sdmsdm
 login
!
!
end

Проверка

Выберите Configure > Interface & Connections > Edit Interface Connections > Test Connection, чтобы проверить подключение для всех компонентов тракта. Можно указать IP-адрес удаленной стороны, щелкнув переключатель User-specified.

basic-router-config-sdm-23.gif

Устранение неполадок

Инструмент Output Interpreter Tool (только для зарегистрированных заказчиков) поддерживает некоторые команды show. Используйте OIT для анализа выходных данных команд show.

Примечание: Изучите статью Важная информация о командах для отладки, прежде чем вводить команды debug.

Для устранения неполадок используются следующие параметры:

  • Выберите Tools > Update SDM на панели инструментов, чтобы отправить эхо-запрос, создать Telnet-подключение и обновить SDM до последней версии. Это можно сделать с веб-узла Cisco.com, с локального компьютера или с компакт-диска.

    basic-router-config-sdm-19.gif

  • Выберите Help > About this Router для отображения информации об аппаратной конфигурации маршрутизатора.

    basic-router-config-sdm-20.gif

    В этом окне отображается информация об образе IOS маршрутизатора.

    basic-router-config-sdm-21.gif

  • Параметр Help предоставляет сведения о различных параметрах конфигурации, доступных в SDM.

    basic-router-config-sdm-22.gif

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 71305