Протокол IP : Cервисы IP-приложения

Использование команд standby preempt и standby track

23 марта 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (28 июля 2013) | Английский (10 августа 2005) | Отзыв

Содержание

Введение
Предварительные условия
      Требования
      Используемые компоненты
      Условные обозначения
Общие сведени
Примеры конфигурации
Связанные обсуждения сообщества поддержки Cisco
Дополнительные сведения

Введение

В этом документе описывается совместное использование команд standby preempt и standby track, а также принципы их использования.

Команда standby preempt превращает маршрутизатор протокола Hot Standby Router Protocol (HSRP) с наивысшим приоритетом в активный маршрутизатор. Приоритет определяется сначала по настроенному значению приоритета, а затем по IP-адресу. В любом случае чем больше значение, тем выше приоритет. Когда маршрутизатор с большим приоритетом становится приоритетным, маршрутизатор посылает сообщение Coup. Когда активный маршрутизатор с меньшим приоритетом получает сообщение Coup или приветственное сообщение от активного маршрутизатора с большим приоритетом, он переходит в состояние разговора и отправляет сообщение об отказе.

Команда standby track позволяет указать другой интерфейс маршрутизатора, который будет отслеживаться процессом HSRP с целью изменения приоритета HSRP для данной группы. Если протокол линии указанного интерфейса отключается, приоритет HSRP уменьшается. Это означает, что другой маршрутизатор HSRP с более высоким приоритетом может стать активным маршрутизатором в том случае, если включена команда standby preempt.

Предварительные условия

Требования

Для данного документа нет особых требований.

Используемые компоненты

Сведения, содержащиеся в данном документе, относятся к следующим версиям программного и аппаратного обеспечения:

  • ПО Cisco IOSIOS® версия 12.2 (10b)

  • Маршрутизаторы Cisco серии 2503

Сведения, представленные в данном документе, были получены на тестовом оборудовании в специально созданных лабораторных условиях. При написании данного документа использовались только данные, полученные от устройств с конфигурацией по умолчанию. При работе с реально функционирующей сетью необходимо полностью осознавать возможные последствия выполнения команд до их применения.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в разделе Технические советы Cisco. Условные обозначения.

Общие сведения

На схеме далее показан пример использования команды standby preempt вместе с командой standby track.

6a.gif

Примеры конфигурации

В схеме сети HSRP настроен следующим образом:

  • R1 является активным маршрутизатором и отслеживает состояние интерфейса serial 0. Когда R1 становится активным маршрутизатором, весь трафик с хоста (хост 1, 2, 3) на серверы направляется через R1.

  • R2 является резервным маршрутизатором и отслеживает состояние интерфейса serial 1 R2.

  • Если интерфейс R1 serial 0 перестает работать, приоритет HSRP маршрутизатора R1 уменьшается на 10. На этом этапе приоритет HSRP у маршрутизатора R2 выше, чем у R1, и R2 становится активным маршрутизатором. Когда R2 становится активным маршрутизатором, весь трафик с хоста на серверы направляется через R2.

Примечание. Шлюз по умолчанию для хостов 1, 2 и 3 настраивается с помощью виртуальных IP-адресов HSRP (в данном случае 171.16.6.100). Протокол маршрутизации, например, RIP, настраивается на маршрутизаторах для обеспечения связи между хостами и серверами.

Далее показана конфигурация каждого маршрутизатора:

Маршрутизатор 1 ( Cisco 2503)

interface Ethernet0 
ip address 171.16.6.5 255.255.255.0

!--- Назначает IP-адрес для интерфейса.

no ip redirects 
standby 1 ip 171.16.6.100

!--- Назначает резервную группу и резервный IP-адрес 

standby 1 priority 105

!--- Назначает приоритет (в данном случае 105) интерфейса маршрутизатора (e0)
!--- для определенного номера группы (1). По умолчанию устанавливается значение 100.

standby 1 preempt

!--- Позволяет маршрутизатору стать активным, если его приоритет
!--- выше приоритета всех остальных маршрутизаторов HSRP в горячей резервной группе. 
!--- Если команда standby preempt не используется при настройке 
!--- маршрутизатора, он не станет активным, даже если
!--- его приоритет выше приоритета всех остальных маршрутизаторов. 

standby 1 track Serial0

!--- Указывает, что HSRP следит за интерфейсом Serial0. 
!--- Также можно настроить приоритет интерфейса, который определяет
!--- значение, на которое снижается приоритет маршрутизатора, когда
!--- интерфейс перестает работать. Значение по умолчанию – 10.

interface Serial0 
ip address 171.16.2.5 255.255.255.0

Маршрутизатор 2 ( Cisco 2503)

interface Ethernet0
ip address 171.16.6.6 255.255.255.0

!--- Назначает IP-адрес для интерфейса.

no ip redirects
standby 1 ip

!--- Определяет горячую резервную группу. В данном случае IP-адрес виртуального маршрутизатора
!--- не настраивается. См. примечание после этой таблицы.

standby 1 preempt

!--- Позволяет маршрутизатору стать активным, если его приоритет
!--- выше приоритета всех остальных маршрутизаторов HSRP в горячей резервной группе. 
!--- Если команда standby preempt не используется при настройке 
!--- маршрутизатора, он не станет активным, даже если
!--- его приоритет выше приоритета всех остальных маршрутизаторов. 

standby 1 track Serial1

!--- Указывает, что HSRP следит за интерфейсом Serial1. 
!--- Также можно настроить приоритет интерфейса, который определяет
!--- значение, на которое снижается приоритет маршрутизатора, когда
!--- интерфейс перестает работать. Значение по умолчанию – 10.
!--- Приоритет также не настраивается и, следовательно,
!--- используется значение приоритета по умолчанию, равное 100.

interface Serial1
ip address 171.16.7.6 255.255.255.0

Примечание. При настройке R2 не используется резервный IP-адрес. Это делается умышленно для того, чтобы продемонстрировать, что это допустимая конфигурация. После обмена приветствиями HSRP между R1 и R2, R2 получает резервный IP-адрес от R1. Настройка R2 с резервным IP-адресом (тот же резервных адрес используется при настройке R1) также является допустимой конфигурацией.

R1# show standby
Ethernet0 - Group 1
Local state is Active, priority 105, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 1.458
Virtual IP address is 171.16.6.100 configured
Active router is local
Standby router is 171.16.6.6 expires in 8.428
Virtual mac address is 0000.0c07.ac01
2 state changes, last state change 02:09:49
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 1 up:
Interface    Decrement  State
Serial0         10      Up
 
R2# show standby
Ethernet0 - Group 1
Local state is Standby, priority 100, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 1.814
Virtual IP address is 171.16.6.100
Active router is 171.16.6.5, priority 105 expires in 9.896
Standby router is local
3 state changes, last state change 00:10:21
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 1 up:
Interface   Decrement  State
Serial1        10      Up

Хотя R2 не использует приоритет HSRP, выходные данные определяют приоритет R2 в качестве значения по умолчанию HSRP (100). Выходные данные двух маршрутизаторов показывают, что маршрутизаторы отслеживают состояние интерфейса serial 0. R1 является активным маршрутизатором, а R2 - резервным. В итоге оба маршрутизатора настраиваются с помощью команды standby preempt.

Что произойдет, если интерфейс serial 0 маршрутизатора R1 перестанет работать? Выходные данные команды show standby выглядят таким образом:

R1# show standby
Ethernet0 - Group 1
Local state is Standby, priority 95 (confgd 105), may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 2.670
Virtual IP address is 171.16.6.100 configured
Active router is 171.16.6.6, priority 100 expires in 8.596
Standby router is local
4 state changes, last state change 00:01:45
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 0 up:
Interface    Decrement  State
Serial0         10      Down
   
R2# show standby
Ethernet0 - Group 1
Local state is Active, priority 100, may preempt
Hellotime 3 sec, holdtime 10 sec
Next hello sent in 0.810
Virtual IP address is 171.16.6.100
Active router is local
Standby router is 171.16.6.5 expires in 9.028
Virtual mac address is 0000.0c07.ac01
4 state changes, last state change 00:01:38
IP redundancy name is "hsrp-Et0-1" (default)
Priority tracking 1 interface, 1 up:
Interface   Decrement  State
Serial1        10      Up

Выходные данные показывают, что приоритет HSRP маршрутизатора R1 сократился на 10 и составил 95. В результате приоритет R2 стал выше (100). R2 настраивался с помощью команды standby preempt, и приоритет этого маршрутизатора стал выше, поэтому R2 становится активным маршрутизатором, а R1 - резервным. Теперь, если интерфейс serial 0 маршрутизатора R1 снова заработает, приоритет R1 будет равен 105. Если это происходит, R1 становится преимущественным и снова является активным маршрутизатором HSRP.

Примечание. Если команда standby preempt не использовалась при настройке R2, то этот маршрутизатор не отсылает сообщение coup на R1 и R2 становится активным. Вместо этого активным маршрутизатором должен был стать R1.

Рассмотрим, например, следующую конфигурацию:

standby priority 120
standby track serial 0
standby track serial 1

Приоритет HSRP, равный 120, настраивается с помощью команды standby priority, а настройки HSRP позволяют отслеживать состояние двух интерфейсов - Serial0 и Serial 1. Поскольку в команде standby track не определено значение декремента, при отказе работы интерфейса приоритет HSRP уменьшается на значение, равное 10 по умолчанию. Исходно оба интерфейса находятся в рабочем состоянии, и приоритет HSRP интерфейса составляет 120, как указано в выходных данных команды show standby.

R1# show standby
Ethernet0 - Group 1
  Local state is Active, priority 120, may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 1.034
  Virtual IP address is 10.0.0.5 configured
  Active router is local
  Standby router is unknown
  Virtual mac address is 0000.0c07.ac01
  2 state changes, last state change 00:00:04
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 2 interfaces, 2 up:
    Interface                  Decrement  State
    Serial0                       10      Up
    Serial1                       10      Up
R1#

Затем интерфейс Serial 0 перестает работать.

R1#
1w0d: %LINK-3-UPDOWN: Interface Serial0, changed state to down
1w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down
R1#

Это уменьшает приоритет HSRP на 10: со 120 до 110. Чтобы проверить это, можно использовать команду show standby.

R1# show standby
Ethernet0 - Group 1
  Local state is Active, priority 110 (confgd 120), may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 2.544
  Virtual IP address is 10.0.0.5 configured
  Active router is local
  Standby router is unknown
  Virtual mac address is 0000.0c07.ac01
  2 state changes, last state change 00:00:48
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 2 interfaces, 1 up:
    Interface                  Decrement  State
    Serial0                       10      Down  (line protocol down)
    Serial1                       10      Up
R1#

Затем прекращает работу второй интерфейс Serial 1:

R1#
1w0d: %LINK-3-UPDOWN: Interface Serial1, changed state to down
1w0d: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1, changed state to down
R1#

Это вновь уменьшает приоритет HSRP на 10: со 110 до 100. Чтобы проверить это, можно использовать команду show standby:

R1# show standby
Ethernet0 - Group 1
  Local state is Active, priority 100 (confgd 120), may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 1.846
  Virtual IP address is 10.0.0.5 configured
  Active router is local
  Standby router is unknown
  Virtual mac address is 0000.0c07.ac01
  2 state changes, last state change 00:01:06
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 2 interfaces, 0 up:
    Interface                  Decrement  State
    Serial0                       10      Down  (line protocol down)
    Serial1                       10      Down  (line protocol down)
R1#

При выходе из строя любого отслеживаемого последовательного интерфейса (serial 0 или serial 1) приоритетность составляет 110. Если прекращают работать оба интерфейса (serial 0 и serial 1), приоритетность равна 100.

Примечание. В некоторых более старых версиях ПО Cisco IOS декремент приоритетности HSRP не является совокупным, если не было явно определено значение декремента команды standby track. Для получения дополнительных сведений см. идентификатор ошибки CSCdp72834 (только для зарегистрированных пользователей).

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 13780