Беспроводные сети / Мобильные решения : "Беспроводные сети, LAN (WLAN)"

Пример настройки VLAN на контроллерах беспроводной LAN

23 марта 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (28 июля 2013) | Английский (26 августа 2011) | Отзыв

Содержание

Введение
Предварительные условия
      Требования
      Используемые компоненты
      Условные обозначения
Настройка
      Схема сети
      Конфигурация коммутаторов Catalyst
      Настройка VLAN на WLAN контроллере
Проверка
      Проверка для коммутаторов Catalyst
      Проверка VLAN на контроллере WLAN
Устранение неполадок
      Процедура устранения неполадок
Связанные обсуждения сообщества поддержки Cisco
Дополнительные сведения

Введение

В настоящем документе описывается пример настройки сетей VLAN на контроллере беспроводной LAN (WLAN) и коммутаторе Cisco Catalyst, который связан с этим контроллером.

Предварительные условия

Требования

Настоящий документ не содержит каких-либо специфических требований. Однако при этом предполагается наличие в сети работающего DHCP-сервера, который выделяет IP-адреса точкам доступа, зарегистрированным на контроллере.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Конфигурация А:

    • Коммутатор Catalyst, на котором установлено ПО Cisco IOS® и контроллер WLAN

    • Контроллер WLAN Cisco 4404 WLAN

  • Конфигурация B:

    • Коммутатор Catalyst, на котором установлена операционная система Catalyst OS (CatOS) и контроллер WLAN

    • Контроллер WLAN Cisco 4404

Информация, представленная в этом документе, была получена при использовании устройств в специальных лабораторных условиях. При написании данного документа использовались только устройства с "чистой" (стандартной) конфигурацией. При работе в условиях реальной сети оператор должен понимать последствия использования любой команды.

Условные обозначения

См. Технические советы Cisco. Условные обозначения для получения дополнительной информации об условных обозначениях в документах.

Настройка

В этом разделе приводятся сведения о настройке функций, описанных в данном документе.

Примечание: для поиска дополнительной информации о командах, упоминаемых в данном документе, используйте средство Command Lookup Tool (только для зарегистрированных пользователей).

Схема сети

Сети VLAN, в которых установлены контроллеры WLAN, имеют следующий вид:

wlan_controllers_vlans1.gif

Конфигурация коммутаторов Catalyst

В данном разделе используются следующие конфигурации:

Коммутатор Catalyst с ПО Cisco IOS

lab1sup720ip1#configure terminal 
Enter configuration commands, one per line.  End with CNTL/Z.
lab1sup720ip1(config)#interface gigabitethernet 1/6
lab1sup720ip1(config-if)#
lab1sup720ip1(config-if)#switchport
lab1sup720ip1(config-if)#switchport trunk encapsulation dot1q
lab1sup720ip1(config-if)#switchport trunk allowed vlan 1,5,15,20,25,30,35,40,45,50,55,100
lab1sup720ip1(config-if)#switchport mode trunk
lab1sup720ip1(config-if)#end
lab1sup720ip1#

Коммутатор Catalyst с ПО CatOS

controller-catos> (enable) set trunk 2/1 on dot1q
Port(s)  2/1 trunk mode set to on.
Port(s)  2/1 trunk type set to dot1q.
!
!clearing out/pruning unwanted vlans
!
controller-catos> (enable) clear trunk 2/1 21-24,26-30,31-34,36-39,41-44,46-49,51-54,
56-99,101-999

!--- Эта команда должна быть записана в одной строке.

Removing Vlan(s) 21-24,26-34,36-39,41-44,46-49,51-54,56-99,101-999 from allowed list.
Port  2/1 allowed vlans modified to 1,5,15,20,25,35,40,45,50,55,100,1000-1005,1025-4094.

Настройка VLAN на WLAN контроллере

Настройка при помощи графического интерфейса пользователя

Для настройки VLAN на контроллере WLAN в графическом интерфейсе пользователя необходимо выполнить следующие действия.

  1. Выберите Controller > Interfaces > New.

    wlan_controllers_vlans2.gif

  2. Введите имя интерфейса (Interface Name) и идентификатор VLAN (VLAN Identifier ). Нажмите Apply.

    После этого появится следующее окно:

    wlan_controllers_vlans3.gif

  3. Укажите IP-адрес (IP Address), маску сети (Netmask), шлюз (Gateway) и IP-адрес DHCP-сервера. Нажмите Apply.

    wlan_controllers_vlans4.gif

    Примечание: IP-адрес, назначенный для этого интерфейса, выполняет роль DHCP-ретранслятора, позволяя клиенту тем самым получить IP-адрес с DHCP-сервера. Например, если клиент пытается присоединиться к WLAN/SSID (см. шаг 5 данной процедуры настройки), которые ассоциированы с данным динамическим интерфейсом, тогда для определения DHCP-сервера он выполняет операцию широковещания в местной подсети. Контроллер направляет DHCP-серверу (или самому себе, если он является DHCP-сервером в данном сегменте) запрос, в котором IP-адрес этого динамического интерфейса указан в качестве релейного IP (relay IP), выполняющего переключение на DHCP-сервер, настроенный для данного интерфейса. Из имеющегося диапазона DHCP DHCP-сервер выделяет клиенту IP-адрес.

  4. Проверка конфигурации интерфейса.

    В меню, расположенном в верхней части окна, щелкните вкладку Controller и из меню, расположенного в левой части, выберите Interfaces.

    wlan_controllers_vlans5.gif

  5. В меню, расположенном в верхней части окна, выберите WLANs и щелкните New....

    wlan_controllers_vlans6.gif

  6. Введите индентификатор набора услуг (service set identifier – SSID) и нажмите Apply.

    Для простоты в данном примере используется vlan15.

    wlan_controllers_vlans7.gif

  7. В раскрывающемся списке "Interface Name", расположенном в нижней части окна, выберите vlan15 и нажмите Apply.

    В данном случае SSID "vlan15" привязан к имени интерфейса "vlan15".

    wlan_controllers_vlans8.gif

Настройка при помощи интерфейса командной строки

В данном разделе описывается процедура настройки VLAN посредством интерфейса командной строки (CLI).

  1. Создайте интерфейс и ассоциированный тэг VLAN.

    Для этого используется команда config interface create имя_интерфейса идентификатор_vlan.

    (lab5wlc4404ip15) >config interface create vlan15 15
    
  2. Назначьте IP-адрес и шлюз, используемый по умолчанию.

    Для этого используется команда config interface имя_интерфейса IP-адрес маска_сети шлюз.

    (lab5wlc4404ip15) >config interface address vlan15 192.168.15.10  
    255.255.255.0 192.168.15.1
    
    !--- Эта команда должна быть записана в одной строке.
    
    
  3. Установка DHCP-сервера.

    Для этого используется команда config interface dhcp имя_интерфейса dhcp_server 1 dhcp_server 2 dhcp_server 3 dhcp_server 4.

    (lab5wlc4404ip15) >config interface dhcp vlan15 192.168.5.15
    
  4. Проверка конфигурации интерфейса.

    Для проверки используйте команду show interface summary.

    (lab5wlc4404ip15) >show interface summary  
    
    Interface Name           Port     Vlan Id      IP Address          Type      Ap Mgr
    -----------------------  ----     --------     ---------------     -------   ------
    ap-manager               1        untagged     192.168.5.215       Static    Yes
    management               1        untagged     192.168.5.15        Static    No
    service-port             N/A      N/A          100.100.100.100     Static    No
    virtual                  N/A      N/A          1.1.1.1             Static    No
    vlan15                   1        15           192.168.15.10       Dynamic   No
    
    
    (lab5wlc4404ip15) >
  5. Установка WLAN.

    Для этого используется команда config interface create имя идентификатора_wlan.

    (lab5wlc4404ip15) >config wlan create 2 vlan15
    
  6. Установка интерфейса для WLAN.

    Для этого используется команда config wlan interface идентификатор_wlan имя_интерфейса.

    (lab5wlc4404ip15) >config wlan interface 2 vlan15
    
  7. Проверка WLAN и ассоциированного интерфейса.

    Для проверки используйте команду show wlan summary.

    (lab5wlc4404ip15) >show wlan summary 
    
    Number of WLANs.................................. 2
    
    WLAN ID   WLAN Name               Status        Interface Name                  
    -------   --------------------    ---------     --------------------------------
    1         lab5wlc4404ip15         Enabled       management                      
    2         vlan15                  Disabled      vlan15                          
    
    (lab5wlc4404ip15) >

Проверка

Воспользуйтесь данным разделом для проверки правильности функционирования вашей конфигурации.

Output Interpreter Tool (только для зарегистрированных клиентов) (OIT) поддерживает определенные команды show. Используйте OIT для анализа результатов команды show.

Проверка для коммутаторов Catalyst

  • Коммутатор Catalyst с ПО Cisco IOS — show running-config interface тип_интерфейса номер_интерфейса

    controller-ios#show running-config interface gigabitethernet 2/1
    
     Building configuration...
     
    Current configuration : 190 bytes
    !
    interface GigabitEthernet2/1
     no ip address
     switchport
     switchport trunk encapsulation dot1q
     switchport trunk allowed vlan 1,5,15,20,25,30,35,40,45,50,55,100
     switchport mode trunk
    end
  • Коммутатор Catalyst с ПО CatOS — команда show config mod

    controller-catos> (enable) show config 2
    
    !--- Эта команда используется только для отображения конфигураций, не заданных по умолчанию.
    !--- Выполните команду show config mod all,  
    !--- чтобы отобразить оба вида конфигураций (по умолчанию и не по умолчанию).
    
    ............................
    begin
    !
    # ***** NON-DEFAULT CONFIGURATION *****
    !
    !
    #time: Sat Jan 7 2006, 08:03:04 
    !
    # default port status is enable
    !
    !
    #module 2 : 2-port 1000BaseX Supervisor
    clear trunk 2/1  2-4,6-14,16-19,21-24,26-34,36-39,41-44,46-49,51-54,56-99,101-999
    set trunk 2/1  on dot1q 1,5,15,20,25,35,40,45,50,55,100,1000-1005,1025-4094
    end
    Console> (enable)

Проверка VLAN на контроллере WLAN

Для выполнения проверки обратитесь к разделу Настройка VLAN на WLAN контроллере, где описана процедура проверки.

Устранение неполадок

В данном разделе описываются процедуры устранения неполадок, связанных с конфигурацией.

Процедура устранения неполадок

Ниже приведены указания по устранению неполадок конфигурации.

  1. Выполните ping-тестирование от контроллера WLAN к шлюзу по умолчанию, на котором настроен маршрутизируемый интерфейс VLAN. Затем выполните ping-тестирование в обратном направлении.

    • Контроллер WAN:

      (lab5wlc4404ip15) >ping 192.168.15.1
      
      Send count=3, Receive count=3 from 192.168.15.1
    • Маршрутизируемый интерфейс VLAN:

      lab1sup720ip1#ping 192.168.15.10
      
      Type escape sequence to abort.
      Sending 5, 100-byte ICMP Echos to 192.168.15.10, timeout is 2 seconds:
      !!!!!
      Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms
      lab1sup720ip1#
  2. В случае неудачного тестирования на коммутаторе необходимо установить уловитель/анализатор пакетов для того, чтобы проверить правильность тегирования VLAN.

    Примечание: при выполнении ping-тестирования от контроллера до шлюза 3-го уровня, который находится в той же самой подсети, что и динамический интерфейс, все выглядит так, как будто источником ping для контроллера является динамический интерфейс.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 68100