Протокол IP : IP-маршрутизация

Перераспределение протоколов маршрутизации

21 мая 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (28 июля 2013) | Английский (22 марта 2012) | Отзыв

Содержание

Введение
Предварительные условия
      Требования
      Используемые компоненты
      Условные обозначения
Метрики
Административное расстояние
Примеры и синтаксис конфигурации перераспределения
      IGRP и EIGRP
      OSPF
      RIP
      IS-IS
      Подключенные маршруты
Как избежать проблем из-за перераспределения
      Пример 1
      Пример 2
      Пример 3
Связанные обсуждения сообщества поддержки Cisco
Дополнительные сведения

Введение

Применение протокола маршрутизации для объявления маршрутов, определяемых другими способами (например, другим протоколом маршрутизации, статическими маршрутами или маршрутами с прямым подключением), называется перераспределением. Хотя во всей объединенной IP-сети желательно использовать единый протокол маршрутизации, по ряду причин часто используется многопротокольная маршрутизация: например, при слиянии компаний, в случае, если несколькими подразделениями управляют несколько сетевых администраторов, или в средах, где используются компоненты от разных поставщиков. При проектировании сети часто используются разные протоколы маршрутизации. В любом случае, наличие среды с несколькими протоколами делает перераспределение необходимым.

Различия в таких характеристиках протоколов маршрутизации, как метрики, административное расстояние, функции с использованием классов и без него, могут повлиять на перераспределение. И чтобы перераспределение проходило успешно, необходимо учитывать эти различия.

Предварительные условия

Требования

Для этого документа нет особых предварительных условий.

Используемые компоненты

Сведения, представленные в этом документе, относятся к следующим версиям программного и аппаратного обеспечения.

  • ПО Cisco IOS® версии 12.2(10b)

  • Маршрутизаторы серии Cisco 2500

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Технические рекомендации Cisco. Условные обозначения.

Метрики

При перераспределении одного протокола в другой следует помнить, что метрики каждого протокола играют важную роль в перераспределении. Каждый протокол использует разные метрики. Например, метрика протокола RIP основана на количестве переходов, однако протоколы IGRP и EIGRP используют составную метрику в зависимости от пропускной способности, задержки, надежности, загрузки и максимального размера передаваемого блока данных (MTU), где пропускная способность и задержка являются единственными параметрами, используемыми по умолчанию. В процессе перераспределения маршрутов необходимо определить метрику, понятную принимающему протоколу. Есть два метода определения метрик при перераспределении маршрутов.

redist-a.gif

Можно определить метрику только для конкретного перераспределения:

router rip
redistribute static metric 1
redistribute ospf 1 metric 1

Или можно использовать одну и ту же метрику по умолчанию для всего перераспределения (использование команды default-metric упрощает задачу, так как в этом случае не нужно определять метрику отдельно для каждого перераспределения.):

router rip
redistribute static
redistribute ospf 1
default-metric 1

Административное расстояние

Если маршрутизатор использует более одного протокола маршрутизации и определяет маршрут до одного и того же места назначения с помощью обоих протоколов, какой из маршрутов должен быть признан лучшим? Каждый протокол использует свой тип метрики для определения лучшего маршрута. Сравнение маршрутов с разными типами метрик невозможно. Административные расстояния решают эту проблему. Административные расстояния назначаются источникам маршрутов, с тем чтобы маршрут от наиболее предпочтительного источника был выбран в качестве лучшего. Дополнительные сведения об административных расстояниях и выборе маршрутов см. в документе Выбор маршрутов в маршрутизаторах Cisco.

Административные расстояния помогают выбрать маршрут среди различных протоколов маршрутизации, но могут привести к проблемам при перераспределении. Среди этих проблем могут быть петли маршрутизации, проблемы сходимости и неэффективная маршрутизация. Ниже представлена топология и описание возможной проблемы.

redist-b.gif

В указанной выше топологии, если в маршрутизаторе R1 применяется RIP, а в R2 и R5 одновременно применяются RIP и IGRP с перераспределением RIP в IGRP, возможно возникновение проблем. Например, R2 и R5 оба получают данные о сети 192.168.1.0 от R1 через протокол RIP. Эти данные перераспределяются в IGRP. R2 получает информацию о сети 192.168.1.0 через R3, а R5 — через R4 с помощью IGRP. У IGRP административное расстояние меньше, чем у RIP (100 против 120), поэтому в таблице маршрутизации используется маршрут IGRP. Теперь существует опасность петли маршрутизации. Даже при наличии разделения горизонта или другой функции, предназначенной для предотвращения петель маршрутизации, все равно имеет место проблема сходимости.

Если R2 и R5 также перераспределяют IGRP в RIP (эта операция иначе называется взаимным перераспределением) и сеть 192.168.1.0 напрямую не подключена к R1 (R1 получает данные о ней от другого, маршрутизатора более высокого уровня), то существует потенциальная опасность, что R1 будет получать информацию о сети из R2 или R5 с лучшей метрикой, чем у оригинального источника.

Примечание: В маршрутизаторах Cisco используется патентованная механика перераспределения маршрутов. Правила перераспределения на маршрутизаторах Cisco требуют, чтобы перераспределяемый маршрут присутствовал в таблице маршрутизации. Присутствия маршрута в топологии или базе данных маршрутизации недостаточно. В таблицу маршрутизации всегда заносятся маршруты с меньшим административным расстоянием (AD) . Например, если статический маршрут перераспределяется в IGRP на маршрутизаторе R5 и затем IGRP в свою очередь перераспределяется в RIP на том же самом маршрутизаторе (R5), этот статический маршрут не перераспределяется в RIP, поскольку он не был занесен в таблицу маршрутизации IGRP. Это происходит потому, что у статических маршрутов AD равно 1, а у маршрутов IGRP AD равно 100, и в таблицу маршрутизации занесен статический маршрут. Чтобы перераспределить этот статический маршрут в IGRP на R5, необходимо воспользоваться командой redistribute static в команде router rip.

Стандартное поведение RIP, IGRP и EIGRP — объявлять напрямую подключенные маршруты, когда инструкция network для протокола маршрутизации включает подключенную подсеть интерфейса. Есть два способа получить подключенный маршрут:

  • Интерфейс настроен с IP-адресом и маской — эта соответствующая подсеть считается подключенным маршрутом.

  • Статический маршрут настроен только с исходящим интерфейсом и без IP-адреса следующего перехода — это также считается подключенным маршрутом.

Router# conf t
   Router(config)# ip route 10.0.77.0 255.255.255.0 ethernet 0/0
   Router(config)# end

   Router# show ip route static
   10.0.0.0/24 is subnetted, 1 subnets
   S 10.0.77.0 is directly connected, Ethernet0/0

Команда network, указанная для EIGRP, RIP или IGRP и включающая ("охватывающая") каждый из этих типов подключенных маршрутов, включает эту подсеть для объявления.

Например, если у интерфейса адрес 10.0.23.1 и маска 255.255.255.0, подсеть 10.0.23.0/24 является подключенным маршрутом и будет объявлена этими протоколами маршрутизации, когда будет выполнена следующая инструкция network:

router rip | igrp # | eigrp #
   network 10.0.0.0

Статический маршрут 10.0.77.0/24 также объявляется этими протоколами маршрутизации, так как он подключен и "охвачен" инструкцией network.

Рекомендации о том, как избежать этой проблемы, см. в разделе Как избежать проблем, возникающих из-за перераспределения.

Примеры и синтаксис конфигурации перераспределения

IGRP и EIGRP

В следующих выходных данных показано перераспределение маршрутизатором IGRP/EIGRP следующих маршрутов: статических, OSPF, RIP и IS-IS.

router igrp/eigrp 1 
network 131.108.0.0 
redistribute static
redistribute ospf 1 
redistribute rip 
redistribute isis 
default-metric 10000 100 255 1 1500

Когда протоколы IGRP и EIGRP перераспределяют другие протоколы, им нужно 5 метрик: пропускная способность, задержка, надежность, загрузка и MTU, соответственно. Вот пример метрик IGRP:

Метрика

Значение

пропускная способность

10000 килобит в секунду для Ethernet

задержка

100 x 10 микросекунд = 1 миллисекунда для Ethernet

надежность

255 для 100-процентной надежности

загрузка

Эффективная загрузка канала выражается числом от 0 до 255 (где 255 – 100-процентная загрузка)

MTU

Минимальный MTU пути; обычно равен MTU для интерфейса Ethernet, то есть 1500 байт

Несколько процессов IGRP и EIGRP могут запускаться на одном и том же маршрутизаторе с перераспределением между ними. Например, IGRP1 и IGRP2 могут выполняться на одном маршрутизаторе. Однако выполнение двух процессов одного протокола на одном и том же маршрутизаторе редко бывает необходимо и может потреблять память и процессорные ресурсы маршрутизатора.

Перераспределение IGRP/EIGRP в другой процесс IGRP/EIGRP не требует какого-либо преобразования метрик, поэтому во время перераспределения нет необходимости определять метрики или использовать команду default-metric.

OSPF

Следующие выходные данные показывают перераспределение маршрутизатором OSPF следующих маршрутов: статических, RIP, IGRP, EIGRP и IS-IS.

router ospf 1 
network 131.108.0.0 0.0.255.255 area 0 
redistribute static metric 200 subnets
redistribute rip metric 200 subnets 
redistribute igrp 1 metric 100 subnets 
redistribute eigrp 1 metric 100 subnets 
redistribute isis metric 10 subnets

Метрика OSPF — это значение стоимости, основанное на значении 108/ пропускная способность канала в битах в секунду. Например, стоимость OSPF для Ethernet равна 10: 108/107 = 10

Примечание: Если метрика не указана, OSPF при перераспределении маршрутов от всех протоколов подставляет значение по умолчанию, равное 20, за исключением маршрутов протокола BGP, которые получают метрику 1.

Если есть основная сеть и подсети, при перераспределении протоколов в OSPF необходимо использовать ключевое слово "subnet". Без этого ключевого слова протокол OSPF перераспределяет только основные сети, не имеющие подсетей.

На одном и том же маршрутизаторе можно запускать несколько процессов OSPF. Однако запуск более одного процесса одного и того же протокола требуется редко и потребляет память и процессорные ресурсы маршрутизатора.

Перераспределение одного процесса OSPF в другой не требует определения метрики или использования команды default-metric.

RIP

Примечание: Принципы, изложенные в этом документе, применимы к RIP версий I и II.

Следующие выходные данные показывают перераспределение маршрутизатором RIP следующих маршрутов: статических, IGRP, EIGRP, OSPF и IS-IS.

router rip 
network 131.108.0.0 
redistribute static
redistribute igrp 1 
redistribute eigrp 1 
redistribute ospf 1 
redistribute isis 
default-metric 1

Метрика RIP состоит из количества переходов, и максимально допустимое значение этой метрики составляет 15. Все, что превышает 15, считается бесконечным. Для описания бесконечного значения в RIP можно использовать значение 16. Компания Cisco рекомендует использовать при перераспределении протоколов в RIP низкие метрики, например 1. Высокая метрика, такая как 10 еще больше ограничивает RIP. Если для перераспределяемых маршрутов определить метрику 10, эти маршруты можно будет объявлять только маршрутизаторам, которые находятся на расстоянии до 5 переходов, после которых метрика (количество переходов) превысит значение 15. Определяя для метрики значение 1, вы разрешаете маршруту максимальное количество переходов в домене RIP. Однако это увеличивает возможность петель маршрутизации, если есть несколько точек перераспределения и маршрутизатор получает данные о сети с лучшей метрикой из точки перераспределения, а не из оригинального источника, как описано в разделе Административное расстояние этого документа. Поэтому необходимо, чтобы метрика была не слишком высокой (не препятствовала объявлению маршрута всем маршрутизаторам) и не слишком низкой (не приводила к петлям маршрутизации, если есть несколько точек перераспределения).

IS-IS

Следующие выходные данные показывают перераспределение маршрутизатором IS-IS следующих маршрутов: статических, RIP, IGRP, EIGRP и OSPF.

router isis 
network 49.1234.1111.1111.1111.00
redistribute static
redistribute rip metric 20 
redistribute igrp 1 metric 20 
redistribute eigrp 1 metric 20 
redistribute ospf 1 metric 20

Метрика IS-IS должна иметь значение от 1 до 63. В IS-IS нет возможности использовать команду "default-metric" — необходимо определять метрику для каждого протокола, как показано в примере выше. Если для маршрутов, перераспределяемых в IS-IS, метрика не указана, по умолчанию используется метрика равная 0.

Подключенные маршруты

Перераспределение напрямую подключенных маршрутов в протоколы маршрутизации не очень распространено и поэтому не показано в примерах, приведенных выше. Однако важно отметить, что его можно выполнить — как прямо, так и косвенно. Чтобы напрямую перераспределить подключенные маршруты, воспользуйтесь командой настройки маршрутизатора — redistribute connected. Также в этом случае необходимо определить метрику. Кроме того, можно косвенно перераспределять подключенные маршруты в протоколы маршрутизации, как показано в следующем примере.

redist-cnctd.gif

В этом примере маршрутизатор B имеет два интерфейса Fast Ethernet. FastEthernet 0/0 находится в сети 10.1.1.0/24, а FastEthernet 0/1 — в сети 20.1.1.0/24. Маршрутизатор B выполняет EIGRP с маршрутизатором A и OSPF с маршрутизатором C. Маршрутизатор B выполняет взаимное перераспределение между процессами EIGRP и OSPF. Вот информация о конфигурации маршрутизатора B:

Маршрутизатор B

interface FastEthernet0/0
 ip address 10.1.1.1 255.255.255.0

interface FastEthernet0/1
 ip address 10.1.1.1 255.255.255.0

router eigrp 7
 redistribute ospf 7 metric 10000 100 255 1 1500
 network 10.1.1.0 0.0.0.255
 auto-summary
 no eigrp log-neighbor-changes
!
router ospf 7
 log-adjacency-changes
 redistribute eigrp 7 subnets
 network 20.1.1.0 0.0.0.255 area 0

Если посмотреть на таблицу маршрутизации для маршрутизатора B, можно увидеть следующее:

routerB# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     20.0.0.0/24 is subnetted, 1 subnets
C       20.1.1.0 is directly connected, FastEthernet0/1
     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0/0

В конфигурации и таблице маршрутизации, приведенных выше, обращают на себя внимание три момента:

  • Рассматриваемые сети представлены в таблице маршрутизации маршрутизатора B как напрямую подключенные сети.

  • Сеть 10.1.1.0/24 является частью процесса EIGRP, а сеть 20.1.1.0/24 — частью процесса OSPF.

  • Маршрутизатор B выполняет взаимное перераспределение между EIGRP и OSPF.

Ниже показаны таблицы маршрутизации для маршрутизаторов A и C.

routerA# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, * - candidate default
       U - per-user static route, o - ODR

Gateway of last resort is not set

     10.0.0.0/24 is subnetted, 1 subnets
C       10.1.1.0 is directly connected, FastEthernet0
     20.0.0.0/24 is subnetted, 1 subnets
D EX    20.1.1.0 [170/284160] via 10.1.1.4, 00:07:26, FastEthernet0


routerC# show ip route
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     20.0.0.0/24 is subnetted, 1 subnets
C       20.1.1.0 is directly connected, FastEthernet1
O E2    10.1.1.0 [110/20] via 20.1.1.4, 00:07:32, FastEthernet1

Маршрутизатор A определил сеть 20.1.1.0/24 через EIGRP, который показан как внешний маршрут, поскольку он был перераспределен из OSPF в EIGRP. Маршрутизатор C определил сеть 10.1.1.0/24 через OSPF, используемый как внешний маршрут, поскольку он был перераспределен из EIGRP в OSPF. Хотя маршрутизатор B не перераспределяет подключенные сети, он объявляет сеть 10.1.1.0/24, которая является частью процесса EIGRP, перераспределенного в OSPF. Аналогичным образом маршрутизатор В объявляет сеть 20.1.1.0/24, которая является частью процесса OSPF, перераспределенного в EIGRP.

Дополнительные сведения о перераспределении подключенных маршрутов в OSPF см. в статье Перераспределение подключенных сетей в OSPF.

Как избежать проблем из-за перераспределения

В разделе об административном расстоянии были рассмотрены проблемы, которые могут возникнуть в результате перераспределения, в том числе неоптимальная маршрутизация, петли маршрутизации и медленная сходимость. Избежать этих проблем в действительности довольно просто — никогда не объявлять информацию, изначально полученную от процесса маршрутизации X, обратно процессу маршрутизации X.

Пример 1

redist-b.gif

В приведенной выше топологии R2 и R5 выполняют взаимное перераспределение. RIP перераспределяется в IGRP, а IGRP перераспределяется в RIP, как показано в конфигурации ниже.

R2:

router igrp 7
network 181.16.0.0 
 
redistribute rip metric 1 1 1 1 1
 
router rip
network 178.1.0.0
redistribute igrp 7 metric 2

R5:

router igrp 7
network 181.16.0.0 
 
redistribute rip metric 1 1 1 1 1
 
router rip
network 178.1.0.0
redistribute igrp 7 metric 2

При такой конфигурации возможны любые из описанных выше проблем. Чтобы их избежать, можно отфильтровать обновления маршрутов следующим образом:

R2:

router igrp 7
network 181.16.0.0 
 
redistribute rip metric 1 1 1 1 1
distribute-list 1 in s1
 
router rip
network 178.1.0.0
redistribute igrp 7 metric 2
 
access-list 1 deny 192.168.1.0
access-list 1 permit any

R5:

router igrp 7
network 181.16.0.0 
 
redistribute rip metric 1 1 1 1 1
distribute-list 1 in s1 
 
router rip
network 178.1.0.0

redistribute igrp 7 metric 2 
 
access-list 1 deny 192.168.1.0
access-list 1 permit any

Списки распределения, добавленные к конфигурациям, как показано выше, фильтруют все обновления IGRP, поступающие в последовательный интерфейс 1 маршрутизаторов. Если маршруты, указанные в обновлениях, разрешены списком доступа 1, маршрутизатор принимает их в обновлении, в противном случае — нет. В этом примере маршрутизаторам говорится, что они не должны определять сеть 192.168.1.0 через обновления IGRP, поступающие в их последовательный интерфейс 1; поэтому эти маршрутизаторы получают данные о сети 192.168.1.0 только через RIP от R1.

Также помните, что в этом случае для процесса RIP необязательно использовать ту же стратегию фильтрации, поскольку у RIP административное расстояние больше, чем у IGRP. Если маршруты, берущие начало в домене IGRP, вернутся в R2 и R5 через RIP, маршруты IGRP все равно будут иметь преимущество.

Пример 2

redist-c.gif

Используя топологию, указанную выше, можно продемонстрировать другой способ (который иногда более предпочтителен) избежать проблем с перераспределением. Этот способ предусматривает использование инструкций route-map, чтобы задать теги для различных маршрутов. Процессы маршрутизации затем могут выполнять перераспределение на основе этих тегов. Обратите внимание, что перераспределение на основе тегов не работает с RIP версии 1 и IGRP.

Одна из проблем, с которой можно столкнуться в указанной топологии, заключается в следующем:

R1 объявляет сеть 192.168.1.0 маршрутизатору R2. R2 затем выполняет перераспределение в EIGRP. R5 определяет сеть через EIGRP и перераспределяет ее в RIPv2. В зависимости от метрики, которую R5 задает для маршрута RIPv2, R6, чтобы достичь сети, может выбрать менее желательный маршрут через R5 вместо маршрута через R1. Следующая конфигурация позволяет этого избежать с помощью установки тегов и последующего перераспределения на основе этих тегов.

R2:

router eigrp 7
network 181.16.0.0
redistribute rip route-map rip_to_eigrp metric 1 1 1 1 1

!--- Перераспределяет маршруты RIP, которые
 

!--- разрешены инструкцией route-map rip_to_eigrp




router rip
version 2
network 178.1.0.0
redistribute eigrp 7 route-map eigrp_to_rip metric 2

!--- Перераспределяет маршруты EIGRP и устанавливает теги,
 

!--- в соответствии с eigrp_to_rip route-map



route-map rip_to_eigrp deny 10
match tag 88

!--- Инструкция route-map, запрещающая перераспределение в EIGRP


!--- всех маршрутов с тегом "88" 
  

!--- Обратите внимание, что маршруты с тегом "88" должны быть
 

!--- маршрутами EIGRP, которые перераспределяются в RIPv2


route-map rip_to_eigrp permit 20
set tag 77

!--- Инструкция route-map для установки тега "77" 


!--- на маршрутах RIPv2, перераспределяемых в EIGRP 


route-map eigrp_to_rip deny 10
match tag 77

!--- Инструкция route-map, запрещающая перераспределение в RIPv2
 

!--- всех маршрутов с тегом "77"


!--- Обратите внимание, что маршруты с тегом "77" должны быть
 

!--- маршрутами RIPv2, которые перераспределяются в EIGRP



route-map eigrp_to_rip permit 20
set tag 88

!--- Инструкция route-map для установки тега "88" 
 

!--- на маршрутах EIGRP, перераспределяемых в RIPv2 

R5:

router eigrp 7
network 181.16.0.0
redistribute rip route-map rip_to_eigrp metric 1 1 1 1 1

!--- Перераспределяет маршруты RIPv2, которые 


!--- разрешены инструкцией route-map rip_to_eigrp




router rip
version 2
network 178.1.0.0
redistribute eigrp 7 route-map eigrp_to_rip metric 2

!--- Перераспределяет маршруты EIGRP и устанавливает теги, 


!--- в соответствии с eigrp_to_rip route-map




route-map rip_to_eigrp deny 10
match tag 88

!--- Инструкция route-map, запрещающая перераспределение в EIGRP
 

!--- всех маршрутов с тегом "88"


!--- Обратите внимание, что маршруты с тегом "88" должны быть
 

!--- маршрутами EIGRP, которые перераспределяются в RIPv2


route-map rip_to_eigrp permit 20
set tag 77

!--- Инструкция route-map для установки тега "77" 


!--- на маршрутах RIP, перераспределяемых в EIGRP


route-map eigrp_to_rip deny 10
match tag 77

!--- Инструкция route-map, запрещающая перераспределение в RIPv2


!--- всех маршрутов с тегом "77"


!--- Обратите внимание, что маршруты с тегом "77" должны быть
 

!--- маршрутами RIPv2, которые перераспределяются в EIGRP


route-map eigrp_to_rip permit 20
set tag 88

!--- Инструкция route-map для установки тега "88" 


!--- на маршрутах EIGRP, перераспределяемых в RIPv2 


Выполнив вышеуказанную конфигурацию, можно проверить некоторые конкретные маршруты в таблице маршрутизации, чтобы убедиться, что теги установлены. Ниже приведены выходные данные команды show ip route для определенных маршрутов в R3 и R1:

R3# show ip route 178.1.10.8
Routing entry for 178.1.10.8/30
  Known via "eigrp 7", distance 170, metric 2560512256
  Tag 77, type external
  Redistributing via eigrp 7
  Last update from 181.16.2.10 on Serial0, 00:07:22 ago
  Routing Descriptor Blocks:
  * 181.16.2.10, from 181.16.2.10, 00:07:22 ago, via Serial0
      Route metric is 2560512256, traffic share count is 1
      Total delay is 20010 microseconds, minimum bandwidth is 1 Kbit
      Reliability 1/255, minimum MTU 1 bytes
      Loading 1/255, Hops 1


R1# show ip route 181.16.2.4
Routing entry for 181.16.0.0/16
  Known via "rip", distance 120, metric 2
  Tag 88
  Redistributing via rip
  Last update from 178.1.10.5 on Serial0, 00:00:15 ago
  Routing Descriptor Blocks:
  * 178.1.10.5, from 178.1.10.5, 00:00:15 ago, via Serial0
      Route metric is 2, traffic share count is 1

Пример 3

Перераспределение также может происходить среди разных процессов одного протокола маршрутизации. Следующая конфигурация является примером использования политики перераспределения для перераспределения двух процессов EIGRP, выполняющихся на одном или нескольких маршрутизаторах:

router eigrp 3
 redistribute eigrp 5 route-map to_eigrp_3
 default-metric 10000 100 255 1 1500

!--- Перераспределяет EIGRP 5 в EIGRP 3, устанавливая теги 


!--- в соответствии с инструкцией "route-map to_eigrp_3"



router eigrp 5
 redistribute eigrp 3 route-map to_eigrp_5
 default-metric 10000 100 255 1 1500

!--- Перераспределяет EIGRP 3 в EIGRP 5


!--- Маршруты с тегом 33 не будут перераспределяться
 

!--- из-за инструкции "route map to_eigrp_5"
!--- Хотя команда default-metric не требуется
!--- при перераспределении между разными процессами EIGRP,
!--- ее можно использовать по желанию, как показано выше, чтобы объявлять 
!--- маршруты с определенными значениями для подсчета метрики.


route-map to_eigrp_3 deny 10
match tag 55

!--- Инструкция "route-map", запрещающая перераспределение в EIGRP 3
 

!--- всех маршрутов с тегом "55"


!--- Обратите внимание, что маршруты с тегом "55" должны быть
 

!--- маршрутами EIGRP 3, которые перераспределяются в EIGRP 5


route-map to_eigrp_3 permit 20
 set tag 33

!--- Инструкция "route-map" для установки тега "33" 
 

!--- на маршрутах, перераспределяемых из EIGRP 5 в EIGRP 3


route-map to_eigrp_5 deny 10
 match tag 33

!--- Инструкция "route-map", запрещающая перераспределение в EIGRP 3 


!--- всех маршрутов с тегом "33"


!--- Обратите внимание, что маршруты с тегом "33" должны быть
 

!--- маршрутами EIGRP 5, которые перераспределяются в EIGRP 3


route-map to_eigrp_5 permit 20
set tag 55

!--- Инструкция "route-map" для установки тега "55" 
 

!--- на маршрутах, перераспределяемых из EIGRP 3 в EIGRP 5


Это всего лишь несколько примеров стратегий фильтрации, использованных для целей этого документа. Однако могут быть и другие стратегии, которые можно использовать. Дополнительные сведения см. в разделе фильтрации информации о маршрутизации в документе Настройка независимых от протокола функций IP-маршрутизации.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 8606