Протокол IP : Cервисы IP-приложения

Разделение нагрузки с HSRP

21 мая 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (28 июля 2013) | Английский (10 августа 2005) | Отзыв

Содержание

Введение
Предварительные условия
      Требования
      Используемые компоненты
      Теоретические сведения
      Условные обозначения
Настройка
      Схема сети
      Конфигурации
      Важное замечание
Проверка
Устранение неполадок
Связанные обсуждения сообщества поддержки Cisco
Дополнительные сведения

Введение

Этот документ содержит пример настройки протокола Hot Standby Router Protocol (HSRP), которая позволит использовать несколько путей для доступа к определенному получателю.

Предварительные условия

Требования

Для данного документа нет особых требований.

Используемые компоненты

Данный документ не ограничен отдельными версиями программного и аппаратного обеспечения.

Сведения, представленные в данном документе, были получены на тестовом оборудовании в специально созданных лабораторных условиях. При написании данного документа использовались только данные, полученные от устройств с конфигурацией по умолчанию. При работе с реально функционирующей сетью необходимо полностью осознавать возможные последствия выполнения команд до их применения.

Теоретические сведения

HSRP часто используется для повышения отказоустойчивости сетей, но использование этого протокола может также привести к снижению эффективности передачи данных в сети. В примере в данном документе присутствуют два пути от сети узла к сети сервера. Для обеспечения избыточности HSRP поддерживается между R1 и R2, каждый из которых может стать активным маршрутизатором и "завладеть" виртуальным IP-адресом HSRP. Второй маршрутизатор становится резервным, но может вновь стать активным, если предыдущий активный маршрутизатор перестает работать. Дополнительная информация об активном и резервном маршрутизаторах представлена в разделе Как использовать команды standby preempt и standby track.

Адрес шлюза узлов по умолчанию был назначен в качестве виртуального IP-адреса HSRP этих маршрутизаторов. Когда главным узлам требуется послать пакеты на серверную сеть, они посылают их на свои шлюзы по умолчанию или на любой активный маршрутизатор. Поскольку активен только один маршрутизатор, пакеты от узлов к серверам проходят только по одному из двух доступных путей.

Примечание. В зависимости от конфигурации R3 пакеты, возвращаемые с серверов на узлы, могут использовать оба обратных пути. Также пакеты, возвращаемые с серверов на узлы, не должны проходить через активных маршрутизатор.

Чтобы использовать оба маршрута от сети узла к сети сервера, нужно настроить протокол HSRP для нескольких групп (MHSRP) на участке между маршрутизаторами R1 и R2. В основном R1 настраивается с двумя группами HSRP (например, группа 1 и группа 2); R2 настраивается с теми же группами HSRP. Для группы 1 R1 является активным маршрутизатором, а R2 – резервным. Для второй группы R2 является активным маршрутизатором, а R1 - резервным. Затем половина шлюзов узлов по умолчанию настраивается с использованием виртуального IP-адреса группы 1 HSRP, а другая половина - с использованием виртуального IP-адреса группы 2 HSRP.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в разделе Технические советы Cisco. Условные обозначения.

Настройка

В этом разделе приводятся сведения о настройке функций, описанных в данном документе.

Примечание. Для поиска дополнительной информации о командах в данном документе используйте средство Command Lookup (только для зарегистрированных клиентов).

Схема сети

В данном разделе используются следующие настройки сети:

7a.gif

Конфигурации

В этом разделе используются следующие конфигурации:

Конфигурация R1 MHSRP

Текущая конфигурация:

interface Ethernet0
        ip address 171.16.6.5 255.255.255.0

        standby 1 preempt
        standby 1 ip 171.16.6.100
        standby 1 track Serial0
        standby 2 preempt
        standby 2 ip 171.16.6.200
        standby 2 track serial 0
        standby 2 priority 95

Конфигурация R2 MHSRP

Текущая конфигурация:

interface Ethernet0
       ip address 171.16.6.6 255.255.255.0
       standby 1 preempt
       standby 1 ip 171.16.6.100
       standby 1 track Serial0
       standby 1 priority 95
       standby 2 preempt
       standby 2 ip 171.16.6.200
       standby 2 track serial 0

Обратите внимание, что в конфигурациях, где два маршрутизатора вначале используют HSRP, значение приоритетности по умолчанию R1 равно 100 для группы 1 и 95 для группы 2. Приоритетность по умолчанию маршрутизатора R2 составляет 100 для группы 2 и 95 для группы 1. Следовательно, R1 является активным маршрутизатором для группы 1, а R2 - активным маршрутизатором для группы 2. В этом примере показано, что можно выполнить процедуру разделения нагрузки с помощью MHSRP. Тем не менее, для этого необходимо использовать приоритетность HSRP и команду preempt. HSRP не влияет на ответный трафик.

Важное замечание

У некоторых контроллеров Ethernet (Lance и QUICC) в продуктах младших моделей может быть только один MAC-адрес для одноадресной рассылки в фильтре адресов. На этих платформах разрешена только одиночная HSRP группа, а адрес интерфейса изменяется на виртуальный HSRP MAC-адрес, когда группа активизируется. Разделение нагрузки на платформах с данным ограничением невозможно при использовании HSRP. Для исправления ошибок, возникающих при использовании HSRP с продуктами младших моделей, была введена команда use-bia. К примеру, при выполнении HSRP и DECnet на одном интерфейсе возникают проблемы, связанные с попытками DECnet и HSRP изменить MAC-адрес. С помощью команды use-bia HSRP может использовать MAC-адрес, созданный в результате процесса DECnet. Однако необходимо осознавать, что использование команды use-bia связано с некоторыми недостатками:

  • Когда маршрутизатор становится активным, виртуальный IP-адрес перемещается в другой МАС-адрес. Новый активный маршрутизатор отправляет ARP-ответ, но не все реализации узлов должным образом обрабатывают сообщения ARP.

  • Конфигурация use-bia нарушает работу прокси-ARP. Резервный маршрутизатор не может заменить утерянную базу данных прокси-ARP неисправного активного маршрутизатора.

Проверка

Для этой конфигурации отсутствует процедура проверки.

Устранение неполадок

Для этой конфигурации отсутствуют сведения об устранении неполадок.


Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 13781