Коммутаторы : Качество голосовой связи

VoIP через Frame Relay с QoS (фрагментация, формирование трафика, приоритет RTP IP/LLQ)

23 марта 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (28 июля 2013) | Английский (2 февраля 2006) | Отзыв

Содержание

Общие сведения
Предварительные условия
      Требования
      Используемые компоненты
      Условные обозначения
Руководство по проектированию QoS для передачи голосовых вызовов по протоколу IP через Frame Relay
      Строгая очередность для голосового трафика (приоритеты LLQ или IP RTP)
      FRTS для голоса
      Фрагментация (FRF.12)
      Сокращение полосы пропускания
Настройка
      LLQ
      Приоритет IP RTP
      Формирование трафика для передачи голоса
      Фрагментация (FRF.12)
      Схема сети
      Настройки
Проверка и устранение неисправностей
      Приоритетные команды LLQ / IP RTP
      Команды фрагментации
      Команды Frame Relay / Interface
      Известные проблемы
      Пример выходных данных команд show и debug
Связанные обсуждения сообщества поддержки Cisco
Дополнительные сведения

Общие сведения

В документе описан пример настройки сети с VoIP через Frame Relay с качеством обслуживания (QoS). В этот документ включены общие технические сведения о настроенных возможностях, указания по проектированию и описания основных стратегий проверки и устранения неисправностей.

Важно отметить, что пример настройки в этом документе содержит 2 голосовых маршрутизатора, подсоединенных к сети Frame Relay. Тем не менее, во многих топологиях маршрутизаторы с поддержкой передачи голоса могут быть установлены в любой зоне сети. Обычно голосовые маршрутизаторы используют LAN-подключение к другим маршрутизаторам, подключенным к WAN. Это важно, потому что если голосовые маршрутизаторы не подключаются напрямую через Frame Relay, все команды конфигурации WAN должны быть настроены на маршрутизаторах, подключенных к WAN, а не на голосовых маршрутизаторах, как показано в примере ниже.

Предварительные условия

Требования

Для данного документа нет особых требований.

Используемые компоненты

В данном документе приведены сведения для следующих версий программного и аппаратного обеспечения:

  • Маршрутизатор Cisco 3640 с ПО Cisco IOS® выпуск 12.2.6a (Enterprise Plus);

  • Маршрутизатор Cisco 2621 с ПО Cisco IOS выпуск 12.2.6a (Enterprise Plus);

  • Организация очереди с малым временем ожидания (LLQ) в постоянных виртуальных каналах Frame Relay (PVC). Данная функция представлена в ПО Cisco IOS версии 12.1(2)T;

  • Приоритет IP RTP протокола Frame Relay, представленного в ПО Cisco IOS выпуск 12.0(7)T;

  • Форум Frame Relay Forum (FRF). Фрагментация 12, представленная в ПО Cisco IOS выпуск 12.0(4)T;

  • Версии ПО Cisco IOS выше 12.0.5T обладают улучшенными характеристиками для сжатого RTP (cRTP).

Данные для документа были получены в специально созданных лабораторных условиях. При написании данного документа использовались только устройства с пустой (стандартной) конфигурацией. При работе с реально функционирующей сетью необходимо полностью осознавать возможные результаты использования всех команд.

Условные обозначения

Для получения дополнительной информации о принятых в документе условных обозначениях обратитесь к разделу Технические рекомендации Cisco. Условные обозначения.

Руководство по проектированию QoS для передачи голосовых вызовов по протоколу IP по технологии Frame Relay

Существует два основных требования для обеспечения хорошего качества голоса:

Для удовлетворения упомянутых требований следуйте инструкциям:

Строгая очередность для голосового трафика (приоритеты LLQ или IP RTP)

Для голосового трафика существуют 2 способа предоставления жесткого приоритета.

  • Приоритет IP RTP (также называется очередь с приоритетом/взвешенное справедливое управление очередями (PQ/WFQ))

  • LLQ (или PQ/очереди с весами на основе классов (PQ/CBWFQ))

Приоритет IP RTP

Приоритет IP RTP Frame Relay создает очередь со строгим приоритетом для постоянного виртуального соединения через Frame Relay для группы потоков пакета RTP, которая принадлежит диапазону порта назначения протокола UDP. В то время как фактические порты используют динамическое согласование между конечными устройствами и шлюзами, все продукты Cisco VoIP используют один и тот же диапазон UDP-портов (с 16384 до 32767). После распознания маршрутизатором трафика VoIP он будет помещен в строго приоритетную очередность. Когда PQ пустая, остальные очереди обрабатываются на основе стандартной программы WFQ. Механизм IP RTP Priority активизируется только при возникновении перегрузок в интерфейсе. На рисунке представлен механизм работы приоритета IP RTP:

pq-wfq.gif

Примечание. Приоритет IP RTP позволяет организовать PQ, когда в очереди по умолчанию (WFQ) есть полоса пропускания. Однако он жестко ограничивает содержание PQ, если интерфейс перегружен.

LLQ

LLQ – это метод, который обеспечивает строго приоритетную очередность (PQ) для CBWFQ. LLQ включает единую строгую PQ в рамках CBWFQ на уровне класса. При использовании LLQ отправка данных, для которых важно время задержки и которые находятся в очереди по приоритету, выполняется вне очереди. В VoIP с установленной LLQ голосовой трафик размещается в строгом соответствии с приоритетом очередности.

PQ управляется так, чтобы справедливые очереди не испытывали недостатка пропускной способности. При настройке PQ следует указать в Кбитах максимальную ширину канала, доступную PQ. Когда интерфейс перегружен, организация очередей с приоритетами PQ обслуживается до тех пор, пока нагрузка не достигает установленного значения скорости в Кбит/с в приоритете оператора. После этого лишний трафик сбрасывается, чтобы избежать проблем нехватки полосы пропускания для PQ с низкими приоритетами, характерных для традиционных очередей Cisco с приоритетами.

Примечание. C помощью LLQ для Frame Relay очереди настраиваются через PVC. Каждый постоянный виртуальный канал имеет очередь приоритетов и назначенное число обычных очередей.

llq.gif

Этот метод более комплексный и гибкий, чем метод приоритета IP протокола реального времени. Выбор метода должен основываться на видах трафика в реальной сети и актуальных потребностях.

Сравнение приоритета LLQ и IP RTP

В таблице представлены главные различия между приоритетом LLQ и IP RTP и данные о границах применимости каждого метода.

LLQ

Приоритет IP RTP

Сопоставление голосового трафика основано на следующем:

  • Списки доступа. Например, следующие поля: диапазон UDP-портов, адреса хостов, тип услуги (ToS) в заголовке IP (например, приоритет IP-пакета, кодовая точка дифференцированных сервисов (DSCP);

  • Диапазон портов IP RTP;

  • Поля IP ToS—DSCP и/или приоритет IP-пакета;

  • Протоколы и входящие интерфейсы;

  • Все действительные критерии совпадения, используемые в CBWFQ.

Достоинства:

  • Больше гибкости в процессе сопоставления потока данных и направления его на определенные PQ и CBWFQ;

  • Можно настроить дополнительные классы для гарантированной пропускной способности для другого трафика, такого как сигналы VoIP и видео.

Недостатки: сложная конфигурация.

Сопоставление голосового трафика основано на:

  • Данных относительно диапазона портов RTP/UDP: 16384-32767.

Достоинства: простая конфигурация.

Недостатки:

  • Трафик протокола RTCP (сигнализация VoIP), обслуживаемый в WFQ-очереди.

    Примечание. Протокол RTP использует RTCP для управления доставкой пакетов RTP. Порты RTP используют четные числа, порты RTCP - нечетные в диапазоне 16384-32767. Приоритет IP RTP помещает порты RTP в PQ, если порты RTCP обслуживаются в очереди WFQ по умолчанию.

  • Обслуживание трафика VoIP в PQ. Однако любой трафик, которому необходимо приоритетное обслуживание и гарантированная полоса пропускания, обслуживается в WFQ. WFQ позволяет различать потоки по весу (на основе приоритета IP-адреса), но не обеспечивает гарантированной полосы пропускания для любого потока.

Инструкции:

  • Выбор между ними следует делать на основе моделей трафика в своей реальной сети и своих фактических потребностей;

  • Если необходимо установить строгий приоритет для голосового трафика, и другой трафик можно принять за однотипный (данные), то приоритет IP RTP окажется очень полезным для сети с простой конфигурацией;

  • Если планируется назначить приоритеты голосовому трафику на основе критериев, отличных от портов UDP. Например, Поведение дифференцированных служб (DiffServ) на каждом переходе (PHB) и LLQ.

FRTS для голоса

FRTS обладает рядом параметров, полезных для управления сетью при перегруженном трафике. FRTS позволяет решить проблему узких мест в сетях Frame Relay с высокоскоростным соединением с центральным узлом и низкоскоростными соединениями с удаленными офисами. Чтобы ограничить скорость передачи данных с виртуального канала (VC) на центральный узел, можно настроить значения контроля за скоростью.

Следующие определения относятся к FRTS:

  • Согласованная скорость передачи данных (CIR) — скорость (бит в секунду), гарантируемая поставщиком услуг Frame Relay для передачи данных. Значения CIR устанавливаются поставщиком услуг Frame Relay и настраиваются пользователем на маршрутизаторе;

    Примечание. Значение скорости доступа порт/интерфейс может быть выше CIR. Значение является средним за период времени, равный фиксированному интервалу измерения скорости (Tc).

  • Согласованный пакет (Bc) — максимальное количество битов, которое сеть Frame Relay может передать за время Tc. Tc = Bc / CIR;

  • Избыточный пакет (Be) — максимальное количество несогласованных битов, которое сеть Frame Relay пытается передать за время Tc со скоростью выше CIR;

  • Фиксированный интервал измерения согласованной скорости (Tc) — интервал времени, за который передаются биты Bc или (Bc+ Be). Tc вычисляется следующим образом: Tc = Bc / CIR. Значение Tc не просто настраивается на маршрутизаторах Cisco. Оно рассчитывается после настройки значений Bc и CIR. Значение Tc не должно превышать 125 мс;

  • Пакет обратного явного уведомления о перегрузке (BECN) — бит в заголовке Frame Relay, означающий перегрузку сети. Когда коммутатор Frame Relay обнаруживает перегрузку, он задает бит BECN на кадрах, направленных на исходный маршрутизатор, предписывая ему снизить скорость передачи.

Настройка FRTS для голосового трафика отличается от настройки трафика, предназначенного только для передачи данных. При настройке FRTS на характеристики голоса приходится изменять некоторые настройки трафика данных. Для получения дополнительной информации обратитесь к разделу Фрагментация (FRF.12) этого документа.

Фрагментация (FRF.12)

Серьезной проблемой при интеграции речи и данных является контроль максимальной однонаправленной задержки связи для такого зависимого от времени трафика, как голос. Для хорошего качества голоса задержка не должна быть больше 150 мсек. Большая часть этой задержки приходится на задержку сериализации интерфейса. Cisco рекомендует значение 10 мсек; в любом случае значение не должно превышать 20 мсек. Задержка сериализации - это фактическое время, затрачиваемое на помещение битов в интерфейс.

Serialization Delay = frame size (bits) / link bandwidth (bps)

Например, 1500-байтовому пакету требуется 214 мс, чтобы покинуть маршрутизатор через канал 56 кбит/с. Если посылаются пакеты данных размером 1500 байт в нереальном времени, то пакеты реального времени (голосовые) помещаются в очередь до тех пор, пока не закончится передача большого пакета данных. Такая задержка недопустима для голосового трафика. Если пакеты данных в нереальном времени фрагментируются на более мелкие кадры, то они перемежаются кадрами реального времени (голосовыми). Таким образом, и речевые, и информационные кадры могут передаваться вместе по низкоскоростным каналам, не вызывая чрезмерной задержки для голосового трафика в реальном времени.

lfi.gif

Для получения дополнительной информации о фрагментации обратитесь к разделу Фрагментация для передачи голосовых данных в Frame Relay.

Примечание. При наличии выделенного канала с пропускной способностью, равной половине пропускной способности канала T1 (768 Кб/с), вам, возможно, не нужна функция фрагментации. Однако вам все равно необходим механизм QoS (в данном случае приоритет IP RTP или LLQ). Половина T1 или большие скорости дают достаточную пропускную способность, чтобы речевые пакеты могли входить и выходить из очереди в рекомендованном диапазоне задержки сериализации (10 мсек, не позднее чем 20 мсек). Кроме того, в случае полного соединения T1 можно обойтись без протокола сжатия в реальном времени (cRTP), который обеспечивает экономию полосы пропускания за счет сжатия заголовков IP RTP.

Сокращение полосы пропускания

cRTP

Основано на RFC 2508 leavingcisco.com, функция cRTP сжимает заголовок пакета IP/UDP/RTP с 40 байт до 2 или 4 байт. Это позволяет уменьшить использование полосы пропускания. Используемая схема сжатия - от перехода к переходу. Следовательно, cRTP должен быть настроен у обеих сторон (если не установлен пассивный параметр).

Примечание. Для обеспечения хорошего качества голосовой связи cRTP не требуется. Эта функция позволяет уменьшить использование полосы пропускания. После соблюдения всех требуемых условий и настройки хорошего качества речи настройте cRTP. Данная процедура может ускорить устранение неисправностей, изолировав потенциальные проблемы cRTP.

Проконтролируйте загрузку ЦП маршрутизатора. Отключите cRTP, если она выше 75%. При больших значениях скорости канала, выгоды от экономии пропускной способности cRTP могут быть сведены на нет из-за дополнительной нагрузки ЦП. Рекомендуется использовать cRTP только в каналах со скоростью ниже 768 Кбит/с, если только маршрутизатор не работает с низким коэффициентом загруженности ЦП.

Примечание. В отсутствие единого стандарта был разработан протокол cRTP для Frame Relay, совместимый с собственным механизмом инкапсуляции Cisco. Поэтому он не совместим с инкапсуляцией IETF (Инженерной группы по развитию Интернета) для Frame Relay. В последнее время FRF.20 был усовершенствован для возможности сжатия заголовков RTP на инкапсуляции IETF. Однако на момент последнего обновления этого документа (май 2002 года) FRF.20 не поддерживается.

Для получения дополнительной информации обратитесь к разделу Сжатый транспортный протокол реального времени.

Выбор Coder/Decoder (Codec)

Используйте низкоскоростные кодеки в ветках вызова VoIP. По умолчанию для каждой точки вызова VoIP установлен кодек G.729 (8 Kбит/сек).

Примечание. Несмотря на то что двухтоновые многочастотные (DTMF) сигналы обычно точно передаются при использовании высокоскоростных голосовых кодеков, например G.711, низкоскоростные кодеки (например G.7 29 и G.723.1) оптимизированы под голосовые шаблоны и искажают DTMF-тоны. Этот подход может вызвать проблемы доступа к системам интерактивного голосового ответа (IVR). Команда dtmf relay решает проблему искажения DTMF. Она передает тональные сигналы DTMF вне полосы или отдельно от кодированного голосового потока. При использовании низкоскоростных кодеков (G.729, G.723) включите команду dtmf relay для адресуемой конечной точки вызова VoIP.

Включите функцию опознавания активности речи (VAD)

Обычный разговор, как правило, содержит 35-50% пауз. Пакеты молчания сжимаются при использовании VAD. При планировании полосы пропускания VoIP предполагается, что VAD уменьшает потребность в полосе на 35%. Опознавание активности речи (VAD) сконфигурировано по умолчанию в VoIP для равноправного коммутируемого элемента.

Настройка

В этом разделе приводятся сведения о настройке функций, описанных в данном документе.

Примечание. Для получения дополнительной информации об упомянутых в этом документе командах используйте Средство поиска команды (только для зарегистрированных пользователей).

LLQ

Используйте эту процедуру для настройки LLQ:

  1. Создайте схему классов для трафика VoIP и определите критерии совпадения.

    Эти команды объясняют, как выполнить задание:

    maui-voip-sj(config)#class-map ?
           WORD 		class-map name
           match-all 	Logical-AND all matching statements under this classmap
           match-any 	Logical-OR all matching statements under this classmap
    maui-voip-sj(config)#class-map match-all voice-traffic 
    
    !--- Выберите описательное имя класса class_name. 
    
    
    maui-voip-sj(config-cmap)#match ?
      access-group         Access group
      any                  Any packets
      class-map            Class map
      cos                  IEEE 802.1Q/ISL class of service/user priority values
      destination-address  Destination address
      input-interface      Select an input interface to match
      ip                   IP specific values
      mpls                 Multi Protocol Label Switching specific values
      not                  Negate this match result
      protocol             Protocol
      qos-group            Qos-group
      source-address       Source address
    
    !--- В данном примере параметр соответствия группы доступа  
    !--- используется для автоматической адаптивности (он использует список доступа).
    
    
    maui-voip-sj(config-cmap)#match access-group ?
      <1-2699>  Access list index
      name      Named Access List
    maui-voip-sj(config-cmap)#match access-group 102 
    
    
    !--- Создать список доступа в соответствии с группой доступа на карте классов:
    
    
    maui-voip-sj(config)#access-list 102 permit udp any any range 16384 32767
    
    !--- Наиболее безопасный и простой способ – согласование с диапазоном портов UDP 16384-32767.
    !--- Это продукты для диапазона портов Cisco IOS H.323, которые используются для 
    !--- передачи пакетов VoIP.
    
    

    Эти списки доступа также используются для поиска соответствий голосового трафика с помощью команды match access-group:

    access-list 102 permit udp any any precedence critical
    
    !--- Данный список фильтрует трафик на основе TOS IP-пакета: поле "Precedence".  
    !--- Примечание. Убедитесь, что то же значение "precedence" не 
    !--- используется для другого трафика, отличного от голосового.
    
    
    access-list 102 permit udp any any dscp ef
    
    !--- Чтобы данный список работал, убедитесь в разметке пакетов VoIP 
    !--- с помощью кода DSCP EF перед их отправкой с интерфейса LLQ WAN. 
    !--- Дополнительную информацию по DSCP см. в разделе 
    !--- "Внедрение политик контроля качества обслуживания с DSCP".
    !--- Примечание. Если конечные точки не проходят проверку доверия по 
    !--- разметке их пакетов, то разметьте входящий трафик путем применения 
    !--- политики обслуживания входных данных на входном интерфейсе. Данная
    !--- процедура не входит в область рассмотрения данного документа. 
    
    
    access-list 102 permit udp host 192.10.1.1 host 192.20.1.1
    
    !--- Данный список доступа можно использовать в случаях, 
    !--- когда устройства VoIP не способны реализовать приоритеты, 
    !--- либо когда разметка DSCP не позволяет определить диапазон
    !--- портов UDP для VoIP.
     

    Существуют другие методы поиска соответствий, которые можно использовать вместо команд групп доступа:

    • Начиная с Cisco IOS выпуска 12.1.2.T, функция IP RTP Priority внедрена для LLQ. Эта функция сопоставляет содержимое класса приоритета, которое настроено на порты UDP. Обслуживание только четных портов в PQ ограничено.

      class-map voice
        match ip rtp 16384 16383
      
    • Предполагается, что эти два метода приемлемы, если пакеты VoIP маркированы на исходном хосте или сопоставлены и маркированы в маршрутизаторе до выполнения исходящей операции LLQ:

      class-map voice 
         match ip precedence 5
      

      ИЛИ

      class-map voice
         match ip dscp ef
      

      Примечание. Начиная с IOS версии 12.2.2T, VoIP адресуемые конечные точки вызова (dial-peer) могут помечать голосовой однонаправленный канал и сигнальные пакеты до срабатывания LLQ. Это позволяет сделать масштабируемыми маркирование и установку соответствий VoIP-пакетов с помощью значений кодов DSCP для LLQ. За более подробной информацией обратитесь к Классификации передачи сигналов и средств связи протокола VoIP с DSCP для QoS.

      Router(config-dial-peer)#ip qos dscp ?
      
  2. Создайте схему классов для VoIP-сигнализации и определите критерии сопоставления (необязательно).

    Используйте следующие команды для выполнения этого задания:

    class-map voice-signaling
      match access-group 103
    !
    access-list 103 permit tcp any eq 1720 any
    access-list 103 permit tcp any any eq 1720
    

    Примечание: Вызовы VoIP можно устанавливать с помощью H.323, протокола инициализации сеанса (SIP), протокола управления шлюзами между средами передачи (MGCP) или облегченного протокола контроля вызовов (SCCP) (это собственный протокол, используемый в Cisco Call Manager). Приведенный выше пример предполагает наличие H.323 Fast Connect. Этот список содержит справочную информацию о портах, используемых каналами сигнализации и управления VoIP:

    • H.323/H.225 = TCP 1720;

    • H.323/H.245 = TCP 11xxx (Стандартное соединение);

    • H.323/H.245 = TCP 1720 (Быстрое соединение);

    • H.323/H.225 RAS = TCP 1719;

    • SCCP = TCP 2000-2002 (CM Encore);

    • ICCP = TCP 8001-8002 (CM Encore);

    • MGCP = UDP 2427, TCP 2428 (CM Encore);

    • SIP= UDP 5060, TCP 5060 (настраиваемый).

  3. Создайте схему политик и свяжите ее со схемами классов VoIP.

    Цель схемы политик - определить, как ресурсы линии распределяются или приписываются различным классам сопоставления. Используйте следующие команды для выполнения этого задания:

    maui-voip-sj(config)#policy-map VOICE-POLICY
    
    !--- Выберите описательное имя  policy_map_name.
    
    
    maui-voip-sj(config-pmap)#class voice-traffic
    maui-voip-sj(config-pmap-c)#priority ?
     <8-2000000>  Kilo Bits per second
    
    !--- Настройте класс голосового трафика на строгое выполнение PQ
    !--- (команд приоритета) и назначьте полосу пропускания.
    
    
    maui-voip-sj(config-pmap)#class voice-signaling
    maui-voip-sj(config-pmap-c)#bandwidth 8
    
    !--- Установите для класса сигналов скорость 8 Кбит/с.
    
    
    maui-voip-sj(config-pmap)#class class-default
    maui-voip-sj(config-pmap-c)#fair-queue 
    
    !--- Оставшийся информационный трафик определяется как WFQ.
    
    

    Примечание. Несмотря на то, в PQ можно поставить в очередь различные типы трафиков в реальном времени, рекомендуется использовать эту очередь только для голосового трафика. Трафик в реальном времени, такой как видеоматериалы, может привести к вариации задержки (PQ относится к очередям FIFO). Голосовой трафик требует, чтобы задержки не были переменными, чтобы избежать "дрожания".

    Примечание. Сумма величин для положений priority (приоритет) и bandwidth (полоса пропускания) должна быть меньше или равна minCIR для PVC. Иначе команда service-policy не может быть присвоена линии. minCIR в два раза меньше CIR по умолчанию. Чтобы получить сообщения об ошибке, убедитесь в активности команды logging console для консольного доступа и команды terminal monitor для доступа через Telnet.

    Для получения дополнительной информации о командах bandwidth и priority обратитесь к разделам Сравнение команд bandwidth и priority политики службы QoS.

  4. Включите LLQ, применив схему политики к исходящему интерфейсу WAN.

    Чтобы включить LLQ, используйте следующие команды:

    maui-voip-sj(config)#map-class frame-relay VoIPovFR
    maui-voip-sj(config-if)#service-policy output VOICE-POLICY
    
    !--- Политика обслуживания применяется к 
    !--- PVC косвенно, путем ее 
    !--- настройки в карте классов, связанной с PVC.
    
    

Приоритет IP RTP

Если вы не используете LLQ, следуйте этим инструкциям:

Router(config-map-class)#frame-relay ip rtp priority starting-rtp-port  
port-range  bandwidth 
  • starting-rtp-port — начальный номер узла UDP. Самый низкий номер порта, на который отправляются пакеты. Для VoIP установите значение, равное 16384;

  • port-range — диапазон портов назначения UDP. Номер, добавляемый к starting-rtp-port, дает самый высокий номер узла UDP. Для VoIP установите значение, равное 16383;

  • bandwidth — максимальная пропускная способность для приоритетной очереди (в Кбитах). Установите этот номер на основе количества спонтанных звонков, добавляя для каждого звонка ширину полосы пропускания каждого звонка, поддерживаемую системой.

Пример конфигурации:

map-class frame-relay VoIPovFR  frame-relay cir 64000
 frame-relay BC 600
 no frame-relay adaptive-shaping
 frame-relay fair-queue
 frame-relay fragment 80
 frame-relay ip rtp priority 16384 16383 45

Формирование трафика для передачи голоса

Следуйте инструкциям для настройки управления трафиком для передачи голоса:

  • Не следует превышать CIR для PVC;

  • Отключите адаптивное управление Frame Relay;

  • Установите низкое значение Bc, так чтобы Tc (интервал формирования) был равен 10 мсек (Tc = Bc/CIR). Чтобы получить ожидаемое значение Tc, настройте значение Bc;

  • Укажите для Be значение 0.

Для получения дополнительной информации обратитесь к разделу Формирование трафика Frame Relay для VoIP и VoFR.

Примечание. Некоторые пользователи используют раздельные PVC для данных и голоса. Если, имея два PVC, вы хотите использовать PVC для пакета данных, оставаясь на уровне CIR или ниже, для голосового PVC, качество голоса будет так же неудовлетворительным, т.к. каналы PVC используют один и тот же физический интерфейс. В таких случаях поставщик услуг Frame Relay и маршрутизатора, должны обеспечить первостепенный приоритет голосового PVC. Последнее можно реализовать с помощью Очередей приоритетов на уровне интерфейса PVC (PIPQ), доступных на базе Cisco IOS выпуск 12.1(1)T.

Фрагментация (FRF.12)

Для низкоскоростных каналов (менее 768 кбит/с) включите фрагментацию. Установите размер фрагмента таким образом, чтобы голосовые пакеты не подлежали фрагментации; задержка сериализации при этом не должна превышать 20 мсек. Установите размер фрагмента на основе самой низкой скорости портов всех маршрутизаторов. Например, если в топологии звездообразной сети Frame Relay концентратор работает на скорости Т1, а удаленные маршрутизаторы имеют порты 64 Кб, то размер фрагмента на обоих маршрутизаторах должен устанавливаться как для 64 Кб портов. Другие PVC, имеющие тот же самый физический интерфейс, необходимо настроить на размер фрагмента, установленный для голосового PVC. Используйте приведенную таблицу для определения размера фрагмента.

Наименьшая скорость связи на пути

Рекомендуемый размер фрагмента (для сериализации 10 мсек)

56 Kбит/сек

70 байт

64 Kбит/сек

80 байт

128 Kбит/сек

160 байт

256 Kбит/сек

320 байт

512 Kбит/сек

640 байт

768 Kбит/сек

1000 байт

1536 Kбит/сек

1600 байт

Пример конфигурации:

map-class frame-relay VoIPovFR 

!--- Некоторые выходные данные опущены.

 frame-relay fragment 80

Примечание. Для 1536 Kбит/сек фрагментация вообще не требуется. Однако фрагментация необходима при включении системы двойной очереди FIFO для получения высокого качества голоса. Размер фрагмента 1600 байт позволяет организовать двойную FIFO. Однако, т.к. значение 1600 байт выше стандартного максимального размера передаваемого блока данных (MTU), большие пакеты данных не подлежат фрагментации.

Схема сети

В данном документе используется сеть, изображенная на следующем рисунке:

VoIP_FR.gif

Настройки

В данном документе используется следующая настройка:

  • maui-voip-sj (Cisco 3640);

  • maui-voip-austin (Cisco 3640).

maui-voip-sj (Cisco 3640)

версия 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname maui-voip-sj
!
logging buffered 10000 debugging
enable secret 5 $1$MYS3$TZ6bwrhWB25b2cVpEVgBo1
!
ip subnet-zero
!

!--- Определение голосового сигнала и схемы классов трафика.
!--- класс "voice-traffic" использует список доступа 102 в качестве критерия сопоставления.
!--- класс "voice-signaling" использует список доступа 103 в качестве критерия сопоставления.

class-map match-all voice-signaling
 match access-group 103
class-map match-all voice-traffic
  match access-group 102
!

!--- Список политик показывает, как распределены ресурсы линии
!--- между различными схемами классов. В данной конфигурации жесткая PQ
!--- приписана классу голосового трафика 
!--- с максимальной полосой пропускания 45 Kбит/сек.
 

policy-map VOICE-POLICY
  class voice-traffic
  priority 45
  class voice-signaling
  bandwidth 8


!--- Приписывает очередь для голосового сигнала 8 Kбит/сек.
!--- Обратите внимание, что это является необязательным и не влияет на качество голоса.
!--- Напротив, это способ сохранения сигнальной информации.


  class class-default
  fair-queue


!--- Класс по умолчанию используется для классификации трафика, который
!--- не подходит ни к одному из определенных классов.
!--- Команда fair-queue связывает очередь WFQ класса по умолчанию.

!
interface Ethernet0/0
  ip address 172.22.113.3 255.255.255.0
  half-duplex
!
interface Serial0/0
 bandwidth 128
 no ip address
 encapsulation frame-relay
 no fair-queue
frame-relay traffic-shaping
 frame-relay ip rtp header-compression

!--- Включает процесс формирования трафика и cRTP. Если формирование трафика не
!--- включено, то схема классов не активируется, и FRF.12 и LLQ не
!--- работает.

!
interface Serial0/0.1 point-to-point
 bandwidth 128
 ip address 192.168.10.2 255.255.255.252
 frame-relay interface-dlci 300
  class VOIPovFR

!--- Эта команда связывает подинтерфейс со схемой классов VoIPovFR.
!--- Команда map-class frame-relay VoIPovFR:
!--- Примечание: Слово "VoIPovFR" выбирается пользователем.
!

ip classless
ip route 172.22.112.0 255.255.255.0 192.168.10.1
!
map-class frame-relay VOIPovFR
 no frame-relay adaptive-shaping

!--- Отключите Frame Relay BECNS. Обратите внимание, что Be=0 по умолчанию.

frame-relay cir 64000
 frame-relay bc 640

!--- Tc = BC/CIR. В этом случае Tc принимает минимальное 
!--- настраиваемое значение 10 мсек.

frame-relay be 0
 frame-relay mincir 64000

!--- Несмотря на то что адаптивное формирование отключено, задайте CIR минимальное значение (minCIR)
!--- для надежности. По умолчанию minCIR = 1/2 CIR.

service-policy output VOICE-POLICY

!--- Включает LLQ на PVC.

frame-relay fragment 80

!--- Включает фрагментацию FRF.12 и устанавливает размер фрагмента, равный 80 байт.
!--- Это значение основано на значении скорости порта самого медленного канала на пути.
!--- Эта команда также включает dual-FIFO.

!
access-list 102 permit udp any any range 16384  32767
access-list 103 permit tcp any eq 1720 any
access-list 103 permit tcp any any eq 1720
!

!--- список доступа 102 сопоставляет трафик VoIP 
!--- исходя из диапазона порта UDP.
!--- В PQ помещаются как четные, так и нечетные порты.
!--- список доступа 103 сопоставляет сигнальный протокол VoIP. В данном
!--- случае, H.323 V2 используется с функцией быстрого старта.

!
voice-port 1/0/0
!
dial-peer voice 1 pots
 destination-pattern 5000
 port 1/0/0
!
dial-peer voice 2 voip
 destination-pattern 6000
 session target ipv4:192.168.10.1
 dtmf-relay cisco-rtp
 ip precedence 5

maui-voip-austin (Cisco 3640)

version 12.2
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname maui-voip-austin
!
boot system flash slot1:c3640-is-mz.122-6a.bin
logging buffered 1000000 debugging
!
ip subnet-zero
!
class-map match-all voice-signaling
match access-group 103
class-map match-all voice-traffic
  match access-group 102
!
policy-map voice-policy
  class voice-signaling
   bandwidth 8
  class voice-traffic
    priority 45
  class class-default
   fair-queue
!
interface Ethernet0/0
 ip address 172.22.113.3 255.255.255.0
 no keepalive
 half-duplex
!
interface Serial0/0
 bandwidth 64
 no ip address
 encapsulation frame-relay
 no ip mroute-cache 
 no fair-queue
 frame-relay traffic-shaping
 frame-relay ip rtp header-compression
!
interface Serial0/0.1 point-to-point
 bandwidth 64
 ip address 192.168.10.1 255.255.255.252
 frame-relay interface-dlci 400
  class VOIPovFR
!
ip classless
ip route 172.22.113.0 255.255.255.0 192.168.10.2
!
map-class frame-relay VOIPovFR
no frame-relay adaptive-shaping
 frame-relay cir 64000
 frame-relay bc 640
 frame-relay be 0
 frame-relay mincir 64000
 service-policy output voice-policy
 frame-relay fragment 80
access-list 102 permit udp any any range 16384 32767
access-list 103 permit tcp any eq 1720 any
access-list 103 permit tcp any any eq 1720
!
voice-port 1/0/0
!
dial-peer voice 1 pots
 destination-pattern 6000
 port 1/0/0
!
dial-peer voice 2 voip
 destination-pattern 5000
 session target ipv4:192.168.10.2
 dtmf-relay cisco-rtp
 ip приоритет 5

Проверка и устранение неисправностей

В этом разделе дается информация для проверки правильности функционирования вашей конфигурации.

Некоторые show команды поддерживаются утилитой Output Interpreter (только для зарегистрированных пользователей). Это позволяет увидеть анализ выходных данных команды show.

Приоритетные команды LLQ / IP RTP

Команды show и debug помогают проверить настройку приоритетов LLQ и IP RTP.

  • show policy-map interface serial interface# — эта команда полезна при просмотре операции LLQ и для обнаружения сброшенных пакетов в PQ. Для получения дополнительной информации о границах применимости этой команды обратитесь к разделу Объяснение счетчиков пакетов в выходных данных show policy-map interface.

  • show policy-map policy_map_name — отображает информацию о настройке схемы политик.

  • show queue interface-type interface-number — выводит настройку справедливой очередизации и статистику для определенного интерфейса.

  • debug priority — отображает события PQ и показывает, происходит ли сбрасывание в этой очереди. Для получения дополнительной информации обратитесь к разделу Поиск и устранение причин потери данных на выходе при использовании очереди с приоритетом.

  • show class-map class_name — отображает сведения о конфигурации схемы классов.

  • show call active voice — проверяет наличие потерянных пакетов на уровне DSP.

  • show frame-relay ip rtp header-compression — отображает статистику сжатия заголовка RTP.

Команды фрагментации

Используйте команды debug и show для проверки и устранения неполадок в настройках функции фрагментации.

  • show frame-relay fragment — отображает информацию о фрагментации Frame Relay на маршрутизаторе Cisco.

  • debug frame-relay fragment — отображает сообщения о событиях и ошибках, связанных с фрагментацией Frame Relay. Функционирует только на уровне PVC выбранного интерфейса.

Команды Frame Relay / Interface

Используйте команды show для проверки и устранения неисправностей в настройках Frame Relay/Interface.

  • show traffic-shape queue interface — отображает информацию об элементах в очереди на уровне DLCI VC. Используется для проверки механизма работы приоритета IP RTP через Frame Relay. При перегрузке линии связи речевые потоки идентифицируются с весом 0. Это означает, что речевой поток использует PQ. См. пример выходных данных.

  • show traffic-shape — отображает такую информацию, как заданные значения Tc, Bc, Be и CIR. См. пример выходных данных.

  • show frame-relay pvc dlci-# — отображает сведения о параметрах формирования трафика, значениях фрагментации и сброшенных пакетах. См. пример выходных данных. Также см. раздел "Устранение неисправностей Frame Relay".

Известные проблемы

Ошибка была определена при помощи LLQ для каждого VC, где PQ была строго ограничена, даже когда на интерфейсе не происходило перегрузок. Ошибка была устранена, и несоответствующие голосовые пакеты сбрасываются только в случае перегрузки VC. LLQ на основе VC при этом становятся похожими на другие интерфейсы, использующие LLQ. Изменения были внесены для ПО Cisco IOS выпуска 12.2(3) и выше.

Пример выходных данных команд show и debug

Это пример выходных данных команд show и debug, используемых для проверки и устранения неполадок.


!--- Для отображения компонентов этих выходных данных полоса
!--- пропускания LLQ PQ уменьшена, а на канале установлено принудительное
!--- отбрасывание пакетов масштабного информационного трафика. 
      
!--- Полоса пропускания приоритетной очереди уменьшена до 10 Кбит/с для
!--- принудительных отбрасываний от PQ.
!--- Примечание. Для сброса счетчиков используйте команду clear counters. 


maui-voip-sj#show policy-map inter ser 0/0.1
  Serial0/0.1: DLCI 300 -

  Service-policy output: VOICE-POLICY

Class-map: voice-traffic (match-all)
         26831 packets, 1737712 bytes
         5 minute offered rate 3000 bps, drop rate 2000 bps
         Match: access-group 102
         Weighted Fair Queueing
         Strict Priority
         Output Queue: Conversation 24
         Bandwidth 10 (kbps) Burst 250 (Bytes)
         (pkts matched/bytes matched) 26311/1704020
         (total drops/bytes drops) 439/28964

   Class-map: voice-signaling (match-all)
         80 packets, 6239 bytes
         5 minute offered rate 0 bps, drop rate 0 bps
         Match: access-group 103
         Weighted Fair Queueing
         Output Queue: Conversation 25
         Bandwidth 8 (kbps) Max Threshold 64 (packets)
         (pkts matched/bytes matched) 62/4897
         (depth/total drops/no-buffer drops) 0/0/0
    
   Class-map: class-default (match-any)
         14633 packets, 6174492 bytes
         5 minute offered rate 10000 bps, drop rate 0 bps
         Match: any
         Weighted Fair Queueing
         Flow Based Fair Queueing
         Maximum Number of Hashed Queues 16
         (total queued/total drops/no-buffer drops) 0/0/0

      

!--- Эти команды используются для проверки конфигурации LLQ.
 
      
maui-voip-austin#show policy-map voice-policy
  Policy Map voice-policy
   Class voice-signaling
        Weighted Fair Queueing
           Bandwidth 8 (kbps) Max Threshold 64 (packets)
   Class voice-traffic
        Weighted Fair Queueing
         Strict Priority
             Bandwidth 45 (kbps) Burst 1125 (Bytes)
   Class class-default
        Weighted Fair Queueing
           Flow based Fair Queueing Max Threshold 64 (packets)

maui-voip-austin#show class-map
 Class Map match-all voice-signaling (id 2)
         Match access-group  103
 Class Map match-any class-default (id 0)
         Match any
 Class Map match-all voice-traffic (id 3)
         Match access-group 102


!--- Выходные данные команды для проверки Frame Relay.


maui-voip-sj#show frame-relay fragment
interface         dlci  frag-type    frag-size  in-frag    out-frag   dropped-frag
Serial0/0.1       300   end-to-end      80         4          4          0

maui-voip-sj#show frame-relay pvc 300

PVC Statistics for interface Serial0/0 (Frame Relay DTE)

DLCI = 300, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.1

 input pkts 7 output pkts 7 in bytes 926
         out bytes 918 dropped pkts 0 in FECN pkts 0
         in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
         in DE pkts 0 out DE pkts 0
         out bcast pkts 2 out bcast bytes 598
         pvc create time 1w2d, last time pvc status changed 1w2d
      service policy VOICE-POLICY

 Service-policy output: VOICE-POLICY

 Class-map: voice-traffic (match-all)
         0 packets, 0 bytes
         5 minute offered rate 0 bps, drop rate 0 bps
      Match: access-group 102
         Weighted Fair Queueing
      Strict Priority
         Output Queue: Conversation 24
         Bandwidth 45 (kbps) Burst 250 (Bytes)
         (pkts matched/bytes matched) 0/0
         (total drops/bytes drops) 0/0

 Class-map: voice-signaling (match-all)
         0 packets, 0 bytes
         5 minute offered rate 0 bps, drop rate 0 bps
         Match: access-group 103
         Weighted Fair Queueing
         Output Queue: Conversation 25
         Bandwidth 8 (kbps) Max Threshold 64 (packets)
         (pkts matched/bytes matched) 0/0
         (depth/total drops/no-buffer drops) 0/0/0

 Class-map: class-default (match-any)
         7 packets, 918 bytes
         5 minute offered rate 0 bps, drop rate 0 bps
         Match: any
         Weighted Fair Queueing
         Flow Based Fair Queueing
         Maximum Number of Hashed Queues 16
         (total queued/total drops/no-buffer drops) 0/0/0


 Output queue size 0/max total 600/drops 0
 fragment type end-to-end fragment size 80
 cir 64000 bc 640 be 0 limit 80 interval 10
 mincir 64000 byte increment 80 BECN response no
 frags 13 bytes 962 frags delayed 8 bytes delayed 642
 
 shaping inactive
 traffic shaping drops 0


!--- В этих выходных данных для проверки Frame Relay 
!--- уменьшена полоса пропускания PQ и установлено принудительное 
!--- отбрасывание масштабного трафика на интерфейсе.


maui-voip-sj#show frame-relay pvc 300

PVC Statistics for interface Serial0/0 (Frame Relay DTE)

DLCI = 300, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/0.1

 input pkts 483 output pkts 445 in bytes 122731
         out bytes 136833 dropped pkts 0 in FECN pkts 0
         in BECN pkts 0 out FECN pkts 0 out BECN pkts 0
         in DE pkts 0 out DE pkts 0
         out bcast pkts 4 out bcast bytes 1196
         pvc create time 1w2d, last time pvc status changed 1w2d
         service policy VOICE-POLICY

 Service-policy output: VOICE-POLICY

 Class-map: voice-traffic (match-all)
         352 packets, 22900 bytes
         5 minute offered rate 2000 bps, drop rate 2000 bps
         Match: access-group 102
         Weighted Fair Queueing
         Strict Priority
         Output Queue: Conversation 24
         Bandwidth 10 (kbps) Burst 250 (Bytes)
         (pkts matched/bytes matched) 352/22900
         (total drops/bytes drops) 169/11188

 Class-map: voice-signaling (match-all)
         7 packets, 789 bytes
         5 minute offered rate 0 bps, drop rate 0 bps
         Match: access-group 103
         Weighted Fair Queueing
         Output Queue: Conversation 25
         Bandwidth 8 (kbps) Max Threshold 64 (packets)
         (pkts matched/bytes matched) 7/789
         (depth/total drops/no-buffer drops) 0/0/0

 Class-map: class-default (match-any)
         79 packets, 102996 bytes
         5 minute offered rate 4000 bps, drop rate 0 bps
         Match: any
         Weighted Fair Queueing
         Flow Based Fair Queueing
         Maximum Number of Hashed Queues 16
         (total queued/total drops/no-buffer drops) 5/0/0
         Output queue size 5/max total 600/drops 169
         fragment type end-to-end fragment size 80
         cir 64000 bc 640 be 0 limit 80 interval 10
         mincir 64000 byte increment 80 BECN response no
         frags 2158 bytes 178145 frags delayed 1968 bytes delayed 166021

 shaping active
         traffic shaping drops 169


!--- Обратите внимание, что интервалы Tc равны 10 мс, 
!--- CIR равны 64000 бит/с, а BC равны 640. 

     
maui-voip-sj#show traffic-shape
Interface  Se0/0.1
       Access Target    Byte   Sustain   Excess    Interval  Increment Adapt
VC     List   Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active
300           64000     80     640       0          10        80         -



!--- Эти выходные данные получены в изолированной лабораторной среде,
!--- в которой маршрутизаторы настроены на приоритет IP RTP, а не на LLQ.
 

maui-voip-austin#show frame-relay PVC 100

PVC Statistics for interface Serial0/1 (Frame Relay DTE)

DLCI = 100, DLCI USAGE = LOCAL, PVC STATUS = ACTIVE, INTERFACE = Serial0/1.1

  input pkts 336           output pkts 474          in bytes 61713
  out bytes 78960          dropped pkts 0           in FECN pkts 0
  in BECN pkts 0           out FECN pkts 0          out BECN pkts 0
  in DE pkts 0             out DE pkts 0
  out bcast pkts 0         out bcast bytes 0         
  PVC create time 1w0d, last time PVC status changed 1w0d
 Current fair queue configuration:   
   Discard      Dynamic       Reserved
   threshold    queue count   queue count
   64            16              2
 Output queue size 0/max total 600/drops 0 
  fragment type end-to-end        fragment size 80
  cir 64000     BC   640      be 0     limit 125    interval 10
  mincir 32000    byte increment 125   BECN response no
  frags 1091      bytes 82880     frags delayed 671      bytes delayed 56000
  shaping inactive
  traffic shaping drops 0
  ip rtp priority parameters 16384 32767 45000


!--- Эта команда отображает сведения о соединениях dial-peers для VoIP.
 
      
maui-voip-austin#show dial-peer voice 2
VoiceOverIpPeer2
        information type = voice,
        tag = 2, destination-pattern = `5000',
        answer-address = `', preference=0,
        group = 2, Admin state is up, Operation state is up,
        incoming called-number = `', connections/maximum = 0/unlimited,
        application associated: 
     type = voip, session-target = `ipv4:192.168.10.2',  
        technology prefix:
     ip precedence = 5, UDP checksum = disabled,
         session-protocol = cisco, req-qos = best-effort, 
         acc-qos = best-effort, 
     dtmf-relay = cisco-rtp, 
        fax-rate = voice,   payload size =  20 bytes
     codec = g729r8,    payload size =  20 bytes,
        Expect factor = 10, Icpif = 30,signaling-type = cas,
     VAD = enabled, Poor QOV Trap = disabled, 
        Connect Time = 165830, Charged Units = 0,
        Successful Calls = 30, Failed Calls = 0,
        Accepted Calls = 30, Refused Calls = 0,
        Last Disconnect Cause is "10",
        Last Disconnect Text is "normal call clearing.",
        Last Setup Time = 69134010.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 12156