Технологии коммутируемого доступа в сеть : Асинхронные подключения

Конфигурирование терминала/общего сервера

23 марта 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (28 июля 2013) | Английский (29 января 2008) | Отзыв

Содержание

Введение
Предварительные условия
      Требования
      Используемые компоненты
      Условные обозначения
Кабельные соединения
Стратегия проектирования
Настройка
      Схема сети
      Настройки
      Краткие сведения о команде
      Коммутация между активными сеансами
      Завершение активных сеансов
Проверка
Устранение неполадок
      Процедура устранения неполадок
Связанные обсуждения сообщества поддержки Cisco
Дополнительные сведения

Введение

Обычно терминал или общий сервер предоставляют внеполосный доступ для нескольких устройств. Терминальный сервер - это маршрутизатор с большим количеством низкоскоростных асинхронных портов, которые подключены к другим устройствам последовательного интерфейса, например, модемам или консольным портам на маршрутизаторах или коммутаторах.

Терминальный сервер позволяет пользоваться единой точкой для доступа к консольным портам многих устройств. Использование сервера терминалов снимает необходимость в настройке резервных сценариев, например, модемов на вспомогательных портах для каждого устройства. Один модем можно подключить к вспомогательному порту терминального сервера; этот модем обеспечит возможность соединения с другими устройствами при сбое в работе сети.

В данном документе показан способ настройки терминального сервера для доступа только к консольным портам других маршрутизаторов с помощью функции Reverse Telnet. Функция Reverse Telnet позволяет осуществлять сеанс Telnet с устройства, на котором выполняется Telnet, но на другом интерфейсе. Дополнительные сведения по функции Reverse Telnet см. в разделе Установка сеанса Reverse Telnet для модема.

Предварительные условия

Требования

Для данного документа нет особых требований.

Используемые компоненты

Данный документ не ограничен отдельными версиями программного и аппаратного обеспечения.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в разделе Условные обозначения для практических рекомендаций компании Cisco.

Данные для документа были получены в специально созданных лабораторных условиях. При написании данного документа использовались только данные, полученные от устройств с конфигурацией по умолчанию. В рабочей сети необходимо понимать последствия выполнения всех команд.

Кабельные соединения

В маршрутизаторах Cisco серий 2509 – 2512 используется 68-контактный разъем и кабель с врезкой. Данный кабель (CAB-OCTAL-ASYNC) предоставляет восемь асинхронных портов скрученного кабеля RJ-45 на каждом 68-контактном разъеме. Можно подключить каждый асинхронный порт с перекрученным кабелем RJ-45 к порту консоли устройства. Маршрутизатор 2511 поддерживает удаленный доступ не более чем к 16 устройствам. Кроме того, для маршрутизаторов Cisco серии 2600 и 3600 доступны асинхронные сетевые модули с высокой плотностью NM-16A или NM-32A, которые поддерживают ту же функцию. Дополнительная информация о кабельных соединениях представлена в документах Руководство по подключению последовательного кабеля и Руководство по прокладке кабелей для консольных и вспомогательных портов.

Примечание: Асинхронные порты с 68-контактным разъемом являются устройствами терминального оборудования (DTE). Для устройств DTE-DTE небходим перекрученный кабель (нуль-модемный), а для устройств DTE - оборудование DCE необходимо прямое кабельное соединение. CAB-OCTAL-ASYNC - перекрученный кабель. Следовательно, каждый кабель можно подключать непосредственно к портам консоли устройств с интерфейсами RJ-45. Однако, если порт консоли устройства, к которому производится подключение, является 25-контактным интерфейсом (DCE), используйте кабель RJ-45 к 25-контактному адаптеру, помеченному "Modem" (чтобы отменить "перекрутку"), для завершения подключения.

В таблице далее показаны типы портов для консоли и вспомогательных портов на маршрутизаторах и коммутаторах Cisco:

Тип интерфейса

Интерфейс DB25

Интерфейс RJ-45

Консоль

DCE

DTE

AUX

DTE

DTE

Стратегия проектирования

Настройте терминальный сервер таким образом, чтобы доступ к нему можно было получить из любого места. Чтобы сделать терминальный сервер доступным, назначьте ему зарегистрированный общедоступный Интернет-адрес и расположите его за брандмауэром. После этого проблемы с брандмауэром не будут оказывать влияние на подключение. Это гарантирует возможность постоянно поддерживать подключение к терминальному серверу и получать доступ к подсоединенным устройствам. Чтобы решить проблемы с безопасностью, настройте списки доступа таким образом, чтобы разрешить доступ к терминальному сервере только для избранных адресов. Чтобы гарантировать большую безопасность, настройте на сервере функции аутентификации, авторизации и учета (ААА); например, RADIUS или TACACS+. Дополнительные сведения об AAA см. в разделе Учебный пример ввода в действие Cisco AAA.

Можно настроить модем на вспомогательный порт терминального сервера для резервного коммутируемого канала по телефонной линии, в случае, если основное подключение (через Интернет) перестанет работать. Это устраняет необходимость в настройке резервирования вызова для каждого устройства. Терминальный сервер подключен через асинхронные порты к консольным портам других устройств. Дополнительная информация о подключении модема к вспомогательному порту представлена в документе Руководство по установке соединения между модемом и маршрутизатором.

Используйте утверждение ip default gateway и укажите маршрутизатор следующего узла в Интернете. Эта команда позволяет подключаться к терминальному серверу через Интернет даже при отключенной маршрутизации. Например, терминальный сервер работает в режиме мониторинга ROM (ROMMON), причиной чему явился неверный перезапуск после отключения электроэнергии.

Настройка

В этом разделе приводятся сведения о настройке функций, описанных в данном документе.

Примечание.  Для поиска дополнительной информации о командах из данного документа используйте средство Command Lookup Tool (только для зарегистрированных пользователей).

Схема сети

В данном документе используется следующая схема сети:

Com_Srv.gif

Конфигурации

В данном документе используются следующие конфигурации.

  • Cisco 2511

Cisco 2511

aus-comm-server#show running-config
!
Версия 12.0

service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
!
hostname aus-comm-server
!
enable secret  <deleted>
!
username cisco password <deleted>
!
ip subnet-zero
ip domain-list cisco.com
no ip domain-lookup

ip host 3600-3 2014 172.21.1.1

!--- Хост 3600-3 подключен к порту 14 общего сервера.
!--- Убедитесь, что используется IP-адрес интерфейса общего сервера.

ip host 3600-2 2013 172.21.1.1
ip host 5200-1 2010 172.21.1.1
ip host 2600-1 2008 172.21.1.1
ip host 2509-1 2007 172.21.1.1
ip host 4500-1 2015 172.21.1.1
ip host 3600-1 2012 172.21.1.1
ip host 2511-2 2002 172.21.1.1
ip host 2511-rj 2003 172.21.1.1
ip host 2511-1 2001 172.21.1.1
ip host 5200-2 2011 172.21.1.1
ip host 2520-1 2004 172.21.1.1
ip host 2520-2 2005 172.21.1.1
ip host 2600-2 2009 172.21.1.1
ip host 2513-1 2006 172.21.1.1
ip host pix-1 2016 172.21.1.1
!
!
process-max-time 200
!
interface Loopback1
 ip address 172.21.1.1 255.0.0.0

!--- Этот адрес используется в командах IP-хоста.
!--- Работа с интерфейсами обратной связи, которые являются виртуальными и всегда доступны.

 no ip directed-broadcast
!
interface Ethernet0
 ip address 171.55.31.5 255.255.255.192

!---  Используйте публичный IP-адрес для обеспечения подключения. 

No ip directed-broadcast
 no ip mroute-cache
!
interface Serial0
 no ip address
 no ip directed-broadcast
 no ip mroute-cache
 shutdown
!
ip default-gateway 171.55.31.1

!--- Это шлюз по умолчанию при отключенной маршрутизации.
!--- К примеру, если маршрутизатор находится в режиме загрузочного ROM.

ip classless
ip route 0.0.0.0 0.0.0.0 171.55.31.1

!--- Установите маршрут по умолчанию для внешней сети.

no ip http server
!
line con 0
 transport input all
 line 1 16
 session-timeout 20

!--- Время ожидания сеанса истекает через 20 минут неактивности. 

no exec

!--- Нежелательные сигналы из прикрепленного устройства не запускаются. 
!--- Сеанс EXEC гарантирует, что линия никогда не будет недоступной
!--- в связи с посторонним процессом EXEC.

 exec-timeout 0 0

!--- Это отключает команду "exec timeout transport input all".
!--- Разрешить всем протоколам использовать линию.
!--- Настройка линий 1 - 16 с помощью команды "transport input Telnet".

line aux 0

!--- Вспомогательный порт может предоставить резервное соединение с сетью по телефонной линии.
!--- Примечание. В эту конфигурацию не входит модем, установленный на модем вспомогательного порта InOut. 
!--- Позволяет вспомогательному порту поддерживать соединения по телефонной линии и внешнее телефонное соединение.

 transport preferred telnet
 transport input all
 speed 38400
 flowcontrol hardware
line vty 0 4
 exec-timeout 60 0
 password <deleted> 
login
!
end

Краткие сведения о командах

ip host —используйте команду, чтобы определить сопоставление имени и адреса статического хоста в кэше хоста. Чтобы удалить сопоставление имени и адреса, используйте форму с no данной команды.

  • ip host name [tcp-port-number] address1 [address2...address8]

    • name—это поле определяет имя хоста. Поле имени не соответствует действительному имени маршрутизатора, к которому происходит подключение. Однако убедитесь, что указано имя, которое будет использоваться в сеансе Reverse Telnet. При использовании этой команды в поля имени не обязательно знать действительный адрес порта удаленного устройства.

    • tcp-port-number—это поле указывает номер порта TCP, к которому просходит подключение при использовании определенного имени хоста вместе с командой EXEC connect или telnet. В данном примере конфигурации мы используем сеанс Reverse Telnet с тем, чтобы номер порта выглядел, как 2000+линия.

    • address1—это поле представляет связанный IP-адрес. В данном примере используется IP-адрес обратной связи.

transport input—используйте данную команду, чтобы определить протоколы, которые используются при подключении к определенной линии маршрутизатора.

  • transport input {all | lat | mop | nasi | none | pad | rlogin | telnet | v120}

    • all—все выбирают все протоколы.

    • none—ни одно устройство не запрещает использование каких-либо протоколов на данной линии. В этом случае порт нельзя использовать для входящих соединений.

    Примечание:  В данном примере асинхронные каналы используют минимальную конфигурацию команды transport input telnet. То есть, можно получить доступ к устройствам по асинхронному каналу с помощью протокола Telnet.

telnet—Используйте команду EXEC для регистрации в хосте, поддерживающем сеанс Telnet.

  • telnet host [port] [keyword]

    • host в этом поле указывается имя хоста или его IP-адрес. Хост может являться одним из полей имени, заданных командой ip host.

    • port—в этом поле определяется десятичный номер порта TCP. Порт маршрутизатора Telnet (десятичное число 23) для хоста является десятичным номером порта TCP по умолчанию. Для обратного сеанса Telnet номером порта является 2000+линия. В данной конфигурации используются номера линий от 1 до 16. Чтобы узнать о доступных каналах связи, используйте команду show line.

Коммутация между активными сеансами

Чтобы осуществить коммутацию между активными сеансами, выполните следующие шаги:

  1. Чтобы выйти из текущего сеанса, используйте последовательность Ctrl-Shift-6-x.

  2. Чтобы отобразить все открытые соединения, используйте команду show sessions.

    aus-comm-server#show sessions 
    Conn Host      Address         Byte Idle  Conn Name
       1 2511-1    171.69.163.26   0     0     2511-1
       2 2511-2    171.69.163.26   0     0     2511-2
     * 3 2511-3    171.69.163.26   0     0     2511-3

    Примечание: Символ "звездочка" (*) указывает на текущий сеанс терминала.

  3. Чтобы подключиться к соответствующему устройству, укажите номер сеанса (conn). К примеру, чтобы подключиться к 2511-1, наберите цифру 1, которая является номером подключения. Однако при нажатии клавиши ввода происходит подключение к текущему сеансу терминала, который в данном случае является маршрутизатором 2511-3.

Завершение активных сеансов

Чтобы прервать сеанс Telnet, выполните следующие действия:

  1. Чтобы выйти из текущего сеанса Telnet, используйте последовательность Ctrl-Shift-6-x.

    Примечание: Убедитесь, что можно безопасно ввести последовательность выхода, чтобы прекратить сеанс Telnet. Для некоторых пакетов эмуляции терминала возникают трудности при отправке правильной последовательности Ctrl-Shift-6, x.

  2. Чтобы отобразить все открытые соединения, используйте команду show sessions.

  3. Чтобы выйти из определенного сеанса, выполните команду disconnect [connection].

Проверка

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются средством Output Interpreter Tool (интерпретатор выходных данных) (только для зарегистрированных пользователей), что позволяет просматривать результаты выполнения команды show.

  • show ip interface brief —показывает, работает ли интерфейс, используемый для сеанса Telnet.

Устранение неполадок

Этот раздел содержит сведения об устранении неполадок конфигурации.

Процедура устранения неполадок

Для устранения неполадок конфигурации выполните следующие действия.

Если невозможно подключиться к выбранному маршрутизатору с помощью имени, настроенного в команде ip host, проверьте следующее:

  1. Проверьте, правильно ли настроен адрес порта.

  2. Проверьте, работает ли адрес (интерфейс), используемый для обратного сеанса Telnet. Эта информация содержится в выходных данных команды show ip interface brief. Компания Cisco рекомендует использовать возвратные петли, поскольку они всегда активны.

  3. Убедитесь, что используется правильный тип кабеля. К примеру, нельзя использовать разделительный кабель, чтобы увеличить длину. Дополнительные сведения см. в разделе Кабельные соединения.

  4. Установите подключение Telnet к порту IP-адреса, чтобы проверить прямое соединение. Необходимо использовать протокол telnet как от внешнего устройства, так и от сервера терминала. К примеру, telnet 172.21.1.1 2003.

  5. Убедитесь, что команда transport input telnet используется для канала целевого устройства. Целевое устройство - это устройство, подключенное к серверу терминала.

  6. Для прямого подключения к консоли целевого маршрутизатора используйте терминал PC/dumb. Целевой маршрутизатор - это устройство, подключенное к серверу терминала. На этом этапе можно выявить наличие проблемы с портом.

  7. Если произошло отключение, проверьте время ожидания. Этот параметр можно удалить или настроить.

    Примечание: Если были обнаружены ошибки аутентификации, помните, что сервер терминала выполняет первичную аутентификацию (при наличии соответствующих настроек), а устройство, к которому производится подключение, выполняет вторичную аутентификацию (при наличии соответствующих настроек). Проверьте, правильно ли настроены функции AAA на сервере терминала и подключаемом устройстве.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 5466