Протокол IP : Сервисы IP-адресации

Динамическая настройка параметров сервера DHCP

23 марта 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (28 июля 2013) | Английский (12 октября 2005) | Отзыв

Содержание

Общие сведения
Предварительные условия
      Требования
      Используемые компоненты
      Условные обозначения
Настройка
      Схема сети
      Настройка
Проверка
Поиск и устранение неисправностей
      Команды поиска и устранения неисправностей
Связанные обсуждения сообщества поддержки Cisco
Дополнительные сведения

Общие сведения

DHCP-протокол позволяет автоматически назначать DHCP-клиентам многократно используемые IP-адреса. В данном документе представлен пример настройки DHCP-параметров, например, таких как адреса службы доменных имен (DNS-адрес) и службы имен Интернета для Windows (WINS-адрес), что позволяет отвечать на DHCP-запросы от локальных клиентов, расположенных за абонентским оконечным оборудованием (CPE).

Ранее сетевые администраторы должны были вручную настраивать параметры DHCP-сервера в Cisco IOS® на каждом устройстве. Обход всех устройств после развертывания очередного маршрутизатора и внесение изменений вручную является долгим, обременительным и дорогим занятием.

Поэтому DHCP-сервер Cisco IOS был улучшен и теперь можно проводить автоматическое обновление сведений о конфигурации. Сетевые администраторы могут настроить один или несколько централизованных DHCP-серверов для обновления определенных DHCP-параметров в рамках пулов DHCP. Удаленные серверы могут запрашивать или импортировать параметры с централизованных серверов.

Предварительные условия

Требования

Компания Cisco рекомендует предварительно ознакомиться со следующими понятиями:

  • DHCP;

  • Служба доменных имён (DNS);

  • Служба имeн  Интернета для Windows (WINS).

Используемые компоненты

При разработке и тестировании данной конфигурации использовались следующие версии программного и аппаратного обеспечения:

  • Программное обеспечение Cisco IOS® Release 12.2(27);

  • Два маршрутизатора Cisco 3660 с модулем NM-1E, используемым для установления соединения с персональным компьютером и клиентом.

Сведения, представленные в данном документе, были получены на тестовом оборудовании в специально созданных лабораторных условиях. При написании данного документа использовались только устройства с пустой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд.

Примечание. Функция DHCP-сервер Cisco IOS впервые появилась в программном обеспечении Cisco IOS Release 12.0(1)T. Для маршрутизаторов серии Cisco 1700 необходимо использовать ПО Cisco IOS® Release 12.0(2)T или более позднюю версию. Дополнительные сведения о маршрутизаторах, поддерживающих функцию DHCP-сервера, см. в разделе Поддерживаемые платформы документа под названием DHCP-сервер Cisco IOS.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе "Технические рекомендации Cisco. Условные обозначения".

Настройка

В данном разделе приводятся сведения о настройке параметров DHCP-сервера для DNS и WINS. "Центральному" маршрутизатору задаются параметры сервера, которые затем импортируются "удаленным" маршрутизатором. Удаленный персональный компьютер или клиент получают эти импортированные параметры от "удаленного" маршрутизатора во время этапа передачи сообщений DHCPACK.

Примечание.  Для поиска дополнительных сведений о командах из данного документа см. Команды DHCP или используйте средство поиска команд Command Lookup (только для зарегистрированных пользователей) .

Схема сети

В данном документе используется сеть, изображенная на следующей схеме.

dhcp_ser_01.gif

Конфигурации

В данном документе используются следующие конфигурации:

Центральная (маршрутизаторы серии 3660)

Central# show running-config
Building configuration...
.
.
.
ip dhcp excluded-address 10.0.0.1 10.0.0.5

!--- Этот диапазон не должен назначаться DHCP-клиентам.

!
ip dhcp pool Central
   network 10.0.0.0 255.255.255.0

!--- Задайте номер сети и маску для DHCP-клиентов.
   
   domain-name Central

!--- Задайте клиенту доменное имя.
   
   dns-server 10.0.0.2

!--- Задайте DNS-сервер, отвечающий на запросы DHCP-клиентов,


!--- которым необходимо преобразовывать имя узла в IP-адрес.
   
   netbios-name-server 10.0.0.2

!--- Задайте сетевую базовую систему ввода-вывода (NetBIOS)


!--- WINS-сервер (для DHCP-клиентов Microsoft)
 
!
.
.
!
interface FastEthernet0/0
 ip address 10.0.0.1 255.255.255.0
 duplex auto
 speed auto
!
.
.
!
end

Удаленная (маршрутизаторы серии 3660)

Remote# show running-config
Building configuration...
.
.
.
ip dhcp excluded-address 192.168.1.1

!--- Этот IP-адрес не должен назначаться DHCP-клиентам.

!
ip dhcp pool Client
   import all

!--- Импортируйте параметры DHCP в базу данных.
   
   network 192.168.1.0 255.255.255.248

!--- Задайте номер сети и маску для DHCP-клиентов.

   default-router 192.168.1.1

!--- Задайте шлюз по умолчанию для DHCP-клиентов.
	
!
.
.
!
interface FastEthernet0/0
 ip address dhcp
 duplex auto
 speed auto
!
interface FastEthernet1/0
 ip address 192.168.1.1 255.255.255.248
 duplex auto
 speed auto
!
end

Проверка

В данном разделе содержатся сведения для проверки работы текущей конфигурации.

Некоторые команды show поддерживаются утилитой Output Interpreter (только для зарегистрированных пользователей), что позволяет просматривать выходные данные команды show.

  • show ip dhcp import — отображает параметры, импортированные в базу данных DHCP-сервера.

Remote#show ip dhcp import
Address Pool Name: Client
Domain Name Server(s): 10.0.0.2
NetBIOS Name Server(s): 10.0.0.2
Domain Name Option: Central
Central#show ip dhcp server statistics
Memory usage         13906
Address pools        1
Database agents      1
Automatic bindings   1
Manual bindings      0
Expired bindings     0
Malformed messages   0

Message              Received
BOOTREQUEST          0
DHCPDISCOVER         1
DHCPREQUEST          1
DHCPDECLINE          0
DHCPRELEASE          0
DHCPINFORM           0

Message              Sent
BOOTREPLY            0
DHCPOFFER            1
DHCPACK              1
DHCPNAK              0
  • show ip dhcp binding — отображает привязку по адресам на Cisco IOSDHCP-сервере.

Central#show ip dhcp binding
IP address       Client-ID/Hardware address	 	Lease expiration            Type
10.0.0.6         0063.6973.636f.2d30.                   Apr 25 2005 12:30 AM        Automatic
                 3036.302e.3563.6634.
                 2e61.3961.382d.4574.        
                 30

Поиск и устранение неисправностей

В данном разделе описывается процесс поиска и устранения неисправностей конфигурации.

Команды поиска и устранения неисправностей

Примечание. Перед использованием команд debug ознакомьтесь с документом под названиемВажные сведения о командах Debug.

  • debug ip dhcp server packet — декодирует данные, получаемые и передаваемые по протоколу DHCP.

Выходные данные команды ipconfig /all получены на персональном компьютере или клиенте под управлением операционной системы Microsoft Windows и содержит значения параметров TCP/IP-конфигурации, настроенные с помощью протокола DHCP.

C:\>ipconfig /all 
  
Windows 2000 IP Configuration 
  
  Host Name . . . . . . . . . . . . : PC 
  Primary DNS Suffix . . . . . . .  : cisco.com 
  Node Type . . . . . . . . . . . . : Hybrid 
  IP Routing Enabled. . . . . . . . : No
  WINS Proxy Enabled. . . . . . . . : No 
  DNS Suffix Search List. . . . . . : cisco.com 
                                       
Ethernet adapter Local Area Connection :
	 
  Connection-specific DNS Suffix . : Central 
  Description . . . . . . . . . .  : 3Com EtherLink XL 10/100 PCI TX NIC(3C905B-TX) 
  Physical Address. . . . . . . .  : 00-10-5A-86-5A-CA 
  DHCP Enabled. . . . . . . . . .  : Yes 
  Autoconfiguration Enabled . . .  : Yes 
  IP Address. . . . . . . . . . .  : 192.168.1.2 
  Subnet Mask . . . . . . . . . .  : 255.255.255.248 
  Default Gateway . . . . . . . .  : 192.168.1.1
  DHCP Server . . . . . . . . . .  : 10.0.0.6 
  DNS Servers . . . . . . . . . .  : 10.0.0.2 
  Primary WINS Server . . . . . .  : 10.0.0.2 
  Lease Obtained. . . .  . . . . . : Tuesday, April 26, 2005 6:04:29 PM 
  Lease Expires . . . . . . . .. . : Wednesday, April 27, 2005 6:04:29 PM

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 22920