Протокол IP : IP-маршрутизация

Использование HSRP для обеспечения избыточности в сети с многоканальным протоколом BGP

23 марта 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (28 июля 2013) | Английский (10 мая 2006) | Отзыв

Содержание

Введение
Предварительные условия
      Требования
      Используемые компоненты
      Условные обозначения
Общие сведения
Настройка
      Схема сети
      Конфигурации
Проверка
      Пакеты, передаваемые из локальной сети по адресу назначения
      Пакеты с пункта назначения передаются в локальную сеть
Устранение неполадок
Связанные обсуждения сообщества поддержки Cisco
Дополнительные сведения

Введение

Данный документ описывает предоставление избыточности в сети с многоканальным протоколом BGP, подключенным к двум различным поставщикам Интернет-услуг (ISP). В случае сбоя подключения к одному ISP трафик динамически перенаправляется через другого ISP с помощью команды set as-path {tag | prepend as-path-string} протокола BGP и протокола HSRP.

Предварительные условия

Требования

Использование данного документа требует наличия следующих знаний:

Используемые компоненты

Данный документ не ограничен отдельными версиями программного и аппаратного обеспечения.

Сведения, представленные в данном документе, были получены на тестовом оборудовании в специально созданных лабораторных условиях. При написании данного документа использовались только данные, полученные от устройств с конфигурацией по умолчанию. При работе с реально функционирующей сетью необходимо полностью осознавать возможные последствия выполнения команд до их применения.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в разделе Технические советы Cisco. Условные обозначения.

Общие сведения

Цель настройки в данном документе заключается в достижении следующей сетевой политики:

  • Весь исходящий трафик из хостов сети 192.168.21.0/24, направляемый в Интернет, должен проходить через R1 в ISP-A. В случае отказа данного канала или R1 весь исходящий трафик должен быть перенаправлен через R2 в ISP-B (а затем в Интернет) без вмешательства оператора.

  • Весь входящий трафик, предназначенный для автономной системы AS 100 из Интернета, необходимо маршрутизировать через R1. В случае отказа канала между ISP-A и R1 входящий трафик должен быть автоматически перенаправлен через ISP-B к R2.

Эти требования могут быть выполнены с помощью технологий BGP и HSRP.

Основная цель полностью избыточного исходящего маршрута может быть достигнута с помощью HSRP. Как правило, у ПК нет возможности собирать сведения о маршрутизации и обмениваться этими сведениями. IP-адрес шлюза по умолчанию настраивается статически на ПК, и, если маршрутизатор шлюза выходит из строя, ПК теряет подключение ко всем устройствам, кроме устройств в локальной сети. Это происходит даже в том случае, если существует запасной шлюз. Технология HSRP была создана для удовлетворения этих требований. Дополнительные сведения см. в разделе Основные возможности HSRP.

Вторая цель может реализовываться с помощью команды BGP set as-path prepend, которая позволяет BGP передавать более длинный путь AS (добавляя собственный номер AS несколько раз) через R2 на канал ISP-B для префикса 192.168.21.0/24. Таким образом, весь трафик с пунктом назначения 192.168.21.0/24, получаемый за пределами AS 100, направляется по более короткому пути AS через канал ISP-A to R1. Если первый путь (ISP-A к R1) выходит из строя, весь трафик идет по более длинному пути AS (ISP-B к R2) к сети 192.168.21.0/24. Дополнительные сведения о команде BGP set as-path prepend можно получить из диаграммы атрибута AS_PATH, представленной в документе Практические примеры BGP. Для получения дополнительных сведений о разделении нагрузки в BGP с помощью команды set as-path prepend, см. раздел Курс электронного обучения BGP – распределение нагрузки в BGP (Обратите внимание, что для просмотра этого курса необходимо установить проигрыватель Flash).

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в данном документе.

Примечание. Для поиска дополнительной информации о командах в данном документе используйте средство "Command Lookup" (Поиск команд) (только для зарегистрированных клиентов).

Схема сети

В данном документе используются следующие настройки сети:

На этой диаграмме маршрутизатор 1 (R1) и маршрутизатор 2 (R2) находится в AS 100, который имеет внешнее соединение BGP (eBGP) с ISP-A (AS 300) и ISP-B (AS 400) соответственно. Маршрутизатор 6 (R6) является частью AS 600, соединяющейся по протоколу eBGP с ISP-A и ISP-B. R2 соединяется по протоколу iBGP, что необходимо для обеспечения оптимальной маршрутизации. Например, чтобы получить доступ к внутренним маршрутам AS 400, R1 пересылает трафик R2 вместо того, чтобы использовать более длинный маршрут через AS 300.

Маршрутизаторы R1 и R2 также настроены для использования HSRP в общем сегменте Ethernet. Маршрут по умолчанию для хостов одного сегмента Ethernet указывает на резервный IP-адрес HSRP 192.168.21.10.

hsrp_bgp-01.gif

Конфигурации

R1

Текущая конфигурация

имя узла R1
!
interface serial 0
ip address 192.168.31.1 255.255.255.0
!
Интерфейс Ethernet0
  ip address 192.168.21.1 255.255.255.0  
  standby 1 priority 105
  standby 1 preempt delay minimum 60
  standby 1 ip 192.168.21.10
  standby 1 track Serial0

!--- Команда 
standby track serial следит за состоянием
!--- интерфейса Serial0 и снижает приоритетность
!--- резервной группы 1 в случае отказа интерфейса.
!--- Команда 
standby preempt delay minimum 60 позволяет проверить, что
!--- R1 становится преимущественным и вновь выполняет роль активного маршрутизатора. Эта команда также гарантирует, что 
!--- маршрутизатор ожидает 60 секунд, чтобы дать время BGP для
!--- слияния и заполнения таблицы маршрутизации. Это позволяет избежать отправки трафика
!--- на R1 до того, как маршрутизатор будет готов к пересылке.

!
!
router bgp 100
  no synchronization
  network 192.168.21.0
  neighbor 192.168.21.2 remote-as 100  
  neighbor 192.168.21.2 next-hop-self  
  neighbor 192.168.31.3 remote-as 300  
  no auto-summary
!

R2

Текущая конфигурация:  

имя узла R2
!
interface serial 0
ip address 192.168.42.2 255.255.255.0  
!
Интерфейс Ethernet0
 ip address 192.168.21.2 255.255.255.0  
 standby 1 priority 100
 standby 1 preempt  
 standby 1 ip 192.168.21.10
! 
!  
router bgp 100
 no synchronization
 network 192.168.21.0
 neighbor 192.168.21.1 remote-as 100  
 neighbor 192.168.21.1 next-hop-self  
 neighbor 192.168.42.4 remote-as 400  
 neighbor 192.168.42.4 route-map foo out 

!--- Присоединяет AS 100 к обновлениям BGP, отсылаемым к AS 400,
!--- чтобы создать ее резервную копию для пути ISP-A к R1.

 no auto-summary
!  
access-list 1 permit 192.168.21.0  
route-map foo permit 10  
 match ip address 1
 set as-path prepend 100  

end

Проверка

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются средством Output Interpreter Tool ( только для зарегистрированных клиентов); это позволяет выполнять анализ выходных данных команды show.

При настройке избыточности в любой сети необходимо учитывать следующие две вещи.

  • Обеспечение избыточного пути для пакетов из локальной сети в сеть назначения.

  • Обеспечение избыточного пути для пакетов из сети назначения в локальную сеть.

Пакеты, передаваемые из локальной сети по адресу назначения

В этом примере используется локальная сеть 192.168.21.0/24. Маршрутизаторы R1 и R2 выполняют протокол HSRP в сегменте Ethernet, подключенном к интерфейсу Ethernet1. R1 настроен как активный маршрутизатор HSRP с резервным приоритетом 105, а R2 настроен с резервным приоритетом 100. Команда standby 1 track Serial0 (s0) на маршрутизаторе R1 поозволяет процессу HSRP осуществлять контроль за этим интерфейсом. Если интерфейс перестает работать, он снижает приоритет HSRP. Когда интерфейсный протокол линии s0 прекращает работу, приоритет HSRP снижается до 95 (значение, на которое снижается приоритет по умолчанию, равно 10). В результате у другого маршрутизатора HSRP, R2, приоритет выше (равен 100). R2 становится активным маршрутизатором HSRP и привлекает таким образом трафик, предназначенный для активного адреса HSRP 192.169.21.10.

Используйте команду show standby для отображения активного маршрутизатора HSRP при работающем интерфейсе s0 на R1:

R1#show standby 
   Ethernet1 - Group 1 
     Local state is Active, priority 105, may preempt 
     Hellotime 3 sec, holdtime 10 sec 
     Next hello sent in 0.338 
     Virtual IP address is 192.168.21.10 configured 
     Active router is local 
     Standby router is 192.168.21.2 expires in 8.280 
     Virtual mac address is 0000.0c07.ac01 
     13 state changes, last state change 00:46:10 
     IP redundancy name is "hsrp-Et0-1"(default) 
     Priority tracking 1 interface, 1 up: 
     Interface                    Decrement   State 
     Serial0                          10      Up 

R2#show standby 
   Ethernet1 - Group 1
     State is Standby
     56 state changes, last state change 00:05:13
     Virtual IP address is 192.168.21.10
     Active virtual MAC address is 0000.0c07.ac01
     Local virtual MAC address is 0000.0c07.ac01 (default)
     Hello time 3 sec, hold time 10 sec
     Next hello sent in 1.964 secs
     Preemption enabled
     Active router is 192.168.21.1, priority 105 (expires in 9.148 sec)
     Standby router is local
     Priority 100 (default 100)
     IP redundancy name is "hsrp-Et0-1" (default)

R1#show standby ethernet 1 brief
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active addr     Standby addr    Group addr
Et1         1   105  P Active   local           192.168.21.2    192.168.21.10
R1#

R2#show standby ethernet 1 brief
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active          Standby         Virtual IP
Et1         1   100  P Standby  192.168.21.1    local           192.168.21.10
R2#

Команда show standby показывает R1 как активный маршрутизатор HSRP из-за более высокого приоритета, равного 105. Поскольку R1 является активным маршрутизатором, ему присвоен резервный IP-адрес 192.168.21.10. Весь IP-трафик, поступающий с хоста, настроенного через шлюз по умолчанию 192.168.21.10, направляется через маршрутизатор R1.

Если вывести из строя интерфейс s0 на маршрутизаторе R1, то изменится активный маршрутизатор протокола HSRP, так как HSRP на R1 настроен для команды standby track serial 0. При отказе интерфейса Serial 0 HSRP снижает приоритет R1 на 10 (по умолчанию) до 95 и R1 изменяет свое состояние на "резервное". R2 становится активным маршрутизатором и владеет резервным IP-адресом 192.168.21.10. Следовательно, весь трафик, направляемый с хостов в сегменте 192.168.21.0/24, посылает трафик через R2. Вывод команд debug и show подтверждает то же самое.

R1(config)# interface s0 
R1(config-if)# shut 
 %STANDBY-6-STATECHANGE: Standby: 1: Ethernet1 state Active         -> Speak 
 %LINK-5-CHANGED: Interface Serial0, changed state to administratively down 
 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down 
 %STANDBY-6-STATECHANGE: Standby: 1: Ethernet1 state Speak  -> Standby 
 %LINK-3-UPDOWN: Interface Serial0, changed state to down: 
 %STANDBY-6-STATECHANGE: Standby: 1: Ethernet1 state Active       -> Speak 
 %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down 
 %STANDBY-6-STATECHANGE: Standby: 1: Ethernet1 state Speak  -> Standby 

Учтите, что R1 становится маршрутизатором по умолчанию.

При переходе R2 в активное состояние получаются следующие выходные данные:

R2# 
 %STANDBY-6-STATECHANGE: Standby: 1: Ethernet1 state Standby        -> Active 

Если выполнить команду show standby на R1 и R2, обзор приоритетности резерва после интерфейса s0 заканчивается на R1:

R1#show standby
Ethernet1 - Group 1
  Local state is Standby, priority 95 (confgd 105), may preempt
  Hellotime 3 sec, holdtime 10 sec
  Next hello sent in 0.808
  Virtual IP address is 192.168.21.10 configured
  Active router is 192.168.21.2, priority 100 expires in 9.008
  Standby router is local
  15 state changes, last state change 00:00:40
  IP redundancy name is "hsrp-Et0-1" (default)
  Priority tracking 1 interface, 0 up:
    Interface               Decrement   State
    Serial0                      10     Down  (administratively down)
R1#
 
R2#show standby
Ethernet1 - Group 1
  State is Active
    57 state changes, last state change 00:00:33
  Virtual IP address is 192.168.21.10
  Active virtual MAC address is 0000.0c07.ac01
    Local virtual MAC address is 0000.0c07.ac01 (bia)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 2.648 secs
  Preemption enabled
  Active router is local
  Standby router is 192.168.21.1, priority 95 (expires in 7.096 sec)
  Priority 100 (default 100)
  IP redundancy name is "hsrp-Et0-1" (default)
R2#

R2#

R1#sh standby ethernet 1 brief
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active addr     Standby addr    Group addr
Et0         1   95   P Standby  192.168.21.2    local           192.168.21.10
R1# 

R2#sh standby ethernet 1 brief
                     P indicates configured to preempt.
                     |
Interface   Grp Prio P State    Active          Standby         Virtual IP
Et0         1   100  P Active   local           192.168.21.1    192.168.21.10
R2#

Учтите, что резервный приоритет R1 снижен со 105 до 95, и R2 становится активным маршрутизатором.

Краткое изложение

В случае сбоя подключения между ISP-A и R1 HSRP снижает приоритетность резервной группы на R1. R1 переходит из активного состояния в резервное. R2 переходит из режима ожидания в активное состояние. Резервный IP-адрес 192.168.21.10 становится активным на R2, а хосты отправляют трафик в Интернет через R2 и ISP-B, предоставляя дополнительный путь для исходящего трафика.

Дополнительная информация о команде HSRP standby track представлена в разделе Как использовать команды standby preempt и standby track.

Пакеты с пункта назначения передаются в локальную сеть

В соответствии с политикой сети, определенной в разделе Общие сведения, пока ISP-A является основным каналов, ISP-B – резервным каналом для трафика, приходящего на адрес 192.168.21.0/24 (по таким причинам, как связь по большей полосе пропускания по направлению к ISP-A), можно удлинить AS канал через ISP-B путем дополнения собственного AS номера в обновления BGP, заявленные для ISP-B R2. Для этого необходимо настроить карту маршрутизации для соседа BGP 192.168.42.4. В этой карте необходимо добавить собственный AS номер в команду set as-path prepend. Примените эту команду route-map к исходящим обновлениям соседа 192.168.42.4.

Примечание. В рамках производства необходимо добавлять номер AS несколько раз, чтобы удостовериться, что объявленный маршрут стал менее предпочтительным.

Ниже приведена таблица BGP в R6 для сети 192.168.21.0 при работающем подключении BGP между R1 и ISP-A, а также R2 и ISP-B.

R6#
show ip bgp 192.168.21.0
BGP routing table entry for 192.168.21.0/24, version 30 
Paths: (2 available, best #1) 
  Advertised to non peer-group peers: 
    192.168.64.4 
  300 100 
    192.168.63.3 from 192.168.63.3 (10.5.5.5) 
      Origin IGP, localpref 100, valid, external, best, ref 2 
  400 100 100 
    192.168.64.4 from 192.168.64.4 (192.168.64.4) 
      Origin IGP, localpref 100, valid, external

BGP выбирает путь AS {300 100} через ISP-A как лучший, поскольку его длина AS меньше, чем длина пути AS{400 100 100 } из ISP-B. Причина большей длины пути AS из ISP-B в том, что путь AS добавляет конфигурацию в R2.

При разрыве соединения между R1 и ISP-A R6 должен выбрать запасной путь через ISP-B, чтобы достичь сети 192.168.21.0/24 на AS 100:

R1(config)#interface s0 
R1(config-if)#shut 
%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0, changed state to down 

Ниже приведена таблица BGP в R6 для сети 192.168.21.0/24:

R6#show ip bgp 192.168.21.0 
BGP routing table entry for 192.168.21.0/24, version 31 
Paths: (1 available, best #1) 
  Advertised to non peer-group peers: 
    192.168.63.3 
  400 100 100 
    192.168.64.4 from 192.168.64.4 (192.168.64.4) 
      Origin IGP, localpref 100, valid, external, best

Дополнительная информация о многосетевой конфигурации BGP представлена в документе Образец конфигурации BGP с двумя разными поставщиками услуг (многоканальное подключение).

Устранение неполадок

Для этой конфигурации отсутствуют сведения об устранении неполадок.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 13768