Протокол IP : Групповая IP-адресация

Краткое руководство по конфигурации мультиадресной рассылки

23 марта 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (28 июля 2013) | Английский (30 августа 2005) | Отзыв

Содержание

Введение
Предварительные условия
      Требования
      Используемые компоненты
      Условные обозначения
Режим уплотнения
Разреженный режим с одним процессором маршрутизации
Разреженный режим с несколькими процессорами маршрутизации
Автоматическая обработка маршрутов (Auto-RP) с одним процессором маршрутизации
Автоматическая обработка маршрутов (Auto-RP) с несколькими процессорами маршрутизации
DVMRP
MBGP
MSDP
Мультиадресная маршрутизация с использованием шлейфных маршрутизаторов
IGMP UDLR для спутниковых каналов связи
PIMv2 BSR
CGMP
Отслеживание IGMP
PGM
MRM
Устранение неполадок
Связанные обсуждения сообщества поддержки Cisco
Дополнительные сведения

Введение

Мультиадресная рассылка IP — это технология, предназначенная для экономии пропускной способности. Она сокращает объем трафика за счет параллельной доставки одного информационного потока тысячам корпоративных получателей и домовладений. В числе приложений, которые получат преимущества при использовании мультиадресной рассылки видеоконференции, корпоративные коммуникации, дистанционное обучение и распространение программного обеспечения, котировок акций и новостей. В этом документе рассматриваются основы конфигурации мультиадресной рассылки для различных сетевых сценариев.

Предварительные условия

Требования

Cisco рекомендует читателям этого документа получить базовые знания о мультиадресной рассылке IP.

Примечание: См. дополнительные сведения в документе Мультиадресная рассылка IP.

Используемые компоненты

Данный документ не ограничивается отдельными версиями программного и аппаратного обеспечения.

Условные обозначения

Дополнительные сведения об условных обозначениях, которые встречаются в этом документе см. в документе Технические рекомендации Cisco. Условные обозначения.

Режим уплотнения

Cisco рекомендует по возможности использовать разреженный режим PIM (Protocol Independent Multicast), в частности Auto-RP, особенно в новых средах. Однако, если необходим режим высокой плотности, настройте глобальную команду ip multicast-routing и команду интерфейса ip pim sparse-dense-mode для каждого интерфейса, который должен обрабатывать мультиадресный трафик. Требование, общее для всех конфигураций в этом документе, — глобальная настройка мультиадресной рассылки и настройка PIM для интерфейсов. Начиная с версии 11.1 программного обеспечения Cisco IOS®, можно настраивать команды ip pim dense-mode и ip pim sparse-mode одновременно с командой ip pim sparse-dense-mode. В этом случае считается, что интерфейс находится в режиме уплотнения, если в этом режиме находится группа. Если группа находится в разреженном режиме (например, если протокол маршрутизации известен), интерфейс будет обрабатываться в соответствии с разреженным режимом.

Примечание:  "Источником" во всех примерах этого документа является источник мультиадресного трафика, а "Получатель" — получатель мультиадресного трафика.

mcast1.gif

Конфигурация маршрутизатора A

ip multicast-routing 

interface ethernet0 
ip address <address> <mask>
ip pim sparse-dense-mode  

interface serial0 
ip address <address> <mask>
ip pim sparse-dense-mode

Конфигурация маршрутизатора B

ip multicast-routing 

interface serial0 
ip address <address> <mask>
ip pim sparse-dense-mode 

interface ethernet0 
ip address <address> <mask>
ip pim sparse-dense-mode 

Разреженный режим с одним процессором маршрутизации

В этом примере маршрутизатор А — процессор маршрутизации, который, как правило, является ближайшим маршрутизатором к источнику. Для статической конфигурации процессора маршрутизации необходимо, чтобы на всех маршрутизаторах в домене PIM были настроены одинаковые команды ip pim rp-address. Можно настроить несколько процессоров маршрутизации, но только по одному процессору маршрутизации на группу.

mcast2.gif

Конфигурация маршрутизатора A

ip multicast-routing 
ip pim rp-address 1.1.1.1
 

interface ethernet0 
ip address <address> <mask>
ip pim sparse-dense-mode 

interface serial0 
ip address 1.1.1.1 255.255.255.0 
ip pim sparse-dense-mode 

Конфигурация маршрутизатора B

ip multicast-routing 
ip pim rp-address 1.1.1.1 


interface serial0 
ip address <address> <mask>
ip pim sparse-dense-mode 

interface ethernet0 
ip address <address> <mask>
ip pim sparse-dense-mode 

Разреженный режим с несколькими процессорами маршрутизации

В этом примере источник Source-A отправляет данные по адресам 224.1.1.1, 224.1.1.2 и 224.1.1.3. Источник Source-B отправляет данные по адресам 224.2.2.2, 224.2.2.3 и 224.2.2.4. Один из маршрутизаторов — RP 1 или RP 2 — может быть процессором маршрутизации для всех групп. Однако, если вы хотите, чтобы разные процессоры маршрутизации обрабатывали разные группы, все маршрутизаторы должны включать группы, которые будет обслуживать процессор маршрутизации. Для этого типа конфигурации статического процессора маршрутизации необходимо, чтобы на всех маршрутизаторах домена PIM были настроены одинаковые команды ip pim rp-addressaddress acl. Кроме того, для создания подобной конфигурации можно использовать более простую в настройке функцию Auto-RP.

mcast3.gif

Конфигурация процессора маршрутизации 1

ip multicast-routing 
 
ip pim RP-address 1.1.1.1 2
ip pim RP-address 2.2.2.2 3 
 
access-list 2 permit 224.1.1.1 
access-list 2 permit 224.1.1.2 
access-list 2 permit 224.1.1.3
access-list 3 permit 224.2.2.2 
access-list 3 permit 224.2.2.3 
access-list 3 permit 224.2.2.4

Конфигурация процессора маршрутизации 2

ip multicast-routing
  
ip pim RP-address 1.1.1.1 2 
ip pim RP-address 2.2.2.2  3
 
access-list 2 permit 224.1.1.1 
access-list 2 permit 224.1.1.2 
access-list 2 permit 224.1.1.3 
access-list 3 permit 224.2.2.2 
access-list 3 permit 224.2.2.3 
access-list 3 permit 224.2.2.4 

Конфигурация маршрутизаторов 3 и 4

ip multicast-routing 
ip pim RP-address 1.1.1.1  2 
ip pim RP-address 2.2.2.2  3
 

access-list 2 permit 224.1.1.1 
access-list 2 permit 224.1.1.2 
access-list 2 permit 224.1.1.3 
access-list 3 permit 224.2.2.2 
access-list 3 permit 224.2.2.3 
access-list 3 permit 224.2.2.4 

Автоматическая обработка маршрутов (Auto-RP) с одним процессором маршрутизации

Для функции Auto-RP необходимо настроить процессоры маршрутизации на объявление о своей доступности в качестве процессоров маршрутизации и агентов сопоставления. Процессоры маршрутизации используют адрес 224.0.1.39 для отправки объявлений. Агент сопоставления процессора маршрутизации прослушивает объявленные пакеты процессоров маршрутизации и отправляет результаты сопоставления процессора маршрутизации и группы в сообщениях об обнаружении по адресу 224.0.1.40. Эти сообщения используются оставшимися маршрутизаторами для составления карты "процессор маршрутизации — группа". Можно использовать один процессор маршрутизации, который также будет служить агентом сопоставления, или настроить несколько процессоров маршрутизации и агентов сопоставления для избыточности.

Обратите внимание, что при выборе интерфейса для объявлений процессоров маршрутизации Cisco рекомендует использовать интерфейс возвратной петли вместо физического интерфейса. Если вы выбираете физический интерфейс, необходимо гарантировать его постоянную доступность. Это не всегда возможно, и если физический интерфейс отключается, маршрутизатор перестанет объявлять себя процессором маршрутизации. В то же время, интерфейс возвратной петли никогда не отключается, что позволяет маршрутизатору объявлять себя процессором маршрутизации через любой доступный интерфейс. Он продолжает работу, даже если один или несколько физических интерфейсов маршрутизатора выходят из строя. Интерфейс возвратной петли должен поддерживать PIM и объявляться с помощью протокола IGP, или он должен быть достижим с помощью статической маршрутизации.

mcast4.gif

Конфигурация маршрутизатора A

ip multicast-routing 
 
ip pim send-rp-announce loopback0 scope 16
ip pim send-rp-discovery scope 16 

interface loopback0
ip address <address> <mask>
ip pim sparse-dense-mode 
 
interface ethernet0 
ip address <address> <mask>
ip pim sparse-dense-mode 

interface serial0 
ip address <address> <mask>
ip pim sparse-dense-mode 

Конфигурация маршрутизатора B

ip multicast-routing 


interface ethernet0 
ip address <address> <mask>
ip pim sparse-dense-mode 

interface serial0 
ip address <address> <mask>
ip pim sparse-dense-mode 

Автоматическая обработка маршрутизации (Auto-RP) с несколькими процессорами маршрутизации

Приведенные в примере списки доступа позволяют использовать процессоры маршрутизации (RP) только для указанных групп. Если списки доступа не настроены, процессоры маршрутизации будут доступны для всех групп. Когда два процессора маршрутизации объявляют о своей готовности стать процессором маршрутизации в одной и той же группе (группах), агент (агенты) разрешают такие конфликты в пользу обладателя наибольшего IP-адреса.

Когда два маршрутизатора объявляют себя процессорами маршрутизации для этой группы, настройте адрес возвратной петли на каждом маршрутизаторе, чтобы определить, какой маршрутизатор будет процессором маршрутизации для той или иной группы. Установите более высокий IP-адрес для предпочтительного процессора маршрутизации, затем используйте интерфейс возвратной петли в качестве источника пакетов объявления ip pim send-RP-announce loopback0. При использовании нескольких агентов сопоставления каждый из них объявляет одну группу для сопоставления процессоров маршрутизации и группы обнаружения 224.0.1.40.

mcast5.gif

Конфигурация процессора маршрутизации 1

ip multicast-routing
 
interface loopback0
ip address <address> <mask>
ip pim sparse-dense-mode  
 
ip pim send-RP-announce loopback0 scope 16 group-list 1
ip pim send-RP-discovery scope 16 


access-list 1 permit 239.0.0.0 0.255.255.255 

Конфигурация процессора маршрутизации 2

ip multicast-routing
 
interface loopback0
ip address <address> <mask>
ip pim sparse-dense-mode 
 
ip pim send-RP-announce loopback0 scope 16 group-list 1
ip pim send-RP-discovery scope 16 


access-list 1 deny 239.0.0.0 0.255.255.255 
access-list 1 permit 224.0.0.0 15.255.255.255 

Дополнительные сведения о функции Auto-RP см. в документе Руководство по конфигурации и диагностике Auto-RP.

DVMRP

Поставщик услуг Интернета (ISP) может предложить создать туннель протокола DVMRP к ISP для того, чтобы получить доступ к магистрали мультиадресной рассылки в Интернете (mbone). Минимальный набор команд, необходимый для настройки туннеля DVMRP, приведен ниже:

interface tunnel0  
ip unnumbered <any pim interface>
tunnel source <address of source>
tunnel destination <address of ISPs mrouted box> 
tunnel mode dvmrp  
ip pim sparse-dense-mode

Как правило, ISP размещает туннель на компьютере UNIX в режиме "mrouted" (DVMRP). Если ISP размещает туннель на другом устройстве Cisco, необходимо использовать режим туннеля GRE по умолчанию.

Если вы хотите создавать мультиадресные пакеты для других пользователей магистрали мультиадресной рассылки (mbone), а не получать их, необходимо объявить исходные подсети. Если адрес узла мультиадресной рассылки — 131.108.1.1, необходимо объявить о существовании этой подсети в магистрали mbone. Сети с прямым подключением по умолчанию объявляются с метрикой 1. Если ваш источник не имеет прямого подключения к маршрутизатору с туннелем DVMRP, задайте следующие параметры для интерфейса tunnel0:

ip dvmrp metric 1 list 3  
access-list 3 permit 131.108.1.0 0.0.0.255  

Примечание:  Необходимо включить список доступа с помощью приведенной выше команды, чтобы предотвратить объявление всей одноадресной таблицы маршрутизации в магистрали mbone.

Если используемая конфигурация аналогична конфигурации, представленной здесь, и необходимо распространить маршруты DVMRP через домен, настройте команду ip dvmrp unicast-routing на интерфейсах serial0 маршрутизаторов A и B. Это действие позволит пересылать данные маршрутов DVMRP соседям PIM, имеющим таблицу маршрутизации DVMRP, которая используется для функции RPF (Reverse Path Forwarding). При использовании функции RPF маршруты, полученные через DVMRP, имеют приоритет над остальными протоколами, за исключением маршрутов с прямым подключением.

mcast6.gif

MBGP

Протокол MBGP — это основной метод переноса двух наборов маршрутов: один набор для одноадресной маршрутизации и второй — для мультиадресной. MBGP предоставляет средства управления, которые определяют, куда может быть направлен поток мультиадресных пакетов. PIM использует маршруты, связанные с мультиадресной маршрутизацией, для создания деревьев распространения данных. MBGP обеспечивает путь RPF, а не создание состояния "multicast". Однако PIM необходим для пересылки мультиадресных пакетов.

mcast7.gif

Конфигурация маршрутизатора A

ip multicast-routing 


interface loopback0 
ip pim sparse-dense-mode 
ip address 192.168.2.2 255.255.255.0 


interface serial0 
ip address 192.168.100.1 255.255.255.0 


interface serial1 
ip pim sparse-dense-mode 
ip address 192.168.200.1 255.255.255.0 


router bgp 123 
network 192.168.100.0 nlri unicast 
network 192.168.200.0 nlri multicast 
neighbor 192.168.1.1 remote-as 321 nlri unicast multicast 
neighbor 192.168.1.1 ebgp-multihop 255 
neighbor 192.168.100.2 update-source loopback0 
neighbor 192.168.1.1 route-map setNH out 


route-map setNH permit 10 
match nlri multicast 
set ip next-hop 192.168.200.1 


route-map setNH permit 20 

Конфигурация маршрутизатора B

ip multicast-routing 


interface loopback0 
ip pim sparse-dense-mode 
ip address 192.168.1.1 255.255.255.0 


interface serial0 
ip address 192.168.100.2 255.255.255.0 


interface serial1 
ip pim sparse-dense-mode 
ip address 192.168.200.2 255.255.255.0 


router bgp 321 
network 192.168.100.0 nlri unicast 
network 192.168.200.0 nlri multicast 
neighbor 192.168.2.2 remote-as 123 nlri unicast multicast 
neighbor 192.168.2.2 ebgp-multihop 255 
neighbor 192.168.100.1 update-source loopback0 
neighbor 192.168.2.2 route-map setNH out 


route-map setNH permit 10 
match nlri multicast 
set ip next-hop 192.168.200.2 


route-map set NH permit 20

Если одноадресная и мультиадресная топологии совмещаются (например, проходят через один и тот же канал), основное различие их конфигурации заключается в команде nlri unicast multicast. Пример приводится ниже:

network 192.168.100.0 nlri unicast multicast

Совмещающиеся топологии с MBGP имеют преимущество, несмотря на то, что трафик проходит через один путь, к одноадресному и мультиадресному потокам BGP можно применить разные политики.

Дополнительные сведения о MBGP см. в документе Что такое MBGP?.

MSDP

Протокол MSDP (Multicast Source Discovery Protocol) соединяет несколько доменов PIM-SM. Каждый домен PIM-SM использует собственный, независимый процессор (процессоры) маршрутизации и не зависит от процессоров маршрутизации в других доменах. MSDP позволяет доменам обнаружить источники мультиадресной рассылки из других доменов. Если вы также используете BGP-подключение к узлу MSDP необходимо использовать один IP-адрес для MSDP и BGP. Когда MSDP выполняет проверку узлов PRF, MSDP ожидает, что адрес узла MSDP будет совпадать с адресом в сообщении SA, который выдает BGP/MBGP в результате поиска в таблице маршрутизации процессора маршрутизации. Однако необязательно запускать BGP/MBGP на узле MSDP, если между узлами MSDP уже имеется маршрут BGP/MBGP. Если путь BGP/MBGP отсутствует и имеется несколько узлов MSDP, используйте команду ip msdp default-peer. В следующем примере показано, что процессор маршрутизации A является процессором маршрутизации для своего домена, а процессор маршрутизации B — процессором маршрутизации для своего домена.

mcast8.gif

Конфигурация маршрутизатора A

ip multicast-routing 


ip pim send-RP-announce loopback0 scope 16
ip pim send-RP-discovery scope 16 


ip msdp peer 192.168.100.2 
ip msdp sa-request 192.168.100.2 

interface loopback0
ip address <address> <mask>
ip pim sparse-dense-mode 
 
interface serial0 
ip address 192.168.100.1 255.255.255.0 
ip pim sparse-dense-mode 

Конфигурация маршрутизатора B

ip multicast-routing 

ip pim send-RP-announce loopback0 scope 16 
ip pim send-RP-discovery scope 16 


ip msdp peer 192.168.100.1 
ip msdp sa-request 192.168.100.1 

interface loopback0
ip address <address> <mask>
ip pim sparse-dense-mode 
 
interface serial0 
ip address 192.168.100.2 255.255.255.0 
ip pim sparse-dense-mode 

Мультиадресная маршрутизация с использованием шлейфных маршрутизаторов

Мультиадресная маршрутизация с использованием шлейфных маршрутизаторов позволяет настроить удаленные шлейфные маршрутизаторы в качестве агентов IGMP-прокси. Вместо того, чтобы принимать полноценное участие в PIM, эти шлейфные маршрутизаторы переадресуют сообщения IGMP от узла (узлов) мультиадресному маршрутизатору более высокого уровня.

mcast9.gif

Конфигурация маршрутизатора 1

int s0 
ip pim sparse-dense-mode 
ip pim neighbor-filter 1 


access-list 1 deny 140.1.1.1

Команда ip pim neighbor-filter необходима, чтобы маршрутизатор 1 не назначил маршрутизатор 2 соседом по домену PIM. Если маршрутизатор 1 настроен для работы в разреженном режиме, использование фильтра соседства не требуется. Маршрутизатор 2 не должен работать в разреженном режиме. Работая в режиме уплотнения, шлейфные источники мультиадресных пакетов могут выполнять лавинную рассылку среди маршрутизаторов магистрали.

Конфигурация маршрутизатора 2

ip multicast-routing 
int e0 
ip pim sparse-dense-mode 
ip igmp helper-address 140.1.1.2 


int s0 
ip pim sparse-dense-mode 

IGMP UDLR для спутниковых каналов связи

Протокол UDLR (Unidirectional Link Routing) предоставляет методы переадресации мультиадресных пакетов через ненаправленные спутниковые каналы в шлейфные сети с обратным каналом. Этот метод аналогичен мультиадресной маршрутизации с использованием шлейфных маршрутизаторов. Без этой функции восходящий маршрутизатор не сможет динамически получать данные о групповых IP-адресах, которые необходимо переадресовать через ненаправленный канал, т. к. нисходящий маршрутизатор не сможет передавать данные обратно.

mcast10.gif

Конфигурация восходящего маршрутизатора

ip multicast-routing 


interface Ethernet0 
description Typical IP multicast enabled interface 
ip address 12.0.0.1 255.0.0.0 
ip pim sparse-dense-mode 


interface Ethernet1 
description Back channel which has connectivity to downlink-rtr 
ip address 11.0.0.1 255.0.0.0 
ip pim sparse-dense-mode 


interface Serial0 
description Unidirectional to downlink-rtr 
ip address 10.0.0.1 255.0.0.0 
ip pim sparse-dense-mode 
ip igmp unidirectional-link 
no keepalive 

Конфигурация нисходящего маршрутизатора

ip multicast-routing 


interface Ethernet0 
description Typical IP multicast enabled interface 
ip address 14.0.0.2 255.0.0.0 
ip pim sparse-dense-mode 
ip igmp helper-address udl serial0 


interface Ethernet1 
description Back channel which has connectivity to downlink-rtr 
ip address 13.0.0.2 255.0.0.0 
ip pim sparse-dense-mode 


interface Serial0 
description Unidirectional to uplink-rtr 
ip address 10.0.0.2 255.0.0.0 
ip pim sparse-dense-mode 
ip igmp unidirectional-link 
no keepalive 

PIMv2 BSR

Если все маршрутизаторы сети используют протокол PIMv2, можно настроить функцию BSR вместо функции Auto-RP. Функции BSR и Auto-RP очень похожи. Для конфигурации BSR необходимо настроить кандидаты в BSR (аналогично объявлению процессоров маршрутизации в Auto-RP) и BSR (аналоги агентов сопоставления в Auto-RP). Чтобы настроить BSR, выполните следующие действия:

  1. На коммутаторе BSR задайте следующие параметры:

    ip pim bsr-candidate interface hash-mask-len pref
    

    Где interface содержит IP-адреса кандидатов в BSR. Рекомендуется (но не требуется), чтобы значение hash-mask-Len было одинаковым для всех кандидатов в BSR. Кандидат BSR с наибольшим значением pref будет выбран BSR для данного домена.

    Пример использования команды приведен ниже:

    ip pim bsr-candidate ethernet0 30 4

    PIMv2 BSR собирает данные о кандидате в процессоры маршрутизации, а также распространяет данные о наборах процессоров маршрутизации, связанных с каждым групповым префиксом. Чтобы исключить критическую точку отказа, можно настроить несколько маршрутизаторов в домене в качестве кандидатов в BSR.

    BSR выбирается из кандидатов в BSR автоматически, на основе заданных значений "pref". Чтобы быть кандидатом в BSR маршрутизатор должен быть подключен и находиться в магистрали сети, а не в области коммутируемых соединений.

  2. Настройка маршрутизаторов — кандидатов в процессоры маршрутизации. В этом примере изображается кандидат в процессоры маршрутизации на интерфейсе ethernet0, для всего диапазона адресов admin-scope:

    access-list 11 permit 239.0.0.0 0.255.255.255
    ip pim rp-candidate ethernet0 group-list 11
    

CGMP

Чтобы настроить протокол CGMP (Group Management Protocol), задайте следующие параметры интерфейса маршрутизатора, к которому подключен коммутатор:

ip pim sparse-dense-mode 
ip cgmp

Затем задайте следующие параметры на коммутаторе:

set cgmp enable

Отслеживание IGMP

Отслеживание IGMP (Internet Group Management Protocol) доступно в версии 4.1 модели Catalyst 5000. Для отслеживания IGMP требуется плата Supervisor III. Для отслеживания IGMP на маршрутизаторе требуется только настройка PIM. Однако, маршрутизатор по прежнему необходим, чтобы обеспечивать опрос IGMP посредством отслеживания IGMP.

В примере показано, как включить отслеживание IGMP на маршрутизаторе:

Console> (enable) set igmp enable  
IGMP Snooping is enabled.  
CGMP is disabled. 

При попытке включить функцию IGMP, если включена функция CGMP, будет выдано следующее сообщение:

Console> (enable) set igmp enable  
Disable CGMP to enable IGMP Snooping feature. 

PGM

PGM (Pragmatic General Multicast) — это надежный транспортный протокол мультиадресной рассылки для приложений, которым необходима доставка упорядоченных недублированных мультиадресных пакетов из нескольких источников нескольким получателям. PGM гарантирует, что получатель в группе либо принимает все пакеты данных при передаче или повторной передаче, либо обнаруживает невосстановимую потерю пакета данных.

Не существует глобальных команд PGM. Протокол PGM настраивается для отдельных интерфейсов с помощью команды ip pgm. Необходимо настроить мультиадресную маршрутизацию на маршрутизаторе с интерфейсом, на котором включен PIM.

MRM

Инструмент MRM (Multicast Routing Monitor) упрощает автоматизированное обнаружение ошибок в крупных средах мультиадресной маршрутизации. Функция MRM разработана для предупреждения администратора сети о проблемах мультиадресной маршрутизации режиме, приближенном к режиму реального времени.

В MRM входит два компонента: Тестер MRM (MRM Tester) и диспетчер MRM (MRM Manager). Тестер MRM является отправителем и/или получателем.

Инструмент MRM доступен в программном обеспечении Cisco IOS версии 12.0(5)T и выше. Только испытатели и диспетчеры MRM должны работать на версии Cisco IOS с поддержкой MRM.

mcast11.gif

Конфигурация Test Sender

interface Ethernet0 
  ip mrm test-sender 

Конфигурация Test Receiver

interface Ethernet0 
  ip mrm test-receiver 

Конфигурация Test Manager

ip mrm manager test1 
 manager e0 group 239.1.1.1 
 senders 1 
 receivers 2 sender-list 1 


 access-list 1 permit 10.1.1.2 
 access-list 2 permit 10.1.4.2 

Выходные данные команды show ip mrm manager для компонента Test Manager приведены ниже:

Test_Manager# show ip mrm manager 
   Manager:test1/10.1.2.2 is not running 
     Beacon interval/holdtime/ttl:60/86400/32 
     Group:239.1.1.1, UDP port test-packet/status-report:16384/65535 
     Test sender: 
       10.1.1.2 
     Test receiver: 
       10.1.4.2

Запустите тест с помощью следующей команды. Компонент Test Manager отправляет управляющие сообщения компонентам Test Sender и Test Receiver в соответствии с параметрами теста. Компонент Test Receiver присоединяется к группе и отслеживает тестовые пакеты от компонента Test Sender.

Test_Manager# mrm start test1 
 *Feb  4 10:29:51.798: IP MRM test test1 starts ......  
Test_Manager#

Для отображения отчета о состоянии для компонента Test Manager, введите следующую команду:

Test_Manager# show ip mrm status  

IP MRM status report cache:  
Timestamp        Manager          Test Receiver   Pkt Loss/Dup (%)       Ehsr  
*Feb  4 14:12:46 10.1.2.2         10.1.4.2        1            (4%)      29  
*Feb  4 18:29:54 10.1.2.2         10.1.4.2        1            (4%)      15  
Test_Manager#

Выходные данные показывают, что получатель отправил два отчета о состоянии (по одной строке каждый) для указанной временно метки. Каждый отчет содержит данные об одной потере пакета в рамках окна интервала (одна секунда по умолчанию). Значение "Ehsr" представляет следующее (приблизительное) значение порядкового номера для компонента Test Sender. Если компонент Test Receiver обнаруживает дублированные пакеты, он выводит отрицательное число в столбце "Pkt Loss/Dup".

Чтобы остановить тест, введите следующую команду:

Test_Manager# mrm stop test1 
*Feb  4 10:30:12.018: IP MRM test test1 stops  
Test_Manager# 

При запуске теста компонент MRM Sender начинает отправлять RTP-пакеты по настроенному групповому адресу с интервалом по умолчанию 200 мс. Компонент MRM Receiver отслеживает (ожидает) получение одинаковых пакетов через одинаковый интервал по умолчанию. Если MRM Receiver обнаруживает потерю пакета в течение интервала окна по умолчанию, который равен 5 секундам, он посылает отчет компоненту MRM Manager. Чтобы получить отчет о состоянии получателя, введите команду show ip mrm status в MRM Manager.

Устранение неполадок

Некоторые из распространенных проблем внедрения мультиадресной рассылки IP в сети возникают, когда маршрутизатор не переадресует мультиадресный трафик из-за сбоя RPF или параметров TTL. Подробное рассмотрение этих и других распространенных проблем, их симптомов и решений см. в документе Руководстве по поиску и устранению неисправностей мультиадресной рассылки IP.


Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 9356