Средства сетевого управления : Устройства защиты Cisco PIX серии 500

Настройка брандмауэра PIX и клиентов VPN при помощи PPTP, MPPE и IPSec

23 марта 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (28 июля 2013) | Английский (13 октября 2008) | Отзыв

Содержание

Общие сведения
Предварительные условия
      Требования
      Используемые компоненты
      Условные обозначения
Настройка
      Схема сети
      Конфигурации
      Cisco VPN 3000 Client 2.5.x или Cisco VPN Client 3.x и 4.x
      Настройка клиента PPTP для Windows 98/2000/XP
Проверка
Устранение неполадок
      Команды устранения неполадок
      Проблемы, связанные с использованием Microsoft
Связанные обсуждения сообщества поддержки Cisco
Дополнительные сведения

Общие сведения

В этом примере конфигурации четыре клиента разных типов подключаются и шифруют трафик при помощи брандмауэра Cisco Secure PIX как конечной точки туннеля:

  • Пользователи с Cisco Secure VPN Client 1.1 под управлением Microsoft Windows 95/98/NT

  • Пользователи с Cisco Secure VPN 3000 Client 2.5.x под управлением Windows 95/98/NT

  • Пользователи со стандартными клиентами, работающими по протоколу туннелирования между узлами (PPTP) под управлением Windows 98/2000/XP

  • Пользователи с Cisco VPN Client 3.x/4.x под управлением Windows 95/98/NT/2000/XP

В данном примере настраивается один пул для IPsec и PPTP. Однако эти пулы могут быть и раздельными.

Предварительные условия

Требования

Для данного документа нет особых требований.

Используемые компоненты

Сведения, содержащиеся в данном документе, приведены на основе следующих версий программного и аппаратного обеспечения:

  • Программное обеспечение PIX, релиз 6.3.3

  • Cisco Secure VPN Client 1.1

  • Cisco VPN 3000 Client, версия 2.5

  • Cisco VPN Client, версии 3.x и 4.x

  • Клиенты Microsoft Windows 2000 и Windows 98

Примечание: эта конфигурация была проверена на релизе 6.3.3 программного обеспечения PIX, но должна работать также в релизах 5.2.x и 5.3.1. Для Cisco VPN Client 3.x и 4.x. требуется программное обеспечение PIX, релиз 6.x. (Поддержка для Cisco VPN 3000 Client 2.5 добавлена в программном обеспечении PIX, релиз 5.2.x. Настройка также работает для программного обеспечения PIX, релиз 5.1.x, кроме части Cisco VPN 3000 Client). Первоначально следует настроить IPsec и PPTP/Microsoft Point-to-Point Encryption (MPPE) для работы по отдельности. Если они не работают отдельно, то не будут работать вместе.

Примечание: PIX 7.0 использует для обработка пакетов RPC команду inspect rpc. Команда inspect sunrpc включает и выключает проверку приложений для протокола Sun RPC. Сервисы Sun RPC могут работать на любом порте системы. Когда клиент пытается получить доступ к сервису Sun RPC на сервере, он должен выяснить, с каким портом работает этот сервис. Это делается с помощью обращения к процессу сопоставления портов на хорошо известном номере порта 111. Клиент посылает программный номер сервиса RPC и получает в ответ номер порта. С этого момента программа-клиент посылает свои запросы RPC на этот новый порт.

Данные для документа были получены в специально созданных лабораторных условиях. При написании данного документа использовались только устройства с пустой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд.

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. в статье "Технические советы Cisco. Условные обозначения".

Настройка

В этом разделе приводятся сведения о настройке функций, описанных в данном документе.

Примечание: для поиска дополнительной информации о командах в данном документе используйте средство поиска команд Command Lookup Tool (только для зарегистрированных клиентов).

Схема сети

В этом документе используются настройки сети, показанные на данной диаграмме.

pptpcrypto3.gif

Конфигурации

Эти конфигурации используются в данном документе.

Cisco Secure PIX Firewall

PIX версия 6.3(3)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password 8Ry2YjIyt7RRXU24 encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname goss-515A
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol ils 389
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
names
access-list 101 permit ip 10.99.99.0 255.255.255.0 192.168.1.0 255.255.255.0
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 172.18.124.152 255.255.255.0
ip address inside 10.99.99.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool bigpool 192.168.1.1-192.168.1.254
pdm history enable
arp timeout 14400
nat (inside) 0 access-list 101
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server RADIUS protocol radius
aaa-server LOCAL protocol local
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
crypto ipsec transform-set myset esp-des esp-md5-hmac
crypto dynamic-map dynmap 10 set transform-set myset
crypto map mymap 10 ipsec-isakmp dynamic dynmap
crypto map mymap client configuration address initiate
crypto map mymap client configuration address respond
crypto map mymap interface outside
isakmp enable outside

!--- Cisco Secure_VPNClient_key.


isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
isakmp identity address
isakmp client configuration address-pool local bigpool outside


!--- ISAKMP Policy для Cisco VPN Client 2.5 или 
!--- Cisco Secure VPN Client 1.1.


isakmp policy 10 authentication pre-share
isakmp policy 10 encryption des
isakmp policy 10 hash md5


!--- Клиенты VPN 1.1 и 2.5 VPN используют политику  
!--- группы 1 Диффи-Хельмана (PIX default).


isakmp policy 10 group 1
isakmp policy 10 lifetime 86400


!--- ISAKMP Policy для VPN Client 3.0 и 4.0.


isakmp policy 20 authentication pre-share
isakmp policy 20 encryption des
isakmp policy 20 hash md5


!--- Клиенты VPN 3.0 и 4.0 VPN используют политику D-H группы 2  
!--- и код PIX 6.0.


isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup vpn3000-all address-pool bigpool
vpngroup vpn3000-all dns-server 10.99.99.99
vpngroup vpn3000-all wins-server 10.99.99.99
vpngroup vpn3000-all default-domain password
vpngroup vpn3000-all idle-time 1800


!--- VPN 3000 group_name и group_password.


vpngroup vpn3000-all password ********
telnet timeout 5
ssh timeout 5
console timeout 0
vpdn group 1 accept dialin pptp
vpdn group 1 ppp authentication pap
vpdn group 1 ppp authentication chap
vpdn group 1 ppp authentication mschap
vpdn group 1 ppp encryption mppe auto
vpdn group 1 client configuration address local bigpool
vpdn group 1 pptp echo 60
vpdn group 1 client authentication local


!--- имя пользователя и пароль PPTP.


vpdn username cisco password *********
vpdn enable outside
terminal width 80
Cryptochecksum:d41d8cd98f00b204e9800998ecf8427e
: end
goss-515A#

Cisco Secure VPN Client 1.1

1- TACconn 
      My Identity
           Connection security: Secure
           Remote Party Identity and addressing
           ID Type: IP subnet
           10.99.99.0
            255.255.255.0
           Port all Protocol all

      Connect using secure tunnel
           ID Type: IP address
           172.18.124.152
 
      Pre-shared Key=CiscoSecure_VPNClient_key

      Authentication (Phase 1) 
      Proposal 1 
          Authentication method: pre-shared key
          Encryp Alg: DES 
          Hash Alg: MD5 
          SA life: Unspecified
          Key Group: DH 1
 
      Key exchange (Phase 2) 
      Proposal 1 
          Encapsulation ESP 
          Encrypt Alg: DES 
          Hash Alg: MD5 
          Encap: tunnel 
          SA life: Unspecified
          no AH 
 
  2- Other Connections 
         Connection security: Non-secure 
         Local Network Interface
           Name: Any 
           IP Addr: Any 
           Port: All

Cisco VPN 3000 Client 2.5.x или Cisco VPN Client 3.x и 4.x

Выберите Options > Properties > Authentication. Имя группы и пароль группы совпадают с group_name и group_password на PIX, как в:

vpngroup vpn3000-all password ******** 
Host-name = 172.18.124.152 

Windows 98/2000/XP PPTP Client Setup

Вы сможете связаться с поставщиком клиента PPTP. Информацию об установке см. в разделеКак настроить брандмауэр Cisco Secure PIX для использования PPTP.

Проверка

Для этой конфигурации отсутствует процедура проверки.

Устранение неполадок

В данном разделе описывается процесс устранения неполадок конфигурации.

Команды устранения неполадок

Инструмент Output Interpreter Tool (только для зарегистрированных клиентов) (OIT) поддерживает отдельные команды show. Это позволяет просмотреть анализ выходных данных команды show.

Примечание: прежде чем применять команды отладки, ознакомьтесь с разделом Важные сведения о командах отладки.

Отладка PIX IPsec

  • debug crypto ipsec — отображает согласования IPSec фазы 2.

  • debug crypto isakmp — показывает согласования фазы 1 по протоколу управления ключами Ассоциации безопасности Интернета (ISAKMP).

  • debug crypto engine — отображает зашифрованный трафик.

Отладка PIX PPTP

  • debug ppp io — показывает информацию о пакетах для виртуального интерфейса PPTP PPP.

  • debug ppp error — показывает сообщения об ошибках виртуального интерфейса PPTP PPP.

  • debug vpdn error — показывает сообщения об ошибках протокола PPTP.

  • debug vpdn packets — показывает пакетную информацию PPTP о трафике PPTP.

  • debug vpdn events — показывает информацию об изменениях событий туннеля PPTP.

  • debug ppp uauth — показывает сообщения отладки аутентификации пользователей ААА виртуального интерфейса PPTP PPP.

Проблемы, связанные с использованием Microsoft


Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 14095